欢迎使用 JMP

下一页

JMP 欢迎使用 JMP

介绍 JMP

欢迎使用 JMP 交互统计和图形化功能。JMP 的任务是帮助研究人员分析其数据并有所发现。

JMP 采用独特的图形界面来显示和分析数据。它是一个交互式统计图形软件，其功能包括：

  • 用于查看、编辑、输入和处理数据的电子表格；
  • 用于数据分析的各种图形和统计方法；
  • 大量的试验设计模型；
  • 选择和显示数据子集的选项；
  • 用于排列和合并数据表的数据管理工具；
  • 用于计算每个表列值的计算器；
  • 用于对数据分组以及计算汇总统计量的工具；
  • 用于质量提高技术的特殊图形、图表和通信功能；
  • 用于打印以及在应用程序间移动分析结果的工具；
  • 用于保存常用例程的脚本语言。

JMP 易于掌握。统计量被组织为具有相应图形和表格的逻辑领域，以帮助您寻找数据的形态规律、标识离群点或模型拟合。根据变量的类型及其扮演的角色，系统能够为您定义和执行相应的分析。

JMP 是一种只需指向并点击即可方便使用的产品，它利用交互统计图形化功能来满足研究人员的分析需要。JMP 提供了一种用于统计分析和探索的工具，使用户能够

发现更多。
使用图形可让数据的模式和关系一目了然，并且可以发现不适合该模式的点。
交互更多。
如果产品易于使用，即可将重点放在问题上，而不是注重于用来查看问题的工具上。通过交互作用，您可以跟踪线索并尝试更多方法。尝试的角度越多，就越有可能发现有用东西。
了解更多。
通过图形，您可以看出数据和模型如何协同工作，从而生成统计量。使用组织有序和精心构造的工具，您可以了解该学科的结构。使用循序渐进的系统，您可以在相应的环境中学习统计方法。

JMP 提供了各种各样的统计方法和图形方法，并将这些方法嵌入为数不多的交互平台中。

JMP 不仅能为初级统计员提供描述统计和简单分析，也能为高级研究员提供复杂的模型拟合。用于试验设计、统计质量控制、三角图和等高线图绘制以及生存分析的标准统计分析方法和专业平台为您提供了迅速分析数据和查看结果所需的工具。

欢迎使用 JMP:
介绍 JMP

下一页


您需要掌握的知识

在开始使用 JMP 之前，您应首先掌握以下知识：

  • 标准的操作及术语，如单击、双击、Ctrl + 单击和 Alt + 单击（Macintosh 中为 command(命令) command(命令) 单击和 Option + 单击；Linux 中为 Shift + Alt + 单击）、Shift + 单击、拖动、选择、复制和粘贴。
  • 如何使用菜单栏和滚动条，如何移动窗口并调整其大小以及如何在桌面处理文件。有关这些主题的更多信息，请参阅随系统提供的参考指南。
  • 基础统计学知识。尽管 JMP 具有很多高级功能，但您只需通过简单的正式统计学培训即可使用。所有分析平台均包含了可供选择的图形显示，有助于您复查和解释结果。每个平台还包括对帮助窗口的访问，提供了一般帮助和一些统计详细资料。


了解 JMP

如果您比较熟悉 JMP，那么您可能只希望了解其最新内容。“最新内容”文档汇总了主要的更改和增补。要了解有关 JMP 的更多信息，请遵循以下章节中的建议。

使用教程

JMP 提供了三种类型的教程：

  • 初学者教程 初学者教程将指导您学习 JMP 界面，同时介绍有关如何使用 JMP 的基础知识。您可以通过启动 JMP 时显示的“今日提示”窗口来访问本教程。要从“今日提示”窗口启动本教程，请单击进入初学者教程。还可以在 JMP 中通过选择帮助（Macintosh 中为查看）> 教程 > 初学者教程（Macintosh 中为查看 > 教程 > 初学者教程）来启动本教程。
  • 特定分析方法教程 这些教程位于帮助（Macintosh 中为查看）> 教程下，可指导您学习如何在 JMP 中创建分析模型。此类教程介绍了如何创建图表以及如何运行试验设计 (DOE) 等内容。
  • JMP 使用指南手册 《JMP 使用指南》由一系列教程组成，旨在帮助您了解 JMP 的概貌。如果未获得本手册的印刷副本，通过选择帮助（Macintosh 中为查看）> 手册 > 使用指南可以查看 .pdf 文件。通过学习这些步骤详细的例子，您可以迅速熟悉 JMP 菜单、选项以及报表窗口。

让 JMP 帮助您

JMP 有许多功能可以为您提供有帮助的信息。

帮助按钮

许多窗口和对话框均包含帮助按钮。单击该按钮可以查找该对话框中的信息。

帮助工具

生成报表后，从工具菜单中选择帮助工具（ [image] ），然后单击该报表的表面以查找有关该报表窗口的信息。

悬停帮助

在某些报表中，用光标画一个小圆圈，以显示该区域中有关项目的信息。

菜单提示

在某些菜单中，将光标停留在菜单项上，以显示有关该菜单项的信息。

帮助系统

在 Windows 和 Linux 中，您可以使用帮助 > 目录、帮助 > 搜索以及帮助 > 索引命令来访问 JMP 帮助系统。帮助系统提供了可以浏览的联机 JMP 文档。

在 Macintosh 中，您可以使用帮助 > JMP 帮助命令来显示 JMP 帮助项目的列表，该列表提供搜索功能以及目录。

了解 JMP 提示和技巧

当您第一次启动 JMP 时，您将看到“今日提示”窗口。该窗口提供了一些可能不为您所知的 JMP 相关使用提示。

要关闭“今日提示”，请撤消选定启动时显示提示 。要再次查看，请选择帮助（Macintosh 中为查看）> 今日提示。有关详情，请参阅"开始使用 JMP" 章节中的 "今日提示窗口" 。

了解统计和 JSL 术语

Windows/Linux 中的帮助 > 索引命令以及 Macintosh 中的查看 > 索引命令可用于显示以下参考资料来源：

  • 统计索引 访问提供统计术语定义的参考资料。在“统计索引”窗口中，您便可以单击主题帮助按钮，进入联机帮助中描述高亮度显示主题的地方。单击脚本按钮可以查看或隐藏与高亮度显示主题相关的脚本。单击启动可以运行与列表中高亮度显示项目对应的脚本。 单击实例可以查看高亮度显示主题的实例。
  • JSL 运算符索引 显示 JSL 运算符列表，例如在编写 JSL 时将用到的 Sin、Cos、Sqrt 和日期缩写等。高亮度显示某个运算符名称可以在右侧的窗口中查看该运算符的说明。单击主题帮助按钮可以定位至联机帮助中的该主题。
  • 对象脚本索引 显示 JSL 对象的列表。这些对象是可脚本化的 JSL 构造区组。高亮度显示对象名称，右侧的窗口中将显示对象可以识别的消息。
  • 显示框脚本索引 显示 JMP 报表组成元素的列表。这些元素是用于构造输出的 JSL 构造区组。高亮度显示显示框，右侧的窗口中将显示每个对象的可用消息。

将本手册与其它随附手册配合使用

您正在阅读的手册是《JMP 用户指南》。它向您提供了有关创建数据表、使用分析报表、所有 JMP 菜单的说明、数据表处理的解释、公式编辑器的说明以及如何使用公式编辑器的参考资料。有关 JMP 的其它说明文档，请参阅以下手册：

  • 《JMP 使用指南》提供教程，通过实例引导您使用 JMP。
  • 《JMP 统计和图形指南》提供分析和图形菜单的说明文档。
  • 《JMP 试验设计》介绍了 JMP 中的试验设计菜单以及试验设计分析。
  • 《JMP 脚本指南》是 JMP 脚本语言 (JSL) 的参考指南，该语言可对一系列操作实现自动化。

如果未获得这些手册的印刷副本，则可以通过选择帮助（Macintosh 中为查看）> 手册 > 使用指南查看 .pdf 文件。

浏览联机 JMP 常见问题解答

如果您遇到了问题，也可能其他人曾遇到这样的问题。JMP 网站有 常见问题解答页，其中列出了许多问题和解答。

如果您是 JMP 老用户

如果您熟悉 JMP 环境，可能就只想了解其新功能。《JMP新功能》 汇总了 JMP 6 的一般更改和添加内容。


关于 JMP 帮助

使用帮助

基本帮助功能

JMP 帮助系统使您可以快速轻易地找到所有 JMP 功能的联机文档。要在帮助中查找主题，请使用方法之一：

目录

单击 [image] 以查看这些部分中列出的目录：

  • 用户指南
  • 统计和图形指南
  • 试验设计指南
  • JSL 语言参考

索引

单击 [image] 以使用关键字搜索信息。

  1. 在该框中： 开始键入要搜索的词。
帮助系统会滚动至与您键入的词相匹配的那些词，并将其高亮度显示。
  2. 要显示选定主题的帮助：请按 Enter 键，双击该主题，或点击列表底部的 [image] 按钮。

搜索

单击 [image] 以在整个帮助系统中进行全文本搜索。

  1. 在该框中： 键入要搜索的词。
  2. 按 Enter，或单击 [image] 以查看包含您所搜索词的页面列表。
  3. 要显示选定主题的帮助：请按 [image], 或者双击该主题。

注：支持布尔搜索。可将逻辑运算数直接键入搜索字符串，或者通过使用搜索编辑框旁边的 [image] 按钮进行访问。点击 [image] 以显示受支持的逻辑运算数： 。

您可以选择高亮度显示您查找的页面中的搜索字符串。要打开和关闭此功能，请点击 [image] 按钮，然后从菜单中选择相应项。

其它帮助系统功能

收藏夹

选项卡使您可以保存经常访问的页面。

要向“收藏夹”列表中添加页面，请定位至该页面，然后点击该框底部的 [image] 。

要删除“收藏夹”列表中的项，请高亮度显示该项并点击 [image] 。

要显示主题，请单击其名称并点击 [image] ，或双击其名称。

定位按钮

点击 [image] 和 [image] 控制扩展目录窗格的显示。

点击 [image] 和 [image] 象 Web 浏览器一样浏览查看过的帮助页面。

点击 [image] 以查看主窗口中的完整目录。

点击 [image] 打开此页。

其它按钮

允许您打印帮助主题。您仅能看到当前页或者当前页及其所有子主题的打印选项。

允许您修改帮助系统的显示和定位、快速访问您的计算机的 Internet 选项设置，以及切换高亮度显示的搜索项。


帮助目录

此帮助系统含有以下部分：

欢迎使用 JMP
对软件及帮助系统的快速介绍。
用户指南
JMP 菜单的完整说明文档、数据表操作说明以及公式编辑器说明。其中的章节介绍了执行一般任务（例如处理文件、转换数据表列以及剪贴 JMP 数据）的方法、统计文本报表以及图形显示。
统计和图形指南
编制统计平台，论述统计方法，并介绍了所有报表窗口和选项。
试验设计
编制 JMP 中的试验设计 (DOE) 工具。
JMP 脚本语言语法参考
JMP 脚本语言 (JSL) 的参考指南，JSL 用于自动化操作顺序。JSL 是一个高级主题，最好在熟悉 JMP 应用程序后学习。


帮助约定

以下文本样式和格式贯穿使用于此帮助文件中，以增强可读性：

  • 本文档中的实例使用的大多数打开的数据表名称均以 Helvetica 字体（动物或动物.jmp）显示。对数据表中的变量名称和报表中项目的引用同样以 Helvetica 字体显示，具体取决于它们在屏幕或手册说明中的显示方式。
  • 特殊信息、警告和限制都会用“注”这个词来标注。
  • 引用的菜单名称（文件菜单）或菜单项（保存命令）以粗体显示，近似于您的屏幕上的显示方式。
  • 从菜单选择命令有时表示为文件 > 新建，意思是“从文件菜单选择新建命令”。
  • 重要的或对 JMP 具有特定定义的词语或短语在首次出现时以斜体显示。


JMP 服务

如果您需要帮助...

请注册您的 JMP 统计发现软件，这样才能从我们曾获奖的技术支持服务获得帮助。所有注册的 JMP 用户都可获得一年免费的技术支持。作为 JMP 的注册用户，您可以在东部时间星期一至星期五的上午 9 点至下午 5 点之间拨打 1-919-677-8008 ， 或发送电子邮件至 support@sas.com，或通过 JMP 网站 http://www.jmp.com 上的“技术支持”链接提交一份表单，报告问题。

要通过 Web 注册软件，只需登录 http://www.jmp.com，并按照“注册”链接中的说明执行必要的操作。或者，您可以填写好随软件提供的 JMP 注册卡，并将其邮寄或传真给我们的注册数据库协调员。

如果您想了解更多...

统计发现不只是关于有何好工具，还关于如何使用它们。SAS Institute 培训服务可以现场或通过美国各地的培训点让您了解 JMP 统计发现软件的独特功能。

学习并掌握各种试验、统计建模和图形可视化工具，就可以毫不费力地从各个角度了解数据。JMP 培训目录提供了有关课程说明、地点、日期和培训选择的信息，此目录可通过拨打 1-919-677-8000（分机号 7321）或发送邮件至 training@sas.com 来获得。

了解 JMP...

作为对打印版本的补充，所有 JMP 说明文档都作为可移植文档格式 (PDF) 文件包括在软件 CD 上，这些文件可用 Adobe® Acrobat® Reader 查看和打印。使用第 5 版，JMP 用户现在可以使用此联机方法快速地找到自己所需的答案。

除了软件随带的那些出版物之外，JMP 统计发现软件用户还可以订购课程讲义及案例分析，补充自己的数据分析技术知识。可提供的《JMP® Start Statistics》一书主要讲解如何使用 JMP 学习统计学，初学者和专家都可使用它。SAS Institute 出版物目录提供有 JMP 说明文档、课程讲义和案例分析的完整列表，此目录可通过拨打 1-800-727-3228 或发送邮件至 pubs@sas.com 来获得。

有关这些服务及其它服务的详细信息，请访问 JMP 网站 http://www.jmp.com 或发送邮件至 jmp@sas.com。


参考文献

“Hot Dogs,” (1986), Consumer Reports (June), 364-367.

Abernethy, Robert B. (1996) The New Weibull Handbook. Published by the author: 536 Oyster Road North Palm Beach, Florida 33408.

Agresti, A. (1984), Analysis of Ordinal Categorical Data, New York: John Wiley and Sons, Inc.

Agresti, A. (1990), Categorical Data Analysis, New York: John Wiley and Sons, Inc.

Agresti, A., and Coull, B. (1998), “Approximate is Better Than `Exact' for Interval Estimation of Bino-mial Proportions,” The American Statistician, 52, 119-126

Aitken, M. (1987) “Modelling Variance Heterogeneity in Normal Regression Using GLIM,” Applied Statistics 36:3, 332-339.

Akaike, H. (1974), “Factor Analysis and AIC,” Pschychometrika, 52, 317-332.

Akaike, H. (1987), “A new Look at the Statistical Identification Model,” IEEE Transactions on Auto-matic Control, 19, 716-723.

Anderson, T. W. (1958) An Introduction to Multivariate Statistical Analysis. New York: John Wiley & Sons.

Anderson, T.W. (1971), The Statistical Analysis of Time Series, New York: John Wiley and Sons.

Andrews, D.F. and A. M. Herzberg (1985), Data: A Collection of Problems from Many Fields for the Stu-dent and Research Worker. New York: Springer-Verlag.

Ashton, W.D. (1972), “The Logit Transformation,” Griffin's Statistical Monographs, New York: Hafner Publishing.

Atkinson, A. C. and Donev, A. N. Optimum Experimental Designs Clarendon Press, Oxford (1992) p.148.

Atkinson, A.C. (1985), Plots, Transformations and Regression, Oxford: Clarendon Press.

Barlow, R.E., Bartholomew, D.J., Bremner, J.M., and Brunk, H.D. (1972), Statistical Inference under Order Restrictions, New York: John Wiley and Sons, Inc.

Barrentine (1991), Concepts for R&R Studies, Milwaukee, WI: ASQC Quality Press.

Bartlett, M.S. (1966), An Introduction to Stochastic Processes, Second Edition, Cambridge: Cambridge University Press.

Bartlett, M.S. and D.G. Kendall (1946), “The Statistical Analysis of Variances-Heterogeneity and the Logarithmic Transformation,” JRSS Suppl 8, 128-138.

Bates, D.M. and Watts, D.G. (1988), Nonlinear Regression Analysis & its Applications. New York, John Wiley and Sons.

Beaton, A.E. and Tukey, J.W. (1974), “The Fitting of Power Series, Meaning Polynomials, Illustrated on Band-Spectroscopic Data,” Technometrics 16, 147-180.

Becker, R.A. and Cleveland, W.S. (1987), “Brushing Scatterplots,” Technometrics, 29, 2.

Belsley, D.A., Kuh, E., and Welsch, R.E. (1980), Regression Diagnostics, New York: John Wiley and Sons.

Benzecri, J.P. (1973), “L'Analyse des Donnees,” l'analyse des Correspondances, Paris: Dunod.

Berger, R.L., and Hsu, J.C. (1996), “Bioequivalence Trails, Intersection-Union Tests and Equivalence Confidence Sets,” Statistical Science, 11, 283-319.

Bose, R.C., (1947) “Mathematical Theory of the Symmetrical Factorial Design” Sankhya: The Indian Journal of Statistics, Vol. 8, Part 2, pp. 107-166.

Bowman, A. and Foster, P. (1992) “Density Based Exploration of Bivariate Data,” Dept. of Statistics, Univ. of Glasgow, Tech Report No 92-1.

Box, G. E. P. (1954). “Some Theorems on Quadratic Forms Applied in the Study of Analysis of Vari-ance Problems, II: Effects of Inequality of Variance and Correlation Between Errors in the Two-Way Classification”. Annals of Mathematical Statistics, 1, 69-82.

Box, G.E.P. (1988), “Signal-to-Noise Ratio, Performance Criteria, and Transformations,” Technomet-rics 30, 1-40.

Box, G.E.P. and Behnken, D.W. (1960), “Some New Three-Level Designs for the Study of Quantita-tive Variables,” Technometrics 2, 455-475.

Box, G.E.P. and Cox, D.R. (1964), “An Analysis of Transformations,” JRSS B26, 211-243.

Box, G.E.P. and Draper, N.R. (1969), Evolutionary Operation: A Statistical Method for Process Improve-ment, New York: John Wiley and Sons.

Box, G.E.P. and Draper, N.R. (1987), Empirical Model-Building and Response Surfaces, New York: John Wiley and Sons.

Box, G.E.P. and Meyer, R. D. (1993), “Finding the Active Factors in Fractionated Screening Experi-ments.”, Journal of Quality Technology Vol.25 #2: 94-105.

Box, G.E.P. and Meyer, R.D. (1986), “An analysis of Unreplicated Fractional Factorials,” Technometrics 28, 11-18.

Box, G.E.P. and Wilson, K.B. (1951), “On the Experimental Attainment of Optimum Conditions,” Journal of the Royal Statistical Society, Series B, 13, 1-45.

Box, G.E.P., Hunter,W.G., and Hunter, J.S. (1978), Statistics for Experimenters, New York: John Wiley and Sons, Inc.

Brown, M.B. and Forsythe, A.B. (1974), “Robust tests for the equality of variances” Journal of the American Statistical Association, 69, 364-367.

Brown, M.B. and Forsythe, A.B. (1974a), “The Small Sample Behavior of Some Statistics Which Test the Equality of Several Means,” Technometrics 16:1, 129-132.

Byrne, D.M. and Taguchi, G. (1986), ASQC 40th Anniversary Quality Control Congress Transactions, Milwaukee, WI: American Society of Quality Control, 168-177.

Carroll, R.J. and Ruppert, D. (1988), Transformation and Weighting in Regression, New York: Chapman and Hall.

Carroll, R.J., Ruppert, D. and Stefanski, L.A. (1995), Measurement Error in Nonlinear Models, New York: Chapman and Hall.

Chen, J., Sun, D.X., and Wu, C.F.J. (1993), “A Catalogue of Two-level and Three-Level Fractional Fac-torial Designs with Small Runs,” International Statistical Review, 61, 1, p131-145, International Statistical Institute.

Cobb, G.W. (1998), Introduction to Design and Analysis of Experiments, Springer-Verlag: New York.

Cochran, W.G. and Cox, G.M. (1957), Experimental Designs, Second Edition, New York: John Wiley and Sons.

Cohen, J. (1960), “A coefficient of agreement for nominal scales,” Education Psychological Measurement, 20: 37-46.

Cole, J.W.L. and Grizzle, J.E. (1966), “Applications of Multivariate Analysis of Variance to Repeated Measures Experiments,” Biometrics, 22, 810-828.

Conover, W. J. (1972). “A Kolmogorov Goodness-of-fit Test for Discontinuous Distributions”. Journal of the American Statistical Association 67: 591-596.

Conover, W.J. (1980), Practical Nonparametric Statistics, New York: John Wiley and Sons, Inc.

Cook, R.D. and Nachtsheim, C.J. (1990), “Letter to the Editor: Resonse to James M. Lucas,” Techno-metrics 32, 363-364.

Cook, R.D. and Weisberg, S. (1982), Residuals and Influence in Regression, New York: Chapman and Hall.

Cook, R.D. and Weisberg, S. (1983), “Diagnostics for heteroscedasticity in regression” Biometrika 70, 1-10.

Cornell, J.A. (1990), Experiments with Mixtures, Second Edition New York: John Wiley & Sons.

Cox, D.R. (1970), The Analysis of Binary Data, London: Metheun.

Cox, D.R. (1972), “Regression Models And Life-tables”, Journal Of The Royal Statistical Society Series B-statistical Methodology. 34 (2): 187-220, 1972.

Cronbach, L.J. (1951), “Coefficient Alpha and the Internal Structure of Tests,” Psychometrika, 16, 297-334.

Daniel C. and Wood, F. (1980), Fitting Equations to Data, Revised Edition, New York: John Wiley and Sons, Inc.

Daniel, C. (1959), “Use of Half-normal Plots in Interpreting Factorial Two-level Experiments,” Tech-nometrics, 1, 311-314.

Davis, H.T. (1941), The Analysis of Economic Time Series, Bloomington, IN: Principia Press.

DeLong, E., Delong, D, and Clarke-Pearson, D.L. (1988), “Comparing the Areas Under Two or more Correlated Receiver Operating Characteristic Curves: A Nonparametric Approach,” Biometrics 44, 837-845.

Derringer, D. and Suich, R. (1980), “Simultaneous Optimization of Several Response Variables,” Jour-nal of Quality Technology, Oct. 1980, 12:4, 214-219.

Devore, Jay L. (1995), Probability and Statistics for Engineering and the Sciences, Duxbury Press, CA.

Draper, N. and Smith, H. (1981), Applied Regression Analysis, Second Edition, New York: John Wiley and Sons, Inc.

DuMouched, W. and Jones, B. (1994), “A Simple Bayesian Modification of D-Optimal Designs to Reduce Dependence on an Assumed Model,” Technometrics, 36, 37-47.

Dunnett, C.W. (1955), “A multiple comparison procedure for comparing several treatments with a control” Journal of the American Statistical Association, 50, 1096-1121.

Dwass, M. (1955), “A Note on Simultaneous Confidence Intervals,” Annals of Mathematical Statistics 26: 146-147.

Eppright, E.S., Fox, H.M., Fryer, B.A., Lamkin, G.H., Vivian, V.M., and Fuller, E.S. (1972), “Nutri-tion of Infants and Preschool Children in the North Central Region of the United States of Amer-ica,” World Review of Nutrition and Dietetics, 14.

Eubank, R.L. (1988), Spline Smoothing and Nonparametric Regression, New York: Marcel Dekker, Inc.

Farebrother, R.W. (1981), “Mechanical Representations of the L1 and L2 Estimation Problems,” Statis-tical Data Analysis, 2nd Edition, Amsterdam, North Holland: edited by Y. Dodge.

Fisher, L. and Van Ness, J.W. (1971), “Admissible Clustering Procedures,” Biometrika, 58, 91-104.

Fisherkeller, M.A., Friedman, J.H., and Tukey, J.W. (1974), “PRIM-9: An Interactive Multidimen-sional Data Display and Analysis System,” SLAC-PUB-1408, Stanford, California: Stanford Linear Accelerator Center.

Fleis, J.L., Cohen J., and Everitt, B.S. (1969), “Large-sample standard errors of kappa and weighted kappa,” Psychological Bulletin, 72: 323-327.

Florek, K., Lukaszewicz, J., Perkal, J., and Zubrzycki, S. (1951a), “Sur La Liaison et la Division des Points d'un Ensemble Fini,” Colloquium Mathematicae, 2, 282-285.

Foster, D.P., Stine, R.A., and Waterman, R.P. (1997), Basic Business Statistics, New York, Springer-Ver-lag.

Foster, D.P., Stine, R.A., and Waterman, R.P. (1997), Business Analysis Using Regression, New York, Springer-Verlag.

Friendly, M. (1991), “Mosaic Displays for Multiway Contingency Tables,” New York University Depart-ment of Psychology Reports: 195.

Fuller, W.A. (1976), Introduction to Statistical Time Series, New York, John Wiley and Sons.

Fuller, W.A. (1987), Measurement Error Models, New York, John Wiley and Sons.

Gabriel, K.R. (1982), “Biplot,” Encyclopedia of Statistical Sciences, Volume 1, eds. N.L.Johnson and S. Kotz, New York: John Wiley and Sons, Inc., 263-271.

Gallant, A.R. (1987), Nonlinear Statistical Models, New York, John Wiley and Sons.

Goodnight, J.H. (1978), “Tests of Hypotheses in Fixed Effects Linear Models,” SAS Technical Report R-101, Cary: SAS Institute Inc, also in Communications in Statistics (1980), A9 167-180.

Goodnight, J.H. and W.R. Harvey (1978), “Least Square Means in the Fixed Effect General Linear Model,” SAS Technical Report R-103, Cary NC: SAS Institute Inc.

Greenacre, M.J. (1984), Theory and Applications of Correspondence Analysis, London: Academic Press.

Greenhouse, S. W. and Geiser, S. (1959). “On Methods in the Analysis of Profile Data.” Psychometrika, 32, 95-112.

Gupta, S.S. (1965), On Some Multiple Decision (selection and ranking), Rules., Technometrics 7, 225-245.

Haaland, P.D. (1989), Experimental Design in Biotechnology, New York: Marcel Dekker, Inc.

Hahn, G. J. and Meeker, W. Q. (1991) Statistical Intervals: A Guide for Practitioners. New York: Wiley.

Hahn, G. J., Meeker, W.Q., and Feder, P. I., (1976), “The Evaluation and Comparison of Experimental Designs for Fitting Regression Relationships,” Journal of Quality Technology, Vol. 8, #3, pp. 140-157.

Hahn, G.J. (1976), “Process Improvement Through Simplex EVOP,” Chemical Technology 6, 243-345.

Hajek, J. (1969), A Course in Nonparametric Statistics, San Francisco: Holden-Day.

Harrell, F. (1986), “The Logist Procedure,” SUGI Supplemental Library User's Guide, Version 5 Edition, Cary, NC: SAS Institute Inc.

Harris, R.J. (1975), A Primer of Multivariate Statistics, New York: Academic Press.

Hartigan, J.A. (1975), Clustering Algorithms, New York, John Wiley and Sons.

Hartigan, J.A. (1981), “Consistence of Single Linkage for High-Density Clusters,” Journal of the Amer-ican Statistical Association, 76, 388-394.

Hartigan, J.A. and Kleiner, B. (1981), “Mosaics for Contingency Tables,” Proceedings of the 13th Sym-posium on the Interface between Computer Science and Statistics, Ed. Eddy, W. F., New York: Springer-Verlag, 268-273.

Harvey, A.C. (1976), “Estimating Regression Models with Multiplicative Heteroscedasticity,” Econo-metrica 44-3 461-465.

Hauck, W.W. and Donner, A. (1977), “Wald's Test as Applied to Hypotheses in Logit Analysis,” Jour-nal of the American Statistical Association, 72, 851-863.

Hawkins, D.M. (1974), “The Detection of Errors in Multivariate Data Using Principal Components,” Journal of the American Statistical Association, 69.

Hayashi, C. (1950), “On the Quantification of Qualitative Data from the Mathematico-Statistical Point of View,” Annals of the Institute of Statistical Mathematics, 2:1, 35-47.

Hayter, A.J. (1984), “A proof of the conjecture that the Tukey-Kramer multiple comparisons proce-dure is conservative,” Annals of Mathematical Statistics, 12 61-75.

Henderson, C.R. (1984), Applications of Linear Models in Animal Breeding, Univ. of Guelph.

Hocking, R.R. (1985), The Analysis of Linear Models, Monterey: Brooks-Cole.

Hoeffding, W (1948), “A Non-Parametric Test of Independence”, Annals of Mathematical Statistics, 19, 546-557.

Hoffman, Heike (2001). “Generalized Odds Ratios for Visual Modeling,” Journal of Computational and Graphical Statistics, 10:4 pp. 628-640.

Holland, P.W. and Welsch, R.E. (1977), “Robust Regression Using Interactively Reweighted Least Squares,” Communications Statistics: Theory and Methods, 6, 813-827.

Hooper, J. H. and Amster, S. J. (1990), “Analysis and Presentation of Reliability Data,” Handbook of Statistical Methods for Engineers and Scientists, Harrison M. Wadsworth, editor. New York: McGraw Hill.

Hosmer, D.W. and Lemeshow, S. (1989), Applied Logistic Regression, New York: John Wiley and Sons.

Hsu, J. (1981), “Simultaneous confidence intervals for all distances from the `best',” Annals of Statistics, 9, 1026-1034.

Hsu, J. (1984), “Constrained two-sided simultaneous confidence intervals for multiple comparisons with the `best',” Annals of Statistics, 12, 1136-1144.

Hsu, J. (1989), “Multiple Comparison Procedures” ASA Short Course notes, Columbus OH: Ohio State University.

Hsu, J. (1989), Tutorial Notes on Multiple Comparisons, American Statistical Association, Washington, DC.

Hunter, J.S. (1985), “Statistical Design Applied to Product Design,” Journal of Quality Technology, 17, 210-221.

Huynh, H. and Feldt, L. S. (1970). “Conditions under which Mean Square Ratios in Repeated Mea-surements Designs have Exact F-Distributions.” Journal of the American Statistical Association, 65, 1582-1589.

Huynh, H. and Feldt, L. S. (1976). “Estimation of the Box Correction for Degrees of Freedom from Sample Data in the Randomized Block Split Plot Designs.” Journal of Educational Statistics, 1, 69-82.

Iman, R.L. and Conover, W.J. (1978), “Approximations of the Critical Regions for Spearman's Rho with and without Ties Present,” Communications in Statistics--Theory and Methods, A5, 1335-1348 (5.2).

Inselberg, A. (1985) “The Plane with Parallel Coordinates.” Visual Computing 1. pp 69-91.

Jardine, N. and Sibson, R. (1971), Mathematical Taxonomy, New York: John Wiley and Sons.

John, P.W.M. (1972), Statistical Design and Analysis of Experiments, New York: Macmillan Publishing Company, Inc.

Johnson, M.E. and Nachtsheim, C.J. (1983), “Some Guidelines for Constructing Exact D-Optimal Designs on Convex Design Spaces,” Technometrics 25, 271-277.

Johnston and DeLong (unpublished paper)

Jones, Bradley (1991), “An Interactive Graph For Exploring Multidimensional Response Surfaces,” 1991 Joint Statistical Meetings, Atlanta, Georgia

Judge, G.G., Griffiths,W.E., Hill,R.C., and Lee, Tsoung-Chao (1980), The Theory and Practice of Econometrics, New York: John Wiley and Sons.

Kaiser, H.F. (1958), “The varimax criterion for analytic rotation in factor analysis” Psychometrika, 23, 187-200.

Kalbfleisch, J.D. and Prentice, R.L. (1980), The Statistical Analysis of Failure Time Data, New York: John Wiley and Sons.

Kenward and Roger. (1997) September Biometrics

Khuri, A.I. and Cornell, J.A. (1987) Response Surfaces: Design and Analysis, New York: Marcel Dekker.

Koehler, M.G., Grigoras, S., and Dunn, J.D. (1988), “The Relationship Between Chemical Structure and the Logarithm of the Partition Coefficient,” Quantitative Structure Activity Relationships, 7.

Kohonen, Teuvo. (1989) Self-Organization and Associative Memory. Berlin: Springer.

Kowalski, S.M., Cornell, J.A., and Vining, G.G. (2002) “Split Plot Designs and Estimation Methods for Mixture Experiments with Process Variables,” Technometrics 44: 72-79.

Kramer, C.Y. (1956), “Extension of multiple range tests to group means with unequal numbers of rep-lications,” Biometrics, 12, 309-310.

Lawless, J.E. (1982), Statistical Models and Methods for Lifetime Data, New York: John Wiley and Sons.

Lebart, L., Morineau, A., and Tabaard, N. (1977), Techniques de la Description Statistique, Paris: Dunod.

Lee, E.T. (1980), Statistical Methods for Survival Data Analysis, Belmont CA, Lifetime Learning Publi-cations, a Division of Wadsworth, Inc.

Lenth, R.V. (1989), “Quick and Easy Analysis of Unreplicated Fractional Factorials,” Technometrics, 31, 469-473.

Leven, J.R., Serlin, R.C., and Webne-Behrman, L. (1989), “Analysis of Variance Through Simple Cor-relation,” American Statistician, 43, (1), 32-34.

Levene, H. (1960), “Robust tests for the equality of variances” In I. Olkin (ed), Contributions to proba-bility and statistics, Stanford Univ. Press.

Lin, D. K. J. (1993), “A New Class of Supersaturated Design,” Technometrics, 35, 28-31.

Linnerud: see Rawlings (1988)

Lucas, J.M. (1976), “The Design and Use of V-Mask Control Schemes,” Journal of Quality Technology, 8, 1-12.

Lucas, J.M., (1990), “Letter to the Editor: Comments on Cook and Nachtsheim (1989),” Technomet-rics, 32, 363-364.

MacQueen, J.B. (1967) (1967) “Some Methods for Classification and Analysis of Multivariate Obser-vations,” Proceedings of the fifth Berkeley Symposium on Mathematical Statistics and Probability, 1, 281-297.

Mahalanobis, P.C. (1947), “Sankhya,” The Indian Journal of Statistics, Vol 8, Part 2, April.

Mallows, C.L. (1967), “Choosing a Subset Regression,” unpublished report, Bell Telephone Laborato-ries.

Mallows, C.L. (1973), “Some Comments on Cp,” Technometrics, 15, 661-675.

Mardia, K.V., Kent, J.T., and Bibby J.M. (1979). Multivariate Analysis, New York: Academic Press.

Marsaglia, G. (1996) DIEHARD: A Battery of Tests of Randomness”. http://stat.fsu.edu/~geo.

Matsumoto, M. and Nishimura, T. (1998)”Mersenne Twister: A 623-Dimensionally Equidistributed Uniform Pseudo-Random Number Generator”, ACM Transactions on Modeling and Computer Simu-lation, Vol. 8, No. 1, January 1998, 3-30.

McCullagh, P. and Nelder, J.A. (1983), Generalized Linear Models, London: Chapman and Hall Ltd.

McLachlan, G.J. and Krishnan, T. (1997), The EM Algorithm and Extensions, New York: John Wiley and Sons.

McQuitty, L.L. (1957), “Elementary Linkage Analysis for Isolating Orthogonal and Oblique Types and Typal Relevancies,” Educational and Psychological Measurement, 17, 207-229.

Meeker, W.Q. and Escobar, L.A. (1998), Statistical Methods for Reliability Data, pp. 60-62, New York: John Wiley and Sons.

Meyer, R.D., Steinberg, D.M., and Box, G. (1996), “Follow-up Designs to Resolve Confounding in Multifactor Experiments,” Technometrics, Vol. 38, #4, p307

Meyer, R.K. and Nachtsheim, C.J. (1995), The Coordinate Exchange Algorithm for Constructing Exact Optimal Designs,” Technometrics, Vol 37, pp. 60-69.

Miller, A.J. (1990), Subset Selection in Regression, New York: Chapman and Hall.

Milligan, G.W. (1980), “An Examination of the Effect of Six Types of Error Perturbation on Fifteen Clustering Algorithms,” Psychometrika, 45, 325-342.

Milliken, G.A. and Johnson, E.J. (1984), Analysis of Messy Data Volume I: Design of Experiments, New York: Van Nostrand Reinhold Company.

Mitchell, T.J. (1974), “An algorithm for the Construction of D-Optimal Experimental Designs,” Tech-nometrics, 16:2, pp.203-210.

Montgomery, D. C. (1991), “Using Fractional Factorial Designs for Robust Process Development,” Quality Engineering, 3, 193-205.

Montgomery, D.C. (2001), Introduction to Statistical Quality Control, 4th Edition New York: John Wiley and Sons.

Montgomery, D.C. and Peck, E.A. (1982), Introduction to Linear Regression Analysis, New York: John Wiley and Sons.

Moore, D.S. and McCabe, G. P. (1989), Introduction to the Practice of Statistics, New York and London: W. H. Freeman and Company.

Morris, M.D., Mitchell, T.J., and Ylvisaker, D. (1993), “Bayesian Design and Analysis of Computer Experiments: Use of Derivatives in Surface Prediction ,” Technometrics 35:2, 243-255.

Mosteller, F. and Tukey, J.W. (1977), Data Analysis and Regression, Reading, MA: Addison-Wesley.

Muller, K.E. and Barton, C.N. (1989), “Approximate Power for Repeated-measures ANOVA Lacking Sphericity,” Journal of the American Statistical Association, 84, 549-555.

Myers, R. H. and Montgomery, D. C. (1995), Response Surface Methodology, New York: John Wiley and Sons.

Myers, R.H. (1976), Response Surface Methodology, Boston: Allyn and Bacon.

Myers, R.H. (1988), Response Surface Methodology, Virginia Polytechnic and State University.

Myers, R.H. (1989), Classical and Modern Regression with Applications, Boston: PWS-KENT.

Nelder, J.A. and Mead, R. (1965), “A Simplex Method for Function Minimization,” The Computer Journal, 7, 308-313.

Nelder, J.A. and Wedderburn, R.W.M. (1983), “Generalized Linear Models,” Journal of the Royal Sta-tistical Society, Series A, 135, 370-384.

Nelson, F. (1976), “On a General Computer Algorithm for the Analysis of Model with Limited Depen-dent Variables,” Annals of Economic and Social Measurement, 5/4.

Nelson, L. (1984), “The Shewhart Control Chart--Tests for Special Causes,” Journal of Quality Tech-nology, 15, 237-239.

Nelson, L. (1985), “Interpreting Shewhart X Control Charts,” Journal of Quality Technology, 17, 114-116.

Nelson, W. (1982), Applied Life Data Analysis, New York: John Wiley and Sons.

Nelson, W. (1990), Accelerated Testing: Statistical Models, Test Plans, and Data analysis, New York: John Wiley and Sons.

Neter, J., Wasserman, W. and Kutner, M.H. (1990), Applied Linear Statistical Models, Third Edition, Boston: Irwin, Inc.

Nunnaly, J. C. (1978) Psychometric Theory, 2nd Ed., New York: McGraw-Hill.

O'Brien, R.G. (1979), “A general ANOVA method for robust tests of additive models for variances,” Journal of the American Statistical Association, 74, 877-880.

O'Brien, R., and Lohr, V. (1984), “Power Analysis For Linear Models: The Time Has Come,” Proceed-ings of the Ninth Annual SAS User's Group International Conference, 840-846.

Odeh, R. E. and Owen, D. B. (1980) Tables for Normal Tolerance Limits, Sampling Plans, and Screening. New York: Marcel Dekker, Inc.

Olejnik, S.F. and Algina, J. (1987), “Type I Error Rates and Power Estimates of Selected Parametric and Nonparametric Tests of Scale,” Journal of Educational Statistics 12, 45-61.

Olson, C.L. (1976), “On Choosing a Test Statistic in manova,” Psychological Bulletin 83, 579-586.

Piepel, G.F. (1988), “Programs for Generating Extreme Vertices and Centroids of Linearly Constrained Experimental Regions,” Journal of Quality Technology 20:2, 125-139.

Plackett, R.L. and Burman, J.P. (1947), “The Design of Optimum Multifactorial Experiments,” Biometrika, 33, 305-325.

Ratkowsky, D.A. (1990), Handbook of Nonlinear Regression Models, New York, Marcel Dekker, Inc.

Rawlings, J.O. (1988), Applied Regression Analysis: A Research Tool, Pacific Grove CA: Wadsworth and Books/Cole.

Reinsch, C.H. (1967), Smoothing by Spline Functions, Numerische Mathematik, 10, 177-183.

Robertson, T., Wright, F.T., and R.L. Dykstra, R.L (1988), Order Restricted Statistical Inference, New York: John Wiley and Sons, Inc.

Rodriguez, R.N. (1990), “Selected SAS/QC Software Examples, Release 6.06,” SAS Institute Inc., Cary, NC.

Rodriguez, R.N. (1991), “Applications of Computer Graphics to Two Basic Statistical Quality Improvement Methods,” National Computer Graphics Association Proceedings, 17-26.

Rosenbaum, P.R. (1989), “Exploratory Plots for Paired Data,” American Statistician, 108-109.

Rousseuw, P.J. and Leroy, A.M. (1987), Robust Regression and Outlier Detection, New York: John Wiley and Sons.

Royston, J.P. (1982), “An Extension of Shapiro and Wilk's W Test for Normality to Large Samples,” Applied Statistics 31, 115-124.

Sall, J.P. (1990), “Leverage Plots for General Linear Hypotheses,” American Statistician, 44, (4), 303-315.

SAS Institute (1986), SAS/QC User's Guide, Version 5 Edition, SAS Institute Inc., Cary, NC.

SAS Institute (1987), SAS/STAT Guide for Personal Computers, Version 6 Edition, Cary NC: SAS Insti-tute Inc.

SAS Institute (1989), “SAS/ Technical Report P-188: SAS/QC Software Examples, Version 6 Edition,” SAS Institute Inc., Cary, NC.

SAS Institute (1995), SAS/QC Software: Usage and References, Version 6, 1st Ed., Vol. 1, SAS Institute Inc., Cary, NC.

SAS Institute (1999), SAS/ETS User's Guide, Version 8, Cary NC: SAS Institute Inc.

SAS Institute Inc. (1996), “SAS/STAT Software, Changes and Enhancements through Version 6.11, The Mixed Procedure, Cary, NC: SAS Institute Inc.

SAS Institute Inc. (1999), SAS/STAT User's Guide, Version 8, Cary, NC: SAS Institute Inc.

Satterthwaite, F.E., (1946), “An approximate distribution of Estimates of Variance Components,” Bio-metrics Bulletin, 2, 110-114.

Seber, G.A.F. (1984), Multivariate Observations, New York: John Wiley and Sons, 413-416.

Seder, L.A. (1990) “Diagnosis with Diagrams, Part I and Part II, Industrial Quality Control,” 6, 11-19, 7-11 (1950) reprinted in Quality Engineering 2, 505-530 (1990).

Shapiro, S.S. and Wilk, M.B. (1965), “An Analysis of Variance Test for Normality (complete samples),” Biometrika 52, 591-611.

Sheffé, H. (1958) Experiments with Mixtures, JRSS B 20, 344-360.

Sneath, P.H.A. (1957) “The Application of Computers to Taxonomy,” Journal of General Microbiol-ogy,17, 201-226.

Snedecor, G.W. and Cochran, W.G. (1967), Statistical Methods, Ames, Iowa: Iowa State University Press.

Snee, R.D. (1975), “Experimental Designs for Quadratic Models in Constrained Mixture Spaces,” Technometrics, 17:2, 149-159.

Snee, R.D. (1979), “Experimental Designs for Mixture Systems with Multicomponent Constraints,” Commun. Statistics, A8(4), 303-326.

Snee, R.D. and Marquardt, D.W. (1974), “Extreme Vertices Designs for Linear Mixture Models,” Tech-nometrics, 16, 391-408.

Snee, Ronald D. (1985)Computer Aided Design of Experiments - Some Practical Experiences, Journal of Quality Technology, Vol 17. No. 4 October 1985 p.231.

Sokal, R.R. and Michener, C.D. (1958), “A Statistical Method for Evaluating Systematic Relation-ships,” University of Kansas Science Bulletin, 38, 1409-1438.

Spendley, W., Hext, G.R., and Minsworth, F.R. (1962), “Sequential Application of Simplex Designs in Optimization and Evolutionary Operation,” Technometrics 4, 441-461.

St. John, R.C. and Draper, N.R. (1975), “D-Optimality for Regression Designs: A Review,” Technomet-rics, 17 pp 15-23.

Stevens, J.P. (1979), “Comment on Olson: Choosing a Test Statistic in Multivariate Analysis of Vari-ance,” Psychological Bulletin, 86, 355-360.

Stevens, J.P. (1986), Applied Multivariate Statistics for the Social Sciences, New Jersey: Laurence Erlbaum Associates.

Taguchi, G. (1976), “An Introduction to Quality Control,” Nagoya, Japan: Central Japan Quality Control Association.

Tamhane, A. C. and Dunlop, D. D. (2000) Statistics and Data Analysis. Prentice Hall.

Tan, Charles Y., and Iglewicz, Boris (1999), “Measurement-methods Comparisons and Linear Statisti-cal Relationship,” Technometrics, 41:3, 192-201.

Tobin, J. (1958), “Estimation of Relationships for Limited Dependent Variables,” Econometrica, 26 24-36.

Tukey, J. (1953), “A problem of multiple comparisons,” Dittoed manuscript of 396 pages, Princeton University.

Tukey, J. (1991), “The Philosophy of Multiple Comparisons,” Statistical Science, 6, 100-116.

Wadsworth, H. M., Stephens, K., Godfrey, A.B. (1986) Modern Methods for Quality Control and Improvement. John Wiley & Sons.

Walker, S.H. and Duncan, D.B. (1967), “Estimation of the Probability of an Event as a Function of Several Independent Variables,” Biometrika 54.

Wegman, E. J. (1990) “Hyperdimensional Data Analysis using Parallel Coordinates.” Journal of the American Statistical Association 85, pp. 664-675.

Welch, B.L. (1951), “On the comparison of several mean values: an alternative approach,” Biometrika 38, 330-336.

Welch, W.J. (1984), “Computer-Aided Design of Experiments for repsonse Estimation,” Technometrics, 26, 217-224.

Western Electric Company (1956), Statistical Quality Control Handbook, currently referred to as the AT&T Statistical Quality Control Handbook.

Westgard, J. O (2002), Basic QC Practices, 2nd Edition. Madison, Wisconsin: Westgard QC Inc.

Winer, B.J. (1971), Statistical Principals in Experimental Design, Second Edition, New York: McGraw-Hill, Inc.

Wright, S.P. and R.G. O'Brien (1988), “Power Analysis in an Enhanced GLM Procedure: What it Might Look Like,” SUGI 1988, Proceedings of the Thirteenth Annual Conference, 1097-1102, Cary NC: SAS Institute Inc.


荣誉榜和致谢

起源

JMP 由 SAS Institute Inc., Cary, NC 开发。虽然 JMP 的某些部分改编自 SAS 系统中的例程，特别是线性代数和概率计算部分，但 JMP 不是 SAS 系统的一部分。JMP 1 制作于 1989 年 10 月。

荣誉榜

John Sall 构思并启动了 JMP，而设计和开发则由 John Sall、Chung-Wei Ng、Michael Hecht、Richard Potter、Brian Corcoran、Annie Dudley Zangi、Bradley Jones、Craige Hales、Chris Gotwalt、Paul Nelson、Xan Gregg、Jianfeng Ding、Scott McQuiggan 和 Wenjie Bao 完成。

在 SAS Institute 技术支持部门，Ryan Gilmore、Wendy Murphrey 和 Toby Trott 提供技术支持并负责测试站点管理。统计技术支持则由 Craig DeVault、Duane Hayes、Elizabeth Edwards、Kathleen Kiernan 和 Tonya Mauldin 提供。

Nicole Jones、Jim Borek、Kyoko Keener、Hui Di、Laura Lancaster、Joseph Morgan、Wenjun Bao、Fang Chen 和 Hugh Crews 提供实时质量保证。其它测试和技术支持由 SAS（日本）的 Noriki Inoue、Kyoko Takenaka 和 Masakazu Okada 完成。

Bob Hickey 是版本工程师。特别感谢来自 SAS 的 Mark Bailey 和 Lori Rothenberg。

JMP 手册由 Ann Lehman、Lee Creighton、John Sall、Bradley Jones、Erin Vang 和 Meredith Blackwelder 编写，Annie Dudley Zangi 和 Brian Corcoran 也做了相应贡献。SAS Publications 负责创作服务和生产。Melanie Drake 完成了帮助系统。

另外还要感谢 Georges Guirguis、Warren Sarle、Gordon Johnston、Duane Hayes、Russell Wolfinger、Randall Tobias、Robert N.Rodriguez、Ying So、Warren Kuhfeld、George MacKensie、Bob Lucas、Warren Kuhfeld、Mike Leonard 和 Padraic Neville 提供了统计研发支持。

致谢

我们要特别感谢鼓励我们启动 JMP 的所有人士、JMP 技术精湛的测试人员以及说明文档的审核人员。在此特别感谢 Michael Benson、Howard Yetter (d)、Andy Mauromoustakos、Al Best、Stan Young、Robert Muenchen、Lenore Herzenberg、Ramon Leon、Tom Lange、Homer Hegedus、Skip Weed、Michael Emptage、Pat Spagan、Paul Wenz、Mike Bowen、Lori Gates、Georgia Morgan、David Tanaka、Zoe Jewell、Sky Alibhai、David Coleman、Linda Blazek、Michael Friendly、Joe Hockman、Frank Shen、J.H.Goodman、David Iklé、Lou Valente、Barry Hembree、Dan Obermiller、Jeff Sweeney、Lynn Vanatta 及 Kris Ghosh。

同时感谢 Dick DeVeaux、Gray McQuarrie、Robert Stine、George Fraction、Avigdor Cahaner、José Ramirez、Gudmunder Axelsson、Al Fulmer、Cary Tuckfield、Ron Thisted、Nancy McDermott、Veronica Czitrom、Tom Johnson、Cy Wegman、Paul Dwyer、DaRon Huffaker、Kevin Norwood、Mike Thompson、Jack Reese、Francois Mainville 和 John Wass。

我们还要由衷感谢以下人士在各自的统计专业领域提供的专家性建议：R. Hocking 和
P. Spector 提供了有关有效假设的建议；Robert Mee 提供了有关筛选设计生成器的建议；Grey Piepel、Peter Goos 和 J. Stuart Hunter 提供了有关试验设计的建议；Jason Hsu 提供了有关多重比较方法的建议（遗憾的是我们未能将所有方法都纳入 JMP）；Ralph O'Brien 提供了有关方差齐性检验的建议；Ralph O'Brien 和 S.Paul Wright 提供了有关统计功效的建议；Keith Muller 提供了有关多元方法的建议；Harry Martz、Wayne Nelson、Ramon Leon、Dave Trindade、Paul Tobias 和 William Q Meeker 提供了有关可靠性图的建议；Lijian Yang 和
J.S. Marron 提供了有关二元平滑设计的建议；George Milliken 和 Yurii Bulavski 提供了有关混合模型开发的建议；Will Potts 和 Cathy Maahs-Fladung 提供了有关数据采集的建议；Clay Thompson 提供了有关等高线标绘算法的建议；Tom Little、Blanton Godfrey、Tim Clapp 和 Joe Ficalora 提供了六西格玛方面的建议。

在样本数据方面，我们要感谢 Patrice Strahle 提供了 Pareto 实例，德克萨斯空气控制委员会提供了污染数据，以及 David Coleman 提供了花粉 (eureka) 数据。

翻译

Erin Vang 负责管理本地化。SAS 日本的 Noriki Inoue、Kyoko Takenaka 和 Masakazu Okada 在整个项目中发挥了不可或缺的作用。特别鸣谢 Toshiro Haga 教授（已退休，东京理科大学）、Hirohiko Asano 教授（东京都立大学）和 Yusuke Ono 审核日文翻译。同时，由衷感谢北京清华大学的教授白峰杉博士、陆璇博士、李建国博士及其助手郭瑞、江山、万志诚和赵强审核简体中文翻译。最后，感谢我们优秀翻译团队的所有成员!

过去的支持

在 JMP 发展过程中许多人士都做出了重要贡献，在此特别感谢 Jeffrey Perkinson、David DeLong、Mary Cole、Kristin Nauta、Aaron Walker、Ike Walker、Eric Gjertsen、Dave Tilley、Ruth Lee、Annette Sanders、Tim Christensen、Jeff Polzin、Eric Wasserman、Charles Soper、Yusuke Ono 及 Junji Kishimoto。感谢 Jeanne Martin、Fouad Younan 和 Frank Lassiter 实现的 SAS Institute 质量保证。版本 3 和 4 的附加测试由 Li Yang、Brenda Sun、Katrina Hauser 和 Andrea Ritter 完成。

另外还要感谢 Jenny Kendall、John Hansen、Eddie Routten、David Schlotzhauer 和 James Mulherin。感谢 Steve Shack、Greg Weier 和 Maura Stokes 测试了 JMP 1。

感谢 Charles Shipp、Harold Gugel (d)、Jim Winters、Matthew Lay、Tim Rey、Rubin Gabriel、Brian Ruff、William Lisowski、David Morganstein、Tom Esposito、Susan West、Chris Fehily、Dan Chilko、Jim Shook、Ken Bodner、Rick Blahunka、Dana C. Aultman 和 William Fehlner 的大力支持。


用户指南

上一页 | 下一页

JMP 用户指南

用户指南包含以下章节：

开始使用 JMP

用前须知

创建新数据表

打开现有 JMP 文件

创建新日志

加密和解密脚本

导入数据

通过电子邮件发送表或报表（仅限于 Windows）

输入和编辑数据

JMP 数据表的元素

指定数据类型和建模类型

输入数据

编辑数据和表

选择行和列

保存表、报表和会话

保存数据表

保存报表

将报表粘贴到其它程序

保存 JMP 会话

保存记录窗口

指定文件保存位置（仅限于 Windows）

为数据指定性质和特征

为行和列指定特征

为列指定性质

移除性质

在列间标准化属性和性质

使用行状态列

使用输出报表

编辑报表

打印报表

将报表粘贴到其它程序

添加选项和运行分析

将步骤保存为脚本

格式化报表

选择图中的点

使用标记

更改图外观和图表外观

向报表中添加元素

重新构造数据表

创建子集表

对数据表排序

堆叠列

拆分列

转置行和列

附加表（合并）

连接表

更新表

汇总数据

汇总列

绘制数据表

使用公式编辑器

创建公式

引用列和表变量

使用局部变量

引用列和表变量

添加运算符

使用函数

公式中表达式的排序

使用公式编辑器选项

编辑公式

自定义公式

实例和教程

使用键盘快捷方式

术语表

个性化 JMP

更改启动首选项

用于打开 Excel 文件的首选项

更改公式和脚本选项

更改数据表选项

更改报表选项

更改颜色主题

自定义字体和语言

指定图形格式

调整通信设置（仅限于 Windows 和 Linux）

调整代理设置（仅限于 Linux）

指定文件位置和关联

自定义文本导入/导出选项

个性化工具栏 (Macintosh)

个性化工具栏（Windows 和 Linux）

自定义菜单（仅限于 Windows 和 Linux）

保存菜单/工具栏（Windows 和 Linux）

了解 JMP 起始页

JMP 起始页窗口概述

文件类别

基本类别

模型类别

多元类别

生存类别

图形类别

曲面类别

测量类别

控制类别

试验设计类别

表类别

了解主菜单

JMP 菜单（仅限于 Mac）

文件菜单

编辑菜单

表菜单

行菜单

列菜单

试验设计菜单

分析菜单

图形菜单

工具菜单

视图菜单

窗口菜单

帮助菜单

布局菜单

在公式中使用函数

行函数

数值函数

超越函数

三角函数

字符函数

比较函数

条件函数

概率函数

统计函数

随机函数

日期时间函数

行状态函数

赋值函数

用户指南


开始使用 JMP

创建和打开数据

在 JMP 中要做的第一件事情就是打开或创建 JMP 数据表：

  • 要将现有文件导入 JMP，可以单击 JMP 起始页中的打开数据表按钮或者选择文件 > 打开。有关详情，请参阅"打开现有 JMP 文件"。
  • 要在 JMP 中手动输入数据，可以单击 JMP 起始页中的新建数据表按钮或者选择文件 > 新建。这样系统将创建一个空白的 JMP 数据表，然后您便可以开始输入您的数据。有关详情，请参阅"创建新数据表"。

本章向您详细介绍如何创建新数据表、如何将数据导入新表、如何导出数据以及如何获得进一步的帮助。

目录

用前须知

今日提示窗口

JMP 起始页窗口

创建新数据表

打开现有 JMP 文件

创建新日志

创建要演示的日志：实例

加密和解密脚本

导入数据

打开文本文件

在文本编辑窗口中打开文本文件

将文本作为数据导入

打开 Excel 和 OpenOffice 文件

打开 SAS 数据集

打开 SAS 传输文件

从数据库打开数据

使用 SQL 语句检索数据

结构化查询语言 (SQL)：参考

使用 WHERE 子句编辑器

读取实时数据（仅限于 Windows 和 Linux）

使用 Internet 打开文件（仅限于 Windows 和 Linux）

通过电子邮件发送表或报表（仅限于 Windows）


用前须知

在开始使用 JMP 之前，请先熟悉一下 JMP 最初的一些窗口：“今日提示”窗口和“JMP 起始页”窗口。

今日提示窗口

在 JMP 打开时，您会看到“今日提示”窗口。该窗口提供了一些可能不为您所知的 JMP 相关使用提示。

  • 启动时显示提示 如果选定，则每次启动 JMP 时都将显示今日提示窗口。通过选择以下各项也可以访问这一选项：文件（Macintosh 中的编辑）> 首选项 > 常规 > 启动时显示今日提示。
  • 进入初学者教程 单击以启动初学者教程。本教程将向初学者详细介绍 JMP 及其命令和控制的工作方式。要访问 JMP 的其它教程，请选择帮助 > 教程。
  • 上一条提示 在今日提示窗口中返回至上一条提示。
  • 下一条提示 在今日提示窗口中前进至下一条提示。

在您安装 JMP 时安装的 Tip of the Day 文件夹中，包含了启动时显示“今日提示”窗口所用的 HTML 文件和图像。您可以添加自己的提示项，方法是将提示项命名为 tipXX.htm，其中提示文件名中的 XX 表示下一个未使用的编号。

要在关闭“今日提示”窗口后重新打开它，请选择帮助 > 今日提示。

JMP 起始页窗口

启动时，“JMP 起始页”窗口在“今日提示”窗口的后面。JMP 起始页中的大多数命令与主菜单和工具栏中的命令相同。

利用“JMP 起始页”窗口可以在不使用主菜单的情况下访问各个命令。如果使用主菜单访问特定类型的分析，有时可能会需要您在开始分析前对窗口进行一些调整。图形和控制页上都有“JMP 起始页”的快捷按钮，通过它们可以定位至已经正确设置的窗口。

有关详情，请参阅"JMP 起始页窗口概述"。

要打开和关闭“JMP 起始页”请选择视图（Macintosh 上的窗口）> JMP 起始页。通过选择文件（Macintosh 上的 JMP）> 首选项并且撤消选定初始 JMP 起始页窗口，也可以阻止在启动时显示“JMP 起始页”。


创建新数据表

要分析数据，您必须首先创建一个数据表。

要创建新数据表，请执行以下操作：

  1. 选择文件 > 新建。此时将显示一个空白的数据表，表中没有行，只有一个数值列，标签为列 1。
  2. 将光标移至单元格中。
  3. 单击单元格。光标变为 I 型光标 ( [image])，如"新数据表" 中所示。
  4. 输入值。
新数据表

在表中填入值有多种方法：

  • 创建新行和列，然后在数据网格中输入或粘贴数据（请参阅"添加和删除行"）。
  • 构建一个公式，以计算列值（请参阅"创建公式"）。
  • 从另一个应用程序中导入数据（请参阅"导入数据"）。
  • 从另一个应用程序中复制值，然后将其粘贴至表中。
  • 使用测量仪器读取外部测量（请参阅"读取实时数据（仅限于 Windows 和 Linux）"）。
  • 将列从一个表中拖至另一个表中。

有关如何设置数据表的格式、编辑数据表和使用数据表的详情，请参阅"输入和编辑数据"。


打开现有 JMP 文件

如果您要导入 JMP 数据表 (.jmp)、脚本 (.jsl) 或日志 (.jrn) 格式的文件，请执行以下操作：

  1. 选择文件 > 打开。
  2. 从出现的窗口中选择文件类型：
    文件类型 | 操作系统 | 打开说明
    JMP 数据表 Windows 从文件类型列表中，选择 JMP 数据表。

    高亮度显示的表中的注释以及行数和列数显示在对话框底部。单击选择列旁边的复选框，以便在打开数据表格时只显示某些列。
    Macintosh 从启用列表中，选择 JMP 数据表。
    高亮度显示的表中的注释以及行数和列数显示在对话框底部。单击打开前选择列旁边的复选框，以便在打开数据表格时只显示某些列。
    Linux 从筛选器列表中，选择 *.jmp（JMP 数据表）。

    请注意，如果您选择某个文件或文件夹，然后单击下一步，则会看到高亮度显示的表中的注释以及行数和列数。单击列名旁边的框即可在打开数据表时将它们显示在表中。
    JMP 脚本 Windows 从文件类型列表中，选择 JMP 文件或 JSL 脚本。
    选择脚本之后，打开后运行此脚本选项将出现在对话框底部。选定它即可在打开脚本之后自动运行该脚本。
    Macintosh 从启用列表中，选择 JMP 脚本。
    选择脚本之后，打开后运行选项将出现在对话框底部。选定它即可在打开脚本之后自动运行该脚本。
    Linux | 从筛选器列表中，选择 *.jsl（JSL 脚本）。
    JMP 日志或报表 | Windows | 从文件类型列表中，选择 JMP 文件或报表文件。
    Macintosh | 从启用列表中，选择 JMP 日志或 JMP 报表。
    Linux | 从筛选器列表中，选择 *.jrn（JMP 日志）或 *.jrp（JMP 报表）。
  3. 高亮度显示要打开的文件名。
  4. 单击打开（Linux 中为完成）。

注：JMP 可以打开第 3 版以及更高版本的 JMP 文件。


创建新日志

创建一个空的日志窗口并且自定义其中的内容对您处理 JMP 项目大有帮助。它会成为一种参考文件类型。在日志中，您可以保存文本项、其它文件的超级链接、URL、脚本以及文件目录。

您甚至可以创建和保存包含所有相关报表和数据表链接的脚本。脚本可以将会话存储为包含表和报表链接的 .jsl 文件。

我们可以将日志看成是一张空白的纸。实际上它是一个非常灵活的可自定义的窗口，您可以在其中加入任何元素，例如图形、表、文本、URL 链接、数据表链接以及其它一些文件。您也可以将它看成是一个包含项目或任务所有部分的存储库。

"使用日志实例" 显示的是如何为一个简单的项目构建日志的实例。

使用日志实例

要创建新日志，请执行以下操作：

  1. 选择文件 > 新建 > 日志。或者，从“JMP 起始页”窗口中选择新建日志。
  2. 按照以下说明添加和编辑日志项。
    任务 | 操作
    在日志中添加项目

    使用鼠标右键单击日志窗口的空白处，然后选择某个选项，如"在新日志中添加项目" 所示。

    在新日志中添加项目
    添加日志注释 | 双击日志窗口的空白处，然后在出现的框中键入相应的注释。
    添加图形 | 复制 JMP 或图形应用程序中的图形，然后使用编辑 > 粘贴将它粘贴到日志中。JMP 会将图形放到日志的末尾。
    编辑项目 使用鼠标右键单击某个项目，然后对其进行编辑，如"编辑日志" 所示。
    编辑日志
  3. 通过选择文件 > 另存为来保存日志。如果您将日志另存为 .html 文件，则在 web 浏览器中查看文件时，所有按钮和链接全都处于活动状态。

创建要演示的日志：实例

大多数人都是使用 PowerPoint 等演示应用程序来直观地辅助演示过程。但是对于 JMP 日志来说，可以不必使用演示应用程序。因为您要讲的要点可以全部输入到日志中，然后与生动的链接和按钮结合起来，从而使 JMP 自动执行您需要的分析。

请按本例中的说明使用日志创建一个样本演示：

  1. 选择文件 > 新建 > 日志。
  2. 使用鼠标右键单击日志。通过选择添加外框项来启动您的外框。
使用鼠标右键单击“日志”窗口。
  3. 输入演示标题。
输入标题

演示中应该包括许多嵌套在一起的外框节点，在演示时，您应该按顺序打开和关闭。

  4. 通过单击“我的二元演示”标题栏中的红色三角形并且选择添加文本项，将要点添加到外框中。
添加文本项

现在，以链接的形式添加文件参考。这样，只要在演示过程中单击一下鼠标就能打开文件。

  5. 单击“我的二元演示”标题栏中的红色三角形，然后选择添加窗口参考。
  6. 选择一个打开的窗口，然后单击确定。
  7. 验证一下单击链接能否打开文件，具体方法是使用鼠标右键单击该链接，然后选择设定脚本来查看文件路径（"添加参考"）。
添加参考
  8. 更改链接外观，通过从菜单中选择下划线型可以使用按钮代替超级文本来显示它。结果应类似于"将链接更改成按钮" 中显示的内容。
将链接更改成按钮

注：要创建按钮，另外一种方法是单击“我的二元演示”标题栏上的红色三角形菜单，然后选择添加文件参考命令并且定位至该文件。


加密和解密脚本

如果您要保护 JMP 脚本语言 (JSL) 文件，您可以将它加密，因此只有知道密码的人才能运行它或者查看并运行它。这一功能非常适用于您想要有限共享脚本的情况。

JMP 提供两种方法来加密脚本：通过使它具有“仅限于运行”或“查看并运行”属性。要加密脚本，请执行以下操作：

  1. 打开脚本。
  2. 选择编辑 > 加密脚本。此时将出现如"加密窗口" 所示的屏幕。
加密窗口
  3. 指定密码以便加密文件：
    • 要加密脚本，以使用户在没有密码的情况下也能运行它，但是只有知道密码才能查看脚本，则只需向 JMP 提供一个解密密码。
    • 要加密脚本，以使用户必须输入一个密码来运行它，然后输入另一个密码来查看它，则要向 JMP 提供一个运行密码和一个解密密码。

      注：密码必须由单字节字符构成，而且不能使用文本输入法编辑器 (IME)。
  4. 加密后的脚本显示在新窗口中，如"加密脚本实例" 所示。
加密脚本实例
  5. 保存已加密的脚本。

要先解密 JSL 脚本，然后再查看它，请执行以下操作：

  1. 选择文件 > 打开，在 JMP 中打开脚本。
  2. 选择编辑 > 解密脚本。此时将出现如"解密脚本" 所示的屏幕。
解密脚本
  3. 输入解密密码。脚本显示在新窗口中。

要运行已加密的 JSL 脚本，请执行以下操作：

  1. 选择文件 > 打开，在 JMP 中打开脚本。
  2. 选择编辑 > 运行脚本。此时将出现如"运行已加密的脚本" 所示的屏幕。
运行已加密的脚本
  3. 输入运行密码，然后单击确定。


导入数据

如果您现在有数据，但不是 .jmp 格式的文件，则可以导入数据并将其另存为 JMP 数据表。以下列表提供了您可以导入至 JMP 中的文件类型。

  • Microsoft Excel (.xls)
  • 文本文件 (.txt)
  • 以逗号分隔值的文本文件 (.csv)
  • SAS 传输文件 (.xpt, .stx)
  • FACS (.fcs)
  • 在安装了符合 V2+ 标准的 ODBC 驱动程序的 Windows 中的 Microsoft Access 数据库 (.mdb)
  • 在安装了符合 V2+ 标准的 ODBC 驱动程序的 Windows 中的数据库 (dBASE) (.dbf, .ndx, .mdx)
  • 在安装了符合标准的 ODBC 驱动程序的 Linux 中的 MySQL、Oracle 和 PostgreSQL 数据库
  • Linux 中的 OpenOffice 电子表格 (.sxc)
  • Windows 中的数据文件 (.dat)
  • Windows 中的 HTML 文件 (.htm, .html)
  • Windows 中的 SAS 第 5-9 版 (.sd2, .sd5, .sd7, .sas7bdat)
  • Macintosh 和 Linux 中的 SAS 第 6 版（.sas7bdat, .ssd, .ssd01 和 .saseb$data）

打开文本文件

您可以打开扩展名为 .txt、.dat（仅限于 Windows）和 .csv 的文本文件。文本文件几乎可以使用任意字符分隔，也可以是固定宽度的文件。JMP 提供了三种不同的打开这些文件的方式：通过为您确定数据排列、通过允许您确定数据排列或者通过在 JMP 中使用文本编辑器打开文件。

下表列出了在打开文本文件时涉及的步骤。

 自动确定数据排列 手动指定数据排列
Windows
  1. 选择文件 > 打开。
  2. 从文件类型字段中，选择文本导入文件。
  3. 要使用“首选项”中设置的导入规则（请参阅"自定义文本导入/导出选项"），请选择使用文本导入首选项。

    要允许 JMP 使用其最佳预测来排列数据，请选择尝试辨别格式。请注意，尝试辨别格式通常可以更好地设置固定宽度文本文件的格式。

    请注意，如果您选择选项下次调用此对话框时选择此筛选器，JMP 会将默认的文件类型选择设置为您在文件类型列表中选择的选项。
  4. 选择您要打开的文件。
  5. 单击打开。
  1. 选择文件 > 打开。
  2. 从文件类型字段中，选择文本导入预览。
  3. 选择您要打开的文件。
  4. 单击打开。
  5. 完成“文本导入预览”窗口。有关详情，请参阅"了解文本导入预览/选项窗口"。
    务必要单击指定字段，然后高亮度显示那些值。单击设置字段，以便指定在打开固定宽度的文件时的列宽。
  6. 单击确定。
Macintosh
  1. 选择文件 > 打开。
  2. 从启用字段中，选择所有文本文档。
  3. 选择您要打开的文件。
  4. 从打开为字段（如果可用）中，选择数据（最佳预测）或数据（使用首选项）。
  5. 单击打开。
  1. 选择文件 > 打开。
  2. 从启用字段中，选择所有文本文档。
  3. 选择您要打开的文件。
  4. 从打开为字段（如果可用）中，选择数据（使用预览）。
  5. 单击打开。
  6. 完成“文本导入预览”窗口。有关详情，请参阅"了解文本导入预览/选项窗口"。
  7. 单击确定。
Linux
  1. 选择文件 > 打开。
  2. 从筛选器字段中，选择：
    1. *.txt（固定宽度文本），如果您文件中的文本行宽是固定的；
    2. *.txt*.csv（分隔文本），如果您的文件中包含分隔符（表示文本行末尾的字符）。
  3. 选择您要打开的文件。
  4. 单击完成。
  1. 选择文件 > 打开。
  2. 从筛选器字段中，选择：
    1. *.txt（固定宽度文本），如果您文件中的文本行宽是固定的；
    2. *.txt*.csv（分隔文本），如果您的文件中包含分隔符（表示文本行末尾的字符）。
  3. 选择您要打开的文件。
  4. 单击下一步。
  5. 完成“文本导入选项”窗口。有关详情，请参阅"了解文本导入预览/选项窗口"。
    如果文件中文本的行宽是固定的，请务必单击指定字段，然后高亮度显示其中值并且单击设置字段以指定列宽。
  6. 单击完成。

了解文本导入预览/选项窗口

通过选择文件 > 打开，然后选择文本导入预览 (Windows)、数据（使用预览）(Macintosh) 或者是 *.txt（固定宽度文本）或 *.txt*.csv（分隔文本）(Linux)，访问“文本导入预览”窗口。然后单击确定或完成。

您可以在“文本导入预览”窗口中指定 JMP 排列数据的方式。“文本导入预览”窗口具有以下两种类型：

  • 固定宽度窗口（"固定宽度文件的文本导入预览"）
  • 分隔窗口（"分隔文件的文本导入预览"）

当您打开文件时，JMP 会检测文件结构并且显示相应的“文本导入预览”窗口类型。如果 JMP 打开的窗口类型不对，例如您的文件是分隔文本但打开的是固定宽度窗口，请单击尝试使用分隔符或尝试使用固定宽度按钮来访问另一种窗口类型。

下面是有关窗口元素的说明。

固定宽度文件的文本导入预览
分隔文件的文本导入预览
  • 字段末 （只有分隔文件的“文本导入预览”窗口才有）单击文本文件中表示字段末的分隔符的字符旁边的框。如果没有列出相应的字符，则可以单击其它旁边的方框并输入所需字符。
  • 行末 （只有分隔文件的“文本导入预览”窗口才有）单击文本文件中表示行末的分隔符的字符旁边的框。如果没有列出相应的字符，则可以单击其它旁边的方框并输入所需字符。请注意，如果在导入文本数据时遇到双引号，则分隔符规则将变为查找右双引号。其它文本分隔符（包括引号中嵌入的空格）将被忽略，并且作为文本字符串的一部分处理。
  • 去除套入引号 如果您要 JMP 移除文本文件中将数据括起来的引号，请单击此方框。
  • 两位数年份规则 使用该下拉菜单指定您是否要使用：
    • 10 - 90（默认值） 使用下表了解在 JMP 中如何使用 10 - 90 规则。
      当前年份的最后两位数（如您的计算机中所示） | 文本文件中两位数的日期 | JMP 显示格式
      介于 11 和 89 之间 | 不适用 | 当前世纪将用作前两位数。
      介于 00 和 10 之间 | 小于 90 | 当前世纪将用作前两位数。
      介于 90 和 99 之间 | 上一个世纪将用作前两位数。
      介于 90 和 00 之间 | 介于 0 和 10 之间 | 下一个世纪将用作前两位数。
      介于 11 和 99 之间 | 当前世纪将用作前两位数。
    • 19xx 在只有两位数表示年份的文件中，JMP 将在日期前面加上 19。
    • 20xx 在只有两位数表示年份的文件中，JMP 将在日期前面加上 20。
    • 自定义 允许您打开并执行 JSL 脚本，以便自定义 JMP 处理日期的方式。
  • 表包含列题头 如果您要 JMP 数据表使用导入文件中的第一行作为数据表题头，请单击此方框。如果没有单击此方框，JMP 则认为导入的文件没有题头，并且将它们标记为列 1、列 2 等。
  • 列数 指定导入的文件包含的列数。
  • 行数 指定导入的文件包含的行数。
  • 列名位于行 告诉 JMP 到哪一行可以找到用作列名的数据。例如，如果文本文件中的列名位于第 3 行，则在方框中输入 3。否则，JMP 将使用导入文件的第一行中的数据作为 JMP 数据表中的列名。
  • 数据开始于行 告诉 JMP 从哪一行开始导入数据。例如，如果您要 JMP 从导入文件的第 5 行开始导入数据，请在方框中输入 5。
  • 指定字段（仅限于 Windows 和 Linux）（只有固定宽度文件的“文本导入预览”窗口才用）单击此按钮，告诉 JMP 数据表中的列有多宽。高亮度显示值，然后单击设置字段，分配的列宽就是高亮度显示的值。
  • 指定列 在您最终确定了窗口中的其它所有设置之后，单击此按钮以展开文本文件中包含列的列表。在此列表中，复选要导入至 JMP 数据表的列。
  • 列 ID 将预览表中的列标记为 1、2、3、4 等。此行不会显示在 JMP 数据表中。

“文本导入预览”窗口（适用于 Windows 和 Macintosh）以及“文本导入选项”窗口（适用于 Linux）的底部显示文本文件在导入 JMP 数据文件中时呈现的预览效果。当您进行了更改时，可以单击应用设置，以查看您的更改对数据表外观的影响。使用 << 和 >> 按钮，在预览的数据中左右滚动。预览的数据表包含以下内容：

  • 名称 显示在 JMP 数据表中指定的列名。要更改列名，请单击该单元格并输入新的名称。这个新名称将覆盖 JMP 在文本文件中找到的列名。使用 << 和 >> 按钮，在预览的数据中左右滚动。请注意，列名最长为 255 个字符。
  • 数据类型 使用下拉菜单指定数据类型：字符、数值、日期等。使用 << 和 >> 按钮，在预览的数据中左右滚动。
  • 数据行 1 和数据行 2  显示将要在 JMP 数据表的行中显示的数据。使用 << 和 >> 按钮，在预览的数据中左右滚动。
  • 尝试使用分隔符或尝试使用固定宽度 当您打开文件时，JMP 会检测文件结构并且显示相应的“文本导入预览”窗口类型。如果 JMP 打开的窗口类型不对，例如您的文件是分隔文本但打开的是固定宽度窗口，请单击尝试使用分隔符或尝试使用固定宽度按钮来访问另一种窗口类型。

在文本编辑窗口中打开文本文件

在 Macintosh 和 Windows 中，JMP 允许您在简单的文本编辑窗口中打开文本文件，而不是打开 JMP 数据表。

要在 Windows 中的文本编辑窗口中打开文本文件，请执行以下操作：

  1. 选择文件 > 打开。
  2. 从文件类型列表（"选择纯文本文件"）中，选择纯文本文件，即您要导入的文件类型。此选择将影响数据在 JMP 中如何显示。
选择纯文本文件
  3. 要设置默认文件类型，以便下一次进入该窗口时文件类型列表中的默认选项是纯文本文件，请单击下次调用此对话框时选择此筛选器旁边的方框。
  4. 高亮度显示要打开的文件名。
  5. 单击打开。

要在 Macintosh 中的文本编辑窗口中打开文本文件，请执行以下操作：

  1. 选择文件 > 打开。
  2. 从启用下拉菜单中选择所有文本文档。
选择所有文本文档
  3. 高亮度显示要打开的文件名。
  4. 单击打开。

将文本作为数据导入

对于以下情况，将文本作为 JMP 数据表导入既快速又有用：首先将文本粘贴至文本窗口中，然后设置文本的格式并调整文本，以便为导入至数据表做准备。

要将文本作为数据表导入，请执行以下操作：

  1. 在 JMP 中打开脚本或者将文本作为脚本打开，并且确保该窗口为活动窗口。
  2. 选择文件 > 作为数据导入（Windows 和 Linux）或编辑 > 作为数据导入 (Macintosh)。
  3. JMP 会使用“文本导入”首选项（在文件 > 首选项 > 文本数据文件（Windows 和 Linux）或 JMP > 首选项 > 文本数据文件 (Macintosh) 下可以找到）中的设置将文本导入 JMP 数据表中。

从网页中提取表格信息时，将文本作为 JMP 数据表导入也很有用。

要从网页中导入数据，请执行以下操作：

  1. 高亮度显示网页中的信息，然后将信息复制到剪贴板上。
  2. 选择新建 > 脚本，在 JMP 中打开新的脚本窗口。
  3. 将信息粘贴至脚本窗口。
  4. 选择文件 > 作为数据导入（Windows 和 Linux）或编辑 > 作为数据导入 (Macintosh)。

导入文件的大小有以下约束：

  • 每个表最多可以导入 10,000 列
  • 每行最多可以导入 128K 的数据

系统可用的 RAM/虚拟内存空间约束了可以导入的文件大小。例如，对于 RAM/虚拟内存总共为 500MB 系统，JMP 无法将 1 GB 的文件导入至其中。为了获得最佳性能，要导入的文件大小应该小于机器中的现有物理 RAM。

打开 Excel 和 OpenOffice 文件

您可以在 JMP（适用于 Windows 和 Macintosh）上打开 Microsoft Excel 文件。您可以在 Linux 上打开 OpenOffice 电子表格：

  1. 选择文件 > 打开。
  2. 在 Windows 中：从文件类型字段中，选择 Excel 文件 (*.XLS)。
    在 Macintosh 中：从启用菜单中，选择所有数据文档。
    在 Linux 中：从筛选器字段中，选择 *.sxc（OpenOffice 电子表格）。
  3. 选择您要打开的文件。

    注：在 Windows 中，“打开数据文件”窗口中包含几个专用于打开 Excel 文件的选项：

    • 如果您的文件的列标题位于 Excel 电子表格的第一行，请单击 Excel 表在行 1 中有标签旁边的方框。
    • 如果您的文件包含多个工作表，并且您只想打开某些工作表，则选定允许单个选择工作表旁边的方框。如果您希望每次您打开 Excel 文件时此选项都处于选定状态，请选择文件 > 首选项，然后选定“常规”类别中的选择单个 Excel 工作表。
  4. 在 Linux 中，单击下一步查看这些选项：
    • 如果您文件的列标题位于 OpenOffice 电子表格的第一行，请单击第一行列标题旁边的方框。
    • 如果您的文件包含多个工作表，但您只想打开其中的某几个，请选定选择要打开的表区域中的相应表旁边的框。
  5. 在 Windows 和 Macintosh 中，单击打开。在 Linux 中，单击完成。
在 Windows 中打开 Excel 文件

打开 SAS 数据集

SAS 数据集是以许多 SAS 格式中的一种格式保存的文件。在 Windows 中，JMP 可以打开 SAS 第 5 版或更高版本的文件。在 Macintosh 和 Linux 中，JMP 可以打开 SAS 第 6 版的文件。

  • 在 Windows 中，JMP 在默认情况下使用 SAS 标签作为 JMP 数据表的列名。您可以覆盖默认的列名，以及请求 JMP 使用 SAS 变量名作为 JMP 列名（请参阅下面的第 4 步）。
  • 在 Macintosh 中，JMP 在默认情况下使用 SAS 变量名作为表的列名。在导入的 JMP 数据表中，您便可以通过双击列名来查看 SAS 标签。SAS 标签显示为注释的性质。您还可以通过运行 JMP 在打开数据表时自动创建的脚本（它位于数据表名称下面的表面板中），将表中的列名替换为 SAS 标签。
  • 在 Linux 中，JMP 在默认情况下使用 SAS 标签作为 JMP 数据表列名。

要打开 SAS 数据集，请执行以下操作：

  1. 选择文件 > 打开。
  2. 在 Windows 中，从文件类型下拉菜单中选择 SAS 数据集或数据文件，如"打开 SAS 数据集" 所示。
    在 Macintosh 中，从启用列表中选择所有可读取文档。
    在 Linux 中，从筛选器列表中选择 *.sd2（SAS 数据集）。
  3. 高亮度显示您要打开的文件。
打开 SAS 数据集
  4. （可选并且仅在 Windows 中提供）选择以下任意项：
    • 下次调用此对话框时选择此筛选器 将默认的文件类型选择设置为您在文件类型列表中选择的选项。如果您单击该选项，则下一次进入该窗口时，默认的文件类型将是 SAS 数据集。
    • 使用列名称的 SAS 变量名 使用 SAS 变量名（而不是标签）作为 JMP 数据表中的列名。
    • 数据集的密码受保护 如果您知道文件有密码保护，请单击此方框。有关详情，请参阅"打开密码保护的数据集"。
  5. 单击打开（适用于 Windows 和 Macintosh）或完成（适用于 Linux）。

    注：如果您要从 SAS 文件中导入日期变量，JMP 将查找 SAS 日期格式，然后将其转换为 JMP 日期列。

打开密码保护的数据集

在 Windows 中，JMP 可以打开密码保护的 SAS 第 6 版或第 7 版的数据集。

要打开密码保护的数据集，请执行以下操作：

  1. 选择文件 > 打开。
  2. 从文件类型下拉菜单中选择 SAS 数据集。
  3. 单击数据集的密码受保护旁边的方框。
  4. 高亮度显示您要打开的文件。
  5. （可选）选择以下任意项：
    • 下次调用此对话框时选择此筛选器 将默认的文件类型选择设置为您在文件类型列表中选择的选项。如果您单击该选项，则下一次进入该窗口时，默认的文件类型将是 SAS 数据集。
    • 使用列名称的 SAS 变量名 使用 SAS 变量名（而不是标签）作为 JMP 数据表中的列名。
  6. 单击打开。

打开 SAS 传输文件

JMP 可以打开用 SAS 的 XPORT 引擎保存的 SAS 传输文件。例如，以下是用于创建名为 test 的传输文件的代码示例。（注：misc 和 work 是 SAS 库参考名称。）

data test;

input name $ age weight;

cards;

nicole 12 72

meredith 10 68

;

libname misc xport 'C:t est.xpt';

proc copy in=work out=misc;

run;

要打开 SAS 传输文件，请执行以下操作：

  1. 选择文件 > 打开。前面的"打开 SAS 数据集" 显示了将会出现的窗口。
  2. 在 Windows 中，从文件类型下拉菜单中选择 SAS 传输文件，如"打开 SAS 传输文件" 所示。
    在 Macintosh 中，从启用列表中选择所有可读取文档。
    在 Linux 中，从筛选器列表中选择 *.xpt（SAS 传输）。
  3. 高亮度显示要打开的文件名。
  4. 在 Linux 中，单击下一步。
打开 SAS 传输文件
  5. （可选并且仅在 Windows 和 Linux 中提供）选择以下任意项：
    • 下次调用此对话框时选择此筛选器 （仅限于 Windows）将默认的文件类型选择设置为您在文件类型列表中选择的选项。如果您单击该选项，则下一次进入该窗口时，默认的文件类型将是 SAS 传输文件。
    • 选择成员 允许您输入 JMP 要打开的特定成员或表的名称。
    • 打开全部成员 打开传输文件中的所有成员或表。
    • 保存全部成员 您一打开文件，就将其另存为 JMP 文件。保存文件的目录与打开 SAS 传输文件的目录相同。
    • 选择列 告诉 JMP 仅打开传输文件中的某些列。当您单击打开（适用于 Windows）或完成（适用于 Linux）时，JMP 将提供列的列表，并且在 JMP 准备打开的列的旁边显示有复选标记。添加或移除复选标记以修改列表。

从数据库打开数据

如果您有数据库的 ODBC（开放式数据库连接）驱动程序，您也可以从数据库中打开数据。

您的操作系统会为 JMP 提供一个界面，以便使用 ODBC 数据源与数据库通信。您可以使用操作系统软件来创建和配置数据源。例如，在 Windows XP 中，使用控制面板 > 管理工具 > 数据源；在 Macintosh 中，使用应用程序 > 实用程序 > OpenLink ODBC 管理器；在 Linux 中，UNIX ODBC 会提供 ODBC 连接。有关详情，请参阅您的 UNIX ODBC 说明文档。

要从数据库中打开数据，请执行以下操作：

  1. 选择文件 > 数据库 > 打开表，以便显示如"数据库打开命令提供的初始窗口" 中所示的窗口。“连接”框将列出 JMP 连接的所有数据源。“表”框将列出当前选定数据源连接的所有数据库表。
数据库打开命令提供的初始窗口
  2. 如果所需的数据源没有列在“连接”框中，请单击连接选择数据源。选择数据源的方法根据您的操作系统来定。"选择数据源 (Windows)" 显示的是 Windows 的数据源选择器。选择数据源，然后单击确定。
选择数据源 (Windows)
  3. 在“连接”框中选择所需的数据源。“表”框中的表列表会相应地自动更新。更新过程可能要持续几秒钟，具体时间由表的个数以及与数据库的连接速度来定。
  4. 通过选择表列表中包含复选框组中的选项可以控制列出哪些表。不同的驱动程序对这些标签的解释也各不相同。您可以选择的选项包括：
    • 用户表 在单击该选项时，表列表中显示所有可用的用户表。用户表专供登录到计算机的用户使用。
    • 视图 在单击该选项时，表列表中显示“视图”以及所有其它可以打开的文件类型。“视图”是属于查询结果集的虚拟表，每次您打开它们时都会更新。它们用于提取和组合一个或多个表中的信息。
    • 系统表 在单击该选项时，表列表中显示所有可用的系统表。系统表是所有用户或系统范围内服务可以使用的表。
    • 同义词 在单击该选项时，表列表中显示所有可用的 ORACLE 同义词。
  5. 从“表”列表中选择所需的表。
  6. 单击打开表，打开选定表中的所有数据；或者单击高级，指定要打开的表子集。

    注：如果您已连接至 dBase 数据库，请选择您要连接的数据库文件夹（而不是选择单个文件，单个文件呈灰色显示而无法选择）。

使用 SQL 语句检索数据

您可以使用结构化查询语言 (SQL) 语句来控制要从数据库中打开的数据。您在 JMP 中打开数据库文件时，实际上是将 SQL 语句发送给数据库。默认情况下，此语句将获得数据库表中的所有文件和记录。在一些情况下，数据量太大。在您只对表数据中的某个子集感兴趣时，您可以自定义 SQL 请求，以便只请求所需的数据。在您执行一个 SQL 查询后，查询的代码以 SQL 表变量的形式存储在数据表中。要使用 SQL 语句检索数据，请执行以下操作：

  1. 按照"从数据库打开数据"中的步骤，连接至数据库。
  2. 在数据库打开表窗口中（如"单击“高级”按钮" 中所示），单击高级按钮。
单击“高级”按钮
  3. 您可以输入任何有效的 SQL 语句，或者修改默认的语句。"从 Excel 目录存储的“大班”表中读取所有变量" 显示适合选定文件的默认 SQL 选择语句。有关您可以使用的 SQL 语句的说明，请参阅"结构化查询语言 (SQL)：参考"。

    此外，您也可以单击 Where 按钮，使用 Where 子句编辑器来创建表达式，进而添加新的表达式。有关详情，请参阅"使用 WHERE 子句编辑器"。
从 Excel 目录存储的“大班”表中读取所有变量
  4. 单击执行 SQL。SQL 语句成为 JMP 数据表中的 SQL 表变量（有关详情，请参阅"添加表变量"）。

例如，如果您只想导入大于 14 岁的女性的姓名和年龄，则您需要在"从 Excel 目录存储的“大班”表中读取所有变量" 中将 SQL 从 SELECT * FROM Bigclass 修改为 SELECT NAME, AGE FROM Bigclass where AGE>14 and SEX=`F'。在您单击执行 SQL 之后，JMP 数据表将会显示，表中包括姓名和年龄列。

请注意，您可以输入任何有效的 SQL 语句，然后单击执行 SQL 以执行命令。有效的 SQL 随数据源和 ODBC 驱动程序的变化而变化。

结构化查询语言 (SQL)：参考

以下部分简要地介绍了 SQL。它们会使您了解到查询功能的强大，但是并不能作为全面综合的参考。

使用 SELECT 语句

JMP 中基本的 SQL 语句是 SELECT 语句。它告诉数据库该取数据源中的哪些行。在您完成"从数据库打开数据"中所述的流程时，您实际上是将以下 SQL 语句发送至您的数据源。

 SELECT * FROM Solubil

* 运算符是“所有列”的缩写。因此，该语句将请求数据库返回指定数据表中的所有列。

如果不需要返回所有行，您可以将 * 替换为数据表中具体的列名。以可溶性数据表为例，通过提交以下语句，您可以只选择 ETH、OCT 和 CCL4 列：

 SELECT ETH, OCT, CCL4 FROM Solubil

 注：JMP 不要求您使用分号来结束 SQL 语句。

JMP 事实上提供了一种图示法用于构造简单的 SELECT 语句，而无需输入实际 SQL 语句。要选择数据源中的某些列，请在列的列表中高亮度显示这些列（"选择某些列"）。

要高亮度显示多行，

  • 可以按住 Shift 键并单击以选择相连的一组列名。
  • 按住 Ctrl 键并单击（Windows 和 Linux）或按住 Command 键并单击 (Macintosh) 以选择单个列名。

请注意，SQL 语句将根据您选择的列名而相应地变化。

选择某些列

有时候，您只想取数据源中唯一的记录。也就是说，您要排除重复的记录。为此，您可以使用 DISTINCT 关键字。

 SELECT DISTINCT ETH, OCT, CCL4 FROM Solubil

对结果排序

您可以按数据库的一个或多个字段对结果进行排序。使用 ORDER BY 命令，指定排序使用的变量。

 SELECT * FROM Solubil ORDER BY LABELS

选择所有字段，并且将由此产生的数据表按 LABELS 变量排序。如果您要指定更多的变量进行排序，可以在以逗号分隔的列表中添加这些变量。

 SELECT * FROM Solubil ORDER BY LABELS, ETH, OCT

使用 WHERE 语句

WHERE 语句允许您根据条件取数据表中的某些行。例如，您可能要选择列 ETH 的值大于 1 的所有列。

 SELECT * FROM Solubil WHERE ETH > 1

WHERE 语句放在 FROM 语句之后，可以使用以下任何逻辑运算符。

运算符 | 含义
= | 等于
!= 或 < > | 不等于
> | 大于
< | 小于
>= | 大于或等于
<= | 小于或等于
NOT | 逻辑非
AND | 逻辑与
OR | 逻辑或

在求条件的值时，首先处理整个语句的 NOT 语句，接着处理 AND 语句，然后再处理 OR 语句。因此

 SELECT * FROM Solubil WHERE ETH > -2 OR OCT < 1 AND CCL4 > 0

等价于

 SELECT * FROM Solubil WHERE ETH > -2 OR (OCT < 1 AND CCL4 > 0)

使用 IN 和 BETWEEN 语句

要指定一组要取的值，可以将 IN 和 BETWEEN 语句与 WHERE 语句结合使用。IN 语句指定一个值列表，而 BETWEEN 让您指定一组值。例如，

 SELECT * FROM Solubil WHERE LABEL IN (`Methanol', `Ethanol', `Propanol')

取 LABEL 列中值为 Methanol、Ethanol 或 Proponol 的所有行。

 SELECT * FROM Solubil WHERE ETH BETWEEN 0 AND 2

取 ETH 值介于 0 和 2 之间的所有行。

使用 LIKE 语句

LIKE 语句允许您选择与指定字符串类似的值。使用 % 代表可表示任意值的字符串。例如，您可能要从 Solubil 数据中选择属于酒精的化学制品，也就是以 -ol 结尾的化学制品。下面的 SQL 语句可以完成此任务。

 SELECT * FROM Solubil WHERE LABELS LIKE `%OL'

% 运算符可以放在 LIKE 语句中的任何位置。下面的实例将提取标签以 M 开头并且以 OL 结尾的所有列：

 SELECT * FROM Solubil WHERE LABELS LIKE `M%OL'

使用聚合函数

聚合函数用于取数据的总和，而不是数据本身。在 SELECT 语句中使用以下任何一个聚合函数。

Function | 含义
SUM( ) | 列的总和
AVG( ) | 列的平均值
MAX( ) | 列的最大值
MIN( ) | 列的最小值
COUNT( ) | 列中的行数

一些实例包括：

  • 下面的语句请求 ETH 和 OCT 列的总和。
 SELECT SUM(ETH), SUM(OCT) FROM Solubil
  • 此语句返回 ETH 值大于 1 的行数：
 SELECT COUNT(*) FROM Solubil WHERE ETH > 1
  • 下面的语句让您知道属于酒精的数据的 OCT 平均值：
 SELECT AVG(OCT) FROM Solubil WHERE LABELS LIKE `%OL'

 注：在使用聚合函数时，作为结果的 JMP 数据表中的列名是 Expr1000、Expr1001 等。在完成取操作之后，您可能要重命名列。

GROUP BY 和 HAVING 命令

GROUP BY 和 HAVING 命令在与聚合函数一起使用时特别有用。它们使您可以根据数据集中的字段值多次执行聚合函数。

例如，您可能要统计数据表格中 ETH 的每个值是 ETH=0，ETH=1 等的记录数。

  • SELECT COUNT(ETH) FROM Solubil GROUP BY (ETH) 返回单列数据，并且每一项对应于一个级别的 ETH。
  • SELECT COUNT(ETH) FROM Solubil GROUP BY (ETH) WHERE OCT > 0 与上面的语句执行的操作相同，但是只针对 OCT > 0 的行。

在将 GROUP BY 与列的聚合函数一起使用时，在 SELECT 语句中包含列本身。例如，

 SELECT ETH, COUNT(ETH) FROM Solubil GROUP BY (ETH)

除了计数之外，还返回包含 ETH 水平的列。

使用子查询

聚合函数对于计算 WHERE 语句中使用的值也很有用。例如，您可能要取大于 ETH 平均值的所有值。换句话说，我们要得出 ETH 的平均值，然后只选择值大于该平均值的那些记录。请记住，SELECT AVG(ETH) FROM Solubil 可以取我们感兴趣的平均值。因此，合适的 SQL 命令将在 WHERE 条件语句中使用此语句：

 SELECT * FROM Solubil WHERE ETH > (SELECT AVG(ETH) FROM Solubil)

保存和载入 SQL 查询

在构建查询之后，您可能在以后的某个时间还需要重复执行该查询。您不必在每次要使用时都手动输入该查询。而是将查询导出为外部文件。要执行此操作，请在"选择某些列" 中所示的对话框中单击导出 SQL 按钮。此时将弹出一个对话框，让您将 SQL 查询保存为文本文件。

要载入保存的查询，请在"选择某些列" 中所示的对话框中单击导入 SQL 按钮。此时将弹出一个对话框，让您定位至保存的查询。在您打开查询后，查询将被载入到该对话框中。

使用 WHERE 子句编辑器

JMP 将会帮助构建在 ODBC 导入过程中用于 SQL 查询的 WHERE 子句。它还会提供一个 WHERE 子句编辑器，帮助您使用常见的 SQL 功能构建基本表达式，同时允许使用供应商专用的函数。例如，您不必知道 SQL 使用 `=' 还是 `==' 来进行比较，也不必知道 SQL 使用 avg() 还是 average() 来求平均值。

  1. 按照"从数据库打开数据"中的步骤，连接至数据库。
  2. 在数据库打开表窗口中（如"单击“高级”按钮" 中所示），单击高级按钮。
单击“高级”按钮
  3. 单击 Where 按钮。
  4. 使用 WHERE 子句编辑器来从工作面板上添加表达式、函数和（或）项。它们将被应用到高亮度显示的红色方框：
    1. 单击“表名浏览器”（"使用 WHERE 子句编辑器"）选择表。该表中的列将出现在列表中。
    2. 单击“SQL 供应商名称浏览器”（"使用 WHERE 子句编辑器"）选择要使用的 SQL 类型：GenericSQL、Access、DB2、MySQL、Oracle、SQL Server 或以上全部类型。通过单击列表中的函数/运算符并从出现的列表中选择运算符来执行操作。
    3. 在公式编辑区域中单击空白的公式元素（"使用 WHERE 子句编辑器"）以将其选中。红色的外框表示它已经被选中。与您单击的位置对应的最小嵌套框中的所有项均将被选定。之后的操作适用于这些组合的元素。
    4. 通过单击键盘上的按钮将运算符（"使用 WHERE 子句编辑器"）添加到表达式中。

WHERE 子句编辑器的工作方式与"使用公式编辑器" 中讲解的公式编辑器类似。

使用 WHERE 子句编辑器

您可以使用多种方法在 WHERE 子句编辑器中自定义表达式、函数和（或）项。要更改字体大小、显示和隐藏外框、更改公式的方向以及关闭自变量，请执行以下操作：

  1. 构建表达式、函数和（或）项。
  2. 单击键盘上方的红色三角形图标，然后从出现的菜单中选择某个选项，如"从键区菜单命令中选择显示外框" 所示。
从键区菜单命令中选择显示外框

读取实时数据（仅限于 Windows 和 Linux）

实时数据传送专线项是指外部数据源通过物理或逻辑通信链接向另一个设备发送信息的方法。您可以通过 Windows 或 Linux 计算机上的串行端口将 JMP 与实时数据传送专线连接起来，从而实时读取传入的数据流。请记住：

  • 数据传送专线必须使用标准的 9 针串行端口。不能通过 USB 端口来读取数据。
  • 您需要知道附带设备的确切波特率、校验位、结束位和数据位。

只要一知道设备数，您就可以将它输入到下面脚本中的 open Datafeed() 命令中。（下面脚本中的 4800、even、2 和 7 都是我们举的例子，您可以使用自己的数据替换它们。）然后，将数据传送专线与您的计算机连接起来并且打开和运行脚本：

 streamScript = expr( line = feed <<Get Line;show(line);
               len = length(line); show(len);
     if (length(line)>=1, show("Hi"); show(line);
                     field = substr(line,5,8); show(field);
          x = Num(field); show(x);
          if (!IsMissing(x), current data table()<<add row({:Column1=x});
         show(x);
     )));
 feed = open DataFeed(Baud Rate(4800),parity(even),Stop bits(2), Data bits(7));
 feed<<Set Script(streamScript);
 feed<<Connect;

为了确保 JMP 的通信设置与外部来源的仪器读数数据保持一致，请选择文件 > 首选项 > 通信。要查找相应的设置，请参阅仪器的说明文档。

使用 Internet 打开文件（仅限于 Windows 和 Linux）

通过选择文件 > Internet 打开，您可以从 Internet 站点、Intranet 站点、服务器和 FTP 地址导入数据。对于必须通过 Internet 协议（如 HTTP 或 FTP）传输的文件，您只能使用此命令。要打开分置式服务器中的文件，请使用文件 > 打开。

在 Linux 中，如果您使用代理服务器来连接至 Internet，那么您首先要设定一些代理设置，然后才能选择文件 > Internet 打开：有关详情，请参阅"调整代理设置（仅限于 Linux）"。

从 Internet 或 Intranet 上打开文件（仅限于 Windows 和 Linux）

要打开或导入位于 Internet 或 Intranet 的文件中的数据，请执行以下操作：

  1. 选择文件 > Internet 打开。此时将显示"Internet 打开窗口" 中的窗口。（在 Linux 中该窗口看上去与"Internet 打开窗口" 有点区别）。另外，在 Linux 中，如果有防火墙或安全套接字，则 Internet 打开命令不能顺利地打开文件。
  2. 单击左边的下拉菜单，然后选择 HTTP://。
  3. 输入 URL。
Internet 打开窗口
  4. 单击打开为下面的下拉菜单，然后选择您要 JMP 显示导入数据的方式：
    • 浏览 HTML 页 在浏览器中打开网页。
    • 编辑 HTML 页 在文本编辑器中打开网页，显示 HTML 标记。
    • 编辑带有虚尾标记的 HTML 页 在文本编辑器中打开网页，只显示文本（不显示 HTML 标记）。
    • 打开 JMP 文件 将 JMP 文件作为数据表打开。只有 JMP 数据表（.jmp 文件）位于您输入的网址时，才能使用此选项。
    • 将 HTML 表提取为 JMP 文件 在数据表中打开网页。只有 HTML 表位于您输入的网址时，才能使用此选项。要创建有意义的数据表，HTML 表信息只能由数据单元格组成。为了确定页面格式而创建的 HTML 表或包含题头的 HTML 表不能产生有意义的 JMP 表。
  5. 单击打开。在 Windows 中，如果表尚未包含注释，表所在 URL 将作为注释性质包含在数据表中。

另外，在 Windows 中，您可以显示浏览器工具栏（包含标准的浏览器按钮：后退、前进、主页、刷新和停止）以及 URL 列表工具栏（包含 URL 地址输入框）：

  1. 选择视图 > 显示工具栏。此时将显示"显示工具栏窗口" 中的窗口。
显示工具栏窗口
  2. 单击浏览器和 URL 列表旁边的方框。
  3. 单击确定。工具栏将显示在 JMP 应用程序的顶部。“浏览器”工具栏（如"浏览器工具栏" 中所示）包含标准的浏览器按钮：后退、前进、主页、刷新和停止。
浏览器工具栏
“URL 列表”工具栏（如"URL 列表工具栏" 中所示）包含一个编辑框，允许您输入 URL 地址，按 Enter 键便可以访问网页。它还包含一个下拉菜单，其中显示所有您已经打开的地址。您可以从此列表中选择地址，然后按 Enter 键，以便显示此页。
URL 列表工具栏

从 FTP 站点打开 JMP 文件（仅限于 Windows 和 Linux）

您可以打开 FTP 地址中的 .jmp 文件：

  1. 选择文件 > Internet 打开。
  2. 单击左边的下拉菜单，然后选择 FTP://（如"FTP 打开窗口" 中所示）。
FTP 打开窗口
  3. 在标签为 JMP 文件路径\名称的框中输入文件路径。
  4. 在机器标识文本框中输入计算机的名称（DNS 名称）。

打开服务器或另一台计算机中的文件（仅限于 Windows）

要从位于服务器或另一台计算机中的文件中导入数据，请执行以下操作：

  1. 选择文件 > Internet 打开。
  2. 单击左边的下拉菜单，然后选择 FILE://（如"Internet 打开窗口" 中所示）。
  3. 输入文件路径。
Internet 打开窗口
  4. 单击打开为下面的下拉菜单，然后选择您要 JMP 显示导入数据的方式：
    • 浏览 HTML 页 在浏览器中打开网页。
    • 编辑 HTML 或文本页 在文本编辑器中打开网页或文本文件，显示 .html 文件中的 HTML 标记。
    • 编辑带有虚尾标记的 HTML 页 在文本编辑器中打开网页，只显示页面的内容（不显示 HTML 标记）。
    • 打开 JMP 文件 在数据表中打开网页。只有 JMP 数据表（.jmp 文件）位于您输入的网址时，才能使用此选项。
    • 将 HTML 表提取为 JMP 文件 在数据表中打开网页。只有 HTML 表位于您输入的网址时，才能使用此选项。要创建有意义的数据表，HTML 表信息只能由数据单元格组成。为了确定页面格式而创建的 HTML 表或包含题头的 HTML 表不能产生有意义的 JMP 表。
    • 运行 JSL 文件 打开 JSL（JMP 脚本语言）文件并运行脚本。


通过电子邮件发送表或报表（仅限于 Windows）

如果您要使用 Windows 操作系统，JMP 提供了一种方法，您只需要轻轻一点，便可通过电子邮件发送数据表或报表。

要从 JMP 中发送电子邮件，请执行以下操作：

  1. 打开数据表或创建报表。
  2. 选择文件 > 发送。JMP 将打开的窗口提交给操作系统中定义的默认电子邮件应用程序。此时将显示一个窗口，其中包含发送电子邮件必需填写的表单。


输入和编辑数据

准备分析

将数据导入 JMP 或创建新数据表后，需要对数据和表进行格式化，以便进行分析。

本章包含的信息有助于您：

  • 了解 JMP 数据表的各个部分
  • 指定数据类型和建模类型
  • 选择数据格式
  • 编辑数据表
  • 锁定数据表
  • 选择行和列

目录

JMP 数据表的元素

数据表面板

数据网格

指定数据类型和建模类型

关于数据类型

关于建模类型

如何指定数据类型和建模类型

选择数值格式

输入数据

添加和删除行

添加和删除列

设置初始数据值

以顺序数据填充列

输入单元格公式

编辑数据和表

编辑单元格

编辑列名

数据重新编码

查看缺失数据的模式

查找和替换单元格值

列重新排序

复制、剪切和粘贴

移动和复制值

使用行编辑器

更改表名称

锁定表

添加表变量

创建脚本

选择行和列

选择排除行、隐藏行或标记行

选择具有特定值的单元格

选择特定行或列

随机选择行

反选和选择所有行

查找下一个选定行和上一个选定行


JMP 数据表的元素

JMP 数据按行和列组织，称为数据表。数据表分为两部分，如"数据表的各个部分" 所示：数据表面板和数据网格。

数据表的各个部分

数据表具有以下特征：

  • 列名可包含任何键盘字符（包括空格），长度最多可达 255 个字符。
  • 数据表名称的最大长度取决于您计算机的操作系统。
  • 选择文件 > 首选项 > 字体，可以更改名称和值的默认大小和字体。（在 Macintosh 上选择 JMP > 首选项 > 字体。）
  • 列名在列名区域中会自动换行，以满足指定的列宽度。
  • 请移动列的边界，将列变大以查看长值。通过在按住 Alt 键（Macintosh 中为 Option 键，Linux 中为 Shift-Alt 组合键）的同时拖动任意选定的列分界上的双箭头光标，可以一次性调整所有选定列的宽度。
  • 数据表中对行数或列数没有约束。但是，表的大小必须在计算机内存容许的范围内。

数据表面板

数据表面板有三种，即表面板、列面板和行面板。数据表面板排列在数据网格的左侧，如"与数据表面板交互" 所示。这些面板包含有关表及其内容的信息。每个面板都有交互组件，如"与数据表面板交互" 所示。

与数据表面板交互

表面板

表面板包含数据表名称、一个红色小三角形图标，以及一个表性质/脚本列表（在"表面板" 中，表变量是名称为“分布”、“二元变量”和“一元变量”等的脚本）。

要访问表命令，请单击数据表名称左边的红色三角形图标，如"表面板" 所示。

表面板

单击表面板中的红色三角形图标，可获得以下选项：

  • 表 为您提供与主菜单中的表命令相同的选项，该命令将在"重新构造数据表"详细讨论。
  • 新建表变量 让您可以创建一个新表变量，可以为文本或任何其它常数字符值，在数据表中始终可以使用这些值。表变量大多数用于文档表。使用公式编辑器时，也可以访问这些变量，以便将其合并到公式或 JSL 脚本中。JMP 有时自动创建表变量，例如：
    • 如果您打开由以前版本的 JMP 创建的数据表，并且表中包含表注释，则将显示含有该注释文本的名称为注释的表变量（有关实例，请参阅"添加表变量"）。
    • 如果您使用“试验设计 (DOE)”命令创建设计表，JMP 则以设计类型的名称作为其值，创建一个名称为设计的表变量。
  • 新建性质/脚本 让您可以创建可随数据表一起保存的 JSL 脚本（表性质）。使用公式编辑器时，也可以访问这些性质或脚本，以便将其合并到计算列值的公式中（有关详情，请参阅"创建公式"）。选择此命令后，请命名脚本并键入值（JSL 命令），如"创建新脚本" 中左侧所示。单击确定后，表面板中将列出新脚本，您可以单击其红色三角形图标以运行、编辑或删除该脚本，如"创建新脚本" 右侧所示。有关详情，请参阅"创建脚本"。
创建新脚本

  • 运行脚本 让您可以运行数据表名称下面列出的高亮度显示脚本（如果有）。如果没有脚本高亮度显示，则运行脚本选项不可用。
  • 编辑 让您可以编辑数据表名称下面列出的高亮度显示脚本（如果有）。如果没有脚本高亮度显示，则编辑选项不可用。
  • 删除 让您可以删除数据表名称下面列出的高亮度显示脚本（如果有）。如果没有脚本高亮度显示，则删除选项不可用。
  • 屏蔽公式计算 会关闭自动计算公式的功能。您可以关闭计算功能，建立公式的各个部分，然后打开计算功能测试公式。
  • 锁定数据表 会锁定数据表，使得无法编辑或添加值。您仍然能够运行分析、指定特征、添加行和列等。有关详情，请参阅"锁定表"。

除了单击表面板图标及从菜单中选择之外，您还可以执行其它操作，如"可在表面板上执行的操作" 所示。

可在表面板上执行的操作

列面板

列面板（"列面板"）包含数据表中的列的列表、每列的建模类型及指定给列的任何属性。

要访问列命令，请单击列字左边的红色小三角形图标，如"列面板" 所示。这些命令为您提供与从主菜单中选择列命令相同的选项，这将在"列菜单"中讨论。

列名左边的图标表示列的建模类型：连续、保序或记名，如"列面板" 所示。建模类型告诉 JMP 如何在分析中使用列值。要更改建模类型，请单击图标，然后选择不同的类型。有关详情，请参阅"关于建模类型"。

列面板

列名右侧的图标如"表示列的特征和性质的元素" 所示，表示各列包含的特征和性质。有关详情，请参阅"为行和列指定特征"和"为列指定性质"。要更改列名，请在列面板中双击其名称，然后开始键入。或者，高亮度显示数据网格中的整个列，然后开始键入。

表示列的特征和性质的元素

行面板

行面板（"行面板"）显示总行数、选定的（高亮度显示的）行、排除的行、隐藏的行和标记的行。

要访问行命令，请单击行字左边的红色小三角形图标，如"行面板" 所示。这些命令为您提供与从主菜单中选择行命令相同的选项，这将在"行菜单"中讨论。

行面板

数据网格

"数据网格" 说明了如何选择行和列、查找行，以及如何使用键盘上的箭头键。有关进行选择的详情，请参阅"选择行和列"。

数据网格

光标形状

光标具有不同的形状，执行的操作取决于光标在数据网格上的位置。有关光标形状的详情，请参阅"工具菜单"。

  • 箭头光标 [image]  在光标位于数据表左边的面板区域、数据网格左上角的三角形行和列区域或表面板的标题栏时，光标是标准箭头。
    • 要使用箭头光标选择一列，请在列面板中单击其名称。
    • 单击表面板标题栏上的表名称可对其进行编辑。
    • 双击列面板中的列名可对其进行编辑。
    • 单击数据网格左上角的三角形区域可撤消选择行和列。
    • 单击并拖动可绘制一条临时线条。释放时，线条将消失。
  • （大加号）选择光标 [image]  当光标位于列标题或行号区域时，就会变成一个大加号，表示可用于选择行或列。单击时，该行或列将高亮度显示。单击并拖动可高亮度显示多行或多列，按住 Ctrl 键并单击（在 Macintosh 中为按住 Command 键并单击），可选择非连续的行或列。
    • 双击某个列标题区域，可查看该列的“列信息”窗口。
    • 选择某列，可更改列名。该列将高亮度显示。开始键入（如果它不是一个锁定列或锁定数据表）。
    • 双击行号区域，可使用行编辑器编辑行。
  • 标准 I 型光标 [image]  选定可编辑文本时，光标将变成标准 I 型光标。要编辑文本，请将 I 型光标放置在高亮度显示的文本中。单击可标记插入点，而拖动可选择要替换的文本。I 型光标放置了一个闪烁的竖线，表示文本插入点，或要替换的文本的高亮度显示区域。
  • 双箭头光标 [image]  光标位于列的边界上时，光标会变为双箭头。将此光标向左或向右拖动，可更改列的宽度。更改列的宽度不会影响“列信息”窗口中指定的列字段宽度（通过双击列名访问）。

    注：通过在按住 Alt 键（Macintosh 中为 Option 键，Linux 中为 Shift-Alt 组合键）的同时拖动任意选定的列分界上的双箭头光标，可以一次性调整所有选定列的宽度。
  • 列表检查光标和范围检查光标 [image]  将鼠标移到有数据验证的列中的值上时，光标会改变形状。鼠标在列表检查列上会变成一个朝下的小箭头，在范围检查列上会变成一个 I 型大光标。单击时，值将高亮度显示，光标会变成标准 I 型光标；您可以以平常的方式输入或编辑具有定义为有效文本或有效数值的数据。使用鼠标右键单击列名，并选择验证，然后选择列表检查或范围检查，可找到列表检查值和范围检查值。有关详情，请参阅"验证列数据"。
  • 弹出式指针光标 [image]  光标移至红色三角形图标或菱形展开按钮（Windows/Linux 中为 [image] ，Macintosh 中为 [image] ）上时，它将变为指针。单击可选择某个菜单项，或打开或关闭面板。


指定数据类型和建模类型

JMP 表中的列可以包含各种类型的信息。但是，单个列中的所有信息都必须有相同的数据类型和建模类型。

  • 将数据导入 JMP 时，它会猜测要使用哪种数据类型和建模类型。因此，您应该进行检查，以确保 JMP 的猜测正确。
  • 将数据手动插入 JMP 时，应在插入数据时指定数据类型和建模类型。

关于数据类型

列的数据类型确定其值在数据网格中的格式、在内部如何存储，以及是否可用于计算。三种数据类型为：

  • 数值 列仅包含具有或没有小数点的数值。
  • 字符 列包含任意字符，包括数值。在字符列中，只将数值视为字符，当作离散值处理（而不是连续值）。字符值的最大字段宽度为 32,766 字节。
  • 行状态 列包含行状态信息，即告诉您是否将行排除、隐藏、加标签、着色或加标记等信息。有关详情，请参阅"使用行状态列"。

关于建模类型

列的建模类型仅适用于数据类型为数值或字符的列。建模类型告诉 JMP 在分析过程中如何处理其值。更改建模类型让您可以在分析中按不同方式查看变量。三种建模类型为：

  • 连续 列仅包含数值数据类型。连续值按连续测量值处理。JMP 在计算中直接使用数值。
  • 保序 列包含数值或字符数据类型。JMP 分析将保序值作为具有顺序的离散分类值处理。如果值为数值，则以数值大小顺序为准。如果值为字符，则以排序顺序为准。
  • 记名 列包含数值或字符数据类型。所有值在 JMP 分析中均被处理，即使这些值是没有隐含顺序的离散值。

下表中列出了数据类型和建模类型的可能组合。

 |  | 数据类型
 |  | 数值 | 字符
建模类型 | 连续 | 是 | 否
 | 保序 | 是 | 是
 | 记名 | 是 | 是

如何指定数据类型和建模类型

有三种方法可用于指定数据类型和建模类型，或用于确保 JMP 自动为您的数据指定正确的数据类型。以下部分说明了这三种方法。

方法 1：创建新列

方法之一是在创建新列时指定数据类型和建模类型。创建新列时（通过选择列 > 新建列），将出现“新建列”窗口，如"添加新列并指定数据类型和建模类型" 所示。在此窗口中指定数据类型和建模类型。

添加新列并指定数据类型和建模类型

方法 2：双击现有列名上方的区域

如果数据已在 JMP 中，但想要指定数据类型和建模类型，请双击列名上方的空白区域。此时将出现“列信息”窗口，如"双击现有列并指定数据类型和建模类型" 所示。在此窗口中指定数据类型和建模类型。

双击现有列并指定数据类型和建模类型

方法 3：使用列面板图标

如果数据已在 JMP 中，请单击列面板中列名旁边表示它所具有的建模类型的图标。从下拉菜单中选择另一个类型。

注：只有在数据类型为数值时才可以选择连续。如果菜单上的连续呈灰色显示，但您想要使该列连续，请先在“列信息”窗口中更改其数据类型（通过高亮度显示此列并且选择列 > 列信息来访问此窗口）。

使用短整型格式

JMP 能够存储低至 8 位（一个字节）的数值数据。要实现此操作，您首先需要在“列信息”窗口的数据类型下拉菜单中告诉 JMP 显示短整型格式。然后，应指定要整数容纳多少字节。数据使用正确的短整型格式时，在数值的显示方式上将看不到任何差异，但是它们占用的磁盘空间较少。

要以短整型格式存储数值数据，请执行以下操作：

  1. 选择文件 > 首选项，然后单击“表”选项卡。
  2. 单击允许短数值选项。
  3. 单击确定返回数据表。
  4. 双击想要其值变为短整型的列名。此时将出现“列信息”窗口。
  5. 单击数据类型下拉菜单，然后选择单字节整数、双字节整数或 4 字节整数。JMP 立即将值存储为与您的选择对应的范围内的整数。例如，选择单字节整数时，您可以输入的数值的范围为 -126 至 127。选择双字节整数时，您可以输入的数值的范围为 -32,766 至 32,767。选择 4 字节整数时，您可以输入的数值的范围为 -2,147,483,646 至 2,147,483,647。

选择数值格式

将变量的数据类型指定为数值时，您还可以为其指定要采用的显示格式。要选择数值格式，请执行以下操作：

  1. 选择列 > 列信息，或双击数据网格中列名上方的区域。或者，如果要创建新列，则选择列 > 新建列。
  2. 单击格式旁边的下拉菜单，如"“列信息”窗口和日期时间格式" 所示，然后选择要 JMP 如何显示数值。有关这些选项的说明，请参阅"数值格式选项"。
“列信息”窗口和日期时间格式
  3. 如果您：
    • 在第 2 步中从格式下拉菜单中选择日期或时间，请单击如"输入格式选项" 所示的输入格式菜单，并选择输入 JMP 时将采用的日期或时间格式。有关这些选项的说明，请参阅"数值格式选项"。有关如何更改图形中日期或时间的显示方式而不更改其在数据表中的显示方式的说明，请参阅"更改轴的数值格式"。
输入格式选项
    • 在第 2 步中从格式下拉菜单中选择固定小数位，则将显示小数文本框，如"指定固定小数位" 所示。键入要 JMP 在数据表中显示的小数位数。如果值的小数点后没有您指定的那么多数字，JMP 会添零补齐这么多的小数位数。例如，值为 1.23，并且您在小数框中键入 5，JMP 则显示具有五位小数位的数值 1.23000。
指定固定小数位
  4. 在宽度文本框中键入要数据表中的单元格容纳的字符数。一定要键入一个您认为列中的值可能具有的最大位数或字符数。如果格式为固定小数位，并且您将单元格的宽度设置为小于您要在值中显示的小数位数，JMP 将忽略您指定的小数位数，并将列宽设定为您在宽度框中指定的字符数。
指定固定宽度
  5. 单击确定。

数值格式选项

格式（"“列信息”窗口"）和输入格式下拉菜单中的选项为数值格式，用于告诉 JMP 如何在数据网格中显示数值。

“列信息”窗口

可用选项包括：

  • 最佳 让 JMP 考虑每个单元格值的精度，并选择最佳显示方式。默认情况下，列的物理宽度为 10 个字符。您可以增加列宽以许多小数位显示大型值，方法是在“列信息”窗口中的宽度文本框中键入所需的字符数。
  • 固定小数位 显示已舍入到您指定的小数位数的所有列值。您可以将小数位数设定为零，以便只查看整数。在“列信息”窗口的小数文本框中键入要 JMP 显示的小数位数。
  • p 值 显示概率值。其默认宽度为 6，并显示 4 个小数位。如果数值小于 0.0001，则该数显示为 <.0001。此格式大多用于 JSL 脚本中，数据表列很少用到。
  • 科学 以标准科学记数法形式显示数字。如果输入的数值为 123456，则显示为 1.23456e+5。
  • 货币 以两个小数位、所需逗号和美元符号 ($) 前缀格式化值。如果输入的数值为 123456，则在数据表中显示为 $123,456.00。货币格式的默认宽度为 10。如果有一个数值需要更大的字段宽度，格式则默认为最佳格式。您可以增加列宽以许多小数位显示大型值，方法是在“列信息”窗口中的宽度文本框中键入所需的字符数。请注意，货币格式不用于图形的轴。
  • 日期 将所有列值显示为日期。如果将日期格式指定给一个未选择数据格式的数值列，则 JMP 将假定其数值为自 1904 年 1 月 1 日以来的秒数。例如，如果输入的日期为 1943 年 2 月 13 日，则 JMP 将显示值 1,234,567,890。如"日期格式" 所示，您可以将日期值显示为上述形式，或选择这些格式之一：（以下实例显示读取或显示日期 2004 年 12 月 31 日的格式。其无格式（数字）值为 3,187,296,600。）
日期格式
    • m/d/y 形式为 mm/dd/yyyy，即 12/31/2004。
    • mmddyyyy 形式为 mmddyyyy，即 12312004。
    • m/y 形式为 mm/yyyy，即 12/2004。
    • d/m/y 形式为 dd/mm/yyyy，即 31/12/2004。
    • ddmmyyyy 形式为 ddmmyyyy，即 31122004。
    • ddMonyyyy 形式为 ddMonyyyy，即 31Dec2004。
    • Monddyyyy 形式为 ddMonyyyy，即 Dec312004。
    • y/m/d 形式为 yyyy/mm/dd，即 2004/12/31。
    • yyyymmdd 形式为 yyyymmdd，即 20041231。
    • yyyy-mm-dd 形式为 yyyy-mm-dd，即 2004-12-31。
    • 完整日期将日期值显示为星期几、月份、日期、年，例如“星期二，2004 年 12 月 31 日”。使用此选项时，您可能需要增加列宽，以其完整形式查看格式化值。要实现此操作，请双击列名并将需要的位数或字符数输入标记为宽度的框中。
    • 缩写日期与完整日期格式相同，但其星期几和月份为三个字符的缩略格式，例如“Tue, 2004-12-31”。使用此选项时，您可能需要增加列宽，以其完整形式查看格式化值。要实现此操作，请双击列名并将需要的位数或字符数输入标记为宽度的框中。
  • 时间使用这些格式之一将所有列值显示为时间实例（如"时间格式" 所示）：
时间格式
    • m/d/y h:m、m/d/y h:m:s、d/m/y h:m、d/m/y h:m:s、y/m/d h:m、y/m/d h:m:s、ddMonyyyy h:m、ddMonyyyyh:m:s、Monddyyyy h:m 和 Monddyyyy h:m:s 显示预先挂起日期的午夜之后的小时、分钟和秒数。日期以上述格式显示。小时、分钟和秒数由冒号隔开。本实例 (04 - 12 - 31) 没有小时数或分钟数。具有零时零分零秒的格式化值的实例为 04 - 12 - 31 上午12:00 和 04 - 12 - 31 上午 12:00:00。
    • :day:hr:m 和 :day:hr:m:s 显示自 1904 年 1 月 1 日以来的天数、小时数、分钟数和秒数。2004 年 12 月 31 日的结果为 :36890:00:00: 和 :36890:00:00:00。
    • h:m:s 和 h:m 给出了日期字段中日期的小时、分钟和秒数部分。此处所用的实例（2004 年 12 月 31 日）未输入时间，因此结果为 00:00:00。
    • yyyy-mm-ddThh:mm 和 yyyy-mm-ddThh:mm:ss 显示年份、月份、日期和时间，例如 2004-12-31T17:34:54。T 是文字，表示它本身。
  • 持续时间使用这些格式之一将所有列值显示为持续时间实例（如"持续时间格式" 所示）：
持续时间格式
  • :day:hr:m 和 :day:hr:m:s 显示持续时间，例如 52:03:01:30 (:day:hr:m:s)，即 52 天 3 小时 1 分 30 秒。
  • h:m、h:m:s 和 m:s 显示持续时间，例如 17:37 (h:m)，即 17 小时 37 分。

使用国际格式

如果要导入或输入的数据包含国家（地区）标准的特定格式，则需要确保数值格式解释正确。要在 Windows 上完成此操作，请访问“控制面板”的时间/区域和语言选项，然后选择应格式化其数字的国家（地区）。在 Macintosh 上，请从 Apple 菜单选择系统首选项，选择国际，再选择数字，然后选择正确的国家（地区）。在 Red Hat 7.x 上，在 KDE 下选择首选项 > 个性化 > 国家（地区）和语言。在 Red Hat 9 上的 KDE 和 GNOME 的主菜单中选择系统设置 > 语言。


输入数据

以下部分说明了如何将数据输入表中，包括一次将数据输入某个单元格中，或一次性添加数据的行和列。

添加和删除行

要添加新空行，请执行以下操作之一：

  • 选择行 > 添加行。然后，输入要添加的行数和行的添加位置。默认情况下，新行显示在表的末尾。
  • 单击表中最后一行下面任意位置的单元格，并开始键入。然后按下 Enter 键（或 Return 键），自动生成包含您键入的值的新行。
  • 双击最后一行下面的空行编号区域，以添加大量空行。
  • 双击数据网格左上角中三角形区域下部，如"双击三角形区域下部" 所示。然后输入要添加的行数，并指定要将其添加到的位置。
双击三角形区域下部

要从数据网格删除行，请执行以下操作：

  1. 高亮度显示要删除的行。
  2. 选择行 > 删除行，或使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）行，然后选择删除行。
  3. 如果您误删除行，请选择编辑 > 撤消删除行。

添加和删除列

要添加新空列，请执行以下操作之一：

  • 双击最后一个数据表列右侧的空白区域，然后开始键入。
  • 选择列 > 新建列。"“新建列”窗口" 中的窗口会提示您命名新列，并提供列特征，包括最初填充列时要使用的数据类型。然后单击下一项以增加另一列，单击确定时将看到新列已显示在数据表中。“新建列”窗口还通过列性质按钮提供了用于将性质指定给列的选项。有关详情，请参阅"为列指定性质"。
“新建列”窗口
  • 选择列 > 添加多列。使用添加多列命令定义多列与使用新建列命令不同，因为用“添加多列”窗口添加的所有列都将具有相同的数据特征。默认情况下，新列名称为 Column 1、Column 2 等。然而，您可以通过在列前缀框键入文本来指定将成为新列名称的前缀的其它文本。然后，如"通过“列”菜单访问的“添加多列”窗口" 所示，输入要添加的列数、列位置、数据类型（有关详情，请参阅"关于数据类型"），以及字段宽度。
通过“列”菜单访问的“添加多列”窗口
  • 双击数据网格左上角中三角形区域的上部。此时将出现如"通过双击访问的“添加多列”窗口" 所示的窗口。默认情况下，新列名称为列 1、列 2 等。然而，您可以通过在列前缀框键入文本来指定将成为新列名称的前缀的其它文本。然后，输入要添加的列数、列位置、数据类型（有关详情，请参阅"关于数据类型"），以及字段宽度。
通过双击访问的“添加多列”窗口

要从数据表删除列，请执行以下操作：

  1. 高亮度显示要删除的列。
  2. 选择列 > 删除列。
  3. 如果您误删除列，请选择编辑 > 撤消删除列。

设置初始数据值

当您将新列添加到数据表（选择列 > 新建列）中时，您可以指定要在列中显示的数据值的类型，如"初始数据值" 所示。

初始数据值
  • 缺失/空  将用黑点 ( [image]) 表示的缺失值放到列中。
  • 常数 将一个数值放到列的所有行中。选择常数，然后在出现的框中键入数值，指定要使用的数值。
  • 顺序数据 根据您在出现的框中指定的参数插入顺序数据。如"为顺序数据输入详细资料" 所示，在自框和至框中指定起始点和终止点，然后在步骤框中指定顺序。例如，要列包含从 2 至 60 的偶数时，就在自框中键入 2，在至框中键入 60，在步骤框中键入 2。在每个值的重复次数框中键入重复该数值的次数（如果适用）。
为顺序数据输入详细资料
  • 随机 将随机数据插入列中。单击要使用的随机数类型旁边的按钮，然后输入随机整数和均匀随机数的范围，以及正态随机数的均值和标准差（"为随机数据输入详细资料"）。
为随机数据输入详细资料

以顺序数据填充列

您可以用数据的重复序列或用连续值填充列：

  1. 在列中创建一个数据序列，如"数据序列" 所示。
数据序列
  2. 高亮度显示包含数据序列的单元格。
  3. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）选定的单元格，然后选择如"数据填充选项" 所示的选项：
数据填充选项
    • 重复至表末尾处的顺序 选定对象下的单元格以重复选定单元格的方式填充。
    • 继续至表末尾处的顺序 选定对象下的单元格以选定单元格中的连续模式填充。例如，选定单元格包含数字 1 和 2，则其它单元格将以 3、4、5 和 6 等数字填充。例如，选定单元格包含数字 2 和 4，则其它单元格将以 6、8、10 和 12 等数字填充。
    • 重复顺序至... JMP 将重复在选定的单元格中找到的模式，直至您指定的行号。
    • 继续顺序至... JMP 将沿用在选定的单元格中找到的模式，直至您指定的行号。

输入单元格公式

在数值列中，您可以输入单元格表达式，即前面有等号 (=) 的表达式。然后，JMP 会立即计算表达式，并将新数值存储为单元格的值。与列公式不同，JMP 不会存储单元格表达式。

单元格表达式可以包含运算符、常数以及全局和列变量。

要输入表达式，请执行以下操作：

  1. 单击要在其中输入表达式的单元格。
  2. 键入等号 (=)。
  3. 输入表达式。
  4. 在键盘上按下 Enter 键或 Return 键。
    表达式实例 单元格值

    =sqrt(2)

             1.41

    =456+890

             1346

    = 高度 + 体重

             计算与您输入表达式所在的单元格在同一行的高度和体重列中的单元格值。

    = 高度[1]

             显示高度列的第 1 行中的值。


编辑数据和表

以下部分说明了如何编辑表中的数据，包括编辑单元格本身以及对行和列进行更改。

编辑单元格

要编辑单元格的内容，请执行以下操作：

  1. 单击一个已存在值的单元格。它将高亮度显示，如"编辑单元格的内容" 所示。
编辑单元格的内容
  2. 再次单击它。此时光标将变成一条闪烁的文本插入线。
  3. 编辑其值。

编辑列名

编辑列名的方式有多种。从以下列表中选择一种方式：

  • 选择列，然后开始键入。
  • 选择列，然后单击列名并且进行编辑。
  • 双击或使用鼠标右键单击列名附近的空白区域，然后选择列信息。在出现的“列信息”窗口中编辑名称。
  • 双击列面板中的列名，然后开始键入。

数据重新编码

如果有编码不正确的数据（例如，包含拼写错误或措词不当），则可以快速地对其重新编码，使其格式一致。您也可以使用重新编码来替换缺失值或空值。

JMP 显示的窗口包含选定列的唯一值，允许您输入新值来进行替换：

  1. 高亮度显示包含要重新编码的数据的列。
  2. 选择列 > 重新编码。此时将出现“重新编码”窗口（"输入新值"）。在此窗口中，计数列列出了数据表中各个值出现的次数。
输入新值
  3. 在与您要更改的旧值相对应的文本框中键入新值。

    提示：如果要将同一个新值应用于多个旧值，请键入该值一次，然后将其复制和粘贴到其它文本框中。
  4. 单击确定。

查看缺失数据的模式

如果数据表包含缺失数据，则可能要查看是否有缺失数据创建的模式。模式有助于您发现数据的规律。选择表 > 缺失数据模式将以数据表格式显示这种模式：

  1. 选择表 > 缺失数据模式。此时将出现“缺失数据模式”窗口（"“缺失数据模式”窗口"）。
“缺失数据模式”窗口
  2. 高亮度显示要从中找到缺失数据的列。
  3. 单击添加列，然后单击确定。此时将出现“缺失数据模式”表（"“缺失数据模式”表"）。
“缺失数据模式”表

在“缺失数据模式”表中，JMP 会自动为计数列指定频数分析角色。现在，如果您使用“缺失数据模式”数据表来运行分析，JMP 就会自动使用“计数”作为频数，因此您不必每次都指定它的角色。有关详情，请参阅"为列指定预选定的分析角色"。

查找和替换单元格值

选择编辑 > 搜索，将出现许多搜索选项，如"搜索选项" 所示。以下规则适用于搜索值：

  • 要查找隐藏列或锁定表中的值，请撤消隐藏列或撤消锁定表。
  • 锁定列中的值不能修改。
  • 撤消命令仅限于替换和替换并查找下一个。您无法撤消全部替换。
  • 如果数据表包含值标签（请参阅"使用值标签"），使用搜索命令将搜索实际值，但是将不会搜索标签。
搜索选项

要查找（或查找并替换）值，请执行以下操作：

  1. 选择编辑 > 搜索 > 查找。此时将显示"搜索功能 (Windows)" 中的窗口。
  2. 在查找内容框中输入一个值。

    注：要查找缺失的字符值，请将查找字段留空，然后选定全字匹配。要查找缺失的数字值，请在查找字段中输入一个句点，然后选定全字匹配。
搜索功能 (Windows)
  3. 如果要用其它值替换找到的值，请在替换为框中输入值。
  4. 细化您的搜索。选择以下任意项：
    • 大小写一致 提供一个区分大小写的搜索，对于查找专有名词或其它大写单词很有用。
    • 全字匹配 检测空格，让您可以搜索字符列中的一系列词语，或查找具有不需要的前导空格或尾随空格。使用全字匹配复选框也可以查找至少具有一个前导空格和尾随空格的词语。
    • 限制为选定行 将搜索约束在选定行。
    • 限制为选定列 将搜索约束在选定列。
    • 搜索数据 仅搜索数据单元格（忽略列名）。
    • 搜索列名称 仅搜索列名（忽略数据单元格）。
    • 方向 按列自上向下逐列搜索表，直到搜索至最右列中的最后一个单元格或直到您停止搜索。按行从左至右逐行搜索数据表，直到搜索至最后一行中的最右侧单元格或直到您停止搜索。
  5. 使用以下表开始搜索：
    操作 | 说明
    在活动表中搜索要查找的值 | 单击查找按钮。搜索从第一列中的第一个单元格开始，搜索每个单元格，直到找到值或到达表的末尾。
    用替换为框中（包含替换值）的内容替换当前高亮度显示的单元格值 | 单击替换按钮。或者，如果“搜索”窗口已关闭，请选择编辑 > 搜索 > 替换。如果替换值为缺失值，则当前高亮度显示的单元格内容将成为缺失值。
    用其它值替换所有出现的指定值 | 单击全部替换按钮。或者，如果“搜索”窗口已关闭，请选择编辑 > 搜索 > 全部替换。
    自动替换值，并搜索下一个值 在 Windows 和 Macintosh 中，首先确保“搜索”窗口中有一个值（通过编辑 > 搜索 > 查找访问）。然后选择编辑 > 搜索 > 替换并查找下一个。或使用 Ctrl-L 组合键 (Windows) 或 Command-L 组合键 (Macintosh)。
    在 Linux 上，单击“搜索”窗口中的查找按钮，然后单击替换并查找下一个按钮。
    退出“查找”窗口，但是将搜索值保留在内存中，这样在下次打开窗口时，您输入的值就会显示出来（仅限于 Windows 和 Macintosh） | 单击不查找按钮（仅限于 Windows 和 Macintosh）。
    当“查找”窗口关闭时，查找表中的下一个值 | 选择编辑 > 搜索 > 查找下一个。或者，使用 Ctrl-G 组合键 (Windows) 或 Command-G 组合键 (Macintosh)。
    查找缺失值 | 在“搜索”窗口中，将一个句号键入查找内容文本框中，然后选定全字匹配旁边的复选框。将句号键入文本框中而不单击全字匹配框来搜索句号。

列重新排序

您可以按数据表列的名称、数据类型或建模类型对其重新排列或排序，也可以反转其当前顺序。您也可以将选定列移到数据表中一个特定的位置。要对列重新排序，请执行以下操作：

  1. 选择列 > 列重新排序。
  2. 从子菜单中选择一个选项，如"列重新排序选项" 所示。
列重新排序选项
    • 移动选定列 将选定列移到数据表中一个特定的位置。选择移动选定列时，“移动选定列”窗口将显示以下选项：
    • 至最前 移动选定列，使其位于数据表中最左边的位置。
    • 至最后 移动选定列，使其位于数据表中最右边的位置。
    • 之后 移动选定列，使其位于标识的列之后。
    • 原始顺序 将列返回至上次保存数据表时所处的顺序。
    • 按名称重新排序 将列（行状态列除外）按列名以字母顺序从左到右排列。
    • 按数据类型重新排序 将列按数据类型（字符、数值和行状态）以字母顺序从左到右排列。
    • 按建模类型重新排序 将列按建模类型（连续、保序和记名）以字母顺序从左到右排列。行状态列没有建模类型，显示在最后面。
    • 倒序 使数据表列的排列顺序变成相反方向。
  1. 如果您错误地移动了一列或多列，请选择编辑 > 撤消移动列（在 Linux 中为编辑 > 撤消），以恢复以前顺序。

复制、剪切和粘贴

通过选择编辑 > 复制或编辑 > 剪切，然后选择编辑 > 粘贴 ，可在 JMP 数据表中进行复制或剪切并粘贴。您剪切或复制到剪贴板上的数据可粘贴到数据表或其它应用程序中。

  • 如果选定一个单元格，编辑命令则仅适用于该单元格。如果未选定列，则编辑命令适用于所有行。同样，如果未选定行，则编辑命令适用于所有列。如果同时选定了行和列，复制命令则复制其相交部分的单元格子集。
  • 如果没有选定列，则编辑命令会影响选定行中的所有值。如果没有选定行，则它们会影响选定列中（题头字段除外）的所有值。
  • 在同时选择了行和列时，编辑命令影响这些行和列交叉部分的单元格子集。

编辑菜单中复制和粘贴命令的功能如下：

操作 | 说明
将高亮度显示行、列、单个单元格或单元格组合从活动数据表复制到剪贴板 | 选择编辑 > 复制。在剪贴板上，字段用制表符分隔，回车字符表明行尾。
将信息从剪贴板粘贴到 JMP 数据表中的高亮度显示区域 | 选择编辑 > 粘贴 。此命令可以与复制命令一起使用，以便复制行、列或高亮度显示行和列定义的单元格子集。
复制整行或整列 | 高亮度显示要复制的行或列，然后选择编辑 > 复制。然后高亮度显示现有行或列，以接收值，并选择编辑 > 粘贴。
复制值的子集 高亮度显示单元格并选择编辑 > 复制。然后高亮度显示现有行或列，以接收值，并选择编辑 > 粘贴 。您必须高亮度显示与原始包含复制值的行和列相同的排列，才能接收复制值。
  • 如果您将较少行的数据粘贴到较多行的目标中，来源值就会重复循环，直到填充完所有接收行。
  • 如果您粘贴的行或列多于高亮度显示的行或列，超出的值就会丢失，除非是粘贴到数据表的末尾。
  • 如果在粘贴之前未高亮度显示行或列，则会根据需要添加行和列。
通过复制和粘贴将数据从其它应用程序转移到 JMP 数据表 | 首先将数据从其它应用程序中复制到剪贴板。然后选择编辑 > 粘贴，将值粘贴到 JMP 中。粘贴将根据需要自动创建行和列。
将第一行数据作为列题头粘贴 | 按住 Shift 键，然后选择编辑 > 粘贴。在 Macintosh 中为按住 Shift-Option 组合键，然后选择编辑 > 粘贴标签。

移动和复制值

拖放是移动或复制数据表中的值的一种简便方法。

要移动列、单元格或行，请执行以下操作：

  1. 在数据表或列面板中，高亮度显示要移动的列、单元格或行。要重新排列几个列、单元格或行，请按住 Shift 键并单击或按住 Ctrl 键并单击（在 Macintosh 中为按住 Option 键并单击）。释放鼠标。
  2. 单击高亮度显示的列、单元格或行，并将其拖至新位置。如果对非连续的列、单元格或行执行此操作，它们在拖放后会变为相邻。
    在拖放单元格时，请注意：
    • 它们保留所有特征和列性质。
    • 它们保留缺失值在原始单元格中，如果数据类型相同，则替换其目标位置的值。
    • 如果您将一组单元格拖至表的空白区域，就会自动创建新列。

另外，请注意另一种移动行的方法：

  1. 高亮度显示要移动的行。
  2. 选择行 > 移动行。
  3. 在“移动行”窗口中指定要移动行的位置。单击相应按钮，将高亮度显示的行移到表的开始处（起始处）、表的结尾处（末尾处）或移到特定行号之后（此行后：）。

要复制列、单元格或行，请执行以下操作：

  1. 在数据表或列面板中，高亮度显示要复制的列、单元格或行。要复制几个列、单元格或行，请按住 Shift 键并单击或按住 Ctrl 键并单击（在 Macintosh 中为按住 Option 键并单击）。释放鼠标。
  2. 按住 Ctrl 键并单击（在 Macintosh 中为按住 Option 键并单击）高亮度显示的列、单元格或行，然后将其拖至新位置。如果对非连续的列、单元格或行执行此操作，它们在拖放后会变为相邻。请注意：
    • 新列具有原始列的显示格式，但不一定有其建模类型。
    • 如果您将一组单元格拖至表的空白区域，就会自动创建新列。值将复制到目标位置，且原始值保留不变。

使用行编辑器

行编辑器让您一次可浏览或编辑一行单元格。您可以从输出报表（请参阅"将报表粘贴到其它程序"）或从数据表访问行编辑器。要从数据表使用行编辑器，请执行以下操作：

  1. 高亮度显示数据表中的行。
  2. 选择行 > 行编辑器或双击行，以显示有关当前行的信息。

    注：如果是在图形内而不是在数据表内，请在图形内部使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击），然后选择行编辑器，以访问行编辑器。
  3. 编辑数据。请注意，如果数据表包含值标签（请参阅"使用值标签"），行编辑器将显示标签，当高亮度显示单元格以进行编辑时，它将显示实际值。
  4. 单击箭头按钮浏览选定行，如果没有选定行，则浏览整个数据集。"行编辑器" 显示了每个按钮的功能。
行编辑器
  5. 单击行编辑器中的红色三角形图标，选择下面选项之一：
    • 下一选定项 显示有关当前行之后的选定行的信息。
    • 上一选定项 显示有关当前行之前的选定行的信息。
    • 下一项 显示有关当前行后面那行的信息（不管是否选定该行）。
    • 上一项 显示有关当前行前面那行的信息（不管是否选定该行）。
    • 保存 保存数据表和通过行编辑器对其进行的任何更改。
    • 新建行 在数据表中创建一个新行。
    • 查找 显示在选定行 > 行选择 > 选择位置时显示的同一窗口。单击当前选定行下要使用的选项，然后高亮度显示要选择其行的列。键入要 JMP 搜索的值。有关详情，请参阅"选择具有特定值的单元格"。
  6. 闪烁 使当前行的高亮度显示部分以极快的速率闪烁。

    注：锁定列或锁定数据表中的文本不能编辑。有关详情，请参阅"锁定列"和"锁定表"。

更改表名称

在窗口顶部、表面板中和所有分析报表上都可找到数据表的名称。这是表本身的名称或将用于保存表的名称。

要更改表名称，请执行以下操作：

  1. 单击表面板中的表名称。它将高亮度显示，如"行编辑器" 所示。
更改表名称
  2. 再次单击它。此时光标将变成一条闪烁的文本插入线。
  3. 编辑此名称。

在 Windows 上也可以通过选择窗口 > 设定标题来更改数据表的名称。

锁定表

可用于锁定 JMP 数据表的方法有两种：

  • 您可以锁定表格，从而不能编辑其值。但是，您可以运行分析、指定特征等。要实现此操作，请从表面板菜单选择锁定数据表（"锁定表，从而不能编辑其值"）。
锁定表，从而不能编辑其值
要撤消锁定文件，请再次选择锁定数据表。
  • 您可以锁定表，使其可被编辑，但是不能保存。要实现此操作，请根据您计算机的操作系统更改文件的性质。例如，将文件更改为“只读”。那么，在 JMP 中打开它时，在表名称下面的表面板中将可看到锁定文件，如"锁定文件" 所示。
锁定文件

如果一个文件同时以上述两种方式锁定，从表面板中选择锁定数据表撤消锁定文件还将移除其“只读”设置。

注：您可以将列锁定在适当的位置，从而在水平滚动时，仍然可以看见列。有关详情，请参阅"原位锁定列"。

添加表变量

表变量是在整个表中都可用的字符串，是数据表中始终可用的任意常数值。表变量名显示在数据网格左侧的表面板中，如"表变量位于数据网格的左侧" 所示。

表变量位于数据网格的左侧

表变量大多数用于文档表。例如，安装 JMP 时，系统还将安装名称为 Sample Data 的文件夹。Sample Data 文件夹的许多文件都包含一个名称为注释的表变量，其中包含说明性信息。"表变量位于数据网格的左侧" 中的实例显示的数据表包含注释，作为它的一个表变量。使用 JMP 中的试验设计命令创建设计表时，JMP 还将自动创建表变量。设计表中名称为设计的表变量将设计类型的名称用作其值。

表变量也可以合并到使用公式编辑器建立的公式，如"表变量可用于创建公式" 所示。这些公式通过引用表变量来计算列的值。有关构建使用表变量的公式的详情，请参阅"引用列和表变量"。

表变量可用于创建公式

表变量的另一个用法是将其合并到 JSL 脚本中。有关详情，请参阅《JMP 脚本指南》。

添加新的表变量

  1. 单击表面板中数据表名称左边的红色三角形图标。
  2. 从下拉菜单选择新建表变量，如"创建表变量" 所示。
创建表变量
  3. 在标记为名称和值的框中为变量指定名称和值，如"命名和定义表变量" 所示。
命名和定义表变量
  4. 单击确定。表面板中将显示表变量。

查看或编辑表变量

  1. 单击作为变量值输入的信息。该值将高亮度显示，如"单击变量值以查看或编辑其值" 所示。
单击变量值以查看或编辑其值
  2. 再次单击它。光标将变成 I 型光标。
  3. 编辑其值。

编辑表变量名

  1. 双击其名称。或者，使用鼠标右键单击（在 Macintosh 中为按住 Command 键并单击）其名称或值，然后选择编辑。此时将显示"命名和定义表变量" 中的窗口。
  2. 编辑其名称。

要删除表变量，请使用鼠标右键单击（在 Macintosh 中为按住 Command 键并单击）其名称或值，然后选择删除。

使用表变量的实例

在需要合并两个或多个数据表时，表变量尤其有用。例如，假定两种试用药物在两家不同的医院试用。其中一种试验药物的数据在名称为癌症1.jmp 的表中，另一种在癌症2.jmp 中。要将这些数据合并到一个表，请选择表 > 合并（有关详情，请参阅"附加表（合并）"）。如果在癌症1.jmp 和癌症2.jmp 中创建了表变量，那么也将合并这些变量，并且在合并的表中显示为列，如"来自癌症1.jmp 和癌症2.jmp（顶部的表）的数据和表变量合并到无标题 11.jmp（底部的表）中的一列" 所示。

来自癌症1.jmp 和癌症2.jmp（顶部的表）的数据和表变量合并到无标题 11.jmp（底部的表）中的一列

创建脚本

您可以创建一个 JSL 脚本，并随数据表一起保存（"随数据表一起保存的脚本"）。这些脚本用于自动完成各种任务和分析。有关这些脚本的完整解释，请参阅《JMP 脚本指南》。

随数据表一起保存的脚本

将脚本添加到数据表

  1. 单击表面板中数据表名称左边的红色三角形图标（请参阅"创建脚本"）。
  2. 从下拉菜单选择新建性质/脚本。
创建脚本
  3. 将名称键入名称旁边的框中，为脚本命名，如"命名和定义脚本" 所示。
  4. 将 JSL 代码键入值旁边的框中，为脚本赋值。
命名和定义脚本
  5. 单击确定。表面板中将显示该脚本。

添加脚本而不键入 JSL 代码

  1. 使用要脚本重复的步骤运行分析并创建输出报告。
  2. 单击报告标题名称旁边的红色三角形图标，如"单击红色三角形" 所示。
单击红色三角形
  3. 选择脚本 > 将脚本保存至数据表。这将创建脚本，并将其添加到表面板中。

运行脚本

  1. 单击脚本名旁边的红色三角形图标。
  2. 从菜单中选择运行脚本。

查看或编辑脚本

  1. 双击其名称。或者，单击脚本名旁边的红色三角形图标，如"单击红色三角形" 所示，然后选择编辑。此时将显示"命名和定义表变量" 中的窗口。
单击红色三角形
  2. 编辑其值。

编辑脚本名

  1. 双击其名称。或者，单击脚本名旁边的红色三角形图标，如"单击红色三角形" 所示，然后选择编辑。此时将显示"命名和定义表变量" 中的窗口。
  2. 编辑其名称。

要删除脚本，请单击脚本名旁边的红色三角形图标，或使用鼠标右键单击（在 Macintosh 中为按住 Command 键并单击）其名称，如"单击变量值以查看或编辑其值" 所示，然后选择删除。


选择行和列

您可以选择行、列或同时选择行和列，如"选定行和列的实例" 所示。

选定行和列的实例

使用以下表选择行。

操作 | 说明
选择整行 | 单击包含行号的空白区域。
选择多行
  • 在数据网格中单击并将光标拖移到行号上。
  • 按住 Shift 键并单击所需范围的第一行和最后一行。
  • 要进行非连续的选择，请按住 Ctrl 键并单击 (Windows/Linux) 或按住 Command 键并单击 (Macintosh) 每一行。
这些命令也可用于切换，即用于撤消选择此前选定的行。
选择/撤消选择
所有行 		选择行 > 行选择 > 选择所有行。或者，按住 Shift 键并单击数据网格左上角中三角形区域的下部，进行选择。再次单击则撤消选择所有行。要清除数据表中所有的高亮度显示部分，请按下键盘上的 Esc 键。
选择行和列交叉部分的单元格区组。 | 沿单元格对角线方向拖动十字光标。
选择某个行号。 | 选择行 > 行选择 > 转至行，然后键入所需的行号。
反向行
选择 		选择行 > 行选择 > 反向行选择。
选择随机数 | 选择行 > 行选择 > 随机选择。有关详情，请参阅"随机选择行"。

使用以下表选择列。

操作 | 说明
选择一列
  • 单击列名附近的空白区域。
  • 单击数据网格左侧列面板中的列名。
选择多个列
  • 在数据网格中单击并将光标拖到列名上。
  • 按住 Shift 键并单击所需范围的第一列和最后一列。
  • 要进行非连续的选择，请按住 Ctrl 键并单击 (Windows/Linux) 或按住 Command 键并单击 (Macintosh) 想要的列。
这些命令也可用于切换，即用于撤消选择此前选定的列。
扩展列选择
  • 按住 Shift 键并单击所需范围的第一列和最后一列。
  • 要进行非连续的选择，请按住 Ctrl 键并单击 (Windows/Linux) 或按住 Command 键并单击 (Macintosh) 想要的列。
这些命令也可用于切换，即用于撤消选择此前选定的列。
一次性选择/撤消选择所有列 | 按住 Shift 键并单击数据网格左上角中三角形区域的上部，进行选择。单击左上角撤消选择所有列。要清除数据表中所有的高亮度显示部分，请按下键盘上的 Esc 键。
进行非连续的选择 | 按住 Ctrl 键并单击 (Windows/Linux) 或按住 Command 键并单击 (Macintosh) 每一列。
选择行和列交叉部分的单元格区组。 | 沿单元格对角线方向拖动十字光标。

选择排除行、隐藏行或标记行

有时需要自动高亮度显示或选择某些类型的行，才能在数据表的许多行中查看或进行操作。要选择已标记为排除、隐藏或标记的行，请执行以下操作：

  1. 选择行 > 行选择（"行选择菜单"）。
行选择菜单
  2. 选择以下选项之一：
    • 选择排除项 选择所有排除的行（不管其当前选择状态），以及撤消选择以前选定的任何行。
    • 选择隐藏项 选择所有隐藏的行（不管其当前选择状态），以及撤消选择以前选定的任何行。
    • 选择标记项 选择所有标记的行（不管其当前选择状态），以及撤消选择以前选定的任何行。

选择具有特定值的单元格

如果要在数据表中查找特定值，有几种方式可用于快速选择该值，如以下部分所述。

选择与当前高亮度显示的单元格匹配的单元格

JMP 可以找到与当前高亮度显示的单元格具有相同值的所有单元格。您可以在一个数据表中或所有打开的数据表中进行此操作。要选择包含的值与高亮度显示的单元格相同的单元格，请执行以下操作：

  1. 高亮度显示包含要查找的值的单元格。
  2. 要在活动数据表中查找所有匹配的单元格，请选择行 > 行选择 > 选择匹配单元格。或者，使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）其中一个高亮度显示的行号，然后选择选择匹配单元格。
    要在所有打开的数据表中查找所有匹配的单元格，请选择选择所有匹配单元格。
  3. 包含的值与高亮度显示的行相同的行将高亮度显示。
  4. 例如，假定您要选择以下数据表中包含高亮度显示的年龄为 28 的年龄列中的所有单元格。您将选择行 > 行选择 > 选择匹配单元格，此时数据表将出现在屏幕上，如"使用选择位置窗口选择行" 所示。
使用选择位置窗口选择行

选择包含特定值的单元格

JMP 可以搜索特定值（或文本字符串），并高亮度显示数据表中包含该值的所有单元格。

要选择包含特定值的单元格，请执行以下操作：

  1. 选择行 > 行选择 > 选择位置。此时将显示"使用选择位置窗口选择行" 中的窗口。
使用选择位置窗口选择行
  2. 如果当前已在数据表中选定了行，请单击当前选定行下的选项，告诉 JMP 如何处理当前选定行：
    • 清除当前选择 从当前选定的行移除高亮度显示部分，然后选择包含指定值的所有行。
    • 扩展当前选择 保持当前选定行的选定状态，并选择在其中找到指定值的行。
    • 从当前选择中选择 选择当前选定表中包含指定值的行。
  3. 从列表中高亮度显示要选择其行的列的名称。
  4. 使用下拉菜单从列表中一个条件（等于、不等于等），如"使用选择位置窗口选择行" 所示。
  5. 键入要 JMP 搜索的值。要搜索缺失值，请将此框留空。
  6. （可选）如果要搜索区分大小写，请单击大小写一致旁边的框。
  7. 单击添加条件。
    如果要给搜索添加更多的条件，请重复步骤 3 - 7，然后单击选择行区域中的相应项，指定是满足所有条件时还是满足某些条件时才让 JMP 选择行。
  8. 单击确定。

使用搜索/查找命令

您也可以通过选择编辑 > 搜索选择行。要查找（或查找并替换）值，请执行以下操作：

  1. 选择编辑 > 搜索 > 查找，如"搜索选项" 所示。
搜索选项
  2. 在查找内容框中输入一个值。要查找缺失的字符值，请将查找字段留空，然后选定全字匹配。有关详情，请参阅"锁定表"。

选择特定行或列

如果您知道要高亮度显示的行号，而不想滚动很多行才能找到该行，则可以使用转至行命令快速查找行号。

要查找一行，请执行以下操作：

  1. 选择行 > 行选择 > 转至行。此时将显示"“转至行”窗口" 中的窗口。
“转至行”窗口
  2. 输入行号，然后单击确定。

要查找一列，请执行以下操作：

  1. 选择列 > 转至。此时将显示"“转至行”窗口" 中的窗口。
“转至”窗口
  2. 输入列编号或列名，然后单击确定。

随机选择行

您可以让 JMP 随机选择特定行数或总行数的一个百分比：

  1. 选择行 > 行选择 > 随机选择，如"选择随机选择" 所示。此时将显示"“随机选择”窗口" 中的窗口。
选择随机选择
  2. 要随机选择特定行数，请在文本编辑框中输入绝对样本大小。
    或者，要随机选择总行数的一个百分比，则输入比例样本大小，如"“随机选择”窗口" 所示。如果输入的数小于 1，JMP 则认为该数是一个比例，并认为您要随机选择行数的该百分比。如果输入的数大于 1，JMP 则认为输入的数是要随机选择的行数。例如，输入 10 则随机选择 10 行。输入 0.1 则随机选择 10% 的行数。
“随机选择”窗口

反选和选择所有行

要选择 JMP 数据表中的所有行，请选择行 > 行选择 > 选择所有行。

要撤消选择所有选定行，并选择此前撤消选择的所有行，请选择行 > 反向行选择。

查找下一个选定行和上一个选定行

您可以查找当前行之后下一个选定的行，并通过选择行 > 下一选定项使它闪烁。同样，您可以查找当前行之前上一个选定的行，并通过选择行 > 上一选定项使它闪烁。

每当您选择行 > 下一选定项或行 > 上一选定项，下一个选定行或上一个选定行都会出现并闪烁。找到最后一个选定行时，系统会发出嘟嘟声。


保存表、报表和会话

多种多样的保存方法

在 JMP 中保存分析结果的方法多种多样。具体选择哪种方法视您将来是否以及如何使用您的分析结果而定。

本章将详细介绍一些在 JMP 中保存数据表和报表的方法。

目录

保存数据表

保存 .jmp 文件以用于 JMP 5.1.2 或更早的版本

另存为文本文件

保存文本文件以用于 JMP 5.1.2 或更早的版本

另存为 SAS 传输文件

另存为 SAS 数据集（仅限于 Windows）

另存为 Microsoft Excel 文件（仅限于 Windows 和 Macintosh）

将数据表保存至数据库

保存报表

使用日志命令保存

使用布局命令保存

以图形的格式保存报表的某些部分

将报表粘贴到其它程序

保存 JMP 会话

退出时保存会话

手动保存会话

保存记录窗口

指定文件保存位置（仅限于 Windows）


保存数据表

JMP 可以使用下列格式保存数据表。

要保存数据表，请执行以下操作：

  • 在 Windows 和 Linux 中，选择文件 > 另存为以便使用多种格式保存数据表。
  • 在 Macintosh 中，选择文件 > 另存为以便将数据表另存为 JMP 文件 (.jmp)，选择文件 > 导出以便使用文本 (.txt)、Microsoft Excel (.xls) 和 SAS 传输 (.xpt) 格式保存数据表。

除了上述文件类型之外，JMP 还可以将数据表另存为具有对应 ODBC 驱动程序的文件类型。有关详情，请参阅"将数据表保存至数据库"。

文件类型 | 扩展名 | 操作系统可用性
JMP 数据表 | .jmp | 全部
JMP 报表 | .jrp | Linux
JMP 日志 | .jrl | Linux
Excel 文件 | .xls | Windows 和 Macintosh
文本文件 | .txt | 全部
SAS 传输文件 | .xpt | 全部
SAS 7 数据集 | .sas7bdat | Windows
MS Access 数据库，CBA_EH_DBC 和 BA_TL_DB | .mdb | Windows
dBASE 文件 | .dbf、.ndx、.mdx | Windows
OpenOffice 电子表格 | .sxc | Linux

数据表名称的最大长度取决于您计算机的操作系统。

保存 .jmp 文件以用于 JMP 5.1.2 或更早的版本

JMP 6 使用的是 Unicode 字符集，它支持许多特殊字符，例如 é 和∫。您可以通过 JMP 来保存数据表 (.jmp)，以便在那些不支持 Unicode 的较早的应用程序（例如 JMP 5.1.2 和更早的版本）中也可以打开这些数据表。它适用于所有数据表字符数据全都可以转换成应用程序可以读取的遗传字符集的情况。

要保存 .jmp 文件以便用在较早版本的应用程序中，请选定在您选择文件 > 另存为之后出现的与 JMP 5 兼容（不使用 Unicode 文本）复选框。之后，JMP 会将这个不含 Unicode 文本的文件保存下来。

另存为文本文件

JMP 可以将数据从 JMP 数据表转换成带有行和列的标准文本格式。

要将数据表另存为文本文件，请根据您使用的操作系统以及您保存文件的方式执行下表中介绍的步骤。

 另存为文本文件
Windows
  1. 选择文件 > 另存为。
  2. 在文件名框中键入文件名称。
  3. 从保存类型下拉菜单中选择文本导出文件 (*.TXT)。
  4. 单击选项按钮，指定行末字符和字段末字符，然后详细叙述列名说明。如果您想要不使用分隔符保存文件，请在字段末框中选择无。有关详情，请参阅"Windows 和 Linux 中的文本格式选项"。
  5. 单击确定。
  6. 单击保存。
Macintosh
  1. 选择文件 > 导出。
  2. 在出现的窗口中，选择文本并且单击下一步。
  3. 在另存为框中键入文件名称。
  4. 单击导出。
Linux
  1. 选择文件 > 另存为。
  2. 在保存类型字段中，选择 *.txt（分隔文本）。
  3. 在文件名框中键入文件名称。
  4. 单击下一步。
  5. 指定行末字符和字段末字符，然后详细叙述列名说明。有关详情，请参阅"Windows 和 Linux 中的文本格式选项"。
  6. 单击完成。

Windows 和 Linux 中的文本格式选项

文本格式选项包括：

    • 将列名导出至文本文件 要将列名保存为文本文件的第一个记录并且随数据一起保存标签或题头信息，请选择是。
    • 字段末 单击在文本文件中找到的字符旁边的框，该字符是表示字段末的分隔符。如果没有列出相应的字符，则可以单击其它旁边的方框并输入所需字符。
    • 行末 单击在文本文件中找到的字符旁边的框，该字符是表示行末的分隔符。如果没有列出相应的字符，则可以单击其它旁边的方框并输入所需字符。

      注：如果在导入文本数据时遇到双引号，则分隔符规则将变为查找结束双引号。其它文本分隔符（包括引号中嵌入的空格）将被忽略，并且作为文本字符串的一部分处理。

保存文本文件以用于 JMP 5.1.2 或更早的版本

JMP 6 使用的是 Unicode 字符集，它支持许多特殊字符，例如 é 和∫。它可以自动将不含特殊 Unicode 字符的文件另存为纯文本文件。但是，包含 Unicode 字符的文件可以从 JMP 中保存，也可以在不支持 Unicode 的较早版本的应用程序（例如 JMP 5.1.2 和更高的版本）中打开它们。为此，请先禁用 JMP 6 中的 Unicode 功能：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别。
  3. 撤消选定以 Unicode 保存文本文件旁边的框。现在，JMP 会将您的文本文件另存为纯（遗传）文本文件。

另存为 SAS 传输文件

您可以使用 SAS 传输文件格式保存 JMP 数据表，或者将数据表附加到现在的 SAS 传输文档中。

使用 Windows 和 Linux

  1. 选择文件 > 另存为。
  2. 在文件名框中键入您的文件名称。请注意，数据表名的最大长度根据您使用的操作系统来定。
  3. 从保存类型下拉菜单中选择文件扩展名 .xpt（SAS 传输文件）。

要将数据表附加到现有的 SAS 传输文件库中，请单击附加至旁边的框，然后高亮度显示要附加的文件。

  4. 单击保存。

使用 Macintosh

  1. 选择文件 > 导出。
  2. 要创建新的 SAS 传输文件，请选择 SAS 传输。
    1. 单击下一步。
    2. 在另存为框中键入文件名称。请注意，数据表名的最大长度根据您使用的操作系统来定。
    3. 单击导出。
要将数据表附加到现有的 SAS 传输文件库中，请选择 SAS 传输，然后选定附加旁边的框。
  1. 单击下一步。
  2. 高亮度显示要附加的文件。
  3. 单击附加。

另存为 SAS 数据集（仅限于 Windows）

在 Windows 中，JMP 可以将数据表另存为 JMP 6 和更高版本的数据集。它可以将列写成 SAS 变量，将行写成 SAS 观测值。它还可以将它们另存为 SAS 可以识别的格式。

要将数据表另存为数据集，请执行以下操作：

  1. 选择文件 > 另存为。
  2. 在文件名框中键入您的文件名称。请注意，数据表名的最大长度根据您使用的操作系统来定。
  3. 从保存类型下拉菜单中选择 SAS V7 数据集。
  4. （可选）如果您要使用 SAS V6 格式 (.sd2) 保存文件，请单击使用 SAS V6 格式 (.sd2) 旁边的框。如果您使用的是 SAS V7 或更高版本，请不要单击此框。
  5. 单击保存。

    注：当您将数据导出至 SAS 文件中时，JMP 日期列会变成对应 SAS 格式的 SAS 日期值。

另存为 Microsoft Excel 文件（仅限于 Windows 和 Macintosh）

您可以使用 Microsoft Excel 工作簿格式保存 JMP 数据表。

使用 Windows

  1. 选择文件 > 另存为。
  2. 在文件名框中键入您的文件名称。请注意，数据表名的最大长度根据您使用的操作系统来定。
  3. 从保存类型下拉菜单中选择文件扩展名 .xls（Excel 文件）。

使用 Macintosh

  1. 选择文件 > 导出。
  2. 选择 Excel。
  3. 单击下一步。
  4. 在另存为框中键入文件名称。请注意，数据表名的最大长度根据您使用的操作系统来定。
  5. 单击导出。

将数据表保存至数据库

您可以将数据表保存到系统中驱动程序符合 ODBC（开放式数据库连接）标准的任何一个数据库中：

  1. 选择文件 > 数据库 > 保存表。"数据库保存表窗口" 显示的是最开始出现的窗口。
数据库保存表窗口
  2. 在“连接”框中，高亮度显示用于保存文件的数据库的名称。“连接”框中包含与您的系统连接的数据库列表（"指定要保存的表"）。
    如果您未与所需的数据库连接，请使用其它应用程序创建这一连接。或者：
    1. 单击连接。
    2. 选择您需要的数据源，然后单击确定。如果要创建新来源，请单击新建按钮（Windows 和 Linux）或添加按钮 (Macintosh)。由于您选择的数据源以及在计算机中安装的数据库驱动程序不同，因此您可能会看到不同的窗口。使用它们创建数据库来源。
    3. 选择用于保存文件的数据库。
  3. 单击要保存的 JMP 数据表旁边的下拉菜单（如"指定要保存的表" 中所示），然后选择要保存到数据库中的 JMP 数据表。
指定要保存的表
  4. 在保存至数据库表旁边的框中，键入您将表保存到数据库中时所用的表名。
  5. 单击保存表。


保存报表

JMP 可以使用下表中列出的格式保存报表。

要保存报表，请执行以下操作：

  • 在 Windows 和 Linux 中，选择文件 > 另存为以便使用多种格式保存报表。
  • 在 Macintosh 中，选择文件 > 另存为以便将报表另存为 JMP 报表 (.jrp)，选择文件 > 导出以便使用文本 (.txt)、HTML (.html) 和富文本 (.rtf) 格式保存报表。
    文件类型 扩展名 说明 操作系统可用性

    JMP 报表

    .jrp

    最初在 JMP 中创建的分析报表。要继续分析，可以重新打开它。

    全部

    超文本置标语言

    .htm、.html

    World Wide Web 格式；标记表示单独图片文件的文本。

    全部

    富文本格式

    .rtf

    字处理格式；图片、文本与表的混合。

    全部

    JMP 日志

    .jrn

    在标题为日志的单独窗口中复制的分析报表。您可以编辑它，也可以将其它报表附加在其中。

    请注意，在 Macintosh 和 Linux 中，选择编辑 > 日志，然后选择文件 > 保存。在 Windows 中，选择文件 > 保存，然后选择日志格式。

    全部

    文本格式

    .txt

    纯文本格式；无图片。

    Windows 和 Macintosh

    便携式网络图形

    .png

    压缩的位图；继 GIF 之后的文件格式。

    Windows

    联合图像专家组

    .jpg

    压缩的位图；标准的相片格式。

    Windows

    可伸缩矢量图

    .svg

    以文本形式存储的图片；最适用于二维图形。

    Windows

    Windows 元文件

    .wmf

    以命令形式存储的图片；独立解析。

    Windows

    纯文本

    .txt

    纯文本格式；无图片。

    Windows

    Microsoft Word

    .doc

    字处理格式；图片、文本与表的混合。

             Windows（您必须安装 Microsoft Word 2000 或更高版本。）

    注：当您在 Windows 和 Linux 中将报表另存为 .html 或 .rtf 文件时，在窗口底部(windows) 或在单击“下一步”按钮 (linux) 之后，有一些选项可供您选择图形文件格式。从 .html 或 .rtf 文件中选择 JMP 保存图形时所用的格式。

使用日志命令保存

您可以通过创建报表窗口日志来保存报表以便将来编辑。此窗口复制在标题为日志的单独窗口中，您可以编辑它，也可以将其它报表附加在其中。

要创建并且保存日志，请执行以下操作：

  1. 选择编辑 > 日志。报表窗口将复制在标题为日志的单独窗口中。
  2. 选择文件 > 另存为。
  3. 以 .jrn 格式保存它，如"以多种文件类型中的一种保存 JMP 日志" 中所示。您还可以在日志中添加元素。有关详情，请参阅"将报表附加到日志中"和"自定义 JMP 日志"。
以多种文件类型中的一种保存 JMP 日志

另外，在 Windows 中，您可以使用“文件 > 另存为”命令将报表另存为日志，但不创建单独的日志窗口。

将报表附加到日志中

要将其它报表附加到您记录的报表中，请再次选择编辑 > 日志。如果已经选择分析窗口的某个区域，编辑 > 日志命令只会保存选定区域而不是保存整个窗口。有关详情，请参阅"自定义 JMP 日志"。

在处理报表时，切记以下几点：

  • 日志窗口的功能与报表窗口相同：您可以单击图标、单击并拖动以及使用鼠标右键单击访问菜单。
  • 在记录报表后，记录的副本将不再与数据表连接起来。

要插入分页符以便于打印，请使用鼠标右键单击日志窗口中的展开按钮（Windows/Linux 上的 [image] ；Macintosh 上的 [image] ），然后选择编辑 > 分页。

注：如果您为一个报表（或数据表）创建日志文件，然后打开另一个报表并且记录它，则第二个报表将附加到日志中第一个报表的末尾。要为单独的报表创建单独的日志，请保存并关闭第一个日志，然后才能创建第二个日志。或者，使用“布局”命令将单独的报表放在单独的布局窗口中，如"使用布局命令保存"中所述。

如果只想将报表或数据表的选定区域保存到日志中，请执行以下操作：

  1. 请单击选择工具 ( [image])。
  2. 单击并拖动以便选择报表或数据表中的项，或者按住 shift 同时单击选择不连续的项。
  3. 选择编辑 > 日志 。或者，如果您已经打开一个日志窗口，请单击选定项并且将它从报表中拖动到日志窗口中。
  4. 选择文件 > 另存为。

自定义 JMP 日志

日志窗口中的报表类似于实时分析，但是它们已经断开与数据的连接，因此分析命令不再可用。但是，就像对待实时分析一样，您仍然可以自定义日志的外观。当 JMP 日志打开时，您可以：

  • 通过选择文件 > 打印来打印日志窗口的内容。
  • 通过双击底部的打开区域在日志末尾处添加注释。
  • 添加文件参考、超级链接以及其它信息。有关详情，请参阅"创建新日志"。
  • 单击展开按钮（Windows/Linux 上的 [image] ；Macintosh 上的 [image] ），打开和关闭报表外框层。
  • 调整图形大小（请参阅"调整图和图形大小"）。
  • 通过复制并粘贴或拖放选择并移动报表中的任何元素。
  • 使用鼠标右键单击（在 Macintosh 中按住 Ctrl 键并且单击）图形，然后指定标记、更改标记大小、更改背景颜色等。
  • 使用“轴规格”窗口（请参阅"自定义轴和轴标签"）或者拖动图形中的轴来定制这些轴。
  • 选择并删除任意报表元素。
  • 使用注释工具 ( [image]) 以及其它绘图工具（请参阅"向报表中添加元素"）。
  • 复制或拖动 JMP 分析窗口中的单个图形和文本报表，然后将它们粘贴或放到图形中。
  • 复制或拖动其它应用程序中的文本和图片，然后将它们粘贴或拖放到图形中或日志窗口的末尾（请参阅"添加图形（仅适用于 Windows 和 Macintosh）"）。
  • 通过单击红色的三角形图标并选择在新窗口中运行，以从日志窗口运行分析结果。

使用布局命令保存

您可以在保存报表前首先编辑或处理它，同时也可以将几个报表合并成一个报表或者重新排列报表元素。通过选择编辑 > 布局可以完成上述操作。使用此命令与使用编辑 > 日志命令不同，因为“布局”命令可以提供其它选项来帮助您撤消对报表各个部分的组合并且重新构造，以便更好地满足您的需要。

要创建布局，请执行以下操作：

  1. 选择编辑 > 布局。报表窗口将复制在标题为布局的单独窗口中。
  2. 此时，您会看到布局菜单。它位于主菜单栏上的编辑菜单和表菜单之间（Linux 上的视图菜单与表菜单之间），如"布局菜单" 中所示。只有在您使用箭头工具选择某项之后，“布局”菜单中的项才可用。有关详情，请参阅"布局菜单"。
布局菜单
  3. 在布局窗口中单击。整个报表将高亮度显示。
  4. 选择布局 > 取消组合，或者在报表中使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并且单击），然后选择取消组合。此时，JMP 将执行对报表元素取消组合的第一阶段，亦即从报表或子报表中撤消（或断开）最顶端的标题栏。每次您从报表中撤消一个报表外框层标题时，该层的展开按钮（Windows/Linux 上的 [image] ；Macintosh 上的 [image] ）就会消失，您就不能再关闭它。但是，您仍然可以执行多个表面操作，例如使用图形中的上下文菜单、定制轴、在新窗口中返回分析结果以及编辑脚本等。
  5. 再次选择布局 > 取消组合，以便撤消报表外框的下一层。请注意，系统只对选定项取消组合。
  6. 继续选择特定的报表元素（或所有元素）并且将它们撤销组合，直至报表或图形的每个标题和每一部分都是对象。

    注：您可以从标题栏开始撤消报表组合，也可以撤消所有主要部分的组合，但是不能从列标题开始撤消报表中的列。
  7. 单击对象选中它，然后将它移到布局窗口中的任意位置。布局窗口具有任意多页，外框是灰色的。
  8. 选择文件 > 另存为。然后，JMP 会将文件另存为日志文件 (.jrn)。

使用下表对布局窗口执行进一步的操作。

操作 | 说明
编辑标题栏 | 双击标题栏或报表列标题。
快速撤消布局组合至最小的对象。 | 反复按 Ctrl-U 键（Macintosh 上的 Command-U 键）。
在新窗口中返回报表 | 单击标题栏上的红色三角形图标，然后从菜单中选择在新窗口中返回。
编辑脚本 | 单击标题栏上的红色三角形图标，然后从菜单中选择编辑脚本。
访问“布局”菜单项（在主菜单栏上） | 选择箭头光标。
插入分页符 | 使用鼠标右键单击标题栏上的展开按钮（Windows/Linux 上的 [image] ；Macintosh 上的 [image] ），然后选择显示框 > 分页。
选择和撤消选择项 | 使用鼠标右键单击标题栏上的展开按钮（Windows/Linux 上的 [image] ；Macintosh 上的 [image] ），然后选择显示框 > 选择或显示框 > 撤消选择。

"布局窗口中的多个分析结果" 中的实例显示的是从二元分析（散点图和多项式拟合）、分布分析（直方图和频数）以及单因子分析（均值和 t 检验）中提取、合并和整理成简洁格式的结果。上述结果可以简单明了地给出试验中耗氧量与运行时间的函数关系。具体方法是构建一个分析的布局窗口，然后将另一个需要的分析元素拖到该布局窗口中，整理需要的部分，然后删除多余的元素。

布局窗口中的多个分析结果

以图形的格式保存报表的某些部分

您可以将分析报表窗口的某些部分另存为图形。虽然在保存报表前，您不能处理或自定义报表，但是您可以快速保存高亮度显示的选择。在 Windows 中，您可以使用 .png、.jpg、.wmf 和 .svg 格式保存所做的选择。在 Macintosh 中，您可以使用 .png 格式保存所做的选择。

要保存所做的选择，请执行以下操作：

  1. 请单击选择工具 ( [image])。
  2. 高亮度显示要保存的区域。
  3. 选择编辑 > 将选择另存为 (Windows/Linux)，或者按 Command 键，然后选择文件 > 导出 (Macintosh)。

选择保存所做的选择时想要使用的图形文件格式。

注：请使用鼠标右键单击所做的选择并且选择复制，然后将所做的选择粘贴到 JMP 的另一部分或另一个软件程序中（请参阅"将报表粘贴到其它程序"）。


将报表粘贴到其它程序

当您需要在其它程序中使用 JMP 报表或数据表时，您可以通过将报表或数据表的各个部分复制并粘贴或拖放到其它程序（如 Microsoft Word 或 PowerPoint）中，来保存这些报表或数据表。然后在该应用程序中保存文档。请注意，在 Linux 中，您可以复制并粘贴或拖放文本，但不能对图形进行这类操作。

  1. 请单击选择工具 ( [image])。
  2. 在报表窗口或数据表中单击并拖动（或按住 Shift 键并单击）以选择项。在报表窗口边缘附近单击可以选择整个报表。
  3. 单击选定项，并将其从 JMP 中拖放至另一个程序中。或者，在 JMP 中复制选定项，并将其粘贴到另一个程序中。在将某个元素粘贴到另一个应用程序时，其所用格式取决于要粘贴到其中的应用程序。如果应用程序具有选择性粘贴命令而您又使用了此命令，则您可以选择要使用的格式，如文本 (.rtf)、不带格式的文本 (.txt)、图片或 Windows 元文件 (.wmf)、位图 (.bmp) 或增强型图片 (.emf)。

    注：要将活动报表窗口中的所有文本（不带图表）作为不带格式的文本进行复制，请选择编辑 > 复制为文本。在 Macintosh 中，按住 Shift 键，然后选择编辑 > 复制为文本。如果只要复制图形（不带文本），请使用鼠标右键单击该图形，然后选择编辑 > 复制图片。


保存 JMP 会话

我们将每次您使用 JMP 的过程叫作会话。已保存的会话是指一个 JSL 脚本，它可以重新打开文档并且重新运行分析以将 JMP 恢复到创建已保存的会话脚本时的状态。已保存的会话可以帮助您重新回到上一个状态，但是不必手动重新打开和重新运行分析。

如果您是高级用户，最重要的是要知道已保存的会话中预留了哪些会话信息。JSL 脚本将重新打开所有已保存的文档（例如数据表、脚本和日志），同时，它还会重新运行支持脚本保存功能的所有窗口（相当于单击报表中的红色三角形，然后选择脚本 > 恢复分析）。运行脚本也有一些副作用，例如系统将不会保存全局变量值或自定义窗口，也不会保存高度交互的分析的状态。

退出时保存会话

对于已保存的会话来说，最常见的用途是保存 JMP 退出时的状态，以便在 JMP 重新启动时可以恢复到这一状态。默认情况下，每次您退出程序时，JMP 都会问您是否要保存会话状态（"退出时保存会话"）。如果您退出时已保存的文件仍然打开，当您返回至 JMP 时，它将重新打开所有尚未关闭的已保存文档，并且重新运行尚未关闭的所有分析。因此，您可以暂时退出 JMP 并且稍后返回，但是无需打开您之前正在使用的文件。

退出时保存会话

要确保退出时始终保存会话，或者退出时从不保存会话，请选定不再询问是否保存此会话旁边的框，然后单击是或否。稍后，您也可以在 JMP 的首选项中更改此选项：

  1. 选择文件 > 首选项。
  2. 选择报表图标。
  3. 在退出时保存会话选项旁边，选择始终保存会话、从不保存会话或让 JMP 问您退出时是否保存会话。

手动保存会话

您也可以将会话保存到选定的位置并且继续处理，以便您可以随时恢复已保存的状态。当您想要加大对保存和恢复会话的控制力度时，尤其是在您想要多个会话保持独立的状态，而且每个会话具有不同的文件和分析集时，手动保存会话尤其有用。

要手动保存会话，请创建一个 JSL 脚本，以便重新打开当前所有打开的文件并且重新运行当前所有打开的分析和图形。因此，您可以暂时退出 JMP 并且稍后返回，但是无需打开您之前正在使用的文件。它还允许您在不退出 JMP 的情况下创建不同的 JMP 会话。

要创建 JMP 会话脚本，请执行以下操作：

  1. 选择文件 > 保存会话脚本。
  2. 在对话框中键入脚本名称，然后单击保存。

手动保存会话的另外一种方法是创建每个会话的日志（请参阅"使用日志命令保存"和"创建新日志"）。日志可以是笔记本样式或项目样式的文件。通过它，您可以将引用收集到项目文件中、开发演示快捷栏、将项目归档以及在同一个位置存储多个脚本。

日志允许您存储会话中的数据表和报表，然后根据需要打开会话及其内容。您也可以每次打开多个包含会话的日志文件。

要创建包含 JMP 会话的日志文件，请执行以下操作：

  1. 打开要包括在日志中的文件。
  2. 选择文件 > 新建 > 日志。或者，要将打开的文件附加到现有日志中，请打开该日志。
  3. 使用鼠标右键单击空日志，然后选择添加所有打开的文件。
创建 JMP 会话日志


保存记录窗口

选择视图 > 记录，以便在 JMP 窗口的底部显示一个用于监控 JMP 活动的窗格。您可以使用记录查找脚本中的错误、更正 JSL 代码或检索请求的信息。

您可能会遇到一些实例，它们是通过运行公式、矩阵或其它运算来将感兴趣的信息写到记录窗口中的。要保存记录窗口中的内容，请执行以下操作：

  1. 使用鼠标右键单击记录窗口，然后选择浮动记录窗口，以便从屏幕底部移走记录窗口。
  2. 选择文件 > 另存为。


指定文件保存位置（仅限于 Windows）

您可以指定用于保存 JMP 数据表、日志和图形选择的默认位置。要指定这些文件的保存位置，请执行以下操作：

  1. 选择文件 > 首选项，然后单击文件位置图标。此时将出现如"指定文件保存位置" 所示的屏幕。
指定文件保存位置
  2. 高亮度显示另存为数据/日志目录，然后单击浏览。
  3. 浏览至用于存储文件的目录，然后单击选择。
  4. 如果您希望每次您选择文件 > 保存或文件 > 另存为时 JMP 都使用指定的目录，请选定显示“数据/日志另存为”时始终转至此目录旁边的框。


为数据指定性质和特征

自定义列和行

除格式化数据等基本操作外，您还可以自定义行和列，以使之适用于分析。您可以排除、隐藏、标记、着色、标注或锁定行或列。这样便可以达到自定义散点图和图形中点外观的目的。

目录

为行和列指定特征

排除行和列

隐藏行和列

标记行和列

为行指定颜色

为行添加标记

根据列值为行指定颜色或标记

删除所有行特征

原位锁定列

为列指定预选定的分析角色

图标指示器

为列指定性质

为列指定用于计算值的公式

锁定列

为列添加注释

验证列数据

使用值标签

对列中的值排序

指定值的颜色范围

更改列的默认轴设置

定义列的低值和高值（试验设计编码）

为混料试验将列设定为因子

指定行在分析报表中的显示方式

输入规格限、控制限和响应限

为列指定设计角色

标识因子变化

为列指定 Sigma 值

指定列的测量单位

创建自己的列性质

移除性质

在列间标准化属性和性质

添加属性和性质

删除性质

使用行状态列

永久高亮度显示单元格


为行和列指定特征

您可以排除、隐藏、标记、着色、标注行和列。这样便可以达到自定义散点图和图形中点外观的目的。总共有 16 种标记和 65 种颜色可供选择。此外，您还可以锁定列，以便在滚动页面时让这些列保持不动。

以下部分介绍了如何为行和列指定性质及特点。

排除行和列

您可以标记行和列，以便在分析中将它们排除在外。如果标记了行和列以将它们排除，则：

  • 文本报表和图形中将不会计算已排除的数据，但图中仍会显示这些数据。要在图中隐藏已排除的观测值，您必须为它们指定隐藏/撤消隐藏特征。
  • 在行号或列面板中的列名旁边将显示一个带删除线的圆圈 ( [image])，表明该行或列已被排除且不会用于任何分析中。
  • 数据将一直被排除，直到您再次选择排除/撤消排除。

要将数据从分析中排除，请执行以下操作：

  1. 高亮度显示要排除的行或列。
  2. 要排除行，请从以下某个位置选择排除/撤消排除，如"访问行特征命令的不同方法" 所示：
    • 主菜单中的行菜单
    • 行面板中的红色三角形图标
    • 数据网格左下角的红色三角形图标
访问行特征命令的不同方法
要排除列，请从以下某个位置选择排除/撤消排除，如"访问列特征命令的不同方法" 所示：
  • 主菜单中的列菜单
  • 列面板中的红色三角形图标
  • 数据网格右上角的红色三角形图标
访问列特征命令的不同方法

隐藏行和列

如果标记了行和列以将它们隐藏，则：

  • 您可以消除（隐藏）行和列，以便将其包含在分析中，但不在图形中显示。
  • 要将已隐藏的观测值从分析中排除，您还必须为它们指定排除/撤消排除特征。
  • 在已隐藏的行号或列名旁边将显示一个面具图标 ( [image])，表明该行或列已被隐藏。
  • 数据将一直被隐藏，直到您再次选择隐藏/撤消隐藏。

要隐藏数据，请执行以下操作：

  1. 高亮度显示要隐藏的行或列。
  2. 要隐藏行，请从以下某个位置选择隐藏/撤消隐藏，如"访问行特征命令的不同方法" 所示：
    • 主菜单中的行菜单
    • 行面板中的红色三角形图标
    • 数据网格左下角的红色三角形图标
访问行特征命令的不同方法
要隐藏列，请从以下某个位置选择隐藏/撤消隐藏，如"访问列特征命令的不同方法" 所示：
  • 主菜单中的列菜单
  • 列面板中的红色三角形图标
  • 数据网格右上角的红色三角形图标
访问列特征命令的不同方法

标记行和列

如果将箭头光标置于图中的某个点上，屏幕将出现该点的标签。默认情况下，显示的标签为行号。自定义标签的方式有两种：

  • 您可以更改标签，以便显示一列或多列中找到的值，而并非显示行号。
  • 您可以让标签始终显示，而不只是将光标置于点上时才显示。

要更改标签以显示一列或多列中找到的值，而并非显示行号，请执行以下操作：

  1. 高亮度显示要作为标签在图中显示值的列。
  2. 从以下某个位置选择标记/撤消标记，如"访问列特征命令的不同方法" 所示：
    • 主菜单中的列菜单
    • 列面板中的红色三角形图标
    • 数据网格右上角的红色三角形图标
访问列特征命令的不同方法

列面板中的列名旁边将显示标签或黄色标签图标 ( [image])，表明图中的点将由列值标识。如果有多个已标记的列，它们的值在图中将以逗号分隔。数据将一直被标记，直到您再次高亮度显示该列并选择标记/撤消标记。

要始终显示标签而不只是在将光标置于点上时显示，请执行以下操作：

  1. 高亮度显示要在图中始终显示其标签的行。
  2. 从以下某个位置选择标记/撤消标记，如"访问行特征命令的不同方法" 所示：
    • 主菜单中的行菜单
    • 行面板中的红色三角形图标
    • 数据网格左下角的红色三角形图标
访问行特征命令的不同方法

为行指定颜色

您可以为高亮度显示的行指定任何颜色，以便图中的点显示为所选择的颜色。当前为行指定的颜色将显示在数据网格中行号的旁边。

  1. 高亮度显示要为其指定颜色的行。
  2. 从以下某个位置选择颜色，如"访问行特征命令的不同方法" 所示：
    • 主菜单中的行菜单
    • 行面板中的红色三角形图标
    • 数据网格左下角的红色三角形图标
访问行特征命令的不同方法
  3. 从出现的选项中选择一种颜色，如"可选择的颜色" 所示。
可选择的颜色

为行添加标记

您可以从 JMP 标记选项板中指定符号，以替换图中的标准点。此外，这些标记还会显示在数据表中行号的旁边。

  1. 高亮度显示要为其指定新标记的行。
  2. 从以下某个位置选择标记，如"访问行特征命令的不同方法" 所示：
    • 主菜单中的行菜单
    • 行面板中的红色三角形图标
    • 数据网格左下角的红色三角形图标
访问行特征命令的不同方法
  3. 从出现的选项中选择一种标记形状，如"可选择的标记形状" 所示。
可选择的标记形状

根据列值为行指定颜色或标记

根据特定列中的值，您可以为数据表中的每一行指定不同的颜色或标记。例如，JMP 可以为性别列中所有值为 F 的行指定红色方形标记，并为所有值为 M 的行指定绿色加号标记。这些颜色和标记将替换图形中的默认黑点，同时在数据网格中显示在行号的旁边。

  1. 从以下某个位置选择按列设定颜色或标记，如"访问行特征命令的不同方法" 所示：
    • 主菜单栏中的行菜单
    • 行面板中的红色三角形图标
    • 数据网格左下角的红色三角形图标
访问行特征命令的不同方法
  2. 高亮度显示要为其指定颜色或标记的列，如"按列设定颜色或标记" 所示。
按列设定颜色或标记
  3. 选择以下任意项：
    操作 | 说明
    根据高亮度显示的列中的值为数据表中的每一行指定不同的颜色 | 单击按值设定颜色旁边的框。
    根据高亮度显示的列中的值为数据表中的每一行指定不同的标记 | 单击按值设定标记旁边的框。
    为新特征附带一个图例，以便轻松确定颜色和标记所对应的行 | 单击生成具有图例的窗口旁边的框。
    根据高亮度显示的列中的值按颜色顺序分配颜色。 | 单击连续尺度旁边的框。

删除所有行特征

要清除数据表中的所有行状态，请高亮度显示行并选择行 > 清除行状态。所有的行都将变为已包含、显示、撤消标记状态，同时在图中以黑点显示。选择行 > 清除行状态不会影响已在行状态列中所保存的行状态，如"使用行状态列" 所述。

原位锁定列

您可以将列锁定在原位，以便在水平滚动时仍可以看到该列。已被锁定列的名称将在数据网格左侧的列面板中以斜体显示。

要对列应用滚动锁定，请执行以下操作：

  1. 高亮度显示要锁定在原位的列。请注意，隐藏的列无法被锁定。
  2. 从以下某个位置选择列 > 滚动锁定/撤消锁定，如"应用滚动锁定的不同方法" 所示：
    • 主菜单栏中的列菜单
    • 列面板中的红色三角形图标
    • 数据网格右上角的红色三角形图标
应用滚动锁定的不同方法

为列指定预选定的分析角色

您可以为选定的列指定分析角色，如 x、y、权重或频数，同时在数据表中保存角色。在执行此操作并运行分析时，JMP 会将预选定的角色自动填写至角色框中，因此您不需要每次都指定这些角色。例如，在对特定数据表执行的每次分析中，如果要让名为身高的列作为 x 角色，则您可以为其指定预选定的 x 角色。

请注意，在选择频数时，JMP 会将该列中的值用作观测值的频数。如果 n 是指定行的频数变量值，则该行将在计算中使用 n 次。如果 n 并非整数，则 JMP 将取其整数。如果 n 小于 1 或缺失，则 JMP 不会使用它来计算任何分析。

如果选择了权重，该列中的值将为数据表中的每个观测值提供权重。此变量不一定为整数，但只有当其值大于 0 时才会应用到分析中。

要为列指定预先选定的角色，请执行以下操作：

  1. 高亮度显示列。
  2. 选择列 > 预选择角色，如"选择预选择角色" 所示。
选择预选择角色
  3. 选择角色：无角色、X、Y、权重或频数。

在选择相应的角色后，列面板中的图标将指明为列指定了何种角色，如"列面板" 所示。单击图标以访问角色列表，然后选择其它角色。

列面板

图标指示器

在指定特征后，数据网格上将显示图标，用于表明为某些行或列指定的特征。图标将显示在列面板中每个列名的右侧，以及数据表中行号的左侧，如"表示特征的元素" 所示。您可以单击每个列名右侧的某些图标，以便显示其内容。

表示特征的元素


为列指定性质

除了"为行和列指定特征"中介绍的列特征之外，列还可以包含某些特殊的列性质，如文档注释、用于计算列值的公式以及对值的约束等。

在为列添加性质后，数据表的列面板中将显示性质图标 ( [image])，表明该列包含一个性质。但是，在对列应用公式、范围检查以及列表检查时，屏幕将显示它们各自的图标。如果列仅包含注释性质，或者根本就没有性质，则性质图标 ( [image]) 将不会显示（"表示性质的元素"）。

表示性质的元素

以下部分介绍了可以为列添加的性质。

为列指定用于计算值的公式

您可以在列中插入公式，用以计算该列的值。一旦执行此操作，该列将被锁定，您将无法手动编辑其数据值（这样可以防止公式失效）。

要创建用于计算列值的公式，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择公式，如"从列性质列表中选择公式" 所示。
从列性质列表中选择公式
  3. 单击编辑公式按钮。
  4. 完成公式（有关详情，请参阅"创建公式"）。锁定旁边的框将被选中，如"从列性质列表中选择公式" 所示，表明您将无法编辑数据表中该列的值。（要编辑列值，您必须首先删除公式。）
  5. 如果不希望 JMP 计算公式，请单击屏蔽计算旁边的框。在公式计算被屏蔽时，列面板中列名旁边的黄色加号图标（Macintosh 中为黑色）将部分变灰（有关详情，请参阅"图标指示器"）。
  6. 如果不希望 JMP 提醒公式中的任何错误，请单击忽略错误旁边的框。
  7. 单击确定。此时，数据表列面板中的列名旁边将显示公式图标 ( [image])，表明该列包含一个公式。单击图标可编辑公式。

锁定列

您可以锁定列，从而禁止编辑列中的值。在锁定列之后，数据表列面板中的列名旁边将显示锁定图标 ( [image])。

请注意，如果添加了公式，列会被自动锁定。但锁定图标 ( [image]) 不会显示在列面板中的列名旁边。取而代之，屏幕将显示公式图标 ( [image])，表明该列包含一个公式。

要锁定列，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 单击锁定旁边的框，如"从列性质列表中选择公式" 所示。
锁定一列
  3. 单击确定。

为列添加注释

就象采用表变量的形式为数据表添加注释一样，您也可以采用列性质的形式为单个列添加注释。例如，您要为数据表中的一列或多列记录或保留注释，如数据来源说明。

要为列添加注释，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择注释。
  3. 在文本框中键入内容，如"添加列注释" 所示。
添加列注释
  4. 单击确定。

验证列数据

您可以设置一个只接受某些特定值的列。这些值可以是单个数值（列表检查），也可以是某个范围内的所有数值（范围检查）。以下部分介绍了两种类型的列验证。

列表检查

您可以设置一个列，使其仅包含所指定的某些单个值。例如，您可以设置一个仅包含数值 2、4 或 6 的列。在执行此操作时，光标被置于列上时将变为 [image] 。如果尝试输入验证列表之外的值，屏幕将显示一则警告消息。如果使用鼠标右键单击某个单元格（Macintosh 中为按住 Ctrl 键并单击），则屏幕将显示可接受值的菜单。随后，您可以从菜单中选择单元格值，而无需在单元格中键入。

在通过制图按某种方式对数据排序时，列表检查也十分有用。例如，直方图的条形柱在默认情况下会按字母顺序排列。要以不同的顺序显示条形柱，请创建一个列表检查，您可以在其中按新的顺序输入值。这些值随后将以该顺序在输出报表中显示，而不是以默认顺序显示。（请注意，列表检查不适用于条形图。）

在列被锁定后，数据表列面板中的列名旁边将显示 [image] 图标。

要设置列表检查，请执行以下操作：

  1. 高亮度显示要应用验证的列。
  2. 通过执行以下某项操作可以访问列表检查信息：
    • 双击数据网格中的列名。此时将出现“列信息”窗口。从列性质下拉菜单中选择列表检查，如"选择“列表检查”作为新性质" 所示。
    • 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）列名，然后选择验证 > 列表检查。此时将显示"“列表检查”窗口" 中的窗口。
    • 选择列 > 验证 > 列表检查。此时将显示"“列表检查”窗口" 中的窗口。
选择“列表检查”作为新性质
“列表检查”窗口
  3. 窗口中的列表包含 JMP 可以接受的值。按照下表中的说明可以更改这些值：
    操作 | 说明
    从列表删除值 | 高亮度显示值，然后单击移除按钮。
    向列表添加值 | 在空文本框中键入值，然后单击添加。
    将高亮度显示的数值移动至列表中的其它位置 | 单击向上移动和向下移动按钮。请记住，值在列表中的显示顺序将作为它们在分析报表中的显示顺序。
  4. 单击确定。此时，数据表列面板中的列名旁边将显示 [image] 图标，表明该列包含一个列表检查。单击图标可对列表检查进行更改。

范围检查

您可以设置一个列，使其仅包含某个数值范围内的值。在执行此操作时，光标被置于列上时将变为复选标记 ( [image])。如果尝试输入验证范围之外的值，屏幕将显示一个窗口，提示您更改单元格的值。

要设置范围检查，请执行以下操作：

  1. 高亮度显示要应用验证的列。
  2. 通过执行以下某项操作可以访问范围检查信息：
    • 双击数据网格中的列名。此时将出现“列信息”窗口。从列性质下拉菜单中选择范围检查，如"选择“范围检查”作为列性质" 所示。
    • 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）列名，然后选择验证 > 范围检查。此时将显示"“范围检查”窗口" 中的窗口。
    • 选择列 > 验证 > 范围检查。此时将显示"“范围检查”窗口" 中的窗口。
选择“范围检查”作为列性质
“范围检查”窗口
  3. 在 a 旁边的框中键入列可以接受的最小值。
  4. 在 b 旁边的框中键入列可以接受的最大值。
  5. 选择要在范围设置中使用的公式。请记住，x 是输入列中的值，a 是范围的起始值，b 是范围的终止值。对于单方向范围检查，请将 a 或 b 留空。
  6. 单击确定。此时，数据表列面板的列名旁边将显示 I 型光标 ( [image])，表明该列包含一个范围检查。单击图标可对范围检查进行更改。

关闭列表/范围检查

要关闭列表或范围检查，请执行以下操作：

  1. 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）列名。
  2. 选择验证 > 不检查。

使用值标签

值标签将允许您在每次出现该值时显示一个标签而并非一个值。如果指定了值标签，数据表中将显示标签而并非原始值，但原始值并未丢失。通过双击标签可以显示原始值。

另请注意：

  • 如果数据表包含值标签，使用搜索命令可以搜索实际值，但无法搜索标签。
  • 如果数据表包含值标签，行编辑器将显示标签，而在高亮度显示单元格以进行编辑时，行编辑器将显示实际值。
  • 如果要复制和粘贴带值标签的单元格，系统将粘贴实际值。

要设置值标签，请执行以下操作：

  1. 在数据表中找到要应用值标签的列，然后双击列名上方的区域。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择值标签，如"选择“值标签”作为新性质" 所示。
选择“值标签”作为新性质
  3. 在值文本框中键入要指定标签的值。
  4. 在标签文本框中键入要作为标签显示的内容。
  5. 单击添加。
  6. 要创建更多值标签，请重复以上步骤。
  7. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

要关闭值标签而不删除已设置的内容，请撤消选定使用值标签旁边的复选框。

要编辑现有的值标签，请执行以下操作：

  1. 在数据表中找到要应用值标签的列，然后双击列名上方的区域。此时将出现“列信息”窗口。
  2. 在当前性质框中高亮度显示值标签。
  3. 高亮度显示要编辑的值标签。
  4. 要编辑其值，请在值框中输入新的值，然后单击更改。
    要编辑其标签，请在标签框中输入新标签，然后单击更改。高亮度显示的值标签位置将出现新值和/或新标签。
  5. 完成时单击确定。

对列中的值排序

JMP 报表中的分类值可能没有按您所希望的顺序显示。例如，您可能需要从小到大排列年龄（"JMP 默认顺序报表（左）和值的排序性质报表（右）" 右侧部分），而不是从大到小显示年龄（"JMP 默认顺序报表（左）和值的排序性质报表（右）" 左侧部分）。要实现此操作，请使用“值的排序”列性质。

JMP 默认顺序报表（左）和值的排序性质报表（右）

要为列指定“值的排序”性质，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择值的排序。值的排序信息将出现在右侧，如"“值的排序”窗口" 所示。
“值的排序”窗口
  3. 窗口中的列表所包含值的显示顺序，也是 JMP 在报表中显示这些值的顺序。按照下表中的说明可以更改值的顺序：
    操作 | 说明
    从列表删除值 | 高亮度显示值，然后单击移除按钮。
    向列表添加值 | 在空文本框中键入值，然后单击添加。
    将高亮度显示的数值移动至列表中的其它位置 | 单击向上移动和向下移动按钮。请记住，值在列表中的显示顺序将作为它们在分析报表中的显示顺序。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

注：如果同时使用了“值的排序”和“行顺序水平”性质，则前者较后者优先。

如果包含以下任何值，在报表中这些值将以相应的顺序自动显示。您不需要为它们的列指定“值排序”性质。

  • 一月、二月、三月、四月、五月、六月、七月、八月、九月、十月、十一月、十二月
  • 一、二、三、四、五、六、七、八、九、十、十一、十二
  • 星期日、星期一、星期二、星期三、星期四、星期五、星期六
  • 极低、低、中低、中、中高、高、极高
  • 完全不同意、不同意、中立、无关紧要、同意、完全同意
  • 失败、不可接受、很差、差、较差、可接受、平均、好、较好、非常好、最佳

指定值的颜色范围

在马赛克图中，记名值和保序值将以颜色显示。在其它附有显示图例的图中，值将以颜色标记。您可以为记名列或保序列中的值指定某种颜色或颜色渐变范围。一旦执行此操作，所有适用的图形中都将以指定的颜色显示列中的值。

要为列中的值指定颜色，请执行以下操作：

  1. 在数据表中高亮度显示记名列或保序列。
  2. 选择列 > 列信息。此时将出现“列信息”窗口。
  3. 从列性质下拉菜单中选择值的颜色。值的颜色信息将出现在右侧，如"“值的颜色”框" 所示。
“值的颜色”框
  4. 要更改颜色，请使用鼠标右键单击右侧的彩色圆，然后选择一种颜色。
  5. 使用“宏”按钮执行以下操作：
    • 终值间的梯度 设置顶部值和底部值的颜色，以便 JMP 可以对整个值范围应用颜色梯度。使用此命令使其它水平的所有颜色都处于中间位置。
    • 选定点间的梯度 设置顶部值和底部值的颜色，以便 JMP 可以对您在“值的颜色”列表中高亮度显示的值范围应用颜色梯度。
  6. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

更改列的默认轴设置

您可以为列指定默认的轴设置，以便只要将该列用于分析中时，JMP 都可以自动使用指定的设置。这些设置包括最小值和最大值、增量数、刻度标记数等。

要指定默认的轴设置，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择轴。轴信息将出现在右侧，如"“轴”框" 所示。
“轴”框
  3. 按照下表中的说明可以指定轴性质：
    操作 | 说明
    更改尺度类型（线性或对数） | 单击尺度类型旁边的下拉菜单，然后选择线性或对数。
    设定要在图形中显示的最小值和最大值。 | 在最小值和最大值旁边的框中键入值。
    指定图形中的增量数 | 在增量旁边的框中键入值。
    指定图形中的副刻度标记数。 | 在副刻度旁边的框中键入值。然后单击显示副刻度旁边的框。
    查看主刻度、主网格、副网格和标签 | 单击显示主刻度、显示副刻度、显示主网格、显示副网格以及显示标签旁边的框。
    在 x 轴上垂直而不是水平显示标签 | 单击旋转标签旁边的框。
    在图形上最多添加四条参考线 | 在参考线下方的框中为每条参考线键入一个值，在图形指定位置处将最多显示四条参考线。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

为列设定默认轴性质的另一种方法：

  1. 创建图形。
  2. 将坐标轴更改为所需的规格（请参阅"自定义轴和轴标签"）。
  3. 使用鼠标右键单击轴，然后选择保存至列性质。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

定义列的低值和高值（试验设计编码）

在模型中拟合列时，列的下限值和上限值将变换为 -1 和 1，这样将使检验和参数估计更具意义。此过程称为编码并可用于任何连续变量。它是 JMP 中由试验设计命令所生成的连续因子的默认值。请注意，如果某个列缺失了一个或多个界限，JMP 将用数据的最小值和最大值替换上限值和下限值。

要指定在列中使用的下限值和上限值，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择编码。编码信息将出现在右侧，如"“编码”窗口" 所示。
“编码”窗口
  3. 在文本框内键入所需的下限值和上限值。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

为混料试验将列设定为因子

您的数据表中可以包含一列，以作为构成 100% 混料的某个因子。您可以设置一个这样的列，以便在分析数据时，JMP 能够使用该列自动生成无截距模型（使用“模型拟合”命令）。

请注意，在为混料试验将列设定为因子后，数据表列面板中的列名旁边将显示性质图标 ( [image])，表明该列包含某个性质。

要设置此列，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择混料。混料信息将出现在右侧，如"“混料”信息" 所示。
“混料”信息
  3. 输入上限和下限以及项总和。

  4. 根据需要选定 L 伪分量编码和 U 伪分量编码旁边的复选框。使用"“混料”信息" 中的实例，其中混料总和值为 1，项将被编码为：
XiL = (Xi - Li)/(1 - L)，用于 L 伪分量
XiU = (Ui - Xi)/(U - 1)，用于 U 伪分量
其中 Li 和 Ui 为下限和上限，L 是 Li 的总和，U 是 Ui 的总和。如果您在此实例中同时选定两个复选框，若 (1 - L) < (U - 1)，“模型拟合”平台将使用 L 编码，否则将使用 U 编码。
在“模型拟合”报表中，主效应被标记为编码转换。交叉效应没有标记，但会使用编码值。所有拟合功能（如刻画器和保存的公式）均会考虑伪分量编码，但只会在表和图形中显示未编码的值。
  5. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

指定行在分析报表中的显示方式

默认情况下，分析报表中的行数据将按数据值排序。但是，如果要以数据表列中的顺序查看分析报表中的行数据，则可以更改其默认设置。

要指定行的显示方式，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择行顺序水平，如"指定行顺序水平" 所示。行顺序水平复选框将出现在右侧。
指定行顺序水平
  3. 确保选定行顺序水平旁边的复选框。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。
  5. 请记住，以上步骤中的操作只会应用于选定的列。要将其应用于其它的列，请对每个列重复上面的步骤，或者使用"在列间标准化属性和性质"中介绍的“标准化属性”命令。

    提示：如果要让列在分析报表中按其它顺序显示（除了按它们的值或在数据表列中的显示顺序之外），则可以使用值的排序性质。有关详情，请参阅"对列中的值排序"。如果同时启用了“值的排序”和“行顺序水平”性质，则前者较后者优先。

输入规格限、控制限和响应限

您可以在列中保存规格限、控制限和响应限。如果执行了此操作，您可以运行性能分析、控制图分析或显示预测及等高线刻画器的分析，而无需每次都重新指定角色和约束。在列中保存这些响应限将有助于确保一致性。例如，如果要运行应用这些约束的分析，并在之后更改数据，则可以使用相同的约束对新数据运行新的分析。

要输入规格限、控制限和响应限，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择以下某个选项，如"新性质列表" 所示。
新性质列表
    • 规格限 允许您为数值列输入规格下限、规格上限和目标值。在为列指定这些值时，JMP 会在您运行性能分析（此类分析在选择分析 > 分布之后运行）时自动使用这些值，如"使用列中的规格限进行性能分析" 所示。
使用列中的规格限进行性能分析
    • 控制限 允许您选择某种控制图类型，然后再输入要在每个图表中用作平均值（平均数）、控制下限 (LCL) 和控制上限 (UCL) 的值。这些值将随列一起保存，并会在使用图形 > 控制图运行分析时自动应用。
    • 响应限 允许您定义用于分析的响应列值，如那些显示预测和等高线刻画器或试验设计。您可以指定下限、中间值、上限以及意愿值，如"定义响应列值" 所示。您也可以选择最大化，匹配目标值、最小化或无，这些都是试验设计响应变量可能的目标。如果存在两个响应，则可以输入一个重要值，以便让 JMP 了解如何衡量两个响应之间的重要性。
定义响应列值
  3. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

为列指定设计角色

您可以告诉 JMP 如何在模型中使用因子列来设计试验 — 将因子列用作连续、分类、区组、协变量、混料、常数、信号或噪声因子。

要为列指定设计角色，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择设计角色，如"选择设计角色" 所示。设计角色信息将出现在右侧。
选择设计角色
  3. 单击“设计角色”下拉菜单，然后选择您希望 JMP 使用因子列的方式：连续、分类、区组、协变量、混料、常数、信号、噪声、不受控或随机区组。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

标识因子变化

要使用 JMP 的 DOE（试验设计）命令创建裂区设计，您必须将因子标识为“困难”，即因子将很难被更改。每次设计试验时都可以在“试验设计”的设计面板中将因子标识为“困难”（有关详情，请参阅《JMP 试验设计》试验设计中的 "创建裂区设计"）。但是，如果每次都要使用某个因子来创建裂区设计，则可以将该因子在所有试验中都设置为“困难”：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择因子变化，如"选择因子变化" 所示。因子变化信息将出现在右侧。
选择因子变化
  3. 单击“因子变化”下拉菜单并选择您要 JMP 使用该因子列的方式：易或难。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

为列指定 Sigma 值

您可以输入要与应用程序将使用的列同时保存的已知 Sigma，例如需要 Sigma 值来完成计算的控制图。如果没有提供值，则可以通过样本计算得出 Sigma 值。

要为 Sigma 指定一个值，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择 Sigma。
  3. 在"“Sigma”窗口" 所示的文本框中键入要用作 Sigma 的值。
“Sigma”窗口
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

指定列的测量单位

JMP 允许您在列中指定用于收集数据的度量单位。例如，您可能需要一列来指明年龄值以月为单位，或者指明货币价值以千美元为单位。

要为列添加此信息，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择单位。
  3. 在"“单位”窗口" 所示的文本框中键入要使用的度量单位。
“单位”窗口
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

创建自己的列性质

您可以创建自己的列性质并为其指定任意名称。此类性质随后可用于 JSL 编程。

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择其它。
  3. 键入新性质的名称。
  4. 输入性质值。


移除性质

您可以随时添加或删除列性质。要删除性质，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从当前性质下拉菜单中选择性质，然后单击移除，如"移除性质" 所示。
移除性质


在列间标准化属性和性质

当列包含了想让其它列也具有的属性（数据类型、建模类型、数字格式等）或性质（公式、注释、列表检查和范围检查等）时，可使用现有列来标准化列间的属性和性质。其中同时包括了添加/删除属性和性质。

添加属性和性质

要将现有列的属性和性质应用于多个列，请执行以下操作：

  1. 选择包含所需属性或性质的列。
  2. 选择列 > 标准化属性。此时将显示"在列间使属性标准化" 中的窗口。
  3. 单击属性按钮（"在列间使属性标准化"），然后选择要在列间复制的项。
在列间使属性标准化
  4. 要更改任何属性的值，请使用属性信息区中的下拉菜单和文本框。
  5. 单击“标准化性质”区域中的列性质按钮，然后再设置要让其它列具有的性质，如"在列间使性质标准化" 所示。
在列间使性质标准化
  6. 单击切换出“标准化列属性”窗口，同时转至数据表。
  7. 在数据表中，高亮度显示要应用其属性和性质的列。
  8. 单击返回“标准化列属性”窗口，然后单击应用。属性和性质将应用于数据表中所有选定的列。您可以查看具体的结果。
  9. 单击确定。

    提示：如果要应用更改的那些列位于包含属性或性质的列的右侧，则需要同时高亮度显示二者并跳过上面的步骤 6 和 7。JMP 将使用最左侧的列作为包含所需属性的列，并将其应用于其它高亮度显示的列。

删除性质

要在多个列间删除相同的性质，请执行以下操作：

  1. 选择包含要删除的属性或性质的列。
  2. 选择列 > 标准化属性。
  3. 单击“删除性质”区域中的列性质按钮，然后选择要删除的性质。
  4. 单击确定。


使用行状态列

您可以创建仅包含行状态信息的列，其中存储了关于行是否被排除、隐藏、标记、着色或标注的信息（有关详情，请参阅"为行和列指定特征"）。该列有自己的数据类型，但没有建模类型，因为它的值并不用于分析。

行状态列的使用分为两个步骤。第一步为设置列。然后，可以根据需要为该列添加值作为数值数据或字符数据。以下部分介绍了如何完成这些步骤。

第 1 步：设置行状态列

  1. 通过双击空列顶部或选择列 > 新建列来创建一个新的列。
  2. 如果双击创建了新的列，请再次双击列名。
  3. 在出现的窗口中单击数据类型菜单，然后选择行状态，如"为列的数据类型选择行状态" 所示。
为列的数据类型选择行状态
  4. 单击确定。
  5. 按照"第 2 步：为行状态列添加值"中的步骤为列添加或复制值。

第 2 步：为行状态列添加值

在设置行状态列后，在该列的单元格中填写新信息或已有的行状态信息。有两种方法可实现此操作：为行状态列创建行状态特征，或者将现有的行状态信息复制到列中。以下部分介绍了这两种方法。

要为行状态列创建行状态特征，请执行以下操作：

  1. 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）行状态列名。
  2. 选择行状态单元格。此时将出现子菜单。
  3. 选择要应用于列中所有行的特征。
将行状态特征应用于整个行状态列

要将现有的行状态信息复制到列中以填写行状态列，请执行以下操作：

  1. 要只填写行状态列中的某些特定行，请高亮度显示那些行。要填写列中所有的行，请高亮度显示行状态列。
  2. 单击列面板（数据网格左侧）中列名旁边的星形图标 ( [image])。此时将出现如"行状态列和行状态条件" 所示的下拉菜单。
行状态列和行状态条件
  3. 选择以下选项之一：
    • 从行状态复制 将特征从行号区域复制到行状态列，替换该列中现有的行状态值。
    • 从行状态添加 将特征从行号区域添加到行状态列，保留该列中的现有行状态值。
    • 复制至行状态 将特征从行状态列复制到行号区域，替换现有的活动行状态。
    • 添加至行状态 将特征从行状态列添加到行号区域，保留现有的活动行状态。

永久高亮度显示单元格

与保存其它行状态特征（隐藏、排除、着色等）一样，您可以在行状态列中保存高亮度显示。这样，您便可以“永久”高亮度显示单元格。请执行以下操作：

  1. 使用鼠标右键单击单元格并选择行状态单元格 > 选择/撤消选择。
  2. 重复此操作可以高亮度显示任意数量的单元格。
  3. 要删除高亮度显示，请使用鼠标右键单击 (Windows) 或按住 Ctrl 键并单击 (Macintosh) 单元格，然后选择行状态单元格 > 选择/撤消选择。


使用输出报表

如何使用报表窗口

所有分析都会生成报表窗口，如下所示。

报表同时包含文本报表和图形。这些报表在设计时考虑了方便性，体现在几个方面：

  • 可调整单个图的大小并可打开和关闭文本报表，以优化屏幕空间（请参阅"调整图和图形大小"和"显示和隐藏报表的各个部分"）。
  • 可打印图和文本报表（请参阅"打印报表"）。
  • 可通过问号工具访问上下文相关帮助。选择后，可单击报表中的任何位置（请参阅"了解 JMP"）。
  • 可将报表的全部或部分复制到其它应用程序，如 Microsoft Word（请参阅"将报表粘贴到其它程序"和"将报表粘贴到其它程序"）。

本章说明了 JMP 中所有报表的共同功能。

目录

编辑报表

访问常规报表格式选项

显示和隐藏报表的各个部分

重命名报表

增大字体

将结果保存为列值

从报表编辑数据表行

了解 p 值指标

打印报表

将报表粘贴到其它程序

添加选项和运行分析

如何访问分析选项

重新运行分析

将步骤保存为脚本

格式化报表

行重新排序（排序）

显示和隐藏列

添加外框和边框

更改数值格式和字段宽度

更改表名称和列标题

将报表转换为数据表

将报表转换为矩阵

选择图中的点

在图、图表和图形中选择行和列

选择矩形区域的点

选择不规则形状区域的点

使用标记

更改标记形状

更改标记颜色

更改标记大小

更改标记绘制模式和透明度

在标记周围添加外框

指定标记透明度

排除和隐藏标记

向标记添加标签

根据值更改标记形状或颜色

移除图例

更改图外观和图表外观

调整图和图形大小

放大和缩小

更改线宽

更改背景颜色或直方图条形柱颜色

显示轴坐标

滚动和缩放轴

自定义轴和轴标签

更改值的顺序

自定义刻度标记和刻度标记标签

添加参考线

向报表中添加元素

添加注释

添加形状

添加图形（仅适用于 Windows 和 Macintosh）


编辑报表

JMP 报表显示在标准窗口中，具有滚动条和用来调整大小的选项。窗口还有如"报表窗口的基本元素" 所示的其它特殊按钮和菜单以及以下部分介绍的按钮和菜单。

报表窗口的基本元素

请注意，通过手形工具（也称为抓手工具： ）可使用报表中的许多功能。以下是手在图形和图中的操作方式的一些实例：

  • 使用手形工具可更改坐标轴值的显示范围：
    • 在 y 轴上，拖动 [image] 或 [image] 缩放 y 轴；拖动 [image] 滚动 y 轴。
    • 在 x 轴上，拖动 [image] 滚动 x 轴；拖动 [image] 或 [image] 缩放 x 轴。
  • 在直方图中，使用手形工具可更改条形柱的数目或移动条形柱的边界。
  • 在旋转图和曲面图中，单击并拖动手形工具可旋转该图。要调整旋转速度，请在拖动手形工具的地方加快速度。或者，在按住 Shift-Alt（在 Linux 中为 Ctrl-Alt）组合键的同时，单击并拖动出现的圆圈（此大圆圈将减慢图形的旋转速度）。
  • 在所有报表中，使用手形工具单击并拖动列以重新排列。

访问常规报表格式选项

使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）展开按钮（在 Windows/Linux 中为 [image] ，在 Macintosh 中为 [image] ）以显示菜单，此菜单让您可以重新排列报表和控制报表外框层。有关实例，请参阅"展开按钮后的菜单" 中的菜单。

展开按钮后的菜单

显示的菜单具有以下报表格式选项：

  • 关闭 关闭（隐藏）报表的该部分。这也可通过单击展开按钮（在 Windows/Linux 中为 [image] ，在 Macintosh 中为 [image] ）来实现。
  • 水平 （如果可用）水平对齐后续的低外框层。默认情况下，大多数报表都按外框层排列，垂直显示缩进外框层。
  • 打开以下所有项 打开选择此命令所在外框层之下的所有外框层，包括该层。
  • 关闭以下所有项 关闭选择此命令所在外框层之下的所有外框层，包括该层。
  • 打开与此类似的所有项 打开与分析窗口中的报表类型相同的所有报表。如果一次分析几个变量或在一次分析中选择多个选项，通常会有许多类型相同的报表，并且要一次全部打开或关闭。
  • 关闭与此类似的所有项 关闭与分析窗口中的报表类型相同的所有报表。
  • 关闭无外框项 关闭没有子层的报表的所有部分。此命令通常用于报表外框的顶层。这是查看报表嵌套结构概览的一种快捷方式。
  • 附加项 显示一个子菜单，其中列出了您可向报表添加结构项的方式。这些项包括文本、外框标题栏、其它 JMP 文件和窗口的引用信息、所有打开 JMP 文件的列表以及 URL。
  • 编辑 显示如"展开按钮后的菜单" 所示的子菜单，该子菜单将影响所在外框层的所有报表：
    • 选择 高亮度显示该外框层的所有报表。
    • 撤消选择 撤消选择该外框层的所有选定报表。
    • 日志 将报表复制到标题为日志的独立窗口中，以便编辑它或向其附加其它报表（有关详情，请参阅"使用日志命令保存"）。
    • 复制图片 将报表复制到剪贴板。然后，您可以打开其它应用程序并粘贴它。
    • 分页 插入分页符，便于打印。

访问这些选项的另一种方法是按住 Alt 键并使用鼠标右键单击（在 Macintosh 中为按住 Ctrl-Option 组合键并单击，在 Linux 中为按住 Ctrl-Alt 组合键并使用鼠标右键单击）展开按钮（在 Windows/Linux 中为 [image] ，在 Macintosh 中为 [image] ）。这将显示一个如"窗口中的菜单项" 所示的窗口，该窗口带有命令和选项的复选框，可用来同时选择多项操作。您也可对红色三角形图标下面的菜单执行相同的操作。

窗口中的菜单项

显示和隐藏报表的各个部分

JMP 报表按层次外框组织。在 Windows 或 Linux 操作系统中，每个外框层都有一个蓝色箭头形展开按钮 ( [image])。在 Macintosh 中，每个外框层都有一个灰色箭头形展开按钮 ( [image])。

要使用展开按钮，请单击该展开按钮来打开和关闭报表的该部分。在"打开（左）和关闭（右）了某个部分的报表" 中，左边的报表打开了“整体模型检验”，而右边的报表则关闭了它。

打开（左）和关闭（右）了某个部分的报表

重命名报表

要更改显示在报表顶部的标题或名称，请执行以下操作：

  1. 双击报表标题。此时光标将变成一条闪烁的文本插入线。
  2. 编辑此标题。

增大字体

在 Windows 和 Linux 中，请通过选择窗口 > 字体大小快速更改 JMP 在报表和数据表中使用的字体大小。然后选择其中一个子菜单项：

  • 增大字体 增大字体。再次选择可再次增大字体。
  • 减小字体 减小字体。再次选择可再次减小字体。

将结果保存为列值

某些报表具有将结果的各个部分保存为对应数据表中的新列的选项。要添加此新列，请执行以下操作：

  1. 在运行分析并取得报表后，请单击报表标题左边的红色三角形图标。
  2. 从出现的下拉菜单中，选择保存选项（如果可用）。
  3. 选择要保存为对应数据表中的新列的部分。有关详情，请参阅"保存报表"。

从报表编辑数据表行

要从报表图形逐行浏览或编辑各个值，请执行以下操作：

  1. 高亮度显示报表中的某个点。
  2. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。
  3. 选择行编辑器。
  4. 当行编辑器出现时，它将显示有关第一个选定行的信息。
  5. 编辑数据。
  6. 单击箭头按钮，浏览选定行或整个数据集。 "行编辑器" 显示了每个按钮的功能。
行编辑器
  7. 单击行编辑器中的红色三角形图标，访问以下选项：
    • 下一选定项 提供与 [image] 按钮相同的功能， 即显示有关当前行之后的选定行的信息。
    • 上一选定项 提供与 [image] 按钮相同的功能， 即显示有关当前行之前的选定行的信息。
    • 下一项 提供与 [image] 按钮相同的功能， 即显示有关当前行之后那行的信息（不管该行是否选定）。
    • 上一项 提供与 [image] 按钮相同的功能， 即显示有关当前行之前那行的信息（不管该行是否选定）。
    • 保存 保存数据表和通过行编辑器对其进行的任何更改。
    • 新建行 在数据表中创建一个新行。
    • 查找 提供与 [image] 按钮相同的功能， 即显示选择行 > 行选择 > 选择位置时显示的同一窗口。单击当前选定行下要使用的选项，然后高亮度显示要选择其行的列。键入要 JMP 搜索的值。有关详情，请参阅"选择具有特定值的单元格"。
    • 闪烁 提供与 [image] 按钮相同的功能， 它会导致当前行由高亮度显示变成闪烁。

      注：锁定列或锁定数据表中的文本不能编辑。有关撤消锁定列的详情，请参阅"锁定列"。有关撤消锁定数据表的详情，请参阅"锁定表"。

您也可以从数据表访问行编辑器。有关详情，请参阅"使用行编辑器"。

了解 p 值指标

小于 0.05 的 p 值从统计角度看是显著的。在输出报表中，JMP 通过在这些值的旁边加上星号 (*) 来表示它们的显著性。


打印报表

要打印活动窗口中的报表，请选择文件 > 打印。此命令将显示用于打印的标准窗口。该窗口的外观取决于您的操作系统和打印机驱动程序。

  • 如果是使用 Windows 操作系统并希望在打印前查看活动窗口的打印效果，请选择文件 > 打印预览。如果没有打开的窗口，则此命令不可用。
  • 要在打印前设定打印的页面特征，请选择文件 > 打印设置 (Windows) 或文件 > 页面设置 (Macintosh)，以显示用于设定这些特征的标准窗口。该窗口的形式取决于您的操作系统和当前的打印机驱动程序。

要插入分页符以便打印，请执行以下操作：

  1. 在报表窗口中使用鼠标右键单击展开按钮（在 Windows/Linux 中为 [image] ，在 Macintosh 中为 [image] ）。
  2. 选择编辑 > 分页。


添加选项和运行分析

如何访问分析选项

单击报表中的红色三角形图标，显示适用于该特定报表的选项列表，如"红色三角形图标" 所示。

红色三角形图标

除单击红色三角形图标外，您还可以：

  • 按住 Alt 键并单击（在 Macintosh 中为按住 Option 键并单击，在 Linux 中为按住 Ctrl-Alt 组合键并单击）红色三角形图标，则出现的面板中的所有命令和选项都将带有复选框，您可以用它们同时选择多项操作。
  • 按住 Ctrl 键并单击（在 Macintosh 中为按住 Command 键并单击，在 Linux 中为按住 Ctrl-Alt 组合键并使用鼠标右键单击）红色三角形图标，将选择的命令应用到分析窗口中的所有相似报表。例如，在单因子分析中按住 Ctrl 键并单击图标，并选择均值/方差分析/t 检验时，将对活动报表窗口中的所有单因子分析进行方差分析。

《JMP 统计和图形指南》中的各章说明了各个统计平台和图形平台的菜单。

重新运行分析

您可以重做分析以获得其报表，而无需返回主菜单。例如，如果运行二元拟合，然后更改数据表中的一个或两个值，则可以返回原始报表并从该处重新运行分析。

要从报表窗口重做分析，请执行以下操作：

  1. 单击报表标题中的红色三角形图标。
  2. 选择脚本 > 重新分析。
重新运行分析


将步骤保存为脚本

完成分析并收到报表后，您可能要将用来生成报表的过程保存为 JSL 脚本。您可以将脚本保存在数据表内、报表内或一个单独的脚本窗口中。要实现此操作，请单击报表标题中的红色三角形图标，并选择脚本 。然后选择您喜欢的保存脚本选项：

脚本菜单
  • 复制脚本 以 JSL 的形式将到达当前报表所执行的步骤复制到剪贴板中。您可以将脚本粘贴到文本编辑器中。
  • 将脚本保存至数据表 将用于生成当前报表的步骤作为 JSL 脚本保存至数据表。脚本将出现在数据表的表面板中。有关详情，请参阅"表面板"和"创建脚本"。
  • 将脚本保存至日志 将用于生成当前报表的步骤作为 JSL 脚本保存至日志（有关日志记录的详情，请参阅"使用日志命令保存"）。在日志中，单击脚本可运行它。
脚本已添加到日志中
  • 将脚本保存至脚本窗口 将用于生成当前报表的步骤作为 JSL 脚本保存至脚本窗口，如"脚本已添加到脚本窗口中" 所示。
脚本已添加到脚本窗口中
  • 将脚本保存至报表 将用于生成当前报表的步骤作为 JSL 脚本保存至报表本身，如"脚本已添加到报表中" 所示。
脚本已添加到报表中
  • 保存所有对象的脚本 将用于生成当前报表的步骤（包括用于变量赋值的所有步骤）作为 JSL 脚本保存至脚本窗口。
  • 数据表窗口 将关联的数据表显示为最前端的窗口。

JMP 的非英语版本可以以英语或您当地的语言保存脚本。请参阅"使用不同的语言保存脚本"。


格式化报表

可用来格式化报表以达到您的要求的方式有很多种。以下部分详细说明了如何对报表的文本部分进行更改。

行重新排序（排序）

要对报表中的行进行排序或重新排列，请执行以下操作：

  1. 使用鼠标右键单击报表中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。
  2. 选择按列排序。
  3. 在出现的窗口中高亮度显示一列或多列，作为排序变量。"报表排序" 显示的是报表的排序顺序。
报表排序
  4. （可选）要按升序（而非按默认的降序）显示已排序的列，请单击升序旁边的复选框。

显示和隐藏列

报表通常有许多列。您可以指定要查看的列。"显示和隐藏列" 中的表是一个仅显示了水平、计数和概率的“频数”表。其中隐藏了标准错误概率值和累积概率值。要显示或隐藏列，请执行以下操作：

  1. 使用鼠标右键单击报表中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。
  2. 选择列。
  3. 选择要显示或隐藏的列。其名称旁边有选定标记的列将出现在表中（"显示和隐藏列"）。
显示和隐藏列

注：名称以 ~ 开头的列（如 ~Bias）不适用于运行的分析，即使在其名称旁边有选定标记，也不会出现在表中。

添加外框和边框

默认情况下，报表没有用来分隔行和列的外框。您可以定制表的外观和内容。要添加外框和边框，请执行以下操作：

  1. 使用鼠标右键单击报表中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。
  2. 选择表样式。
  3. 选择其中一个选项，以增强表的外观（"表样式菜单和斜对角表（Windows 中）"）。
表样式菜单和斜对角表（Windows 中）
    • 无格式 无任何分隔线或边框。
    • 边框 表周围有边框，列之间有分隔线。
    • 凸起效果 在 Windows 和 Linux 中，对边框和分隔线增加三维效应。在 Macintosh 中，将边框从黑色更改为灰色。
    • 斜对角 在 Windows 中，增加三维效应并使边框的角呈圆形而非方形。在 Macintosh 和 Linux 中，使表背景呈灰色阴影。

更改数值格式和字段宽度

默认情况下，JMP 会挑选它认为最适合报表和数据表中的数字的格式。对于长小数，此格式的宽度将适于该列。它还会截断尾随的零。要在报表中进行更改，请执行以下操作：

  1. 双击报表数值列中的任意位置，如"更改表的格式" 所示。此时将出现“列数值格式”窗口。
更改表的格式
  2. 从格式下拉菜单中选择一种格式，如"“格式”菜单" 所示。
“格式”菜单
  3. 如果选择固定小数位、日期、时间或持续时间，此时将出现其它字段。请键入小数位数、选择日期格式，或从下一个框中选择时间格式。
  4. 在字段宽度框中，键入希望报表中的列容纳的字符数。一定要键入一个您认为列中的值可能具有的最大位数。
  5. 单击确定，则分析表中的列将相应地格式化。

更改表名称和列标题

您可以更改报表的名称和列标题：

  1. 双击表名称或标题。它将高亮度显示，如"双击表名称（左）或列标题（右）以更改它" 所示。
双击表名称（左）或列标题（右）以更改它
  2. 再次单击它。此时光标将变成一条闪烁的文本插入线。
  3. 编辑其内容。

将报表转换为数据表

您可以根据报表创建 JMP 数据表。"转换为数据表的报表" 中的数据表是根据输出报表中的“频数”表创建的 JMP 数据表。要将报表转换为数据表，请执行以下操作：

  1. 使用鼠标右键单击报表中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。
  2. 选择制成数据表，以根据报表创建数据表。
    选择制成合并数据表，以在报表中搜索与单击的表类似的其它表，并将它们合并成单个数据表。
转换为数据表的报表

将报表转换为矩阵

您可以根据报表创建 JMP 矩阵。例如，使用 JMP 脚本语言 (JSL) 时，您可能要访问已存储至 JSL 变量的报表。或者，您可能要将报表的值作为表性质或作为 JSL 赋值存储至表性质，这些将存储在数据表中并可通过脚本或公式编辑器访问。

要将矩阵形式的表存储至全局变量、表性质或作为赋值存储至表性质，请执行以下操作：

  1. 使用鼠标右键单击报表中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。
  2. 选择制成矩阵，如"选择“制成矩阵”" 所示。
选择“制成矩阵”
  3. 在出现的窗口中，告诉 JMP 如何存储表，如"选择“至全局变量”" 所示。
选择“至全局变量”
  4. （可选）通过在名称旁的框中输入新名称来重命名变量或性质。


选择图中的点

要选择图中的某个点，请使用箭头光标单击该点。这将选择该点以及当前数据表中对应的行。要选择所有点，请在单击新点的同时按住 Shift 键。将光标放置在点上面时（无论单击与否），系统将显示点的标签。

在图、图表和图形中选择行和列

代表同一数据表的所有图形和图都相互链接并与对应的数据表链接。单击图中的点或图形中的条形柱时，数据表中的对应行将高亮度显示。"高亮度显示直方图中的行" 中的实例显示了 SPEEDYTYPE 条形柱高亮度显示的直方图以及表中高亮度显示的对应行。您也可通过按住 Shift 键并单击直方图中的条形柱来扩展条形柱的选择范围。

高亮度显示直方图中的行

选择矩形区域的点

您可以使用箭头光标选择一个矩形区域内的所有点。单击并拖动箭头可高亮度显示各点。另外，您也可以使用笔刷工具。在图形上移动笔刷时，将选定矩形内的点。数据表中标记为隐藏的点（请参阅"隐藏行和列"）都将不会被选定。

要使用笔刷工具选择点，请执行以下操作：

  1. 单击工具栏中的笔刷工具 ( [image])。
  2. 在图中单击并按住光标（现在为笔刷形状）。此时将出现一个矩形。
  3. 在点上面移动该矩形。当矩形经过这些点时，这些点会变大并同时在图中和活动数据表中高亮度显示。

    注：要在点上面移动笔刷形状的光标时选定所有点，请在图中单击之前按住 Shift 键。
  4. 释放后，将选定矩形内的点。

笔刷工具的其它使用方式有：

  • 要更改选择矩形的大小，请在图中单击之前，按住 Alt 键（在 Macintosh 中为按住 Option 键，在 Linux 中为按住 Alt-Shift 组合键）。此形状的功能类似于切片工具，可跨越任何轴高亮度显示点的切片。
  • 如果在按住 Ctrl 键（在 Macintosh 中为 Command 键）的同时拖动笔刷工具，矩形内各点的选择状态将连续反向变化。这将使数据表中选定的点和行号闪烁。
  • 如果按住 Ctrl-Alt 组合键并拖动（在 Macintosh 中为按住 Command-Option 组合键并拖动）笔刷工具，然后释放（推动矩形），矩形将在框架中反弹。推动（或拖动）光标的速度和方向决定了矩形反弹矩形的速度和方向。单击报表可停止矩形。

选择不规则形状区域的点

您可以使用套索工具选择不规则形状区域内的点。数据表中标记为隐藏的点（请参阅"隐藏行和列"）都将不会被选定。

要选择不规则形状区域内的点，请执行以下操作：

  1. 单击工具栏中的套索工具 ( [image])。
  2. 在图中单击并按住光标（现在为套索形状）。

    注：要在几组点周围拖动套索时选定所有点，请在图中单击之前按住 Shift 键。
  3. 在任何一组点周围拖动套索。
  4. 释放后，JMP 将自动闭合套索并高亮度显示闭合区域中的点。


使用标记

标记是图形中表示数据的点。一旦更改了标记的默认设置，它们还会显示在数据表的行旁边。以下部分显示了如何更改标记形状、大小、颜色等。

更改标记形状

您可以从 JMP 标记选用区中指定一个字符来代替散点图和旋转图中的标准点。此外，这些标记还会显示在数据表中行号的旁边。

  1. 高亮度显示要更改其形状的标记。
  2. 使用鼠标右键单击图形中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。在直方图中，使用鼠标右键单击右边的箱型图区域。
  3. 选择行标记。此时将出现如"行标记" 所示的菜单。
行标记
  4. 从出现的选项中选择一种标记形状。

更改标记颜色

您可以为高亮度显示行指定任何颜色。进行此操作时，散点图和旋转图中的点将以从颜色调色板中选择的颜色显示。当前为行指定的颜色将显示在数据网格中行号的旁边。

要更改图形上的标记（点）的颜色，请执行以下操作：

  1. 高亮度显示要更改其形状的标记。
  2. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。在直方图中，使用鼠标右键单击右边的箱型图区域。
  3. 选择行颜色。此时将出现颜色调色板。
  4. 选择其中一种颜色。

更改标记大小

要增大或减小图形上的标记（点），请执行以下操作：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。按住 Ctrl 键并使用鼠标右键单击（在 Macintosh 中为按住 Command-Ctrl 组合键并单击），将命令应用于同一窗口中类型相同的所有图。在直方图中，使用鼠标右键单击右边的箱型图区域。
  2. 选择标记大小。此时将出现如"选择一种标记大小" 所示的菜单。
选择一种标记大小
  3. 选择列出的其中一种标记大小。首选大小是 JMP 估计最适合图形的大小。

更改标记绘制模式和透明度

在图形上使用大量标记时，标记会显得拥挤。您可能需要更改透明度，以取得更佳的视图效果。更改透明度也可能会影响标记绘制模式，这是 JMP 刷新报表窗口时使用的模式。在图上绘制标记时，它使用两种速度之一：正常或快速。

要更改标记绘制速度，请执行以下操作：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。在直方图中，使用鼠标右键单击右边的箱型图区域。
  2. 选择标记绘制模式。此时将出现如"选择一种标记绘制模式" 所示的菜单。
选择一种标记绘制模式
  3. 选择正常或快速。
    • 正常 -- 如果 JMP 处于正常绘制模式且图形中的标记数超出指定的阈值，则 JMP 会自动切换至快速模式。有关设定标记阈值的详情，请参阅"标记绘制速度阈值"。
    • 快速 -- 如果将标记绘制速度设定为快速，则显示大量标记的图形将以较快速度显示。请注意，当绘制速度设定为快速时，标记大小将恢复为首选大小，标记透明度设置将恢复为默认的不透明性。

      注：您可以在"在标记周围添加外框"部分找到有关“标记绘制模式”菜单中的外框选择的信息。

在标记周围添加外框

您可以向图中的标记添加黑色的外框或框架。中、大、XL、XXL 和 XXXL 大小的标记都可以加外框（有关详情，请参阅"更改标记大小"）。要添加外框，请执行以下操作：

  1. 使用鼠标右键单击图或图形。
  2. 选择标记绘制模式，如"选择一种标记绘制模式" 所示。
  3. 选择外框。

要充分发挥外框的功能，标记的颜色最好是除黑色以外的颜色。要更改标记颜色，请执行以下操作：

  1. 高亮度显示要更改其颜色的标记。
  2. 使用鼠标右键单击图形中的任意位置（在 Macintosh 中为按住 Ctrl 键并单击）。
  3. 选择行颜色。
  4. 从出现的选项中选择一种标记颜色。高亮度显示的点和行上将出现外框。

指定标记透明度

您可以更改图形中标记（点）的透明度，这样就可控制叠加点的可视性。

请注意，绘制速度设定为快速时，标记透明度设置将恢复为默认的不透明性，标记大小将恢复为首选大小。

要调整标记的透明度，请执行以下操作：

  1. 使用鼠标右键单击图形中的任意位置。在直方图中，使用鼠标右键单击右边的箱型图区域。
  2. 选择透明度。此时将出现如"透明度窗口" 所示的窗口。
透明度窗口
  3. 键入希望图形上的标记（点）具有的透明度水平。值 1 表示完全不透明，而 0 表示不可见。1 和 0 之间的值表示半透明。
  4. 单击确定。

排除和隐藏标记

使用排除/撤消排除命令，您可以将高亮度显示的行从统计分析中排除。在为高亮度显示的行选择行 > 排除/撤消排除之前，数据将保持排除状态。

警告：即使数据已被排除在文本报表和图形中的计算之外，这些数据也不会在图中自动隐藏。

使用隐藏/撤消隐藏命令，您可以抑制（隐藏）高亮度显示的点出现在散点图中。例如，您可以在分析中排除某些点，然后在散点图中隐藏这些点。在为高亮度显示的行选择行 > 隐藏/撤消隐藏之前，数据将保持隐藏状态。

警告：即使隐藏的点不显示在图中，这些点也不会自动排除在影响文本报表和图形的统计计算之外。要将隐藏的观测值从分析中排除，您必须高亮度显示它们，然后选择行 > 排除/撤消排除特征。

要从分析中排除或隐藏标记（点），请执行以下操作：

  1. 高亮度显示要排除或隐藏的标记。
  2. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。
  3. 选择排除行或隐藏行。

向标记添加标签

如果将箭头光标置于图中的某个点上，屏幕将出现该点的标签。默认情况下，标签为行号。自定义标签的方式有两种：

  • 您可以更改标签，以便显示一列或多列中找到的值，而并非显示行号。
  • 您可以让标签始终显示，而不只是将光标置于点上时才显示。

要更改标签以显示在一列或多列中找到的值，而不显示行号，请执行以下操作：

  1. 在数据表中，高亮度显示要作为标签在图中显示值的列。
  2. 从以下某个位置选择标记/撤消标记，如"访问列特征命令的不同方法" 所示：
    • 主菜单中的列菜单
    • 列面板中的红色三角形图标
    • 数据网格右上角的红色三角形图标
访问列特征命令的不同方法

列面板中的列名旁边将显示标签或黄色标签图标 ( [image])，表明图中的点将由列值标识。如果有多个已标记的列，它们的值在图中将以逗号分隔。数据将一直被标记，直到您再次高亮度显示该列并选择标记/撤消标记。

要始终显示标签而不只是在将光标置于点上时显示，请执行以下操作：

  1. 高亮度显示要在图中始终显示其标签的点。
  2. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。在直方图中，使用鼠标右键单击右边的箱型图区域。
  3. 选择行标签，如"选择行标签" 所示。
选择行标签

数据表中的行号旁边将显示标签或黄色标签图标 ( [image])，表明图上与行对应的点将显示有标签。

根据值更改标记形状或颜色

在某些图中，通过添加行图例，可以根据点的值更改标记形状和（或）颜色。之所以称为行图例，是因为 JMP 会使用行颜色或行标记设置（"使用鼠标右键单击图例以移除图例"）自动插入图例。以这种方式指定标记或颜色时，它会将相应特征指定给图形中的所有点（不管选择了哪些点），并覆盖先前所有的标记和颜色设置。

要根据标记值添加形状或颜色，请执行以下操作：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。在直方图中，使用鼠标右键单击右边的箱型图区域。
  2. 选择“行图例”，如"选择行图例" 所示。
选择行图例
  3. 在出现的窗口（"添加行图例"）中，高亮度显示要为其值指定颜色和（或）作标记的列。
添加行图例
  4. 使用以下选项细化行图例：
    • 单击按值设定颜色，使高亮度显示列中的值确定行/图例的颜色。
    • 单击按值设定标记，使高亮度显示列中的值确定图形中使用的行标记。
    • 单击生成具有图例的窗口，在报表窗口中纳入图例，说明什么颜色和（或）形状与哪个值对应。此操作仅适用于保序和记名列。如果要连续列的图例，请选择连续尺度，如下所述。
    • 单击如果相容，则保留当前颜色或标记以纳入图例，该图例承兑了任何先前指定的颜色范围，如在通过单击列名并选择列信息 > 列性质 > 值颜色完成列的颜色范围的设置时。有关详情，请参阅"指定值的颜色范围"
    • 单击连续尺度，按与值的升序或降序对应的频谱指定颜色。如果高亮度显示的列包含连续值，请使用此选项。JMP 按粉红、红、黄、黄-绿、浅蓝色、蓝色的顺序将颜色指定给按大到小的顺序排列的数字。

请注意，如果值多于可选择的颜色或标记，则可能重复使用颜色或标记。

移除图例

制作图例后，可以使用鼠标右键单击它，以便更改颜色和标记或移除图例。要移除颜色和（或）标记，请在数据表中高亮度显示行，然后选择行 > 清除行状态（"使用鼠标右键单击图例以移除图例"）。

使用鼠标右键单击图例以移除图例


更改图外观和图表外观

可用来格式化报表以达到您的要求的方式有很多种。以下部分详细说明了如何对输出报表的图形部分进行更改。

调整图和图形大小

调整图和图形大小的方法主要有两种：使用单击拖动法和根据像素大小调整。

使用单击拖动法

要使用单击拖动法调整图或图形的大小，请执行以下操作：

  1. 将光标放在图框架的右边、底边或右下角。光标将变为小双箭头指针，如"调整图或图形大小" 所示。
调整图或图形大小
  2. 单击并拖动以更改图的大小。调整大小时，该框架中所有图的高度和宽度调整都独立于同一报表窗口中的其它框架。使用下表将图调整为所需的形状：
    操作 | 说明
    调整图框架但保留比例（纵横比率） | 按住 Shift 键，然后单击并拖动框架的角。
    以 8 像素为增量调整图 | 按住 Alt 键（在 Macintosh 中为 Option 键），然后单击并拖动框架的角。
    同时调整类型相同的所有图 | 按住 Ctrl 键（在 Macintosh 中为 Command 键），然后单击并拖动其中一个图的角。例如，对某个散点图执行此操作时，则窗口中的所有散点图都将一起调整大小，而马赛克图则保持不变。

指定像素大小

要将图或图形调整为特定的像素大小，请执行以下操作：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图或图形。
  2. 选择大小/尺度。要输入框架高度和宽度的像素数，请选择框架大小。当 x 轴和 y 轴使用相同的计量单位，并且您想要精确地表示图形上的距离而不考虑方向时，请选择调整为相同大小。
“大小/尺度”菜单
  3. 按像素量输入所需的测量值，如"指定所需大小" 所示。
指定所需大小

放大和缩小

放大镜 ( [image]) 可用来自动放大图中的任何区域。在您单击放大镜时，您单击的点或区域将变为新的数据视图中心。新视图的尺度将变大，让您可更近距离地查看感兴趣的点或图案。您可以：

  • 单击并拖动放大镜，将焦点置于图上的特定区域。
  • 在三元图上，拖动放大镜，放大三角轴。
  • 重复放大，更近距离地查看数据。
  • 双击放大镜，恢复原始图。

"使用放大镜工具放大的实例" 中的实例使用花粉.jmp 说明了放大镜的作用。要执行此实例，请从安装 JMP 时安装的 Sample Data 文件夹中打开花粉.jmp 文件。

在本实例中，数据以隐藏图案（消息）的方式隐藏在 3800 多个点中。选择分析 > 以 X 拟合 Y 可将整个表显示为如"使用放大镜工具放大的实例" 中左边所示的密集云。单击放大镜两次将产生中间的图，再单击两次则将显示右边图中所示的惊奇消息。

使用放大镜工具放大的实例

更改线宽

在使用线条拟合图形或者使用已有的线条生成图形之后，您可以调整线条的宽度：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。
  2. 选择线宽尺度。
  3. 选择以将当前线宽扩大为其默认宽度的一到三倍。或者选择其它，然后指定一个较大或较小的数值。当您通过窗口 > 字体大小（在 Windows 和 Linux 中）和查看 > 增大/缩小文本（在 Macintosh 中）增大 JMP 的显示字体大小时，选择使用字体标度来增大行的大小。

更改背景颜色或直方图条形柱颜色

要更改任何图形的背景颜色，请执行以下操作：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）图形中的任意位置。在直方图中，使用鼠标右键单击右边的箱型图区域。
  2. 选择背景颜色。
  3. 在 Macintosh 中，单击圆圈中的颜色，选择一种预置颜色，然后使用圆圈右边的滑动杆增加或降低颜色强度。
    在 Windows 和 Linux 中，从基本颜色区域中单击某个颜色方框，选择一种预置颜色。
或者，按以下步骤创建自定义颜色：
  1. 单击窗口右边大颜色区域中的一个颜色带。或者，如果知道想要使用的颜色的值，请键入红、绿和蓝值。
  2. 使用大颜色区域右边的滑动杆增加或降低颜色强度。如果您知道要使用的颜色的强度，请键入色调、饱和度和亮度 。
  3. 单击添加到自定义颜色（"背景颜色选项 (Windows)"）。该颜色将添加到自定义颜色区域的空方框中。
背景颜色选项 (Windows)

要更改直方图中条形柱的颜色，请执行以下操作：

  1. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）直方图中的任意位置，并选择直方图颜色。
  2. 单击颜色区域中的某个颜色方框。

显示轴坐标

您可以在图形中测量各点和距离，或方便地找出图和图形上各点和距离的精确值或坐标。要实现此操作，请单击十字准线工具 ( [image])，然后在图形上的任何位置单击并按住鼠标。在图中拖动十字准线时，坐标值将出现在十字准线与垂直轴和水平轴的相交处。

在拟合线或拟合曲线上，十字准线将标识任何预测值的响应值。在三元图上，该工具显示为三角十字准线条。

滚动和缩放轴

手形工具（也称抓手工具） ( [image]) 提供了一种更改图的轴和视图的方法：

  • 在 y 轴上，拖动 [image] 或 [image] 缩放 y 轴；拖动 [image] 滚动 y 轴。
  • 在 x 轴上，拖动 [image] 滚动 x 轴；拖动 [image] 或 [image] 缩放 x 轴。

自定义轴和轴标签

双击数值轴可使用“轴规格”窗口自定义该轴。或者，使用鼠标右键单击轴区域并选择轴设置，也可访问该窗口。

窗口中的自定义功能取决于轴的数据类型以及 JMP 用来创建图或图表的特定平台。 "数值轴的“轴规格”窗口" 显示了数值轴的典型“轴规格”窗口。

数值轴的“轴规格”窗口

以下部分说明了如何使用“轴规格”窗口以及使用它可完成的任务。

更改轴尺度类型

查看具有数值轴的图形时，您可以更改轴尺度：

  1. 双击某个数值轴。或者，使用鼠标右键单击并选择轴设置。此时将出现“轴规格”窗口。
  2. 选择尺度类型：线性或对数。

要为变量设定默认的尺度类型，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。

更改轴的数值格式

对于包含数值轴区域的图和图表，您可以更改轴的格式。要在查看图形时更改数值格式，请执行以下操作：

  1. 双击某个数值轴。或者，使用鼠标右键单击并选择轴设置。此时将出现“轴规格”窗口。
  2. 在格式旁边的框中，使用下拉菜单选择一个选项。有关详情，请参阅"数值格式选项"。
  3. 如果您：
    • 在上一步骤的格式下拉菜单中选择了日期或时间，请使用选择的选项右边的下拉菜单选择刻度标记的日期增量。有关这些选项的说明，请参阅"数值格式选项"。您还需要指定增量的格式，如"更改轴增量"所述。
    • 在上一步骤的格式下拉菜单中选择了固定小数位，则将在格式框旁边出现一个文本框。键入要 JMP 显示的小数位数。

注：更改轴的数值格式不会更改这些值在对应的数据表中显示的数值格式。要更改日期或时间在数据表中的显示方式，请参阅"选择数值格式"。

从日期增量下拉菜单中选择日期间隔，会将 JMP 日期（秒数）划分为相应的单位，从而给出数据所需的图形尺度。日期轴必须是带有 JMP 日期值的列，并以“列信息”窗口中的日期格式显示在“轴规格”窗口中。但是，您可以使用“轴规格”窗口使日期在图中的显示格式如您所愿。

建立最小轴值和最大轴值

对于包含数值轴区域的图和图表，您可以更改要图形显示的最小值（最小）和最大值（最大）。

要在查看图形时更改最小轴值和最大轴值，请执行以下操作：

  1. 双击某个数值轴。或者，使用鼠标右键单击并选择轴设置。此时将出现“轴规格”窗口。
  2. 键入要图形显示的最小值和最大值。

通过使用鼠标右键单击数值轴并选择恢复轴，您可以恢复数值轴默认的最小轴设置和最大轴设置。

要为变量设定默认的最小轴值和最大轴值，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。

"重新调节轴以放大图的某个部分" 中右边的实例是点聚类的放大样式，其中显示了左图中 -200 至 500 之间的值。通过重新指定最大轴值和最小轴值并更改副刻度标记数，可获得放大图（有关详情，请参阅"添加副刻度标记"）。

重新调节轴以放大图的某个部分

更改轴增量

在查看图形时，您可以更改轴增量：

  1. 双击某个数值轴。或者，使用鼠标右键单击数值轴，然后选择轴设置。此时将出现“轴规格”窗口。
  2. 在增量旁边的文本框中，键入要显示的增量数。
  3. 如果轴的格式为日期或时间（如格式下拉菜单中所示），则增量旁边会出现另一下拉菜单（请参阅"更改轴增量"）。从该框中选择增量格式。
更改轴增量

要为变量设定默认的轴增量，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。

添加和移除轴标签

您可以添加或移除数值轴上的标签。要添加轴标签，请执行以下操作：

  1. 使用鼠标右键单击数值轴，然后选择添加轴标签。
  2. 键入轴标签的名称。轴区域将放大，以容纳输入的标签行数。

此命令可使用多次，以添加多个标签。要在将标签添加到轴后编辑它，请单击该标签，这将使它变成编辑框。

要移除轴标签，请使用鼠标右键单击数值轴，然后选择移除轴标签。这将移除添加的最后一个标签。

更改轴标签字体

您可以修改任何类型的轴上的轴标签字体。修改它时，所作的更改仅适用于活动的图形。要设定默认的轴标签字体，请参阅"自定义字体和语言"。

要更改当前字体类型和大小，请执行以下操作：

  1. 使用鼠标右键单击某个轴标签。
  2. 选择字体。
  3. 在窗口中进行选择。

要更改字体颜色，请执行以下操作：

  1. 使用鼠标右键单击某个轴标签。
  2. 选择字体颜色。
  3. 从提供的调色板中为文本选择一种颜色。

旋转轴标签

您可以修改任何类型的轴上的轴标签。要旋转轴标签，请执行以下操作：

  1. 使用鼠标右键单击某个轴标签。
  2. 选择旋转文本。
  3. 选择文本的旋转方向：水平、左或右。

要为变量设定默认的轴标签位置，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。

复制并粘贴图形内容

通过添加元素（如拟合线）自定义图形后，您可以将某个图形的内容复制并粘贴到另一个兼容的图形：

  1. 使用鼠标右键单击自定义图形。
  2. 选择编辑 > 复制框架内容。
  3. 使用鼠标右键单击要将设置复制到的图形。
  4. 选择编辑 > 粘贴框架内容。

复制和粘贴轴设置

自定义轴后（如"自定义轴和轴标签"中所述），您可以将新设置复制并粘贴到另一个轴：

  1. 使用鼠标右键单击已自定义的轴。
  2. 选择编辑 > 复制轴设置。
  3. 使用鼠标右键单击要将设置复制到的轴。
  4. 选择编辑 > 粘贴轴设置。

更改值的顺序

JMP 报表中的数据可能没有按您所希望的顺序显示。要为数据指定特定顺序，使其在报表中按该顺序显示，请在运行分析前为列指定“值的排序”性质，如"对列中的值排序"所述。

如果包含以下任何值，在报表中这些值将以相应的顺序自动显示：

  • 一月、二月、三月、四月、五月、六月、七月、八月、九月、十月、十一月、十二月
  • 一、二、三、四、五、六、七、八、九、十、十一、十二
  • 星期日、星期一、星期二、星期三、星期四、星期五、星期六
  • 极低、低、中低、中、中高、高、极高
  • 完全不同意、不同意、中立、无关紧要、同意、完全同意
  • 失败、不可接受、很差、差、较差、可接受、平均、好、较好、非常好、最佳

自定义刻度标记和刻度标记标签

在数值轴上，您可以添加和移除刻度标记、添加和移除格线，以及添加副刻度标记。您还可以更改字体类型、大小和样式（粗体或斜体）、文本颜色，旋转轴标签，或向记名轴或保序轴的刻度标记标签添加外框。以下部分说明了如何自定义它们。

添加刻度标记和格线

对于包含数值轴区域的图和图表，您可以显示或隐藏刻度标记和格线。要实现此操作，请双击某个数值轴。或者，使用鼠标右键单击数值轴，然后选择轴设置。此时将出现“轴规格”窗口，如"显示或隐藏刻度标记和格线" 所示。使用下表可显示或隐藏刻度标记和格线。

显示或隐藏刻度标记和格线

操作 | 说明
显示主刻度标记 | 单击主右边和刻度标记下面的框。
显示副刻度标记 | 单击副右边和刻度标记下面的框。
显示副刻度标记增量的格线 | 单击副右边和格线下面的框。
显示主刻度标记增量的格线 | 单击主右边和格线下面的框。

要为变量设定默认的刻度标记，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。

添加副刻度标记

要向数值轴添加刻度标记，或更改数值轴上出现的副刻度标记数，请执行以下操作：

  1. 双击该刻度标记。或者，使用鼠标右键单击它，然后选择轴设置。此时将出现“轴规格”窗口。
  2. 在副刻度数旁边的框中，键入要出现在主刻度标记之间的副刻度标记数。请参阅"更改副刻度标记数"。
  3. 单击副右边和刻度标记下面的框，指明要将刻度标记显示在轴上。请参阅"更改副刻度标记数"。
更改副刻度标记数

要为变量设定默认的副刻度标记，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。

调整标签的字段宽度

在包含数值轴区域的图和图表上，您可以调整刻度标记标签的宽度，以便显示具有多位小数的大值或仅显示少量空间/被截断的值。如果设定的字段宽度过小，刻度标记标签将显示为省略号（三个点）。

要在查看图形时更改字段宽度，请执行以下操作：

  1. 双击某个数值轴。或者，使用鼠标右键单击并选择轴设置。此时将出现“轴规格”窗口。
  2. 在字段宽度文本框中，键入容纳新列可能具有的最大位数或字符数所需的字符数。数值的最大字段宽度为 40。字符值则无约束。

请注意，增加/减少刻度标记标签的字段宽度不会更改对应数据表中包含这些值的单元格的字段宽度。要更改数据表中单元格的字段宽度，请参阅"选择数值格式"部分。

更改刻度标记标签字体类型和大小

您可以修改数值轴刻度标签的字体类型、大小和样式（粗体和斜体）。要更改字体类型和大小，请执行以下操作：

  1. 双击该刻度标签。或者，使用鼠标右键单击它，然后选择轴设置。此时将出现“轴规格”窗口。
  2. 选择字体，然后进行选择。

注：要对所有类型的轴的字体类型和大小进行全局更改，请选择文件 > 首选项（Macintosh 中为 JMP > 首选项）。单击字体选项卡，然后单击轴。

旋转刻度标记标签

要垂直或水平地旋转刻度标记标签，请执行以下操作：

  1. 双击该刻度标签。或者，使用鼠标右键单击它，然后选择轴设置。此时将出现“轴规格”窗口。在记名轴上，使用鼠标右键单击该刻度标签，并选择旋转刻度标签。
旋转记名轴或保序轴上的刻度标签
  2. 选择旋转刻度标签，如"旋转记名轴或保序轴上的刻度标签" 所示。

要旋转回去，请再次执行这些步骤。

扩展分隔线和框架

当记名变量或保序变量具有多个水平时，扩展刻度标签之间的垂直分隔线会尤为有用。

要向 x 轴标签扩展分隔线，请执行以下操作：

  1. 使用鼠标右键单击记名轴或保序轴。
  2. 选择分隔线以添加线条，或选择低框架以在轴区域周围添加框架。

添加参考线

要向图形添加参考线，请执行以下操作：

  1. 双击某个数值轴。或者，使用鼠标右键单击数值轴，然后选择轴设置。此时将出现“轴规格”窗口。
  2. 在添加参考线按钮左边的文本框中，键入将与参考线对应的值。这将成为该线条在图形上的位置，如"添加参考线" 所示。
  3. 通过选择以下其中一个选项，进一步自定义参考线：
    操作 | 说明
    为线条指定颜色 | 单击颜色条下拉菜单并选择一种颜色，如"添加参考线" 所示。
    使用点线 | 单击线条下拉菜单并选择其中一种线条类型，如"添加参考线" 所示。
  4. 单击添加参考线按钮。该值将移至添加参考线按钮右边的框，表示它将显示在图形上。
  5. 要添加更多线条，请重复以上步骤。
添加参考线

要为变量设定默认的参考线，以避免每次运行分析时都作此更改，请参阅"更改列的默认轴设置"。


向报表中添加元素

您可以使用工具栏中的图形工具向报表添加文本注释、线条、多边形、椭圆和矩形。

添加注释

您可以使用注释工具 ( [image]) 向 JMP 报表添加可编辑的文本注释。要添加注释，请执行以下操作：

  1. 从工具菜单或工具栏中选择注释工具 ( [image])。
  2. 在窗口中单击要添加注释的位置。或者，单击并拖动以确定注释的大小。这将显示一个白色的可编辑文本框。
  3. 输入文本。
  4. 在注释外单击。注释将变成黄色。
  5. 使用鼠标右键单击注释以访问以下选项：
    • 背景颜色 提供一个调色板，从中可选择注释的背景颜色。
    • 文本颜色 提供一个调色板，从中可选择注释的文本颜色。字体的颜色同时也定义注释外框的颜色。如果为背景和字体选择了同一种颜色，则除黑色和白色外，字体不会显示。黑色背景上的黑色字体会变为白色，而白色背景上的白色字体则会显示为黑色。
    • 字体 用于更改当前字体类型、样式和大小。要更改默认字体，请参阅"自定义字体和语言"。
    • 标签线 向注释附加一条线，指向文本中的某个位置，如下所示。要将该线与文本一起移至新位置，请按住 Ctrl 键（在 Macintosh 中为按住 Command 键）并拖动注释。
    • 填充 移除注释的背景颜色，使之看起来透明。透明的注释便于在图形上放置标题和脚注。
    • 重新定位 重新定位注释。
    • 删除 删除整个注释。

      注：如果要添加多个注释，请在首次选择注释工具时按住 Shift 键。这样将使随后的单击添加注释，而不必在每次添加注释之前都从工具栏中选择注释工具。

添加注释后，您可以执行以下操作：

操作 | 说明
添加或编辑注释 | 在文本框内单击。
移动注释 | 在注释框内单击并拖动它。注释移动后，其将处于选定状态，周边显示带图柄的蓝色双划线。
调整注释大小 | 将光标置于选定注释的图柄（显示在边缘的中间及角上）上，它将显示为单十字箭头；拖动它即可调整注释大小。
删除注释 | 单击注释的图柄，高亮度显示注释。然后按下 Delete（或 Backspace）键。

添加形状

您可以使用绘制工具 ( [image]) 向报表添加可编辑的线条、多边形和简单形状（椭圆或矩形）。以下部分说明了如何使用各个工具。

注：每个图形工具都会记忆最近选择的选项。如果需要具有许多特征相同的注释或其它图形，这会很有用。例如，假设需要许多一端带箭头的绿色粗线。根据需要创建一条线，然后设置选项，则这些选项将对后续线条起作用。这些选项将始终有效，直到更改它们。

添加线条

要向报表窗口添加线条，请执行以下操作：

  1. 单击工具选用区中的线条工具 ( [image])。
  2. 在要插入线条的位置单击并拖动。出现的线条处于选定状态，两端显示图柄，如"使用鼠标右键单击线条以定制其外观。" 所示。
  3. 单击并拖动线条可移动它。
  4. 单击图柄并拖动可旋转线条。
  5. 使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）线条可弹出选项菜单，其中的选项可用于定制线条的外观，如"使用鼠标右键单击线条以定制其外观。" 所示。
使用鼠标右键单击线条以定制其外观。
    • 箭头指向和箭头起始 将箭头置于线条的任意一端（或同时置于两端）。
    • 粗 使线条宽度交替显示为粗或细。默认情况下，线条是细的。
    • 虚线 使线条交替显示为虚线或实线。默认情况下，线条是实线。
    • 颜色 显示 JMP 调色板，用来更改形状的颜色。
    • 重新定位 重新定位形状。
    • 删除 从报表曲面移除形状。您还可以通过选择形状，然后按下 Delete（或 Backspace）键的方式，来移除形状。

添加多边形或样条

要向报表窗口添加多边形（也称为样条），请执行以下操作：

  1. 单击工具选用区中的多边形工具 ( [image])。
  2. 单击创建多边形第一条边的起始点。
  3. 在要完成第一条边的位置再次单击，然后开始绘制邻边。此时将在多边形区域的周围出现一个带图柄的选择方框。
  4. 第三次单击，完成第二条边。
  5. 继续此过程，直到成功创建所需的多边形。每次完成一条边后，选择框都将调整大小以包围多边形的各边。
  6. 双击释放多边形工具。

添加多边形后，您可以执行以下操作：

操作 | 说明
选择或撤消选择多边形 | 单击已完成的多边形的边缘。
调整多边形的大小 | 选择它并拖动选择框的其中一个图柄。
移动多边形 | 在框的图柄之间单击并拖动选择框。
更改多边形的边数 | 单击并拖动各边以形成一个新形状。

选择多边形，然后使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）它，这将弹出一个可用于定制其外观的选项菜单，如"使用鼠标右键单击多边形以定制其外观。" 所示。

使用鼠标右键单击多边形以定制其外观。
    • 填充 交替填充或清空形状区域。
    • 上凸 在形状周围显示粗阴影线条。如果该图形同时已填充，则图的下边缘会向上凸起，呈现出三维效果。
    • 平滑 使多边形的顶点显得平滑，产生 Bezier 曲线效果。经平滑处理的图形可像多边形一样调整形状和大小，并且可填充和上凸。
    • 闭合 交替打开或关闭多边形的最后一段。
    • 颜色 显示 JMP 调色板，用来更改形状的边的颜色以及启用“填充”选项时的填充颜色。
    • 重新定位 重新定位形状。
    • 删除 从报表移除形状。您还可以通过选择形状，然后按下 Delete（或 Backspace）键的方式，来移除形状。

添加椭圆或矩形

要向报表窗口添加椭圆或矩形，请执行以下操作：

  1. 单击工具选用区中的简单形状工具 ( [image])。
  2. 在要插入形状的位置单击并拖动。此时将出现一个周围有选择框的椭圆。
  3. （可选）使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）椭圆的边缘，并选择形状，将椭圆变为矩形。

添加形状后，您可以执行以下操作：

  • 选择该形状并拖动选择框的其中一个图柄，可调整形状或大小。
  • 单击并拖动选择框的边缘（位于两个图柄之间），可移动它。
  • 选择该形状，然后使用鼠标右键单击（在 Macintosh 中为按住 Ctrl 键并单击）它，这将弹出一个可用于定制其外观的选项菜单，如"使用鼠标右键单击椭圆或矩形以定制其外观。" 所示。
使用鼠标右键单击椭圆或矩形以定制其外观。
    • 填充 交替填充或清空形状区域。
    • 上凸 在形状周围显示粗阴影线条。如果该图形同时已填充，则图的下边缘会向上凸起，呈现出三维效果。
    • 形状 显示一个子菜单，其中的选项可用于将选定形状转换为椭圆或矩形。
    • 颜色 显示 JMP 调色板，用来更改形状的边的颜色以及启用填充选项时的填充颜色。
    • 重新定位 重新定位该形状。
    • 删除 从报表移除形状。您还可以通过选择形状，然后按下 Delete（或 Backspace）键的方式，来移除形状。

添加图形（仅适用于 Windows 和 Macintosh）

要使用徽标、图片或任何其它类型的图形来增强图形效果，您可以将它以 .bmp、.jpeg 或 .png 格式粘贴到报表中。您也可以将图形拖放到报表中。

要添加图形，请执行以下操作：

  1. 打开该图形文件并选择图形。将它复制到计算机的剪贴板上。
  2. 在图形内使用鼠标右键单击。
  3. 选择粘贴。图形将插入图形中使用鼠标右键单击的点。

通过将图形复制到计算机内存，并确保在报表为活动窗口时选择编辑 > 粘贴，您还可以将图形添加到报表窗口的末尾。

添加和编辑图形脚本

具备报表后，您就可以添加用于将图形元素插入报表的脚本。

要向报表添加图形脚本，请执行以下操作：

  1. 使用鼠标右键单击该图形。
  2. 选择编辑 > 添加图形脚本。
  3. 键入或粘贴脚本。
  4. 如果要在图形数据之前插入使用脚本创建的图形对象，请单击在数据前绘制旁边的框。

如果已添加图形脚本并需要编辑它，请按照上面的说明进行操作，但选择的是编辑图形脚本。

"使用 JSL 语句修改过的分析窗口" 中的实例显示了变量身高和体重的二元分析。其中添加了一个图例（通过使用鼠标右键单击图形并选择行图例），以不同颜色的标记标识性别。通过重新使用鼠标右键单击该图形，选择编辑 > 添加图形脚本，然后输入脚本，可在图上以体重的最大值和最小值绘制水平虚线。

使用 JSL 语句修改过的分析窗口


重新构造数据表

辅助设置、合并以及其它

您可以对 JMP 数据执行很多不同的数据管理任务：

  • 根据另一个数据表的行和列的子集创建新数据表
  • 按任意多个列排序
  • 将多列堆叠成一列
  • 将一列拆分成两列
  • 转置行和列
  • 首尾相连合并多个表
  • 并排合并两个表
  • 使用一个表中的值更新另一个表中的列

目录

创建子集表

根据直方图创建子集表

对数据表排序

堆叠列

堆成一列实例

堆成多列实例（使用多序列堆叠选项）

拆分列

拆分列实例

转置行和列

转置实例

附加表（合并）

合并列名相同的表实例

合并列名不同的表实例

连接表

如何连接表

连接表实例

更新表

更新表实例


创建子集表

您可以创建一个新数据表，它可以是活动数据表中所有行和列的子集、高亮度显示的行和列的子集或随机选择的行的子集。

要创建子集，请执行以下操作：

  1. 选择表 > 子集。此时将显示"子集窗口" 中的窗口。
子集窗口
  2. 从列表中选择行选项：
    • 所有行 创建一个包含活动表中所有行的子集表。
    • 选定行 创建一个只包含活动表中选定行的子集表。
    • 随机 - 抽样率 创建一个子集表，其中的数据与活动数据表成随机比例。在文本框中输入所需的样本比例。例如，如果您想要随机抽取 50% 的数据包括在新表中，请在文本框中输入 0.5。
    • 随机 - 样本大小 创建一个子集表，其中的数据是活动数据表的随机样本。在文本框中输入所需的样本大小。例如，如果您想要在新表中包括 16 个随机行，请在文本框中输入 16。
  3. 从列表中选择列选项：
    • 所有列 创建一个包含活动表中所有列的子集表。
    • 选定列 创建一个只包含活动表中选定列的子集表。
  4. 请使用下表进一步自定义您的子集表：
    操作 | 说明
    输出表名 | 要命名子集表，请在输出表名旁边的框中键入一个名称。
    链接至原始数据表 | 使子集表以及其中的任何图形链接至原始表，单击链接至原始数据表旁边的框。
    复制公式 | 要将原始表中的公式包括在输出列中，请单击复制公式旁边的框。如果数据表中没有公式，此选项将不会出现。
    屏蔽公式计算 | 要阻止 JMP 在创建新表的过程中计算列中的公式，请单击屏蔽公式计算。如果数据表中没有公式，此选项将不会出现。

提示：要快速地创建子集表，请高亮度显示要作为子集的行，然后按住 Shift 键并选择表 > 子集。JMP 创建链接的子集表，但不要求您完成“子集”窗口。

根据直方图创建子集表

在创建包含直方图的输出（通过选择分析 > 分布）之后，您可以使用直方图来创建一个新数据表，其中包含直方图中高亮度显示的条形柱中的数据。

要创建子集，请双击高亮度显示的条形柱。或者，使用鼠标右键单击（在 Macintosh 中按住 Ctrl 键并且单击）直方图中的任意位置，然后从菜单中选择子集。此时将出现子集表，如"根据直方图创建的子集" 所示。

根据直方图创建的子集


对数据表排序

您可以按列的升序或降序对 JMP 数据表进行排序。默认情况下是按列的升序对数据表进行排序。您既可以创建一个包含排序后的值的新表，也可以使用排序后的表替换掉原始表。

如果列中包含值标签（请参阅"使用值标签"），则排序时根据的是实际的数据值而不是值标签。但是，值标签仍然会显示在排序后的数据表中。

要排序，请执行以下操作：

  1. 选择表 > 排序。此时将显示"排序窗口" 中的窗口。
排序窗口
  2. 高亮度显示要作为排序依据的列的名称。
  3. 单击依据按钮，将它们添加到排序列表中。您添加到列表中的列将建立排序的优先顺序。列表中的第一列是主要排序字段。以后的每个变量都在排序列表的上一个变量中排序。
  4. 请使用下表进一步自定义排序：
    JMP 中的选项 | 说明
    升序/降序按钮 ( [image]) | 要更改 JMP 列出分组变量的值的顺序（升序或降序），请从分组变量列表中选择一个变量，然后单击升序/降序按钮 ( [image])。变量旁边图标的变量表示排序顺序。要返回至上一个排序顺序，请再次单击 a...Z/Z...a 按钮。
    替换表 | 要使用排序后的表替换原始数据表，而不是使用排序后的值创建新表，请单击替换表旁边的框。如果仍然存在根据原始表生成的任何打开的报表窗口，此选项将不可用。
    输出表名 | 要命名子集表，请在输出表名旁边的框中键入一个名称。
  5. 在输出表旁边的框中键入新排序表的名称。
  6. 单击排序。

要执行本例的下面部分，请打开您安装 JMP 时安装的 Sample Data 文件夹中的爆玉米花.jmp 文件。"按升序或降序排序" 显示的是原始格式（顶部的表）的爆玉米花.jmp 数据表，以及按爆玉米花和产量（爆玉米花内）排序后的数据表（底部的表）。

按升序或降序排序


堆叠列

您可以通过将两列或多列堆成一个新列并且保留其它列中的值来重新排列数据表。或者，您可以将一组列堆成多个组。下表中的步骤 3 将会向您介绍堆叠列的不同方法。

要堆叠列，请执行以下操作：

  1. 选择表 > 堆叠。此时将出现如"堆叠窗口" 所示的窗口。
堆叠窗口
  2. 高亮度显示要堆叠的列的名称，然后单击堆叠列。
  3. 请使用下表进一步自定义堆叠过程：
    JMP 中的选项 | 说明
    多序列堆叠
            要将选定的列堆成两列或更多的列，请选定多序列堆叠旁边的框。在序列数框中输入一个数字，从而指定您堆叠选定列时的目标列数。当您选定多序列堆叠旁边的框时，此框将出现。有关详情，请参阅"堆成多列实例（使用多序列堆叠选项）"。 注：您向右面的框中添加列的顺序将确定它们所属的组。

    按行堆叠     		如果不选定按行堆叠，JMP 将堆叠另一行下面的一列。如果选定它，JMP 将按行堆叠列。
    排除缺失行

    要排除新表中的缺失行，请选定排除缺失行旁边的框。如果已经选定按行堆叠，则 JMP 只会排除包含所有缺失数据的行。
    删除未堆叠的列

    如果只想将已堆叠的列显示在新表中，请选定删除未堆叠的列旁边的框。如果未选定，新表中将包含原始表中的所有列还有新堆叠的列。
    输出表名 | 要命名新表，请在输出表名旁边的框中键入一个名称。
    已堆叠的数据列 | 要为包含已堆叠的列数据的列指定一个名称，请在已堆叠的数据列框中输入一个名称。如果没有为新堆叠的列输入名称，默认情况下它的名称为数据。如果不想此列显示在新表中，请将此框留空。
    来源标签列
            要为包含原始表中的列名的列指定一个名称，请在来源标签列框中输入一个名称。默认名称为标签。如果不想此列显示在新表中，请将此框留空。
    复制公式 | 如果要将原始表中的公式也包括在输出列中，请单击复制公式旁边的框。如果数据表中没有公式，此选项将不会出现。
    屏蔽公式计算 | 要阻止 JMP 在创建新表的过程中计算列中的公式，请选定屏蔽公式计算旁边的框。如果数据表中没有公式，此选项将不会出现。

堆成一列实例

"堆叠窗口和堆叠列实例" 中左侧的数据表显示的是名为爆玉米花试验.jmp 的 JMP 样本数据表，其中包含的两列分别列出了在不同条件下进行的两次爆玉米花试验的产量。研究人员想要数据表仅显示一个包含试验产量的列。他想将两个名为产量1 和产量2 的列堆成一列（默认情况下，新列名为堆叠）。

通过选择表 > 堆叠并且填写"堆叠窗口和堆叠列实例" 中间显示的窗口，研究人员可以创建一个新表，位于"堆叠窗口和堆叠列实例" 的右侧。名为标签的列是来源标签列，用于标识数据来源。它的值是原始表（堆叠值来源于此）中的列名。

堆叠窗口和堆叠列实例

堆成多列实例（使用多序列堆叠选项）

假设某个研究人员已经找到位于"多序列堆叠实例" 顶部的数据表。她的目标是让 A1、A2、A3 和 A4 在第一列，B1、B2、B3 和 B4 在第二列，C1、C2、C3 和 C4 在第三列，因此她选择表 > 堆叠，然后使用“堆叠”窗口中的多序列堆叠选项。她指定 3 作为序列数，因为她想要输出表包含 3 个堆叠列。另外，她还按顺序添加了这些列，从而反映出她想要这些列在已分组的序列中显示的顺序。

多序列堆叠实例


拆分列

您可以将一列拆分成几个新列，从而根据活动表创建新数据表。拆分列时依据的是在另一列中找到的值，也称为拆分依据列。您也可以根据一个或多个分组变量的值来拆分列。

要拆分列，请执行以下操作：

  1. 选择表 > 拆分。此时将显示"拆分窗口" 中的窗口。
拆分窗口
  2. 高亮度显示要拆分的列的名称，然后单击拆分列。
  3. 高亮度显示要使用其中的值作为新列名的列，然后单击拆分依据。该列名将出现在拆分依据框中。
  4. 请使用下表进一步自定义拆分过程：
    JMP 中的选项 | 说明
    组 | 要使用分组变量，请高亮度显示一个或多个列，其中的值可以唯一标识新表中的每一行，然后单击组。这些列将成为您的分组变量。每个组都可以在输出表中产生一行。
    输出表名 | 要命名新表，请在输出表名旁边的框中键入一个名称。
    复制公式 | 如果要将原始表中的公式也包括在输出列中，请单击复制公式旁边的框。如果数据表中没有公式，此选项将不会出现。
    屏蔽公式计算 | 要阻止 JMP 在创建新表的过程中计算列中的公式，请单击屏蔽公式计算。如果数据表中没有公式，此选项将不会出现。
    全部保留 | 要将所有列都包括在新表中，请单击剩余列区域中的全部保留选项。
    全部删除 | 如果只想将拆分中使用的列包括在新表中，请单击剩余列区域中的全部删除选项。
    选择 | 要选择将哪些列保留在新表中，请单击剩余列区域中的选择选项。然后，选择要保留在新表中的列。
  5. 单击拆分。

拆分列实例

例如，假设您想要重新排列"拆分实例" 顶部的表，使其类似于下面的表。选择表 > 拆分将显示 "拆分实例" 中的窗口。在本例中，“拆分”窗口指定由产量的每个值构成一个新列。试验是拆分标签列变量。它的值用作新表中的列名（产量 1 和产量 2）。

拆分实例


转置行和列

您可以创建一个新的 JMP 表，它是活动数据表的转置形式。其中，活动表的列是新表的行，活动表的行是新表的列。

在转置列时，您可以：

  • 选择要转置的列
  • 指定一个“标签”列，新列可以从中得到自己的名称（可选）。
  • 指定“依据”列，它将通知 JMP 转置组内的数据（可选）。

您要转置的列必须具有相同的数据类型。另外，如果列中包含值标签（请参阅"使用值标签"），则转置时根据的是实际的数据值而不是值标签。

要转置行和列，请执行以下操作：

  1. 打开包含您要转置的行和列的数据表。
  2. 选择表 > 转置。此时将显示"转置窗口" 中的窗口。如果自动显示在要转置的列框中的列不是您要转置的列，请高亮度显示它们，然后单击移除。
转置窗口
  3. 高亮度显示左侧的选择列框中要转置的列名。
  4. 单击转置列。
  5. 要进一步自定义您的转置，请执行以下操作：
    JMP 中的选项 | 说明
    标签 要使用原始表的列数据作为新表中的列名，请执行以下操作：
    1. 高亮度显示左侧的选择列框中的列。
    2. 单击标签。该列名将出现在标签框中。
    请注意，您只能为标签列中的每个唯一值创建一列。因此，如果标签列中出现重复的值，JMP 只会使用最后一个重复的行中的值为重复值创建一列。
    依据 | 要根据您在依据框中放入的列将转置列整理成组，请高亮度显示选择列框中要将其值看成组的列名，然后单击依据。
    仅转置选定行 | 如果只想转置活动表中当前高亮度显示的行，请单击仅转置选定行旁边的框。
    输出表名 | 要命名子集表，请在输出表名旁边的框中键入一个名称。
  6. 单击转置。转置后的数据表将出现在屏幕上。新表中还有一个名为标签的附加列，其值是原始表的列名。

以下规则适用于转置：

条件 | 结果
原始表有列但没有行 | 新表中包含一列，它会列出这些列的列名。
原始表中有一列并且分配给标签 | 它的值将成为转置表中的列名。
原始表具有多个列并且包含一个标签列 | 当窗口出现时，JMP 会自动将标签列插到标签框中。
原始表中没有标签列 | 转置表中的列名分别为行 1、行 2、...,、行 n，其中 n 表示原始表的行数。

转置实例

"简单转置" 中的原始表（也就是顶部的表）包含两行和三个名为塑胶、锡和黄金的连续列。选择表 > 转置将创建如右侧所示的转置表。转置表的行分别对应于实例表的三个列，而它的列行 1 和行 2 则对应于原始表中的行。另外还有一个名为标签的列，它使用原始表中的列名（塑胶、锡和黄金）作为它的值“塑胶”、“锡”和“黄金”。

简单转置

"使用标签转置" 顶部的表与"简单转置" 使用同一个原始表，但是它包含一个名为物料的附加列。选择表 > 转置并且指定您要使用项列作为新表的列标签将创建如右侧所示的表。此新表使用活动表中的项列的值作为转置表中的列名。

使用标签转置

"组内转置" 显示的是如何转置数据组但不转置整个数据表。选择表 > 转置并且指定依据组将创建如底部所示的表。此新表包含已转置在组中的值。

组内转置


附加表（合并）

当您在 JMP 中合并表时，您可以附加它们，以便为原始表中的每个列名在新表中创建一列。如果您要合并的表中的列名相同，新表中的列将会列出所有表中的值以便于合并。如果两个原始表具有名称不同的列，这些列将都包括在新表中并且显示出缺失值。

要合并两个列名相同的数据表，请执行以下操作：

  1. 选择表 > 合并。此时将显示"合并窗口" 中的窗口。
合并窗口
  2. 高亮度显示要添加到活动数据表末尾的表名，然后单击添加。
  3. （可选）单击保存并计算公式旁边的框，以请求 JMP 包括原始数据表中的所有公式（包括在那些不属于匹配列的列中找到的公式）并且计算这些公式。如果未单击此选项，JMP 将不会在新表中包括任何公式。
  4. （可选）单击创建来源列旁边的框以在新表中添加一个名为“Source Table”的列。此列将在对应行中标识出来源表名。
  5. 单击确定。

合并列名相同的表实例

假设您想要合并两个列名相同的数据表，如"合并列名相同的表" 所示。在选择表 > 合并之后，"合并列名相同的表" 中的窗口将出现在屏幕上并会列出所有打开的 JMP 数据表：试验1 和试验2。请注意，这些表具有相同的列名。要合并，请从窗口左侧的列表中选择它们，然后单击添加。单击合并以将数据表合并成一个无标题的新表，其中的所有行都来自于第一个数据表，而第一个数据表的所有行都来自于第二个数据表。

合并列名相同的表

合并列名不同的表实例

在合并后的表中，原始数据表中的每个列名都有对应的一列。例如，在"合并列名不同的表" 左侧显示的表中，试验1.jmp 中的产量1 和试验2.jmp 中的产量2 包含类似的信息（为了说明如何合并列名不同的表，我们已经更改列名）。但是，右侧显示的新合并表中包含以上两个变量的列。这些列具有表中某些行上的缺失值，该表中不存在列。此时，名为试验的列将出现在这两个表中并且合并在一起，从而在新表中生成一个新列。

合并列名不同的表

您可以根据需要合并任意多个表。新表中的行数就是所有表中行数的总和。


连接表

通过选择表 > 连接，您可以将两个数据表合并成一个新表。通过以下三种不同的方法可以合并数据表：

  • 按照行号合并数据表（请参阅"如何连接表"和"实例 1：按行号连接"）。
  • 在笛卡儿方法中，您可以生成一个新表，其中包含两个原始表中所有可能的行组合（请参阅"如何连接表"和"实例 2：笛卡儿连接"）。
  • 通过匹配两个数据表中一个或多个列中的值（请参阅"如何连接表"和"实例 3：按匹配列连接"）。

如何连接表

要将两个数据表连接成一个新表，请执行以下操作：

  1. 选择表 > 连接。在出现的窗口中，所有打开的表的名称将出现在与...连接的下面，如"连接窗口" 所示。
连接窗口
  2. 在与...连接框中，高亮度显示要与活动表连接的表。
  3. 选择如何从匹配规格区域连接表：
    • 按行号 并排连接两个表。
    • 笛卡儿连接 使用笛卡儿方法连接两个表，它会生成一个新表，其中包含两个原始表中所有可能的行组合。JMP 会将第一个表中的数据与第二表中的数据交叉，从而显示每个集中的所有值组合。
    • 按匹配列 当您选择此选项时，窗口展开并且提示您为要连接的行选择两个表中值和数据类型必须匹配的列。您应该：
    • 高亮度显示来源列区域的每个列表中的列名。顶部列表中第一个高亮度显示的列与底部列表中第一个高亮度显示的列配成一对，第二列配成一对，依此类推。只有在所有列对的值和数据类型全都匹配的情况下，才能连接行。
    • 单击匹配。选定的列对将显示在匹配列框中。匹配列不一定要具有相同的列名，也不一定要在两个表中的同一位置。
    • （可选）要只包括找到的第一个匹配项，请选定与两个表中的删除多项关联的框。此时，JMP 只会将找到的第一个匹配项写到新表中。如果您为一个表指定此选项，则第一个匹配值将与另一个表中的所有匹配项连接在一起。如果未选定与某个表中的删除多项关联的框，则 JMP 将对每组匹配列值执行笛卡儿连接。
    • （可选）要包括数据表中的所有行，即使没有匹配值的行也包括在内，请选定与包括非匹配项关联的框。您可以为要连接的任意一个表或同时为两个表指定此选项。
  4. 在输出表名旁边的文本框中键入新表的名称。
  5. 请参照下表进一步指定合并数据表的方式：
    JMP 中的选项 | 说明
    选择已连接表的列
            如果您想要从要包括在输出表中的某个表中选择列子集，请选择为合并表选择列选项。然后，执行以下步骤：
    1. 在来源列区域中，高亮度显示要包括在新表中的每个表中的列。
    2. 单击输出列区域中的选择。
    使用第二个表中的数据更新第一个表

            在选定使用第二个表中的数据更新第一个表之后，第二个表中的列数据将用于更改原始表中同名列的数据。 注：
    • JMP 不会使用缺失值替换数据。
    • 输出表使用的列与原始表相同。因此，当您使用使用第二个表中的数据更新第一个表时，为合并表选择列选项将不适用。
    • 只有在按行号或按匹配列合并时，使用第二个表中的数据更新第一个表选项才可用。
    合并具有相同名称的列

            如果您想要使用第二个表中的数据替换原始表中同名列的数据，而不管它们是否属于缺失值，请单击合并名称相同的列旁边的框。
    如果按匹配列合并，新表中将包含一个名为匹配标志的列。
    • 如果 1 出现在此列中，表示数据来自于第一个（活动）表。
    • 如果 2 出现在此列中，表示数据来自于第二个表。
    • 如果 3 出现在此列中，表示您在第一个表和第二个表中都能找到这些数据。
    复制公式
            要将原始表中的公式包括在输出列中，请单击复制公式旁边的框。
    屏蔽公式计算 | 要阻止 JMP 在创建新表的过程中计算列中的公式，请单击屏蔽公式计算旁边的框。
  6. 单击确定查看新数据表。

连接表实例

下面将介绍一些如何使用连接命令的实例。

实例 1：按行号连接

按行号连接表是指并排连接两个表，因此新表中将同时包括上述两个表中的所有列（除非您指定只包括其中的某些列）。

连接行数不等的表

如果您要连接的两个表的行数不相等，新表中将包括在这两个表中找到的所有行的值。例如，如"按行号连接表" 所示，如果要将一个只有两行的表（左侧的表）与一个只有四行的表（中间的表）连接起来，新表（右侧的表）中将包含四行。

按行号连接表

连接名称相同的列

如果两个表中某些列的名称相同，则这些列在新表中的名称将显示为“表名的列名”。例如，如果您要连接名为动物数据.jmp和爬行动物数据.jmp的两个表，它们中都有一个名为性别的列，则新表中将包含两个名为动物数据的性别和爬行动物数据的性别的列，如"按行号连接表" 所示。

按行号连接表

还有一个类似的例子，假设您想要将每个数据表中的八行（如"试验1.jmp 和试验2.jmp 数据表" 所示）合并成一个表。您要合并它们，以使新表中包含两个原始表的所有列。要执行本例的下面部分，请打开您安装 JMP 时安装的 Sample Data 文件夹中的试验1.jmp 和试验2.jmp 两个数据表。

试验1.jmp 和试验2.jmp 数据表
  1. 选择表 > 连接，"连接窗口" 中的窗口将出现在屏幕上。
连接窗口
  2. 高亮度显示与...连接框中的试验2。
  3. 然后，单击确定，结果是如"连接后的表" 所示的数据表。
连接后的表

请注意，如果两个原始表中的列名相同，输出列名只能是来源表名。例如，新表中的列名为“表名的变量名”。

只连接指定列

第二个实例使用的数据表与上一个实例相同，假设您不想将原始数据表中的所有列都包括在合并后的表中。您只想将试验1 列表中的爆玉米花和产量列以及试验2 中的产量列包括在合并后的表中。

  1. 选择表 > 连接。
  2. 高亮度显示与...连接框中的试验2。
  3. 单击输出列区域中的选择已连接表的列，然后指定所需的列子集。
  4. 从来源列列表中的两个表中选择所需的所有列，然后单击选择。在本例中，从试验1 列表中选择爆玉米花和产量，从试验2 列表中选择产量。此时，输出列区域中的框将列出您想要包括在新表中的所有列。表试验1 和试验2（"只连接指定列"）的爆玉米花列数据相同，因此只需要将它们中的一个包括在连接后的表中。
  5. 单击确定。

新表将只包含选定列，如"只连接指定列" 所示。

只连接指定列

实例 2：笛卡儿连接

在进行笛卡儿连接时，JMP 会使用笛卡儿方法连接两个表，它会生成一个新表，其中包含两个原始表中所有可能的行组合。这会使输出表中产生多种可能，而且每种可能只对应于列值的一种组合。例如，如"使用笛卡儿方法连接表" 所示，JMP 将表 a 中的数据与表 b 中的数据交叉以便显示每个集中的所有值组合（名为笛卡儿连接的表）。

使用笛卡儿方法连接表

下面我们举另一个例子，假设您想要构建一个 JMP 表，其中的行对应于爆玉米花实例中不同试验条件下的各个水平组合。

首先，您有"笛卡儿连接实例" 顶部显示的三个小表：油量.jmp、包型.jmp 和爆玉米花.jmp。每个表都是两行一列。其中的值是爆玉米花产量试验的试验类别。

在本例中，您必须使用表 > 连接命令两次。第一次连接是使用“笛卡儿”选项将油量.jmp 与包型.jmp 合并。此次连接将生成"笛卡儿连接实例" 中左下方所示的表，其中包含两个原始表中的所有列。另外，油量.jmp 中的每个值与包型.jmp 中的每个值配成一对，生成一个包含四行的新表。

第二次连接是将新表（笛卡儿油量 + 包型）与爆玉米花.jmp 合并，从而生成"笛卡儿连接实例" 中右下方所示的表（已连接所有表）。这个最终的数据表中的行对应于每个试验条件，而且可用于记录爆玉米花试验的结果。切记，笛卡儿连接生成的行数就是所有原始表中行数的乘积。

笛卡儿连接实例

实例 3：按匹配列连接

在按匹配列连接时，JMP 会查找两个表中的指定列值，然后将与该值关联的所有值合并成一个新的数据表。请注意，要按匹配列连接，这些列必须具有相同的数据类型（数字、字符或行状态）。

按不同顺序连接具有相同行的表

假设您有一个数据表，其中包含学生的姓名、年龄和性别。您还有另一个数据表，其中包含学生的姓名、身高和体重。这次我们不是要处理这两个单独的表，而要将它们合并成一个，如"按匹配列连接学生1.jmp 和学生2.jmp" 所示。然后，您可以随时运行任何适用的分析。

您意识到学生的姓名在这两个表中的顺序不同。例如，Alice 在第一个表中的第 7 行，但在第二个表中位于第 9 行。

"按匹配列连接学生1.jmp 和学生2.jmp" 显示的是两个原始表以及您要创建的新表。

按匹配列连接学生1.jmp 和学生2.jmp

要连接这两个表，以使新表中包含 Alice 以及其他学生的姓名、年龄、性别、身高和体重，请执行以下操作：

  1. 选择表 > 连接，然后从与...连接框中选择试验2。

由于这两个表中有一列（姓名）包含相同的值，因此您要通知 JMP 它们之间可能有相同项。之后，JMP 将检查第一个表中姓名列中的每个值，看看它们在第二个表的姓名列中是否具有对应的值。例如，它会检测两个表中是否都有 Alice。然后，它会在新表中创建一个姓名列，并且使用 Alice 作为其中的值。它会将表 1 中 Alice 的年龄和性别放在新表中，同时将表 2 中 Alice 的身高和体重也放在新表中。

  2. 选择匹配规格区域中的按匹配列。
  3. 高亮度显示试验1 列表中的姓名以及试验2 列表中的姓名，然后单击匹配。完整的窗口应类似于"匹配列" 中显示的内容。
  4. 如果您只想新表中包含每个姓名的一行，请选定两个表中的删除多项框。然后，单击确定。
匹配列

连接行数和列名均不相同的表

要执行本实例，请打开安装 JMP 时安装的 Sample Data 文件夹中的试验1.jmp 和少量.jmp 两个数据表。

假设 Sarah 和 Joe 正在进行爆玉米花试验。她们使用不同的油量爆了不同类型的玉米花（gourmet 和 plain）。她们正在记录生成的玉米花量（产量）。

Sarah 在名为试验1.jmp 的文件中提供了第一次试验的数据。Joe 在名为少量.jmp 的文件中提供了第二次试验的数据。"两个表" 显示了这两个表。

两个表

在检查收集到的数据之前，您发现如果将 Sarah 和 Joe 的表连接成一个表（例如"合并表的外观" 中的表）将会方便得多。

合并表的外观

要连接 Sarah 和 Joe 的表，请执行以下操作：

  1. 选择表 > 连接。
  2. 将少量识为要与试验1 连接的表。

这两个表都有三列（爆玉米花、油量和包型），而且上述三列包含相同的值。您可以将 JMP 中的列唯一标识为“匹配”。此外，由于 Sarah 和 Joe 为油量列指定的名称不同，因此您要通知 JMP 油量和油实际上是相同的两列。

  3. 选择“匹配规格”区域中的按匹配列。
  4. 高亮度显示试验 1 列表中的爆玉米花、油量和包型。
  5. 高亮度显示少量列表中的爆玉米花、油和包型。
  6. 单击匹配。

就像您在"两个表" 中看到的一样，Sarah 已经完成了她的试验，但是 Joe 只完成了试验的一部分。因此，您从 Sarah 和 Joe 那里收到的表具有不同的行数：试验1.jmp 包含 8 个试验条件的值；而少量.jmp 只包含 4 个试验条件的值。

您想要新表包含在试验1.jmp 中找到的所有行，即使在少量.jmp 表中该行包含缺失值。

  7. 为这两个表选定包括不匹配项框。

在新表中，您只想包括一列爆玉米花、一列油和一列包型。但是，您需要两列产量 —“试验1”中的产量和“少量”中的产量。

  8. 因此，请选定选择已连接表的列旁边的框。
  9. 高亮度显示试验1 列表中的爆玉米花、油量、包型和产量，然后单击选择。
  10. 高亮度显示少量中的产量，然后单击选择。
  11. 确保完成后的窗口与"按匹配列合并窗口" 完全吻合，然后单击确定。
按匹配列合并窗口

JMP 将创建如"按匹配列连接的表" 所示的表。现在，新表将按匹配列排序，如"按匹配列连接的表" 所示。请注意，少量.jmp 中的产量列（“少量”中的产量）具有缺失值，而试验1 中没有匹配的值。

按匹配列连接的表


更新表

如果您有两个数据表并且想要使用一个表中的数据更新另一个表，请选择表 > 更新。

在更新表之前，请确保您要替换的值所在的列的列名与替换所用的数据所在的列的列名相同。

要使用另一个打开的表中的值替换活动表中的值，请执行以下操作：

  1. 单击要更新的表（也就是要替换其值的表），使其成为活动表。
  2. 选择表 > 更新。在出现的窗口中，活动表的名称将出现在列表上方，如"更新表" 所示。
更新表
  3. 高亮度显示包含您要转移的数据的表。
  4. 如果这两个表中有一列或多列的值可以唯一标识每行，JMP 将使用这些列作为匹配列值。也就是说，JMP 将更新匹配列值完全相同的行。JMP 使用这些列来保留数据已经排好的顺序。如果您的表没有匹配列值，您可以继续执行步骤 5，按它们的行顺序来组合更新后的值。但是，要继续处理包含匹配列值的表，请执行以下操作：
    1. 选定匹配列。此时将出现如"当您单击“匹配列”时，此窗口将出现。" 所示的屏幕。
当您单击“匹配列”时，此窗口将出现。
    1. 高亮度显示要匹配的两个列名（在各自的表中）。
    2. 单击匹配。反复匹配多列。

      注：JMP 会将不匹配的列名以及两个表之间不同的列名作为单独的列添加到第一个表的末尾。
  5. 如果您不想要 JMP 使用在第二个表中找到的缺失值替换第一个表中的值，请单击忽略缺失值旁边的框。如果在第二个表中对应的值是缺失值，第一个表将继续保留它的原始值。
  6. 单击确定。

更新表实例

假设某个研究人员有一个名为大班.jmp 的数据表，同时她又收到一个名为新身高.jmp（"大班.jmp（左）和新身高.jmp（右）"）的数据表，其中包含最近测量的学生身高。

该研究人员不想通过滚动查看大班.jmp 数据表来查找身高发生变化的学生。她也不想复制并粘贴或键入新值。她只想快速地使用从新身高.jmp 中得到的最近测量的身高值更新大班.jmp 数据表。

大班.jmp（左）和新身高.jmp（右）

她打开这两个表并且选择表 > 更新。然后选择新身高.jmp（"使用新身高.jmp 更新大班.jmp"）。之后，她单击匹配列。在出现的窗口中，她从这两个表的列列表中选择 姓名，然后单击匹配。也就是通知 JMP 使用姓名作为匹配列值，因为姓名列就是可以其值可以唯一标识每行的列。

使用新身高.jmp 更新大班.jmp

更新后的表如"更新后的表" 所示。

更新后的表


汇总数据

使用汇总和制表命令

您可以对 JMP 数据执行很多不同的数据管理任务：

  • 创建包含汇总统计量列的表
  • 将数据制成表，以便以表格的形式显示它们。

目录

汇总列

创建汇总表

向现有的汇总表中添加统计量列

统计量说明

添加统计量列实例

绘制数据表

如何使用制表命令创建表

“制表”窗口中的表元素

单击并拖动项

插入分组列

插入分析列

使用对话框

在“制表”窗口中编辑表

其它制表选项

绘制数据表实例


汇总列

利用表 > 汇总命令可以计算不同的汇总统计量，其中包括均值和中位数、标准差、最小值和最大值、极差、合计百分比、总和方差、标准误差、变异系数以及用户指定的分位数。

在汇总表中：

  • 您指定的分组变量的每个水平都有对应的一行。如果未指定分组变量，则整个数据表对应一行。
  • 如果具有多个分组变量，则表中的行对应于所有分组变量的水平组合。
  • 除了每个分组变量具有一列之外，表中还包含一个名为行数的频数列，其中的值是每个分组水平的计数。
  • 汇总表和它的来源表已经链接起来。因此，当您选择汇总表中的行时，其来源表中的对应行也会高亮度显示。
  • 如果来源表中的列包含值标签，则这些值标签也会显示在新表中。
  • 除非您选择文件 > 另存为为汇总表指定名称和位置，否则在关闭汇总表时，JMP 不会保存它。
使用一个分组变量创建汇总表的实例

创建汇总表

要创建汇总表，请执行以下操作：

  1. 打开数据表。
  2. 选择表 > 汇总 。此时将显示"汇总窗口" 中的窗口。
汇总窗口
  3. 要添加列，并且这些列显示的是来源表中任意数值列的汇总统计量（例如均值、标准差和中位数等），请执行以下操作：
    1. 在“汇总”窗口中，高亮度显示要用于计算统计量的列。
    2. 单击统计量按钮。
    3. 从统计量下拉菜单中选择一个标准一元描述性统计量。统计量如"统计量说明"中所述。"添加汇总统计量" 中的实例将会介绍如何生成分组变量每个水平的盈利/雇员均值。
  4. 如果您要按组汇总统计量，请高亮度显示要作为分组变量的列，然后单击组以将该变量移到分组变量列表中。有关实例，请参阅"添加统计量列实例"。
    1. 对您需要的任意多个分组变量重复这一步骤。
    2. 要更改 JMP 列出分组变量的值的顺序（升序或降序），请从分组变量列表中选择一个变量，然后单击升序/降序按钮 ( [image])。变量旁边图标的变化表示排序顺序的变化。
    3. 要在输出列中添加边缘统计量（为分组变量），请单击包含边缘统计量旁边的框。除了为每个分组变量添加边缘统计量外，JMP 还会在表末尾添加一行，用于显示整个表的汇总统计量。"包含边缘统计量的汇总表" 显示的是分组变量类型和公司大小以及它们的边缘统计量的汇总表。
包含边缘统计量的汇总表
  5. 要添加特定的分位数统计量，请在对于分位数统计量下面的框中键入第一个分位数的所需分位数值 (%)（例如 25）。
  6. 要更改统计量列的列名格式，请从统计量列名格式下拉菜单中选择一种格式。"更改列名的显示方式" 显示的是可供选择的选项。默认情况下，列名格式为统计量（来源列），其中统计量是在“汇总”窗口中选择的统计量，来源列是在“汇总”窗口中选择的来源表中的列。
更改列名的显示方式
  7. 要命名子集表，请在输出表名称旁边的框中键入一个名称。
  8. 要通过添加子组变量来创建汇总统计量的双因子表，请执行以下操作：
    1. 高亮度显示要用作嵌套变量的列。这些就是您的“子组变量”。
    2. 单击子组将变量移到子组列表中。
    3. 高亮度显示要按子组汇总其统计量的列。
  9. 单击确定。

向现有的汇总表中添加统计量列

在创建完汇总表之后，您可以为来源表中的任意数值列添加一些描述性汇总统计量列，如"具有汇总统计量列的汇总表实例" 所示。

具有汇总统计量列的汇总表实例

要在以前创建的汇总表中添加统计量列（如"创建汇总表"中所述），请单击数据网格左上角的红色三角形图标（如"在数据表内创建汇总统计量列" 所示），然后选择添加统计量列。此时屏幕上将显示“汇总”窗口。

在数据表内创建汇总统计量列

统计量说明

您可以为来源表中的任意数值列添加一些描述性汇总统计量列，具体方法是单击统计量按钮（"添加汇总统计量"），然后从下面介绍的统计量下拉菜单中选择一个标准一元描述性统计量。

添加汇总统计量
统计量下拉菜单将提供数值列的以下汇总统计量：
  • 数目 非缺失值的数目。
  • 均值 某列中值的算术平均值。它等于所有非缺失值的总和（如果定义的话，还要乘以权重变量）除以权重和。
  • 标准差 根据非缺失值计算出来的样本标准差。它等于样本方差的平方根。
  • 最小值 某列中的最小非缺失值。
  • 最大值 某列中的最大非缺失值。
  • 极差 最大值与最小值的差值。
  • 合计 % 每组总数的百分比。或者，如果您已经指定，也可以表示列中非缺失值数占每组总数的百分比。
  • 缺失项数 缺失值数。
  • 总和 列中所有值的总和。
  • 权重和 列中所有权重值的总和（请参阅"为列指定预选定的分析角色"）。或者，如果没有为任何列指定权重角色，则权重和表示非缺失值的总数。
  • 方差 根据非缺失值计算出来的样本方差。它等于与均值差的平方和除以非缺失值数减 1。
  • 标准误差 均值的标准误差。它等于标准差除以 N 的平方根。如果已经为某列指定权重角色，则分母等于权重和的平方根。
  • CV（变异系数） 离差的测量值，也就是标准差除以均值，然后乘以 100。
  • 中位数 50%，也就是一半的值在它下面，另一半的值大于或等于第 50 个分位数（中位数）。
  • 分位数 指定一个值，从而使特定百分比的自变量小于或等于此值所在的位置。例如，75% 的数据小于第 75 个分位数。“汇总”窗口中有一个编辑框，您可以在其中输入所需的分位数百分比。

添加统计量列实例

假设某个研究人员正在使用公司.jmp 数据表，它按类型和公司大小对公司进行分组。要执行本例的下面部分，请打开您安装 JMP 时安装的 Sample Data 文件夹中的公司.jmp 文件。

假设研究人员想要：

  • 创建一个表，其中显示小型、中型和大型计算机公司以及小型、中型和大型制药公司中每位雇员的平均盈利情况（也就是创建一个表，其中以公司的各种规模作为行，以每种类型的公司中每位雇员的平均盈利情况作为列）。
  • 创建这样一个表，以使单元格包含子组的均值（通过行与列的交叉部分来定义）。

该研究人员首先选择表 > 汇总，然后选择公司大小作为分组变量，因为他想要使该列中的值变成新表中的行。然后，他高亮度显示盈利/雇员并且单击统计量按钮，进而从下拉菜单中选择均值来计算盈利/雇员的均值。接着，他高亮度显示类型并且单击子组按钮，以将其标识为子组变量。这也就是通知 JMP 为子组变量（类型）中每个水平（计算机，制药）的每位雇员的平均盈利情况创建一列（均值（盈利/雇员））。所得的结果即为"子组的汇总统计量" 中显示的汇总表。

子组的汇总统计量


绘制数据表

使用表 > 制表命令来构建描述性统计量表。这些表是根据分组列、分析列以及统计量关键字构建的。“制表”命令是一种非常强大而灵活的方法，通过它可以使用表格的形式显示汇总表，而且可以使用它的交互界面来定义和修改表，如"表实例" 所示。

表实例

如何使用制表命令创建表

“制表”窗口中的报表由一个或多个并排相连的列表以及一个或多个首尾相连的行表构成。报表只能包含列表或行表。

使用交互表创建表的过程实际上一个迭代的过程：

  1. 单击并且拖动相应列表中的项（列列表中的列名或关键字列表中的统计量）。请参阅"“制表”窗口中的表元素"中有关交互表中元素的说明。
    注：如果您更喜欢使用对话框而不是交互表，有关详情，请参阅"使用对话框"。
  2. 将维度（行表或列表）中的项放到您要放置项标签的位置。
    有关详情，请参阅"单击并拖动项"和"“制表”窗口中的表元素"。
  3. 在创建完表之后，请重复上面的过程添加项。表会随时更新以反映出最新添加的项。如果已经存在列标题或行标签，您可以决定相对于现有项来说，要在哪里添加新的项。

“制表”窗口中的表元素

本节将定义制表过程中使用的术语。

列表和行表

在制表过程中，表是通过它的列标题和行标签来定义的。因此，我们将它们分别称为列表和行表。

列表和行表实例

分组列

分组列是指用于将数据分成不同信息类别的列。它们可以具有字符、整数甚至小数值，但是对使用的特殊值数目有所限制。

如果具有多个分组列，制表命令将根据列值的分层嵌套构建不同的类别。

例如，根据值为 F 和 M 的分组列“性别”以及值为已婚和单身的分组列“婚姻状况”，制表命令将构建 4 个不同的类别：F 和已婚、F 和单身、M 和已婚、M 和单身。

您可以为列表以及行表指定分组列。它们结合起来将生成一些可定义每个表单元格的类别。

制表过程中不会包括一个或多个分组列中具有缺失值的观测值。

分析列

分析列是指要计算其统计量的任意数值列。它们一般是连续的列。制表过程会计算根据分组列构建的每个类别的分析列中的统计量。

请注意，所有分析列必须驻留在同一维度（行表或列表）中。

统计量

制表命令支持标准统计量列表。此列表显示在控制面板中。您可以将任何关键字从该列表中拖到表中，就像对列一样。

JMP 会根据分组列所定义的类别中所有观测值的分析列中的值，计算与每个单元格关联的统计量。

请注意，所有需要的统计量必须驻留在同一维度（行表或列表）中。

下面将定义制表过程中使用的一些关键字。"统计量说明" 中将列出详细的说明。

  • 数目是指无分析列时的默认统计量。
  • 总和是指表中无其它统计量时分析列的默认统计量。
  • 分位数用于指定一个值，从而使特定百分比的自变量小于或等于此值所在的位置。例如，75% 的数据小于第 75 个分位数。通过单击“分位数”关键字并且将其拖到表中，然后在出现的框中输入分位数，您可以申请使用不同的分位数。
  • 合计 % 用于计算样本总体的合计百分比。计算公式中使用的分母是所有观测值的合计，分子是类别合计。如果没有分析列，合计 % 是指总计数的百分比。如果有分析列，合计 % 是指分析列总和的合计百分比。因此，分母是分析列所有包含的观测值的总和，分子是分析列该类别的观测值的总和。
    • 如果将一个或多个分组列从表中拖到合计 % 标题中，将会更改分母定义。为此，制表过程将使用这些分组列的总和作为分母。
    • 要获得列合计的百分比，请将行表中的所有分组列拖放到合计 % 标题中。同样，要获得行合计的百分比，请将列表中的所有分组列拖放到合计 % 标题中。
  • 全部是适用于分组列的特殊关键字。当您想要将分组列各个类别的汇总信息综合到一起时可以使用它。例如，假设表中的某个分组列是性别，它有两个类别 F 和 M。在添加关键字全部之后，JMP 将创建第三个名为全部的类别，如"使用“全部”关键字" 所示。此类别可以将 F 和 M 两组的统计量综合起来。JMP 是单独将此关键字添加到表中的，没有与其它统计量关键字和列一起添加。
使用“全部”关键字

列对类别

“列对类别”是分组列的一个变形。它们是独立的分组列，但是共享一组通用值。当一组分组列共同用作“列对类别”时，JMP 将生成一个由这些列中的列名和类别构成的交叉表格。其中的每个单元格均由一列和一个类别构成。如果您是在“列”表中定义的“列对类别”，则对应的类别将自动用于定义行表。

例如，某个研究人员通过一些是非问题收集了雇员的调查数据。"通过将列添加为“列对类别”来绘制表格" 顶部的表是使用每个问题的肯定响应数和否定响应数制成的表。这一表格是通过将所有列（除了第一列）添加为“列对类别”生成的。

"通过将列添加为“列对类别”来绘制表格" 底部的表通过分解运算 (DivCode) 继续分解该表。

通过将列添加为“列对类别”来绘制表格

单击并拖动项

每个列标题都有两个区域：上区和下区。在将每个列标题拖到相应的区域之后，光标形状将变成矩形，表示您可以将列标题放到该位置。

  • 如果放在上区，JMP 会将新项放在已拖放的添加项的上面（前面）。
  • 如果放在下区，JMP 会将新项放在已拖放的添加项的下面（后面）。

每个行标签都有两个区域：左区和右区。

  • 如果放在左区，JMP 会将新项放在已拖放项的左面（前面）。
  • 如果放在右区，JMP 会将新项放在已拖放项的右面（后面）。

在正确创建的表中，所有分组列排放在一起，所有分析列排放在一起，所有统计量排放在一起。因此，JMP 不会在分析列列表中放入统计量关键字，也不会将分析列插到分组列列表中。

如果项的角色非常明显（例如是关键字或字符列），当您拖放时，JMP 就会自动使用给定的项填写表。此外，您也可以利用弹出式菜单选择项的角色。弹出式菜单上包括的角色有：

  • 添加分组列 如果您要使用变量对数据进行分类，请选择添加分组列。如果具有多个分组列，制表命令将创建变量的分层嵌套结构。
  • 添加分析列 如果您要计算这些列的统计量，请选择添加分析列。
  • 列对类别 如果列是独立的分组列（也就是没有分层嵌套）并且共享一组类似但数据值不同的集，而且您想要按列对类别的布局交叉制表，请选择列对类别。
  • 单独表的分组列 如果您有多个独立的分组列，并且您想为每个分组列生成单独的表，请选择单独表的分组列。

插入分组列

要插入分组列，请单击某个列名或统计量关键字并且将其拖放到表中。从出现的菜单中选择添加分组列，如"添加分组列实例" 所示。如果将其作为分组列添加到表中是唯一合理的选择，JMP 会自动将其作为分组列插入到表中，弹出式菜单也不会出现。

添加分组列实例

插入分析列

要插入分组列，请单击某个列名或统计量关键字并且将其拖放到表中。从出现的菜单中选择添加分析列，如"添加分组列实例" 所示。如果将其作为分析列添加到表中是唯一合理的选择，JMP 会自动将其作为分析列插入到表中，弹出式菜单也不会出现。

使用对话框

如果您不喜欢通过单击并拖放操作交互构建表，您可以使用对话框界面创建一个简单的表。在选择表 > 制表之后，请从构建表的工具旁边的下拉菜单中选择对话框，如"使用对话框" 所示。此对话框与“汇总”对话框（请参阅"汇总列"）非常相似，生成的表与汇总表的布局也类似。在更改使用对话框生成的表时，您可以使用与更改通过拖放操作生成的表相同的方法。

使用对话框

在“制表”窗口中编辑表

JMP 为您提供了很多方法来编辑要添加到表中的项。

更改数值格式

每个单元格的格式由分析列和统计量来决定。计数的默认格式中不含小数位。对于某些统计量定义的每个单元格，JMP 都会尝试使用所需的分析列和统计量格式确定一个最合理的格式。要改写默认格式，请执行以下操作：

  1. 单击“制表”窗口底部的更改格式按钮。
  2. 在出现的窗口中（"更改数值格式"），输入您要显示在表中的字段宽度、逗号以及小数位数。如果您想要 JMP 确定您要使用的最佳格式，请在文本框中键入最佳一词。这样，JMP 就会考虑每个单元格值的精度，然后选择最佳的显示方式。
  3. 单击确定。
更改数值格式

删除项

在添加项之后，您也可以通过单击“取消”按钮来删除它们。您也可以使用鼠标右键单击表中的项，然后从出现的菜单中选择删除（"删除项"）。

删除项

移除列标签

将光标定位在列上可以在与该列关联的类别顶部显示列名。对于某些列，列名好像有些多余。因此，请使用鼠标右键单击列名，然后选择移除列标签（"使用鼠标右键单击以显示菜单"），以便从列表中删除列名。要重新插入列标签，请使用鼠标右键单击某个与它关联的类别，然后选择恢复列标签。

使用鼠标右键单击以显示菜单

编辑统计量关键字和标签

有时，您可能会想要编辑统计量关键字或变量的标签。例如，您可能想要使用 Average 一词代替 Mean。要进行编辑，请使用鼠标右键单击您要编辑的关键字，然后选择更改项标签 （"使用鼠标右键单击以显示菜单"）。在出现的框中，键入新标签（"编辑项"）。

编辑项

请注意，如果您要将一个统计量关键字更改成另外一个统计量关键字，JMP 会假设您实际上是想要更改统计量，而不仅仅是更改标签。这就好像您已经从表中删除统计量，然后又添加一样。

其它制表选项

“制表”窗口的底部还有许多复选框，您可以利用它们来控制工具提示和阴影。

  • 显示工具提示 当您在表的各个区域中移动鼠标时，显示相关提示。
  • 显示明暗 如果表中有多行，则在表中显示灰色的阴影框。

通过单击“制表”窗口中的红色三角形图标还可以使用其它选项。它们显示在"检验样板" 中。

检验样板
  • 显示表 以表格的形式显示汇总数据。
  • 显示图表 在条形图中显示汇总数据，从而反映出汇总统计量表的结构。利用简单的条形图，您可以直观地比较汇总统计量的相对大小。默认情况下，所有条形柱使用相同的尺度。通过撤消选定均匀图形刻度复选框，您可以让每个条形柱使用根据每个显示列中的数据单独确定的刻度。此外，图表还允许您指定均匀的自定义刻度。图表要么以 0 为尺度基准，要么以 0 为中心。如果数据全部非负或全部非正，图表将以 0 作为基准线。否则，图表将以 0 为中心。
  • 显示控制面板 显示控制面板，以便进一步执行交互操作。
  • 显示检验样板 显示一个控制区域，它允许您使用原始表中的某些值创建“检验体”。有关详情，请参阅"使用大量数据（检验体功能）"。
  • 制成数据表 根据报表制成数据表。每个行表均有一个对应的数据表，因为不同行表的标签不能映射至同一个结构。有关详情，请参阅"将报表转换为数据表"。
  • 脚本 显示保存脚本、重做分析以及查看数据表等选项。有关详情，请参阅"将步骤保存为脚本"。

使用大量数据（检验体功能）

如果您的数据表很大，您可能会想要使用小的数据表子集来尝试构建不同的表布局，从而寻求一个最佳的途径来显示汇总信息。在这种情况下，JMP 将根据指定要求生成随机大小的子集，然后在构建表时使用该子集。要使用检验体功能，请执行以下操作：

  1. 单击“制表”标题栏中的红色三角形图标。
  2. 选择显示检验样板。
  3. 在样本大小 (>1) 或抽样率 (<1) 下面的框中输入所需的样本大小，如"检验样板" 所示。样本大小可以与您输入的活动表成一定的比例，也可以是活动表中的行数。
检验样板
  4. 单击再取样。
  5. 要查看 JMP 数据表中的取样数据，请单击检验数据视图按钮。当您不想使用检验样板时，“制表”窗口将按照设计好的布局使用完整的数据表重新生成这些表。

绘制数据表实例

要执行本例的下面部分，请打开您安装 JMP 时安装的 Sample Data 文件夹中的汽车民意测验.jmp 文件。

创建计数表

假设您要查看一个表，其中包含的是调查中拥有日本、欧洲和美国制造的汽车的人数。要创建表，请选择表 > 制表。然后，单击国家并且将其拖放到表的左列，如"在表中添加国家列" 所示。

在表中添加国家列

接下来，进一步在表中添加统计量和变量。您想要查看按汽车外型尺寸细分的驾驶日本、欧洲和美国制造的汽车的人数。为此，请单击汽车尺寸并且将其拖放到国家的旁边，如"在表中添加汽车尺寸列" 所示。

在表中添加汽车尺寸列

创建显示统计量的表

现在，假设您要查看拥有各种外型尺寸汽车的人的年龄均值和标准差：

  1. 单击年龄并且将其拖放到表中汽车尺寸的右侧。从出现的菜单中选择添加分析列。
  2. 单击均值并且将其放到表中总和的上面。
  3. 单击标准差并且将其拖放到表中年龄的右侧。

结果将显示在"包含年龄均值和标准差的表" 中。

包含年龄均值和标准差的表

重新排列表的内容

通过单击汽车尺寸并且将其拖放到表的右侧更改数据视图，如"移动汽车尺寸列" 所示。

移动汽车尺寸列

现在，单击年龄并且将其拖放到表中 Large 的下面。单击均值和标准差并将它们拖放到表中大型的下面。结果将显示在"移动项的结果" 中。

移动项的结果

现在，您的表已经将所有数据清晰地显示出来。您很容易就能知道按汽车外型尺寸和国家细分的车主年龄均值和标准差。


使用公式编辑器

构建公式

按照"为列指定用于计算值的公式"中所述，您可以创建通过公式计算值的列，并且将该公式存储为列信息的组成部分。公式可以是数值、字符或行状态常数的简单赋值，也可以包含基于条件子句的复杂计算。JMP 的公式编辑器为您提供这些功能，并且还允许您随时检查或更改公式。

公式编辑器窗口与袖珍型计算器一样，有按钮、显示区和函数列表。

公式是数据表不可分割的组成部分，这是因为：

  • 在您保存数据表时，公式作为列信息的组成部分保存。
  • 您可以通过打开公式编辑器随时检查或更改公式。
  • 公式的值可以链接至或取决于其它列的值。只要您编辑与公式链接的列中的值，系统就会自动重新计算公式的值。
  • 公式的值在数据表中被锁定，因此，不能手动编辑公式值。

本章介绍公式编辑器并说明如何建立公式。

目录

创建公式

引用列和表变量

使用局部变量

合并参数

插入常数

添加运算符

使用函数

引用行

添加数值函数

插入对数函数或三角函数

添加字符自变量和返回字符串

比较值

使用条件子句

计算分位数和概率

计算统计函数

生成随机数

使用日期和时间

处理行状态数据

使用赋值函数

公式中表达式的排序

按优先顺序建立公式

使用公式编辑器选项

计算导数

简化复杂公式

计算公式

忽略错误

在公式编辑器中查看公式值

在 JSL 中查看公式

编辑公式

更正错误

选择表达式

删除函数

剪切、复制和粘贴

单击并拖动

自定义公式

更改字体大小

隐藏和显示外框

更改公式的方向

打开和关闭自变量

实例和教程

使用基本公式编辑器功能

在公式中使用局部变量

使用 Munger 函数

使用 Match 条件函数

使用键盘快捷方式

术语表


创建公式

公式是存储在列中的表达式，它执行运算以便将值插入到该列中。公式可以执行数学运算，如加法和乘法，也可以通过参考同一数据表中的其它区域来比较列值或连接值。公式可以由任何符合标准的 JMP 脚本语言 (JSL) 命令组成。一旦您将公式插入到列中，列将被锁定：只有通过更改公式，才能编辑列的值。

建立一个公式有三个基本步骤：

  1. 通过使用鼠标右键单击要应用公式的列名并选择公式，打开公式编辑器。
    或者
    双击要应用公式的列名，从列性质下拉菜单中选择公式，然后单击编辑公式。
  2. 在公式编辑区域中单击空白的公式元素以将其选中。（当公式元素有红色外框时表示公式已被选中。）与您单击之处相关的最小嵌套框中的所有项都将被选中。之后的操作适用于这些组合的元素。
  3. 在公式工作面板中添加表达式、函数和（或）项。它们将被应用到高亮度显示的红色方框。本章中的以下部分详细说明如何添加常数、元素、运算符和函数。
如何建立公式

有关如何使用公式编辑器的实例，请参阅"使用基本公式编辑器功能"。


引用列和表变量

您可以创建一个公式，该公式引用数据表其它部分（如其它列和表变量）中的值。

如果您创建了一个公式，该公式引用其它列中的值，则包含该公式的列中的值取决于其它那些列中的值。只要公式引用的列发生变化，则相关列也会相应地变化。如果您删除引用的列，则包含该公式的列中将出现空白项。

如果您创建一个公式，该公式引用表变量中的值，则这些表变量必须已经在数据表中。表变量是可用于整个表的字符串，它们的名称显示在数据网格左边的表面板中（有关详情，请参阅"添加表变量"）。

要建立一个公式，该公式引用列或表变量中的值，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击方框以将其选中。（红色的外框表示已被选中。）
  3. 单击公式元素浏览器中的下拉菜单，选择表列或表变量，如"公式元素浏览器" 中所示。然后，高亮度显示该类别列表中元素。元素将被添加至公式编辑区域的选定框中。
公式元素浏览器

有关在公式中引用列的实例，请参阅"使用基本公式编辑器功能"。


使用局部变量

您可以创建临时数字变量，然后在表达式中使用。您可以使用普通的局部变量，或者您可以使用参数，参数是特殊类型的局部变量。局部变量仅在定义了它们的列中以变量的形式存在。在公式中，它们显示为加粗的斜体项。

局部变量通常与赋值函数一起使用（有关详情，请参阅"使用赋值函数"），赋值函数可以将表达式赋值给复杂方程式中使用的局部变量。此方法有时可以简化方程式的建立，并且提高计算的效率。

要建立一个公式，该公式引用局部变量中的值，请执行以下步骤：

第 1 步：创建局部变量

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击方框以将其选中。（红色的外框表示已被选中。）
  3. 单击公式元素浏览器中的下拉菜单，从公式元素浏览器下拉菜单中选择局部变量。
  4. 单击新建局部变量。
  5. 键入局部变量的名称。默认情况下，局部变量的名称为 t0、t1 等，并且具有缺失值。
  6. 指定一个起始值，然后单击确定。
  7. （可选）要复制、编辑或删除局部变量，请使用右键单击（Macintosh 中为按住 Ctrl 键并单击）局部变量的名称，然后选择复制、编辑或删除。

第 2 步：将局部变量插入到公式中

  1. 在公式编辑区单击某个项以将其选中。（红色的外框表示已被选中。）
  2. 在局部变量列表中单击局部变量的名称。在公式中，局部变量名称显示为加粗的斜体项。

    注：创建局部变量的另一种方法是使用公式编辑器键区中的 [image] 按钮，它将自动创建并显示局部变量，并且在后面加上一个分号。有关详情，请参阅"添加运算符"。

有关在公式中引用局部变量的实例，请参阅"在公式中使用局部变量"。

合并参数

参数是特殊类型的局部变量。它们可以象普通的局部变量那样用于公式中。

要查看参数实例，请打开安装 JMP 时安装的 Sample Data 文件夹中的 Nonlinear Examples 文件夹 > 美国人口.jmp。然后使用鼠标右键单击列名 x 公式，并且从公式元素浏览器中选择参数。

请注意：

  • 在完成非线性拟合或者使用非线性控制面板中的重置按钮之后，参数的值就是最近由非线性平台计算的值。
  • 如果计算流程更改了参数值，则新值则会显示在参数列表中。
  • 在您将带参数的公式粘贴到列中时，系统将自动为该列创建参数，除非列已经具有相同名称的参数。

要建立一个公式，该公式引用参数中的值，请执行以下操作：

第 1 步：创建参数

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 确保在公式编辑区域中选择了某一项（在公式编辑区域中有红色的外框）。
  3. 单击公式元素浏览器中的下拉菜单，从公式元素浏览器下拉菜单中选择参数。
  4. 单击新建参数。
  5. 键入参数的名称。默认情况下，参数的名称为 b0、b1 等，并且具有缺失值。
  6. 指定一个起始值，然后单击确定。在非线性平台的模型中使用参数时，输入此值是非常重要的。在完成非线性拟合之后，参数的值就是最近由非线性平台计算的值。
  7. （可选）要复制、编辑或删除参数，请使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）参数的名称，然后选择复制、编辑或删除。

第 2 步：将参数插入至公式中

  1. 在公式编辑区单击某个项以将其选中。（红色的外框表示已被选中。）
  2. 单击参数列表中的参数名称。在公式中，参数显示为粗体类型。


插入常数

公式可以是数值、字符或行状态常数的简单赋值，也可以包含基于条件子句的复杂计算。常数包括常用的数值项，例如 e、pi、-1、0、1 和 2。有两种方法将常数值添加至公式：

  • 使用键盘手动键入常数值。
  • 在公式元素浏览器中选择常数值，如"公式元素浏览器" 中所示。
公式元素浏览器

要建立包含常数的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击方框以将其选中。（红色的外框表示已被选中。）
  3. 可以键入一个数字，或者单击公式元素浏览器上面的下拉菜单并选择常数，如"公式元素浏览器" 中所示。然后单击显示的列表中的值 - 0、1、2、-1、pi 和 e。值显示在带外框的方框中。
  4. 使用键区和（或）函数完成构建公式的其它步骤（请参阅"引用列和表变量"、"添加运算符"和"使用函数"）。


添加运算符

通过单击键区（如"键区" 中所示），您可以将运算符添加至公式中，键盘中包括一组用于帮助建立公式的按钮。它由常用的运算符（也称为函数）组成。

键区

要使用屏幕键区中的运算符建立公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击方框以将其选中。（在它有红色的外框时表示已被选中。）运算符将对高亮度显示的区域执行运算。
  3. 单击键区按钮。有关使用键区的实例，请参阅"使用键区运算符的实例"。
使用键区运算符的实例

使用下表可以了解屏幕键区按钮。

键 | 名称 | 说明
 | 算术按钮 | 就象在袖珍型计算器上一样正常使用，提供了加、减、乘、除运算符。
 | Insert | 插入新子句或函数自变量。首先选择要在其后插入新元素的现有子句或自变量，然后单击此按钮。新子句将显示并且被选中。通过键入逗号，您还可以插入新子句或自变量。
 | 删除 | 删除元素的值，或者删除子句。删除按钮的功能与键盘上的 Delete 键的功能相同。
 | 指数 | 计算某个值的指定次方。默认的指数是 2。最初乘方被高亮度显示，并且可以更改为其它值。
 | Root | 计算被开方数的指定方根。默认的方根指数是 2（平方根），它不会显示。最初方根指数被高亮度显示，以便您能够输入其它指数值。
 | 转换项 | 确定选定表达式中间的运算符，然后转换运算符两边的表达式。
 | 一元正负号函数 | 颠倒自变量的正负号。将一元正负号函数应用于变量表达式，或者使用它来输入负常数。
 | 局部变量 | 创建并显示局部变量，并且将选定表达式的值赋值给该变量。在表达式中局部变量的默认名称为 t0，名称后面有分号。有关创建和插入局部变量的详情，请参阅"使用局部变量"。有关实例，请参阅"实例和教程"。
 | 删除表达式（剥除） | 删除选定的表达式并将选定的空白项留在原位。重复此流程，以便从选择的第一项开始，按照公式的优先顺序逐项删除公式项，如"反复单击删除表达式按钮，将会产生下面一系列的步骤"中所示。屏幕上的删除表达式按钮还允许您从函数的自变量中剥除函数。要执行此操作，请选择函数及其自变量，然后单击此按钮。函数及其除第一个自变量之外的其它所有自变量都将被删除。有关详情，请参阅"删除函数"。

反复单击删除表达式按钮，将会产生下面一系列的步骤


使用函数

您可以在公式中添加许多类型的函数。所有这些函数都被整理在函数浏览器中，该浏览器将一系列的函数和功能组成列表，在列表中按字母顺序（函数（所有））和主题（函数（分组））组织这些函数和功能，如"函数浏览器" 中所示。使用函数浏览器指定您要针对公式中的元素执行的计算类型。

函数浏览器

要创建包含函数的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（在它有红色的外框时表示已被选中。）函数将针对高亮度显示的区域执行运算。
  3. 单击函数浏览器中的下拉菜单，查看函数的分组。
  4. 选择要查看的一组函数。属于该组的函数则会显示在下拉菜单下面的列表中。下面的列表中简要地介绍了函数组。有关详尽的说明，请参阅以下部分，从"引用行"开始。
    • 函数（所有） 按字母顺序显示所有可用函数的列表。
    • 函数（分组） 显示按主题分组的所有可用函数的列表。
    • 行 显示包含辅助函数（如 Lag、Dif、Subscript、Row 和 NRow）的函数列表。有关详情，请参阅"引用行"。
    • 数值 显示属于公式中常用项的函数的列表。有关详情，请参阅"添加数值函数"。
    • 超越 显示自然对数、常用对数、指数、方根、阶乘、组合、beta 和 gamma 等函数的列表。有关详情，请参阅"插入对数函数或三角函数"。
    • 三角 显示属于标准三角函数（正弦、余弦、正切、反函数和双曲线函数）的函数的列表。有关详情，请参阅"插入对数函数或三角函数"。
    • 字符 显示对字符自变量执行操作（修整、查找字符串长度，将数字更改为字符或将字符更改为数字）的函数的列表。有关详情，请参阅"添加字符自变量和返回字符串"。
    • 比较 显示属于标准逻辑比较（如小于、小于或等于、不等于等等）的函数的列表。有关详情，请参阅"比较值"。
    • 条件 显示类似于编程函数（如 If、Match 和 Select）的函数的列表。有关详情，请参阅"使用条件子句"。
    • 概率 显示计算标准统计分布（如正态分布、学生 t 分布、卡方分布和 F 分布）的概率和分位数的函数的列表。有关详情，请参阅"计算分位数和概率"。
    • 统计 显示计算标准统计数量（如平均差或标准差）的函数的列表。有关详情，请参阅"计算统计函数"。
    • 随机 显示根据预定义分布（如均匀分布、正态分布、柯西分布等）生成随机数的函数的列表。还有一个函数用于完全打乱表行的顺序。有关详情，请参阅"生成随机数"。
    • 日期时间 显示要求自变量是日期数据类型的函数的列表，日期数据类型自 1904 年 1 月 1 日起以秒数表示。日期时间函数返回日、星期、或一年中的月份等值。它们还可以计算日期并且可以找到数据间隔。有关详情，请参阅"使用日期和时间"。
    • 行状态 显示用于指定或检测以下六种行状态的函数的列表：颜色、标记、标签、隐藏、排除或选定。有关详情，请参阅"处理行状态数据"。
    • 赋值 显示将赋值运算符右边的值放到运算符左边变量中的函数的列表。有关详情，请参阅"使用赋值函数"。
  5. 单击函数列表中的任意函数，以便将函数应用于选定项。在您单击某些项时，您就会展开一个可以从中选择的子菜单。

    注：大多数公式通过在公式编辑区域的方框中插入灰色文字，提供有关相应自变量的提示。如果可以添加其它的条件自变量，公式还会在自变量区域中显示一个小的 ^ 符号。
  6. 通过在公式元素浏览器、键区或函数浏览器中高亮度显示并单击项，以继续建立公式。

引用行

在公式中添加一个行函数，使您可以引用特定行或特定行中的单元格。它允许您插入辅助函数，如 Lag、Dif、Subscript、Row 和 NRow。要引用行，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择行，如"从函数浏览器列表中选择行" 中所示。行函数此时显示于下拉菜单下面的列表中。
从函数浏览器列表中选择行
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"行函数"。

添加数值函数

您可以创建一个公式，该公式中包含公式中常用的算术运算符，如取绝对值、模运算和取整。要在公式中添加这样的数值项，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择数值，如"从函数浏览器列表中选择数值" 中所示。数值函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择数值
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"数值函数"。

插入对数函数或三角函数

您可以创建支持超越函数的公式，如任意底数的对数函数、组合计算的函数、Beta 函数和多个 gamma 函数。要添加超越函数，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择超越，如"选择超越" 中所示。超越函数此时显示于下拉菜单下方的列表中。
选择超越
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"超越函数"。

JMP 还支持大多数三角函数。要创建一个使用了三角函数的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择三角，如"从函数浏览器列表中选择三角" 中所示。三角函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择三角
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"超越函数"。

添加字符自变量和返回字符串

您可以创建一个公式，该公式接受字符自变量或返回字符串，并且将一个值的数据类型从数值转换为字符，或者从字符转换为数值。在您创建这些公式时，请注意：

  • 字符函数可以产生字符或数值数据。如果您计算的数据类型不同于指定的数据类型，则计算的列的数据类型将自动改变，以便与结果相符。
  • 在字符函数产生的字符值超出分配的字段宽度时（该宽度在“列信息”窗口中指定，双击列名便可以访问该窗口），字符字段的长度将自动增加，以便存放计算的结果。
  • 属于文字字符串的自变量必须使用引号括起来。

要建立包含字符函数或返回字符串的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择字符，如"从函数浏览器列表中选择字符" 中所示。字符函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择字符
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"字符函数"。

有关实例，请参阅"使用 Munger 函数"。

比较值

您可以创建一个公式，比较两个自变量的值。您可以使用比较函数完成此操作。每个比较关系根据数值大小或字符等级求出真或假值。真关系计算的值为 1，假关系计算的值为 0。

在条件表达式中包含比较很有用，但是，如果两个比较项都不缺失，则比较也可以作为数值表达式单独使用。

关系符号的自变量可以是任意两个表达式。但是，比较函数中的两个自变量必须属于同一种数据类型。另请注意：

  • 如果在条件表达式中应该使用“==”的位置您使用了单“=”，则 JMP 将显示错误。
  • 公式编辑器在比较字符串时使用“国际实用程序”软件包。该软件包包含每一个国际字符集的不同等级，并且考虑了附加符号。
  • 尤其是在与缺失值比较时，您不应该使用比较运算符。而应使用 Is Missing 函数，检测缺失值（请参阅"比较值"）。

要建立包含比较函数的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择比较，如"从函数（分组）列表中选择比较" 中所示。比较函数此时显示于下拉菜单下方的列表中。
从函数（分组）列表中选择比较
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"比较函数"。
  5. 在表示 a 和 b 的框中输入值。

使用条件子句

您可以在公式中包含条件表达式（简称条件）。这些表达式使您可以建立与结果表达式成对的一连串子句。在您要有条件地给计算的列中的单元格赋值时，构造一连串子句是一种方法。条件表达式遵循以下规则：

  • 在没有子句为真时，公式编辑器将计算与 else 子句在一起的结果表达式的值。
  • 条件表达式中所有结果表达式的值必须属于相同的数据类型。
  • 缺失项与任何数据类型都匹配。
  • 根据定义，求出的值为零的表达式为假。
  • 如果求出的表达式值为缺失值，则不执行子句并且返回缺失值。其它所有数值表达式为真。

要建立包含条件子句的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择条件，如"从函数浏览器列表中选择条件" 中所示。条件函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择条件
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"条件函数"。

有关实例，请参阅"使用 Match 条件函数"。

计算分位数和概率

您可以创建一个公式，该公式计算各种标准统计分布的分位数和概率。要计算分位数和概率，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择概率，如"选择概率" 中所示。概率函数此时显示于下拉菜单下方的列表中。
选择概率
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"概率函数"。

计算统计函数

您可以在公式中使用两种统计函数：

  • 名称前缀为 Col 的函数。这些函数计算数值列或涉及列的表达式的统计量。
  • Mean、Std Dev、Number、Sum、Quantile、Maximum、Minimum 和 N Missing 函数。这些函数在列或自变量间求值。在自变量序列间计算每一行的统计量。您可以使用屏幕键区中的插入按钮 ( [image])，或者键入逗号，在接受多个自变量的函数中添加自变量。在有多个相邻的自变量时，可以选择函数和第一个自变量，然后按住 Shift 键并单击组中的最后一个自变量。则这些函数会自动显示完整的自变量列表。

要创建包含统计函数的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择统计，如"从函数浏览器列表中选择统计" 中所示。统计函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择统计
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"统计函数"。

生成随机数

您可以创建公式，这些公式在指定的分布约束范围内象“掷骰子”一样生成实数。每次您单击公式编辑器窗口中的应用时，这些函数都将产生一组新的随机数。

注：随机数是使用 Mersenne-Twister 演算法生成的数字。此方法的周期长度是 219937-1（而 JMP 4.03 和早期版本中所用生成器的周期长度是 231-1）。Matsumoto 和 Nishimura 在 1998 年出版的文献中详细介绍了生成器。根据 Marshalled 1996 年出版的文献记载，新的生成器经过证实，通过了所有 DIEHARD 测试。

要创建包含随机数的公式：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择随机，如"从函数浏览器列表中选择随机" 中所示。随机函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择随机
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"随机函数"。

使用日期和时间

JMP 使用 Macintosh 标准（自 1904 年 1 月 1 日起以秒数表示）在数值列中存储日期和时间。在列中有日期值时，您可以双击列名，并从格式菜单中选择日期或时间，为该列指定日期格式。有关详情，请参阅"数值格式选项"。

要在公式中使用日期和时间，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择日期时间，如"从函数（分组）列表中选择比较" 中所示。日期和时间函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择日期时间
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"日期时间函数"。

处理行状态数据

数据表中的行可能具有以下六种性质：选定、隐藏、排除、已加标签、已加色和已加标记。如果您为行指定其中一个或多个性质（有关详情，请参阅"为行和列指定特征"），然后创建行状态数据表列（有关详情，请参阅"使用行状态列"），则您可以创建一个计算并保存行状态条件的公式。此公式会象处理字符和数值数据一样，来处理行状态数据。

注：可以给行指定任意组合的行状态；行状态列可以将多个行状态作为一个值。

使用下表可以了解每个行状态函数需要的自变量类型以及每个函数返回的值。

函数名称 | 需要的自变量类型 | 函数的返回值（您的列数据类型应该为此类型）
Row State | 无 | 当前行的行状态
As Row State | 数值 | 当前行的所有行状态
Combine States | 多个行状态自变量 | 多个行状态赋值
Excluded State | 正整数或零 | 行状态 - 排除或不排除
Hidden State | 正整数或零 | 行状态 - 隐藏或不隐藏
Labeled State | 正整数或零 | 行状态 - 已加标签或未加标签
Color State | 整数 | 行状态颜色
Marker State | 整数 0 - 15（黑色） 16 - 31（灰色） | 行状态标记
Selected State | 正整数或零 | 行状态 - 选定或未选定
Hue State | 整数 | 行状态 - 色调
Shade State | 整数 1 - 5 | 行状态 - 强度
Excluded | 行状态() 或行状态列 | 数值 0（未排除）或 1（已排除）
Hidden | 行状态() 或行状态列 | 整数 0（未隐藏）或 1（隐藏）
Labeled | 行状态() 或行状态列 | 整数 0（未加标签）或 1（已加标签）
Color Of | 行状态() 或行状态列 | 彩图整数
Marker Of | 行状态() 或行状态列 | 标记图整数
Selected | 行状态() 或行状态列 | 整数 0（未选定）或 1（选定）

要使用公式处理和存储行状态数据，请执行以下操作：

  1. 确保数据表中的行至少必须有一个性质（请参阅"为行和列指定特征"）。
  2. 确保列的数据类型正确。使用上表确定要给列分配的数据类型（行状态、数值或整数）。要创建行状态数据表列，请参阅"使用行状态列"。要创建数值和整数列，请参阅"关于数据类型"和"如何指定数据类型和建模类型"。
  3. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  4. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  5. 单击函数浏览器中的下拉菜单，并且选择行状态，如"从函数（分组）列表中选择比较" 中所示。行状态函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择行状态
  6. 使用上表帮助选择要插入到公式中的函数。有关每个函数的说明，请参阅"行状态函数"。

使用赋值函数

赋值函数作用于当前位置。也就是说，运算（运算符右边）返回的结果存储在运算符左边的自变量中并且替换自变量的当前值。

赋值语句通常与其它命令结合使用，以建立 JMP 脚本语言 (JSL) 脚本。您可以使用公式编辑器，在该列中创建和执行脚本，但是由于可能造成脚本相互依存和含义不明确，因此建议您不要这样做。通常脚本存储为 .jsl 文件，并且可以与数据表一起保存（有关详情，请参阅"创建脚本"）。有关所有脚本命令的说明文档，请参阅《JMP 脚本指南》。

注：赋值函数的第一个自变量必须能够被赋值。这意味着您的赋值不能象 3+=4 这样，因为 3 是常数值，不能给它重新赋值。您必须首先创建值等于 3 的变量（表变量或局部变量）。（有关表变量的详情，请参阅"添加表变量"。有关局部变量的详情，请参阅"引用列和表变量"。）然后使用该变量作为赋值函数左边的自变量。

要建立包含赋值函数的公式，请执行以下操作：

  1. 通过使用鼠标右键单击数据网格中的列名并选择公式，打开公式编辑器。
  2. 在公式编辑区域中单击某个表达式以将其选中。（红色的外框表示已被选中。）
  3. 单击函数浏览器中的下拉菜单，并且选择赋值，如"从函数浏览器列表中选择赋值" 中所示。赋值函数此时显示于下拉菜单下方的列表中。
从函数浏览器列表中选择赋值
  4. 选择要在公式中插入的函数。有关每个函数的说明，请参阅"赋值函数"。


公式中表达式的排序

在您建立公式时，记住所有函数都遵照下表中列出的优先顺序，第 1 级函数优先顺序最高。程序先计算优先顺序高的表达式的值，然后再计算级别较低的表达式的值。如果表达式中的运算符有相等的优先顺序，则从左至右进行计算。必要时，您可以使用括号以超越其它优先规则，因为程序总是先计算括号中表达式的值。项没有优先顺序，因为无法对它们进一步求值。使用下表了解从第 1 级到第 6 级的优先顺序。

第 1 级 | 圆括号
第 2 级 | 函数浏览器列表中的函数，在其它级别中列出的函数除外
第 3 级 | *, ÷, Modulo
第 4 级 | +, -
第 5 级 | 比较：<, ≤, =, ≠, ≥, >, ≤ x <, < x ≤, < x <
第 6 级 | 逻辑函数：And，Not，Or

注：在函数将表达式作为它的自变量时，该自变量的优先顺序要高于它在函数外部且用括号括起来时的优先顺序。

按优先顺序建立公式

最好从任何用作自变量的表达式开始建立公式。这是因为函数的优先顺序高，并且总是与它对应的自变量组合在一起。如果可能，按从高到低的优先顺序创建表达式也是一个好主意。如果您需要使用括号，确保先键入左括号，然后再输入要括起来的表达式。

例如，假设一个数据表有列 A、B 和 C，则使用下面的步骤来创建表达式 A(B + C)。请注意，此表达式不同于 A x B + C，后者的计算与 (A x B) + C 相同。要输入表达式，请执行以下操作：

  1. 从公式元素浏览器列表中选择表列。
  2. 单击表列列表中的列 A。
  3. 单击公式编辑器键区中的乘法按钮 ( [image])。
  4. 键入左括号 - (。
  5. 单击表列列表中的列 B。
  6. 单击公式编辑器键区中的加法按钮 ( [image])。
  7. 单击表列列表中的列 C。

由于优先顺序确定了各个函数影响的自变量，因此优先顺序也将影响表达式的组合。选择公式中的函数，以核实优先顺序规则的应用情况。

构造计算效率高的公式

通常，没有必要在构造公式时考虑计算效率。多数公式不管其结构如何都可以瞬间完成计算。这是因为在计算列的值时，统计函数和常数表达式只计算一次。

但是，在您创建条件表达式时，记住 Match 条件表达式与等效的条件函数 If 相比，计算速度更快，并且使用内存要少。

考虑用两种公式来根据年龄预测儿童的身高（如"Match 条件表达式要比 If 函数计算的快" 中所示）。在这两个公式中，基本身高都是 58.125 英寸，随着年龄变量值的变化，身高将增加。

Match 条件表达式要比 If 函数计算的快

Match 条件表达式比 If 函数计算的快，是因为对于数据表中的每一行只需要计算年龄变量一次。如果使用 If 条件，则对于每一行必须在每个 If 子句处计算年龄变量，直至计算的子句的值为真。


使用公式编辑器选项

在创建公式时，您可以使用多个公式编辑器选项。以下部分将讨论这些选项。

计算导数

JMP 的公式编辑器可以计算并显示函数的导数。求导是对您高亮度显示的函数自变量（单个变量名）进行的。因此，对 x 求导，x 必须是表达式中的自变量之一。键区上方的红三元图标包含了导数命令，如"从键区菜单命令中选择导数" 中所示。

从键区菜单命令中选择导数

要计算导数，请执行以下操作：

  1. 输入函数。
  2. 高亮度显示变量。
  3. 从菜单中选择导数。"使用导数选项" 显示完成这些步骤的过程。
使用导数选项

简化复杂公式

在公式编辑器包含复杂的公式时，JMP 可以使用各种代数规则进行简化。它可以查找常数表达式、将乘法分配给加法、组合项等等。

要简化复杂公式，请选择公式的一部分或整个公式，单击键区上方的红色图标，然后从显示的下拉菜单中选择简化，如"使用简化（左）生成一个简化的公式（右）" 中所示。

使用简化（左）生成一个简化的公式（右）

计算公式

默认情况下，JMP 将计算您创建的每一个公式，并且在您创建公式时在后台检查公式，以确保公式有效。您可以关闭此计算，或者在完成创建公式之前实施此操作。

屏蔽计算

在建立复杂公式时，关闭计算是一种很有用的公式开发模式。您可以关闭计算，然后建立公式的组成部分，并且只是在需要测试时进行计算。特别是，您可以关闭公式编辑器，在以后的某个时间再打开它以继续建立公式，而且 JMP 不会计算公式的值。

要屏蔽公式计算，请单击键区上方的红色图标，然后从显示的下拉菜单中选择屏蔽计算，如"选择屏蔽计算" 中所示。

选择屏蔽计算

在计算被屏蔽时，会显示一个加号图标（Windows/Linux 中显示为黄色 ( [image])，Macintosh 中显示为黑色 ( [image])）：

  • 如果图标显示在公式编辑器中红三元图标的右边，则表示该公式的公式计算被屏蔽。
  • 如果图标显示在列面板中列名的旁边，则表示列中的值由公式计算得出。在公式计算被屏蔽时，该加号图标将变成灰色（有关详情，请参阅"图标指示器"）。

    注：应用按钮将忽略公式计算设置。因此，在公式计算被屏蔽时，单击应用按钮将不考虑屏蔽而计算公式的值，然后将公式应用于列。

忽略错误

一旦您构建一个公式并且单击确定，JMP 将在后台检查公式是否有错误，然后在发现错误时向您发出警告。对于每个错误都会显示一则错误消息，并且询问您是否要忽略以后的错误。

有时您可能要在开发公式时屏蔽错误消息。如果您要查看一些行的计算结果并且不想看到公式计算发现有问题的每一行的错误消息，在这种情况下，该选项对您很有用。

要使 JMP 忽略发现的任何错误，请执行以下操作：

  1. 创建公式。
  2. 单击键区上方的红三元图标，然后选择忽略错误，如"从键区菜单命令中选择忽略错误" 中所示。
从键区菜单命令中选择忽略错误

在公式编辑器中查看公式值

一旦 JMP 计算了某个公式，您就可以选择一个表达式，以便查看表达式的值。这适用于计算的值是常数值的参数和表达式。要查看值，请执行以下操作：

  1. 在公式编辑器中，选择您要了解的表达式。
  2. 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）选定的表达式。此时将显示"使用鼠标右键单击以查看表达式的值" 中所示的菜单。
  3. 选择计算。选定表达式的当前值显示于黄色方框中，直至您移动光标。
使用鼠标右键单击以查看表达式的值

在 JSL 中查看公式

您可以选择在文本模式下输入或更改公式的任何部分。文本模式使用 JMP 脚本语言 (JSL) 显示公式。当您在公式的方框区域中双击空白时，整个公式（或公式的任何项）将以文本模式显示。方框中的元素以纯文本形式显示，然后您可以象在任何文本编辑器中一样来编辑公式。

公式的任何元素都可以被显示为脚本命令，然后可以对其进行编辑。在编辑公式脚本命令之后，在公式外单击鼠标，可以查看格式化的公式。例如，体重标准化的文本为：(：体重 - 列均值(：体重))/列标准差(：体重)。要以文本形式输入 If 语句，请在语句中为每个 If/Then 子句添加成对的自变量，如果需要，可以为 else 子句添加一个最后自变量。"公式模式下的 If 语句" 中的 If 语句的文本形式看起来应该象这样：If(total!==0, (count/total)*100, 0)。

公式模式下的 If 语句


编辑公式

如果您在退出公式编辑器之后需要更改公式，则可以使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）数据网格中的列名，然后选择公式。

更正错误

如果您在输入公式时出错，可以选择编辑 > 撤消。撤消将撤消上一个（可撤消）命令产生的效应。

还有其它一些编辑命令帮助您修改公式：

  • 单击公式编辑器键区中的删除按钮 ( [image])，可以移除选定的表达式。
  • 使用剪切、复制和粘贴快捷命令，或者使用鼠标右键单击高亮度显示的部分公式，然后从菜单中选择剪切、复制或粘贴。
  • 要重新排列项或表达式，可以单击以看到小手 ( [image])，以抓取项。拖动鼠标以移动公式。

选择表达式

使用键盘上的箭头键选择要编辑的表达式，或者在没有括号或外框选项未生效（请参阅"隐藏和显示外框"）时，查看公式的优先顺序。

单击表达式中的运算符（+，-，*，÷）可以选择运算符及其操作数。一旦选择了运算符：

  • 左右箭头键可以在表达式中优先顺序相同的其它结合运算之间移动选择。
  • 左箭头扩大选择的内容，使选择的内容包括优先顺序更高的下一个操作数和运算符，直至选择了整个公式。
  • 上箭头将优先顺序更高的操作数和运算符添加到选择的内容中，从而扩大当前选择的内容。
  • 下箭头从选择的内容中移除操作数和运算符，从而缩小当前选择的内容。

删除函数

删除一个函数也将删除该函数的自变量。删除函数中必需的自变量或缺失项有时也会删除该函数。

您可以剥除函数，从函数的自变量中删除函数。要从单个自变量中剥除函数，请执行以下操作：

  1. 选择函数。
  2. 单击公式编辑器键区（"剥除自变量"）中的剥除按钮 ( [image])。或者，使用手形工具，将自变量拖到函数的上方。
剥除自变量
  3. 完成公式更改。
  4. 单击应用，新值将自动填入数据表列中。
  5. 一旦您创建了公式，您就可以通过您的公式更改引用的列中的值。JMP 自动重新计算公式的列中所有受影响的值。

剪切、复制和粘贴

您可以剪切或复制任何表达式或整个公式，然后将其粘贴到另一个显示的公式中。使用剪切、复制和粘贴快捷命令，或者使用鼠标右键单击高亮度显示的部分公式，然后从菜单中选择剪切、复制或粘帖，如"剪切、复制和粘贴命令" 中所示。以下各项在您剪切、复制和粘贴公式时适用：

  • 在您将公式粘贴到另一个显示的公式中时，公式以格式化的形式显示。
  • 公式作为一个 JSL 语句保存在剪贴板上。因此如果您将公式复制到其它应用程序中，它将显示为 JMP 脚本语言 (JSL) 语句。
  • 如果使用的是欧洲区域设置，则会将逗号随数值一起复制和粘贴过去。

注：请按下键盘上的 Shift 键，然后单击红色三角形图标以展开一个名为复制为 SAS 公式的命令。

剪切、复制和粘贴命令

单击并拖动

您可以将任何可以选定的公式部分拖至其它任何可以选定的位置。要单击并拖动，请执行以下操作：

  1. 将箭头光标置于表达式内部。
  2. 单击表达式。表达式将被高亮度显示，并且箭头光标变成手形光标。
  3. 在公式中间拖动。目标表达式将被高亮度显示。
  4. 将选定的表达式拖至所需的新位置。选定的表达式将被复制到新位置，并取代新位置处的现有表达式。


自定义公式

在公式编辑器中有多种自定义公式的方法。以下部分介绍如何更改字体大小、显示和隐藏外框、更改公式的方向以及关闭自变量。

更改字体大小

通过单击键区上方的红三元图标，然后选择大字体或小字体，如"选择更大或更小的字体" 中所示，您可以逐渐增大或减小显示格式化公式所用的字体。重复执行此流程，可以进一步增大或减小字体。

选择更大或更小的字体

隐藏和显示外框

默认情况下，JMP 将给公式中的特定项加有边框。此边框称为外框。在您要选择和修改特定的公式部分或需要确定发生的计算顺序时，外框就很有用。要打开或关闭外框，请执行以下操作：

  1. 建立公式。
  2. 单击键区上方的红三元图标，然后选择显示外框，如"从键区菜单命令中选择显示外框" 中所示。在菜单中显示外框旁边显示有复选标记时，公式中会显示外框。在没有复选标记时，不会显示外框。
从键区菜单命令中选择显示外框

更改公式的方向

默认情况下，JMP 会估算公式的大小并在公式编辑器中以最佳的方向（水平或垂直）显示公式。但是，如果您创建一个长公式，您可能需要以满足自己偏好的布局显示公式。

要更改公式的方向，请执行以下操作：

  1. 建立公式。
  2. 高亮度显示自变量或公式。
  3. 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）高亮度显示的自变量或公式。
  4. 从显示的菜单中选择方向，如"选择方向" 中所示。
选择方向
  5. 从方向选项中选择：最佳、水平或垂直。

打开和关闭自变量

您可以关闭公式和自变量，以便它们最小化。当您有一个大公式或者具有大量自变量并且想在屏幕上显示整个公式时，这对您很有用。要关闭自变量，请执行以下操作：

  1. 建立公式。
  2. 高亮度显示自变量或公式。
  3. 使用鼠标右键单击（Macintosh 中为按住 Ctrl 键并单击）高亮度显示的自变量或公式。
  4. 从显示的菜单中选择关闭或关闭自变量，如"从菜单中选择" 中所示。
从菜单中选择


实例和教程

为了让您更好地熟悉如何建立公式，您可以仔细阅读下面的实例和教程。

使用基本公式编辑器功能

以下实例使用大班.jmp 引导您使用公式编辑器的基本功能。您可以在名为 Sample Data 的文件夹中找到大班.jmp，该文件夹已在安装 JMP 时安装就绪。

大班.jmp 有一个名为体重的列。假设您需要一个新列，用于计算标准的体重值。要创建此列并且使用公式获取列值，请执行以下操作：

  1. 打开大班.jmp。
  2. 选择列 > 新建列。
  3. 键入新名称、标准体重于列名旁边的方框中。
  4. 从列性质下拉菜单中选择公式，如"创建新公式" 所示。
创建新公式
  5. 在公式编辑区域中单击空白的公式元素以将其选中，如"选择空白的公式元素" 中所示。在您创建了公式并且选定显示外框（请参阅"隐藏和显示外框"）时，公式的选定部分将显示于细红线的方框中。与您单击之处相关的最小嵌套框中的所有项都将被选中，之后的操作适用于这些组合的元素。
选择空白的公式元素

接着，按以下这些步骤输入用于标准化体重值的公式：

  1. 在选定了初始缺失项时，单击公式元素浏览器列选择器列表中的体重。
  2. 单击公式编辑器键区中的减法按钮 ( [image])。此时在减号后面显示一个新缺失项，如"建立公式" 中所示。
  3. 再次单击体重。
  4. 单击函数浏览器下拉菜单，然后选择统计。
  5. 从统计列表中选择列均值，如"列均值" 中所示。
列均值
  6. 选择整个表达式。红色方框应该包括整个公式。
  7. 单击键区中的除法按钮 ( [image])。结果将为整个表达式提供一个处于选定状态的缺失分母。
  8. 再次单击列选择器列表中的体重。则它会显示于分母中并且处于选定状态。
  9. 从统计列表中选择 Col Std Dev。完整公式应类似于"建立公式" 中显示的内容。
  10. 通过单击确定，关闭公式编辑器。新列中将填入值。当体重值发生变化时，计算的标准体重值也将自动重新计算。
建立公式

在公式中使用局部变量

假如，您有变量 x 和 y，并且您要使用"公式中的局部变量" 中所示的标准公式，计算 y 相对于 x 的简单线性回归的斜率。一种方法是创建两个局部变量（请参阅"使用局部变量"），名称分别为 XY 和 Xsqrd。然后，将它们分别指定为斜率计算公式的分子和分母。使用分号分隔每个赋值，如"公式中的局部变量" 中所示。（公式编辑器中的语句实际上是 JSL 编程语句。公式中的多个语句之间必须使用分号分隔。）斜率计算被简化为 XY 除以 Xsqrd。

公式中的局部变量

注：另一种创建局部变量的方法是使用屏幕键区中的局部变量 [image] 按钮，它在表达式中自动创建和显示默认名为 t0 的局部变量，并且在后面加上一个分号。

使用 Munger 函数

下面的实例说明如何使用 Munger 函数。在这些实例中，假设有一个姓名字符列，其中的一个列值是“Veronica Layman”。为了简化实例，文字名称“Veronica Layman”应该是搜索字符串，而不是列名。

有关如何将字符函数（如 Munger）合并到公式的说明，请参阅"添加字符自变量和返回字符串"。

插入字符

此 Munger 实例查找名字与姓氏之间的空格，然后插入中间缩写名“J.”。公式 Munger("Veronica Layman", 1, " ", " J. ") 将插入中间缩写名 J.，并且计算的值为 Veronica J.Layman。

对于文字字符串，包括由空白字符组成的字符串或者字符串的开头和结尾为空白字符时，Munger 函数要求在字符串的两边加上双引号。

删除字符

要从字符串中删除一个或多个字符，在 Munger 函数中将要删除的字符指定为查找字符串，然后输入双引号作为替换字符串，双引号表示空字符串。例如，函数 Munger("Veronica Layman", 1, "onic", " ") 将从 Veronica 中移除“onic”，并且计算的值是 Vera Layman。

注：替换字段中有用引号括起来的空（无值）字符串与替换字段中没有值是不同的。如果您完全删除替换字符串，Munger 将在公式编辑器窗口中显示自变量名称（“替换”），并且将可选的自变量当作不存在。由此产生的数据类型可能从字符变为数值，取决于查找/替换自变量的值。

查找值的位置（索引）

在查找/长度字段包含字符时，Munger 函数就象索引函数一样，如果存在搜索字符串，该函数将返回第一次出现该字符串的编号位置。例如，Munger("Veronica Layman", 1, " ") 将搜索单个空格，并且在位置 9 处找到该字符。如果未找到搜索字符串，Munger 将返回零。Munger 的这种用法产生的结果与 Contains 函数相同，如"添加字符自变量和返回字符串"中所示。

查找子字符串

Munger 可以提取子字符串。例如，为了只看到名字，Munger("Veronica Layman", 1, 8,) 将从位置 1 开始，一直读到位置 8，然后忽略后面的字符，这是因为没有定义替代自变量。这样会得出“Veronica”，与子字符串产生的结果相同，如"添加字符自变量和返回字符串"所示。

另外一种查找子串的方法就是使用起始值、任何负数查找值和无替代自变量。Munger("Veronica Layman", 9, - 1,) 将返回“Layman”。

使用 Match 条件函数

要执行此实例，请打开安装 JMP 时安装的 Sample Data 文件夹中的大班.jmp 文件。要将字符文字赋值给大班数据表中的年龄值，您的公式应该如"条件表达式" 中所示。

条件表达式

要使用快捷方式建立 Match 条件表达式，请执行以下操作：

  1. 在列选择器列表中选择列。
  2. 按住 Shift 键并选择条件函数列表中的 Match。

例如，假设您希望将 Match 条件表达式用于热狗.jmp 数据表（在 Sample Data 文件夹中也可以找到该数据表）中的记名变量（原料）类型，该变量具有值 Beef、Meat 和 Poultry。首先从列选择器列表中选择列类型。然后，在显示的公式中选定（原料）类型，按住 Shift 键并单击 Match，以查看"按住 Shift 键并单击 Match"中所示的公式。

按住 Shift 键并单击 Match


使用键盘快捷方式

您可以使用下面显示的键盘快捷方式，将选定的表达式替换为函数或自变量。

将选定项替换为 | 使用此快捷方式
缺失元素 () | 删除
Subscript | [
() 一组括号 | (
() 一组括号 | )
* | 键区或键盘中的 *
+ | 键区或键盘中的 +
- | 键区或键盘中的 -
÷ | 键区或键盘中的 /
+/- | 按 Shift 键和减号
And | &
Not | !
Or | |
Power | ^
新自变量 | ,
x<y | <
x=y | =
x>y | >


术语表

请记住：

  • 函数总是对选定表达式执行运算。
  • 自变量总是依函数分组。
  • 要弄清哪些表达式将用作一个函数的自变量，可以在公式中选择该函数。
  • 带边框的分组将显示如何应用优先顺序规则，并且显示在您删除函数时会删除哪些自变量。有关详情，请参阅"公式中表达式的排序"。

下面是公式的各个部分自身使用的术语的列表：

  • 元素 元素浏览器列表中显示的常数、表变量、表列、局部变量或参数的名称。
  • 自变量 供函数执行运算的任何元素或整个表达式（包括算术操作数）。
  • 项 表达式的必备部分，如常量和变量。
  • 表达式 可以作为单个单元选定的公式的任何部分，包括项、缺失项、与自变量组合在一起的函数以及整个公式。
  • 子句 条件函数中一个完全段。
  • 函数 对一个或多个自变量执行特定操作的算术或逻辑运算。函数包括函数浏览器列表中的大多数项以及所有键区运算符。函数总是对选定表达式执行运算，而自变量总是与函数合在一起。要弄清哪些表达式将用作一个函数的自变量，可以在公式中选择该函数。带边框的分组将显示如何应用优先顺序规则，并且显示在您删除函数时会删除哪些自变量。
  • 缺失项 空白的表达式占位符，使用空白的方框表示。
  • 缺失值 排除数据或空数据，由数值数据的缺失值标记 () 或字符数据的空字符串组成。


个性化 JMP

自定义首选项、工具栏和菜单

本章介绍了定制 JMP 的方法，以满足您的个性化首选项需要。

  • JMP 首选项允许您指定和保存一般设置和特定设置，以便将这些设置与 JMP 会话相关联。
  • 菜单和工具栏的完全自定义功能提供了极大的灵活性，以便仅显示所需的命令或者为特殊兴趣小组设置 JMP（仅限于 Windows）。

要更改首选项，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。此时将出现"常规首选项窗口 (Windows)" 所示的窗口，同时显示常规首选项类别。
  2. 单击类别并进行选择。单击应用以查看结果，然后单击确定。
常规首选项窗口 (Windows)

目录

更改启动首选项

“今日提示”窗口

启动画面窗口

“JMP 起始页”窗口

窗口列表（仅限于 Windows）

用于打开 Excel 文件的首选项

以 JMP 列名的形式导入 Excel 标签（仅限于 Windows 和 Macintosh）

Excel 工作簿/工作表选择（仅限于 Windows 和 Macintosh）

更改公式和脚本选项

公式计算

脚本计算

自动括弧配对（仅限于 Windows）

使用不同的语言保存脚本

更改数据表选项

高亮度显示移动

箭头样式（仅限于 Windows）

数值格式

数据表打印格式

工具栏位置（仅限于 Windows）

更改报表选项

自定义分析设置

报表说明

菜单提示（仅限于 Windows 和 Linux）

日期、时间、名称和注释

表样式

标记大小

关闭并保存会话

关闭并保存报表

激光指针选项

标记绘制速度阈值

不使用 Unicode 保存文本文件

更改颜色主题

更改图形颜色

更改窗口颜色（仅限于 Windows 和 Linux）

更改标题栏颜色（仅限于 Windows）

自定义字体和语言

更改字形和字号

使用 Windows 中的下划线和删除线

使用希腊字母和数学符号

在英文和日文之间切换（仅限于日文 Windows 系统）

指定图形格式

调整通信设置（仅限于 Windows 和 Linux）

调整代理设置（仅限于 Linux）

指定文件位置和关联

指定文件位置（仅限于 Windows 和 Linux）

重置文件关联（仅限于 Windows）

自定义文本导入/导出选项

个性化工具栏 (Macintosh)

个性化工具栏（Windows 和 Linux）

显示/隐藏工具栏

重新排列工具栏

重新排列按钮

删除工具栏

删除按钮

添加工具栏

添加按钮

导入自定义工具栏（仅限于 Windows）

自定义菜单（仅限于 Windows 和 Linux）

重新排列菜单项

删除菜单

添加菜单

添加菜单项

重命名菜单项

保存菜单/工具栏（Windows 和 Linux）

使用单独的自定义文件（仅限于 Windows）

更改 .jmpcmd 文件的默认位置


更改启动首选项

您可以更改系统默认设置，以便 JMP 在启动时仅显示指定的信息。

“今日提示”窗口

要更改“今日提示”窗口的默认设置，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别。
  3. 选定启动时显示“今日提示”以显示该窗口。撤消选定此项可以在启动时隐藏该窗口。有关“今日提示”的详情，请参阅"今日提示窗口"。

启动画面窗口

要更改启动 JMP 时的启动画面窗口默认设置，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别。
  3. 选定初始启动画面窗口可以在启动时显示初始启动画面窗口。撤消选定此项可以在启动时隐藏该窗口。

“JMP 起始页”窗口

要更改 JMP 起始页窗口的默认设置，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别。
  3. 选定初始 JMP 起始页窗口可以在启动时显示“JMP 起始页”窗口。撤消选定此项可以在启动时隐藏该窗口。有关 JMP 起始页窗口的详情，请参阅"JMP 起始页窗口"。

窗口列表（仅限于 Windows）

JMP 允许您访问窗口列表，也就是 JMP 应用程序左侧的窗格，其中会列出每个打开的 JMP 窗口。利用这一列表，您可以更方便地查看当前打开的窗口以及从一个窗口定位至另一个窗口。

要查看窗口列表，请选择视图 > 窗口列表。

或者，如果要更改 JMP 的默认设置以便始终打开窗口列表，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击常规类别。
  3. 选定初始窗口列表，以便在启动时显示此列表。撤消选定此项可以在启动时隐藏该列表。

要使用其中的窗口，请执行以下操作：

  • 单击窗口名称，以将窗口带至前台显示。
  • 使用鼠标右键单击列表中的窗口标题可关闭、重命名、刷新或隐藏它（"打开的窗口面板"）。
  • 单击列表右上角的关闭图标即可关闭列表。
打开的窗口面板


用于打开 Excel 文件的首选项

在打开 Excel 文件时，JMP 使您可以灵活地更改与文件打开方式有关的首选项。

用于打开 Excel 文件的首选项

以 JMP 列名的形式导入 Excel 标签（仅限于 Windows 和 Macintosh）

当 JMP 打开 Microsoft Excel 文件之后，它首先会将第一行数据放到 JMP 的第一行。但是，您的 Excel 文件的第一行可能包含标签。在这种情况下，您可能会想要使用这些标签作为 JMP 中的列名。要使 JMP 自动使用 Excel 标签作为它的列名，请执行以下操作：

  1. 选择文件 > 首选项 (Windows) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别，如"用于打开 Excel 文件的首选项" 所示。
  3. 单击使用 Excel 标签作为标题旁边的框。

Excel 工作簿/工作表选择（仅限于 Windows 和 Macintosh）

当 JMP 打开包含多个工作表的 Microsoft Excel 工作簿时，默认情况下，它会打开所有工作表。如果您只想打开某些工作表，请执行以下操作：

  1. 选择文件 > 首选项 (Windows) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别。
  3. 单击选择单个 Excel 工作表旁边的框。现在，您可以指定在打开 Excel 工作簿时要导入的工作表，如 "指定要导入的 Excel 工作表" 所示。有关如何打开 Excel 文件的详情，请参阅"打开 Excel 和 OpenOffice 文件"。
指定要导入的 Excel 工作表


更改公式和脚本选项

在创建公式和脚本时，您可能会想要设置一些 JMP 首选项来满足自己的需要。本节将会介绍 JMP 提供的一些首选项。

公式计算

要更改打开数据表时公式计算的默认设置，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击表 (Windows/Linux) 或常规 (Macintosh) 类别，如"更改公式和脚本选项" 所示。
  3. 选定屏蔽打开时的公式计算可以在打开数据表时屏蔽公式的计算。撤消选定此项可以让 JMP 在打开数据表时计算公式。
更改公式和脚本选项

脚本计算

要更改打开数据表时脚本计算的默认设置，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击表类别，如"更改公式和脚本选项" 所示。
  3. 选定屏蔽打开时的脚本计算可以在打开数据表时抑制自动执行脚本。

自动括弧配对（仅限于 Windows）

在 Windows 平台上，只要您在脚本中键入一个开括弧，JMP 就会自动提供一个闭括弧。要设置此功能，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击常规类别，如"自动括弧配对" 所示。
  3. 选定脚本编辑器中括弧自动配对。
自动括弧配对

使用不同的语言保存脚本

JMP 的非英语版本可以以英语或您当地的语言保存脚本。用户指定的值（例如列名和文本字符串）在这些脚本中的显示方式与它们在数据表中的显示方式完全相同，但是命令字（例如 Distribution 和 Set Value）是以英文而不是本地语言的形式显示的，因为脚本只能以英文的形式在 JMP 上运行。当字体支持必要的字符时，JMP 就会使用英文正确显示 JMP 中的非罗马字符（例如日文变量名）。

要指定在使用非英文版本的 JMP 时使用英文保存脚本，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击常规类别。
  3. 选定将脚本另存为英文。


更改数据表选项

JMP 允许您更改元素在数据表中的使用方式。本节将会列出这些更改并且介绍如何进行更改。

高亮度显示移动

当数据表中的某个单元格高亮度显示之后，如果您按键盘上的 Enter/Return 键，高亮度显示就会向下移动。如果按键盘右侧的数字键区上的 Tab 键或 Enter 键，高亮度显示就会向右移动。

但是，您也可以更改这些默认设置。只要按数字键区上的 Enter 键，高亮度显示就会向下移动而不是向右移动。

要更改默认位置，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 在 Windows/Linux 平台上，单击表类别。
    在 Macintosh 平台上，单击常规类别。
  3. 选定按数字键区上的 Enter 键向下移动（Windows 和 Linux）或按 Enter 键向下移动 (Macintosh) 旁边的框。

箭头样式（仅限于 Windows）

要指定 JMP 在它的滚动条中使用的箭头样式，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击常规类别。
  3. 选定以下选项之一：
    • 滚动条箭头样式 选择传统可以将箭头置于垂直滚动条的上下两端以及水平滚动条的左右两侧。选择向上集中可以将两个箭头都置于垂直滚动条的上端以及水平滚动条的左侧。选择向下集中可以将两个箭头都置于垂直滚动条的下端以及水平滚动条的右侧。有关实例，请参阅"滚动条样式"。
    • 滚动条滑动杆样式 选择比例可使显示的滚动条滑动杆与窗口大小成正比。选择传统可使显示的滚动条滑动杆为固定大小，而与窗口长度无关。有关实例，请参阅"滚动条样式"。
滚动条样式

数值格式

JMP 能够存储低至 8 位（一个字节）的数值数据。此选项允许在选择列 > 列信息并为列指定数据类型时使用短整型格式。数据使用正确的短整型格式时，在数值的显示方式上将看不到任何差异，但是它们占用的磁盘空间较少。有关详情，请参阅"使用短整型格式"。

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击表类别。
  3. 选定允许短数值。

数据表打印格式

要按屏幕上的显示打印 JMP 数据表而不调整列宽，以便适应内容宽度，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击表类别。
  3. 选定原样打印数据网格。

工具栏位置（仅限于 Windows）

要将工具栏位置指定为在 JMP 会话过程中保持不变，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击常规类别。
  3. 选定保持工具原位置。


更改报表选项

您可以根据自己的喜好自定义 JMP 报表设置。下面，本节将会介绍报表的自定义方法。

自定义分析设置

每个报表分析均包含各种默认显示的图表选项。但在每次运行特定分析时，您可能会需要查看其它选项。例如，二元分析会默认显示点，但您每次可能还需要查看线性拟合。通过使用“首选项”窗口中的平台选项卡，您可以为分析设定默认选项。（分析可通过启动平台来运行，如“二元”平台；因此，此类别的名称为平台。）

要为分析设定默认选项，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击平台类别，如"“平台”选项卡" 所示。
  3. 在选择平台列表中高亮度显示分析名称。选项框中将显示可供选择的选项，其中的默认值将被选定。
  4. 单击在高亮度显示的平台上运行分析时将自动显示的选项。
“平台”选项卡

报表说明

使用箭头光标在某些报表上画一个小圆圈可以显示分析结果的说明。要启用或禁用此功能，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 选定显示说明。

菜单提示（仅限于 Windows 和 Linux）

要更改在将鼠标置于红色三角形菜单项上时出现的菜单提示的默认设置，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击常规类别。
  3. 选定显示菜单提示可以显示菜单提示。撤消选定此项可以隐藏菜单提示。

日期、时间、名称和注释

要自动在输出报表的顶部添加分析发生的日期和时间，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 选定输出窗口显示日期可以显示分析发生的日期和时间。
    选定输出窗口显示数据表标题可以将数据表的标题和注释（如果有）置于报表输出结果的顶部。

表样式

要为所有报表设定默认表样式，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 单击报表样式旁边的菜单，然后选择某个选项。

标记大小

要为所有图形设定默认标记大小，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 单击图形标记大小旁边的菜单，然后选择某个选项。

关闭并保存会话

我们将每次您使用 JMP 的过程叫作会话。默认情况下，每次您退出程序时，JMP 都会问您是否要保存会话状态。如果您退出时已保存的文件仍然打开，当您返回 JMP 时，它就会重新打开这些已保存的文件并且返回相关分析结果。因此，您可以暂时退出 JMP 并且稍后返回，但是无需打开您之前正在使用的文件。

要设定保存会话的默认方法，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 单击退出时保存会话（"关闭并保存报表和会话"）旁边的菜单，然后选择某个选项。
    • 始终 当您退出 JMP 时，它始终会自动保存当前会话。
    • 从不 当您退出 JMP 时，它从不保存当前会话。
    • 提示 当您退出 JMP 时，它会问您是否保存当前会话。

有关 JMP 会话的详情，请参阅"保存 JMP 会话"。

关闭并保存报表和会话

关闭并保存报表

当您关闭报表时，您可能会想要 JMP 像对其它文档或一次性数据视图那样处理报表。JMP 中有许多可供您设置的首选项，您根据自己的需要进行设置。这些首选项中包括您可以自定义在您关闭或保存报表时 JMP 应该执行哪些操作。

要自定义在您关闭报表时 JMP 处理报表的方式，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 单击关闭报表操作（"关闭并保存报表和会话"）旁边的菜单，然后选择某个选项。
    • 提示 当您关闭报表时，JMP 会问您是否保存报表。
    • 放弃 当您关闭报表时，JMP 从不会保存报表。
    • 保存/自动保存 当您关闭报表时，JMP 始终会自动保存报表，具体方式根据您在报表自动保存至旁边的菜单中选择的选项而定。

要自定义 JMP 保存报表的方式，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 单击报表自动保存至（"关闭并保存报表和会话"）旁边的菜单，然后选择某个选项。
    • 提示 当您关闭报表时，JMP 会问您是否保存报表。
    • 数据表脚本 当您关闭报表时，JMP 会将它另存为打开的数据表中的脚本。要重新打开此报表，请使用鼠标右键单击数据表中的该脚本，然后选择运行脚本。
    • 日志窗口 当您关闭报表时，JMP 会将它保存到日志窗口中。有关日志的信息，请参阅"创建新日志"和"使用日志命令保存"。
    • 记录窗口 当您关闭报表时，JMP 会将它保存到记录窗口中。有关记录窗口的信息，请参阅"保存记录窗口"。

有关如何保存 JMP 报表的详情，请参阅"保存报表"。

激光指针选项

JMP 具有一个内置的激光指针，您可以利用它来直观地突出显示报表的某些部分。默认情况下，它是关闭的。要打开它，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 在激光指针菜单中，选择关闭它或者选择想要激光指针使用的颜色。

要使用激光指针，请单击并拖动报表上的某一部分，光标在此处显示为一个朝左指向的箭头。在您释放鼠标键之前，彩色的激光指针线会一直留在那里。

标记绘制速度阈值

当 JMP 刷新报表窗口时，它可以在图中用两种不同的速度绘制标记：正常和快速。如果 JMP 处于正常绘制模式且图形中的标记数超出指定的阈值数，则 JMP 会自动切换至快速模式。

要更改阈值数，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击报表类别。
  3. 在快速标记阈值旁边的框中输入阈值数。

有关正常和快速绘制模式的更多信息，请参阅"更改标记绘制模式和透明度"。

不使用 Unicode 保存文本文件

JMP 6 使用 Unicode 字符集，而它支持许多特殊字符，例如 é 和 ∫。它会将不含特殊 Unicode 字符的文件自动另存为纯文本文件。不但如此，JMP 也可以保存含有特殊 Unicode 字符的文件。这样，在较早的不支持 Unicode 的应用程序（例如 JMP 5.1.2 和更早的版本）中也可以打开这些文件。为此，请首先禁用 JMP 6 中的 Unicode 功能：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击常规类别。
  3. 撤消选定以 Unicode 保存文本文件旁边的框。现在，JMP 可以将您的文本文件另存为纯（原）文本文件。


更改颜色主题

JMP 允许您自定义图形和报表的背景颜色。它也允许您更改标题栏的颜色。本节将会介绍如何自定义这些颜色方案。

更改图形颜色

您可以设定默认用于所有图形的背景颜色。

  1. 选择文件 > 首选项。
  2. 单击报表类别。
  3. 单击图形背景颜色按钮。
  4. 单击调色板中的某种颜色（"Windows 和 Linux（左）与 Macintosh（右）中的自定义颜色调色板"）。或者，在 Windows 和 Linux 平台上，通过输入新颜色值的具体数值并且单击添加到自定义颜色来创建自定义颜色。
  5. 单击确定。
Windows 和 Linux（左）与 Macintosh（右）中的自定义颜色调色板

更改窗口颜色（仅限于 Windows 和 Linux）

在 Windows 和 Linux 系统中，您可以设定默认用于所有窗口的背景颜色。

  1. 选择文件 > 首选项。
  2. 在 Windows 中，单击特定于 Windows 类别，然后单击选择颜色... 按钮。
    在 Linux 中，单击特定于 Linux 类别，然后单击窗口背景按钮。
  3. 单击调色板中的某种颜色（"Windows 和 Linux（左）与 Macintosh（右）中的自定义颜色调色板"）。或者，通过输入新颜色值的具体数值并且单击添加到自定义颜色来创建自定义颜色。
  4. 单击确定。

更改标题栏颜色（仅限于 Windows）

要为数据表和报表窗口中的标题栏加上淡灰色阴影，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击特定于 Windows 类别。
  3. 单击高亮度显示外框题头旁边的框。
  4. 单击“首选项”窗口中的应用按钮以预览结果。


自定义字体和语言

自定义报表、数据表和脚本外观的一种方法是使用字体类别（"“字体”选项卡 (Windows)"）来更改文字样式，该类别中列出了系统中的可用字体和大小以及常规、粗体、斜体和粗斜体等样式。您设定的规格将被用作默认设置。

“字体”选项卡 (Windows)

更改字形和字号

要更改默认字形和字号，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击字体类别。
  3. 选择要更改的范围。
    • 文本 为 JMP 分析报表的文字部分设定字体。
    • 题头 为分析报表中的列标题设定字体。
    • 标题 为所有标题栏中显示的标题设定字体。
    • 小 为小文字设定字体，例如在关闭数据表的侧面板时数据网格左上角显示的字体。
    • 单一 为脚本命令设定在 JMP 脚本语言 (JSL) 编辑器中使用的字体。
    • 公式编辑器 为输入公式编辑器中的表达式设定字体。
    • 注释 为注释设定默认使用的字体。
    • 轴 为轴标签设定字体信息。
    • 菜单（仅限于 Linux） 设定 JMP 主菜单、复选框上的标签以及其它文本对象的字体。

      注：要快速更改 JMP 中任何位置的字体大小，按 Ctrl-Shift-+ 组合键（加号）可以增大字体，按 Ctrl-Shift-- 组合键（减号）可以减小字体。在 Macintosh 上，按 Command-+（加号）键和 Command--（减号）键。

使用 Windows 中的下划线和删除线

要查看 Windows 中的下划线和删除线文本选项，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击字体类别。
  3. 选定启用特殊字体效果。
  4. 选择要进行更改的区域（文本、大标题、标题等）。
  5. 在出现的窗口中，选定删除线和（或）下划线旁边的框。

使用希腊字母和数学符号

要在 JMP 中启用和禁用希腊字母和数学符号，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击字体类别。
  3. 选定使用希腊字母和（或）使用数学符号。

在英文和日文之间切换（仅限于日文 Windows 系统）

如果您正在 Windows 上运行日文版的 JMP，您可以在英文和日文之间切换查看 JMP。此选项提供了一种以英文快速查看 JMP 某些部分的方法，而无需重置您的地区语言设置。

  1. 选择文件 > 首选项。
  2. 单击特定于 Windows 类别。
  3. 单击确定。要使更改生效，您必须重新启动 JMP。


指定图形格式

您可以为 JMP 指定将图形复制到剪切板或另存为 .rtf 和 .html 文件时使用的默认格式。

要指定默认格式，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 在 Windows 中，单击特定于 Windows 类别（"Windows 中的“图形格式”选项卡"）。
    在 Macintosh 中，单击 MacOS 设置类别。
    在 Linux 中，单击图形格式类别。
  3. 按照下表中的说明可以指定格式：
    对图形执行的操作 | 如何设置格式
    在将图形拖放或复制并粘贴至其它应用程序时使用某种格式（仅限于 Windows） | 在复制/拖放图形格式区域中单击选定所需的格式。
    在将 JMP 报表另存为 .rtf 文件或 .html 文件时使用某种图形格式（仅限于 Windows） | 选择 RTF/HTML 文件的图形格式旁边的某种格式。
    在将图形另存为 .rtf 文件或拖放至其它应用程序时，将图形在原始尺寸基础上放大或缩小。 | 在图形尺度因子 % 文本框 (Windows/Macintosh) 或尺度文本框 (Linux) 中输入图形在其它应用程序中显示的百分比。此功能可能无法适用于所有选择的应用程序版本。
Windows 中的“图形格式”选项卡


调整通信设置（仅限于 Windows 和 Linux）

只有在使用设备从外部来源读取数据时才需要指定通信设置。要指定设置，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击通信类别。

要查找相应的设置，请参阅设备的说明文档。有关详情，请参阅《JMP 统计和图形指南》。

“通信设置”选项卡


调整代理设置（仅限于 Linux）

通过选择文件 > Internet 打开，您可以从 Internet 站点、Intranet 站点、服务器和 FTP 地址导入数据。在 Linux 中，如果您使用代理服务器来连接至 Internet，那么您首先要设定一些代理设置，然后才能打开文件：

  1. 选择文件 > 首选项。
  2. 单击代理类别。
  3. 输入您的代理服务器的地址。


指定文件位置和关联

您可以更改 JMP 系统文件的默认位置，也可以设定 JMP 文件的文件关联，以便在使用本版本的 JMP 时，它们可以始终打开。下面，本节将会介绍如何进行这些更改。

指定文件位置（仅限于 Windows 和 Linux）

尽管大多数已安装文件都应存放在默认的安装目录下，但您也可以更改 JMP 系统文件的默认位置。可能需要移动这些系统文件的情况包括：

  • 要将帮助文件等较大的文件（例如，Windows 中的 jmp.chm 文件和 Linux 中的 .html 文件）移动至硬盘外的其它位置。
  • 技术支持人员需要安装目录中的信息。
  • 要指定用于保存首选项文件目录（Windows 中的 jmp.pfs 和 Linux 中的 jmpPreferences）的目录。即使目录中暂时没有 jmp.pfs 或 jmpPreferences 文件，您仍可以指定目录。在 JMP 保存首选项时，它会在该目录中创建 jmp.pfs 或 jmpPreferences 文件。

此外，您可以设定文件关联，以便在您打开文件时，JMP 始终会启动指定位置中的路径。

要更改默认文件关联，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击文件位置类别，如"文件位置选项卡" 所示。
  3. 在列表中高亮度显示要更改其位置的项。文本框中将显示其当前的位置。

    注：在 Windows 中，如果您希望每次您选择文件 > 打开、保存或另存为时 JMP 全都使用指定的目录，请选择数据文件目录或另存为数据/日志目录。另外，您还必须选定在显示“打开文件”时始终转至此目录或在显示“数据/日志另存为”时始终转至此目录。

    在 Linux 中，选择数据文件目录，然后设定您希望每次您选择文件 > 打开时 JMP 使用的目录路径。
  4. 单击浏览。
  5. 浏览至用于存储文件的目录并选择该目录。

注：要将文件位置重置为默认位置，请删除当前位置的路径并将该框留空。

文件位置选项卡

重置文件关联（仅限于 Windows）

要设定 JMP 的文件关联以便始终使用当前版本的 JMP 打开文件，请选择文件 > 首选项 > 特定于 Windows，然后单击重置关联按钮。这样将确保在双击 JMP 文件或使用自动化命令时（此时并未运行 JMP）能使用指定版本的软件打开文件。

如果存在以下情况，则可能需要设置文件关联：

  • 安装了多个版本的 JMP
  • 使用自动化命令打开 JMP 文件
  • 之前使用 Windows 操作系统界面更改过 JMP 文件类型关联，但现在又要恢复之前的关联


自定义文本导入/导出选项

当您将文本文件导入或导出 JMP 时，JMP 会使用默认的规则来解释字段末和行末分隔符。要更改这些规则并指定导入和导出文本文件时 JMP 使用的设置，请执行以下操作：

  1. 选择文件 > 首选项 (Windows/Linux) 或 JMP > 预置 (Macintosh)。
  2. 单击文本数据文件类别，如"文本数据文件选项卡" 所示。
  3. 在窗口中进行选择，有关可用选项的详情，请参阅"打开文本文件"。
文本数据文件选项卡


个性化工具栏 (Macintosh)

在 Macintosh 中，您可以通过 JMP 报表、日志和布局窗口顶部的工具栏添加和删除项。要个性化工具栏，请执行以下操作：

  1. 使用鼠标右键单击工具栏，然后从菜单中选择自定工具栏，如"个性化工具栏" 所示。
个性化工具栏
  2. 此时将出现如"Macintosh 中的自定义 JMP 工具栏" 所示的窗口。窗口的列表中包含多个项，您可以将它们从列表中拖到活动工具栏中。
Macintosh 中的自定义 JMP 工具栏


个性化工具栏（Windows 和 Linux）

在 Windows 和 Linux 中，有多种方法可以个性化工具栏。例如，您可以隐藏或显示工具栏、删除或重新排列工具栏按钮或者创建新的工具栏或按钮。您可以为菜单项创建工具栏按钮，以方便您选择经常使用的菜单项。

此外，您还可以删除或重新排列工具栏，并可在保存后随时在 JMP 会话过程中使用。

要恢复默认的工具栏，请选择编辑 > 自定义 > 恢复为出厂默认值。

恢复默认工具栏

显示/隐藏工具栏

要在 Windows 和 Linux 中显示或隐藏工具栏，请执行以下操作：

  1. 选择视图 > 显示工具栏。
  2. 单击选定要在 JMP 中显示的工具栏，如"选择显示工具栏可以显示工具栏复选框选项" 所示。

    注：要在 Linux 中快速隐藏和显示工具栏，请使用鼠标右键单击工具栏，然后再选择隐藏或显示工具栏。
选择显示工具栏可以显示工具栏复选框选项

文件编辑

显示一个工具栏，其中包含文件和编辑菜单中的命令图标。

分析

显示一个工具栏，其中包含分析菜单中的命令图标。

图形

显示一个工具栏，其中包含图形菜单中的命令图标。

工具

显示一个工具栏，其中包含可用于单击和用作光标的工具图标。

数据表列表

显示所有已打开数据表的列表。这在打开多个数据表时很有用。您可以在此列表中选择数据表，以使其成为当前表。请注意，当前表不一定是顶层窗口。要让表（或任何窗口）成为顶层窗口，请从窗口菜单的列表中选择其名称。

表

显示一个工具栏，其中包含表菜单中的命令图标。

试验设计

显示一个工具栏，其中包含试验设计菜单中的命令图标。

浏览器  [image] （仅限于 Windows）

显示标准浏览按钮，如前进、后退和主页等，以便在 JMP 中使用浏览器打开互联网页面时使用。有关详情，请参阅"从 Internet 或 Intranet 上打开文件（仅限于 Windows 和 Linux）"。

URL 列表  [image] （仅限于 Windows）

列出在当前 JMP 会话中请求的浏览器页面。如果启用了此工具栏，要在 JMP 浏览器中打开新的网页，您可以在文本区中键入 URL，然后再按 Enter 键访问该页面。或者，您也可以选择之前访问过的网页。有关详情，请参阅"从 Internet 或 Intranet 上打开文件（仅限于 Windows 和 Linux）"。

搜索列表控件  [image] （仅限于 Windows）

记录当前数据表中已执行的所有数据表搜索。当您在文本区中输入值并单击搜索图标按钮时，此操作与编辑 > 搜索 > 查找命令等效。连续单击搜索图标按钮与编辑 > 搜索 > 查找下一个命令等效。

颜色  [image] （仅限于 Windows）

显示可供图形中的点使用的颜色列表。

标记  [image] （仅限于 Windows）

显示可供图形中的点使用的标记列表。

重新排列工具栏

在 Windows 和 Linux 中使用 JMP 时，您可以将显示的工具栏置于任何位置。要重新排列工具栏，请执行以下操作：

  1. 单击工具栏的左上角。此时工具栏周围将显示一个外框。
  2. 将工具栏拖放至希望的位置：拖至屏幕顶部工具栏区域的其它位置，或者拖离工具栏区域（如"将“文件编辑”工具栏移出工具栏区域" 所示）。
将“文件编辑”工具栏移出工具栏区域

提示：要在 Linux 中快速重新排列工具栏，请使用鼠标右键单击工具栏并选择排列。

重新排列按钮

在 Windows 中

在 Windows 中，可以通过单击和拖动来重新排列当前工具栏中的按钮：

  1. 选择编辑 > 自定义 > 工具栏。此时将出现如"自定义工具栏" 所示的屏幕。
自定义工具栏
  2. 单击要移动的按钮。
  3. 将按钮拖至窗口中的任意位置，以便将其拖离原工具栏。
  4. 在其它任何工具栏、同一工具栏的不同位置或者窗口的背景中释放该按钮（在窗口的背景中释放按钮会将其保存为“碎片”，并可在下次选择编辑 > 自定义 > 工具栏时供您选择，如"单击按钮并将其拖至“碎片区域”" 所示）。
  5. 重复此操作可以移动任意数量的按钮。
  6. 关闭窗口并单击是，以便应用更改。请注意，“碎片区域”中的按钮不会在任何工具栏中显示，同时也不会被删除。

在 Linux 中

在 Linux 中，可以通过单击按钮来重新排列当前工具栏中的按钮：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示要重新排列其按钮的工具栏名称。高亮度显示的工具栏中的按钮将显示在右侧的列表中，如"自定义工具栏" 所示。
自定义工具栏 (Linux)
  3. 高亮度显示右侧列表中的按钮。
  4. 单击相应的按钮（向上移动、向下移动等）以重新排列按钮。

删除工具栏

您可以删除工具栏，以使其不再显示在屏幕上方的主菜单栏下。

在 Windows 中

要在 Windows 中删除工具栏，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 使用鼠标右键单击要删除的工具栏名称，然后从下拉菜单中选择删除工具栏，如"使用鼠标右键单击工具栏并选择删除工具栏" 所示。
或者，单击要删除的工具栏，然后将其拖至屏幕右侧。
已删除的工具栏将被固定在屏幕右侧，同时被保存为“碎片”。在下次选择编辑 > 自定义 > 工具栏时可供您选择。如果确定不需要将其删除，请单击工具栏并将它从屏幕右侧的碎片区域拖至屏幕左侧所有其它活动工具栏所在的区域。
要永久删除该工具栏，请再次使用鼠标右键单击工具栏名称（此时工具栏位于“碎片区域”），然后选择删除。
使用鼠标右键单击工具栏并选择删除工具栏
  3. 关闭窗口并单击是，以便应用更改。请注意，“碎片区域”中的工具栏不会显示，同时也不会被删除。

在 Linux 中

要在 Linux 中删除工具栏，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示要删除的工具栏名称。高亮度显示的工具栏中的按钮将显示在右侧的列表中。
  3. 单击删除按钮。

    注：如果意外删除了“编辑”菜单，同时又需要恢复自定义功能，请使用鼠标右键单击 JMP 中的空白区，然后选择自定义 > 恢复为出厂默认值。

删除按钮

在 Windows 中

要在 Windows 中删除工具栏按钮，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 使用鼠标右键单击要删除的按钮。
  3. 从下拉菜单中选择删除，如"使用鼠标右键单击按钮并选择“删除”" 所示。
使用鼠标右键单击按钮并选择“删除”
或者，单击要删除的按钮并将其拖至屏幕右侧，如"单击按钮并将其拖至“碎片区域”" 所示。
单击按钮并将其拖至“碎片区域”
已删除的按钮将被固定在屏幕右侧，同时被保存为“碎片”。在下次选择编辑 > 自定义 > 工具栏时可供您选择。如果确定不需要将其删除，请单击工具栏并将它从屏幕右侧的碎片区域拖至屏幕左侧所有其它活动工具栏所在的区域。
要永久删除该按钮，请再次使用鼠标右键单击工具栏名称（此时工具栏位于碎片区域），然后选择删除。
  4. 关闭窗口并单击是，以便应用更改。请注意，“碎片区域”中的按钮不会在任何工具栏中显示，同时也不会被删除。

在 Linux 中

要在 Linux 中删除工具栏按钮，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示要删除的工具栏名称。高亮度显示的工具栏中的按钮将显示在右侧的列表中。
  3. 在右侧的列表中，高亮度显示要删除的按钮名称。
  4. 单击删除按钮。

添加工具栏

在 Windows 中

要在 Microsoft Windows 中使用 JMP 添加新工具栏，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 使用鼠标右键单击窗口背景中的空白区域（并非工具栏中的空白区域）。
  3. 选择新建工具栏，如"使用鼠标右键单击空白区域并选择“新建工具栏”" 所示。
使用鼠标右键单击空白区域并选择“新建工具栏”
  4. 窗口底部将显示一个无标题工具栏，如"使用鼠标右键单击按钮并选择“删除”" 所示。
显示无标题工具栏
  5. 按照下表中的说明可以选择其它操作：
    操作 | 说明
    在工具栏中插入按钮 | 执行"添加按钮"中的步骤。
    将现有工具栏中的按钮移至新工具栏 | 单击并拖动按钮。
    隐藏新工具栏，以便在返回 JMP 时不进行显示
    1. 使用鼠标右键单击无标题工具栏内部，然后选择性质。
    2. 撤消选定可见。如果工具栏不可见，则在选择查看 > 显示工具栏时其名称将显示为未选定。
    从 JMP 中的现有工具栏撤消附加新工具栏
    1. 使用鼠标右键单击无标题工具栏内部，然后选择性质。
    2. 撤消选定停放。
    将工具栏从无标题工具栏重命名为其它名称
    1. 使用鼠标右键单击无标题工具栏内部，然后选择性质。
    2. 在标题旁边的文本框中键入工具栏的唯一名称，如"“工具栏性质”窗口" 所示。您不能为两个或多个工具栏指定相同的名称，包括无标题工具栏名称。
“工具栏性质”窗口

在退出时关闭所有窗口并单击是，以便应用更改。

在 Linux 中

要在 Linux 中添加新工具栏，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示左侧列表中的工具栏。确保右侧列表中没有任何高亮度显示的项。
  3. 单击插入之前或插入之后。
  4. 通过单击性质将工具栏从无标题重命名为其它名称。

添加按钮

在 Windows 中

在 Windows 中，可以按照以下步骤为现有工具栏创建新的按钮：

第 1 步：创建占位按钮

  1. 选择编辑 > 自定义 > 工具栏。
  2. 使用鼠标右键单击窗口背景中的空白区域（并非工具栏中的空白区域）。
  3. 选择新建项目，如"使用鼠标右键单击空白区域并选择“新建项目”" 所示。在窗口背景的空白区域将出现占位图标。
使用鼠标右键单击空白区域并选择“新建项目”

注：通过使用鼠标右键单击现有按钮并选择复制，然后再使用鼠标右键单击占位按钮并选择粘贴，您可以使占位按钮具有与现有工具栏中按钮相同的特征。

第 2 步：确定按钮类型

  1. 使用鼠标右键单击占位工具栏按钮并选择性质。此时将出现“性质”窗口，如"工具栏按钮性质“常规”选项卡" 所示。
工具栏按钮性质“常规”选项卡
  2. 在常规选项卡中选择命令或分隔符，以指定将按钮用作命令按钮还是分隔符按钮。
    • 命令按钮是可以在单击后执行命令的按钮。
    • 分隔符按钮 ( [image]) 是可以添加在命令按钮之间的按钮，有助于对命令按钮进行分隔和分组。分隔符不会被赋予任何命令功能，同时也无法单击。

第 3 步：应用标题和工具提示

标题是为工具栏按钮指定的名称。工具提示是将光标置于按钮上时所出现的文字。要为按钮添加标题和工具提示，请执行以下操作：

  1. 在常规选项卡中，在标题框中键入唯一的菜单名称。您不能为两个或多个工具栏按钮指定相同的名称，包括无标题名称。
  2. 在工具提示框中键入按钮说明。请注意，如果没有在该框中输入工具提示文字，JMP 将使用输入的标题文字作为工具提示文字。

第 4 步：指定按钮功能

在单击时，JMP 的工具栏按钮可以执行预定义的命令或运行 JSL 脚本。下表中的说明将有助于您指定按钮可执行的操作。

操作 说明
单击工具栏按钮时访问现有的 JMP 命令
  1. 在常规选项卡中，从选择此命令时要执行的操作框中选择内建命令。
  2. 单击下拉菜单并从列表中选择某个命令，该列表包含了 JMP 中所有平台层的命令，包括子菜单中的命令，如非线性或分割。
使工具栏按钮运行单个文件中的 JSL 脚本
  1. 在常规选项卡中，从选择此命令时要执行的操作框中选择运行此文件中的 JSL。
  2. 单击浏览按钮并指定包含 JSL 的文件的路径。
运行您已键入并随按钮保存的 JSL 脚本
  1. 在常规选项卡中，从选择此命令时要执行的操作框中选择执行此 JSL。
  2. 键入 JSL。

第 5 步：为按钮指定图标

您的按钮可以包含图形，用于表示单击时将执行的操作。此图形可以是 JMP 提供的通用图形，也可以是计算机中的任何图形。要为按钮指定图标，请执行以下操作：

  1. 单击“工具栏按钮性质”窗口中的图标选项卡，如"“图标”选项卡" 所示。
“图标”选项卡
  2. 选择以下选项之一：
    • 无 如果不为工具栏按钮指定图标，请选择此选项。
    • 内建图标 ID 如果要为工具栏按钮指定 JMP 提供的图标，请选择此选项。单击下拉菜单并选择图标标识，以便为按钮指定一个 JMP 预定义的图标。
    • 使用位图 如果要为工具栏按钮指定计算机中的位图作为图标，请选择此选项。单击浏览并选择位映象图像文件，然后单击确定。

第 6 步：为按钮指定快捷键

如果需要，您可以为按钮指定快捷键，以便仅通过键盘即可访问该命令。要指定快捷方式，请执行以下操作：

  1. 单击“工具栏按钮性质”窗口中的快捷方式选项卡，如"“快捷方式”选项卡" 所示。请注意，当前快捷键列表中的项是 JMP 中已使用的快捷键。因此，您不能使用列表中的任何组合来创建新的快捷方式。
“快捷方式”选项卡
  2. 在快捷键旁边的框中键入所创建的快捷方式的字符部分。
  3. 在组合键区域，单击要用作所创建快捷方式的组合键部分的按键。
  4. 单击确定。

要从按钮性质中删除快捷方式，请单击清除。

在 Linux 中

在 Linux 中，可以按照以下步骤为现有工具栏创建新的按钮：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示要添加按钮的工具栏。
  3. 如果该工具栏已包含按钮，请高亮度显示某个按钮并单击插入之前或插入之后。
    如果工具栏未包含任何按钮，请高亮度显示左侧列表中的工具栏名称，然后单击插入至工具栏。
  4. 高亮度显示新添加的按钮并单击性质，以便确定按钮类型、应用标题和工具提示以及指定功能与图标。

导入自定义工具栏（仅限于 Windows）

在 Windows 中，如果您是 JMP 4 的用户并设定了自定义工具栏，则可以将其导入至 JMP 6 使用。要导入工具栏，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 使用鼠标右键单击窗口背景中的空白区域（并非工具栏中的空白区域）。
  3. 选择导入 V4 工具栏文件，如"选择“导入 JMP 4 工具栏文件”" 所示。
选择“导入 JMP 4 工具栏文件”
  4. 定位至版本 4 工具栏文件所在的位置。默认情况下，自定义工具栏文件将被命名为用户 1、用户 2 等并存储在 JMP 4 文件夹中。
  5. 单击确定。
  6. 使用鼠标右键单击窗口背景中的空白区域（并非工具栏中的空白区域）。
  7. 选择应用更改以应用 JMP 4 工具栏。


自定义菜单（仅限于 Windows 和 Linux）

在 Windows 和 Linux 中，所有主菜单及其子菜单都可重新排列或者从菜单栏中删除。这些自定义菜单可随时在 JMP 会话中保存和使用。

您也可以通过选择编辑 > 自定义 > 恢复为出厂默认值随时恢复默认的菜单。

恢复默认菜单

重新排列菜单项

在 Windows 和 Linux 中，您可以重新排列菜单中所列命令的顺序。例如，在文件菜单中，您可以将打开移动到新建之前。

此外，您也可以重新排列 JMP 中菜单本身的显示顺序。例如，您可以将主菜单栏中的表菜单移动到编辑菜单左侧。

在 Windows 中

在 Windows 中，重新排列菜单只需通过拖放操作即可实现：

  1. 选择编辑 > 自定义 > 菜单。此时将显示"自定义菜单选用区" 中的窗口。该窗口包含所有的主菜单图样。
自定义菜单选用区
  2. 单击要重新排列菜单项的菜单标题（如编辑、布局等），此时将显示整个菜单。
  3. 单击菜单中的菜单项，然后将其拖至其它位置。

在 Linux 中

在 Linux 中，可以通过单击按钮来重新排列菜单：

  1. 选择编辑 > 自定义 > 菜单。
  2. 高亮度显示要重新排列其子菜单的菜单名称。高亮度显示的菜单中的按钮将显示在右侧的列表中，如"自定义菜单 (Linux)" 所示。
自定义菜单 (Linux)
  3. 高亮度显示子菜单。
  4. 单击相应的按钮（向上移动、向下移动等）以重新排列按钮。

实例

假设在 Windows 中，您需要通过排除生存和可靠性以及建模，同时保留建模中的非线性命令来简化分析菜单，如"初始默认分析菜单" 所示。

初始默认分析菜单
  1. 选择编辑 > 自定义 > 菜单。此时将出现“自定义菜单”窗口。
  2. 滚动至分析菜单并单击打开。
  3. 单击生存和可靠性并将其拖至选用区中的任意位置，以便将其拖离菜单，如"单击生存和可靠性和建模并将它们拖离“分析”菜单" 所示。
  4. 单击建模并将其拖至选用区中的任意位置，以便将其拖离菜单，如"单击生存和可靠性和建模并将它们拖离“分析”菜单" 所示。
单击生存和可靠性和建模并将它们拖离“分析”菜单
  5. 单击建模以打开其子菜单，如"单击生存和可靠性和建模并将它们拖离“分析”菜单" 所示。
  6. 将非线性从建模子菜单拖至分析主菜单中的任意位置。
将“非线性”从“建模”子菜单拖至“分析”菜单
  7. 关闭窗口。系统将提示您保存和应用更改。此时，菜单栏中的分析菜单如"重新排列后的“分析”菜单" 所示。
重新排列后的“分析”菜单

删除菜单

在 Windows 中

在 Windows 中，您可以删除整个菜单或子菜单。要删除菜单，请执行以下操作：

  1. 选择编辑 > 自定义 > 菜单。此时将出现“自定义菜单”窗口。
  2. 使用鼠标右键单击要删除的菜单名称（如文件、编辑、表等）或子菜单名称（如新建、打开、保存等）。
  3. 选择删除。或者，单击要删除的菜单，然后将其拖至屏幕右侧。
已删除的菜单将被固定在屏幕右侧，同时被保存为“碎片”。在下次选择编辑 > 自定义 > 菜单时可供您选择。如果确定不需要将其删除，请单击工具栏并将它从屏幕右侧的碎片区域拖至屏幕左侧所有其它活动工具栏所在的区域。

在 Linux 中

要在 Linux 中删除菜单，请执行以下操作：

  1. 选择编辑 > 自定义 > 菜单。
  2. 高亮度显示要删除的菜单名称。高亮度显示的菜单中的子菜单将显示在右侧的列表中。
  3. 要删除菜单，请确保右侧列表中没有任何高亮度显示的项，然后单击删除。
    要删除子菜单，请在右侧的列表中高亮度显示要删除的按钮名称，然后单击删除。

添加菜单

在 Windows 中

在 Windows 中，您可以在 JMP 中创建自己的菜单并将其添加到主菜单栏中：

  1. 选择编辑 > 自定义 > 菜单。
  2. 使用鼠标右键单击窗口背景中的空白区域（并非菜单中的空白区域）。
  3. 选择新建项目。
  4. 使用鼠标右键单击占位菜单，然后选择性质，如"使用鼠标右键单击空白区域并选择“新建项目”" 所示。此时将出现“菜单项性质”窗口。
使用鼠标右键单击占位菜单
  5. 在“常规”选项卡中选择子菜单，如"选择“命令”选项" 所示，以便让 JMP 将此菜单项作为包含子菜单的主菜单命令。
选择“命令”选项
  6. 在标题框中为菜单项输入唯一的名称。您不能为两个或多个菜单指定相同的名称，包括无标题名称。
  7. 单击确定。
  8. 单击菜单项并将其拖至菜单栏，如"将新的菜单命令放入菜单栏" 所示。
将新的菜单命令放入菜单栏

现在，您便可以通过添加菜单项来构建菜单了，如"添加菜单项"所述。

在 Linux 中

要在 Linux 中添加新菜单，请执行以下操作：

  1. 选择编辑 > 自定义 > 菜单。
  2. 高亮度显示左侧列表中的菜单。确保右侧列表中没有任何高亮度显示的项。
  3. 单击插入之前或插入之后。
  4. 通过单击性质将菜单从无标题重命名为其它名称。

添加菜单项

在 Windows 中

在 Windows 中，可以按照以下步骤为现菜单创建新的菜单项：

第 1 步：创建占位菜单项

  1. 选择编辑 > 自定义 > 菜单。此时将出现“自定义菜单”窗口。
  2. 使用鼠标右键单击窗口背景中的空白区域（并非菜单中的空白区域）。
  3. 选择新建项目，如"使用鼠标右键单击空白区域并选择“新建项目”" 所示。在窗口背景的空白区域将出现占位菜单。
使用鼠标右键单击空白区域并选择“新建项目”

第 2 步：确定菜单类型

  1. 使用鼠标右键单击占位菜单项并选择性质。此时将出现“性质”窗口，如"菜单项性质“常规”选项卡" 所示。
菜单项性质“常规”选项卡
  2. 在常规选项卡中，选择命令、子菜单或分隔符。
    • 命令菜单项是可以在单击后执行命令的项。
    • 子菜单项是单击后可以显示更多菜单选项的菜单项。例如，文件菜单项便是一个子菜单类型的菜单项。而在文件菜单中，新建也属于子菜单项，因为它还包含了其它菜单项。
    • 分隔符菜单项 ( [image]) 是可以添加在菜单项之间的线，有助于对菜单项进行分隔和分组。分隔符不会被赋予任何命令功能，同时也无法单击。

第 3 步：应用标题

标题是为菜单项指定的名称。此名称将显示在主菜单中。要为菜单项指定标题，请在常规选项卡的标题框中为菜单键入唯一的名称。您不能为两个或多个菜单项指定相同的名称，包括无标题名称。

注：您不能对分隔符菜单项应用标题。

第 4 步：指定菜单项功能

在选择菜单项时，JMP 将执行预定义的命令或运行 JSL 脚本。

按照下表中的说明可以指定命令菜单项能够执行的操作：

操作 说明
单击菜单项时访问现有的 JMP 命令
  1. 在常规选项卡中，从选择此命令时要执行的操作框中选择内建命令。
  2. 单击下拉菜单并从列表中选择某个命令，该列表包含了 JMP 中所有平台层的命令，包括子菜单中的命令，如非线性或分割。
使菜单项运行单个文件中的 JSL 脚本
  1. 在常规选项卡中，从选择此命令时要执行的操作框中选择运行此文件中的 JSL。
  2. 单击浏览按钮并指定包含 JSL 的文件的路径。
运行输入并随菜单项保存的 JSL 脚本
  1. 在常规选项卡中，从选择此命令时要执行的操作框中选择执行此 JSL。
  2. 键入 JSL。

第 5 步：为菜单项指定图标

您的菜单项可以包含图形，用于表示选择时将执行的操作。这些图形将位于菜单中菜单项的左侧。

要为菜单项指定图标，请执行以下操作：

  1. 单击“菜单项性质”窗口中的图标选项卡，如"“图标”选项卡" 所示。
“图标”选项卡
  2. 选择下列选项之一：
    • 无 如果不为菜单项指定图标，请选择此选项。
    • 内建图标 ID 如果要为菜单项指定 JMP 提供的图标，请选择此选项。单击下拉菜单并选择图标标识，以便为菜单项指定一个 JMP 预定义的图标。
    • 使用位图 如果要为菜单项指定计算机中的位图作为图标，请选择此选项。单击浏览并选择位映像文件，然后单击确定。

第 6 步：为菜单项指定快捷键

您可以为菜单项指定快捷键，以便仅通过键盘即可访问该命令。

要指定快捷方式，请执行以下操作：

  1. 单击“菜单项性质”窗口中的快捷方式选项卡，如"“快捷方式”选项卡" 所示。请注意，当前快捷键列表中的项是 JMP 中已使用的快捷键。因此，您不能使用列表中的任何组合来创建新的快捷键。
  2. 在快捷键旁边的框中键入所创建的快捷键的字符部分。
  3. 在组合键区域，单击要用作所创建快捷键的组合键部分的按键。
  4. 单击确定。

要从菜单项性质中删除快捷方式，请单击清除。

在 Linux 中

在 Linux 中，可以按照以下步骤来创建新菜单项：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示要添加菜单项的菜单。
  3. 如果该菜单已包含菜单项，请高亮度显示某个菜单项并单击插入之前或插入之后。
    如果菜单未包含任何菜单项，请高亮度显示左侧列表中的菜单名称，然后单击插入至子菜单。
  4. 高亮度显示新添加的菜单项并单击性质，以便确定菜单类型、应用标题和工具提示以及指定功能、图标和快捷键。

重命名菜单项

菜单名称是菜单项所显示的文字，如新建、打开和保存。在 Windows 和 Linux 中，您可以根据个人偏好更改这些名称。

在 Windows 中

要在 Windows 中重命名菜单项，请执行以下操作：

  1. 选择编辑 > 自定义> 菜单。
  2. 使用鼠标右键单击要重命名的菜单名称（如文件、编辑、表等），或者单击菜单名称以显示子菜单，然后再使用鼠标右键单击子菜单名称（如新建、打开、保存等）。
  3. 选择性质。
  4. 在标题框中为子菜单键入新名称。您不能为两个或多个子菜单指定相同的名称。
  5. 单击确定，菜单系统将反映所作的更改。

在 Linux 中

要在 Linux 中重命名菜单项，请执行以下操作：

  1. 选择编辑 > 自定义 > 工具栏。
  2. 高亮度显示要重命名的菜单。
  3. 单击性质。


保存菜单/工具栏（Windows 和 Linux）

在 Windows 中打开 JMP 时，它将调用名为 JMP.jmpcmd 的文件中的菜单和工具栏配置。此文件一般在用户的本地应用程序数据文件夹中。

在 Linux 中打开 JMP 时，应用程序将调用名为 jmpMenus 的文件中的菜单和工具栏配置。该文件通常位于 .jmp 文件夹中的用户主目录下。

因此，要自定义菜单和工具栏，您必须更改 JMP.jmpcmd 或 jmpMenus 文件。如果选择执行此操作，默认设置将被改写。但是，您可以随时选择编辑 > 自定义 > 恢复为出厂默认值来恢复最初的 JMP.jmpcmd 或 jmpMenus 文件（出厂默认主菜单和工具栏）。

要保存菜单和工具栏的自定义设置，请执行以下操作：

  1. 选择编辑 > 自定义> 菜单或工具栏。
  2. 自定义菜单或工具栏。
  3. 关闭“自定义菜单”或“自定义工具栏”窗口。在 Linux 中，单击接受。
  4. 在 Windows 中，当 JMP 询问您是否保存更改时，请单击是。您所作的更改将替换 JMP.jmpcmd 中的菜单或工具栏。
  5. 在 Windows 中，当 JMP 询问您是否应用更改并将设置应用于当前会话时，请单击是。JMP 将使用新规范来重置工具栏或菜单。
  6. 要恢复初始设置，请选择编辑 > 自定义 > 恢复为出厂默认值。

使用单独的自定义文件（仅限于 Windows）

如果不希望更改启动时默认显示的菜单和工具栏设置，您可以将自定义设置存储在单独的文件中，例如名为 mymenus.jmpcmd 的文件。由于文件名并非 JMP.jmpcmd，JMP 在启动时不会调用其中的设置。如果在保存后要查看自定义设置，您必须在 JMP 中打开文件。

以下部分介绍了如何创建文件，以及如何打开和关闭文件。

创建文件

  1. 选择编辑 > 自定义> 菜单或工具栏。
  2. 自定义菜单或工具栏。
  3. 选择文件 > 另存为。
  4. 为自定义菜单或工具栏键入新名称（JMP.jmpcmd 除外），然后保存。
  5. 关闭“自定义菜单”或“自定义工具栏”窗口。
  6. 在您退出 JMP 时，系统将询问您是否保存更改。请单击否。如果单击是，JMP 将以新设置改写 JMP.jmpcmd 文件，而 JMP.jmpcmd 文件和使用另存为命令所保存的文件将包含相同的设置。

使用自定义文件

在创建新的 .jmpcmd 文件后，您随时都可以在 JMP 会话中使用该文件。只需打开并应用该文件，JMP 即会自动将新文件另存为 JMP.jmpcmd 文件，同时用作默认设置。

要载入该文件，请执行以下操作：

  1. 选择文件 > 打开。
  2. 在文件类型菜单中，选择 JMPCMD 文件 (.jmpcmd)。
  3. 选择文件名并单击打开。
  4. 在下一个窗口中，选择并查看指定文件中的菜单或工具栏。如果要同时使用指定文件中的菜单和工具栏，您必须分别打开文件。例如，选择菜单并对菜单完成以下步骤，然后从该窗口选择工具栏并重复这些步骤。
  5. 查看文件。如果需要，请将文件复制并粘贴到其它打开的 .jmpcmd 文件中。
  6. 关闭窗口。
  7. 如果进行了更改，JMP 将询问您是否保存更改。
  8. JMP 将询问您是否应用菜单/工具栏。请单击是，以便在当前会话中使用新设置。
  9. 如果在询问是否应用更改时（第 8 步）选择了是，在关闭 JMP 时，系统将询问您是否保存更改。只有在准备以自定义设置改写默认的菜单和工具栏设置（位于 JMP.jmpcmd 文件中）时，您才能单击是。这两个文件此时将包含相同的设置。

更改自定义文件

在 Windows 中创建新的 .jmpcmd 文件后，您随时都可以在 JMP 会话中对其进行更改。

要更改该文件，请执行以下操作：

  1. 选择文件 > 打开。
  2. 在文件类型菜单中，选择 JMPCMD 文件 (.jmpcmd)。
  3. 选择文件名并单击打开。
  4. 在下一个窗口中，选择并查看指定文件中的菜单或工具栏。如果要同时使用指定文件中的菜单和工具栏，您必须分别打开文件。例如，选择菜单并对菜单完成以下步骤，然后从该窗口选择工具栏并重复这些步骤。
  5. 进行更改。
  6. 关闭窗口。
  7. JMP 将询问您是否保存更改。请单击是。JMP 会将更改保存至自定义文件。
  8. JMP 将询问您是否应用更改。请单击是，以便在当前会话中使用新设置。如果在询问您是否应用设置时选择了是，则在关闭 JMP 时，它将询问您是否保存设置。如果在此窗口中单击是，当前使用的设置将改写默认菜单和工具栏设置（位于 JMP.jmpcmd 文件中）；JMP.jmpcmd 文件和自定义文件随后将包含相同的设置。

更改 .jmpcmd 文件的默认位置

您可能需要更改 JMP 在 Windows 中存储 .jmpcmd 文件的默认位置。初始默认位置与存储 JMP 应用程序的文件夹相同。

要更改此默认位置，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击文件位置类别。
  3. 选择 JMPCMD 文件目录。当前的默认位置将显示在浏览上方的框中，如"文件位置类别" 所示。
文件位置类别
  4. 通过在框中键入目录路径，或者单击浏览，然后定位至目录并单击选择，您可以更改位置。
  5. 单击确定。
  6. 如果在询问是否将当前设置保存到该新目录时单击了是，JMP 将更改默认位置，同时用当前工具栏和菜单设置改写该目录中的现有文件。如果单击了否，当前的菜单和工具栏设置不会被保存到此目录。在下次启动时，JMP 将从新指定的位置调用工具栏和菜单设置。


了解 JMP 起始页

类别和按钮综述

在 JMP 应用程序打开时，您会看到 JMP 起始页。如果此前您没有用过 JMP，则最好从下图所示的 JMP 起始页开始入门。它提供了另一种访问主菜单或工具栏中大多数命令的方法。

本章概括地介绍了 JMP 起始页，并且简要地说明了每个选项卡页以及其中的项或命令。

目录

JMP 起始页窗口概述

文件类别

基本类别

模型类别

多元类别

生存类别

图形类别

曲面类别

测量类别

控制类别

试验设计类别

表类别


JMP 起始页窗口概述

当 JMP 打开时，JMP 起始页将在“今日提示”窗口后台出现。JMP 起始页提供了另一种访问主菜单或工具栏中大多数命令的方法。您可以在需要时关闭 JMP 起始页；运行 JMP 并不要求 JMP 起始页。

要打开和关闭 JMP 起始页，请选择视图 > JMP 起始页（适用于 Windows 和 Linux）或者窗口 > JMP 起始页（适用于 Macintosh）。

JMP 起始页类别的排列方式与主菜单相似，如"JMP 起始页类别" 所示。文件类别后面的四个类别对应于“分析”菜单下面的选项。它们逐步引导您对数据进行适当的分析。以下的四个类别对应于“图形”菜单。以下的两个类别对应于“试验设计”和“表”菜单。

JMP 起始页类别


文件类别

JMP 起始页首先显示的是文件类别，如"JMP 起始页文件页" 所示。文件类别中的大多数命令对应于主菜单栏中的文件菜单命令。

文件类别中的命令用于打开 JMP 数据表或其它种类的 JMP 窗口，这通常是您首先需要执行的操作。

JMP 起始页文件页
  • 新建数据表按钮 打开一个空白的无标题数据表。有关详情，请参阅"创建新数据表"。
  • 打开数据表按钮 显示一个窗口，您可以使用它来定位您要打开的文件。此窗口还允许您指定引入文件的文件格式。有关详情，请参阅"打开现有 JMP 文件"。
  • 打开数据库表按钮（仅限于 Windows） 打开系统中有 ODBC 驱动程序的任何数据库的连接。有关详情，请参阅"从数据库打开数据"和"将数据表保存至数据库"。
  • 新建脚本按钮 打开一个新的空白脚本窗口，这是一个可以编辑文本的窗口，用于输入和提交 JMP 脚本语言 (JSL) 命令。有关 JSL 的详情，请参阅《JMP 脚本指南》。
  • 打开脚本按钮 显示一个专用的打开文件窗口，用于定位您要打开的脚本。有关详情，请参阅"打开现有 JMP 文件"。
  • 新建日志按钮 打开一个空白的日志窗口。有关详情，请参阅"使用日志命令保存"。
  • 打开日志按钮 显示一个专用的打开文件窗口，用于定位您要打开的日志。有关详情，请参阅"打开现有 JMP 文件"。
  • 首选项按钮 允许您指定一般设置和特定设置，以及保存这些设置以便这些设置与您的 JMP 会话关联。有关详情，请参阅"要更改首选项，请执行以下操作："。


基本类别

基本类别（"JMP 起始页基本类别"）着重于一元和二元分析。通过查看分布并且将其与已知的分布进行比较，您就会明白如何一次检查一个变量。在有单个响应 (y) 和单个因子 (x) 两个变量时，JMP 会根据变量是连续变量还是分类变量，来执行相应的双元分析。通过在基本类别中单击它们的按钮可以执行这些分析，如"JMP 起始页基本类别" 所示。

JMP 起始页基本类别

分布按钮

单击分布按钮或者选择分析 > 分布，启动“分布”平台，它使用柱状图以及其它图表和文本报表来介绍数据表列中值的分布。请参阅《JMP 统计和图形指南》 中的 "初始文本报表"。

双样本 t 检验按钮

单击双样本 t 检验按钮，将直接带您进入设置单因子分析的窗口。使用此按钮好过单击分析 > 以 X 拟合 Y。

配对按钮

单击配对按钮或者选择分析 > 配对，查看两个（或更多）列之间的平均差值。它将在旋转的散点图中绘制点，散点图根据两个变量的差异和平均值呈现这些点。

《JMP 统计和图形指南》中的“成对数据”一章介绍了配对并以独特的图形方式呈现了这种分析。

以 X 拟合 Y 按钮

单击以 X 拟合 Y 按钮或者选择 分析 > 以 X 拟合 Y，对活动数据表中每对指定为 x 和 y 的列启动一个报表平台以便分析。以 X 拟合 Y 按钮下面有四个子按钮：

  • 单因子按钮 如果 x 有记名或保序分析类型，并且 y 是连续分析类型，单击单因子按钮并且在窗口中进行选择，将针对 x 的每个离散值绘制 y 值分布图，并且计算单因子方差分析表。
  • 二元按钮 如果 x 和 y 都有连续分析类型，单击二元按钮并且在窗口中进行选择，将显示散点图。
  • 列联按钮 如果 x 和 y 都有记名或保序建模类型，单击列联按钮并且在窗口中进行选择，将会显示列联表和马赛克条形图。
  • 逻辑斯蒂按钮 如果 x 是连续分析类型，而 y 是记名或保序分析类型，单击逻辑斯蒂按钮并在窗口中进行选择，将会执行逻辑斯蒂回归并且显示一系列逻辑斯蒂概率曲线。

《JMP 统计和图形指南》 中的 "二元散点图和拟合"、"单因子方差分析"、"列联表分析"和"简单逻辑斯蒂回归"章节中讲述了这四种情形。


模型类别

模型类别（"JMP 起始页模型类别"）提供了用于拟合所有类型的模型的选项 - 从简单的变量回归和分析到复杂的非线性拟合。

JMP 起始页模型类别

模型拟合按钮

单击模型拟合按钮或者选择分析 > 模型拟合，将一个或多个 y 变量与 x 变量的模型拟合。

有关“模型拟合”窗口和“模型拟合”分析的详细说明，请参阅《JMP 统计和图形指南》中的“模型拟合简介”“标准最小二乘：简介”、“标准最小二乘：估计透视”、“标准最小二乘：探索预测方程”以及“标准最小二乘：随机效应”。

非线性按钮

单击非线性按钮或者选择分析 > 建模 > 非线性，允许您指定非线性模型，即参数呈非线性变化的模型。您可以结合拟合过程，协调 JMP 中的三个重要组成部分：数据表、公式编辑器和非线性拟合平台。

关于数据表和公式编辑器的详细资料在本手册的"输入和编辑数据"、"重新构造数据表"和"使用公式编辑器"章节中。

有关非线性拟合的详情，请参阅《JMP 统计和图形指南》中的“非线性回归”。

时间序列按钮

单击时间序列按钮或者选择分析 > 建模 > 时间序列，查看一个值与它的后续值之间的关系。数据必须经过排序，并且时间间隔相等。时间序列将绘制时间序列和自相关的图、显示变量图，并且显示光谱密度。

《JMP 统计和图形指南》中的“时间序列分析”将会介绍时间序列分析并且提供一些实例和统计详细资料。

分割按钮

单击分割按钮或者选择分析 > 建模 > 分割，根据与 y 值关联的 x 值将行递归分割成组。此分割将创建一个分区树。因子列 (x) 可以是连续或分类（记名或保序）的列。

神经网络按钮

单击神经网络按钮或者选择分析 > 建模 > 神经网络按钮，拟合单层神经网络。神经网络是一组非线性方程式，它使用线性回归层和 S 形函数灵活地预测输入变量 (x) 的输出变量 (y)。JMP 使用标准的非线性最小二乘回归法拟合神经网络。


多元类别

多元类别介绍了在连续变量仅被看作是响应时查看连续变量的方法；没有因子或自变量。通过相关和聚类分析进行多元研究，使您可以同时查看许多变量。

JMP 起始页多元类别

多元按钮

单击多元按钮或者选择分析 > 多元方法 > 多元，为您提供研究多个变量之间如何相关的方法。平台从标准的相关矩阵开始，提供了用于相关的附加选项以及其它查看多个变量的方法。

层次聚类和 K 均值聚类按钮

聚类是一种将在几个变量上有相似值的行聚成一类的方法。它是一种探索方法，帮助您了解数据的聚集结构。单击层次聚类或 K 均值聚类按钮或者选择分析 > 多元方法 > 聚类，将出现一个窗口，让您选择是运行 K 均值聚类还是层次聚类。

  • 层次聚类适用于小表，最多只能有几百行。它按树结构的层次顺序组合行。在 JMP 中，树也称为树状图，是一种动态响应图。在建立树之后，您可以指定聚类数。
  • K 均值聚类适用于更大的多达几十万行的表。它从聚类种子点开始。然后，聚类过程将循环执行以下两个操作：按您指定的聚类数分配点和重新计算聚类中心。
在完成聚类过程之后，您可以将聚类分配保存至数据表，或者使用它们来设置数据表行的颜色和标记。

有关多元关系和聚类的详细说明，请参阅《JMP 统计和图形指南》中的“相关性和多元技术”以及“聚类”章节。

判别按钮

单击判别按钮或者选择分析 > 多元方法 > 判别，开始进行判别分析。此方法基于一组测量变量与要预测的水平的多元均值的接近程度。（可选）您可以执行逐步的判别分析。

PLS 按钮

单击 PLS 按钮或者选择分析 > 多元方法 > PLS，使用偏最小二乘 (PLS) 方法拟合模型，这种方法会平衡解释响应变异和解释预测值变异这两个目标。PLS 方法通过提取称为因子（又称为分量或潜在向量）的预测值的连续线性组合，处理其中一个目标或同时处理这两个目标。使用 JMP 中的 PLS 平台可以选择按交叉验证提取的因子的数量，这样便可以将模型拟合为部分数据，将未拟合部分的预测误差降到最低。

项目分析按钮

单击项目分析按钮或者选择分析 > 多元方法 > 项目分析，使用项目响应原理提供检验项目分析。


生存类别

生存数据包含出现特定事件之前的持续时间，有时被称为事件时间响应数据。事件可以是失败，如引擎故障或病人死亡。

JMP 起始页中的生存类别

生存类别中的按钮（也可以在分析 > 生存和可靠性菜单下面找到），可以帮助您通过多种方式分析生存数据：

  • 生存/可靠性按钮（一元生存分析） 可进行一元生存分析，在绘出韦布尔、对数正态和指数分布参数估计的同时，也使用乘积极限 (Kaplan-Meier) 方法计算生命表。
  • 参数回归按钮 用于旨在检验指数、韦布尔或对数正态分布的拟合情况的分析。
  • 比例危险按钮 用于进行旨在拟合 Cox 模型的回归分析。
  • 再现按钮 在系统需要维修时执行分析，查看系统的使用年龄。系统可能有多次维修，每次维修时有相应的年龄，一直到系统不能再使用。典型的系统可能是引擎或设备的一些组件。

    注：您还可以使用非线性平台处理带损失函数的非线性模型，以便建立其它参数生存模型。

有关生存平台的详情，请参阅《JMP 统计和图形指南》中的“生存和可靠性分析 I”。


图形类别

图形类别（如"JMP 起始页图形页" 所示）对应于主菜单中的命令，用于生成汇总数据图和图表、三维旋转图、等高线和三元图。

JMP 起始页图形页

图表按钮

单击图表按钮或者选择图形 > 图表，并且完成窗口中的选择，将显示指定的每一个数值 y 的图表，其中 y 是要绘制图表的统计数据。x 值始终都将被视为离散值。图表在当前数据表中的值变化时将会自动更新，之后您可以激活图表窗口。

叠加图按钮

单击叠加图按钮或者选择图形 > 叠加图，并且在窗口中进行选择，将会显示重叠的单一数值或分类 x 列以及所有数值 y 变量的图。（可选）可以分别显示每一个 y 的图，常用的 x 轴可有可无。可以修改图的范围和针选项、颜色、对数轴和网格线。叠加图在当前数据表中的值发生变化时会自动更新，之后您可以激活叠加图报表窗口。

旋转图按钮

单击旋转图按钮或者选择图形 > 旋转图，并且在窗口中进行选择，可以生成一个三维可旋转图，显示活动数据表中的任何三个数值列中的值。它还会通过主成分、标准化主成分、旋转的成分和双向图，生成接近更高维数的效果。旋转图一次可以显示选择的列中的三个变量。

为了帮助获取更高维数中的差异并使之形象化，在您请求主成分时，旋转图平台将显示双向图以表示点和变量。

等高线图按钮

单击等高线图按钮或者选择图形 > 等高线图并且在窗口中进行选择，将构造响应变量 y 关于两个 x 变量值的等高线图。等高线图需要 x 和 y 轴的两个变量以及第三个变量（在“等高线图”窗口中表示为 y），用于绘制等高线图。

三元图按钮

单击三元图按钮或者选择图形 > 三元图，将会创建三元图，显示三部分合成数据的分布和变异性。合成数据的实例包括土壤中沙子、泥沙以及泥土的比例，或者试验药品中三种化学药剂的比例。您可以使用以比例或绝对度量表示的数据。三元图平台将绝对值转换为比例。

JMP 中的三元图也有等高线的功能，这意味着您可以在每一个点使用一个响应测量，以在三元结构中构成等高线图。

有关三元图的详情和实例，请参阅《JMP 统计和图形指南》中的“三元图”。

平行图按钮

单击平行图按钮或者选择图形 > 平行图，将绘制一个平行坐标图，该图显示相连的线段，表示数据表中的每一行。

方格图按钮

单击方格图按钮或者选择图形 > 方格图，将生成一个与数据表值一一对应的矩形单元格表。

直方图按钮

单击直方图按钮或者选择分析 > 直方图，让您构建分析，通过直方图和其它图形报表或文本报表显示值的分布。

散点图矩阵按钮

单击散点图矩阵按钮或者选择分析 > 多元方法 > 多元，研究多个变量之间如何相互关联以及点对此关系的拟合好坏。该平台帮助您查看两个或多个响应 (y) 变量之间的相关性，查找离群值，以及检查用于查找因子的主成分。

马赛克图按钮

在您有记名或保序 x 和 y 值时，单击马赛克图按钮将生成列联表和马赛克条形图。


曲面类别

曲面类别（如"JMP 起始页曲面页" 所示）对应于主菜单中的命令，用于生成多维图表，如刻画器和曲面图。

JMP 起始页曲面页

刻画器按钮

单击刻画器按钮或者选择图形 > 刻画器，将对一个或多个 y 变量，关于模型中的效应变量生成预测刻画器。预测刻画器对每一个 x 变量显示预测迹。预测迹是当一个变量发生变化而其它变量保持当前值不变时的预测响应。如果您保存了模型的预测方程式，则可以直接通过图形 > 刻画器菜单访问该数据表的预测刻画器，无需重新运行该模型。

等高线刻画器按钮

单击等高线刻画器按钮或者选择图形 > 等高线刻画器，绘制交互式等高线刻画。此功能对于以图形方式优化响应曲面很有用。此交互作用图使您可以同时调整多个响应和多个因子，并且显示您指定的响应值可接受的因子设置区域。如果您保存了模型的预测方程式，则可以直接通过图形 > 等高线刻画器菜单访问该数据表的等高线刻画器，无需重新运行该模型。

《JMP 统计和图形指南》中的“标准最小二乘：探索预测方程”一章将会介绍有关刻画器和等高线刻画器的信息。

曲面图按钮

单击曲面图按钮或者选择图形 > 曲面图，生成平滑三维曲面图。

定制刻画器按钮

单击定制刻画器按钮或者选择图形 > 定制刻画器，显示可与预测公式交互作用并且优化预测公式的界面。


测量类别

测量类别（如"JMP 起始页测量类别" 所示）可以访问图形菜单中的命令，这些命令用于统计质量控制；但性能按钮除外（它用于访问分析菜单中的分布命令）。

JMP 起始页测量类别

变异性图按钮

单击测量页中的变异性图按钮或者选择图形 > 变异性/度量图，执行变异性分析，也称为度量 R&R 分析。在变异性分析中，假定相同的许多部件都来自生产线。许多操作员都使用不同的测量仪器多次测量每一个部件。您可能要知道由于操作员、部件和仪器造成的差异大小。

《JMP 统计和图形指南》中的“变异性图”一章将会介绍变异性平台生成的图形和报表。

属性图按钮

在您的响应值是二元值或分类值时，可以单击属性图按钮或者选择图形 > 变异性/度量图并从下拉菜单中选择属性。例如，电路的测量结果可能是通过或失败。因为根据判定者生成的报表不同，因此每一个判定者需要在不同的列中。《JMP 统计和图形指南》中的“变异性图”一章将会介绍变异性平台生成的图形和报表。

性能按钮

单击测量页中的性能按钮或者选择分析 > 分布，为质量控制应用程序的性能分析提供一个平台选项。能力研究可以衡量流程与指定规格限的偏差。窗口提示您输入规格下限、规格上限和目标。您也可以输入已知的 Sigma 值（过程标准差）

有关性能分析实例的信息，请参阅《JMP 统计和图形指南》中的“一元分析”一章。

Pareto 图按钮

单击测量页中的 Pareto 图按钮或者选择图形 > Pareto 图，创建一个条形图（Pareto 图），显示在与质量有关的制程或操作中问题的严重性（频数）。Pareto 图是一种统计质量改进工具，用于显示问题的频数、相对频数及累积频数。Pareto 图的定义特征就是条按值的降序排列，这样可以直观地强调最重要的测量或频数。

《JMP 统计和图形指南》中的“Pareto 图”一章将会介绍简单的前后 Pareto 图和双因子比较 Pareto 图。

鱼骨图按钮

单击测量页中的鱼骨图按钮或者选择图形 > 鱼骨图，构建石川图，也称为鱼骨图或因果图。这些图表对于整理问题（果）的来源（因）很有用，例如在集思广益的讨论过程中，或在进一步的试验准备过程中用于初步分析，以确定存在的变量。

《JMP 统计和图形指南》中的“石川图”一章将会介绍如何创建这些图。


控制类别

控制类别（如"JMP 起始页控制类别" 所示）可以访问用于统计质量控制的命令。

JMP 起始页控制类别

运行图按钮

单击运行图按钮或者单击图表 > 叠加图，提供单个数值或分类的 x 列以及所有指定的数值 y 变量的叠加图。

X Bar 按钮

单击 X Bar 按钮将提供 [image] 、R 图和 S 图的组合 [image] 。图绘制子组均值，R 图绘制子组范围，而 S 图绘制子组标准差。

IR 按钮

单击 IR 按钮将提供个别测量图（显示个别测量）或移动控制范围图（显示两个或多个连续测量的移动控制范围）。

UWMA 按钮

单击 UWMA 按钮将提供等加权移动均值线 (UWMA) 图，也称为移动均值线图。UWMA 图中的每一个点都是最近 w 个子组均值（包括现在的子组均值）的加权平均值。

EWMA 按钮

单击 EWMA 按钮将提供了指数加权移动均值线 (EWMA) 图，也称为几何移动均值线 (GMA) 图。EWMA 图中的每一个点都是以前所有子组均值（包括现在的子组样本的均值）的加权平均值。随着时间回溯，权重以指数方式减少。

累计和按钮

单击累计和按钮将提供累计和控制图，显示测量或子组均值与目标值差异的累计和。

预先汇总按钮

单击预先汇总按钮，将根据所选样本大小或样本标签将制程列汇总至样本均值和（或）标准差。然后，它将汇总数据按个体或移动控制范围绘图。

Levey Jennings 按钮

单击 Levey Jennings 按钮将提供一个图，显示控制限基于长期 sigma 的制程均值。控制限距离中心线 3s。

多元按钮

单击多元按钮将提供 T 平方控制图，它根据协方差结构测量多元点到目标的距离。

P 按钮

单击 P 按钮将提供 p 图，该图显示子组样本（大小可能不相同）中不合格（有缺陷）项的比例。由于 p 图的每个子组由 N 个项组成，并且每项被判断为合格或不合格，因此子组中不合格项的数量最多为 N。

NP 按钮

单击 NP 按钮将提供 np 图，该图显示大小不变的子组样本中不合格（有缺陷）项的数量。由于 np 图的每个子组由 N i 个项组成，并且每项被判断为合格或不合格，因此子组 i 中不合格项的最大数量是 N i。

C 按钮

单击 C 按钮将提供 c 图，该图显示通常由一个检查单元组成的子组样本中的不合格点（缺陷）数目。缺陷最大数没有限制。

U 按钮

单击 U 按钮将提供 u 图，该图显示可以有许多不同检查单元的子组样本中每个单元的不合格（缺陷）点数。缺陷最大数没有限制。

OC 曲线

单击 OC 曲线按钮访问一组计算和绘制操作特征曲线的 JSL 脚本。《JMP 统计和图形指南》中的“统计控制图”一章将会详细介绍如何运行操作特征曲线脚本。


试验设计类别

试验设计类别（如"JMP 起始页试验设计类别" 所示）对应于试验设计主菜单中的命令。这些命令可以构建标准和自定义的试验设计，并且将它们保存在 JMP 表中。选择一种设计类型将提供一个环境，用于描述进行该类型的设计所需的因子、响应和其它规格。

有关 JMP 中的试验设计的完整介绍，请参阅《JMP 试验设计》。

JMP 起始页试验设计类别

定制设计按钮

单击定制设计按钮或者选择试验设计 > 定制设计，为您指定的设计生成 D 优化设计，并且可以根据需要为响应表面设计生成 I 优化设计。定制的设计可以有任意水平数、交互效应数和混料成分数的连续因子和分类因子。设计还可以有协变量，协变量是有不可更改值的因子；设计围绕协变量建立。您可以构建定制设计模型，包括连续因子的交互作用项和多项式项。因子可以有不等式限制条件。您还可以指定试验运行的次数（可以是大于或等于模型中项数的任意数）。

筛选设计按钮

单击筛选设计按钮或选择试验设计 > 筛选设计，允许您指定连续因子、二水平和三水平因子以及分类因子。它创建标准的筛选设计表，您可以从中选择设计。

响应面设计按钮

单击响应面设计按钮或者选择试验设计 > 响应面设计，让您定义许多连续因子。然后，此环境提供了标准的响应面设计表，您可以从中选择设计。

非线性设计按钮

单击非线性设计按钮或者选择试验设计 > 非线性设计，让您为参数呈非线性变化的模型创建优化设计。

空间填充按钮

单击空间填充按钮或者选择试验设计 > 空间填充，让您为确定或近乎确定的建模系统运行试验。您可以选择突出分开的扩散点、模仿统一分布或者选择这两者的折衷方案。

完全析因设计按钮

单击完全析因设计按钮或者选择试验设计 > 完全析因设计，让您指定一组任意水平数的连续因子和分类因子。JMP 创建的设计包含那些因子所有可能出现的组合。

田口设计表按钮

单击田口设计表按钮或者选择试验设计 > 田口设计表，引导您完成信号和干扰因子的定义。信号因子构成内表，而干扰因子构成外表。内表和外表设计是传统田口正交表，如 L4，L8，L16 等。

混料设计按钮

单击混料设计按钮或者选择试验设计 > 混料设计，让您定义属于混合成分的一组因子。JMP 创建一个新的窗口，用于在几种标准的混料设计方法中选择，如单纯形设计、顶点设计和格子设计。如果是极角点设计法，您可以提供一组线性不等式约束，限制混料因子空间的几何分布。

扩充设计按钮

单击扩充设计按钮或者选择试验设计 > 扩充设计，让您修改现有的设计。您可以添加中心点、重复设计、创建折叠设计，以及对项数超过原设计的模型添加试验点的设计。

样本大小与功效按钮

单击样本大小与功效按钮或者选择试验设计 > 样本大小与功效，对给定的 alpha 和误差标准差，计算功效，样本大小，或效应大小。您提供其中两个值，样本大小和功效功能将计算第三个值。如果您只提供其中一个值，结果是出现其它两个值的图。该功能适用于单样本、双样本和 k 样本的情形。


表类别

表类别（"JMP 起始页表类别"）对应于表主菜单中的命令。有关每个表菜单命令的详细说明和实例，请参阅"重新构造数据表"一章。

JMP 起始页表类别

表页中的按钮可以帮助您以多种方式分析生存数据：

  • 汇总按钮 创建汇总表，该表汇总了活动数据表（称为来源表）中的列。对于您指定的分组变量的每个水平，汇总表中都有对应的单个行。（可选）您可以在该表中添加汇总统计数据列，以及请求汇总统计数据。
  • 制表按钮 根据活动数据表创建制表格式的表。它对合计和小计进行计算和排序，并以报表格式而不是数据表格式向您显示。
  • 子集按钮 创建由选定行和列或活动数据表中的随机样本组成的新数据表。
  • 排序按钮 按一个或多个列对数据表进行排序。
  • 堆叠按钮 通过将指定列堆叠至单个列中，根据活动表创建新数据表。
  • 拆分按钮 通过拆分一个或多个列以形成更多列，根据活动表创建新数据表。
  • 转置按钮 创建新数据表，将活动表的列和行分别作为该数据表的行和列。
  • 合并按钮 将两个或多个打开的数据表首尾相连进行合并，创建新数据表。
  • 连接按钮 通过并排合并（连接）两个表，创建新数据表。
  • 更新按钮 使用一个数据表中的数据更新另一个表，但不生成新数据表。
  • 缺失数据模式按钮 显示缺失数据创建的模式。该模式有助于您发现数据的规律。


了解主菜单

命令说明

本章概括地介绍了位于屏幕顶部的 JMP 主菜单栏中的命令。

Windows 和 Linux 工具栏：

Macintosh 工具栏：

目录

JMP 菜单（仅限于 Mac）

文件菜单

编辑菜单

表菜单

行菜单

列菜单

试验设计菜单

分析菜单

图形菜单

工具菜单

视图菜单

窗口菜单

在 Microsoft Windows 和 Linux 平台上

在 Macintosh 平台上

帮助菜单

布局菜单


JMP 菜单（仅限于 Mac）

  • 关于 JMP 打开 JMP 的“关于”窗口，其中包含版本、版权、操作系统和 JMP 的许可证所有人信息。
  • 美国政府通知 显示受限制的权利通知。
  • 撤消对计算记的授权 撤消在当前的计算机上运行的 JMP 许可证。在撤消对计算机的授权后，您可以在其它机器上激活许可证。
  • 预置 允许您更改启动项、分析目标、输出信息、表格样式、字体、图形格式等等。有关预置命令的详情，请参阅"个性化 JMP"。
  • 服务 JMP 不支持服务菜单。
  • 隐藏 JMP 隐藏所有 JMP 窗口并将最近使用的应用程序带至前台。
  • 隐藏其他 隐藏其它所有正在运行的应用程序的窗口。
  • 显示全部 在视图上显示所有打开的应用程序。
  • 退出 JMP 关闭所有 JMP 窗口，同时允许您先复查和（或）保存已修改的文档，然后退出 JMP。


文件菜单

“文件”菜单中的命令执行文件管理或影响 JMP 环境。

文件 > 新建

选择文件 > 新建显示子菜单，其中有新建数据表或脚本窗口的选项。子菜单包含：

  • 文件 > 新建 > 数据表 打开空白的无标题数据表。有关详情，请参阅"创建新数据表"。
  • 文件 > 新建 >脚本 打开新的空白脚本窗口，这是一个可以编辑的文本窗口，用于输入和提交 JMP 脚本语言 (JSL) 命令。
  • 文件 > 新建 > 日志 打开空的日志窗口。有关详情，请参阅"创建新日志"。

文件 > 打开

打开命令显示专用的打开文件窗口，找到要打开的文件并指定引入的文件的文件格式。“打开”窗口显示引入的文件类型的相应信息。打开命令可直接读取 JMP 数据表、JMP 日志文件、JMP 脚本文件、SAS 数据集、SAS 传输文件、使用任意分隔符的文本文件和 Microsoft Excel 文件。在 Windows 平台上，该命令还可打开 Windows CMD 文件，即在您修改 JMP 主菜单并保存结果（另存为 .jmpcmd）时创建的文件。有关打开命令的详情，请参阅"打开现有 JMP 文件"。

文件 > 打开最近文件

打开最近文件命令（仅限于 Macintosh 和 Linux）的子菜单列出了最近打开的 JMP 表和脚本。在您单击列表中的表名时，JMP 就会打开该表。在您单击列表中的脚本名时，JMP 就会打开该脚本。一些脚本会自动运行。要打开但不运行脚本，请在选择时按住 Ctrl 键（Macintosh 平台上按 Option 键）。

文件 > 关闭

关闭命令关闭活动窗口。它的效果与单击活动窗口的关闭框相同。

注意：在 Macintosh 平台上，文件菜单上的关闭命令将关闭活动窗口。按住 Option 键选择文件显示全部关闭命令，将关闭所有的数据表。另外，按 Option 键单击关闭框可关闭所有的数据表。

文件 > 作为数据导入

作为数据导入命令将打开的文本文件写入 JMP 数据表。有关详情，请参阅"将文本作为数据导入"。

文件 > 保存

保存命令将活动的数据表、日志或布局写入文件。有关详情，请参阅"保存数据表"和"保存报表"。

文件 > 另存为

另存为命令在提示您输入文件名和文件类型之后，将活动的数据表、日志或布局写入文件。有关保存表的详情，请参阅"保存数据表"，有关保存报表的详情，请参阅"保存报表"。

在 Macintosh 平台上，按 Option 键选择文件显示将选择另存为命令，保存采用 Macintosh 图片或 JPEG 图形格式的数据表、报表、日志或布局中高亮度显示的图形。在 Windows 和 Linux 平台上，将选择另存为命令位于编辑菜单中。

文件 > 恢复（适用于 Windows/Linux）或文件 > 恢复保存（适用于 Macintosh）

恢复命令（适用于 Windows/Linux）或恢复保存命令（适用于 Macintosh）将当前的数据表恢复到上一次保存时的状况。除非已经编辑了数据表，否则 文件菜单中的该命令呈灰色显示。

文件 > 导出（仅限于 Macintosh）

导出命令将数据导成文本、Microsoft Excel 以及 SAS 传输文件格式。请参阅"另存为文本文件" 和 "另存为 SAS 传输文件"。

文件 > 数据库

数据库命令将打开系统中有 ODBC 驱动程序的任何数据库的连接。有关详情，请参阅"从数据库打开数据"和"将数据表保存至数据库"。选择文件 > 数据库显示一个子菜单，其中有用于打开或保存系统中有 ODBC 驱动程序的任何数据库的选项。子菜单包含：

  • 文件 > 数据库 > 打开表 显示“数据库打开表”窗口，让您连接要从中打开表的数据库。
  • 文件 > 数据库 > 保存表 显示“数据库保存表”窗口，让您连接数据库。然后，您可以将数据表保存到该位置。

文件 > Internet 打开

Internet 打开命令（适用于 Windows 和 Linux）允许您在 JMP 中打开 Internet 浏览器。有关详情，请参阅"读取实时数据（仅限于 Windows 和 Linux）"。

文件 > 首选项

首选项命令显示带选项卡的页，其中包含以下一组选项：

  • 一般 允许您指定首选项，包括启动选项、分析目标、输出中要包含的信息、报表样式等等。
  • 背景色（适用于 Windows 和 Linux） 设置窗口的背景色。您可以从标准的调色板中选择颜色，或者从调色盘中选择颜色并且将它添加到调色板中。
  • 字体 显示字体列表，用于设置文字、题头和标题的样式。
  • 图形格式 允许您选择在保存、复制或拖动报表中的图形时使用的默认图形格式。
  • 通信设置（适用于 Windows 和 Linux） 提供了收集实时数据的选项。
  • 文件位置（仅限于 Windows） 允许您输入默认路径以便打开 JMP 文件。例如，您可以告诉 JMP 每次您选择文件 > 打开时，它都要打开特定的文件夹。
  • 平台 允许您指定每次运行特定的分析时要显示哪些选项。
  • 文本导入/导出 允许您设置在导入和导出文本文件时 JMP 解释字段结尾和行结尾的分隔符所使用的默认规则。有关详情，请参阅"打开文本文件"。

文件 > 打印

打印命令打印活动窗口。它显示打印的标准窗口。该窗口的外观取决于您的操作系统和打印机驱动程序。有关详情，请参阅"打印报表"。

文件 > 打印预览

打印预览命令（仅限于 Windows）以打印的形式显示活动窗口。除非有打开的窗口，否则文件菜单中的打印预览呈灰色显示。

文件 > 打印设置（适用于 Windows）或页面设置（适用于 Macintosh）

打印设置命令（适用于 Windows）或页面设置命令（适用于 Macintosh）显示用于设置打印页特性的标准窗口。该窗口的形式取决于您的操作系统和当前的打印机驱动程序。

文件 > 发送

发送命令（仅限于 Windows）将报表和数据表提交给您定义的电子邮件应用程序。有关详情，请参阅"通过电子邮件发送表或报表（仅限于 Windows）"。

文件 > 最近文件

最近文件命令（仅限于 Windows）有一个子菜单，列出了最近打开的 JMP 表和脚本。在您单击该列表中的表名时，JMP 就会打开该表。在您单击该列表中的脚本名时，JMP 就会打开并自动运行脚本。要打开脚本，但不运行脚本，请按住 Ctrl 键，选择文件 > 最近文件，然后单击脚本名。

文件 > 保存会话脚本

“保存会话脚本”命令将创建一个 JSL 脚本，重新打开当前所有打开的文件并且重新运行当前所有打开的分析和图形。

文件 > 退出（适用于 Windows 和 Linux）

退出命令（适用于 Windows 和 Linux）关闭所有的 JMP 窗口（提示您保存更改）并退出 JMP 应用程序。在 Macintosh 平台上，退出命令位于 JMP 菜单中。


编辑菜单

编辑菜单包含标准的命令，这些命令作用于选定的行和列、报表的选定区域、脚本和文本以及公式编辑器中选定的公式元素。如果没有选择列，命令将作用于整个行。同样，如果没有选择行，命令将作用于整个列。在同时选择了行和列时，编辑命令影响那些行和列交叉的单元格定义的值的子集。

编辑菜单与 JMP 工具相结合可以用于复制全部或部分的活动分析报表窗口。有关详情，请参阅"工具菜单"。

编辑 > 撤消

撤消命令取消最近可撤消的编辑、行或列命令产生的效果。大多数破坏性的数据表操作（例如剪切、粘贴或删除行）是可以撤消的。在最近执行的命令是不可撤消时，撤消命令呈灰色显示。

编辑 > 恢复

恢复命令取消撤消命令产生的效果。

编辑 > 剪切

剪切命令将活动的数据表中的选定字段复制到剪贴板上，并换成缺失值。它相当于先执行复制命令，然后执行清除命令。您还可以使用剪切命令，复制全部或部分报表。然而，在报表中剪切命令类似于复制命令，不清除复制的图像。

编辑 > 复制

复制命令将活动数据表的选定数据单元格中的值复制到剪贴板上。它通过工具菜单中的区域选择工具（ [image] ）获取报表中的图和表。

如果您按住 Shift 键并选择复制（在 Macintosh 平台上按住 Option 键并选择复制），JMP 将执行复制标签命令，即保留复制的图像中的数据表的列标签。按住 Shift 键并选择粘贴（在 Macintosh 平台上按住 Option 键并选择粘贴标签），将信息复制到新的列中，并保留原有的列名。有关详情，请参阅"复制、剪切和粘贴"。

编辑 > 复制为文本

复制为文本命令将活动的报表窗口中的所有文字（不带图表）作为不带格式的文本复制到剪贴板上。在 Macintosh 平台上，只有在适用的情况下复制为文本命令才会出现。

编辑 > 粘贴

粘贴命令将剪贴板中的信息复制到 JMP 数据表的选定区域。粘贴可以与复制命令一起使用，以便复制行、列或选定的行和列定义的任何单元格子集。

如果您按住 Shift 键并选择粘贴（在 Macintosh 平台上按住 Option 键并选择粘贴），JMP 将执行粘贴标签命令，该命令将剪贴板中的第一行信息用作列题头。

编辑 > 清除 (Windows/Linux)，编辑 > 删除 (Macintosh)

清除命令清除活动的数据表中的所有选定单元格的值，并将它们替换为缺失值。值不会复制到剪贴板上。

编辑 > 全选

当活动窗口中是数据表时，全选命令将选择（高亮度显示）当前数据表中的所有行。当活动窗口中是报表、布局或日志时，全选将选择图中的点或选择布局或日志窗口中的所有对象。

编辑 > 将选择另存为

在 Windows 平台上，将选择另存为命令以图形格式保存分析窗口中高亮度显示的部分。在 Macintosh 平台上，按住 Option 键并选择文件显示将选择另存为命令。有关详情，请参阅"以图形的格式保存报表的某些部分"。

编辑 > 加密脚本和解密脚本

“加密脚本”和“解密脚本”命令将给您的脚本加上密码，以便只有在打开脚本的用户拥有密码的情况下，才能打开和（或）运行它。有关详情，请参阅"加密和解密脚本"。

编辑 > 作为数据导入

作为数据导入命令将打开的文本文件写入 JMP 数据表。有关详情，请参阅"将文本作为数据导入"。

编辑 > 运行脚本

运行脚本提交包含 JMP 脚本语言 (JSL) 命令的文本文件。您可以通过以下两种方式之一创建 JSL 脚本：

  • 选择文件 > 新建 > 脚本，然后手动键入 JSL 命令。
  • 完成分析，单击报表的红三元图标，并选择将脚本保存至脚本窗口。这让您保存描述整个分析报表或部分报表的脚本。要提交部分脚本，首先拖动鼠标以便高亮度显示所需的部分，然后选择编辑 > 运行脚本。如果没有高亮度显示脚本命令，将提交整个脚本。

有关详情，请参阅《JMP 脚本指南》。

编辑 > 停止运行脚本

停止运行脚本命令将停止运行 JSL 脚本。只有在脚本正在运行的情况下，它才会出现。

编辑 > 搜索

搜索命令让您能够使用大多数字处理和编辑程序中的常用方式，查找和替换数据表和脚本（包括列名）中的文字。有关详情，请参阅"使用搜索/查找命令"。

编辑 > 转至行

在打开脚本窗口时，转至行命令显示一个窗口，让您输入脚本的行号，然后使编辑集中在该行。

编辑 > 平衡

在 Macintosh 平台上，编辑 > 平衡命令可确保每个打开的 JSL 脚本都有闭括号。为此，在 Windows 和 Linux 平台上，请按 Ctrl+]。

编辑 > 日志

日志命令在脚本显示在报表窗口中时保存脚本。有关详情，请参阅"使用日志命令保存"。

编辑 > 布局

布局命令让您在保存报表之前编辑或处理报表，从而使您可以将几个报表合并成一个报表，或者重新排列报表的元素。在活动（最前面的）窗口是布局窗口时，布局菜单出现在编辑与表菜单之间（适用于 Windows 和 Macintosh）或视图和表菜单之间（适用于 Linux）。有关详情，请参阅"使用布局命令保存"和"布局菜单"。

编辑 > 自定义

自定义命令（适用于 Windows 和 Linux）有一个自定义菜单和工具栏的子菜单。恢复为出厂默认值将菜单和工具栏恢复到第一次安装 JMP 时的排列方式。有关定制 JMP 菜单的进一步介绍和实例，请参阅"个性化 JMP"。


表菜单

表菜单命令修改 JMP 表或者根据现有的一个或多个表创建新的 JMP 表。本小节概括地介绍了每一个表菜单命令。

表 > 汇总

汇总命令创建包含汇总表的 JMP 窗口，该窗口汇总了活动的数据表（称为来源表）中的列。有关详情，请参阅"汇总列"。

表 > 子集

子集命令创建新的数据表，它是活动数据表的子集。要快速地创建子集表，高亮度显示要作为子集的行，然后按住 Shift 键并选择表 > 子集。JMP 创建链接的子集表，但不要求您完成“子集”窗口。有关创建子集的详情，请参阅"创建子集表"。

表 > 排序

排序命令按一个或多个列对 JMP 数据表进行排序。排序命令显示一个窗口，让您指定要用作排序字段的列。有关详情，请参阅"对数据表排序"。

表 > 堆叠

堆叠命令通过将指定的列堆叠到单个新列中，根据活动的表创建新的数据表。新的数据表将保留其它列中的值。此外，堆叠将创建 ID 列，使用原始表中对应的列名作为值来标识新表中的每一行。与堆叠相反的命令就是拆分。有关详情，请参阅"堆叠列"。

表 > 拆分

拆分命令通过分割一个或多个列以便形成多个列，根据活动的表创建新的数据表。新的列对应于 ID 变量的值（水平）。拆分需要一个或多个列，组合的列值标识新表中的每一行。有关详情，请参阅"拆分列"。

表 > 转置

转置命令创建新的数据表，原始表的列是新表的行，而原始表的行是新表的列。有关详情，请参阅"转置行和列"。

表 > 合并

合并命令将两个或多个打开的表的首尾相连，创建新的数据表。有关详情，请参阅"附加表（合并）"。

表 > 连接

连接命令通过并排合并（连接）两个表，创建新的数据表。有关详情，请参阅"连接表"。

表 > 更新

使用一个数据表中的值更新另一个表。有关详情，请参阅"更新表"。

表 > 制表

以表格形式显示描述性的统计量。有关详情，请参阅"绘制数据表"。

表 > 缺失数据模式

显示数据表中的缺失数据（在单元格中以黑点表示）产生的模式。有关详情，请参阅"查看缺失数据的模式"。


行菜单

您可以从行菜单中访问影响高亮度显示的行的命令。单击数据表左侧的行面板上的红色三角形图标或单击行号上方的数据表左上角的红色三角形图标，找到其中的大多数命令。

行 > 排除/撤消排除

排除/撤消排除命令从统计分析中排除选定的行。有关详情，请参阅"排除行和列"。

行 > 隐藏/撤消隐藏

隐藏/撤消隐藏命令禁止出现（隐藏）行，以便在图形和图表中不显示这些行。有关详情，请参阅"隐藏行和列"。

行 > 标记/撤消标记

标记/撤消标记命令标记或标识所有散点图中的点。有关详情，请参阅"标记行和列"。

行 > 颜色

颜色命令可将所有散点图中高亮度显示的点改为您选定的颜色。有关详情，请参阅"为行指定颜色"。

行 > 标记

标记命令分配 JMP 标记选择面板中的字符，以便取代散点图和旋转图中的标准点。有关详情，请参阅"为行添加标记"。

行 > 下一选定项

下一选定项命令找到当前行之后第一个选择的行，并且使该行闪烁。有关详情，请参阅"查找下一个选定行和上一个选定行"。

行 > 上一选定项

上一选定项命令的行为与下一选定项相同，但是它找到当前行之前第一个选择的行，并且使该行闪烁。有关详情，请参阅"查找下一个选定行和上一个选定行"。

行 > 行选择

行选择命令有一个子菜单，子菜单中有一些选项用于：

  • 选择特定的行号（行 > 行选择 > 转至行）
  • 选择以前没有选择的所有行（行 > 行选择 > 反向行选择）
  • 选择数据表中的所有行（行 > 行选择 > 选择所有行）
  • 根据排除、隐藏或加标签的行状态选择行的子集（行 > 行选择 > 选择排除项、隐藏或标记）
  • 根据输入的标准选择子集（行 > 行选择 > 选择位置）
  • 选择活动数据表中值与高亮度显示的行相似的行（行 > 行选择 > 选择匹配单元格）
  • 选择所有打开的数据表中值与高亮度显示的行相似的行（行 > 行选择 > 选择所有匹配单元格）
  • 随机选择行（行 > 行选择 > 随机选择）

有关详情，请参阅"选择行和列"。

行 > 清除行状态

清除行状态命令清除数据表中所有活动行的状态。所有的行都将变为已包含、显示、撤消标记状态，同时在图中以黑点显示。它不影响行状态列中保存的行状态。

行 > 按列设定颜色或标记

按列设定颜色或标记命令让您为图中的点添加颜色或标记。有关详情，请参阅"根据列值为行指定颜色或标记"。

行 > 行编辑器

行编辑器命令可让您浏览或编辑单元格。有关详情，请参阅"使用行编辑器"。

行 > 删除行

删除行命令从 JMP 数据表中删除所有选定的行。使用编辑菜单中的撤消命令，取消意外删除操作。有关详情，请参阅"添加和删除行"。

行 > 添加行

添加行命令显示一个窗口，提示您输入要添加的行数并指定表中行的位置。有关详情，请参阅"添加和删除行"。

行 > 移动行

移动行命令将高亮度显示的行移到您在“移动行”窗口中指定的位置。


列菜单

您可以通过列主菜单、数据表左侧的列面板或数据表左上角的三角形图标，访问影响选定列的命令。

列 > 新建列

新建列命令显示一个窗口，您可以在该窗口中输入新列的信息，例如列名和特性。有关详情，请参阅"添加和删除列"。

列 > 添加多列

添加多个列命令显示一个窗口，让您可以在表中一次添加多个列。有关详情，请参阅"添加和删除列"。

列 > 转至

高亮度显示表中特定的列。

列 > 列信息

列信息命令显示新建列命令使用的窗口，不同之处在于没有添加新列的下一步按钮。有关详情，请参阅"为列指定性质"。

列 > 公式

公式命令显示列的公式编辑器，用于创建计算列值的公式。有关详情，请参阅"为列指定用于计算值的公式"和"使用公式编辑器"。

列 > 预选择角色

预选择角色命令将角色分配给选定的列，并且在数据表中保存角色。有关详情，请参阅"为列指定预选定的分析角色"。

列 > 验证

验证命令让您设置列，以使它只接受某些值。有关详情，请参阅"验证列数据"。

列 > 标记/撤消标记

标记/撤消标记命令是一个切换式命令，它标记或标识所有散点图中的点。有关详情，请参阅"标记行和列"。

列 > 滚动锁定/撤消锁定

滚动锁定/撤消锁定命令锁住选定的列，因此，当您水平滚动时，仍然可以看到这些列。有关详情，请参阅"原位锁定列"。

列 > 隐藏/撤消隐藏

隐藏/撤消隐藏命令是一个切换式命令，它禁止显示（隐藏）列，使得这些列不出现在图形或图表中。有关详情，请参阅"隐藏行和列"。

列 > 排除/撤消排除

排除/撤消排除命令是一个切换式命令，用于在统计分析时排除选定的列。有关详情，请参阅"排除行和列"。

列 > 标准化属性

标准化属性命令让您将属性（包括数据类型、建模类型和数值格式等等）以及特性（包括公式、列表、注释、列表和范围检查等等）应用于多个列。有关详情，请参阅"在列间标准化属性和性质"。

列 > 列重新排序

重新排列列顺序命令让您根据子菜单中的选择移动列：

  • 移动选定列 在“移动选定列”窗口中选择至最前将选定的列移至数据表的最左侧；选择至最后，将选定的列移至数据表的最右侧，或者选择之后：将选定的列移至您确定的列的后面。
  • 原始顺序 将列返回到上一次保存数据表时的排列顺序。
  • 按名称重新排序 将列（行状态列除外）按列名以字母顺序从左到右排列。
  • 按数据类型重新排序 将列按数据类型（字符、数值和行状态）以字母顺序从左到右排列。
  • 按建模类型重新排序 将列按建模类型（连续、保序和记名）以字母顺序从左到右排列。行状态列没有建模类型，并且在最后面显示。
  • 倒序 使数据表列的排列顺序变成相反方向。

如果您错误地移动一个列或多个列，使用编辑菜单中的撤消命令，恢复以前的顺序。

列 > 删除列

删除列命令从数据表中移除选定的列。有关详情，请参阅"添加和删除列"。

列 > 重新编码

重新编码命令让您快速地为编码不正确的数据（例如，包含拼写错误或措词不当）重新编码，以使它遵循统一的格式。有关详情，请参阅"数据重新编码"。


试验设计菜单

JMP 中的试验设计（试验设计）菜单是一种环境，用于描述创建指定的试验所需的因子、响应和其它规范，并且将它们保存在 JMP 数据表中。此处简要地介绍了具体的设计，在《JMP 试验设计》中有详细的介绍。

试验设计 > 定制设计

定制设计命令为所有的设计选择提供了最大的灵活性。使用该选项，您可以拥有任意水平数、交互作用、混合成分和协变量（有不可更改的固定值的因子）的连续因子和分类因子。您可以构建自行设计的模型，包括连续因子的交互项和多项式项。您还可以指定关于因子的不等式限制条件以及试验运行的次数（可以是大于或等于模型中的项数的任意数）。有关详情，请参阅《JMP 试验设计》。

试验设计 > 筛选设计

筛选设计命令让您指定连续因子以及二水平或三水平分类因子。它创建标准的筛选设计表，您可以从中选择设计。有关详情，请参阅《JMP 试验设计》。

试验设计 > 响应面设计

响应面设计命令让您可以定义多个连续因子。然后，此环境提供了标准的响应面设计表，您可以从中选择设计。有关详情，请参阅《JMP 试验设计》。

试验设计 > 完全析因设计

对于完全析因设计命令，您可以指定一组任何水平的连续因子和分类因子。JMP 创建的设计包含那些因子所有可能出现的组合。有关详情，请参阅《JMP 试验设计》。

试验设计 > 混料设计

混料设计命令让您定义是混料成分的一组因子。JMP 创建一个新的窗口，用于在几种标准的混合设计方法中选择，例如，单纯形设计、顶点设计和格子设计。如果是顶点设计法，您可以提供一组线性不等式限制条件，限制混料因子空间的几何分布。有关详情，请参阅《JMP 试验设计》。

试验设计 > 空间填充设计

空间填充设计命令通过尽量拉大设计点之间的距离创建设计。防止重复点并且均匀散布设计。有关详情，请参阅《JMP 试验设计》。

试验设计 > 非线性设计

非线性设计命令让您为参数中的非线性模型创建最佳的设计。有关详情，请参阅《JMP 试验设计》。

试验设计 > 田口设计表

田口设计表命令引导您完成定义信号和干扰因子的整个过程。信号因子构成内部数组，而干扰因子构成外部数组。内部数组和外部数组设计是传统的田口正交表，例如 L4，L8，L16 等等。有关详情，请参阅《JMP 试验设计》。

试验设计 > 扩充设计

扩充设计命令让您修改现有的设计。您可以添加中心点、按指定的次数复制设计、创建折叠设计，并且为使用项数超过原始设计的模型添加试验点。有关每一种设计类型的介绍以及详细信息和实例，请参阅《JMP 试验设计》。

试验设计 > 样本大小与功效

样本大小与功效对给定的 alpha 和误差标准差，计算功效，样本大小，或效应大小。您提供其中两个值，样本大小和功效功能将计算第三个值。如果您只提供其中一个值，结果则为其它两个值的图像。该功能适用于单样本、双样本和 [image] 样本的情形。有关预期的检出力分析的介绍和实例，请参阅《JMP 试验设计》。


分析菜单

每一个分析命令都会启动一个平台。平台是一个交互式窗口，您可以将其用于分析数据、处理图形中的点以及保存结果。JMP 分析中的报表是分层次组织的。展开报表的方法适合数据的结构。许多结果会自动显示，而更多的结果是通过下拉菜单提供。

分析 > 分布

选择分布启动分布平台，它通过柱状图和其它图形报表和文本报表描述了值的分布：

  • 连续的列显示柱状图和箱型图。您可以测试分布的均值和标准差，以及从各种分布拟合中进行选择。对于连续变量，可进行性能分析。
  • 记名列和保序列通过每一水平保序变量或记名变量的相对频数的柱状图表示。您可以选择查看马赛克（堆叠的）条形图及选择测试概率。

《JMP 统计和图形指南》 中的 "一元分析"详细介绍了分布命令并给出了实例。

分析 > 以 X 拟合 Y

以 X 拟合 Y 研究两个变量的关系。该平台显示图，并且同时分析每一对 x 和 y 变量。执行的这种分析取决于 x 和 y 列的建模类型（连续、记名或保序）。

  • 如果 x 和 y 都有连续的建模类型，以 X 拟合 Y 显示散点图。通过使用这些选项，您可以深入了解数据的各种回归拟合，并且选择最适合的拟合供进一步分析。每个拟合都具有一个支持统计分析和参数估计值的表。
  • 如果 x 是记名或保序建模类型，而 y 是连续建模类型，以 X 拟合 Y 为每一个不连续的 x 值标绘 y 值的分布图。您可以使用选项查看每一个 x 值的均值菱形和箱型图，并且使用比较圆圈比较分组均值。附加的文本报表还显示了单因子方差分析表。（可选）您可以请求进行非参数分析、查看多重比较并检验方差的齐性。
  • 如果 x 有连续值，而 y 有记名值或保序值，则以 X 拟合 Y 执行逻辑回归并显示一系列逻辑概率曲线。表显示了每一个曲线的对数似然分析和参数估计值。

    注：保序列的逻辑回归以参数表示，它的表示方式不同于记名列的逻辑回归，并且有时产生不同的结果。
  • 如果 x 和 y 都是记名值或保序值，以 X 拟合 Y 显示列联表和马赛克条形图。显示表的同时还显示每一个单元格的统计检验、频数、比例和卡方值等。（可选）您可以请求进行对应分析。

《JMP 统计和图形指南》 中的个别章节介绍了以 X 拟合 Y 命令提供的每一种分析类型。

分析 > 配对

如果两个响应构成来自相同的试验单元或对象的一对测量值，在这种特殊的情况下，配对命令处理二元数据。例如，配对可能是同一对象的前后血压的测量值。响应之间相关，称为成对的 t 检验的统计方法分析这种相关。

“配对”平台通过每一对 x 的均值标绘每一对 y 值之间的差异散点图显示数据，并且该平台包含标准成对的 t 检验，这相当于测试成对值之间的平均差值是零。有关详情，请参阅《JMP 统计和图形指南》。

分析 > 模型拟合

模型拟合让您使用数据特定模型定制分析。您在“模型拟合”窗口中选择列、分配角色并构建要拟合的模型。

模型拟合将一个或多个 y 变量与 x 变量的模型拟合。您从“模型拟合”窗口提供的拟合特点菜单中选择适于数据的模型类型。提供的拟合特性取决于您选择的响应类型。下面的列表简要地介绍了几种不同的拟合方法：

  • 标准最小二乘法 提供单个连续响应的最小二乘拟合，同时提供杠杆图和方差分析表。
  • 筛选 为具有连续值的单个或多个 y 列进行初步筛选分析。
  • 逐步 为单个连续或分类 y 值和所有类型的效应提供逐步回归。
  • 多元方差分析 为多个连续响应列执行多元方差分析。多元方差分析显示一个窗口，让您以交互方式拟合多元模型。
  • 对数线性方差 适用于单个连续响应和参数估计值，它们可以同时优化均值和方差。
  • 记名逻辑 通过最大似然将单个记名响应与记名回归拟合。
  • 保序逻辑 通过最大似然将单个保序响应与保序累积逻辑回归拟合。
  • 比例危险 为单个连续响应的删失数据生存分析执行比例危险 (Cox) 模型拟合。
  • 参数生存 测试指数、Weibull 或对数正态分布的拟合情况。

《JMP 统计和图形指南》的独立章节介绍了模型拟合平台提供的每一种方法。

分析 > 建模

建模命令包含启动这些平台的子菜单：

  • 非线性 拟合非线性模型，即关于参数非线性的模型。作为协调 JMP 中的三个重要组成部分：数据表、公式编辑器和非线性平台，将他们有机的结合起来。
通过公式编辑器定义非线性预测公式。然后选择非线性，以响应变量作为 y，以含有拟合公式的模型列作为 x。您通过“非线性拟合”控制面板使用以下途径与平台相交流：
  • 开始、停止或逐步完成拟合过程以及重置参数值的按钮
  • 指定损失函数和计算方法的拟合选项
  • 处理消息区域
  • 当前和极限收敛准则和迭代步数、当前参数估计值和误差平方和的列表
  • 指定置信区间的 alpha 水准和数值导数的 delta 水平的选项
非线性平台可以显示模型以及关于每个模型参数的导数及其拟合结果报表。该平台还对参数给出置信区间，并对单个变量给出拟合函数的图像。您还可以在包含用于绘制值的网格的数据表中保存 SSE 值。《JMP 统计和图形指南》 中的 "非线性回归" 一章详细介绍了非线性命令并给出了示例。
  • 分割 根据与 y 值关联的 x 值将行递归划分成组。此分割将创建一个分区树。
因子列 (x) 可以是连续或分类（记名或保序）的列。如果 x 是连续变量，将根据剪切值创建分块（分割），其将样本分成剪切值以下的值和以上的值两部分。如果 x 是分类变量，样本将被分成两个水准组。
响应列 (y) 可以是连续或分类变量（记名或保序分析类型）。如果 y 是连续变量，则平台拟合均值并根据均值差平方和最显著分离均值的准则创建分割。如果 y 是分类变量，则响应率成为拟合值。最显著的分割可以由最大的似然比或卡方统计量决定。总之，选择分割以使二个响应之间的差最大化。有关详情，请参阅《JMP 统计和图形指南》。
  • 神经网络 是标准的神经网络类型。它是反向传播正向馈送多层感知的神经网络的特定情况。类神经网络是一组非线性方程式，它使用线性回归层和 S 形函数灵活地用输入变量 (x) 预测输出变量 (y)。JMP 使用标准的非线性最小二乘回归法拟合类神经网络。有关详情，请参阅《JMP 统计和图形指南》。
  • 时间序列 让您深入了解、分析和预测一元时间序列。启动窗口（角色分配窗口）要求将一个或多个连续变量分配为时间序列。（可选）您可以指定时间 ID 变量，用于标记时间轴。如果指定了时间 ID 变量，它必须是连续的变量，按升序排列，并且间隔平均，且无缺失值。
分析开始于时间序列点的图形。此外，平台还显示序列自相关图和偏自相关图。这些图表示序列中的每一个点如何与序列中更早的值关联以及关联的程度有多深。您可以交互式添加：
  • 变异图 — 描述过程扰动
  • AR 系数 — 自回归系数
  • 频谱密度图 — 白噪音测试的周期和频数图
这些图表可以用于标识适合描述和预测时间序列演变的模型类型。模型类型包括：
  • ARIMA — 自回归积分移动平均，通常称为 Box-Jenkins 模型
  • 季节性 ARIMA — 包含季节性分量的 ARIMA 模型
  • 平滑模型 — 指数平衡和 Winters 法的几种形式
有关详情，请参阅《JMP 统计和图形指南》 中的 "时间序列分析"。

分析 > 多元方法

多元方法子菜单有启动以下平台的上述命令：

  • 多元 深入了解多个变量如何相互关联，以及点如何拟合这种关系。该平台帮助您查看两个或多个响应 (y) 变量之间的相关，查找查找离群点，"以及检查主成分以查找因子。
多元平台出现时，显示相关性和散点图矩阵。选项提供：
  • 伴随有条形图的逆、偏、非参数及成对相关。
  • 二元散点图矩阵以及每一对 y 变量图。
  • Mahalanobis 距离离群值图。
  • 折叠的多元距离离群值图，在该图中计算每个点的距离时不包括点本身。
这些图中有保存距离得分的选项。
您还可以请求主成分、标准化主成分、旋转指定的分量数和因子分析信息。
《JMP 统计和图形指南》 中的 "相关性和多元技术"一章介绍了多元命令。
  • 聚类 将 JMP 数据表的行聚类。聚类可以执行层次聚类或 k 均值聚类方法。层次聚类平台通过聚类树图（称为树状图）显示结果，后跟类之间的距离图。树状图有一个滑动的聚类选择器，可让您确定任意大小的类的行。还有用于保存每行聚类数的选项。层次聚类使用以下五种聚类方法：
    • 类平均连接法以两类之间的成对观测值间的平均距离为两个类之间的距离。
    • 重心法以两类之间的平均值之间的平方欧几里得距离为两个类之间的距离。
    • Ward 最小方差法（默认方法）以两类之间的对所有的变量相加的 ANOVA 平方和为两个类之间的距离。
    • 单一连接法以一个类中的观测值与另一个类中的观测值之间的最小距离为两个类之间的距离。
    • 完全连接法以一个类中的观测值与另一个类中的观测值之间的最大距离为两个类之间的距离。
k 均值聚类法根据由一个或多个定量变量计算的欧几里得距离找到不相连的类。每一个观测值只能属于一个类 — 这些类不能像分层聚类一样构成树结构。您要指定所需的类数。
聚类平台还提供了执行普通的混合聚类和 SOM（自组织图）的选项。
《JMP 统计和图形指南》 中的 "聚类"一章详细介绍了聚类命令并显示了聚类实例。
  • 判别 提供了根据响应的已知值预测单因子分类水平的方法。此方法基于一组测量变量与要预测的水平的多元均值的接近程度。您也可以选择逐步判别分析。有关详情，请参阅《JMP 统计和图形指南》。
  • PLS（偏最小二乘） 使用偏最小二乘法拟合模型，这种方法可平衡解释响应变异和解释预测值变异这两个目标。PLS 方法通过逐步提取称为因子（又称为分量或潜在向量）的预测值的线性组合，处理其中一个目标或同时处理这两个目标。使用 JMP 中的 PLS 平台可以按交叉验证选择提取的因子的数量。交叉验证方法用部分数据拟合模型，并将对未用于拟合的数据的预测误差最小化。有关详情，请参阅《JMP 统计和图形指南》。
  • 项目分析 让您使用项目响应原理 (IRT) 估计测试项的参数。另外，选择该选项可让您访问逻辑 1PL、2PL 和 3PL 模型。

分析 > 生存和可靠性

生存和可靠性子菜单中有一个包含以下命令的子菜单：

  • 生存/可靠性 进行一元生存分析，它估计 Weibull、对数正态和指数参数，并使用乘积极限法计算生命表。
  • 参数生存模型拟合 启动“拟合模型”窗口，使参数生存拟合特性生效。分析测试指数、Weibull 或对数正态分布的拟合情况。
  • 比例危险模型拟合 启动“拟合模型”窗口，使比例危险拟合特点生效。该回归分析拟合 Cox 模型。
  • 再现分析 在系统需要维修时查看系统的使用年限。系统可能有多次维修，到了一定的使用期限就需要维修一次，一直到系统不能再使用。典型的系统可能是引擎或设备的一些组件。

    注：您还可以使用非线性平台处理带损失函数的非线性模型，以便建立其它的参数存活模型。有关详情，请参阅《JMP 统计和图形指南》。


图形菜单

图形菜单命令显示一个窗口，其中包含带支持表格和统计量的图形或图表。有关每个图形菜单命令的详细介绍，请参阅《JMP 统计和图形指南》。

图形 > 图表

图表命令提供了指定的每个数值 y 变量的图表，其中 y 是用于绘制图表的统计量。x 值始终都将被视为离散值。在默认设置下，显示垂直的条形图，但是有显示水平条形图、线形图、阶梯图、针状图、点图和饼图的选项。

您最多可以在图表上指定两个 x 变量用于分组。第一个 x 是组变量，第二个 x 是水平（子组）变量。如果没有 x 变量，则每一行都是一个条。《JMP 统计和图形指南》中的“条形图、线形图和饼图”一章将会介绍图表命令以及相关的实例。

图形 > 叠加图

叠加图命令将单个数值或分类 x 列和所有指定的数值 y 变量重叠在一起。轴可以有线性尺度或对数尺度。（可选）可以分别显示每一个 y 的图，常用的 x 轴可有可无。

在使用默认设置时，x 变量的值以升序排列，并且也按该顺序绘制点图。您可以选择按照 x 值在数据表中出现的顺序绘制 x 值的图。

注：对于使用了回归拟合选项的两个变量的散点图，应该使用以 X 拟合 Y 命令，而不是叠加图命令。

《JMP 统计和图形指南》中的“叠加图”一章将会详细介绍叠加图命令并且给出绘制数据图的实例。

图形 > 旋转图

旋转图可以产生三维可旋转图，显示活动数据表中的任意三个数值列的值。它还会通过主成分、符合标准的主成分、旋转的成分和双向图，生成接近更高维数的效果。有保存主成分得分、标准化得分和旋转得分的选项。

旋转图平台还提供了主成分的因子分析型旋转，以便形成与空间中变量聚类的方向对应的正交组合。所使用的方法称为方差最大旋转法，因子分析通常也是使用该方法。

《JMP 统计和图形指南》中的“旋转图”一章将会详细介绍旋转图命令并且给出绘制数据图和计算主成分的实例。

图形 > 等高线图

等高线图命令构建一个或多个响应变量 y 对于两个 x 变量值的等高线图。等高线图假设 x 值位于成直角的坐标系统中，但是观测的点不必形成网格。部分等高线图选项包括：

  • 显示或隐藏数据点
  • 显示或隐藏三角测量或边界
  • 指定和标记水平
  • 显示等高线或填充区域

《JMP 统计和图形指南》中的“等高线图”一章将会详细介绍等高线图命令并且给出绘制数据图的实例。

图形 > 控制图

控制图命令将在 JMP 接收和记录样本子组时创建动态的样本子组图。控制图是在统计质量改进中使用的图形分析工具。根据数据分析的类型可以将控制图变泛地分类：

  • 变量控制图用于分析连续测量的质量特性。
  • 属性控制图用于分析计数不合格（缺陷）的质量特性，不合格（缺陷）的计数可以是在一个产品中，也可以是在一批样品中。

控制图的基本概念是可以通过一组控制界限量化任何过程中的自然变异性，并且变异超出界限，意味着变异的特殊原因的信号。在工业领域，控制图通常用于调查制造过程中产出的变异。它们通常用于区分由特殊原因和普通原因造成的变异。

控制图平台提供了以下几类图表：

  • 均值、控制范围和标准差
  • 单个测量和移动控制范围（运行图表、X 条形图和 IR）
  • p 图表、np 图表、c 图表和 u 图表
  • UWMA 和 EWMA
  • 累计和
  • 预先汇总的图表
  • Levey-Jennings

《JMP 统计和图形指南》中的“统计控制图”一章将会详细介绍控制图命令。

图形 > 变异性/度量图

在变异性分析中，假定相同的许多部件都来自生产线。许多操作员都使用不同的测量仪器多次测量每一个部件。您可能要知道由于操作员、部件和仪器造成的差异大小。Shewhart 控制图可以确定将在一段时间内失控的制程，变异性图表以同样的方式帮助确定操作员、部件和仪器。

变异性或连续度量图表适用于值可以通过连续尺度进行测量的响应。例如，测量的垫圈宽度可能是 2.3 mm。

属性度量图表适用于值是二元值或分类值的响应。例如，电路的测量结果可能是通过或失败。因为根据判定者生成的报表不同，因此每一个判定者需要在不同的列中。《JMP 统计和图形指南》 中的 "变异性图" 一章详细介绍了变异性/度量图命令。

图形 > Pareto 图

Pareto 图 命令创建一个条形图（Pareto 图），显示在与质量有关的制程或操作中问题的严重性（频数）。Pareto 图比较制程或操作中与质量有关的测量或计数。Pareto 图的定性特性是条按值的降序排列，这样可以再现地突出最重要的测量或计数。

Pareto 图使用称为制程变量的单个 y 变量，根据您指定的变量提供不同的图：

  • 当您没有指定 x（分类）变量时，提供简单的 Pareto 图
  • 当您指定单个 x 变量时，提供单因子比较 Pareto 图
  • 当有两个 x 变量时，提供双因子比较图

Pareto 图命令不辨别数值变量和字符变量，也不辨别建模类型。所有值都被视为离散，而条柱表示计数或百分比。

《JMP 统计和图形指南》中的“Pareto 图”一章将会详细介绍 Pareto 图命令。

图形 > 三元图

三元图命令使用三角形坐标绘制图。三元图平台使用的选项与等高线平台构建和填充等高线图的选项相同。此外，它有专用的十字准线工具，供您阅读三元轴的值。

《JMP 统计和图形指南》 中的 "三元图"一章详细介绍了三元图命令并显示了三元图的实例。

图形 > 鱼骨图

鱼骨图平台用于构建石川图，也称鱼骨图或因果图。在理清问题（果）的原因（因）时，这些图对于集思广益的讨论过程很有用，或者在进一步的试验准备过程中，这些图表可用作初步分析以确定变量。有关石川图实例的信息，请参阅《JMP 统计和图形指南》中的“石川图”。

图形 > 平行图

平行图命令可绘制平行坐标图，显示代表数据表中每一行的连接线段。

图形 > 方格图

产生与数据表值一一对应的长方形格子表。

图形 > 树图

树图命令将显示树图，也可以将它看成是折进二维空间里的条形图，不留下任何多余的空间。当存在多种类别时，它非常有用。树图是在有许多水平的组中观测模式的图形方式。它们特别适用于直方图无效的情况。

图形 > 刻画器

刻画器适用于根据模型预测公式计算列值的表格。通常在您执行标准的最小二乘法分析后请求该分析时，产生一张剖面图。然而，如果您保存了分析的预测方程式，就可以在从图形菜单中访问预测剖面图，并且使用包含保存的预测公式的响应列查看模型。

预测剖面显示每一个 x 变量的预测迹。预测迹是当一个变量发生变化而其它变量保持当前值不变时的预测响应。预测剖面是一种一次变化一个变量的方法，查看对于预测响应的效果。您可以与预测剖面进行交互；在您更改了 x 变量的值时，预测剖面将会重新计算以下值：

  • 每一个因子显示在 x 轴上的最低值和最高值，并显示当前值。
  • 每个 y 变量的当前预测值对应于 x 变量的当前值。
  • 预测剖面图中的线与标记显示当单个 x 变量变化时预测值的变化情况，并且通过在每个标记上和下的误差条显示预测值的 95% 置信区间。

预测剖面图在多重响应模型中非常有用，可帮助判断哪些因子值可以优化一组复合的准则。有关详情，请参阅《JMP 统计和图形指南》。

图形 > 等高线刻画器

等高线刻画器命令的使用方式与刻画器命令相同。在模型有多重响应时通常从拟合模型平台访问该命令。然而，如果您保存响应的预测公式，则以后可以从图形菜单中访问等高线刻画器，并且用指定的列作为响应列预测方程。有关刻画器和等高线刻画器的实例，请参阅《JMP 统计和图形指南》 中的 "标准最小二乘：探索预测方程"一章 。

图形 > 曲面图

曲面图命令根据公式或数据绘制三维图中的面和点。《JMP 统计和图形指南》将会详细介绍曲面图命令以及有关实例。

图形 > 定制刻画器

定制刻画器命令适用于根据模型预测公式计算列值的表格。“定制刻画器”在多重响应模型中尤其有用，有助于判断哪些因子值可优化一组复杂的准则。《JMP 统计和图形指南》将会详细介绍定制刻画器命令以及有关实例。


工具菜单

工具菜单是特殊的工具面板，光标可以变成这些工具的形状。有一些处理图中的点的常用工具和特殊的制图工具。默认的工具是箭头。单击“工具”菜单中的工具激活该工具。

箭头

在光标位于数据表左边的面板区、数据网格左上角的三角行和列区域或表格面板的标题栏时，光标是标准的箭头。此外，使用箭头单击并拖动可选择图中的点。在图形以外，单击并拖动可绘制一条临时线条。释放时，线条将消失。

帮助

问号图标可访问 JMP 帮助系统。选择帮助工具，然后单击需要帮助的数据表或报表中的某个位置。上下文帮助将告诉您有关您单击位置附近的项的信息。

选择

使用大加号（选择工具）选择数据表的行和列或者报表的区域。在您单击时，行或列将高亮度显示。单击并拖动可高亮度显示多个行和列，按住 Ctrl 键单击（在 Macintosh 平台上按住 Command 单击），可选择不连续的行或列。在报表边缘附近单击将高亮度显示整个报表。要撤消选择，在高亮度显示的区域再次单击。

滚动

拖动滚动工具，上下滚动报表，以便显示要查看的部分。滚动与垂直和水平滚动条执行完全相同的功能。在单击之后，滚动还原成箭头。在选择滚动时按住 Shift 键，可使光标在多次单击下依然保持为滚动。

抓手

手形（抓手）工具用于直接操纵图、图表、轴和公式组件。使用手形工具可更改轴值的显示范围。在 y 轴上，拖动 [image] 或 [image] 缩放 y 轴；拖动 [image] 滚动 y 轴。在 x 轴上，拖动 [image] 滚动 x 轴；拖动 [image] 或 [image] 缩放 x 轴。

笔刷

笔刷工具用于高亮度显示图中点的区域。在您单击时，会出现一个方框。将方框移到点上以便高亮度显示点。按住 Shift 键单击扩大选择的范围。按住 Alt 键单击（在 Macintosh 平台上按住 Option 键单击，在 Linux 平台上按住 Alt 和 Shift 键单击）更改选择矩形的大小，也可以扩大选择的范围。有关详情，请参阅"选择矩形区域的点"。

套索

套索工具用于高亮度显示图中点的不规则区域。在任何一组点周围拖动套索。在您松开套索时，它自动闭合并高亮度显示封闭区中的点。有关详情，请参阅"选择不规则形状区域的点"。

放大镜

扩大镜（缩放）工具可让您自动放大图表的任何区域。在您单击放大镜时，您单击的点或区域将变为新的数据视图中心。按住 Alt 键单击（在 Macintosh 平台上按住 Option 键单击）恢复到原始大小的图。在三元图上，拖动放大镜工具，放大三角轴。

十字准线

十字准线工具是一组可以移动的轴，用于测量图表中的点和距离。您在图中拖动十字准线时，将自动显示十字准线与水平轴和垂直轴相交处的值。在三元图上，该工具显示为三角十字准线条。

注释

注释工具可以在 JMP 报表、日志或布局窗口中添加可编辑的文字注释。有关详情，请参阅"添加注释"。单击之后，注释工具将还原成箭头。在选择注释工具时按住 Shift 键，可使光标在多次单击之后继续成为注释工具。

线条、多边形和简单形状

线条、多边形和简单形状工具用于在 JMP 报表、日志或布局窗口中添加可编辑的线条、多边形和简单的形状（椭圆或矩形）。有关详情，请参阅"添加形状"。单击之后，形状工具将还原成箭头。在选择形状工具时按住 Shift 键，可使光标在多次单击之后继续具有形状格式。


视图菜单

在 Windows 和 Linux 平台上，您可以在视图菜单中找到这些命令：

视图 > JMP 起始页

JMP 起始页命令打开和关闭 JMP 起始页。当 JMP Starter 是活动的窗口时，可以选择文件 > 关闭或单击关闭框，关闭 JMP 起始页。在 Macintosh 平台上，JMP 起始页命令位于窗口菜单中。有关详情，请参阅"JMP 起始页窗口"。

视图 > 窗口列表（仅限于 Windows）

“窗口列表”命令将在 JMP 窗口的左侧显示一个窗格，其中会列出您在 JMP 中打开的每个窗口的名称。使用鼠标右键单击列表中的窗口标题可关闭、重命名、刷新或隐藏它。有关详情，请参阅"窗口列表（仅限于 Windows）"。

视图 > 记录

记录命令在 JMP 窗口底部显示一个窗格，在执行 JSL 语句时监控 JSL 语句（JSL 脚本）。记录窗口是可编辑的窗口。例如，您可以使用记录找到脚本中的错误，更正代码，将它复制并重新粘贴到脚本窗口中，提交更正后的脚本。要从屏幕底移走记录窗口或者使该窗口再次回到屏幕底部，右键单击并选择浮动记录窗口或固定记录窗口。

视图 > 显示工具栏

显示工具栏命令显示一个窗口，列出所有可用的工具栏，工具栏旁边有一个复选框用于显示或隐藏工具栏。在 Windows 平台上，选择编辑 > 自定义 > 工具栏能使您更改和重新排列每一个工具栏上显示的工具图标。有关在 Windows 平台上自定义工具栏的完整介绍，请参阅"个性化工具栏（Windows 和 Linux）"。

视图 > 状态栏

状态栏命令可隐藏和显示窗口底边的状态栏。

在 Macintosh 平台上，您在视图菜单中可以找到这些命令：

视图 > 新建数据视图

新建数据视图命令显示与打开的数据表完全相同的另一个视图。新的视图链接至原始视图和所有对应的报表。在原始视图成为活动视图时，将反映对新视图所做的更改。在 Windows 平台上，新建数据视图命令位于窗口菜单。

视图 > 刷新窗口

刷新窗口命令将刷新活动窗口。在高速地动态处理窗口造成数据表视图和图表累积了零零散散的缺陷时，该命令有助于清理这些数据表视图和图表。

视图 > 扩大文本、缩小文本

扩大文本和缩小文本命令可增大和缩小 JMP 中的文本大小。


窗口菜单

窗口菜单可帮助您组织在 JMP 会话期间出现的窗口。

在 Microsoft Windows 和 Linux 平台上

在 Windows（左边）和 Linux（右边）平台上，您可以在窗口菜单中找到以下命令：

窗口 > 新建数据视图

新建数据视图命令显示与打开的数据表完全相同的另一个视图。新的视图链接至原始视图和所有对应的报表。在原始视图成为活动视图时，将反映对新视图所做的更改。在 Macintosh 平台上，新建数据视图命令位于视图菜单中。

窗口 > 关闭所有数据表（仅限于 Windows）

在 Windows 平台上，如果活动窗口是数据表，关闭所有数据表命令关闭所有的数据表。如果活动窗口是 JMP 启动器，该命令将是关闭启动器。如果活动窗口是报表，该命令将是关闭所有报表。如果活动窗口是脚本，该命令将是关闭所有脚本。

窗口 > 关闭全部

关闭全部命令可关闭所有打开的窗口。

窗口 > 排列（仅限于 Windows）

在 Windows 平台上，排列命令可帮助您组织 JMP 中打开的窗口。选择以下某个子菜单项：

  • 层叠 排列打开的窗口，以便看到每一个窗口的标题栏。
  • 平铺 并排排列打开的窗口，这样可以看到所有的窗口。水平平铺命令堆叠窗口，垂直平铺并排排列窗口。
  • 排列图标 在 JMP 窗口的底部将最小化的图标排成行。

窗口 > 层叠（仅限于 Linux）

层叠命令排列打开的窗口，以便可以看到每一个窗口的标题栏。在 Windows 平台上，该命令位于窗口 > 排列 > 层叠菜单中。

窗口 > 平铺（仅限于 Linux）

平铺并排排列打开的窗口，这样可以看到所有的窗口。在 Windows 平台上，该命令位于窗口 > 排列 > 平铺菜单中。

窗口 > 刷新

刷新窗口命令将刷新活动窗口。在高速地动态处理窗口造成数据表视图和图表累积了零零散散的缺陷时，该命令有助于清理这些数据表视图和图表。在 Macintosh 平台上，刷新命令位于视图菜单中。

窗口 > 字体大小（仅限于 Windows 和 Linux）

在 Windows 和 Linux 平台上，字体大小命令使您能够快速更改 JMP 使用的字体大小。选择以下某个子菜单项：

  • 增大字体 增大字体。再次选择可再次增大字体。
  • 减小字体 减小字体。再次选择可再次减小字体。

窗口 > 移至最后

移至最后命令可将活动窗口移到当前 JMP 会话产生的其它所有窗口的后面，显示序列中的下一个窗口。

窗口 > 设定标题

设定标题命令可让您更改任何活动的 JMP 窗口的名称。如果您在 JMP 会话期间生成多个输出报表并且需要区别这些报表，该命令将非常有用。有关更改数据表标题的选项，请参阅"更改表名称"。有关更改 JMP 输出报表标题的选项，请参阅"重命名报表"。

窗口 > 隐藏

隐藏命令将抑制显示活动窗口，但不关闭该窗口。在 Windows 平台上，隐藏的窗口不会出现在窗口菜单底部打开的 JMP 窗口列表中。

窗口 > 撤消隐藏（仅限于 Windows）

要重新显示隐藏的窗口，从撤消隐藏命令显示的列表中选择窗口的名称。从撤消隐藏菜单中选择全部将显示所有的 JMP 窗口。

窗口 > 显示全部

显示全部命令让您能够选择所需的活动窗口。如果有许多打开的窗口，这些窗口可能是数据表、报表、日志和布局，该命令对您将很有用。在 Microsoft Windows 平台上，隐藏的窗口不会出现在列表中。

窗口菜单的最后一部分列出了所有可以使用的窗口。在 Windows 平台上，列表中不显示隐藏的窗口。在列表中单击任何一个窗口，该窗口就会显示在前面。

在 Macintosh 平台上

在 Macintosh 平台上，您在窗口菜单中可以找到这些命令：

窗口 > 最小化

最小化命令可将窗口缩成固定区的一个图标。要展开窗口，可再次选择最小化。

窗口 > 缩放

缩放命令放大窗口，以便在显示器屏幕的可用区显示窗口。要缩小窗口，可再次选择缩放。

窗口 > 全部调到前面

全部调到前面命令可将所有的 JMP 窗口移到屏幕的前面。

窗口 > 设定报表标题

设定标题命令可让您更改任何活动的 JMP 窗口的名称。如果您在 JMP 会话期间生成多个输出报表并且需要区别这些报表，该命令将非常有用。

窗口 > JMP 起始页

JMP 起始页命令可打开和关闭 JMP 起始页。在 JMP 起始页是活动的窗口时，还可以选择文件 > 关闭或单击关闭框，关闭 JMP 起始页。

窗口菜单的最后一部分列出了所有可以使用并且没有隐藏的窗口。在列表中单击任何一个窗口，该窗口就会显示在前面。

窗口 > 记录

记录命令在 JMP 窗口底部显示一个窗格，在执行 JSL 语句时监控 JSL 语句（JSL 脚本）。记录窗口是可编辑的窗口。例如，您可以使用记录找到脚本中的错误，更正代码，将它复制并重新粘贴到脚本窗口中，提交更正后的脚本。


帮助菜单

在 Windows 和 Linux 平台上：

  • 帮助 > 内容、帮助 > 搜索和帮助 > 索引命令访问 JMP 帮助系统。帮助系统提供了可以浏览的联机 JMP 文档。
  • 帮助 > 今日提示命令可显示“今日提示”窗口。有关详情，请参阅"开始使用 JMP" 章节中的 "今日提示窗口" 。
  • 帮助 > 索引命令可显示以下参考资料：
    • 统计索引 访问提供统计术语定义的参考资料。要是在“统计索引”窗口中，您便可以单击主题帮助按钮，进入联机帮助中描述高亮度显示主题的地方。单击脚本按钮，查看或隐藏与高亮度显示的主题关联的脚本。单击启动，运行与您在列表中高亮度显示的项对应的脚本。单击实例，查看高亮度显示主题的实例。
    • JSL 运算符索引 显示 JSL 运算符列表，例如在编写 JSL 时将用到的 Sin、Cos、Sqrt 和日期缩写等。高亮度显示某个运算符名称可以在右侧的窗口中查看该运算符的说明。单击主题帮助按钮可以定位至联机帮助中的该主题。
    • 对象脚本索引 显示 JSL 对象的列表。这些对象是可脚本化的 JSL 构造区组。高亮度显示对象名称，右侧的窗口中将显示对象可以识别的消息。
    • 显示框脚本索引 显示 JMP 报表组成元素的列表。这些元素是用于构造输出的 JSL 构造区组。高亮度显示显示框，右侧的窗口中将显示每个对象的可用消息。
  • 帮助 > 教程命令可打开一组 JMP 教程。
  • 帮助 > 手册命令打开 JMP 文档的 .pdf 文件。
  • 帮助 > 样本数据目录命令可打开存储样本数据文件的目录。
  • 帮助 > JMP 网页命令可打开默认的浏览器，并且将您带到 JMP 的网站 www.jmp.com。
  • 帮助 > 关于 JMP 命令显示一个面板，提供了正在运行的 JMP 的版本、版权、操作系统和所有者信息。

在 Macintosh 平台上，JMP 帮助命令可显示带搜索功能和目录的 JMP 帮助项列表。


布局菜单

如果您要将 JMP 窗口复制到另一个窗口中并分片处理，可以使用布局命令。有关详情，请参阅"使用布局命令保存"。

布局 > 组合

组合命令将选定的对象合并成单个对象或组。

布局 > 取消组合

布局窗口从组合成单个对象的所有报表元素开始。在您单击布局时，组会被高亮度显示。取消组合命令将打散选定的组合对象。

您第一次使用取消组合时，分析标题将成为对象，并且是最外层的分析。其它的嵌套级别将成为一个对象。您可以继续选择布局窗口的任何部分，并且反复使用取消组合命令，将分析打散到最小的元素。

布局 > 对齐

对齐命令可根据您从对齐子菜单中选择的对齐类型将选定的对象对齐。您可以根据需要选择多个要对齐的对象。然而，如果在布局窗口中对象的放置方式与对齐请求相冲突，对象将会重叠。

布局 > 清除

布局对象可以移到布局窗口中的任何位置，这意味着对象可以重叠。在对象重叠时，最前面的对象会遮住下面所有或一部分对象。清除命令可移动选定的对象，以便它们在布局窗口中有各自的位置，都显示出来。

布局 > 前进；移至最前；后退；移至最后

前进和后退命令可将选定的对象一次向前或向后移动一层。移至最前可移动选定的对象，以使该对象位于其它所有对象的上面。移至最后可移动选定的对象，以使该对象位于其它所有对象的下面。请注意：在叠放对象时，最前面的对象可能会遮住下面的对象。


在公式中使用函数

JMP 中可用函数的说明

您可以在公式中添加函数。所有这些函数都被整理在函数浏览器中，该浏览器将一系列的函数和功能组成列表，在列表中按字母顺序（函数（所有））和主题（函数（分组））组织这些函数和功能，如下所示。

有关如何创建包含函数的公式的说明，请参阅"创建公式"。

本章介绍公式编辑器中的函数。

目录

行函数

数值函数

超越函数

三角函数

字符函数

比较函数

条件函数

概率函数

统计函数

随机函数

日期时间函数

行状态函数

赋值函数


行函数

在公式中添加一个行函数，使您可以引用特定行或特定行中的单元格。有关语法的详情，请参阅《JMP 脚本指南》。行函数的类型包括：

Sequence [image] 生成数据表中各行的算术序号，其中起始值、结尾限制和增量被指定为自变量。
Count [image] 创建以 from 值开头并以 to 值结尾的值列表。steps 数指定列表中在 from 值和 to 值之间（包括首尾值）的值的数量。Count 函数的前三个自变量确定的每一个值都会连续出现您使用 times 自变量指定的次数。在达到 to 值时，Count 将重新从 from 值开始。 （可选）您可以使用键区的插入键 ( [image]) 添加 times 自变量。此自变量的默认值是 1，但是此函数可以按您指定的次数多次重复计数过程，如"Count 函数的实例" 中数据表的计数4 列所示。要向 Count 函数中添加自变量，请高亮度显示您要在其后输入自变量的自变量，然后输入逗号或者使用公式编辑器键区的插入按钮 ( [image])。 下面数据表的列中显示的数据来自以下公式： Count (1, 9, 2) 得出计数1 Count (1, 9, 3) 得出计数2 Count (1, 9, 9) 得出计数3 Count (1, 9, 3, 3) 得出计数4
Count 函数的实例
Count 函数对于生成一列网格值很有用。例如，下面的公式将创建增量为 NRow()（Row 函数提供数据表中的总行数）并且轴的范围为 -5 到 5 的方格： Count (-5, 5, Root(NRow())) Count (-5, 5, Root(NRow(), Root(NRow()))
Lag [image] 返回由当前行所定义行中第一个自变量减去第二个自变量的值。默认的滞后值为 1，您可以将其更改为任何一个数值。对于确定的行号小于 1 的滞后，返回的值为缺失值。请注意，Lag(X, n) 的结果与带下标的符号 X Row( )-n 的结果相同。
Dif [image] 返回当前行中第一个自变量的值与该值在当前行所定义行中的值减去第二个自变量后的值之间的差值。默认的差值是 1，您可以将其更改为任何一个数值。请注意，Dif(X, n) 与 X Row()-X Row()-n 或 X Row()-Lag(X, n) 的结果相同。
Subscript [image] 允许您使用某个列在当前行之外的其它行中的值。从列表中选择 Subscript 后，在下标自变量中输入数值表达式。如果计算的下标值是不存在的行号，则生成缺失值。没有下标的列名表示当前行。要移除下标，请选择下标并将其删除。然后，删除缺失框。 公式 Count Row() - Count Row()-1 使用下标计算 Count 列的每一对值之间的差值，在此公式中，Row() 是下面所述的行号。此结果与 Dif() 函数的结果相同。在 Row() 为 1 时，计算得出缺失值。 下面的公式计算 Fib 列，其中包含 Fibonacci 数列（每一个值都是计算列中该行前面两个行中值的和）。
它说明如何使用下标执行递归计算。递归公式包括计算列的名称，列带有下标，以便它只参考先前计算的行（从第 1 行到第 (i - 1) 行）。显示的 Fibonacci 数列计算包括一个条件表达式和一个比较。有关详情，请参阅"使用条件子句"和"比较值"小节。
Row [image] 返回在其中计算表达式的行的行号。您可以在任何表达式中使用 Row()，包括列名下标。除非另外指定，否则，列名的默认下标就是 Row()。
NRow [image] 返回活动数据表中的总行数。


数值函数

您可以创建一个公式，该公式中包含公式中常用的算术运算符。这些算术运算符包括：

Abs [image] 返回与自变量值的量值大小相同的正数。例如，|5| 和 |-5| 的结果都是 5。
Modulo [image] 返回第一个自变量除以第二个自变量所得的余数。例如，Modulo(6, 5) 的结果是 1。
Ceiling [image] 返回大于或等于其自变量的最小整数。例如，Ceiling(2.3) 的结果是 3，而 Ceiling(-2.3) 的结果是 -2。
Floor [image] 返回小于或等于其自变量的最大整数。例如，Floor(2.7) 的结果是 2，但是 Floor(-0.5) 的结果是 -1。
Round [image] 将第一个自变量四舍五入为第二个自变量指定的小数位数。例如，Round(3.554, 2) 舍入为 3.55，而 Round(3.555, 2) 舍入为 3.56。

有关语法的详情，请参阅《JMP 脚本指南》。


超越函数

您可以创建支持超越函数的公式，如任意底数的对数函数、组合计算的函数、Beta 函数和多个伽马函数。有关语法的详情，请参阅《JMP 脚本指南》。您可以在公式中添加的超越函数包括：

Exp [image] 计算 e 的指定乘幂。因此，Exp(1) = e。
Log 和 Log10 [image] 计算自然对数（底数是 e）。要更改默认的底数，高亮度显示该自变量，然后输入逗号或者单击键区的插入键。底数将会显示并且可以编辑。Log 自变量可以是任意数值表达式。表达式 Log(e) 计算结果为 1，Log2(32) 的值为 5。Log10 函数只计算使用底数 10 的对数。
Squish [image] 可以有效地计算函数 1 / (1+e-x)，其中 x 是任意数值列、变量或表达式。
Root [image] 计算其自变量的指定指数的方根。Root 最初显示的指数是 2。要更改指数，高亮度显示指数自变量，然后输入您需要的值。
阶乘 [image] 返回从 1 到您指定的自变量的所有数的乘积。例如，Factorial(5) 的结果是 120。
NChooseK [image] 返回从 n 样东西中一次取出 k 样东西时可能的组合数（n 选择 k），使用阶乘进行计算的标准方法为 n!/ (k!(n - k)!)。例如，NChooseK(5,2) 的结果为 10。
Beta [image] 添加两个参数的 Beta 函数，且是 Gamma 函数的表达式：
Gamma [image] 添加 Gamma 函数，表示为 Γ(i)，并且定义为：
在 JMP 中，此公式将当前行号用作 i.计算每一个行的 Gamma 值。当前行号用在 Gamma 分布和其它概率分布的公式中。（单个自变量的 Gamma 函数与 Gamma(x, infinity) 相同。可选的第二个自变量将积分上限从无穷大更改为您输入的值）。其它需要关注的 Gamma 函数关系包括 如果 α > 1，Γ(α) = (α-1) Γ(α-1) 如果是任意正整数 n，露≤(n) = (n-1)!，表示为 n! Γ(0.5) = π 的平方根
LGamma [image] 计算 Gamma 函数值的自然对数。将 Log（自然对数）函数与 Gamma 函数结合使用，您可以得到同样的结果。但是，LGamma 函数的计算效率要高于 Log（自然对数）和 Gamma 函数相结合的计算效率。NChooseK 函数是用 LGamma 函数来实现的。结果不会总是一个精确的整数。如果结果接近某个整数，则使用 Floor 函数舍入取整。
Arrhenius

对自变量进行 Arrhenius 变换。Arrhenius 变换等于：
ArrheniusInv

进行 Arrhenius 逆变换*。
Logit [image] 对自变量进行 Logit 变换。
ScheffeCubic

用于拟合某些模型 。Scheffe Cubic (X1, X2) 相当于 X1*X2*(X1 - X2)。


三角函数

您可以创建支持超越函数的公式，如任意底数的对数函数、组合计算的函数、Beta 函数和多个伽马函数。有关语法的详情，请参阅《JMP 脚本指南》。三角函数包括：

Sine，Cosine，Tangent [image] Sine 和 Cosine 函数分别计算各自按弧度指定的自变量的正弦和余弦。例如，表达式 Sine(0) 的值为 0，Cosine(0) 的值为 1。正切函数计算按弧度指定的自变量的正切。表达式 Tan(.25) 的计算结果为 0.255342。
ArcSine，ArcCosine，ArcTangent [image] ArcSine 和 ArcCosine 函数分别计算各自自变量的反正弦和反余弦。返回的值以弧度表示。例如，ArcSine(1) 和 ArcCosine(0) 两个表达式的值都是 1.57080。ArcTangent 函数返回自变量的反正切。返回的值以弧度表示。表达式 ArcTangent(0.5) 的计算结果为 0.46364。
SinH，CosH，TanH [image] SinH 和 CosH 函数返回各自自变量的双曲正弦和双曲余弦。表达式 SinH(1) 的计算结果为 1.175201，CosH(0) 的计算结果为 1.0。TanH 函数返回自变量的双曲正切。表达式 TanH(1) 的计算结果为 0.761594。
ArcSinH，ArcCosH，ArcTanH [image] ArcSinH 和 ArcCosH 函数返回各自自变量的反双曲正弦和反双曲余弦。表达式 ArcSinH(1) 的计算结果为 0.881374，ArcCosH(1) 的计算结果为 0。ArcTanH 函数返回自变量的反双曲正切。表达式 ArcTanH(0.5) 的计算结果为 0.549306。


字符函数

您可以创建一个公式，该公式接受字符自变量或返回字符串，并且将一个值的数据类型从数值转换为字符，或者从字符转换为数值。有关语法的详情，请参阅《JMP 脚本指南》。字符函数包括：

Char [image] 生成与数值自变量中的数字对应的字符串。例如，Char(1.123) 的计算结果为 1.123。有关详情，请参阅《JMP 脚本指南》中的“字符函数”和表 3.23 “用于存储或计算表达式的函数”。
Concat || 通过将函数的第二个字符自变量追加在第一个字符自变量的后面，合并字符串以生成新字符串。例如 "Dr." || " " || name 将生成一个由称呼 Dr. 、一个空格以及 name 字符串的内容组成的新字符串。
Contains [image] 如果第一个自变量中包含第二个自变量，则返回第二个自变量在第一个自变量中第一次出现的编号位置。第二个自变量可以包含一个或多个字符。如果第二个自变量不存在，则 Contains 返回零。例如，Contains("Veronica Layman", "ay") 的计算结果为 11。Contains("Lillie Layman", "L") 的计算结果为 1。
Munger [image] 通过插入或删除字符，根据现有字符串计算新字符串。该函数还可以生成子串、计算索引以及执行其它任务，这取决于您如何指定它的自变量。Munger 函数将同一字母的大写和小写视为不同的字符。 文本是一个字符表达式。Munger 将其它三个自变量应用于该字符串，以计算结果。 位移是一个数值表达式，指明在字符串中搜索的起始位置。如果位移大于查找自变量第一次出现的位置，则忽略第一次出现的自变量。如果位移大于搜索字符串的长度，则字符串的长度就是位移值。 查找/长度是一个字符或数值表达式。将字符串用作搜索标准，或者使用正整数从 Offset 位置开始返回该数量的连续字符以作为搜索标准。如果您指定一个负整数作为长度值，Munger 将返回从位移一直到字符串结尾的所有字符。 替换（可选自变量）可以是字符串或者不指定。如果它是字符串并且查找/位移值是数值，Munger 将使用替换字符串替换搜索标准以形成替换后的结果。如果查找/位移值是数值并且没有指定字符串，则 Munger 将计算子串。如果查找/长度值是字符串，则 Munger 总是返回位移的数值，即使存在替换值也不予考虑。要插入替换自变量，可以单击 Munger 函数中的任何自变量，然后单击插入按钮。使用键盘上的删除键或公式编辑器键区的删除按钮 ( [image])，可以移除替换自变量。
Lowercase，Uppercase [image] Lowercase 函数将自变量中找到的大写字符转换为对等的小写字符。例如，Lowercase("VERONICA LAYMAN") 的计算结果为 veronica layman。Uppercase 函数将自变量中找到的小写字符转换为对等的大写字符。例如，Uppercase("Veronica Layman") 的计算结果为 VERONICA LAYMAN。
Length [image] 计算自变量的长度。例如，Length("Veronica") 的计算结果为 8。
Num [image] 在字符串只是由数字组成时，生成与它的字符串自变量对应的数值。如果字符串包含非数值，则结果为缺失值。例如，Num("1.123") 的计算结果为 1.123。
Substr [image] 在第一个自变量中，从第二个自变量指定的位置开始提取第三个自变量指定的数量的字符，这些字符是第一个自变量的一部分。第一个自变量可以是字符列或文字值。起始自变量和长度自变量可以是计算结果为数值的数个表达式。。例如，如果只想显示名字，Substr("Veronica Layman", 10, 6) 从位置 10 开始，一直读到位置 15，结果是 Layman。
Trim [image] 删除其自变量未尾的空白字符，生成新字符串。例如，Trim ("john") 的计算结果为 john。
Word [image] 提取字符串中的第 n 个字。一个或多个空格将定义每个字的开始和结束，除非指定了可选的分隔符自变量。例如，Word(2, "Veronica Layman") 将返回 Layman。 要插入分隔符自变量，可以单击 Word 函数中的任何自变量，然后单击键区的插入按钮。使用键盘上的删除键或公式编辑器键区的删除按钮 ( [image])，可以移除分隔符自变量。 多数特殊字符可用作单个分隔符。您可以输入任何字符或字符组作为字分隔符。例如，要提取下面实例中的姓氏，使用逗号加空格作为分隔符，要求返回第一个字。
Word(1, "Layman, Veronica", ", ") 返回字 Layman。
Item [image] 与 Word 函数不同，因为两者处理字分隔符的方式不同。如果多次发现某个分隔符，或者您输入一个具有多个字符的分隔符，Word 函数将它们视为单个分隔符。Item 函数使用每个分隔符来定义新的字位置。为了进行比较，我们假设姓名的格式是“姓氏, 名字。”分隔符是一个逗号加上一个空格，如： Item(2, "Layman, Veronica", ", ") Word(2, "Layman, Veronica", ", ") Item 函数分别处理逗号和空格，在这两个分隔符之间没有找到任何字符，因此，该函数返回缺失值。Word 函数将逗号和空格作为一个分隔符处理，并且找到 Veronica 是第二个字。
Hex [image] 返回以十六进制表示的自变量。如果自变量是字符（加引号），则结果是两倍长度的字符串，包含字符值的十六进制代码。例如，Hex("A") 返回字符串 41。 如果自变量为数值，则 Hex 函数的结果是以 8 个十六进制字符表示返回的整数。例如，Hex(12) 返回字符串 0000000C（适用于 Macintosh）或 0C000000（适用于 Windows 和 Linux）。
HexToChar [image] 将十六进制字符串转换成字符。生成的字符串可能不是有效的显示字符。所有字符必须成对出现，其中包括 0 - 9、A - Z 以及 a - z。允许使用空格和逗号，但是它会跳过这些符号。有关详情，请参阅《JMP 脚本指南》中“语法参考”一章中的“内部函数（计算器函数）”。
Repeat [image] 按第二个自变量指定的次数，重复第一个自变量，创建一个字符串。第一个自变量可以是字符文字、字符变量或字符表达式。例如，Repeat(“Katie”, 3) 的结果为 KatieKatieKatie。
在 JSL 使用 Repeat 函数重复矩阵时，则需要应用第三个自变量。在第一个自变量是矩阵时，第二个自变量是行范围的重复，第三个自变量是列范围的重复。


比较函数

您可以创建一个公式，使用比较函数比较两个自变量的值。每个比较关系根据数值大小或字符等级求出真或假值。真关系计算的值为 1，假关系计算的值为 0。

在条件表达式中包含比较很有用，但是，如果两个比较项都不缺失，则比较也可以作为数值表达式单独使用。有关语法的详情，请参阅《JMP 脚本指南》。

比较函数包括：

< 小于
> 大于
<= 小于或等于
>= 大于或等于
== 等于
!= 不等于
a<b<=c b 大于 a 并且小于或等于 c
a<=b<c b 大于或等于 a 并且小于 c
Is Missing [image] 如果当前行的自变量值缺失，函数返回 1，如果值不缺失，则函数返回 0。公式编辑器在进行统计计算时排除缺失的数值。


条件函数

您可以在公式中包含条件表达式（简称条件）。这些表达式使您可以建立与结果表达式成对的一连串子句。在您要有条件地给计算的列中的单元格赋值时，构造一连串子句是一种方法。有关语法的详情，请参阅《JMP 脚本指南》。条件函数包括：

If 显示单个 If 条件，其中包含一个缺失表达式和缺失的 then 子句。高亮度显示 expr 或 then 子句，然后输入值。例如，要在总数不为 0 时按合计的百分比计算计数，可以输入"条件表达式" 中的条件表达式（使用计数列和合计列）。
条件表达式
  • 要向 If 条件中添加新条件，可以高亮度显示 then 子句，然后单击公式编辑器键区的插入按钮 ( [image])。最初，会将现有的 else 条件更改为 expr 子句。再次单击插入按钮，添加 else 子句。高亮度显示 then 或 else 并反复单击插入按钮，可以将 else 更改为 expr 或者添加新 expr 子句。
  • 要删除某个子句，可以选择它上面的 then 子句，然后按键盘上的删除键或者单击公式编辑器键区的删除按钮 ( [image])。
  • 根据定义，求出的值为零的表达式为假。如果求出的表达式值为缺失值，则不执行子句并且返回缺失值。其它所有数值表达式为真。
Match 将表达式与列表中的子句进行比较，并且返回遇到的第一个匹配子句的结果表达式的值。您只需提供一次匹配表达式，然后给出每一个子句的匹配值。在您选择 Match 时，公式编辑器显示单个匹配条件，其中包含一个缺失表达式和一个缺失的 then 子句，如"使用 Match 函数的实例" 中所示。
使用 Match 函数的实例
在您选择 Match 之后，您应该高亮度显示 expr、value 或 then 子句，然后输入表达式。（或者，如果您高亮度显示一个表达式，然后单击 Match，则公式编辑器将创建一个新 Match 条件表达式，并且将原来高亮度显示的表达式用作 expr，value 和 else 子句仍为缺失。）另外，请记住：
  • Match 条件表达式比等效的 If 条件计算的快，并且使用的内存要少，这是因为对于数据表中每一行只需要计算变量一次。如果使用 If 条件，则对于每一行必须在每个 If 子句处计算变量，直至计算的子句的值为真。有关 Match 和 If 条件表达式的比较，请参阅"比较值"。
  • 使用 If 和 Match，公式编辑器将从序列的最上面向下搜索第一个真子句，然后计算对应的结果表达式的值。后面的真子句将被忽略。
例如，考虑使用下面的两个公式来根据儿童的年龄预测身高。在这两个公式中，基本身高都是 58.125 英寸，随着年龄变量值的变化，身高将增加。
Choose Choose 是 Match 的特殊情况，在这种情况下，条件的自变量是从 1 开始的整数序列。子句的值替代匹配条件。Choose 条件的实例如"Choose 条件的实例" 所示。使用 Choose，公式编辑器将直接定位至正确的子句选项并且计算结果表达式的值。
Choose 条件的实例
在您高亮度显示一个表达式并且单击 Choose 时，公式编辑器将创建包含一个子句的新条件表达式。按照前面对 If 条件的介绍，可以使用键区的插入 ( [image]) 和删除 ( [image]) 按钮，添加新子句或移除不需要的子句。 Choose 将计算 choose 表达式的值，然后直接定位至对应的结果表达式，以生成返回值。使用 Choose，您需要提供选择表达式一次，该表达式产生从 1 开始的连续整数，然后您就可以提供对序列中每个整数的选择。
And  & 在两个自变量都是真时，计算的值为 1。否则，计算的值是 0（请参阅"And 或 Or 表达式的计算"）。在"创建 And 函数" 中，只有当两个比较表达式的值都为真时，公式才会标记组 1 为司机。
创建 And 函数
Or  | 只要其中有一个自变量为真，计算的值就为 1。如果两个自变量都为假，则求出的 Or 表达式值为 0（请参阅"And 或 Or 表达式的计算"）。在"创建 Or 函数" 中，公式将男性以及 13 岁以上的所有参与者都分配给组 1。
创建 Or 函数
"And 或 Or 表达式的计算" 中左侧的真值表举例说明在两个自变量都有非缺失值并且计算值为真或假时，And ( & ) 和 Or (| ) 函数的结果。右侧的表举例说明在左边或右边的表达式（称之为 a 和 b）或者两个表达式都有缺失值时，两个函数的结果。
And 或 Or 表达式的计算
Not ! 在它的自变量为假时计算的结果为 1。否则，Not 的计算结果为 0。在您应用 Not 函数时，必要时可以使用括号以免含义模糊。例如，!(weight == 64) 可能为真或假（1 或 0），但是 (!weight) == 64 却始终为假 (0)，因为 Not 只能返回 0 或 1。象 !(weight == 64) 这样的表达式也可以输入为 weight != 64。
Interpolate 在两个点 x1，y1 与 x2，y2 之间线性插入与您提供的自变量对应的 y 值。您可以使用插入键插入其它成对的 x，y 自变量。Interpolate 查找与 x 值对应的一对 x，y 点，并完成插值操作。
Step 类似于 Interpolate，不同之处是它返回与小于或等于 x，y 自变量的最大的 x 值对应的 y 值。也就是说，它通过阶梯函数而不是点间的线性拟合查找指定的 x 对应的 y。与 Interpolate 一样，您可以根据需要有多个 x，y 自变量对。
For [image] 只要 while 条件为真，就反复执行主体自变量中的语句。初始和下一个控制迭代。
While [image] 重复检验表达式条件并执行主体，直至表达式不再为真。

使用公式编辑器面板中的插入子句和删除子句按钮扩展表达式。为了效率最高，可以在序列中列出计算最频繁的子句/结果对。

注：Interpolate、Step、For 和 While 经常与其它命令结合使用，以建立 JSL 脚本。您可以使用公式编辑器，在该列中创建和执行脚本，但是由于可能造成脚本相互依存和含义不明确，因此建议您不要这样做。通常脚本存储为 .JSL 文件，并且可以作为表特性与数据表一起保存。有关表特性的详情，请参阅"表面板"，有关所脚本命令的说明文档，请参阅《JMP 脚本指南》。


概率函数

您可以创建一个公式，该公式计算 Tukey HSD 的分位数以及 Beta 分布、卡方分布、F 分布、Gamma 分布、正态分布、学生 t 分布和 Weibull 分布的分位数和概率。有关语法的详情，请参阅《JMP 脚本指南》。您可以用来完成该任务的函数包括：

Beta Density 需要一个分位数自变量，然后根据需要接受形状参数 (alpha > 0) 和尺度参数 (beta > 0)。它返回指定自变量的 Beta 概率密度函数 (pdf) 的值。Beta 密度可用于随机变量的概率行为的建模，如限制在区间 [0, 1] 的比例。"三个 Beta 密度曲线的叠加图" 中显示了 α 和 β 的几种组合的密度的实例。
三个 Beta 密度曲线的叠加图
Beta Distribution 只对于长度有限的 x 区间有正密度，这与正态分布和 Gamma 分布不同，后两者对于无穷区间有正密度。理论上的 Beta 分布有一个形状参数 (α > 0) 和尺度参数 (β > 0)，以及定义分布值区间的常数 a ≤ x ≤ b。Beta 分布函数接受响应自变量 x，该自变量的范围定义了分布的区间。标准的 Beta 分布出现于区间 [0, 1]。Beta Distribution 是 Beta Quantile 函数的反函数。
Beta Quantile 接受概率自变量 p 以及形状参数和尺度参数（α > 0 和 β > 0）。它返回标准 Beta 分布中的 p 分位。Beta Quantile 是 Beta Distribution 函数的反函数。
ChiSquare Density 接受卡方分布的值范围中的分位数自变量、自由度自变量和（可选）非中心参数。它返回自变量的卡方密度函数 (pdf) 的值。"三个卡方密度曲线的叠加图" 显示三个卡方曲线的形状，自由度 (DF) 分别是 4、6 和 10。
三个卡方密度曲线的叠加图
ChiSquare Distribution 接受一个响应自变量（x 值范围）和三个参数自变量：分位数、自由度和非中心参数。它返回观测值小于或等于指定分位数的概率，观测值来自使用指定的非中心参数和自由度的卡方分布。例如，表达式 ChiSquare Distribution(11.264, 5) 返回观测值小于或等于 11.264 的概率，观测值来自中心为 0 且自由度为 5 的卡方分布。表达式的计算结果为 0.95361。 而且，ChiSquare Distribution 函数接受整数和非整数的自由度。默认情况下，中心为 0。ChiSquare Distribution 函数是 ChiSquare Quantile 函数的反函数。
ChiSquare Quantile 接受三个自变数：概率 p、自由度和非中心参数。它返回使用指定的非中心参数和自由度的卡方分布中的第 p 个分位数。例如，表达式 ChiSquare Quantile(.95, 3.5, 4.5) 返回中心为 4.5 且自由度是 3.5 的卡方分布中的 95% 分位数。表达式的计算结果为 17.50458。 ChiSquare Quantile 函数接受整数和非整数的自由度。默认情况下，中心为 0。ChiSquare Quantile 函数是 ChiSquare Distribution 函数的反函数。
F Density 接受 F 分布的值范围中的分位数自变量、分子和分母自由度自变量和（可选）非中心参数。它返回自变量的 F 密度函数 (pdf) 的值。"三个 F 密度曲线的叠加图" 显示 F 密度曲线的形状，自由度分别是 (5, 10)、(10, 20) 和 (20, 50)。
三个 F 密度曲线的叠加图
F Distribution 接受四个自变量：分位数、分子和分母自由度以及非中心参数。它返回观测值小于或等于指定分位数的概率，观测值来自使用指定的非中心参数和自由度的 F 分布。例如，表达式 F Distribution(3.32, 2, 3) 返回观测值小于或等于 3.32 的概率，观测值来自分子中的自由度是 2 且分母中的自由度是 3 的中心 F 分布。表达式的计算结果为 0.82639。 F 分布函数接受整数和非整数的自由度。默认情况下，中心为 0 并且分子自由度为 1。F Distributon 函数是 F Quantile 函数的反函数。
F Quantile 接受四个自变量：概率 p，分子和分母自由度以及非中心参数。它返回使用指定的非中心参数和自由度的 F 分布中的第 p 个分位数。例如，表达式 F Quantile(0.95, 2, 10, 0) 返回中心是 0 以及分子中的自由度是 2 且分母中的自由度是 10 的 F 分布中的 95% 分位数。表达式的计算结果为 4.1028。 F Quantile 函数接受整数和非整数的自由度。默认情况下，中心为 0 并且分子自由度为 1。F Quantile 函数是 F Distribution 函数的反函数。
Gamma Density 需要分位数自变量。（可选）Gamma Density 函数接受形状参数 a（默认值为 1）、尺度参数 b（默认值为 1）和阈值参数（默认值为 0）。"形状参数为 1、3 和 5 的 Gamma 密度的叠加图" 显示了形状参数为 1、3 和 5 的 Gamma 概率密度函数的形状。标准的 Gamma 密度函数在 α（形状） ≤1 时严格下降。在 α > 1 的情况下，密度函数从 x 为 0 时的函数值 0 开始上升，并在达到最大值后下降。
Gamma Distribution 基于标准的 Gamma 函数，并且接受分位数值的单个自变量。（可选）Gamma Distribution 函数接受形状参数、尺度参数和阈值参数，在前面对 Gamma Density 函数的讨论中介绍了这些参数的默认值。它返回标准的 Gamma 分布中的观测值小于或等于指定的 x 的概率。Gamma Distribution 函数是 Gamma Quantile 函数的反函数。
Gamma Quantile 接受概率自变量 p，并且返回使用您指定的形状参数的标准 Gamma 分布中的第 p 个分位数。Gamma Quantile 函数是 Gamma Distribution 函数的反函数。
形状参数为 1、3 和 5 的 Gamma 密度的叠加图
Normal Density 接受标准正态分布的值范围中的分位数自变量。它返回自变量的标准正态概率密度函数 (pdf) 的值。例如，您可以创建一个使用公式 count(-3, 3, nrow()) 的分位数值 (x) 列以及按 Normal Density(X) 计算得出密度值的第二个列。然后，选择图形 > 叠加图以按 x 绘制正态密度图。"正态密度曲线的叠加图" 显示具有各种均值和标准差的正态密度曲线的叠加图。
Normal Distribution 接受均值为 0 且标准差为 1 的标准正态分布的值范围中的分位数自变量。它返回标准正态分布中的观测值小于或等于指定的分位数的概率。例如，表达式 Normal Distribution(1.96) 返回 0.975，即标准正态分布中的观测值小于或等于第 1.96 个分位数的概率。（可选）您可以指定均值和标准差参数，以获得非标准正态分布中的概率。Normal Distribution 函数是 Normal Quantile 函数的反函数。
Normal Quantile（概率单位） 接受概率自变量 p，并且返回标准正态分布中的第 p 个分位数。例如，表达式 Normal Quantile(0.975) 返回标准正态分布中的 97.5% 分位数，计算的结果为 1.96。（可选）您可以指定均值和标准差的参数值，以获得非标准正态分布的分位数。Normal Quantile 函数是 Normal Distribution 函数的反函数。
正态密度曲线的叠加图
t Density 接受 t 分布的值范围中的分位数自变量、自由度自变量和（可选）非中心参数。它返回自变量的 t 密度函数 (pdf) 的值。要将自由度是 5 的 t 密度与标准正态分布密度进行比较，您可以创建一个使用公式 count(-3, 3, nrow()) 的分位数值 (x) 列、按 t Density(X) 计算的第二个列和按 Normal Density(X) 计算的第三个列。然后，选择图形 > 叠加图以按 x 绘制 t 密度和正态密度图，然后便可以看到"比较正态密度和 t 密度" 中所示的图。您可以看到 t 密度比正态密度稍微更分散。
t Distribution 接受三个自变量：分位数、自由度和非中心参数。它返回观测值小于或等于指定分位数的概率，观测值来自使用指定的非中心参数和自由度的学生 t 分布。例如，表达式 t Distribution(.9, 5) 返回观测值小于或等于 0.9 的概率，观测值来自中心为 0 且自由度为 5 的学生 t 分布。表达式的计算结果为 0.79531。t 分布函数接受整数和非整数的自由度。默认情况下，中心为 0，但是您可以输入非中心参数的值。t Quantile 函数是 t Distribution 函数的反函数。
t Quantile 接受三个自变量：概率 p、自由度和非中心参数。它返回使用指定的非中心参数和自由度的学生 t 分布中的第 p 个分位数。例如，表达式 Student's t Quantile(.95, 2.5) 返回中心为 0 且自由度为 2.5 的学生 t 分布中的 95% 分位数。表达式的计算结果为 2.558219。t Quantile 函数是 t Distribution 函数的反函数。此函数还接受整数和非整数的自由度。默认情况下，中心为 0，但是您可以选择输入非中心参数的值。t Distribution 函数是 t Quantile 函数的反函数。
比较正态密度和 t 密度
Weibull Density 接受 Weibull 分布的值范围中的分位数自变量。它返回 Weibull 概率密度函数 (pdf) 的值，即 Weibull 分布中的观测值小于或等于指定的分位数自变量的概率。
Weibull Distribution 使用分位数值自变量以及（可选）尺度参数 α 和形状参数 β。它返回观测值小于或等于使用您指定的形状参数和尺度参数的 Weibull 分布的指定 x 的概率。Weibull Distribution 函数是 Weibull Quantile 函数的反函数。 Weibull 分布有不同的形状，取决于 α（影响 x 方向的尺度参数）和 β（形状参数）的值。通常，Weibull 分布可以为估计使用寿命提供有效模型，特别是在机械设备和生物学方面。双参数 Weibull 与阈值参数为零的三参数 Weibull 相同。"Weibull 曲线的对比" 显示了阈值参数等于零时形状参数值和尺度参数值的几种组合的实例。极值分布是一种具有变换参数 δ = 1 / α 和 γ = ln(β) 的双参数 Weibull (α, β) 分布。
Weibull 曲线的对比
Weibull 分布有两个参数，α > 0 和 β > 0。在 α = 1 时，概率密度函数 (pdf) 简化为指数分布 (γ = 1 / β)。指数分布是 Gamma 分布和 Weibull 分布的特殊情况。但是，有不是指数分布的 Weibull 分布。
Weibull Quantile 接受概率自变量 p，并且返回使用指定的形状参数和尺度参数的 Weibull 分布中的第 p 个分位数。Weibull Quantile 函数是 Weibull Distribution 函数的反函数。
Binomial Distribution 它返回使用参数 p 和 n 的二项分布中的观测值小于或等于 k 的概率。通常，二项函数接受成功概率 p（感兴趣的事件）、试验数 n 和成功数 k 这些自变量。
Binomial Probability 计算二项分布中的随机变量等于 k 的概率。通常，二项函数接受成功概率 p（感兴趣的事件）、试验数 n 和成功数 k 这些自变量。
NegBinomial Distribution 计算负二项分布中的随机变量小于或等于 k 的概率。通常，负二项函数接受成功概率 p、试验数 n，以及感兴趣计数 k（在第 n 次成功之前的失败数）这些自变量。
NegBinomial Probability 计算负二项分布中的随机变量等于 k 的概率。通常，负二项函数接受成功概率 p、试验数 n，以及感兴趣计数 k（在第 k 次成功之前的失败数）这些自变量。
Hypergeometric Distribution 计算超几何分布中的随机变量小于或等于 x 的概率。超几何分布模拟从有限人口中进行固定抽样但不替换的成功数。超几何函数接受人口大小 N、人口中有所需特性的总项数 K、抽样数 n 以及样本中的成功数 x 等自变量。
Hypergeometric Probability 计算超几何分布中的随机变量等于 x 的概率。
Poisson Distribution 计算 Poisson 分布中具有均值 lambda 的随机变量小于或等于感兴趣计数的概率。通常，Poisson 函数接受感兴趣计数自变量和均值参数 lambda。
Poisson Probability 计算 Poisson 分布中具有均值 lambda 的随机变量等于感兴趣计数的概率。
Tukey HSD Quantile 接受概率自变量 p，并且返回按您指定的参数进行的 Tukey's HSD 检验中的第 p 个分位数。alpha 自变量为您需要的显著性水平，nGroups 是研究的组数，dfe 是基于整个研究样本的误差自由度。这是在 Tukey 的多重比较检验中用于计算最小显著差异的分位数。
F Power 和 F Sample Size F Power 函数计算涉及 F 检验或 t 检验的给定情形下的效能，F Sample Size 函数计算样本大小。自变量是您为了计算预期效能分析而指定的值。（如果您选择试验设计 > 样本大小与效能，这些函数将执行相同的计算。有关效能和样本大小的介绍，请参阅《JMP 试验设计》。）自变量包括：
  • alpha 您要容忍的显著性水平（通常是 0.05）。
  • dfh 假设自由度。对于 t 检验，它的值是 1。
  • dfm 模型自由度（满足 dfe = n - dfm）。
  • SquaredSize 以误差方差为尺度的效应大小平方，用于建立 F 分布的非中心自变量。对于此自变量，使用平方大小 = Δ2/σ2，其中 σ2 是误差方差。也就是说：
用于单样本 t 检验
用于双样本 t 检验
用于 k 样本 F 检验
  • n（只用于 F Power 函数中） 您预期的观测值（试验、试验单元或样本）的总数。效能（用于 F Sample Size 函数中）是结果有显著性的概率。


统计函数

您可以在公式中使用的统计函数包括：

Col Mean [image] 计算通过自变量标识的数值的均值（或算术平均值）。公式 Col Mean(age) 计算 age 列中所有非缺失值的平均值。
Col Std Dev [image] 度量通过自变量标识的分布围绕均值的散布度。在正态分布中，大约 68% 的分布在均值的一个标准差范围内，95% 的分布在均值的两个标准差范围内，99% 的分布在均值的三个标准差范围内。
Col Number [image] 计算您指定的列中的非缺失值数。在单元格没有赋值或者值为无效运算（例如除以 0）的结果时，会出现缺失数值。缺失值在电子表格中显示为缺失值标记 ()。缺失字符值为空字符串。在行状态列的公式中，已排除行状态特性被视为一个缺失值。对于其它缺失值，公式编辑器将根据它们的数据类型进行解释。
Col NMissing [image] 计算您指定的列中的缺失值数。在单元格没有赋值或者值为无效运算（例如除以 0）的结果时，会出现缺失数值。缺失值在数据网格中显示为缺失值字符 ()。缺失字符值为空字符串。
Col Sum [image] 计算其数值自变量中的值的总和。缺失值将被忽略。
Col Minimum 和 Col Maximum [image] Col Minimum 取数值自变量中的最小值。Col Minimum 忽略缺失值。Col Maximum 取数值列自变量的最大值，并且忽略缺失值。
Col Quantile [image] 计算一个值，该值指定百分比的数值小于或等于该值。例如，计算结果是 50% 分位数（也称为中位数）大于或等于数据的 50%。一半的数据值小于 50％ 分位数。 Col Quantile 函数的分位数自变量表示除以 100 的分位数百分比。25% 分位数（也称为下四分位数）对应于 p = 0.25，75% 分位数（称为上四分位数）对应于 p = 0.75。 公式编辑器通过按升序排列值，计算一列 n 个非缺失值的分位数。排序后的列值下标 y 1，y 2，...，y n 表示按升序排列的秩。 使用公式 p(n + 1) 计算第 p 个分位数值，其中 p 是分位数，n 是非缺失值的总数。如果 I 是整数，则分位数值是 y p = y i。如果 I 不是整数，则通过将结果的整数部分赋值给 i，小数部分赋值给 f 并且应用公式 qp = (1 - f)y i + (f)yi+1，来插入值。 例如，假设列中的值包括 2、4、6、8、10、12、14、16、18 和 20。50% 分位数的计算方法为 0.5(10 + 1) = 5.5。 由于结果是小数形式，因此 50% 分位数值可以按以下方式插入： (1 - 0.5) x 10 + (0.5) x 12 = (0.5)10 + (0.5)12 = 6 + 5 = 11 下面是 ColQuantile 公式的实例：
  • ColQuantile(age, 1) 计算最大的年龄。
  • ColQuantile(age, 0.75) 计算上四分位数年龄。
  • ColQuantile(age, 0.5)  计算中位数年龄。
  • ColQuantile(age, 0.25) 计算下四分位数年龄。
  • ColQuantile(age, 0) 计算最小的年龄。
ColQuantile 自变量可以是计算值介于 0 和 1 之间（包括 0 和 1）的任何表达式。例如，"分位数函数的实例" 中的第一个公式计算每一行按升序排列的年龄的分位数值。然后，列将包含计算列中按升序排列的年龄的插入值。第二个公式列出按降序排列的年龄的插入值。
分位数函数的实例
Col Standardize [image] 对它的数值表达式执行通常的标准化。对于每一行 i，Col Standardize(height) 就是 (HeightRow()-Col Mean(Height))/Col Std Dev(Height)。
Mean [image]   计算指定的非缺失自变量的算术平均值。自变量可以是常数、数字或表达式。Mean 函数最初显示有单个自变量。使用公式编辑器键区的插入按钮 ( [image]) 或者输入逗号，您可以添加自变量。
Std Dev [image] 计算指定的自变量列表的标准差。自变量可以是常数、数字或表达式。Std Dev 函数最初显示有单个自变量。通过单击公式编辑器键区的插入按钮 ( [image]) 或者输入逗号，您可以添加自变量。
Number [image] 计算您指定的自变量列表中的非缺失值数。
Sum [image] 返回自变量的总和。
Quantile [image] 为第一个自变量后面给出的所有自变量计算第一个自变量给出的分位数。
Summation (Σ ) 它对求和指数给出的列中明确的一批值求值，这与其它所有统计函数（Product 函数除外）不同，这些统计函数总是对每一行求值。该 Summation 函数使用"Summation 函数的实例" 中所示的求和符号。要计算一个和，可以将缺失实体项替换为包含指数变量 i 或包含您指定的指数变量的表达式。Summation 重复计算 i = 1，i = 2 一直到 i = NRow() 时表达式的值，最终将非缺失结果相加起来，确定最后的结果。
您可以将 NRow()（活动电子表格中的行数）和指数常数 i 替换为适合您的公式的表达式。例如，"Summation 函数的实例" 中的求和公式将计算从行 1 到当前行号的每一行的所有收入值的总和，并且在计算的列中填入收入列的累积总和。
Summation 函数的实例
Product (Π) 它对求和指数给出的列中明确的一批值求值，这与其它所有统计函数（Summation 函数除外）不同，这些统计函数总是对每一行求值。Product 使用"Product 函数的实例" 中右边的公式中所示的符号。将缺失实体项替换为包含指数变量 j 的表达式。Product 重复计算 i = 1，i = 2 一直到 i = n 时表达式的值，然后将非缺失结果相乘，以确定最后的结果。
您可以将 NRow()（活动电子表格中的行数）和指数常数 i 替换为适合您的公式的表达式。 例如，"Product 函数的实例" 中的第二个乘积表达式实例将计算 i!（每个行号的阶乘）。
Product 函数的实例
Minimum 和 Maximum [image] 分别返回您指定的非缺失自变量列表中的最小值和最大值。
N Missing [image] 计算您指定的自变量列表中的缺失值数。
Desirability

可用于拟合控制点的分段平滑函数。最小和最大函数是由三个部分构成的分段平滑函数，其中尾部呈指数分布，中间呈三次分布。

目标函数也是分段函数，目标两侧分别等于刻度乘以正态密度（每侧具有不同的曲线）。它也是分段平滑，拟合控制点。

有关语法的详情，请参阅《JMP 脚本指南》。


随机函数

您可以创建一类公式，这些公式在指定的分布约束范围内象“掷骰子”一样生成实数。使用 Mersenne - Twister 演算法生成的数字。有关详情，请参阅《JMP 统计和图形指南》的参考部分中提到的 Matsumoto 和 Nishimura 在 1998 年出版的文献。有关语法的详情，另请参阅《JMP 脚本指南》。您可以用来完成该任务的随机函数包括：

Random Uniform [image] 生成介于 0 和 1 之间的均匀随机数。这表示生成 0 和 1 之间的任何一个数与生成其间的其它数的机会均等。结果大致呈平均分布。您可以移动分布，以及使用常量更改它的范围。例如，5 + Random Uniform()*20 生成介于 5 和 25 之间的均匀随机数。
Random Normal [image] 使用均值 0 和标准差 1（在没有使用自变量时）或者使用您作为自变量输入的均值和标准差，生成接近正态分布的随机数。正态分布显示为钟形并且对称。如果没有输入自变量，您可以使用常数修改 Random Normal 函数，以提供特定均值和标准差的正态分布。例如，公式 Random Normal()*5 + 30 使用均值 30 和标准差 5 生成一个随机的正态变量。
Random Exp [image] 生成分布参数 lambda=1 的单参数指数分布。您可以修改指数函数，以使用其它 lambda。例如，0.1*Random Exp() - 0.1 将生成 lambda=0.1 的指数分布。指数分布常用于模拟简单的失败时间数据，其中 lambda 是失效率。
Random Gamma [image] 提供 alpha 参数（您输入作为函数自变量）的 Gamma 分布。Gamma 分布描述某个事件第 k 次出现之前的时间。Gamma 分布还可以有一个尺度参数 beta。使用公式 beta*Random Gamma(alpha) 可以生成使用形状参数 alpha 和尺度参数 beta 的 Gamma 变量。如果 2*alpha 是一个整数，则使用公式 2*Random Gamma(alpha) 可以生成 2*alpha 自由度的卡方变量。
Random Beta

生成一个分布 Beta (alpha, beta) 的伪随机数值。
Random Cauchy [image] 生成位置参数为 0 和尺度参数为 1 的 Cauchy 分布。Cauchy 分布呈钟形并且对称，但是要比正态分布尾部更重。使用公式 alpha+beta*Random Cauchy() 可以生成位置参数 alpha 和尺度参数 Beta 的 Cauchy 变量。
Random Triangular [image] 使用您输入作为函数自变量的中间点，生成 0 和 1 之间的数值的三角分布。您可以在函数中添加常数以移动分布，或者使用乘法更改它的范围。
Random Integer [image] 为介于 1 和您输入的自变量 n1 之间的整数生成均匀分布（如果没有输入 n2 的值）。如果您同时输入 n1 和 n2 (n1<n2)，则 Random Integer 将生成 n1 和 n2 之间（包括 n1 和 n2）整数的均匀分布。
Random Binomial [image] 生成二项分布（使用您输入作为函数自变量的参数）中的随机数。第一个自变量为 n，即二项试验中的试验数。第二个自变量为 p，即出现感兴趣事件的概率。在 n 等于 1 时，二项函数将生成 Bernoulli 试验的分布。例如，在 n =1 且 p = 0.5 时，函数将提供类似于投硬币结果的分布。二项分布的均值为 np，并且方差为 np(1 - np)。
Random Negative Binomial [image] 为您作为函数自变量输入的参数生成负二项分布。第一个参数是兴趣成功数 (r)，第二个参数是成功概率 (p)。兴趣的随机变量是第 r 次成功之前的失败数。二项变量的试验数固定，成功数为变量，与之相比，负二项变量的成功数固定，而试验数为随机数。负二项分布的均值为 (r(1 - p))/p，方差为 (r(1 - p))/p2。
Random Geometric [image] 生成几何分布（使用您输入作为函数自变量的参数）中的随机数。参数 p 是特定事件在任何一个试验中出现的概率。几何分布描述了特定事件第一次出现之前的试验数。几何分布的均值为 (1 - p)/p，方差为 (1 - p)/p 2。
Random Poisson [image] 根据您作为函数自变量输入的参数 lambda 的值，生成 Poisson 变量。Lambda 通常是事件在每单位时间或单位区域出现的频率。Lambda 既是 Poisson 分布的均值，也是 Poisson 分布的方差。
Random Reset [image] 使用您指定的种子重新开始随机数序列。
Random Seed [image] 允许您以指定的种子开始随机数序列。要使用 Random Seed 函数，您需要分配函数的自变量并且将其用于 If 条件函数中。然后，将您需要的随机数字函数用作 else 子句。"生成均匀随机数序列" 中的实例使用数字 1234567 作为生成均匀随机数序列的种子。
生成均匀随机数序列
Random Seeded Uniform 和 Random Seeded Normal [image] 这些函数使用较早的种子随机数生成器生成均匀的和正态的随机数。在您为了检验需要重复生成相同的随机数序列时，它们对您很重要。请注意，为了兼容，使用 Random Uniform() 和 Random Normal() 函数的 JMP 3 数据表会将这些旧函数的名称转换为新名称 RandomSeededUniform() 和 RandomSeededNormal。
Col Shuffle [image] 从当前数据表中随机选择一个行号。每个行号只能选择一次。在将 Col Shuffle 用作下标时，函数返回在用作自变量的列中随机选择的值。作为 Shuffle 的结果，原始列中的每一个值只能分配一次。 例如，要确定 50% 随机样本但不替换样本，可以使用"确定 50% 随机样本的公式" 中的公式。
确定 50% 随机样本的公式
"确定 50% 随机样本的公式" 中的公式从列 x 中选择一半的值 (n/2)，然后将它们赋值给计算列的前一半行。计算列的剩余行填入缺失值。
ResampleFreq [image] 生成有放回的随机选择频率计数，适合用于再抽样。例如，它支持另一个自变量 FreqColumn，允许它执行与第二个自变量中指定的预存频数列内的再取样。Resample Freq() 可生成 100% 的再取样。ResampleFreq(fraction) 可生成 fraction*nrow 频数样本，而 ResampleFreq(n) 可生成 n 频数样本。


日期时间函数

您可以在公式中添加的日期时间函数包括：

In Minutes, In Hours, In Days, In Weeks, In Years [image] 根据函数名称的单位将自变量转换为相等的秒数。自变量必须是数字或数值表达式。例如¨In Minutes(2) 得出 120，In Years(1) 得出 31,557,600（60 秒 * 60 分钟 * 24 小时 * 365.25 天）。
Date DMY，Date MDY [image] 接受日期、月份和年份的数值表达式，然后返回相关的 JMP 日期。例如，Date DMY (20, 3, 1991) 和 Date MDY(3, 20, 1991) 的计算结果是 2,752,272,000。
Today [image] 返回 1904 年 1 月 1 日与当前日期之间的秒数。例如，1991 年 3 月 20 日（星期三）的午夜，Today 函数返回 2752272000（2,752,272,000 秒）并继续计数。如果您在那一天更晚的时间计算 Today 函数的值，结果会反映增加的秒数。
Day, Month, Year [image] 分别返回一个月中的日期、月份（从 1 到 12 的数字）以及四位数的年份。这些函数的自变量被解释为 JMP 日期。例如，在 1991 年 3 月 20 日：
  • Day(2752272000) 返回数字 20。
  • Month(2752272000) 返回数字 3。
  • Year(2752272000) 返回数字 1991。
Day of Week, Day of Year, Week of Year [image] 这些函数的自变量是 JMP 日期。Day Of Week 返回从 1 到 7 的数字，其中 1 代表星期日。Day Of Year 返回从年初至今的天数。Week Of Year 返回从 1 到 52 的数字。Time Of Day 返回从 0 到 86399 的数字（按秒计）。例如，在 1991 年 3 月 20 日，星期三：
  • Day Of Week(2752272000) 返回数字 4。
  • Day Of Year(2752272000) 返回数字 79。
  • Week Of Year(2752272000) 返回数字 12。
  • Time Of Day(2752272000) 返回数字 0。
Informat [image] Informat 函数的自变量是日期字符串。例如，Informat("03/20/1991") 返回相应的 JMP 日期值 2752272000。JMP 可以读取除缩写日期和完整日期之外的所有日期格式。
Abbrev Date，Long Date，Short Date [image] 这些日期函数的自变量是 JMP 日期。它们返回以日期格式表示自变量的字符串。例如：
  • Abbrev Date(2752272000) 返回 Wed, Mar 20,1991。
  • Long Date(2752272000) 返回 Wednesday, March 20, 1991。
  • Short Date(2752272000) 返回 3/20/91。
Format [image] Format 函数中的第一个自变量是 JMP 日期。该函数按您在第二个自变量中指定的日期格式返回表示日期的字符串。如果您将此公式应用于数值列，JMP 会自动将列的数据类型更改为字符。
MDYHMS [image] MDYHMS 的自变量是 JMP 日期。此函数显示所有日期和时间字段，如果没有时间信息显示，则追加 0 作为时间字段。如果用公式表示日期列导致未能显示所有日期信息，这对您很有用。MDYHMS 函数可以用于查看所有可用的日期和时间信息。

有关语法的详情，请参阅《JMP 脚本指南》。


行状态函数

数据表中的行可能具有以下六种性质：选定、隐藏、排除、已加标签、已加色和已加标记。如果您为行指定其中一个或多个特性（请参阅"为行和列指定特征"），然后创建行状态数据表列（请参阅"使用行状态列"小节），则您可以创建一个公式来计算和保存行状态条件。此公式会象处理字符和数值数据一样，来处理行状态数据。有关语法的详情，请参阅《JMP 脚本指南》。行状态函数包括：

Row State [image] 返回当前行的活动行状态条件（真或假）。您可以使用此函数方便地编写取决于当前行状态的条件子句。例如，"Row State" 将 1 指定给当前选定且已加标签的行，将 0 指定给其它行。
Row State
As Row State [image] 将数值自变量转换为行状态或一组行状态条件。行状态在 JMP 内部被存储为 16 位数字，每一位都被指定用于表示一个可能的行状态，如"行状态存储为 16 位数字：每一位表示一种行状态" 中所示。例如，1327 二进制表示是 0000010100101111。因此，As Row State(1 3 2 7) 将行的状态设置为选定、排除、隐藏、已加标签，标记为 2 并且颜色是 10。
Combine States [image] 使用二个或多个自变量生成行状态的组合。使用公式编辑器键区的插入按钮 ( [image]) 或者输入逗号，在 Combine States 函数中添加自变量。在您选择 Combine States 时，当前选定的表达式将成为第一个自变量。将每个自变量替换为计算结果为行状态的表达式。此公式： Combine States(
Selected State(Modulo(Row(),2),
Labeled State(Modulo(Row()+1,2)) 交替标注或选择计算行状态列中的每一行。在本小节的后面定义了 Selected State 和 Labeled State 函数。使用公式编辑器键区中的插入 ( [image]) 按钮和删除 ( [image]) 按钮，添加更多的自变量或移除不需要的自变量。 如果您在组合中包含冲突的行状态，则结果不可预计。
Excluded State 将数值自变量解释为真或假。在自变量的计算结果为真时，Excluded State 函数将指定排除条件作为列中该行的值。例如，Excluded State(Modulo(Row(),2) 将指定排除行状态作为每个奇数行的行状态列的值。
Hidden State 在自变量大于 0 时指定隐藏行状态条件。如果自变量为 0，则不隐藏列中该行的值。
Labeled State 在自变量大于 0 时指定已加标签行状态条件。如果自变量为 0，则不标注列中该行的行值。
Color State 返回 JMP 颜色图中与它的整数自变量对应的颜色。从 0 到 84 对 JMP 颜色编号，但是与颜色索引对应的更大整数将被视为 modulo 84。0 对应于黑色。
Marker State 返回 JMP 标记图中与它的整数自变量对应的标记。从 0 到 16 对标记编号，但是与标记索引对应的更大整数将被视为 modulo 16。公式 Marker State(Row()) 将当前行号确定的重复序列中的所有行状态标记指定给计算的行状态列。行状态列可以有多个行状态为一个值。
Selected State 在自变量大于 0 时指定选定行状态条件。如果自变量为 0，则不选定列中该行的值。
Hue State 返回 JMP 色调图中与它的整数自变量对应的颜色。从 1 到 11 对 JMP 色调编号，但是更大的整数将被视为 modulo 12。Hue State 函数不对应黑色、灰色或白色。色调 0 对应红色，色调 11 对应洋红色。"色调和暗度函数的实例" 中左侧的公式根据 z 的值指定色彩范围中的颜色。Hue State 函数用于行状态数据类型列。
Shade State 将五个暗度级别指定给颜色或色调。暗度 -2 表示最暗，暗度 +2 表示最亮。暗度 0 表示是纯色。"色调和暗度函数的实例" 中右侧的公式根据 z 的值指定暗度值。
色调和暗度函数的实例
要指定调色板中所有颜色的所有暗度，您需要将 Hue State 和 Shade State 指定一起使用。"使用 Hue State 和 Row State 的 Combine States 实例" 中的公式使用本节开始介绍的 Combine States 函数。Combine States 函数的第一个自变量是前面介绍的 Hue State 公式，第二个自变量是 Shade State 公式。此外，自变量为 2 的 Marker State 函数将 X 标记指定给每一行，而自变量为 1 的 Selected State 函数选择每一行。
使用 Hue State 和 Row State 的 Combine States 实例
Excluded、Hidden、Labeled 和 Selected 接受计算结果为 1 或 0（真或假）的行状态表达式自变量（行状态列或行状态常数）。默认情况下，这些特性无效。通常，Row() 函数用作自变量，检测每一行的活动行状态条件。例如，在"使用 Selected 函数的公式实例" 中，只要当前选定了某个行，公式将指定 99，否则为 0。请注意，此公式用于具有数值数据类型的列。
使用 Selected 函数的公式实例
"计算行状态列中的行状态信息" 中的实例将行状态条件指定给行状态列。行状态列的公式（位于 row state col 列中）将查看活动行状态是否为 Hidden 或 Excluded，要是如此，还将指定 Labeled 行状态。
计算行状态列中的行状态信息
Color Of 接受任何行状态表达式或列，或者接受 Row State() 函数作为它的自变量并且返回 JMP 颜色图中与活动颜色状态对应的编号或缺失值（如果没有分配的颜色）。
Marker Of 接受任何行状态表达式或列，或者接受 Row State() 函数作为它的自变量并且返回 JMP 标记图中与活动标记对应的编号或缺失值（如果没有分配的标记）。


赋值函数

赋值函数作用于当前位置。也就是说，运算（运算符右边）返回的结果存储在运算符左边的自变量中并且替换自变量的当前值。

赋值语句通常与其它命令结合使用，用于建立 JSL 脚本。有关语法的详情，请参阅《JMP 脚本指南》。赋值函数包括：

=（赋值） 将 b 的值放到 a 中。例如，(a = b)。
+=（自加赋值） 将 b 的值添加至 a，然后将结果放回到 a 中。例如，a+ = b。
-=（自减赋值） 减去 b 的值，然后将结果放回到 a 中。例如 a- = b。
*=（自乘赋值） 用 b 乘以 a，然后将结果放回到 a 中。例如，a* = b。
/=（自除赋值） 用 b 除 a，然后将结果放回到 a 中。例如，a/ = b。
++（后增） 给 a 加 1，用 a++。例如，如果 a 的初始值是 4，则表达式 a++ 将 a 的值更改为 5。
--（后降） 从 a 中减去 1，用 a- -。例如，如果 a 的初始值是 4，则表达式 a- - 将 a 的值更改为 3。


统计和图形指南

上一页 | 下一页

JMP 统计和图形指南

欢迎使用 JMP 交互统计和图形化功能 JMP 的任务是帮助研究人员分析其数据并有所发现。JMP 提供了各种各样的统计方法和图形方法，并将这些方法组织到为数不多的交互平台中。

统计和图形指南包含以下章节：

了解 JMP 分析

JMP 统计平台

响应模型

因子模型

一般假设

基本概念

一元分析

启动平台

初始文本报表

整体平台选项

分类变量选项

连续变量选项

高级一元分析

容忍区间

预测区间

性能分析

分布拟合

二元散点图和拟合

启动平台

拟合命令

显示选项和保存命令

单因子方差分析

启动平台

单因子平台布局

分位数与箱型图

单因子方差分析与 t 检验：表与图

多重比较

非参数检验

方差齐性检验

功效的详细信息

匹配模型分析

比较环的详细资料

列联表分析

启动平台

列联表分析

对应分析

Cochran-Mantel-Haenszel 检验

简单逻辑斯蒂回归

启动平台

记名逻辑斯蒂回归

保序逻辑斯蒂回归

成对数据

简介

启动配对平台

成对 t 检验图的情况

模型拟合简介

模型设置对话框：简易实例

模型类型

响应按钮（Y、权重和频数）

模型效应按钮

宏弹出式菜单

效应属性和变换

拟合特点

其它模型对话框功能

标准最小二乘：入门

启动平台：简单实例

功能增强选项包

整体模型统计表

杠杆率图

效应详细资料

行诊断命令和保存命令汇总

统计实例

标准最小二乘：估计透视

估计值和效应筛选菜单

显示预测表达式

扩展估计值和记名项编码

尺度无关估计和连续项编码

序贯检验

定制检验

反预测

参数功效

估计值的相关性

效应筛选

标准最小二乘：探索预测方程

刻画简介

刻画器

模拟器

交互作用图

等高线刻画器

作为独立平台的刻画器

立方图

响应面曲率

Box Cox Y 变换

曲面刻画器

标准最小二乘：随机效应

随机效应主题

指定随机效应

REML 结果

矩法结果

不平衡实例

广义线性模型

广义线性模型

广义线性模型特点

广义线性模型实例

实例

平台命令

使用对数线性方差模型拟合离差效应

对数线性方差模型

JMP 中的对数线性方差模型

逐步回归

逐步回归简介

多重回归实例

所有可能的回归

具有交叉项、交互作用项或多项式项的模型

包括相关项的规则

具有记名项和保序项的模型

针对层次项的构建模型命令

逻辑斯蒂逐步回归

记名响应和保序响应的逻辑斯蒂回归

逻辑斯蒂模型简介

统计报表

平台选项

记名逻辑斯蒂模型实例：清洁剂数据

保序逻辑斯蒂实例：奶酪数据

二次保序逻辑斯蒂实例：爆玉米花盐量数据

当数据为多个列中的计数时应该怎么办

多重响应拟合

多重响应模型设置

多元检验

带重复测量的多元模型

复合多元模型

响应类型命令和效应

判别分析

非线性回归

非线性拟合过程

简单指数实例

使用模型库

迭代控制面板的详细资料

解结果的详细资料

化学动力学实例

自定义损失函数的工作原理

极大似然实例：逻辑斯蒂回归

迭代再加权最小二乘实例

含有二项误差的 Probit 模型：数值导数

Poisson 损失函数

导数说明

有关有效非线性建模的说明

脚本说明

非线性建模模板

相关性和多元技术

启动平台和选择选项

计算和统计详细资料

聚类

聚类方法简介

聚类启动对话框

层次聚类

排序与色彩图实例

K 均值聚类

自组织图

正态混合

偏最小二乘

PLS

启动平台

交叉验证

平台选项

统计详细资料

神经网络

简介

背景

神经网络实例

神经网络中的报表和图形

使用交叉验证

平台选项

判别分析

简介

判别组

命令和选项

生存和可靠性分析 I

生存分析简介

一元生存分析

竞争原因估计

生存和可靠性分析 II

参数回归生存拟合

选项与报表

比例危险模型

非线性参数生存模型

再现分析

可修理系统的再现分析

递归划分

划分图

分类响应实例

连续响应实例

平台命令

拟合优度图

交叉验证

使用 Fisher 的鸢尾花实例

统计的详细资料

时间序列分析

启动平台

时间序列命令

建模报表

ARIMA 模型

季节调整 ARIMA

平滑模型

项目响应原理

项目响应原理简介

启动平台

项目分析输出

平台命令

技术细节

条形图、线形图和饼图

条形图、线形图、针状图、点图和饼图

制图选项

平台选项

实例

叠加图

叠加图形平台

分组变量

叠加图选项

旋转图

启动平台

旋转图形

显示选项

主成分

旋转成分和因子分析

失真控制

控制曲面

曲面图

启动平台

曲面图控制面板

键盘快捷方式

等高线图

简单等高线图实例

等高线设置

平台选项

统计控制图

使用控制图的统计质量控制

控制图启动对话框

定制水平轴

显示选项

特殊原因检验

运行警告脚本

保存和检索界限

实时数据捕获

排除、隐藏和删除的样本

Shewhart 控制图

Shewhart 变量控制图

移动平均图

Shewhart 属性控制图

相

累积和控制图

累积和图

累积和图公式

变异性图

变异性图

方差成分

R&R 测量系统

判别比报表

属性度量图

石川图

准备制图数据

图表类型

互动式构建图表

基于单元格的图

简介

平行坐标图

方格图

Pareto 图

Pareto 图

启动选项

前后 Pareto 图

双因子比较 Pareto 图

每单位缺陷的分析

三元图

三元图平台

显示选项

弹簧单高跷跳实例

树图

树图

启动平台

平台选项

树图实例

统计细节

响应模型

连续因子

记名因子

保序因子

杠杆率图细节

多元详细资料

功效计算

包含置信限的反预测

随机效应详细资料

统计和图形指南


了解 JMP 分析

JMP 分析平台

本章将为您介绍 JMP 分析平台。其中提供了有关如何使用分析平台的基本导航说明，概述了软件所涵盖的统计模型，同时还介绍了一些概念的背景知识。您只需花费较少的时间来阅读本章中的内容，便可在之后的学习中做到事倍功半。

如果对统计学不熟悉，则本章将帮助您掌握开始数据分析所必需的知识。如果您已熟练掌握统计学知识并想直奔主题，则可以参阅特定的平台和分析方法章节，或者参阅附录"统计细节"，以获得有关统计方法的更详细说明。

目录

JMP 统计平台

1. 指定建模类型

2. 选择分析方法

3. 为列选择角色

响应模型

连续响应模型

记名响应模型

保序响应模型

因子模型

连续因子

记名因子

保序因子

一般假设

假定模型

相对显著性

多元推断

有效性评估

替代方法

基本概念

不确定性，一个统一概念

两个基本拟合装置


JMP 统计平台

JMP 涵盖了大量的统计方法，这些统计方法在整理归类后分为分析、试验设计和图形命令，您也可以通过“JMP 起始页”窗口访问。有关更多信息，请参阅《JMP 用户指南》。

各种统计方法被归类至不同的层次结构，而不是通过庞大的单层列表来访问。例如，您可以在“列联”平台中进行列联分析。最初，您可能需要参考本书或联机帮助来查找具体的分析方法，但随着对 JMP 统计方法的进一步熟悉，JMP 所固有的层次结构会让您觉得简单易用。我们将向您逐步介绍适用于具体数据环境的方法。许多分析结果均可自动获得，而分析报表窗口中的弹出式菜单还可以提供其它一些分析结果。

每个分析和图形命令都可以启动平台。平台是一个交互式窗口，您可以将其用于分析数据、处理图形中的点以及保存结果。平台将始终打开，除非您将其关闭。您可以同时打开任意数量的数据表，并为每个数据表启动任意数量的平台。如果有多个数据表，则启动的平台将分析当前的数据表。该表可以是活动数据表窗口，也可以是与分析报表窗口对应的表。其名称会一直显示在 JMP 窗口的工具栏中。

JMP 分析组件的导航说明很简单，但在开始前须注意设计原理的一些要点。

首先，JMP 实现了与基本概念一致的一般方法（请参阅"基本概念"）。所有平台均可针对不同情况生成多种结果。它们处理数据和统计概念的方式始终保持一致。

其次，JMP 方法属于通用方法。它们可以适应实际的情况。其主要概念是适合所有分析方法的建模类型。例如，对于具有记名值的变量和具有连续值的变量，JMP 进行自动分析的方法将不同。

第三，JMP 不用等待选项和命令。平台将同时提供几乎所有需要的内容。如果平台提供了多余的信息，您可以隐藏不需要的表格或图形。其优点在于无需四处单击鼠标按钮来寻找额外统计量对应的命令。

JMP 是一个探索工具而不是展示工具，对数据的了解越透彻将对您越有帮助。计算机的速度足以提供令人眼花缭乱的各种数据视图。在发现数据所蕴涵的意义后，您可以从中选择最能表现结果的视图。

要开始数据分析，请打开一个数据表并遵循以下三个步骤：

  • 根据需要为变量指定建模类型（"为列指定建模类型"）
  • 启动分析平台
  • 为列选择角色

1. 指定建模类型

变量的建模类型分为连续、记名或保序。您可以通过数据表窗口的列面板弹出式菜单来指定建模类型，如"为列指定建模类型" 所示，或者通过“列信息”对话框中的建模类型弹出式菜单来指定建模类型。此建模类型指定将作为一个列属性，除非您对其加以更改，并且它会在数据表关闭时与之同时保存。

为列指定建模类型

建模类型不仅仅是一些说明性标记。它们告诉每个分析平台应如何分析和绘制数据，同时规定了如何处理模型中的值。此外，建模类型处理中也存在差异，具体须取决于是响应 (Y) 变量还是因子 (X) 变量。要以不同方式研究相同的变量，则可以灵活改变建模类型。

JMP 使用以下建模类型：

连续
对于连续列，模型中将直接使用数值。对于连续因子，响应是因子的连续函数。变量通常都在连续尺度基础上测量。连续变量用期望值或均值等概念刻画。特别，连续响应都被刻画包含一个随机成分，该成分通常被视为正态分布的误差项。
保序
保序值不直接使用，而只是作为名称。保序列可以是数值列或字符列，其值可以是数字或字符。但是，JMP 会将该列解释为包含离散值，从而视为有序分类。数字将按数值升序排列，而字符则按字母顺序或指定的方式排列。
对于保序因子，随着因子移至不同的水平，响应将转变为不同的值。对于保序响应，JMP 将为有序分类构建离散 probit 模型。
记名
对于记名建模类型，值将被视为无序分类，或者作为名称。字符列始终是记名列。其值可以是字符或数字，但数字将被视为无序离散值。

2. 选择分析方法

根据要同时处理 X 和 Y 变量的方式，您可以从“JMP 起始页”窗口或者通过分析或图形菜单来启动分析平台。

以下是对分析平台的简要说明：

分布
可以通过适用于连续列的直方图、箱型图和正态图以及适用于记名和保序列的划分（马赛克）条形图来描述每个选定进行分析的列的分布情况。您也可以将计算出的分布均值及标准差与某个常数进行比较，同时检查不同分布的拟合。
以 X 拟合 Y
可以描述所指定的每对 X 和 Y 列。显示结果与报表随指定给 X 和 Y 列的建模类型（连续、记名和保序）而变化。响应与因子建模类型的四种组合产生了四种不同的分析方法：二元分析、单因子方差分析、列联表分析以及逻辑斯蒂回归。
配对
可对特殊情况加以分析：对单个对象进行多次测量，并且需要成对 t 检验或重复测量分析。
模型拟合
提供了通用拟合平台，用于以所有创建的效应拟合一个或多个 Y 列。通用拟合平台可以拟合多重回归模型、具有复杂效应的模型、响应曲面模型以及包括判别和典型分析的多元模型。杠杆率图、刻画图以及等高线图可以帮助您观察整个模型以及每个效应。专门的对话框将为您显示对比、自定义检验和功效的详细信息。“模型拟合”平台还带有特殊的效应筛选工具，如立方图、预测刻画器、等高线刻画器，以用于具有多个响应的模型。

建模用于参数为非线性的高级模型或具有相关项的模型。在某些情况下，模型的形式并不重要。

非线性
可以将响应 (Y) 拟合为所指定 x 变量和参数的非线性公式的函数。非线性用于拟合参数为非线性的模型。非线性拟合从使用公式编辑器在列中创建的公式开始。该公式包含将由非线性平台估计的参数。在启动非线性平台时，您可以通过控制面板来实现结果的拟合和标绘。
划分
可以拟合分类和回归树。
神经
可以实现简单的单层神经网络。
时间序列
可以执行简单的预测并拟合 ARIMA 模型。

多元方法可以提供多元数据分析方法，其中包括聚类分析、相关性分析、主成分分析和判别分析等工具。

多元
可以通过相关性，散点图矩阵、偏相关矩阵、逆相关矩阵、多元离群值图或折叠离群值图以及主成分分析来描述响应间的关系。您也可以显示协方差矩阵，然后查看主成分的三维旋转图。
聚类
可以使用分层、k 均值或 EM（最大期望值）方法对 JMP 表中的行分组。分层聚类方法通过聚类树图显示结果，后跟聚类之间的距离图。k 均值聚类选项适用于较大的表，可以为指定的聚类数分配点。EM 混料聚类方法用于分布混料，与 k 均值方法类似。
判别
可以在已知连续响应基础上预测分类变量（记名或保序）。判别分析可视为多元方差分析的反向预测。
PLS
可以使用偏最小二乘分析数据。

生存和可靠性可对一元或多元生存和可靠性数据进行分析。

生存/可靠性
可以使用乘积极限 (Kaplan-Meier) 生命表生产函数分析生存数据。
参数生存模型拟合
可以启动模型拟合平台的一项特点，以实现删失数据的参数拟合。
比例危险模型拟合
可以启动模型拟合平台的一项特点，以进行旨在拟合 Cox 模型的比例危险回归分析。
再现分析
可以执行再现分析。

3. 为列选择角色

您可以分析变量选择 X 或 Y 角色，具体取决于您准备让 JMP 如何处理变量。具有 Y 角色的列叫做响应变量或因变量。x 列是对响应进行拟合、预测或分组的因子变量。每个分析平台都会弹出一个启动对话框，与"指定变量角色" 中的对话框类似。

指定变量角色

变量角色包括如上所述的 X 和 Y，如果要为每一行指定权重或频数，则还将包括权重或频数。

有关数据类型、建模类型和变量角色的更多详细介绍，请参阅《JMP 用户指南》。

"在 JMP 中执行分析的三个通用步骤" 是使用 JMP 分析数据的简单流程示意图。

在 JMP 中执行分析的三个通用步骤


响应模型

JMP 中的模型及方法简单实用、应用广泛，能够满足统计软件工具中对通用方法的要求。与所有统计软件一样，您需要了解所选择模型的假设以及假设不成立将导致的后果。有关更多信息，请参阅本章中的"一般假设"。

连续响应模型

如果响应列（指定为 Y 角色的列）是连续列，那么 JMP 将直接拟合响应的值。基本模型是适用于每个观测值的模型，

Y =（X 的某些函数以及参数）+ 误差

统计检验建立在模型中的误差项呈正态分布这一假设基础上。

连续响应的拟合原理

此拟合原理称为最小二乘。最小二乘法用于估计模型中的参数，以尽可能降低误差平方和。模型拟合中的误差称为残差，是每个观测值的实际值与模型拟合的预测值之间的差值。

如果误差呈正态分布，则最小二乘法与极大似然估计方法等效。这意味着此分析方法将对提供极大似然估计的模型进行估计。对数似然是正态分布的误差平方和的尺度倍数。

基本模型

最简单的连续测量模型只对单个值拟合，以预测所有的响应值。此值即为均值的估计。而均值只是响应值的算术平均值。所有其它模型都将与此基本模型进行比较。

记名响应模型

如果响应列（指定为 Y 角色的列）具有记名建模类型，JMP 将对响应是数据值给定的不同响应水平 r 的概率进行拟合。基本模型是适用于每个观测值的模型，

所有概率估计都必须为正数。对于给定的 X 布局，所有响应水平的概率估计总和必须为 1。JMP 用于预测概率的函数由一个线性模型和一个多响应逻辑斯蒂函数组成。这在有些情况下被称为对数线性模型，因为概率比的对数为线性模型。例如，如果 Y 可以是 1 或 2，则对数线性模型表示为

记名响应的拟合原理

此拟合原理称为极大似然。它可以估计参数，以便将数据给定的所有响应的联合概率作为模型所能得到的最大概率。不同于直接输出联合概率（似然），此方法在报告似然的负对数合计值时更加方便。

不确定性（负对数似然）是概率的负对数总和，模型将这些概率当作是响应的概率，而实际上是样本数据的概率。对于大小为 n 的样本，常以 H 表示，记为

如果将每个实际发生事件的概率视作 1，那么完全拟合的负对数总和为 0。

记名模型会耗费大量的时间和内存来进行拟合，特别是在有许多响应水平的情况下。JMP 通过迭代历史记录跟踪计算过程，该历史记录显示了负对数似然值在向估计收敛过程中逐渐变小。

基本模型

最简单的记名响应模型是一组常数响应概率，拟合为整个数据表中每个响应水平的发生几率。也就是说，y 作为响应水平 j 的概率可通过将整个样本数 n 划分至每个响应水平 nj 来估计，记为

所有其它模型都将与此基本模型进行比较。此基本模型对记名响应的作用与样本均值对连续模型作用类似。

统计量可以测量模型认为不确定的部分，即

但对于分类模型，实践中 R 平方很少会接近 1。

保序响应模型

对于保序响应 (Y)，与记名响应一样，JMP 将对响应是数据值给定的不同响应水平 r 的概率进行似合。

保序数据的保序类似于连续数据。分析中将使用该保序，但不会使用排序水平间的间距。如果存在数值响应，但又希望模型忽略值的间距，那么您可以为响应列指定保序水平。如果存在分类变量且水平为某种自然保序，如低、中和高，那么您可以使用保序建模类型。有关已拟合函数的详情，请参阅"简单逻辑斯蒂回归"和"记名响应和保序响应的逻辑斯蒂回归"章。

考虑保序模型的一种方法是将响应机制假设为一个双阶段过程。x（线性模型）将首先通过连续值确定某个变量 z。但是，不会对 z 加以观察。而 z 将确定 y 在通过不同阀值时的保序响应水平。

如下所示

z =（y 的某些函数以及参数）+ 误差
y =（某些由 z 值确定的水平）

其中，误差具有逻辑斯蒂分布。

特别是当 z 通过特定阀值时，y 值也将提高保序水平。如果 y 的水平为 1 到 r，则

另一种不同的方法是从记名模型入手，此方法在数学上等效，您可以对累积概率建模而不是对单个的概率建模。不同于对最后水平外的所有水平拟合函数，您可以只拟合一个函数并使之拟合每个累积响应概率。

保序响应的拟合原理

保序响应模型的极大似然拟合原理与记名响应模型相同。它可以估计参数，以便将所有响应的联合概率作为模型所能得到的最大概率。它所使用的迭代方法比记名拟合更快且占用更少的内存。

基本模型

与记名响应一样，最简单的保序响应模型是一组响应概率，拟合为整个数据表中响应的发生几率。


因子模型

模型中有关因子的主要问题是以何种方式对 x 变量（因子）建模以预测期望值或概率。

在预测方程中，因子可作为 x 值的线性组合以及要估计的参数。在连续响应模型中，i 表示观测值，j 表示参数，典型观测值 [image] 的假定模型表示为

其中
为响应
为数据函数
为无法观测的随机误差
为要估计的未知参数

每种建模类型根据分子项在线性模型中形成 x 的方法均不相同。线性模型 x 也可以是复杂效应，如交互效应或嵌套效应。稍后将详细介绍复杂效应。

连续因子

如果 x 为连续变量，其值将直接用于预测公式。x 变量被称为回归量或协变量。

记名因子

如果 x 变量具有记名建模类型，则响应可以有单独的预测系数，用于与它的每个水平拟合。您可以对预测系数建模，以表示每个水平与所有记名值的平均响应之间的差异。

在线性模型环境中，除最后一个水平外的每个记名水平都有一个指标变量。在出现最后一个记名水平时，指标变量将被设定为 -1。这将导致所有的指标变量都被设定为 -1，使所有水平的参数总和等于 0。

例如，假设记名因子 A 有三个水平 1、2 和 3，而您要将其作为线性模型拟合。此模型有截距和两个参数，如果 A 的水平为 1 或 2，则两个参数表示了要与截距相加的一个值。对于 A 的最后一个水平，您可以从截距减去两个 A 参数来获得预测值，

其中
为截距参数
和 [image] 为 A 记名效应的参数
在 [image] 时为 1， [image] 时为 0，时为 -1
在 [image] 时为 0， [image] 时为 1，时为 -1

因此，对于如下所示的“参数估计”报表，报表右侧的方程式是所拟合的 Y 的预测公式：

其中， [image] 时的值 4.4 是其它两个值 -2.6 与 -1.8 之和的相反数。这只是借助模型来将三个均值与三个组拟合的方法之一。

保序因子

如果为 x 变量指定了保序建模类型，其最小值将被视作一个基线值，而基线之上的每个水平都贡献了一个用于确定响应的附加量。

在线性模型环境中，除第一个水平外的每个因子水平都有一个指标变量。等于或小于当前因子水平的指标变量的所有指标变量都将被设定为 1。

注：如果在检验查看时没有效应，对于简单模型，记名因子和保序因子没有太大的差异。但如果指定了交互，则会产生较大的差异。有关复杂保序因子的介绍，请参阅附录"统计细节"。我们建议您在大多数模型中使用记名因子，而不要使用保序因子。


一般假设

在开始信任统计学之前，您需要再次确保自己已明白所用技术的价值和局限。统计方法只是一些工具 — 它并不能确保您避免所有的错误科学（无效的统计假设）或不良数据。

假定模型

统计方法大都建立在假设模型正确的基础上。您可以假设方程式的确能够根据正态分布随机误差来确定响应。在模型可能出现错误的情况下，您必须降低模型生成的统计报表的可信度。

相对显著性

许多统计检验不会从绝对意义上对模型进行评估。显著检验统计方法只会说明某个模型能比其它简化模型（如均值）拟合得更好。模型看上去会拟合数据，但可能根本就不会描述底层的物理模型。

多元推断

统计结果的值通常并不是您想像的那样，但它们的确为某些探索提供了方法。要确认探索结果，您可能还需要作进一步的研究。否则，您可能只是在数据中走马观花而已。

例如，如果进行了充分的分析，您可以独自在百分之五的研究中偶然发现 5% 的显著效应，即使因子没有预测值。同样，在使用数据制作模型的情况下（而不是检验数据的正确模型），您将在报表中破坏显著性水平。随机误差随后会影响您的模型选择，并让您自认为模型比实际上要好。

有效性评估

下面的一些技术和模式可用于评估模型有效性：

  • 通过“失拟合”检验根据饱和因子检查模型有效性。如果具有重复的非饱和 x 数据，则“模型拟合”平台将自动显示这些检验。
  • 通过查看“模型拟合”平台中的残差及被学生氏化残差图，您可以检查连续响应的分布假设。或者，您也可以使用平台弹出式菜单中的保存命令在数据表列中保存残差。然后对这些列使用分析 > 分布，以查看包含正态曲线和正态分位数图的直方图。残差并非完全独立，但您可以大致确定严格意义上的非正态分布。
  • 杠杆率图是适用于连续响应的最佳综合诊断工具，因为它可以显示每个假设检验中每个点的影响。如果怀疑数据中存在错误值，此图形可帮助您确定单个点是否会严重影响统计检验。杠杆率图将在"标准最小二乘：入门"章节中介绍。
  • 寻找数据中的离群值并对它们加以检查是一种很好的方法，这样可以确定它们是否为有效观测值。您可以在“分布”平台报表和图形中寻找一元离群值。二元离群值通常出现在“以 X 拟合 Y”散点图和多元散点图矩阵中。您可以在图形 > 旋转图命令生成的三维旋转图中查看三元离群值。更高维数的离群值可通过旋转图或多元平台生成的“主成分”以及在“多元”平台中计算和绘制的 Mahalanobis 距离和折叠距离来查找。

替代方法

统计书本介绍了一些特殊的非参数和稳健方法，而 JMP 目前仅实现了其中的一部分。这些方法要求更少的分布假设（非参数），从而其抗污染的能力更强（稳健）。但是，它们对一般方法无太大用处，统计检验中的小样本概率计算很费时。

如果对线性秩检验感兴趣，则只需要正态大样本显著性近似值，您便可以对数据的秩进行分析，以执行 Wilcoxon 秩和或 Kruskal-Wallis 等效的单因子检验。

如果不确定连续响应完全满足正态假设，您可以将建模类型从连续类型更改为保序类型，然后再进行实际分析。即使这样，此方法仍会在展示的丰富性以及统计功能方面带来某些损失。


基本概念

两个基本概念促成了经典统计学的统一，它们将统计性质和拟合原理融合为了可视化形式：

  • 不确定性，一个统一概念
  • 两个基本拟合装置

这两种思想以基于数理统计的直观概念来帮助启发对统计学的理解。

统计学对科学的重要性好比会计学在商业中所扮演的角色。它是权衡与平衡观测证据的技术。统计检验如同信用审核。但统计工具能做的还远不止于此。它们是探索工具，能够展示令人意想不到的数据性质，并由此带来有趣的新思想。在使用这些强大的工具之前，您需要首先大致了解它们的工作原理。

不确定性，一个统一概念

在财务计算过程中，您需要计算资金总额。在关注涉及不确定性或噪声的科学观测值时，您需要某些统计测量方法来汇总数据。与资金可以累计一样，如果选择了正确的测量方法，不确定性也是可以累计的。

最佳测量方法并非直接概率，因为要知道联合概率，您必须假设观测值是独立的，同时应将概率相乘而不是相加。对每个概率取对数较为容易，因为然后您可以将它们相加，而合计值即为联合概率的对数。

但是，因为是 0 和 1 之间数值的对数，所以概率对数为负。为保持数值为正，JMP 使用了概率的负对数。随着概率越来越小，其负对数将越来越大。这种测度称为不确定性，由概率以反向方式测量。

在商业中，您要在成本最小的前提下实现收益最大化。在科学研究中，您要实现不确定性的最小化。科学研究中的不确定性所扮演的角色与成本在商业中的角色相同。所有的统计方法均可以拟合不确定性最小化的模型。

实现不确定性的可视化并不难。就像连续抛掷硬币，每一次抛掷都是独立的。正面的抛掷概率为 0.5，基数 2 对数的 [image] 为 2。连续抛掷 h 次正面的概率可以简单表示为

求 h 得到

您可以将某些事件的不确定性看成获得相等次数而必须连续抛掷正面的次数。

总而言之，我们在统计研究中所做的任何事都具有不确定性 [image] 。统计书本将不确定性称为负对数似然。

两个基本拟合装置

统计拟合存在一个令人惊奇的事实：大多数典型方法均可归结为使用了两个简单装置，即弹簧和汽缸。

弹簧

首先，弹簧是用于连续响应模型的拟合装置 (Farebrother,1987)。假设有 n 个点，您需要知道这些点的期望值（均值）。不妨设想一下将这些点分布在某个尺度上，然后用弹簧将它们连接至一个公共接头（请参阅"将弹簧连接至数据点"）。当您释放时，弹簧将上下扭动接头点并随后停在均值位置。这在物理学上是一种必然的结果。

如果数据呈正态分布，并且其均值位于弹簧连接的接头点位置，则每个点位置处弹簧的物理能量与数据点的不确定性成比例。要计算弹簧的能量（不确定性），您只需要计算每个点到均值距离的平方和。

要选择一个估计来表明观测数据的最小不确定性，则可以选择弹簧稳定点作为均值估计。该点表示了拉伸弹簧所需最小能量，与最小二乘拟合等效。

将弹簧连接至数据点

这便是您拟合一个或多个均值的方法，也是您似合线条、平面或超平面的方法。此外，它也是将几乎任何模型与连续数据拟合的方法。要通过距离平方和来测量能量或不确定性，您必须拉伸弹簧。

统计学家之所以信任正态分布，是因为它对可信性的要求最低。在某种意义上说，也就是随机性最强。它是一种无信息的分布。此类分布能提供给定方差的最如所期待的不确定性，而其不确定性可通过平方距离测量。在许多情况下，如果有混合分布或独立变量汇总，则此分布为约束分布。此分布可以检验统计量，而统计量的测量过程非常简单。

如果拟合受假设约束，您同样可以通过测量弹簧能量来检验假设。假设某项试验提供了源于四种不同处理方法的响应，而您需要检验均值是否存在显著差异。首先，设想将数据按组标绘为如下所示的图形，但每次处理都将弹簧连接到独立的均值。然后施加与弹力反向的压力，将单个均值迅速移至一般均值。将均值控制在相同水平的能量值即为所需的检验统计量。此能量是假设的 F 检验的主要成分，而该假设用于检验均值是否相同。

汽缸

究竟响应是分类类型还是连续类型呢？例如，假设响应是某款小汽车的原产国。样本中提供了三个响应水平：American、European 和 Japanese 的概率。您可以将三个原产国的概率设定为某个估计，然后再评估数据中的不确定性。通过对数据给定的响应概率的负对数求和，您可以找出该不确定性。记为

弹簧理论阐述了如何以均值拟合连续数据。如果响应为分类响应，则统计方法将直接估计响应概率，同时选择可使数据不确定性最小化的估计。概率估计不能为负，且其总和应等于 1。您可以将响应概率作为组成部分绘制在总长度为 1 的尺度上。对于每个响应观测值，请将其输入响应区，如气缸、轮胎气泵。保持响应水平间的划分不断变化，直至达到最低势能平衡。最后得到的划分大小即可估计响应概率。

"划分汽缸效应" 显示了单个类型的情况，如 medium 尺寸汽车的情况（请参阅"分类数据的马赛克图" 中根据汽车民意测验.jmp 标记为 medium 的马赛克列）。假设有 13 个响应（汽车）。第一个水平 (American) 有 6 个响应，第二个水平有 2 个响应，而最后一个响应有 5 个响应。则响应概率分别为 6/13、2/13 和 5/13，如同响应划分的压力达到平衡使整个能量达到最小的情况。

划分汽缸效应

与连续数据的弹簧相同，您可以按某个因子来划分样本并拟合单个划分。然后测量需要多少额外能量可使划分相同，从而检验组间的响应率是否相同。想像一下按汽车尺寸分组的汽车原产地概率的汽缸图。使每个组中的划分水平排列所需的能量可以检验变量是否具有相同的概率。"分类数据的马赛克图" 显示了这些划分。

分类数据的马赛克图


一元分析

分布平台

分布平台使用直方图和其它图形及文本报表描述数据表各列值的分布情况。

对于分类（记名/保序建模类型）变量：

  • 图形显示可包含直方图和分开式（马赛克）条形图。直方图显示每个水平的保序变量或记名变量的条形柱。
  • 文本报表显示计数、比例、累积比例和卡方检验。

对于数值连续变量：

  • 图形显示以直方图和离群值箱型图开始。直方图为连续变量的分组值显示一个条形柱。您还可以要求显示分位数箱型图、正态分位数图、茎叶图和叠加的非参数平滑曲线。
  • 文本报表将显示选定的分位数和矩。相关选项让您可以将秩、概率得分和正态分位数值另存为数据表中的新列。可选命令根据您指定的常数，检验列的均值和标准差，检验您所指定各种分布的拟合，并且还可以完成质量控制中的性能分析。

目录

启动平台

调整图形大小

调整连续列直方图条形柱

高亮度显示条形柱并选择行

初始文本报表

分类变量的频数表

连续变量的分位数表

连续变量的矩表

整体平台选项

分类变量选项

显示

直方图选项

马赛克图

检验概率：检验概率表

置信区间：得分置信区间表

保存

连续变量选项

显示

直方图

正态分位数图

离群值箱型图

分位数箱型图

茎叶图

CDF 图

检验均值

检验标准差

置信区间

保存


启动平台

首先，从分析菜单（或工具栏）中选择分布，或者单击 JMP 起始页窗口的基本统计量选项卡中的分布。

在出现“启动”对话框后，如"启动对话框" 中所示，分配一个或多个数值或字符列进行分布分析。对于需要分析的变量，在列选择器列表中选择变量，并单击相应的角色按钮，或者将变量拖至对话框右边的角色框中。

启动对话框

在您单击确定时，分布命令启动一个平台，显示在 Y，列列表中输入的每一个变量的图形说明和相应报表。如"分布平台" 所示为典型的分布分析结果。

每个被分析的列对应有直方图，并带有以不同方式显示分布的图和表。报表标题上的弹出式图标提供了适用于变量的建模类型的命令。在直方图标题栏中，

  • 每个连续型列名旁边的弹出式图标使您可以对任意值检验样本均值和标准差、拟合各种分布、执行性能分析、选择图形和显示选项，并保存直方图的信息。
  • 每个分类型列名旁边的弹出式图标让您可以选择显示选项、检验概率，并保存有关直方图水平的信息。

    您在对话框中添加频数变量时，就会在矩表 (N) 中出现的总体计数中将该变量相加，从而影响输出。因此，频数变量还会影响所有其它的矩统计量（均值、标准差等等）。

    如果您添加变量作为权重，则不会影响总数。在报表的更多的矩部分中将显示权重和。因此，基于权重和的任何矩量都会受到影响。特别是均值、均值标准误差以及置信区间的上限和下限都会受到权重的影响。

    如果您用于频数或权重的变量不是整数，那么权重和的结果将不同，这是因为指定作为频数的列，所有值均被截为整数。
分布平台

调整图形大小

您可以在任何分析或图形平台上调整图框架的大小。要调整图形或图的大小，可将光标移到图框右边、底边或右下角。当光标变为双箭头时，您可以拖动图框以调整大小。直方图与伴随图表或图的高度将始终作为一个整体进行调整，但是，所有图的宽度可以分别调整。

  • 按住 Control 键（在 Mac 中为 Command 键）一起调整所有图形的大小。
  • 使用 Alt（或 Option）键以 8 个像素的增量调整大小。
  • 使用 Shift 键可以保持纵横比来调整图框的大小。

调整连续列直方图条形柱

要调整直方图的条形柱，请从图形光标工具栏中选择抓手（手形）工具，并且在直方图图框中的任意位置定位光标。按住鼠标按钮并移动鼠标。如果将每一个条形柱视为存放许多观测值的柱体，向左移动手形图标将增加柱体的宽度并合并区间。此时，由于增加了条柱的大小，因此条柱的数量将减少。向右移动手形图标将减少柱体宽度，可以产生更多的条形柱（请参阅"更改直方图条形柱"）。上下移动手形图标来移动柱体在轴上所处的位置，可以改变每个柱体的内容和大小。

注：要重新调整任何连续直方图的轴，请双击轴并且填写“轴规格”对话框。

更改直方图条形柱

高亮度显示条形柱并选择行

使用箭头光标单击任何直方图条形柱，将会高亮度显示条形柱，同时数据表中对应的行会处于选中状态，其它所有图形相应部分也会高亮度显示。"高亮度显示观测值" 显示了在身高直方图中高亮度显示一个条形柱的效果。数据表中对应的行被选定。按住 Control 键并单击（Macintosh 系统中按住 command(命令) 键并单击）撤消选择直方图条形柱。

高亮度显示观测值

选择直方图中的子集

Alt 键（Option 键）可用于通过多个直方图进行选择。换句话说，您可以在一个直方图中选择条形柱，然后使用 Alt 键在另一个直方图中单击，以便进一步使用另一个变量值的来指定选择。

例如，假设您要选择小型和中型制药 (pharmaceut) 公司。使用样本数据表公司.jmp，产生所列出的公司类型（类型）和规模（公司大小）直方图。在公司大小直方图中，请单击“small”条形柱，然后按 Shift 键并单击“medium”条形柱。此时，所有小型和中型公司均被选定。要仅选择制药公司，请按 Alt (Option) 键并单击类型直方图中的“制药 (pharmaceut) ”条形柱。选择对象缩小为只包含制药 (pharmaceut) 公司。

使用 Alt 键进行选择


初始文本报表

下面介绍与您所选择分布分析对应的自动报表（除非其它首选项已生效）。

分类变量的频数表

频数表列出了记名或保序响应变量每个水平的以下信息。分析中忽略了缺失值：

水平
列出了响应变量每个值。
计数
列出了响应变量每个水平的行数。
概率
列出了响应变量每个水平的发生概率（或比例）。概率是由计数除以变量的总频数计算而得，显示在表的底部。
标准差概率
列出了概率的标准误差。上面的实例中隐藏了此列。使用鼠标右键单击（在 Mac 中按 Control 键并单击）表，然后从列子菜单中选择标准误差概率以撤消隐藏此列。
累积概率
列出了概率列的累积总和。上面的实例中此列也是隐藏的。

连续变量的分位数表

分位数表列出了选定分位数（有时称为百分位数）的值。它是分位数箱型图中可以独立显示或隐藏的文本表。有关分位数箱型图的介绍，请参阅"连续变量选项"。

计算分位数的方法如下：

要计算列中 N 个非缺失值的第 p 个分位数，按升序排列 N 个值，并且将这些列值称为 y 1、y 2、...y N。使用公式 p / 100(N + 1) 计算第 p 个分位数的秩数。

如果结果是整数，第 p 个分位数就是秩对应的值。

如果结果不是整数，则利用插值找到第 p 个分位数。第 p 个分位数记为 q p，公式是

q p = (1 - f)y i + (f)yi+1

其中

n 表示变量的非缺失值数

y 1, y 2, ..., y n 表示有序的变量值

可以将 yn+1 当成 y n

np=i + f

i 表示 np 的整数部分，f 表示小数部分。

(n + 1)p = i + f

例如，假设数据表有 15 行，并且您要找到连续列的 75% 和 90% 分位数的值。在按升序排列列之后，包含这些分位数秩的计算方式是

且

值 y 12 是 75% 分位数。

按照 y 90 = 0.6y 14 + 0.4y 15 的方法计算第 14 和 15 个秩值的加权平均值，为 90% 分位数。

连续变量的矩表

“矩”表显示了均值、标准差及其它统计量。如果样本为正态分布，则将围绕样本均值（算术平均值）对称排列数据值。

矩表显示以下统计量：

均值
估计响应变量相应分布的期望值。它是列值的算术平均。它等于非缺失值的总和除以非缺失值的数量。如果数据表中有指定为权重角色的列，则将每个列值乘以它对应的权重，并求和，再除以权重的总和，即得到均值。
标准差
刻画围绕均值的分布情况。它一般表示为 s，等于样本方差（表示为 s 2）的平方根。
正态分布主要由均值和标准差给出。随着样本变大，这些参数提供了一种简单的方式来总览数据：
68% 的值分布在均值的一个标准差范围内。
95% 的值分布在均值的两个标准差范围内。
99% 以上的值分布在均值的三个标准差范围内。
标准误差均值
均值的标准误差估计了均值估计量分布的标准差。将样本标准差 s 除以 N 的平方根，来计算标准误差均值。如果谋列分配了权重角色，分母是 [image] 的平方根。在对均值进行 t 检验和构建均值的置信区间时将使用该统计量。如果未指定权重列，对于所有的 i，w i = 1 并且 [image] ，
95% 均值上限和 95% 均值下限
是均值的 95% 置信区间。它们定义了很有可能包含真正总体均值的区间。即如果从相同的总体中抽取了很多随机样本，并为每一个总体均值都确定了 95% 置信区间，则包含真正总体均值的区间在 95%。
数目
指非缺失值的总数，被用于在未给列分配权重权重角色时计算矩表中的统计量。

请您注意，可从平台的显示选项中选择更多矩量给出以下统计量。

权重和
是指定为权重角色的列的列和，并且用在分母中计算均值，以代替 N。
总和
响应值的总和。
方差
（样本方差）样本标准差的平方。
偏度
度量片面性或对称性。它为基于均值的第三个矩，计算方式是
，其中 [image] 和 w i 是一个权重项（对于相等的加权项 = 1）
峰度
度量尾部的峰度或粗度。它为基于均值的第四个矩，计算方式是
，其中 [image] 和 w i 是一个权重项（对于相等的加权项 = 1）
变异系数
变异的百分比系数。它可通过将标准差除以均值再乘以 100 计算而得。


整体平台选项

每个统计平台都在平台名称旁边的最远外框层中都有一个弹出式菜单。此菜单中的选项和命令将影响平台上的所有文本报表和图形。

“分布”平台的整体平台选项包含以下内容：

均匀刻度
使用相同的最小值、最大值及区间来调整所有轴，以便轻松比较分布情况。选定时，此选项可作用于所有响应变量的报表。
堆叠
让您可以确定报表窗口中的所有输出是以横向还是纵向堆叠。
脚本
让您可以再次运行或保存产生平台结果的 JSL 脚本。如果脚本保存到文件，您可对其进行编辑；如果与当前的数据表保存在一起，则可在您下次打开表时运行。如果没有 By-Group，保存所有对象的脚本生成的 JSL 与将脚本保存至脚本窗口生成的相同。在含有 By-Group 时，脚本包含确定 By-Group 级别的 JSL Where 子句。
数据表窗口
提供了基础数据表的视图，在含有 By-Group 时尤为有用。


分类变量选项

“分布”报表的所有部分都是可选的。报表顶部的变量名称旁边的弹出式菜单列出了适用于变量建模类型的选项。这里所示的弹出式菜单列出了分类（记名/保序）变量的命令和选项。随后部分将介绍这些选项。

显示

显示选项命令可以用来显示或隐藏频数表（在"分类变量的频数表"中有介绍）并将直方图从垂直条形图更改为水平条形图。

频数
可切换显示频数表。
水平布局
更改直方图的方向和文本报表的相对位置。

直方图选项

连续变量的直方图将值分组成条形柱，以说明列分布的形状。记名和保序变量的直方图是每个变量值（水平）均有一个条形柱的条形图。直方图选项具有包含以下功能项的子菜单：

直方图
显示或隐藏直方图。
垂直
将直方图（仅限于直方图，不包括周围的报表）从横向改为纵向。
标准误差条
使用合并或成比例的标准误差 [image] （其中 p i=n i/n）来绘制直方图每个水平的标准误差栏。当您使用手形工具调整条形柱数时，标准误差栏将自动调整。
计数轴
添加一个轴，显示直方图条形柱表示的列值的频数。
概率轴
添加一个轴，显示直方图条形柱表示的列值的比例。
密度轴
密度是指直方图条形柱的长度。计数和概率值都基于以下公式
 概率 =（条形柱宽度）*密度
 计数 =（条形柱的宽度）*密度*（总计数）
显示百分比
标记每个直方图条形柱表示的列值的比例。
显示计数
标记每个直方图条形柱表示的列值的频数。

所有这些选项生效时如下图所示。

在查看通过拟合分布选项添加的密度曲线时，密度轴对于连续分布尤为有用。它帮助显示曲线的点估计。

您可以将这些轴的任何组合添加至分类或连续直方图中。

注：在您使用手形工具更改条形柱的长度时，“计数”和“概率”轴也会变化，但是密度轴保持不变。

马赛克图

马赛克图命令可用于显示每个记名或保序响应变量的马赛克条形图。马赛克图是一种堆叠的条形图，其中的每一个段与其组的频数计数成比例。如"马赛克图" 所示为记名变量年龄的马赛克图。

马赛克图

检验概率：检验概率表

选择检验概率选项将显示对话框，此对话框让您输入假设的概率，如下图所示。对话框上的单选按钮让您可以选择重新调整假设值的尺度，以将其（假设值）相加为一个值，或者选择使用您输入的值（省略重新调整尺度）。如果刚好有两个水平，您可以在确切的二项检验或者卡方检验的两个不同方向之间选择。单击完成，将为那些概率计算似然比和 Pearson 卡方检验，并为二项检验计算准确的概率。

检验概率标记您输入的假设值的尺度，使得其概率和为 1。因此，检验所有概率相等的最简单方式就是在每一个字段中输入 1。如果您要检验概率的子集，请将不相关的水平留为空白。然后 JMP 将替代估计的概率。

置信区间：得分置信区间表

选择置信区间选项将生成类似于下表的“得分置信区间”表。由于得分置信区间往往有更好的覆盖概率 (1 - α)，尤其对于较小的样本（Agresti 和 Coul 1998），因此建议使用得分置信区间。

保存

保存选项允许您将报表相关信息另存为数据表中的列：

水平数
在数据表中创建一个名称为 Level colname 的新列。每个观测值的水平数对应于包含该观测值的直方图条形柱。直方图条形柱的编号是自 1 开始且按由低到高的顺序排列的。
将脚本存入日志窗口
显示一个日志窗口，其中包含用以生成与您所生成的报表相同的报表的脚本命令。例如，以使用直方图和马赛克图选项显示的变量性别为例，将脚本存入记录显示包含 JSL 脚本命令的脚本：
 Distribution(Column(sex),Mosaic Plot, Histogram)


连续变量选项

连续变量选项的功能分为以下几大类（见"连续变量的命令和子命令菜单"）：

  • 直方图选项和影响报表和图表显示的选项，以及请求完成其它图的命令
  • 执行统计检验和性能分析的命令
  • 分布拟合命令
连续变量的命令和子命令菜单

下面介绍"连续变量的命令和子命令菜单" 中的各命令。

显示

显示选项显示选项命令提供了以下子命令，其中包含本章开头"初始文本报表"所介绍的概念。

分位数
显示或隐藏“分位数”表。
矩
显示或隐藏“矩”表，表中提供了均值、标准差、均值的标准误差、均值的 95% 置信上限和下限及样本大小。
更多的矩
通过添加总和、方差、偏度、峰度和变异系数，扩展矩表。
水平布局
切换执行。
  • 水平布局在文本报表对应的图形右侧排列文本报表，并且显示横向条形图作为直方图和
  • 将文本报表垂直排列到其对应的图形下方并将直方图显示为垂直的条形图。

直方图

（请参阅本章前面"分类变量选项"的介绍）。

正态分位数图

正态分位数图选项用于在报表中添加图形，从而使正态分布变量的范围形象化。如果变量是正态的，正态分位数图接近对角线。这种图也称为分位数- 分位数图或 Q-Q 图。

正态分位数图还显示 Lilliefor 置信界限、参考线和图中说明的概率尺度 (Conover 1980)，如此处所示。

正态分位数图的 y 轴显示列值，x 轴显示每个值期望的正态得分。如"正态分位数图比较" 所示为从四个不同的分布中生产的 400 个点所绘制的正态分位数图：

  • 标题为正态的图是正态分布对应的正态四分位数图，表现出明显的对角线模态。
  • 第二个实例为均匀分布，该分布产生 S 形分位数图。非常尖的分布产生倒 S 形分位数图（未在此处显示）。
  • 使正态分布平直会生成一个向右倾斜的新分布模式。这就会产生凹陷的正态分位数图，标记为方形正态。
  • 向左倾斜的分布产生凸起的图案，它与标记为方形正态的实例中显示的图案类似。

此处未显示的另外一种图案是阶梯图案，它表示已经舍入或有离散值的数据。

正态分位数图比较

正态分位数值通过以下公式进行计算

其中 Φ 为正态分布的累积概率分布函数，r i 指第 i 个观测值的秩，而 N 指非缺失观测值的数量。这些正态得分是 Van Der Waerden 近似正态分布期望的顺序统计量。

离群值箱型图

离群值箱型图是一种示意图，让您可以看到样本分布情况，并找出包含极值（有时称为离群值）的点。箱型图显示连续分布指定的分位数。

箱型图的两端分别为 25% 和 75% 分位数，也称为四分位数。四分位数之间的差即四分位数间距。箱型图中间的横线确定了样本值的中位数，均值菱形指明了样本均值和 95% 置信区间。

离群值箱型图命令用以构建带虚线的箱型图，该虚线有时称为须，它从每个端点延伸，再从两端向外延伸（请参阅"离群值箱型图"）。这些须从箱的两端向外延伸，一直到达位于通过以下公式计算得出的距离内的最远数据点：

 上四分位数 + 1.5*(四分位间距)
 下四分位数 + 1.5*(四分位间距)。

箱型图边上的括号表示最短半集，其中包含最密集的 50% 的观测值（Rousseuw 和 Leroy 1987）。

离群值箱型图

使用鼠标右键单击箱型图将显示一个菜单，让您可以打开和关闭均值置信菱形和最短半集括号。

分位数箱型图

分位数箱型图有时可以显示响应轴上附加的分位数（90%，95% 或 99% 分位数）。如果是正态分布，则箱型图中显示的分位数彼此间的距离几乎相等。这使您一眼可以看出分布是否为正态分布。例如，如果分位数标志紧密地聚集在一端，而另一端的间距更宽，则分布向间距更宽的一端倾斜，如"分位数箱型图和分位数表" 所示。

请注意，分位数箱型图不同于 Tukey 分位数箱型图。分位数值将分布分为两组，其中第 p 个分位数大于 p% 的观察值。例如，一半数据低于 50% 分位数（中位数），一半数据大于或等于 50% 分位数。

分位数箱型图和分位数表

"正态分布中分位数的间距"列出了正态 (0,1) 分布的分位数间距。双尾的外部区域大约相当于同等的正态分位数间距，它的计算公式是 2*（1 - 概率）。

警告：由于分布尾部两个末端的分位数估计非常容易发生变化，因此除非样本很大，正态数据可能没有相等的间距。

正态分布中分位数的间距
概率 | 正态分位数 | 1 正态分位数/0.674 | 外部区域（双尾）
0.5 | 0 | 0 | 1.0 |
0.75 | a0.674 | 1 | 0.5 | 一半数据在箱型图中，另一半在其外
0.90 | 1.282 | 1.9 | 0.2 | 80% 介于第一对标记之间
0.975 | 1.960 | 2.9 | 0.05 | 95% 介于第二对标记之间。
0.995 | 2.576 | 3.8 | 0.01 | 99% 介于第三对标记之间。

1 对于正态分布，选定分位数的间距大体相等。

茎叶图

茎叶图命令用于构建直方图中变异的图。在计算机尚未普及的年代，为标记数据，茎叶图应运而生。

图的每一行有一个茎值，它是一组列值中重要的数字。叶值产生于该值的下一个数值。您可以检查图底部的图例，将茎和叶相连，重新构建数据值。茎叶图自动响应单击和笔刷工具。

CDF 图

CDF 图命令使用观测值（如果指定了权重或频数，则包含权重或频数）来构成累积分布函数阶梯图。

CDF 图与密度曲线相关。对于曲线上的一点 x i，CDF 图上的 F(x i) 被定义成密度函数的 x i 的积分。CDF 图估计密度曲线下面的区域面积最大为 x i。

检验均值

检验均值命令将提示您输入与样本均值相比较的统计量的检验值。如果您输入标准差的值，则计算 z 检验，否则样本标准差用于计算 t 统计量。您可以根据需要进行非参数 Wilcoxon 符号秩检验。单击确定后，“检验均值”表将附加至此变量报表的底部。

您可以重复使用检验均值命令来检验不同值。您每次检验均值时，文本报表中将会加上一个新的检验均值表。

检验均值命令会计算以下统计量：

t 检验
（或 z 检验）列出检验统计量的值以及双边和单边统计量的 p 值。该检验假定分布是正态的。
符号秩
列出 Wilcoxon 符号秩统计量的值，接着列出双边和单边统计量的 p 值。检验只假定分布是对称分布。Wilcoxon 符号秩检验使用打结的平均秩。如果 [image] ，则 p 值是准确的，其中 n 是不等于假设值的值的数量。如果 n > 20，则使用 Iman 和 Conover (1978) 给出的学生氏 t 近似值。

“检验均值”表提供的概率值定义为：

p 值 > |t|
指在样本均值与假设值相同时，只因偶然因素获得更大的绝对 t 值的概率。这是双尾 t 检验的观测显著性的 p 值。
p 值 > t
指在样本均值与假设值相同时，只因偶然因素获得比计算的样本 t 比率更大的 t 值的概率。这是单尾 t 检验的观测显著性的 p 值。该概率值是 p 值 > |t| 的一半。
p 值 < t
指在样本均值与假设值相同时，只因偶然因素获得比计算的样本 t 比率更小的 t 值的概率。这是单尾 t 检验的观测显著性的 p 值。该概率值为 1 - p 值 > t。

检验标准差

检验标准差命令将提示您输入与样本标准差相比较的统计量的检验值详情请见（Neter、 Wasserman 和 Kutner 1990）。单击确定后，“检验标准差”表将附加至此变量报表的底部。

您可以重复使用检验标准差命令来检验不同值。您每次检验标准差时，文本报表将会加上一个新表。

服从自由度为 n - 1 的卡方变量分布。我们需要使用与置信级别相关的临界值来计算对应的置信限

检验标准差表给出计算的卡方统计量，该统计量检验假设的标准差是否与计算的样本标准差相同，检验标准差表也给出与该卡方值相关的概率：

最小 p 值
指在样本标准差与假设值相同时，只因偶然因素获得更大的绝对卡方值的概率。它是双尾检验的观测显著性的 p 值。
p 值 > 卡方
指在样本标准差与假设值相同时，只因偶然因素获得比计算的样本卡方值更大的卡方值的概率。这是单尾 t 检验的观测显著性的 p 值。该概率值是 p 值 > |卡方| 的一半。
p 值 < 卡方
指在样本标准差与假设值相同时，只因偶然因素获得比计算的样本卡方值更小的卡方值的概率。这是单尾 t 检验的观测显著性的 p 值。此概率值为 1 - p 值 > 卡方。

置信区间

置信区间选项显示一个弹出框，让您选择一个水平 α，同时还有一个选项用于选择单边或双边置信区间。

JMP 将置信区间表附加至报表的末尾，显示内容包括均值和标准差参数估计以及 1 - α 置信区间的上限和下限。

在置信区间对话框中给出已知的 Sigma，将根据 z 值而不是 t 值计算有关均值的置信区间，

其中 [image] 是标准化的正态分位数。

保存

您可以使用保存菜单命令来保存连续响应变量计算出来的信息。每一个命令将在当前的数据表中产生一个新列，该列通过将响应列名附加至保存的统计量名称来命名。

注：您可以反复选择保存命令。这使您可以在不同的情况下多次保存相同的统计量，例如在组合直方图条形柱之前和之后保存。如果您多次使用保存命令，统计的列名将按名称 1，名称 2 等依次编号来产生唯一的列名。

保存命令包含如下内容：

水平数
创建一个名为 Level colname 的新列。每个观测值的水平数对应于包含该观测值的直方图条形柱。直方图条形柱的编号是自 1 开始且按由低到高的顺序排列的。
水平中间点
创建一个名为 Midpoint colname 的新列。每个观测的中间点值的计算方法是将一半的水平宽度与水平限的下限相加。
秩
创建名为 Ranked colname 的新列，其中包含以 1 开头的每个对应列值的序号。重复响应值是按其在电子表格中的出现顺序排列的指定连续秩。
秩平均
创建一个名为 RankAvgd colname 的新列。如果值唯一，则平均秩与秩相同。如果值出现 k 次，则平均秩可通过将值的秩总和除以 k 计算而得。
概率得分
创建一个名为 Prob colname 的新列。如果有 N 个非缺失得分，则将值的平均秩除以 N + 1，计算出该值的概率得分。该列类似于经验累积分布函数。
正态分位数
创建一个名称为正态分位数列名的新列。正态分位数值的计算公式如下：
其中 [image] 指正态分布的累积概率分布函数，r i 指第 i 个观测值的秩，而 N 指非缺失观测值的数量。这些正态得分是 Van Der Waerden 近似正态分布期望的顺序统计量。正态分位数值可通过由秩平均命令创建的列中的 JMP 函数正态分位数计算而得。例如，名为高度的列的正态分位数值的计算公式是：
已标准化
创建一个名为 Std colname 的新列。您可以通过公式编辑器使用以下公式来创建数值列的标准化值。
规格限
将应用于性能分析的规格限存储在当前数据表中，并且在您重复执行性能分析时自动更新和显示这些规格限。


高级一元分析

性能分析和拟合分布

本章对“分布”平台作了进一步说明，其中包括高级选项。

  • 性能分析用于质量控制。性能研究可以衡量制程与某些规格限的一致性。σ 有多个不同的估计。
  • JMP 可以拟合多种统计分布（正态、对数正态、Weibull、极值、指数、gamma、beta 及其它），同时还可对这些拟合执行拟合优度检验。

目录

容忍区间

预测区间

性能分析

分布拟合


容忍区间

“分布”报表中的容忍区间选项可以显示一个对话框，该对话框允许您选择要包含在选定区间中的置信 (1 - α) 和比例 (p)。JMP 可以生成单侧或双侧容忍区间。请从对话框中选择相应的选项。

其中

是一个常数，可在 Odeh 和 Owen (1980) 的表 4 中找到。

要确定 g，请考虑容忍区间所获取的总体的比例。Tamhane 和 Dunlop (2000) 提供的该比例为

其中 Φ 表示标准正态 c.d.f.（累积分布函数）。因此，g 可以求解方程式

其中 1 - γ 是包含在容忍区间中的所有预计观测值的比例。

有关更多信息，请参阅 Hahn 和 Meeker (1991) 中的表 A.1a、A.1b、A.11a 和 A.11b。

容忍区间是可以要求至少包含一个指定置信度比例的区间 — 实质上它是一个总体比例的置信区间。Hahn 和 Meeker (1991) 以及 Tamhane 和 Dunlop (2000) 中提供了有关容忍区间的完整讨论。

例如，使用大班.jmp 中的身高变量，设定 α = 0.05 和 p = 0.90 即可获得如"“容忍区间”报表" 所示的报表。

“容忍区间”报表

通过此报表，研究人员可以说：“我们有 95% 的把握可以保证，至少有 90% 的总体数据位于 53.8309 和 71.2691 之间。”


预测区间

对于预计样本的均值及标准差，“分布”平台提供了单侧和双侧“预测区间”。

预测区间是一些具有指定置信度的区间，它们可以包含下一个随机选定样本的单个观测值，或者包含其均值及标准差。

如果从某个变量的下拉菜单中选择了预测区间，您将看到以下对话框。

在第一个编辑框中为预测区间输入 1 - α。由于预测区间取决于预计观测值的大小，因此您需要在第二个字段中输入预计样本大小（我们选择了 2）。使用单选按钮选择下限、上限或双侧界限，然后单击确定。以下输出（此情况下为双侧报表）将被添加到“分布”报表中。

预测区间的解释

在许多独立的随机样本对中，如果根据第一个样本的数据计算出 100(1 - α)% 预测区间，从而包含了第二个样本的值，则 100(1 - α)% 的区间将在对数运算中正确包含预计值。（Hahn 和 Meeker 1991）

计算公式

JMP 用于计算预测区间的公式如下。

关于预计的个体值或均值：

关于预计的标准差：

有关参考，请参阅 Hahn and Meeker (1991)，第 61 - 64 页。


性能分析

性能分析选项可对质量控制应用程序进行性能分析。性能研究可以衡量制程与指定规格限的一致性。对话框将提示您输入规格下限、规格上限和目标。您只需要输入三个值中的一个即可。只有您输入的那些字段将作为最终“性能分析”表的一部分。此外，您也可以输入已知的 Sigma 值（制程标准差）。

通过使用 σ 的多个不同短项估计，“性能分析”可以计算出性能指数。在请求执行分布操作后，您可以从外框栏的弹出式菜单中选择对感兴趣的变量选择性能分析。此时将出现如"“性能分析”对话框" 所示的对话框，您可以在其中选择长项、单个或多个短项 sigma 规格（按列或固定样本大小分组）。

“性能分析”对话框

所有性能分析均使用相同的公式。这些选项的不同点在于计算 sigma 的方法。这些 sigma 选项可解释为：

  • 长项使用全部 sigma 并与 JMP 之前的默认输出相同。此选项用于 Ppk 统计量，sigma 的计算公式如下：
  • 指定 Sigma 允许用户输入特定的已知 Sigma 以用于性能分析计算。显然，Sigma 是由用户指定且尚未计算的值。此选项用于控制图表生成性能分析，其中用于图表的 Sigma 是输入（对话框中）的指定 Sigma。
  • 短项，按固定子组大小分组可用于使用以下公式计算 σ。在此情况下，如果 r 为子组数且每个第 i 个子组均按数据顺序定义，则 sigma 的计算公式如下：
  • 短项，按列分组将打开一个列列表对话框，您可以从中选择分组列。在此情况下，如果 r 等于子组数，则 sigma 的计算公式如下：

（请注意，此公式与短项，按固定子组大小分组的公式相同。）

注：此时将显示名为 Ppk 能力标记的“分布”首选项，将使用 Ppk 标签标记长项性能输出。您可以使用文件 > 首选项找到此选项。

如果单击确定，则平台将在文本报表底部附加“性能分析”表，如"“性能分析”表" 所示。您可以随意多次移除和恢复性能分析。

规格限可以存储，并可从数据表中自动检索。要执行此操作，请从保存命令菜单中选择规格限。如果保存了规格限，下一次打开直方图时便会显示这些规格限。

“性能分析”表

“性能分析”表分为两部分。表的上半部分将显示以下量：

  • 规格列将列出所显示值的项目名称，其中包括规格下限、规格上限和规格目标。
  • 值列将列出为每个界限和目标指定的值。
  • 实际 % 是在规格限之外观测到的数据百分比。

“性能分析”表的下半部分列出 5 项基本的制程性能指数及其值，以及置信区间的上限和下限。此外，该部分还将列出规格限之外区域的 PPM 百分比。PPM 列（百万分率）为百分比列乘以 10,000 所得的结果。

此 Sigma 质量测量常用于六西格玛方法，即制程西格玛。

例如，如果在 n=1,000,000 的观测值中存在 3 个缺陷，则该公式的计算结果为 6.03（即 6.03 Sigma 制程）。上面和下面的列都不会计入合计列中，因为 Sigma 质量要使用正态分布值，因此不加入合计中。

"性能指数名称和计算方法"对这些指数进行了介绍，同时还提供了计算公式。

性能指数名称和计算方法
指数 指数名称 计算方法
CP 制程性能比，Cp
(USL - LSL)/6s，其中 USL 为规格上限，
LSL 为规格下限
CP 的
置信区间 		CP 上的置信区间下限
CP 上的置信区间上限
CPK
（AIAG
的 PPK） 		制程性能指数，Cpk
最小值 (CPL、CPU)

CPK 的置信区间

期望值

假设

表示非中心参数，且

以 σ 单位数表示规格限。则期望值为

方差

使用上面的 c 和 d，方差为

置信区间
下限

置信区间
上限

CPM

制程性能指数，Cpm

CPM 的置信区间

CPM 上的置信区间下限

CPM 上的置信区间上限

CPL

单侧规格下限的制程性能比
（均值 - LSL）/3s，其中 s 为估计的标准差

CPU

单侧规格上限的制程性能比
（USL - 均值）/3s

在日本，性能指数 1.33 被视为可接受的最小值。对于正态分布，此值提供了一个期望值，表示每 100,000 单位中大约有 6 个不合格单位。

使用广义的 Chou et al. (1990) 方法可以准确计算出 CPL 的 100(1 - α)% 置信下限和上限，该方法指出 CPL（用 CPLLCL 表示）的 100(1 - α) 置信下限满足方程式

其中 Tn-1(δ) 具有 n - 1 自由度的非中心 t 分布以及非中心参数 δ。

使用广义的 Chou et al. (1990) 方法也可以准确计算出 CPU 的 100(1 - α)% 置信下限和上限，该方法指出 CPU（用表示 CPULCL）的 100(1 - α) 置信下限满足方程式

其中 Tn-1(δ) 具有 n - 1 自由度的非中心 t 分布以及非中心参数 δ。

报表底部报告了 Z 统计量。根据《AIAG 统计过程控制》手册中的说明，Z 表示从制程均值至感兴趣的值（如工程规格）的标准差单位数。用于性能评估时，Z 规格上限表示与规格上限的距离，而 Z 规格下限表示与规格下限的距离。

Z 规格上限 = (USL-Xbar)/sigma = 3 * CPU

Z 规格下限 = (Xbar-LSL)/sigma = 3 * CPL

Z 检验台 = 逆累积 Prob（1 - P（规格下限）- P（规格上限））

其中

P（规格下限）= Prob（X < 规格下限）= 1 - 累积 Prob（Z 规格下限）

P（规格上限）= Prob（X > 规格上限）= 1 - 累积 Prob（Z 规格上限）

注：您也可以使用分布拟合选项来执行非正态性能分析，下一节中将详细介绍。在对分布进行拟合后，您可以选择为拟合分布生成分位数和目标值。如果提供了目标值，则通过使用指定的分位数值以及目标值即可自动生成性能分析。


分布拟合

分布拟合命令将提供一个分布列表，您可以对分析变量进行拟合。如果选择了某个分布，则报表中将附加一个显示拟合分布参数估计的表。您可以随意多次重复此拟合过程。

分布拟合命令

下面章节将讨论分布拟合命令所提供的各种分布。

注：每个拟合分布的标题栏均有一个弹出式菜单，其中包含该拟合的附加选项。这些选项将在下一节中讨论。

正态

正态拟合选项可以根据分析样本估计正态分布参数。正态分布的参数包括可定义 x 轴上分布位置的 μ（均值）以及可定义分布离散或散布的 σ（标准差）。当 [image] 和 [image] 时为 标准正态分布。正态分布拟合的“参数估计”表可以显示 mu（μ 的估计）和 sigma（σ 的估计）及其 95% 的置信下限和上限。

下图显示了使用正态选项标绘出的正态（钟形）曲线。数据由随机数字函数 Random Normal() 生成。正态曲线通常用于对测量数据建模，而这些测量数据与曲线中间的大多数值相对应。您可以为任何一组数据选择正态拟合，然后检验正态分布的数据拟合情况。

如果样本大小为 ≤ 2000，系统将报告 Shapiro-Wilk 正态性检验结果；在 > 2000 的情况下，则计算 KSL 检验。

注：此例介绍了正态拟合弹出式菜单中的密度曲线选项。此选项可以通过样本数据的参数估计在直方图上叠加密度曲线。有关用于每种分布拟合的选项，请参阅下一节。

对数正态

对数正态拟合选项可以为变量 Y 的双参数对数正态分布估计参数 μ 和 σ，只有当 [image] 为正态时，其中的 Y 才为对数正态。数据必须为正数。

Weibull、有阈值的 Weibull 和极值

Weibull 分布具有两种不同的形状，具体取决于值 α（尺度参数）和 β（形状参数）。通常，Weibull 分布可以为估计使用寿命提供有效模型，特别是在机械设备和生物学方面。双参数 Weibull 与阈值参数为零的三参数 Weibull 相同。

有阈值的 Weibull 可以在分布中添加阈值中心参数。JMP 当前不会估计阈值参数。如果您知道应该选取的参数，则可以使用固定参数选项进行设定。

极值分布是一种具有变换参数 δ = 1/α 和 λ = ln(β) 的双参数 Weibull (α, β) 分布。

指数

指数分布是形状参数 α 为 1 时的一种特殊 Weibull 和 gamma 分布。指数分布对描述一段时间内随机出现的事件（如生存数据）特别有用。此外，它还可用于描述非重叠事件的间隔时间，如用户计算机发出请求与服务器进行响应、客户到达服务台以及从总机转入的电话等事件的间隔时间。

Devore (1995) 特别提到指数分布无记忆性，也就是说，如果在 t 小时后检查某个成分，而该成分仍在正常工作，则附加生命期在已存活时间条件下进一步存活时间的概率分布与原始分布相同。

Gamma

Gamma 拟合选项可以根据分析样本估计 gamma 分布参数 α > 0 和 β > 0。参数 α 即拟合 gamma 报表中的 alpha，它可以描述形状或曲率。参数 β 即 beta，它是分布的尺度参数。

注：名为阈值的第三个参数是下限终点参数，其值必须大于数据中的最小数据值。默认情况下，阈值设定为零。但是，您也可以在拟合分布的报表弹出式菜单中使用固定参数选项重新设定其值。它是在密度公式中用于调节每个样本值的常数：

  • 标准 gamma 分布中 β = 1。Beta 被称为尺度参数，这是因为除 1 之外的值可以沿着 x 轴伸展或压缩分布。
  • χ2 分布是 σ = 2 且 θ = 0 时出现的一系列 gamma 曲线。
  • 指数分布是 α = 1 且 θ = 0 时出现的一系列 gamma 曲线。

"α = 1、α = 3 和 α = 5 时的 Gamma 分布直方图" 显示了各种 α 值时 gamma 概率密度函数的形状。直方图数据通过使用包含自变量 1、3 和 5 的随机 Gamma() 函数而生成。标准 gamma 密度函数在 [image] 时严格递减。在 [image] 的情况下，如果 x = 0，则密度函数将从零开始增加，并在达到最大值后递减。

α = 1、α = 3 和 α = 5 时的 Gamma 分布直方图

Beta

Beta 分布拟合选项可以根据分析样本估计两个 beta 分布形状参数 α > 0 和 β > 0。此时同样存在阈值下限参数 θ = A 和 σ，它们可用于将阈值上限定义为 θ + σ = B。Beta 分布的定义区间为 [image] 。如果 A = 0 和 B = 1，则分布为标准 beta 分布。

您可以通过拟合分布报表弹出式菜单中固定参数选项将参数设定为固定值，但阈值上限必须大于最大数据值，而阈值下限则必须小于最小数据值。

有时，标准 beta 分布可用于概率表征随机变量（如约束在区间 0 和 1 中的比例）的建模。

Poisson

Poisson 分布可以根据分析样本估计单个尺度参数 λ > 0。您可以使用拟合分布报表中的固定参数选项将此参数设定为固定值。

Poisson 的置信区间是通过“极大似然”法而得出。

在样本大小小于或等于 100 的情况下，通过将两个单侧 Kolmogorov 精确检验合并为一个接近精确检验，从而形成拟合优度检验（有关详情，请参阅 Conover 1972）。在样本大小大于 100 的情况下，系统将执行“Pearson 卡方”拟合优度检验。

注：由于 Poisson 分布属于离散分布，其平滑曲线（或 PDF）实际上是一个阶梯函数，在每个整数位置均会出现跳跃。

二项

“二项”分布采用两种格式将二项分布与数据拟合。选择“二项”时，将出现一个对话框，在其中可以指定以下其中一项：

  • 成功在一列，且试验数固定，您可在对话框中输入试验数。
  • 成功数在一列，而试验数在另一列。

平滑曲线

平滑曲线命令可以通过非参数密度估计将平滑曲线与连续变量直方图拟合。平滑曲线还将在图的下方显示一个滑块。您可以使用此滑块来设定核心标准差。该估计是通过汇总每个数据点上核心标准差的正态密度而得出。通过更改核心标准差，您可以控制平滑数。

分布拟合选项

每个分布拟合表都有如此处所示的弹出式菜单，其中包含增强拟合分布报表功能的选项。

分位数图可以使用 y 轴上的选定分布分位数以及 x 轴上的变量值来生成分位数图。

“分位数图”还有自己的一系列选项：

  • 旋转可以将 x 轴和 y 轴反转。
  • 置信限可以为“正态分位数图”标绘 Lilliefors 95% 置信限，以及为所有其它分位数图标绘 95% 等精度界（a = 0.001 且 b = 0.99）(Meeker and Escobar (1998))。
  • 拟合直线可以标绘对角参考线。如果用某个变量拟合选定的分布，那么值将大致位于该参考线上。
  • 均值参考线可以在响应均值位置标绘一条水平线。
  • 概率标签可以在分位数图的右侧添加一条概率轴。

密度曲线可以使用分布的估计参数在直方图中叠加一条密度曲线。如前所述，正态及 Beta 分布的说明中均列举了叠加密度曲线的实例。

拟合优度可以计算拟合分布的拟合优度检验。请注意，拟合优度检验并非卡方检验，而是 EDF（经验分布函数）检验。EDF 检验比卡方检验更具优势，相对于直方图中点来说，EDF 检验在幂和不变性方面得到了改善。

下表列出了 JMP 可对每种分布

JMP 拟合优度检验
分布 | 参数 | JMP 可执行的检验
Beta | α 和 β 已知 | Kolmogorov 的 D
 | α 或 β 未知 | （无）
指数 | σ 已知或未知 | Kolmogorov 的 D
Gamma | α 和 σ 已知 | Cramer von Mises W 2
 | α 或 σ 未知 | （无）
正态 | μ 和 σ 未知 | Shapiro-Wilk（少于 2000 个数据点）Kolmogorov-Smirnoff-Lillifors（2000 个或更多数据点）
 | μ 和 σ 已知 | Kolmogorov-Smirnoff-Lillifors
 | μ 或 σ 已知 | （无）
对数正态 | μ 和 σ 已知或未知 | Kolmogorov 的 D
二项式 | p 和 n 已知 | Kolmogorov 的 D
Kolmogorov D 执行的检验

固定参数可以在报表中附加对话框，以便您在自定义值列中键入特定参数值。

单击完成可以生成一个固定参数表，其中将显示所输入的参数值。所有仍未固定的参数将在考虑固定约束的情况下被重新估计。系统将根据固定参数重新计算其它参数的置信限。用于适合性检验的零假设是指可以充分描述数据的新约束参数化。这意味着较小的 p 值将拒绝该假设，同时推断新的参数化并不适合。

分位数可以返回特定上限和下限范围内的未调整比例且未中心化的分位数，您可以在分位数选项显示的对话框中指定该上限和下限。

对于正态分布，3σ 既可表示 0.135 百分位数下限到中位数（或均值）的距离，也可表示中位数（或均值）到 99.865 百分位数上限的距离。根据这一事实，规格限可以计算出广义的标准性能指数。这些百分位数均根据拟合分布估计得出，而相应的百分位数到中位数的距离将替换标准公式中的 3σ。

使用 T 来表示目标值，而 LSL 和 USL 则分别表示规格下限和规格上限，同时使用 P α 来表示第 100 个百分位数，则广义的性能指数如下所示：

如果数据为正态分布，则这些公式即可简化为标准性能指数公式（"性能指数名称和计算方法"）。

保存拟合分位数可以将拟合的分位数值在当前数据表中保存为新的列。

保存密度公式可以在当前数据表中创建一个新的列，其中将包含通过密度公式计算得出的拟合值，而响应变量的估计参数在计算过程中充当了自变量。

保存规格界限可以将性能分析中给定的规格限保存到列中。

移除拟合可以从报表窗口中移除分布拟合信息。


二元散点图和拟合

以 X 拟合 Y 平台

您可以利用“二元”平台来研究一个连续变量相对于另一个连续变量的分布情况。“二元”平台是以 X 拟合 Y 命令的连续变量对连续变量的特殊情况命令的。此分析以一个散点图开始，之后您可以在其中交互式的添加其它拟合类型：

  • 简单线性回归 -- 通过数据点拟合直线
  • 选定次数的多项式回归 -- 拟合抛物线或高阶曲线
  • 平滑样条 -- 可以选择平滑度
  • 二元正态密度椭圆 -- 使用图形显示相关性
  • 二元非参数密度等高线
  • 对由分组变量定义的组进行多次拟合

注：您既可以通过以 X 拟合 Y 主菜单命令（或工具栏）来启动“二元”平台，也可以通过“JMP 起始页”的基本选项卡上的二元按钮来启动它。如果您从分析菜单中选择以 X 拟合 Y，JMP 将按内容执行分析，此分析适用于您为响应和因子变量指定的建模类型。如果您使用“JMP 起始页”上的二元按钮，则启动对话框需要连续建模类型的因子和响应变量，它还会询问您是否需要指定其它建模类型。

有关数据类型和建模类型的说明，请参阅《JMP 用户指南》。有关更复杂模型的实例，请参阅本书中的以下几章："标准最小二乘：入门"、"标准最小二乘：估计透视"、"标准最小二乘：探索预测方程"、"标准最小二乘：随机效应"和"多重响应拟合"。

目录

启动平台

选择列角色

散点图

拟合命令

显示点

拟合均值

拟合直线与拟合多项式

拟合特殊变换

拟合样条

拟合每个值

正交拟合

拟合密度椭圆

非参数密度：非参数密度估计

直方图边框

成对 t 检验

分组依据

显示选项和保存命令


启动平台

从分析菜单或工具栏中选择以 X 拟合 Y 或者单击“JMP 起始页”的基本选项卡上的二元按钮，您首先会看到一个“启动”对话框（如"“以 X 拟合 Y”启动对话框"）。当您在此对话框中选择分析变量并单击确定之后，以 X 拟合 Y 将启动一个平台，其中包含响应 (Y) 变量与因子 (X) 变量每个指定组合的图形以及附带的文本报表。

平台类型随变量的建模类型而有所不同。"“以 X 拟合 Y”回归平台" 所示为连续建模类型列 X 和 Y 的“以 X 拟合 Y”报表。

“以 X 拟合 Y”回归平台

选择列角色

在如"“以 X 拟合 Y”启动对话框" 所示的对话框中指定用于分析的列。对话框左侧的选择列表显示了当前表中的所有列。要为列分配角色，请在列选择器列表中选择一列或多个列，并单击角色按钮。或者，将变量从列选择器列表拖至下列角色框中的一个：

  • X，因子为 x 轴角色，一个或多个因子变量。
  • Y，响应为 y 轴角色，一个或多个响应变量。
  • 区组不用于连续对连续建模类型变量的分析。
  • 权重是一个可选角色，用于标识一个列，该列的值将为每个“y 对 x”组合中的响应赋予权重。
  • 频数是一个可选角色，用于标识一个列，该列的值为分析指定每行的频数。

要从指定角色中移除不想使用的变量，请在角色框中选择此变量并单击移除。指定角色完成后，请单击确定以查看每个变量 Y 对 X 组合的分析。

注：通过在电子表格左侧的“列”面板中选择列，可以将任何列或列组合指定为标签。然后，从“列”面板顶部的列弹出式菜单中选择标签即可。当您单击图中的某个点时，您所指定的标签变量列的值就会标识它。

“以 X 拟合 Y”启动对话框

散点图

“二元”平台由生成每对 X 和 Y 变量的散点图开始。与 JMP 中的其它图形类似，散点图也具有调整图形大小、使用光标或笔刷工具高亮度显示点以及标记点等功能。

有关这些功能的介绍，请参阅《JMP 用户指南》。

通过散点图标题上的弹出式图标可以访问包含拟合命令和选项的菜单，利用它们可以在散点图中叠加曲线以及显示统计表。

以下实例中的数据均来自于 Sample Data 文件夹中的大班.jmp 数据表。


拟合命令

下图所示为散点图名称旁边的弹出式菜单（“拟合”菜单）。

您可以反复选择拟合命令。每次新的拟合都会叠加在散点图上。这样您可以排除不同的点反复拟合并在同一个图上对它们进行比较。每次您选择一个拟合，JMP 均会在平台上添加一个文本报表。报表类型视您所制定拟合种类而定。

注：当您按住 Control 键（Mac 中为 command(命令) 键）并选择某个拟合选项时，JMP 将为该窗口中的所有二元分析同时执行该选定拟合。如果您按住 Control 键（ command(命令) 键）拖动某个散点图的调整大小框，所有图形的大小将同时调整。

拟合命令可分为两类：

回归拟合
回归方法通过点来拟合曲线该曲线是按最小二乘估计的方程式（线性模型）。最小二乘法就是使每个点与线（或曲线）之间距离的平方和达到最小。在此拟合中，假设 Y 变量以随机散点的形式分布在拟合直线上下。
密度估计
密度估计是将二元分布与点拟合。您可以选择二元正态密度、使用椭圆等高线或常规非参数密度表征。

以下部分将说明这些选项、拟合及其统计结果，另外还会介绍平台的一些其他功能。

显示点

显示点用于隐藏或显示图中的点。

拟合均值

使用拟合均值命令可以在图中响应变量 (Y) 的均值处添加一条水平线。您可以使用拟合置信曲线和单个置信曲线选项来添加置信曲线，如本章第 91 页中的"显示选项和保存命令"部分所述。首先拟合均值，将其作为其他拟合的参考线，通常很有用。我们可以先看一下"选定拟合的实例" 所示的实例，它是将均值直线与直线拟合以及二次多项式加以比较。拟合均值等同于拟合 0 次多项式。

“拟合均值”的拟合表给出以下的统计量，它汇总了响应变量相关信息：

均值
响应变量的样本均值（算术平均数）。它是当模型中没有指定效应时的预测响应。
标准差 [RMSE]
响应变量的标准差。它等于响应变量均方的平方根，也称为均方根误差 (RMSE)。
标准误差
响应均值的标准差。它等于 RMSE 除以非缺失值个数的平方根。
误差平方和
简单均值模型的误差平方和。它等于每个点与均值之间距离的平方和。在每个模型拟合的方差分析表中，它显示为误差平方和。

拟合直线与拟合多项式

使用拟合直线命令可以利用最小二乘回归图在图中添加直线拟合。有关如何在图中添加置信曲线的说明，请参阅本章第 91 页的"显示选项和保存命令"部分。另外，还有一些命令可用于将线性拟合的预测值和残差另存为当前数据表中的新列。

拟合直线命令寻找直线方程中的参数 [image] 和 [image] 使拟合点残差的平方和达到最小。第 i 行的模型计算公式为 [image] 。

如果此直线的置信区域包含响应均值，则拟合直线的斜率在显著性水平为 0.05 时与 0 将没有显著差异。拟合直线命令等同于拟合一次多项式。"选定拟合的实例" 所示为将简单均值直线以及二次多项式拟合与线性拟合进行比较的实例。

使用拟合多项式命令可以拟合多项式曲线，次数为您从拟合多项式子菜单中选择的。在选择多项式次数之后，JMP 将使用最小二乘回归将曲线与数据点拟合。您可以使用拟合置信曲线和单个置信曲线显示选项来添加表示 95% 置信限的曲线。

您可以多次选择拟合多项式选项并选择不同的多项式次数来进行比较。与线性拟合一样，这些选项也可以让您将每次多项式拟合的预测值和残差另存为当前数据表中的新列。

二次多项式是抛物线；三次多项式是三次曲线。如果次数为 k，则第 i 个观测值的模型为：

拟合命令不是切换命令，故可以反复选择。因此，您可以排除不同的数据点得到不同的拟合并在同一个图上对它们进行比较。

选定拟合的实例

每次您选择线性拟合或多项式拟合时，JMP 均会在报表中附加三个额外的表。如果存在重复，则还会显示第四个表“失拟合”。

下面将介绍这些表。

拟合汇总表

"线性拟合与多项式拟合的“拟合汇总”表" 中的“拟合汇总”表显示了相同数据在线性拟合和二次多项式拟合后响应的数值汇总。您可以比较一下两个“拟合汇总”表，看看两个模型哪个更好些。事实上，R 平方值较大且均方根误差较小是模型比较好的标志。

线性拟合与多项式拟合的“拟合汇总”表

拟合结果首先给出拟合方程式（"线性拟合与多项式拟合的“拟合汇总”表"）。请注意，此方程式是可编辑的。“拟合汇总”表给出了以下量：

R 平方
度量线性模型或多项式模型所描述均值附近变异的比例。剩余的变异归为随机误差。如果模型的拟合效果非常好，R 平方则为 1。如果 R 平方为 0，表示该拟合与简单均值模型效果一样。在使用相应方差分析表中的量时，任何区间响应拟合的 R 平方计算公式始终如下：
"线性拟合与多项式拟合的“拟合汇总”表"中的 R 平方值表明，二次多项式拟合仅比线性拟合好一点点。
调整 R 平方
通过在计算中使用自由度，调整 R 平方值，使它在具有不同参数个数的模型中更具可比性。它是均方比而不是平方和比，计算方法如下
其中误差的均方可在“方差分析”表中找到，C. 合计均方的计算方法为 C. 合计的 C. 合计平方和除以其各自的自由度（请参阅"线性拟合与多项式拟合的“拟合汇总”表" 和"“方差分析”表"）。
均方根误差
估计随机误差的标准差。它是在"“方差分析”表"的“方差分析”表中找到的误差的均方平方根。
响应均值
响应变量的样本均值（算术平均数）。它是当未指定模型效应时的预测响应。
观测值
用于估计拟合的观测值个数。如果存在权重变量，则此值为权重和。

失拟合表

“失拟合”表给出了一个特殊的诊断检验，它只有在数据和模型适宜时才出现。其原理为有时可以在不知道模型形式正确与否的情况下直接估计误差方差。如果观测值对于 x 变量而言彼此完全重复，就会出现这种情况。可将这些完全重复测量的误差称为纯误差。不管模型使用的是什么形式的 x 变量，这都是无法解释或预测的样本误差部分。但是，如果自由度很少（即重复的 x 值很少），则失拟合检验的用处可能不大。

模型残差和纯误差之间的差称为失拟合误差。如果回归量的函数形式不正确，则失拟合误差将显著大于纯误差。在这种情况下，您应尝试使用其它类型的模型拟合。

“失拟合”表显示了误差项的有关信息：

来源
列出名称为失拟合、纯误差和总误差的三个变异来源。
DF
记录每个误差来源的关联自由度 (DF)。
总误差 DF 是指“方差分析”表的误差行上的自由度（如第 78 页的"方差分析表"所示），即该表中的合计 DF 与模型 DF 之间的差。误差 DF 分为失拟合自由度和纯误差自由度。
纯误差 DF 是由有多行相同值的各个效应的各个组合并而成的。例如，大班.jmp 样本数据表中有多个这样的实例，其中的多个对象具有相同的高度值。一般来说，如果有 g 组的多个行有相同值的效应，，则记为 DFp 的合并 DF 为
其中 n i 为第 i 组中对象的个数。
失拟合 DF 是总误差 DF 与纯误差 DF 之差。
平方和
记录每个误差来源的关联平方和（简称 SS）。
总误差 SS 是"方差分析表"中所示的对应“方差分析”表里误差行中各值的平方和。
纯误差 SS 是由每个组的 SS 相加而成，其中这些组中有多个行变量 x 的值相同。其估计了模型效应 x 无法解释的真实随即误差部分。一般来说，如果有 g 个含有多个行为相同 x 值的组，则记为 SSp 的合并 SS 的计算公式为
其中 SSi 是指根据均值校正的第 i 组的平方和。
失拟合 SS 是总误差平方和与纯误差平方和之差。如果失拟合 SS 较大，则该模型可能不适合这些数据。下述的 F 比率用于检验由于失拟合导致的变异是否足够小（足以将其认为成纯误差的可忽略部分）。
均方
等于平方和除以其关联自由度。计算会将平方和转换为一个平均值（均方）。统计检验中的 F 比率是均方之比。
F 比率
失拟合均方与纯误差均方之比。它检验失拟合误差为零的假设。
p 值 > F
只当由失拟合方差产生的变异与由纯误差方差产生的变异相同时，偶然获得较大 F 值的概率。如果 p 值较大，表示误差的不显著部分可以通过失拟合来解释。
最大 R 平方
是模型仅使用模型中的变量就可达到的最大 R 平方。因为纯误差对于不同的模型形式是固定不变的，并且它是最小的可能方差，所以最大 R 平方的计算公式如下：

方差分析表

线性回归中的方差分析 (ANOVA) 可以将样本的总变异分为几个成分。这些成分用于计算评估模型有效性所需的 F 比率。如果与 F 比率的关联概率较小，则认为使用此模型对数据进行统计拟合的效果比单独使用响应均值要好。"“方差分析”表" 中的“方差分析”表将线性拟合（拟合直线）与二次多项式拟合（拟合多项式）进行了比较。从统计角度看，这两个拟合与均值处的水平线均有差异。

“方差分析”表

“方差分析”表将给出以下统计量：

来源
列出名称为模型、误差和 C. 合计的三种变异来源。
DF
记录每个变异来源的关联自由度 (DF)。
对于计算中使用的每个参数估计，JMP 均会从它的非缺失值总数 N 中减去自由度。在计算总样本变异时会用到均值估计，因此还要从总自由度（为 39）中减去一个自由度。校正后的总自由度分为模型项和误差项。
总自由度中的一个自由度（显示在模型行）用于估计线性拟合的单回归参数（斜率）。两个自由度用于估计二次多项式拟合的参数（ [image] 和 [image] ）。
误差自由度是总自由度与模型自由度之差。
平方和
记录每个变异来源的关联平方和（简称 SS）。
在本实例中，每个响应与样本均值的距离平方和合计（C. 合计）为 19224，如"“方差分析”表" 所示。它是用于与其它所有模型进行比较的基本模型（或简单均值模型）的平方和。
对于线性回归，每个点与拟合直线之间的距离的平方和从 19924 降为 9555.9。它就是在模型拟合后无法解释的误差（残差）SS 部分。二次多项式拟合的残差 SS 为 9150.1，表明它所能解释的变异比线性拟合略大一些。
合计 SS 减去误差 SS 可得到归结于模型的平方和。
均方
等于平方和除以其关联自由度。统计检验的 F 比率等于以下均方的比：
线性拟合的模型均方为 9668.09 并且可用于估计方差，但是只有在满足模型参数为 0 的假设时才能得到上述值。
误差均方为 251.47 并且可用于估计误差项的方差。
F 比率
等于模型均方值除以误差均方。拟合的基本假设是所有回归参数（除截距外）均为 0。如果此假设为真，则误差均方和模型均方均可用于估计误差方差，并且它们的比呈 F 分布。如果某个参数是显著模型效应，则其 F 比率值一般会大于偶然原因得到的F比率值。
p 值 > F
当指定模型的拟合效果与整体响应均值的效果一样时，偶然获得较大 F 值的显著性概率（p 值）。如果观测的显著性概率等于或小于 0.05，一般可以认为是回归效应。

参数估计表

线性拟合的“参数估计”表中（"线性拟合与多项式拟合的“参数估计”表"）包括两项：截距和单个 x 变量。在线性拟合下面，"线性拟合与多项式拟合的“参数估计”表" 给出了二次多项式模型的参数估计。对于 k 次多项式拟合，该表会给出模型截距估计以及每个 x 变量的 k 次幂的参数估计。

线性拟合与多项式拟合的“参数估计”表

“参数估计”表给出以下信息：

项
项列出所指定模型中每个参数的名称。截距是所有模型中的常数项。
估计
列出线性模型的参数估计。预测公式为这些估计与它们对应变量值的线性组合。
标准误差
列出参数估计的标准误差估计，用于构建检验和置信区间。
t 比率
列出假设每个参数均为 0 的检验统计量。它是参数估计与其标准误差的比率。如果假设为真，则此统计量呈学生氏t 分布。查找绝对值大于 2 的 t 比率，是用于判断显著性的常用经验，这是因为它近似于 0.05 的显著性水平。
p 值 > |t|
列出根据每个 t 比率计算得出的观测显著性概率。此概率为在假设为真时，偶然获得一个绝对值大于计算的 t 比率值的概率。低于 0.05（或有时低于 0.01）的值通常解释为参数与 0 有显著差异。

拟合特殊变换

使用拟合特殊命令将显示一个对话框，从中可以选择 Y 和 X 的变换。变换包括对数、平方根、平方、倒数和指数。

拟合特殊变换菜单和对话框

拟合直线将以原始尺度标绘，如"拟合变换后的变量" 所示。显示的回归报表包含变换后的变量，还有一个附加报表将会给出以原始 Y 尺度变换的拟合度量（如果对 Y 作了变换）。

拟合变换后的变量

中心多项式

利用拟合特殊变换命令可以关闭中心多项式功能，如"拟合特殊变换菜单和对话框" 所示。撤消选定中心化多项式复选框即可关闭中心多项式功能。

拟合样条

利用拟合样条命令可以根据 lambda (λ)（样条公式中的调谐参数）来拟合平滑样条，样条会因平滑度（或灵活性）而不同。您可以从拟合样条子菜单中选择 Lambda。如果要使用子菜单中未列出的 λ 值，请选择其它选项并在系统提示时输入相应的值。此外，您可以通过选择此对话框中的复选框来指定是否将 x 值标准化。

λ 值越小，样条模型误差项的权重就越大，拟合就越灵活和弯曲。λ 值越大，拟合就越僵直（较不弯曲），接近于直线。"不同 Lambda 值的样条拟合" 比较了僵直与灵活的样条拟合。

三次样条法使用一组接合在一起的三次多项式，因此产生的曲线在接合处（结点）是连续且平滑的。通过求目标函数（误差平方和与曲线上曲率积分罚项的组合）的最小值，可完成估计过程。有关此方法的说明，请参阅 Reinsch (1967) 或 Eubank (1988) 的论文。

平滑样条是一种用于了解 y 与 x 分布前瞻值的形状的有效方法。最靠近拟合曲线的各个部分的点对曲线的影响最大。当您设定调谐参数以生成较灵活的曲线（lambda 值较小）时，影响会更大。您可以首先尝试使用多个 Ι 值或者使用“平滑样条拟合”表下面的 Lambda 滑动杆，然后再确定最适合您的数据的样条曲线。但是， Ι 对于数据的尺度来说不是固定不变的。

不同 Lambda 值的样条拟合

“平滑样条拟合”表只会给出样条拟合的 R 平方和误差平方和。同时，它还有一个滑动杆可用来调整 Ι 值。

如果要将样条拟合与其它拟合加以比较，或者将不同的样条拟合彼此之间进行比较，这些值会非常有用：

R 平方
测量样条模型所说明的总变异比例。在上述实例中，在 λ = 1000 的情况下拟合样条可以解释 52.06% 的总变异。
误差平方和
每个点与拟合样条之间距离的平方和。它就是在拟合样条模型后无法解释的误差（残差）。

注：“拟合样条”的弹出式菜单中有一个保存系数命令，可用来将样条系数另存为新数据表，其中包含名称为 X、A、B、C 和 D 的列。X 是指结点。A、B、C 和 D 分别指三次样条切片的截距、线性、二次和三次系数。

拟合每个值

使用拟合每个值命令可以将值与每个唯一的 x 值拟合。拟合每个值与单因子方差分析类似；不过，在连续对连续建模类型二元平台中，您可以将它与其它拟合直线加以比较，并将了解失拟合的概念。

正交拟合

利用正交拟合命令可拟合那些要同时考虑因 X 和 Y 的变异性的问题。标准最小二乘拟合假设 x 变量是固定的，而 Y 变量是 X 的函数加上误差。如果在测量 X 时也存在随机变异，则不能拟合标准回归线，而应拟合与拟合直线垂直的线（如下图所示）。但是，垂直距离取决于 X 和 Y 的尺度，因此垂线的尺度实是统计问题，而不是图形问题。

正交拟合要求指定 X 方向误差与 Y 方向误差的方差比。这是误差方差，而不是样本点方差，因此必须谨慎选择。在标准最小二乘中，由于 [image] 为 0，因此比率 [image] 为无穷大。如果使用较大的误差比进行正交拟合，则拟合直线接近标准最小二乘拟合直线。如果指定的比率为 0，则此拟合等同于 X 在 Y 上的回归，而不是 Y 在 X 上的回归。

这种方法最常用于比较两个测量系统，其在测量同一个值时均会产生误差。因此，Y 响应误差与 x 测量误差属于同一种测量误差。但是从哪里才能得到测量误差方差呢？首先，不能根据二元数据来求得误差方差，因为您并不知道每个测量系统所产生的误差比例。因此，您必须试探性地假定某个比率（例如 1），或者依赖两个测量系统对同一单位进行的单独的反复测量。

这种方法的优点在于：通过计算可以同时求出 Y 和 X 的预测值；这些预测值就是最接近数据点的直线上的点，而接近程度与方差比有关。

置信限的计算方法如 Tan 和 Iglewicz (1999) 中所述。

正交拟合命令中的以下选项可用于指定方差比：

一元方差，主成分
使用根据 X 和 Y 的样本计算得出的一元方差估计。它就是标准的第一个主成分。
注：请注意，这在测量系统应用中并不是一个好选择，因为误差的方差通常不可能与总体方差成比例。
等方差
使用 1 作为方差比，即假设误差方差相同。使用等方差等同于非标准化的第一个主成分直线。如果散点图在 x 和 y 方向的尺度相同，并且显示正态密度椭圆，您将看到此直线就是椭圆的长轴（"正交拟合选项示意图"）。
以 X 拟合 Y
使用 0 作为方差比，表示 Y 没有方差（请参阅"正交拟合选项示意图"）。
指定方差比率
允许您根据需要输入任意比率，同时还允许您利用有关 X 测量误差和 Y 响应误差的已知信息。

"正交拟合选项示意图" 中的散点图显示了标准化的高度值和体重值，以及体现正交方差比选项生成的各种直线拟合。当 X 变量的方差非常小时，给出的就是标准线性回归。当忽略 Y 变量的变异时，以 X 拟合 Y 的情况则恰好相反。其它所有直线都会落在两个极值范围内，并且随着方差比的变化而变化。当方差比增大时，Y 响应的变异将占据主导地位，而拟合直线的斜率将更接近 Y 对 X 拟合。同样，当方差比减小时，拟合直线的斜率将更接近 X 对 Y 拟合。

在极端情况下，拟合直线将穿过椭圆的水平切线和垂直切线。中间情况是拟合直线穿过椭圆的长轴，而长轴要根据相对尺度来定。也就是说，您可以通过调整图形大小来更改纵横比率，从而使拟合直线穿过长轴。

正交拟合选项示意图

实例
假设您有两台秤，一个好秤 A，一个较差的秤 B。秤 A 是无偏的，经过反复测量得出它的标准差为 21 克。秤 B 是有偏的（但偏差时线性的），经过反复测量得出它的标准差为 23 克。您手上有两台秤上测得的重量数据。很多人可能只使用那个好秤 A 得到的测量值。但是，您可以做得更好。秤 B 的读数也是非常有价值的。您可以在 A 的重量测量基础上加上B 的正交回归，使用 (23/21)2 作为方差比。然后，得出 A 和 B 的预测值。由于 A 是无偏，因此使用 A 的预测值作为新改进的测量结果，而且测量误差的方差几乎可以达到单独使用秤A 得到的误差方差的一半。

实际等效性
如果您试图使拟合直线的斜率为某个界限（置信区间为 1 - alpha）内的值，则可以使用 Tan 和 Iglewicz (1999) 的方法以及 Berger 和 Hsu (1996) 进一步介绍的双单侧检验 (TOST) 法。在这种情况下，您要做的只是在置信区间 Alpha 列中输入 2*alpha，然后检查置信限是否包含在您所检验的界限内。例如，很多人经常想要确认斜率实际上是否接近 1，1 两侧的实际界限为 0.8 - 1.25。如果您将变量 X 和 Y 互换，它们应是对称的界限，检验也是相同的。输入 0.10 作为 alpha 值，然后查看置信限是否在 0.8 - 1.25 的范围内；如果在此范围内，它们将被认为实际平均等效。

拟合密度椭圆

使用密度椭圆命令可以绘制一个包含指定的一组点（由从密度椭圆子菜单中所选择的概率确定）的椭圆。密度椭圆根据变量 X 和 Y 的二元正态分布拟合计算得出。二元正态密度是变量 X 和 Y 的均值与标准差以及它们之间的相关性的函数。您可以利用其它选项指定任何大于 0 并且小于或等于 1 的概率。

这些椭圆既是密度等高线，也是置信曲线。作为置信曲线，它们会显示给定百分比的数据的前瞻位置，其中假设为二元正态分布。"选定的密度椭圆" 比较了概率不同的多个椭圆。

选定的密度椭圆

密度椭圆是两个变量之间相关性的一个很好的图形指标。当两个变量之间的相关性接近 1 或 -1 时，相应椭圆会是倾斜的。如果两个变量不相关，椭圆体会更圆一些（不是很倾斜）。

每次密度椭圆拟合均会产生一个“密度椭圆”表（"选定的密度椭圆"），其中会给出变量 X 与 Y 的相关性系数，以及变量之间显著相关性的概率。要查看多对变量的椭圆体和相关性的矩阵，请使用分析 > 多元方法菜单中的多元命令。

“二元”表中会给出以下量：

均值
提供变量 X 和 Y 的算术平均数。此均值等于非缺失值之和除以非缺失值的个数。
标准差
提供变量 X 和 Y 的标准差。它可用于度量均值附近的分布情况。它一般表示为 s，等于样本方差（表示为 [image] ）的平方根。对于正态分布，大约 68% 的分布是在均值的一个标准差范围内。
"一元分析" 章节中的 "连续变量的矩表" 部分详细介绍了均值和标准差。
相关性
Pearson 相关性系数（表示为 r），计算公式为：
其中
其中，如果已经指定权重列，则 [image] 为第 i 个观测值的权重；如果未指定，则为 1。如果两个变量之间是确切的线性关系，则相关性为 1 或 -1，具体取决于变量是正相关还是负相关。如果二者之间没有任何关系，则相关性趋于 0。
注：相关性系数也是“多元”平台给出的统计文本报表的一部分，如"相关性和多元技术"一章所述。“多元”平台只会使用具有所有指定 Y 变量值的行。如果指定了多个 Y 变量但其中存在缺失值，则 JMP 将从计算中排除其观测值，即使特定变量对无缺失值。“多元”平台还会提供成对相关性。
显著性概率
在 X 变量与 Y 变量之间不存在任何线性关系时，偶然得到绝对值比计算值大的相关性的概率。

以下命令可用于密度椭圆

阴影等高线
使密度椭圆内部的区域呈阴影。
选择内部点
选择椭圆内部的点。
选择外部点
选择椭圆外部的点。

非参数密度：非参数密度估计

非参数密度功能适用于下述情况：数据有几千个点，导致散点图变得非常黑，以至于根本看不清点密度的规律。

二元密度估计将建立一个平滑曲面模型，用于说明数据点在曲面上各个点的密集程度。该图上将添加一组表示密度的等高线（"选定的密度椭圆"）。可以选择 5% 区间内的分位数等高线，及线条略粗的 10% 分位数区间。这意味着，5% 的点在最低等高线的下面，而 10% 的点则在下一条等高线的下面，依此类推。最高等高线下面大约有 95% 的点。最高等高线下面大约具有 95% 的点。

显示二元密度信息的等高线

图下面的弹出式菜单为您提供以下可选命令：

核心控制
显示每个变量的滑动杆，您可以利用滑动杆来更改用于定义 X 和 Y 值范围的核心标准差，以便确定等高线密度。
5% 等高线
显示或隐藏 5% 等高线，隐藏时仅显示 10% 等高线。
网状图
在两个分析变量的网格基础上估计出来的密度的三维图形（"网状图"）。
保存密度网格
将密度估计及其相关分位数保存在新数据表中。网格数据可用于以其它方法来将密度分别可视化，例如使用“旋转图”或“等高线图”平台。
模型聚类
在当前数据表中创建一个新列并在其中填入聚类值。

注：如果先保存模型聚类值，然后再保存密度网格，则网格表中也会包含聚类值。聚类值可用于对图中的点进行着色和标记。

网状图

这种非参数密度法在处理几千个点的情况时非常有效，但当点数较少时，使用它就会非常耗时。此方法的具体步骤如下：

  1. 将每个轴分成 50 个小区间，这样整个曲面共有 2,500 个小块。
  2. 计算每个小块内的点数。
  3. 根据 Bowman 和 Foster (1992) 的建议确定平滑核心标准差。
  4. 使用 FFT 和逆 FFT 运行二元正态核心平滑器便进行卷积。
  5. 使用双线性曲面轨迹模型在 2,500 个小块上创建一个等高线图。

直方图边框

利用直方图边框命令可以在散点图的 x 轴和 y 轴上各附加一个直方图。

直方图边框

成对 t 检验

在 JMP 的第 3 版中，成对 t 检验是“二元”平台的一部分。其中的两个成对变量被描绘成二元散点图的 x 轴和 y 轴，图上还叠加了一条 45 度线。JMP 4 中已经增强此分析及其图形，并将它提升为自己的平台（有关“配对”平台的详情，请参阅《JMP 统计和图形指南》 中的 "成对数据"）。但是，如果您还是比较喜欢此检验在第 3 版中的形式，可以通过按住 Shift 键并选择“二元报表”标题栏上的弹出式菜单来访问它。配对数据 t 检验将出现在菜单上。"第 3 版中的成对 t 检验" 显示了狗.jmp 数据表中两个变量的成对 t 检验分析。

该图包含一条灰色的 45 度直线，表示在此线上两列的值相等。另外，它还包含一条与灰线平行的红线，由与两个响应之间的均值差相等的值代替。红色拟合直线附近的虚线代表均值差的 95% 置信区间。

第 3 版中的成对 t 检验

分组依据

利用“拟合”菜单中的分组依据命令可以显示一个对话框，它会提示您选择分类（分组）变量。当分组变量生效时，“以 X 拟合 Y”平台会计算分组变量每个水平的单独分析，并将回归曲线或椭圆重叠在散点图上。分组变量每个水平的拟合信息都会在散点图下给出，同时还有相应的弹出式菜单可用来保存或移除拟合信息。

当分组变量生效时，JMP 就会选定“拟合”菜单中的分组依据命令。您可以通过选择分组依据命令并移除（撤消选定）现有变量来更改分组变量。然后，再次选择分组依据命令并与前面一样的方式处理其对话框。

由于叠加了线性回归直线，因此您可以直观地比较它们的斜率。而叠加的密度椭圆可以显示分组变量各个水平的点聚类。例如，"分组变量的密度椭圆" 中的椭圆清楚地显示了不同类型的热狗相对于价格变量的聚类情况。

注： "分组变量的密度椭圆" 中的图像使用了热狗.jmp 样本数据表，描绘了变量美元/盎司对美元/磅蛋白质图。分组依据变量为类型，一共提供三个密度椭圆。

分组变量的密度椭圆

分组回归的另一个用途是叠加直线以便比较不同组的斜率。"全样本与分组样本的回归分析" 左侧的散点图具有一个直线单回归，它表明了数据表中所有公司的公司盈利与雇员人数之间的关系。此单回归表明两个变量之间存在负线性关系。右侧散点图上的回归线分别为每个公司类型（计算机和制药）说明了同一关系。为每个公司类型单独计算的统计量表明：当制药公司的雇员人数增加时，盈利却下降了；而计算机公司的雇员人数增加时，盈利却没有什么变化。

全样本与分组样本的回归分析

注： "全样本与分组样本的回归分析" 中的图使用了公司.jmp 样本数据表中的数据绘制的。


显示选项和保存命令

所有拟合在散点图上都用实线绘制。您可以使用每个拟合的显示弹出式菜单选项拟合置信曲线和单个置信曲线来向均值、线性拟合以及多项式拟合添加置信曲线，这些拟合信息显示在散点图的下面（"显示选项"）。

您选择的每个拟合均会在分析窗口中添加一个文本报表。例如，在您依次选择拟合均值、拟合直线和拟合多项式（三次）之后，就会出现如"显示选项" 所示的报表标题。

"显示选项" 右侧的弹出式菜单给出了可用于每个指定拟合的显示命令和保存命令。

显示选项
拟合直线
显示或隐藏拟合直线。
拟合置信曲线
显示或隐藏拟合均值、直线和多项式时产生的置信曲线。此选项不适用于拟合样条和密度椭圆，因此在这些菜单上，它呈灰色显示。
单个置信曲线
显示单个预测值的 95% 置信上限和下限。置信限反映了误差变异和参数估计变异。
线条颜色
允许您从调色板中选择要指定给每个拟合的颜色。
线型
允许您从线型选用区中选择要指定给每个拟合的线型。
线宽
为拟合直线提供了三种线宽。默认线宽为最细。
报表
打开和关闭拟合的文本报表。
保存预测值
在当前数据表中创建一个名称为 Predicted colname 的新列，其中 colname 是变量 Y 的名称。此列包含预测公式以及计算出来的样本预测值。预测公式会自动为添加到表中的行计算相应的值。
保存残差
在当前数据表中创建一个名称为 Residuals colname 的新列，其中 colname 是变量 Y 的名称。每个值均等于实际（观测）值与其预测值之间的差异。此选项不适用于拟合均值或密度椭圆，因此在这些菜单上，它呈灰色显示。
标绘残差图
标绘预测值对残差值图形。
设定 Alpha 水平
提示您输入 alpha 水平，以便计算并显示直线拟合、多项式拟合和特殊拟合的置信水平。
阴影化的拟合置信带
绘制与置信曲线拟合命令相同的曲线，并使曲线之间的区域为变暗
阴影化的个体置信带
绘制与“单个置信曲线”命令相同的曲线，并使曲线之间的区域为变暗。
移除拟合
从图形中移除相应的拟合并移除其文本报表。

注：您可以为每个拟合使用保存预测值和保存残差命令。如果多次使用这些命令或者使用了分组变量，最好重命名数据表中的结果列，以便反映出每个拟合的情况。


单因子方差分析

以 X 拟合 Y 平台

“单因子”平台用于分析在按分类变量 x 定义的组之间，连续变量 Y 的分布有哪些不同。该平台可以计算和检验组均值，及其它统计量和检验。“单因子”平台是以 X 拟合 Y 命令的连续建模类型对记名/保序建模类型特殊情况。此平台开始时使用 X 对 Y 散点图来显示每个组内的值分布，而且可以：

  • 执行单因子方差分析以拟合均值并检验它们是否相等
  • 执行非参数检验
  • 检验方差齐性
  • 通过均值比较环对均值进行多重比较检验
  • 显示出现在每个组上的离群值箱型图
  • 显示单因子布局的功效详细信息

注：您既可以通过以 X 拟合 Y 主菜单命令（或工具栏）来启动“单因子”平台，也可以通过“JMP 起始页”的基本选项卡上的单因子按钮来启动它。如果您从分析菜单选择以 X 拟合 Y，JMP 将按数据内容执行分析，此分析适用于您指定的响应和因子变量的建模类型。如果您使用“JMP 起始页”上的单因子按钮，则“启动”对话框（角色对话框）将需要连续响应以及记名或保序因子变量。若您需要指定其它建模类型，JMP 还会提出建议。

有关更复杂的模型实例，请参阅以下各章："标准最小二乘：入门"、"标准最小二乘：估计透视"、"标准最小二乘：探索预测方程"和"标准最小二乘：随机效应"，其中将会介绍适于标准最小二乘模型拟合的“模型拟合”平台。

另外，"变异性图"一章所讨论的“变异性图”平台也会从另一个角度来介绍单因子分析。

目录

启动平台

单因子方差分析图

简单实例

单因子平台布局

平台命令

显示选项

分位数与箱型图

单因子方差分析与 t 检验：表与图

拟合汇总表

t 检验表

方差分析表

单因子方差分析均值表

均值菱形和 x 轴成比例

均值直线、误差条与标准差线

多重比较

组均值的直观比较

配对比较的学生氏 t 检验

适于所有比较的 Tukey-Kramer HSD 检验

使用 Hsu 的 MCB 检验，与最佳组比较

Dunnett 检验，与控制组比较

等价性检验

非参数检验

方差齐性检验

功效的详细信息

匹配模型分析

比较环的详细资料


启动平台

从分析菜单或工具栏中选择以 X 拟合 Y 或者单击“JMP 起始页”的基本选项卡上的单因子按钮之后，您首先会看到如下所示的“启动”对话框（如上一章"二元散点图和拟合"所述）。通过“单因子”角色对话框可以选择区组。

下图使用了止痛剂.jmp 数据集。

区组变量可用于指定构成双因子分析（无交互作用）的第二个因子。如果具有区组变量，则分析将需要平衡数据并按组单元格使每个区组中的计数相等。

“以 X 拟合 Y”单因子方差分析平台

在将所需列指定为响应变量和因子变量并单击确定之后，选定的变量 x 与 Y 的每个组合均会得到一个单独的分析。

下个实例中的数据在止痛剂.jmp 样本数据表中。

单因子方差分析图

连续变量关于记名/保序变量分析图将会沿竖直方向显示每个因子 (X) 值响应点的分布（"连续变量关于记名/保序变量图"）。有时，不同的 x 值也称作水平。基本拟合方法是计算每组内的响应均值。如果假定所有组中的组响应方差都相同，则单因子方差分析将会检验这些组的均值是否相等。

连续变量关于记名/保序变量图

简单实例

假设上面的实例显示的是使用名为 A、B 和 C 的三种药物记录的疼痛水平评分。疼痛水平评分为数值型响应 Y，三种药物为分类型因子 X 的水平。“单因子”平台将会查看组均值的差异，并执行单因子方差分析，以确定它们是否有显著差异。

"连续变量关于记名/保序变量图" 中的初始散点图表明某一药物的评分始终低于其它药物。此外，x 轴刻度并不是等间隔的，它与每个组中的评分数（观测值个数）成比例。

通过“单因子”标题栏上平台菜单中的均值/方差分析/t 检验命令可以对止痛剂数据执行方差分析，同时还能自动显示置信区间均值菱形，如"带均值菱形的连读关于记名/保序散点图" 所示。（请注意，如果只有两个水平，均值/方差分析将显示为均值/方差分析/t 检验，并将合并的 t 检验添加至输出。

穿过菱形的直线代表组均值。每个菱形的垂直范围代表每个组的 95% 置信区间。稍后，"均值菱形和 x 轴成比例"一章将详细介绍均值菱形。

带均值菱形的连读关于记名/保序散点图

方差分析的结果显示在散点图下面的报表中，其中包括三个表（如"单因子方差分析报表" 所示）。

单因子方差分析报表
  • “拟合汇总”表提供有关分析的全面汇总信息。
  • “方差分析”表提供包含指明评分组均值之间是否存在差异的概率的标准方差分析表。请注意，p 值 > F（p 值）为 0.0053，这是表明组间存在显著差异的最直观证据。
注：如果只有两个组，则方差分析表还会给出 t 检验。
  • “单因子方差分析均值”表提供分类因子每个水平的均值、样本大小及标准误差。

您可以继续通过交互式命令来研究数据，如进行多重比较、非参数分析以及其他感兴趣的检验。


单因子平台布局

"平台命令和显示选项" 是可通过散点图顶部标题栏中的弹出式菜单图标访问的命令和选项示意图。选择平台分析命令，JMP 就会启动显示选项，以在图形显示中添加更多元素。例如，通过分位数命令可以添加箱型图；通过均值/方差分析/t 检验命令可以添加均值菱形；通过均值/标准差/标准误差命令可以添加误差条和标准差标记；通过比较均值命令可以添加比较环。

平台命令和显示选项

下面将简要介绍一下平台命令。稍后将会在本章中介绍平台命令及其相关显示选项的详细资料和实例。

平台命令

通过散点图顶部标题栏中的弹出式菜单图标可以显示平台命令和选项，如"平台命令和显示选项" 所示。选择某个平台命令之后，JMP 会自动显示其对应的显示选项。但是，您也可以随时撤消选定的任何显示选项。

分位数
显示“分位数”表，其中会列出每个组的以下分位数：0%（最小分位数）、10%、25%、50%（中位数）、75%、90% 和 100%（最大分位数），同时还可以从显示选项菜单中激活箱型图。有关更多信息，请参阅"分位数与箱型图"。
均值/方差分析/合并的 t
拟合每个组的均值，并执行单因子方差分析，以检验均值之间是否存在差异。其中将生成三个表：汇总表、单因子方差分析表，以及列出使用合并的误差方差估计计算得出的组频数、均值和标准误差的表。如果只有两个组，则还会给出 t 检验。通过此选项可以激活均值菱形显示选项。
均值与标准差
拟合每个组的均值，但这里使用每个组内计算得出的标准差，而不是使用用于计算均值标准误差的合并标准差来估计。此命令可显示均值直线、误差条和标准差线显示选项。
t 检验
生成 t 检验报表，其中假设方差不相等。否则，此报表将与如"t 检验表" 所示的报表相同。
比较均值
其子菜单可以提供以下四种多重比较方法，用于比较各个组均值集。有关这些比较均值选项的详细资料和实例，请参阅"多重比较"和"比较环的详细资料"两部分。
配对比较，学生氏 t 检验将会显示一个包含组均值所有组合的学生氏 t 统计量表，并可激活比较环显示选项。
所有成对检验，Tukey HSD 将会给出一个组均值的 Tukey-Kramer HSD（可靠显著差异）比较表，及其对应的比较环。
与最佳组比较，Hsu MCB 检验将会给出一个组均值与最佳（最大或最小）组均值之间的 Hsu MCB（与最佳组进行多重比较）比较表，及其相应的比较环。
与控制组比较，Dunnett 检验将会给出一个组均值与指定的控制组之间的 Dunnett比较表，及其相应的比较环。
非参数
其子菜单可以提供以下三种组均值的非参数比较方法。有关统计详细资料，请参阅"非参数检验"。
Wilcoxon 检验将会给出Wilcoxon 秩和检验（如果只有两个组）和 Kruskal-Wallis非参数单因子方差分析（如果有多个组）。请注意，Wilcoxon 检验等同于 Mann-Whitney U 统计量。
中位数检验将会显示双样本中位数检验或 k 样本（Brown-Mood 中位数检验）来比较组均值。
Van der Waerden 检验将会显示 Van der Waerden 检验来比较组均值。
不等方差
命令将会给出一个包含四个检验（用于检验组方差是否相等）的表：O'Brien 检验、Brown-Forsythe 检验、Levene 检验和 Bartlett 检验。如果各个组的方差不相等，则不满足一般的方差分析假设，方差分析 F 检验无效，此时将首选 Welch 方差分析。有关这些统计检验的详细资料，请参阅"方差齐性检验"。
等价性检验
检验差异是否小于阈值。
功效
提供统计功效的计算以及有关给定假设检验的其它详细资料。有关功效计算的信息，请参阅"功效的详细信息"。另外，“功效详细信息”对话框和报表与使用模型拟合命令启动的通用拟合平台中的对话框和报表相同。在"标准最小二乘：估计透视"一章中可以找到有关功效计算的详细资料和实例。
设定 Alpha 水平
其子菜单允许您从最常用的 alpha 水平中进行选择或者通过选择其它选项来指定任意水平。更改 alpha 水平将会导致重新计算所有置信限、调整图上的均值菱形（如果显示），以及修改报表中置信水平的上限值和下限值。
正态分位数图
显示变量 x 每个水平的叠加正态分位数图。此图将会显示分类因子 x 每个水平的均值差异（垂直方向）和方差（斜率）。
正态分位数图具有以下附加选项：
标绘实际值对分位数图将会生成一个分位数图，其中 y 轴代表响应变量，而 x 轴代表分位数。此图将会给出在分类因子 X 的每个水平内计算得出的分位数。
标绘分位数对实际值图只是将 x 轴与 y 轴反过来，如此处所示。
拟合直线将会绘制变量 x 每个水平的对角参考线。
概率标签将会在“分位数对实际值”图的右轴和“实际值对分位数”图的顶轴上显示概率。
CDF 图
将在“单因子”报表中标绘所有组的累积分布函数。"单因子 CDF 图" 所示为大班数据集变量身高（指定为变量 Y ）和性别（指定为变量 X ）的原始分析以及 CDF 图。单因子分析中变量 x 的水平显示为不同的曲线。单因子分析中的 y 值是 CDF 图中的水平轴。
单因子 CDF 图
匹配列
让您可以通过指定匹配变量来执行匹配模型分析。匹配列命令适用于单因子分析中的数据来自于匹配（成对）的数据，而不同组中的观测值也来自于同一个对象的情况。匹配列命令可以激活显示线条显示选项来连接匹配点。如果不需要它们，您可以关闭线条。有关详情和实例，请参阅"匹配模型分析"。
保存
其命令子菜单可以将以下数量另存为当前数据表中的新列：
保存残差可以保存由因子变量每个水平内的响应变量减去响应变量的均值计算出的值。
保存标准化值可以保存因子变量每个水平内计算得出的响应变量的标准化值。此值等于每个水平内的中心化响应除以标准差。
保存正态分位数可以保存分类因子变量每个水平内计算得出的正态分位数值。
保存预测值可以保存因子变量每个水平的响应变量的预测均值。

显示选项

您可以通过使用显示选项在散点图中添加或移除元素。请注意，屏幕上只会显示相关的菜单项。因此，无论在哪种情况下，您都不会看到所有的菜单项。

所有图形
显示或隐藏所有图形。
点
显示散点图上的数据点。
箱型图
显示每个组的离群值箱型图。
均值菱形
绘制通过每个组均值的水平线，与其 x 轴成比例。

均值菱形的顶点和底点分别代表每个组的 95% 置信区间的上限和下限。

均值直线
绘制每个组的均值直线。
均值置信区间线
在 95% 置信区间的上限和下限处绘制线条。
均值误差条
使用大标记标识每个组的均值，同时在位于均值上下一个标准误差处显示误差条。
总均值
在散点图上绘制变量 Y 的整体均值。
标准差线
在位于每个组的均值上下一个标准差处显示虚线。
比较环
显示在平台菜单中选择的多重比较方法计算得出的比较环。
连接均值
使用直线连接组均值。
X 轴成比例
使 x 轴上的间隔与每个水平的样本大小成比例。
点的散布
在区间的宽内散布数据点。
点的跳动
添加随机水平跳动，以便您可以查看叠加在同个 y 值上的点。点的水平调整范围介于 0.375 至 0.625 之间并呈 4*(Uniform - 0.5)5 分布。
匹配线
连接使用匹配列命令选择的匹配点。
匹配虚线
使用虚线连接表中缺失单元的单元格均值。线条端点的值可以使用双因子方差分析模型求出。
直方图
在主图右侧绘制并列的直方图。


分位数与箱型图

从平台弹出式菜单选择分位数选项，“分位数”表和离群值箱型图就会自动显示在屏幕上。但是，您可以随时通过使用或不使用平台命令或其它相关显示选项来显示或隐藏它们。

“分位数”表将会列出响应变量每个水平的选定百分位数，如下所示。中位数为第 50 个百分位数，第 25 个百分位数和第 75 个百分位数称作四分位数。

使用箱型图选项可以将并列的离群值箱型图叠加在每个因子组上，如"离群值箱型图" 所示。箱型图将会汇总每个因子水平的点分布。箱的末端位于 25% 和 75% 分位数。四分位数之间的差即四分位数之间的距离。穿越箱型图中间的横线确定了样本值的中位数。每个箱型图都有一些从两端伸展出来的线条，一般称作须。这些须从箱型图的端点扩展出去，一直到达位于通过以下公式计算得出的距离内的最远数据点：

 上四分位数 + 1.5*(四分位间距)。
 下四分位数 - 1.5*(四分位间距)。
离群值箱型图


单因子方差分析与 t 检验：表与图

单因子方差分析主要用于分析和检验响应中的部分总变异是否由因子组之间均值响应的差异引起的。方差分析方法将会计算每个组的均值以及每个点与组均值之间的距离的平方和。然后，它会将这些平方和合计（求和），从而得出无法通过响应分组方式计算出来的总变异估计。通过将总响应变异减去此残差可以确定方差分析模型中解释的变异量。

利用均值/方差分析/t 检验命令可以执行方差分析（"单因子方差分析报表"），同时还会将结果显示在此处显示的一组表中。请注意，如果只有两个水平（就像性别一样），则输出将包括一个以等方差为假设的 t 检验表。通过使用不等方差的 T 检验命令可以得出不等方差的 t 检验。

每个表均有一个展开按钮可用来打开或关闭它们。您可以使用“首选项”来更改默认布局，以显示所需的表。

拟合汇总表

“拟合汇总”表给出单因子方差分析的汇总，并会列出以下量：

R 平方
度量通过将均值与每个因子水平拟合得出的变异比例。剩余的变异将归为随机误差。如果拟合组均值时考虑了所有没有误差的变异，则 R 平方的值为 1。如果 R 平方的值为 0，表明该拟合作为预测模型与整体响应均值一样。如果使用模型“方差分析”表中的数量，则所有连续响应拟合的 R 平方的计算方法始终如下：
注：R 平方也称为决定系数。
调整 R 平方
通过在计算中使用自由度，调整 R 平方使它在具有不同参数个数的模型中更具可比性。它是均方比而不是平方和比，计算方法如下：
其中误差的均方可在“方差分析”表找到，C. 合计的均方的计算方法为 C. 合计平方和除以给出的“方差分析”表。
均方根误差
估计随机误差的标准差。它是“方差分析”表中误差均方的平方根。
响应均值
响应变量的整体均值（算术平均数），是基本模型的预测响应。
观测值
用于估计拟合的观测值个数。如果使用了权重，则它为权重和。

t 检验表

如果分析中只有两个 x 水平，则除了“方差分析”表中给出的 F 检验之外，JMP 还会执行两次 t 检验。

t 检验表

t 检验表给出等方差假设的以下量：

差
给出两个 x 水平之间的估计差、此差的标准误差以及差的 95% 置信区间。
t 检验
给出 t 检验值。
DF
给出用于 t 检验的自由度。
p 值 > |t|
给出与 t 检验关联的 p 值。

报表右图显示了比较两个水平的差值（红线）。

注：要在假设方差不相等的情况下执行 t 检验，请从平台菜单中选择不等方差的 T 检验。

方差分析表

“方差分析”表会将样本的总变异划分成多个成分。均方成分的比率构成了 F 比率，此比率评估了模型拟合的有效性。如果与 F 比率关联的概率较小，则此模型从统计角度看是比整体响应均值更好的拟合。

“方差分析”表给出以下量：

来源
列出变异的三种来源：模型来源（如实例中的性别）、误差和 C. 合计（校正后的总和）。
DF
记录每个变异来源的关联自由度（简称 DF）。
对于模型计算中使用的每个参数估计，JMP 均会从它的非缺失值总数 N 中减去自由度。例如，均值参数的估计用于计算样本总变异。因此，C. 合计行中显示的 DF 是从观测值总数中减去 1 之后得出的值 (32)。总自由度将划分成（分为）模型（性别）项和误差项。
如果因子有 k 个水平，则 k - 1 自由度用于计算归为方差分析模的变异。本实例中有两个记名型性别水平，因此产生一个模型自由度。
误差自由度是 C. 合计自由度与模型自由度的差。
平方和
记录每个变异来源的距离平方和（简称 SS）。
合计（C. 合计）在本实例中，整体响应均值中每个响应的平方和为 338.57。C. 合计平方和是用于与其它所有模型进行比较的基本模型。
在本实例中，每个点与各自组均值之间的距离平方和为 238.679。它是在拟合方差分析模型后未解释的剩余误差（残差）SS。
合计 SS 减去误差 SS (99.895) 即为归为模型的平方和。这样，您就可以知道模型解释了多少的总变异。
均方

等于平方和除以其关联自由度。

在本实例中，模型均方为 49.947。它用来估计误差的方差，但是只能在假设组均值相等的前提下才能估计。
在本实例中，误差均方为 7.96。它用来估计与模型均方无关的误差项的方差，并且不受任何模型假设的约束。
F 比率
等于模型均方值除以误差均方。如果“组均值相等”（也就是组均值之间不存在任何实际差异）的假设为真，误差均方和模型均方均可用于估计误差方差。它们的比率呈 F 分布。如果方差分析模型导致合计中的变异显著减少，则 F 比率将高于期望值。
p 值 > F
是指在拟合组均值时考虑的变异与使用整体响应均值时的变异一样的情况下，偶然获得比计算值大的 F 值的概率。如果观测的显著性概率等于或小于 0.05，一般可以证明使用方差分析模型来拟合数据更适合。

如果指定了“区组”列，则 JMP 会修改报表，以显示“区组”贡献，同时还会显示一个区组均值附加报表。

注：通过“方差分析”表上的弹出式命令功效可以访问 JMP 功效详细信息工具，从而您可以查看分析功效。

单因子方差分析均值表

“单因子方差分析均值”表汇总了记名因子或保序因子每个水平的响应信息。

“单因子方差分析均值”表给出以下量：

水平
列出保序变量或记名变量的值，用于命名或说明拟合每个组均值时使用的类别。
数值
列出用于计算每个组均值估计的观测值个数。
均值
列出每个组的均值响应（样本均值）的估计。
标准误差
列出组均值标准差的估计。估计此标准误差时，假设每个水平的响应方差相同。标准误差等于“拟合汇总”表中的均方根误差除以用于计算组均值的值的个数的平方根。
95% 下限与 95% 上限
列出组均值 95% 置信区间的下限和上限。

均值菱形和 x 轴成比例

均值菱形的图形显示了样本均值和 95% 置信区间，如"“均值菱形”选项和“X 轴成比例”选项" 中的图形所示。横穿菱形的直线代表组均值。每个菱形的垂直范围代表每个组的 95% 置信区间。组均值上下还会绘制出叠加标记 [image] 。对于样本大小相等的组来说，重叠的标记表明在 95% 置信水平上，两个的组均值没有显著差异。

如果 X 轴成比例显示选项有效，则每个组沿 x 轴的水平范围（菱形的水平大小）将与变量 x 每个水平的样本大小成比例。由此得出，菱形越窄，通常就越高，这是因为数据点越少，生成的组均值估计就越不精确。

计算置信区间时假设所有观测值的方差都相等。因此，置信区间（菱形）的高度与组中观测值个数的平方根的倒数成比例。

从平台菜单选择均值/方差分析/t 检验选项之后，均值菱形会自动显示出来。但是，您可以随时通过均值/方差分析/t 检验命令或其它有效的显示选项显示或隐藏它们。

“均值菱形”选项和“X 轴成比例”选项

以下部分说明这些平台选项及其相关显示选项。

均值直线、误差条与标准差线

从显示选项子菜单选择均值误差条之后，散点图将在每个组的均值处显示一条线，同时在每个组均值上下一个标准误差处显示误差条。如果还选择了标准差线选项，则在组均值上下一个标准差处还会看到虚线（如图所示）。

选择均值/标准差/标准误差平台选项之后，均值线、均值误差条和标准差线显示选项就会自动出现在屏幕上。但是，通过使用平台命令或其它的显示选项，您也可以随时显示或隐藏它们。


多重比较

可用来检验组均值间差异（多重比较）的方法有很多种，这些方法定量刻画检验得方式不同，以适应不同类型的多重比较。以 X 拟合 Y 可以自动生成标准的方差分析，并可根据需要提供以下四种多重比较检验：

配对比较，学生氏 t 检验使用学生氏 t 检验计算各个成对比较。该检验的工作量取决于各个比较。如果您进行了多次成对检验，则推论之间不存在保护，因此假设检验中的 alpha 大小（第一类）误差率也高于单个检验的误差率。

所有成对检验，Tukey HSD 给出一个检验，该检验的工作量取决于均值中的所有差异。这就是 Tukey 或 Tukey-Kramer HSD（可靠显著差异）检验 (Tukey 1953, Kramer 1956)。如果样本大小相同，则该检验为精确 alpha 水平检验；如果样本大小不同，则为保守检验 (Hayter 1984)。

与最佳组比较，许宝碌 MCB 检验检验均值是否小于未知的最大值（或者是否大于未知的最小值）。这就是 Hsu MCB 检验 (Hsu 1981)。

与控制组比较，Dunnett 检验检验这些均值与控制组的均值是否有差异。这就是 Dunnett 检验 (Dunnett 1955)。

上述四种多重比较检验即是 Hsu (1989) 为以下三种情况推荐的 5 水平检验：MCA（适于所有配对的多重比较）、MCB（与最佳组进行多重比较）和 MCC（与控制组进行多重比较）。

如果指定了“区组”列，则将对为区组均值调整的数据执行上述多重比较方法。

组均值的直观比较

每次多重比较检验开始时都会给出比较环图，它是组均值比较的直观表示。图的后面还有一个显示均值比较的表。"组均值的直观比较" 显示了将比较环与其各自组均值的置信区间对齐以进行学生氏 t 比较的过程。其它比较检验可以加宽或缩短环的半径。

每个菱形上均会显示叠加标记，其计算公式为（组均值 ± 置信区间）。如果某个菱形中的叠加标记比另一个菱形中的叠加标记更加接近该菱形的均值，表明在 95% 置信水平处，这两组并没有差异。

组均值的直观比较

您可以通过检查比较环的交叉情况，来直观地比较每对组均值。外交叉角可以告诉您组均值是否有显著差异（请参阅"交叉角与显著性"）。有显著差异的均值环路要么不交叉，要么略有交叉，因此外交叉角小于 90 度。如果环的交叉角大于 90 度或者它们嵌套在一起，表明均值没有显著差异。

交叉角与显著性

如果交叉角接近 90 度，您可以通过单击比较环以高亮度显示它，来验证均值是否有显著差异。高亮度显示的环使用粗实线表示。利用红色细线表示的环所代表的均值与高亮度显示的没有显著差异（请参阅"高亮度显示比较环"），灰色粗线条的环代表那些与高亮度显示环的均值有显著差异的。要撤消选择环，请单击图形中环外的任意位置。

高亮度显示比较环

有关比较环的更多信息，请参阅"比较环的详细资料"。

另外，均值比较报表包含多个可自定义的选项。上述所有方法均使用均值的合并方差估计。

置信分位数
显示用于置信区间的 t 统计量或其它对应的分位数。
差矩阵
显示包含所有均值的差的表。
LSD 阈值矩阵
输出的结果是一个矩阵，各元素的值表示比较的差异是否被认定为显著的。
连接字母报表
显示传统字母编码报表，用不同的字母表示均值有显著差异。
顺序差报表
按排序顺序显示所有正差及其置信区间。对于 学生氏t 比较和 Tukey-Kramer 比较，“有序分”报表显示在文本报表下。下面的报表来自金鱼藻.jmp 数据表。
顺序差报表
此报表将按从高到低的顺序显示差以及叠加在图上的置信区间范围。不完全包含其对应条形柱的置信区间彼此有显著差异。
详细比较报表
给出每次比较的详细报表。每个部分均会显示水平之间的差异、标准误差和置信区间、t 比率、p 值以及自由度。说明该比较的图显示在每个报表的右侧。

在不同的比较检验中，这些命令的可用性也不同。对于学生氏 t 检验，所有选项均可用。对于 Tukey HSD 检验，除了详细比较报表外，所有选项均可用。许宝碌 MCB 检验和 Dunnet 检验，只有差矩阵、置信分位数和 LSD 阈值矩阵可用。

配对比较的学生氏 t 检验

利用配对比较，学生氏 t 检验命令可以为每对组水平执行学生氏 t 检验，而且只会检验单个比较。此处的实例是体重对年龄的单因子布局，数据来自大班样本数据表。它是带有比较环的组比较，比较环可用于说明所有可能的 t 检验。

均值比较方法可用于查看均值的实际差异是否大于显著差异。此差异称作 LSD（最小显著差异）。LSD 项既可用于学生氏 t 区间，也可用于带区间的内容，以便进行其它检验。在比较环图中，环中心之间的距离代表实际差异。LSD 是指环交叉形成直角时的距离。

"学生氏 t 检验的均值比较" 显示了均值比较报表，其中学生氏 t 比较使用了默认选项（置信分位数、LSD 阈值矩阵、连接线报表以及顺序差报表）。

"学生氏 t 检验的均值比较" 所示的 LSD 阈值表中的值是指绝对差与有显著差异的 LSD 之间的差。如果这些值为正，将认为差异显著。最大差异一般位于右上角和左下角，非显著差异一般在表对角线的下面。

学生氏 t 检验的均值比较

适于所有比较的 Tukey-Kramer HSD 检验

利用 Tukey-Kramer 检验，您可以保护所有配对组合的显著性检验，而且 LSD 区间会远远大于学生氏 t 的成对 LSD。从图形角度来说，比较环会变得更大（如下所示）；因此，差异较不显著。

"使用 Tukey HSD 执行的均值比较" 显示了 Tukey 的 HSD 报表，其中使用了默认选项（置信分位数、LSD 阈值矩阵、连接线报表以及顺序差报表）。Tukey-Kramer LSD 阈值矩阵显示了均值的实际绝对差减去 LSD（显著差异）之后的值。为正值的配对有显著差异。由于表头顺序是按均值排序的，因此显著差异一般位于表的右上角或对称的左下角。

使用 Tukey HSD 执行的均值比较

对角线附近的值一般是负值，因为它们的均值比较接近。q*（显示在“LSD 阈值矩阵”表上方）是指用于调节 LSD 的分位数。在计算角色方面它相当于学生氏 t 统计量。

使用 Hsu 的 MCB 检验，与最佳组比较

Hsu 的 MCB 检验用于确定是否可以拒绝某个均值作为多个均值中的最大值或最小值。通常情况下，按每个均值与未知最大均值之间差的置信区间来表示 Hsu 的 MCB。在此处，为了与 JMP 中其它的方法和图形表示保持一致，将按 LSD（最小显著差异）来表示此检验。

如果一个均值与其上的另一个均值之间的间隔大于 LSD，则可以将此均值视为显著小于最大值。每个均值用于调节 LSD 的分位数并不相同。从图形角度讲，比较环方法也不适用，因为必须根据要检验的均值重新调节环（除非样本大小相等）。图形会使用显示的最大分位数值来绘制环。如果环路上面还有另一个环，表示两个均值有显著差异。否则，请检查报表以查看此均值是否显著小于最大值，或单击它的环以查看高亮度显示的差异。

总之，您可以得出如下结论： 如果某个均值

  • 上面有与它显著间隔的均值，则不能将它视作最大值。
  • 下面有与它显著间隔的均值，则不能将它视作最小值。
  • 显著位于其它所有均值的上面，则可将它视作最大值。
  • 显著位于其它所有均值的下面，则可将它视作最小值。

注：MCB 未视作最大值或最小值的均值也就是未包含在潜在的最大或最小均值（Gupta (1965) 选定子集）中的均值。

"Hsu 的 MCB 默认报表" 所示为均值比较报表，其中 Hsu 的 MCB 比较使用了默认选项（置信分位数和 LSD 阈值矩阵）。

下面看一下显示的每个均值的 LSD 阈值矩阵中的列。对于最大值报表，列中显示的是行均值减去列均值再减去 LSD 之后的值。如果某列具有正值，表示这些行的均值显著位于列均值的上方，因此列均值显著地非最大值。

最小值报表也是如此，如果某列具有负值，表示这些行的均值显著位于列均值的下方，因此列均值显著地非最小值。

Hsu 的 MCB 默认报表

Dunnett 检验，与控制组比较

Dunnett 检验主要是将一组均值与控制组的均值加以比较。它生成的 LSD 介于学生氏 t 和 Tukey-Kramer 检验之间，因为它们的大小可以防止出现比较中间的数。

要进行 Dunnett 检验，您必须首先高亮度显示均值图上的某个行或点，以将该组标识为控制组。JMP 将找到的第一个高亮度显示行所标识的组设置为控制组。如果没有高亮度显示的行，JMP 将显示一个对话框，使您可以选择一个组作为控制组。

Dunnett 检验的比较环，如"学生氏 t 检验和 Dunnett 检验的比较环" 所示。其中高亮度显示的是控制组（年龄等于 12）。其它均值的显著性将按颜色和线型进行编码。从图形角度讲，如果某个均值的环与控制组环分隔，或者至少是交叉之后形成的交叉角小于 90 度，则该均值与控制组均值有显著差异。

学生氏 t 检验和 Dunnett 检验的比较环

在 Dunnett 报表中将会显示 [image] 分位数，它的使用方式与学生氏 t 统计量类似。"Dunnet 检验的默认报表" 所示为 Dunnet 报表，其中使用了选定的默认选项（显示均值比较报表，其中学生氏 t 比较使用了默认选项（置信分位数和 LSD 阈值矩阵））。LSD 矩阵显示了差的绝对值减去 LSD 之后的值。如果某个值为正，表明它的均值与控制组均值的差异远远大于 LSD，因此该均值有显著差异。如果每个组的观测值个数均与控制组相同，则在下面显示的报表中，控制组的值（12 岁为 - 26.596）将为所有比较的 LSD 的负数，且它恰好是分位数值、2 的平方根以及均值的标准误差的乘积。

Dunnet 检验的默认报表

尽管上述四个检验全都可以检验组均值之间的差异，但是结果却不尽相同。"四个多重比较检验的比较环" 对上述数据的均值环进行了比较，同时还将最小组均值与其它均值加以比较。学生氏 t 检验最不保守，它表明三个最小均值并无差异。而其它三个保守的检验表明所有四个组均值均无差异。尽管它们的结果相同，但是比较环的半径以及它们的交叉角仍说明了各个组之间的显著性水平并不相同。

四个多重比较检验的比较环

等价性检验

等价性检验试图确认均值之间并无差异，由于这是不可能的，因此您需要选择一个差阈值（更小的差异被认为实际上是等效性）。要构建的最直接检验将使用差区间两侧的双单侧 t 检验。如果两个检验均被拒绝，表明这些组是等效的。等价性检验命令将会使用这种双单侧检验 (TOST) 方法。

例如，假设您想知道男性与女性的高度差是否小于 6（使用大班.jmp 数据表）。在运行以 X 拟合 Y 命令（其中身高作为 Y 变量而性别作为 X 变量）之后，请选择等价性检验命令。在出现的对话框中输入 6 作为差异的阈值，然后单击确定，则得到如"实际等效性输出" 所示的输出。

实际等效性输出

实际差异为 3.02，检验表明此差 p 值为 0.01。在上述的设定之下您可以断言本问题的差异是 0。


非参数检验

非参数检验可用于检验各个组之间的组均值或中位数是否集中在同一位置。但是，它不需要一般的方差分析中的正态性假设。非参数检验使用响应变量秩的函数，称为秩得分 (Hajek 1969)。

JMP 提供三种非参数检验，用于检验因子水平的分布是否集中在同一位置：

  • Wilcoxon 秩得分是数据的简单秩。Wilcoxon 检验用于误差呈逻辑斯蒂分布情况是最有效的秩检验。
  • 中位数秩得分为 1 或 0，具体取决于秩是大于还是小于中位数秩。中位数检验用于误差呈双重指数分布情况是最有效的秩检验。
  • Van der Waerden 秩得分 = 数据的秩/(1 + 转换成正态得分的观测值个数)，其中观测值的个数是通过求正态分布函数的倒数得出的。Van der Waerden 检验用于的误差呈正态分布情况是最有效的秩检验。

如果因子只有两个水平，则 JMP 将会提供相应双样本检验的正态近似以及单因子检验的卡方近似。"非参数检验使用指导"列出了因子水平数给定时的相应检验。

非参数检验使用指导
命令 | 两个水平 | 两个或多个水平 | 最强大的秩得分检验
非参数 Wilcoxon | Wilcoxon 秩和 | Kruskal-Wallis | 逻辑斯蒂
非参数中位数 | 双样本中位数 | k 样本中位数 (Brown-Mood) | 双重指数
非参数 VW | Van der Waerden | k 样本 Van der Waerden | 正态

如上所示的三个表具有相同的格式并且均会显示以下信息：

水平
列出数据中出现的因子水平。
计数
记录每个水平的频数。
得分和
记录每个水平的秩得分和。
得分均值
记录每个水平的秩得分均值。
（均值 - 均值 0）/标准 0
记录标准化的得分。均值0 是指在零假设情况下期望的得分均值。Std0 是指在零假设的情况下期望的得分和标准差。零假设是指各组的组均值或中位数均位于同一位置。
S
记录双样本检验的检验统计量。JMP 只给出具有两个水平因子的 S 值。
Z
记录 S 检验统计量的正态近似。JMP 只会给出具有两个水平因子的 Z 值。如果只有两个组，则此项的作用与（均值 - 均值0）/标准0 相同。
p 值 > |Z|
是指在两个水平的分布均集中在同一位置的情况下，偶然得到比计算值大的 Z 绝对值的双尾概率。如果观测的显著性概率等于或小于 0.05，一般可以认为两个水平的分布并未集中在同一位置。JMP 只会给出具有两个水平因子的 p 值 > |Z|。对于单尾检验的上限或下限来讲，观测的显著性水平为 p 值 > |Z| 的一半。
卡方
记录单因子检验的检验统计量。
DF
记录与单因子检验关联的自由度。如果因子具有 k 个水平，则检验具有 [image] 自由度。
p 值 > 卡方
是指在因子水平的分布均集中在同一位置的情况下，偶然得到比计算值大的卡方值的概率。如果观测的显著性概率等于或小于 0.05，一般可以认为因子水平的分布并未集中在同一位置。

如果指定了“区组”列，则将对为区组均值调整的数据执行非参数检验。


方差齐性检验

如果各个组的方差不相等，将不满足一般的方差分析假设，方差分析中的 F 检验也就无效。JMP 提供了四种用于检验组方差是否相等的方法，以及一种在组样本方差不相等时有效的方差分析。前三个等方差检验的原理是对为了测量每个组的散布而构建的新响应变量执行方差分析。而第四个检验“Bartlett 检验”与正态分布情况下的似然比检验类似。

  • O'Brien's 检验会构建一个因变量，以使新变量的组均值等于原始响应的组样本方差。对 O'Brien's 变量执行方差分析实际上就是对组样本方差执行方差分析（O'Brien's 1979，Olejnik 和 Algina 1987）。
  • Brown-Forsythe 检验将会给出方差分析中的 F 检验，其中的响应等于每个观测值与组中位数之差的绝对值（Brown 和 Forsythe 1974）。
  • Levene 检验也会给出方差分析中的 F 检验，但其中的响应等于每个观测值与组均值之差的绝对值 (Levene 1960)。
  • Bartlett 检验会将样本方差的加权算术平均数与样本方差的加权几何平均数加以比较。其中，几何平均数始终小于或等于算术平均数；且只有在所有样本方差均相等的情况下，它们才会相等。组方差之间的变异越多，这两个平均数之间的差就越大。JMP 创建了这两个平均数的函数，近似于 χ2 分布（事实上，在某个公式下为 F 分布）。较大值对应于算术平均数与几何平均数之比的较大值，因此也对应于差异较大的组方差。表中显示的 F 值等于 Bartlett 卡方检验统计量除以自由度。Bartlett 检验在违反正态假设的情况下，并不是非常稳健（Bartlett 和 Kendall 1946）。

注：如果只检验了两个组，则将执行适于不等方差的标准 F 检验。其中，F 检验是较大的方差估计与较小的方差估计的比率。F 分布中的 p 值也会加倍，以便成为双侧检验。

“等方差检验”表会显示组均值与总体均值的差以及组均值与中位数的差，同时还会汇总检验程序。

如果等方差检验表明各个组方差有显著差异，则应使用均值的 Welch 方差分析代替“拟合均值”表中的一般方差分析。Welch 统计量基于一般方差分析 F 检验，但是均值已按组均值样本方差的倒数加权（Welch 1951；Brown 和 Forsythe 1974b；Asiribo、Osebekwin 和 Gurland 1990）。

如果只有两个水平，则 Welch 方差分析等同于不等方差 t 检验（t 值是 F 的平方根）。

“等方差检验”表会给出以下量：

水平
列出数据中出现的因子水平。
计数
记录每个水平的频数。
标准差
记录每个因子水平响应的标准差。标准差等于 O'Brien's 变量的均值。如果某个水平只在数据中出现一次，则不会计算标准差。
均值的绝对差的平均
记录响应与组均值的平均绝对差。平均绝对差等于 Levene 变量的组均值。
中位数的绝对差的平均
记录响应与组中位数的绝对差。平均绝对差等于 Brown-Forsythe 变量的组均值。
检验
列出执行的各种检验的名称。
F 比率
记录在每个检验中按下面的公式计算得出的 F 统计量：
O'Brien's 检验会构建一个因变量，以使新变量的组均值等于原始响应的组样本方差。O'Brien's 变量的计算公式如下：
其中，n i 是指第 i 个水平的计数；y i 是指第 i 个水平的平均响应；s i2 是指第 i 个水平的响应样本方差；w 设定为 0.5。
Brown-Forsythe 是方差分析在 [image] 中模型的 F 统计量，其中 y i 是第 i 个水平的中位数响应。如果 z ij 为零，则 JMP 将使用同一个水平中次最小的 z ij 来代替它。这样可以校正观测值个数为奇数的水平中出现假零的情况。
Levene F 是方差分析在 [image] 中模型的 F 统计量，其中 [image] 是第 i 个水平的均值响应。
Bartlett 检验的计算公式如下：
其中 [image] 且
n i 是第 i 个水平的计数；s i2 是第 i 个水平的响应样本方差。Bartlett 统计量呈 χ2 分布。最终的 F 值等于卡方检验统计量除以自由度。
分子自由度
记录每个检验中分子的自由度。如果因子具有 k 个水平，则分子将有 k - 1 个自由度。如果某个水平只在数据中出现一次，则不会使用它来计算 O'Brien、Brown-Forsythe 或 Levene 的检验统计量。在这种情况下，分子自由度等于计算中使用的水平个数减去 1。
分母自由度
记录每个检验中的分母的自由度。对于 O'Brien、Brown-Forsythe 和 Levene 来说，计算检验统计量时使用的每个因子水平均要减去一个自由度。整体均值还要再减去一个自由度。如果因子具有 k 个水平，则分母自由度为 n - k。
p 值 > F
是指在所有水平的方差均相等的情况下，偶然得到比计算值大的 F 值的概率。如果观测的显著性概率等于或小于 0.05，一般可以认为各个水平的方差并不相等。

另外的表给出 Welch 方差分析来检验组均值是否相等（这时允许各组方差不相等）。如果只有两个水平，则此检验等同于不等方差 t 检验。

Welch 方差分析会显示下面的计算结果：

F 比率
计算公式如下：
其中 [image] 、 [image] 、 [image] ，
且 n i 是指第 i 个水平的计数； [image] 是第 i 个水平的响应均值；s i2 是第 i 个水平的响应样本方差。
分子自由度
记录检验中分子的自由度。如果因子具有 k 个水平，则分子将有 k - 1 自由度。如果某个水平只在数据中出现一次，则不会使用它来计算 Welch 方差分析。在这种情况下，分子自由度等于计算中使用的水平个数减去 1。
分母自由度
记录检验的分母中的自由度。分母自由度的 Welch 近似等于
其中 w i、n i 和 u 的定义与 F 比率公式中的定义相同。
p 值 > F
是指在所有水平的均值均相等的情况下，偶然得到比计算值大的 F 值的概率。如果观测的显著性概率等于或小于 0.05，一般可以证明所有水平的均值并不相等。

如果指定了“区组”列，则将对为区组均值调整的数据执行方差检验。


功效的详细信息

执行功效命令之后将会出现“功效详细信息”对话框（"功效详细信息对话框"）。您可以按照以下说明填写，然后单击完成。JMP 会提供统计功效的计算以及有关给定假设检验的其它详细资料。（请注意：实例使用了打印数据.jmp）

  • LSV（最小显著值）是某些参数或参数函数的值，能够生成某个 p 值 alpha。换句话说，您可以知道某个效应在某个 p 值的 alpha 处所表现的显著性小到何种程度。LSV 提供了一种按参数尺度而并不是按概率尺度表示的显著性测量标准。它表明了设计和数据的灵敏度。
  • LSN（最小显著数）是在数据具有相同形式的情况下，能够生成特定 p 值的 alpha 的观测值总数。LSN 定义为将估计方差减至足够小，以达到给定的 alpha、sigma 和 delta 值（分别为显著性水平、误差的标准差和效应大小）的显著性结果而所需的观测值个数。如果您需要更多的数据点才能达到显著性目标，LSN 将告诉您还需要多少。LSN 是指近似产生 50% 功效的观测值总数。
  • 功效是指在给定情况下，显著性达到或低于给定 p 值的 alpha 的概率。它是一个有关样本大小、效应大小、误差的标准差和显著性水平的函数。功效将告诉您试验在给定的 alpha 水平检测到差差（效应大小）的可能性有多大。

注：如果单因子布局中只有两个组，则功效工具计算得出的 LSV 将与多重比较表中显示的最小显著差异 (LSD) 相同。

功效详细信息对话框

对于 Alpha、Sigma、Delta 和数值四列中的每一列，您都可以填写单个值、两个值，或起始值、终止值以及连续值的增量，如"功效详细信息对话框" 所示。您可以对指定值的所有可能的组合执行功效计算。

Alpha (α)
为显著性水平，其值介于 0 与 1 之间，通常为 0.05、0.01 或 0.10。初始值设为 0.05。单击这三个位置之一，然后输入或编辑一个、两个或一串值。
Sigma (σ)
为模型中残差的标准误差。最初这里提供的是 RMSE（均方根误差）的估计。单击这三个位置之一，然后输入或编辑一个、两个或连续值。
Delta (δ)
为原始效应大小。有关效应大小计算的详情，请参阅"标准最小二乘：估计透视"一章中的"效应大小"部分。第一个位置的值最初设定为假设平方和除以 n 之后的平方根（即 [image] ）。单击这三个位置之一，然后输入或编辑一个、两个或连续值。
数值 (n)
为样本大小。最初在第一个位置输入的是实际样本大小。单击这三个位置之一，然后输入或编辑一个、两个或连续值。

单击以下复选框以得到所需的结果。

功效求解
选定此复选框可以求出作为全部四个值 α、σ、δ 和 n 函数的功效（显著性结果概率）。
最小显著数求解
选定此复选框可以求出在 α、σ 和 δ 给定的情况下，达到显著性 alpha 值而预计需要的观测值个数。
最小显著值求解
选定此复选框可以求出能够生成 p 值得 α 所需的参数值或线性检验值。这是 α、σ、n 以及估计标准误差的函数。此功能仅适用于单自由度检验，一般用于单个参数。
调整的功效和置信区间
要回顾考察功效，您可以使用标准误差和检验参数的估计。调整功效是根据非中心参数的无偏估计计算得出的功效。调整功效的置信区间基于非中心估计的置信区间。只能为原始 δ 值计算调整功效和置信限，因为其中存在随机变异。

在填写完对话框后，请单击完成以查看报表底部的计算结果。请注意，对于在“功效详细信息”对话框中输入的两个 δ（效应大小）值，JMP 均会为其计算功效和 LSV。本实例中，这两个差的功效都很高（分别为 0.881 和 0.994）。请注意，每个样本只有 8 个观测值（精确地说是 7.4 个）的相同样本结果已经获得显著性。

如果您在“功效详细信息”对话框中输入了样本大小范围 (n)，则“功效”表中的弹出式菜单将标绘出功效对 n 图。

要计算功效，请使用非中心 F 分布。公式（O'Brien 和 Lohr 1984）如下

Power = Prob(F > F crit, ν1, ν2, nc)

其中

F 分布为非中心 F(nc, ν1, ν2)， Fcrit = F(1 –α, ν1, ν2) 为 F 分布的 1 - α 分位数，自由度为 ν1 和 ν2。
ν1 = r - 1 是分子自由度
ν2 = r(n - 1) 是分母自由度
n 是每组的数量
r 是组数
nc = n(CSS)/σ2 是非中心参数
是校正后的平方和

μg 是第 g 个组的均值

μ 是整体均值

σ2 由均方误差 (MSE) 估计

另外，“功效详细信息”对话框和报表与使用模型拟合命令启动的通用拟合平台中的对话框和报表相同。"标准最小二乘：入门"一章将会详细介绍有关功效计算报表的详细资料和相关统计背景的详细资料。


匹配模型分析

利用匹配列命令可以指定匹配模型分析的匹配 (ID) 变量。匹配列命令适用于单因子分析中的数据来自于匹配（成对）数据，而不同组中的观测值也来自于同一个对象的情况。

这一特殊情况可以导致成对 t 检验。JMP 中的配对平台可以处理此类数据，但是需要将数据整理一下，确保配对在不同的列中而不在不同的观测值中。

匹配列命令具有以下两个功能：

  • 它可以拟合加法模型，其中包括所选择的分组变量（“以 X 拟合 Y”分析中的 x 变量）和匹配变量。它会使用迭代比例拟合算法来执行这一操作。当等效线性模型的速度非常慢且需要大量内存资源而产生数百个对象时，此算法将非常有用。
  • 它会在各个组中的匹配点之间绘制相应的线条。如果多个观测值具有相同的匹配 ID 值，则它会从观测值组的均值处开始绘制线条。

匹配列命令可以激活显示线条选项来连接匹配点。如果不需要它们，您可以关闭线条。

举例来说，假设使用的是配对.jmp 样本数据表中的数据（如"匹配变量实例" 所示）。其中在某段时间（季节）观察了某动物（课题），此处时间是分组变量 x 。该动物行走过的英里数（英里数）为响应变量 Y，它的测量情况与前面所述的测量情况相同。分类数据将堆叠到季节列中，就像匹配列命令期望的一样。

在"匹配变量实例" 中，右图显示了英里数与季节的“以 X 拟合 Y”平台图，其中将课题作为匹配变量。在本实例中，种类和课题的值用于标记每个对象的第一次测量。分析会显示 F 检验 的季节和课题效应。如果只运行两个模型，而且其中一个具有交互作用项而另一个没有，则上述检验等同于使用“模型拟合”平台得到的检验。如果只有两个水平，则 F 检验等同于成对 t 检验。

该功能的另一个用途是在以类似方式转换变量尺度时，绘制平行坐标图。

匹配变量实例


比较环的详细资料

要比较两个均值，一种方法是看看它们的实际差异是否大于它们的最小显著差异 (LSD)。此最小显著差异等于学生氏 t 统计量乘以两个均值的差的标准误差，公式如下：

两个独立均值的差的标准误差是根据下面的关系式计算出来的：

当均值不相关时，这些数量的关系式如下：

这些平方值构成了 Pythagorean 关系式，"两个均值之间差的关系式" 中所示的直角三角形从图形的角度说明了这一关系式。

两个均值之间差的关系式

此直角三角形中的斜边是均值比较的测量标准。如果实际差异大于斜边 (LSD)，并且只有在这种情况下均值才有显著差异。

现在，假设您有两个恰好在边缘上的均值，而且它们的实际差异与最小显著差异相同。接下来画一个三角形，它的顶点是根据垂直尺度测得的均值。另外，再根据每个均值画一个圆圈，以使每个圆圈的直径都等于该均值的置信区间。

t 检验统计量的几何关系

每个圆圈的半径都是该三角形上对应直角边的长度，也就是 [image] 。

请注意，这些圆圈必须在三角形两直角边所构成的直角处相交，因而具有以下关系：

  • 如果这些均值的差恰好是它们的最小显著差异，则每个均值的置信区间圆圈都在直角处相交。也就是说，正切角为直角。

现在，我们讨论一下这些均值的差大于或小于最小显著差异时这些圆圈的交叉情况。

  • 如果这些圆圈交叉形成的外角大于直角，则这些均值没有显著差异。如果这些圆圈交叉形成的外角小于直角，则这些均值有显著差异。外角小于 90 度表示这些均值与最小显著差异相差很大。
  • 如果圆圈不交叉，表明它们有显著差异。如果它们嵌套在一起，则表明它们没有显著差异。"交叉角与显著性" 说明了如何解释比较环。
交叉角与显著性

同一图形方法适用于多个多重比较检验，同时也可替代学生氏 t 检验的其它概率分位数值。


列联表分析

以 X 拟合 Y 平台

“列联表”平台可用于研究受分类因子 X 的值约束的分类响应变量 Y 的分布。当变量 Y 和 X 均是记名或保序建模类型时，“列联表”平台是以 X 拟合 Y 命令的一个特殊情况。在此平台上，保序值与记名值的处理方法没有差别。对于每个 X 和 Y 的组合，此平台均会给出：

  • 马赛克图。
  • 双因子频数（列联表）表，它包含频数、百分比和单元格卡方 (χ2) 信息。
  • “检验”表，它包含 Pearson (χ2) 和似然比 (G 2) 卡方统计量。如果两个变量都只有两个水平，则还会提供 Fisher 精确检验。
  • （可选）Kappa 统计量，当 X 和 Y 具有相同的值集时，它可用于度量一致性。
  • （可选）对应分析图。
  • （可选）Cochran-Mantel-Haenszel 检验，用于检验在对第三个分类划分组后，两个分类变量之间是否存在任何关系。

注：您既可以通过主菜单的以 X 拟合 Y 命令（或工具栏）来启动此平台，也可以通过“JMP 起始页”的基本选项卡上的列联表按钮来启动它。如果您从分析菜单中选择以 X 拟合 Y，JMP 将按相应需要执行分析，此分析适用于您所指定的响应和因子变量的建模类型。如果您使用“JMP 起始页”上的列联表按钮，则“启动”对话框（角色对话框）将需要记名/保序因子和响应变量，它还会询问您是否需要指定其它建模类型。

有关建模类型和数据类型的说明，请参阅《JMP 用户指南》。

目录

启动平台

列联表分析

平台命令

马赛克图

列联表

检验报表

相对风险和风险差

一致性统计量

对应分析

对应分析图

邮件实例

Cochran-Mantel-Haenszel 检验


启动平台

使用以 X 拟合 Y 命令可以在其启动对话框中为已给定因子 (X) 和响应 (Y) 角色的每对列启动报表平台。"二元散点图和拟合"一章介绍启动对话框。

变量 X 和 Y 的每个组合均会生成一个图以及相应的文本报表。平台类型随变量 X 和 Y 的建模类型而有所不同。"列联表中“以 X 拟合 Y”马赛克图" 解释了当 X 和 Y 均为记名或保序列时平台提供的列联表分析。

列联表中“以 X 拟合 Y”马赛克图


列联表分析

当响应和因子均为记名或保序建模类型时，此平台将按频数和比例汇总数据。此信息会为因子 X 的每个水平估计 Y 水平的响应率。

平台命令

  • “列联表”分析标题栏上的弹出式菜单提供了“列联表”平台的命令，其中包括频数表（列联表）、统计检验表（包含相等响应率的卡方检验）、对应分析和 Cochran-Mantel-Haenszel 检验。此外，平台菜单上的显示选项 > 水平马赛克图命令还可以将马赛克图旋转 90 度。
  • 马赛克图具有一些可用于设定颜色和标签的命令，您可以在马赛克图上使用鼠标右键单击来访问它们。
  • “列联表”还有一个可用于切换某些数量显示方式的菜单，您可以从“列联表”外框节点上的红色三角形下拉菜单上选择它。每个命令的具体解释将在下面给出。

马赛克图

双因子频数表可以绘制成马赛克图。马赛克图是指任何分成许多个小矩形且每个矩形的面积与指定变量频数成比例的图。为了计算每个 (X, Y) 比例，JMP 会在每个 x 水平内按水平总数来划分 Y 的计数。此比例将估计每个 (X, Y) 水平的响应概率。马赛克图由 Hartigan 和 Kleiner 在 1981 年提出，而后经 Friendly (1994) 进一步改进。

"列联分析马赛克图" 是大班.jmp 数据表中年龄与性别的马赛克图：

  • x 轴上显示的比例代表男女总数的相对比例。
  • 同样，右 y 轴上显示的比例代表合并水平中每个年龄组的相对比例。
  • 左 y 轴上的尺度代表响应概率，整个轴代表概率 1（全体样本）。

马赛克图相当于条形柱并列的条形图。对于每个性别，每个年龄的比例均垂直划分条形柱。要查看响应概率如何随 X 水平的不同而变化，请比较不同 X 水平内 Y 水平的高度。如果各个响应部分在不同的 X 水平之间水平排列，则响应率相同。

列联分析马赛克图

注：当您单击马赛克图的某个部分时，JMP 会高亮度显示该部分并会选终数据表中对应的行。

在马赛克图上使用鼠标右键单击可以选择以下命令：

设定颜色
打开一个对话框，其中会显示当前指定给各个水平的颜色。要更改任意水平的颜色，请单击第二个颜色列中相应的椭圆，随后出现一个对话框，从中可以选择新颜色。马赛克图的颜色取决于响应列是保序还是记名的，以及是否存在现有的“值颜色”列性质。
您还可以使用其中一个宏命令来让 JMP 计算任意两个水平之间的颜色渐变。如果选择的是一个水平范围（通过在要选择的水平上拖动鼠标或者按住 Shift 键并单击第一个和最后一个水平），则选定点间的梯度命令会对您选择的所有水平应用颜色渐变。终值间的梯度命令会对变量的所有水平应用渐变。
使用这些宏，最实用的方法是显著更改两个端点上的颜色，然后在两个端点之间应用渐变，以便形成渐变外观。
恢复以前的颜色可以撤消所有更改。
如果选择将颜色保存至列复选框，则 JMP 还会在列中添加一个名为值颜色的新列性质。通过从列 > 列信息对话框中查看此性质，您可以进一步编辑颜色。
单元格标签
允许您指定一个要在马赛克图中绘制的标签。其中的选项包括显示计数（每个单元格中的观测值个数）、显示百分比（每个单元格中的观测值百分比）、显示标签（与每个单元格对应变量 x 的水平）以及显示行标签（单元格表示的所有行的行标签）。

列联表

“列联表”可以显示为简单的双因子频数表，如下表。其中，每个因子水平均有对应的行，每个响应水平均有对应的列。表的最右边列显示的是行和，最下面的行显示的是列和，表右下角的单元格显示的是总计。

您可以从“列联表”旁边的弹出式菜单中（或者在表内使用鼠标右键单击）选择以下单元格量：

计数
单元格频数、边际总频数以及总计（全体样本数）。
合计百分比
单元格计数与边际合计占总计的百分比。
行百分比
每个单元格计数占其行合计的百分比。
列百分比
每个单元格计数占其列合计的百分比。
预期值
在独立性假设下，每个单元格的期望频数 (E)。它等于对应行合计与列合计的乘积除以总计。
偏差
等于观测（实际）单元格频数 (O) 减去期望单元格频数 (E)。
单元格卡方值
单元格卡方每个单元格的卡方值，它等于 (O - E)2 /E。

您可以选择或移除任何单元格选项。

检验报表

“检验”报表与连续建模类型数据的“方差分析”表类似，它将显示两个检验，其中所有 X 水平之间的响应水平率均相同。分类数据的负对数似然与连续数据中的平方和作用相同。

当两个分类变量均为响应（变量 Y ）时，卡方统计量将检验它们是否独立。如果将其中的一个变量视作 Y，而 X 是固定的，则卡方统计量将检验变量 Y 在每个 X 水平中的分布是否相同，这就是边际齐性检验。“检验”表中包含以下信息：

来源
列出不确定性的三个来源，分别为模型、误差和 C. 合计。
DF
记录与不确定性的每个来源相关的自由度。
大班.jmp 表中的观测值总数 N 为 40。与 C. 合计关联的自由度为 35，它的计算公式为 N - (r - 1)，其中 r 是指响应水平个数。总自由度分为模型项和误差项。
其中，模型自由度用于计算每个因子水平的响应率，等于 (s - 1)(r - 1)，其中 r 指响应水平个数，s 指因子水平个数。
误差自由度是 C. 合计自由度与模型自由度的差。此值没有多大意义。如果列联表比较稀疏即许多单元格都没有数据，则它将变为负数。
负对数似然
负对数似然，可用于度量拟合和不确定性，度量方法与平方和在连续响应中的方法相同。
C. 合计的负对数似然是指在按固定比率估计每个响应水平的概率时的负对数似然（或不确定性）。它对应于“方差分析”表中的总变异，计算公式如下：
其中
n ij 是指第 i 个因子水平（样本）的第 j 个响应水平的计数，N j 是指第 j 个响应水平的合计，并且 [image] 。请注意，j 是指 x 因子水平。
误差负对数似然（负对数似然）指在模型拟合后计算出来的不确定性。通过使用每个样本单独的观测响应率可以得到此项。对数似然拟合过程最小化此值。它的计算公式如下：
其中
模型负对数似然是 C. 合计负对数似然与误差负对数似然的差异，可用于度量因模型拟合而导致的不确定性的降低。它的计算公式如下：
此值用于构建似然比卡方检验统计量。
R 平方 (U)
归结到模型拟合中的不确定性的部分。它的计算公式如下：
其中使用了“检验”表中的对数似然量。通过拟合全体样本的固定响应率可以得出负对数似然合计。如果 R 平方为 1，表示因子完全可以预测分类响应：如果 R 平方为 0，表示使用此模型来代替固定背景响应率没有收到任何成效。在分类数据分析中，很少出现 R 平方值非常大的情况。
检验
列出假设“每个样本类别中的响应率均相同”的两个卡方统计检验。
似然比卡方检验等于“检验”表中“模型”的负对数似然乘以 2。有些书中使用 G2 来表示此统计量。至于两个负对数似然的差，一个具有整体 - 总体响应概率，一个具有每个 - 总体响应率，它们的公式如下：
其中 [image] 且 [image] 。
许多课本中经常将此公式表达为更简洁的形式：
.
Pearson 卡方是假设“每个样本类别中的响应率均相同”的另一个卡方检验。它等于观测单元格计数与前瞻单元格计数之差的平方和。Pearson 卡方具有以下性质：当样本量大时，频数趋向于正态分布。此卡方统计量的常用形式为：
此处没有进行连续性校正，因为它一般是在 2 x 2 表中进行的。
p 值 > 卡方
列出在响应与因子之间不存在任何关系时，偶然得到比计算值大的卡方值的概率。如果两个变量都只有两个水平，则还会显示单尾检验和双尾检验的 Fisher 精确概率。

2 x 2 表

如果列联表为 2 x 2 表，则还可以使用以下分析：

Fisher 精确检验
会自动执行并显示单尾检验和双尾检验。
相对风险
一个用于显示一个样本与另一个样本的比率之比及其置信区间的命令。
机会比
一个用于显示机会比的命令，置信区间的命令。

相对风险和风险差

您可以使用相对风险和风险差命令计算 [image] 列联表的风险比和风险差。您可以在 Agresti (1990) 的 3.4.2 部分中找到这两种方法的详细资料。

相对风险

在本例中，使用 Sample Data 文件夹中的汽车民意测验.jmp。选择分析 > 以 X 拟合 Y，然后将婚姻状况指定为 Y，将性别指定为 X。如果出现“列联”报表，则从报表的下拉菜单中选择相对风险。

此时将生成一个显示多个选项的对话框。

相对风险对话框

如果您只关注单个响应/因子组合，则可在此处进行选择。例如，如果您在"相对风险对话框" 的对话框中单击了“确定”，则 JMP 将计算相关风险比

如果您要计算所有响应和因子水平组合 ( [image] = 4) 的风险比，则请选定计算所有组合复选框。当您要计算所有组合时，"风险比报表" 将显示此报表。

风险比报表

要查看如何计算相对风险，请检查“相对风险”报表中的第一个条目。

P(已婚|女性)/P(已婚|男性)

您可以从“相对风险”报表上方的列联表中读取这些概率。我们计算的是关于性别的两个水平的概率（与表中各行间的概率不同）。因此，我们将使用行百分比来读取概率：

P(已婚|女性) = 0.6884
P(已婚|男性) = 0.6121

因此，

P(已婚|女性)/P(已婚|男性) = [image] = 1.1248

风险差

风险差（Agresti 1990 中称作比例差）是在每个响应水平的因子水平间计算而得。"风险差报表" 介绍了汽车民意测验实例的计算。

风险差报表

和风险比一样，您可以从相关列联表中读取计算结果。

P(已婚|女性) - P(已婚|男性) = 0.6884 - 0.6121 = 0.0763

一致性统计量

当两个分类变量中具有匹配水平时，一致性统计量命令也可用。此命令会显示 Kappa 统计量 (Agresti 1990)、其标准误差和 Bowker 对称性检验（也称为 McNemar 检验）。以下实例使用的是样本数据表属性量规.jmp 中的评定者 A 和 B。一致性统计量比较高 (0.86)，查看列联表的主对角线可以进一步确信较高的一致性。

作为 n 个对象中的两个独立评级的两个响应变量，如果评定者意见完全一致性，则 Kappa 系数等于 +1。当观测到的一致性超过随机的一致性时，Kappa 系数为正，并且其大小反映了一致性的强度。当观测的随机的一致性小于机会一致性时，Kappa 系数为负。当然这在实际应用中并不常用，Kappa 的最小值介于 -1 和 0 之间，具体取决于边际比例。

细节

与 Kappa 统计量相关的量计算如下：

其中 [image] 且

简单 Kappa 系数的渐进方差使用下面的公式进行估计：

其中 [image] 、 [image] 且

对于 Bowker 对称性检验，零假设是 2 x 2 表中的概率满足对称性（p 12 = p 21 且 p 11 = p 12）。


对应分析

对应分析是一种用于显示频数表中的哪些行或列具有类似模式的图形方法。在对应分析图中，每行和每列均有对应的点。

定义行特征作为行中的计数，除以该行的总计数。如果两个行具有极为相似的行特征，则它们在对应分析图中的点也会非常接近。行点之间距离的平方与卡方距离（用于检验该对行之间的齐性）近似成比例。

由于先前已经以对称方式定义了该问题，因此列特征与行特征相似。行点与列点之间的距离并不重要，但是从原点出发的列和行的方向非常重要，它们的关系对解释该图帮助很大。

对应分析在法国 (Benzecri 1973, Lebart et al.1977) 和日本 (Hayashi 1950) 尤其流行，但是只是在最近才开始在美国 (Greenacre 1984) 流行。

这种方法对于水平个数非常多的表尤其有用，因为在这些表中，很难从表中得到有用的信息。举个对应分析的实例，我们看看 McCullagh 和 Nelder (1989) 中讨论的 Newell 奶酪品尝试验。数据在奶酪.jmp 样本数据表中。此试验记录了 4 种不同奶酪添加剂的 9 种不同响应水平。变量响应具有保序建模类型，其值从 1 到 9，其中 9 代表最好的味道。x 因子为奶酪，频数为频数变量。

您可以立即在马赛克图（"对应分析选项"）中看到分布是不均匀的。但是，很难理解 9 个水平对应的图表。在这种情况下，对应分析有助于确定它们之间的关系。要获得对应分析图，请从“列联表”标题栏上的弹出式菜单中选择对应分析命令。

对应分析选项

对应分析图

对应分析命令首先会显示如"奶酪试验的对应图" 所示的图形，其中以图形的形式显示了对应分析，并将图轴分别标记为 c1 和 c2。您可以按照以下方法来理解这幅图：

  • 较高的响应水平在 c1 轴趋负，在 c2 轴趋正。
  • 中等的响应水平在 c2 轴趋负，在 c1 轴为中性。
  • 最低的响应值在 c1 和 c2 轴均为正。

c1 轴倾向于线性计算响应水平。c2 值表示非中性。根据上述说明，很明显 D 是最受消费者喜爱的奶酷奖得主，然后按降序依次是 A、C 和 B。

奶酪试验的对应图

制表和三维图

在对应分析输出的图中，有些点经常会叠加在一起，因此很难看清所有标签。利用平台下拉菜单中的制表命令可以输出一个同时具有 X 和 Y 标签以及得分的表，因此您可以更好地检查结果。输出表包括一个脚本，它会生成相应的旋转图，以便您可以查看三维对应分析。

奶酪实例的旋转图

我们可以得出以下结论：最突出的成分 c1 通常对应于响应水平，而 c2 则对应于某方面的质量，奶酪 A 和 C 以及奶酪 B 和 D 在这方面是不同的。

对应分析的统计细节

您可以打开“对应分析”图附带的详细资料表，以便查看有关该图的统计信息。

“详细资料”表中显示以下量：

奇异值
列出下面矩阵的奇异值：
其中 P 为计数除以总频数的矩阵，r 和 c 是指 P 的行总和以及列总和，D 是 r 值和 c 值的对角矩阵。
惯量
列出尺度无关表的奇异值平方，反映典型维度中的变异。如果前两个奇异值比较占优，则二维对应分析图将非常近似于表中更高维的关系。
部分
与总惯量有关的惯量部分。
X 变量（奶酪）c1、c2、c3
用于在图中定位点的行值的坐标。
Y 变量（响应）c1、c2、c3
用于在图中定位点的列值的坐标。

邮件实例

以下实例使用电子邮件日志以分析发件人和收件人的模式。"邮件日志数据分析表" 下面显示的是样本数据邮件通信.jmp 的部分列表，变量分别为 When（时间）、From（寄自）和 To（寄给）。

利用记名变量寄给和寄自的以 X 拟合 Y 将生成频数表以及显示在数据表旁边的卡方检验。

邮件日志数据分析表

"邮件日志数据分析表" 中的卡方检验非常显著，表明变量寄给和寄自并不是独立的。查看频数表即可看出它们的明显差异。例如，

  • Jeff 将邮件发送给每个人，但是只接收来自 Michael 的邮件。
  • Michael 和 John 发送的邮件比其他人发送的邮件多。
  • Michael 将邮件发送给每个人。
  • John 将邮件发送给除 Jeff 之外的每个人。
  • Katherine 和 Ann 只将邮件发送给 Michael 和 John。

您可以直观地查看列联表结果以及对应分析。“详细资料”表提供对应分析的结果。

表中的部分列表明，邮件发送模式的变异 (56% + 42%) 量是将寄给组和寄自组的 c1 和 c2 汇总在一起的结果。

c1 和 c2 的“对应分析”图显示了邮件组中的邮件分布模式：

  • Katherine 和 Ann 具有相似的发送模式和接收模式。她们都是将邮件发送给 Michael 和 John，并且接收来自 Michael、John 和 Jeff 的邮件。
  • Jeff 和 Michael 在一个维度中，但是他们具有相反的发送模式和接收模式；Jeff 将邮件发送给每个人，但只接收来自 Michael 的邮件。Michael 则将邮件发送给每个人并且也接收每个人的邮件。
  • John 的模式与其他人都不同。他只将邮件发送给 Ann、Katherine 和 Michael，但却接收每个人的邮件。

通过按照以上实例中的说明标绘 c1、c2 和 c3，您可以考虑典型维度中第三个变量 c3 的效应。

请按以下步骤创建旋转图的邮件三维表：

  1. 在“详细资料”表的寄给部分使用鼠标右键单击（在 Macintosh 中为按住 Control 键并单击），然后选择制成数据表命令来创建 JMP 表。
  2. 创建一个新列，并将“寄给”附加至发件人姓名的后面。为该列指定一个新名称，寄给/寄自。
  3. 在“详细资料”表的发件人部分使用鼠标右键单击（在 Macintosh 中按住 Control 键并单击），然后选择制成数据表命令来创建另一个新的 JMP 表。
  4. 创建一个新列，并将“寄自”附加至收件人姓名的后面。前面将此列的名称指定为您在另一个数据表中使用的名称（寄给/寄自）。
  5. 使用表菜单中的合并命令来附加这两个表并且创建如下所示的表。

现在，使用“旋转图”平台来查看 c1、c2 和 c3。当点投影到 (x, y) 平面上时，模式与之前显示的“对应”图相同。当您按"旋转三个邮件模式对应坐标" 中的方向旋转“旋转图”时，您会清楚地看到 John、Katherine 和 Michael 之间的关系中又出现一个额外的维度：

  • Katherine 只将邮件发送给 Michael 和 John。
  • John 发送给 Michael 和 Katherine 的邮件比发送给其他人的邮件多。
  • Michael 发送给 John 和 Katherine 的邮件比发送给其他人的邮件多。
旋转三个邮件模式对应坐标


Cochran-Mantel-Haenszel 检验

列联表分析平台还提供了 Cochran-Mantel-Haenszel 检验，用于检验在对第三个分类划分组后，两个分类变量之间是否存在任何关系。选择 Cochran Mantel Haenszel 检验命令后，将有一个对话框要求您标识分组变量。

"Cochran-Mantel-Haenszel 卡方检验" 中的实例使用了热狗.jmp 样本数据表。针对类型对口味（未显示）的列联表分析表明，边际显著卡方概率大约为 0.0799。

但是，如果您将蛋白质与脂肪的比进行分层（值 1-5），口味对类型将不会显示任何关系。对它们之间调整后的相关性进行的 Cochran-Mantel-Haenszel 卡方检验生成的概率为 0.857，而与类别的一般关系相应的卡方概率为 0.282。

Cochran-Mantel-Haenszel 卡方检验

Cochran-Mantel-Haenszel 卡方统计量将检验对立假设，即如果您定义了第三个层因子，行变量与列变量之间存在线性关系：

得分的相关性
用于 Y 或 X 为保序的情况。对立假设为“至少一层上的 Y 与 X 之间存在线性关系”。
按列类别列出的行得分
用于 Y 为保序或区间的情况。对立假设为“至少一层上有 r 行的得分均值不相等”。
按行类别列出的列得分
用于 X 为保序或区间的情况。对立假设为“至少一层上有 c 列的得分均值不相等”。
类别的一般关系
检验是否至少有一层的 X 与 Y 之间存在某种关系。


简单逻辑斯蒂回归

以 X 拟合 Y 平台

“逻辑斯蒂”平台将响应类别的概率与连续型变量 x 的预测值拟合。拟合的模型将估计归结到各个 x 值的概率。“逻辑斯蒂”平台是以 X 拟合 Y 命令的记名/保序对连续建模类型时的特殊情况。在此平台中，记名响应和保序响应有以下差别：

  • 记名逻辑斯蒂回归首先估计一组曲线，将归结概率分给各个响应。
  • 保序逻辑斯蒂回归则是建立小于等于给定响应概率的模型。此模型含有估计单个逻辑斯蒂曲线的效应，单个逻辑斯蒂曲线通过平移来生成有序分类的概率。此模型不太常用但是非常简约，建议用于有序响应。

逻辑斯蒂回归具有非常悠久的历史，而且应用极其广泛，例如建立给药 - 响应数据模型和购买 - 选择数据模型。但遗憾的是，许多统计学入门课程中并没有介绍这一相当简单的方法。除了有关逻辑斯蒂回归的课本外（Hosmer 和 Lemeshow 1989），分类统计学中的许多课本也介绍了这一方法。有些分析人员将此方法用于不同的分布函数（正态分布），此时称它为 probit 分析。有些分析人员则使用判别分析来代替逻辑斯蒂回归，因为他们更喜欢将连续变量视作 Y，将分类变量视作 X，然后逆向分析。不过，判别分析需要假设连续数据是呈正态分布的随机响应，而不是固定的回归量。

对“模型拟合”平台中的分类响应来说，简单逻辑斯蒂回归是一种更简单、更直观的常用工具。有关更复杂的逻辑斯蒂回归模型实例，请参阅"记名响应和保序响应的逻辑斯蒂回归"。

注：您既可以通过以 X 拟合 Y 主菜单命令（或工具栏）来启动“逻辑斯蒂”平台，也可以通过“JMP 起始页”的基本选项卡上的逻辑斯蒂按钮来启动它。如果您选择以 X 拟合 Y，JMP 将按具体需要执行分析，此分析适用于您指定的响应和因子变量的建模类型。如果您使用“JMP 起始页”上的逻辑斯蒂按钮，则“启动”对话框（角色对话框）将需要分类响应和连续因子变量，它还会询问您是否需要指定其它建模类型。

目录

启动平台

记名逻辑斯蒂回归

累积逻辑斯蒂概率图

图选项

整体模型检验表

参数估计表

反预测

ROC（接受者操作特征）曲线

机会比

保序逻辑斯蒂回归


启动平台

使用分析菜单（或工具栏）上的以 X 拟合 Y 命令或“JMP 起始页”的基本选项卡上的逻辑斯蒂按钮来启动“逻辑斯蒂”平台。然后，为 x 指定连续因子，为 Y 指定记名或保序响应。变量 X 和 Y 的每个组合均会生成一个图以及相应的文本报表。有关如何使用启动对话框选择列角色的介绍，请参阅"二元散点图和拟合"。

"“以 X 拟合 Y”的逻辑斯蒂回归平台" 所示为简单逻辑斯蒂回归在不同建模类型组合的“以 X 拟合 Y”平台中如何拟合。

“以 X 拟合 Y”的逻辑斯蒂回归平台


记名逻辑斯蒂回归

记名逻辑斯蒂回归用于估计作为因子平滑函数的所选择响应水平的概率。拟合概率必须在 0-1 之间，对于给定因子值，所有响应水平的拟合概率总和必须为 1。

在逻辑斯蒂概率图中，y 轴代表概率。如果有 k 个响应水平，则 k - 1 条平滑曲线会将总概率 (1) 划分给各个响应水平。逻辑斯蒂回归的拟合原则是使与响应事件拟合的概率的负对数和最小化，也就是极大似然。

以下实例使用大班.jmp 样本数据表来解释逻辑斯蒂回归。假设您要推测与已知体重值对应的年龄值。将年龄指定为记名响应，将体重指定为连续因子。逻辑斯蒂回归分析开始时的图如"记名对连续的“以 X 拟合 Y”平台" 所示。左侧 y 轴代表概率，右侧 y 轴上显示的比例代表全体样本中每个年龄组的相对大小。

累积逻辑斯蒂概率图

累积逻辑斯蒂概率图将提供逻辑斯蒂模型拟合内容的完整信息。对于每个 x 值，y 方向上的概率尺度将概率分配到各个响应类别中。概率是通过曲线之间的垂直距离来测量的，而且所有 Y 类别的概率合计为 1。

记名对连续的“以 X 拟合 Y”平台

在"逻辑斯蒂概率图的解释" 中，第一条（最下面的）曲线代表随着体重的变化，属于年龄等于 12 的组的概率。下一条稍高一点的曲线代表属于年龄 ≤ 13 的组的概率。因此，前两条曲线之间的距离为年龄等于 13 时的概率。最上面的曲线与图形顶部的距离代表属于年龄等于 17 的组的概率。请注意，当体重增加时，模型会将更多的概率分配给更大的年龄。当体重等于 180 时，模型会将大部分概率归结于年龄为 17 的组中。

数据标记绘制在它们的 x 坐标上，而 y 的位置将在与该行的响应类别对应的范围内随机跳动。您可以看到有些点将曲线推开，并在它们大量出现的地方形成垂直空间，而在没有数据的地方，它们允许曲线靠得很近。由于已最大化的准则等于模型拟合概率的乘积，因此数据可以推开曲线。拟合会尝试避免使用那些可能会产生较小概率的点，这些点的周围充满拟合曲线。有关计算细节的更多信息，请参阅附录"统计细节"中的"记名响应"。

逻辑斯蒂概率图的解释

如果 x 变量对响应没有影响，则拟合直线为水平直线，而且在连续因子范围内，每个响应的概率均为常数。"表示 X 与 Y 不存在任何关系的逻辑斯蒂概率图" 所示为选定年龄的逻辑斯蒂概率图，其中每个年龄均具有相同的体重分布。体重因子没有预测值。请注意，右侧 y 轴已按此缩小的模型进行划分。

表示 X 与 Y 不存在任何关系的逻辑斯蒂概率图

如果完全可以按因子值来预测响应，则逻辑斯蒂曲线是垂直的。在这种情况下，参数估计将非常大，在回归报表中还会标记为不稳定的。每个因子水平上的响应预测均是确定的（概率为 1），如"表示 X 与 Y 的关系近乎完全的逻辑斯蒂图" 所示。有趣的是，虽然参数模型为了达到完全拟合效果已经分解，但是尽管参数不稳定，拟合概率的效果还是非常好。

表示 X 与 Y 的关系近乎完全的逻辑斯蒂图

记名对连续建模类型平台具有两个文本报表，即“整体模型检验”表和“参数估计”表，它们与"列联表分析"中描述分类模型的表类似。

图选项

您可以从平台的下拉菜单中进入图选项：

显示点
打开或关闭显示点。
线条颜色
允许您挑选图中曲线的颜色。

整体模型检验表

“整体模型检验”表显示模型的拟合效果是否比常数响应概率好。此表与连续响应模型的“方差分析”表类似。它是一个特定似然比卡方检验，用于评估分类模型拟合数据的效果如何。观测概率的负对数和称为负对数似然（负对数似然）。而分类数据的负对数似然的作用与连续数据中的平方和相同。数据拟合模型与等概率模型的对数似然值的差为卡方统计量。此检验统计量用于检验“变量 x 对响应没有影响”这一假设。

R 平方 (U)（有时也己为 R 平方）的值在 0 - 1 之间，其中 1 代表完全拟合，0 表示使用此模型的效果并不比使用固定背景响应率好。在"表示 X 与 Y 的关系近乎完全的逻辑斯蒂图" 中，响应事件的所有概率均为 1，R 平方也为 1。在"表示 X 与 Y 不存在任何关系的逻辑斯蒂概率图" 中，所有拟合直线均为水平直线，R 平方为 0。分类模型中很少出现 R 平方值非常大的情况。如果 R 平方为 1，表示因子完全可以预测分类响应。

“整体模型检验”表中包含以下项：

模型（有时称为“来源”）和 DF，"列联表分析"以前曾经介绍过“整体模型检验”表中的这两项。

负对数似然
度量样本中的变异，有时也称为不确定性：
完全（完全模型）是指拟合模型后算出的负对数似然（或不确定性）。拟合过程包含使用线性模型和逻辑斯蒂响应函数预测的响应率。拟合过程会将此值最小化。
缩减是指按固定背景率估计概率时的负对数似然（或不确定性）。它是指模型没有效应时的背景不确定性。
上述两个负对数似然的差就是因模型拟合而产生的减少量。此值的两倍就是似然比卡方检验统计量。
卡方
“模型的拟合效果与整个样本中的固定响应率一样”假设的似然比卡方检验。它是差模型的负对数似然的两倍。它等于两个负对数似然的差，其中一个具有整体 -总体响应概率，另一个具有每个 - 总体响应率。此统计量有时记为 G 2，计算公式如下：
其中的总和是指所有观测值而不是所有单元格的总和。
p 值 > 卡方
卡方检验的观测显著性概率，一般称为 p 值。它是指偶然得到比计算值大的卡方值的概率。如果此概率小于 0.05，一般判定模型显著。
R 平方 (U)
归结到模型拟合中的不确定性的合计比例。模型拟合的对数似然与使用水平线的对数似然的差是用于验证“因子变量对响应没有影响”假设的检验统计量。R 平方值等于 1 减去此检验统计量与背景对数似然的比。更简单的方法是使用下面的公式来计算：
其中使用了“整体模型检验”表中的量。
观测值
（或权重和）是指计算中使用的全部样本数。

参数估计表

记名逻辑斯蒂模型将拟合 [image] 次逻辑斯蒂比较中每次比较的截距和斜率参数，其中 k 是指响应水平数。“参数估计”表（如下所示）将列出这些估计。每个参数估计均可以单独进行检查和检验，不过一般没有太大的兴趣这么做。

项
列出逻辑斯蒂模型中的每个参数。因子在响应变量的每个水平上均有一个截距和一个斜率项。
估计
列出逻辑斯蒂模型生成的参数估计。
标准误差
列出每个参数估计的标准误差。它们用于计算将每项与 0 加以比较的统计检验。
卡方
给出“每个参数均为 0”假设的 Wald 检验。Wald 卡方等于 [image] 。
p 值 > 卡方
列出卡方检验的观测显著性概率。

反预测

反预测与预测相反，它是根据给定的 y 值来预测 x 值。但是逻辑斯蒂回归中使用的不是 y 值，而是归于任意一个 Y 水平的概率。此功能只有在具有两个响应类别（二元响应）的情况下才能用。例如，在实验室研究中，您可能想要知道多大剂量的毒素可以使一只老鼠的死亡概率达到 0.5。在此例中，对 0.5 进行的反预测称为 LD50，致命剂量对应于 50% 的死亡率。

反预测是指找到与较低响应类别的给定概率对应的 x 值。您可以使用十字准线工具来直观地近似反预测，如下所示。以下实例所示为根据给定身高值预测性别的逻辑斯蒂图。但是，如果您想要知道哪个高度值可以使男女性别具有相等的可能性，可以将水平十字准线放在垂直（性别）概率轴上的 0.5 处，然后将十字准线的交叉点移到预测线上，并读取水平轴上显示的身高值。在本实例中，当学生的身高大约为 61.529 时，男女性别具有相等的可能性。

如果响应只有两个水平，则使用反预测命令可以使您得到准确的反预测值（如"反预测" 所示）。如果变量之间的关系非常紧密，则“反预测”表会显示反预测值的置信上限和置信下限。

另外，“模型拟合”平台还有一个可提供置信限的反预测选项。有关反预测的更多信息，请参阅"标准最小二乘：估计透视"和"记名响应和保序响应的逻辑斯蒂回归"。

反预测

ROC（接受者操作特征）曲线

假设 x 值代表诊断度量，且您想要确定 x 的阈值，而判断在 x 值大于或小于该阈值时，情况是否存在。例如，您可以将血液检查各指标的水平作为诊断检验来预测癌症类型。现在，假设在您更改阈值后，诊断检验可以导致或多或少的假阳性和假阴性。那么，您可以将这些比率标绘在图上。理想的结果是产生极差很小的 x 标准值，但它们能够最好地区分真阴性和真阳性。ROC 曲线可以显示发生转移的速度有多快，从而通过诊断使曲线下的面积最大化。

医学中常用下面两个标准定义：

  • 敏感度，给定 x 值（检验或测量）正确预测情况出现的概率。对于给定 x，错误预测情况出现的概率为 1 - 敏感度。
  • 特定性，检验正确预测情况不出现的概率。

接受者操作特征曲线 (ROC) 是按每个 x 值的敏感度和（1 - 特定性）绘制的图形。ROC 曲线下的面积是用于汇总曲线中包含信息的常用指标。

当您使用二元输出结果进行简单逻辑斯蒂回归时，平台选项会生成该分析的 ROC 曲线。在选择“ROC 曲线”选项后，将有一个对话框要求您指定将哪个水平的规格作为“阳性”。

性别对身高实例的结果如下所示。ROC 曲线将标绘前面描述的概率以便预测性别。

如果检验的预测效果极佳，曲线上将有一个值，整个异常总体都在此值的上面，而所有正常值都在此值的下面。另外，曲线会非常敏感并且穿过网格上的点 (0,1)。ROC 曲线离此理想点越近，它的判别能力越强。没有预测能力的检验将生成一条沿网格对角线方向的曲线（DeLong 等人，1988）。

ROC 曲线是假阳性率与真阳性率之间关系的图形表示。评估这一关系的标准方法是使用曲线下的面积，其显示在该图下面。在图中，黄线呈 45 度角与 ROC 曲线相切。在假设假阴性与假阳性具有类似成本的前提下，此曲线会标记一个非常好的切割点。

机会比

机会比的使用方法与它们在“模型拟合”平台中的使用方法相同。有关详情，请参阅"记名响应和保序响应的逻辑斯蒂回归" 章节中的 "机会比（仅适用于记名响应）" 。


保序逻辑斯蒂回归

如果 Y 为保序建模类型，则需使用改进的逻辑斯蒂回归来执行拟合。等于或低于每个响应水平的累积概率通过曲线来表示。除了向右或向左平移，每个水平的曲线完全相同。

保序逻辑斯蒂模型可以为 r - 1 次累积逻辑斯蒂比较中的每次比较拟合不同的截距，但斜率总是相等的，其中 r 是响应水平数。每个参数估计均可以单独进行研究和检验，不过一般没有太大兴趣这么做。

在适用的情况，用户一般更喜欢使用保序模型而不是记名模型，因为保序模型中要估计的参数比较少。事实上，它非常适用于拟合具有几百个响应水平的保序响应。有关逻辑斯蒂回归模型公式的信息，请参阅附录"统计细节"中的"保序响应"。

为了解释保序逻辑斯蒂回归，假设您想要推测与给定体重值对应的年龄值。在下图中，年龄为保序型变量，体重为连续型变量。您可以按照以前曾经在"记名逻辑斯蒂回归"中介绍过的记名对连续平台的解释方法来解释此平台。

下面显示的保序型变量对连续型变量的“整体模型检验”表与记名型变量对连续型变量分析中的表相同。

有关“整体模型检验”表和“参数估计”表的介绍，请参阅"记名逻辑斯蒂回归"。在“参数估计”表中，平台会估计每个响应水平（除了最后一个）的截距参数，但只有一个斜率参数。截距参数表示响应水平的间距，而且它们始终单调递增。


成对数据

配对平台

“配对”平台可以比较两个响应列的均值。例如，配对的对象可以是治疗前后对同一个对象测量到的血压值。响应相互关联，名为成对 t 检验的统计方法将考虑这种关联。

此平台可以根据均值生成差图，同时为所有三个可选假定提供学生成对 t 检验结果。在简单的重复测量分析中，为两个以上的匹配响应以及在样本间执行检验的分组列提供了其它功能。

目录

简介

分析配对的方法

配对图形

配对平台输出

启动配对平台

分组变量

响应相关性

比较成对 t 检验和独立均值 t 检验

多个 Y 列

成对 t 检验图的情况


简介

“配对”平台可以使用成对 t 检验对两个响应列的均值加以比较。通常，这两个列提供同一个对象在治疗前后的测量值。

如果将成对数据排列在两个数据表列中，则可以使用“配对”平台。如果所有的测量值都位于同一列中，则可以采用另一种方法执行配对分析，相关内容将在后面加以介绍。或者，您可以使用表菜单下的拆分列命令，将测量值列拆分为两个列。

分析配对的方法

成对 t 检验与其它几种方法等效，其中包括：

  • 对于两个响应列，您可以创建第三个列，以便用于计算两个响应列之间的差值。然后通过“分布”平台检验差值列的均值是否为 0。
  • 对存储在同一列（由 ID 列标识）的不同行中的两个响应，您可以执行双因子方差分析。一个因子（列）将确定两个响应，而其它因子将确定对象。您可以对匹配列使用以 X 拟合 Y 单因子平台，或者对区组列使用模型拟合平台。ID 因子检验与成对 t 检验等效。

注：如果是成对数据，请不要执行两组非成对 t 检验。如果没有指定区组或匹配列，请不要将数据堆叠在一列中并对 ID 列使用以 X 拟合 Y 单因子方差分析。这样做将忽略响应之间的相关性，如果响应呈负相关，则会导致检验对效应估计过高；如果响应呈正相关，则会导致检验对效应估计过低。

配对图形

在平台的主要图形中，两个响应的差值位于 y 轴，两个响应的均值位于 x 轴。此图形与两个原始变量的散点图相同，只是被旋转了 45 度。旋转 45 度可以将原始坐标变换为差值和总和。通过重新调整尺度，此图形可以显示差值和均值，如"变换为以总和拟合差值图形相当于旋转 45 度" 所示。

变换为以总和拟合差值图形相当于旋转 45 度

以下实例使用了狗.jmp 样本数据集。假设您需要研究一对名为组织胺0的对数和组织胺1的对数的测量值，它们是在不同时间对同一个对象测量而得。为了通过图形阐明研究方法，狗.jmp 数据表包含了通过公式编辑器新创建的两个列，分别是两个响应列的差值和均值。

现在，通过“二元”平台（以 X 拟合 Y）来观察以组织胺0的对数拟合组织胺1的对数的散点图，以及以均值拟合差的散点图，如"显示旋转的二元图" 所示。请注意，它们的布局在旋转 45 度后是相同的。

显示旋转的二元图

配对平台输出

“配对”平台结合了前面章节中介绍的概念。此图形是以均值拟合差值而生成的散点图，也就是这些列生成的散点图在旋转 45 度后的结果。成对 t 检验与对差值列执行的检验相同。

在图形中，请注意以下内容：

  • 呈 45 度角倾斜的正方形显示了倾斜的原始列散点图框架。
  • 均差显示为水平线，而 95% 置信区间则位于其上方和下方。如果置信区域中的水平线穿过零点，那么 0.05 置信水平的均值差异不会太显著。在本实例中，差值较为明显。
  • 配对的均值的平均值以垂直的线显示。


启动配对平台

要查看前一节所示的结果，请从分析菜单（或工具栏）选择配对，或者单击 JMP 起始页建模选项卡中的配对按钮。然后，请填写此处所示的启动对话框。您必须选择两个或更多响应列。您可以选定一个分组变量，而系统将在分组中分析成对差值。

分组变量

如果配对在不同组中生成不同的均值，那么在启动“配对”对话框时，您可以将该变量指定为 X，分组。如果指定了一个分组变量，平台将估计均值并在对与对之间以及在对中检验两者。

在下面实例中，药剂变量的值 trimeth 和 morphine 被指定为一个分组列。

交互作用
"分组数据的配对分析" 显示了成对数据的分组分析结果。报表中的平均差值列显示了两个成对列之间每个差值组中的行间均值。在此实例中，平均差值是 morphine 组和 trimeth 组的 （组织胺1的对数 - 组织胺0的对数）均值。换句话说，这就是对象内与对象间的交互，或者裂区图与整区的交互。
分组数据的配对分析
主题间
“组间”表中的平均均值报表列中显示了两个成对列之间每个均值组中的行间均值。在此实例中，平均均值是 morphine 组和 trimeth 组的（组织胺1的对数 + 组织胺0的对数）/2 均值。换句话说，这就是对象间或整区效应。
组间
有两种 F 检验可以检验组间值是否存在差异。这些检验与平均差值和平均均值的值对应：
平均差值用于检验响应对间的变化是否与其它组不同。
平均均值用于检验对象的平均响应是否与其它组不同。

如之前的"分组数据的配对分析" 所示，分析正好与简单重复测量分析相关。如果使用“模型拟合”平台的多元方差分析进行重复测量分析（成对列作为两个响应，一个药剂因子），同时指定了重复测量响应函数，您将得到相同的检验结果。

多元方差分析结果如此处所示。针对差值的药剂效应检验是时间*药剂对象内的交互 F 检验。针对均值的药剂效应检验是药剂对象间的 F 检验。

通过使用 EMS 方法，您也可以借助“模型拟合”平台中的随机效应模型获得这些结果。在该情况下，响应必须堆叠在由 ID 列标识的单个列中。

响应相关性

通常，如果响应呈正相关，成对 t 检验将得出一个比独立均值 t 检验更为显著的 p 值。如果响应呈负相关，成对 t 检验得出的结果将不如独立 t 检验显著。如果成对测量值是在不同时间对相同个体测量而得，那么在多数情况下它们都将呈正相关。但是，如果它们表现为竞争性响应，则可能呈负相关。

"旋转前后的正相关表明差值方差较小" 显示了两个响应的正相关如何变成较小的差值方差（y 轴）。如果呈负相关，则椭圆会朝向另一个方向，而 y 轴上旋转图形的方差较大。

旋转前后的正相关表明差值方差较小

比较成对 t 检验和独立均值 t 检验

"比较配对分析和独立 t 检验" 显示了对狗数据的三个 t 检验的结果。配对分析以及将成对列间的差值与 0 比较均得出相同的正确结果。对堆叠数据的独立组进行 t 检验将得出错误的结果，这是因为忽略了响应间的相关性。

比较配对分析和独立 t 检验

多个 Y 列

您可以选择两个以上的配对。配对平台可以通过图形显示对所有可能的成对响应列进行的单独分析。例如，请参阅以下分析排列矩阵：

Y2 与 Y1 | Y3 与 Y1 | Y4 与 Y1
 | Y3 与 Y2 | Y4 与 Y2
 |  | Y4 与 Y3

如果响应数为偶数，“配对”平台将显示提示信息并询问您是否需要执行一系列的配对，而不是所有可能的配对，同时提供以下排列：

Y2 与 Y1 Y4 与 Y3


成对 t 检验图的情况

对于要在新坐标中显示的模式，存在多种编写语句的可能性。"无变化" 至"没有平均移动且正相关，呈下降趋势而不是上升" 中的实例介绍了五种不同的情形及其解释。

无变化

垂直分布范围较小且集中在零点周围。从 Y1 到 Y2 的变化不显著。这是一个原始散点图的高度正相关模型，而且颇具代表性。

显著下移

Y2 的值在所有对象中始终比 Y1 低。

没有平均移动，但存在放大关系

同一对象中两个值的差值变动较小，而均值方差较大。就整体而言，从 Y1 到 Y2 的均值都相同；但就个别而言，较高的值将变得更高，而较低的值将变得更低。

没有平均移动，但存在反向关系

同一对象中两个值的差值变动较大，而均值方差较小。就整体而言，从 Y1 到 Y2 的均值都相同；但较高的 Y1 将获得较低的 Y2，反之亦然。因为这是一个原始散点图的高度负相关模型，但此模型并不常见。

没有平均移动且正相关，呈下降趋势而不是上升

就整体而言，从 Y1 到 Y2 的均值都相同，但较高的值将略微降低，较低的值将略微增高。


模型拟合简介

模型设置对话框

分析 > 模型拟合启动通用拟合平台，在此构建的线性模型将比其它 JMP 统计平台采用的模型具有更复杂的效应。拟合模型显示“模型设置”对话框（有时简称为“拟合模型”对话框），用于定义复杂模型。在此可选择指定的模型效应和误差项，并根据需要在模型设置中添加项或从中删除项。

“模型设置”对话框是统一的启动台，用于各种拟合特点，如：

  • 一个或多个连续响应（多重回归）的标准最小二乘拟合
  • 效应很多但观测值很少的试验数据的筛选分析
  • 逐步回归
  • 记名响应或保序响应的逻辑斯蒂回归
  • 多个连续响应的多元方差分析 (manova)
  • 同时拟合均值和方差的对数线性方差拟合
  • 删失生存数据的比例危险拟合

本章详细介绍了“模型设置”对话框，并定义了用于各种统计分析的报表表面显示选项及保存命令。"标准最小二乘：入门"、"标准最小二乘：估计透视"、"标准最小二乘：探索预测方程"、"标准最小二乘：随机效应"、"逐步回归"、"记名响应和保序响应的逻辑斯蒂回归"和"多重响应拟合"等几章介绍了标准最小二乘，并为每种拟合模型特点提供了详细说明和实例。

目录

模型设置对话框：简易实例

模型类型

响应按钮（Y、权重和频数）

模型效应按钮

宏弹出式菜单

效应属性和变换

变换

拟合特点

其它模型对话框功能

重点选项

运行模型

有效性检验

其它模型设置选项


模型设置对话框：简易实例

模型拟合命令首先显示“模型设置”对话框，如"多重回归时的“模型设置”对话框" 所示。您可以使用此对话框为数据定制模型。“模型设置”对话框为非模式，即除非显式的关闭此对话框，否则它会持续存在。这样就可在关闭窗口前更改模型设置并拟合几个不同模型。

"多重回归时的“模型设置”对话框" 中的实例使用 Sample Data 文件夹中的健身.jmp (SAS Institute 1987) 数据表。这些数据是有氧运动健身研究的结果。摄氧量变量为连续响应变量（因变量）。显示在构建模型效应列表中的骑行时间、骑行时脉搏和静止时脉搏变量都是连续效应（也称为回归量、因子或自变量）。对话框右上方的弹出式菜单显示标准最小二乘，用于定义拟合方法或拟合特点。本章后面将介绍各种拟合特点。

多重回归时的“模型设置”对话框

此标准最小二乘实例具有一个连续 Y 变量和几个连续 X 变量，用于指定多重回归。

在“模型设置”对话框中定义模型后，单击运行模型按钮可执行分析，并生成一个具有相应表和支持图形的报表窗口。

像这种多重回归一类的标准最小二乘分析首先显示“拟合汇总”表、“参数估计值”表、“效应检验”表、“方差分析”、“残差对预测值图”以及杠杆图。如果需要，您可以打开其它如"多重回归的部分报表" 所示的表和图形，以查看分析的详细资料。或者，如果有某个筛选或响应面分析更适合，则可以从报表顶部的“效应筛选”和“因子刻画图”菜单中选择命令。

“模型拟合”平台上的所有表和图形都将在"标准最小二乘：入门"、"标准最小二乘：估计透视"和"标准最小二乘：探索预测方程"几章中详细介绍。

有关模型及将它们输入“模型设置”对话框所需的单击顺序的说明，请参阅下一节中的"模型类型"和"选定模型的单击顺序"。

多重回归的部分报表


模型类型

"模型类型"中的列表是一个模型实例目录，这些模型可使用“模型设置”对话框定义，其中 X 和 Z 效应有连续值，A、B 和 C 有记名值或保序值。此列表并不完整。

正确指定模型类型时，模型效应将显示在“模型设置”对话框中的构建模型效应列表中。有关用于获取其中一些模型效应集的单击顺序，请参阅"选定模型的单击顺序"。

模型类型
模型类型 | 模型效应
简单回归 | X
2 次多项式 (x) | X, X*X
2 次多项式 (x, z) | X, X*X, Z, Z*Z
三次多项式 (x) | X, X*X, X*X*X
多重回归 | X, Z, ...，其它连续列
单因子方差分析 | A
双因子主效应方差分析 | A, B
双因子交互作用方差分析 | A, B, A*B
三因子完全析因 | A, B, A*B, C, A*C, B*C, A*B*C
协方差分析，相同斜率 | A, X
协方差分析，不同斜率 | A, X, A*X
简单嵌套模型 | A, B[A]
复合嵌套模型 | A, B[A], C[A B]
简单裂区设计或重复测量 | A，B[A]& 随机，C，A*C
响应面 (x) 模型 | X&RS, X*X
响应面 (x, z) 模型 | X&RS, Z&RS, X*X, Z*Z, X*Z
多元方差分析 | 多个 Y 变量

以下惯例用于指定单击：

  • 如果列名无格式，请单击列选择列表中的名称。
  • 如果列名为粗体，则选择对话框模型效应列表中的该列。
  • 要单击的按钮的名称都以大写字母显示。
    选定模型的单击顺序
    模型类型 | 单击顺序
    简单回归 | X, ADD
    2 次多项式 (x) | X，2 次，在宏弹出式菜单中选择多项式次数
    3 次多项式 (x, z) | X，3 次，在宏弹出式菜单中选择多项式次数
    多重回归 | X，ADD，Z，ADD，... 或 X，Z，...，ADD
    单因子方差分析 | A, ADD
    双因子主效应方差分析 | A，ADD B，ADD，或 A，B，ADD
    双因子交互作用方差分析 A，B，ADD，A，B，CROSS 或
    A，B，在宏弹出式菜单中选择完全析因试验
    三因子完全析因 | A，B，C，在宏弹出式菜单中选择完全析因设计
    协方差分析，相同斜率 | A，ADD，X，ADD 或 A，X，ADD
    协方差分析，不同斜率 | A, ADD, X, ADD, A, X, CROSS
    简单嵌套模型 A，ADD，B，ADD，A，B，NEST，或
    A，B，ADD，A，B，NEST
    复合嵌套模型 | A, B, ADD, A, B, NEST, B[A], C, ADD, A, B, C, NEST
    简单裂区设计或重复测量 | A，ADD，B，ADD，A，B，NEST，从效应属性弹出式菜单中选择随机，C，ADD，C，A，CROSS
    二因子响应面 | X，Z，在宏弹出式菜单中选择响应面


响应按钮（Y、权重和频数）

对话框左上方的列选择列表列出了当前数据表中的列。单击某个列名时，该列名会高亮度显示，并对使用对话框中的其它按钮选择的操作作出响应。在多个列上拖动鼠标或按住 Shift 键并单击，可以选择多个列名，而按住 Ctrl 键并单击（Macintosh 系统中为按住 command(命令) 键并单击），可以选择不相邻的名称。

要为 Y、权重或频数角色指定变量，请选择变量，然后单击相应角色按钮。

  • Y 为模型标识一个或多个响应变量（因变量）。
  • 权重是一个可选角色，用于标识一个列，该列的值将提供响应权重。
权重影响模型中每一行的重要性。
  • 频数是一个可选角色，用于标识一个列，该列的值为分析的每行指定频数。此变量的值用于确定如何计算自由度。

如果要从角色中移除变量，请将其高亮度显示，然后单击移除或按退格键。


模型效应按钮

假定某个数据表包含取连续值的 X 和 Z 变量，以及取记名值的 A、B 和 C。下面几段介绍了“模型设置”对话框中用于指定模型效应的按钮。

添加

要将简单回归量（连续列）或主效应（记名列或保序列）作为 x 效应添加到模型中，请从列选择列表中选择该列并单击添加。该列名将显示在模型效应列表中。添加效应时，请注意为该变量声明的建模类型，以及在拟合模型时该建模类型的结果：

  • 连续建模类型的变量变为简单回归量。
  • 记名建模类型的变量以虚拟变量表示，以便拟合变量中各个水平的系数。
  • 记名建模类型和保序建模类型的处理方法相似，但是编码略有不同。有关效应编码的详情，请参阅附录"统计细节"。

如果错误地添加了效应，请在模型效应列表中选定它，然后单击移除。

交叉

要交叉两个或多个变量以创建复合效应，请按住 Shift 键并单击列选择列表选择这些变量。如果变量在列选择列表中并不相邻，请按住 Ctrl 键并单击（Macintosh 系统中为按住 command(命令) 键并单击）。然后单击交叉：

  • 交叉后的记名变量变为交互作用效应。
  • 交叉后的连续变量变为倍增的回归量。
  • 如果对记名变量和保序变量的组合进行交叉，则会产生适用于斜率齐性检验的特殊效应。

如果在列选择列表中选择了列名并在模型效应列表中选择了效应，则交叉按钮会将选定的列与选定的效应交叉，然后将此复合效应添加到效应列表中。

有关如何进行交叉效应参数化和编码的论述，请参阅附录"统计细节"。

嵌套

如果效应 B 的多个水平只出现在效应 A 的单个水平内，则称 B 嵌套在 A 内，并将 A 称为外部效应。符号 B[A] 读作“B 在 A 中”，表示要在 A 的每个水平内拟合 B 效应。B[A] 效应相当于合并 B+A*B。要指定嵌套效应，请执行以下操作：

  • 在列选择列表中选择外部效应，然后单击添加或交叉。
  • 在模型效应列表中选择外部效应。
  • 在列选择列表中选择嵌套变量，然后单击嵌套。

例如，假定要指定 A*B[C]。先在列选择列表中同时高亮度显示 A 和 B，然后单击交叉按钮，以便查看模型效应列表中的 A*B。高亮度显示模型效应列表中的 A*B 项和列选择列表中的 C。然后单击嵌套，以便查看作为模型效应的 A*B[C]。

注：嵌套项必须按从外到内的顺序指定。如果 B 嵌套在 A 内，且 C 嵌套在 B 内，则可按如下形式指定模型：A, B[A], C[B,A]。

JMP 最多允许组合十个项进行交叉和嵌套。


宏弹出式菜单

此处显示的效应宏弹出式菜单中的命令会自动生成常用模型的效应。您可以根据需要在自动生成的模型设置中添加或移除项。

完全析因设计
要查看许多交叉因子（如在因子设计中），请使用完全析因设计。此命令创建的效应集与在列列表中选择的所有变量的所有交叉对应。例如，如果选择了变量 A、B 和 C，则该因子选择会在效应列表中生成 A、B、A*B、C、A*C、B*C 和 A*B*C。要移除不需要的模型交互作用，请将其高亮度显示，然后单击移除。
因子阶数
要创建受限制的因子，请在次数框中输入需要的交互作用次数，然后选择因子阶数。
因子排序
如果选择因子排序，则会创建与完全析因设计相同的效应集，但这些效应会按次数顺序列出。首先列出所有主效应，接着是所有双因子交互作用，然后是所有三因子交互作用，依此类推。
响应面
在响应面模型中，目的是找到生成最大或最小期望响应的项的值。在二次模型中，这可通过拟合一组项来实现。表面的临界值是根据参数估计值计算得到，在表面形状上以报表形式显示。
要指定响应面效应，请在列选择列表中选择两个或多个变量。从效应宏弹出式菜单选择响应面时，响应面表达式将显示在模型效应列表中。例如，如果选择变量 A 和 B
Surface(A) 拟合
Surface(A,B) 拟合
响应面效应属性（以 & 符号为前缀）将会自动附加到模型效应列表中的效应名称上。下一节将介绍属性弹出式菜单。
混合响应面
混合响应面设计将忽略平方项及截距，将 &RS 效应属性附加到主效应中。有关详情，请参阅《试验设计指南》。
多项式阶数
多项式效应由一系列项组成，这些项是一个变量的幂。要指定多项式效应，请执行以下操作：
  • 单击列选择列表中的一个或多个变量。
  • 在次数框中输入多项式的次数。
  • 使用宏弹出式菜单中的多项式次数命令。
例如，假定选择了变量 x。效应列表中的二次多项式拟合 x 和 x 2 的参数。模型对话框中的三次多项式拟合 x、x 2 和 x 3 的参数。
Scheffe 三次项
在将三次多项式模型与混合拟合时，必须特别小心，不要引入偶次幂项，因为它们是不可估计的。处理三次模型时，不能指定形如 X1*X1*X2 的效应。但是，表面的完全多项式规格应当引入如下形式的项：
X1*X2*(X1 - X2)
称为 Scheffe 三次项。
在“模型拟合”对话框中，如果 (a) 在“次数”框中输入 3，接着在一组混合列上执行“混合响应曲面”命令，或 (b) 使用“宏”按钮中的 Scheffe 三次项命令，该宏将创建一个完全三次模型，其中包括 Scheffe 三次项。


效应属性和变换

上一节中提到的效应属性弹出式菜单具有 5 种特殊属性，可以指定给模型效应。

随机效应
如果与在裂区设计或重复测量设计时一样，有多个误差项或随机效应，则可以在模型效应列表中将它们高亮度显示，然后在属性弹出式菜单中选择随机效应。有关随机效应的详细说明和实例，请参阅"标准最小二乘：随机效应"。
响应面效应
如果具有响应面模型，可以使用此属性来标识响应面中将包含哪些因子。如果使用的是响应面效应宏，则自动指定此属性。要获得对响应面因子进行的附加分析，只需标识主效应，而不必标识交叉项。
对数方差效应
有时，试验的目标并不只是将响应本身最大化或最小化，而是要针对某个目标响应并实现最小变异性。要分析此类试验的结果，请执行以下操作：
1. 指定响应 (Y) 变量并选择对数线性方差作为拟合特点。
2. 通过在模型效应列表中高亮度显示来指定对数线性方差效应，然后在属性弹出式菜单中选择对数方差效应。效应会显示在模型效应列表中，其名称旁边带有对数方差 (&L)。
如果要将某个效应同时用于响应的均值和方差，则必须将其指定为效应两次，其中一次使用对数方差效应属性。
混合效应
您可以使用混合效应属性来指定混合模型效应，而无需使用混合响应面效应宏。如果未使用效应宏，则必须自己将此属性添加到效应，以便模型可了解哪些效应是混合的一部分。
已排除效应
如果需要估计交互作用的最小二乘均值，或要在缺少拟合计算的情况下将它包括在内，但在模型中将其排除，则可以使用已排除效应属性。
已结入
使用已结入属性可让 JMP 将一段平滑多项式与指定效应拟合。选择此属性时，将出现一个对话框，让您可以指定结点数。
注：主效应项才能实现结入样条。
JMP 遵循书本中有关定位点的建议。如果有 100 个点或少于 100 个点，则第一个结和最后一个结分别是最小点和最大点内的第五个点。而如果有 5 个结或少于 5 个结，则第一个结和最后一个结位于 0.05 和 0.95 分位数；而如果多于 5 个结，则为 0.025 和 0.975 分位数。除非少于或等于 30 个点（默认值为 3 个结），否则默认结数为 5。
结入样条与平滑样条类似。"平滑样条与结入样条" 使用了增长.jmp，对两个拟合平滑样条和一个结入样条进行了对比。
平滑样条与结入样条

与平滑样条相比，结入样条具有如下性质：

  1. 结入样条在具有许多项的通用模型内部起作用，而平滑样条针对二元回归。
  2. 回归基础不是响应函数。
  3. 结入样条很简约，对于 K 个节点，仅为曲率添加 k - 2 个项。
  4. 如果数据范围外归纳是一条直线，而不是（曲线）多项式，那么与纯多项式相比，结入样条较保守。
  5. 曲率检验较简便。

要检验曲率，请选择估计 > 定制检验，并为每个结入效应都添加一列。要复制曲线并检验"平滑样条与结入样条" 中曲线的曲率，请执行以下操作：

  • 选择分析 > 模型拟合。
  • 将比率指定为 Y 并将年龄添加为模型效应。
  • 在“构造模型效应”框中选择年龄变量，然后选择属性 > 已结入。
  • 接受默认的 5 个结。
  • 单击运行模型。

出现报表时，

  • 选择效应 > 定制检验并请注意，有三个结入列。因此，单击添加列按钮两次将总共生成三列。
  • 以如"曲率自定义检验的构造" 所示的方式填充列。
曲率自定义检验的构造
  • 单击完成。

这将生成如"曲率报表" 所示的报表。如果 p 值 > F 值较低，则表明数据的确存在曲率。

曲率报表

变换

变换弹出式菜单有 8 个函数可用于变换选定的连续效应或 Y 列。可用的变换包括无、对数、平方根、平方、倒数、指数、Arrhenius 和 ArrheniusInv。这些变换只能用于单列连续效应。
Arrhenius 变换为 [image] 。


拟合特点

JMP 的“模型设置”对话框提供了许多不同的拟合方法。并不是每个方法都有一个单独的对话框，而是用一个对话框列出每种方法的拟合特点。通常，将根据响应和输入的因子自动选择特点，但可以在拟合特点弹出式菜单中将选项更改为其它方法。

下面的列表简要介绍了每种模型类型。在各个单独章节中，可以找到每种模型拟合类型的文本报表、图形、选项、特殊命令以及实例分析的详细资料：

标准最小二乘法
JMP 将按最小二乘拟合线性模型，以通常的方式建立一个或多个连续响应的模型。标准最小二乘报表平台提供了两种表和图形：
传统统计量用于误差自由度数允许假设检验的情形。这些报表包括杠杆图、最小二乘均值、对比和输出公式。
筛选和响应面方法用于分析效应很多但观测值很少的试验数据。传统的统计方法关注的是残差。但是，由于在近饱和设计中，几乎不能或根本不能估计残差，因此重点在于预测方程式和效应大小。在许多筛选设计可拟合的效应中，您可能期望一些重要项相对于其它项更突出。另一个实例是试验目标是优化设置，而不是显示统计显著性，优化期望响应的因子组合受到最大关注。
逐步
逐步回归是一种为回归模型选择效应子集的方法。逐步功能计算与其它最小二乘平台相同的估计，但简化了在许多模型中的搜索和选择。逐步特点只允许一个连续的 Y。
多元方差分析
当选择了多元方差分析拟合特点，且为模型指定了多个 Y 变量时，“拟合模型”平台将 Y 与指定效应集拟合，并提供多元检验。
对数线性方差
一个或多个效应建立方差模型（而不是均值模型）时，可使用“对数线性方差”。使用对数线性方差特点时必须谨慎。有关此功能的详细信息，请参阅"使用对数线性方差模型拟合离差效应"。
记名变量逻辑斯蒂
如果响应为记名，则“拟合模型”平台将使用最大似然，将线性模型与多水平逻辑响应函数拟合。
保序逻辑斯蒂
如果响应变量有保序建模类型，则“拟合模型”平台将使用最大似然，将累积响应概率与线性模型的逻辑分布函数拟合。
比例危险模型
比例危险 (Cox) 模型是一个特殊拟合特点，可用于将带失败时间的模型定义为删失适当的响应变量及与时间无关的协变量。通常，可以将所需的协变量指定为用于定义子总体或层的分组变量。
参数生存模型
“参数生存”执行的分析与分析 > 生存工具菜单上的拟合参数生存命令相同。有关详情，请参阅"生存和可靠性分析 I"。
广义线性模型
用各种分布函数和关联函数来拟合广义线性模型。有关广义线性模型的完整论述，请参阅"广义线性模型"。
拟合特点的特征
特点 | 响应 (Y) 类型 | 注
标准最小二乘 | ≥ 1 连续 | 所有效应类型
逐步 | 1 连续 | 所有效应类型
多元方差分析 | > 1 连续 | 所有效应类型
对数线性方差 | 1 连续 | 方差效应
记名变量逻辑斯蒂 | 1 记名 | 所有效应类型
保序逻辑斯蒂 | 1 保序 | 所有效应类型
比例危险模型 | 1 连续 | 仅限于生存模型
广义线性模型 | 连续、记名、保序 | 所有效应类型


其它模型对话框功能

重点选项

重点弹出式菜单控制作为初始分析报表一部分的图形类型。

效应杠杠率
以用于整体模型的杠杆图和残差图开始。接着，可请求效应详细信息和其它统计报表。
效应筛选
显示整体模型信息，接着是带图形和预测刻画器的尺度转换参数报表。
最小报表
抑制回归图之外的所有图形。您可通过平台弹出式菜单请求所需的信息。

运行模型

运行模型按钮向拟合平台提交模型。由于“模型设置”对话框为非模式，运行模型按钮不会关闭该对话框窗口。您可继续使用此对话框，并针对其它拟合来更改模型，也可以更改数据，然后重新拟合同一模型。

有效性检验

拟合模型会检查模型误差，如在层次结构中有效应重复或效应缺失。如果得到警告消息，可以忽略此种情况继续拟合，或单击警告消息中的取消，停止拟合流程。

另外，数据可能会有缺失值。如果有 Y 或 X 值缺失，则默认行为是排除行。在有些 Y 没有缺失值而其它 Y 有缺失值情况下，这会浪费行。因此，可以考虑分别拟合每个 Y。

在这种情况下，会出现如"缺失值警告" 所示的对话框，提出警告。此对话框提供了分别拟合每个 Y 的选项。分别拟合各个 Y 的结果是刻画器每次只处理一个 Y，保存的脚本一次只运行一个 Y。另外，大型问题的计算可能不会很快。

缺失值警告

注：此对话框只在交互运行模型时显示。除非在运行模型命令中有分别拟合，否则脚本将继续使用默认行为。

其它模型设置选项

“模型设置”窗口标题栏的弹出式菜单提供了其它选项。

中心多项式
会导致参与交叉项的连续项将根据其均值居中。居中的例外是带编码或混合特性的效应。在连续交叉效应情况下，在使主效应检验成为有意义的假设方面，此选项将起到重要作用。
保存至数据表
将模型另存为当前数据表的特性。模型弹出式菜单图标显示在“表”面板数据网格的左边，其中带运行脚本命令。如果选择运行脚本命令来提交模型，则将显示新完成的“模型设置”对话框。《JMP 脚本指南》是有关 JSL 语句的参考资料。
运行脚本命令
保存至脚本窗口
将已完成模型的 JSL 命令保存在新打开的脚本窗口中。您可以保存脚本窗口，并可在任何时候通过运行脚本来重新创建模型。
载入版本 3 模型
显示“打开文件”对话框，供您选择包含 JMP 版本 3 模型语句的文本文件。接着，模型显示在“模型设置”对话框中，并可另存为当前版本模型。
创建 SAS 任务
在脚本窗口中创建 SAS 程序，以便在 SAS 中重新创建当前分析。创建后，有多种方法可用于将代码提交给 SAS。
1. 将产生的代码复制并粘贴到 SAS 程序编辑器中。如果运行的是较早版本的 SAS（版本 8.2 之前），此方法就比较有用。
2. 选择编辑 > 运行脚本。这将弹出一个对话框（如此处所示），您可以在其中输入可访问 SAS 服务器（通过 IOM 访问）的名称。如果将此对话框留空并单击“确定”，则将使用 SAS 本地副本（如果存在）。
单击“确定”后，脚本将通过 IOM 发送给 SAS，结果会返回给 JMP。结果显示在一个独立的日志窗口中。
3. 保存文件并单击它，在 SAS 本地副本中打开它。如果要利用 SAS ODS 选项，如从 SAS 代码中生成 HTML 或 PDF 输出，此方法很有用。
提交至 SAS
通过 IOM 将脚本发送给 SAS，结果会返回给 JMP。结果显示在一个独立的日志窗口中。


标准最小二乘：入门

模型拟合平台

此拟合工具可以拟合许多不同类型的模型（回归、方差分析、协方差分析以及混杂），此外您还可以尝试其它拟合方法。因此，尽管此平台比较复杂，但您仍可以轻松完成一些简单的任务。

这里“标准最小二乘”拟合的特点是可使用最小二乘将连续响应拟合为因子的线性模型。系统将列出详细的结果，包括杠杆率图和最小二乘均值。此外，此平台还具有许多其它功能，例如进行对比和保存输出公式。

但请不要仅局限于本章中的内容，有些时候您可能需要跳转至其它的章节：

  • 如果您尚未学习如何在“模型设置”对话框中指定模型，则您可能需要跳转回"模型拟合简介"。
  • 如果涉及响应曲面效应或需要计算追溯功效，请参阅"标准最小二乘：估计透视"。
  • 要筛选应用程序，请向前跳转至"标准最小二乘：探索预测方程"。
  • 如果涉及随机效应，请参阅"标准最小二乘：随机效应"。
  • 如果需要了解关于 JMP 如何对模型进行参数化的详情，请参阅附录"统计细节"。

标准最小二乘只是“模型拟合”平台的一个拟合特点。其它七个特点将在后面的章节"标准最小二乘：估计透视"、"标准最小二乘：探索预测方程"、"标准最小二乘：随机效应"、"逐步回归"、"记名响应和保序响应的逻辑斯蒂回归"和"多重响应拟合"中讨论。

目录

启动平台：简单实例

回归图

功能增强选项包

整体模型统计表

拟合汇总表

方差分析表

失拟合表

参数估计表

效应检验表

杠杆率图

效应详细资料

最小二乘均值表

最小二乘均值图

最小二乘均值对比

最小二乘均值学生氏 t 和最小二乘均值 Tukey HSD

检验切片

功效分析

行诊断命令和保存命令汇总

行诊断

保存命令

统计实例

带有对比的单因子方差分析

协方差分析

不同斜率的协方差分析


启动平台：简单实例

为了介绍“模型拟合”平台，先看一个简单的单因子方差分析实例，讨论的是三种药物中均值响应中的差异。实例数据（Snedecor 和 Cochran 1967）来自对 30 个对象分别接受三种药品（标记为 a、d 和 f）治疗后的响应进行测量的研究。结果放在药物.jmp 样本数据表中。

首先在“模型拟合”的“模型设置”对话框中指定模型，如"单因子方差分析的“模型设置”对话框" 所示。有关如何使用此对话框的详情，请参阅"模型拟合简介"。要将药物添加为效应，请在列选择列表中选定它，然后单击添加。在选择 y 列作为 Y 响应时，拟合类型将变为标准最小二乘，重点则为效应杠杆率。在其它情况下，您可以更改这些选项。单击运行模式查看初始结果。

单因子方差分析的“模型设置”对话框

输出结果的顶部为如"整体模型杠杆率图和药物效应杠杆率图。" 所示的图形，其中显示了数据与模型的拟合效果。这些图形称为杠杆率图，因为这些图形传递了数据点拖动代表模型拟合的直线的思想。杠杆率图具有这些有用的性质：

  • 从各点到拟合直线的距离为该点的误差或残差。
  • 从各点到水平线的距离为在模型中移除效应时的误差。

因此，效应强度表现为这些点将拟合直线拖离水平线的程度。置信曲线位于图形上，因此一眼即可看出效应是否显著。在各个图形中，如果 95% 置信曲线与水平参考线相交，则该效应显著；如果曲线不相交，则（在 5% 水平上）不显著。

整体模型杠杆率图和药物效应杠杆率图。

在这个简单的例子中，预测值只是简单均值，药物的杠杆率图显示实际值对于药物水平均值的回归。（Levin、Serlin 和 Webne-Behrman (1989) 提出了这一观点。）药物 a、d 和 f 在"整体模型杠杆率图和药物效应杠杆率图。" 中分别标记为正方形、十字形和三角形。因为模型中只有一种效应，整体模型的杠杆率图和效应药物的杠杆率图是等效的。其差别仅仅在于 x 轴的尺度不同。整体模型杠杆图始终是实际响应与预测响应的对比图，因此落在直线上的点就是最佳预测点。

在本实例中，置信曲线与水平线相交；因此，尽管拟合直线上具有较大的方差（本例中为关于组均值），药物的效应仍是显著的。

检查拟合图后，在图形下面可以看到文本详细资料。在本例中有三种水平的药物，有两个参数用于描述它们之间的差异。文本报表显示了估计、各种检验统计量和关于参数估计的汇总统计量。整体模型杠杆率图下方的“拟合汇总”表和“方差分析”表将拟合作为一个整体显示出来。关于药物效应的两个参数的检验统计量显示在药物的“效应检验”汇总和详细资料报表中。因为药物是唯一的效应，所以同一检验也将显示在“方差分析”表和“效应检验”表的模型行中。

“方差分析”表显示药物效应的观测显著性概率为（p 值 > F）0.0305，与 0.05 相比几乎完全不显著。R 平方表明响应中 22.8% 的变异可以通过模型拟合来解释。

有记名型效应（如药物）时，比较水平对响应的预测效果将很有趣。与直接使用参数估计相比，在记名值的各水平上比较预测值通常更有意义。这些预测值称为最小二乘均值 (LSMeans)，在这个简单的例子中，它们与通常的均值相同。从后面的实例中可以看出，当模型中存在其它效应时，最小二乘均值可能与通常的均值不同。记名效应的“最小二乘均值”表显示在效应的杠杆率图（"最小二乘均值表和刻画图"）下方。

使用效应的弹出式菜单也可以得到最小二乘均值图，如"最小二乘均值表和刻画图" 所示。该图以图形方式显示均值及相应的 95% 致信区间。

最小二乘均值表和刻画图

后面"统计实例"的“统计详细资料实例”一节中将继续用“参数估计”表进行药物分析，并用最小二乘均值对比来查看组均值。

回归图

如果一个模型中只有一个连续项，且不超过一个分类项，则 JMP 将标绘一条或多条回归线，该功能通过“标绘回归图”命令实现。选择此命令可打开或关闭该图形输出。

回归图


功能增强选项包

模型拟合过程可以生成各种表、图形和图表。为了方便，系统提供了三种标准选项包，让您可以选择最能满足需要的报表设计。就像汽车分为豪华轿车、跑车和经济型一样，这些选项也提供了各种线性模型结果，以满足您的需要。"“功能增强”定义的标准最小二乘报表设计"介绍了标准最小二乘分析的报表布局类型。

"模型拟合简介"一章介绍了功能增强菜单。重点的默认值是考虑指定的效应数和数据表中的行数（观测值）时，平台对您所需要情况的最佳预测。

“功能增强”定义的标准最小二乘报表设计
功能 | 报表说明
效应杠杆率 | 在需要关于各种效应显著性的详细资料时，请选择效应杠杆率。此增强的初始报表有杠杆率图，且各种效应的报表都水平排列。
效应筛选 | 在具有多种效应但是不想在看不出效应的强弱时显示详细资料时，效应筛选布局则更适合。在效应较多而观测值较少，且需要找出较强的效应而不是检验显著性的情况下，推荐使用此布局进行筛选设计。这种排列最初显示整体模型信息，然后显示效应详细资料、尺度无关估计和预测刻画器。
最小报表 | 最小报表开始时很简单，您可以根据需要自定义表和图形的结果。选择最小报表会取消所有图形输出（回归图除外），并垂直排列整体模型表和效应详细资料表。


整体模型统计表

本节开始介绍有关报表中的标准统计量的详细资料。您可以先跳过其中一些细节，稍后面再来仔细阅读。

从报表的红色三角菜单中访问“回归报表”菜单，通过它可以打开和关闭回归报表。

“整体模型”一节展示了如何将模型作为一个整体来拟合。初始报表如"按“增强”排列整体模型" 所示。下一节将介绍下列表：

  • 拟合汇总
  • 方差分析
  • 失拟合
  • 参数估计
  • 效应检验

效应和杠杆率图相应表的论述将在"效应检验表"和"杠杆率图"中给出。

按“增强”排列整体模型

以下实例使用来自于 Sample Data 文件夹的大班.jmp 数据表。此模型将身高指定为响应变量 (Y)，将年龄和体重指定为效应，其中年龄为保序建模类型。

拟合汇总表

“拟合汇总”表首先给出，并列出多重回归模型的以下响应数值汇总：

R 平方
估计响应相对于可归于模型中各项（而不是随机误差）的均值的变异比例。使用“方差分析”表中相应的数量可按如下公式计算出 R 平方：
它也是实际响应和预测响应之间相关系数的平方。在完全拟合（误差全部为零）时，R 平方为 1。R 平方为 0 表示拟合预测的响应几乎与整体响应均值一样。
调整 R 平方
通过在计算中使用自由度，调整 R 平方使它在具有不同参数个数的模型中更具可比性。它是均方比而不是平方和，计算公式如下
其中误差其中误差的均方可从“方差分析”表（见下一节“方差分析表,”"方差分析表"）找到，C. 合计均方的计算方法为 C. 合计平方和除以各自的自由度。
均方根误差
估计随机误差的标准差。它是相应“方差分析”表中的均方根误差，通常记为 σ。
响应均值
是响应值的整体均值。作为预测的基本模型，该值很重要，因为所有其它模型都与它相比较。根据此均值度量的方差为“方差分析”表中的校正合计（C. 合计）均方。
观测值（或权重和）
记录拟合中使用的观测值个数。如果没有缺失值，且没有排除的行，该值就与数据表中的行数相同。如果有一列被指定为权重角色，就为权重列值的总和。

方差分析表

“方差分析”表给出了线性模型的基本指标。此表将模型拟合与单个均值的简单拟合进行对比：

来源
列出了名为模型、误差和 C. 合计的三种变异来源。
DF

记录每个变异来源的相关自由度 (DF)。

C. 合计自由度用于简单均值模型。此变异的计算中只使用了一个自由度（均值参数估计），因此 C. 合计自由度通常比观测值个数少一个。
总自由度分为模型项和误差项：
模型自由度是用于模型拟合的参数个数（截距除外）。
误差自由度是 C. 合计 DF 和模型 DF 之间的差。
平方和
记录每个变异来源的相关平方和（简称 SS）。SS 列考虑了响应中度量的变异性，即拟合响应和实际响应之差的平方和。
合计（C. 合计）SS 为各个响应与样本均值的距离平方和，在本节开始的实例中为 1288.7。它是用于与其它所有模型进行比较的基本模型（或简单均值模型）。
误差 SS 为拟合值与实际值之差的平方和，在上述实例中为 417.2。此平方和对应于拟合回归模型后未解释的误差（残差）。
合计 SS 减去误差 SS 可得到归于模型的平方和。
这些量的常用符号为 SSR、SSE 和 SST，分别表示由于回归（模型）、误差及合计产生的平方和。
均方
等于平方和除以其相关自由度。计算会将平方和转换为一个平均值（均方）。
本节开头的表中模型均方为 290.5。
误差均方为 16.046，用于估计误差项的方差。它通常记为 MSE 或 s 2。
F 比率
等于模型均方值除以误差均方。它检验所有回归参数（截距除外）为零的假设。在整体模型假设下，这两个均方的期望值相同。如果随机误差为正态的，则在这种假设下，SS 列中报告的值是两个不相关的卡方。这两个卡方除以各自自由度之后的比值（DF 列中报告）具有 F 分布。如果模型中有一个显著效应，则 F 比率只是在偶然情况下高于期望值。
p 值 > F
是在指定的模型拟合几乎与整体响应总均值一样时，纯粹由于偶然获得更大的 F 值的概率。显著性概率小于或等于 0.05 通常被认为是模型中至少有一个显著回归因子的证据。
请注意，较大的模型 SS 值与较小的误差 SS 值相比会得到较大的 F 比率和较小的 p 值，而这正是为了表明模型中的项与零显著不同时所希望的情况。大多数专业人员首先检查此 F 检验，确定它具有显著性，然后才进一步深入研究该拟合的详细资料。上一节中的整体模型杠杆率图也以图形方式表明了这一显著性。

失拟合表

“失拟合”表给出了一个特殊的诊断检验，并且只有在数据和模型适宜时才出现。其原理为有时可以在不管模型形式是否正确的情况下估计误差方差。如果观测值对于变量 X 而言彼此完全重复，就会出现这种情况。可将这些完全重复值测量的误差称为纯误差。不管模型使用的是什么样的 X 变量形式，都无法解释或预测的样本误差的全部。但是，如果自由度很少，即很少重复的 x 值，则失拟合检验可能用处不大。

模型残差和纯误差之间的差称为失拟合误差。如果某些回归量的函数形式错误，或方差分析模型中交互作用效应太少，失拟合误差可显著大于纯误差。这种情况下，应考虑添加交互作用项（如果需要），或尝试较好地获取回归量的函数形式。

没有失拟合检验的情况通常有以下两种：

  1. 相对于 X 数据没有完全重复点，因此纯误差没有自由度。
  2. 模型达到饱和，意味着该模型本身的每个不同 x 值都有一个自由度，因此失拟合没有自由度。

“失拟合”表给出了误差项的有关信息：

来源
列出名为失拟合、纯误差和总误差的三个变异来源。
DF
DF 记录每个误差来源的相关自由度 (DF)。
总误差 DF 是“方差分析”表的误差行上的自由度，即该表中的合计 DF 与模型 DF 之间的差。误差 DF 分为失拟合自由度和纯误差自由度。
纯误差 DF 是由各个有多个相同值的效应的各个组合合并而成。在大班.jmp 在数据表中有一个实例，其中两个对象的年龄和体重值相同（Chris 和 Alfred 都是 14 岁，体重均为 99），纯误差为 1(2 - 1) = 1 DF。一般来说，如果有 g 个每个效应应都有多个相同值的组，则记为 DFp 的合并 DF 为
其中 n i 为第 i 组中对象的个数。
失拟合 DF 是总误差自由度与纯误差自由度之差。
平方和
记录每个误差来源的关联平方和（简称 SS）。
总误差 SS 是对应的“方差分析”表中误差行上的平方和。
纯误差 SS 是由各个有多个相同值的效应的各个组合合并而成。这就估计了模型效应未解释的真实随机误差部分。一般来说，如果有 g 个每个效应都有多个相似值的组，则记为 SSp 的合并 SS 可写为
其中 SSi 为根据均值校正的第 i 组的平方和。
失拟合 SS 是总误差平方和与纯误差平方和之差。如果失拟合 SS 较大，则该模型可能不适合这些数据。下述 F 比率用于检验由于失拟合导致的变异是否足够小，是否可接受为纯误差的可忽略部分。
均方
等于平方和除以其相关自由度。计算会将平方和转换为一个平均值（均方）。统计检验的 F 比率是均方之比。
F 比率
是失拟合均方与纯误差均方之比。它检验失拟合误差为零的假设。
p 值 > F
是在失拟合的方差与纯误差方差相同时，纯粹由于机会而获得更大的 F 值的概率。这意味着误差的不显著部分由失拟合解释。
最大 R 平方
是模型仅使用模型中的变量就可实现的最大 R 平方。因为纯误差对于模型形式是不变的，并且是最小的可能方差，所以可以按如下公式计算最大 R 平方

参数估计表

“参数估计”表给出线性模型中的参数估计及各参数都为零的假设的 t 检验。简单连续回归量只有一个参数。复合分类效应的模型的每个预期自由度都有一个参数。

“参数估计”表给出了这些量：

项
命名估计参数。第一个参数始终为截距。简单回归量显示为数据表的列名。作为根据记名效应或保序效应构建的虚拟指标的回归量，都用将水平名称加上括号来标记。对于记名变量，拟变量编码为 1，但最后一个水平在该效应的所有其它拟变量中都编码为 -1。在本实例中保序编码指标的参数用于测量每个水平与其前一水平之间的差。
估计
列出各项的参数估计。它们是由最小二乘找到的线性模型的系数。
标准误差
参数估计分布的标准差估计，用于构建 t 检验以及参数置信区间。
t 比率
检验真实参数是否为零的一个统计量。它是估计与其标准误差的比，在关于模型的常见假设下具有学生氏 t 分布。
p 值 > |t|
在参数为零的假设下获得较大 t 偶数统计量（绝对值）的概率。这是一个针对各个方向的对立双尾检验。概率小于 0.05 通常被视为参数不为零的显著证据。

尽管最初处于隐藏状态，以下各列仍然可用。使用鼠标右键单击（在 Macintosh 系统中为按住 control 键并单击），然后从列菜单中选择所需的列。

标准 Beta
如果回归的所有变量都已标准化（均值为 0，方差为 1），则标准 Beta 为参数估计。
VIF
显示方差膨胀因子。较高的 VIF 表明存在共线性问题。
请注意，VIF 定义为
其中 R 平方定义为回归量列根据其它所有回归量回归的情况。但是，无截距模型的 R 平方定义将有所变化。对于无截距模型和隐藏截距模型，JMP 使用未校正平方和（如零模型）中的 R 平方，而不是均值模型中的校正平方和。

效应检验表

效应检验是个体效应的所有参数均为零的联合检验。如果某个效应只有一个参数，如简单回归量，则这些检验与“参数估计”表中的 t 检验没有区别。奇异性的参数化和处理方式与SAS GLM 程序不同，相关详情在附录"统计细节"中有所论述。

“效应检验”表给出各个效应的以下信息：

来源
列出模型中效应的名称。
Nparm
与效应相关的参数个数。连续效应只有一个参数。记名效应的参数个数比水平个数少一个。交叉效应将乘以各项参数的个数。嵌套效应取决于水平的产生方式。
DF
效应检验的自由度。通常情况下，参数个数和 DF 相同。如果回归量中有线性组合，从而不能对效应进行完全检验，则两者不同。有时 DF 甚至会为零，表明效应的任何一部分都不可检验。DF 小于参数个数时，报表中线条的右侧都会出现注释丢失 DF。
平方和
列出的效应为零的假设下的平方和。
F 比率
效应为零的检验的 F 统计量。它是效应均方与误差均方之比。效应均方为除以其自由度的效应平方和。
p 值 > F
F 比率的显著性概率。它是如果原假设为真，只由于随机误差才出现较大 F 统计量的概率。小于 0.0005 的值显示为 0.0000，即在概念上视为零。


杠杆率图

要以图形方式查看模型的显著性，或将注意力集中在效应是否显著，您可能要从该效应的假设角度显示数据。您可能会说 X 射线图能更多地显示数据的内在性质，而不是外部的曲面视图。杠杆图就是这类数据视图，是一种经过计算能最大限度反映数据拟合情况的视图。

通过将残差平方和与移除效应后模型的残差平方和进行比较，可检验模型中效应的显著性。当模型中包括效应时，剩余误差会小得多，从而可确定该效应对该拟合具有显著贡献。

效应显著性检验的图形显示称为杠杆率图 (Sall 1990)。这种图形显示模型中具有该效应和没有该效应两种情况下各个点的残差。在“模型拟合”报表的行诊断子菜单中可以找到杠杆图。

杠杆图的构造如"一般杠杆率图示意图" 所示。从一个点到拟合直线的距离表示了实际残差。从点到均值水平线的距离表示了模型中没有效应时的剩余误差。换句话说，此杠杆图中的均值线表示参数的假设值（效应）限制为零时的模型。

回顾历史上，Belsley、Kuh 和 Welsch (1980) 提出了偏回归残差杠杆率图，Cook 与 Weisberg (1982) 提出了附加变量图，杠杆图是它们的推广。

使用杠杆率术语是因为当点在水平方向离图形中间越远，它对拟合的影响就越大。在极端情况下，残差在受假设约束前后的差异更大，并为该效应的假设检验贡献了更大部分的平方和。

拟合平台将为模型中的每个效应都生成一个杠杆率图。此外，有一种称为整体模型的特殊杠杆图，可用于显示根据预测值标绘的响应的实际值。此整体模型杠杆率图可用于显示模型中所有参数（截距除外）为零的检验。在“方差分析”报表中有相同检验的报告。

一般杠杆率图示意图

简单回归中线性效应的杠杆图与实际响应值和回归量的传统杠杆图相同。"整体模型杠杆率图和效应杠杆率图" 中的杠杆率图实例来自一个用于预测变量身高与年龄（来源于大班.jmp）的简单线性回归。左侧图形是所有效应的整体模型检验，右侧图形为效应年龄的杠杆率图。

整体模型杠杆率图和效应杠杆率图

简单回归杠杆图上的点是实际数据坐标，约束模型的水平线为响应的样本均值。但是，杠杆率图被用于多个效应之一时，这些点就不再是实际数据值。水平线则表示一个部分约束的模型，而不是一个完全约束在一个均值的模型。但是，不管是对于简单回归还是多重回归，图形的直观解释都相同。重点是判断效应杠杆率图上拟合直线支持的点是否显著优于水平线上支持的点。

"一般杠杆率图示意图" 是"整体模型杠杆率图和效应杠杆率图" 中图形的一般形式。再次强调，在将回归量从模型移除的情况下，点到拟合直线的距离是实际残差，从点到均值的距离是剩余误差。

置信曲线

杠杆率图与置信曲线一起显示。置信曲线一起显示。这些图形通过显示拟合直线的置信区域，表明检验在 5% 水平是否显著。如果曲线之间的置信区域包含水平线，则效应不显著。如果曲线与直线相交，则效应显著。请比较"比较杠杆率图中所示的显著性" 中所示的实例。

比较杠杆率图中所示的显著性

X 尺度的解释

如果回归量的建模类型是连续的，则 x 轴与回归量的尺度一样，杠杆图中拟合直线的斜率就是回归量的参数估计，如"比较杠杆率图中所示的显著性" 中右侧图形所示。

如果效应为记名效应、保序效应或复合效应，如交互作用（而不是简单回归量），则 x 轴无法直接表示效应的值。这种情况下，x 轴与 y 轴的尺度一样，拟合直线是一条斜率为 1 的对角线。整体模型杠杆率图就是这种形式的图形。x 轴实际上是整体模型的预测响应，如"简单回归和复合效应的杠杆率图" 左侧图形所示。

简单回归和复合效应的杠杆率图

所有杠杆率图中的影响点都为远离 x 轴的点。如果一个模型中的两个效应密切相关，则这些效应作为一个整体的杠杠效应不明显。这个问题称为共线性。通过按回归量轴的原始值转换其尺度，共线性展示了点在 x 方向上的收缩。

有关构造杠杆率图的详情，请参阅附录"统计细节"。


效应详细资料

每个效应的名称旁边都可显示一个弹出式菜单。效应弹出式菜单可用于生成该效应的表、图形和检验。针对效应的命令会将结果附加至效应报表。您可以选择关闭结果或放弃结果，方法是取消选定相应菜单项。

下一节将介绍“效应”弹出式菜单命令。

最小二乘均值表

最小二乘均值由分类效应各水平间的指定模型给出，其中其它模型因子是通过设置为中性值来控制的。中性值是具有区间值的回归量的样本均值（可能为加权均值），以及不相关记名效应各个水平的平均系数。

最小二乘均值让您可以观测哪些水平产生的响应更高或更低，其它变量则保持为模型常数。最小二乘均值又称为已调整的均值或总体边际均值。

最小二乘均值是检验效应时进行比较的统计量。如果因子的值没有反映实际值的普遍组合，它们可能不能反映响应的典型实际值。在试验中进行比较时，最小二乘均值非常有用。

系统将为模型中所有分类效应生成具有标准误差的“最小二乘均值”表。对于主效应，“最小二乘均值”表还包括样本均值。最小二乘均值通常比样本均值彼此更加靠近。有关最小二乘均值的详细介绍，请参阅附录"统计细节"。

“最小二乘均值”表给出了以下量：

水平
列出各个分类水平的名称。
最小二乘均值
列出分类变量各个水平的最小二乘均值。
标准误差
列出分类变量各个水平的标准误差。
均值
列出分类变量各个水平的响应样本均值。如果模型中其它效应的值在此效应中不平衡，这个值将与最小二乘均值不同。

最小二乘均值图

最小二乘均值图选项可用于标绘记名主效应和保序主效应以及双因子交互作用的最小二乘均值（刻画图）。"标准最小二乘：探索预测方程"介绍了因子刻画图菜单中的交互作用图命令，此命令以另一种格式提供了交互作用图。

"主效应和交互作用的最小二乘均值图" 所示为主效应及双因子交互作用的效应图。对数据（爆玉米花.jmp）的解释参见《JMP 使用指南》的“因子分析”一章。在本试验中，对给定数量的玉米粒测量出爆玉米花的产出量进行了三种条件下的比较：

  • 爆玉米花类型（gourmet 和 plain）
  • 爆玉米花的包型（large 和 small）
  • 油量（little 和 lots）
主效应和交互作用的最小二乘均值图

注：要将最小二乘均值刻画图的因子转置为双因子交互作用，请按住 Shift 键并选择最小二乘均值选项。

最小二乘均值对比

一个对比就是您所要联合检验（假设为零）的参数的一组线性组合。JMP 会按照效应的最小二乘均值建立对比。按惯例，对比的每一列经过标准化后的总和都为 0，绝对总和则都等于 2。

要在效应中设置对比，请使用最小二乘均值对比命令，显示一个对话框，以指定关于该效应的对比。此命令仅仅对于纯分类效应才可用。

此处显示的“对比”对话框用于名称为年龄的效应。它显示效应的名称及效应中各个水平的名称。水平旁是个矩形区域，该矩形的 + 和 - 符号框旁边有一列数字。

要构建对比，请单击要进行对比的水平旁的 + 框和 - 框。如有可能，每次单击时，对话框都将进行标准化，使每列的总和都为 0，使绝对总和都等于 2；并按比例加到正值或负值。

例如，要构成一个对比，以便将前两个年龄水平与紧接的两个水平进行比较，请单击年龄 12 和 13 的 +，并单击年龄 14 和 15 的 -。如果要进行更多比较，请单击新建列按钮，创建一个新列，以定义新的对比。下面显示了年龄的对比。

定义对比后，请单击完成。对比将被估计，此处显示的“对比”表将附加到该效应的其它表中。

“对照”表将给出：

  • 对话框指定的对比作为最小二乘均值的函数
  • 最小二乘均值对比的估计和标准误差，以及对比各列的 t 检验
  • 联合检验的对比中各列的 F 检验
  • 显示按参数表示的对比的“参数函数”表。本实例中的参数是针对保序变量年轻的。

最小二乘均值学生氏 t 和最小二乘均值 Tukey HSD

最小二乘均值学生氏 t 命令和最小二乘均值 Tukey HSD 命令可用于提供模型效应的多重比较检验。

最小二乘均值学生氏 t
使用学生氏 t 检验计算模型中最小二乘均值的各个成对比较。该检验度量各个比较。如果进行了多次成对检验，则推断之间不存在保护。因此，假设检验中的 alpha 大小（类型 I）误差率高于各个检验的误差率。
最小二乘均值 Tukey HSD
给出一个检验，该检验的工作量取决于最小二乘均值中的总体差异。这就是 Tukey 或 Tukey-Kramer HSD（可靠显著差异）检验。(Tukey 1953, Kramer 1956)。如果样本大小相同，则该检验为精确 alpha 水平检验；如果样本大小不同，则为保守检验 (Hayter 1984)。

在"单因子方差分析" 章节中的 "多重比较" 中对这些检验进行了详细介绍，其中包括关于如何理解和解释多重比较表的实例和说明。

这两个命令产生的报表均有菜单，可用于显示三种报表。

交叉列表报表
显示或隐藏交叉列表报表。此报表是一个双因子表，以红色高亮度显示显著差异。
连接线报表
显示或隐藏以字母表示显著差异的报表（类似于传统 SAS GLM 输出结果）。没有通过相同字母连接起来的水平显著不同。
顺序差报表
显示或隐藏按差从最低到最高进行排序的报表。它还在具有叠加置信区间线的直方图上标绘差。关于顺序差报表的实例，请参阅"单因子方差分析" 章节中的 "顺序差报表" 。
详细比较报表
显示以成对方式将效应的每个水平与所有其它水平进行比较的报表和图形。有关详细比较报表的实例，请参阅"单因子方差分析" 章节中的 "详细比较报表" 。
等价性检验
使用 TOST 方法检验实际等效性。有关详情，请参阅"单因子方差分析" 章节中的 "等价性检验" 。

检验切片

检验切片命令可用于交互作用效应，是一种同时执行多项对比的快速方式。对于交互作用中每个分类栏的每个水平，该命令都将对交互作用中其它分类列的所有水平之间进行比较。例如，若有一个交互作用 A*B*C，则有一个切片称为 A=1，它检验 A=1 时的所有 B*C 水平。对于 A、B 和 C 的其它水平，则依此类推。这种方法可发现操作在交互作用内出现的位置。

功效分析

功效分析将在"标准最小二乘：估计透视"一章中介绍。


行诊断命令和保存命令汇总

模型拟合结果的所有结果都是可选的。单击位于最顶端外框线的响应名称旁的三角形弹出式图标时，"针对最小二乘分析的命令：行诊断命令和保存命令" 所示菜单将列出可用于连续响应模型的命令。

针对最小二乘分析的命令：行诊断命令和保存命令

“模型拟合”平台的细节取决于执行的分析类型以及所选择的选项和命令。弹出式图标列出了各个分析水平的命令和选项。您随时可以通过这些菜单项访问所有表和图形。此外，您还可以使用首选项或脚本命令来更改结果的默认排列。

估计值和效应筛选菜单将在"标准最小二乘：估计透视"中详细介绍。有关效应筛选和因子刻画菜单中命令的说明，请参阅"标准最小二乘：探索预测方程"。

下面几节将简要介绍行诊断和保存菜单中的命令。

行诊断

杠杆率图（标绘实际值对预测值图和标绘杠杆效应图命令）已在前面的"杠杆率图"中介绍过。

标绘实际值对预测值图
按 Y 的预测值显示观测值。它是整体模型的杠杆率图。
标绘效应杠杆率图
为模型中各个效应生成杠杆率图，逐点显示该效应的检验。
标绘残差对预测值图
按 Y 的预测值显示残差值。通常，您可看到约为零的随机散布残差值。
按行标绘残差图
按其观测值的行号显示残差值。
Press
显示一个 Press 统计量，该值将计算出残差平方和，其中各行的残差是在计算中除去该行后算出的，Press RMSE 定义为 [image] 。
Durbin-Watson 检验
显示 Durbin-Watson 统计量，以检验误差是否具有一阶自相关。其中还将显示残差的自相关。Durbin-Watson 表有一个弹出式命令，可用于计算并显示与统计量相关的精确概率。此 Durbin-Watson 表只有在您怀疑误差与时间相关时才适用于时间序列数据。
注：如果有许多观测值，计算 Durbin-Watson 精确概率可能很耗时。计算所需的空间和时间将分别按观测值个数的平方和立方函数而增加。

保存命令

保存子菜单提供了以下选项。每个选项都将在当前数据表中生成一个或多个名为如下所示的新列，其中 colname 为响应变量的名称：

预测公式
创建一个名称为 Pred Formula colname 的新列，其中包含由指定模型计算出的预测值。该列与保存预测值列不同，因为预测公式与新列保存在一起。这对预测新行中的值或获得模型拟合的情况很有帮助。
使用列信息命令并单击编辑公式按钮可查看预测公式。如果模型较大，预测公式可能需要较大空间。如果不需要公式有预测值列，请使用保存预测值选项。有关公式的信息，请参阅《JMP 用户指南》。
预测值
创建一个名称为 Predicted colname 的新列，其中包含由指定模型计算出的预测值。
残差
创建一个名称为 Residual colname 的新列存放残差，其中残差等于观测到的响应值减去预测值。
均值置信区间
创建名称为 Lower95% Pred colname 和 Upper95% Pred colname 的两个新列。新列包含拟合直线的 95% 置信上下限。
注：如果按下 Shift 键并选择保存均值置信区间，系统就会提示您输入一个用于计算 α 水平。
个体置信区间
创建名称为 Lower95% Indiv colname 和 Upper95% Indiv colname 的两个新列。这两个新列将包含个体响应值的 95% 置信上下限。
注：如果按下 Shift 键并选择保存个体置信区间，系统就会提示您输入一个用于计算 α 水平。
学生氏化残差
创建一个名称为 Studentized Resid colname 的新列。新列的值等于残差除以其标准误差。
随机编码
创建一个名称为 h colname 的新列。新列的值为矩阵 [image] 的对角值，有时称为随机编码值。
预测值的标准误差
创建一个名称为 StdErr Pred colname 的新列，其中存储预测值的标准误差。
残差的标准误差
创建一个名称为 StdErrResid colname 的新列，其中存储残差值的标准误差。
个体的标准误差
创建一个名称为 StdErr Indiv colname 的新列，其中包含个体预测值的标准误差。
效应杠杆率对
创建一组新列，其中包含各个杠杆率图的值。这些新列由模型中各个效应的 X 和 Y 列组成。这些列的命名方式如下。如果响应列名为 R，效应为 X1 和 X2，则新列名为
X Leverage of X1 for R  Y Leverage of X1 for R
X Leverage of X2 for R  Y Leverage of X2 for R
Cook's D 影响
保存 Cook's D 影响统计量。影响观测值是根据各种准则对参数估计可能有较大影响的那些值。
预测值的标准误差（带公式）
创建一个名称为 Pred SE colname 的新列，其中存储预测值的标准误差。该列与预测值的标准误差选项相同，但是它将公式与该列一起保存。此选项仅在所有效应都连续时才有效。另外，它也可以生成非常大的公式。


统计实例

本节继续本章开头的例子，并使用药物.jmp 数据表（Snedecor 和 Cochran (1967, p.422)）。引言中给出了标记为 a、d 和 f 的三种药物的单因子方差分析，并假定这三组是从 30 个对象中随机选择的。

以响应 Y 和效应药物再次运行该实例。下一节将进行更加深入的分析，同时添加另一个效应 X 在模型中扮演相应角色。

带有对比的单因子方差分析

在单因子方差分析中，将一个不同的均值与按记名变量标识的各个样本（响应）组拟合。要指定 JMP 的模型，请选择一个连续 Y 和一个记名 X 变量，如药物。在本实例中，药物可取值 a、d 和 f。标准最小二乘拟合方法会将此规格转换为一个如下的线性模型：记名变量定义一个拟变量序列，它们只能取值 1、 0 和 -1。该线性模型可写为

在这里可以看出，第一个拟变量记为药物=a，贡献的值为 1，药物=f 为拟变量贡献的值为 -1。

其中为第二个拟变量指定的值如下

最后一个水平不需要拟变量，因为在此模型中其水平是通过减去所有其它参数求出的。因此，所有水平中的系数总和为零。

按照参数化表示的这三个水平的均值估计如下：

求出 β 的值，得到

（水平的平均值）

因此，如果回归量变量按各水平的指标减去最后一个水平的指标进行编码，则一个水平的参数将解释为该水平的响应与所有水平的平均响应之差。

上图为根据药物数据的单因子分析得出的“参数估计”报表和“效应检验”报表。本章开头的"最小二乘均值表和刻画图" 所示为药物效应的“最小二乘均值”报表和“刻画图”。

使用最小二乘均值的对比可对药物效应进行更深入的研究。为此，请单击药物效应标题旁边的弹出式图标，然后选择最小二乘均值对比获得“对比”设置对话框。

单击药物 a 和 d 的 + 框以及药物 f 的 - 框，以定义将药物 a 和 d 与 f 进行比较的对比（如"药物试验的对比实例" 所示）。然后单击完成，获得“对比”报表。该报表表明使用一个自由度的比较检验药物效应显得更加显著；药物 f 的最小二乘均值与其它两种药物的最小二乘均值的平均值显著不同。

药物试验的对比实例

协方差分析

添加了回归量项的方差分析模型称为协方差分析。假定数据同上，但是具有一个附加项 X3，在公式中作为新的回归量。X1 和 X2 继续充当对记名效应三个水平进行索引的拟变量。该模型可写为

现在有了一个截距和两个效应，其中一个是使用两个参数的记名主效应，另一个是使用一个参数的区间协变量回归量。

重新运行（Snedecor 和 Cochran）药物.jmp 实例，但是向模型效应中添加 x 作为一个协变量。与主效应模型（仅限于药物效应）相比，R 平方从 22.8% 上升到 67.6%，残差的标准误差从 6.07 下降到 4.0。整体模型的 F 检验显著性从 0.03 下降到 0.0001 以下。

有时，您可以研究协变量的函数贡献。例如，协变量经过某些变换后的拟合效果可能更佳。如果偶巧数据的回归量效应具有完全重复观测值，则可以将总误差划分为两个成分。一个成分将估计所有 x 值都相同的数据中的误差。另一个成分将估计可能包含未指定函数形式的协变量的效应的误差，或记名效应的交互作用。这是失拟合检验的基础。如果拟合不足误差显著，则“模型拟合”平台会发出警告，说明数据中有些效应没有由模型解释。请注意，本实例中没有显著失拟合误差，这可从较大概率值 0.7507 看出。

协变量 X 具有一个关于药物的替代效应。它解释了前面药物变量解释的响应中的大部分变异。因此，即使模型的拟合误差小得多，药物效应也不再显著。此前在主效应模型中观测到的效应现在在一定程度上似乎可以按协变量的值进行解释。

最小二乘均值与普通均值不同，这是因为它们已在响应 Y 上为 X 的效应（即协变量）进行了调整。现在最小二乘均值是您药物三个值中每一个值的期望预测值，其中假定协变量 X 保持为某个常数值。为了方便，在此将该常数值选为协变量的均值，即 10.7333。

由此，预测方程给出如下所示的最小二乘均值：

拟合方程式：
 -2.696 - 1.185*药物[a-f] - 1.0761*药物[b-f] + 0.98718*x
a：
 -2.696 - 1.185*(1) -1.0761*(0) + 0.98718*(10.7333) = 6.71
d：
 -2.696 - 1.185*(0) -1.0761*(1) + 0.98718*(10.7333) = 6.82
f：
 -2.696 - 1.185*(-1) -1.0761*(-1) + 0.98718*(10.7333) = 10.16

由于有两个效应，因此现在有针对整体模型的杠杆率图和针对各个效应的杠杆率图。如果协变量没有影响，则药物的杠杆率图与"药物检验数据的杠杆率图比较" 中所示的将没有很大不同。但是，如果由于协变量有很大影响，药物的杠杆值就与其最小二乘均值差得较远。

药物检验数据的杠杆率图比较

上述杠杆率图高亮度显示了三个点 5、17 和 29，说明了以下情形：

  • 点 29 使药物看起来较不显著，而使 x 看起来较显著。它将药物的杠杠拟合直线的右端向均值线方向拉拢，从而减小其斜率。它将 x 的杠杠拟合直线的左端拉离均值线，从而增大其斜率。
  • 类似地，点 5 使药物看起来较显著，使 x 较不显著。
  • 点 17 对药物和 x 两者的显著性检验同等重要。它的残差很小，但是远离 x 轴。这意味着，如果从模型中移除一个或两个效应，其残差就会很大。

“保存”菜单中的保存预测公式命令将使用此处显示的预测公式在数据表中创建一个名称为 Pred Formula Y 的新列。

使用此命令时，JMP 首先试图从刻画器中（如果使用了该选项）或从响应列中找到一个包含合意性函数的“响应限”特性。如果稍后重置了意愿，则会影响随后的保存操作，但是不影响已保存的列。

不同斜率的协方差分析

本实例是上一节中给出的药物.jmp 实例的继续。实例中使用的数据来自 Snedecor 和 Cochran (1967, p.422)。对具有值 a、d 和 f，且名称为药品的变量的单因子方差分析显示：药物主效应与显著性概率 0.03 之间的均值响应存在差异。

对具有主效应药物和协变量 x 的模型的失拟合检验不显著。但是，为了说明的需要，本实例包括了主效应和药物*x 效应。此模型将检验协变量的回归对于不同的药物水平是否有独立的斜率。

本设置将向线性模型中添加两列（名称为 X4 和 X5），允许协变量的斜率对于各个药物水平都不相同。新变量是通过将药物的拟变量乘以协变量值方式构成的，形式如下

"不同斜率的协方差分析编码"表明了模型和效应 x 的显著性。注： X 的均值为 10.7333。

不同斜率的协方差分析编码
回归量 | 效应 | 值
X 1 | 药物[a] | 如果为 a，则为 +1；如果为 d，则为 0；如果为 f，则为 -1
X 2 | 药物[d] | 如果为 a，则为 0；如果为 d，则为 ＋1；如果为 f，则为 -1
X 3 | X | X 的值
X 4 | 药物[a]*(X - 10.733) | 如果为 a，则为 +X - 10.7333；如果为 d，则为 0；如果为 f，则为 -(X - 10.7333)
X 5 | 药物[d]*(X - 10.733) | 如果为 a，则为 0；如果为 d，则为 +X - 10.7333；如果为 f，则为 -(X - 10.7333)

R 平方从针对具有相同斜率的协方差分析的 67.63%（请参阅上一实例）增加到针对不同斜率的模型的 69.2%（“拟合汇总”表未在此处显示）。独立斜率模型将失拟合误差（"失拟合表的比较"）的两个自由度转移到该模型，将该模型的 DF 从 3 增加到 5，如"方差分析表的比较" 所示。

失拟合表的比较

在"方差分析表的比较" 中的两个“失拟合”表中所示的纯误差相同，这是因为独立斜率协方差模型中没有新变量。独立斜率模型中的新效应是根据原始协方差分析模型中的效应构造而成的。

方差分析表的比较

其它报表为“最小二乘均值”表和其它详细资料。在“效应检验”报表中，药物和药物*x 效应都不显著。拟合不同斜率将导致调整各种药物的最小二乘均值，并稍微增加其标准误差。

"不同斜率的模型的杠杆率图" 中的杠杆率图表明了模型和 x 效应的显著性。本图中，药物 a 标记为正方形，药物 d 标记为三角形，药物 f 标记为菱形。药物主效应没有原来显著，且独立斜率协变量将吸收它的一些效应。您可以高亮度显示点 5 和 25，这是对独立斜率效应有较大影响仅有的两个点。

不同斜率的模型的杠杆率图

为了对药物数据的拟合进行汇总，以下三个图分别说明的问题是：

  • 简单主效应模型（"简单均值模型示意图"）
  • 具有协变量和常用斜率的模型（"协方差分析模型示意图"）
  • 具有协变量和独立斜率的模型（"具有不同斜率的协方差模型示意图"）

它们同时还显示了最小二乘均值的构造。作为练习，您可以使用“以 X 拟合 Y”分组功能平台和表菜单中的堆叠表操作构造这些图形。

"简单均值模型示意图" 所示为一个散点图，使用按各个药物组的均值绘制的线条来说明模型 y = 药物。

简单均值模型示意图

"协方差分析模型示意图" 所示为一个散点图，使用按各个药物组的相同斜率绘制的直线来说明模型 y = 药物, x。

协方差分析模型示意图

"具有不同斜率的协方差模型示意图" 所示为一个散点图，使用按各个药物组的不同斜率绘制的直线来说明模型 y = 药物, x, 和药物*x。

具有不同斜率的协方差模型示意图


标准最小二乘：估计透视

模型拟合平台

虽然拟合平台通常都可以生成关于效应的参数预测值和检验报表，但其它许多选项也可以使结果更易于理解。以下部分解决了这些问题：
  • 如何解释记名因子的估计？如何获得缺失水平系数？
扩展估计值
  • 如何以固定尺度方式测量统计效应大小？
尺度无关估计
  • 如果有包含多种效应但观测值较少的筛选设计，
    那么如何确定相当大的有效效应？
效应筛选选项
  • 如何实现一系列的效应检验，即使在设计不平衡的
    情况下，这些独立检验的平方和都将等于总和值？
序贯检验
  • 如何检验某些特定的组合？
自定义检验
  • 如何预测（向后）可得到给定 y 值的 x 值？
反预测
  • 如果收集了更多的数据，效应是变得怎样更加显著，是有不同的效应大小呢，还是有不同的误差方差？
功效分析
  • 估计相关的程度如何？
估计值的相关性

目录

估计值和效应筛选菜单

显示预测表达式

扩展估计值和记名项编码

尺度无关估计和连续项编码

序贯检验

定制检验

反预测

参数功效

功效分析对话框

效应大小

功效分析的文本报表

功效对样本大小图

最小显著值 (LSV)

最小显著数 (LSN)

功效

调整的功效和置信区间

前瞻功效分析

估计值的相关性

效应筛选

Lenth 方法

参数估计总体

正态图

半正态图

贝叶斯图

因子活性贝叶斯图

Pareto 图


估计值和效应筛选菜单

大部分模型拟合结果均为可选。如果在顶端外框层单击响应名称旁边的弹出式菜单图标，"最小二乘分析命令：估计值和效应筛选菜单" 中所示的菜单将列出可用于连续响应模型的命令。

最小二乘分析命令：估计值和效应筛选菜单

“模型拟合”平台的特定细节取决于执行的分析类型以及请求的选项和命令。弹出式图标可以列出分析的每个水平所包含的命令和选项。通常，您可以通过这些菜单项访问所有的表格和图形。此外，您还可以使用首选项或脚本命令来更改结果的默认排列。

本章将重点介绍估计值和效应筛选菜单中的选项，包括反预测和参数功效的讨论。


显示预测表达式

显示预测表达式命令在报表中放入预测表达式。


扩展估计值和记名项编码

扩展估计值适用于模型中包含分类（记名）项并且您需要一组完整效应系数的情况。

如果模型中包含了记名项，平台需要构建一组虚拟列来表示分类中的水平。（附录"统计细节"中提供了完整的详细资料。）如果存在 n 个水平，则平台将构建 n - 1 个虚拟列。除最后一个水平会将所有拟变量都编码为 -1 外，其它拟变量将以 0 或 1 来标识特定水平。例如，A 列包含水平 A1、A2 和 A3，则 A1 和 A2 的拟列显示如下。

这些列并不会显示出来。它们只是为了让完成拟合的方法概念化。参数估计是与这些列拟合的系数。在此情况下，存在两个参数估计，分别标记为 A[A1] 和 A[A2]。

此编码方法使得参数估计可被解释为每个水平的响应与所有水平的平均值存在多大差异。但是，假设您要让最后一个水平的系数为 A[A3]，那么最后一个水平的系数将是其它水平总和的负数，因为所有水平的总和被限制为零。尽管还有许多其它可能的编码方法，但是这种编码方法已被证明是一种实用、明了的方法。

然而，您可能不希望手动计算最后一个水平的估计。估计值菜单中的扩展估计值命令可以计算这些缺失的估计，然后在文本报表中显示结果。您可以验证某个分类中估计的均值（或总和）是否为零。

请记住，对于二水平因子的深度交互，扩展估计值选项将生成一个冗长的报表。例如，二水平因子的五路交互只会生成一个参数，但包含 25 = 32 个扩展系数，这些系数除了符号不同之外均相同。

以上一章的药物.jmp 为例，如果选择了扩展估计值，您将看到最后一个水平是如何扩展的（请参阅"比较参数估计和扩展估计"），而估计体现了最小二乘均值与平均值之间的差异。

比较参数估计和扩展估计

要计算扩展估计，可将提供的总均值减去最小二乘类别均值：

  5.3 - 7.9 = -2.6
  6.1 - 7.9 = -1.8
 12.3 - 7.9 =  4.4


尺度无关估计和连续项编码

参数估计与因子尺度紧密相关。如果将因子由克转换为千克，参数估计将乘以 1000。如果对平方（二次）项执行相同的转换，尺度将乘以 1,000,000。如果要关注效应大小，那么您应以更稳定的固定尺度来检验估计。这意味着从任意尺度转换为有意义的尺度，从而将估计大小与响应效应大小相联系。有多种方法可以达到此目的。在 JMP 中，效应筛选菜单中的尺度无关估计命令可以给出与因子对应的系数，而这些因子在尺度无关操作后的均值为 0，并包含两个范围。如果数据中的因子呈对称分布，则尺度无关因子的值范围为 -1 至 1。这相当于试验设计 (DOE) 惯例中使用的缩放比例。因此，对于简单回归量，尺度无关估计应为预测响应变化量的一半，因为回归因子涵盖了其整个范围。

在对使用未编码值的试验数据评估效应大小时，尺度无关估计较为重要。如果使用了已编码值（-1 至 1），则尺度无关估计与常规估计相同。

同样，如果因子具有编码列特性，则您不需尺度无关估计。在该情况下，如果对模型进行了估计且结果可被解释为效应大小，这些因子将被转换为未编码的形式。

如果选择了尺度无关估计，屏幕将出现如此处所示的估计表。如报表所示，估计是均值居中且按范围一半转换尺度的参数。

尺度无关估计还将考虑多项式（交叉连续）模型，即使这些模型尚未被参数化的中心化多项式（默认启动选项）中心化。


序贯检验

序贯检验可以显示在模型拟合中输入每种效应时残差平方和的减少。序贯检验也称为第一类平方和 (Type I SS)。Type I SS 所具有的理想特性在于它们彼此独立，并且其和等于回归平方和。而此类平方和的缺点在于它们须取决于模型中项的顺序。只能对模型中先前的效应加以调整。

以下模型被认为适于第一类假设：

  • 以正确顺序指定的平衡数据的方差分析模型（即交互不早于效应列表中的主效应，诸如此类）
  • 以正确顺序指定的完全嵌套模型
  • 以正确顺序指定的多项式回归模型


定制检验

如果要检验一个定制假设，请从估计弹出式菜单中选择定制检验。这时将显示如"年龄变量的定制检验对话框和检验结果" 左侧所示的对话框，用以根据所有参数构建检验。在完成检验填写后，请单击完成。该对话框随后将切换至结果报表，如"年龄变量的定制检验对话框和检验结果" 右侧所示。

定制检验标题栏下方的编辑区域可用于输入检验名称。请使用如下所示的“自定义检验”对话框：

参数
可以列出模型参数的名称。参数列表右侧的列包含与这些参数对应的零值。单击其中某个单元格，然后输入一个与所需检验对应新值。
添加列
可以添加一个零值列，以便同时检验参数的多个线性函数。使用添加列按钮可以为检验添加所需的列。

“参数”列表中的最后一行标记为 =。您可以在该框中输入一个常数，以便对线性约束进行检验。例如，要检验假设 β0=1，请在 = 框中输入 1。在"年龄变量的定制检验对话框和检验结果" 中，常数等于 0。

在完成检验指定后，单击完成以查看所执行的检验。结果将附加在对话框的底部。

在完成定制检验后，报表将列出检验名称、被检验参数的函数值、标准误差以及对话框中每个检验列的其它统计量。所有列的联合 F 检验将显示在底部。

警告：检验通常针对残差。在模型中存在随机效应的情况下，如果使用 EMS 代替 REML，则此检验可能不适用。

注：如果在分类效应中进行检验，请考虑使用对比对话框代替定制检验，前者将检验假设的最小二乘均值。

年龄变量的定制检验对话框和检验结果


反预测

要查找给定 y 的 x 值，您需要进行反预测，有时也称为校准。估计值菜单中的反预测命令可以显示一个对话框（"模型拟合平台给定的反预测"），以便您在指定因变量值和其它 x 值的情况下寻找一个特定的自变量 (X) 值。反预测计算中包括预测的置信限（置信范围）。

例如，使用 Sample Data 文件夹中的健身.jmp 文件并将摄氧量指定为 Y，骑行时间指定为 X。在只有单个 X 的情况下，如本实例，“以 X 拟合 Y”平台可以提供反预测值的直观估计。此处的图形为“以 X 拟合 Y”散点图，并已启用拟合直线选项。十字准线工具可用于查看反预测的近似值。要查看摄氧量值为 50 时所对应的骑行时间值，请将十字准线工具的水平线对准摄氧量轴上的 50 刻度，然后将十字准线的中心点定位在预测线上。垂直十字准线与骑行时间轴交点位置的值约为 9.75，即反预测值。

但是，要查看骑行时间的精确预测，请使用“模型拟合”对话框并将摄氧量指定为 Y 变量，将骑行时间指定为单个模型效应。单击运行模型，然后从估计菜单中选择反预测。在出现“反预测”对话框时，输入一个或多个摄氧量值，如"模型拟合平台给定的反预测" 所示。如果单击运行，该对话框将消失，"模型拟合平台给定的反预测" 中所示的“反预测”表将提供每个指定摄氧量值对应的精确预测值，同时显示 95% 的置信上限和下限。当摄氧量为 50 时，骑行时间的精确预测值为 9.7935，这与使用“以 X 拟合 Y”平台得出的预测值 9.75 相近。

模型拟合平台给定的反预测
模型拟合平台给定的反预测

注：置信限是通过 Fieller 方法而得出。有时，此方法会导致退化（外部）区间，并且 JMP 将报告出现缺失值。有关计算置信限的详细信息，请参阅附录"统计细节"。

如果模型中存在多种效应，反预测命令还可以预测单个 x 值。要预测单个 x，请提供一个或多个感兴趣的 y 值，然后设定您要作为缺失值预测的 x 值。默认情况下，其它 x 值被设定为回归量的均值，但您可以将其更改为任何需要的值。"多重回归模型的“反预测”对话框" - "多重回归模型的反预测" 中的实例显示了用于预测骑行时时间的对话框及其结果，其中摄氧量为 Y，骑行时间、骑行时脉搏和静止时脉搏为回归量。

多重回归模型的“反预测”对话框
多重回归模型的反预测


参数功效

假定您想了解在给定 α 水平下试验检测到某些差值的可能性。获得显著检验结果的概率称为功效。功效是检验的未知参数值、样本大小以及未知残差方差的函数。

或者，假定您已完成试验但效果并不明显。如果您觉得有更多的数据将使效果显著，那么请好好预计一下自己还需要多少数据。

JMP 提供了下列统计功效计算方法以及其它与给定假设检验相关的详细资料。

  • LSV 即最小显著值，它是某些参数或参数函数的值，能够产生某个 p 值 alpha。
  • LSN 即最小显著数，它是在数据具有相同结构并作为当前样本用于估计的情况下，能够产生特定 p 值 alpha 的观测值数。
  • 功效是给定的检验达到或低于给定 p 值 alpha 的概率。

LSV、LSN 和功效值是可用于所有检验统计量的重要测量标准，尤其是在检验统计量无法突出显著性时，这些值特别重要。如果某个结果并不显著，试验者至少应知道结果在估计范围内（而不是概率中）与显著标准的差距，以及还需要多少附加数据才能确认给定参数值的显著性。

有时，初学者会混淆零虚假设的作用，认为无法否定虚假设就等于证实了该假设。正因如此，建议您从其它可体现检验灵敏度的方面（功效和 LSN）来验证检验。如果某项分析表明没有显著差异，则了解检验可能检测到的最小差值 (LSV) 将很有用。

JMP 提供的功效详细信息可用于前瞻功效分析和回顾功效分析。前瞻分析用于研究的计划阶段，可以确定样本必须达到多大才能获得假设检验中的期望功效。有关更多信息和完整实例，请参阅章节"前瞻功效分析"。回顾分析用于数据分析阶段，可以确定已执行的假设检验的功效。

功效、LSN 和 LSV 的技术详情在章节"功效计算"和附录"统计细节"中介绍。
对实际样本大小和估计效应大小计算回顾功效稍显信息不足，甚至存在争议 [Hoenig and Heisey, 2001]。当然，它并不会为显著性检验提供附加信息，而是以不同的角度来说明检验。但是，我们相信许多研究正是由于没有足够的样本大小来检测有意义的效应大小而导致了失败，因此的确需要某些功能对指定的效应大小和样本大小加以进一步的研究。 有关更多信息，请参阅 John M. Hoenig 和 Dennis M. Heisey (2001) 所著 The Abuse of Power: The Pervasive Fallcay of Power Calculations for Data Analysis，American Statistician (v55 No 1, 19-24)。

功效命令仅适用于连续响应模型。功效和其它检验详细信息可用于以下情况：

  • 如果需要所有参数估计的 0.05 水平的详细信息，请使用估计值菜单中的参数功效命令。这将为线性模型中每个参数的 0.05 alpha 生成 LSV、LSN 和调整功效。
  • 如果需要某个效应的 F 检验的详细信息，请从该效应的详细资料下方的弹出式菜单中选择功效分析命令。
  • 如果需要某个对比的详细信息，请从效应标题旁边的弹出式菜单中创建对比，然后在对比旁边的弹出式菜单中选择功效分析。
  • 如果需要某个自定义检验的详细信息，请首先使用平台弹出式菜单中的定制检验命令创建所需的检验，然后在“定制检验”旁边的弹出式菜单中选择功效分析命令。

除第一种情况外，您可以在“功效分析”对话框中为所需的计算输入信息。

功效分析对话框

“功效分析”对话框（"功效分析对话框"）可以显示有关检验细节的情境和选项。您可以按照以下说明填写值，然后单击完成。结果将附加在报表的末尾位置。

以下实例使用样本数据文件夹中的大班.jmp 数据表。模型拟合脚本生成报表，您可以从该报表中获取功效实例。

功效分析对话框

对于 Alpha、Sigma、Delta 和数值四列中的每一列，您都可以填写单个值、两个值，或起始值、终止值以及多个值的增量，如"功效分析对话框" 中的对话框所示。您可以对指定值的所有可能的组合执行功效计算。

Alpha (α)
为显著性水平，其值介于 0 与 1 之间，通常为 0.05、0.01 或 0.10。开始时，Alpha 值自动默认为 0.05。单击这三个位置之一，然后输入或编辑一个、两个或多个值。
Sigma (σ)
为模型中残差的标准误差。开始时，此处的值自动默认为 RMSE（均方根误差）。单击这三个位置之一，然后输入或编辑一个、两个或多个值。
Delta (δ)
为原始效应大小。有关详情，请参阅"效应大小"。第一个位置的值最初设定为假设平方和的平方根与 n 之商。单击这三个位置之一，然后输入或编辑一个、两个或多个值。
数值 (n)
为样本大小。开始时，实际样本大小位于第一个位置。单击这三个位置之一，然后输入或编辑一个、两个或多个值。

单击以下复选框以请求所需的结果：

功效求解
选定此复选框可以求出作为 α、σ、δ 和 n 函数的功效（显著结果概率）。
最小显著数求解
选定此复选框可以求出要获得给定 α、σ 和 δ 的显著性 alpha 值而预计所需的观测的数量。
最小显著值求解
选定此复选框可以求出生成 alpha p 值的参数值或线性检验值。这是 α、σ 和 n 的一个函数。此功能仅适用于单自由度检验，同时用于单个参数。
调整的功效和置信区间
要回顾考察功效，您可以使用标准误差和检验参数的估计。调整功效是根据非中心参数的无偏估计计算得出的功效。调整功效的置信区间基于非中心估计的置信区间。只能为原始 σ 值计算调整功效和置信限，因为其中存在随机变异。

效应大小

功效是在给定与假设相关的非中心参数的情况下，F 检验达到 α 临界值的概率。当虚假设为真，即零效应大小为零时，非中心参数为零。非中心参数 λ 可被分解为三个部分，在 JMP 功效对话框中指定为如下形式：

λ = (nδ2)/s 2

功效按 λ 递增，这意味着它将按样本大小 n 和原始效应大小 δ 递增，按误差方差 σ2 递减。有些书 (Cohen 1977) 中使用标准化效应大小而非原始效应大小，即 Δ = δ/σ，将非中心参数分解为两个部分 λ = nΔ2。

Delta (δ) 最初设定为由 SSH/n 平方根给定的估计所隐含的值，其中 SSH 为假设的平方和。如果对 delta 使用此估计，您可能需要通过获得“调整功效”来纠正偏差。

特殊情况下，k 水平均衡单因子布局为

因为 JMP 参数的形式为

其中

二水平均衡布局的 delta 为

功效分析的文本报表

功效分析工具可以计算功效，作为在“功效分析”对话框中指定的 α、σ、δ 和 n 值的每种组合的函数。

  • 对于“功效分析”对话框中 α、σ 和 δ 的每种组合，它可以计算最小显著数。
  • 对于 α、σ 和 n 的每种组合，它可以计算最小显著值。

例如，如果运行如"功效分析对话框" 所示的请求，您将得到"功效分析表" 中所示的表。

功效分析表

如果在“功效分析”对话框中选定了调整的功效和置信区间，则“功效”报表将包含调整功效、控制下限和控制上限列。"包含置信限的功效分析表" 中的表显示了最小显著数的请求结果，以及数值在 10 至 20 间（增量为 2）时的功效和置信限。

包含置信限的功效分析表

功效对样本大小图

“功效”报表底部的弹出式命令提供了命令功效图，可以按功效表中的 N 个列标绘功效。"功效对样本大小图" 右侧的图形显示了标绘"功效分析表" 中实例表时获得的结果。此图形在大刻度标记上增加了水平和垂直网格线。双击坐标轴并填写对话框，以更改刻度标记并在坐标轴上添加网格线。

功效对样本大小图

最小显著值 (LSV)

在执行单自由度假设检验后，您通常都需要了解检验的灵敏度水平。换句话说，您想要知道某个效应在某个 p 值 alpha 处所表现的显著性小到何种程度。LSV 提供了一种按参数尺度而并不是按概率尺度表示的显著性测量标准。它表明了设计和数据的灵敏度。通过高亮度显示在数据中检测到多小的值才具有显著性，它可以促进与零虚假设相关的正确统计直觉。

  • LSV 是参数必须大于或等于绝对值的值，以便为显著性检验的 p 值提供一个小于或等于 alpha 的值。
  • LSV 是参数的置信区间半径。1-alpha 置信区间是将参数估计加上或减去 LSV 而得。
  • 当且仅当其显著性检验的 p 值正好等于 alpha 时，参数的绝对值或被检验参数的函数等于 LSV。

将参数估计的绝对值与 LSV 对比，如果参数估计的绝对值较大，则参数与零存在显著差异，如果 LSV 较大，则参数与零不存在显著差异。

最小显著数 (LSN)

LSN 或最小显著数定义为将估计方差减至足够小，以达到给定的 alpha、sigma 和 delta 值（分别为显著性水平、标准差和效应大小）的显著性结果而所需的观测的数量。如果您需要更多的数据点（更大的样本）才能达到显著性目标，LSN 将告诉您还需要多少。

注：LSN 并不会建议要采集多大的样本，因为 LSN 的显著性（功效）概率只有大约 0.5。

LSN 具有以下特征：

  • 如果 LSN 小于实际样本大小 n，则效应显著。这意味着您现有的数据超过了在给定的 alpha 水平检测显著性所需的数据量。
  • 如果 LSN 大于 n，则效应不显著。在此情况下，如果您认为更多数据将得到与当前样本相同的标准误差和相同结构的结果，则 LSN 将建议需要多少数据才能达到显著性目标。
  • 如果 LSN 等于 n，则 p 值等于显著性水平 alpha。检验已接近于显著水平。
  • 当 n = LSN 时计算得出的功效（如下所述）始终大于或等于 0.5。

功效

功效是指获得显著性结果的概率。它是样本大小 n、效应大小 δ、标准差 σ 和显著性水平 α 的函数。功效将告诉您试验在给定的 α 水平检测到差异的可能性有多大。功效具有以下特征：

  • 如果参数的真实值为假设值，则功效应为 alpha，即检验的大小。如果为真，则您不会拒绝该假设。
  • 如果参数的真实值并非假设值，则您希望功效尽可能大。
  • 功效会随样本增大而增大。它还会随误差方差的减小而增大。功效会在真实参数远离假设值时递增。

调整的功效和置信区间

因为功效是未知总体数量的函数，在功效计算过程中替换样本估计是常用的做法（Wright 和 O'Brien 1988）。如果将这些样本估计视为随机值，则您可以对其进行调整，以获得更准确的期望值。您也可以为此调整功效构建置信区间；但是，置信区间的范围通常非常大。只能为原始的 δ 值计算调整的功效和置信区间，因为其中存在随机变异。有关调整功效的详情，请参阅附录"计算调整功效"中的"统计细节"。

前瞻功效分析

前瞻分析可以帮助您回答“在给定建议样本大小、群内方差估计和 alpha 水平的情况下，是否能检测到前瞻的群组差异？”在前瞻功效分析过程中，您必须在“功效分析”对话框中提供数据表中的组均值和样本大小的估计，以及群内标准差 σ 的估计。

试验设计菜单中的样本大小与功效命令提供了一个工具，可以在给定 alpha 和误差标准差的情况下计算要检测的功效、样本大小或效应大小。您可以提供其中的两个值，“样本大小与功效”功能将计算第三个值。如果您只提供其中一个值，结果是出现其它两个值的图。此功能适用于单样本、两个样本和 k 个样本的情形，并可以假定样本大小均相等。对于不相等的样本大小，您可以按如下实例执行操作。

本例出自 Wright 和 OBrien (1988)。牙科医生 Noah Decay 博士计划进行一次试验，对两种可减少牙斑的治疗方法加以对比。Decay 博士相信控制组和两种治疗方法的均值分别为 32、26 和 24，群内标准差介于 6 和 9 之间。控制组中的病人数量是每个治疗组的两倍。

为了对组效应检验执行前瞻功效分析，Decay 博士必须首先创建如下所示的数据表，其中有组号、均值和个数三个列，分别包含组名称、组均值和建议的组大小。您可以打开 Noah Decay.jmp 样本数据表查看这些内容。

Decay 博士使用“模型拟合”平台设置了单因子方差分析（如下所示）。请注意，样本大小变量 N 被指定为个数。此外，最小报表重点选项已生效。

分析结果表明，平方和误差与均方误差为零。但是，Decay 博士怀疑标准差应介于 6 和 9 之间。于是，他从“效应详细资料”下方的组号报表弹出式菜单中选择了功效分析，同时选定了功效求解和最小显著数求解。随后，"前瞻分析的功效详细信息和功效对 N 图" 右侧所示的“功效分析”对话框将列出 alpha = 0.05，样本大小为 40 至 80（增量为 20）以及标准差 (sigma) 为 6 至 9（增量为 1）的所有组合。

显示的 Delta 值是根据指定均值计算而得。前瞻功效分析将使用总体值，而该值提供了一个无偏非中心参数值，因此调整功效和置信限并不相关。

前瞻分析的功效详细信息和功效对 N 图


估计值的相关性

估计平台菜单中的估计值的相关性选项可以为模型中的所有效应生成相关矩阵。此处的实例使用了轮胎刻印数据，包括作为响应的磨损、作为因子的二氧化硅和硅烷以及它们的交互作用。

估计值的相关性报表


效应筛选

效应筛选命令有助于检查效应大小。尺度无关估计命令在前面"尺度无关估计和连续项编码"讨论尺度转换问题时已加以了介绍。在这里，我们将讨论其它一些效应筛选命令。这些命令可对尺度转换和估计间的相关性加以校正。这些效应筛选命令功能的实现须注意以下三个方面：

  1. 拟合过程可视作是将一组随机值（响应值）的实现转换为另一组随机值（参数估计）的实现。如果是平衡设计，即每个因子都具有相等数量的水平，那么这些估计将呈独立均匀分布，正如响应一样。如果参数与数据点一样多，它们的方差甚至都会与响应一样。
  2. 如果正在拟合的筛选设计具有多种效应且仅运行数次，那么您将只希望少数几个效应有效。也就是说，少数效应具有相当大的影响，而其它效应无效（估计为零）。这就是所谓的效应稀疏性假设。
  3. 如果给定上述的 1、2 两点，您可以考虑将筛选用于确定哪些随机值在零附近的效应无效、哪些是离群值而不是无效效应分布的一部分。

因此，您可以将估计本身视为一组数据，以帮助确定有效和无效的效应。如果运行次数较少且误差自由度较小或没有，那么将没有可用的典型显著性检验，此时就需要使用这种方法。

最后三个效应筛选命令正是以这种方法来考察参数。Lenth's PSE 和“参数估计总体”表是两个默认的报表，其中的显著性因子已呈高亮度显示。效应筛选命令还带有一个子菜单，可通过使用尺度无关估计和三个图形来从不同角度考察模型参数。

效应筛选

以下内容是对化学反应.jmp 数据执行分析的说明，分析中使用了 Ct、A、T 和 Cn 这四个因子并在模型中包含了所有的二因子交互作用。

Lenth 方法

标准误差的估计是使用 Lenth (1989) 方法计算而得并显示在“效应筛选”表中（如上所示）。此估计称为伪标准误差，是在整个估计组中除去所有大于中位数绝对值的 3.75 倍的估计后，将剩余估计的中位数绝对值乘以 1.5 所得出的值。

参数估计总体

大多数关于效应大小的推论会首先假定估计不相关且具有相等方差。对于部分因子设计和某些传统试验设计而言的确如此。但对于另一些设计则不正确。最后三个效应筛选命令可以显示“参数估计总体”报表，其中首先将确定估计的相关性，同时告诉您估计是否不相关以及是否具有相等方差。

如果估计相关，则可以应用标准化变换使它们不相关并具有相等方差。如果存在误差方差估计，则变换后的估计方差接近于 1 并与 t 比率相同。如果无法获得误差方差的估计，则变换后的估计方差与误差方差相同。

如果估计不相关且具有相等方差，则系统将显示以下附注，而分析过程简单直接。

  • 参数估计具有等方差
  • 参数估计不相关。

如果估计相关且（或）具有不等方差，则两个附注栏将显示为弹出式菜单，表明它已转换估计，同时为您提供撤消变换的选项。

如果您单击这些弹出式菜单并撤消两个变换，则这两行将显示如下内容：

可使估计不相关的变换功能与用于计算连续平方和的变换功能相同。在将所有以前的变量输入到模型后，估计可以测量变量的附加贡献。

此处显示了一个“参数估计总体”表，其中包含以下列：

原始
列出了拟合线性模型的参数估计。这些估计只有在 X 转换为相同尺度后才可比较大小。
正交编码
包含了正交估计。这些值可用于 Pareto 图，因为该图形将划分效应总和，这便需要正交性。正交值是用 XX 的 Cholesky 根自左乘原始估计的列向量计算而得。这些估计将取决于模型顺序，除非原始设计具有正交性。
如果是正交平衡设计，则这些估计将与原始估计相同。否则，在将每个效应与它之前的效应进行正交之后，系统将测量该效应的贡献。
正交 t 检验
列出了变换后呈独立均匀分布的参数估计。这些值用于需要不相关的相等方差估计的正态图（稍后介绍）中。与正交 t 检验估计关联的 p 值（在 p 值 > |t| 列中提供）与第一类序贯检验等效。这意味着如果模型的参数相关，则估计及其 p 值取决于模型中项的顺序。正交 t 检验估计是正交估计（正交编码估计）与其标准误差之商。正交 t 检验值使 JMP 能够将估计视为随机样本中的值，以用于正态图或 Bayes 图。
p 值 > |t|
是显著性水平或与正交 t 检验列中的值相关联的 p 值。

正态图

正态图命令可以显示“参数估计总体”表（已在前面章节中介绍），同时提供这些参数估计的正态图 (Daniel 1959)。估计位于垂直轴，而正态分位数位于水平轴。化学反应.jmp 筛选模型中 Y 的正态图如"Reactor 数据二因子交互正态图" 所示。如果所有效应归因于随机干扰，则它们将沿斜率为 σ 的标准误差直线分布。斜率等于 Lenth's PSE 估计的直线显示为蓝色。如果存在误差自由度，则斜率等于均方根误差 (RMSE) 的直线显示为红色。

正态图有助于您找出偏离法线的效应。明显偏离的估计将被加上标记。在本例中，A 因子似乎并不重要。不仅如此，其它三个因子（T、Ct 和 Cn）均有效，T（温度）似乎也与 Ct 和 Cn 交互。

Reactor 数据二因子交互正态图

半正态图

正态图的顶部有一个弹出式菜单，如 中的"效应筛选" 所示。

单击该菜单并选择半正态图可以生成估计的绝对值与绝对值正态分布的正态分位数的图形，如"半正态图" 所示。某些分析人员更喜欢使用此图形。

半正态图

贝叶斯图

确定重要效应（有时是指哪种对比有效）的另一种方法是使用贝叶斯定理来计算先验概率。此方法源于 Box and Meyer (1986)，它假定估计是两种分布的混合。某些部分的效应被假定为源于具有小方差的纯随机干扰。其它项则被假定为源于方差是误差方差 K 倍的污染分布。

效应的先验概率是该效应非零（或位于污染项分布中）的几率。这些先验概率通常被设定为与每个效应的值相等，0.2 是常用的建议先验概率值。K 污染系数通常被设定为 10，也就是说污染分布的方差是误差方差的 10 倍。

贝叶斯图是根据已转换为无相关性并且具有相等方差的标准化估计而生成的图形（JMP 称之为正态 t 检验）。要了解 Reactor 实例的 Box-Meyer 贝叶斯分析方法，请从效应筛选菜单中选择贝叶斯图。"“Bayes 图”对话框和 Bayes 图" 左侧显示的对话框面板将要求您填写先验概率和 K 系数。当然，您也可以编辑其它值。没有必要使用非零的 DFE。单击执行便会开始计算后验概率。

“Bayes 图”对话框和 Bayes 图

对于没有误差估计的饱和模型，标准误差尺度字段应设定为 0。如果存在标准误差估计（均方根误差），由于估计已转换并调整为单位方差，所以此字段将被设定为 1。如果在此字段中指定其它值，则该值将被作为 RMSE 估计的尺度因子。

系统列出了最终的后验概率并用条柱进行标绘，如"“Bayes 图”对话框和 Bayes 图" 所示。书本中称之为 Bayes 图。对于未污染样本的输出结果，系统还列出了总体后验概率。此结果是通过以下公式用每个样本 [image] 的后验概率计算而得

因子活性贝叶斯图

JMP 包括一个脚本，让您可以确定设计中哪些因子是活跃的。Sample Scripts 文件夹中的 BayesPlotforFactors.jsl 可用于生成因子活性图。在“反应”数据上打开并运行该脚本（编辑 > 运行脚本），并将 Y 用作 Y，将 F、Ct、A、T 和 Cn 用作因子。这将生成下图。

因子活性贝叶斯图

在此情况下，已指定要考虑的最高阶交互作用为 2。因此，将构造所有可能包括（最多为）二阶交互作用的模型，且根据指定给“先验概率”（请参阅图中的“控制”部分），将为每个可能的模型计算后验概率。因子的概率是其涉及的每个模型的概率总和。

在此实例中，可以看出 Ct、T 和 Cn 活跃，而 A 和 F 不活跃。这符合"“Bayes 图”对话框和 Bayes 图"。

注：如果岭参数为 0（不允许），则所有模型都将通过最小二乘拟合。随着岭参数变大，任何模型的参数估计都将向零收缩。Box 和 Meyer (1993) 中讲解了岭参数（及其为何不能为零）的详情。

Pareto 图

Pareto 图选项可以生成尺度无关估计的绝对值图形，以反映绝对值总和的组成。Pareto 图是根据非正交估计而生成的图形。


标准最小二乘：探索预测方程

模型拟合平台

即使预测方程式估计非常精确，也需要探索该方程式本身，以便回答一系列问题：

  • 预测响应对因子变化的敏感度如何？
  • 响应面具有哪些曲率？
  • 优化响应的因子设置有哪些？
  • 因子空间的角落里有哪些预测值？
  • 响应变换是否会产生更佳的拟合？

本章中说明的工具可用于探索预测方程式，并在假定方程式足够精确的情况下回答这些问题。

目录

刻画简介

刻画器

解释预测刻画器

意愿刻画图

预测刻画器选项

模拟器

因子规格

指定响应

轮胎刻印模拟

模拟通用公式

交互作用图

等高线刻画器

作为独立平台的刻画器

立方图

响应面曲率

参数估计值

典型曲率表

Box Cox Y 变换

曲面刻画器


刻画简介

"用于最小二乘分析的命令和选项" 说明了用于最小二乘拟合特点的相关命令。本章将介绍各个因子刻画命令。以下很多实例都使用化学反应.jmp 样本数据文件。

用于最小二乘分析的命令和选项

以下是各项功能的简短说明，可帮助您决定需要哪部分。

刻画器
显示预测值相对于一次更改一个因子的变化。您可以设置意愿函数，帮助找到可优化响应的因子设置。
交互作用图
一个因子的不同设置下另一个因子的多个刻画图。在具有可调整大小的交互作用时，迹不平行。
等高线刻画器
显示预测值相对于一次更改两个因子的变化。您可以设置约束，帮助在可行区域中优化响应。
立方图
显示因子空间的角落里的预测值。
Box Cox Y 变换
寻找响应的拟合最好的幂变换。
曲面刻画器
以三维图显示一个预测表面。表面图的详细资料将在"控制曲面" 一章中介绍。

注：将拟合方程式作为公式存储在数据表列中时，刻画器、等高线刻画器和曲面刻画器（列为曲面图）也可作为图形菜单平台使用。

在进行响应面分析时，刻画图也很有用。虽然响应面分析不是一个选项，但是当模型具有响应面效应（说明响应相对于因子的曲率类型）时，也会自动生成报表。对于某些响应面模型，此功能可以找到数学意义上的最佳方式。


意愿函数

刻画器

刻画器显示每个 X 变量的预测迹（请参阅"预测迹示意图"）。预测迹是当一个变量发生变化而其它变量保持当前值不变时的预测响应。“预测刻画器”将在您更改 X 变量的值时重新计算迹和预测响应（实时）。

  • 每个 X 变量的垂直点线都显示其当前值或当前设置。如果变量为记名变量，则 x 轴标识类别。有关详情，请参阅"解释预测刻画器"。
对于每个 X 变量，因子名称上的值为其当前值。通过单击图形或将点线拖到希望的新当前值位置，可以更改当前值。
  • 水平点线显示对于 X 变量当前值的每个 Y 变量的当前预测值。
  • 图形上的线条和标记显示了更改单个 X 变量的当前值时预测值的变化。预测值的 95% 置信区间显示为预测迹（连续变量）或误差条（分类变量）周围的点曲线。

“预测刻画器”这种方法一次更改一个变量，并查找预测响应的效应。

预测迹示意图

解释预测刻画器

"将一个因子从 0 更改为 0.75" 中的示意图说明了如何使用预测刻画器的成分。解释预测刻画器时，需要注意几个要点：

  • 因子的重要性在一定程度上可通过预测迹的陡度来评估。如果模型具有曲率项（如平方项），则迹可能为曲线。
  • 如果更改了因子的值，则其预测迹不会受到影响，但是所有其它因子的预测迹会改变。Y 响应线必需经过预测迹与其当前值线条的交点。

注：如果模型中具有交互作用效应或叉积效应，则预测迹可能在您更改其它项的当前值时改变其斜率和曲率。这就是交互作用的功能。如果没有交互作用效应，迹只会改变高度，不会改变斜率或形状。

将一个因子从 0 更改为 0.75

预测刻画器在多重响应模型中尤其有用，可帮助判断哪些因子值可优化一组复杂的准则。

单击图形或向右或向左拖动当前值线条，可更改因子的当前值。响应值将按图形主体中的水平参考线发生变化。如果按住 Alt 键并单击（在 Macintosh 系统中为按住 option 键并单击）图形，就会有一个对话框提示您输入特定当前因子值（单击一次会自动移动当前值线条），然后编辑该因子的其它设置。单击垂直轴时，会显示该点的 X 值。双击一个轴，可弹出一个可用于更改其设置的对话框。

意愿刻画图

通常，每组试验条件都需要测量多个响应，输出结果的意愿涉及到几个或所有这些响应。例如，您可能要将一个响应最大化，将另一个最小化，而让第三个响应接某个目标值。在意愿刻画图中中，您可为每个响应都指定一个意愿函数。在此可将整体意愿定义为每个响应的意愿的几何平均数。

要使用意愿刻画图，请单击“预测刻画器”标题栏上的弹出式图标，然后选择意愿函数。

注：如果响应列具有响应限特性，意愿函数在默认情况下为打开。

此命令会在图形矩阵底部附加一个新行，专用于绘制意愿图。该行的每个因子都有一个图形，显示其意愿迹，如"意愿刻画图" 所示。它还为每个 Y 变量添加一个具有可调整意愿函数的列。整体意愿测量将在意愿迹的行左侧以 0-1 尺度显示。

意愿刻画图

意愿刻画图成分和意愿函数设置实例将在下面介绍。

意愿函数

要使用变量的意愿函数，请拖动功能标志点，以表示响应值。

拖动这些标志点时，变化的响应值就显示在图形左侧标记为意愿的区域中。点线为当前因子设置的响应。整体意愿显示在意愿迹的左侧。另外，您可以选择设定意愿，为点输入特定值。

意愿函数

意愿函数是平滑分段函数，用于拟合控制点。

  • 最小化函数和最大化函数是三元分段平滑函数，具有指数尾部和三次中部。
  • 目标函数是分段函数，是目标任何一侧上的正态密度的尺度倍数（每一侧都有不同的曲线），也是分段平滑函数，与控制点拟合。

这些选项使得此类函数意愿值在最大值、目标值和最小值之间切换时具有良好的表征。为了说明完整，我们也实现了一个颠倒的目标。

JMP 不使用 Deringer 和 Suich 函数形式。因为它们不平滑，所以始终无法很好地与 JMP 优化算法兼容。

其中不允许控制点在尾部控制点始终达到 0 或 1。

下面的示意图显示了创建意愿设置的步骤。

最大化
默认的意愿函数设置为最大化（“越大越好”）。顶部功能标志点位于最大的 Y 值处，列为高意愿，接近 1。底部功能标志点位于最小的 Y 值处，列为低意愿，接近 0。
目标
您可以将一个目标值指定为“最佳”。在本实例中，中间功能标志点位于 Y = 55，并列为最大意愿 1。Y 随着其值接近 70 或 42，其意愿将逐渐降低。位于 Y = 70 和 Y = 42 的顶部和底部功能标志点位于接近 0 的最小意愿。
最小化
最小化（“越小越好”）意愿函数将高响应值与低意愿关联，将低响应值与高意愿关联。该曲线为沿图形中心的水平线翻转而成的最大化曲线。

注：将最大化或最小化意愿函数顶点或底点拖过中点结果的 y 值，可导致对点反映，从而最小化变为最大化，反之亦然。

意愿刻画

图形的最后一行显示每个响应的意愿迹。垂直轴上意愿字样旁边的数值为意愿测量的几何平均数。这行图形显示由于一次更改一个因子而产生的当前意愿和意愿迹。

例如，假定"意愿和因子值经调整的预测刻画图" 中的意愿函数用于目标值 60。意愿图表明，将 Ct 向其下限值反向降低或降低 A，即可达到该目标的最佳意愿。"意愿和因子值经调整的预测刻画图" 中的刻画显示了 Ct 为 -0.74 时的情况。意愿为最大，而 Y 正好在目标值 60 处。

意愿和因子值经调整的预测刻画图

误差条的传递

在因子值不太好控制时，将响应变异归因于因子值变异时，误差传递 (POE) 很重要。

实现 JMP 时，刻画器首先查看因子变量和响应变量，看是否有 Sigma 列特性（列过程标准差的规格，可通过列 > 类信息对话框访问）。如果存在性质，“刻画器”下拉菜单中的误差条的传递命令将变为可访问。这将显示由于因子变异使响应蕴含的 3σ 区间。

该区间的计算公式如下（其中假定因子中的变异不相关）

其中 [image] 为预测函数相对于因子的偏导数。

目前，这些偏导数是通过数值导数（居中，δ=xrange/10000）计算得来。

位于响应面的斜率较大的部分时，响应面模型中的 POE 界限会大大增加。稳健制程的目标之一是在响应面的平面区域运行操作，从而使因子变异不会在其响应效应中放大。

多个响应的意愿刻画图

有多个响应时，意愿指数将变得尤其有用。这一概念由 Derringer 和 Suich 于 1980 年率先提出，他们给出了如下实例。假定有磨损、弹性系数、伸长和硬度四个响应。中心合成设计中有二氧化硅、硅烷和硫磺三个因子。

数据在 Sample Data 文件夹下的轮胎刻印.jmp 表中。使用数据表中的 4 种反映的反映表面设计脚本，它以一个全二次响应面为 4 个响应定义了一个模型。所有响应都显示有汇总表和效应信息，随后是如"多个响应的预测刻画图" 所示的预测刻画图。默认刻画图在其中点因子值处设定所有 X 变量。

多个响应的预测刻画图

"意愿函数优化了效应值模式" 中的意愿函数是为目标值而设置，x 值已调整为至少实现一个局部最佳值。底部的意愿迹处处降低（效应的当前值除外），表明任何进一步的调整都可能降低整体意愿。

  1. ABRASION 最大值和 MODULUS 最大值最合意。
  2. ELONG 目标值 500 最合意。
  3. HARDNESS 目标值 67.5 最合意。
意愿函数优化了效应值模式

自定义意愿函数

您可以根据其它 Y 变量的预测值使用自定义意愿函数。例如，假定您要使用以下函数进行最大化

首先，创建一个包含上述公式的 MyDesire 列。然后，使用图形 > 刻画器并包括所有预测公式列和 MyDesire 列来启动刻画器。个体效应的所有意愿函数都必须关闭，方法是双击意愿迹并从显示的对话框（"选择无意愿目标"）中选择无。

选择无意愿目标

此时，选择最大化意愿仅使用自定义的 myDesire 函数。

最大化的自定义意愿

混料设计

在分析混料设计时，JMP 约束了因子范围，使得不能在混料约束外进行设置。这就是为什么在某些混料设计中刻画迹变得格外陡峭的原因。

此外，某些混料成分有除通常的 0-1 约束之外的约束时，“刻画器”菜单中就会出现两个新选项。

在边界线处转变
让设置沿着约束条件的边界继续延伸。
在边界线处停止
在保持严格比例的区域将预测迹截断。

预测刻画器选项

“预测刻画器”标题栏上的弹出式菜单具有如下选项，可帮助您设定刻画轴及意愿函数：

置信区间
显示或隐藏连续因子的预测迹上的置信条。
意愿函数
显示或隐藏意愿函数，如"多个响应的预测刻画图" 和"意愿函数优化了效应值模式" 所示。
最大化意愿
设定当前因子值，以最大化意愿函数。
最大化选项
让您可以通过一个对话框来细化优化设置。
保存意愿
将每个因子的三个意愿函数设置以及关联的意愿值另存为数据表中的响应列性质。
设定意愿
弹出一个对话框，可在其中设定特定意愿值。
保存意愿公式
用意愿公式在数据表中创建一个列。在能够访问拟合公式时，公式将使用拟合公式，否则使用响应变量。
重置因子网格
显示一个对话框，供您为因子的当前设置和轴尺度输入特定值。
因子设置
包含以下选项的子菜单：
记住设置向报表添加一个外框节点，每当您调用“记住设置”命令时，该报表都将积累当前设置的值。
设定行中的数据将数据表行的值指定给刻画器。
复制设置脚本和粘贴设置脚本允许您将当前刻画器的设置移到其它报表中的刻画器。
将设置附加至表将当前刻画器的设置附加到数据表的末尾。如果要将刻画器中的设置组合添加到试验中以再次运行，这将非常有用。
输出网格表
用包含网格值的因子的列、各个网格点具有计算值的各个响应的列以及各个网格点的意愿计算值生成一个新数据表。
如果有许多因子，使用输出网格表命令则不切实际，因为这将生成一个大表。这种情况下，应该锁定某些因子，让其保持在锁定的常数值。要获得该对话框以指定锁定列，请按住 Alt 键或按住 option 键并单击刻画图内部，以便获得具有“锁定因子设置”复选框的对话框。
交互作用刻画器
弹出与刻画器值交互的交互作用图。此选项可以帮助通过查看项的当前值变化时图形的变化，来观察三次交互作用。随指定项变化的单元与该项没有直接关系。
记住设置
将当前设置添加到“记住设置”外框节点（如果尚未存在则会创建该节点）。
设定行中的数据
提示输入一个行号，然后将当前因子值设定为数据中该行的值。
默认水平数
允许您为每个连续因子设置默认水平数。当刻画器特别大时，此选项很有用。第一次计算迹时，JMP 会测量所用时间。如果时间多于 3 秒，系统就会发出警告，即降低“默认水平数”会提高计算速度。
条件预测
在模型中包括随机效应时显示。显示的随机效应用于用公式表述预测值。
模拟器
启动“模拟器”。“模拟器”让您可以使用添加到模型因子和预测值的随机噪声创建 Monte Carlo 模拟。典型的用途是在最优设置处设定固定因子，以及将不受控因子和模型噪声设定为随机值，并求出响应超出规格限的比率。有关模拟器用法的详情，请参阅“模拟器”部分。
交互作用刻画器
弹出“交互作用刻画器”。（很明显，这是占位符文本）。

刻画图问答

如果要将意愿函数同时用于因子和响应，应该怎么办？
您可以在“拟合模型”对话框中同时包括 X 因子和 Y 响应。拟合将很完美，且可以添加意愿函数。
如果要将不同模型与各个响应拟合，应该怎么办？
分别进行拟合，并使用保存预测公式在数据表中添加新列。接着使用图形菜单中的刻画器图来标绘预测列。
如果响应具有不同的缺失值模式，应该怎么办？如果缺失一个响应，JMP 就会忽略一行。这意味着，如果同时拟合几个响应，就会丢失数据。是否仍然可以使用预测刻画器？
请参阅上一个问题的答案。


模拟器

模拟让您可以发现模型输出作为因子和模型噪声的随机变异函数的分布。刻画器中的模拟工具提供了一种设置随机输入和运行模拟的方式，可用于产生模拟值的输出表。

此工具用法的一个实例就是求出已拟合制程的缺陷率，并查看其对于因子变异是否稳健。如果已在响应中设定了规格限，则会将它们留到模拟输出，允许使用新因子设置对模拟模型进行前瞻性能分析。

因子规格

在“刻画器”中已为因子（输入）和响应（输出）指定角色。模拟器的其它规格是关于如何将随机值指定给因子以及如何在响应中添加随机噪声。

对于每个因子，有关如何提供值的选项如下：

固定
将因子固定为指定值。初始值是刻画器中的当前值，此值可能是通过优化获得的。
随机
使用指定分布和分布参数为因子指定一个随机值。有关这些功能的说明，请参阅《JMP 用户指南》。如果是分类因子，则分布的特征是为每个类别指定的概率，其中值都正规化为总和为 1。
顺序
其适用的模拟不是运行单个模拟，而是要运行一系列模拟且每组都将此因子固定。此因子对于每组模拟都固定，且会随下一个组递增。您可以指定序列界限以及划分步数。模拟器会计算增量（高 - 低）/（步阶数 - 1），并通过值（低、低 + incr、低 + 2 incr 等）排序，直至其达到高。如果有多个顺序因子，则将模拟所有可能的水平组合，因此生成的模拟表可能会较大。
顺序 + 随机
是顺序和随机的组合。您想通过因子值排序来探索因子空间，而不是让它们保持固定，实际因子值具有一些添加的随机值（对于无法精确控制 igt 的情况）。在模拟输出中，因子出现两次：一次是同其顺序值一起显示，另一次是随添加的随机噪声一起显示。后一种情况是采用后缀 +Noise 的命名方式。
表达式
让您可以使用 JMP 脚本语言 (JSL) 的方式将表达式写入字段中。这让您可以灵活地制作新的随机分布。例如，您可以使用如 Max(0,RandomNormal(5,2)) 的表达式创建截断的正态分布，从而保证非负值。
多元
让您可以在具有相关因子时生成多元正态分布。使用因子指定均值和标准差，并单独指定一个相关矩阵。

指定响应

如果模型只是因子函数的一部分，且其它响应变异是由随机噪声引起的，则需要使用响应指定此种情况。选项包括：
无噪声
只根据模型计算响应，而不添加其它随机噪声。
添加随机噪声
将具有指定标准差的正态随机数添加到计算的模型，从而获得响应
添加多元噪声
产生如下的响应：使用指定的相关性结构获取多元随机正态向量，然后按指定标准差标度它，并将其添加到通过模型求得的值。

轮胎刻印模拟

现在使用轮胎刻印.jmp 数据探索 4 个响应上 3 个因子（二氧化硅、硅烷和硫磺）的效应。

首先，记住某些规格限，即是要计算缺陷率和性能指数。为了简化后面的工作，现在将列属性添加到这些因子的响应。规格限属性将自动留到保存的“预测公式”列。在拟合响应曲面模型时，也无需在保存的公式中输入 Sigma 属性值，这些公式复制自 RMSE（均方根误差）。
因子 | 规格限属性 | Sigma 属性
磨损 | 规则下限：110 | 5.611247
弹性子数 | 规格下限：1000 | 328.6934
伸长 | 规格下限：350 规格上限：550 目标：450 | 20.54917
硬度 | 规格下限：66 规格上限：74 目标：70 | 1.267356

运行 4 种反应的反应表面设计脚本，并为每个响应（共 4 个）选择保存列 > 预测公式。现在应由 4 列包含公式和预测值。

现在，选择图形 > 定制刻画器并将预测公式磨损、预测公式弹性子数、预测公式伸长和预测公式硬度指定为 Y，预测公式角色。单击确定后，将看到如"定制刻画器" 所示的自定义刻画器。

定制刻画器

要将模型优化为自己希望的形式，请单击优化按钮。此时可启动模拟器。请注意，将因子的默认值保留为与刻画器（"初始模拟器对话框"）中的值一样。

初始模拟器对话框

假设难以精确控制硅烷成分，只能将其控制在标准差 2 之内。因此使用该标准差将硅烷更改为随机。此外，希望响应为随机，并使用来自拟合模型的 Sigma，（选择添加随机噪声命令时将自动显示）。最后，使用默认的 1000 运行数运行模拟。

产生的表有一个脚本可生成“分布”分析（"生成模拟分析"）。因为此前在原始表中输入的规格限都会复制到输出表，所以分布分析会自动附加一个性能报表。要根据所有的 4 个响应汇编这些性能报表，请使用鼠标右键单击报表，并选择制作合并数据表。

生成模拟分析

使用 JMP 制图平台可以更清晰地了解这些结果。下面的步骤显示了有关这些结果的条形图，其中显示了每个响应的变异性，由“低于 LSL”、“高于 LSL”和“全部在界限外”展开。

  1. 选择图形 > 图表。
  2. 选择 % 实际，然后单击统计量 > 数据
  3. 将 Y 和部分（按此顺序）指定为类别，X，水平角色。
  4. 将图表类型更改为水平。

好像只有硬度变异会成为问题，而伸长是唯一一个缺陷很少的响应。

现在继续探索。请使用模拟器的排序能力来逐步完成几个值，而不是将因子保留固定。在模拟器中，将所有固定变量都更改为顺序，并将随机变量（硅烷）更改为顺序 + 随机。接受“高”和“低”的默认值，但将步数更改为 11。

按模拟按钮，然后在报告模拟数的屏幕上单击继续。这将创建一个大型表，每个组合都超过 1000，因此可能要 1 分钟才会生成。请注意，由于有个规格中的规格限，因此最后添加了一个公式列。它有一个用于计算规格限的公式（显示在"模拟表" 的右侧），并为规格中生成 1，为规格外生成 0。

模拟表

由于我们对规格中的感兴趣，因此使用表 > 汇总功能来求每个变量（共 3 个）位于规格中的平均数。

  1. 选择表 > 汇总
  2. 选择规格中，然后单击统计量 > 均值
  3. 将二氧化硅、硅烷和硫磺添加到组角色中
  4. 单击确定。

出现表时，使用表 > 排序按均值（规格中）进行排序。表底部应与下表相似（但不相同）。

要显示缺陷率曲面，可以返回原始数据，删除所有缺陷，并使用“曲面图”平台通过密度网格标绘 3 个因子。

3 个因子的密度网格

模拟通用公式

虽然刻画器和模拟器都设计用来根据模型拟合时存储的公式工作，但它可根据任何公式工作。来自基于电子表格的 what-if 模拟器的典型模拟应用是在某些概率情况下执行财务模型，获得目标的分布。这在 JMP 中可实现，关键是将公式存储到列中，设置范围，然后进行模拟。
财务模拟的因子和响应
输入 （因子） | 单位销量 | 介于 1000 和 2000 之间的随机均匀因子
 | 单位价格 | 固定
 | 单位成本 | 均值为 2.25 和标准差为 0.1 的随机正态因子
输出 （响应） | 收益 | 公式：单位销量*单位价格
 | 总成本 | 公式：单位销量*单位成本 + 1200
 | 利润 | 公式：收益 - 总成本

以下 JSL 脚本使用一些初始标度数据创建了数据表，并将公式存储到输出变量中。它还启动了“定制刻画器”。

 dt = newTable("Sales Model");
 dt<<newColumn("Unit Sales",Values({1000,2000}));
 dt<<newColumn("Unit Price",Values({2,4}));
 dt<<newColumn("Unit Cost",Values({2,2.5}));
 dt<<newColumn("Revenue",Formula(:Unit Sales*:Unit Price));
 dt<<newColumn("Total Cost",Formula(:Unit Sales*:Unit Cost + 1200));
 dt<<newColumn("Profit",Formula(:Revenue-:Total Cost));
 Custom Profiler(Y(:Revenue,:Total Cost,:Profit), Objective Formula(Profit));

创建后，请从“定制刻画器”选择“模拟器”。请使用"财务模拟的因子和响应" 中的规格填写模拟器。

现在，在生成的表中运行模拟和脚本，这将生成如下“分布”报表。

好像没什么盈利。将规格限置于利润下限 0 后，性能报表将指出没有盈利概率为 63%。

因此将价格提高到 $3.25（即将单位价格从 3 更改为 3.25），然后重新运行分析。再次以规格下限 0 进行性能分析，可以看到没有盈利概率降低到大约为 23%。


交互作用图

模型中有交互作用效应时，在因子刻画子菜单中选择交互作用图，将显示一个交互作用图矩阵。作为实例，请使用反应.jmp 样本数据，其中有因子 Ct、A、T 和 Cn，以及所有二因子交互作用。接着，您可以使用交互作用图命令查看交互作用效应。

在交互作用图中，交互作用显著性以非平行线显示。例如，图形（"Reactor 实例的交互作用图"）底行的 T*Cn 图中，Cn 的效应在温度值较低时非常小，但是在温度值较高时偏离较大。Cn 与 T 的交互作用掩盖了作为主效应的 Cn。

Reactor 实例的交互作用图

请注意，当模型中没有相应交互作用项时，交互作用图中单元格的线条为点线，而不是实线。


等高线刻画器

因子刻画子菜单中的等高线刻画器选项可提供一个交互等高线刻画器工具。这对于以图形方式优化响应面很有用。

"等高线刻画器和弹出式菜单命令" 显示了轮胎刻印样本数据等高线刻画器的有注释实例。要查看本实例，请以磨损、弹性系数、伸长和硬度作为响应变量，以二氧化硅、硅烷和硫磺作为因子，运行响应面模型。数据表中附加的脚本可完成此任务。"等高线刻画器和弹出式菜单命令" 中显示了以下功能：

  • X 和 Y 变量都可以用滑块控件和编辑框进行调整。
  • 当前 X 值生成当前 Y 值。当前 X 位置由图形上的十字准线标示。当前 Y 值由滑块控件中的红色小菱形标示。
  • 图形中的其它线条是通过 Y 滑动杆控件或在等高线列中输入值来设定的响应的等高线。每个响应都有一条单独着色的等高线（本实例中有 4 种，分别表示这些响应变量）。
  • 您可以为响应输入上限和下限，从而生成阴影区域。要设定界限，您可以单击并拖动 Y 滑动杆的侧面区域，或在下限列或上限列中输入值。
  • 如果有两个以上的因子，请使用图形左上角的复选框，将图形切换到其它因子。
  • 按住 option (Alt) 键并单击滑块控件，可更改滑块的尺度（以及当前 X 变量的图形）。
  • 对于每条等高线，在较高响应值的方向都有一条点线，让您有方向感。
等高线刻画器和弹出式菜单命令

网格密度
用于设定网状图（曲面图）的密度。
图形更新
提供用于更新等高线刻画器的选项，包括用于连续更新的每当鼠标移动以及用于鼠标释放后才更新的每当鼠标释放。（在速度很快的机器上可能注意不到差异。）
曲面图
隐藏或显示有等高线刻画器的网状图，如图所示。默认情况下，将显示网状图。
等高线标签
隐藏或显示等高线的标签。标签颜色与等高线颜色匹配。
等高线网格
根据指定的区间在等高线刻画器上绘制等高线。
因子设置
一个子菜单命令，可用于保存等高线刻画器的设置，并将其转移到 JMP 的其它部分。在 中的刻画器论述中有关于此子菜单的详细资料。

注：对于混料设计，在等高线刻画器中会出现一个“锁定”列（"锁定列"）。使用此列可以锁定混料值的设置，这样在需要调整混料时（由于更改了其它混料效应），这些设置不会发生变化。存在锁定列时，混料的阴影区域能识别新构建的区域。

锁定列


作为独立平台的刻画器

假定您一个非线性模型，他对不同的相应有不同的模型，但要一起来刻画。这种情况下，“拟合模型”平台中的刻画器就无法满足需要。

您可以使用图形主菜单（或工具栏）上的命令将这些刻画器的各个版本作为独立平台启动。为此，请完成分析并保存预测公式，或创建具有要使用的公式的数据表列。通过图形菜单中的刻画器平台，您可以指定包含公式的列。刻画器使用这些公式所依赖的因子列，然后显示一条刻画，其中包含“拟合模型”中的刻画器具有的所有功能，但它不知道预测值的置信区间。

“刻画器”启动对话框具有展开中间公式复选框。选定该复选框并检查检查刻画图的的公式后，如果它引用的列具有包含对其它列的引用的公式，则它将替换该公式，并根据终端引用绘制刻画，而不是根据中间列。

此外，使用展开中间公式复选框将启用平台弹出式菜单中的保存展开公式命令，让您可以将展开的公式保存到原始数据表。

例如，当拟合模型拟合一个有两个水平的逻辑回归并保存公式时，则将有一个名称为 Lin[xxx] 的线性模型列，该列具有用回归项表示的公式，其中还有终端公式 Prob[xxx]，这些公式是 Lin[xxx] 列的函数。只有公式本身引用其它列，才考虑对其进行“挖掘”。仅仅是由常数、随机函数或行计算构成的表达式的列，则不予考虑。


立方图

因子刻画子菜单中的立方图选项显示了因子范围极值的一组预测值，布局在立方体的顶点上，如"立方图实例" 所示。如果因子为记名因子，则顶点为第一个水平和最后一个水平。要调整立方图大小，请单击图形框架的右下角，并在光标变为双箭头时进行拖动。

如果要更改布局，使得各项映射到不同的立方体坐标，请单击第一个立方体中其中一个项名称，然后将它拖到您希望的坐标。在下面的实例中，如果单击 T 并将其拖到 Cn=-1，则 T 标识立方体，Cn 标识前后坐标。如果有多个响应，则显示的多个响应将堆叠在各个顶点上。

立方图实例


响应面曲率

通常在工业试验中，目标是找到一个或多个因子的值，使响应最大化或最小化。JMP 提供了具有特殊报表的表面建模，这些报表会显示临界值、表面曲率以及响应等高线图。

效应宏弹出式菜单中的响应面选项将自动构建响应面模型需要的所有线性项、二次项和叉积项。

使用“模型设置”对话框中的添加和交叉按钮创建模型效应，可以指定相同模型。接着，可以选择一个模型项，并为它指定属性弹出式菜单中的响应面效应。构建模型效应列表中显示的响应面效应在其名称后有 &RS，如"响应面分析的“模型设置”对话框" 所示。

估计参数后，在估计表面中可以找到因子的临界值。临界点在最大值、最小值和表面的鞍点处发生。计算得出的二次参数的特征值和特征向量决定曲率类型。特征向量显示表面的主方向，包括最大曲率和最小曲率的方向。

以下实例使用的是 Sample Data 文件夹中的原始气味控制.jmp 文件。该实例使用了 John (1971) 中讨论的数据。目标是找出使化学物生产流程的气味最小的温度（温度）范围、气液比（气/液比）和高度（高度）值。要运行此响应面模型，请从变量选择器列表中选择响应变量气味，然后单击 Y。拖动或按住 Shift 键并单击以高亮度显示因子温度、气/液比和高度，然后从宏弹出式菜单中选择响应面。请注意，主效应将自动显示在构建模型效应列表中，其名称后有 &RS（请参阅"响应面分析的“模型设置”对话框"）。

响应面分析的“模型设置”对话框

参数估计值

“参数估计值”表将显示线性项、各因子的二次项以及两个因子的交叉效应的估计值。

如果使用了保存列子菜单中的保存预测公式命令，则名称为 Pred Formula odor 的新数据表列将使用“参数估计值”表中的系数保存预测公式。以下公式来自预测值列中的 JMP 计算器：

 -30.666672+-12.125*temp+-17*gl ratio-21.375*ht++(temp)*((temp)*32.083337)+(gl ratio)*((temp)*8.25)++(gl ratio)*((gl ratio)*47.8333337)+(ht)*((temp)*1.5)++(ht)*((gl ratio)*-1.75)+(ht)*((ht)*6.083368)

“方差分析”表中的概率值 0.0657 表明该三变量响应面模型只是略微优于样本均值。

响应面分析还显示“响应面”表和“解”表（"响应面模型的基本报表"）。“解”表显示表面变量的临界值，指明表面解点为本实例的一个最小值。

典型曲率表

“典型曲率”报表位于“响应面”标题下，显示特征结构（"响应面模型的基本报表"），用于标识曲率的形状和方向，由二阶参数估计值矩阵的特征值分解产生。如果响应面的形状从最大值处向内弯曲，则特征值（在“典型曲率”表的第一行中指定）为负数。如果表面的形状从最小值处向上弯曲，则特征值为正数。如果特征值是混合的，则表面为鞍形，在一个方向向上弯曲，在另一个方向则向下弯曲。

特征值（48.8588、31.1035 和 6.0377）下面列出的特征向量显示了主轴的方向。本实例中的特征值为正数，表明曲率从最小值处向上弯曲。曲率最大处的方向对应于具有关联特征向量（气/液比）的最大成分的最大特征值 (48.8588) 和变量。在湿度上是在特征值 31.1035 的方向分布最多，具有和气/液比相差不多的曲率。

有时会出现零特征值的情况。这表示沿相应特征向量描述的方向，拟合表面是平坦的。

响应面模型的基本报表


Box Cox Y 变换

有时对响应进行变换后拟合模型比原始响应的拟合效果更好。常用变换会将响应提高到一定效能。Box 和 Cox (1964) 正式提出和说明了这个系列的幂变换。因子刻画菜单具有 Box Cox Y 变换命令。变换公式的构建使得可以提供连续定义，并且误差平方和可以比较。

其中 [image] 为几何平均数
此处显示的图形说明了该系列幂变换对 Y 的效应。

Box-Cox Y 变换命令将变换以增量 0.2 从 λ = -2 拟合至 2，还标绘了 λ 功效间的误差平方和 (SSE)。下面的图形显示了当 λ 介于 0 与 0.5 之间时化学反应.jmp 数据的最佳拟合，其中使用的模型具有效应 F、Ct、A、T 和 Cn 以及所有二因子交互作用。通过查找曲线的最低点，可以找到图形上的最佳变换。

通过表显示按钮旁边的弹出式图标可访问保存最佳变换命令，在数据表中创建新列，并保存最佳变换的公式。


曲面刻画器

曲面刻画器显示了响应面的三维表面图。"控制曲面" 一章中有曲面图的详细资料。

响应网格滑块调整沿响应轴移动的可选网格。

请注意，“曲面刻画器”可显示连续或分类效应。

曲面刻画器


标准最小二乘：随机效应

模型拟合平台

随机效应是指从较大水平总体中随机选择效应水平，表示为样本。相反，固定效应的水平则具有直接关系，而非代表关系。如果模型中同时具有随机效应和固定（非随机）效应，则称为混合模型。

声明随机效应很重要。否则，将使用错误假定来计算拟合模型生成的检验统计量。

典型的随机效应有

  • 重复测量试验中的主题，其中将多次测量主题。
  • 裂区试验中的图形，其中会将试验单元进一步细分并进行多次测量，通常对子单元采用另一种试验。
  • 测量研究，其中将进行多次测量来研究测量变异。
  • 随机系数模型，其中随机效应使用与类别交叉的连续项建立。

JMP 中的“模型拟合”平台使用现代方法拟合混合模型，现在一般认为这是最好的方法：

  • REML 估计方法（约束极大似然）
  • Kenward-Rogers 检验

出于历史原因，平台还提供矩法 (EMS)，但这不再是建议的方法，等效于 REML 的特殊情况除外。

如果模型的所有效应都是随机，则还可以在“变异性图”平台上拟合。

目录

随机效应主题

随机效应简介

概括性

REML 方法

JMP 中方差成分的无限制参数化

负方差

随机效应 BLUP 参数

REML 和传统方法在标准实例中一致

混合模型中的 F 检验

指定随机效应

裂区设计实例

模型对话框

REML 结果

REML 保存菜单

矩法结果

不平衡实例


随机效应主题

随机效应简介

随机效应的水平是从较大水平总体中随机选择的。为了检验假设，假设响应在各个水平上的效应呈正态分布，均值为零并有一个方差（称为方差成分）。

从某个角度来说，每个模型都至少有一个随机效应，即构成残差的效应。假设构成个体观测值的单元是从某个大得多的总体中随机选择的，并假设效应大小的均值为零且方差为 σ2。

具有随机效应（而非残差）的最常见模型是重复测量模型或裂区图模型。"裂区设计模型中的效应类型"列出了裂区图模型中的效应类型。在这些模型中，试验分两层。先在试验的整区或对象中应用一些效应。然后，拆分这些整区，或在不同时间测量对象，并在这些子单元内应用其它效应。说明整区或对象的效应是一种随机效应，而说明子区或重复测量的效应则是另一种随机效应。在模型中通常会忽略子单元效应，将它吸收为残差。

裂区设计模型中的效应类型
裂区设计模型 | 效应类型 | 重复测量模型
整区处理 | 固定效应 | 对象间处理
整区 ID | 随机效应 | 对象 ID
子区处理 | 固定效应 | 对象内处理
子区 ID | 随机效应 | 重复测量 ID

其中每个实例都可作为分层模型来处理，并且有几种传统的方式可用来适当地拟合它们。这种情况按两个不同的试验处理：

  1. 整区试验将整区或对象视为试验单元，构成其误差项。
  2. 子区处理使用每个试验单元的个体测量来构成其误差项（保留为残差）。

检验整区的较古老传统方法是执行以下操作之一：

  • 取各个测量的均值并将这些均值与整区效应拟合。
  • 将整区均方除以整区 ID 均方得出 F 比率。
  • 组织数据以使拆分测量或重复测量构成不同的列并建立多元方差分析模型，然后使用一元统计量。

如果结构简单并且数据完整且平衡，则可采用这些方法，但是，有一种更通用的模型可用于任何随机效应结构。这种更通用的模型称为混合模型，因为它同时具有固定效应和随机效应。

另一种涉及多个随机效应的常见情况出现在测量系统中，其中多次测量会有不同的部分、不同的运算符、不同的规范和不同的重复。这种情况下，所有效应都被视为随机效应。

概括性

随机效应是从较大总体中随机选择的，其中假设效应在响应中的分布为正态分布的实现，均值为零且具有可估计的方差。

通常，精确效应大小并无多大直接关系。重要的是它们表示较大总体。从效应的均值和方差中可以了解到有关从中抽取效应水平的母体的情况。这一点与固定效应不同，在固定效应中，您只了解在数据中实际遇到的水平。

REML 方法

用于拟合混合模型的 REML（约束极大似然）方法现在是最新的主流方法，取代了原来的方法。

在功能强大的计算机产生之前，研究人员需要将兴趣约束在某些情况下，即有计算快捷方法可用于在混合模型中求方差成分估计和固定效应检验。现在的大部分书籍都讲解了使用这些快捷方法的混合模型，这些快捷方法对平衡数据有效。矩法用于计算均方 (EMS) 相对于方差成分的期望值，然后向后求得方差成分。也可以使用这些方法求检验统计量的表达式，这些统计量在合成自均方的零假设下有相应的期望值。

如果模型满足某些条件（即其随机效应包含它们为其提供随机结构的固定效应的项），那么可以使用 EMS 选项生成这些传统分析。但是，由于较新的 REML 方法生成的结果与这些模型相同，但通用得多，因此从不建议使用 EMS 方法。

REML 方法最早由 Patterson 和 Thompson 于 1974 年率先提出，并经过了 Henderson、Harville、Searle 和其他人进一步发展。首选 REML 的原因是它不依赖于平衡数据或快捷近似值，还因为它使所有检验都符合要求，即使跨交互作用的对比也是如此。使用传统 EMS 方法的大多数程序包要么无法检验其中某些对比，要么计算的方差不正确。

JMP 中方差成分的无限制参数化
仅当您关心是否符合某些课本中的结果时，才阅读本节。

方差成分参数化有两种统计传统：无限制法和限制法。JMP 和 SAS 使用无限制法。此方法中，虽然估计效应的总和始终为零，但是对于随机水平的特定随机选择，并不假定真实效应的总和为零。这与残差的假设相同。估计值使残差的均值为零，且真实均值也为零。但使用真实参数的数据随机抽取是随机事件，均值并不一定刚好为零。

因为许多统计学课本都使用限制法，所以您需要了解这种假设。在过去的 50 年中，两种方法都在教学中广泛使用。能同时说明这两种方法的一个比较好的来源是 Cobb (1998) 第 13.3 节。

负方差
仅当您关心负方差成分时，才阅读本节。

虽然方差始终为正，但也可能出现方差的无偏估计值为负的情况。这种情况发生在这样的试验中：当效应非常弱时，产生的数据偶然导致估计值为负。

JMP 可生成 REML 和 EMS 的负估计。对于 REML，模型对话框中有个复选框可用于将估计约束为非负。建议您不要选定此复选框。约束方差估计会导致固定效应检验产生偏。

如果您仍然对方差负估计觉得不满意，请考虑一下，随机效应模型在统计学上是否真的等效于方差成分实际上是整区中所有误差的协方差的模型。很容易就能想到协方差估计为负的情况，不管是随机偶然事件，还是真实制程中。在真实制程中，某些观测值在一个方向上的偏差会导致其它观测值在另一个方向上的偏差。以此方式进行随机效应建模时，协方差结构称为复合对称性。

因此，请将负方差估计视为有用信息。如果负值较小，则在真实方差较小的情况下可以将其视为偶然事件。如果负值较大（方差比可达 0.5），这表示需要进行故障排除，即行并不像假定那样独立，且值得调查的某个制程恰好在块内。

随机效应 BLUP 参数

随机效应具有双字符。一方面，它们就像残差误差，通常误差都与整区试验单元关联。另一方面，它们又像固定效应，其中有一个参数与每个效应类别水平都关联。作为参数，您有关于它们的额外信息，它们是从均值为零且方差是由方差成分估计的正态分布导出的。此额外信息的效应使参数估计向零收缩。与随机效应关联的参数估计称为 BLUP（最佳线性无偏预测）。一些研究人员将这些 BLUP 视为感兴趣的参数，其他人则将它们视为不感兴趣的方法的副产品。在 JMP 中，这些估计可用，但在初始关闭的报表中。

BLUP 参数估计用于估计随机效应最小二乘均值，因此这些均值也向总均值收缩，至少与将效应视为固定效应时的情况相比是这样的。收缩度取决于效应的方差以及效应中每个水平的观测值个数。如果方差估计较大，则收缩较小。如果方差成分很小，则收缩会很大。如果方差成分为零，则效应水平刚好收缩为零。甚至可以得到负方差成分，但收缩为反向。您可以将固定效应视为随机效应的一个特例，其中方差成分很大。

如果每个水平的观测值个数较大，则估计值将收缩较小。如果每个水平的观测值个数较少，则估计值将收缩较大。如果存在无限观测值，则无收缩，答案与固定效应的相同。

REML 方法使用各水平间的方差信息来平衡每个个体水平的信息。

例如，假定有不同棒球球员的击球平均值。各球员击球表现的方差成分说明球员之间的击球平均值通常存在多少变异。如果球员参赛次数很少并且击球平均值极其小或极其大，那么您很可能不信任该估计，因为这仅仅是基于少数击球，估计存在很高的标准误差。但是，如果将它与总均值混合，即向总均值收缩估计值，则可能会更相信该估计值一些。对于具有长期击球记录的球员，其收缩要比只有期短记录的球员小得多。

您可亲自运行此实例并查看结果。击球平均数据实例在棒球.jmp 样本数据文件中，其中变量为竞赛者和击球。要对矩法 (EMS) 和 REML 进行比较，请运行该模型两次。击球为 Y，竞赛者为随机效应，如图所示。

运行模型并从方法弹出式菜单中选择 REML（建议）。

以方法中的 EMS（传统）再次运行该模型。

"矩法与 REML 估计值比较"汇总了此模拟实例中的一组棒球球员的矩法和 REML 的估计值。请注意，Suarez 仅有 3 次击球，要比具有更多击球的其他人收缩更大。

矩法与 REML 估计值比较
 | 矩法 | REML | N
方差成分 | 0.01765 | 0.019648 |
Anderson Jones Mitchell Rodriguez Smith Suarez | 0.29500000 0.20227273 0.32333333 0.55000000 0.35681818 0.55000000 | 0.29640407 0.20389793 0.32426295 0.54713393 0.35702094 0.54436227 | 6 11 6 6 11 3
最小二乘均值 | 与普通均值相同 | 从均值收缩 |

REML 和传统方法在标准实例中一致

在平衡设计中可看出，固定效应的 REML F 检验值将与矩法（期望均方）的相同。在某些实例中，自由度可能会不同。获取 REML F 检验自由度的方法有多种；JMP 使用的方法是与所属效应相关联的最小自由度。

混合模型中的 F 检验
本节详细说明随 REML 产生的检验

REML 方法会求方差成分和参数估计，但没有一些附加步骤用于求模型中固定效应的检验。目标是构造 F 统计量和关联的自由度，以求显著性检验的 p 值。

传统上在使用矩法 (EMS) 的简单模型中，标准检验是通过构造在零假设下具有相应期望值的二次型导出的。如果均方必须合成自均方的线性组合，以便具有相应的期望值，则 Satterthwaite 方法可用于求自由度，以获取 p 值。有时，这些是因子自由度，就跟在现代 (Aspin-Welch) t 检验中求得的一样。

通过现代的计算功效和较近的方法，有很多改善过的方法可用于获得检验。首先，Kackar 和 Harville (1984) 找到一种估计较小样本的偏校正项的方法。这一方法被 Kenward 和 Roger (1997) 进一步细化，可进一步校正及求自由度，自由度提供了与检验统计量分布最匹配的 F 分布。这些都不是简单的计算，因此对于较大模型需要较多的执行时间。

如果有一个简单的平衡模型，则 REML-Kenward-Roger 生成的结果将符合传统方法生成的结果。

  • 这些结果不取决于分析模型的语法结构。在求包含的效应方面没有任何规则。该方法不考虑整区固定效应是否纯嵌套在整区随机效应中，不管怎样，它都会求出正确的答案。
  • 这些结果不需要具有分类因子。它处理连续（随机系数）模型也很方便。
  • 这些方法将生成各种结果，这些结果比 JMP 旧版本（即 JMP 6 以前的版本）好，因为以前的版本都使用较旧的、较不精确的技术来进行这些检验。
  • 这些方法不需要具有正方差成分。不仅支持负方差成分，而且还必须允许它们，以便生成无偏检验。

实现这些方法的目标不是为了解决一般实例，而是解决无需用户了解太多详细资料的实例。只需声明哪些效应为随机，其它都是自动完成。特别重要的一点就是工程师需要学会如何声明随机效应，因为他们有疏忽的执行裂区试验的经历，即未标识结构。


指定随机效应

具有随机效应的模型使用与其它模型相同的“模型设置”对话框。要标识一个随机效应，请在模型效应列表中高亮度显示它，然后从属性弹出式菜单中选择随机效应。这样将在型效应列表中的效应名称后附加 & 随机。

裂区设计实例

分层设计中的最常见类型为平衡裂区设计，其形式通常为跨时间的重复测量。其中将对某些效应的一个试验单元进行拆分（有时按时间期），然后将其它效应应用于这些子单元。

以 Sample Data 文件夹中的动物.jmp 数据为例（数据是编造的）。"重复测量试验数据表" 显示了一个表列表。该研究收集了有关狐狸 (fox) 和土狼 (coyote) 在季节猎食习性中的差异的信息。其中对三只狐狸 (fox) 和三只土狼 (coyote) 作了标记，并在一年中进行了定期（每季）观测。此处还记录了它们在一年中的不同季节里离开窝穴行走的平均英里数（四舍五入为最接近的英里数）。模型由以下元素确定：

  • 连续响应变量，名称为英里数
  • 种类效应，为 fox 或 coyote
  • 季节效应，为 fall、winter、spring 和 summer
  • 动物标识代码，名称为对象，对于狐狸 (fox) 和土狼 (coyote) ，记名值均为 1、2 和 3

该模型有两层。

  1. 顶层为对象间层，其中根据各个对象的变异检验作为狐狸 (fox) 或土狼 (coyote) 的效应（种类效应）。底层为对象内层，其中根据同一对象内各个季节的变异检验四个季节的重复测量因子（季节效应）。对象内变异性反映在残差中。
  2. 季节效应可使用残差作为其 F 统计量的分母。但是，对象间变异性不是通过残差测量，而必须通过模型中种类（对象[种类]）效应内的对象来捕获。对象间效应种类的 F 统计量使用此嵌套效应作为其 F 比率的分母，而不是使用残差。
重复测量试验数据表

模型对话框

拟合模型命令用于构建模型项和标识误差项。要使用正确的 F 统计量运行嵌套模型动物数据，请按如下所示指定响应列并向构建模型效应列表添加项，以查看如"重复测量试验的“模型设置”对话框" 所示的完成对话框。

  • 从列选择器中选择英里并单击 Y。
  • 从列选择器列表中选择种类并单击添加。
  • 从列选择器列表中选择对象并单击添加。
  • 再次从列选择器列表选择对象，同时在构建模型效应列表中选择对象。单击嵌套将种类（对象[种类]）效应内的对象添加到模型中。
  • 选择嵌套效应对象[种类]，然后从属性弹出式菜单中选择随机效应。此嵌套效应现在应标识为种类效应的误差项，并显示为对象[种类]& 随机。
  • 从列选择器列表中选择季节并单击添加。

当在属性弹出式菜单中将任何效应指定为随机效应时，对话框右上方将会出现“方法”选项（REML 和 EMS），其中选定了 REML 作为默认值。

重复测量试验的“模型设置”对话框

注：JMP 仅对数据中实际发生的组合创建设计列。

注：不必包含全部的效应。例如，如果模型中已有 A*B*C，则不必具有 A*B、A*C 和 B*C。


REML 结果

REML 的一个优点是报表不需要验证（"REML 分析报表"）。其中已相应收缩所有估计值且已相应转换标准误差的尺度 (SAS Institute Inc. 1996)。方差成分显示为与误差方差的比率以及总方差中的一部分。

因为所有调整都是由模型本身自动完成的，所以没有合成检验创建的特殊表。因为此方法不需要期望均方表，所以没有该表。

如果模型中有随机效应，则不会显示方差分析报表。这是因为对于基于 REML 的估计值，方差和自由度属性都不会以通常的方式划分。您可以从 REML 报表获取剩余方差估计值，而非从方差分析报表中获取。

REML 分析报表

您可以使用鼠标右键单击“方差成分估计”表，在附加列中切换，显示方差成分的 95% 置信区间（使用 Satterthwaite (1946) 近似）。

此外，还可使用相同的方式显示方差成分的变异系数 (CV)。

注：如果模型中有随机效应且您调用了刻画器，则在“刻画器”输出中将抑制随机项。预测将和随机效应结合，因此它们看起来很普通（即不感兴趣）。您仍可以使用重置因子网格命令显示它们。

REML 保存菜单

使用 REML 时，在“保存”子菜单中将出现如下额外菜单。所有这些命令都允许随机效应参与预测，而不是使用它们的期望值（零）。

在下图中，左侧显示上述实例的预测公式没有随机效应参与，右侧显示有随机效应参与。

条件预测公式
将预测公式（包括随机效应）保存到数据表的新列中。
条件预测值
将预测值（不是公式本身）保存到数据表的新列中。
条件残差
将模型残差保存到数据表的新列中。
条件均值置信区间
保存均值置信区间
条件个体置信区间
保存单个值的置信区间。

除了这些选项，还有一个新的刻画器选项可用

条件预测
显示随机效应并将其用于用公式表述预测值。在下面的实例中，第一次显示刻画器时，没有显示随机效应。选择条件预测后，将出现随机效应变量的各个水平。请注意，包括随机效应时，其它因子的置信区间将变化。


矩法结果

本节仅用于与历史结果匹配

我们不再建议矩法，但我们知道出于教学目的需要给予支持，以便与仍在使用的许多教科书的结果匹配。

在“模型设置”对话框中，可从方法弹出式菜单中选择传统的矩法（EMS 期望均方），如图所示。

矩法各步骤的结果如下：

  • 对于每个效应，计算其期望均方系数。这是方差成分和固定效应值的线性组合，说明了该效应的期望均方值。所有效应都还有一个剩余方差的单元系数。
  • 所有随机效应的期望均方的系数（包括残差）都聚集在一个矩阵中，并用于求解每个随机效应的方差成分。
  • 对于要检验的每个效应，使用不包含要检验的效应或其它固定效应的分子中均方线性组合的项，合成该效应的分母。因此，对于分子与分母的公共项，期望值相等。然后由分子中的剩余项构成效应检验。
  • 使用 Satterthwaite 方法构建合成分母的自由度。
  • 效应检验使用合成分母。

JMP 与 SAS GLM 程序一样，使用 Random 语句和检验选项处理随机效应。"动物数据的矩法分析报表" 显示了实例结果。

警告：最小二乘均值的标准误差与对比 F 检验的分母也使用合成分母。对比可能不适合使用合成分母，尤其是在常用水平进行比较的交叉效应中。杠杆图和自定义检验是根据残差完成的，因此可能不适合。

警告：交叉关系和嵌套关必须显式声明。例如，如果已知对象 ID 同时标识包含该对象的组（即，如果每个对象都仅在一个组中），则必须将对象声明为嵌套在组内。这种情况下，必须显式声明嵌套以定义设计结构。

局限性：如果无法在当前效应语法下指定某一层的误差项的效应，则 JMP 无法拟合分层设计。例如，在整区中使用拉丁方的设计，其误差项为 Row*Column-Treatment。使用 JMP 拟合这种特殊实例需要使用几个模型运行的连续平方和来构建自己的 F 检验。

以上 Animals 实例的标准矩法报表如下。

动物数据的矩法分析报表

将 EMS 表中的随机子矩阵求逆并乘以均方，求出方差成分估计值。这些估计值通常（但不一定需要）为正。残差的方差成分估计值即为均方误差。

请注意，在“方差成分估计值”报表中，方差成分的 CV 最初是隐藏的。要显示它，请使用鼠标右键单击（在 Macintosh 系统上为按住 control 并单击），并从出现的菜单中选择列 > CV。


不平衡实例

Sample Data 文件夹中的机器.jmp 数据表记录了三台不同机器的六个对象给出的 44 种响应（等级）。这 44 种响应的分布如下。

如"具有两个随机效应的模型的“模型设置”对话框" 所示，在“模型设置”对话框中定义模型。此设计声明了两个随机效应，即人工和机器 * 人工。

"具有两个随机效应的不平衡设计的分析报表" 显示了此分析的方差成分估计值和效应检验。

具有两个随机效应的模型的“模型设置”对话框
具有两个随机效应的不平衡设计的分析报表

随机效应的方差比率（方差比率）可通过将其方差成分（方差成分）值除以残差的方差成分求得。因此，随机效应的方差比率为一 (1) 表示随机效应与残差无差别，可将残差用作 F 比率的分母。较大的方差比率表示使用随机效应作为 F 比率的分母更合适。


广义线性模型

模型拟合平台

广义线性模型提供了一种统一方式，用于拟合不符合最小二乘拟合普通要求的响应。特别是那些有 Poisson 分布特征，以模型为索引的频数，使用广义线性模型拟合较方便。

Nelder 和 Wedderburn (1972) 率先使用的方法，其中包括变换响应的一组迭代再加权最小二乘拟合。

JMP 广义线性模型的其它特色功能包括

  • 自定义对比（即参数线性函数）和基于其渐近卡方分布的 p 值的似然比统计量
  • 自定义对比及最小二乘均值的估计值、标准误差和置信限
  • 用于检查模型的图形刻画器
  • 基于侧似然函数的模型参数的置信区间

目录

广义线性模型

广义线性模型特点

广义线性模型实例

模型选择与偏差

实例

Poisson 回归

带位移的 Poisson 回归

正态回归，对数链接

平台命令


广义线性模型

虽然传统的线性模型广泛应用于统计数据分析，但它们可能不适用于某些类型的问题。

  • 有时假定数据呈正态分布可能是不合理的。例如，正态分布（连续）不足以对离散的计数或测量比例进行建模。
  • 如果数据均值自然约束在某个值范围之内，传统的线性模型可能就不适合，因为线性预测值可为任意值。例如，测量比例的均值介于 0 和 1 之间，但在传统的线性模型中均值的线性预测值并不约束在此范围内。
  • 假定所有观测值的数据方差都为常数可能较为不现实。例如，通常会观测到数据方差随数据均值的增加而增加。

广义线性模型扩展了传统的线性模型，因此它适用的数据分析问题范围更广。有关指数系列分布中的概率分布形式，请参阅"广义线性模型实例"部分。

与传统的线性模型一样，拟合的广义线性模型也可通过一些统计量来汇总，如参数估计、标准误差及拟合优度统计量。您也可以使用置信区间和假设检验对参数进行统计推断。但是，特定推断程序通常都基于渐近考虑，因为精确分布理论对于广义线性模型来说不可用或不切合实际。


广义线性模型特点

广义线性模型为“模型拟合”对话框的一个特色。在选择分析 > 模型拟合后，在给模型指定效应之前或之后从下拉菜单选择广义线性模型。

广义线性模型启动对话框

您指定要拟合广义线性模型后，“模型拟合”对话框将发生变化，允许您选择“分布”和“链接函数”。此外，还会出现一个“位移”按钮及“过度分散检验和区间”选项。


广义线性模型实例

通过指定数据中的响应和解释变量并选择相应的链接函数和响应概率分布，即可构建广义线性模型。解释变量可以是连续变量、分类变量的任意组合或交互作用。
广义线性模型实例
模型 | 响应变量 | 分布 | 典型链接函数
传统线性模型 | 连续 | 正态 | 恒等，g(μ) = μ
逻辑斯蒂回归 计数或二元随机变量 二项
Logit,
对数线性模型中的
Poisson 回归 		计数 Poisson 对数，g(μ) = log(μ)
指数回归 正连续 指数

JMP 使用参数向量的极大似然估计，将广义线性模型与数据拟合。参数的极大似然估计通常没有闭合解。JMP 通过迭代拟合过程以数值方式估计模型参数。离差参数 phi symbol 也通过将 Pearson 拟合优度统计量除以其自由度来估计。估计参数的协方差和标准误差，根据极大似然估计量的渐近正态性计算。

JMP 中有很多链接函数和概率分布。内建链接函数包括

恒等：g(μ) = μ
Logit：
Probit：g(μ) = Φ-1(μ)，其中 Φ 是标准的正态累积分布函数
对数：g(μ) = log(μ)
倒数：g(μ) =
幂：
成分重对数：g(m) = log(-log(1 - μ))

可用分布和关联方差函数如下

正态：V(μ) = 1
二元（比例）：V(μ) = μ(1 - μ)
Poisson：V(μ) = μ

注：选择二元分布时，需要第二个 Y 变量来指定试验数。

模型选择与偏差

广义线性建模的一个重要方面就是选择模型的解释变量。拟合优度统计量的更改通常用于计算解释变量子集对特定模型的贡献。偏差定义为极大可达对数似然与回归参数极大似然估计的对数似然之差的两倍，通常用于度量拟合优度。极大可达对数似然通过对于每个观测值都有一个参数的模型来实现。下表给出了 JMP 中每个可用概率分布的偏差。
分布 偏差
正态
偏差函数
Poisson
二项1

1 在二项情况下，y i = r i /m i，其中 r i 为二项计数，m i 为二项试验数参数

Pearson 卡方统计量定义为

其中 V 为方差函数。

变量选择的一个策略是拟合一序列模型，首先拟合只有一个截距项的模型，然后在每个后续模型中都包括一个附加解释变量。根据各个后续模型之间在偏差或拟合对数似然的差异，可以度量附加解释变量的重要性。JMP 计算的渐近检验让您可以评估附加项的统计显著性。


实例

下列实例说明了如何使用 JMP 的广义线性模型平台。

Poisson 回归

此实例使用群居蟹研究数据。每只母蟹都有一只公蟹住在其窝中。此研究为了调查附近是否有其它公蟹（称为伴侣）居住。数据集蟹伴侣.jmp 包含列出伴侣数的响应变量以及描述母蟹颜色、脊柱状况、重量和外壳宽度的变量。数据如"蟹伴侣数据" 所示。

蟹伴侣数据

要拟合 Poisson 对数线性模型，请执行以下操作

  • 选择分析 > 模型拟合
  • 将 satell 指定为 Y
  • 将 color、spine、width 和 weight 指定为效应
  • 选择广义线性模型特点
  • 选择 Poisson 分布

系统应为您自动选择对数链接函数。

  • 单击运行模型。

结果将显示在"蟹伴侣结果" 中。

蟹伴侣结果

整体模型检验提供模型的整体信息。

  • 首先，给出完全模型和缩减模型之间的比较。缩减模型是指只包含一个截距的模型。完全模型则包含所有效应。差模型是指完全模型和缩减模型的对数似然差。p 值 > 卡方与整体模型 F 检验类似。
  • 其次，给出了拟合优度统计量。类似于失拟合检验，它们检验模型的适当性。如果拟合优度统计量的值较低，则表明可能需要在模型中添加高阶项、添加更多协变量、更改分布，或考虑添加过度分散参数（特别适用于 Poisson 和二项情况）。

“效应检验”表显示个体效应的所有参数均为零的联合检验。如果某个效应只有一个参数，如简单回归量中，则这些检验与“参数估计”表中的检验没有区别。

“参数估计”表显示模型中的参数估计及各参数都为零的假设的检验。简单连续回归量只有一个参数。分类效应复杂的模型的每个期望自由度都有一个参数。其中还显示置信限。

带位移的 Poisson 回归

样本数据表货船损伤.jmp 改编自 McCullugh 和 Nelder (1983)。它包含有关因波浪给船头带来的某种损伤类型的信息。轮船建造工程师对与三个变量相关联的损伤的风险感兴趣：货船类型，货船建造年限（制造年度）以及货船服务年限（运行年度，其中 60=1960-74）。

此分析中使用了 Log(Service)，即总计服务月份的对数，作为位移变量。位移变量的处理方式与回归协变量类似，其参数固定为 1.0。

这最常被用于使用对数链接标度的 Poisson 回归中的均值的建模。在此实例中使用了 Log(Service)，因为人们认为修复数与服务月份数成比例。为了解工作原理，假定 GLM 线性成分称为 eta，然后通过对数链接函数，包括位移的均值模型为：

exp(Log(Service) + eta) = (Service) * exp(eta).

要运行此实例，请将

  • 广义线性模型指定为特点
  • Poisson 指定为分布，JMP 将自动选择对数链接函数
  • 将数量指定为 Y
  • Log(Service) 指定为位移
  • 类型、制造年度、运行年度指定为模型效应
  • 选定过度分散检验和区间

“模型拟合”对话框应如"货船损伤模型拟合对话框" 所示。

货船损伤模型拟合对话框

单击“运行模型”时，将看到如"货船损伤报表" 所示的报表。请注意，所有三个效应（类型、制造年度和运行年度）都很显著。

货船损伤报表

正态回归，对数链接

请看下列数据集，其中 x 为解释变量，y 为响应变量。

Nor.jmp 数据集

使用“以 X 拟合 Y”，容易发现 y 随 x 非线性地变化，且方差近似为常数。在此选择了正态分布和对数链接函数来对这些数据进行建模，即 log(μi) = x i'β，因此 μt = exp(x i'β)。填写好的“模型拟合”对话框如"Nor 模型拟合对话框" 所示。

Nor 模型拟合对话框

单击运行模型后，将获得如下报表。

Nor 结果

通过执行以下操作，可获得原始值的预测曲线图

  • 选择保存列 > 预测值。
  • 为 Y 选择图形 > 叠加图，选择预测 Y 作为 Y，并选择 X 作为 X。
  • 在生成的图中，使用鼠标右键单击预测 Y 以撤消选择显示点，然后重复以选择连接点。
预测曲线和原始值

因为是正态分布，所以被学生氏化的偏差残差和偏差残差相同。要进行查看，请从平台下拉菜单选择诊断图 > 偏差残差对预测值图。


平台命令

“广义线性模型”报表中包含如下命令：

定制检验用于检验定制假设。有关定制假设的详情，请参阅"标准最小二乘：估计透视" 章节中的 "定制检验" 。

对比用于检验某个变量内各个水平的差异。在“蟹伴侣”实例中，假设要检验 Dark 颜色的蟹吸引的伴侣是否与 Medium 颜色的蟹不同。选择对比将获得如下对话框。

在此可选择 color 作为兴趣变量。单击执行时，将显示“对比设置”对话框。

要对 Dark 颜色和 Medium 颜色进行比较，请单击 Dark 和 Dark Med 旁边的 + 按钮，以及 Medium 和 Light Med 旁边的 - 按钮。

然后单击完成，获得如下所示的“对比”报表。

由于 p 值 > 卡方小于 0.05，因此可以证明伴侣吸引力会因颜色的不同而不同。

估计值的协方差用于生成模型中所有效应的协方差矩阵。参数估计量的估计协方差矩阵的计算公式如下

Σ = -H-1

其中 H 是在最后一次迭代中使用参数估计计算得出的 Hessian（或二阶倒数）矩阵。请注意，离差参数不管是估计的还是指定的，都将合并到 H。与混杂参数对应的行和列不包括在 Σ 中。

估计值的相关性用于生成模型中所有效应的相关矩阵。相关矩阵是正规化协方差矩阵。也就是说，如果 σij 是 Σ 的元素，则相关矩阵的对应元素为 σij/σiσj，其中

刻画器会弹出用于检查每个 X 变量的预测迹的刻画器。有关刻画器的详情，请参阅"标准最小二乘：探索预测方程" 章节中的 "刻画器" 。

等高线刻画器会弹出交互式等高线刻画器。有关详情，请参阅"标准最小二乘：探索预测方程" 章节中的 "等高线刻画器" 。

曲面刻画器会弹出一个 3D 曲面刻画器。有关曲面图的详情，请参阅"控制曲面" 一章。

诊断图是一个包含多个命令的子菜单，您可以使用这些命令来标绘残差、预测值和实际值的组合，以便搜索离群值和确定模型的适当性。偏差如上"模型选择与偏差"中所述。其中具有如下图表：

被学生氏化的偏差残差对预测值图

被学生氏化的 Pearson 残差对预测值图

偏差残差对预测值图

实际值对预测值图

保存列是用于保存数据表中某些量的子菜单。

预测公式

保存当前模型预测的值

预测值

保存当前模型预测的值

均值置信区间

保存预测方程的 95% 置信限。置信限反映了参数估计变异

保存个体置信限
保存给定个体值的置信限。置信限反映了误差变异和参数估计变异
预测值

保存当前模型预测的值

偏差残差

保存偏差残差

Pearson 残差

保存 Pearson 残差

被学生氏化的偏差残差

保存被学生氏化的偏差残差

被学生氏化的 Pearson 残差

保存被学生氏化的 Pearson 残差


使用对数线性方差模型拟合离差效应

模型拟合平台

此拟合平台允许您使用回归模型来建立期望值和响应方差的模型。它会将方差的对数与一个线性模型拟合，同时将期望响应与另一个线性模型拟合。

对于许多工程师来说，试验的目标并不只是将响应本身最大化或最小化，而是要针对某个目标响应达到最小变异性。对数线性方差模型可以提供一种非常全面且有效的方法来建立方差模型。它既可用于无重复项的数据，也可用于有重复项的数据。

建立离差效应模型在大多数课本中没有介绍，但在田口体系中则不然。在田口类型的试验中，通过以下操作来处理这一问题：多次测量外部数组的设置，构建用于测量此外部数组中变异性偏离度的新响应，然后拟合模型以确定产生最小变异性的因子。此类建模需要专业化的设计，而此设计必须是两个设计的完整笛卡儿积。本章中介绍的方法使用更灵活并基于模型的途径来建立方差模型。田口推荐变异性建模使用的特定性能统计量为 STD = -log(s)。在 JMP 的方法中，将建立 log(s 2) 模型，并将它与带有均值的模型合并。尽管田口版本并不使用方差来为估计均值模型参数所用的数据加权，以上两种方法一般也是等价的，因为 log(s 2)=2 log(s)。

目录

对数线性方差模型

估计方法

JMP 中的对数线性方差模型

模型设置

实例

显示输出

为拟合构建的列

平台选项

备注


对数线性方差模型

对数线性方差模型（Harvey 1976、Cook 和 Weisberg 1983、Aitken 1987、Carroll 和 Ruppert 1988）提供一种非常简洁的方法，只需通过线性模型就能建立方差模型。除了用于建立均值响应模型的回归量项外，线性模型中还有许多用于建立方差对数模型的回归量项：

均值模型：E(y) = Xβ
方差模型：log(Variance(y)) = Z λ，

或者等价于

Variance(y) = exp(Z λ)

其中 X 列是响应均值的回归量，而 Z 列是响应方差的回归量。β 具有常规线性模型参数，λ 具有方差模型参数。

估计方法

对数线性方差模型可通过一种简单的交替方案（EM 方法的一种）来进行估计，从而得到最大似然估计值。

  • 其中将拟合常规 (X) 模型，即响应的均值或期望值模型。
  • 平台会计算出此均值模型的残差，并将其用于创建一个列 ((y-Xβ)2/Z λ -1)，此列将用作估计对数方差模型的因变量。
  • 方差模型用于构建均值模型的权重。
  • 均值模型使用权重进行估计。

此迭代过程会反复交替执行，直至过程收敛。


JMP 中的对数线性方差模型

本部分介绍一种新效应，即离差效应，其标记为对数方差效应，可以建立响应方差变化的模型。“模型拟合”平台通过一个名称为对数方差的拟合特殊情况来实现此功能。

模型设置

通过在“模型拟合”对话框中高亮度显示对数线性方差效应，然后从属性下拉菜单中选择对数方差，可指定这些效应。& 对数方差将出现在效应末尾。在使用此属性时，它还会将顶部的拟合特点更改为对数线性方差。如果要将某个效应同时用于响应的均值和方差，则必须两次指定它，其中一次要使用对数方差选项。

您使用对数方差属性指定的效应将成为生成模型中的 Z 效应，而其它效应则成为模型中的 X。

实例

数据表铸模.jmp 中包含有四个附加中心点的 7 因子 27-3 部分因子设计的试验结果（来自 Myers 和 Montgomery，1995，第 519 页，最初由 Montgomery 提出，1991）。初步研究确定，均值响应似乎只会随着前两个因子铸模温度和转速的变化而变化，而方差似乎只受持续时间的影响。

铸模数据

要继续进行分析，请选择分析 > 模型拟合，然后填写如"“模型拟合”对话框" 所示的“模型拟合”对话框。在将持续时间添加到模型中后，通过属性弹出式菜单选择它并且将其更改为“对数方差”效应。此操作还会将拟合特点强制更改为对数线性方差。单击运行模型按钮开始拟合。

“模型拟合”对话框

显示输出

结果报表的顶部显示了期望响应的拟合，其中的报表类似于标准最小二乘，但是实际上它们是根据加权最小二乘导出的。

均值模型输出
方差模型输出

报表的第二部分给出了方差模型的拟合。方差参数估计值报表会显示估计值及其相关统计量。其中，列 exp（估计值）是估计值的指数。因此，如果因子编码为 +1 和 -1 两个值，则因子的 +1 水平等于方差乘以 exp（估计值）值，而 -1 水平等于方差乘以此列的倒数。记为 exp（2|估计值|）的列是较高方差与较低方差之比（如果回归量在 -1 到 +1 范围内）。另外，此报表还会显示每个估计值的标准误差和 t 比率。截距参数的指数等于方差的整体估计值，其中假设其它所有回归量均为 0。

方差模型的拟合效果显著好于原始模型吗？此问题的似然比检验会将模型拟合与所有参数（截距除外）均为 0 的模型（也就是相等方差模型）进行比较。在本实例中，p 值非常显著。持续时间的变化将会改变方差。

为拟合构建的列

作为拟合过程的一部分，平台总是会创建三个新列，而且每个列的名称中均会附加上响应变量名。名称以 LogVarResid 开头的列为 (r i2/s i2 -1)，它用作方差模型的因变量。名称以 LogVarStd 开头的列为每行的标准差估计值，它实际上是线性模型预测值指数的平方根。名称以 LogVarWgt 开头的列为均值模型中参数估计的权重，它是 LogVarStd 列的平方的倒数。

为拟合构建的列

平台选项

似然比检验
依次去掉模型的各项并重新拟合，从而得到似然比检验。似然比检验一般比 Wald 检验更可信，但它花费的计算时间比较长。
置信区间
为每个参数计算 95% 刻画器似然置信区间。
边际方差
计算对数方差效应每个水平的拟合方差，同时保存其它项的中性值。边际方差类似于均值模型的最小二乘均值，只不过它们是拟合方差。在上述实例中，所有因子均为连续。如果您在将持续时间的建模类型更改为记名后重新运行该实例，则此命令将生成边际方差及其平方根（标准差）的报表：
保存公式
创建四个新数据表列，每个列均包含公式。第一列名称为 yname 均值，其中的公式使用估计的均值模型来计算预测值。第二列名称为 yname 方差，其中的公式使用估计的方差模型来计算拟合方差。第三列名称为 yname 标准差，其中的公式为方差列的平方根。第四列名称为 yname 残差，其中的公式为预测值的响应差异。如果您将本实例的均值公式和方差公式中的系数与参数估计值比较一下，就会知道平台是如何计算模型的。

检查残差

要查看离差效应，我们为持续时间在“单因子”平台上调用了收缩残差（使用保存公式命令生成）：通过下图，您很容易就会看出当持续时间增加时，方差也会增大。此图将持续时间视作记名因子。在前面的拟合中，最开始将它视为连续因子。

残差对离差效应

拟合模型刻画器

包含保存公式的列可用于刻画器、等高线刻画器或曲面刻画器，以便更深入地了解模型拟合。您可以从刻画器子菜单下的平台下拉菜单中选择上面提到的每个选项。例如，假设目标是找到已经达到响应目标 30.23 并且方差最小的因子设置。在模型拟合并保存公式后，请调用公式列中的“刻画器”平台，然后为要优化的合意性函数设置此目标值。

可使方差最小并实现目标的已存公式的刻画器

备注

请注意，在拟合离差模型时，均值模型用权重（拟合方差的倒数）拟合。如果离差效应非常显著，表示这些权重的差异非常大，几乎如同丢掉一半或更多的数据。不要期望得到与未加权的分析相同的结果。

每次估计均值模型的另一个参数时，至少还需要一个观测值，如果可以使用更多观测值更佳。但是对于方差参数来说，每个方差参数均需要多几个观测值。因此，估计方差所需的数据比估计均值需要的数据多。

对数线性方差模型是一种非常灵活的拟合离差效应的方法。与它目前在各种文献中的地位相比，应该受到更多的关注。


逐步回归

模型拟合平台

在 JMP 中，逐步回归是“模型似合”平台的一个特点；是“模型设置”对话框中“拟合特点”弹出式菜单的选项之一。

逐步回归是一种为回归模型选择效应子集的方法。此方法是在模型项的选择方面没有什么理论可以指导的情况下使用，建模者无奈之下，无论什么方法，只要看来可以提供较好的拟合，都想使用。

此方法有些争议。选定模型统计量的显著性水平违背了标准统计假设，因为在固定模型中，是选定了模型而不是检验了模型。从积极的一面来看，此方法已使用了 30 年，帮助优化了用于预测多种响应的模型。《Subset Selection in Regression》一书（作者 A. J. Miller (1990)）使得模型选择统计学具有统计意义。

本章以机械的方式使用术语“显著性概率”，来表示拟合模型中的计算应该有效，认识到真实的显著性概率远不及报告的概率。

目录

逐步回归简介

多重回归实例

逐步回归控制面板

当前估计值表

向前选择实例

步骤历史记录表

向后选择实例

构建模型

所有可能的回归

具有交叉项、交互作用项或多项式项的模型

包括相关项的规则

具有记名项和保序项的模型

针对层次项的构建模型命令

逻辑斯蒂逐步回归


逐步回归简介

在 JMP 中，逐步回归是“模型似合”平台的一个特点，是“模型设置”对话框中“拟合特点”弹出式菜单的选项之一（请参阅"逐步模型的“模型设置”对话框"）。逐步功能计算与其它最小二乘平台相同的估计值，但简化了在许多模型中的搜索和选择。


多重回归实例

作为实例，现在看一下 Sample Data 文件夹中的健身.jmp (SAS Institute Inc. 1987) 数据表，这是需氧锻炼研究的结果。"健身数据表" 显示了健身.jmp 数据表的部分列表。

需氧锻炼可使用一个特殊检验进行评估，此检验将测量一个用踩踏车骑过指定距离的人的摄氧量。但是，找到使用更简单测量（可评估健康和预测摄氧量）的公式，会更省事。要标识这样一个方程式，要对运动了 1.5 英里的 31 名参与者进行年龄、体重、运动时间、脉搏的测量。

要找到一个好的摄氧量预测方程式，需要对许多不同的回归模型进行比较。“逐步”平台可在具有效应组合的模型中搜索，并选择您想要的模型。

健身数据表

注：为了方便说明，对 Rawlings (1988, p.105) 报告数据中的最大脉搏和骑行时脉搏的某些值作了更改。

逐步模型的“模型设置”对话框

要执行逐步回归，请先在分析菜单中选择拟合模型。在“模型设置”对话框中，选择 Y 响应（摄氧量）和一组侯选 X 回归量列。

接着，从对话框右上角的“拟合特点”弹出式菜单中选择逐步，如"逐步模型的“模型设置”对话框" 所示，并单击运行模型。

运行模型时，它将显示一窗口，其中有三个区域：

  • “逐步回归控制”面板，用于对平台进行操作的交互控制面板。
  • “当前估计值”表，显示指定模型的当前状态，并提供附加控制功能。
  • “步骤历史记录”表列出了逐步选择的步骤。

以下几节说明了这些区域中的组件，以及如何使用它们。如果有分类响应，请参阅"逻辑斯蒂逐步回归"。

逐步回归控制面板

如下所示的“逐步回归控制”面板（简称控制面板）有编辑区域、按钮和弹出式菜单。使用这些对话框功能，可限制回归量效应概率，确定选择效应的方法，开始或停止选择流程，以及创建模型。

选择控制面板，如下所示：

进入的概率
是必须归于一个回归量项的显著性概率，以将其作为一个向前步骤输入模型。单击该字段以输入值。
剔除的概率
是必须归于一个回归量项的显著性概率，以将其作为一个向后步骤从模型中移除。单击该字段以输入值。
方向
访问此处所示的弹出式菜单，可用于选择如何将变量输入回归方程式。
如果此项在进入的概率指定的水平上显著，向前会生成最能改进拟合的回归量。
如果此项在剔除的概率指定的水平上不显著，向后会移除最小影响拟合的回归量。
混合交替使用向前步骤或向后步骤。它包括满足进入的概率的最显著项，并移除满足剔除的概率的最不显著项。它会继续移除项，直到剩余项都为显著项，然后再变为向前方向。

控制面板上的按钮可用于控制逐步处理：

执行
启动选择流程。此流程会持续在后台运行，直至完成模型。
停止
停止后台选择流程。
步骤

在逐步流程的每个步骤后都停止

输入全部
将所有未锁定项输入模型。
移除全部

从模型中移除所有项。

构建模型
根据“当前估计值”表中当前显示的模型，为“模型设置”对话框构成模型。在记名项或保序项的情况下，构建模型可创建新的数据表列，以包含模型所需的项。

当前估计值表

通过“当前估计值”表可在模型效应中进行输入、移除和锁定操作。平台开始时，模型中除了截距没有其它项，如下所示。截距永久锁定在模型中。

您可使用复选框来定义逐步回归流程：

锁定
将项锁定在模型内或模型外。锁定不允许将选定的项输入模型或从模型中移除。单击效应复选框可更改锁定状态。
已输入
显示某项当前是否在模型中。您可以单击项的复选框，将效应手动输入模型或排除在模型之外。
参数
列出回归量项（效应）的名称。
估计
当前参数估计值。如果效应当前不在模型中，此值缺失 (.)。
自由度
项的自由度数。如果输入一个项还会强制将其它项输入模型，则此项的自由度不止一个。
SS
将项输入模型时，为误差（残差）SS 的降低量；从模型移除项时，为误差 SS 的增加量。如果以某种方式对项进行限制，则报告的 SS 可能为 0。
“F 比率”
是传统的检验统计量，用于检验项效应是否为 0。它是 t 比率的平方。因为是在拟合时选择模型，所以没有用于检验项的 F 分布，因此用引号引起来。
“p 值 > F”
与 F 统计量关联的显著性水平。与“F 比率”一样，因为不被视为真实的显著性概率，所以用引号引起来。

当前模型的统计量显示在效应列表的上方：

SSE、DFE 和 MSE
当前模型的平方和、自由度和均方误差（残差）。
R 平方
可归于模型中各项（而不是随机误差）的响应的变异比例。
调整 R 平方
通过在计算中使用自由度，调整 R 平方，使它在具有不同参数个数的模型中更具比较性。调整过的 R 平方在逐步过程中很有用，因为可查看许多不同的模型，并可针对模型中的项数进行调整。
Cp
用于选择模型的 Mallow Cp 准则。它是总平方误差的可选测量，定义为
其中 s 2 为整体模型的 MSE，SSEp 为具有 p 变量的模型的平方和误差，其中包括截距。请注意，p 的值为 x 变量个数 + 1。如果 Cp 以 p 绘制，Mallows (1973) 建议选择 Cp 首先达到 p 的模型。
AIC
为 Akaike 信息准则，定义为
其中 n 为观测值个数，p 为模型参数个数，其中包括截距。这是一个用于选择要包含在模型中的最佳参数个数的通用准则。AIC 值最小的模型将被认为是最佳模型 (Akaike 1974)。

向前选择实例

选择的默认方法是向前选择。您可以继续处理健身.jmp 数据实例，方法是使用控制面板上的逐步按钮。此时可看到，在一个步骤之后，会将最显著项骑行时间输入模型（“当前估计值”表的上方，如"当前估计值表" 所示）。单击执行，可查看逐步回归流程运行直至完成。

"当前估计值表" 中的下表显示了，除静止时脉搏和体重之外的所有项都已添加，它们在“逐步回归控制”面板中指定的进入的概率值为 0.25 时不显著。

当前估计值表

步骤历史记录表

随着每个步骤的执行，“步骤历史记录”表会记录将项添加到模型的效应。健身数据实例的“步骤历史记录”表显示了将项输入模型的顺序，以及 R 平方和 Cp 反映的效应。

如果将 Mallow Cp 用作模型选择准则，请选择 Cp 接近 p（模型中参数的个数）的模型。在此实例中，三个或四个变量对于回归模型是较好的选择。

向后选择实例

在向后选择中，先将项输入模型，然后移除最不显著项，直至所有剩余项都显著。

要在 JMP 中执行向后选择逐步回归，请使用控制面板，然后单击输入全部，这将显示如"逐步回归中的向后选择实例" 所示的“当前估计值”表。接着，从方向弹出式菜单中选择向后，并单击步骤或执行。

逐步回归中的向后选择实例

第一个向后步骤将删除静止时脉搏，第二个向后步骤将删除体重。此时不再有满足控制面板中指定的进入的概率的项。“当前估计值”表和“步骤历史记录”表将如"移除项后的“当前估计值”表和“步骤历史记录”表" 所示，其中汇总了向后逐步选择流程。

移除项后的“当前估计值”表和“步骤历史记录”表

构建模型

单击构建模型时，“当前估计值”表中的模型将显示在“模型设置”对话框中。例如，如果在"移除项后的“当前估计值”表和“步骤历史记录”表" 中进行向前选择之后单击构建模型，将会显示如"向前逐步过程中的新“模型设置”对话框" 所示的“模型设置”对话框，其中没有选择拟合特点。

向前逐步过程中的新“模型设置”对话框


所有可能的回归

逐步包含了所有可能的模型命令。您可访问逐步控制面板上的红三角下拉菜单（请参阅"所有可能的模型"）。

所有可能的模型

选定时，将运行回归参数的所有可能模型，生成的报表如"“所有可能的模型”报表" 所示。请注意，此报表适用于三变量（包括骑行时间、骑行时脉搏和最大脉搏）模型。

模型以包含的参数个数的降序排列。其中高亮度显示了每个参数个数的 R 平方最高的模型。

“所有可能的模型”报表

注：在此计算了 Mallow C p 统计量，但在表中一开始是隐藏的。要使其可见，请使用鼠标右键单击（在 Macintosh 系统上为按住 control 键并单击），并从显示的菜单中选择列 > Cp。


具有交叉项、交互作用项或多项式项的模型

来自试验设计的模型中，通常会有叉积项或交互作用项。对于连续因子，这是简单乘法。对于记名因子或保序因子，交互作用是许多列的外积。有交叉项的情况下，通常要对模型选择流程确定规则，从而不能输入交叉项，除非它的所有子项（它所包含的项）都在模型中。

下一个实例使用了化学反应.jmp 样本数据（Box、Hunter 和 Hunter 1978）。响应为 Y，变量为 F、Ct、A、T 和 Cn。

此处显示的模型由所有这样的因子项组成，其中 5 个连续因子中最多有两个因子的交互作用。请注意，有些项有多个自由度（自由度），这是由于对一些项的限制。在上述模型选择规则下，交叉项的所有子项不全都在模型中时，不能将其输入模型。例如，如果逐步流程输入 F*Ct，则还必须输入 F 和 Ct，将 F*Ct 的自由度指定为 3。

多项包含过程是计量自由度与拟合改进机会之间的平衡。有显著交互作用项时，常常在同一步骤中输入几项。在本实例中执行完一个步骤之后，将一起输入 Ct*T 及其包含的两个效应 Ct 和 T。但是，由于可在不移除交叉项的两个子项的情况下移除交叉项，因此向后步骤是不对称的。请注意，如果“逐步”移除 Ct，则也会移除 Ct*T，因此 Ct 目前自由度为 2。


包括相关项的规则

模型中有项的层次结构时，您可以更改应用的规则。请注意，当项相关时，系统会显示名称为规则的附加弹出式菜单。

规则选项用于相关项：

合并
将项与其优先项进行组合，并计算组的显著性概率，作为联合 F 检验输入。合并为默认规则。
限制
限制有优先项的项，从而只能在输入其优先项后，才能输入它们。
无规则
给予选择例程完全的自由进行项的选择，而不管例程是否违反了层次结构。
整体效应
当效应中的所有项都显著时，只输入整体效应。


具有记名项和保序项的模型

传统的逐步回归没有解决模型中有分类项的情况。模型中有记名项或保序项时，这些项作为拟变量列组或指标列组处理。只有两个水平时，由于只生成一列，所以不会出现问题。但是，对于两个以上的水平，必须处理多列。JMP 在标准平台上处理记名变量的惯例是对这些项进行建模，使得在所有水平中参数估计值的平均值为 0。

在逐步平台上，分类变量（记名和保序）以层次方式进行编码，这与最小二乘拟合平台不同。在层次编码中，将以某种顺序考虑分类变量的水平，并进行拆分以构成两组水平，这两组水平能够对响应均值实现最大分隔。接着，将每个组进一步划分为更加独立的子组，以此类推，直到水平 k 的所有水平都划分为 k - 1 项。

例如，使用美式橄榄球.jmp 数据根据体重和位置2 变量来预测速度。位置2 是记名变量，它的值用一个或两个字母缩写形式来表示足球位置。

  • 只考虑位置2 和响应变量速度，方法首先以位置2{wr&db&o&lb&te-ki&l} 项，将位置划分为两组。较慢的组包括传球队员 (wr)、防守后卫 (db) 和进攻后卫 (o)、后卫队员 (lb) 以及进攻队员 (te)。较快的组为中锋 (ki) 和前锋 (l)，划分为位置2{ki-&l}。
  • 下一步将较慢的组进一步划分为传球队员 (wr)、防守后卫 (db) 和进攻后卫 (o)，以及后卫队员 (lb) 和进攻队员 (te)，显示为位置2{wr&db&o-lb&te}。后卫队员 (lb) 和进攻队员 (te) 构成位置2{lb-te}。
  • 对较慢的组再次划分为位置2{wr&db-o}，即传球队员 (wr)和防守后卫 (db) 以及进攻后卫 (o)。
  • 最后的细分为传球队员 (wr) 和防守后卫 (db)，为位置2{wr-db}。

这些项可以按照"项及相应“当前估计值”表的树结构" 顶部所示的树层次结构表示。底部的“当前估计值”表列出了各项及其估计值。

项及相应“当前估计值”表的树结构

使用针对要输入模型的项的默认合并规则或使用限制规则时，除非层次结构中在某项上面的所有项都已输入，否则此项不能输入模型。因此，生成位置2{wr&db&o-lb&te&ki&l} 项很简单，因为层次结构中没有任何项在它之上。但输入 {te-ki} 要求先输入层次结构中在其之上的其它三项：位置2{lb-te&ki}、位置2{lb&te&ki-l} 和位置2{wr&db&o-lb&te&ki&l}。

选择层次编码有几个原因：

  1. 层次编码为正交编码，使得 X 列的变换和 Beta 列的变换相同。在矩阵形式中，
因为 [image] 。
  2. 层次结构导致了自然分级规则。
  3. 造成最大初始分隔的组在初期即输入模型。

对于记名项，水平顺序由 Y 均值确定。对于保序项，保序是固定的。


针对层次项的构建模型命令

为具有记名项或保序项的模型单击构建模型时，拟合模型将在所需数据表中创建一组新列。响应变量的模型将显示在新“拟合模型”窗口中。下一个实例使用了热狗肠2 样本数据说明了逐步如何构建具有层次效应的模型。

一个简单模型（"具有层次效应的模型的逐步平台"）将每盎司的成本视为 Type（Meat、Beef 和 Poultry）与 Size（Jumbo、Regular 和 Hors d'oeuvre）的函数。逐步将构建"具有层次效应的模型的逐步平台" 中所列的模型效应的层次树。该树由对模型具有最大影响的因子水平的组合构成。

在此实例中，向前逐步流程使用规则弹出式菜单中的限制输入效应，并包括模型中四项的三项。

具有层次效应的模型的逐步平台

在“逐步回归控制”面板中选择构建模型时，将发生两个操作：

  • “当前估计值”表列出的指标变量显示在热狗肠2 数据表中，如"通过逐步分析构建的指标变量" 所示。
  • 此时将打开新“模型设置”对话框。效应是通过逐步分析流程选择的新变量，可用于进一步的数据分析。
通过逐步分析构建的指标变量


逻辑斯蒂逐步回归

JMP 执行逻辑斯蒂逐步回归的方式与标准最小二乘逻辑斯蒂回归的方式类似。要运行逻辑斯蒂逐步回归，只需照常向模型添加项，并从“特点”下拉菜单中选择“逐步”。

响应为分类时报表中的差异在报表的当前估计值部分。此时将显示 Wald/Score 卡方统计量，模型的总体拟合显示为负对数似然。实例如"逻辑斯蒂逐步回归报表" 所示。

逻辑斯蒂逐步回归报表

输入和移除统计量分别使用廉价的 Wald/Score 卡方检验进行计算，但回归估计值和对数似然值是基于完全迭代最大似然拟合。如果要比较 Wald/Score 值，请查看“步骤历史记录”报表。


记名响应和保序响应的逻辑斯蒂回归

模型拟合平台

如果模型响应为记名，则 “拟合模型”平台将使用极大似然方法，将线性模型与多水平逻辑斯蒂响应函数拟合。它还将计算整体模型的似然比检验统计量，以及模型中每个效应的失拟合检验和 Wald 检验统计量。其中的选项可用于提供效应和置信限的似然比检验，以及极大似然参数估计值的机会比。

如果响应变量为保序的，则此平台将使用极大似然方法，将累积响应概率与线性模型的逻辑斯蒂分布函数拟合。其中会提供整体模型以及失拟合的似然比检验统计量。

对于简单主效应，您可以使用"简单逻辑斯蒂回归"一章中介绍的“以 X 拟合 Y”平台，查看每个效应的累积逻辑斯蒂概率图。有关这些模型的详情，请参阅"了解 JMP 分析"一章和附录"统计细节"。

目录

逻辑斯蒂模型简介

统计报表

逻辑斯蒂图

迭代历史记录

整体模型检验

失拟合检验（拟合优度）

似然比检验

平台选项

效应 Wald 检验

置信区间

机会比（仅适用于记名响应）

反预测

保存命令

ROC

上升曲线

刻画器

记名逻辑斯蒂模型实例：数清洁剂数据

保序逻辑斯蒂实例：奶酪数据

二次保序逻辑斯蒂实例：爆玉米花盐量数据

当数据为多个列中的计数时应该怎么办


逻辑斯蒂模型简介

逻辑斯蒂回归可用于将记名响应 Y 与 X 项的线性模型拟合。为了使结果更精确，它会使用逻辑斯蒂函数来拟合响应水平的概率。如果有两个响应水平，则函数为：

或者等价于

如果具有 r 个记名响应，并且 [image] ，则它会拟合下面等式的 [image] 组线性模型参数：

极大似然的拟合原理是选择 β，使模型归结到响应中的联合概率最大化。此拟合原理等同于最小化负对数似然（负对数似然）

其属性由模型决定。

举个实例，假设要对一些经过不同时间的加热和浸透的金属锭进行一项试验。然后，检验这些金属锭是否可以进行轧压 (Cox 1970)。Sample Data 文件夹中的铸块.jmp 数据表含有试验结果。

名称为可用性的分类变量的值 1 和 0 分别表示可以和不可以进行轧压。

“拟合模型”平台会将不可以的 (0) 响应的概率与应用于线性模型的逻辑斯蒂累积分布函数拟合，其中使用了加热时间和浸泡时间两个回归量：

其中通过最小化由模型观测值得到的概率的负对数和，来估计其中的参数（极大似然）。

要分析此模型，请选择分析 > 拟合模型。变量可用性为响应 Y，加热时间和浸泡时间为模型效应。数量列为频数变量。当您单击运行模型时，平台就会执行迭代计算。当拟合过程收敛时，将出现记名/保序回归报表。以下部分说明了报表布局和统计表，同时还会给出一些实例。


统计报表

逻辑斯蒂平台最初生成如下所示的报表。失拟合检验只有在适用的情况下才会显示，而似然比检验只在要求时才进行。

所有检验均会将指定的拟合模型与子集或超集模型进行比较，如"统计表之间的关系" 所示。如果检验显示显著性，则证明是高阶模型。

  • 整体模型检验：适用于指定模型显著优于缩减模型，而且除了截距外没有其它任何效应的情况。
  • 失拟合检验：适用于饱和模型显著优于指定模型的情况。
  • 效应检验：适用于指定模型显著优于没有指定效应的模型的情况。
统计表之间的关系

逻辑斯蒂图

如果模型包含一个连续效应，则将出现与“以 X 拟合 Y”中的报表类似的逻辑斯蒂报表。有关这些图的解释，请参阅 上的"逻辑斯蒂概率图的解释"。

迭代历史记录

在启动“拟合模型”后，平台将开始执行迭代估计过程，并报告每次迭代。在拟合过程结束后，您可以打开“迭代历史记录”报表并查看迭代步骤。如果拟合时间过长，您可以随时按下 Escape 键（Macintosh 中为 command(命令) command(命令) - 句号组合键）取消拟合。否则，只有在下述情况下，迭代过程才会停止：对数似然的变化不超过一个相对非常小的量（目标值 - 准则）；参数估计值的变化不超过一个相对较小的量（Delta - 准则）；或者已经执行 15 次迭代。

整体模型检验

“整体模型检验”表将显示一些检验，将整体模型拟合与忽略所有回归效应（截距参数除外）的模型加以比较。此类检验与连续响应的“方差分析”表类似。其中，负对数似然对应于平方和，卡方检验对应于 F 检验。

“整体模型检验”表将会显示以下量：

模型
列出名称为差（完全模型与缩减模型之差）、完全（包含截距以及所有效应的模型）和缩减（只包括截距的模型）的模型标签。
负对数似然
记录每个模型的相关负对数似然。
差是指缩减模型与完全模型之差。它用于测量整体回归量的拟合显著性。
完全描述了整个模型的负对数似然。
缩减描述了只包含截距参数的模型所产生的负对数似然。在金属锭试验中，只包含截距的缩减模型的负对数似然为 53.49。
DF
记录完全模型与缩减模型之差的关联自由度 (DF)。在金属锭试验中，使用两个参数来表示不同的加热时间和浸透时间，因此自由度为 2。
卡方
假设所有回归参数均为 0 时的似然比卡方检验。它等于拟合模型与只含截距的缩减模型之间的负对数似然的差乘以 2。
p 值 > 卡方
在指定模型的拟合效果与只含截距的模型一样的情况下，偶然得到较大卡方值的概率。
R 平方 (U)
显示 R 2，等于差与缩减负对数似然值的比率。有时将它称为 U（不确定性系数）。R 平方的范围介于 0（无改进）和 1（完全拟合）之间。通常，记名模型很少会具有较高的 R 平方；只有在所有事件概率均为 1 时，它的 R 平方才为 1。
观测值
（或权重和）样本中的观测值总数。

在前面的金属锭实例中，当使用两个回归量拟合完全模型后，差行上的负对数似然从缩减负对数似然 53.49 降为 5.82。差与缩减的比率（由拟合得到的不确定性比例）为 10.8%，并且报告为 R 平方 (U)。

要将回归量作为一个整体检验是否显著（“整体模型”检验），可以通过将拟合模型与只含截距的缩减模型之间的负对数似然差乘以 2，计算卡方统计量。在金属锭实例中，此卡方值为 [image] ，显著性为 0.003。

失拟合检验（拟合优度）

JMP 解决的下一个问题是：使用当前模型中的变量是否包含了足够的信息或者是否需要添加更复杂的项。失拟合检验（有时也称为拟合优度检验）可以提供此信息。它通过为数据（“失拟合”表中的饱和行）中回归值的每个组合构建相应的类别来计算纯误差的负对数似然，然后还会检验此对数似然是否显著优于拟合的模型。

饱和自由度为 m-1，其中 m 为总体个数。拟合自由度为参数（不包括截距）个数。在 Ingots 实例中，它们的自由度分别为 18 和 2。失拟合 DF 是饱和模型 DF 与拟合模型 DF 之差，本例中为 18-2=16。

“失拟合”表列出了失拟合的误差、饱和模型的误差（纯误差）以及拟合模型中的总误差的负对数似然。卡方统计量也可用于检验失拟合。

在本实例中，失拟合卡方不显著（p 值 > 卡方 = 0.617），因此可得出这样一个结论，即引入其它变量（如使用多项式或交叉项）并没有多大用处。

似然比检验

利用似然比检验命令可以生成一个与下表相似的表。似然比卡方检验等于整体模型与有待检验假设约束的模型（不含效应）之间的对数似然差乘以 2。由于每个检验均要进行一组单独的迭代，因此这些检验可能要花一些时间。

如果完成拟合的时间少于 10 秒，则此检验为默认检验。


平台选项

分析名称旁边的弹出式菜单将为您提供下面要介绍的 6 个附加命令。

效应 Wald 检验

似然比检验的一个缺点就是涉及重新拟合整体模型，而且会使用另一系列的迭代。因此，大型问题可能需要很长的时间。逻辑斯蒂拟合平台提供了另一个功能相同但更简单的检验。Wald 卡方是对似然比检验的一步线性近似，也是计算的副产品。尽管很多人认为 Wald 检验的可信度不大，但是它们的确能够为筛选效应提供充分的显著性指标。每个 Wald 检验均会显示一个参数估计值和一个效应。如果完成拟合的时间多于 10 秒，则此检验为默认检验。

似然比检验是一个在"似然比检验"中介绍的平台选项，我们极力建议您使用此选项。

置信区间

您还可以要求模型参数的侧似然置信区间。在您选择置信区间命令后，将有一个对话框提示您输入 α 以计算 1 - α 置信区间，或者您可以使用默认值 α = 0.05。每个置信限均要求在模型拟合中进行一组迭代，因此会非常耗时。另外，结果也不一定都是可以成功找到置信限。

机会比（仅适用于记名响应）

当您从平台弹出式菜单中选择极差机会比或单位机会比时，“参数估计值”表将展开以显示机会比，如"具有机会比的参数估计值" 所示。

具有机会比的参数估计值

在简介部分（对于两个响应水平），我们已经知道

因此，机会比为：

请注意，exp(βi(X i + 1)) = exp(βi X i) exp(βi)。这表明，如果 X i 按单位值变化，机会将乘以 exp(βi)，我们将它标记为单位机会比。当 X i 在它的整个极差范围内变化时，机会将乘以 exp((X high - X low)βi)，我们将它标记为极差机会比。对于二元响应，翻转响应变量的对数机会比只涉及更改符号，因此您可能会希望负报告值只出现在最后一个响应值上，而不出现在第一个响应值上。

二水平记名效应的第一个水平和第二个水平编码分别为 1 和 -1，因此极差机会比或它们的负值非常重要。

药剂反应实例

在样本数据表药剂反应.jmp 中，剂量在 1-12 之间变化。利用“模型拟合”平台，在从平台下拉菜单中选择单位机会比和极差机会比命令后，我们可以得到如下报表。

剂量的单位机会比为 1.606（也就是 exp(0.473)），表示每增加一个单位的剂量，就会使获得 Y = 0（而不是 Y = 1）的机会按因子提高1.606。剂量的极差机会比为 183.8 (exp((12-1)*0.473))，表示当剂量在 1-12 之间变化时，机会将按因子 提高183.8。

反预测

对于二水平响应，使用反预测命令可以找到产生指定概率的 x 值。例如，使用铸块.jmp 数据，忽略变量浸泡时间，然后使用用于简单逻辑斯蒂回归的以 X 拟合 Y 命令拟合可用性对加热时间的概率（数量为频数）。累积逻辑斯蒂概率图将显示结果。

请注意，在温度水平大约为 39.5 时，拟合曲线穿过 0.9 的概率水平，这就是反预测。为了使结果更精确并得出置信区间，您可以使用以 X 拟合 Y 中的反预测命令（有关“以 X 拟合 Y”简单逻辑斯蒂分析的详细介绍，请参阅"简单逻辑斯蒂回归"一章）。如果您在“反预测”对话框中精确地指定 0.9，则温度的预测值（反预测）为 39.8775，如上表所示。

但是，如果您还有另一个回归量变量（浸泡时间），则必须使用“拟合模型”平台。选择反预测命令将会显示如"“反预测”对话框和表" 所示的“反预测”对话框，在此可要求获得某个自变量的给定值的概率。要填写此对话框，请单击可编辑的 X 和概率列并键入相应的值。输入一个 X（加热时间或浸泡时间）的值以及所需的预测概率。通过单击剩余自变量的 X 字段并将其删除，将其设定为缺失。缺失回归量即为要预测的值。

“反预测”对话框和表

有关反预测的详情，请参阅附录"统计细节"。

保存命令

如果您具有保序或记名响应模型，则可以利用保存概率公式命令来创建新的数据表列。

如果响应为数值并且具有保序建模类型，则保存分位数和保存期望值命令也可用。

利用保存命令可以创建以下新列：

保存概率公式
在当前数据表中创建一些列，用于保存响应水平的线性组合公式、响应水平的预测公式以及提供极大似然响应的预测公式。
对于具有 r 个水平的记名响应模型，JMP 将会创建：
  • 名称为线性 [j] 的列，其中包含响应水平 j = 1, 2, ... r - 1 的回归量的线性组合
  • 名称为概率 [r] 的列，其中包含用于与最后一个水平 r 拟合的公式。
  • 名称为概率 [j] 的列，对于 j < r，则其中包含用于与水平 j 拟合的公式。
  • 名称为极大似然响应名称的列，根据计算得出的概率选择每行的极大似然水平。
对于具有 r 个水平的保序响应模型，JMP 将会创建：
  • 名称为线性的列，其中包含回归量（不含截距项）的线性组合公式。
  • 名称为积累 [j] 的列，每个列中均包含响应小于或等于水平 j 的累积概率公式（对于 j = 1, 2, ... r - 1 个水平）。其中没有积累 [ j = 1, 2, ... r - 1]，因为所有行的此值均为 1。
  • 名称为概率 [ j = 1, 2, ... r - 1] 的列，对于 1 < j < r，则每个列均包含响应为水平 j 的概率公式。概率 [j] 等于积累 [j] 与积累 [j - 1] 之差。概率 [1] 为积累 [1]，概率 [r] 为 1 - 积累 [r - 1]。
  • 名称为极大似然响应名称的列，根据计算得出的概率选择每行的极大似然水平。
保存分位数
在当前数据表中创建名称为.05 分位数、.50 分位数和 .95 分位数的列，用于拟合这三个概率的分位数。
保存期望值
在当前数据表中创建一个名称为保序预期值的列，它是响应值与每行的拟合响应概率的线性组合，可提供期望值。

ROC

接受者操作特征 (ROC) 曲线可用于测量模型拟合概率的排序效率，以便对响应水平进行排序。ROC 曲线还可以帮助设定诊断检验中的准则点。曲线越高于对角线，拟合越好。ROC 曲线简介可在"简单逻辑斯蒂回归" 章节中的 "ROC（接受者操作特征）曲线" 部分找到。如果逻辑斯蒂拟合具有两个以上的响应水平，则它会生成一条广义 ROC 曲线（与“划分”平台中的曲线相同）。在此类图中，每个响应水平均有一条对应的曲线，这就是该水平对其它所有水平的 ROC 曲线。有关这些 ROC 曲线的详情，请参阅"递归划分" 章节中的 "拟合优度图" 。

上升曲线

产生模型上升曲线。上升曲线显示的信息与 ROC 曲线显示的信息相同，但是它最初会展示排序的重要性。Y 轴会显示与响应水平的整体比例进行比较，该总体部分占选定响应水平的重要性比率。有关上升曲线的详情，请参阅"递归划分" 章节中的 "上升曲线" 。

刻画器

生成预测刻画器，在更改模型中的因子值时，它还会显示指定响应概率的拟合值。此选项目前只适用于记名响应，不适用于保序响应。


记名逻辑斯蒂模型实例：清洁剂数据

曾经有过一次市场研究，目的是评选出消费者首选的清洁剂品牌（Ries 和 Smith 1963）。结果位于清洁剂.jmp 样本数据表中。

模型由以下元素确定：

  • 名称为品牌的响应变量，值为 m 和 x。
  • 名称为柔软度（水柔软度）的效应，值为 soft、medium 和 hard。
  • 名称为先前使用过的效应，值为 yes 和 no。
  • 名称为温度的效应，值为 high 和 low。
  • 名称为频数的计数变量，提供每个效应类别组合的频数。

研究开始时指定了一个三因子完全析因模型，如"具有记名响应的三因子析因模型" 中的“模型设置”对话框所示。要指定析因模型，请高亮度显示列选择器列表中的三个主效应。然后，从宏弹出式菜单中选择完全析因（试验）。

具有记名响应的三因子析因模型

"记名响应的三因子析因模型表" 表中，显示此三因子析因模型，总体上是显著的（p 值 > 卡方 =0.0006）。“效应似然比检验”表表明，包含柔软度的效应对模型拟合没有显著贡献。

记名响应的三因子析因模型表

接下来，再次使用“模型设置”对话框移除其中的柔软度因子及其交互作用，因为它们并不显著。通过在“模型拟合”对话框中双击柔软度因子，即可轻松地实现此目的。此时将出现一个对话框，询问您是否要移除涉及柔软度的其它因子，若您移除了这将得到如"具有记名响应的二因子析因模型" 所示的二因子模型。

具有记名响应的二因子析因模型

“整体模型检验”表表明，二因子模型的拟合效果与三因子模型的效果一样好。事实上，"记名响应的三因子析因模型表" 中的“整体模型”表表明，三因子模型的卡方值 (32.83) 比二因子模型的卡方值 (27.17) 大。这是因为用于计算卡方值及其概率的自由度发生了变化。

"记名响应二因子析因模型" 中显示的报表表明，以前使用的清洁剂品牌对消费者的清洁剂选择有很大的影响，水温也有边缘显著影响，但水柔软度似乎没有什么作用。

记名响应二因子析因模型


保序逻辑斯蒂实例：奶酪数据

如果响应变量有保序建模类型，则此平台会使用极大似然，将累积响应概率与线性模型的逻辑斯蒂函数拟合。其中会提供整体模型以及失拟合的似然比检验统计量。每个效应都会有 Wald 检验统计量。

如果具有保序响应以及单个连续数值效应，则“以 X 拟合 Y”中的保序逻辑斯蒂平台将显示累积逻辑概率图。

有关建模类型的详情，请参阅"了解 JMP 分析"一章；有关拟合的详情，请参阅附录"统计细节"。Walker 和 Duncan (1967)、Nelson (1976)、Harrell (1986) 以及 McCullagh 和 Nelder (1983) 中也有介绍这种方法。

注：如果具有多个响应水平，则保序模型的拟合速度比记名模型要快得多，同时它占用的内存也比记名模型少。

举个保序逻辑斯蒂模型拟合的实例，McCullagh 和 Nelder (1983) 曾报告过一项由 Newell 进行的试验，目的在于检验不同种类的奶酪添加剂 (A-D) 对于味道的影响。味道通过品尝小组来测量并按从 1（非常不喜欢）到 9（非常美味）的保序尺度来记录。数据位于奶酪.jmp 样本数据表中。

要运行模型，请将响应指定为 Y；奶酪指定为效应；计数指定为频数。

本实例中的方法只需要进行 6 次迭代，因此将背景负对数似然从 429.9 减少为 355.67。进而得出整体模型的似然比卡方 148.45 和自由度 3，表明所感觉到的奶酪味道存在高度显著差异。

“失拟合”检验会将保序响应模型与记名模型进行比较，加以检验。这是因为如果将响应视为记名响应而不是保序响应，模型就会饱和，并会提供 21 个附加参数，因此失拟合自由度就是 21。失拟合的非显著性可以证明保序模型的合理性。

由于总共有 9 个响应类别，因此具有 8 个截距参数。但只有 3 个结构参数。因此在记名模型中，共有 [image] 个结构参数。

由于只有一个效应，因此对它进行的检验等同于整体模型的似然比检验。此处的似然比卡方为 148.45，与 Wald 卡方 115.12 不同，表明 Wald 检验是有某些值得质疑的地方。

A | -0.8622 | 第 2 名
B | 2.4895 | 最不喜欢
C | 0.8477 | 第 3 名
D | -2.4755 | 最喜欢

要查看消费者是否喜欢某种奶酪添加剂，请查找参数的最大负值（奶酪 D 的效应为其它值总和的负数）。

您也可以对此模型使用“以 X 拟合 Y”平台，它会使用相同的方法来处理记名响应和保序响应，并显示列联表分析。这里显示的误差对数似然与前面显示的失拟合饱和对数似然一致。

如果要查看响应概率（四种奶酪的参数估计值的函数）图形，您可以创建一个新的连续变量（称之为得分）以及如"保序逻辑斯蒂回归的模型对话框" 所示的公式。使用新变量作为“模型设置”对话框中的响应面效应（如下所示）。要创建如"保序逻辑斯蒂回归的模型对话框" 所示的模型，请从列选择器列表中选择得分，然后从“模型设置”对话框的“宏”弹出式菜单中选择响应面。

保序逻辑斯蒂回归的模型对话框
[

单击运行模型，可查看分析报表及如"保序逻辑斯蒂回归的累积概率图" 所示的累积逻辑斯蒂概率图。每条曲线间的距离代表水平的拟合响应概率（按水平在该图右轴上的顺序）。

保序逻辑斯蒂回归的累积概率图


二次保序逻辑斯蒂实例：爆玉米花盐量数据

“保序响应模型”可以拟合二次表面，从而优化较高或较低响应的概率。结构参数的算法与连续响应的算法相同。最多可以使用 5 个因子，但本实例中只有一个因子，其中提供了其概率图。

假设某个微波炉爆玉米花制造商想要了解消费者喜欢的爆玉米花盐量。为此，该制造商想要知道最好响应的最大概率，作为在爆玉米花包中添加的盐量的函数。试验将盐量控制在 0、1、2 和 3 茶匙之间，并且消费者对味道的评分按 1（低）到 5（高）的尺度来表示。最佳盐量是指使消费者的最好响应概率达到最大时的那个量。每个盐量水平的 10 个观测值如下所示。

使用拟合模型以及样本数据爆玉米花盐量.jmp 将保序味道检验与盐量的表面效应拟合。填写“模型设置”对话框（如上述实例所示）。

报表会将显示二次模型是如何拟合响应概率。生成的曲线不再是移位逻辑斯蒂曲线，而是一些皱褶式曲线，而且每条曲线都是在同一点达到最优值。临界值位于 -0.5 b1/b2 处，其中 b1 是指线性系数，b2 是指二次系数。根据“参数估计值”表，您可以计算最优值为

茶匙的盐。

每条曲线之间的距离用于度量 5 个响应水平中每个水平的概率。最高响应水平的概率为最上边的曲线到图方框顶部的距离。当盐量大约为 1.3 茶匙时，此距离达到最大值。所有曲线的临界点都相同。

盐和盐*盐的参数估计值成为用于查找临界值的系数。尽管它显示为最小值，但这只是相对于概率曲线而言。在最大化最高响应的概率时，它实际上是一个最大值。


当数据为多个列中的计数时应该怎么办

数据表的多个列中列出的频数（计数）的数据不是进行逻辑斯蒂回归时所需的形式。例如，数据文件夹中的数据表铸块2.jmp（"更改数据表格式" 左侧的表）具有可用数量和不可用数量两个列，它们将为加热时间和浸泡时间值的每个组合提供就绪的金属锭数和未就绪的金属锭数。要进行逻辑斯蒂回归，您需要类似于"更改数据表格式" 右侧表中的数据格式。

要制作新表，请从表菜单中选择堆叠命令。通过选择可用数量和不可用数量作为要堆叠的列来填写“堆叠”对话框，然后单击“堆叠”对话框中的确定。此操作将在"更改数据表格式" 的右侧创建一个新表。如果使用默认列名，则标签为响应 (Y) 列，Data 为频数列。

"逻辑斯蒂模型简介"部分的实例显示了使用样本数据表铸块.jmp 进行的逻辑斯蒂回归。它具有一个名称为数量的频数列（相当于下表中的 Data 列）和一个名称为可用性的响应变量，其中值 1 表示金属锭就绪；值 0 表示未就绪。

更改数据表格式

注：数据表中的有些列处于隐藏状态。


多重响应拟合

模型拟合平台

当“模型拟合”平台中的模型指定了多个 Y 时，可为多元拟合选择多元方差分析特性。多元模型将多个 Y 与一个效应集拟合。通过相应的响应设计可检验 Y 间的函数。除标准的多元方差分析模型之外，还可通过此工具实现以下技术：

  • 对每个对象都进行重复测量，且同时要分析测量中的对象间效应和对象内效应时，可进行重复测量分析。当测量间的相关性结构是任意时，这种多元方法尤其重要。
  • 典型相关性，用来查找具有最高相关性的 X 和 Y 变量的线性组合。
  • 判别分析，用来查找点之间的距离公式和各组的多元均值，由此可将点分类到最可能属于的组中。在判别平台中可实现更完整的判别分析。

多元拟合与一元拟合不同。多元拟合从初步的预先分析开始，从而显示参数估计值和最小二乘均值。接着，您可以指定 Y 间的响应设计，执行多元检验。

目录

多重响应模型设置

初始拟合

响应设计规格

多元检验

扩展多元报表

多元检验比较

一元检验和球形检验

带重复测量的多元模型

重复测量实例

复合多元模型

响应类型命令和效应

检验详细资料（典型详细资料）

重心图

保存典型值（典型相关性）

判别分析


多重响应模型设置

要构成多元模型，请从分析菜单中选择拟合模型，并在对话框中指定多个 Y。接着，从拟合特点弹出式菜单中，选择如下所示的多元方差分析，然后单击运行模型。

下一个实例使用高尔夫球.jmp 样本数据表（McClave 和 Dietrich，1988）。这些数据是三种品牌的高尔夫球的飞行距离和耐用性程度的比较。自动高尔夫球机以随机顺序击打每种品牌 10 个球中的一个随机样本。检验假设是三种品牌的高尔夫球的距离和耐用性相同。

初始拟合

多元拟合平台使用最小二乘将响应与效应拟合。下图显示了初始拟合结果的多元方差分析报表。所有表均显示为关闭，但有些表默认情况下通常是打开的。这些结果本身可能并不十分有趣，因为还没有指定响应设计。在指定响应模型后，多元平台将显示多元估计值和检验表。后面几节将论述初始表、响应设计规格和多元详细资料表。

参数估计值表

“参数估计值”表只包括每个响应变量的参数估计值，不包括如标准误差或 t 检验等详细资料。其中，每个响应变量都有一列。

最小二乘均值报表

对于每个纯记名效应，“最小二乘均值”表均报告了所有响应列的总体最小二乘均值、每个记名水平的最小二乘均值以及均值的刻画图。"最小二乘均值报表" 显示了高尔夫球品牌的刻画图和最小二乘均值表。在此通过开启展开/隐藏按钮，可获得总体均值的图形和表。

最小二乘均值报表

偏协方差表和偏相关表

“偏相关”表显示根据 X 效应调整的初始拟合残差的偏相关矩阵和协方差矩阵。

总体 E 矩阵和 H 矩阵

多元检验的主要成分是 E 矩阵和 H 矩阵：

  • E 矩阵的元素是残差的叉积。
  • H 矩阵与假设平方和及叉积对应。

其中，有针对整体模型的 H 矩阵，以及针对模型中每个效应的 H 矩阵。E 矩阵和 H 矩阵的对角元素与一元 F 检验的假设（分子）和误差（分母）平方和对应。任何指定响应设计的新 E 矩阵和 H 矩阵都根据这些初始矩阵构成，并且多元检验统计量也是根据它们计算。

响应设计规格

使用报表顶部的“响应规格”对话框可指定各种检验的响应设计。

该对话框有如下可选复选框：

  • 同时进行一元检验复选框用于重复测量模型，以获得调整和未调整的一元重复测量检验和多元检验。
  • 同时分别检验各列复选框用于获得对每个响应进行的一元方差分析检验及多元检验。

响应设计构成 M 矩阵。M 矩阵的列定义了一组用于多元分析的变换变量。选择响应弹出式菜单列出了如下所示的针对 M 的选项。该弹出式菜单有如下响应矩阵，它还允许通过自定义命令建立自己的响应。

重复测量将同时构建并运行“总和”和“对比”响应。

汇总是响应的总和，提供了单个值。

恒同使用各个单独响应，即单位矩阵。

对比比较每个反响应和第一个响应。

多项式构建一个正交多项式矩阵。

Helmert 将每个响应与其下的组合响应进行比较。

刻画将每个响应与其下的响应进行比较。

均值将每个响应与其它响应的均值进行比较。

复合创建和运行几个相应的响应函数（如果响应由两个效应复合而成）。

定制使用输入的任何自定义 M 矩阵。

注：本章开头的矩阵名称 E 和 H 指的是误差和假设叉积。在设定响应设计之后，E 和 H 指的是由响应设计变换的叉积，实际上是 MEM 和 MHM。

最典型的响应设计是多元回归的重复测量和恒同。对比、Helmert、刻画和均值给出的检验会稍有差异，因为它们生成的空间相同。但是，最小二乘均值及其“参数估计值”表中的检验和详细资料会相应显示不同的高亮度显示项。

重复测量和复合响应选择会显示用于指定响应效应名称的对话框。接着，它们会继续拟合几个响应函数，而不等待更多的用户输入。

另外，选择扩展了控制面板，并向用户提供了更多细化规格的机会。响应函数以 M 矩阵的形式显示，而控制按钮显示在对话框底部（请参阅下图）。您可以以如下方式使用该对话框的此部分：

  • 选定同时进行一元检验复选框，查看重复测量情况下的调整和未调整的一元检验及多元检验。对于正交化版本的 M，则进行一元检验。
  • 单击 M 矩阵文本编辑框中的任何一个值，可对其进行更改。
  • 使用正交化按钮，将矩阵正交化。在列对比（总和为 0）之后，对除汇总和恒同之外的所有响应类型执行正交化。
  • 使用删除最后一列，减少变换的维数。

下图显示了从响应设计弹出式菜单选择的恒同变换以及 Y 变量距离和耐用性的默认 M 矩阵。“响应规格”对话框一直打开，以便为估计和检验指定更多的响应设计。


多元检验

在完成“响应规格”对话框后，请单击对话框底部的“运行”，查看多元估计和检验。分析报表会附加至初始表。

多元检验菜单

每次运行响应设计时，JMP 都会用该设计的其它表来扩展报表。右边的实例显示了恒同设计和这些扩展的报表的外框：

  • M 矩阵响应设计
  • M 变换参数估计值
  • 除用于截距的截距检验以及模型中的每个效应之外，对所有效应共同进行整体模型检验

另外，响应矩阵名称旁边的弹出式命令可用于构建自定义检验。模型效应旁边的菜单还提供了其它选项，稍后讲述。

扩展多元报表

在多元拟合中，假设和误差的平方和是平方和叉积的矩阵，而不是单个数字。对于假设平方和及叉积的矩阵（称为 H 或 SSCP）与残差矩阵（称为 E）比较，有许多方法可用来评定哪个值较大。JMP 提供了 4 种在参考书中通常都有介绍的多元检验。如果要查找显著性水平精确的检验，必须在参考书中查找表。幸运的是，所有 4 种检验都可变换为近似 F 检验。如果响应设计产生单个值，或假设为单个自由度，则多元检验是等价的，并将产生相同的精确 F 检验。JMP 标记了文本精确的 F 值；否则标记为近似值 F 值。

本章开头所述的高尔夫球的实例中，只有一种效应，因此整体模型检验与品牌检验是相同的，即显示了 4 种带近似 F 检验的多元检验。其中只有一个单截距，带两个自由度（每个响应各一个），因此它的 F 检验是精确的，并标记为精确的 F 值。

通过“整体模型”、“截距”和“品牌”表名称旁边的弹出式菜单图标，可访问相关命令，以便生成附加信息，其中包括特征值、典型相关性、重心值列表、重心图以及可用于保存典型变量的保存命令。这些选项将在"响应类型命令和效应"节讨论。

效应（本实例中的品牌）弹出式菜单还包括用于指定对比的选项。

自定义检验和对比功能与单个响应的回归相同。有关对比和自定义检验的说明和实例，请参阅"标准最小二乘：入门"和"标准最小二乘：估计透视"两章。

附录"统计细节"中的"多元详细资料"显示了用于多元方差分析表检验的公式。

每个多元方差分析检验表（除了“球形检验”表之外）都有以下元素：

检验
标记了表中的每个统计检验。如果响应函数值（M 矩阵中指定的列）的个数为 1，或如果每个响应函数的效应都只有一个自由度，则显示精确 F 检验。否则，为标准的 4 个多元检验统计量提供近似 F 检验：Wilk's Lambda (Λ)、Pillai's Trace、Hotelling-Lawley Trace 和 Roy's Maximum Root。
值
报表中每个多元统计检验的值。
近似值 F 值（或精确的 F 值）
与多元检验相对应的 F 值。如果响应设计产生单个值，或如果检验为一个自由度，则检验为精确 F 检验。
分子自由度
分子自由度。
分母自由度
分母自由度。
p 值 > F
与 F 值对应的显著性概率。

多元检验比较

尽管 4 个标准多元检验的结果通常相似，但有些情况下也会有差异，可能一种比另一种更有优势。不幸的是，没有哪一种明显更胜一筹。通常，从效能角度看的优先顺序为：

  1. Pillai's Trace
  2. Wilk's Lambda
  3. Hotelling-Lawley Trace
  4. Roy's Maximum Root。

当虚假设有较大偏差且特征值有较大不同时，优先顺序相反 (Seber 1984)。

一元检验和球形检验

在重复测量模型等情况下，可以将多元问题变换为一元问题（Huynh 和 Feldt 1970）。在以下情况下，在多元检验文中使用一元检验是合法的：

  • 如果响应设计矩阵 M 为正交（MM = 单位矩阵）。
  • 如果 M 产生多个响应，每个变换的系数总和为 0。
  • 如果满足球形条件。球形条件意味着 M 变换的反响应互不相关，但有相同的方差。MΣM 与单位矩阵成比例，其中 Σ 为 Y 的协方差。

如果保持这些条件，E 和 H 检验矩阵的对角元素总和为 F 检验分母和分子的一元平方和。

在“响应规格”对话框中选定同时进行一元检验复选框时，将看到如下所示的“球形检验”表，以及多元报表表中调整的一元 F 检验。

球形检验将使用 Mauchly 准则，检查对象内效应未调整的一元 F 检验的恰当性，以便检验球形假设 (Anderson 1958)。球形检验和一元检验始终通过正交化 M 矩阵实现。您可按如下方式解释球形检验：

  • 如果球形卡方检验不显著，则可使用未调整的一元 F 检验。
  • 如果球形检验显著，则使用多元检验或调整的一元检验。

一元 F 统计量有近似 F 分布（即使没有球形），但分子自由度和分母自由度会由于某个小数 Epsilon (ε) 而降低。BOX (1954)、Geisser 和 Greenhouse (1958) 以及 Huynh-Feldt (1976) 提供了用于估计 Epsilon 自由度调整的方法。根据效能研究，Muller 和 Barton (1989) 推荐 Geisser-Greenhouse 版本。

多元报表中的 Epsilon 调整检验标记为 G-G (Greenhouse-Geisser) 或 H-F (Huynh-Feldt)，其中 Epsilon 调整显示在值列。


带重复测量的多元模型

多元拟合常用于分析重复测量数据，也称为纵向数据。对象随时间重复测量，且将排列数据，使每次的测量都构成一个变量。由于测量之间的相关性，因此应将数据堆叠到一个单列，作为一元模型分析，除非相关性构成球形模型。有关此主题的详情，请参阅上一节"一元检验和球形检验"。

通过重复测量，可将分析分为两层：

  • 通过将重复测量列总和与模型效应拟合，可建立对象间（或者跨对象）效应模型。这和使用汇总响应函数对应，是 1 单向量的 M 矩阵。
  • 通过响应函数拟合重复测量列的差，可建立对象内效应（重复效应或时间效应）模型。此分析的实现方法包括对比响应函数或任何其它类似差函数：多项式、Helmert、刻画或均值。在重复测量间建立差模型时，请将差视为新对象内效应，通常是时间。模型拟合效应时，请将它们解释为对象内效应的交互作用。例如，截距效应变为时间（对象内）效应，体现了重复测量间的总体差。如果有效应 A，对象内检验将解释为 A*Time 交互作用的检验，从而体现重复测量间的差在 A 效应中有何不同。

"对应的多元检验和一元检验"显示了与一元模型设置相比，响应函数与模型效应之间的关系。同时使用汇总（对象间）和对比（对象内）模型，可以重新构建多个检验，将响应堆叠到单列并获得标准一元拟合。

要执行重复测量分析，有直接方法和间接方法两种：

  • 直接方法是使用弹出式菜单项“重复测量”。此方法会提示您对效应进行命名，以表示重复测量间的对象内效应。接着，它将拟合“对比”和“总和”响应函数。此方法的优点在于将效应相应标记为对象内效应名称。
  • 间接方法是分别指定两个响应函数。首先，执行“总和”响应函数，然后指定“对比”响应函数或另一个用于建立差模型的函数。必须记住，要在对比拟合中将对象内效应与模型效应关联。

重复测量实例

以 Cole 和 Grizzle (1966) 所做的一项研究为例。结果在 Sample Data 文件夹下的狗.jmp 表中。其中将 16 只狗分为 4 组，由变量药剂和组织胺1 定义，每个变量有两个水平。因变量为注射药物后 0、1、3 和 5 分钟时的血液组胺浓度。浓度的对数用于将数据的均值和方差之间的相关性降到最低。

对于重复测量，在控制面板弹出式菜单（如前所示）上指定重复测量设计，然后显示此处所示的对话框。

如果选定同时进行一元检验复选框，报表将包括与此一元检验相对应的检验，如"多元检验菜单" 所示。计算一元检验时，假设将响应堆叠到单列。

"对应的多元检验和一元检验"显示了如果将组织胺0的对数、组织胺1的对数、组织胺3的对数和组织胺5的对数列的数据堆叠到单个 Y 列，且新行标识有一个记名分组变量时间，汇总与对比响应设计的多元检验与一元检验标记方式的对应关系。

对应的多元检验和一元检验
总和 M 矩阵 对象间 |  | 对比 M 矩阵 对象内
多元检验 | 一元检验 | 多元检验 | 一元检验
截距 | 截距 | 截距 | 时间
药剂 | 药剂 | 药剂 | 时间*药剂
消耗 | 消耗 | 消耗 | 时间*消耗

首先生成对象间分析。如果在弹出式菜单上选择了汇总，此分析会和期望相同（标题除外）。

然后生成对象内分析。如果在弹出式菜单上选择了对比，此分析会和期望相同（标题除外），尽管对象内效应名称（时间）已添加到报表中的效应名称中。请注意，原先截距的位置被时间占用，这是因为截距项正在估计重复度量间的整体差。

狗数据的重复测量分析


复合多元模型

JMP 可处理多层重复测量的数据。例如，参阅 Sample Data 文件夹（"复合多元设计的数据"）中的胆固醇.jmp 表。5 个对象的组属于 4 个治疗组中的一个，即 A、B、Control 和 Placebo。早上和下午分别对胆固醇进行测量，每月一次，共三个月（数据是编造的）。在此实例中，响应列按时间顺序（每月具体日期的时间）排列。这些列按三列 AM 和三列 PM 的测量顺序交叉排列，其中 AM 在前。

复合多元设计的数据

要分析此试验设计，请将治疗声明为唯一效应，所有 6 个响应列声明为 Y 变量，完成“模型设置”对话框。单击运行模型时，将显示 4 个用于初始拟合的表。

在“最小二乘均值”表中，可以发现这 4 个治疗组以非常类似的胆固醇均值开始此项研究。A 和 B 治疗组在试用期结束时表现出较低的胆固醇值。Control 和 Placebo 组保持不变。

接着，从“响应设计”弹出式菜单选择复合。完成此对话框后，就向 JMP 说明了响应在数据表中的排列方式，以及每个响应的水平数。在胆固醇实例中，时间列排列在月份中。因此，在第一个框中命名时间，在第二个框中命名月份效应（请参阅"复合对话框"）。请注意，检验交互作用效应为可选项。

复合对话框

单击确定时，将显示每个效应的检验。部分统计报表如"胆固醇研究结果" 所示。

  • 进行测量的时间没有显著效应。请注意，因为只有两个水平的时间测量，所以显示精确 F 检验。
  • 如"胆固醇研究结果" 所示的第二个表显示治疗组之间每月胆固醇水平的显著差异。
  • 图中底部的表中显示的时间与治疗之间的交互作用并不显著。
胆固醇研究结果


响应类型命令和效应

响应类型名称旁边的自定义检验弹出式命令（"多元检验"的"多元检验菜单"）会显示“自定义检验”对话框，用于设置效应水平的自定义检验。有关如何使用“自定义检验”对话框以创建自定义检验的说明，请参阅"标准最小二乘：估计透视" 章节中的 "定制检验" 。

每个效应名称旁边的弹出式菜单图标都提供了在此显示的命令，要求输入有关多元拟合的附加信息：

检验详细资料
显示用于构建多元检验统计量的 [image] 矩阵的特征值和特征向量。
重心图
在由检验空间构成的前两个典型变量上标绘重心（多元最小二乘均值）。
保存典型值
保存 canon[1]、canon[2] 等变量，作为当前数据表的列。这些列既有值，又有自己的公式。
对比
执行在对比对话框中指定的治疗水平的统计对比。注：对比命令与单个响应回归的命令相同。有关自定义检验和对比命令的说明和实例，请参阅"标准最小二乘：估计透视"一章。

检验详细资料（典型详细资料）

作为实例，请打开 Sample Data 文件夹中的 Fisher 的 Iris 数据鸢尾花.jmp（Mardia、Kent 和 Bibby 1979）。Iris 数据有三个水平的种类，即 Virginica、Setosa 和 Versicolor。每个样本都有 4 个测量（花瓣长度、花瓣宽度、萼片长度和萼片宽度）。在此将 4 个花瓣和萼片测量指定为响应 (Y)，拟合种类效应的多元模型（恒等）。接着，从 Species 弹出式菜单选择检验详细资料命令。

检验详细资料命令会将效应的典型详细资料附加至其检验报表（如此处的黑外框所示）。此附加信息列出了用于构建多元检验统计量的 [image] 矩阵的特征值和特征向量。

特征值
列出了用于计算多元检验统计量的 [image] 矩阵的特征值。
典型相关性
列出了与每个特征值关联的典型相关性。这是变换响应与效应的典型相关性，为模型中所有其它效应都进行了校正。
特征向量
列出了 [image] 矩阵或 [image] 的特征向量。

重心图

重心图命令在由检验空间构成的前两个典型变量上标绘重心（多元最小二乘均值），如"重心图和重心值" 所示。第一个典型轴是垂直轴，因而如果检验空间只有一维，重心将在垂直轴上。重心点与一个相当于 95% 置信区域的圆一起显示（Mardia、Kent 和 Bibby、1980）。在效应检验下创建重心图时，与检验的效应对应的圆以红色显示。其它圆显示为蓝色。二维图射线显示原始响应变量在检验空间中的方向。

单击重心值展开图标，可将附加信息（如"重心图和重心值" 所示）附加至文本报表。

"重心图和重心值" 中的重心图中，第一个带特征值的典型轴的分隔比第二个轴大。其中对均值进行很好的分隔（判别），第一组比其它两组分隔较大。第一个典型变量似乎是根据花瓣宽度变量来载入花瓣长度变量。变量组之间的关系可用二维图射线和关联特征向量验证。

重心图和重心值

保存典型值（典型相关性）

典型相关性分析不是一个特定命令，但可以在多元拟合平台中通过一连串的命令来实现：

  • 选择拟合模型命令。
  • 指定 Y 和 X，然后从特点下拉菜单中选择多元方差分析，然后单击运行模型。
  • 在“选择响应”对话框中选择恒同作为多元函数。
  • 在整体模型弹出式命令中，选择检验详细资料和保存典型值。详细资料在特征值旁边列出了典型相关性（典型相关性）。保存的变量称为 canon[1]、canon[2] 等。这些列既包含值，又包含自己的公式。
  • 要获得 X 侧的典型变量，请重复相同的步骤，但要交换 X 和 Y 变量。如果已有列 canon[n]，新列则命名为附加的 canon[1]2（或其它数字），以使名称唯一。

例如，以来自 Rawlings (1988) 的 Linnerud 数据进行试验，其名称为锻炼.jmp，位于 Sample Data 文件夹中。它包含生理 X 变量体重、腰围和脉搏以及锻炼 Y 变量引体向上、仰卧起坐和向上跳。下表显示了请求详细资料后“整体模型”表的显示内容。

输出典型变量使用显示为 Y 变量线性组合的特征向量。例如，canon[1] 的公式为

 0.025036802*引体向上 + 0.0063795*仰卧起坐 + -0.0052909*向上跳

此典型分析不生成均值为 0、标准差为 1 的标准化变量，但通过具备这些功能的计算器容易定义新标准化变量。

交换 X 和 Y 变量将生成相应的报表，如图所示。请注意，典型相关性与上表中的相同，但特征向量涉及其它变量。

使用分析 > 多元方法菜单中的多元命令，可查看典型变量的相关性表。“多元”平台显示每个典型变量之间的零相关性，但两组之间的相关性（典型相关性）除外。

相关性的符号是任意的，因为各自特征向量的符号是任意的。


判别分析

判别分析是一种根据响应的已知值预测某一水平的单因子分类的方法。此方法基于一组测量变量与要预测的水平的多元均值的接近程度。使用判别平台（"判别分析"），可更完全地实现判别分析。

在 JMP 中，可将测量变量指定为 Y 效应，将分类变量指定为单个 X 效应。多元拟合平台给出了均值的估计值以及数据的协方差矩阵，其中假设每组的协方差都相同。通过多元方差分析平台名称旁边弹出式菜单中的保存判别值命令，可获得判别信息。此命令使用初始 E 和 H 矩阵，在当前数据表将距离和概率另存为列。

对于 k 水平的分类变量，JMP 会在当前数据表中添加 k 距离列、k 分类概率列、预测分类列以及两个其它计算信息列。

接着，再次使用 Fisher 的 Iris 数据（鸢尾花.jmp，位于 Sample Data 文件夹中），如“Mardia、Kent 和 Bibby”中所示。其中品种水平为 k = 3，每个样本有 4 个测量。保存判别值命令可用于将以下 9 列添加至鸢尾花.jmp 数据表。

Dist[0]
Mahalanobis 距离计算所需的二次型。
Dist[SETOSA]
从 Setosa 重心观测到的 Mahalanobis 距离。
Dist[VERSICOLOR]
从 Versicolor 重心观测到的 Mahalanobis 距离。
Dist[VIRGINICA]
从 Virginica 重心观测到的 Mahalanobis 距离。
Prob[0]
下面使用的 Mahalanobis 距离的负指数的总和。
Prob[SETOSA]
属于 Setosa 类别的后验概率。
Prob[VERSICOLOR]
属于 Versicolor 类别的后验概率。
Prob[VIRGINICA]
属于 Virginica 类别的后验概率。
Pred 种类
通过概率得出的最有可能品种。

您可以将数据表中的新列用于其它 JMP 平台，以便通过报表和图形汇总判别分析。例如，如果使用“以 X 拟合 Y”平台，并将 Pred 种类指定为 X，将种类指定为 Y 变量，则在此显示的“列联表”报表将汇总判别分类。

如果要为每个品种标绘后验概率，请使用“以 X 拟合 Y”平台。

Y 变量为每一组的概率值，X 变量为分类变量。此处的实例将分类的概率标绘为每个品种的 Versicolor。Pred 种类列为标签，标识了三个错误分类。


非线性回归

非线性平台

非线性命令使用最小二乘或自定义损失函数拟合参数为非线性的模型。如果模型变量为非线性，而参数为线性，则无需使用此平台。同样，如果您可以将模型变换为参数中为线性，则可以使用线性平台。

与线性模型相比，非线性模型拟合的难度更大。因为非线性模型需要准备更多的模型设置和参数值的初始假定。迭代方法可用于搜索最小二乘估计，但是这并不保证可以找到解。当然，可能会发散，或者收敛到非最小二乘解的局部解。由于非线性拟合不具有线性模型的某些良好性质，因此需谨慎解释其结果。例如，没有明确定义的 R 平方统计量；估计的标准误差为近似值；以及不能提供杠杆率图。

非线性拟合以模型公式开始，公式可以通过公式编辑器在列中构建，也可以在 JMP 的内建模型库中选择。公式通过要估计的参数指定。输入公式后，选择非线性命令并与其交互迭代控制面板一起完成拟合。

平台本身易于使用。JMP 应用的迭代方式是使用行搜索的 Gauss-Newton 法的变形。此方法使用模型每个参数的导数，但是这些导数由平台自动获取。通过求出二阶导数，也可以使用 Newton-Raphson 法。如果模型仅为一个列的函数，则具有用于求参数的侧置信限以及标绘拟合函数的功能。

还可以定义要使用的特殊损失函数，而不是最小二乘。损失函数可以是模型的函数、其它变量和参数。当定义自定义损失函数后，此平台将最小化损失函数各行的总和。因此，如果要极大化似然，请指定对数似然负值的总和作为损失。

目录

非线性拟合过程

简单指数实例

使用参数创建公式

启动非线性平台

驱动迭代控制面板

使用模型库

迭代控制面板的详细资料

面板按钮

当前参数估计

保存估计值

置信限

非线性拟合弹出式菜单

解结果的详细资料

解表

排除点

侧置信限

拟合函数图

化学动力学实例

自定义损失函数的工作原理

极大似然实例：逻辑斯蒂回归

迭代再加权最小二乘实例

含有二项误差的 Probit 模型：数值导数

Poisson 损失函数

导数说明

有关有效非线性建模的说明

脚本说明

非线性建模模板


非线性拟合过程

使用分析 > 建模子菜单上的非线性命令可以启动交互非线性工具。您可以结合拟合过程，协调 JMP 中的三个重要部分：数据表、公式编辑器和“非线性”平台。

  • 您可以使用公式编辑器定义列及其预测公式。公式通过要估计的参数指定。使用公式编辑器定义参数并指定初始值。
  • 使用 Y 角色中的响应变量启动“非线性”平台并使用预测列中的拟合启动模型列。如果没有指定 Y 列，则预测列公式将用于残差。如果已指定损失列，则可能不需要预测列或 Y 列设置。
  • 通过迭代控制面板与平台交互。


简单指数实例

Sample Data 文件夹的非线性实例中的美国人口.jmp 表阐释了简单非线性指数模型。

其中将人口值建模为年度的非线性函数。要查看非线性公式，请高亮度显示包含该模型的 X - 公式列。然后从列菜单选择 X，预测公式命令。列公式编辑器显示描述指数模型的公式，用于计算 1790 年到 1990 年间美国的人口增长。

使用参数创建公式

将非线性公式与数据拟合时，首先要使用公式编辑器在数据表中创建一个列以建立预测公式，其中包含要估计的参数。此公式包含参数的初始值。

首先在公式编辑器中定义非线性公式的参数。从列选择器列表上方的弹出式菜单中选择参数，如"创建公式参数" 左侧所示。该列表将由列选择器列表更改为参数选择器列表。当选择器列表中出现新建参数时，单击它并填写“新建参数”定义对话框，如"创建公式参数" 所示。使用此对话框命名参数并为其指定一个初始值。单击确定后，新参数的名称会显示在选择器列表中。继续此过程可创建其它参数。人口实例使用两个参数。现在，您可以使用数据表列和参数建立所需的公式。

创建公式参数

参数名称是任意的。在此实例中，选择如下初始值：

  • B0 是 1790 年的人口预测值（应接近 3.93），这是数据表中首次记录的人口数量实际值。因此，3.93 似乎可以作为 B0 的合理初始值。
  • B1 是增长率参数，指定的初始值为 0.022，该值为使用直线（或拟合变换且在人口变换中指定）将人口的自然对数与年度拟合时获取的斜率估计。此初始值似乎是合理的，因为非线性指数模型可以含有相似的最终参数估计。

现在，您可以使用数据表列和参数建立公式。

 B0*Exp(B1*(年度 - 1790))

单击公式编辑器面板中的列名、参数名称、运算符键和函数列表项，输入公式。另外，也可以双击公式编辑器中的拟合公式将其更改为文本编辑模式。这样就可以以文本格式键入公式。

有关建立公式的信息，请参阅《JMP 用户指南》。

启动非线性平台

建立公式后，选择分析 > 建模 > 非线性（或单击“JMP 起始页”窗口的建模选项卡上的非线性拟合）并完成启动对话框，如"非线性启动对话框" 所示。选择人口作为 Y 响应，并将含有拟合公式（X - 公式）的列作为 X，预测公式。

非线性启动对话框

模型公式和损失函数的公式（如果有）将会以文本格式显示在非线性启动对话框底部的公式区域（请参阅"非线性启动对话框"）。

如果拟合公式计算残差而不是预测值，或者存在自定义损失函数，则不需要 Y 变量。在某些含有损失函数的实例中，甚至不需要指定 X，预测公式列（模型）。

注：您也可以选择权重、频数、依据和组列。如果权重列包含一个公式，则对于每次迭代都将重新计算它。这也会导致含有预测值的列每次迭代都更新。如果指定了组变量，则在制图时，JMP 会为组列中的每个值都绘制一条曲线。这里假定该模型只是组列和另一个连续列的函数。

驱动迭代控制面板

完成启动对话框后，请单击确定，将看到迭代控制面板。“控制面板”让您可以定制非线性拟合过程。“控制面板”中显示公式构造中产生的参数初始值。如果需要收敛解的近似准确值，请编辑停止界限区域。如果要编辑参数的当前值，请单击重置来设定这些值，用于下一次拟合。单击执行开始拟合迭代。您可以在“控制面板”中观察到迭代过程。

如果迭代不收敛，请尝试使用其它参数起始值；每次单击重置并重新运行拟合时，都会重新计算误差平方和，因此尝试多个值就很方便。有时，锁定部分参数并调整其余参数进行迭代会有所帮助。如果模型只是一个列的函数，请使用输出图形上的滑动杆直观地修改曲线，以更好的进行拟合。

如果迭代收敛，则会在“控制面板”中显示解报表和附加区域，如"拟合过程完成后的非线性迭代控制面板" 所示。单击迭代控制面板底部的置信限，计算参数估计的侧似然置信区间。这些置信限显示在“解”报表中（请参阅"指数模型人口增长实例结果"）。置信限计算涉及每个参数的每个界限的一组新的迭代，通常情况下迭代无法成功求得此界限。

当存在只有单个因子时，结果包括响应与因子的图形，如"指数模型人口增长实例结果" 所示。参数的解估计列在图的下方，可使用滑动杆改变这些值来修改相应的拟合曲线。

拟合过程完成后的非线性迭代控制面板

单击置信限按钮生成参数的置信区间。

指数模型人口增长实例结果


自定义非线性模型库

使用模型库

单击“非线性”启动对话框上的模型库按钮可调用内置模型库。调用后会出现“非线性模型库”窗口。

“非线性模型库”对话框

该库中大约包含 33 种模型。用户可以选择其中一种模型，然后单击显示图形或制作公式。

显示图形命令会显示一个参数模型的 2 维理论曲线和两个参数模型的 3 维曲面图。含有两个以上解释变量 (X) 的模型没有图形显示。在图形窗口中，请使用滑动杆或直接单击并键入值来更改参数的默认初始值（请参阅"模型库中的图形实例"）。

模型库中的图形实例

图形窗口的重置按钮用于将参数的初始值设置回其默认值。

单击制作公式将打开一个窗口，您可以在该窗口中为模型选择 x 变量。从数据表中选择一列并单击 X（或 X1、X2，具体取决于模型中的变量数）。然后，单击确定在数据表中创建一个新列，该列包含参数的最新初始值。

如果数据表中已含有名为 X1 和 X2 的列，请在“选择列”窗口未启动的情况下新建一个包含公式的列。在数据表中创建公式后，请继续在非线性平台上进行分析，在“非线性”启动对话框中将新建列指定为 X 预测公式。

许多函数的名称为模型 A、模型 B 等，其定义如"非线性建模模板指南" 所示。

自定义非线性模型库

模型库由名为 nonlibLib.jsl 的内建脚本创建，该脚本位于包含 JMP（Windows 和 Linux）或应用程序软件包 (Macintosh) 的文件夹的 Builtin Scripts 子目录下。您可以通过修改此脚本来自定义非线性库脚本。

要添加模型，必须向 Listofmodellist# 列表中添加三行。实际上，这三行本身就是一个列表，由以下三部分组成：

  • 模型名称，一个带引号的字符串
  • 模型公式，一个表达式
  • 模型尺度

例如，假设您想要添加名为“简单指数增长”的模型，其形式为

将以下行添加到 nonlibLib.jsl 脚本

 {//简单指数增长
 "简单指数增长",
 Expr(Parameter({b1=2, k=0.5}, b1*exp(k * :X)),
 lowx = -1; highx = 2; lowy = 0;  highy = 2},

请注意以下事项：

  • 第一行只是一个开括弧（起始列表）和可选注释。第二行是显示在模型库窗口中的字符串。
  • lowx、highx、lowy 和 highy 的值指定理论图的初始窗口。
  • 以上实例都以逗号作为最后一个字符。如果是在 Listofmodellist# 列表中输入的最后一行，则可以省略逗号。
  • 如果模型使用两个以上的参数，请使用带引号的字符串“字符串不可用”替换最后一行（包含图形界限）。

要删除模型，请从 Listofmodellist# 列表中删除相应的三行列表。


迭代控制面板的详细资料

“非线性”平台显示在迭代控制面板中，如"拟合前的迭代控制面板" 所示。初始控制面板具有以下功能：

  • 处理消息区域，用于显示拟合过程的进度。
  • 可编辑参数区域，用于编辑参数起始值。编辑完成后单击重置。
  • 在拟合过程中使用的执行、停止和步骤按钮。
  • 重置按钮，用于重置输入公式的可编辑值、重置迭代值并使用这些新值计算误差平方和。
  • 用于收敛准则和步骤计数的初始值。
  • 含有拟合选项的弹出式菜单，用于指定计算方法和保存置信限。这些弹出式菜单项将在下一节中介绍。
拟合前的迭代控制面板

拟合过程收敛后，控件会出现在控制面板底部，您可以使用它们为置信限和预测值的计算指定 Alpha 水平和收敛准则（"拟合后的控制面板"）。单击置信限时，其结果会显示在“解”报表中，如前面"指数模型人口增长实例结果" 所示。

拟合后的控制面板

下一节中将更详细的介绍迭代控制面板的功能。

面板按钮

执行
启动迭代拟合过程。该过程在后台运行，因此您可以在其运行期间进行其它操作。如果要重新运行此模型，必须首先单击重置按钮。如果您多次单击执行，则状态栏中会显示一则消息，提醒您执行此操作。
停止
停止迭代过程。由于该平台只侦测步骤间的事件，因此可能需要几秒钟才能真正停止。再次单击执行可以重新启动迭代。
步骤
在过程中进行单步迭代。
重置
重置迭代计数和收敛准则，将可编辑值复制到内部公式，然后计算这些新值的误差平方和。可以使用重置执行以下操作：
  • 迭代停止后执行附加步骤。例如，如果为求解更准确的值而设定停止界限，则需要附加步骤。
  • 编辑参数估计以清除之前的拟合信息并使用这些新的起始值开始迭代。
  • 使用当前参数值计算误差平方和。

当前参数估计

控制面板还显示参数估计的当前值和计算得出的误差平方和。这些值最初为公式中指定的初始值。之后，将更改为迭代过程生成的值。迭代开始之前没有误差平方和，在非线性拟合后显示第一个误差平方和。

如果要更改参数值并开始或继续拟合过程，请单击并编辑参数估计的当前值列中的参数。然后依次单击重置和执行。

注：非线性平台可以复制自己的列公式，因此如果打开模型列的公式编辑器，则您在其中所做的更改不会影响激活非线性平台。参数值不会存储回列公式中，除非单击保存估计值。

保存估计值

非线性拟合完成后，保存估计值按钮会出现在“控制面板”上。单击保存估计值后，会将参数估计存储在列公式中，这会导致数据表重新计算该列。如果使用分组变量，将不会进行此操作，因为公式位于来源表中，而不是位于分组变量中。

置信限

拟合后，“解”报表上方的置信限按钮变为可用。它用于计算每个参数估计的置信区间。这些区间为侧似然置信限，而且每个参数的每个界限都包含一组新的迭代，因此如果迭代无法求解，它可能会花费大量时间并导致缺失值。虽然计算不在后台运行，但是可以通过 Escape 键（Mac 中为 command(命令) - period 组合键）取消计算。有关置信限的详情，请参阅"解表"。

非线性拟合弹出式菜单

您可以使用“非线性拟合”标题栏上的弹出式菜单图标定制拟合过程、查看关于结果的附加信息，将置信限另存为当前数据表中的新列。

以下列表描述了各个弹出式菜单项：

参数界限

要设定参数界限，请选择参数界限选项，以展开参数值旁边的新的可编辑字段，然后您可以在其中输入参数的上限和下限。将字段留作缺失值 (.) 表示无界限参数。

如果保存脚本，则界限会以如下方式保存：

 Parameter Bounds(paramName(lower, upper)...)

标绘

如果预测公式恰好为另一个连续变量的函数并将响应指定为 Y 变量，则标绘显示一个有关函数和观测数据的图（请参阅"指数模型人口增长实例结果"）。如果在启动时指定了“组”变量，则将显示每个组的曲线。参数的初始估计显示在图的下方，可以使用滑动杆调整这些值。您可以使用这些滑动杆调整参数并获得预测函数的经验拟合，也可以使用非线性拟合过程生成的参数估计值和起始值。

迭代选项

您可以使用迭代选项指定用于最优化算法的选项。

迭代日志
打开一个附加窗口（名为迭代日志）并记录拟合过程的每个步骤。您可以通过迭代日志查看拟合过程中每个步骤的参数估计以及目标准则在每个步骤中的更改。
只用数值导数
这对模型太复杂而无法解析法求解导数时很有用。它对于在复杂情况下得到收敛也很有用。
二阶导数法
使用迭代方法中的二阶导数和一阶导数来求解。二阶导数法称为 Newton-Raphson，而非称为 Gauss-Newton。只在残差过大或指定了自定义损失函数且模型参数为非线性的情况下，此方法才有用。
注：也可以使用启动对话框上的复选框要求使用二阶导数法。
牛顿
选择 Gauss-Newton（用于常规最小二乘）或 Newton-Raphson（用于含有损失函数的模型）作为最优化方法。
拟牛顿 SR1
选择拟牛顿 SR1 作为最优化方法。
拟牛顿 BFGS

选择拟牛顿 BFGS 作为最优化方法。

接受当前估计
告诉 JMP 生成含有当前估计的解报表（即使估计没有收敛）。
显示导数
显示 JMP 日志中非线性公式的导数。如果当前没有打开 JMP 日志，则可以使用视图菜单或窗口菜单中的记录命令查看。有关导数的技术细节，请参阅"导数说明"。

刻画器

“刻画器”子菜单会弹出三个用于查看预测曲面的工具。有关刻画的详情，请参阅"刻画简介"。

刻画器
弹出 JMP 刻画器。您可以使用刻画器依次查看每个 x 变量的曲面垂直切片并求出因子的最优值。有关刻画器的详情，请参阅"刻画器"。
等高线刻画器
弹出 JMP 等高线刻画器。您可以使用等高线刻画器查看二维等高线和三维网状图。有关等高线刻画器的详情，请参阅"等高线刻画器"。
曲面刻画器
创建三维曲面图。必须存在两个连续因子，该工具才能工作。有关曲面图的详情，请参阅"控制曲面" 一章。
参数刻画器
弹出 JMP 刻画器并刻画作为参数函数的误差平方和或损失。有关刻画器的详情，请参阅"刻画器"。
参数等高线刻画器
弹出 JMP 等高线刻画器并刻画作为参数函数的误差平方和或损失。有关等高线刻画器的详情，请参阅"等高线刻画器"。
参数曲面刻画器
创建一个三维曲面图并刻画作为参数函数的误差平方和或损失。有关曲面图的详情，请参阅"控制曲面" 一章。

SSE 网格

要探索关于参数估计的拟合敏感度，可以在解的估计值附近创建一个网格，计算每个值的误差平方和。解的估计值应含有最小误差平方和。

要创建网格表，请使用 SSE 网格命令打开“为输出表指定网格”对话框，如下所示。在对话框中编辑值以自定义网格。

“为输出表指定网格”显示以下项：

参数
列出拟合模型中的参数（即上图中的 B0 和 B1）。
最小值
显示网格计算中使用的最小参数值。默认情况下，最小值是解的估计值减去近似标准误差的 2.5 倍。
最大值
显示网格计算中使用的最大参数值。默认情况下，最大值是解的估计值加上近似标准误差的 2.5 倍。
点数
给出要为每个参数创建的点数。要计算新网格表中的总点数，请将所有点数值相乘。最初，前两个参数的点数为 11，其余为 3。如果要指定一个新值，请使用奇数值以确保网格表包括解的估计值。将点数设定为 0，则所有参数都只记录网格表中的解的估计值。
单击执行后，JMP 会创建一个包含网格坐标的新无标题表，如下表所示。高亮度显示的 X 标记解的估计值行（如果解在表中）。您可以使用图形菜单中的旋转图命令研究 SSE 或似然曲面。有关旋转图实例，请参阅"旋转 SSE 网格"。

恢复原始参数

“恢复原始参数”命令将重置非线性平台以使用最初指定的参数（即在任何拟合前就已经存在的参数）。

记住解

记住解命令用于为一系列受约束的估计划分阶段，以便在约束上构造检验。仅在完成每个模型的估计后才使用此命令。

例如，假设要使用含有一个受约束参数的模型检验无约束的指数模型。首先，将参数值设定为其受约束的值并选定其锁定框。然后，单击执行获取受约束的结果。单击记住解命令记住此解。现在，可以撤消选定锁定并重复此过程，即依次单击重置、执行和记住解。随后 JMP 会显示每个解的拟合统计量以及比较解的检验。"记住的模型" 显示了使用美国人口.jmp 的实例，其中 B1 参数在约束模型中被约束为 0.1。

记住的模型

定制估计

您可以使用定制估计命令提供仅涉及参数的表达式。JMP 使用当前估计计算表达式，还使用一阶 Taylor 级数近似值计算表达式的标准误差。

定制反预测

如果指定了 y 值，定制反预测命令会计算 x 值，并生成估计模型的 y 值。它也计算标准误差和置信区间。JMP 必须能够求模型的逆以获取逆表达式，仅当模型为在表达式中出现一次的一个变量的函数时，才能进行此操作。此标准误差以使用逆表达式的一阶 Taylor 级数近似值为基础。置信区间使用含有标准误差的 t 分位数。

保存预测置信限
保存个体置信限

保存选项在当前数据表中新建名为均值下限、均值上限、个体值下限和个体值上限的列，这些列中包含使用渐近线性近似值计算的 95% 置信下限和 95% 置信上限。保存预测置信限保存非线性拟合的置信限（即期望的或拟合的响应），涉及估计中的方差，但不涉及误差项自身的方差。保存个体置信限保存个体预测值的置信限值，它将误差项方差添加到涉及估计的预测方差中以形成区间。

保存公式

保存预测公式
创建一个包含预测模型的新列作为其公式，其中所有参数都将替换为其估计。单击“保存估计值”按钮后，生成的值与模型列中的值相同。生成的列将命名为“拟合的标准误差名称”，其中“名称”是指定模型的列的名称。
保存预测值的标准误差
新建一个列，该列包含用于预测值的标准误差的公式，其中所有参数都将替换为其估计。此标准误差说明参数估计中的所有不确定性，但是在预测个体 Y 时不添加此不确定性。生成的列将命名为已拟合的标准误差名称，其中名称是指定模型的列的名称。公式的形式为 Sqrt(VecQuadratic(matrix1,vector1))，其中 matrix1 是与参数估计相关的协方差矩阵，vector1 是模型中每个参数的偏导数的集合。
保存个体的标准误差
新建一个列，该列包含用于个体值的标准误差的公式，其中所有参数都将替换为其估计。此标准误差说明参数估计和模型误差中的不确定性。生成的列将命名为个体标准误差名称，其中名称是指定模型的列的名称。公式的形式为 Sqrt(VecQuadratic(matrix1,vector1)+mse)，其中 matrix1 是与参数估计相关的协方差矩阵，vector1 是模型中每个参数的偏导数的集合，mse 是误差方差估计。
保存残差公式
创建一个包含公式的列，用于计算当前模型的残差。新列将命名为残差名称，其中名称为 Y 列的名称。
保存反预测公式
创建一个包含公式的列，用于预测给定 y 值的 x 值。生成的列将命名为反预测名称，其中名称为 Y 列的名称。使用该公式还将为预测值的标准误差和个体的标准误差创建两个附加列，分别命名为标准误差反预测名称和个体标准误差反预测名称。
其内部实现使用与 JSL 操作符 InvertExpr 相同的程序和限制，即表达式只包含到达逆目标的表达式路径的可逆表达式，该目标只在公式中出现一次，同时它使用有利假定将函数限制在可逆区域内。


解结果的详细资料

在迭代控制面板上单击执行即开始拟合过程。在方法收敛或收敛失败之前，迭代都在后台运行。拟合过程中，“控制面板”上的过程消息将监督迭代过程。迭代过程完成后，这些消息将显示迭代是否符合收敛准则。

如果符合收敛准则，会将相关报表附加到迭代控制面板，其排列方式如下。其中始终会显示解表和估计值的相关性表。仅当预测公式为另一个变量的函数时，拟合函数图才可用（请参阅"指数模型人口增长实例结果"）。

解表

迭代完成后，结果显示在“解”表中，如下所示。

误差平方和
显示残差误差平方和。误差平方和是要最小化的目标。如果已指定定制损失函数，则该值为损失函数的总和。
分母自由度
表示误差自由度，它等于使用的观测值个数减去拟合的参数个数。
均方误差
显示均方误差。它是残差误差的方差估计，由误差平方和除以分母自由度得出。
RMSE
估计残差误差的标准差，即上述均方误差的平方根。
参数
列出在拟合公式中给出参数的名称。
估计
列出生成的参数估计。请记住，使用非线性回归时，此估计可能会出现问题（即使一切看起来都很正常）。
近似标准误差
列出近似标准误差，该值的计算方法与线性回归类似。该值通过求 RMSE 和导数叉积逆矩阵对角元的平方根的乘积得出。
CL 下限和 CL 上限
是参数的 100 (1-α) % 置信下限和上限。它们显示为缺失，除非单击“控制面板”上的置信限。
置信上限和置信下限以对另一些参数最小化后的每个参数值的搜索为基础，以生成比解的最小误差平方和更大的误差平方和。此差异的目标以 F 分布为基础。有时，这些区间称为似然置信区间或侧似然置信区间（Bates 和 Watts 1988；Ratkowsky 1990）。

排除点

有时，由于存在用于结果的交叉验证的组，因此会将数据备用。现在，“非线性”平台可计算已排除数据的拟合统计量。您可以将此功能和记住结果一起使用，以更改排除项并获得反映不同排除项的新报表。

例如，下列报表使用美国人口.jmp。其中排除了 10% 的数据点，然后运行非线性拟合。其中将此解记为“首次排除”，然后再排除另外 10% 的数据点，将此解记为“第二次排除”。

排除的和记住的模型

侧置信限

所有侧置信限都以目标 SSE 开始，该目标 SSE 是误差平方和（或损失函数和），F 检验考虑其在给定的 a 水平上是否与解 SSE 显著不同。如果将损失函数指定为负对数似然，则使用卡方分位数代替 F 分位数。对于每个参数的置信上限，向上移动参数值，直到误差平方和达到目标 SSE。但是在向上移动参数值的过程中，将根据刻画参数的更改，将其它所有参数均调整为最小二乘估计。从理论上讲，这是一组复合的嵌套迭代，但是可以在内部使用由 Johnston 和 DeLong 开发的一组迭代完成此操作。

"置信区域图" 中的图显示目标 SSE 或负似然的等高线，阴影区域内为最小二乘（或最小损失）解。

  • 渐近标准误差生成置信区间，该区间近似椭圆体区域并获得水平切线和垂直切线上的参数值极值。
  • 侧置信限在真实区域的极值处（而不是近似椭圆体处）求参数值。
置信区域图

与根据近似标准误差计算的置信区间相比似然置信区间更可信。如果无法求得特定界限，则 JMP 开始计算下一个界限。如果难以收敛，请尝试以下操作：

  • 使用较大 Alpha 值（区间会较短）可能更容易执行操作。
  • 使用二阶导数选项。
  • 放宽置信限准则。

拟合函数图

如果预测公式恰好为另一个变量的函数，则将响应分别指定为 Y 变量，然后标绘展开按钮会显示一个有关函数和观测数据的图，如下所示。

可以使用图形下方、估计右侧的滑动杆调整参数值并观测曲线效应。图形会随参数值的变化而变化。


化学动力学实例

根据药理学，可用液化有机酶作用物的浓度与酶作用物摄入率间的关系通常可通过 Michaelis-Menten 方程式建立模型，其形式为

其中 Y 表示摄入速率，x 表示浓度。参数 V max 和 K 分别估计最大速率和传输常数。化学动力学.jmp 数据表（可在 Sample Data 中的非线性例子文件夹中找到）记录沉淀物样本中葡萄糖类酶作用物的摄入速率。此数据表使用起始参数值（其中 Vmax=0.04，K=0）存储 Michaelis-Menten 模型。

  1. 从分析 > 建模菜单中选择非线性，将模型 (x) 指定为 X 预测公式并将速度 (y) 指定为 Y 响应。单击确定；显示“控制面板”后，在非线性标题栏的弹出式菜单中使用标绘选项查看当前起始值的模型。
  2. 然后，使用 k 滑动杆调整下限和上限值，使之介于 -2 和 2 之间。使用滑动杆稍微更改 K 值，从而可以更好的开始拟合。
  3. 单击步骤一次，就会看到参数和标绘是如何改变的。
  4. 单击执行继续迭代步骤，直到收敛为止。

"用于观测非线性拟合过程的“标绘”选项实例" 说明上述拟合过程。

用于观测非线性拟合过程的“标绘”选项实例

“非线性拟合”弹出式菜单中的 SSE 网格选项有助于研究参数估计附近的误差平方和。新表的未旋转的旋转图（原始位置）将 SSE 等高线显示为参数估计网格的函数，并使用高亮度显示的 x 标记解。另外，也可以使用“曲面图”平台查看曲面。旋转该图可查看估计附近的曲面，如"旋转 SSE 网格" 中的两个实例所示。

旋转 SSE 网格


自定义损失函数的工作原理

非线性拟合工具可以最小化或最大化函数，而不只是默认的残差平方和。本节介绍其实现的数学原理。

假设 f(β) 为模型。那么“非线性”平台将尝试最小化损失函数的总和，该函数表示为

每行的损失函数 [image] 都可以是数据表中其它变量的函数。它必须有非零的一阶和二阶导数。默认的 [image] 函数，即残差平方为

要指定含有自定义损失函数的模型，请在数据表中构造一个变量并建立损失函数。启动“非线性”平台后，选择包含损失函数的列，作为损失变量。

非线性最小化公式通过获取 [image] 对应的模型的前两阶导数以及构成梯度和近似 Hessian 来进行工作，如下所示：

如果 [image] 关于参数是线性关系，则最后一个方程式中的第二项为零。如果不为零，则其和仍可能小于第一项，并使用

如果 ρ 为残差平方，则第二项可能很小，因为残差和很小（没有截距项的情况下为零）。对于最小二乘，该项用于将 Gauss-Newton 和 Newton-Raphson 区分开来。在 JMP 中，仅在选定二阶导数法选项时才计算第二项。

损失函数中的参数

您可以使用损失函数中的参数，但是这些参数可能与模型中的参数不同。JMP 使用这些参数的一阶和二阶导数，也就是说 JMP 为这些参数采用完全的 Newton-Raphson 步骤。


极大似然实例：逻辑斯蒂回归

在此实例中，显示了最小化损失函数的几个变型，其中的损失函数为对数似然函数的负值，因此会产生极大似然估计。

Sample Data 中非线性例子文件夹中的带损失的逻辑斯蒂回归.jmp 数据表具有用于使用损失函数拟合逻辑斯蒂回归的实例。"带损失的逻辑斯蒂回归.jmp 数据表和公式" 展示了带损失的逻辑斯蒂回归.jmp 表的一部分。

Y 列是 x 值的相同大小样本的响应比例（1 的比例数）。模型 Y 列含有线性模型公式 b0+b1*X。但是损失列含有非线性公式，显示在模型公式下方。它是每个观测值的负对数似然，即实际获得响应的概率的负对数。
模型公式 [image] 损失公式
带损失的逻辑斯蒂回归.jmp 数据表和公式

要运行模型，请选择分析 > 建模 > 非线性，然后依次将 Y 指定为 Y 响应、模型 Y 指定为 X 预测公式，以及损失指定为损失函数，完成启动对话框。单击确定将会看到迭代控制面板。适合参数 b0 和 b1 的初始值为零（或 10-100，非常接近零）。

单击执行运行模型。结果会显示在“解”表中，负对数似然作为误差平方和。

相同的问题也可以通过不同的发式解决，比如定义一个模型列公式来引进逻辑斯蒂函数，以及一个使用模型列模型2 的损失函数，从而形成分类响应水平的概率。损失2 的负对数似然为事件发生的概率。该值为 P（模型的发生）或 1 - P（模型的发生）。

在这种情况下，最好是使用二阶导数，因为模型为非线性。使用最小二乘，将二阶导数和残差相乘，该值通常会接近于零。对于自定义损失函数，二阶导数发挥的作用将更大。

再次选择非线性，依次将 Y 指定为 Y 响应、模型2 Y 指定为 X 预测公式以及将损失2 指定为损失函数，完成角色分配对话框。

在启动对话框中选中二阶导数复选框，然后单击确定。然后再次运行模型。“解”表显示与前面相同的对数似然值和参数估计，但近似标准误差略有不同。


迭代再加权最小二乘实例

迭代再加权最小二乘 (IRLS) 用于稳健回归（Holland 和 Welsch 1977）并用于为许多模型拟合极大似然（McCullagh 和 Nelder 1983）。“非线性”平台可以将权重列与公式列一起使用，并在其为模型函数的情况下重复重新计算公式。这些方法可自动给离群值指定比较小的权重，因为较大的残差值可能导致极小的权重（视权重函数而定）。例如，Beaton 和 Tukey (1974) 提出最小化函数

，其中
σ 为误差度量，如 [image] ，(Myers, 1989)，
B = 调整常数，通常介于 1 和 3 之间。

IRLS 举例.jmp 样本数据表包含构造用于说明 IRLS 过程的列。

IRLS 举例表列使用以下公式：

  • 模型列（模型），其中包含使用三个参数 b0、b1 和 b2 的模型公式
 pop - b0 + b1*year + b2*year*year
  • B，一个调整常数
  • 权重列（权重），其中公式使用模型、B 和局部变量 t1，误差度量：

Myers (1989) 提出将调整常数限制在 1 和 3 之间。如果在模型收敛遇到困难时，请尝试移动调整常数，使其接近 2。在此实例中，B（调整因子）等于 1.9。Myers 还建议使用误差度量，其计算公式为 [image] 。在此实例中，该公式包括用于将局部变量 t1 定义为 [image] 的 JSL 语句。

注：指定模型的变量必须出现在权重公式中，以便每次迭代都更新加权。如果使用实际公式，则 JMP 将参数视为不同的参数集，而不进行更新。

要完成 IRLS 实例，请执行以下步骤：

  1. （简单最小二乘步骤）选择分析 >建模> 非线性。选择模型作为 X 预测公式列，但不选择指定权重。此最小二乘分析生成的参数估计提供加权模型的起始值。在启动对话框上单击确定，然后在“控制面板”上单击执行。您可以获得如下所示的起始值。
在迭代末尾，在“控制面板”上单击保存估计值，来将 b0、b1 和 b2 参数设定为这些估计，这些值是 IRLS 步骤所需的。
  2. （IRLS 步骤）再次选择非线性。将模型指定为预测列并将权重指定为权重变量。单击确定将会看到“控制面板”，然后单击执行以获取最终参数估计，如"最终 IRLS 解表" 所示。误差平方和从 136.2935（最小二乘分析时）减少到 3.0492（IRLS 分析时）。

IRLS 将较小权重指定给极值，在分析时会拒绝它们。很容易就可将 1940 和 1950 年标识为离群值，因为它们的权重极小。IRLS 可以减少使用过度影响数据点的影响，因此可以更好地为其它数据建立模型。"最终数据表" 显示了最终数据表的一部分。

最终 IRLS 解表
最终数据表


含有二项误差的 Probit 模型：数值导数

Sample Data 文件夹中的铸块2.jmp 文件记录了在经过多次不同加热和浸透处理检验后依然可用的铸块数量。

响应变量不可用数量为二项分布，具体取决于检验的铸块数量（总量）以及加热和浸透的次数。要获得含有二项误差的 Probit 模型生成参数的极大似然估计，请使用

  • 数值导数
  • 作为损失函数的负对数似然
  • Newton-Raphson 法

就绪的铸块的平均数为检验的数量和使用就绪的铸块（指定加热和浸透的总时间）的概率的乘积。使用 Probit 模型，模型变量 P 的拟合方程式为

 Normal Distribution[b0*heat+b1*Heat+b2*Soak]

Normal Distribution 函数的自变量是试验的线性模型。由于使用了 Normal Distribution 函数，因此“非线性”平台指定了数值导数。有关数值导数的详情，请参阅"导数说明"。

要指定二项误差，损失函数 Loss 的公式为

 -[Nready*Log[p] + [Ntotal - Nready]*Log[1 - p]]

要完成非线性启动对话框，请将 P 指定为 X，预测公式并将 Loss 指定为损失。在启动对话框上单击二阶导数。单击确定。

参数默认的起始值零（接近零）应生成如"使用二阶导数法求出的铸块 2 数据的解" 所示的解。JMP 使用 Newton-Raphson 或二阶导数法来求解。

使用二阶导数法求出的铸块 2 数据的解


Poisson 损失函数

Poisson 分布通常用作拟合频数的模型。

，n = 0, 1, 2, ...

其中，μ 可以为单个参数或含有许多参数的线性模型。许多文章都有介绍如何变换模型以及如何使用迭代再加权最小二乘进行拟合（Nelder 和 Wedderburn 1972）。但是，JMP 使直接拟合模型变得更为简单。例如，McCullagh 和 Nelder (1989) 展示了如何分析已报告的波浪损坏运输船事件的次数。数据在货船损伤.jmp 样本数据中，包括名为模型和 Poisson 的列。

Poisson 列的公式为 Poisson 分布的损失函数（或负对数似然），它为概率分布函数的对数：

  -(N*model-Exp(model))-Log(Gamma(N+1))
其中 Gamma 是 Γ 函数 Γ(n + 1) = n! 且 e model 表示 μ。

model 的公式为

要运行该模型，请选择分析 >建模> 非线性。在启动对话框中选择模型作为 X，预测公式，Poisson 作为损失，然后单击确定。在“控制面板”中，将 B0 的初始值设定为 1，其它参数设为 0，然后单击执行。"Poisson 损失实例的“解”表" 中的表显示运行模型后的结果，然后选择置信限。

Poisson 损失实例的“解”表


导数说明

非线性平台通过最常见的操作获得公式的符号导数。本节介绍导数表达式结果的类型。

如果打开负指数.jmp 非线性样本数据实例，则实际公式如下：

 Parameter({b0=0.5, b1=0.5,}b0*(1-Exp(-b1*X)))

如果使用公式编辑器，则会隐藏公式中的 Parameter 块，但这就是如何将其存储在列中以及如何使其显示在非线性启动对话框中的形式。为 b0 和 b1 两个参数指定初始值并在要拟合的公式中使用。

“非线性”平台制作一个单独的公式副本，编辑它以便从表达式中提取参数并将其引用映射到要估计的位置。非线性平台采用预测公式对参数的分析导数。如果使用显示导数命令，则可以获取日志中列出的公式，如：

预测模型：

 b0 * First(T#1=1-(T#2=Exp(-b1*X)), T#3=-(-1*T#2*X))

模型对参数的导数为：

 {T#1, T#3*b0}

导数工具的工作方式如下：

  • 要避免重复计算子表达式，请将预测模型和赋值链接在一起，以存储导数计算所需的子表达式的值。将赋值命名为 T#1、T#2 等。
  • 当预测模型需要计算附加的子表达式时，则使用 First 函数，该函数返回第一个自变量表达式的值并计算另一个自变量。在此情况下，导数将需要另外赋值。
  • 导数表本身就是表达式列表，一个表达式用于每个要拟合的参数。例如，对于 b0 的模型导数为 T#1；其在预测模型中的线程为 1-(Exp(-b1*X))。对于 b1 的导数为 T#3*b0，即 -(-1*Exp(-b1*X)*X)*b0（如果在以上赋值中替换）。虽然进行了很多最优化，但通常情况下并不是以最佳方式组合各项操作，这从 T#3 表达式不移除双重负号就可以看出。

如果要求计算二阶导数，则可以以列表形式获得 (m(m + 1))/2 个二阶导数表达式列表，其中 m 为参数个数。

如果指定了损失函数，则公式编辑器将对参数求导（如果存在），并获得对于模型的一阶和二阶导数（如果存在）。

如果导数机制不知道如何获得函数的解析导数，则会使用 NumDeriv 函数获得数值导数。在这种情况下，平台将显示 Delta。它用于计算函数相对于变量中的 Delta 变化的变化。您可能需要用不同的 Delta 设置多次试验，以获得良好的数值导数。

提示

有许多方式可用于表示指定模型，并且与其它形式相比，某些方式更适合于指定模型。Ratkowsky (1990) 在其文章中介绍了另一种形式。

如果具有在公式中重复出现的重复子表达式，则最好将赋值指定为临时变量并随后在公式中引用它。例如，上述模型公式之一如下所示：

 If(Y==0, Log(1/(1+Exp(model))), Log(1 - 1/(1 + Exp(model))));

通过因子分解出表达式并将其指定为局部变量，可以将此公式简化为：

 temp=1/(1+Exp(model));
 If(Y==0, Log(temp), Log(1-temp));

导数工具可以在赋值和条件之间跟踪导数。


有关有效非线性建模的说明

我们极力鼓励您使用中心多项式。

无论您在何处拥有参数为线性关系的完全多项式项，都可以使用中心多项式。这会改进数值曲线状况以实现最优化。例如，如果表达式为

a 1 + b 1 x + c 1 x 2

则应将其变换为

这两个模型是等效的，与参数变换无关，但是如果模型为非线性，则第二个模型更易于拟合。

此参数变换易于求解。

如果迭代数依然为最大值，则增加迭代的最大数并从红色三角形菜单中选择二阶导数法。

不存在能很好解决所有问题的综合最优化方法。JMP 中可选择的方法有牛顿、拟牛顿 BFGS、拟牛顿 SR1、二阶导数法和只用数值导数，用于扩展可由非线性平台解决的问题范围。

因此，如果 JMP 默认为无法为特殊问题收敛求解，则使用这些设置的各种组合可以增加获得收敛解的机会。

某些模型对参数的起始值很敏感。通常，使用新的起始值会有效。编辑起始值并单击重置以查看效应。

通常，使用图会很有用。使用滑动杆可以直观地修改曲线以更好地进行拟合。使用参数刻画器也有帮助，但是速度可能会很慢（小数据集除外）。


脚本说明

如果使用 JSL 脚本运行“非线性”平台，则可以使用以下命令和非线性平台弹出式菜单列出的命令。

非线性 JSL 命令
 Model(Parameter({name=expr,...},expr)
要拟合的模型。如果没有指定，则可能位于 X 列的公式中（如果存在 X 列）。
 Loss(expr) 或
 Loss(Parameter({name=expr,...},expr)
要使用的损失函数。如果没有指定，则可能位于损失列的公式中（如果存在损失列）。
 Go
与执行按钮类似，它启动迭代，但与执行按钮不同的是，迭代在前台运行，而不是在后台运行。
 Finish
用于代替执行命令。拟合完成后，Finish 会中断脚本执行。
 Reset
与重置按钮的功能一致。
 Set Parameter(name=expression,...)
用于提供新的起始值。表达式也可能是“列”函数，如 Col Maximum。名称为参数名称。
 Lock Parameter(name,...)
用于锁定或撤消锁定。name 为参数名称。
 Save Estimates
与保存估计值按钮的功能一致。
 Confidence Limits
与置信限按钮的功能一致。
 SSE Grid(name(first,last,),...)
用于计算网格的SSE，网格为每个参数指定的范围内的 n 个值。未指定参数留在解值中。

下面的第一个实例使用分组变量，并指定一个表达式以计算出起始值。第二个实例指定模型自身。

 Nonlinear(x(Model),y(pop),By(group),
     Set Parameter(B0=ColMinimum(Pop),B1=.03),
     Go);
 Nonlinear(y(pop),
     Model(
         Parameter({B0=3.9,B1=0.022},
         B0*Exp(B1*(year-1790)))),
     SSEGrid(B0(2,20,10),B1(.01,.05,6)));


非线性建模模板

本节介绍非线性模型实例和每个模型的数据源。这些模型公式位于“模型库”中，在"使用模型库"节中有相关介绍

非线性建模模板指南
数据引用
公式
模型
Meyers (1988), p.310
A
Michaelis- Menten
Draper and Smith (1981), p.522, L
θ1[1 - exp(θ2x)]
B
Draper and Smith (1981), p.476
θ1 + (0.49 - θ1)exp[-θ2(x - 8)]
C
Draper and Smith (1981), p.519, H
D
Draper and Smith (1981), p.519, H
E
Bates and Watts (1988), p.310
θ1 + θ2exp(θ3x)
F
渐近回归
Bates and Watts (1988), p.310
G
逻辑斯蒂
Bates and Watts (1988), p.310
θ1exp[-exp(θ2 - θ3 - x)]
H
Gompertz 增长
Draper and Smith (1981), p.524, N
θ1[1 - θ2exp(θ3x)]
I
Draper and Smith (1981), p.524, N
θ1 - ln[1 + θ2exp(θ3x)]
J
逻辑斯蒂对数
Draper and Smith (1981), p.524, P
K
Draper and Smith (1981), p.524, P
ln[θ1exp(-θ2x) + (1 - θ1)exp(-θ3x)]
L
Bates and Watts (1988), p.271
M
Bates and Watts (1988), p.310
O
Morgan- Mercer- Florin
Bates and Watts (1988), p.310
P
Richards 增长
Bates and Watts (1988), p.274
S


相关性和多元技术

“多元”平台

多元平台专用于研究有多少个变量彼此相关的问题。此平台首先显示标准相关矩阵。“多元”平台弹出式菜单提供更多相关选项及其它技术，以分析多个变量，如

  • 带正态密度椭圆的散点图矩阵
  • 逆相关性、偏相关性和成对相关性
  • 协方差矩阵
  • 非参数的关联测量
  • 简单统计量（如均值和标准差）
  • 显示根据相关性结构行与中心之间相隔距离的离群值分析
  • 主成分工具具有用于旋转成分的几个选项和一个显示旋转因子模式及公因子方差的表

所有图和当前数据表均可链接。您可以高亮度显示散点图矩阵中任何散点图上的点或离群距离图上的点。这些点将在其它所有图中高亮度显示，并可在数据表中被选中。

目录

启动平台和选择选项

相关多元性

逆相关性和偏相关性

散点图矩阵

协方差矩阵

成对相关性

彩图

简单统计量

非参数相关性

离群值分析

主成分

项目可靠性

计算和统计详细资料

Pearson 乘积矩相关系数

非参数的关联性度量

逆相关矩阵

距离测量

Cronbach's Alpha


启动平台和选择选项

选择分析 > 多元方法 > 多元后，标准相关矩阵和散点图矩阵将首先出现在屏幕上。此处显示的平台弹出式菜单列出了用于查看多个变量的附加相关选项及其它技术。以下部分将介绍“多元”平台提供的表和图。

以下多数分析选项中，观测值中的缺失值将导致整个观测值均被删除。成对相关性中存在例外，它将排除任一考虑变量中的缺失行，然后选择简单统计量 > 一元来逐列计算其统计量，而不考虑其它列中的缺失值。

以下许多实例都使用了溶解度.jmp 样本数据表。

相关多元性

相关多元性选项提供了“相关性”表，该表是汇总了每对响应 (Y) 变量之间线性关系强度的相关性系数的矩阵。此相关矩阵仅使用包含非缺失观测值得所有变量。

逆相关性和偏相关性

下图顶部显示的逆相关矩阵（逆相关性表）提供了有用的多元信息。矩阵的对角元素是表示这个变量与其它变量的线性函数接近程度的函数。在逆相关性中，所有其它变量与该变量拟合的对角是 1/(1 - R 平方)。如果多重相关性为零，且对角逆元素为 1。如果多重相关性为 1，则逆元素将变为无穷大，且被报告为缺失。

“偏相关性”表（偏相关性表）显示了调整所有其它变量后每对变量的偏相关性。它是将尺度调整为单位对角的逆相关矩阵的负值。

散点图矩阵

为使您可以看到相关性，每对响应变量的散点图将显示在矩阵排列中，如"散点图矩阵实例" 所示。默认情况下将显示散点图矩阵。如果未显示散点图，请从平台弹出式菜单中选择散点图矩阵。散点图矩阵的单元格的大小相互关联，所以从任何单元格拉伸图形均能重新调整所有散点图单元格的大小。

默认情况下，每个散点图上均强加 95% 二元正态密度椭圆。如果变量呈二元正态分布，则此椭圆将包围约 95% 的点。您可以通过沿对角轴折叠椭圆来查看变量相关性。如果椭圆非常圆且不对角朝向，则变量不相关。

散点图矩阵实例

该散点图矩阵标题栏按钮旁边的弹出式菜单允许您通过设置 α 水平来定制带颜色和密度椭圆的矩阵。

密度椭圆
在由您选择的 α 水平构建的散点图上切换显示密度椭圆。默认情况下是 95% 椭圆。
显示相关性
在每个散点图的右上角显示每个直方图的相关性。
显示直方图
在散点图矩阵的对角线上绘制直方图。这些直方图可被指定为水平或垂直的。另外，您还可以通过使用显示计数命令切换标记每个条形柱的计数。
椭圆 α
允许您从标准 α 水平子菜单中进行选择，或选择其它命令并特别为密度椭圆设定 α 水平。
椭圆颜色
允许您从调色板中进行选择以更改椭圆颜色。

您可以通过将对角（标签）单元格拖放至对角线上的其它位置来重新为散点图矩阵列排序。例如，如果您将标记为 1-octanol 的列单元格沿对角线往下拖动一个单元格，则列将重新排序，如"重新排序散点图矩阵" 所示。

当您查找重新排序列的整个散点图矩阵的模式时，您可以清楚地看到变量根据其相关性聚类成组，如"散点图矩阵实例" 中显示的两组所示。

重新排序散点图矩阵

协方差矩阵

协方差矩阵命令用于显示分析的协方差矩阵。

成对相关性

“成对相关性”表使用所有可用值列出了每对 Y 变量的 Pearson 乘积矩相关系数。计数值会因任一对变量中的任一变量包含缺失值而有所不同。这些值是通过选择“以 X 拟合 Y”平台上的密度椭圆得出的。

“成对相关性”报表还通过条形图显示了显著性概率并比较了相关性，如"成对相关性报表" 所示。

成对相关性报表

彩图

方格图子菜单为您提供了两个选项：相关性彩图或 p 值彩图。第一个选项可用于制作如"方格图" 所示的方格图，显示从红色 (+1) 到蓝色 (-1) 尺度上的变量间的相关性。p 值彩图显示了从 p = 0（红色）到 p = 1（蓝色）尺度范围内的相关显著性。

方格图

简单统计量

“简单统计量”子菜单允许您显示每列的简单统计量（均值、标准差等）。这些统计量可通过两种符号计算，具体采用哪一种将取决于数据表中是否有缺失值。

一元简单统计量
无论其它列中的值如何，每列均需计算。这些值与使用“分布”平台生成的值相匹配。
多元简单统计量
计算分析中，不包含那些任一列中含有缺失值的行。它们是“多元”平台用以计算相关性的统计量。

非参数相关性

从平台弹出式菜单中选择非参数相关性后将显示“非参数的关联度量”表。“非参数”子菜单提供了以下三种非参数度量：

Spearman Rho
在数据值的秩上而非值本身计算的相关性系数。
Kendall Tau
基于协调和不协调的成对观测值个数。如果观测值的 X 值和 Y 值都较大，则该对协调。如果观测值的 X 值较大，而 Y 值较小，则该对不协调。联结对（成对观测值具有相等的 X 值和相等的 Y 值）具有相关性。
Hoeffding D
是 -0.5 到 1 范围内的统计尺度，其中较大的正值表示相依性。此统计量近似于 2 x 2 分类表的卡方统计量观测值的加权和，并可检测违背独立性的更多常项。

“非参数的关联度量”报表还显示了所有度量的显著性概率，并将其与条形图（类似于"成对相关性报表" 中的条形图）进行比较。

有关计算信息，请参阅"计算和统计详细资料"。

离群值分析

离群值分析子菜单可切换显示以下三个图：

  • Mahalanobis 距离
  • Jackknife 距离
  • T 平方统计量

所有这些度量距离都与相关性结构有关，如此处显示的正态椭圆等高线。点 A 表示离群值，因为它违背了相关性结构，而不是因为它是任何坐标方向上的离群值。

"Mahalanobis 离群距离图" 显示了每点与多元均值（重心）之间的 Mahalanobis 距离。标准的 Mahalanobis 距离取决于数据的均值、标准差和相关性的估计。每个观测数值的距离均被标绘。极端的多元离群值可以通过高亮度显示有最大距离值的点来标识。有关更多信息，请参阅"计算和统计详细资料"。

Mahalanobis 离群距离图

JMP 还可通过折叠技术计算间隔距离。您可以通过均值、标准差和相关矩阵的估计（不包括观测值本身）计算每个观测值的距离。折叠距离在存在离群值时非常有用。在此情况下，Mahalanobis 距离会失真，将掩盖离群值，或者使其它点看上去比其本身更远离中心。

折叠距离图

第三个选项是 T 平方统计量。它是 Mahalanobis 距离的平方，极适用于多元控制图。此图包含了计算的 T 平方统计量的值及其控制上限。超出此上限的值可能成为离群值。

T 平方统计量图

保存距离和值

您可以使用三种查看离群值方式中的任意一种将距离保存回数据表。要保存距离，请使用要保存的距离名称旁边的弹出式菜单。例如，下图保存了 T 平方统计量的值。

不存在与距离列一起保存的公式。这意味着，如果您修改数据表，距离将不会重新计算。如果您向数据表添加或删除列或更改其中的值，您应重新选择分析 > 多元方法 > 多元以计算新距离。

保存在数据表中的距离

除保存每行的距离值以外，您还可以创建包含距离值（适用于 Mahalanobis 距离和折叠距离）或包含 T 平方统计量的控制上限的列表。

主成分

主成分是一种采用原始变量线性组合的技术，使得第一个主成分变异最大、第二个主成分拥有第二大变异（要求与第一个正交），依此类推。还可在“旋转图”平台上执行主成分分析。

主成分文本报表（"主成分/因子分析报表"）汇总带有主成分指定 Y 变量的变异。主成分可根据相关矩阵、协方差矩阵或在未调整比例且未中心化的数据的特征值分解中求出。

报表的详细资料显示了主成分如何承担数据中的变异和成分相对于变量的方向。主成分点根据标准化变量的特征向量线性组合导出。

主成分/因子分析报表
特征值
文本报表的第一行按从左至右的顺序（第一个主成分、第二个主成分，依此类推）列出了与每个主成分对应的特征值。特征值表示多元样本中总变异的一部分，在对相关矩阵执行主成分分析时，它们计算变量总数。

“主成分”报表中的附加行提供了以下信息：

百分比
报表的第二行占总特征值的百分比形式列出了每个特征值。在上述实例中，第一个主成分占样本中变异的 79.7503%。
累积百分比
此列显示特征值表示的变异的累积百分比。在上述实例中，前三个主成分占样本中变异的 97.8087%。
特征向量
这些值列是每个主成分的特征向量，顺序为从左至右。使用这些系数来构成原始变量的线性组合将生成主成分变量。

主成分/因子分析标题栏中的弹出式菜单为您提供可查看旋转主成分和保存主成分得分结果的选项。

因子旋转
为您提供了主成分的因子分析样式旋转。选择此命令将显示以下对话框。
使用此对话框可指定：
1. 因子分解方法、主成分（其中对角线为 1）或常用因子分析（其中对角线是 SMC - X i 和其它 p - 1 个变量之间的多重相关性的平方）。
2. 要旋转的因子数。
3. 旋转方法。
旋转可以更好地将因子方向与原始变量对齐，以使因子看起来更加明显。您希望变量的聚类高度相关以定义旋转因子。聚类判读性旋转的成功与选择旋转的因子数密切相关。
初次提取后，因子不会彼此相关。如果通过正交变换旋转因子，则这些旋转的因子也不会相关。如果通过斜角变换旋转因子，这些旋转的因子将相互关联。斜角旋转通常会比正交旋转产生更为有用的模式。但是，相关因子的结果是：解释变量时，没有一个衡量因子重要性的明确标准。
此处显示的“旋转成分”表提供了先验公因子等于 1.0 的旋转因子模式、两个旋转因子和最大变异旋转方法。最大变异方法试图使此矩阵中的元素移向 1 或 0，从而显示变量聚类。请注意，第一个旋转成分载入 cc14-c6c6-hex-chc13 聚类，第二个旋转成分载入 eth-oct 聚类。有关主成分和因子分析的详细介绍，请参阅"旋转图"章。
碎石图

将排序的特征值显示为特征值指数的函数。

旋转主成分
显示任意三个主成分的 3 维旋转图。您还可通过图形 > 旋转图生成此图。
保存主成分，保存旋转成分
保存您在当前数据表中指定为新列的主成分和旋转成分数。

项目可靠性

项目可靠性表示一组仪器测量整体响应的一致性程度。Cronbach's α (Cronbach's 1951) 是一种可靠性测量方法。Cronbach's α 的两个主要应用是工业仪器可靠性和调查表分析。

Cronbach's α 基于某种测量尺度下的项目之间的平均相关性。它相当于计算数据集中所有半分块相关性的平均值。如果项目的方差变化较大，则可要求使用标准化的 α。范围内的项目可以连续，如同在 Likert 尺度或分类中一样。

Cronbach's α 与显著性水平 α 不相关。而且，项目可靠性与生存时间可靠性分析不相关。

例如，请参考 Sample Data 文件夹中的危险度.jmp 数据。此表列示了 30 个达到某种级别的固有危险的项目。三组人员（学生、非学生、专家）根据感知到的危险级别对项目进行了评级。请注意，核能被学生和非学生评定为非常危险 (1)，但专家却评为低 (20)。另一方面，三个判定组将摩托车分别评定为第 5 和第 6。

您可以使用 Cronbach's α 评估各组以感知方式评定项目的一致性。"Cronbach's α 报表" 底部的结果显示了总体 α 为 0.8666，表示三组之间的排序值具有很高的相关性。此外，您将专家从分析中排除后，非学生和学生对危险性的评定几乎相同，其 Cronbach's α 得分分别为 0.7785 和 0.7448。Nunnally (1979) 建议将 Cronbach's α 得分为 0.7 作为经验性可接受的一致性标准。

要查看个别项目的影响，JMP 可将其从计算中排除并显示 Cronbach's α 值的效果。如果排除变量（项目）时 α 增大，则表示此变量不与其它变量密切相关。如果 α 减小，您便可知道此变量与尺度范围内的其它项目密切相关。Cronbach's α 的计算说明将在下一节"计算和统计详细资料"中提供。

请注意在此类实例中，每组中的秩组值相同，因此标准化数据不会产生影响。

Cronbach's α 报表


计算和统计详细资料

Pearson 乘积矩相关系数

Pearson 乘积矩相关系数可用于衡量两个变量间的线性相关强度。对于响应变量 X 和 Y，它表示为 r，并可通过以下公式进行计算

。

如果两个变量之间存在严格的线性关系，则相关性为 1 或 -1，具体取决于变量是正相关还是负相关。如果二者之间没有任何关系，则相关性趋于 0。

非参数的关联性度量

对于 Spearman、Kendall 或 Hoeffding 相关性，请首先计算此数据的秩。然后计算数据值秩。如果存在联结，则可使用平均秩。

Spearman ρ (rho) 系数

您可使用上述计算 Pearson 相关系数的公式来计算数据秩，从而可得出 Spearman ρ 相关性系数。

Kendall τb 系数

Kendall τb 系数基于协调和不协调的对数。如果两个变量组成的两行的变量值均较大，则它们协调。否则它们就不协调或相互联结。

公式

计算出 Kendall τb，其中

,
, 且
,

请注意，如果 [image] ， [image] 等于 1，如果 [image] ，等于 0，如果 [image] ，则等于 -1。

t i (u i) 表示在第 i 个联结 X（分别对应 y）组中联结 X（分别对应 y）的值得个数，n 表示观测值数，Kendall τb 在 -1 到 1 之间。如果指定了权重变量，则可忽略它。

可通过以下方式进行计算：

  • 观测值根据第一个变量值进行排序。
  • 然后根据第二个变量值重新计算观测值的秩。
  • 用第一个变量的交换数来计算 Kendall τb。

Hoeffding D 统计量

Hoeffding D (1948) 的计算公式为

。

Ri 和 Si 表示 x 值与 y 值的秩，Qi（有时称为二元秩）表示 1 加上 x 值和 y 值均小于第 i 组点的点数。对于其 x 值或 y 值联结（但非二者均联结）的点，如果另一值小于第 i 个点的对应值，则 Qi 加上1/2。x 和 y 值的点均联结的点 Qi 加上1/4。

观测值之间不存在联结时，D 统计量的值在 -0.5 到 1 之间，其中 1 表示完全相依性。如果指定了权重变量，则可忽略它。

逆相关矩阵

逆相关矩阵可提供实用的多元信息。逆相关矩阵的对角元素，有时称为方差膨胀因子 (VIF)，是表示变量与其它变量的线性函数接近程度的函数。尤其是，如果相关矩阵表示为 R，逆相关矩阵表示为 R-1，则对角元素表示为 [image] ，则它的计算方式是

,

其中 R i2 是当第 i 个变量根据所有其它变量回归时而产生的多重相关性的平方。因此，较大的 r ii 表示第 i 个变量与很多个其它变量密切相关。

请注意，无截距模型的 R 平方定义将改变。对于无截距模型和隐藏截距模型，JMP 使用未校正平方和（如零模型）中的 R 平方，而不是均值模型中的校正平方和。

距离测量

离群距离图显示了每个点与多元均值（重心）之间的 Mahalanobis 距离。Mahalanobis 距离将数据的相关性结构和单个尺度考虑在内。对于每个数值，此距离都表示为 d i，并可通过以下公式进行计算

Mahalanobis 距离图上绘制参考线的计算公式为 [image] ，其中 nvars 表示变量数，而公式编辑器的 F 可通过以下符号计算：

F Quantile(0.95，nvars，n-nvars-1，中心为 0）

如果变量是其它变量的严格线性组合，则相关矩阵是奇异的，且此变量的行和列均被清零。生成的广义逆矩阵对形成距离仍然有效。

T 平方距离正好等于 Mahalanobis 距离的平方，因此 T i2 = d i2。T 平方的控制上限为

其中

n = 观测值数

p = 变量数（列）

α = 第 α 个分位数

β = Beta 分布

多元距离对于在高维中寻找离群值尤为有用。但是，如果在多元意义中的变量彼此密切相关，则可将点视为多元空间中的离群值，而不要看作任意维子集中的不寻常值。换言之，如果数据相关，当您沿一条或两条轴查看点时，点可能为正常点，但在违反相关性时仍为离群值。

统计警告：在离群点本身可能以掩盖离群值的方式歪曲协方差和均值的估计的意义上说，离群距离不是显著稳健。您可能需要使用间隔距离命令以折叠方法计算距离。您可以通过均值、标准差和相关矩阵估计（不包括观测值本身）计算每个观测值的间隔距离。

Cronbach's α

Cronbach's α 被定义为

其中

k = 尺度范围内的项目数
c = 各项间的平均协方差
v = 各项间的平均方差

如果将项目标准化以包含常数方差，则公式将变成

其中
r = 各项间的平均相关性

整体 α 系数越大，您就越可以确信这些项对于尺度或检验非常可靠。如果存在多个密切相关项，则系数可能接近 1.0。


聚类

聚类平台

聚类是一种将有在多个变量间共用相似值的行分组在一起的方法。它是一种有效的探索方法，帮助您了解数据的聚集结构。JMP 提供三种不同的聚类方法：

  • 层次聚类适用于小表，最多只能有几千行。它按树结构的层次顺序合并行。在 JMP 中，树也称为树状图，是一种动态响应图。可在建立树之后，您可以选择所需的聚类数。
  • K 均值聚类适用于较大的表，这些表多达几十万行。首先，K 均值聚类将对聚类种子点进行一个非常完善的预测。然后，它将开始迭代，交替执行下面两个操作：将点指定给聚类和重新计算聚类中心。您必须先指定聚类数，然后才能开始这一过程。
  • 正态混合聚类适用于假定数据来自于叠加的多元正态分布混合的情况。最大似然用于估计混合比例和均值，同时还会连带地估计标准差和相关性。这种方法尤其适用于估计每个组的总计数。但是，需要为每个点（而不是分类到一个组中）均指定一个分配到每个组中的概率。EM 算法用于获得相应的估计值。

完成聚类过程之后，您可以将聚类结果保存至数据表，或者使用它们来设定行的颜色和标记。

目录

聚类方法简介

聚类启动对话框

层次聚类

排序与色彩图实例

层次聚类选项

聚类的可视化

层次聚类的技术细节

K 均值聚类

查看 K 均值聚类过程

平台选项

自组织图

正态混合

固定聚类中心

估计过程的细节


聚类方法简介

聚类是一种将取值接近的多个行分组在一起的多元分析方法。它可以使用任意多个变量。但是，为了使数值差有意义，这些变量必须是数值类型的。常见的情况是数据没有均匀散布在 n 维空间中，相反，它们聚集成块、局部密集区域、密集点或聚类。这些聚类的识别非常有助于确定值分布的特征。

JMP 将提供两种聚类方法：

  • 层次聚类适用于小表，最多只能有几千行。
  • k 均值和正态混合聚类适用于较大的表，可多达几十万行。

由于层次聚类是一个合并过程，因此它也称为集结聚类。这种方法开始时将每个点（行）都作为独立的聚类。然后，聚类过程将每步计算各个聚类之间的距离并将最近的两个聚类合并在一起。合并过程将一直持续下去，直至所有点均在一个最终聚类中。接下来，用户可以选择适当的聚类数并在该点将聚类树砍掉。JMP 会将合并记录标绘成树，称为树状图，其中单个点作为树叶，由所有点构成的最终聚类作为树干，中间聚类组合作为树枝。由于此过程开始时 n 个点之间共有 n(n + 1)/2 个距离，因此当 n 非常大时，使用这种方法将非常耗用内存和时间。假设有 500 个点，这种方法将需要 1 MB 的内存来计算它们之间的距离，而且要很长时间才能完成。

分层聚类还支持字符。如果该列为保序的，则用于聚类的数据值恰好为排序类别的指数，与连续型数据处理。如果该列为记名的，则当类别一致时，距离为零。否则它们的距离为 2。

JMP 提供五个规则来定义聚类之间的距离：平均、重心、Ward、单一和完全。每个规则均会生成不同的聚类序列。

K 均值聚类是一种迭代模仿方法。首先，用户必须指定聚类数 k。然后，JMP 会执行某个搜索算法来找到数据中的 k 个点（称为种子），这些点彼此并不靠近。每个种子都将作为一个聚类的中心处理。接着，程序将检查所有点（行）并将每个点都指定给离它最近的聚类。对于每个聚类来说，新的聚类中心为聚类中当前点的均值（重心）。此过程将继续交替执行下面两个操作：将点指定给聚类和重新计算聚类中心，直至聚类稳定下来。

正态混合聚类与 k 均值聚类相似，开始时也要使用自定义的聚类数，然后选择距离种子。JMP 将使用 k 均值选择的聚类中心作为种子，或者使用您选择的变量值来设定聚类中心。但是，需要为每个点（而不是分类到一个组中）均指定一个分配到每个组中的概率。

SOM 是指 k 均值变异，其中的聚类中心变成一个网格。

K 均值、正态混合以及 SOM 聚类均是双重迭代过程。在执行特定 EM 算法的过程中，聚类过程将以迭代方式执行以下两个步骤：

  • 一个是混合聚类中的期望步骤，它的作用是为每个观测值都指定一个属于每个聚类的概率。
  • 对于每个聚类，JMP 将使用每个观测值及其成员概率（作为权重）构成新中心。这就是极大化步骤。

此过程将交替执行期望步骤和极大化步骤，直至聚类稳定下来。

注：对于 k 均值聚类来说，您可以选择一个变量并且使用它的值来构成聚类的预置固定中心，而不必使用默认的聚类随机种子。


聚类启动对话框

当您从分析 > 多元方法子菜单中选择聚类之后，或者单击“JMP 起始页”的多元选项卡上的任意一个聚类按钮之后，“聚类启动”对话框（如"聚类启动对话框" 所示）将出现在屏幕上。通过从列选择器列表中选择相应变量并单击 Y，列，您可以根据需要指定任意多个 Y 变量。然后，您可以从“聚类启动”对话框的弹出式菜单中选择层次或 K 均值聚类方法。

分层聚类按如下方式支持字符列。K 均值聚类只支持数值列。

  • 如果该列为保序的，则用于聚类的数据值恰好为排序类别的指数，与连续型数据处理。
  • 如果该列为记名的，则类别一致时，其距离为零，否则标准化距离为 2。

数值保序列与数值连续列的处理方式相同。

默认情况下，JMP 会按列均值和标准差对数据执行标准化。如果您不想要根据标准化的值来计算聚类距离，请撤消选定标准化数据复选框。

在“层次聚类”启动对话框中，您可以选择指定排序列。在排序列中，聚类按其均值排序。

要使用此功能，一种方法是完成主成分分析（使用多元），并且保存第一个主成分以用作排序列。然后，JMP 将按这些值对聚类排序。

“聚类”平台提供了以下两种方法：

层次结构
如果选择此方法，您还必须选择以下五个聚类距离选项中的任意一个：平均连接法、重心法、Ward 最小方差法、单一连接法和完全连接法。这些聚类方法计算两个聚类之间的距离的方式不尽相同。"层次聚类的技术细节"中将会详细讨论这些聚类方法。在您单击确定之后，层次聚类也就运行完毕。
K 均值
如果选择 K 均值，您必须指定要达到的聚类数，或者选择一个变量并且使用它的值来构成预置聚类中心。当聚类控制面板出现后，其它选项就会变成可用。在您单击启动对话框上的确定按钮之后，聚类过程将开始挑选种子，但是它会一直运行，直到您单击聚类控制面板中的按钮时才会停止。有关详细说明，请参阅后面的"K 均值聚类"部分。
聚类启动对话框


层次聚类

层次选项可以将具有以下特点的行聚成一类，这些行将 JMP 表中的点（行）分为彼此的值（相对于其它聚类的值来说）非常接近的聚类。层次聚类过程开始时每个点都是独立的聚类。接下来，它会将两个最接近的聚类合并成一个聚类。此过程会一直执行下去，直至只有一个包含所有点的聚类。这种聚类方法比较适用于较小的数据集（几百个观测值）。

要查看层次聚类的简单实例，请选择 Sample Data 文件夹中的出生死亡率子集.jmp 表。其中的数据是 1976 年每 100,000 个人的自然出生率与死亡率。

选择聚类命令后，将出现“聚类启动”对话框（如前面的"聚类启动对话框" 所示）。本实例中使用出生和死亡列作为层次聚类的默认方法 Ward 最小方差法中的聚类变量。

在聚类问题中，指定标签变量将非常有用，以便您可以确定将哪些观测值聚在一起。本实例中使用国家作为标签变量。

在您单击确定之后，聚类过程将开始执行。当聚类过程完成后，“层次聚类”平台报表将包含以下内容：“聚类历史记录”表、树状图以及聚类之间的距离图。如果您已经为变量指定标签角色，则其值将会标识树状图上的每个观测值。

打开“聚类历史记录”表，查看"出生死亡率子集数据的聚类历史记录表" 中所示的结果。最初的聚类数是 33（数据表中的行数减去 1）。您会看到两个最近的点 Philippines 和 Thailand 已经结合在一起，因而现有的聚类数减少为 32。它们显示为“聚类历史记录”表中的第一个领先者和结合者。接下来两个最近的点是 Bangladesh 和 Saudi Arabia，然后是 Poland 和 USSR。在将第六行的 Philippines 与 Brazil 结合起来之后，由于之前已将 Thailand 与 Philippines 结合起来，因此形成第一个包含三个点的聚类。最后一个要与其它点结合的点是 Afghanistan，从而将该结合的聚类数从 4 减少为 3。最后是将由 Afghanistan 代表的包含 7 个点的聚类与其余点结合起来，由 Argentina 代表。每个结合中聚类的顺序并不重要，重要的是数据的排序方式。

出生死亡率子集数据的聚类历史记录表

在树状图的帮助下，可以非常直观地显示聚类序列，如"“出生死亡率子集”表的聚类树状图" 所示。树状图是一个可列出每个观测值，并显示它所在的聚类以及它何时进入该聚类的树。

您可以通过拖动树状图顶部或底部的小菱形图柄来标识给定的聚类数。如果单击任意一个聚类茎，则该聚类的所有成员均会高亮度显示在树状图和数据表中。

树状图下面的碎石图中的点代表每个聚类连接。纵坐标是每个步骤中两个聚类之间的连接距离。通常会出现一个自然的间断，在那里距离突然跳跃。这些间断表明通过自然的断点可以确定聚类数。

“出生死亡率子集”表的聚类树状图


排序与色彩图实例

通过聚类对话框中的排序选项可以按特定列对数据进行排序。如果将第一个主成分用作要按其排序的列，则 JMP 将同时按使用的所有变量中从普遍较小的值至普遍较大的值的顺序对数据进行排序。

通过色彩图选项可以在渐变色标上标绘出每个变量的数据值，具体取决于选择的颜色主题。如果首先对所有变量中的数据排序，则 JMP 会在树状图上生成色彩图，所有变量的色彩图均已按降序排序。

下面的实例使用的是溶解度.JMP 数据，其中包括两次运行。对于第一次运行：

  • 选择分析 > 多元方法 > 聚类，并保留默认的层次选项。
  • 选择全部六个连续变量作为变量 Y。
  • 单击确定。
  • 从平台弹出式菜单中选择色彩图 > 由绿到黑到红。

产生的部分树状图如"运行 1 的树状图" 所示。

运行 1 的树状图

接下来，对相关性运行主成分分析并将第一个主成分保存到数据表中。

  • 选择多元方法 > 多元。
  • 选择全部六个连续变量作为变量 Y。
  • 单击确定。
  • 从平台菜单中选择主成分 > 相关性。
  • 选择保存主成分。
  • 在出现的对话框中，选择其中一项以保存一个主成分。

现在显示树状图。

  • 选择多元方法 > 聚类。
  • 选择全部六个连续变量作为变量 Y 。
  • 选择主成分 1 作为排序变量。
  • 单击确定。
  • 选择色彩图 > 由绿到黑到红。

结果如"运行 2 的树状图" 所示。在第二次运行中，您会看到色彩的排序情况略好一些。只有很少几个亮红色块出现在顶端。请注意，包含 Hydroquinone 和 Trichloroacetic Acid 的聚类已向顶部移动并且呈绿色，而包含 Hexanol 和 Dimethylphenol 的聚类已向底部移动并且趋向于红色。

对于有更多变量同时排序更随机的大数据集来说，这种差异会更明显。

运行 2 的树状图

层次聚类选项

层次聚类的弹出式菜单如下所示。

聚类着色与标记聚类
自动为树状图中通过滑动菱形的位置来标识的聚类指定颜色和标记。
保存聚类
将每行的聚类数保存在新的数据表列中（聚类数通过树状图中的滑动杆标识）。
保存显示顺序
在数据表中创建一个新列，列出聚类表中每个观测值的顺序。
保存聚类层次结构
保存利用脚本创建自定义树状图时所需的信息。对于每次聚类，它均会输出三行：结合者、领先者和结果；而结果中又包含聚类中心、大小以及其它信息。
聚类数
提示您输入聚类数并将树状图的滑动杆定位在该数值处。
彩图
此选项可用于添加色彩图，其中会显示在其值范围内的所有数据的彩色值。它的子菜单中包含几个颜色主题选项。此功能又称为热量图。
几何 X 尺度
此选项尤其适用于存在许多聚类并且您想要靠近树状图顶部的聚类比底部的聚类更明显的情况。现在，如果行数多于 256 行，默认情况下就会使用此选项。
距离图
显示或隐藏树状图底部的碎石图。
双向聚类
按列添加聚类。JMP 会自动根据列树状图添加色彩图。

如果具有大量的聚类并且框架已经被挤到下面，聚类会根据需要将聚类标签改成较小的字体。

具有几何 X 尺度和色彩图的树状图

聚类的可视化

在出生死亡率子集表中，您可以使用“以 X 拟合 Y”来查看出生与死亡的散点图，它可以使您直观地查看可能的聚类。您可以使用颜色、标记以及聚类数来标识散点图中的聚类。例如，下表显示的是您将三个聚类（由"“出生死亡率子集”表的聚类树状图" 中的树状图标识）保存到出生死亡率子集表之后的结果。

现在，请使用分析 > 以 X 拟合 Y 来标绘出生与死亡图，并且注意这些聚类内点的排列方式。"显示三个聚类的散点图" 的左图显示了使用颜色聚类选项指定的标记来标识的聚类。国家是标签列，JMP 已标记选定的国家。在右侧的散点图中，新的聚类列已指定为标签列，并已标记所有点。

显示三个聚类的散点图

要获得"显示八个聚类的散点图" 中的两个散点图，请执行以下操作：

  1. 单击树状图中的滑动菱形并将其拖到表示八个聚类的位置上。
  2. 使用保存聚类创建一个新的数据表列。
  3. 将新列聚类指定为标签角色。
  4. 使用以 X 拟合 Y 标绘出生与死亡图，并标记所有点（行），同时还要调整图形大小。
  5. 使用聚类列作为分组变量来拟合 95% 椭圆。
显示八个聚类的散点图

层次聚类的技术细节

在下面的层次聚类方法介绍中，我们将会介绍多种距离公式，其中小写符号一般用于表示观测值，而大写符号则用于表示聚类。

n 是指观测值个数
v 是指变量个数
x i 是指第 i 个观测值
C K 是指第 K 个聚类，{1, 2,..., n} 的子集
N K 是指 C K 中的观测值个数
是指样本均值向量
是指聚类 C K 的均值向量
是指 x 元素的平方和的平方根（向量 x 的欧几里德长度）
d(x i, x j) 等于
平均连接法
在平均连接法中，两个聚类之间的距离等于成对观测值（或每个聚类中的一个观测值）之间的平均距离。平均连接法一般倾向于结合方差较小的聚类，而且略微偏重于生成方差相同的聚类 (Sokal and Michener 1958)。
平均连接聚类法的距离公式如下：
重心法
在重心法中，两个聚类之间的距离等于它们均值之间的欧几里德距离的平方。从离群值的角度来讲，重心法比其它大多数层次聚类法要稳健得多。但是，从其它方面来讲，一般不如使用 Ward 最小方差法或平均连接法 (Milligan 1980)。
重心聚类法的距离公式如下：
Ward 最小方差法
在 Ward 最小方差法中，两个聚类之间的距离等于在所有变量基础上累积起来的两个聚类之间的方差分析平方和。每次生成新聚类时，其准则是极小化所有可通过合并两个聚类（上一次生成的聚类）得到的部分聚类内平方和。这些平方和更容易解释何时将它们除以总平方和才能提供方差比例（平方半偏相关）。
Ward 最小方差法会以最大化层次结构中每个水平的似然，将两个聚类结合起来，前提是多元正态混合、球形协方差矩阵和抽样概率相等假设。
Ward 最小方差法一般倾向于结合观测值个数较小的聚类，而且比较偏重于生成观测值个数大致相同的聚类。它对离群值也非常敏感 (Milligan 1980)。
Ward 最小方差法的距离公式如下：
单一连接法
在单一连接法中，两个聚类之间的距离等于一个聚类中的观测值与另一个聚类中的观测值之间距离的最小值。单一连接法有很多良好的理论性质（Jardine 和 Sibson 1976；Fisher 和 Van Ness 1971；Hartigan 1981），但在 Monte Carlo 研究中的进展不大 (Milligan 1980)。由于对聚类的形状没有任何约束，因此单一连接法可能漏失些紧致型的聚类，但它可以检测到那些拉长的及不规则的聚类。在将主聚类分离之前，单一连接法一般会切掉分布的尾部区域 (Hartigan 1981)。单一连接法最初由 Florek 等人 (1951a, 1951b) 提出，后来由 McQuitty (1957) 和 Sneath (1957) 再一次提出。
单一连接聚类法的距离公式如下：
完全连接法
在完全连接法中，两个聚类之间的距离等于一个聚类中的观测值与另一个聚类中的观测值之间距离的最大值。完全连接法比较偏重于生成直径大致相等的聚类，而且中等离群值会使它严重失真 (Milligan 1980)。
完全连接聚类法的距离公式如下：


K 均值聚类

k 均值聚类法会执行一个迭代交替拟合过程，以便生成指定的聚类数。k 均值法首先会选择 n 个点为聚类种子，作为对聚类均值的初始预测。然后，它会将每个观测值都归并给最近的种子，以便形成一组临时聚类。接下来，它会使用聚类均值代替这些种子并且重新指定点。此过程会一直执行下去，直至聚类不出现任何进一步的变化。当聚类过程完成时，您会看到几个显示聚类简要汇总的表。k 均值法是一种名为 EM 算法的通用方法的特例。其中 E 代表 Expectation（期望，此处指聚类均值），M 代表 Maximization（最大化，此处指将点指定给最近的聚类）。

k 一般适用于比较大的数据表，观测值的量可以在 200 到 100,000 个之间。对于规模较小的数据表，结果可能对数据表中观测值的排列顺序高度敏感。

要查看 k 均值聚类实例，请打开样本数据表血细胞计数.jmp。此表有两个数值变量和 3000 个观测值。

选择聚类命令，然后从“启动”对话框的弹出式菜单中选择 K 均值。添加变量 CD3 和 CD8 作为 Y，列变量（请参阅"聚类启动对话框"）。您可以输入任意聚类数。但是，聚类过程只会为指定聚类数（本实例中为 4）继续执行聚类，如"聚类数为 4 的 k 均值聚类的聚类启动对话框" 所示。如果要查看其它聚类数的结果，请重新运行聚类过程。您只需在聚类控制面板中即可轻松完成这一操作（稍后介绍）。

聚类数为 4 的 k 均值聚类的聚类启动对话框

注：如果您选择中心列，JMP 将使用该列作为聚类标识。变量中心的水平数将用于确定 k 均值过程中的聚类数。然后，JMP 会将聚类均值和标准差固定在变量中心每个水平的观测均值和标准差处。

单击确定之后，将出现“控制面板”。此时，最初种子选择过程已经完成，观测值也已指定给临时聚类，如“控制面板”下面的“聚类汇总”表所示（请参阅"迭代前后的 K 均值聚类平台"）。

迭代聚类控制面板

“控制面板”具有以下功能：

  • 利用下拉列表可以在“K 均值”、“正态混合”以及 SOM 之间切换。
  • 利用执行按钮可以开始聚类过程的迭代，并一直继续下去。
  • 利用步骤按钮可使聚类过程每次只执行一步。
  • 利用聚类数按钮可以更改聚类数。如果单击此按钮，屏幕上会出现一个对话框，提示您输入新数字。之后，JMP 将会查找新的聚类种子。

注：如果要停止迭代，请按住 Windows 中的 Escape 键，或按住 Macintosh 中的 Command 键，并键入周期。

“控制面板”上的复选框具有以下功能：

按标准差标准化数据
用于计算距离，从而对于每个维来讲，JMP 均会使用该差来除以所有行中该变量的样本标准差。它的功能与“聚类启动”对话框中的标准化数据复选框相同。不过，在 k 均值聚类中，用户可以随时打开或关闭标准化功能，以便影响后面的迭代。
聚类时着色
为每个聚类指定不同的颜色，并在将行指定给聚类时为行着色。对于大型问题来讲，这是一个很好的功能（打开图形的情况下），因为您在观察过程进展的同时，既可以得到视觉上的享受，又可以从中得到启发。
使用抽样率移动距离
假设您有一组大小不等的聚类，并且应将点优先指定给较大的聚类（因为根据较大的聚类得出的先验概率也比较大）。此选项是高级功能。无论您是否使用此选项，先验距离（从点与聚类之间的距离中减去此值）均会显示在名称为先验距离的列中。正态混合中会进行此选项的计算，但不会显示出来。
使用聚类内的标准差
如果不使用此选项，所有距离将按每个变量的标准差的整体估计值转换尺度。如果使用此选项，它将会计算按每个聚类的估计标准差进行尺度转换的距离。一般不建议 k 均值聚类使用此选项，但是正态混合估计默认情况下会打开它。

单击“控制面板”中的执行按钮之后，聚类过程即开始。您会在“控制面板”下面的汇总表中看到每次迭代的结果。如果聚类分配没有进一步的变化，此过程将停止。最终结果将显示在"迭代前后的 K 均值聚类平台" 右侧的表中。

迭代前后的 K 均值聚类平台

查看 K 均值聚类过程

k 均值平台本身不会生成任何图形显示。但是，您可以通过观察聚类时使用的任意两个变量构成的散点图来查看聚类过程。本实例中只有两个变量，因此“以 X 拟合 Y”平台所显示的散点图将会提供执行聚类过程之前的完整印象。"K 均值聚类使用的两个变量的散点图" 左侧的 3,000 个点显得非常密集，但是使用这种方法研究数据有助于您决定要指定多少个聚类。

在聚类过程中，您可以看到某些点会高亮度显示并且假设在指定给不同聚类时使用了不同的颜色。聚类过程结束时，本实例中的散点图的外观类似于"K 均值聚类使用的两个变量的散点图" 右侧的图形，其中的聚类呈彩色显示（在黑白打印机上变为灰色阴影）。

K 均值聚类使用的两个变量的散点图

平台选项

您可以通过标题上的弹出式菜单访问这些选项。它们均适用于 k 均值法、正态混合法和 SOM 法。

标记聚类
为每个聚类指定一个唯一的标记。
双向图
显示数据前两个主成分中的点对聚类图。JMP 会在聚类中心周围绘制一些圆圈，它们的面积与该聚类中的点数成比例。主成分空间中的变量方向通过一组由中心点发出的轴射线表示。JMP 最初会在图中心绘制一些射线，但是您可以将它们拖到图形的其它部分，以使它们不遮住点或聚类。要移动射线，请单击并拖动它们的交点。如果您是在执行迭代前选择双向图，则它还会显示每次迭代后聚类的变化情况。
双向图选项
包含两个可用于控制双向图的选项。显示双向图射线使您可以关闭双向图射线。双向图射线位置使您可以定位双向图的射线显示。这是可行的，因为双向图射线仅表示经典空间中原始变量的方向，而且它们位于图形的哪个位置并不重要。
平行坐标图
单独为每个聚类标绘一个图，同时还会标绘一个显示每个聚类的均值的附加图。它会随着迭代中平台的进展而更新。
以选定行作随机种子
在数据表中选择要作为起始聚类中心的行，然后选择此选项。聚类数将更改为您在数据表中选择的行数。
保存聚类
创建一个新列，其中有为每行指定的聚类数。对于正态混合，这是最有可能的聚类。
保存混合概率
为每个聚类创建一个列，同时会将观测值属于该聚类的概率保存在该列中。此项适用于 k 均值和正态混合。
保存混合公式
创建一些显示混合概率的列，但会将混合公式存储在列中并且需要其它列来保存公式的中间结果。如果要计算排除数据或新添加到表中的数据的概率，请使用此功能。
模拟混合物
（对于正态混合）创建一个新数据表，该表将会使用估计的聚类混合概率、均值以及每个聚类的标准差来模拟数据。此选项的主要作用是分析模拟数据旁边的实际数据，看看模型是否能够充分说明数据的分布。
保存密度公式
将密度公式保存在数据表中。


自组织图

自组织图（SOM，读为 "somz"）只能在 K 均值聚类平台中执行。这种方法最初由 Teuvo Kohonen (1989) 发明，后经许多神经网络专家和统计学家的进一步推广。SOM 的本义是一个学习过程，就像最初的神经网络算法一样。但是，我们这里的 SOM 是指 k 均值聚类的简单变型，实施方式也简单得多。在 SOM 的文献中，这称之为使用局部加权线性平滑器的分批算法。

SOM 的目标不仅仅在于构建聚类，而是要在聚类网格的特定布局中构建聚类，以使在 SOM 网格中彼此非常接近的聚类中的点在多元空间中也非常接近。在经典 k 均值聚类中，聚类的结构比较随意；而在 SOM 中，聚类具有网格结构。这种网格结构对于在二维中解释聚类尤其有帮助。

具有 K 均值以及 SOM 选项的双向图

在 JMP 中创建 SOM

使用出生率与死亡率.jmp 样本数据表。选择分析 > 多元方法 > 聚类并按"自组织图选项" 中的方式完成启动对话框。从下拉菜单中选择 K 均值聚类和自组织图。

自组织图选项

要求生成 SOM 时，JMP 需要将聚类数转换成网格。例如，如果指定了 24 个聚类，则 JMP 会将这些聚类转换成 6 x 4 网格（网格最接近正方形）。因此，聚类数不能是质数。如果给定的聚类数是质数，JMP 将无法完成 SOM。在这种情况下，请将聚类数更改为合数。

在指定变量并且单击确定之后，迭代聚类控制面板将出现在屏幕上。

有关此面板中选项的详情，请参阅 的"迭代聚类控制面板"。

实现的技术细节

SOM 在 JMP 中的实施过程如下所示：

  • 第一步是获得一些优质的初始聚类种子，它们可以较好地覆盖多维空间。JMP 将使用主成分来确定数据变异最大的两个方向。
  • 然后，它会在此主成分空间中设计一个网格，其边缘与每个方向的中央的距离为 2.5 个标准差。接着，JMP 会将此网格转换成变量的原始空间，从而形成聚类种子。
  • 聚类分配过程开始，与 k 均值法类似，它也会将每个点都配置给与其最近的聚类。
  • 估计每个聚类的均值（方法与 k 均值类似）。JMP 将使用这些均值来设置一个加权回归，其中每个变量都作为回归中的响应，SOM 网格坐标作为回归量。加权函数将会使用核心功能，此功能可以将较大的权重指定给要估计其中心的聚类，并将较小的权重指定给离 SOM 网格中的聚类比较远的聚类。新聚类均值就是本回归中的预测值。
  • 上述迭代会一直执行，直至过程收敛。


正态混合

正态混合是在 k 均值聚类平台上实现的一种迭代方法，说它是用于对行进行分组的聚类方法，它更像是一种确定聚类组特征的估计方法。正态混合不是将每个行都分组到某个聚类中，而是估计某个行在各个聚类中的概率（McLachlan，G.J. 和 Krishnan，T.1997）。

在聚类比较分散的情况下，分层聚类法和 k 均值聚类法均会效果良好。但是，当聚类重叠时，很难将每个点都只指定给一个聚类。在叠加的区域内，几个聚类中的许多点会共享同一个位置。如果要获得每组中总体的准确估计值，切记要使用正态混合法，而不能使用 k 均值聚类，因为它使用的是成员概率，而不是基于边框的任意聚类分配。

正态混合法中的算法是 BFGS 拟牛顿法，由于估计值在很大程度上取决于初始估计，因此平台会执行多个历程，每个历程均会使用随机选择的点作为初始中心。

如果执行多个历程，估计过程就会变得相当费时，因此在处理大型问题时，要有足够的耐心。您可以使用控件指定历程限和迭代限。

有关使用正态混合的实例，请打开样本数据表鸢尾花.jmp。此数据集最初由 Fisher (1936) 提出，其中包括四组不同的测量值：萼片长度、萼片宽度、花瓣长度和花瓣宽度，它们均是对三种鸢尾花（每种 50 个样本）执行的测量。

正态混合聚类法可以预测每个聚类内期望的响应比例。假设可以使用三个多元正态分布的混合来近似测量列的联合概率分布，其中三个多元正态分布代表与三种鸢尾花对应的三个聚类。这些分布均有每个聚类的单个均值向量以及标准差向量。

结果是获得每组中比例的准确估计值。要对本实例执行正态混合聚类，请从分析 > 多元方法菜单中选择聚类命令，然后依次从“启动”对话框的弹出式菜单中选择 K 均值和正态混合。另外，您也可以单击“JMP 起始页的多元选项卡上的 K 均值聚类按钮。

请注意，必须提前选择聚类数（本实例中为 3 个）。要完成启动对话框，请将萼片长度、萼片宽度、花瓣长度和花瓣宽度指定为 Y 列。

在您单击确定之后，如前所示的“迭代聚类控制面板”将显示在屏幕上，其中会显示每个 Y 列的初始聚类均值和标准差。

单击执行。每次迭代之后，聚类均会得到细化，直至过程收敛。有些问题可能会执行几百次迭代，因此它会提示您是否继续执行迭代。此处的 Iris 数据经过 105 次迭代之后收敛，如"正态混合聚类实例的最终结果" 所示。

请注意，最终结果中将会提供归到每个聚类中的观测值（行）的比例和计数，但是这些计数不会是精确整数，就像它们在 k 均值聚类中一样。这是因为正态混合聚类确定的是可能的聚类成员而不是确定的成员，它允许聚类有重叠。在本实例中，如果每个种类近似于 33.33% 样本，则各组的估计值如下：聚类 1 为 35.78%，聚类 2 为 30.88%，聚类 3 为 33.33%。

下面介绍几种保存聚类信息的方法：

  • 您可以将任意表保存在报表中，方法如下：通过在表中单击（在 Windows 中使用鼠标右键单击，在 Macintosh 中为按住 Control 键并单击），然后选择制成数据表命令。
  • 您可以使用标题栏弹出式菜单中的保存混合概率命令将混合概率保存至原始数据表。此命令将在数据表中为每个聚类创建一个新列，然后将观测值（行）属于该聚类的概率保存在其中。或者，使用保存混合公式命令来得到这些带有公式（用于计算其它数据）的列。
  • 另一个方法是使用“迭代聚类”标题栏弹出式菜单中的保存聚类命令将聚类数保存至数据表。这将在数据表中创建一个新列，并使用最可能的聚类位置来为每个观测值指定聚类数。
正态混合聚类实例的最终结果

固定聚类中心

在您已经知道观测值的分组并且想要计算其它数据的聚类时，可以有两个选择：

  1. 如果您使用的是正态混合，请使用保存混合公式命令、删除所有行并且保存一份结果表的副本。这个空表将用作表模板。然后，将包含数据的数据表合并到表模板中，以便第一个表的公式可用于计算第二个表的值。
  2. 创建一个用于标识已知数据聚类的列，此列中缺失或没有要计算的新数据。然后，启动“聚类”平台并从“聚类启动”对话框的中心列列表中选择此列。

在 Do 和 McLachlan (1984) 进行的案例研究中，使用下面的实例来确定猫头鹰的食物构成（根据几种马来西亚老鼠在食物中的估计比例）。研究人员使用了两个数据集。第一个（分类）数据集有 179 个观测值并且包含 7 个已知品种的头骨长度、牙齿排数、上颚孔和下颚宽度的测量结果。第二个（观测）数据集有 115 个观测值并且包含头骨长度、头骨宽度、下颚宽度和牙齿排数的测量结果，但是没有关于品种的信息。目标是使用分类数据集中的信息将观测数据集中的老鼠分配到相应的品种中。

分类数据和观测数据均已合并（附加）到 Sample Data 文件夹中的猫头鹰食物.jmp 数据表中，同时让品种列包含观测数据集中老鼠的缺失值（"猫头鹰食物数据与品种分布"）。

要在 JMP 中实现此操作，请从分析 > 多元方法菜单中选择聚类，然后依次从“启动”对话框中选择 K 均值和正态混合。使用头骨长度、牙齿排数、上颚孔和下颚长度作为 Y 列，品种作为中心列。单击确定将会看到聚类“控制面板”。

JMP 将会使用分类数据集中的聚类中心作为初始值。在您单击执行后，JMP 会将包含“中心”变量的缺失值的观测值分配到离它们最近的聚类中。这种方法与判别分析法相似。

猫头鹰食物数据与品种分布

"使用中心变量的聚类实例" 显示了对观测行执行聚类后的初步计数和结果，其中使用“品种”作为中心列。

使用中心变量的聚类实例

估计过程的细节

由于估计受到离群值的制约，因此 JMP 会使用比较稳健的方法来估计正态参数的。JMP 将会通过 Huberized 正态分布的混合的最大似然计算估计值，其中 Huberized 正态分布混合是一种改进的正态分布，经改进后，它对离群值抗性比正态分布好一些。

Huberized 高斯分布具有 pdf [image] 。

因此，在界限内，当 k 变为任意大时， [image] 也趋于正态 PDF。而当 [image] 时， [image] 会趋于指数 (Laplace) 分布。

另外要设定正则化参数 k，以便 P(Normal(x) < k) = HuberCoverage，其中 Normal(x) 表示多元正态变量。HuberCoverage 是自定义字段（默认值为 0.90）。


偏最小二乘

PLS 平台

PLS 平台使用偏最小二乘 (PLS) 拟合模型。PLS 会平衡解释响应变异和解释预测值变异这两个目标。由于它适合于 x 变量多于观测值的分析，因此尤其有用。

要提取的因子的数量取决于数据。如果模型以多个提取因子为基础（预测值的连续线性模型，又称为成分或潜在向量），可以以最佳方式处理其中一个目标或两个同时处理：解释响应变异和解释预测值变异。特别地，偏最小二乘法通过寻求可同时解释响应变异和预测值变异的因子，平衡了这两个目标。请记住，提取太多因子可能会引起过拟合（因当前数据过多地定制模型），给将来的预测带来损害。使用 PLS 平台可以选择按交叉验证提取的因子的数量，即将模型与部分数据拟合，将未拟合部分的预测误差降到最低。它还允许通过刻画器交互探索提取因子，极大简化了因子含义的标识。

目录

PLS

启动平台

模型系数和 PRESS 残差

交叉验证

平台选项

统计详细资料

居中和尺度转换

缺失值


PLS

JMP 平台中实现的普通最小二乘回归（如“拟合模型”和“以 X 拟合 Y”）只有一个目标，即将样本响应预测误差降到最低，寻求将尽可能解释每个响应的变异的预测值的线性函数。PLS 平台中实现的技术的另一个目标是考虑预测值的变异，其中假设当预测值高度相关时，准确抽样的预测值空间中的方向应为新观测值提供更好的预测。PLS 平台中实现的技术的工作原理是提取称为因子（又称为成分或潜在向量）的预测值的连续线性组合，从而以最佳方式处理解释响应变异和解释预测值变异的双重目标。特别地，偏最小二乘法通过寻求可同时解释响应变异和预测值变异的因子，平衡了这两个目标。

但是，最重要的是在 OLS 不起作用的场合下 PLS 能够起作用。如果数据的 x 变量比观测值多，OLS 就无法生成估计值，而 PLS 可以。


启动平台

作为实例，请打开波罗的海.jmp 数据表。这些数据已在“Umetrics (1995)”中报告，原始来源为“Lindberg、Persson 和 Wold (1983)”。假设要研究波罗的海的污染，并要使用海水样本的频谱来确定波罗的海海水样本中以下三种化合物的含量：木质素磺酸盐（造纸工业污染）、腐殖酸（天然林产品）和清洁剂（光学漂白剂）。频谱测定校准这种类型的问题中使用偏最小二乘将非常有效。预测值为样本频谱中 (v1-v27) 不同频率的频谱发射强度，响应为样本中各种化学物质的含量。

为了校准模型，使用了成分已知的样本。校准数据由木质素磺酸盐、腐殖酸和清洁剂已知浓度的 16 个样本组成，频谱基于 27 个频率（或相当于波长）。

通过选择分析 > 多元方法 > PLS 启动 PLS 平台。屏幕将显示如"PLS 启动对话框" 所示的启动对话框。

PLS 启动对话框

将 LS、HA 和 DT 指定为 Y，响应，将 v1-v27 指定为 X，因子。单击确定后，将出现初始 PLS 报表。

在报表的顶部，可以看到各 X 值相对于相应的 Y 值的图形，如"值图" 所示。继续分析时，此图形会根据指定的值个数进行更新。

值图

默认情况下，通常 JMP 会将默认维数确定为大于 30 的最小维数 (k)，从而提供斜率比（Y 得分 -X 得分图的斜率/Y 得分 k-X 得分图的斜率）。在 Baltic 实例中，默认情况下，跟踪 5 个特征向量。对于 Baltic 数据，由各个潜在因子解释的变异的百分比显示在“已解释变异的百分比”报表中（"“已解释的百分变异”报表"）。请注意，X 中的大多数变异由三个因子解释，Y 中的大多数变异可由 6 至 7 个因子解释。请注意，在此情况下，“因子”指潜在变量，而不是数据表中的列。

“已解释的百分变异”报表

只有指定了要在模型中使用的因子个数时，PLS 模型才算完整。JMP 在“N 潜在向量”控制面板中推荐了许多因子，如"“N 特征向量”控制面板" 所示。

“N 特征向量”控制面板
最小值
指定模型中可估计的潜在向量的最小个数。
默认值
JMP 推荐的解释数据中的变异所需的向量个数。
最大值
模型中可估计的潜在向量的最大个数。
使用交叉验证
模型中可使用交叉验证估计的潜在向量的个数。
用户指定
使用在维数旁边指定的潜在向量的个数。

您可以使用交叉验证选择因子的个数，其中数据集分为两个组或多个组。您可以将模型与所有组（其中一个组除外）拟合，然后检查模型的能力，预测忽略的组的响应。为每个组重复该操作，然后即可测量该模型指定形式的整体能力。JMP 使用每个因子数量的预测均方根误差显示结果，如"“交叉验证”报表" 所示。

“交叉验证”报表

预测 RMSE 最低的模型具有 7 个因子。但请注意，这与具有 4 个因子的模型几乎完全一样。具有 4 个因子的模型为首选项，因此预测报表基于 4 个模型因子。

在交叉验证报表中，还可以看到预测 Y 和预测 X 的图形，如"预测图形和滑动杆" 所示。请注意，这些值为 X 和 Y 的尺度转换值，不是原始值。这些图形的下面是一个用于输入要预测的值的文本框，及四个用于调整各个潜在向量的值的滑动框。

预测图形和滑动杆

移动滑动杆可动态查看预测中的各个因子的效应。例如，移动本实例中第四个滑动杆时，表明该潜在变量对第二个 Y 变量（腐殖酸）具有较大影响。此因子明显表示影响腐殖酸的数量远远超过木质素磺酸盐或清洁剂。它可能表明某种因素增加了天然（而不是人为）污染的发生。

与此相似，移动第二个滑动杆会影响第 11 个和 21 个频谱值的数量。因此，滑动杆表示的实际数量通过在那些频率中的变异说明了自己比其它变量多得多，其它变量实质上保持不变。

要预测特定行号的值，请在值滑动杆上方的文本框中输入行号。例如，要预测第一行的值，则在框中输入 1。预测值将显示在 X 和 Y 两个因子的图形上（"第 1 行的预测"）。

第 1 行的预测

模型系数和 PRESS 残差

“模型系数”报表和“PRESS 残差”报表最初都是关闭的。模型系数显示在预测图形下，本实例中如"模型系数" 所示。

模型系数

PRESS 残差（"PRESS 残差"）显示在预测图形上方。

PRESS 残差


交叉验证

观测数据拟合的质量不可用于选择要提取的因子的个数；提取因子的个数必须根据模型与建模程序本身中不涉及的观测值之间的拟合效果来选择。

选择提取因子的个数的一种方法是只将模型与可用数据的一部分（训练集）拟合，然后测量提取因子个数不同的模型与数据的其它部分（检验集）的拟合效果。这称为检验集验证。

要在 JMP 中完成此操作，请选择检验集，再将它从分析中排除。接着，拟合一个 PLS 模型，并将预测公式保存至数据表。这将向数据表中添加一列，该列将包含训练集和检验集两者的预测值。


平台选项

PLS 平台有几个选项可用于保存分析产生的预测值和预测公式。报表顶端外框栏的平台下拉菜单中具有所有选项。

显示点
显示或隐藏 Y 值与 X 值散点图上的点。
显示置信线
显示或隐藏 Y 值与 X 值散点图上的置信线。
保存预测公式
保存数据表中每个 Y 变量的预测公式。
保存输出结果
以两种方式保存平台的输出结果。一种是另存为数据表，便于进一步分析。此外，可将脚本添加至数据表，其中包含 X 值、Y 值、X 负载和 Y 负载矩阵。
在执行脚本时，每个量的个数都会显示在日志窗口中。例如，
NRow(X Scores): 16
NRow(X Loadings): 27
NRow(Y Scores): 16
NRow(Y Loadings): 3


统计详细资料

偏最小二乘 (PLS) 的工作原理是一次提取一个因子。令 X = X 0 为预测值的居中尺度转换矩阵，Y = Y 0 为响应值的居中尺度转换矩阵。PLS 方法从预测值的线性组合 t = X 0 w 开始，其中 t 称为值向量，w 是其关联的权重向量。PLS 方法通过 t 回归预测 X 0 和 Y 0：

= tp'，其中 p' = (t't)-1 t'X 0
= tc'，其中 c' = (t't)-1 t'Y 0

向量 p 和 c 分别称为 X 负荷和 Y 负荷。

特定线性组合 t = X 0 w 具有某个响应线性组合 u = Y 0 q 的最大协方差 t 0 u。另一个特征是 X 权重和 Y 权重 w 和 q 与协方差矩阵 X 0'Y 0 的最左边和最右边的奇异向量成比例，或分别与 X 0'Y 0 Y 0'X 0 和 Y 0'X 0 X 0'Y 0 的第一个特征向量成比例。

以上说明了如何提取第一个 PLS 因子。第二个因子的提取方式相同，只需将 X 0 和 Y 0 替换为第一个因子中的 X 残差和 Y 残差

X 1 = X 0 -
Y 1 = Y 0 -

这些残差又称为压缩 X 区组和 Y 区组。提取值向量和压缩数据矩阵的流程可根据需要的提取因子个数重复任意多次。

居中和尺度转换

默认情况下，预测值和响应会居中，并尺度转换为均值为 0 和标准差为 1。预测值和响应居中可确保用于选择连续因子的标准是基于它们可解释预测值、响应或两者中的变动数。如果不居中，选择因子时就会涉及到变量均值和均值变异。尺度转换旨在将所有预测值和响应根据它们在数据中的变异置于同等基础上。例如，Time 和 Temp 为两个预测值，则尺度转换假定 Time 中 std(Time) 的更改大致等同于 Temp 中 std(Temp) 的更改。

缺失值

带缺失自变量的观测值均从分析中排除，并且系统不会为此类观测值计算预测。无缺失自变量但带缺失因变量的观测值也从分析中排除，但是计算预测。


神经网络

神经平台

“神经”平台使用标准的神经网络。神经网络根据灵活的输入变量函数网络来预测一个或多个响应变量。如果不需要知道响应面的函数形式，神经网络是非常好的预测工具。

目录

简介

背景

神经网络实例

控制面板选项

神经网络中的报表和图形

使用交叉验证

随机缩进

K 折叠交叉验证

实例

平台选项


简介

目前有大量有关神经网络的文献。早期的文献指出，S 形函数是一种激活函数，它的工作方式类似于大脑中的神经元。通过增强和减弱迭代方法中的系数，S 形函数可以模拟学习过程。我们一般喜欢将模型看作有用的非线性回归模型，并且 JMP 会使用标准的非线性最小二乘回归法来拟合它。

神经网络的优点在于它可以高效、灵活地模拟不同的响应面。而且，所有表面均可近似到任意精确度（假设有足够多的隐藏节点）。

不过，神经网络也有一些不足之处。

  • 它产生的结果一般无法解释，因为 X 与 Y 之间存在一个中间层，而不像在常规回归中，它们是直接相连的。
  • 神经网络很容易出现过度拟合数据集的情况，这样就无法再很好地预测将来的数据。
  • 从参数角度讲，拟合是不稳定的。因此在许多拟合中，目标函数在参数稳定以前就早已经收敛了。
  • 由于存在一些局部最佳值，因此每次运行它时，您可能会得到不同的答案。而且，收敛的估计值也不是最佳。

另外，由于这些局部最佳值的存在，平台还会从不同的随机起始估计出发多次估计模型。每个起始估计值及其后续的迭代称为历程，默认历程数为 20。这样可以确保简单模型有好的拟合效果。

由于过度拟合的问题，神经网络几乎总是使用部分样本进行拟合，然后交叉验证估计过程中未使用的那些数据的估计值。用于拟合的数据一般称为训练集，备用数据称为验证集。要创建备用集，请选择要备用的行，然后将其行状态设定为“排除”（使用行 > 排除/撤消排除命令）。“行”菜单中具有一些可随机选择此集的功能（行 > 行选择 > 随机选择）。

一种名称为对拟合罚项（常称权衰减）的方法可避免过度拟合，同时提高数值收敛，它会对参数估计值的大小应用罚则。


背景

神经网络就是一组非线性方程，它使用线性回归层和 S 形函数灵活地预测输入变量 (X) 的输出变量 (Y)。JMP 使用的神经网络仅限于只有一个隐藏层，定义如下。

用于将真实变元转换到 [0, 1] 区间的 S 形激活函数就是我们非常熟悉的逻辑斯蒂函数

。

注：此函数以 Squish() 的形式在 JMP 脚本语言中实现。

每个 H j（未观测到的隐藏节点）定义为：

其中

N X 是指 X 变量的个数
S H(x) 代表逻辑斯蒂函数

且

X i 为输入，一般要被变换成 [0, 1] 区间内的值。

输出 [image] 的计算公式如下：

其中

N H 是指隐藏节点的个数。
S Y(x) 默认情况下为恒等函数（可更改）。

的值也要转换成 [0, 1] 区间内的值。

X（输入）和 Y（输出）的值就是 JMP 的数据列。JMP 既不会将隐藏节点存储在数据表中，也不会对其进行指定。

另外，还要估计系数 a、b、c 和 d。


神经网络实例

本实例使用轮胎刻印.jmp 数据表，其中的数据来自于 Derringer 和 Suich (1980) 的多 Y 响应面试验。其中具有 4 个输出响应变量 Y 和 3 个输入因子 X。如果使用回归来拟合其中的数据，需要使用二次响应面模型以及多个平方和叉积的附加项。如果使用神经网络来拟合这些数据，由于非线性行为可以在模型内处理，因此只需要指定 3 个输入变量。

要开始拟合，请选择分析 > 建模 > 神经网络。指定变量角色，如"启动平台" 所示。

启动平台

单击确定即会看到“控制面板”，您可以先更改其中的设置，然后再拟合模型。

神经网络控制面板

控制面板选项

隐藏节点是需要指定的最重要的数值。如果将此值设定得过低，则会拟合不足；而如果过高，则会过度拟合。

对拟合罚项则有助于防止过度拟合模型。优化准则等于残差平方和加上对拟合罚项，然后乘以参数估计值的平方和。当神经网络处于过度拟合的状态时，参数会变得过大，而此准则可以将参数（权重）维持在较小状态。罚则系数一般称为 lambda 或权衰减。如果将它设定为 0，则不但会出现过度拟合的情况，而且数值迭代也会出现大量有问题的收敛。如果您的数据非常多，则对拟合罚项的作用较小。如果您的数据很少，则对拟合罚项会较大幅度的抑制估计值。建议您多尝试几个 0.0001 和 0.01 之间的值。

历程数用于设定历程数。神经网络一般具有多个局部最小值，因此为了它更可能会找到全局最小值，它会根据不同的随机起始值来多次（历程数）拟合模型。建议历程数为 20。如果计算的时间过长，可以指定略小一点的值。如果您不相信已经找到全局最优值，也可以将其指定为更大一点的值。

最大迭代数是指在报告非收敛前，神经网络在每个历程中执行的迭代次数。

收敛准则是指目标函数中的相对变化，迭代必须满足这一准则才能确定它已经收敛。检验值为

|变化| / min(10-8, max(108, obj))

其中，变化是指一步（非步长缩短）迭代的目标函数 (obj) 值中的变化。

在此点上面，您在估计过程中可能想要创建历程、迭代或估计的记录。平台下拉菜单中的设置迭代记录选项菜单具有如下选项。

记录历程显示每个历程中的最佳目标函数值。

记录迭代显示每次迭代的目标函数。

记录估计值显示每次迭代的估计值。

迭代记录选项

轮胎刻印实例使用了 3 个隐藏节点以及对拟合罚项的默认值。它产生的模型具有 28 个参数，与整个二次响应面的 40 个参相数比要少得多。由于只有 20 行，因此它不应保留备用样本。


神经网络中的报表和图形

结果会显示找到的最佳拟合。尽管已经执行 20 个历程，但是这并不保证它就是实际的全局最佳拟合，也可能只是接近最佳值而已。请注意，20 个历程中的 2 个已经收敛为目标值。还有 11 个历程收敛为较差值。而剩下的 7 个历程在达到最大迭代数后终止运行。

初始结果

人们一般不太关注参数估计值本身。JMP 甚至不会计算它们的标准误差。

“参数估计值”表

请注意报表底部“随机种子”的值。这是植入随机数生成器的值，而生成器提供了当前报表中的结果。如果要精确地复制结果，请使用 Random Reset (seed) JSL 命令将此种子指定为迭代的起始值。

下面是显示实际变量对预测值的图（"实际值对预测值图"），以及显示残差对预测值的图（"残差对预测值图"）。

实际值对预测值图
残差对预测值图

人们一般比较关注响应面切片的形状。而刻画器选项可以使用与其它平台中相同的交互形式来显示它们。（有关“刻画器”的完整介绍，请参阅"标准最小二乘：探索预测方程" 章节中的 "刻画器" ）。

"预测刻画器" 显示了两次运行“神经网络”平台后的“预测刻画器”，其中使用了三个不同的隐藏节点数。

  • 第一次拟合显示了其它设置都为默认值时的两个隐藏节点。
  • 第二次拟合显示六个隐藏节点，此种情况下显得有点多，导致过拟合。很明显，曲线过于灵活。
  • 第三次拟合显示六个隐藏节点，但过拟合罚项增加了（0.1，而不是默认的 0.001）。通过增加过拟合罚项，曲线更僵直了。
预测刻画器

“拟合历史记录”控件是在一个会话中编译所有神经网络。此控件上的单选按钮让您可以在此前拟合的模型中切换，从而更改图形和报表以拟合选定模型。例如，"拟合历史记录控件" 显示了"预测刻画器" 中显示的三个模型的“拟合历史记录”。

拟合历史记录控件


使用交叉验证

一般来讲，神经网络模型过于参数化，因此看起来提供（训练）数据最佳拟合的模型对于其它数据则为过拟合。

因此，只由拟合优度类型方法选择的模型对于训练数据通常都是精确预测值，而对于新数据集则为很差的预测值。换句话说，模型不能很好地推广到新数据。

要找到可很好地推广到新数据的模型，请使用交叉验证。这将保留现有数据集的一部分，然后使用它来验证未缩进的培训数据生成的模型。JMP 有三个交叉验证选项，这三个选项都可在启动对话框中获得：无、K 折叠或随机缩进。

交叉验证选项

注：这些方法生成的是随机样本，因此您的数字可能与此处显示的不一样。设定随机种子命令（"迭代记录选项"）可设定随机种子，以提供一致结果（如果需要）。

随机缩进

“随机缩进”是两个方法中较简单的一个。在将任何模型与数据拟合之前，先将数据分为两组：训练组用于拟合模型，而检验（缩进）组用于比较已与训练数据拟合的模型。

缩进型交叉验证最适用于大型数据集，其中有足够的数据用来以合理方式使用 75% 或更少的数据（事实上，66.67% 是 JMP 默认的缩进百分比）拟合复杂模型。

模型只使用培训数据拟合。拟合模型后，JMP 将计算训练数据（在 JMP 报表中表示为 R 平方）和检验数据（在报表中表示为 CV R 平方）的 R 平方。实际上，训练数据的 R 平方 值会随网络中的节点数的增加而单调递增，且随罚项参数的减少而单调递增。但是，检验 R 平方（CV R 平方）最初随节点数的增加而增加，然后就开始减少。一旦达到某个节点数，模型就开始过拟合数据。

实例

"带随机缩进的神经网络实例" 显示了"启动平台" 中的轮胎刻印实例，其中使用了默认的随机缩进 66.667%（及所有其它默认选项）。事实上此数据集对于缩进来说太小了，此处使用只是为了保持实例一致性。

带随机缩进的神经网络实例

请注意新的“拟合历史记录”外框节点，它记录了当前会话中拟合的所有模型的结果。它记录每个模型使用的节点数、罚项参数、训练数据的拟合 R 平方以及检验（缩进）数据的交叉验证 R 平方。右边还有一个用于选择模型的单选按钮。如果使用此单选按钮选择模型，用户就可以使用选定模型进行预测、重新计算模型中原来位于“结果”菜单的所有统计量，以及使用此模型刷新所有刻画器（如果启用了刻画器）。

要查看此效果，请在神经网络控制面板中将隐藏节点数从 3 更改为 5，然后单击执行。这将重新计算模型，并在“拟合历史记录”表中多添加一行。

第二个神经网络模型

与第一个模型相比，第二个模型与数据拟合得较差。如果需要，可对“控制面板”中的其它项目应用不同的设置，运行更多模型。

在这两个模型中，第一个模型更佳。因此，更希望使用所有数据拟合此模型。要完成此操作，请按将模型与完整数据拟合按钮。按此按钮将使 JMP 将当前选定模型与完整的数据集（培训数据 + 检验数据）拟合，并使用新值改写训练参数值。

K 折叠交叉验证

K 折叠交叉验证方法适用于较小的数据集。在此交叉验证类型中，先将数据随机分成指定的组数 (K)，并遵循下列过程：

  1. 将模型与完整的数据集拟合。
  2. 然后使用起始值的整体拟合，对于 i = 1, 2, ..., K，第 i 个组作为缩进集处理，而模型与其它 N-N/K 观测值拟合，且计算 R 平方时将第 i 个组用作缩进
  3. 在迭代所有 K 个起始值后，CV R 平方设定为 K 次迭代中 R 平方值的平均值。

由于模型重新拟合次数，K 折叠交叉验证的计算次数大约是缩进交叉验证的 K 倍。因此，如果模型较复杂（节点很多）且数据集较大（假设超过 1000 个观测值），应使用此方法。但是，对于较小的数据集，与对应的 (1-1/K)*100% 缩进交叉验证拟合统计量相比，CV R 平方变化更少且更可靠。K 折叠交叉验证通常适用于 K 介于 5 和 20 之间的情况。

实例

再次使用"启动平台" 中的轮胎刻印实例，并从启动对话框中选择 K 折叠交叉验证。这将显示如"K 折叠启动对话框" 所示的初始启动对话框。在此可指定 K，即交叉验证组数。

K 折叠启动对话框

单击执行后，将看到标准的“神经网络”控制面板（"神经网络控制面板"），且分析将按上例的方式进行。“拟合历史记录”外框节点的工作方式与“随机缩进”部分说明的一样，只是没有显示将模型与完整数据拟合按钮。


平台选项

在“神经网络”报表的平台弹出式菜单中可以找到以下选项。

因果图选项可生成一个神经网络图，其中会显示如何将每个层连接至它前面的一层。您可以从“控制面板”弹出式菜单中可选择因果图。

神经网络因果图

刻画器显示“预测刻画器”（"预测刻画器"）。有关“刻画器”的细节，请参阅"标准最小二乘：探索预测方程" 章节中的 "刻画器" 部分。

等高线刻画器激活“等高线刻画器”。有关“等高线刻画器”的细节，请参阅"标准最小二乘：探索预测方程" 章节中的 "等高线刻画器" 部分。

曲面刻画器激活“曲面刻画器”。有关“曲面刻画器”的细节，请参阅"控制曲面"。

保存预测值在数据表中为每个响应变量创建一个用于保存预测值的新列。

保存公式在数据表中为每个响应变量创建一个新列。此列中保存的是每个响应的预测公式，因此平台会计算每行的预测值。如果要将行也添加到数据表中，此选项也很有用，因为这样平台就可以自动计算预测值。如果不需要公式，请使用保存预测值选项。

保存刻画公式选项所保存的公式与使用保存公式命令生成的公式几乎完全相同，只不过它将隐藏层计算嵌入到最终的预测公式中，而不是通过中间隐藏层来进行。它允许您使用“刻画器”和“等高线刻画器”。

保存隐藏列与尺度无关列选项可以创建一些新列，其中包含用于生成估计值的已转换尺度的数据、隐藏列的值以及预测值。它不会保存公式。

设定随机种子设定随机种子您可以指定供随机数生成器使用的种子。


判别分析

判别平台

判别分析是一种根据已知的连续响应 (Y) 来预测分类 (X) 变量（记名或保序）的方法。此方法可视为多元方差分析 (manova) 的反预测。实际上，“拟合模型”的多元方差分析功能也提供了一些判别功能。

其中包括：

  • 逐步选择对话框，有助于选择能进行准确判别的变量。
  • 判别得分，表明每个点接近哪一个组。
  • 错误分类汇总。
  • 图形的点和均值分布于典型空间，该空间能体现均值的最佳分离。
  • 用于将预测距离和概率保存到数据表的选项。

目录

简介

判别组

典型图

判别得分

命令和选项

得分选项

典型选项


简介

判别分析是逻辑斯蒂回归的替代方法。在逻辑斯蒂回归中，分类变量是随机的，由系统根据连续变量预测得出；但在判别分析中，分类变量是固定的，而 Y 值则根据随机变量得出。但是，两种情况下的分类值均根据连续变量预测得出。

判别分析有几种形式。JMP 可以实施最简单的一种 － 线性判别分析。在线性判别分析中，假定 Y 以相同的方差和协方差呈正态分布，但是，X 定义的每个组都有不同的均值。此方法可以测量数据集中的每个点到每个组的多元均值（通常称为重心）之间的距离，并可将点划分到最近的组中。使用的距离测量方法为 Mahalanobis（马氏）距离法，它可以将变量之间的方差及协方差考虑在内。


判别组

Fisher 著名的“鸢尾花”数据集是判别分析的经典实例。在此实例中，对三种不同鸢尾花组成的样本进行了四次测量。目的在于通过四次测量的值来准确识别每种鸢尾花。打开鸢尾花.jmp，然后选择分析 > 多元方法 > 判别以启动“判别分析”平台。屏幕将显示如"判别启动对话框" 所示的启动对话框。

判别启动对话框

如果要找出哪些变量能进行准确判别，请单击逐步变量选择。否则，平台将使用您指定的所有变量。在本例中，四个连续变量被指定为 Y，协变量，而种类则被指定为 X，类别。

如果选择了逐步变量选择，屏幕将显示用于选择变量的对话框（"逐步控制面板"）。您可以查看 F 比率较大或 p 值较小的那些列，同时控制要输入判别模型的列。此外，对话框还将显示模型内外的列数，以及要输入或移除的最大和最小 p 值。

逐步控制面板

已输入复选框用于显示当前模型中已有的列。您可以单击这些列，以便将其移入或移出模型。

锁定复选框用于强制某个列保持其当前状态，而不管通过按钮执行的步骤。

向前逐步用于将最显著的列添加到尚未包含该列的模型中。

向后逐步用于移除模型中显著性最低的列。

输入全部用于将所有的列输入到模型中。

移除全部用于移除模型中所有的列。

应用此模型用于最终确定要在分析中包含的列，同时继续进行估算和计分。

"逐级模型" 显示了三个向前步骤，除花瓣长度之外的所有列都将被添加到模型中。

逐级模型

单击应用此模型以估算此模型。在完成估算和计分后，系统将生成两个报表：“典型图”（"典型图"）和“计分报表”。

典型图

“典型图”可以在二维图中显示数据点和多元均值，而二维图能够很好地区分每个组。

典型图
  • 数据集中的每一行显示为一个数据点，具体可通过典型选项 > 显示点选项加以控制。
  • 每个多元均值都将用圆圈标记。圆圈的大小与均值的 95% 置信限对应。存在明显差异的组趋向于生成非相交的圆圈。这可以通过典型选项 > 显示椭圆均值置信区间选项加以控制。
  • 典型空间中的变量方向由总均值发出的标记射线表示。这可以通过典型选项 > 显示双向图射线选项加以控制。您可以将双向图射线的中心拖至图形中的其它位置。
  • 如果假设成立，则选项显示正态 50% 等高线将显示包含该组约 50% 数据点的区域。在线性判别分析中，它们的大小均相同。

为了像重心圆一样编辑数据点的颜色，请使用设定点颜色选项或按钮。这与行 > 按列设定颜色或标记的功能类似，即按分类列设定颜色。

如果同时显示了数据点和变量方向射线（如"典型图" 所示），则典型图也可称为双向图。它与“拟合模型”平台的多元方差分析功能中生成的重心图相同。

判别得分

计分报表可以显示每个数据点的分类准确性。报表的前五列将表示实际（所观测）的数据值，其中包括行号、实际分类、与该分类均值的距离以及相关概率。JMP 可以通过图形表示负对数（概率），以便在数据点预测不准确的情况下显示对数似然中的损失。如果红色条柱较大，则表示该点的预测不准确。

在图形的右侧，报表显示了具有最高预测概率的类别，以及预测概率高于 0.1 的其它类别（如果存在）。星号 (*) 表示被错误分类的点。

在"仅显示需要的行" 中，由于设定了仅显示需要的行选项，因此只会显示拟合概率在 0.05 和 0.95 之间的行或分类错误的行。

仅显示需要的行

"仅显示需要的行" 的底部显示了“计数”报表。如果所有的分类均正确，则对角线之外的计数将为零。


命令和选项

平台弹出式菜单包含了以下命令。

逐步变量选择用于返回到逐步控制面板。

得分数据用于显示或隐藏报表的判别得分部分。

典型图用于显示或隐藏典型图。

指定先验概率用于显示一个对话框，允许您在其中指定每个 X 变量水平的先验概率，如"指定先验概率对话框" 所示。默认情况下，系统将为每个水平指定相等的概率。

指定先验概率对话框

考虑新水平用于某些点无法与任何已知的组拟合，但可以考虑某个未评分的新组的情况。

保存判别矩阵用于创建一个全局列表 (DiscrimResults)，在 JMP 的脚本语言中使用。该列表分别包含一个 YNames、XNames、XValues 列表以及一个 YMeans 矩阵和 YPartialCov（协方差）矩阵。以下是来自“鸢尾花”数据 DiscrimResults 的实例：

 {
YNames = {"Sepal length", "Sepal width", "Petal length", "Petal Width"}, XName = "Species", XValues = {"setosa", "versicolor", "virginica"},
YMeans = [5.005999999999999 3.428000000000001 1.462 0.2459999999999999,5.936 2.77 4.26 1.326, 6.587999999999998 2.974 5.552 2.026],
YPartialCov = [0.2650081632653061 0.09272108843537413 0.1675142857142858 0.03840136054421769, 0.09272108843537413 0.1153877551020407 0.055243537414966 0.03271020408163266, 0.1675142857142858 0.055243537414966 0.1851877551020409 0.04266530612244898, 0.03840136054421769 0.03271020408163266 0.04266530612244898 0.04188163265306122]
}

显示内部协方差用于显示或隐藏“协方差矩阵”报表。本实例的报表如"“协方差矩阵”报表" 所示。

“协方差矩阵”报表

显示组均值用于显示或隐藏包含每个变量的均值的表。系统将显示 X 变量的每个水平以及所有水平的均值。

获取判别矩阵只能通过编写脚本使用，与保存判别矩阵获得的值相同，但此选项会将值返回调用程序，而不是存储在数据表中。

得分选项

这些选项用于处理观测值的计分。

仅显示需要的行用于显示错误分类的行以及任何 p > .05 且 p < 0.95 的行（其中 p 为属性概率）。

显示分类计数用于显示每个分类的实际对预测计数的矩阵。如果数据预测非常准确，对角线之外的元素将为零。

选择错误分类的行用于选择原始数据表中分类错误的行。

选择未确定的行用于选择数据表中包含未确定分类的行。如果选择了此选项，屏幕将显示一个对话框，以便您指定要标记为未确定的差值（默认值为 0.1）。

保存公式用于将公式保存到数据表中。距离公式包括用于 Mahalanobis 距离计算的 Dist[0] 以及 Dist[ ] 列（每个 X 水平的 Mahalanobis 距离）。概率公式包括 Prob[0]（-0.5 的幂和乘以 Mahalanobis 距离）以及 Prob[ ] 列（每个 X 水平在该类别中的后验概率）。预测列包含每一行最可能的水平。

显示各组距离用于附加一个表，以便显示每个组的平方距离。

显示各组概率用于附加一个表，以便显示每个组的概率。

ROC 曲线用于在报表中附加 ROC 曲线。

典型选项

这些选项都将影响典型图。

显示点用于在图形中显示或隐藏数据点。

显示椭圆均值置信区间用于显示或隐藏每个均值的 95% 置信椭圆。由于缩放，椭圆将显示为圆形。观测值越多的类别，圆形将越小。

显示正态 50% 等高线用于显示或隐藏正态等高线，该等高线能够估计该水平 50% 的点所在的区域。

显示双向图射线用于显示或隐藏双向图射线设定点颜色。这些射线可以指明典型空间中变量的方向。

双向图射线位置让您可以指定典型图中双向图射线的位置和半径尺度（默认值 = 1）。

设定点颜色用于根据 X 变量的水平设定数据点的颜色。此语句的功能相当于选择行 > 按列设定颜色或标记并选择 X 变量。

显示典型详细资料用于显示或隐藏典型详细资料。鸢尾花数据集的详细资料如"典型详细资料" 所示。报表底部的矩阵可通过单击其名称旁边的蓝色三角形来打开，也可以通过单击矩阵的名称将其关闭。

典型详细资料

保存典型得分用于在数据表中创建列，以用于保存每个观测值的典型得分。新列命名为 Canon[ ]。


生存和可靠性分析 I

一元生存

生存数据包含出现特定事件之前的持续时间，有时称为事件 - 时间响应数据。事件通常是失败，如引擎故障或病人死亡。如果在观测值研究结束之前事件尚未发生，则称此观测值为删失。

通过生存和可靠性子菜单可访问四种生存分析。

本章重点讲解“生存和可靠性”菜单上的第一个菜单项，即一元生存。生存/可靠性通过将乘积极限 (Kaplan-Meier) 方法用于一组或多组右删失数据，计算生存函数的估计。它给出每组和整个样本的估计生存函数的叠加图。JMP 还计算对数秩和 Wilcoxon 统计量以检验组间齐性。另外，还有用于指数、Weibull 和对数正态生存分布的诊断图和拟合选项，以及 Weibull 模型竞争原因分析。Turnbull 估计支持区间删失。

在"生存和可靠性分析 II" 一章中，讲解了参数和比例危险模型。"再现分析"详细讲解了再现分析。

目录

生存分析简介

一元生存分析

选择一元生存分析变量

实例：电扇可靠性

实例：老鼠数据

一元生存平台概览

一元分析统计报表

平台选项

拟合分布

区间删失

WeiBayes 分析

竞争原因估计

忽略原因

保存竞争原因信息

模拟时间和原因数据


生存分析简介

生存数据需要用专用方法来分析，原因有两个：

  1. 生存时间有专用的非正态分布，如指数、Weibull 和对数正态。
  2. 有些数据可以删失，即您不知道精确生存时间，但知道它大于指定值。这称为右删失。研究结束时有部分单位失败，或者研究结束前有病人必须退出研究，这时发生删失。忽略删失观测值，必然会导致分析偏差。

生存模型的元素包括

  • 表示在单位（或病人）经历事件或被删失之前经过的时间。时间为模型响应 (Y)。
  • 表示观测值是经历事件还是删失的删失指示符。JMP 使用的约定是代码 1（或任何非零值）表示删失单位，代码 0 表示非删失事件。
  • 解释变量（如果使用了回归模型）。
  • 如果需要区间删失，那么两个 y 变量则保存限定事件时间的下限和上限。

术语“失效时间”、“生存时间”和“持续时间”，可互换使用。


一元生存分析

要进行一元生存分析，单击 JMP 起始页生存选项卡上的生存命令，或者选择分析 > 生存和可靠性并从其子菜单上选择生存/可靠性。

完成启动对话框（此处显示的）之后，单击确定，生存和可靠性命令产生乘积极限（也称为 Kaplan-Meier）生存函数估计、具有可选参数估计的研究图，以及生存曲线的比较（有多个组时）。

选择一元生存分析变量

生存平台只需要一个时间 (Y) 变量，此变量必须是持续时间或生存时间。删失、分组和频数变量可选。数据的排序顺序无关紧要。

Y，事件时间
是要求的唯一变量，其中包含事件时间或删失时间。如果有区间删失，则指定两个 Y 变量：下限和上限。
删失
表中具有删失代码的列，0 表示未删失，非 0 表示删失。
分组
以其将数据划分成组的列，各个组将分别拟合。
频数
一个列，该列的值是在有多个记录单位时，每行的观测值频数。

默认情况下，删失列值 0 表示事件（如失败），非零代码表示删失值。要支持编码不同的数据集，可以在启动对话框的“删失代码”编辑框中输入一个不同的代码来表示删失（如 0）。为了提供与 JMP 以前版本的兼容性，代码 1 解释为任何正值，表示删失。

实例：电扇可靠性

Nelson 研究了柴油发动机电扇的故障（1982，第 133 页，另见 Meeker and Escobar，1998，附录 C1）。部分数据列表如"电扇数据" 所示。

电扇数据

启动分析 > 生存和可靠性 > 生存/可靠性之后，请将时间指定为 Y，事件时间，将删失指定为删失。另外，选定标绘失败图而非生存图复选框，因为显示失败概率图比生存概率图更符合传统。完成的对话框如"电扇启动对话框" 所示。

电扇启动对话框

"电扇初始输出" 显示失败图。请注意失败概率的增加是时间的函数。

电扇初始输出

下一步通常是用该分布的图和拟合选项研究分布拟合，如 Weibull 模型。

电扇数据的 Weibull 输出

由于拟合是合理的，并且 Beta 估计接近 1，因此可得出这似是指数分布的结论，而指数分布的危险率是常数。分布拟合图选项将产生三种分布拟合视图。

分布拟合图

实例：老鼠数据

为了研究老鼠食用某种致癌物后的生存时间，进行了一项试验，其中将老鼠分成两个治疗组。数据位于 Sample Data 文件夹中的老鼠.jmp 表中。天数变量为以天为单位的生存时间。部分观测值为删失。此实例中的事件是死亡。目标是看一个治疗组中的老鼠是否比另一个治疗组中的老鼠活的时间长（天数多）。

请使用生存启动对话框，按上面实例对话框的方式将列指定为相应角色。

一元生存平台概览

生存平台为一组或多组计算乘积极限 (Kaplan-Meier) 生存估计。可以将其用作一个完整分析或者用作探索分析，以获得更复杂模型拟合的信息。

Kaplan-Meier 生存平台

  • 显示每个组以及整个样本（可选）的估计生存函数图。
  • 计算并列出每组和合并样本的生存函数估计。
  • 可选择显示指数、Weibull 和对数正态诊断失败图，以图形方式检查将这些分布用于进一步回归建模的适当性。参数估计按要求提供。
  • 计算对数秩和 Wilcoxon 卡方统计量，以检验估计生存函数的组间齐性。
  • 可选择执行竞争原因分析，提示输入失败原因变量，为与每个原因对应的删失模式估计 Weibull 失效时间分布。

开始时，生存平台显示各组的估计生存函数的叠加阶梯图，如"生存平台的生存图和报表结构" 所示。有关图例用颜色和线型来标识各组。

图下面的表提供了生存时间的汇总统计量和分位数，列出在各组内计算的每个观测值的估计生存时间及根据合并样本计算的生存时间。有多个组时，将提供统计检验，比较生存曲线。

生存平台的生存图和报表结构

一元分析统计报表

初始报表为“汇总”表和“分位数”表（如"一元生存分析汇总统计量" 所示）。“汇总”表显示每组（多当存在组时）和整个研究的失败次数和删失观测值个数，以及删失调整后的均值和标准差。有关这些统计量的计算详情，请参阅《SAS/Stat User's Guide》(2001)。

“分位数”表显示单个组和合并组的失效时间统计量。这些包括中位数生存时间与 95% 置信上限和置信下限。中位数生存时间是一半主题失败时的时间（天数）。其中还包括四分位数生存时间（25% 和 75%）。

一元生存分析汇总统计量

有多个组时，“组间检验”表（如下所示）会提供组间齐性统计检验 (Kalbfleisch and Prentice 1980)。

检验
指定假设为各组间生存函数相同的两个统计检验。
卡方
给出统计检验的卡方近似值。
对数秩检验对于较大生存时间有较大的权重，并在要比较的各组内危险函数比近似为常数时最有用。危险函数是在给定时间的瞬时失败率，它也称为死亡率或死亡力。
如果误差异布为逻辑斯蒂分布，Wilcoxon 检验则对早期的生存时间有较大的权重，且是最优秩检验 (Kalbfleisch and Prentice, 1980)。
DF

给出统计检验的自由度。

p 值 > 卡方
列出在生存函数在所有组中都相同时，偶然得到比计算值大的卡方值的概率。

"生存估计表实例" 显示其中一个组的乘积极限生存函数估计的实例。

生存估计表实例

注：当记录的最后时间为删失观测值时，报表显示偏均值估计。偏均值估计是真实均值的下限。

平台选项

“乘积极限生存拟合”标题栏上的弹出式菜单列出了以下生存平台选项。

所有平台选项都用来交替隐藏或显示信息。下面的列表汇总了这些选项：

生存图
显示每个组的叠加生存图，如"生存平台的生存图和报表结构" 所示。
失败图
在传统的可靠性分析文献中显示每组的叠加失败图（随时间失败的比例）。失败图反转 y 轴，显示失败数，而不是生存数。通过实例很容易看出这个区别。老鼠.jmp 数据表的两个图如"老鼠数据的生存图和失败图" 所示。
请注意，失败图取代了旧版本 JMP 中的反转 Y 轴命令（脚本中仍有此命令）。
老鼠数据的生存图和失败图
图选项
包含以下选项的子菜单。请注意，前四个选项（显示点、显示合并、显示置信区间、显示联立置信区间）与初始生存图相关，而最后两个（中间分位点和连接分位数点）则只与分布图相关。
显示点隐藏或显示生存图每个阶梯的样本点。在每个阶梯底部显示失败点，在阶梯上方用点表示删失。
显示 Kaplan Meier 隐藏或显示 Kaplan-Meier 曲线。
显示合并在生存图上用加粗灰线显示合并组的生存曲线。
显示置信区间在生存图上显示各组的 95% 置信区间，用显示合并选项显示时则在合并图上显示 95% 置信区间。
在图上使用显示点和显示合并选项时，全体或合并样本的生存图显示为灰线，点显示在各组的图阶梯上。
显示联立置信区间在图上开关所有组的置信区间。
中间分位点更改标绘位置，使用经修改的 Kaplan-Meier 标绘位置，相当于取 Kaplan-Meier 曲线的中间位置，而不是阶梯底部位置。其结果是图中又多了一个点。建议使用此选项，因此默认情况下其为打开的。
连接分位数点开关图上的线，此选项默认情况下为开。
拟合分位数开关拟合的 Weibull、对数正态或指数分位数图上的直线拟合。
拟合分位数置信区间线开关拟合的 Weibull、对数正态或指数分位数图的 95% 置信带。
阴影化拟合分位数 CI 决定是否将拟合 95% 置信带显示为阴影区域或虚线。
生存拟合置信区间开关（生存图上）拟合分布的置信区间。
拟合失败置信区间开关（失败图上）拟合分布的置信区间。
指数图
选定时，按时间标绘每组的 -log(生存率)，其中生存率为生存分布的乘积极限估计。近似线性的线按经验指示使用指数模型做进一步分析的适当性。在"指数、Weibull 和对数正态图表" 中，指数图中 Group 1 和 Group 2 为曲线，而不是直线，这表明指数分布不适合此数据。
指数拟合
产生如所示的"指数、Weibull 和对数正态图表"指数参数表。参数 Theta 与均值失效时间对应。
Weibull 图
按 log(时间) 标绘每组的 log(- log(生存率))，其中生存率为生存分布的乘积极限估计。如果 Weibull 图显示近似平行线和直线，则表明 Weibull 生存分布模型适合用于做进一步分析。
对于 Weibull 拟合和对数正态拟合，如果您在选择此命令时按住 Shift 键，则将显示下面的对话框。
您可以在这里设定上下限的置信水平和 Sigma 的约束值（有关使用此选项的详情，请参阅"WeiBayes 分析"），并请求置信等高线图。
置信等高线图
Weibull 拟合
产生如“极值参数估计”表和“Weibull 参数估计”表显示的两种常用估计形式（"指数、Weibull 和对数正态图表"）。Alpha 参数为失效时间分布的 63.2% 分位数。极值表显示同一拟合的不同参数化，其中 Lambda = ln(Alpha)，Delta = 1/Beta。
对数正态图
按照每组的时间日志标绘 1 减去生存率（用 Probit (1-生存率) 表示）的逆累积正态分布，其中生存率为生存分布的乘积极限估计。如果对数正态图显示近似平行线和直线，则表明对数正态分布适合用于做进一步分析。按住 Shift 键可获得更多选项，如上面的“Weibull 图”一节所述。
对数正态拟合
产生如"指数、Weibull 和对数正态图表" 所示的“对数正态参数估计”表。Mu 和 Sigma 与时间变量的正态分布自然对数的均值和标准差对应。
分布拟合图
与拟合分布相关联，显示三个与拟合分布对应的图：生存图、密度图和危险图。如果没有执行“拟合”命令，则不会显示任何图。下一节展示了一个实例。
竞争原因
提示输入数据表中包含失败原因标签的列。然后，使用该原因进行 Weibull 模型估计，以表示失败事件，而使用其它原因表示删失。在生存图上拟合分布用虚线显示。
估计生存概率
弹出一个对话框，您可在其中最多输入 10 个时间，并针对输入的时间估计生存概率。
估计时间分位数
弹出一个对话框，您可在其中最多输入 10 个概率，并针对每个输入的概率估计时间分位数。
保存估计值
创建一个 JMP 数据表，将所有信息保存在生存估计表中。

拟合分布

对于 JMP 支持的三种分布，每种都有一个图形命令和一个拟合命令。使用图形命令查看这些事件标记是否近似一条直线（分布正确时会呈一条直线）。然后，使用拟合命令估计参数。

指数、Weibull 和对数正态图表

下表显示此分布直线拟合时标绘的内容
分布图 | X 轴 | Y 轴 | 解释
指数 | 时间 | -log(生存率) | 斜率为 1/theta
Weibull | log(时间) | log(-log(生存率)) | 斜率为 beta
对数正态 | log(时间) | Probit(1-生存率) | 斜率为 1/sigma

指数分布是最简单的，只有一个参数，我们称其为 theta。它是常数危险分布，不记忆它为了影响一个事件似然性所生存的时间。参数 theta 为期望生存时间。

Weibull 分布最常用于事件时间数据。用于参数化分布的方法有多种，不同的作者选用不同的方法（如"用 JMP alpha 和 beta 表示的各种 Weibull 参数"所示）。JMP 报告两种参数化，即标记为 lambda-delta 极值参数化和 Weibull alpha-beta 参数化。alpha-beta 参数化用于可靠性分析文献 (Nelson 1990)。Alpha 解释为 63.2% 单位失败的分位数。Beta 解释为危险随时间增加 (beta>1) 还是降低 (beta<1)，beta=1 时为常数危险指数分布。

对数正态分布也很常用。在这种分布中，您取对数值时，分布为正态分布。如果要将数据与正态分布拟合，可以取其 exp() 并将其当作对数正态来分析，如后面的 Tobit 实例所示。

选项分布拟合图将显示拟合分布。此处有 9 幅图，生存、密度和危险的三种分布图，即指数、Weibull 和对数正态。这些图共用一个轴尺度，因此很容易就可以比较这些分布。

三种分布的分布拟合图。

这些图可以通过图形脚本转换为其它图形。要复制图，使用鼠标右键单击要复制的图并选择编辑图形脚本。高亮度显示所要的脚本，并将其复制到剪贴板中。使用鼠标右键单击目标图，并选择添加图形脚本，将脚本从剪贴板粘贴到出现的窗口中。
用 JMP alpha 和 beta 表示的各种 Weibull 参数
JMP Weibull | alpha | beta
Wayne Nelson | alpha = alpha | beta = beta
Meeker 和 Escobar | eta = alpha | beta = beta
Tobias 和 Trindade | c = alpha | m = beta
Kececioglu | eta = alpha | beta = beta
Hosmer 和 Lemeshow | exp(X beta) = alpha | lambda = beta
Blishke 和 Murthy | beta = alpha | alpha = beta
Kalbfleisch 和 Prentice | lambda = 1/alpha | p = beta
JMP 极值 | lambda = log(alpha) | delta = 1/beta
Meeker 和 Escobar s.e.v. | mu = log(alpha) | sigma = 1/beta

区间删失

通过区间删失数据，您仅知道事件发生在某个时间区间。Turnbull 方法用于获得生存函数的非参数估计。

在 Nelson [1990 p 147] 的这个实例中，在各个时间上查看和检查微处理单元，并统计失败单元。一个列中的缺失值表示您不知道其下限或上限，因此该事件分别为左或右删失。数据如"微处理数据" 所示。

微处理数据

启动生存平台后，请将时间上限和时间下限分别指定为两个 Y 列，如"区间删失启动对话框" 所示。

区间删失启动对话框

显示产生的 Turnbull 估计。Turnbull 估计可能有时间间隔，其中生存概率不可估计，如本实例 12 和 24 之间所示。

这时选择一种分布，查看其拟合估计，此处拟合了对数正态分布。其中缩小了失败图，因为失败率非常小时图不能显示很多信息。

区间删失输出

WeiBayes 分析

现在 JMP 在拟合这类分布时，可以限制 Beta (Weibull) 和 Sigma (对数正态) 参数的值。在 WeiBayes 情况下需要此功能 (Abernethy, 1996)，如

  • 很少或没有失败的情况下，
  • beta 具有现有历史值，并且
  • 仍需估计 alpha。

没有失败时，标准方法是在结束时添加一次失败，估计值将反映 alpha 值的下限，而不是真实估计。此功能允许真实估计。

要使用此功能，请在选择 Weibull（或对数正态）拟合时按住 Shift 键，并在得到提示时输入参数值（例如，分为 beta 或 sigma）。


竞争原因估计

有时系统中有多个失败原因。例如，假设生产过程有若干阶段，任何阶段的失败都造成整个系统的失败。如果各原因都是独立的，失效时间则可以通过估计各个原因的生存分布来建模。对给定的原因进行删失估计时，将所有不属于该原因的事件时间都当作删失观测值。

Nelson (1982) 讨论了一种小电器的失效时间，其失败原因有多种。一组（组 2）数据是 Reliability 子文件夹中的电器设备.jmp 数据表的样本数据。上表显示电器失败数据的部分列表。

要指定分析，只需在生存对话框中输入时间变量（时间周期）然后使用竞争原因菜单命令，它会提示您选择数据表中的一个列来标记失败原因。对于此例，选择原因编号作为标签变量。

整个系统的生存分布正好是生存概率的乘积。"竞争原因图表" 中的生存图显示了初始生存分布和拟合分布。失败原因上重叠了一条虚线。“竞争原因”表显示在报表的底部，给出了各个失败原因的 Alpha 和 Beta 估计。

在此实例中，大多数失败都是由于原因 9 引起的。原因 1 只发生了一次，不能产生良好的 Weibull 估计。原因 15 只在很短的时间内发生，并且导致 beta 较小但 alpha 较大。请记住，alpha 是失效时间 63.2% 分位数的估计，早期失败的原因往往都是 alpha 很大；如果这些 alpha 不导致早期失败，它们则不会导致后续失败。

竞争原因图表

"Time Cycles 与 Cause Code 的以 X 拟合 Y 图及箱型图" 显示了使用分位数选项时 Time Cycles 与 Cause Code（以 X 拟合 Y）图。此图说明了 alpha 和 beta 与失败分布的关系。

Time Cycles 与 Cause Code 的以 X 拟合 Y 图及箱型图

忽略原因

如果原因 9 得到纠正，其它原因将如何影响生存呢？

通过“竞争原因”标题栏上的弹出式菜单图标可访问如下所示的菜单。忽略原因命令提示您输入要忽略的一个或多个原因值，然后再次计算竞争原因。

在此实例中，无原因 9 的竞争危险给出了首先在"带有忽略原因的生存图" 中显示的生存估计和修正后的生存图。请注意，生存率（用虚线显示的）在 2,000 个周期之前并没有太大的改善，但之后达到 10,000 个周期时，则变得平坦了许多。

带有忽略原因的生存图

保存竞争原因信息

“竞争原因”表弹出式菜单上有用于保存估计和保存失败原因坐标的命令。

保存原因坐标值命令在当前表中添加名为 log(- log(生存率)) 的新列。此信息经常用于标绘时间变量，其中带有分组变量，如失败类型代码。

模拟时间和原因数据

“竞争原因”表弹出式菜单包含模拟命令。

此命令使用由数据估计出的 Weibull 分布的时间和原因数据来创建一个新数据表。


生存和可靠性分析 II

回归拟合

本章重点讲解生存和可靠性子菜单的第二项和第三项。

参数生存模型拟合启动回归平台，按照线性模型的尺度拟合生存分布。可选择的分布有指数、Weibull 和对数正态。回归使用迭代极大似然法。加速失效模型属于回归模型。本章还说明如何使用非线性平台拟合参数模型。

比例危险模型拟合启动回归平台，使用 Cox 比例危险方法拟合线性模型。比例危险模型 (Cox 1972) 是带协变量的生存数据的常用回归模型。此模型为半参数模型，仅估计线性模型，而不估计危险函数的形式。不支持时变协变量。

通过分析 > 模型拟合也可访问参数回归和比例危险生存方法，在“模拟拟合”对话框中将它们作为拟合特征。

目录

参数回归生存拟合

实例：计算机程序执行时间

选项与报表

实例：Arrhenius 加速失效对数正态模型

实例：区间删失加速失效时间模型

实例：右删失数据；Tobit 模型

比例危险模型

实例：老鼠数据

比例危险模型统计报表

非线性参数生存模型

生存分布损失公式

Tobit 模型实例

拟合简单生存分布


参数回归生存拟合

如果生存时间中危险率与一个或多个变量的函数成比例，则需要一个回归平台，用于拟合线性回归模型，但不考虑生存分布和删失。您可以用生存子菜单上的参数回归命令，或使用名为参数生存模型的模型拟合特例，进行这类分析。

实例：计算机程序执行时间

数据表计算时间.jmp 摘自 Meeker and Escobar (p.434)，是用于分析计算机程序执行时间的数据，其对数正态分布取决于回归量负载。它位于 Sample Data 的 Reliability 子文件夹中。

计算时间.jmp 数据

要开始分析，请选择分析 > 生存和可靠性 > 参数生存模型拟合。出现启动对话框后，请选择准确时间作为事件时间，并添加负载作为模型效应。然后，将分布从默认的“Weibull”更改为“对数正态”。完成的对话框应如"计算时间对话框" 所示。

计算时间对话框

只有一个回归量时，此回归量的函数将显示对于三个生存概率的生存曲线图。

计算时间输出

根据 Meeker 和 Escobar 的文献第 438 页的说明，当 90% 的任务都是在系统负荷为 5 的情况下完成时，就非常需要时间分位数。选择估计时间分位数命令，将弹出如"估计时间分位数对话框" 所示的对话框。输入 5 作为负载，0.1 作为生存概率。

估计时间分位数对话框

单击“执行”将生成分位数估计和置信区间。

时间分位数估计

这估计出在系统负载为 5 的情况下，90% 的任务将用 631 秒执行时间完成。


选项与报表

作为演示此平台组件的实例，请使用 Sample Data 文件夹中的 VA 肺癌.jmp 表（Kalbfleisch 与 Prentice 1980）。响应生存天数为一组肺癌病人的生存时间，单位为天。回归量包括年龄（年龄）及从以月份为单位，表示从诊断到试验的时间（诊断时间）。删失等于 1 表示删失值。

参数回归生存命令启动如"用于参数生存分析的模型拟合对话框" 所示的模型拟合对话框。此对话框专门用于生存分析，其上有用于标记时间（事件时间）和删失（删失）变量的按钮。此外，拟合特性显示为参数生存模型，另一个弹出式菜单让您可以选择适用于数据的生存分布类型（Weibull 损失、对数正态损失或指数损失）。

用于参数生存分析的模型拟合对话框

单击“模型设置”对话框中的运行模型时，生存分析表将显示“整体模型检验”和“参数估计”。如果模型中没有回归量，且只拟合了一个截距项，则“整体模型检验”会将完全拟合与期望拟合效果进行比较。

在仅有截距项的情况下产生的拟合与一元生存平台产生的拟合相同。Delta（或者 beta）是 Weibull 分布的斜率参数。另一个 Weibull 参数（lambda 或 alpha）等效于整体线性模型。

以下是可用的参数生存选项（请参阅"参数生存模型报表"）：

似然比检验
生成将拟合模型的对数似然与从模型中逐个移除项的对数似然进行比较的检验。似然比检验附加在文本报表后。
置信区间
计算各参数的侧似然 95% 置信区间，并将其在“参数估计”表中列出。
估计值的相关性
产生模型效应相互间以及与拟合分布参数间的相关矩阵（Weibull 或对数正态）。
估计生存概率
弹出一个对话框，您可在其中指定回归量值和一个或多个时间值。接着对于所有可能的项目组合，JMP 都会计算生存概率和失败概率及 95% 置信限。
估计时间分位数
弹出一个对话框，您可在其中指定回归量值和一个或多个生存值。接着对于所有可能的项目组合，它都会计算时间分位数和 95% 置信限。
残差异位数图
显示一个图，其中残差在 x 轴上，Kaplan-Meier 估计的分位数在 y 轴上。如果是区间删失，则使用中点。这种残差是 Cox-Snell 残差的最简单形式，它将事件时间转换为删失标准 Weibull 或其它标准分布。
保存残差
新建一个列来存放残差。
参数生存模型报表

有关统计模型的详情，请参阅"非线性参数生存模型"部分。

实例：Arrhenius 加速失效对数正态模型

Devalt.jmp 数据集（也称为设备 A 数据）摘自 Meeker 和 Escobar（第 493 页和附录 C10），原始出处为 Hooper 和 Amster (1990)。数据集位于 Reliability 样本数据文件夹中。数据集的部分列表如"Devalt 数据表" 所示。

Devalt 数据表

通过加热给单元施加压力，以便使其快速失效并获得足够多的失效来拟合分布。

使用二元平台，用时间的对数尺度标绘时数与温度图。[Meeker 和 Escobar 中的图 19.1]。这可以手动完成（分析 > 以 X 拟合 Y 以时间为 Y，温度为 X）或者通过运行数据表左边的 Bivariate 脚本完成。

时间与对数温度的二元图

使用一元生存平台产生每个温度数据的对数正态图。要完成此操作，请选择分析 > 生存和可靠性 > 生存/可靠性，将时间作为 Y，删失作为删失，温度作为分组，权重作为频数。或者，运行数据表旁边的生存脚本。两种方法都可以产生如"对数正态图" 所示的图形。

对数正态图

然后，用温度作回归量拟合一个模型。回归量 x，也称为激活能量，是对利用存储在数据表中 X 列的公式计算出的温度的 Arrhenius 变换：

Hours 是失败或删失时间。对数正态分布将会与此时间的分布拟合。要完成此操作，请选择分析 > 生存和可靠性 > 参数生存模型拟合，并将时间指定为事件时间，x 指定为模型效应，删失指定为删失，权重指定为频数。此外，将分布类型更改为对数正态。

单击运行模型后，结果显示数据的回归拟合。如果只有一个回归量并且是连续的，那么生存图则显示为回归量的函数，且线条位于 0.1、0.5 和 0.9 的生存概率。如果回归量列含有用另一个列表示的公式，如本例，该图则按内部列绘制。在本实例中，回归量为 x 列，但是图是按照 Temp 绘制的，因为 x 是 Temp 的函数。

Devalt 参数输出

最后，演示如何获取 10000 和 30000 小时时外推到摄氏 10 度的生存概率的估计。选择估计生存概率命令，在对话框中输入下面的值： 10 度的 Arrhenius 变换为 40.9853，是回归量值。

估计生存概率

单击执行后，报表显示估计和置信区间，如 Meeker 和 Escobar 的实例 19.8 所示。

生存概率

实例：区间删失加速失效时间模型

继续讲解 Meeker 和 Escobar [第 508 页和附录 C.15] 的另一个实例，IC设备02.jmp 给出的数据中失败发生在检验区间之间。Reliability 样本数据文件夹中的数据如"IC设备02 数据" 所示。

IC设备02 数据

此模型使用两个 y 变量，包含失效时间的上限和下限。右删失时间显示为缺失上限。要执行分析，请选择分析 > 生存和可靠性 > 参数生存模型拟合，其中 HoursL 和 HoursU 作为事件时间，Count 作为频数，而 DegreesC 作为模型效应。得到的回归图为时间与温度图。

IC 设备输出

实例：右删失数据；Tobit 模型

Tobit 模型为正态分布，在零处有截断。但是，可以取响应的指数，并设置右删失问题的区间。Tobit2.jmp 位于在样本数据 Reliability 文件夹中，请在其中运行附带的脚本，估计对数正态分布。


比例危险模型

比例危险模型是 D. R. Cox (1972) 提出的一种特殊的半参数回归模型，用来检查解释变量对生存时间的影响。一个总体中每个成员的生存时间都假定为符合其本身的危险函数。

因为比例危险涉及未指定的任意基准危险函数，所以它是非参数的。因为它假定协变量的参数形式，所以它又是参数的。基准危险函数按模型（时间无关）协变量的函数标度，以提供一般危险函数。与 Kaplan-Meier 分析不同，比例危险计算各协变量的参数估计和标准误差。与解释变量和标准误差关联的回归参数 (β) 是用极大似然法估计的。条件危险比（或危险比）及其置信限也是根据参数估计计算的。

比例危险中的生存估计是用经验方法 (Lawless, 1982) 生成的，表示生存函数 S(t) 的经验累积危险函数估计 H(t)，可用危险函数写为 S 0 = exp(-H(t))。

响应中有结时，即在给定时间事件处有多次失效时，采用 Breslow 似然法。

实例：老鼠数据

以下实例使用老鼠.jmp 样本数据。要定义比例危险生存模型，请从生存子菜单中选择比例危险，

这将启动用于生存分析的模型拟合对话框，比例危险显示为拟合特性。或者，可以使用模型拟合命令来指定比例危险拟合特性（"比例危险分析的模型拟合对话框"）。

接着，将天数指定为事件时间变量，删失指定为删失，并将组添加到模型效应列表。下一节描述比例危险分析结果。

比例危险分析的模型拟合对话框

比例危险模型统计报表

计算比例危险模型的参数估计是模型计算中显示的迭代过程。“迭代历史记录”表列出前 15 次迭代的结果。拟合结束时，将显示如"比例危险分析报表" 所示的报表。

  • “整体模型”表显示似然函数（负对数似然）的负自然对数，此似然函数用于有（/无）分组协变量的模型。
  • 它们之间的正差的两倍提供组间生存时间无差异假设的卡方检验。自由度 (DF) 等于完全模型和缩减模型之间参数个数的变化。
  • “参数估计”表给出组的参数估计、其标准误差以及置信上限和下限。正参数估计与大于 1 的危险比对应。不包括零的置信区间证明组间存在 alpha 水平显著差异。
  • “危险比”表给出这两组的危险函数比，以及置信上限和下限。估计为 1.347（大于 1）意味着，当您将总体均值移到第 2 组时危险函数跟着增加。危险比不包括 1 时的置信区间证明组间存在 alpha 水平显著差异。
  • “效应似然比检验”显示组协变量参数估计为零的零假设的似然比卡方检验。因为 Group 只有两个值，所以“整体模型”表显示的组间无差异的零假设检验与 Group 回归系数为零的零假设相同。
比例危险分析报表


非线性参数生存模型

本节演示如何将非线性平台用于生存模型。在下列情况下只需要学习本节的方法：

  • 模型是非线性的
  • 需要的分布不是指数、Weibull 或对数正态
  • 需要的删失不是通常的右、左或区间删失。

非线性平台具有估计指定损失函数的参数的能力，因此成为拟合极大似然模型的强大工具。有关非线性平台的详情，请参阅"非线性回归"一章。

要在删失数据时拟合非线性模型，首先使用公式编辑器创建一个参数方程式，表示为删失观测值调整的损失函数。然后，使用分析 > 建模菜单中的非线性命令，以极大似然估计参数。

举个例子，假设有一个以变量 time 为响应的表。首先，新建一个列 model，为线性模型。使用计算器将 model 公式建立为时间的自然对数减去线性模型，即 ln(time) - B + B*z，其中 z 是回归量。

然后，因为非线性平台最小化损失，并且要最大化似然，所以创建损失函数，作为负对数似然。对数似然公式必须是条件公式，它取决于给定观测值的删失（如果部分观测值已删失）。

生存分布损失公式

负对数似然将下列公式用于拟合常用参数模型。每个公式都使用计算器 if 条件函数，其中条件的未删失情况在先，而右删失情况作为 Else 子句。您可以从 Sample Data 的 Loss Finction Templates 文件夹中的表中复制这些公式，然后粘贴到您的数据表中。"损失函数公式"显示的损失函数与在公式编辑器创建的列中显示的一样。

指数损失函数

指数损失函数如"损失函数公式"所示，其中 sigma 表示指数分布的均值，Time 为失效时的年龄。

指数分布的特征是瞬时失效率不随时间变化。这就意味着，在给定的时间长度里所有主题的失败概率都一样，无论主题的研究时间有多长。

Weibull 损失函数

Weibull 密度函数常常为生存时间分布提供良好的模型。您可以使用一元生存平台进行数据的初始研究，以确定 Weibull 损失函数是否适合数据。

损失函数样板文件夹中有一个参数、两个参数和极值函数的实例。

对数正态损失函数

下面所示的公式是对数正态损失函数，其中 Normal Distribution(model/sigma) 是标准正态分布函数。t = 0 时危险函数的值为 0，增加到最大值，然后减小，并且当 t 变大时接近于零。

对数逻辑斯蒂损失函数

对数逻辑斯蒂函数具有对称密度，均值为 0，尾部比正态密度函数略大。选择损失函数之后，请选择非线性命令并完成对话框。如果模型公式中包括响应，则不需要 Y 变量。此模型为预测列，损失函数列为损失列。

损失函数公式
指数损失函数
Weibull 损失函数
对数正态损失函数
对数逻辑斯蒂损失函数

Weibull 损失函数实例

此实例使用 VA 肺癌.jmp 表。其中使用 Weibull 损失、对数正态损失和指数损失分布将模型与生存时间拟合。模型拟合包括只有两个回归量的简单生存模型、具有所有回归量和部分协变量的复杂模型，以及创建要包括在完全模型中的协变量细胞类型的拟变量。

打开数据表 VA 肺癌.jmp。第一个模型和所有的损失函数都已经创建为数据表中的公式。Model 列的公式为

 Log(Time) - B0 + b1*Age + b2*Diag Time

初始参数估计

非线性模型拟合通常对为模型参数指定的初始值很敏感。在本实例中，求合理初始值的一个方法是先只使用非线性平台拟合线性模型。模型收敛时，参数的解值就成为非线性模型的初始参数值。

要完成此操作，请选择分析 > 建模 > 非线性。将模型指定为 X，预测公式，然后单击确定，将看到非线性控制面板，如"非线性拟合控制面板中的初始参数值" 左侧所示。单击执行时，平台计算此模型的最小二乘参数估计，如右边的控制面板所示。

单击保存估计值将列公式中的参数估计设定为此非线性初始拟合过程的估计。

非线性拟合控制面板中的初始参数值

关于损失函数的估计

Weibull 列包含前面所示的 Weibull 公式。要继续拟合过程，请再次选择非线性，选择模型作为 X，预测公式列，Weibull 损失作为损失。单击确定时，将显示"带自定义损失函数的非线性模型" 左侧的非线性拟合控制面板。现在，损失函数中就有另外一个名为 sigma 的参数。因为它是一个分数的分母，所以 sigma 合理的初始值为 1。使用默认函数以外的任何损失函数时，默认情况下，控制面板上的损失为负的对数似然框为选定。单击执行时，拟合过程收敛，如右侧控制面板所示。

带自定义损失函数的非线性模型

通过最大化 Weibull 似然函数的负对数，拟合过程会估计参数。“解”表出现后，您可以单击控制面板上的置信限按钮来获得参数的置信上限和置信下限，如“解”表所示。

注：由于置信限不是标准渐进置信区间，而是侧似然置信区间，所以它们的计算需要时间。

您还可以用预定义的指数和对数正态损失函数运行模型。在拟合另一个模型之前，请将参数估计重置为最小二乘估计，否则它们可能不会收敛。

Tobit 模型实例

您还可以用非线性平台分析左删失数据。如果是左删失数据，零为删失值，因为零还表示观测值的最小已知时间。Tobit 模型常用于响应必须是正数或零的经济分析，其中零标识删失点。

Reliability 样本数据文件夹中的 Tobit2.jmp 数据表可用于演示 Tobit 模型。响应变量为一种产品的耐用性测量值，不能小于零（Durable 在零点为左删失）。Age 和 Liquidity 为自变量。表中还包括模型和 Tobit Loss 函数。残差形式的模型为 durable-b0+b1*age+b2*liquidity。Tobit Loss 具有此处显示的公式。

要运行模型，请选择非线性，然后选择模型作为 X，预测公式，Tobit Loss 作为损失，然后单击确定。出现非线性拟合控制面板时，模型参数的起始值设定为（或接近）零，损失函数的参数 Sigma 设定为 1，选定损失为负的对数似然。单击执行。如果在模型收敛后还在控制面板上单击了置信限，就会看到如下所示的“解”表。

拟合简单生存分布

下面的实例演示，在只有删失状态效应时如何使用极大似然方法估计时间删失数据的分布。Loss Function Templates 文件夹中的模板具有指数、一个和两个参数的 Weibull、极值、正态和对数正态损失函数的公式。要使用这些损失函数，请将时间值和删失值复制到损失函数模板的时间和删失列中。

要运行模型，请选择非线性，并将损失列指定为损失变量。由于响应模型和删失状态都包括在损失函数中，并且没有其它效应，因此不需要预测列（模型变量）。

指数、Weibull 和极值损失函数实例

Reliability 样本数据文件夹中的电扇.jmp 数据表演示了 Nelson (1982) 讨论的指数损失、Weibull损失和极值损失损失函数。这些数据来自一项对 70 台柴油机电扇进行的研究，其累积总使用时间为 344,440 小时。电扇是在不同的时间投入使用的。响应为电扇的失效时间或运行时间（如果删失）。此处显示了电扇.jmp 表的一部分。

"损失函数公式"显示损失函数的公式，与在公式编辑器中的一样。

损失函数公式
两个参数的指数
Weibull损失
极值损失

要使用指数损失函数，请选择非线性，选择指数损失作为损失函数，然后单击确定。在非线性拟合控制面板上，输入 1 作为 Sigma 的起始值，然后单击执行。模型收敛后，单击置信限可看到如下所示的结果。

要使用两个参数的 Weibull 损失函数或极值损失函数，请再次选择非线性和想要的损失函数。使用 1 作为 Weibull 函数中 alpha 和 beta 参数、极值函数中 delta 和 lambda 参数的起始值。结果如上所示。

注：单击执行之前，务必选定损失为负对数似然复选框。

对数正态损失函数实例

Reliability 样本数据文件夹中的机车.jmp 数据表可用于演示对数正态损失。当数据的控制范围为 10 的几次幂时，对数正态分布就很有用。表中的对数正态列具有如下公式

对数正态损失函数对其参数的起始值会非常敏感。因为对数正态与正态分布很类似，所以可以新建一个为时间以 10 为底的对数的变量，并使用分布计算此列的均值和标准差。然后，用这些值作为非线性平台的起始值。在本实例中，时间以 10 为底的对数均值为 2.05，标准差为 0.15。

按上面实例中描述的方式运行此实例。将对数正态指定为损失函数。在非线性拟合控制面板上，将 Mu 和 Sigma 的起始值分别设定为 2.05 和 0.15，并单击执行。获得解之后，可以在控制面板上单击置信限，即可看到如下所示的表。

注：请记住在要求置信限之前保存估计值。

对数正态参数的极大似然估计为 Mu 等于 2.2223 和 Sigma 等于 0.3064 （以 10 为底的对数）。对数正态分布中位数的相应估计为 2.2223 (102.2223) 的逆对数，近似于 167,000 英里。此值表示机关车引擎的典型寿命。


再现分析

再现平台

本章的重点是生存和可靠性子菜单中的最后一项，即再现分析。

再现分析可用于分析生存分析或可靠性分析的事件次数，但它们是对于每个器件都能递归多次的事件。通常，这些事件是在每个器件损坏后需要修理时发生，修理后，该器件仍会继续投入使用。这些器件将继续投入使用，直到最终停止使用。同样，再现分析可用于分析长期疾病的连续治疗数据，例如接受膀胱癌治疗的病人中的肿瘤再现。分析的目标是获得 MCF（均值累积函数），该函数将每个器件的总成本显示为次数函数，其中成本可以是修理次数，也可以是修理的实际成本。

目录

可修理系统的再现分析

发动机阀座实例

膀胱癌实例


可修理系统的再现分析

再现分析将在器件老化过程中一直跟踪修理的累积频数或成本，直到停止使用它。JMP 中的再现分析平台可生成递归事件的描述性分析。

在进行再现分析的数据中，每个事件都有一行，不再使用器件时则有一个关闭行。通常，许多器件或系统都是这样。

发动机阀座实例

典型的系统可能是引擎或设备的一些组件。例如，看一下样本数据表发动机阀座.jmp (Meeker and Escobar 1998, p.395)，该表记录了船舶的动力器件历史记录。发动机标签列标识了一个特定器件。使用年限为引擎阀座从开始使用到更换的时间。请注意，发动机标签可能包含具有期限值和服务值的多个行，表明经过了多次修理。

完成此处所示的启动对话框。

Y，事件的期限
包含修理时的期限，或不再使用器件时的期限（成本代码为零时）。这是一个必需的数值列。通常为服务时间值，而不是按年代顺序排列的期限。
分组
如果要为本列标识的各个组生成独立的 MCF 估计值，则为一个可选列。
成本，服务终止
是一个必需列，指定是修理事件（编码为 1）还是不再使用该器件时的期限（编码为 0）。大多数情况下，您可以使用正值在此输入一个成本金额，则 MCF 估计值将为修理成本，而不是修理频数。对于具有唯一系统 ID 的所有器件，此变量都只能有一行值为零，指明该器件的服务终止期限。
标签，系统 ID
是一个用于标识器件的必需列。

如果不是每个器件在表中都只有一个服务终止行（其中“花费”列单元格为零），则会收到该效应的一则错误提示消息。

单击确定时，“再现”平台将显示如"再现分析的 MCF 图和部分表" 和"发动机阀座再现分析实例的事件图" 所示的报表。MCF 图显示了均值累积函数。对于每个期限，这就是修理的估计平均成本或频数。此函数将随着器件的老化和修理总成本的上升而逐渐升高。

"再现分析的 MCF 图和部分表" 中的图形显示了一次修理事件的平均（近似）期限是大约 580 天。曲线的斜率是为上升的，表明修理成本随期限的增加而增加，尤其是在 600 天以后。

再现分析的 MCF 图和部分表

"发动机阀座再现分析实例的事件图" 中的事件图显示了各个系统的时线。每次修理后都会留下标记，直线一直延长到服务终止。例如，器件 409 只有在 389 天和 3 次修理后才停止使用。

发动机阀座再现分析实例的事件图

选项

均值累积函数图
打开和关闭均值累积函数图。
均值累积函数置信限
打开和关闭对应于均值累积函数的 95% 置信限的直线。
事件图
打开和关闭事件图。
标绘均值累积函数差异
如果有一个分组变量，此选项将创建均值累积函数差异的一个图形，包括该差异的 95% 置信区间。均值累积函数具有显著差异，其中置信区间线与零线不相交。

膀胱癌实例

此样本数据文件膀胱癌.jmp（Andrews 和 Herzberg、1985、表 45）包含来自 Veteran's Administration Co-operative Urological Research Group 的数据。所有病人都有表面膀胱肿瘤，这可在试验治疗后割除。接着，将每位病人都指定到三个治疗小组之一：安慰剂药丸、吡哆醇（维生素 B6）药丸或用噻替派进行定期化疗。以下再现分析将探索疾病的进展，以及三种治疗之间是否有差异。

使用如"膀胱癌启动对话框" 所示的选项启动平台。

膀胱癌启动对话框

结果报表显示了三种治疗的均值累积函数图。

膀胱癌均值累积函数图

请注意，这三条均值累积函数曲线本质上都是直线。因此，斜率一直保持不变，从而可作出判断，随着病情的发展，病人没有好转，也没有恶化。

要检查这些治疗之间是否有差异，请从平台下拉菜单中选择标绘均值累积函数差异命令。

均值累积函数差异

要确定各种治疗之间是否具有显著差异，请检查差异图上的置信限。如果置信限不包括零，则治疗不同。"均值累积函数差异" 中的图形显示了治疗之间看起来没有显著差异。


递归划分

划分平台

划分平台将根据 X 值与 Y 值之间的关系递归划分数据，同时创建划分树。它会查找最适合预测 Y 值的 X 值分块或分组，并通过彻底搜索所有可能的分块或分组来完成这一操作。数据的拆分型（或划分）是递归进行的，同时还会形成决策规则树，直至达到所需的拟合。

这种方法的变型具有许多名称和品牌名称：决策树、CARTTM、CHAIDTM、C4.5 和 C5 等等。这种方法一般称为数据挖掘方法，因为：

  • 它非常适于研究没有好的先验模型的关系
  • 它可以非常容易地处理大型问题
  • 所有结果均可解释清楚。

它最适于下述情况：您想要将某种疾病的症状和诊断结果数据表转换成询问新患者时使用的问题层次结构，以便进行快速的初步诊断。

因子列 (X) 可以为连续或分类的（记名或保序的）。如果 X 为连续的，则 JMP 将按切割值创建拆分（划分）。样本分成此切割值上下的值。如果 X 为分类，样本将被分成两个水平组。

响应列 (Y) 也可以为连续或分类的（记名或保序的）。如果 Y 为连续，则平台将拟合均值，并且创建多个将均值最显著区分的拆分（通过检查均值差的平方和来判定）。如果 Y 为分类的，则响应率（每个响应水平的估计概率）将成为拟合值，而最显著的拆分要由最大似然比卡方统计量来确定。总之，需要选择拆分来使该拆分的两个分支之间的响应差最大化。结果树表现出可通过机器学习的人工智能。

这是一个非常强大的平台，因为它能够检查大量可能的分块并从中挑出最佳的一个。

目录

划分图

分类响应实例

连续响应实例

平台命令

拟合优度图

实际值与预测值图

ROC 曲线

上升曲线

交叉验证

K 折叠交叉验证

排除行

使用 Fisher 的鸢尾花实例

统计的详细资料


划分图

“划分”平台会根据模型中的 y 变量是连续变量还是分类变量，显示略有不同的输出。划分报表的输出如"分类变量的划分输出" 和"连续变量的划分输出" 所示。1

分类变量的划分输出
连续变量的划分输出

每个标记均表示它所在的类别和划分中的一个响应。y 位置在 y 划分中是随机的，x 位置是随机排列，因此这些点将位于同一个矩形中但在后续分析中位置不同。

1 分类版本也称为双层图（double-decker plot) (Hoffman, 2001)。


分类响应实例

打开汽车民意测验.jmp 并调用划分命令，同时将国家作为 Y 变量，将其它列（性别、婚姻状况、年龄、汽车尺寸和车型）作为 X 变量（"“划分”平台"）。此实例的目标是调查哪些因子会影响购车国家。在启动对话框中指定 Y 列和 X 列。如果您已经预先汇总数据，则还可以使用权重或频数列。

“划分”平台

此平台最初以一个包含非缺失 y 组开始。在第一次执行拆分命令后，平台会计算将其最佳拆分成两组 X 列的一个（或组）拆分值。接下来的每个步骤均会继续进行拆分，同时选择最佳拆分。

最初，所有数据均在一个组中。为了确定第一个最佳拆分，您必须考虑所有 X 列。候选列显示在候选报表中，您可以打开和浏览此报表，看下一步要进行哪个拆分。如"初始划分报表" 所示，外型尺寸列具有最大的 G 2 值，因此是要进行的最佳拆分。

初始划分报表

单击拆分按钮，它会将整个外型尺寸列的总体分成两组：“Large”组和“Small, Medium”组。

第一次拆分后的划分

请注意，大型汽车购买者的国家与品牌比与小型和中型汽车购买者的国家与品牌比存在很大的差异。此数据是在二十世纪八十年代初收集的，当时大型汽车绝大多数都是美国品牌的汽车。

像以前一样，我们要检查一下候选项，查看下一步要进行哪个拆分。在本实例中，下一次还是要对外型尺寸变量进行拆分。

再次选择拆分，JMP 也将再次选择外型尺寸，然后将它分成一个划分中的“Small”组和另一个划分中的“Medium”组。

单击剪除按钮即可撤消最近的操作，将最近执行的拆分还原成一个组。


连续响应实例

要通过连续响应实例解释“划分”平台，请打开波士顿住宅.jmp 数据表。此数据由 Belsley、Kuh 和 Welsch (1980) 报告，来自于 1970 年进行的一次人口普查，它具有以下变量：

中位数是指住宅中位数

犯罪率是指人均犯罪率

区是指城镇的住宅用地面积超过 25,000 平方英尺的比例

产业是指每个城镇中非零售商业用地的比例

查尔斯河是一个拟变量，如果地区以 Charles River 为界，则其值为 1。

氧化氮是指每 100,000,000 平方单位中的氮氧浓度

房间数是指平均房间的平均面积

年龄是指在 1940 年前建造的自住单元的比例

距离是指距波士顿区五个就业中心的加权距离的对数

高速公路是指可达性（到达呈辐射状分布的高速公路的距离）的指数对数

税是指每 10,000 美元的全额财产的税率

学生老师比是指城镇的学生与教师比

b 等于 (B - 0.63)2，其中少数民族是指总人口中黑人所占的比例。

低收入者是指社会地位较低的人口所占比例的对数。

"波士顿住宅的初始情况" 显示了数据的初始情况，其中中位数作为 Y 变量，而其它所有变量均作为效应，这表明房间数是最佳候选项。

波士顿住宅的初始情况

在第一次拆分后，拆分所涉及的每个组上均出现一条水平线。这些线上标记拆分变量和其水平。在本实例中，拆分位于房间数变量上并且其值为 6.94。非叶节点（例如第一次拆分后“所有行”上的线）均显示为淡灰色的直线。

从根本上说，具有大中型住宅的普查片区的均值比具有中小型住宅的普查地区的均值大。

第一次拆分后

"四次拆分后" 显示了进行四次拆分后的图，其中已启用小型树视图选项。小树形视图使用的是小字体（可在 JMP 的首选项中找到），在本实例中，它已经提高到 8 像素类型。请注意，当划分中的行数较少时，可能会没有足够的空间来显示标签。此时，您可以将标签框的下角或下限向下拖动，以便提供更多的空间来显示多行的标签。

四次拆分后


平台命令

“划分”平台具有以下命令：

显示选项
提供一个包含三个菜单项的子菜单，这些菜单项用于切换报表元素。
显示点用于显示点而不显示彩色面板。
显示树用于切换较大的划分树。
显示图形用于切换划分图。
连续响应的分块具有以下两个选项。
显示分块统计量用于显示分块统计量，如 G 2 或者均值和标准差
显示分块候选项用于显示外框节点上的分块候选项，同时提供每个 X 变量的 G 2 或 SS 和对数值。
对分块候选项进行排序用于按统计量或对数值（二择其一）对候选项报表进行排序。此选项可以开启或关闭。如果关闭，则它不会更改任何报表，但平台将按指定的 X 项的顺序（不按统计量）对新的候选项报表进行排序。
具有分类响应的分块具有以下四个选项。
显示分块条形柱用于切换显示每叶中的拆分比例的彩色条形柱。
显示分块统计量用于切换显示统计量。
显示分块概率（默认情况下关闭）用于显示响应变量每个水平的概率。
显示分块候选项用于切换显示候选项外框节点。
最佳拆分
在最佳拆分点拆分树。它的作用与拆分按钮相同。
剪除最差
移除判别能力最差的终端拆分。它的作用相当于单击“剪除”按钮。
准则
提供两个拆分选项。拆分统计量最大化用于根据平方和（连续变量）或 G 2（分类变量）的原始值进行拆分。显著性最大化用于计算每个拆分候选项的显著性值，并使用这些值（而不是原始值）来确定最佳拆分。此选项为“准则”的默认选项。
在选定显著性最大化的情况下，候选项报表将包括一个名为 LogWorth 的新列。它是调整后 p 值的负对数。调整后 p 值的对数的计算方式非常复杂，需要考虑可能出现的大量不同的拆分方法。与未调整的 p 值相比，此计算是非常必要的，它偏重于计算具有多个水平的 X 变量。而 Bonferroni p 值在经过过度调整后，它偏重于计算那些水平数较少的 X 变量。有关详情，请参阅单独的技术报告。在报告中，使用的是对数尺度，因为许多显著性值很容易可用机器浮点格式表示的数据向下溢出。另外，它在报表中的值为负对数，因此较大值对应于显著项。
上述两种方法的根本差别在于：显著性最大化倾向于选择只涉及少量水平的拆分，而且与拆分统计量最大化方法相比，它还允许在具有多次机会时偶然得到显著的结果。
对于连续响应，显著性最大化倾向于选择样本内方差较小的组，而拆分统计量最大化只会考虑效应大小和样本大小，不会考虑剩余方差。
缺失值规则
一个具有两个选项的子菜单。最近选项用于将缺失值指定给响应拟合效果最佳的组。遗憾的是，“最近”选项关于拆分效果的展望总是过于乐观。随机（默认选项）用于需要对拟合优度进行更实际测量的情况。它也适用于具有多个缺失值的情况。通过随机选项，JMP 根据要拆分的划分中非缺失样本大小的概率随机指定缺失值。
最小拆分规模
显示一个对话框，您可以在其中输入全体样本大小的数值或比例数，此值将成为允许的最小拆分大小。默认值为 5。要指定样本大小的比例数，请输入小于 1 的值。要指定实际数值，请输入大于或等于 1 的值。
锁定列
显示一个复选框表，允许您交互式锁定列，以便在拆分时不考虑这些列。您可以在不影响单个锁定的情况下关闭要显示的复选框。
标绘实际值对预测值图
生成一个实际值对预测值图。
小树形视图
在散点图的右侧显示一个小型划分树。
叶报表
提供报表底层叶的均值和计数或比率。
保存列
一个子菜单，详细内容稍后介绍。
列贡献
生成一个报表，其中会显示每个输入列在拟合中的贡献，包括拆分次数以及该列的总 G 2 或平方和。
分块历史记录
显示“分块历史记录”图。此图显示 R 平方与分块次数。如果使用 K 折叠或排除行交叉验证，则会为 K 折叠 R 平方或排除 R 平方绘制单独的曲线。下图显示了带排除点的“分块历史记录”图。
K 折叠交叉验证
将所有行（非排除行）随机指定给 k 个组中的任意一个，然后使用根据所有组（该点所属的组除外）估计的均值或比率计算每个点的误差。结果为交叉验证的 R 平方。
设定点颜色
根据点的响应分类设定它们的颜色。此选项仅适用于分类预测值。为了使用户可以非常方便地访问这一实用命令，JMP 还为它提供了一个按钮。不过，一旦执行完此命令，该按钮就会被移除。
脚本
典型的 JMP 脚本子菜单，用于重复分析或将脚本保存到不同的位置。

以下命令显示在保存列子菜单中。

保存预测值
将模型中的预测值保存到数据表中。这些预测值是指连续响应的叶均值或分类响应的一组响应水平率。
保存叶数
将树的叶数保存到数据表的列中。
保存叶标签
将树的叶标签保存到数据表中。这些标签会记录行在树上跟踪的每个分支（使用“&”分隔）。前面分析中的标签可表示为“size(Small,Medium)&size(Small)”。但是，JMP 不会在重复的类别标签格式中包括多余的信息。如果某个叶的类别标签引用了更高层树节点中的类别列表，JMP 将在具有多余标签的树节点出现的位置添加一个脱字符号 (^)。因此“size(Small,Medium)&size(Small)”将表示为“^&size(Small)”。
保存预测公式
将预测公式保存到数据表的列中。此公式由一些嵌套的条件子句构成。对于分类响应，每个响应水平均有一个对应的新列。
保存叶数公式
将叶数计算公式保存到数据表的列中。
保存叶标签公式
将叶标签计算公式保存到数据表的列中。

每次拆分时，子菜单中还会出现以下命令：

最佳拆分
查找并执行此节点中或此节点下面的最佳拆分。
在此处拆分
在最佳列（拆分依据）的选定节点处进行拆分。
指定分块
让您指定要进行拆分的地方。这在证明准则是切割点的函数以及确定自定义的切割点时尤其有用。结果表具有一个表脚本，因此可以非常方便地绘制数据图。
选择此命令后，将出现下面所示的对话框。
最优值在选定变量的最优值处进行拆分。
指定值用于指定进行拆分的水平。
输出分块表生成一个数据表，显示所有可能的拆分及其相关拆分值。
指定拆分 X
允许设置 X 列作为拆分依据。您还可以指定切割值或组水平作为拆分依据。
剪除以下项
消除选定节点下的拆分。
剪除最差
查找并移除选定节点下的最差拆分。
选择行
选择与此节点对应的数据表行。
显示详细资料
生成一个用于显示选定变量的拆分准则的数据表。此数据表由拆划分间及其相关的准则值构成，还有一个可生成相应准则图的附加脚本。


拟合优度图

拟合优度图取决于使用响应的类型。

实际值与预测值图

对于连续响应，“实际值与预测值”图将显示拟合效果。每个叶均使用其均值进行预测，因此 x 坐标为这些均值。而实际值成为每个叶均值附近的散点。对角线表示预测值和实际值相等的轨迹。如果是完全拟合，则所有点都将在此对角线上。

ROC 曲线

当您累加秩排序中的频数时，ROC 曲线的经典定义中会涉及到“真阳性对假阳性”的计数。真阳性 y 轴标记为“敏感度”，假阳性 X 轴标记为“1-特异性”。其思路是如果您滑过按秩排序的预测值，并令左侧的项为阳性，右侧的项为阴性，则此曲线会跟踪预测值中的权衡。

为了推广到一分为几的情况（超过 2 个响应水平）中，“划分”平台会创建一条每个水平对其它水平的 ROC 曲线。如果只有两个水平，则一个为另一个的对角反射，同时还会根据将哪个水平视作“阳性”响应水平来显示不同的曲线。

ROC 曲线只不过是一条模型效率排序的曲线。模型首先按秩顺序对给定 Y 值的拟合概率进行排序，然后从左下角开始向右上角（如果 Y 属于另一个类别）绘制上升曲线（如果行属于该类别）。

在下图中，n1 = Y 值的个数，其中 Y = 1；n0 = Y 值等于零的 Y 的个数

如果模型非常完美地按秩顺序对响应值进行了排序，则排序后的数据将首先显示所有目标值，然后再显示其它所有值。曲线首先会一直向上移动，然后再向右移动。

完全拟合的 ROC

如果模型预测效果不好，它会按从左下角到右上角的方向在对角线周围徘徊。

实际中，曲线从对角线处开始上升。曲线下的面积是拟合优度的指标，介于 0.5（无预测值）和 1（完全拟合）之间。

如果某个划分包含全是或几乎全是一个响应水平的部分，则曲线将暂时从左侧近似竖直地上升。这就表示样本对于检测该水平几乎十分敏感。如果某个划分中不包含或几乎不包含某个响应水平，则顶部的曲线将暂时近似水平地横越。这就表示样本中确实没有该响应水平。

由于有些划分包含具有相同（即打结）预测率的行集，因此曲线实际上会倾斜，而不是纯粹的竖直或水平。

对于一分为几的情况，您会看到哪些响应类别恰好从对角线处开始上升。在前面的“汽车民意测验”实例中，欧洲生产的汽车一直比另外两个类别的汽车少得多。美国的汽车开始时使用最敏感的响应（汽车尺寸 (Large)），而日本的汽车则使用针对性最不强的响应（汽车尺寸 (Large) 在日本只有很少的份额）。

上升曲线

上升曲线显示的信息与 ROC 曲线显示的信息相同，但是它最初会展示排序的重要性。Y 轴会显示与响应水平的整体比例进行比较，该总体部分占选定响应水平的重要性比率。例如，如果拟合概率的最佳值 10% 具有选定响应 25% 的重要性，而总体的重要性只有 5%，则上升曲线将在 Y 坐标为 5 (25%/5%) 时通过 X 坐标 0.10。当总体作为一个整体具有一般响应率时，则所上升曲线都恰好达到 (1,1)。

如果出现某个类别的响应率始终非常低的情况（例如直接邮件的响应率），上升曲线将使用比 ROC 曲线更详细的方法来解释相关信息。

上升曲线


交叉验证

在“划分”平台上，实现交叉验证的方式有两种。

  • 使用 K 折叠交叉验证
  • 使用排除行。

K 折叠交叉验证

K 折叠交叉验证将所有行（非排除行）随机指定给 k 个组中的任意一个，然后使用根据所有组（该点所属的组除外）估计的均值或比率计算每个点的误差。结果为交叉验证的 R 平方。

K 折叠交叉验证报表

排除行

通常会使用数据集的一部分计算模型（训练数据集），并使用其它数据验证模型（验证数据集）。要在 JMP 中使用此方法，请选择要排除的行，并使用行 > 排除/撤消排除命令排除它们。通常，行是通过行 > 行选择 > 随机选择命令选择的，这让您可以随机选择一定百分比或一定数量的行。

如果使用排除行运行“划分”平台，报表会稍有变化，显示数据集中被包括部分和被排除部分的 R 平方。"带排除值的报表" 显示了附加报表。

带排除值的报表


使用 Fisher 的鸢尾花实例

下面显示了一个划分例证性实例，使用的是样本数据表鸢尾花.jmp。它是包含三个品种的鸢尾花测量的典型数据集。

在打开此数据集后，请选择分析 > 建模 > 划分。将种类指定为 Y 角色，将花瓣长度和花瓣宽度指定为 X 角色。此时将出现如"初始划分报表" 所示的报表。

初始划分报表

第一次拆分（"第一次拆分鸢尾花数据"）在花瓣长度 = 3 处划分数据。

第一次拆分鸢尾花数据

这是一个非常好的拆分位置，因为所有 setosa 鸢尾花的花瓣长度均小于 3，其它品种则不属于这种情况。因此，可以很好地判别此响应组。花瓣宽度对花瓣长度图（在花瓣长度 = 3 处具有一条参考线）已经清楚地说明这一情况（"花瓣宽度对花瓣长度的二元图"）。

花瓣宽度对花瓣长度的二元图

第二次拆分产生了如"第二次拆分报表" 所示的报表。

第二次拆分报表

第二次拆分在花瓣宽度 = 1.8 处划分数据。二元图再次说明了这一情况。

第二次拆分后的二元图

此次拆分是对剩余点（本例中的品种 “virginica” 和 “versicolor樱┙行的最佳划分°

第三次拆分在花瓣长度 = 5 处再次划分花瓣长度。查看二元图（"第三次拆分后的二元图"），看看为什么此次拆分的效果会如此好。

第三次拆分报表
第三次拆分后的二元图

结果是平台已将大多数数据“提炼”到某个品种占绝对优势的划分中。同时，在边界区域中还有一个各个品种混合更均匀的剩余划分。


统计的详细资料

响应可以为连续或分类的（记名或保序的）。如果 Y 为分类的，则平台会拟合响应水平的估计概率，同时使残差对数似然卡方 [2*熵] 最小化。如果响应为连续的，则平台会拟合均值，同时使误差平方和最小化。

因子可以为连续或分类的（记名或保序的）。如果 X 为连续的，则平台会按 X 的划分“切割”值进行划分。如果 X 为分类的，则平台会将 X 类别分成两个水平组，然后将所有可能的分组加到两个水平中。

准则。对于连续响应，统计量为平方和，即因拆分产生的误差平方的变化。对于分类响应，准则为似然比卡方，在报表中报告为 G^2。它实际上是 [自然对数] 熵的两倍或熵变化的两倍。熵是指每个观测值的 Σ -log(p)，其中 p 是指发生响应的概率。

选定的候选项的 G 2 为

G 2 test = G 2 parent - (G 2 left + G 2 right)。

选定的候选项的 SS 为

SStest = SSparent - (SSright + SSleft)，其中节点中的 SS 恰好为 s 2(n - 1)。

当“划分”平台在排除了数据基础砂锅内对分类响应计算 G 2 或 R 平方时，如果在某个具有 m 行的组中遇到 0 比率，它会使用比率值 0.25/m。否则，它将报告缺失统计量，因为 0 没有对数。

性能

尽管绝大多数情况下平台的速度都非常快，但是也有例外，即当分类响应的水平数超过 2 个且分类 X 的水平数超过 10 个的情况。如果 X 具有 k 个水平，则平台会搜索所有可能的拆分，共计 2k - 1。这很快就会变成一个非常庞大的数字。目前，应该避免出现这种情况。在将来的版本中，我们计划使用启发式方法来处理这种情况。

缺失值

利用缺失值规则 > 随机选项可以将缺失的 X 指定给随机组，而不指定给最佳拟合组。如果选择缺失值规则 > 最近，在 Y 缺失时，只是忽略该行。如果 X 缺失，在计算准则值时将忽略该行，但是该行将成为它要最佳拟合的组中的一部分（由 Y 值确定）。

停止规则

目前，“划分”平台完全是交互式平台。一直按拆分按钮，直到达到满意的效果。与人们期望它运行时无需人来照管且自动停止的数据采集软件包不同，“划分”平台是一个可帮助您交互式研究关系的探索性平台。


时间序列分析

时间序列平台

“时间序列”平台可用于探索、分析和预测一元时间序列。时间序列是在一系列等距时间获得的一组观测值 y 1、 y 2、 ... 、y N。从时间序列中的点图开始分析。此外，平台还显示序列自相关图和局部自相关图。这些图表示序列中的每一个点如何与序列中更早的值关联以及关联的程度有多深。您可以以交互方式添加：

方差变化图
描述过程扰动
自回归系数
自回归系数
谱密度图
相对于周期和频数，带白干扰检验。

这些图表可以用于标识适合描述和预测时间序列演变的模型类型。模型类型包括

ARIMA
自回归求和移动平均，常称为 Box-Jenkins 模型
季节调整 ARIMA
带季节成分的 ARIMA 模型
平滑模型
指数平滑和 Winter 方法的几种形式。

注：时间序列启动对话框要求将一个或多个连续变量指定为时间序列。（可选）您可以指定时间 ID 变量，用于标记时间轴。如果指定了时间 ID 变量，它必须是连续的变量，按升序排列，并且间隔平均，且无缺失值。

目录

启动平台

选择列角色

时间序列图

时间序列命令

图形

自相关

偏自相关

方差变化图

自回归系数

谱密度

保存谱密度

预测周期数

差

建模报表

模型比较表

模型汇总表

参数估计表

预测图

残差

迭代历史记录

模型报表选项

ARIMA 模型

季节调整 ARIMA

平滑模型

平滑模型对话框

简单指数平滑

双重 (Brown) 指数平滑

线性 (Holt) 指数平滑

衰减趋势线性指数平滑

季节调整指数平滑

Winters 法（加法型）


启动平台

要开始时间序列分析，请从分析 > 建模工具子菜单选择时间序列命令，显示时间序列启动对话框（"时间序列启动对话框"）。通过此对话框可以指定用于计算自相关和偏自相关的滞后数。在此也可指定将来周期数，以便使用数据拟合的模型进行预测。选择分析变量并在对话框上单击确定后，在启动的平台上指定的每个时间序列 (Y) 变量都有图形和附带文本报表。

选择列角色

在如"时间序列启动对话框" 所示的对话框中指定用于分析的列。对话框左侧的选择器列表显示了当前表中的所有列。要分配列的角色，请在列选择器列表中选择一列或更多列，并单击角色按钮。或，将变量从列选择器列表拖至以下其中一个角色框：

X，时间 ID
用于 x 轴，用于标记时间轴的变量
Y，时间序列
用于 y 轴，一个或多个时间序列变量。

要从指定角色中移除不想使用的变量，请在角色框中选择此变量并单击移除。指定角色之后，请单击确定，查看每个时间序列变量相对于时间 ID 的分析。

您可以在自相关滞后框中设置自相关图和偏自相关图的滞后个数。这是用于相关性计算的点之间的最大周期数，必须大于 1 但小于行数。最大滞后数的常用经验值为 n/4，其中 n 为观测值个数。通过预测周期数框可设置将来周期数，用于预测拟合模型。默认情况下，JMP 使用 25 个滞后和 25 个预测周期。

以下实例的数据位于 Time Series 样本数据文件夹中的系列G.jmp 表中（Box 和 Jenkins 1976）。时间序列变量为乘客数，时间 ID 为时间。

时间序列启动对话框

时间序列图

“时间序列”平台开始时是一个时间序列对时间 ID 的图（未指定时间 ID 时则为行数）（"系列G（航空旅客）数据的时间序列"）。与 JMP 中的其它图形一样，此图形也具备一些功能，如调整图形大小、用光标或笔刷工具高亮度显示点以及标记点。有关这些功能的介绍，请参阅《JMP 用户指南》。

系列G（航空旅客）数据的时间序列

默认情况下，也会显示时间序列的自相关图和偏自相关图（"自相关图和偏相关图"），但通过“时间序列”标题栏上平台弹出式菜单中的命令可隐藏它们。

下面将介绍的平台弹出式菜单也有用于显示其它图形和统计表的拟合命令和选项。


时间序列命令

时间序列名称旁边的弹出式菜单具有如下所示的命令：

此菜单中的前九个菜单项控制描述和诊断的表，通常用于确定要与序列拟合的模型的本质。

ARIMA、季节调整 ARIMA 以及平滑模型命令用于将各种模型与数据进行拟合并生成预测。您可以重复选择模型拟合命令。每个新拟合的结果都将附加到报表中。拟合第一个模型后，将在第一个模型报表的正上方插入所有模型的汇总（实例如"模型比较表"所示）。

下一节将介绍各个选项和模型似合、统计结果以及其它平台功能。

图形

“时间序列”平台先显示时间序列图，如此前"系列G（航空旅客）数据的时间序列" 中所示。平台弹出式菜单中的图形命令有一个子菜单，其中的命令可用于控制时间序列图。

时间序列图
隐藏或显示时间序列图。
显示点
隐藏或显示时间序列图中的点。
连接线
隐藏或显示时间序列图中连接点的线。
均值线
隐藏或显示时间序列图中描述时间序列均值的水平线。

自相关

自相关命令可用于隐藏或显示样本的自相关图（通常称为样本自相关功能）。此图以给定的时间或滞后间隔，描述了时间序列中所有点对之间的相关性。第 k 个滞后的自相关为

其中

其中 [image] 为时间序列中 N 个非缺失点的均值。条柱以图形方式描述了自相关。

根据定义，第一个自相关（滞后为 0）的长度始终为 1。曲线显示了两倍大滞后标准误差（± 2 倍标准误差），计算如下：

系列G 数据的自相关图如"自相关图和偏相关图" 中左图所示。您可以检查自相关图和偏自相关图，以确定时间序列是否平稳（指任何时候都有固定的均值和标准差），以及哪个模型适于拟合时间序列。

偏自相关

偏自相关命令可用于隐藏或显示样本偏自相关图。"自相关图和偏相关图" 中右图显示了系列G 数据的偏自相关函数。黑实线表示近似 95% 置信限的 ± 2 倍标准误差，其中标准误差计算为

（对于所有 k）
自相关图和偏相关图

方差变化图

方差变化图命令可用于显示或隐藏方差变化图。方差变化图测量相隔 k 个滞后点间差的方差，并将其与相隔一个滞后的点进行比较。方差变化图根据自相关计算如下

其中 r k 为滞后为 k 的自相关。"方差变化图（左侧）和自回归系数图（右侧）" 中左图显示了系列G 数据的方差变化图。

自回归系数

自回归系数命令可用于显示或隐藏自回归 (AR) 系数的最小二乘估计图。这些系数的定义将在下面给出。这些系数近似于由拟合高阶、纯自回归模型时获得的系数。"方差变化图（左侧）和自回归系数图（右侧）" 中右图显示了系列G 数据的自回归系数。

方差变化图（左侧）和自回归系数图（右侧）

谱密度

谱密度命令可用于显示或隐藏谱密度图，此图作为周期和频数的函数（"谱密度图"）。

Fourier 级数的系数的最小二乘估计

和

其中对 [image] 进行合并，构成周期图 [image] ，表示频数 f i 的密度。

其中以 1/(4πι) 对周期图进行平滑和尺度转换，构成谱密度。

Fisher's Kappa 统计量根据序列有一些周期成分的可选假设，检验序列值来自方差为 1 的正态分布的零假设。Kappa 是周期图的最大值 I(f i) 与其平均值的比率。如果虚假设为真，则观测到更大 Kappa 的概率如下

其中，如果 N 为偶数，则 q = N / 2，如果 N 为奇数，则 q = (N - 1) / 2，κ 为 Kappa 的观测值。如果此概率小于显著性水平 α，则拒绝零假设。

对于 q - 1 > 100，Bartlett's Kolmogorov-Smirnov 将正态累积周期图与区间 (0, 1) 上的均匀分布的累积分布函数进行比较。检验统计量等于累积周期图和均匀 CDF 的最大绝对差。如果超过 [image] ，则拒绝序列来自正态分布的假设。a = 1.36 陆脮 a = 1.63 分别对应于显著性水平 5% 和 1%。

谱密度图

保存谱密度

保存谱密度可用于创建一个包含谱密度和周期图的新表，其中第 i 行对应于频数 f i = 1 / N（即 1 / N 的第 i 个调和）

新数据表包含以下列：

周期
为第 i 个调和的周期 1 / f i。
频数
为调和的频数 f i。
角频数
为调和的角频数 2πf i
正弦
为 Fourier 正弦系数 a i
余弦
为 Fourier 余弦系数 b i
周期图
为周期图 I(f i)。
谱密度
为谱密度，是经过平滑的周期图。

预测周期数

预测周期数命令可用于显示一个对话框，用于重置拟合模型要预测的将来周期数。初始值在时间序列启动对话框中设定。通过此命令，所有的现有和将来预测结果都将显示周期数。

差

许多时间序列不显示固定均值。这种不平稳序列不适于使用某些时间序列模型来说明，如只带自回归项和移动平均项的时间序列模型（ARMA 模型）。但是，这些序列通常可通过对序列中的值进行差运算而变得平稳。差序列的计算如下

其中 t 为时间指标，B 为 y t = yt-1 定义的二次变换运算符。

差命令可用于计算差序列，并生成差序列的自相关图和偏自相关图。这些图可用于确定差序列是否平稳。

随后几节将介绍的几个时间序列模型提供了差操作（ARIMA、季节调整 ARIMA 模型，以及一些平滑模型）。差命令对于确定应在这些模型中指定的差阶数很有用。

选择“差”命令时，报表窗口中将显示“指定差”对话框。在此，您可指定要用于时间序列的差操作。单击确定可查看差操作的结果。通过“指定差”对话框可指定非季节差阶数 d、季节差阶数 D，以及每季周期数 s。将差阶数的值选择为零等同于不进行此类差操作。

差图的弹出式菜单选项如下：

图形
控制差序列图，与时间序列图形菜单下菜单项的功能相同。
自相关
显示或隐藏差序列的自相关。
偏自相关
显示或隐藏差序列的偏自相关。
方差变化图
显示或隐藏差序列的方差变化图。
保存
将差序列附加至原始数据表。在差流程中，丢失 d + sD 首项元素。在保存的序列中，它们以缺失值表示。


建模报表

时间序列建模命令用于将理论模型与序列拟合，并使用拟合模型来预测序列的将来值。这些命令还将生成统计量和残差，用于确定选择要使用的模型的适当性。您可以重复选择建模命令。每次选择模型时，系统都会将拟合结果报表和预测添加到平台结果中。

每个模型的拟合都以一个对话框开始，用于指定要拟合的模型的详细资料以及如何拟合模型。模型的每个通用分类都有各自的对话框，已在前面各自的章节中讨论过。通过将似然函数最大化进行模型拟合，其中使用 Kalman 过滤器计算似然函数。ARIMA、季节调整 ARIMA 和平滑模型以下列报表表开始。

模型比较表

“模型比较”表汇总了每个模型的拟合统计量。您可以使用此表来比较与同一时间序列拟合的几个拟合模型。其中每行都对应于一个不同的模型。表中的数值来自于每个拟合模型的“模型汇总”表。上面显示的“模型比较”表分别汇总了 ARIMA 模型 (1, 0, 0)、(0, 0, 1) 和 (1, 0, 1)。

模型汇总表

每个模型拟合都会生成一个“模型汇总”表，此表汇总了拟合的统计量。在下面的公式中，n 为模型中非缺失观测值的个数，k 为拟合参数的个数。

DF
拟合中的自由度数 n - k。
误差平方和
预测误差的平方和 (SSE)。SSE 的计算如下
其中 [image] 为上一步的预测值。
方差估计值
无条件平方和 (SSE) 除以自由度数，即 SSE / (n - k)。随机冲击 a t 的方差的样本估计，在"ARIMA 模型"一节有介绍。
标准差
方差估计的平方根。这是随机冲击 a t 的标准差的样本估计
Akaike 信息准则 [AIC]、Schwartz 的 Bayesian 准则 [SBC 或 BIC]
这些准则的值越小，表示拟合越好。计算方式如下：
和
R 平方

R 平方的计算方式如下

其中 [image] 、 [image] 和 [image] 为上一步的预测， [image] 为均值 y i。
注：如果模型对序列拟合得较差，则模型误差平方和 (SSE) 可能会大于总平方和，SST 和 R 平方可能会为负值。
调整 R 平方
调整过的 R 平方为
。
-2 对数似然
减去在最佳拟合参数估计中计算的似然函数的自然对数的两倍。值越小则拟合越好。
稳定
表示自回归运算符是否稳定。即， [image] 的所有根是否都在单位圆之外。
可逆
表示移动平均运算符是否可逆。即， [image] 的所有根是否都在单位圆之外。

注： phi symbol 和 θ 运算符在"ARIMA 模型"一节中定义。

参数估计表

每个选定拟合都有一个“参数估计”表，其中给出了时间序列模型参数的估计。每种类型的模型都有一组自己的参数。这些参数在时间序列模型各章节中有介绍。“参数估计”表包含以下各项：

项
列出参数名称。每种模型类型的参数都将在下面介绍。有些模型包含截距项或均值项。在这些模型中，也显示了相关的常数估计。在 ARIMA 模型的介绍中，给出了常数估计的定义。
因子（只限于季节调整 ARIMA）
列出包含参数的模型因子，只为乘法模型显示。在乘法季节模型中，因子 1 为非季节因子，因子 2 为季节因子。
滞后（只限于 ARIMA 和季节调整 ARIMA）
列出滞后度或二次后移位运算符，应用于与参数相乘的项。
估计
列出时间序列模型的参数估计。
标准误差
列出参数估计的标准误差估计，用于构建检验和置信区间。
t 比率
列出每个参数都为 0 的假设的检验统计量。它是参数估计与其标准误差的比率。如果假设为真，则此统计量近似于 Student's t 分布。查找绝对值大于 2 的 t 比率，是用于判断显著性的通用法则，这是因为它近似于 0.05 显著性水平。
p 值 > |t|
列出根据每个 t 比率计算得出的观测显著性概率。此概率为在假设为真时，纯粹由于机会获得一个绝对值大于计算值的 t 比率的概率。低于 0.05（或有时低于 0.01）的值通常解释为参数与 0 有显著差异的证据。

对于包含截距项或均值项的模型，“参数估计”表还给出了常数估计值。在"ARIMA 模型"给出了常数估计的定义。

预测图

每个模型都有自己的预测图。预测图显示了模型为时间序列预测的值。它由一条垂线分为两个区域。在分隔线的左侧，显示了上一步的预测，其中叠加了输入数据点。在分隔线的右侧，为模型预测的将来值以及预测的置信区间。

您可以通过在平台启动对话框中更改预测周期数框的设置，或从“时间序列”下拉菜单中选择预测周期数，来控制预测值的个数。使用模型弹出式菜单中的显示点命令和显示置信区间命令，可打开或关闭数据和置信区间。

残差

输出结果残差部分下方的图形根据模型拟合显示了残差的值。这些值为减去上一步的预测值后得到的实际值。此外，还显示了这些残差的自相关和偏自相关。这些可用于确定模型拟合是否适于描述数据。如果适合，对于大于 0 的滞后数，残差图中的点应当关于 0 线呈正态分布，残差的自相关和偏自相关应当没有任何显著成分。

迭代历史记录

模型参数估计是一个迭代程序，在此过程中通过调整参数估计实现对数似然的最大化。请求的每个模型的迭代历史记录显示了每个迭代的似然函数的值。这对于诊断拟合程序中的问题非常有用。试图拟合不适于数据的模型会导致大量的迭代，从而不能在似然的最佳值处收敛。“迭代历史记录”表显示了以下数量：

迭代
列出了迭代数。
-2 对数似然
列出每一步 -2 倍对数似然的值。
步骤
列出迭代步骤类型。
目标值 - 准则
列出每一步对数似然的因子变化。

模型报表选项

请求的每个模型的标题栏在右侧都有显示的弹出式菜单，其中该模型有以下选项：

显示点
隐藏或显示预测图中的数据点。
显示置信区间
隐藏或显示预测图中的置信区间。
保存列
创建新数据表，其中的列表示模型结果。
残差统计量
控制显示模型的残差统计量图。这些图在"时间序列命令"一节有介绍；但是，它们应用于残差序列（上一步模型预测值减去输入序列）。


ARIMA 模型

自回归求和移动平均 (ARIMA) 模型根据时间序列的过去值和误差序列（也称为随机冲击或更新）的线性组合，来预测其将来值。ARIMA 命令会对时间序列执行指定 ARIMA 模型的最大似然拟合。

对于响应序列 [image] ，ARIMA 模型的通常形式为：

其中
t 为时间指标
B 为 B 为后移位运算符，定义为
为求差后的响应序列
μ 为截距项或均值项。
和 [image] 分别为自回归运算符和移动平均运算符，记为
和
为随机冲击序列。
假定 [image] 为独立正态分布，均值为 0 且方差为常数。模型可记为
其中常数估计值 δ 由关系式 [image] 给出。

ARIMA 命令会显示“指定 ARIMA 模型”对话框，此对话框可用于指定要拟合的 ARIMA 模型。单击估计时，会显示结果。

使用“指定 ARIMA 模型”对话框，可为 ARIMA 模型指定以下三种阶数：

  1. 自回归阶数为多项式 [image] 运算符的阶数 (p)。
  2. 差阶数为差运算符的阶数 (d)。
  3. 移动均值阶数为差运算符 [image] 的阶数 (q)。
  4. ARIMA 模型通常表示为 ARIMA(p,d,q)。如果 p、d 或 q 任何一个为 0，则将丢弃相应的字母。例如，如果 p 和 d 为 0，则模型表示为 MA(q)。

置信区间框可用于为预测置信限设定 0 和 1 之间的置信水平。截距复选框用于确定截距项 μ 是否为模型的组成部分。如果选定了约束拟合复选框，则拟合程序会将自回归参数约束为始终保持在稳定区域，将移动平均参数约束在可逆区域。如果拟合器在查找真正最佳值有困难，或想加快拟合，则可以撤消选定此复选框。您可以选定“模型汇总”表，查看生成的拟合模型是否稳定和可逆。


季节调整 ARIMA

在季节调整 ARIMA 建模的情况下，差、自回归和移动平均运算符为季节和非季节多项式的积：

其中 s 为季节中的周期数。系数的第一个指标为因子编号（1 表示非季节，2 表示季节），第二个指标为项的滞后。

选择季节调整 ARIMA 命令时，将显示“季节调整 ARIMA”对话框。此对话框有着与 ARIMA 对话框相同的元素，并添加了其它元素，用于指定季节自回归阶数 (P)、季节差阶数 (D)，以及季节移动平均阶数 (Q)。同时，通过每季周期数框也可指定每季的周期数 (s)。季节调整 ARIMA 模型表示为季节 ARIMA(p,d,q)(P,D,Q)s。


平滑模型

JMP 提供了各种平滑技术。

平滑模型表示时间序列按照模型的变化：

其中
为时变均值项，
为时变斜率项，
为其中一个时变季节项，
为随机冲击。

无趋势模型具有 [image] ，非季节模型则有 [image] 。这些时变项的估计量为

平滑水平，用于估计
平滑趋势，用于估计
对于 [image] ，为 [image] 的估计。

每个平滑模型都定义了一组再现平滑方程式，用以描述这些估计量的变化。平滑方程式以称为平滑权重的模型参数表示。这些参数是

α，水平平滑权重
γ，趋势平滑权重
φ，趋势衰减权重
δ，季节平滑权重。

当这些参数以不同方式输入每个模型（或根本不输入）时，它们都有共同的特性，即较大的权重对当前数据影响较大，而较小的权重对当前数据影响较小。

每个平滑模型都有一个等效的 ARIMA 模型。这些 ARIMA 等效模型用于估计平滑权重和提供预测。您可能不能使用 ARIMA 命令指定等效 ARIMA 模型，因为有些平滑模型本身以 ARIMA 命令不允许的方式约束了 ARIMA 模型参数。

平滑模型对话框

当选择了其中一条平滑模型命令时，在报表窗口中将出现“平滑模型”对话框。

置信区间框可用于为预测置信限设定置信水平。用于季节平滑模型的对话框包括一个每季周期数框，用于设定季节中的周期数。通过此对话框还可指定在拟合过程中要用于平滑权重的约束类型。约束包括：

0 到 1
将平滑权重值保持在 0 到 1 范围内。
无约束
允许参数范围自由变动。
稳定可逆
约束参数，从而让等效 ARIMA 模型保持稳定和可逆。
定制
展开对话框，允许对个体平滑权重设定约束。

每个平滑权重可以为界限、固定或无约束，具体由权重名称旁边弹出式菜单的设置确定。

此实例中水平权重 (α) 固定在 0.3，趋势权重 (γ) 的界限为 0 和 1。在这种情况下，趋势权重的值可在 0 到 1 范围内变动，而水平权重保持在 0.3。请注意，您可以使用这些自定义约束提前指定平滑权重。在那种情况下，尽管仍然会计算预测和残差，却不会根据数据估计任何权重。单击估计时，对话框将关闭，显示拟合结果。

简单指数平滑

简单指数滑模型为 [image] 。

平滑方程式 L t = αy t + (1 -α)L t-1 是根据单个平滑权重 α 定义的。此模型与 ARIMA(0, 1, 1) 模型等效

其中

此模型的移动平均形式为

双重 (Brown) 指数平滑

双重指数平滑模型为 [image] 。

平滑方程式以单个平滑权重 α 定义，为

和

此模型与 ARIMA(0, 1, 1)(0, 1, 1)1 模型等效

其中

此模型的移动平均形式为

线性 (Holt) 指数平滑

线性指数平滑模型为

平滑方程式以平滑权重 α 和 γ 定义，为

和

此模型与 ARIMA(0, 2, 2) 模型等效

其中 [image] 且

此模型的移动平均形式为

衰减趋势线性指数平滑

衰减趋势线性指数模型为

平滑方程式以平滑权重 α、γ 和 φ 定义，为

和

此模型与 ARIMA(0, 1, 2) 模型等效

其中 [image] 且

此模型的移动平均形式为

季节调整指数平滑

季节调整指数平滑模型为

平滑方程式以平滑权重 α 和 δ 定义，为

和

此模型与季节调整 ARIMA(0, 1, 1)(0, 1, 0)S 模型等效，其中定义了

、 [image] 及

因此

其中

、 [image] 且

此模型的移动平均形式为

其中

Winters 法（加法型）

Winter 法的加法型版本的模型为

平滑方程式以权重 α、γ 和 δ 定义，为

、 [image] 和

此模型与季节调整 ARIMA(0, 1, s+1)(0, 1, 0)s 模型等效

此模型的移动平均形式为

其中


项目响应原理

项目分析平台

项目响应原理 (IRT) 是一种计分检验方法。尽管传统的检验理论方法在过去一个世纪中得到了广泛的应用，但 IRT 却能够提供更好、更科学的计分过程。其优点包括：

  • 在项目层对检验进行计分，能够深入了解每个项目对整体检验得分的影响。
  • 采用相同的尺度同时生成检验员和检验项目。
  • 拟合非线性逻辑曲线，比传统的线性统计模型更能体现实际的检验性能。

目录

项目响应原理简介

启动平台

项目分析输出

特征曲线

信息曲线

对偶图

平台命令

技术细节


项目响应原理简介

心理测量是指定数量值来表示个体或对象特性的过程，因此也称为心理构建。测量原理由用于确定上述数量值的规则组成。项目响应原理 (IRT) 就是一种测量原理。

IRT 可以利用数学函数将个体对某个项目的正确响应概率与该个体的特质相关联。通常情况下，此类特质无法直接度量，因此也被称为潜在特质。

要了解 IRT 如何将特质与概率关联，请首先考虑 Guttman 的“完美度量表”的检验问题，如"完美度量表项目的项目特征曲线" 所示。水平轴表示受试者具有的理论特质量。垂直轴表示受试者正确回答该项目的概率。"完美度量表项目的项目特征曲线" 中的曲线也称为项目特征曲线 (ICC)。

完美度量表项目的项目特征曲线

此图表明能力值低于 b 的人正确回答该项目的机会为零，特质水平高于 b 的人正确回答项目的机会为 100%。

当然，这是一个不现实的项目，但它却直观地显示了特质与问题概率的关联方式。概率可以在零至一之间变化的曲线更具代表性。经验发现，典型的曲线是 S 形的逻辑函数，它的下渐近线为 0 而上渐近线为 1。它表现出明显的非线性。"项目响应曲线实例" 给出了曲线一个例子。

项目响应曲线实例

逻辑斯蒂模型是对此曲线建模的最佳选择，因为它具有所需的渐近特性，而在计算方面比其它可能的模型（如累积正态密度函数）更易于处理。模型本身为：

在这个被称为 3PL（三参数逻辑斯蒂）的模型中，变量 a 表示参数曲线在拐点处的陡度。"不同 a 值的逻辑斯蒂模型" 显示了具有不同 a 值的曲线。此参数可以解释为某个项目的判别度量，即与低特质水平的人相比，该项目对高特质水平的人带来的困难程度。如果 a 值非常大，模型实际上就成为了阶梯函数，如"完美度量表项目的项目特征曲线" 所示。通常情况下，我们假定随着受试者特质水平的提高，他们正确回答项目的概率也增加。因此，我们假定 a 为正数且 ICC 呈单调递增。我们有时还会在项目适合性检验中使用曲线的正数 -- 递增特性。曲线形状不是这样的项目应视为检验不合格的候选人。

不同 a 值的逻辑斯蒂模型

更改 b 值只会将曲线从左边移至右边，如"不同 b 值的逻辑斯蒂曲线" 所示。它与 P(θ)=0.5 时的 θ 值对应。因此，参数 b 可以解释为项目难度，根据图形，高难度项目的拐点位于沿 x 坐标轴的较远右。

不同 b 值的逻辑斯蒂曲线

请注意

因此，c 表示下渐近线（可为非零）。"多个 c 值的逻辑斯蒂模型" 所示为不同 c 值的 ICC。理论上，c 是一个令人满意的参数，因为不具备该特质能力的人正确回答项目的机会为零。因此，有时也将 c 称为伪猜测参数。

多个 c 值的逻辑斯蒂模型

通过改变三个参数，我们能获得多种用于建模的概率曲线。"三个项目特征曲线" 所示为三种不同 ICC 的例子。请注意，下渐近线会有所不同，而上渐近线相同。这是因为假设了可能存在猜测下渐近线，但随着特质水平的提高，理论上始终存在 100% 正确回答项目的概率。

三个项目特征曲线

但请注意，在许多情况下都无需使用 3PL 这样的复杂模型。例如，如果 c 参数被限制为零（在实践中这是合理的限制），则要预测的参数较少。这种仅估计 a 和 b 参数的模型称为 2PL 模型。

2PL 模型的另一个优点（除了比 3PL 稳定外）在于它可以将 b 解释为受试者具有 50% 正确回答项目机率的点。此解释对于 3PL 模型不成立。

如果研究者可以假定所有检验项目具有同等的区分能力，则可以对通用模型进行进一步的限制。在这些情况下，参数 b 被设定为零（实质上就是从模型中排除该参数），保留一个要估计的参数。1PL 模型通常也称为 Rasch 模型，此名称源于其发明人丹麦数学家 Georg Rasch。Rasch 模型非常出色，而且计算成本十分低廉。


启动平台

例如，打开样本数据文件数学理科教育调查.JMP。这些数据是 1996 年举行的第三次数学和科学教学比较研究项目 (TIMMS) 数据的一部分。

要启动“项目分析”平台，请选择分析 > 多元方法 > 项目分析。这样将显示"项目分析启动对话框" 所示的对话框。

项目分析启动对话框
Y，检验项目
是检验中所提处的问题。
标签
（可选）指定在报表中用于标记各个点的变量。
依据
对指定变量的每个水平单独执行分析。

从模型下拉菜单中选择所需的模型（1PL、2PL 或 3PL）。

在本例中，请将全部十四个问题（问题1、问题2、... 和问题14）指定为 Y，检验项目，然后单击确定。这样将接受默认的 2PL 模型。

有关 3PL 模型的特别提示

如果选择了 3PL 模型，弹出的对话框将询问您 c 参数（阈值）的罚则。这并不是在询问阈值本身。所要求的罚则类型类似在岭回归或神经网络中看到的罚参数。

罚则基于估计阈值的样本方差，因此，较大的罚则将使估计阈值彼此更加接近。这样有助于加快计算，同时减少阈值的变异性（但会产生某些偏差）。

如果项目为多选检验问题，其中每个问题的可能响应数相同，则通常有理由相信（先验）每个项目的阈值参数均相似。例如，如果对 20 个问题的多选检验结果进行分析，其中每个问题都有四个可能的响应，那么可以认为猜测参数（或阈值）将全部为 0.25。因此，在某些情况下，除计算优势外，应用此类罚则还可以提供“物理直觉”支持。


项目分析输出

“项目分析”报告中将给出以下图形。

特征曲线

每个问题的项目特征曲线显示在输出的顶部。最初，所有曲线都堆叠显示在单个列中。通过使用报表标题栏下拉菜单中的交叉图数命令，您可以重新排列这些曲线。如"成分曲线" 所示，设置的连续图数为四。

成分曲线

在每条曲线的拐点处都绘制了一条垂直的红线。此外，图中还按每个能力水平的实际比例绘制了一些点，为判断拟合优度提供图形方法。

灰色的信息曲线显示了每个问题对总检验信息提供的信息量。信息曲线为 ICC 曲线的斜率，在拐点时值最大。

ICC 显示的元素

信息曲线

问题为不同的能力水平提供的信息水平也不同。每个项目的灰色信息曲线显示了每个问题对总检验信息提供的信息量。报表的“信息图”显示了整个能力范围内的总检验信息（"信息图"）。

信息图

对偶图

从 IRT 模型的项目难度参数中获取的信息可用于构建问题的递增尺度（由易到难），与受试者的尺度相同。此结构可以提供与低水平特质关联的项目信息，以及与高水平特质关联的项目信息。

JMP 可以通过对偶图来显示该对应关系。本例的对偶图如"对偶图" 所示。

对偶图

在对偶图中，问题被标绘在垂直虚线左侧，而受试者则标绘在虚线右侧。此外，图形的右侧还附加了一个能力水平的直方图。

本例展示了较宽的能力范围。Q8 被定为困难，受试者几乎要超出均值三个标准差才能达到 50% 正确回答问题的机率。其它问题分布在较低的能力水平，其中 Q3 和 Q10 最容易。

相应的参数估计值显示在对偶图的下方，如"参数估计值" 所示。

参数估计值
项目
标识检验项目。
难度
是模型中的参数 b。难度估计值的旁边同时显示难度参数的柱状图。
判别
是模型中的参数，只有 2PL 和 3PL 模型会显示该参数。判别估计值的旁边同时显示判别参数的柱状图。
阈值
是模型中的参数 c，只有 3PL 模型会显示此参数。阈值估计值的旁边同时显示阈值参数的柱状图。


平台命令

报表标题栏的下拉菜单中包含以下三个命令：

连续图数
可以显示一个对话框，用于指定要在一条线上分布的图形数量。最初，所有图形均将堆叠显示。 上的"成分曲线" 显示了四个连续的图形。
保存能力公式
在数据表中创建一个新的列，其中包含用于计算能力水平的公式。由于能力水平被存储为公式，因此您可以在数据表中添加行，并通过存储的能力估计值对它们评分。此外，您还可以运行多个模型，并在同一个数据表中存储多个能力估计值。
被测者的能力可通过 IRT Ablilty 函数计算。该函数的组成如下：
 IRT Ability (Q1, Q2,...,Qn, [a1, a2,..., an, b1, b2,..., bn, c1, c2, ..., cn]);
其中，Q1, Q2,...,Qn 是数据表中用于存放项目的列，a1, a2,..., an 是对应的难度参数，b1, b2,..., bn 是项目的对应判别参数，c1, c2, ..., cn 是对应的阈值参数。请注意，这些参数应作为矩阵输入，其两边需添加方括号。
脚本
可以访问用于重新计算分析的标准脚本菜单。


技术细节

请注意，P(θ) 并不一定表示某个特定个体的正响应概率。很可能存在以下情况：受试者明确选择了错误的答案，或根据受试者先前的经验和知识确定知道某个答案，而与特质水平无关。将 P(θ) 当作能力水平为 θ 的一组个体将更为合适。换言之，如果特质水平相同的一大组个体回答了项目，P(θ) 将预测回答正确的个体的比例。这意味着 IRT 模型是项目不变式；理论上，无论检验的组如何，模型的参数都相同。

这些 IRT 模型的假设前提是潜在特质具有线性。也就是说，问题所度量的潜在特质只有一个，而在理论上则可以在连续集上进行度量。此连续集是曲线图中的水平轴。如果要测量多个特质，且每个特质之间存在复杂的交互，则不适合使用这些一维模型。


条形图、线形图和饼图

图表平台

图形菜单（或工具栏）中的图表命令可以为指定的每个数值型变量绘制统计量图。您也可以在“JMP 起始页”窗口中使用图形选项卡中的图表按钮来启动“图表”平台。图形 > 图表可以为分类变量 X 的每个水平创建一个条形柱，同时对计数或统计量制图（如有需要）。您最多可以将两个 X 变量用作类别。X 值始终都将被视为离散值。

目录

条形图、线形图、针状图、点图和饼图

启动对话框

附加角色

分组变量

制图选项

设定图表中条形柱的颜色

单个图选项

单个水平选项

平台选项

实例

对单个统计量制图

标绘多个统计量的线形图

使用两个 X 变量对多个统计量制图

绘制堆叠条形图

生成饼图

创建控制范围图


条形图、线形图、针状图、点图和饼图

图形菜单中的图表命令可以为指定的每个数值型变量的统计图或计数图。如果指定了某个统计量，图形 > 图表命令将计算要求的统计量，同时为分类变量 X 的每个水平创建一个条形柱。如果没有要求统计量，JMP 将使用 Y 值的计数来创建图表。您最多可以将两个 X 变量作为类别。如果没有指定 X 变量，JMP 将为数据表的每一行标绘一个条形柱。所有的 X 值始终都将被视为离散值。

启动对话框

选择了图表命令，您首先将看到图表启动对话框（"图表启动对话框"）。您可以在该对话框中指定：

  • 最多两个 X 变量，这些变量将按其在对话框中的顺序显示在 X 轴上
  • 任意数量的数值型 Y 变量。如果是已经汇总的数据，请选择数据作为统计量选项。
图表启动对话框

对话框左侧的制图选项允许您选择图表的方向：垂直或水平。您还可以选择图表类型条形图、线形图、饼图、针状图和点图。在显示图表后，您仍可以随时更改这些选项。（请参阅"单个图选项"）。

制图选项

类别, X, 水平

您最多可以选择使用两个 X 变量，其水平将作为 x 轴上的类别。“图表”平台可以为 X 变量的每个水平或水平组合生成一个条形柱。如果没有指定 X 变量，则数据表中的每一行都将在图表中显示为一个条形柱。

顺序

默认情况下，“图表”平台将按字母数字顺序排列条形柱。但是，如果分组列具有“行顺序水平”列性质，则水平将按该顺序排列。如果分组列具有“值排序”列性质，则按该顺序排列。如果同时定义了“行顺序水平”和“值排序”性质，则优先采用“行顺序水平”性质。

制图计数

您可以指定 X 变量但不需指定 Y 变量。在这种情况下，JMP 将生成条形图，其中显示的是指定 X 变量的每个水平的计数。在以下使用大班样本数据的实例中，年龄被指定为类别, X, 水平变量。此外，没有指定任何统计变量。最终得出的图表将显示每个年龄组中的人数。

两个 X 变量

如果指定了两个 X 变量（没有统计变量），则 JMP 将根据这两个 X 变量所包含的水平对数据分组，然后标绘出每个组中的成员数。在以下实例中，这两个 X 变量为年龄和性别（按此顺序）。由于性别处于第二位，因此它被置于年龄分组当中。

Y 变量统计量

以上两个实例中均未使用统计量。但是，您可以在 y 轴上标绘任意多的统计量。启动对话框中的统计量弹出式菜单将列出可供选择的统计量。要指定 y 轴，请在变量选择列表中高亮度显示一个或多个数值列，然后从统计量列表中进行选择。要标绘的统计量随后将出现在对话框右侧的统计量列表中（请参阅"图表启动对话框"）。如果同一列的所有要求统计量为计数统计量（如 N），则该列为默认的 X。

举一个简单的例子，我们现在来根据学生的年龄组来标绘他们的平均身高。要完成此操作，请

  1. 选择年龄，然后单击类别, X, 水平
  2. 选择高度并单击统计量。从可供选择的统计量下拉列表中选择均值。
  3. 单击确定。

这样即可生成下图。

注：请记住，默认情况下“图表”平台将为数据表中的每一行标绘一个条形柱。因此，如果忘记将年龄作为类别, X, 水平，您将获得如下所示的图表。

如果启用了叠加选项（位于平台下拉菜单中），多个统计量（Y 变量）将显示为并排的分类变量水平条形柱，如下所示。此处的实例显示了分类变量类型的平均销售额和平均利润。如果未启用叠加选项，则系统将显示两个单独的图表。

此外，您也可以将多个 Y 统计量与多个类别, X, 水平变量进行组合。

下面介绍“图表”平台中的可用统计量。这些统计量与通过分析菜单中的统计平台以及表菜单中的汇总命令计算出的统计量相同。

数据
如果没有分类变量，则对数据表中每一行的值制图。如果有分类变量，则数据将在其水平范围内生成点图。
数目
是非缺失值的数量，可在未指定任何列作为权重变量的情况下用于计算统计量。“图表”平台将为每个分类变量水平显示 N。
合计 %
是分类值的每个水平包含的行数所占总行数的百分比。
缺失项数
是每个分类变量水平中缺失值的数量。
最小值
是分类变量的水平中的最小值，不包括缺失值。
最大值
是分类变量的水平中的最大值。
权重和
是在启动对话框中指定了“权重”角色的列中所有值的总和，用于代替 N 来计算其它统计量。图表将显示每个分类变量水平的权重变量总和。
总和
是每个分类变量水平中所有值的总和。
均值
是某列中值的算术平均值。均值等于非缺失值的总和除以非缺失值的数量。
方差
是为每个分类变量水平计算得出的样本方差。
标准差
是为每个分类变量水平计算得出的样本标准差。标准差等于水平值方差的平方根。
标准误差
是每个分类变量水平的均值所具有的标准误差。标准误差等于每个水平的标准差除以 N 的平方根。如果为某个列指定了权重变量，则分母应为权重和的平方根。
极差
是每个分类变量水平中最大值与最小值的差值。
中位数
是每个分类变量水平中的中间值。该水平中有一半的值大于或等于中位数，而另一半则小于中位数。
分位数
可以划分数据集，因此 n% 的数据将位于第 n 个百分位数之下。要计算特定分位数，在从菜单请求分位数之前，请在“图表”启动对话框（请参阅"图表启动对话框"）左下角的文本框中输入分位数值。

附加角色

打开“附加角色”外框节点，您就可在启动对话框中找到以下选项。

分组变量

如果存在一个或多个分组变量，则“图表”平台将为每个分组变量水平或水平组合生成单独的结果。这些结果将显示在同一窗口的不同图形中。例如，使用如下设置可生成以下的图表：

  • (Y) 统计量：均值（高度）
  • 类别, X, 水平：年龄
  • 组：性别

您也可以选择多个分组列。以下实例使用样本数据表汽车民意测验.jmp，其设置如下：

  • (Y) 统计量：均值（年龄）
  • 类别, X, 水平：性别
  • 组：婚姻状况和国家

按期望使用多个 X 进行分组。图表的周围显示了多个组标签，而多个 X 使得图表被划分为不同的部分。

  • (Y) 统计量：均值（年龄）
  • 类别, X, 水平：性别
  • 组：婚姻状况和国家

如果有多个统计量，默认情况下将选定叠加选项，并且每个分组变量水平都将叠加（即标绘在同一个图上）Y 变量（统计量），如下图所示。

分组变量的水平无法叠加到相同的图形框架中。本例中的组包括 M 和 F，叠加选项不能用于叠加 M 和 F 图形。要得到此类结果，请使用类别, X, 水平代替分组变量。

依据变量

依据变量将在单独的外框节点位置创建图形。请比较以下两个图表，它们均以年龄作为类别, X, 水平创建所得。其中一个图使用了依据角色，而另一个图使用了组角色。


制图选项

“启动”对话框以及平台弹出式菜单中的选项允许您选择各种图表选项。平台选项将影响报表窗口中的所有图表。但是，许多选项都可应用到单个图中（单图选项），如下所述。

设定图表中条形柱的颜色

条形柱可交互着色，或在创建图表后自动着色。

  • 要手动设定所有条形柱的颜色，请确保未选定任何条形柱，然后选择 Y 选项 > 水平选项 > 颜色，再从调色板中选择颜色。
  • 要设定单个条形柱的颜色，请选定图表中的条形柱，然后选择 Y 选项 > 水平选项 > 颜色，再从调色板中选择颜色。
  • 要自动为水平分配颜色，请为值颜色列性质分配颜色，可通过列 > 列信息对话框进行访问。

单个图选项

您可以将此处显示的弹出式菜单中的选项应用到单个图表中。如果只有单个图表，请使用鼠标右键单击图形框架，以便查看此处显示的弹出式菜单。如果叠加选项已生效，请使用鼠标右键单击单个图表的图例文字以查看菜单。如果是通过平台弹出式菜单访问此菜单，并且没有高亮度显示任何图例，则命令将应用于所有图表。

条形图
为图表变量的每个水平显示一个条形柱。默认的图表为条形图。
线形图
用线形图代替了条形图，由直线连接各个点。您还可以选择显示点选项来显示或隐藏图中的点。线形图还可以用作平台选项，以便同时应用于所有图表。
针状图
将所有条形柱替换为从坐标轴垂直连接到标绘值的直线。针状图还可用作平台选项，以便同时应用于所有图表。
点图
仅显示标绘的点而不连接它们。
显示点
在线形图或针状图中显示或隐藏点标记。
连接点
显示或隐藏连接各点的直线。
标准误差条
在均值图中显示或隐藏标准误差条。请注意，此选项仅适用于有关变量均值的图形。
叠加颜色
为统计量（y 轴）指定颜色。在与其它图表重叠的情况下，这样将有助于标识其点。
叠加标记
为统计量指定标记，以便在叠加图中标识它们，如下所示。
画笔样式
允许您从选用区中选择线型，如下所示。

作为有关这些选项的实例，请打开股票价格.jmp。其中的变量表示了一段时期内的日期和股价。请注意，变量年周是一个通过计算得出的列，它表示了单个变量中的年份和星期。显示该数据最理想的图形是控制范围图，它可以显示每种股票的最高价、最低价和收盘价。如果某些周中的多个日期都存在数据，系统将标绘其平均值。

使用数据表附带的 JSL 脚本图表可以重新生成图形。

 Chart(X( :年周), Y(Mean( :最高价), Mean( :最低价), Mean( :收盘价)), Range Chart(1), Y[3] << Connect Points(1))

脚本还可以显示图中使用的统计量和选项 — 作为 Y 变量的最高价、最低价和收盘价均值以及作为 X 变量的年周，并且启用了控制范围图和连接点选项。

单个水平选项

您可以单击图形中某个水平的图例，以便将其呈高亮度显示。如果使用鼠标右键单击高亮度显示的图例，屏幕将显示可用于访问颜色和标记选用区的命令；这些命令只会影响选定的水平以及它在数据表中相关联的行。


平台选项

在图表启动对话框中指定图表变量并单击确定后，所显示图表的平台弹出式菜单中包含了多个选项。

叠加图
在具有多个 Y 变量（统计量）时显示单个叠加图。您可以为单个图表指定图表类型并叠加这些图表。例如，如下所示的图表包含了三个叠加变量；其中两个为条形图，另一个为线形图。如果未选定叠加，平台将为每个图表显示双轴符号。默认情况下，如果图表未叠加，则只有显示的最后一个图表才会显示轴符号。
垂直图、水平图
可以将水平条形图或饼图更改为垂直条形图（垂直），或者将垂直条形图或饼图更改为水平条形图（水平）。
饼图
可以将水平或垂直图类型更改为饼图。
控制范围图
可以显示控制范围图。有关控制范围图的实例，请参阅"创建控制范围图"。
堆叠条形柱
可以将条形柱按子组水平进行首尾堆叠。要使用此选项，您需要两个类别, X, 水平变量和一个统计量。有关堆叠条的实例，请参阅"绘制堆叠条形图"。
Y 选项
允许您选择之前在"单个图选项"中介绍的选项。这些选项将影响图例已呈高亮度显示的图表。
水平选项
允许您选择之前在"单个图选项"中介绍的颜色和标记选项。这些选项将影响呈高亮度显示的条形柱。
标签选项
允许您在图形中附加标签。在标签选项菜单中，前两个选项（显示标签和移除标签）可用于显示或隐藏标签。最后三个选项（按值标记、按总值的百分比标记和按行标记）可以指定要显示的标签。但每次只能显示一个标签。
粗连接线
可以将线形图中的连接线切换为粗线条或细线条。
显示 Y 图例
可以显示图形的 Y 图例。默认情况下，系统会为叠加图启用此选项。
显示水平图例
可以显示图形中水平的图例。默认情况下，系统会为单个图启用此选项。
单独轴
如果存在多个图表，则在每个图表中重复轴符号。默认情况下，如果图表未叠加，则只有显示的最后一个图表才会显示轴符号。
撤消图形分组
为指定分组变量的每个水平创建单独的图表。
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件。


实例

下面的章节给出了不同的 X 变量与 Y 统计量组合的实例。这些实例使用 Sample Data 文件夹中的财务.jmp 和公司.jmp 数据表。

对单个统计量制图

如果没有在类别, X, 水平框中为 x 轴上的类别指定变量，则大多数统计量都会为数据表中的每个观测值生成一个条形柱。在这些情况下，您通常可以指定数据作为要标绘的统计量。每个条形柱都将反映 Y 变量的值，如下所示。

标绘多个统计量的线形图

要对多个统计变量制图，请在变量选择器列表中高亮度显示变量，然后从统计量弹出式菜单中选择所需的统计量（请参阅"图表启动对话框"）。

对要在同一图表中查看的其它统计量继续执行此过程。如果分析中适用，您也可以选择 X 变量。如果没有用于分组的 X 变量，“图表”平台将为数据表中的每个行提供一个条形柱或点。

从平台下拉菜单中选择 Y 选项 > 线形图，以便显示右侧显示的实例。

X 变量与两个统计量的叠加条形图和线形图

如果没有选定叠加而是选择了条形图，则条形图将在窗口中垂直排列，如"多个响应的垂直和叠加条形图" 所示。

使用两个 X 变量对多个统计量制图

下一实例中使用了 Sample Data 文件夹中的公司.jmp 表，其中显示了两个分类变量。此表同时包含公司类型（类型）和公司大小（公司大小）两个 x 变量。如果在图表启动对话框中选择了两个类别, X, 水平变量，那么第二个变量将构成子组。“图表”平台将为每个分组变量水平中的每个子组变量水平生成一个图表。子组图表将并排显示每个 Y，如"多个响应的垂直和叠加条形图" 中左侧的图表所示。如果使用了叠加选项，则会生成右侧的图表。Y 变量将显示在公共轴上，并为每个子组生成一个叠加条形图。

多个响应的垂直和叠加条形图

绘制堆叠条形图

如果有两个 X 水平和单个 Y 变量，则可以从平台菜单选择堆叠条形柱命令来堆叠条形柱。例如，创建以均值（销售($M)）为 Y 变量、类型和公司大小为 X 变量的图表。在显示图表后，从平台菜单中选择堆叠条形柱。这样将产生如"堆叠条形图" 所示的图表。

堆叠条形图

生成饼图

有两种方法可以生成饼图。

  4. 在启动对话框中，从图表类型列表中选择饼图
  5. 从平台下拉列表中选择饼图

例如，使用公司.jmp 时，请选择图形 > 图表，然后将公司大小指定为类别, X, 水平角色。此时，您可以

  • 在启动对话框中将图表类型更改为饼图，然后单击确定。
  • 单击确定，然后从平台下拉菜单中选择饼图。

创建控制范围图

使用公司.JMP时，将均值（盈利($M)）和均值（销售($Mil)）用作统计量进行标绘，同时使用公司大小作为类别, X, 水平。单击确定以显示条形图，然后从平台菜单中选择控制范围图。


叠加图

叠加图形平台

图形菜单中的叠加图命令可以绘制单个 X 列以及一个或多个 Y 数值。在一条公共的 x 轴上，每个 Y 的曲线可以显示为单独的图形。通过修改极差和针选项、颜色、对数轴以及网格线，您可以对图形进行修改。具有两种不同尺度的曲线可以在同一个图形中叠加，同时外加一条右侧的轴。

目录

叠加图形平台

分组变量

叠加图选项

平台选项

Y 选项


叠加图形平台

图形 > 叠加图命令可以将数值 Y 与单个变量 X 叠加。“叠加图”平台不接受非数值的 y 轴变量。

在单个 y 轴上标绘两个变量

要演示“叠加图”平台，请打开样本数据文件夹中的春天.jmp 数据表。表中有一列包含了四月份的每一天。名为四月的列，为该月的日期数字，其中包含该月的日期数字，而其它列为各种天气统计量。

请从图形菜单中选择叠加图命令，然后按照"启动“叠加图”对话框" 所示填写叠加图启动对话框。四月列中的值是该月的日期。请将四月指定为 X 角色，同时将每天下午 1:00 和 4:00 的湿度测量值下午 1点的湿度和下午 4 点的湿度指定为 Y 变量。

请注意，指定为 Y 角色的列在名称左侧都将显示一个左箭头或右箭头。此键头指定了变量将显示在哪一条垂直轴（图形的左侧或右侧）上。通过高亮度显示 Y 列表中的项并单击左尺度/右尺度按钮，您可以更改指定的轴。

对 X 排序选项可以将点按 X 值的升序连接起来。否则，这些点将按行顺序进行连接。

启动“叠加图”对话框

如果单击确定，屏幕上将显示如"使用叠加选项绘图" 所示的图形。最初，此平台会叠加所有指定的 Y 列。图形下方的图例显示了单独的标记和颜色，用于标识图中的每个 Y 列。

使用叠加选项绘图

用另一条 y 轴标绘两个变量

另一条 Y 轴可用于在同一图形上以不同尺度标绘数据，如股市收盘价格和当日成交量或者温度和气压等。例如，根据道琼斯工业股票平均指数来标绘一支便宜股票的卖价。相关数据可以在样本数据文件股票价格.JMP 中找到。

  • 指定最高价、最低价、收盘价和成交额为 Y 变量。
  • 选择 Y 列表中的成交额，然后单击左尺度/右尺度。
  • 指定日期为 X 变量。
  • 单击确定。

屏幕将显示如"双坐标轴叠加图" 所示的图形。

双坐标轴叠加图


分组变量

通过使用分组变量，“叠加图”平台可以在单个窗口中生成多个图形。如果使用单个分组变量，系统将显示堆叠的图形向量，分组变量的每个水平都将生成一个图形。使用两个分组变量则会生成图形矩阵。

例如，使用大班数据表生成身高 (Y) 与体重 (X) 叠加图，同时将年龄和性别用作分组变量。如"无单独坐标轴的分组图形" 所示为部分图形。

无单独坐标轴的分组图形

选定单独轴选项可以生成带有单独轴的图形，如"分组变量" 所示。

分组变量


叠加图选项

“叠加图”平台提供了标绘选项，您可以通过“叠加图”标题栏上的弹出式菜单图标访问这些选项。如果在平台层中选择了其中某个选项，若没有高亮度显示的图例，则选择的选项将影响报表中的所有图形。如果高亮度显示了一个或多个图例，则选项只会影响相应的图形。此外，每个 Y 变量还有一个单独图选项菜单，在高亮度显示图形下方的 Y 变量图例并使用鼠标右键单击时，屏幕将显示此选项菜单。

单个图形选项与平台层的 Y 选项子菜单中的选项相同。

平台选项

平台选项会影响报告窗口中的每个图形：

叠加图
可以为所有指定了 Y 角色的列叠加图形。图形最初按默认的叠加图选项显示。如果关闭叠加图选项，图形将单独显示。例如，如果关闭如"使用叠加选项绘图" 所示图形（数据点连接）的叠加图选项，JMP 将显示如下的图形。
单独轴
可以将每幅图形与其自己的 XY 轴相关联。如果关闭单独轴，同一行中的图形将共用一条垂直轴，而同一列中的图形则共用一条水平轴，如下图所示。
统一 Y 尺度
可以为分组的图形设定相同的 Y 尺度。
穿过缺失值连接
可以连接图上相邻的点而忽略缺失值。
控制范围图
可以将每个 x 值的最低和最高点用直线连接起来，并在每一端显示条形线。"带有范围选项和指定标记的叠加图"（ ）所示图形是对"使用叠加选项绘图"（ ）中图形应用控制范围图选项后的结果。
注：针选项将在下一节中介绍，它与控制范围图选项相互独立。
Y 选项
如果从平台窗口选择此选项，则会将其应用于报表窗口中的所有图形；如果从图例中选择此选项，则会将其应用于单个图形。Y 选项菜单将在下一节Y 选项中介绍。
撤消图形分组
可以为分组变量的每个水平创建单独的图表。
排列图形
允许您指定每列的图形数。
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件。

Y 选项

每个 Y 变量均在图形下方以图例标记。如上所述，Y 选项位于平台标题栏的 Y 选项子菜单中。此外，您也可以使用鼠标右键单击图形下方的某个 Y 变量图例，以便查看 Y 选项菜单。按住 Shift 键并单击鼠标可以高亮度显示多个 Y 图例。选择某个选项将影响所有图例已高亮度显示的图形。

如果从“叠加”主菜单中选择 Y 选项，每个选择的选项将影响图形中所有的 Y 变量。

显示点
可以显示或隐藏点。如"带有范围选项和指定标记的叠加图" 所示，该图形使用了显示点选项以及前面介绍的控制范围图选项。
连接点
是一个切换命令，可用于显示或隐藏点之间的连线。您可以使用连接而不显示点。
针
可以从每个点绘制一条到 x 轴的垂线。
注：连接、阶梯和针选项相互排斥。每次只能选择其中的一个选项。
阶梯
通过从每个点绘制一条水平直线到下一个点的 x 值，然后再绘制一条到该点的垂线，用不连续的阶梯来连接点。您可以使用阶梯而不显示点，如"已隐藏点的阶梯图" 所示。
注：连接、阶梯和针选项相互排斥。每次只能选择其中的一个选项。
函数图
可以将公式（存储在 Y 列中）标绘为平滑曲线。要使用此函数，请将公式存储在某一列中，而该列是单个 X 列的函数。然后将公式指定给 Y 角色。例如，"函数图" 中的数据表可以生成右侧所示的叠加图。使用线型和线宽命令可以改变标绘函数的外观。
函数图
注：如果 Y 列包含一个公式，“叠加图”通常会假定您需要函数图。但是，如果公式包含随机数的函数，则该函数与模拟同时使用的频率更高，而通常不需要进行函数绘图。因此，如果存在随机数的函数，则函数图选项将关闭（默认），而此选项对其它所有函数为打开状态。
连接线颜色
可以显示标准的 JMP 调色板，用于指定连接各点的线条颜色。
叠加标记
可以使用标准的 JMP 标记选用区来指定已绘制的点的标记。"带有范围选项和指定标记的叠加图" 中所示的图形使用指定的叠加标记并高亮度显示所有的行。
叠加标记颜色
可以指定选定变量所有点的颜色。选择黑色会在图形中使用数据表行状态中的颜色。如果要以黑色显示点，请不要将行状态颜色指定为默认值（黑色）。
线型
提供虚线、点线或其它线型以供选择。
带有范围选项和指定标记的叠加图
已隐藏点的阶梯图


旋转图

旋转图平台

图形菜单（或工具栏）中的旋转图命令显示数据的三维视图以及维数较高数据的主成分近似。您也可以使用“JMP 起始页”窗口图形选项卡页中的旋转图按钮来启动“旋转图”平台。该图形是当前数据表中数值列的值的可旋转显示。“旋转图”平台一次显示选定列中的三个变量。

为了帮助获取和观察维数较高的变异，当您需要主成分时，“旋转图”平台会显示点和变量的双向图表示。

“旋转图”平台还提供主成分的因子分析样式旋转，以便形成与空间中变量方向聚类对应的正交组合。使用的方法称为最大变异旋转，是因子分析中使用的传统方法。旋转成分与 Kaiser (1963) 称为 little jiffy 的因子分析方法相对应。

旋转图是由 Fisherkeller (1974) 等人提出的。

目录

启动平台

平台弹出式菜单

旋转图形

手动旋转

按钮旋转

显示选项

高亮度显示点

颜色和标记编码

重新调节轴

主成分

获取主成分

主成分射线

主成分文本报表

双向图

搜索离群值

旋转成分和因子分析

失真控制


启动平台

要生成旋转图，必须选择列作为成分，以便进行标绘。选择旋转图命令后，将会出现启动对话框（如下所示）。您可以随时使用添加变量命令添加更多变量，如以下章节"平台弹出式菜单"所述。

“旋转图”平台将显示三维旋转图，如"旋转图平台" 所示。平台的左上方为旋转控制面板，右边为图形框。显示选项可由旋转控制面板右边的弹出式菜单图标访问。通过平台名称旁边的弹出式菜单图标可访问另一菜单，从而向成分列表添加变量并启动主成分分析。

旋转图平台

开始时，“旋转图”平台在旋转图的 x、y 和 z 轴上显示成分列表中的前三个变量（请参阅"旋转图平台"）。只要成分列表中有三个变量，平台就会始终将变量指定给三个轴。要标绘另一组（三个）变量，请单击含有 X、Y 或 Z 的方框中的一个，并将该轴字符拖至另一成分。此操作将选择该轴的成分。这样，您就可以标绘成分列表中三个变量的每个组合。

平台弹出式菜单

“旋转图”标题栏上的弹出式菜单列出了可用于在“旋转图”平台中更改图形成分列表、计算主成分、旋转主成分以及显示主成分射线的选项。

其中还有一些选项可用于将成分值另存为当前数据表中的新列：

添加变量
弹出变量选择对话框，用于向旋转成分列表添加更多变量。
主成分
计算成分列表中变量组的主成分并将主成分添加到列表中。您可以对不同的变量组重复执行此操作。
标准主成分
与主成分命令一样都是计算主成分，但将转换主成分值尺度，以产生单位方差，而非典型方差。
注：如果需要 GH' 双向图而非 JK' 双向图，请使用此选项。GH' 双向图显示的点间距离意义不大，但双向图射线的角可更好地度量相关性。请参阅"双向图"一节。
旋转成分
提示您指定要旋转的因子数，然后计算许多旋转成分值。
双向图射线
显示或隐藏图形中与变量中的主成分或主成分中的变量对应的射线。
保存主成分
将所要求的当前主成分值个数保存为当前数据表中的列。这些列包括它们的公式并已锁定。根据成分列表中的 n 个变量，系统将创建 n 个主成分列，并分别命名为 Prin Comp 1、Prin Comp 2 ... Prin Comp n，依此类推。
保存旋转成分
将旋转成分值另存为当前数据表中的列。这些列包括它们的公式并已锁定。如果要求了 n 个旋转成分，则将创建 n 个旋转成分列，并分别命名为 Rot Comp 1、Rot Comp 2 ... Rot Comp n，依此类推。
重置尺度
对每个成分（旋转）变量显示一个对话框，用于指定中心值和上限值。
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件。

有关主成分和旋转成分的详情，请参阅"主成分"和"旋转成分和因子分析"两节。


旋转图形

选择三个变量后，就可以以两种方式旋转产生的点云：

  • 使用抓手工具（位于工具菜单）移动或绕原点以任意方向旋转图形。
  • 使用旋转控制面板上的方向按钮将点云绕三个旋转轴中的每一个进行旋转：前后旋转、左右旋转和平面旋转。

只要您按住鼠标按钮，每种情况都会持续旋转。释放鼠标按钮后，按住 Shift 键并单击可继续旋转。

手动旋转

要手动旋转图形，请选择抓手（位于工具菜单）。将抓手移至显示平台，通过按住鼠标按钮来抓住图形，然后左右移动手形。按住鼠标按钮时，轴将随着手形的移动而旋转。

"手动旋转选项"汇总了可控制旋转图的各种方法。

手动旋转选项
旋转图效果 | 使用抓手工具和鼠标操作
通过移动鼠标手动旋转 | 按“手动旋转”中所述拖动图形
旋转速度与圆圈大小成比例 | 按住 Alt 键并单击（在 Macintosh 系统中为按住 option 键并单击），此时将出现一个圆圈，显示手动旋转操作的跟踪杠杆的半径。拖动圆圈使之缩小或放大，对于给定的手形移动，图形的旋转速度将加快或减慢。圆圈越小，小移动产生的旋转就越快。
旋转由手形与中心的相对位置控制；按住鼠标时将连续旋转 | 在单击手形工具之前，按住 Control 键并单击（在 Macintosh 系统中为按住 command(命令) 键并单击），按住鼠标进行连续旋转，旋转方向与手形与图形中心的相对方向一致。旋转速度与手形距中心的距离成比例。 连续旋转；旋转速度随鼠标距中心的距离的增加而增加。
旋转由手形与中心的相对位置控制； 单击可连续旋转；单击图形可停止 旋转 | 按住 Shift-Control 组合键并单击（在 Macintosh 系统中为按住 shift- command(命令) 组合键并单击）将连续旋转，旋转速度随鼠标距中心的距离的增加而增加。
连续滑行旋转 | 按住 Shift 键并单击，推动再释放，推动速度越快，旋转速度越快。单击桌面任意位置可停止 旋转。
后台连续滑行旋转 | 在显示选项中选定后台滑行，旋转将成为闲置期间继续运行的后台任务，即使您进行其它操作也如此。在此模式中，要停止旋转，必须单击活动旋转平台窗口。

按钮旋转

下面显示的旋转控制面板包含十二个小图标，可用来指定旋转轴、控制旋转速度、转换图中点的尺度，以及访问显示选项弹出式菜单的图标。

六个箭头图标提供六个方向的三维旋转。

如果按住 Shift 键并单击旋转按钮，图形将继续旋转（旋转将滑行）。

后台滑行选项在此处同样起作用，使滑行既可作为后台任务，也可作为专项任务。请注意，单击图上的任意位置都将停止常规滑行，而单击活动旋转窗口则可停止后台旋转。

除前后旋转、左右旋转和平面旋转外，其中还有以下图标：
兔子和海龟图标使得每个旋转步骤的角度（因而影响速度）更大或更小。因为步长更改增量很小，所以要看出旋转速度的差异，可能需要单击多次。按住 Alt 键并单击（在 Macintosh 系统中为按住 option 键并单击）将以 10 度的增量更改旋转步长。按住鼠标按钮时，图形框架中会显示增量角。
如果单击尺度图标并按住鼠标按钮，这些图标将持续放大或缩小点的尺度。
起始状态图标使图形回到起始状态位置：x 轴在右、y 轴在上、z 轴在中。
弹出式菜单图标列出了"平台弹出式菜单"中介绍的“旋转图”平台显示选项。


显示选项

“旋转图”控制面板旁边的弹出式菜单提供了多个显示选项。所有显示选项都可在打开或关闭每项功能之间切换。如果功能旁边有选定标记，则表示该功能处于打开状态。

白色背景
使“旋转图”平台的背景交替显示为黑色和白色。此选项独立于“首选项”窗口中的背景选项。
轴线
显示或隐藏旋转图中的 x、y 和 z 轴。
框
在点云周围绘制参考立方体。
射线
在每个点与图形的原点之间绘制一条直线。
深度提示
启用或关闭以两个深度显示各点的功能（近点较亮，远点较暗）。
小点
将所有点显示为小点并稍微加快旋转速度。
后台滑行
指定滑行旋转（按住 Shift 键并单击任意一个旋转图标或使用抓手工具时将持续旋转）是专项任务还是后台任务。
快速模式
当图中有几千个点时，可以使旋转平滑。但是，此选项不支持颜色、标记或其它行状态。当图形的大小和尺度保持为初始状态时，此选项最有效。
轴标签
使轴的标签在列标签与“X”、“Y”和“Z”之间交替。

高亮度显示点

工具菜单中的箭头、笔刷和套索工具可高亮度显示旋转图中的点，如《JMP 用户指南》中所述。当靠近某个点单击时，它将在旋转图、数据表以及包含该点的其它所有图形中高亮度显示。按住 Shift 键并单击可延展高亮度显示的选择部分。按住 Alt 并单击（在 Macintosh 系统中为按住 option 键并单击）可将点的标签复制到剪贴板中。

按住鼠标按钮可显示行标签。"高亮度显示标记的点" 中的实例展示了溶解度.jmp 数据（CAFFEINE 点在旋转图和数据表中高亮度显示）。

高亮度显示标记的点

笔刷工具（位于工具菜单中）可高亮度显示在笔刷矩形内以及电子表格上的所有点。按住 Alt 键并单击（或按住 option 键并单击）可更改笔刷形状，并可通过按住 Shift 键并单击来延展选择部分。套索工具可用来高亮度显示图形不规则区域中的点。

您可以使用行菜单中的命令将各种行状态属性应用于高亮度显示的点。行状态包括颜色、标记、隐藏、排除、标签和选择状态。《JMP 脚本指南》的“数据表”章节中对行状态有所说明。

颜色和标记编码

为了在旋转图中可视化更多维数，您可以使用颜色和标记样式来为各个变量值进行标识。执行此操作的方式有以下几种：

  • 使用电子表格左边“行”面板弹出式菜单中的按列设定颜色或标记命令。此命令将要求您选择变量，然后为每个值指定颜色和标记。
  • 使用分析菜单中的分布命令。然后逐条高亮度显示各点，在处理变量的水平或范围时，按顺序指定颜色或标记。
  • 您还可以使用公式编辑器来根据构建的公式为各行指定行状态特征。通过使用行状态数据类型创建新变量，可将这些行状态作为特殊行状态变量保存在数据表中。

重新调节轴

转换旋转图中的数据的尺度，使均值居于中心，且轴上有三个标准差的空间。如果数据分散得较远，则延伸尺度以包括所有数据。如果要更改轴中变量的尺度，请在成分列表中双击该轴成分名称。此处显示的对话框将给出选定成分的当前值和上限。您可以编辑这些值，以最佳效果显示关注的图形点。

注：请勿更改主成分或旋转成分的中心，因为这样会使图形中射线的意义失效。

在“旋转图”平台中更改轴尺度与使用控制面板上的缩放按钮不同。缩放按钮会统一扩大或收缩所有尺度，而不是针对选定成分。

更改旋转轴值也与使用行菜单中的隐藏/撤消隐藏命令隐藏离群值不同。隐藏离群值时，即使不再显示离群点，尺度仍然保持不变。


主成分

如果要查看许多相关联变量中点的性态，您可以使用主成分分析，以显示高维数据的最显著方向。使用主成分分析可降低数据集的维数。主成分是一种通过使用尽可能少的变量来尽可能完整地反映数据结构的方法。

对于 n 个原始变量，将按以下方式构成 n 个主成分：

  • 第一个主成分是具有最大可能方差的标准化原始变量的线性组合。
  • 后续的每个主成分都是具有最大可能方差且与先前定义的所有成分都不相关联的标准化原始变量的线性组合。

每个主成分都是通过关联矩阵的特征向量与标准化原始变量的线性组合来计算。特征值显示每个成分的方差。

主成分组（n 个成分）的总变异和结构与原始变量的总变异和结构相同。后续成分与先前成分不相关（正交）的约束确保了每个新成分的方差都低于它前面成分的方差。由此得出，前几个主成分常常捕捉到大部分样本变异。

分析主成分有时有助于使用前几个成分来在各组之间进行判别并检测离群观测值（特别是当原始变量相关时）。

为了说明此问题，假设有两个高度相关变量的散点图。如果要计算两个变量最能捕捉到散点的线性组合，则可使用"两个主成分" 左边 P1 线所示的组合。旋转该图形，使 P1 成为主轴上的变量（如"两个主成分" 右边所示），这样可获得二维点云的最佳一维近似。第二个主成分 P2 描述剩余变异。这就是两个变量的主成分分解的实例。

两个主成分

同样，通过将前三个主成分作为旋转轴并检查该图形，可以找到高维数据的最佳三维视图。

获取主成分

要从图形选择列表中获取变量的主成分，请使用平台弹出式菜单中的主成分命令。主成分将成为成分列表中的新变量，如"显示主成分" 所示。主成分轴显示在图形中，且标记为主成分的显示按钮将生成一个报表。

显示主成分

主成分射线

如果将原始变量载入到两个或三个轴上并获得主成分，这些成分在旋转图中将显示为射线。这些射线（称为 p 射线）作为轴上变量的函数，近似于主成分。如果只有两个或三个变量，则射线刚好表示主成分。射线的长度与主成分的特征值或方差对应。因为第一个主成分捕捉到大部分可能的变异性，因此与后续成分相比，P1 射线可能较长。

在所有原始变量的高维空间中，主成分之间是正交的，但如果强制它们近似于较少的维数，则在图形中它们并不正交。如果只有两个或三个变量，可以清楚地看到主成分在旋转图中的作用。

主成分文本报表

“主成分”文本报表在多元数据表中根据主成分汇总了变异。主成分根据变量相关矩阵的特征值分解导出。报表的详细内容分为主成分如何吸收数据中的变异以及成分相对于变量的方向两部分。

主成分点根据标准化变量的特征向量线性组合导出。

文本报表的第一行按从左至右的顺序（第一个主成分、第二个主成分，依此类推）列出了与每个主成分对应的特征值。特征值表示多元样本中总变异的一部分，其总和为变量个数。

百分比
报表的第二行以总特征值的百分比形式列出了每个特征值。在上述实例中，第一个主成分占样本中变异的 79.7503%。
累积百分比
此列显示特征值表示的变异的累积百分比。在上述实例中，前三个主成分占样本中变异的 97.8087%。
特征向量
这些值列是每个主成分的特征向量，顺序为从左至右（第一个主成分、第二个主成分，依此类推）。使用这些系数来构成原始变量的线性组合，生成主成分变量。

双向图

双向图 (Gabriel 1971) 是一种用于在一个图形中同时显示一组变量和点的近似的技术。从本质上讲，双向图对于主成分点图形的贡献在于可在一个图示中同时显示变量和点。

如果选择两个或三个主成分作为轴，则将显示变量射线，产生的图示即为 Gabriel 所定义的 JK' 主成分二元图。

这些图形在二维或三维子空间中近似于点之间的高维距离结构。它们还提供了有关变量的一些信息。每条射线与一个假设观测值对应，其中除一个变量的值外（该值设定为均值之上的三个标准差），其它值都为均值。

如果转换数据尺度，使每个主成分的标准差为 1，其结果为 GH' 双向图。GH' 双向图在表示变量的互相关性方面优于 JK' 双向图，但在近似点间距离方面不如 JK' 双向图。使用标准主成分命令可得到 GH' 双向图。

从较高维数减少至二维或三维时，原先视为正交的变量相互之间更接近了。最相关的变量成为最接近的变量。在二维或三维子空间中，经常存在聚集在一起的变量组。与这些变量聚类对应的组合就是分析人员进行因子分析时希望找到的，其中的因子个数与表示的维数对应。

"主成分和变量射线" 显示了溶解度数据的前三个主成分的变量射线。由于主成分性质的关系，数据在 x 轴上的分布多于在 y 轴或 z 轴上的分布。另请注意，变量倾向于构成两组，ether 和 1-octonol 在一个组，carbon tetrachloride、benzene、hexane 和 chloroform 在另一个组。在每个组内，变量都高度相关，但两组之间的变量不相关。您可以在多元分析平台中检查此数据的相关性结构，来确定这一点。

主成分和变量射线

搜索离群值

在多元数据中查找离群值的一个很好方法是在图形轴上显示主成分，然后旋转三维散点云，并查找远离点云的点。有一种方法是先查找前三个主成分。这样可获得整体数据形状的最佳视图。要获得每个变量的细节，可在将 x 轴和 y 保持在前两个主成分上的同时，用各个变量排列 z 轴。但是，这样仍然会漏掉维数较高的离群值。通过查看最后主成分的图形，更容易找到这些维数较高的离群值。最后成分显示最不显著受支持的空间方向，而高维离群值是这个不常用空间中突出的栖居者。

您可以通过多元平台提供的 Mahalanobis 离群值图验证找到的多元离群值，高亮度显示这些点，并构成子集以进行报告。


旋转成分和因子分析

一组列的主成分显示数据中最大方差的方向。但是，这些成分没有其它有意义的解释。对于相关联的数据，主成分的前几维中经常会有相关变量的聚类。查看双向图射线时，经常可以看到与高度相关的变量组对应的射线聚类组。您可以在"相关性和多元技术" 章节中的 "主成分" 部分找到 JMP 中主成分的完整细节资料。

平台弹出式菜单中的旋转成分命令用于完成主成分的旋转。调用命令将显示一个对话框，提示您输入要包含的成分数和旋转方法。某些方法产生正交组合，而某些方法产生斜角旋转。

  • 对于正交旋转，我们建议使用最大变异旋转。它是用于因子分析的传统方法。旋转成分与 Kaiser (1963) 称为 little jiffy 的因子分析方法对应。虽然有些因子分析爱好者偏爱可估计公因子方差的方法并使用其它旋转，但是 JMP 提供了这一基本 little jiffy 方法，该方法是研究变量空间的极佳工具。
  • 对于斜角旋转，我们建议使用四次方最小旋转。

旋转成分的目的是构成这些主成分的组合，与空间中变量聚类的方向对应。从视觉上看，这是取双向图中前三个主成分的轴并旋转它们，以使每个轴点尽可能接近变量射线（或者说变量射线的负像）。

例如，在溶解度数据中，我们选择旋转成分并选择带有最大变异旋转的两个旋转因子。存在两个高度相关变量的聚类，ether 和 octane 在一组，carbon tetrachloride、benzene、hexane 和 chloroform 在另一组。"主成分空间中的旋转成分" 中左边的图形显示了前两个主成分中的数据以及最大变异旋转成分的射线。它们相互成直角并表示主轴的旋转。在图形中它们并不显示为直角，除非将主轴标度为与它们的特征值的平方根成比例的范围，或使用标准主成分命令。

如果将轴重新指定给这两个旋转成分，则可以以更圆的形式查看数据，如"主成分空间中的旋转成分" 的右图所示。其中转换了旋转成分的尺度，使它们的得分具有等方差且不相关。

主成分空间中的旋转成分

旋转因子模式显示在“旋转成分”报表中。最大变异方法试图使此矩阵中的元素向 1 或 0 移动，从而显示聚类。请注意，第一个旋转成分载入到 Carbon Tetrachloride-Benzene- Hexane-Chloroform 聚类，第二个旋转成分载入到 Ether-Octane 聚类。


失真控制

由于数值误差的累积，经过一定旋转后，图形通常会产生沿旋转轴收缩的趋势。JMP 同时使用低精度和简捷计算来提高旋转性能。由于对失真进行了监控，因此不会影响图形的精确度。当“旋转图”平台检测到失真超过某个阈值时，它会重新载入数据并重新变换。可能会在图形中看到简短的正在重新正交化消息。


控制曲面

曲面图平台

曲面图平台既能用作单独平台，又能作为模型拟合平台中的选项使用。同一图中最多能显示四个相关曲面。图下方的因变量部分包含 4 个对应于这四个曲面的行。根据您选择查看的内容（工作簿、点、等面或密度网格）和是否提供公式变量，因变量部分中显示的选项将有所不同。

可以通过使用 JMP 脚本语言的三维场景命令构建曲面图。《JMP 脚本指南》中有关于 OpenGL 式场景命令全面的说明文档。

在此平台中，您可以

  • 使用鼠标将曲面拖放至新位置
  • 使用鼠标右键单击曲面以更改背景颜色或显示虚拟对比度球（有助于定位曲面）
  • 启用可能提高相关性能（如果系统支持）的硬件加速
  • 将光源亮度拖动至其它位置，为其指定颜色并进行启用或关闭

目录

曲面图

启动平台

标绘单个数学函数

仅标绘点

从数据列中标绘公式

密度网格

等面

曲面图控制面板

外观控件

自变量

因变量

轴

缩放

旋转

键盘快捷方式


曲面图

曲面图平台可用于以三维场景标绘点和曲面。

曲面图可用作单独平台（图形 > 曲面图）和许多报表中的选项（也称为曲面刻画器）。无论出现在哪里，其功能都相似。

此类图可以是点或曲面。曲面图用作单独平台（即不是刻画器）时，点将被链接至数据表 — 这些可供点击且能对笔刷工具做出响应，并在数据表中反映出指定颜色和标记。曲面通过数学方程或一组定义多边形曲面的点来定义。这些曲面可以显得非常平滑或显示为带或不带等高线的网状。标签、轴和光线可以完全自定义。


启动平台

要启动平台，请从“图形”菜单中选择“曲面图”。如果有打开的数据表，将显示"曲面图启动对话框" 中的对话框。如果没有打开的数据表，将向您显示"默认曲面图" 中所示的默认曲面图。

曲面图启动对话框

通过将其放置到列角色来指定要标绘的列。依据角色中的变量将为每个依据变量的水平生成一个单独的曲面图。

标绘单个数学函数

要产生不带任何数据点的数学函数图形，请不要在启动对话框中填入任何角色。只需单击确定，获得默认的曲面图，如"默认曲面图" 所示。

默认曲面图

选择显示公式复选框以显示可用于标绘的四个公式空间。默认情况下，只显示一个曲面，但您可以激活更多曲面。

默认函数将显示在框中。要标绘自己的函数，请将其输入至此框。

仅标绘点

要生成 3 维散点图，请从列列表中选择 x、y 和 z 值，然后单击列按钮。例如，使用轮胎刻印.jmp 数据，"3 维散点图的启动和结果" 将显示启动对话框，从而生成曲面图。

3 维散点图的启动和结果

从数据列中标绘公式

要标绘公式（即根据数据表中的列标绘公式），在列列表中选择列，单击列按钮，并且单击确定。例如，假设您已运行轮胎刻印.jmp 数据表中附带的 RSM 脚本并将预测公式保存到此数据表。在"公式的启动和输出" 中显示了标绘该曲面图（及其产生的输出）所使用的启动对话框。您不必为图形指定因子，因为平台会从公式中自动将其提取。

公式的启动和输出

请注意，此选项仅标绘预测曲面。要标绘除公式之外的实际（观测）值，

  • 请选择图形 > 曲面图。
  • 将观测的值（磨损）和预测公式（预测公式磨损）选入启动对话框的列角色中。

"公式和数据点的启动和输出" 显示了启动对话框和最终结果。

公式和数据点的启动和输出

密度网格

密度网格是由三个变量定义的外壳。点的密集聚类密度较高，且因变量控制面板中的值滑动杆可用于更改外壳所包含的密度。JMP 最多能标绘四个嵌套的密度外壳（以图形正下方的因变量下的四组控件表示）。

带三个外壳的密度网格

可通过三个重要的控件获得效果良好的图形。前两个控件可在控制面板的右上角找到（请参阅"密度网格的分解率控件" 上的 ）。

  • 分解率（下拉框），可确定数据所属的柱体数量
  • 平滑（滑动杆），可确定数据被载入到柱体之后将向其应用的平滑度。平滑度越小，拟合就越密集，如同手套一般。平滑度过大，拟合就会松散，呈球状。
  • 值（因变量部分中的滑动杆），用于选择所需的密度的级别。最大密度值对应数据中心附近的小点。最小密度值对应数据周围的大球形区域。

所有三个控件彼此交互，因此您可能需要在更改分解率时，同时调整平滑滑动杆和值滑动杆。

要查看密度网格的实例，请打开血细胞计数.jmp 数据集，然后选择 CD3、CD8 和 CD4 作为变量以进行标绘。

出现报表时，请选择“密度网格”单选按钮。这将在点云周围绘制单个密度外壳 l。移动图形下方的“值”滑动杆可更改此外壳所包含的密度。

要添加更多外壳，请将当前设置为关闭的曲面设置更改为双面。"带三个外壳的密度网格" 显示了分解率为 64 的三个外壳。

等面

等面是指类似于 2 维等高线图的 3 维图。等面要求提供带有三个自变量的公式。“分解率”滑动杆可确定通过公式计算的 [image] 立方个点。因变量部分中的“值”滑动杆可用于挑选等面（即等高线层级）值。

例如，打开轮胎刻印.jmp 数据表并运行 4 种反应时反应堆表面设计脚本。这将生成一个带因变量磨损、弹性系数、伸长和硬度的响应曲面模型。由于等面要求提供公式，因此请为磨损、弹性系数和伸长选择保存列 > 预测公式。

现在请启动曲面图平台并将此三个预测列指定为要标绘的预测列。

出现报表时，请选择“等面”单选按钮。在因变量外框节点中，为所有三个变量选择双面。

三个变量的等面

对于轮胎刻印数据，一个变量可以将强度设置为固定的最小值，将拉长长度设置为固定的最大值，然后使用模数滑动杆查看哪些模数值是在由其它两个曲面设定的极限值集以内的。


曲面图控制面板

主曲面图标题栏的下拉菜单中包含三个项目。第一个项目用于显示或隐藏控制面板。第二个用于显示或隐藏亮边框。第三个则是标准的 JMP 脚本菜单。

控制面板包括以下选项组。

外观控件

第一组控件，允许您指定曲面图的整体外观。它们显示在"外观控件" 中。

外观控件
工作簿，点
用于设置显示工作簿、点和线
等面
将显示更改为等面...
密度网格
显示密度...

两个复选框改变您查看该图的方式。

正投影
以正交射影方式提供视图，而不是其它方式...
显示公式
显示图下的公式编辑框，允许您输入要标绘的公式。

分解率滑动杆会影响一个公式将计算的点数 T。

分解率控件可更改为密度网格的预定义的分解率下拉列表，分解率过低粗则意味着可能无法很好地表示有明显更改的函数，而将分解率设置为高将减慢曲面的计算和显示速度。

密度网格的分解率控件

自变量

自变量控件显示在"变量控件" 中。

变量控件

如果有两个以上的自变量，您则可使用此面板中的单选按钮选择在 x 和 y 轴上分别显示哪两个变量。滑动杆和文本框可用于设置每个变量的当前值，这对未在轴上显示的变量最为重要。实质上，此图显示了在文本框中显示值的三维切片。移动滑动杆可以看到不同的切片。

锁定尺度 Z 可将 z 轴锁定为其当前值。如果不在轴上移动滑动杆时，这非常有用。

网格复选框可激活与每根轴平行的网格。滑动杆允许您调整每个网格的位置。激活网格，单击滑动杆右侧的矩形。每个网格的分解率能通过分解率滑动杆（位于控制面板右上角）进行控制。举个实例，"激活的 X 网格和 Y 网格" 显示激活了 X 和 Y 网格的曲面。

激活的 X 网格和 Y 网格

因变量

因变量控件可进行更改，具体取决于您是否已选择了外观控件中的工作簿、点、等面或密度网格。

工作簿、点的控件

"因变量控件" 中显示了因变量控件及其默认的菜单。

因变量控件
公式
使您可以选择要在图中作为曲面显示的公式。
点响应列
使您可以选择列用于存放要作为点标绘的值。
样式
在您选择了点响应列之后出现的菜单。样式菜单使您可以选择如何显示点，是作为点、针、网状、曲面显示还是关闭（根本不显示）。点可显示根据数据表中的行的颜色和标记设置进行更改的单个点。针可从 x-y 平面到点绘制线，或者，如果还标绘曲面，则将曲面连接至点。网状可将点连成三角网状。曲面可将一个平滑的反射曲面重叠到点上。"使用了小池塘.jmp 的点、针、网状和曲面选项" 中显示了使用小池塘.jmp 的实例。
使用了小池塘.jmp 的点、针、网状和曲面选项
表面图
使您可以指定显示曲面的哪一面。选项有关闭、双面、仅上层和仅下层。
网格
滑动杆和复选框可激活因变量的网格。使用滑动杆可调整网格绘制处的值，或将值键入到滑动杆上方的网格值框。

等面控件

多数等面控件与工作簿、点的控件相同。"等面因变量控件" 显示了默认控件，表明了稍有差别的表示。

等面因变量控件

密度网格控件

多数密度网格控件与工作簿、点的控件相同。"等面因变量控件" 显示了默认控件，表明了稍有差别的表示。

密度网格的因变量控件

因变量菜单选项

因变量有多个平台选项，可通过平台的弹出式菜单访问。

公式
切换编辑框，您可以为每个曲面（共四个）分别输入公式。
颜色
切换两个控件。控件允许您选择显示曲面的哪一侧（双面、仅上层、仅下层、有关闭），另一个则允许指定显示曲面的颜色。
网线
显示菜单，使您可以指定应如何绘制网状（关闭、X 和 Y、X 或 Y）。
使用 X 和 Y 网状设置且指定颜色为黑色的曲面
等高线
显示菜单，使您可以指定曲面的等高线（有时称为水平曲线）。等高线下拉列表允许您选择绘制等高线的位置，可以是上方、下方或曲面上。（请参阅"下方（左侧）和曲面上（右侧）的等高线"）。单击菜单右侧的彩色矩形可更改等高线的显示颜色。在"下方（左侧）和曲面上（右侧）的等高线" 中，左边的等高线是黑色，右边的等高线是白色。
下方（左侧）和曲面上（右侧）的等高线
点

可显示或隐藏上述点响应列和样式菜单。

密度

可显示或隐藏曲面的密度值。

响应网格

显示或隐藏上面详细介绍且在"因变量控件" 中显示的的网格控件。

轴

"轴控制面板" 显示轴控制面板。它控制轴的外观。

轴控制面板
显示刻度标签
切换显示对应的刻度标签。
显示轴标签
切换显示对应的轴标签。
显示轴线
切换显示对应的轴线。
显示主刻度
切换显示对应轴的主刻度标记。
显示主网格
切换显示对应轴的网格。
标签旋转
可旋转对应轴的数值标签（90 度）和轴标签（180 度）。
标签翻转
翻转对应轴标签。
标签反射
轴标签显示为其反射图像，这在从特定角度查看图时非常有用。
轴的远侧 1
显示曲面图的轴的远侧上对应的轴标签和线。
轴的远侧 2
显示曲面图的轴的远侧上对应的轴标签和线。
轴的其它平面
显示轴平面或与轴平面成 90 度角处的对应轴标签和线。
刻度标签大小
设置对应刻度标签字体的相对大小。
轴标签大小
设置对应轴标签字体的相对大小。

缩放

"大小控制面板" 显示了缩放控制面板。每个滑动杆都可用于调整对应轴的尺度。

大小控制面板

旋转

"旋转控制面板" 显示了旋转控制面板。每一个滑动杆用于精确地控制围绕对应轴的旋转。

旋转控制面板


键盘快捷方式

以下键盘快捷方式可用于处理曲面图。
曲面图键盘快捷方式
键 | 功能
left、right、up 和 down | 旋转
Page Up, Page Down, Home, End | 对角旋转
Enter | 顺时针滚转
Delete | 逆时针滚转
Control | 将旋转速度加快 10 倍
Shift | 允许在背景中旋转
Return | 打开对比度球外观


等高线图

等高线图平台

图形菜单（或工具栏）中的等高线图命令可以在直角坐标系中构造响应等高线。您也可以在“JMP 起始页”窗口中使用图形选项卡中的等高线图按钮来启动“等高线图”平台。

“等高线”平台提供的可用选项有

  • 指定等高线层数
  • 选择线条式或填充式等高线
  • 显示或隐藏数据点
  • 用响应值来标记等高线
  • 自定义色彩主题
  • 将等高线结构信息保存至 JMP 表

目录

简单等高线图实例

等高线设置

平台选项


简单等高线图实例

要创建等高线图，您需要指定用于 x 轴和 y 轴的两个变量以及至少一个等高线变量（当然，您也可以指定多个 y 变量）。例如，"等高线图的数据表和启动对话框" 中的数据表显示了 Sample Data 文件夹中的小池塘.jmp 数据表的部分。

图形菜单中的等高线命令可以显示"等高线图的数据表和启动对话框" 所示的等高线图启动对话。在本例中，我们为坐标变量 X 和 Y 指定了图形的 X 角色，而 Z 变量（池塘深度）指定 Y（或称为等高线变量）。

注：函数 Z 应当正好是两个变量的函数。这两个变量应该是在等高线图启动对话框中输入的 x 变量。

等高线图的数据表和启动对话框

在等高线图启动对话框中单击确定，平台将构建出如"带图例的等高线图" 所示的图形。默认情况下，等高线的层级由 JMP 根据数据计算出的值确定。在创建图形之前，通过使用等高线图启动对话框中的选项，或者使用等高线图标题栏的弹出式菜单中的选项，您也可以指定等高线的层数和层级增量。此外，您还可以使用列公式来计算等高线变量值。

有关这些选项的更多细节，请参阅下一节"等高线设置"。

带图例的等高线图


等高线设置

如果没有在等高线图启动对话框中调整选项，则默认的图形将在 Y 变量的范围内设定相同的等高线层级间距。默认颜色由深到浅，从调色板的中间列由上至下进行循环。通过使用行菜单中的颜色命令，或者使用鼠标右键单击（Macintosh 中为按住 Control 键并单击）等高线图图例中的项，您可以查看调色板。

等高线图启动对话框（请参阅"等高线图的数据表和启动对话框"）包含如上图中用于指定等高线值的选项：

指定
可以显示等高线规格对话框（如此处所示），该对话框允许您更改等高线数量，设定最小和最大响应值来定义图形中使用的响应值范围，以及更改等高线值的增量。您可以提供四个值中的三个，另一个值将由 JMP 计算得出。单击复选框可以撤消选择其中某个数字，系统将自动选择其他的复选框。
颜色由系统自动指定，具体取决于图形中的层级数。在显示图形后，您可以使用鼠标右键单击（Macintosh 中为按住 Control 键并单击）图例中的任意等高线，然后从 JMP 调色板中选择要更改的等高线颜色。
提取
允许您从打开的 JMP 数据表中提取等高线数量、每个层级的准确值以及每个层级的颜色。
对于层级值设置，“等高线图”平台将查找一个数值列，该列的名称与启动对话框中指定的响应列名称相同。如果未找到该名称的列，则系统将使用找到的第一个数值列。行数即为所需的层级数。
如果某个行状态列包含了颜色信息，这些颜色将用于表示等高线层级。否则，系统将使用默认的平台颜色。
注：除非打开的数据表中包含等高线标绘值，否则检索按钮将处于非激活状态。如果单击了提取，屏幕将显示如下所示的对话框。您可以从已打开数据表的列表中选择包含等高线层级的数据表。
填充区域
如果选定了填充区域选项框，系统将在等高线之间的区域填充等高线颜色。此外，您也可以从平台弹出式菜单中选择填充区域选项，下一节"平台选项"中将进行介绍。
使用表数据，设定网格
通常，您可以为记录有响应值的表构造等高线图，如之前的小池塘表所示。在此情况下，使用表数据将被选定，而设定网格将呈灰色显示。但是，如果某一列带有公式，而您又将该列指定为响应 (Z)，则设定网格按钮将被激活。如果单击了设定网格，您将看到如"JMP 精细的等高线设置表" 所示的对话框。您可以填写“设定网格”对话框并根据需要定义等高线网格，而不必考虑现有数据表中的行。此外，表模板中也提供了此功能，这些模板包含了由公式定义的一个或多个列，但其中没有公式定义的行。
JMP 精细的等高线设置表


平台选项

“等高线图”标题栏上的平台弹出式菜单包含多个选项，您可以使用这些选项来自定义等高线图的外观，同时保存有关其绘制的信息。

显示数据点
可以显示或隐藏 (x, y) 点。默认设置为隐藏数据点。
显示等高线
可以显示或隐藏等高线或填充内容。默认设置为显示等高线。
显示边界
可以显示或隐藏整个等高线区域的边界。
填充区域
可以用单一颜色填充等高线之间的区域。它与启动对话框中的选项功能相同，但此选项使您能够在看到等高线之后再填充颜色。
标记等高线
可以显示或隐藏等高线的标签（z 值）。默认设置为隐藏标签。
反转颜色
可以反转指定的等高线层级颜色的顺序。
更改等高线
可以显示包含以下选项的子菜单，这些选项与等高线图启动对话框中的选项相同。有关这些选项的讨论，请参阅"等高线设置"。
保存
给出包含以下选项的子菜单：
保存等高线可以创建一个新的 JMP 表，其中的列包括“等高线”平台为每条等高线生成的 x 和 y 坐标值、为每个坐标集计算的响应以及等高线层级。此表中的观测值数量取决于您指定的等高线数量。您可以使用坐标和响应值在其它 JMP 平台中观察数据（如"等高线图及其对应的三维旋转图" 所示），该图使用了牛仔帽.jmp 样本数据表和“旋转图”平台。
生成网格可以显示一个对话框，提示您输入所需的网格大小。单击“确定”后，“等高线”平台将创建一个新的 JMP 表，其中包含您所请求的网格坐标数，以及根据线性插值计算得出的网格点等高线值。
保存三角剖分可以创建一个新的 JMP 表，其中将列出每个用于构造等高线的三角形的坐标。
等高线图及其对应的三维旋转图
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件。


统计控制图

控制图平台

本章讲解适用于所有控制图的选项。

目录

使用控制图的统计质量控制

控制图启动对话框

制程信息

图表类型信息

参数

使用指定统计量

定制水平轴

显示选项

单个图表选项

窗口选项

特殊原因检验

Western Electric 规则

Westgard 规则

运行警告脚本

保存和检索界限

实时数据捕获

在数据表中设置脚本

排除、隐藏和删除的样本


使用控制图的统计质量控制

控制图是一种图形分析工具，用于判定制程是否处于统计控制状态以及监督控制内制程。

控制图具有以下特征：

  • 每个点都代表根据质量特征度量的子组样本计算出的汇总统计量。
  • 控制图的垂直轴的标度单位与汇总统计量的单位相同。
  • 控制图的水平轴标识子组样本。
  • 当制程处于统计控制状态时，Shewhart 控制图中的中心线表示汇总统计量的平均（期望）值。
  • 控制上限和控制下限分别标记为 UCL 和 LCL，给出在制程处于统计控制状态时汇总统计量中期望的变异范围。
  • 控制限（或累计和图的 V 形遮盖）之外的点表示存在变异特殊原因。
  • 在收到和记录样本或将其添加到数据表中时，图形 > 控制图子命令会创建可动态更新的控制图。


控制图启动对话框

从图形 > 控制图菜单（"“控制图”菜单"）上选择“控制图”时，将会看到如"控制图启动对话框" 所示的控制图启动对话框。（显示的控件会因选择的图表类型的不同而不同。）最初，对话框显示以下三种信息：

  • 制程信息，用于测量变量选择
  • 图表类型信息
  • 界限设置
“控制图”菜单

每一部分显示的特定信息会因要求的图表类型的不同而不同。

控制图启动对话框

通过与启动对话框的交互，可以精确指定图表创建方式。以下几节将介绍面板元素。

制程信息

启动对话框显示当前数据表中的列列表。您可以在此指定要分析的变量和子组样本大小。

制程

选择用于绘图的变量。

  • 对于变量图，请将测量值指定为制程。
  • 对于属性图，请将缺陷计数或缺陷比例指定为制程。

样本标签

可用于指定其值标记水平轴的变量，也可以用于标识不等子组大小。如果没有指定样本标签变量，则通过其子组样本编号来标识这些样本。

  • 如果样本子组的大小相同，请选定样本大小常数单选按钮，并在文本框中输入大小。如果输入了“样本标签”变量，则其值用于标记水平轴。
  • 如果样本子组的行数不相等或者含有缺失值并且还有标识每个样本的列，则选中按样本标签对样本分组单选按钮并输入作为样本标签列的样本。

对于属性图（p、np、c 和 u 图），此变量为子组样本大小。在变量图中，它用于标识样本。当图表类型为 IR 时，会出现控制范围变动文本框。控制范围变动指定计算移动控制范围的连续测量数。

"含有不等子组样本大小的变量图" 中的示意图显示含有不等子组样本大小的制程的 [image] 图，其中使用 Quality Control 样本数据文件夹中的涂料.jmp 样本数据。

含有不等子组样本大小的变量图

相

相角色可用于指定标识不同相或部分的列。相是数据表中一组连续的观测值。例如，相可能会与时间周期对应，在此时间周期内新制程进入生产，然后经过连续的变化。对于每个指定的“相”变量水平，相都生成一个新的 Sigma、一组界限、区及产生的检验。有关相的详情，请参阅"Shewhart 控制图" 章节中的 "相" 。

图表类型信息

Shewhart 控制图大体上分为变量图和属性图。移动均值图和累计和图可以被视为变量图的特殊类型。

  • XBar 图表菜单选项提供 XBar、R 和 S 复选框。
  • IR 菜单选项含有“单个测量”、“移动控制范围”和“中位数移动控制范围”图复选框选项。
  • 等加权移动均值 (UWMA) 和指数加权移动均值 (EWMA) 选项是均值的特殊图。
  • 累计和图是均值或单个测量的特殊图。
  • 预先汇总可用于指定预先汇总统计量的信息。
  • P、NP、C 和 U 图、运行图以及 Levey-Jennings 图没有附加设置。

有关控制图的类型，请参阅"Shewhart 控制图"。

参数

您可以通过输入 k (K Sigma) 值或输入 α (Alpha) 概率指定控制限的计算方法，也可以通过查找的制程列的属性或之前创建的界限表生成的界限值指定控制限的计算方法。有关界限表的信息，请参阅本章后面的"保存和检索界限"一节。必须有 K Sigma 或 Alpha 的设置。对话框中默认的 K Sigma 为 3。

K Sigma

允许以样本标准误差的倍数计算控制限设置。K Sigma 将 k 个样本标准误差处的控制限指定为大于和小于期望值（显示为中心线）。要指定 k，即 Sigma 数，请单击 K Sigma 并将正的 k 值输入到文本框中。通常情况下 k 为 3，表示三个标准差。"K Sigma =3（左）和 K Sigma=4（右）时的控制限" 中显示的实例比较了涂料.jmp 数据在分别使用 K Sigma = 3 和 K Sigma = 4 绘制控制线时的 [image] 图。

K Sigma =3（左）和 K Sigma=4（右）时的控制限

Alpha

以单个子组统计量超出其控制限的概率 α 指定控制限（也称为概率极限），其中假定制程在控制内。要指定 Alpha，请单击 Alpha 单选按钮并输入需要的概率。α 的合理选项为 0.01 或 0.001

使用指定统计量

如果在控制图启动对话框上单击指定统计量按钮（如果可用），则会在启动对话框的底部出现包含可编辑字段的选项卡。您可以在此输入制程变量的历史统计量（从历史数据获得的统计量）。控制图平台使用这些项目构造控制图。在此实例中，将 1 显示为制程变量的标准差，将 20 显示为均值测量值。

注：当均值是由用户指定时，则其在图中标记为 μ0。

如果在控制图启动对话框上选定“性能”选项（请参阅"控制图启动对话框"），则在启动平台时会出现一个要求输入规格限的对话框。选定控制图的标准差将发送到该对话框，并显示为“指定 Sigma”值，即默认选项。输入规格限并单击“确定”后，则会在控制图旁边的同一窗口中出现性能输出。有关如何计算性能指数的信息，请参阅"性能指数名称和计算方法"。


定制水平轴

双击 x 轴后，会显示“X 轴设置”对话框，您可以在此处指定格式、轴值、刻度数、格线以及要显示在 x 轴上的参考线。

例如，泡菜.JMP 数据列出每天的八次测量值（为期三天）。此实例的默认情况为每隔一个刻度标记 x 轴。有时会显示冗余标签，如"标记的 x 轴刻度标记实例" 左图所示。如果将标签增量指定为 8 且其之间的刻度数为 7，则 x 轴显示每天标记一次，如右图所示。

标记的 x 轴刻度标记实例


显示选项

控制图包含可影响平台各部分的弹出式菜单：

  • 位于最顶端标题栏的菜单会对整个平台窗口产生影响。其选项随选择的图表类型的变化而变化。
  • 在含有选项的图表类型标题栏上有一些菜单项，会分别对每个图产生影响。

单个图表选项

单击图表名称旁边的图标，或使用鼠标右键单击图表的空白处（Windows 中为使用鼠标右键单击，而 Macintosh 中为按住 Control 键并单击），会显示图表选项的弹出式菜单。"累积和控制图"中将介绍累计图的不同选项。

箱型图

将箱型图添加在均值图中标绘的子组均值上。箱型图显示子组最大值、最小值、第 75 个百分位数、第 25 个百分位数和中位数。除非撤消选择显示点选项，否则会显示子组均值标记。显示的控制限只适用于子组均值。箱型图选项仅在 [image] 图中可用。它最适用于较大的子组样本大小（子组中有 10 个以上的样本）。

针

使用垂直线段将标绘的点连接到中心线。

连接点

在是否连接点之间切换。

显示点

在是否显示表示汇总统计量的点之间切换。最初，会显示点。使用箱型图选项时，可以使用此选项关闭表示子组均值的标记。

飞机场.jmp 数据的“箱型图”选项和“针”选项

连接线颜色

显示 JMP 调色板，您可以在其中选择用于连接点的线段的颜色。

中心线颜色

显示 JMP 调色板，您可以在其中选择用于绘制中心线的线段的颜色。

界限颜色

显示 JMP 调色板，您可以在其中选择上限线和下限线使用的线段的颜色。

线宽

可用于选择控制线的宽度。选项包括细、中等或粗。

显示中央线

中心线最初显示为绿色。撤消选择显示中央线会从图表中移除中心线及其图例。

显示控制界限

在是否显示图形控制限及其图例之间切换。

检验

显示一个子菜单，当检验为真正时，您可以从中选择一个要标记在图中的检验。这些检验仅适用于界限为 3σ 的图。检验 1 至 4 适用于均值图、单个图和属性图。检验 5 至 8 仅适用于均值图和单个测量图。如果没有适用于图表的检验，则“检验”选项显示为灰色。即使检验适用，但是对于控制限因子组样本大小不等而变化的图表，也不会显示，除非样本大小相等。这些检验也称为 Western Electric 规则。有关特殊原因检验的详情，请参阅本章后面的特殊原因检验。

显示区域

在是否在特殊原因检验中显示区域线之间切换。在涂料.jmp 样本数据的重量均值图中，区域标记为 A、B 和 C（如图所示）。控制图检验将区域线用作边界线。7 条区域线设定为以 1 Sigma 为间隔，并以中心线为中心。

Westgard 规则

下面将详细介绍。请参阅 中的文本和图表。

检验超出界限

用“*”标记所有超出界限的点。此检验可用于含有界限的所有图表，不管样本大小是否为常数以及 k 的大小或界限的宽度。例如，如果样本大小不等且要标记 r 图中所有超出界限的点，则可以使用此命令。

OC 曲线

提供特定控制图的操作特征 (OC) 曲线。OC 曲线在 JMP 中定义，仅用于 [image] 、p、np、c 和 u 图。曲线显示接受样本质量更改的概率。从控制图选项列表中选择 OC 曲线选项后，JMP 会打开一个包含曲线的新窗口，其中使用直接来自被激活控制图的计算值。另外，也可以从“JMP 起始页”窗口中的“QC（质量控制）”选项卡直接运行 OC 曲线。选择想要曲线依据的图表，然后对话框会提示输入目标、控制下限、控制上限、K、Sigma 和样本大小。

窗口选项

窗口标题栏上的弹出式菜单列出影响报表窗口的选项。如果同时要求 XBar 和 R，则会显示如下所示的实例菜单。您可以选定每个图表以显示或隐藏它。

可用的特定选项取决于要求的控制图类型。不可用选项显示为灰色菜单项。

运行图之外的所有控制图都会显示以下选项：

显示界限图例
显示或隐藏图表右侧的平均数、控制上限和控制下限值。
穿过缺失值连接
在某些样本具有缺失值时连接点。"穿过缺失值连接选项实例" 中左图为不包含缺失点的控制图。中间图的样本 8、9 和 10 缺失，其中有些点没有连接。如果使用穿过缺失值连接选项（这是默认情况），则会出现最右边的图表。
穿过缺失值连接选项实例
保存 Sigma
在 JMP 数据表中的制程变量列中，将 Sigma 计算值保存为列属性。
保存界限 > 在列中
在 JMP 数据表的制程变量列中，将 Sigma、中心线、上限和下限的计算值保存为列属性。“控制图”对话框随后会自动更新这些界限，并用于后续分析。
保存界限 > 在新建表中
在新的 JMP 数据表中保存用于特殊图表类型的所有参数，包括 Sigma、K Sigma、样本大小、中心线以及控制上限和控制下限。可以使用“控制图”对话框查找这些界限，并在随后的分析中使用它们。有关详情，请参阅"保存和检索界限"一节。
警告脚本
显示用于选择或输入脚本或脚本名的对话框，只要特殊原因检验生效且点超出范围，就会执行此脚本。有关详情，请参阅"特殊原因检验"一节。有关编写自定义警告脚本的详情，请参阅"运行警告脚本"。
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件。


特殊原因检验

图表类型弹出式菜单中的“检验”选项显示用于选择检验的子菜单。您可以使用此选项弹出式菜单选择一个或多个特殊原因检验。Nelson (1984) 提出用于在控制图上标识特殊检验的编号表示法。

如果选定检验为真正，检验序列中的最后一点使用检验号标记，其中该序列为计算该特定检验的移动点集。如果选择显示几个检验且在特定点选择了多个检验信号，则指定的数值最小的检验的标签将显示在该点旁边。

Western Electric 规则

Western Electric 规则可在检验子菜单中实现。"特殊原因检验的介绍和解释" 列出并解释这八个检验，"特殊原因检验示意图" 演示了这些检验。以下规则适用于每个检验：

  • 将上限和下限之间的区域分为 6 个区域，每个区域都为一个标准差宽度。
  • 这些区域分别标记为 A、B、C、C、B、A，其中 C 区最接近中心线。
  • 如果一个点超出分隔 C 区和 B 区的线，则其要么在 B 区内，要么超出 B 区。也就是说，距中心线多于一个标准差。
  • 分隔两个区域的线上的任何点都被视为属于更外面的区域。

注：所有检验和区域都需要非缺失数据子组中的样本大小相等。

检验 1 至 8 适用于均值 ( [image] ) 和单个测量图。检验 1 至 4 也适用于 p、np、c 和 u 图。

检验 1、2、5 和 6 分别适用于图表的上半部分和下半部分。检验 3、4、7 和 8 适用于整个图表。

有关如何使用这些检验的进一步建议，请参阅 Nelson (1984, 1985)。

特殊原因检验的介绍和解释
检验 1 | 1 点超出 A 区 | 检验均值的移动、标准差的增量或制程中的单个失常。为了解释检验 1，R 图可用于排除变异中的增量。
检验 2 | 9 点连续，位于或超出 C 区 的单侧（上侧或下侧） | 检验制程均值的移动。
检验 3 | 6 点连续，平稳增加或降低 | 检验制程均值中的趋势或偏差。在检验 1 之前，此检验会显示小的趋势。
检验 4 | 14 点连续，上下交替 | 检验系统效应，如两个交替使用的设备、 供应商或操作员。
检验 5 | 3 点连续中的 2 点，位于或 超出 A 区 | 检验制程均值的移动或标准差中的增量。3 点中的任何 2 点都提供真正检验。
检验 6 | 5 点中的 4 点位于或超出 B 区 | 检验制程均值的移动。5 点中的任意 4 点都提供真正检验。
检验 7 | 15 点连续，位于 C 区中， 在中心线上下 | 当单个子组中的观测值来自不同均值的多个来源时，检验子组的层次。
检验 8 | 8 点连续，在中心线的两侧， 但没有 1 点在 C 区 | 当一个子组中的观测值来自单个来源，但是子组来自不同均值的不同来源时，检验子组的层次。
Nelson (1984, 1985)

特殊原因检验示意图

Nelson (1984, 1985)

Westgard 规则

在控制图平台的 Westgard 规则子菜单下可实现 Westgard 规则。使用特定检验的决策规则缩写各种检验。例如，1 2s 指一种检验，其中一个点偏离均值两个标准差。

由于 Westgard 规则以 Sigma 而不是以区域为基础，因此可以在不考虑常数样本大小的情况下计算这些规则。

Westgard 规则

规则 1 2s 常用于 Levey-Jennings 图，其中将控制限设定为偏离均值两个标准差。

当任何一个点超出这些界限时，都会启动此规则。

规则 1 3s 常用于 Levey-Jennings 图，其中将控制限设定为偏离均值三个标准差。

当任何一个点超出这些界限时，都会启动此规则。

当两个连续控制测量偏离均值超过两个标准差时，

将启动规则 2 2s。

当组中的一个测量是均值上方两个标准差，且下一个测量是均值下方两个标准差时，
将启动规则 4s。

当四个连续测量偏离均值超过一个标准差时，将启动规则 4 1s。

当 10 个连续点位于均值一侧时，将启动规则 10 X。


运行警告脚本

如果要运行一个脚本，以便在数据的一个或多个检验失败时警告您，则可以运行警告脚本。调用警告脚本时，在发布的脚本和后续 JSL 脚本中都可使用下列变量：

qc_col 是列名

qc_test 是失败的检验

qc_sample 是样本编号

qc_firstRow 是样本中的第一行

qc_lastRow 是样本中的最后一行

实例 1：自动写入日志

生成自动警报的一个方法是创建脚本并将其存储在数据表中，作为数据表属性，这个脚本称为质量控制警告脚本。要在检验失败时将消息自动写入日志，请执行以下操作：

  • 运行以下脚本，将脚本保存为数据表的一个属性，
  • 运行控制图，
  • 打开需要的检验。如果有样本失败，则将在日志中看到一则消息。
 CurrentData Table()<<Set Property(“质量控制警告脚本”,
     Write(match(
       QC_Test,	1,“1 点超出 A 区”,
                 2,“9 点连续，位于或超出 C 区”,
                 3,“6 点连续，平稳增加或降低”,
                 4,“14 点连续，上下交替”,
                 5,“3 点连续中的 2 点，位于或超出 A 区”,
                 6,“5 点连续中的 4 点，位于或超出 B 区”,
                 7,“15 点连续，位于 C 区中”,
                 8,“8 点连续，在中心线的两侧，但没有 1 点在 C 区” )));

实例 2：运行具有检验的图表

打开涂料.JMP 数据表，并提交下列脚本：

     Control Chart(Alarm Script(Speak(match(
         QC_Test,1,“1 点超出 A 区”,
         QC_Test,2,“9 点连续，位于 C 区或超出”,
         QC_Test,5,“3 点连续中的 2 点，位于或超出 A 区”))),
 Sample Size( :Sample), Ksigma(3), Chart Col( :Weight,
 Xbar(Test 1(1), Test 2(1), Test 5(1)), R));

您可以让这些脚本使用任何的 JSL 警告命令，如口头、写入或邮件。

注：在 Windows 中，为了实现声音警告，必须安装 Microsoft Text-to-Speech 引擎，这是在安装 JMP 产品时的一个选项。


保存和检索界限

JMP 可将此前建立的控制限用于控制图：

  • 控制上限、控制下限和中心线值
  • 用于计算界限的参数，如均值和标准差。

控制限或界限参数值必须位于 JMP 数据表（称为界限表），或存储为制程列中的列属性。指定控制图命令时，可以使用控制图启动对话框中的获取界限按钮查找界限表。

创建界限表的最简便方法是保存控制图平台计算的结果。每个控制图的弹出式菜单中的保存界限命令都可自动保存来自样本值的界限。在表中保存的数据类型会因分析窗口中控制图类型的不同而不同。您也可以使用来自任何来源的值，创建自己的界限表。所有界限表都必须具有

  • 一列标识每一行的特殊关键字
  • 一列用于存放每个值为已知标准参数或界限的变量。列名必须与控制图平台要分析的数据表中相应的制程变量名一致。

您可以将界限保存在新数据表中，或保存为响应列的属性。使用在新建表中命令保存控制限时，写入表的界限关键字取决于显示的当前图表类型。界限关键字及其关联控制图列表如"相应图表的界限表关键字及其含义" 所示。

随后显示的数据表是使用金属夹1.jmp 数据分析保存限制时创建的数据表。该报表窗口显示个体测量图和移动控制范围图，其中指定的标准差为 0.2126。请注意，有一组包含每个图的中心线值和控制限。包含值 _Mean、_LCL 和 _UCL 的行用于个体测量图。值 _AvgR、_LCLR 和 _UCLR 用于移动控制范围图。如果再次使用此界限表要求这些图表类型，则控制图平台将标识来自 _LimitsKey 列中的关键字的相应界限。

请注意，可在控制图启动对话框中指定 _KSigma、_Alpha 和 _Range Span 的值。JMP 总是首先查看来自该对话框的值。在此对话框中指定的值优先于处于激活状态的界限表中的值。

控制图命令会忽略关键字未知的行和标记为排除行状态的行。除了 _Range Span、_KSigma、_Alpha 和 _Sample Size 之外，未指定的任何所需值都根据数据估计。

为了便于参考"相应图表的界限表关键字及其含义"，以下列表汇总了控制图平台中可用的图表类型：

运行图

变量图包括

  • 图（均值）
  • R 图（控制范围）
  • S 图（标准差）
  • IM 图（个体测量）
  • MR 图（移动控制范围）
  • UWMA 图（等加权移动均值）
  • EWMA 图（指数加权移动均值）
  • 累计和图（累计和）。

属性图包括

  • p 图（子组样本中不合格或缺陷项的比例）
  • np 图（子组样本中不合格或缺陷项的个数）
  • c 图（子组样本中不合格点数或缺陷数）
  • u 图（每单位不合格点数或缺陷数）。

相应图表的界限表关键字及其含义
关键字 | 图表... | 含义
_Sample Size | 、R、S、p、np、c、u、UWMA、EWMA、累计和 | 对于控制限样本大小固定；如果样本大小不固定，则设定为缺失值。如果在控制图启动对话框中已指定，则将显示固定样本大小。
_Range Span | 个体测量、移动控制范围 | 指定连续值个数 ( [image] ) 以计算移动控制范围
_Span | UWMA | 指定连续子样本均值个数 ( [image] ) 以计算移动均值
_Weight | EWMA | 常数权重以计算 EWMA
_KSigma | 全部 | 统计量标准差的倍数以计算控制限；如果界限按 Alpha 水平，则设定为缺失值
_Alpha | 全部 | 用于计算控制限的第一类错误；未在启动对话框或界限表中指定标准差倍数时使用
_Std Dev | 、R、S、IM、MR、UWMA、EWMA、累计和 | 已知制程标准差
_Mean | 、IM、UWMA、EWMA、累计和 | 已知制程均值
_U | c, u | 已知每单位的平均不合格点数
_P | np, p | 已知平均不合格比例值
_LCL、_UCL | , IM, p, np, c, u | 均值图、单个测量图或任何属性图的控制下限和控制上限
_AvgR | R、MR | 平均控制范围或平均移动控制范围
_LCLR、_UCLR | R、MR | R 或 MR 图的控制下限 R 或 MR 图的控制上限
_AvgS、_LCLS、_UCLS | S 图 | S 图的平均标准差、控制上限和控制下限
_HeadStart | 累计和 | 单侧方案的起始值
_Two Sided、_Data Units | 累计和 | 图表类型
_H、_K | 累计和 | Alpha 和 Beta 的替代选项；K 可选
_Delta _Beta | 累计和 | 要作为制程标准差或标准误差概率的倍数检测的最小移动绝对值，只有指定 _Alpha 时才可用。
_Avg R_PreMeans _Avg R_PreStdDev _LCL R_PreMeans _LCL R_PreStdDev _UCL R_PreMeans _UCL R_PreStdDev _Avg_PreMeans _Avg_PreStdDev _LCL_PreMeans _LCL_PreStdDev _UCL_PreMeans _UCL_PreStdDev | IM、MR | 基于预先汇总的组均值或标准差的均值、控制上限和控制下限。


实时数据捕获

在 JMP 中，实时数据流使用 DataFeed 对象处理，此对象可通过 JMP 脚本语言 (JSL) 脚本设置。DataFeed 对象设置一个并发线程，其中具有一个有关输入行的队列，这些输入行可实时到达，但在后台事件期间处理。设置的脚本可用于处理这些行以及将数据传送到数据表，或执行任何此类操作。有关编写脚本的详情，请参阅《JMP 脚本语言指南》。

Open Datafeed 命令

要创建 DataFeed 对象，请使用 Open DataFeed 函数指定有关连接的详细资料，形式如下

     feedname = Open DataFeed( options... );

例如，提交如下脚本可获取 com1 中的记录并仅将它们列在日志中。

     feed = OpenDataFeed(
             Connect( Port("com1:"),Baud(9600),DataBits(7)),
             SetScript(print(feed<<getLine)));

此命令将创建一个可脚本化对象并启动一个线程，监控通信端口并收集行。随后会返回对此对象的引用，需要通过将此引用赋给一个全局变量的方式来保存它。该线程将收集字符，直至达到一行。完成一行后，它会将其附加到行队列，并调度一个事件来调用 On DataFeed 处理程序。

DataFeed 命令

可脚本化的 DataFeed 对象会对几则消息做出响应。要以 JSL 发送消息，请使用 << 运算符，目标是关于对象的变量的名称。

要指定脚本或容纳脚本的全局变量的名称：

     feedName << Set Script(script or script name);

要测试 DataFeed 脚本，可将脚本中的行发送给它：

     feedName << Queue Line (character expression);

要让 DataFeed 脚本从队列中获取行，请使用此消息：

     feedName << GetLine;

要获取包含所有行的列表以清空队列，请使用：

     lineListName = feedName << GetLines;

要关闭 DataFeed，包括小窗口：

     feedName << Close;

要连接到处于激活状态的数据源：

     feedName << Connect(port specfication);

其中 Connect 命令中的端口设置如下：每个选项都只能接受一个自变量，但它们显示在下面，其中可能的自变量都以“|”分隔，且默认值先显示。最后三个选项接受布尔值，用于指定在设备之间往返发送哪些控制字符，以指明其已准备好获取数据。通常，至多只使用三个选项中的一个：

         Port( "com1:" | "com2:" | "lpt1:" |...),
         Baud( 9600 | 4800 | ...),
         Data Bits( 8 | 7 ),
         Parity( None | Odd | Even ),
         Stop Bits( 1 | 0 | 2 ),
         DTR_DSR( 0 | 1 ),		// DataTerminalReady
         RTS_CTS( 0 | 1 ),		// RequestToSend/ClearToSend
         XON_XOFF( 1 | 0 )

如果需要连接，则需要 Port 设置；否则，对象仍将工作，但不会与数据传送连接。

要与处于激活状态的数据源断开连接：

     feedName << Disconnect;

要停止并在随后重新启动排队行的处理，请单击相应按钮或提交等效消息：

     feedName << Stop;
     feedName << Restart;

运算

脚本使用 Set Script 指定。

     feedName << Set Script(myScript);

此处 myScript 是设置用来包含处理数据传送的脚本的全局变量。脚本通常会调用 Get DataFeed 来获取行副本，并执行需要的操作。通常，它会解析数据行，并将其添加到某个数据表。在上述实例中，它期望从列 11 开始找到一个三位长的数字；如果找到，它会在数据表中的 thickness 列添加一行。

     myScript= Expr(
         line = feed<<Get Line;
         if (Length(line)>=14,
             x = Num(SubString(line,11,3));
             if (x!=.,
                 CurrentDataTable()<<Add Row({thickness=x}))));

设置脚本以启动一个新数据表

下面是一个脚本示例，它将设置一个新数据表并根据数据传送启动一个控制图：

 // 制作数据表
     dt = NewTable("Gap Width");
 // 创建新列并设置控制图属性
     dc = dt<<NewColumn("gap",Numeric,
     SetProperty("Control Limits",
         {XBar(Avg(20),LCL(19.8),UCL(20.2))}),
     SetProperty("Sigma", 0.1));

 // 进行数据传送
     feed = OpenDatafeed();
     feedScript = expr(
         line = feed<<get line;
         z = Num(line);
         Show(line,z); // 如果正在记录或调试
         if (!IsMissing(z), dt<<AddRow({:gap = z}));
 );
     feed<<SetScript(feedScript);
 // 启动控制图
     Control Chart(SampleSize(5),KSigma(3),ChartCol(gap,XBar,R));
 // 启动传送：
 // feed<<connect("com1:",Port("com1:"),Baud(9600));
 // 传送一些数据看其如何工作以进行测试：
     For(i=1,i<20,i++,
         feed<<Queue Line(Char(20+RandomUniform()*.1)));

在数据表中设置脚本

为了进一步自动化制作设置，可以将一个如上所述的脚本放置到名为 On Open 的数据表属性中，打开数据表时将执行它。如果进一步将数据表标记为模板样式文档，则每次打开模板表时，都将创建一个新数据表。


排除、隐藏和删除的样本

下表汇总了各种条件对样本和子组的影响：
排除、隐藏和删除的样本
创建图表之前排除样本。 | 计算界限时不包括样本，但它会显示在图形上。
创建图表后排除样本。 | 计算界限时包括样本，它也会显示在图形上。如果在打开图形时排除样本，输出不会发生任何改变。
创建图表之前隐藏样本。 | 计算界限时包括样本，但它不会显示在图形上。
创建图表后隐藏样本。 | 计算界限时包括样本，但它不会显示在图形上。图形上没有样本标记，样本标签仍显示在轴上，但界限不变。
创建图表之前既排除又隐藏样本。 | 计算界限时不包括样本，它也不会显示在图形上。
创建图表后既排除又隐藏样本。 | 计算界限时包括样本，但它不会显示在图形上。图形上没有样本标记，样本标签仍显示在轴上，但界限不变。
在创建图表之前删除样本时， 将数据集分为子集。 | 计算界限时不包括样本，轴不包括样本值，且图形上也没有样本标记。
在创建图表后删除样本时， 将数据集分为子集。 | 计算界限时不包括样本，它也不会显示在图形上。图形上没有样本标记，仍从轴上移除样本标签，图形将移动，界限也将改变。

附注：

  1. 排除和隐藏仅适用于样本中第一个观测值的行状态。例如，如果样本中的第二个观测值为隐藏，而第一个观测值不为隐藏，则样本仍将显示在图表上。
  2. 排除/隐藏规则的例外：特殊原因检验可以标记是否排除了样本，但不会标记是否隐藏了样本。


Shewhart 控制图

变量和属性控制图

控制图是一种图形分析工具，用于判定制程是否处于统计控制状态。

控制图的基本概念是任何制程中的自然变异性可以通过一组控制限量化，且当变异超出这些界限时将发出信号，通知变异的特殊原因。失控外制程通常需要某种干预来解决问题，使之回到控制内。

Shewhart 控制图大体上分为变量控制图和属性控制图。移动平均图和累计和图是特殊的变量控制图。

JMP 中的“控制图”平台可实现各种控制图：

  • 、R 和 S 图，
  • 单个图和移动控制范围图，
  • p、np、c 和 u 图，
  • UWMA 和 EWMA 图，
  • 累计和图
  • 、r、r、IR、p、np、c、u 的相控制图，预先汇总图和 Levey-Jennings 图。

通过图形菜单中的控制图命令、或者通过工具栏或 JMP 起始页，以及编写脚本的方法都可启动该平台。

在表中添加数据或更改数据时，控制图会动态更新。这是控制图独有的、不同于 JMP 中其它平台的功能。

目录

Shewhart 变量控制图

XBar、R 和 S 图

运行图

单个测量图

预先汇总图

移动平均图

等加权移动平均 (UWMA) 图

指数加权移动平均 (EWMA) 图

Shewhart 属性控制图

p 和 np 图

u 图

c 图

Levey-Jennings 图

相

实例


Shewhart 变量控制图

根据图上标绘的子组汇总统计量，变量控制图分为：

  • 图显示子组均值（平均值）
  • R 图显示子组范围（最大值至最小值）
  • S 图显示子组标准差。
  • 运行图将数据显示为一系列连接点。

选择 IR 后，会添加以下两种图型：

  • 显示单个测量的单个测量图
  • 显示两个或多个连续测量的移动控制范围的移动控制范围图。

XBar、R 和 S 图

对于以连续尺度测量的质量特征，典型分析在对应的 R 或 S 图上方，用一个平均图显示此制程均值及其变异性。或者，如果要绘制单个测量图，单个测量图则在其对应的移动控制范围图上方显示。

实例： 和 R 图

下面的实例使用 Quality Control 样本数据文件夹中的涂料.jmp 数据（摘自数据表示和控制图分析 ASTM 手册）。关注的质量特征是重量列。选择子组样本四。此制程的 [image] 图和 R 图如"“涂料”数据变量图" 所示。

要重复此实例，请执行以下操作：

  • 选择图形 > 控制图 > XBar 命令。
  • 请注意选定图类型为 XBar 和 R。
  • 将重量指定为制程变量。
  • 将样本大小常数从 5 更改为 4。
  • 单击确定。

另外，对于此实例也可以提交以下 JSL：

 Control Chart(Sample Size(4), K Sigma(3), Chart Col( :Weight, XBar, R));

样本六表明此过程不在统计控制中。要选择样本值，请在任一个控制图中单击样本六汇总点。对应行将在数据表中高亮度显示。

注：如果 S 图与 [image] 图一起选择，那么 [image] 图的界限则以标准差为基准。否则， [image] 图的界限以控制范围为基准。

“涂料”数据变量图

您可以用以 X 拟合 Y 得到另一种数据显示。首先，将样本的建模类型更改为“记名”。将区间变量重量指定为 Y，并将记名变量样本指定为 X。"“以 X 拟合 Y”平台上的“分位数”选项" 中的箱型图显示第六个样本有小范围的较高值。

“以 X 拟合 Y”平台上的“分位数”选项

和 R 图的控制限

JMP 生成 [image] 和 R 图的控制限，具体如下：

图的控制下限 =
图的控制上限 =
R 图的控制下限 =
R 图的控制上限 =

/R 图的标准差的估计公式为

其中

= 子组均值的加权平均数
σ = 制程标准差
n i = 第 i 个子组的样本大小
d 2(n) 为具有单位标准差 n 个独立正态分布自变量的控制范围期望值
d 3(n) 为具有单位标准差 n 个独立观测值的控制范围标准误差
N 为 n1〉=2 的子组数

实例：子组大小可变的 和 S 图

此实例使用的数据与 Quality Control 样本数据文件夹中的实例 1 涂料.jmp 相同。这一次关注的质量特征是重量 2 列。此制程的 [image] 图和 S 图如"子组大小可变的 和 S 图" 所示。

要重复此实例，请执行以下操作：

  • 选择图形 > 控制图 > XBar 命令。
  • 选择图类型 XBar 和 S。
  • 将重量 2 指定为制程变量。
  • 将样本列指定为样本标签变量。
  • 样本大小选项应自动更改为按样本标签对样本分组。
  • 单击确定。

另外，对于此实例也可以提交以下 JSL：

 Control Chart(Sample Size( :Sample), KSigma(3), Chart Col( :Weight 2, XBar, S));
子组大小可变的 [image] 和 S 图

重量2 的数据中有几个缺失值，因此您也许会注意到图的界限不均匀。尽管每个样本都有相同数量的观测值，但是样本 1、3、5、7 各有一个缺失值。

注：尽管区或检验将打开并显示为选定，但是只有所有样本大小都相等，它们才会显示在图中，这是因为它们在样本大小不相等的图中都是无效的。如果在图打开时样本改变并且大小变得相等，而且选定了区和（或）检验选项，则将立即应用区和（或）检验并显示在图上。

和 S 图的控制限

JMP 生成 [image] 和 R 图的控制限，具体如下：

图的控制下限 =
图的控制上限 =
R 图的控制下限 =
R 图的控制上限 =

/S 图中标准差的估计公式为

其中

= 子组均值的加权平均数
σ = 制程标准差
n i = 第 i 个子组的样本大小
c 4(n) 为具有单位标准差的 n 个独立正态分布变量的控制范围期望值
c 5(n) 为正态总体中具有单位标准差的 n 个独立观测值的控制范围标准误差
N 为 ni〉=2 的子组数
s i 为第 i 个子组的样本标准差

运行图

运行图将数据列显示为一系列连接点。下面的实例是涂料.jmp 中重量变量的运行图。

运行图

您在运行图的下拉菜单中选择显示中央线选项时，将通过列的中心值绘制一条直线。这条中心线是由平台下拉菜单的使用中位数设置确定的。选择使用中位数时，就将中位数用作中心线。否则，使用均值。将界限另存为文件时，总体均值和中位数都将被保存。

如果通过对话框或者脚本给定样本标签，运行图还可以标绘组均值。

单个测量图

单个测量图类型显示单个测量值。单个测量图适于每个子组样本都只有一个测量值的情形。

移动控制范围图类型显示两个或多个连续测量值的移动控制范围。移动控制范围的计算是针对您在“控制范围变动”框内输入的连续测量值的个数。默认控制范围变动为 2。因为各移动控制范围是相关的，所以在解释这些图时应仔细对待。

实例：单个测量图和移动控制范围图

Quality Control 样本数据文件夹中的泡菜.jmp 数据记录了泡菜缸中的含酸量。由于泡菜对酸性敏感，而且用大缸淹制，所以强酸会腐蚀整个泡菜缸。在每天下午 1、2、3 点对四个缸中的酸性进行测量。数据表记录日期、时间和酸性测量值。通过"单个测量图和移动控制范围图的启动对话框" 中的对话框可创建水平轴上为日期标签的单个测量图和移动控制范围图。

单个测量图和移动控制范围图的启动对话框

要完成此实例，请执行以下操作：

  • 选择图形 > 控制图 > IR 命令。
  • 选择单个测量和移动控制范围图类型。
  • 将酸性指定为制程变量。
  • 将日期指定为样本标签变量。
  • 单击确定。

另外，对于此实例也可以提交以下 JSL：

 Control Chart(Sample Label( :Date), KSigma(3), Chart Col( :Acid, Individual Measurement, Moving Range));

"“泡菜”数据的单个测量图和移动控制范围图" 中所示的单个测量图和移动控制范围图监控每个缸内的酸性。

“泡菜”数据的单个测量图和移动控制范围图

单个测量图和移动控制范围图的控制限

单个测量图的控制下限 =
单个测量图的控制上限 =
移动控制范围图的控制下限 =
移动控制范围图的控制上限 =

IR 图的标准差的计算公式为

其中

= 单个测量的均值

= 单个测量的均值

σ = 制程标准差

d 2(n) = 具有单位标准差的 n 个独立正态分布变量的控制范围期望值

d 3(n) = 正态总体中具有单位标准差的 n 个独立观测值的控制范围标准误差

注：如果选择了中位数移动控制范围图，单个图上的界限将中位数移动控制范围用作 Sigma，而不是平均移动控制范围。

预先汇总图

如果数据包含同一制程单位的重复测量值，那么需要将这些测量合并为此单位的一个测量值。除非数据在每个制程或测量单位中都有重复测量值，否则不建议预先汇总。

预先汇总根据选定样本大小或样本标签将制程列汇总为样本均值和（或）标准差。然后，根据在启动对话框上选择的选项，绘制汇总数据图。您还可以在启动对话框上选定适当的框，来附加一个性能分析。

实例：预先汇总图

举个实例，请使用涂料.jmp 数据表。

  • 选择图形 > 控制图 > 预先汇总命令。
  • 选择重量作为“制程”变量，样本作为“样本标签”。
  • 在对话框中，同时选定基于组均值的个别值和基于组均值的移动控制范围。选择“样本标签”变量时，将自动选定按样本标签对样本分组按钮。
  • 单击确定。
预先汇总对话框
绘制预先汇总数据图的实例

尽管 [image] 和 S 图上的点与“基于组均值的个别值”图和“基于组标准差的个别值”图相同，但界限不同，因为它们是按单个图进行计算的。

下面是用涂料.jmp 数据表生成预先汇总图的另一种方法。

  • 选择表 > 汇总。
  • 将样本指定为“组”变量，然后将均值（重量）和标准差（重量）指定为统计量。
  • 单击确定。
  • 选择图形 > 控制图。
  • 再次将图类型设定为 IR 并选择均值（重量）和标准差（重量）作为制程变量。
  • 单击确定。

产生的图与预先汇总图一致。

使用预先汇总图时，可以选择基于组均值或基于组标准差，或者两个都选。如果两种 IR 图类型都选定，则每个选项都将创建两个图（一个是单个测量图，另一个是移动控制范围图）。

基于组均值选项计算每个样本均值，然后标绘这些均值并创建这些均值的单个测量图和移动控制范围图。

基于组标准差选项计算每个样本标准差，然后将这些标准差标绘成单个点，并创建这些标准差的单个测量图和移动控制范围图。


移动平均图

前面讨论的控制图都是依据单个子组样本的信息来标绘各个点。移动平均图与其它类型不同，因为每个点都合并了当前样本和过去样本的信息。因此移动平均图对制程均值的微小移动都较为敏感。另一方面，由于连续移动平均高度相关，因此移动平均图上点的模式较难解释 (Nelson 1983)。

在移动平均图中，被平均的数量可以不是子组均值，而是单个观测值。但是，单个测量值的移动平均图与单个测量值或标绘了单个测量值的移动控制范围的控制 (Shewhart) 图不同。

等加权移动平均 (UWMA) 图

等加权移动平均 (UWMA) 图也称为移动平均图，其上的每个点都是 w 个最新子组均值（包括当前子组均值）的平均值。获得一个新的子组样本时，下一个移动平均的计算则丢弃前面 w 个子组均值中最旧的均值，并添加最新的子组均值。常数 w 称为移动平均的范围，表示移动平均是由多少个子组构成的。范围 (w) 越大，UWMA 线就越平滑，反映的移动量就越小。这就意味着 w 值越大，移动就越小。

实例：UWMA 图

举一个实例，请看金属夹1.jmp。我们关注的测量值是加工好的金属夹两端的间隙。要监控此制程并找到平均间隙的变化，每天都选择五个金属夹的子组样本，并检查移动平均范围 3 时的 UWMA 图。要查看此图，请完成"金属夹1.jmp 数据的 UWMA 图设置" 所示的“控制图”启动对话框，提交 JSL 或执行以下步骤。

 Control Chart(Sample Size(5), KSigma(3), Moving Average Span(3), Chart Col( :Gap, UWMA));
  • 选择图形 > 控制图 > UWMA 命令。
  • 将移动平均范围更改为 3。
  • 选择间距作为制程变量。
  • 单击确定。
金属夹1.jmp 数据的 UWMA 图设置

结果如"金属夹1 数据的 UWMA 图" 所示的图。第一天的点是当天五个子组样本值的均值。第二天的标绘点是第一天和第二天子组样本均值的平均值。其余各天的点则是当天和前两天样本均值的平均值。

金属夹的平均间隙看上去在减小，但是样本点都没有超出 3σ 界限。

与所有控制图一样，在当前数据表添加行时，UWMA 图也会动态更新。"添加了五个点的 UWMA 图" 中的图显示又添加了五天数据的金属夹1 图。

金属夹1 数据的 UWMA 图
添加了五个点的 UWMA 图

UWMA 图的控制限

UWMA 图控制限的计算公式如下：

控制下限 =
控制上限 =

其中

w 为范围参数（移动平均的项数）
ni 为第 i 个子组的样本大小
为子组均值的加权平均数

指数加权移动平均 (EWMA) 图

指数加权移动平均 (EWMA) 图也称为几何移动平均 (GMA) 图，其上的每个点都是所有前面子组均值的加权平均数，其中包括当前子组样本的均值。随着时间后移，权重将以指数方式减少。指定给当前子组样本均值的权重 ( [image] ) 是 EWMA 图的一个参数。小权重值用于预防小移动。

实例：EWMA 图

请使用金属夹1.jmp 数据表，提交 JSL 或执行以下步骤。

 Control Chart(Sample Size(5), KSigma(3), Weight(0.5), Chart Col( :Gap, EWMA));
  • 选择图形 > 控制图 > EWMA 命令。
  • 将权重更改为 0.5。
  • 选择间距作为制程变量。
  • 样本大小常数保持为 5。
  • 单击确定。

下图显示"金属夹1 数据的 UWMA 图" 所示数据的 EWMA 图。这个 EWMA 图是在权重 = 0.5 时生成的。

EWMA 图

EWMA 图的控制限

EWMA 图控制限的计算公式如下：

控制下限 =
控制上限 =

其中

r 为 EWMA 权重参数 (0 < r 1)
x ij 为第 i 个子组中第 j 个测量值，j = 1, 2, 3,..., n i
n i 为第 i 个子组的样本大小
为子组均值的加权平均数


Shewhart 属性控制图

在前面的图类型中，测量数据是制程变量。此数据经常是连续的，而且这些图是以连续理论为基础。另外一种数据类型是计数数据，其关注的变量是每个子组中缺陷数的离散计数。对于离散计数数据，可使用属性图，因为它们是基于二项模型和 Poisson 模型。由于计数是按子组测量的，因此，在比较图时确定各个图的子组中是否包含相似的项数，这一点是非常重要的。与变量图一样，属性图根据上图所标绘的子组样本统计量也分为：

确定使用哪一种属性图
每一项都被判定为合格或不合格 |  | 对每一项的缺陷数进行计数
子组大小不变 | 子组大小变化 | 子组大小不变 | 子组大小变化
np 图 | p 图 | c 图 | u 图

  • p 图显示大小可变的子组样本中不合格（缺陷）项的比例。由于 p 图的每个子组由 N 个项组成，并且每项被判断为合格或不合格，因此子组中不合格项的数量最多为 N。
  • np 图显示大小不变的子组样本中不合格（缺陷）项的个数。由于 np 图的每个子组由 N i 个项组成，并且每项被判断为合格或不合格，因此子组 i 中不合格项的最大数量是 N i。
  • c 图显示通常只有一个检验单位的子组样本中的不合格点（缺陷）数。
  • u 图显示可以有许多不同检验单位的子组样本中每单位的不合格点（缺陷）数。

p 和 np 图

实例：np 图

Quality Control 样本数据文件夹中的垫圈.jmp 数据包含 15 批镀锌垫圈的缺陷计数，每批 400 个垫圈。对垫圈做光洁度缺陷检验，例如，镀面粗糙和钢材暴露。如果垫圈有光洁度缺陷，则被认为不合格或有缺陷。因此，缺陷计数表示大小为 400 的每批中有多少垫圈有缺陷。要重复此实例，请执行以下步骤或提交 JSL 脚本：

  • 选择图形 > 控制图 > NP 命令。
  • 选择次品数作为制程变量。
  • 将常数大小更改为 400。
  • 单击确定。
 Control Chart(Sample Size(400), KSigma(3), Chart Col( :Name("# defects"), NP));

这里的实例演示了缺陷数的 np 图。

np 图

实例：p 图

请再次使用垫圈.jmp 数据，可以指定样本大小变量，此变量将允许改变样本大小。

注：此数据包含所有常数样本大小。执行以下步骤或提交 JSL 脚本：

  • 选择图形 > 控制图 > P 命令。
  • 选择组作为样本标签变量。
  • 选择次品数作为制程变量。
  • 选择组大小作为样本大小变量。
  • 单击确定。
 Control Chart(Sample Label( :Lot), Sample Size( :Lot Size), K Sigma(3), Chart Col(Name("# defects"), P))

这里显示的图说明了缺陷比例的 p 图。

p 图

请注意，尽管图上的各点看上去与 np 图一样，但是 y 轴、平均数和界限则完全不同，因为它们以比例为基础。

p 和 np 图的控制限

控制下限 LCL 和控制上限 UCL 的计算公式分别如下：

p 图控制下限 =
p 图控制上限 =
np 图控制下限 =
np 图控制上限 =

其中

为跨子组抽取的不合格项的平均比例，即：
n i 为第 i 个子组中的项数
N 为子组数

u 图

Quality Control 本数据文件夹中的支架.jmp 数据记录了汽车支架一箱中的缺陷计数。一箱支架为一个检验单位。（每天）检验的箱数为子组样本大小，是可变的。这里显示的 u 图监控每个子组样本大小的支架缺陷数。上限和下限可根据检验单位数而变化。

注：当您生成 u 图并选择性能时，JMP 启动 Poisson 分布拟合并提供 Poisson 特定的性能分析。

u 图

实例：u 图

要重复此实例，请执行以下步骤或提交下列 JSL：

  • 打开 Quality Control 样本数据文件夹中的支架.jmp 数据。
  • 选择图形 > 控制图 > U 命令。
  • 选择次品数作为制程变量。
  • 选择单位大小作为单位大小变量。
  • 选择日期作为样本标签。
  • 单击确定。
 Control Chart(Sample Label( :Date), Unit Size( :Unit size), K Sigma(3), Chart Col( :Name("# defects"), U));

u 图上的控制限

控制下限 LCL 和控制上限 UCL 的计算公式分别如下：

控制下限 =
控制上限 =

界限随 n i 的变化而变化。

u 为制程产生的每单位的不合格期望数。
u i 为第 i 个子组中每单位的不合格数。一般来讲，u i = c i/n i。
c i 为第 i 个子组中的不合格总数。
n i 为第 i 个子组中的检验单位数
为跨子组抽取的每单位的平均不合格数。数量 [image] 计算为加权平均数
N 为子组数

c 图

c 图与 u 图的相似之处是，它们都监控整个子组中的不合格数，此子组由一个或多个单位组成。但是，它们要求子组大小不变。c 图还可以用于监控每检验单位的平均缺陷数。

注：当您生成 c 图并选择性能时，JMP 启动 Poisson 分布拟合并提供 Poisson 特定的性能分析。

实例 10：每单位不合格数的 c 图

在此实例中，一家制衣厂以每箱十件衬衣来发货。发货前，对每件衬衣进行缺陷检验。因为这家制衣厂对每件衬衣的平均缺陷数感兴趣，所以将每箱衬衣中发现的缺陷数除以 10，然后进行记录。要重复此实例，请执行以下步骤或提交下列 JSL：

  • 打开 Quality Control 样本数据文件夹中的衬衣.jmp 数据。
  • 选择图形 > 控制图 > C 命令。
  • 选择# 次品作为制程变量。
  • 选择盒装尺寸作为样本大小。
  • 选择盒作为样本标签。
  • 单击确定。
 Control Chart(Sample Label( :Box), Sample Size( :Box Size), K Sigma(3), Chart Col( :Name("# Defects"), C));
c 图

c 图上的控制限

控制下限 LCL 和控制上限 UCL 的计算公式分别如下：

控制下限 =
控制上限 =

界限随 n i 的变化而变化。

u 为制程产生的每单位的不合格期望数。
u i 为第 i 个子组中每单位的不合格数。一般来讲，u i = c i/n i。
c i 为第 i 个子组中的不合格总数。
n i 为第 i 个子组中的检验单位数。
为跨子组抽取的每单位的平均不合格数。数量 [image] 计算为加权平均数
N 为子组数

Levey-Jennings 图

Levey-Jennings 图显示制程均值，其控制限基于一个长期 Sigma。控制限距离中心线 3s。

Levey-Jennings 图的 s 计算方法与分布平台中的标准差相同，即：

Levey Jennings 图


相

相是数据表中一组连续的观测值。例如，相可能会与时间周期对应，在此时间周期内新制程进入生产，然后经过连续的变化。对于每个指定的“相”变量水平，相都生成一个新的 Sigma、一组界限、区及产生的检验。

在 [image] 、r、s、IR、p、np、c、u、预先汇总和 Levey-Jennings 图的对话框上，都会出现一个相变量按钮。如果指定了相变量，则执行检查相变量，以确定每个行属于哪个相。

保存到界限文件后，可显示计算出来的每个相的 Sigma 和特定界限。

实例

打开 Quality Control 本数据文件夹中的直径.JMP。这个数据集合包含每天用第一种模型（相 1）和第二种模型（相 2）测得的直径。

  • 选择图形 > 控制图 > XBar。
  • 选择直径作为制程，日期作为样本标签，阶段作为相。
  • 单击确定。
相启动对话框

生成的图中每个相都有不同的界限

相控制图


累积和控制图

累积和图

在检测到某个制程已偏离指定制程均值是很重要时，累积和控制图则被使用。虽然 Shewhart [image] 图可以检测制程是否超出二或三西格玛移动，但它们不能发现均值中的一西格玛移动。而在累积和控制图中，这样的移动仍然在控制之内，因为差累积和偏离指定目标的距离越来越远，而且均值中的很小波动都将很快很明显地显现出来。

目录

累积和图

累积和图启动选项

累积和图选项

累积和图公式

表示法

单侧累积和图

双侧累积和方案


累积和图

累积和图显示来自目标值的子组或单个测量的累积和。累积和图是用于确定制程是否处于统计控制状态及检测制程均值移动的图形和分析工具。

JMP 累积和图可以是单侧的以检测来自指定目标均值的一个方向上的移动，也可以是双侧的以检测任何一个方向上的移动。两种图都可以用几何参数（"双侧累积和图的 V 形遮盖示意图" 中所述的 h 和 k）指定；双侧图可以用误差概率 α 和 β 指定。

要解释双侧累积和图，请将点与构成 V 形遮盖的极限进行比较。通过标绘 V 形极限可以生成 V 形遮盖。V 形遮盖的原点是最新标绘的点，上下臂沿 x 轴向后扩展，如"双侧累积和图的 V 形遮盖示意图" 所示。收集数据时，将更新累积和序列，且原点会重新定位到最新的点。

双侧累积和图的 V 形遮盖示意图

从直观角度讲，在累积和图上很容易检查出制程均值的移动，因为它们会改变标绘点的斜率。斜率变化的点就是发生移动的点。如果此前标绘的一个或多个点跨过 V 形遮盖的上臂或下臂，则状况将不受控制。点跨过下臂表示制程均值增大，点跨过上臂表示向下移动。

累积和图与其它控制 (Shewhart) 图有几个主要差异：

  • Shewhart 控制图根据来自单一子组样本的信息标绘点。在累积和图中，每个点都基于来自所有抽样样本的信息，包括当前子组。
  • 在 Shewhart 控制图中，水平控制限定义某个点是否指示失控状况。在累积和图中，极限可以是 V 形遮盖形式或水平决策区间形式。
  • Shewhart 控制图中的控制限通常指定为 3σ 极限。在累积和图中，根据平均运转周期、误差概率或经济设计确定极限。

累积和图在检测制程均值中的小移动方面更有效。Lucas (1976) 指出：V 形遮盖在检测 1σ 移动速度方面是 Shewhart 控制图的四倍。

累积和图启动选项

选择图形 > 控制图 > 累积和时，将出现控制图启动对话框，其中包括如下所示的相应选项和设置。

有关 K Sigma 和 Alpha 的说明，请参阅"统计控制图" 章节中的 "参数" 。下面的项目只适用于累积和图：

双侧的

选定时将出现一个双侧累积和方案。如果没有选定，则使用单侧方案且不会出现 V 形遮盖。如果指定了 H 值，将显示决策区间。

数据单位

指定计算累积和时没有标准化的子组均值或单个值，因此累积和图的垂直轴的标度单位与数据相同。

注：数据单位要求将子组样本大小指定为常数。

Beta

指定无法发现发生指定移动的概率。Beta 是第二类错误的概率，只在指定了 Alpha 时才可用。

H

双侧方案中 V 形遮盖的原点与 V 形遮盖的上臂或下臂之间的垂直距离 h。单击 H 时，Beta 输入框标记为 K。您也可以输入子组轴发生一个单位大小变化时 V 形遮盖下臂增大的值（请参阅"“显示参数”和“显示 ARL”选项"）。对于单侧方案，H 为决策距离。选择的 H 应为标准误差的倍数。

指定统计量

将此处显示的面板附加到控制图启动对话框中，以便输入制程变量设置。

目标

制程或总体的目标均值（目标）。目标均值的标度单位必须与数据相同。

Delta

分别将要检测的最小移动绝对值指定为制程标准差或标准误差的倍数，具体取决于是将移动视为总体均值移动，还是视为子组均值的抽样分布移动。Delta 是移动选项（下面将讲述）的替代方法。下面的公式体现了移动和 Delta 之间的关系

其中 δ 表示 Delta，Δ 表示移动，σ 表示制程标准差，而 n 是（公共）子组样本大小。

移动

是要在目标均值任一侧检测的最小值。输入移动值使用的单位必须与数据相同，且必须将其解释为子组均值的抽样分布均值移动。您可以选择输入移动或 Delta。

Sigma

为制程标准差 σ 指定已知的标准差 σ0。默认情况下，“控制图”平台根据数据估计 Sigma。您可以使用 Sigma 替代控制图启动对话框上的 Alpha 选项。

起始值

为单侧累积和方案指定累积和初始值 S 0（S 0 通常为零）。输入的“起始值”必须为标准误差的倍数。

累积和图选项

除了标准图选项之外，累积和图还有以下选项。

显示点

显示或隐藏样本数据点。

连接点

使用直线连接样本点。

遮盖颜色

显示 JMP 调色板，供您选择 V 形遮盖的线条颜色。

连接线颜色

连接线选项生效时，显示 JMP 调色板，供您选择连接线的颜色。

中心线颜色

显示 JMP 调色板，供您选择中心线的颜色。

显示移动

显示或隐藏输入的移动或中心线。

显示 V 形遮盖

根据将“累积和”选定为图标类型时，以在控制图启动对话框中指定的参数（统计量）为基础显示或隐藏 V 形遮盖。

显示参数

显示汇总了累积和制图参数的“参数”表（请参阅"“显示参数”和“显示 ARL”选项"）。

显示 ARL

显示平均运转周期 (ARL) 信息。

实例 1：带 V 形遮盖的双侧累积和图

要查看双侧累积和图实例，请从 Quality Control 样本数据文件夹打开石油1 累计和.jmp 文件。某台机器装满数个 8 盎司油罐的二冲程发动机油添加剂。一般认为装满制程在统计控制下。此处对制程进行了设定，使得装满油罐的平均重量 μ0 为 8.10 盎司。此前的分析表明装满重量的标准差 σ0 为 0.05 盎司。

其中选定了四个油罐的子组样本，并在 12 个小时内每小时都进行称重。石油1 累计和.jmp 数据表中的每个观测值都包含一个重量值及其关联值小时。观测值的排序方式是使小时值按升序排列。“控制图”模型假定数据按升序排序。

双侧累积和图用于至少检测一个标准差在自目标均值 8.10 盎司的任意方向上的移动。

要创建此实例的累积和图，请执行以下操作：

  • 选择图形 > 控制图 > 累积和命令。
  • 单击双侧的复选框（如果还未选定）。
  • 将重量指定为“制程”变量。
  • 将小时指定为“样本标签”。
  • 单击 H 单选按钮，然后在文本框中输入 2。
  • 单击指定统计量，打开累积和图的已知统计量选项卡。
  • 将目标设定为平均重量 8.1。
  • 输入 Delta 值 1。
  • 将 Sigma 设定为标准差 0.05。

填写好的对话框应如"累积和实例对话框" 所示。

或者，可以忽略此对话框，而是提交以下 JSL 脚本：

 Control Chart(Sample Size( :小时), H(2), Chart Col( :重量, CUSUM(Two sided(1), Target(8.1), Delta(1), Sigma(0.05))));
累积和实例对话框

单击确定时，将出现如"石油1 累计和.jmp 数据的累积和图" 所示的图。

石油1 累计和.jmp 数据的累积和图

通过将点与 V 形遮盖（其右角的中心位于最近的点（小时 = 12））进行比较，可解释该图。因为没有点跨过 V 形遮盖的两臂，所以没有发生制程移动的证据。

如果在时间 t 之前标绘的一个或多个点跨过 V 形遮盖的一个臂，则在时间 t 会指示移动或管制外状况。跨过下臂的点指示向上移动，而跨过上臂的点指示向下移动。发生移动的时间与在标绘点斜率上观测到不同变化的时间对应。

添加新样本时，累积和图会自动更新。"更新后的 OIL 数据累积和图" 中的累积和图是上图加上附加点后的形式。通过使用手形工具单击某个点，即可移动 V 形遮盖的原点。中心线和 V 形遮盖会变化，以反映该点的制程状况。

更新后的 OIL 数据累积和图

实例 2：不带 V 形遮盖的单侧累积和图

看一下实例 1 中使用的数据，其中该机器装满了数个 8 盎司油罐的发动机油。还有就是为了降低成本，制造商现在关心的是显著的过满，而不是不满。单侧累积和图可用于标识靠近或超过指定侧的数据。超出均值 8.1 0.25 盎司都被认为是出现问题。要实现此实例，请执行以下操作：

  • 选择图形 > 控制图 > 累积和命令。
  • 撤消选定双侧的复选框。
  • 将重量指定为制程变量。
  • 将小时指定为样本标签。
  • 单击 H 单选按钮，然后在文本框中输入 0.25。
  • 单击指定统计量，打开累积和图的已知统计量选项卡。
  • 将目标设定为平均重量 8.1。
  • 输入 Delta 值 1。
  • 将 Sigma 设定为标准差 0.05。

您也可以提交以下 JSL 脚本：

 Control Chart(Sample Size( :小时), H(0.25), Show Limits Legend(0), Chart Col( :重量, CUSUM(Two Sided(0), Target(8.1), Delta(1), Sigma(0.05))));

产生的输出图应如"OIL 数据单侧累积和图" 所示。

OIL 数据单侧累积和图

请注意，决策间隔或水平线设定在输入的 H 值 (0.25)。另请注意，单侧累积和图没有出现 V 形遮盖。

累积和图弹出式菜单中的显示参数选项用于将“参数”报表显示在"OIL 数据单侧累积和图" 的左侧。“参数”报表汇总了来自控制图启动对话框中的“累积和图的已知统计量”选项卡的制图参数。另一个图表选项显示 ARL 用于将平均连串长度 (ARL) 信息添加到报表中。平均连串长度是指在指示管制外状况前抽取的前瞻样本数：

  • ARL (Delta)（有时表示为 ARL1）是用于检测指定 Delta 大小移动的平均连串长度。
  • ARL(0)（有时表示为 ARL0）是指定参数的管制内平均连串长度 (Montogomery (1985))。
“显示参数”和“显示 ARL”选项


累积和图公式

表示法

这些公式使用了这些表示法：

μ 表示总体均值，也称为制程均值或制程水平。

μ0 表示总体的目标均值（目标）。符号 [image] 在统计质量控制术语和表中用于 μ0。您可以在对话框中或通过 JSL 将 μ0 作为目标提供。

σ 表示总体标准差。

σ0 表示已知标准差。您可以在对话框中或通过 JSL 将 σo 作为目标提供。

表示 σ 估计。

n 表示累积和方案的记名样本大小。

δ 表示要检测的 μ 移动，表示为标准差的倍数。您可以在对话框中或通过 JSL 将 δ 作为目标提供。

Δ 表示要检测的移动，表示为数据单位。如果样本大小 n 在子组中都是常数，则

请注意，一些作者使用符号 D 替代 Δ。您可以在对话框中或通过 JSL 将 Δ 作为目标提供。

单侧累积和图

正向移动

如果要检测的移动 δ 为正向移动，则计算得出的第 t 个子组的累积和为

S t = max(0, S t -1+ (z t - k))

其中 t = 1, 2,..., n，S 0 = 0, z t 定义为双侧方案，参数 k（术语称为参考值）为正。累积和 S t 称为上累积和。由于 S t 可以写为

序列 S t 累积子组均值中自 σ0 起大于 k 标准误差的偏差。如果 S t 超过正值 h（称为决策区间），将指示移动或管制外状况。

反向移动

如果要检测的移动为反向移动，则计算得出的第 t 个子组的累积和为

S t = max(0, S t -1 - (z t + k))

其中 t = 1, 2,..., n，S 0 = 0, z t 定义为双侧方案，参数 k（术语称为参考值）为正。累积和 S t 称为下累积和。由于 S t 可写为

序列 S t 累积子组均值中自 σ0 起小于 k 标准误差的偏差绝对值。如果 S t 超过正值 h（称为决策区间），将指示移动或管制外状况。

请注意，不管 δ 是正还是负，S t 始终为正，而 h 始终为负。对于设计用来检测反向移动的方案，一些作者定义了在 S t 小于负极限时为其指定移动的 S t 的反映版本。

Lucas 和 Crosier (1982) 描述了累积和方案的快速初始响应功能的属性，其中初始累积和 S 0 设定为“起始值”。它们提供的平均连串长度计算表明在制程处于管制内状态时 FIR 功能没什么影响，且它对初始管制外状况的响应比标准累积和方案快。您可以在对话框中或通过 JSL 提供起始值。

常数样本大小

在子组样本大小为常数 (= n) 时，可能计算标度单位与数据相同的累积和会更好。则累积和的计算公式为

其中 δ > 0 且方程

其中 δ < 0。在任何一种情况下，如果 S t 超过 [image] ，都将指示移动。一些作者将符号 H 用作 h'。

双侧累积和方案

如果累积和方案为双侧，为第 t 个子组标绘的累积和 S t 为

S t = S t - 1 +z t

其中 t = 1, 2,..., n。此处 S 0 = 0，且项 z t 的计算公式为

其中 [image] 是第 t 个子组平均值，n t 是第 t 个子组样本大小。如果子组样本包含各个测量 x t，则项 z t 简化为

z t = (x t - μ0)/σ

因为第一个方程可写为

序列 S t 累积子组平均值与目标均值 μ0 的标准化偏差。

在许多应用中，子组样本大小 n i 为常数 (n i = n)，因此可简化 S t 方程。

在一些应用中，S t 计算公式可能最好为

其中标度单位与数据的相同。在此情况下，程序会将 V 形遮盖参数 h 和 k 分别重新标度为 [image] 和 [image] 。一些作者将符号 F 用作 k'，将 H 用作 h'。

如果制程在管制内且均值 μ 位于或接近目标 μ0，点不会展示某种趋势，因为自 μ0 的正向移动和反向移动会互相抵消。如果 μ 正向移动，则点会展示向上趋势，而如果 μ 反向移动，则点展示向下趋势。


变异性图

变异性图与度量 R&R 分析

您可以使用图形菜单（或工具栏）中的变异性/度量图命令启动“变异性图”平台，也可以使用“JMP 起始页”的测量选项卡上的变异性图按钮或属性图按钮来启动它。

变异性图标绘的是第二个因子每个水平的均值，所有图均并列显示。除了这些数据，您还可以查看每个类别中数据的均值、极差和标准差，还可以查看它们在不同类别中的变化。分析选项假定主要关注的是均值和方差在不同类别中的变化。

  • 此图表的传统名称为多元图，但是由于人们不太熟悉该名称，因此我们使用一个更为通用的名称，“变异性图”。
  • 变异性图与“单因子”平台一样，会并列显示数据，但是它已经广泛用于处理多个分组列。
  • 变异性图通常用于测量系统分析（如度量 R&R），它会分析因操作员变异（重制能力）和测量变异（重复能力）导致的变异性大小。度量 R&R 可用于交叉模型与嵌套模型的所有组合（不管该模型是否平衡）。
  • 就像控制图显示制程中某段时间的变异，变异性图显示不同类别（如部件、操作员、重复和仪器）的同一种变异。
  • “变异性图”平台可以计算方差成分。另外，此平台中还具有多个由纯随机模型的交叉因子和嵌套因子构成的模型。
  • 此平台可以用来分析属性（多水平）数据。

目录

变异性图

启动变异性平台

变异性图

变异性平台选项

方差成分

R&R 测量系统

度量 R&R 变异性报表

偏差

线性研究

判别比报表

属性度量图

数据组织

启动平台

属性度量图

一致性

有效性报表


变异性图

建立变异性图的目的在于研究测量值在各个类别中的变化。除了这些数据，您还可以查看每个类别中数据的均值、极差和标准差。分析选项假定主要关注的是均值和方差在不同类别中的变化情况。

变异性图在 y 轴和多水平分类 x 轴上均有响应。该图的主要部分具有如"变异性图实例" 所示的功能。

变异性图实例

注：如果数据不平衡，“变异性/度量图”平台就会调用 REML 来计算方差成分。要在数据平衡时强制执行 REML，请在脚本窗口中键入以下信息并执行该脚本，从而将 JSL 全局变量 Vari Chart Force REML 设定为 1。

 Vari Chart Force REML = 1;

启动变异性平台

选择图形菜单上的变异性/度量图命令即可显示如"变异性/度量图启动对话框" 所示的“变异性图”启动对话框。您可以在分组列表 X 中指定用于对测量进行分组的分类列。如果因子形成一个嵌套层次结构，请先指定较高项。如果是度量研究，请先指定操作员，然后指定部件。在响应列表 Y 中指定测量列。如果指定了多个 Y 列，则每个响应都将有一个单独的变异性图。

通过指定包含测量部件的“真”值或已知值的标准列或参考列，可启动“偏差”选项和“线性研究”选项。这两个选项都可用于分析观测的测量值与参考值或标准值之间的差异。

您可以在此处或通过平台弹出式菜单中的方差成分命令，来确定模型类型（主效应、交叉、嵌套等）。

以下实例使用了 Variability Data 文件夹中的样本数据表 2 因子交叉.jmp。

变异性/度量图启动对话框

变异性图

在您填写完启动对话框并单击确定之后，默认情况下，变异性图和标准差图（如"二因子交叉数据的变异性图" 所示）将出现在屏幕上。此变异性图显示了每个操作员对编号为 1 - 10 的部件进行的三次测量，其中最大值 - 最小值连线代表测量极差。标准差图标绘了每个操作员对每个部件进行测量的标准差。

二因子交叉数据的变异性图

变异性平台选项

变异性图和标准差图之所以具有如"二因子交叉数据的变异性图" 所示的外观，是因为我们从弹出式菜单中选定以下选项的结果。以下选项让您可以自定义变异性图的外观，并可以生成“度量 R&R”分析。

变异性图
开关整个度量变异性图。
显示点
显示单个行上的点。
显示极差栏
显示每个单元格中最小值至最大值的条柱。
显示单元格均值
显示每个单元格的均值标记。
连接单元格均值
连接一组单元格内的单元格均值。
显示组均值
使用水平实线来表示单元格组的均值。
显示总均值
使用贯穿整个图形的灰色虚线表示整体均值。
显示总中位数
使用贯穿整个图形的蓝色虚线表示整体中位数。
显示箱型图
开关箱型图。
点的跳动
在标绘的点中添加一些随机干扰，以使重合点不彼此重叠。
标准差图
显示一个单独的图形，其中会显示类别单元格的单元格标准差。
方差成分
估计特定模型的方差成分。平台会计算以下模型的方差成分：嵌套、交叉、先交叉后嵌套（仅限三因子模型）和先嵌套后交叉（仅限三因子模型）。
度量研究
将第一个因子解释为“操作员”，将第二个因子解释为“部件”。然后，它会使用估计的方差成分创建“度量 R&R”报表。系统会提示您确认使用给定的 k 值转换结果尺度。度量 R&R 分析仅适用于二因子交叉模型。
在此菜单中，您可以选择判别比，此选项用于描述对特定产品进行的给定测量的相对有效性。它会将测量的总方差与测量误差的方差加以比较。偏差报表将显示观测值与标准值的平均差值。每个 X 变量均有一个平均偏差图和一个汇总表。线性研究执行回归时，将标准值用作 X 变量，并将偏差用作 Y 变量。此分析将检查偏差与部件大小之间的关系。理想的结果是斜率等于 0。如果斜率不等于 0，表示您的度量对大小不同的部件执行了不同的测量。此选项仅适用于已给定“标准”变量的情况。
AIAG 标签允许您指定按 AIAG 标准标记质量统计量，这一方法广泛应用于汽车分析中。
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件。


方差成分

您可以使用模型来模拟两次测量中的变异，其中假定响应为常数均值加上与不同分类水平相关联的随机效应。具体模型取决于现有新随机值的个数。例如，在某个模型中，B 嵌套在 A 中，另外还有多次测量同时嵌套在 B 和 A 中，其中包括 nanbnw 次测量。而 A 产生了 na 个随机效应，A 中的每 nb B 个水平产生了 nanb 个随机效应，A 内 B 中的每 nw 个水平产生了 nanbnw 个随机效应，则公式如下：

其中，Z 代表每个分类水平的随机效应。假定每个 Z 均具有 0 均值且与其它所有随机项无关。那么，响应 y 的方差等于每个 z 成分产生的方差之和：

平台会估计方差成分子菜单（如下所示）中所有模型的所有这些方差。

如果您要求提供方差成分估计，则将看到如"变异性分析中的方差分析和方差成分" 所示的对话框。

“方差成分”对话框

"变异性图平台支持的模型"显示了支持的模型以及模型中的效应。

变异性图平台支持的模型
模型 | 因子 | 模型中的效应
交叉 | 1 2 3 4 5 | A A, B, A*B A, B, A*B, C, A*C, B*C, A*B*C A, B, A*B, C, A*C, B*C, A*B*C, D, A*D, B*D, A*B*D, C*D, A*C*D, B*C*D, A*B*C*D, 等等，适于 5 或 6 个因子
嵌套 | 1 2 3 4 | A A, B(A) A, B(A), C(A,B) A, B(A), C(A,B), D(A,B,C)
先交叉后嵌套 | 3 | A, B, A*B, C(A,B)
先嵌套后交叉 | 3 | A, B(A), C, A*C, C*B(A)

注：如果数据不平衡，“变异性/度量图”平台就会调用 REML 来计算方差成分。要在数据平衡时也强制平台执行 REML，请在脚本窗口中键入以下信息并执行该脚本，从而将 JSL 全局变量 Vari Chart Force REML 设定为 1。

Vari Chart Force REML = 1;

“方差分析”报表会显示模型中每个效应的显著性。“方差成分”报表会显示估计本身。在对话框中选择交叉选项后显示如"变异性分析中的方差分析和方差成分" 所示的报表。

变异性分析中的方差分析和方差成分


R&R 测量系统

测量系统分析是所有质量控制应用程序中一个非常重要的步骤。在开始研究过程本身之前，您需要确保因测量误差产生的变异小于过程中的变异。执行测量所用的仪器称为“度量”，它们的变异分析就是度量研究。如果您看到的绝大部分变异来自测量过程本身，表明您并不了解此过程的可靠性。因此，您要执行测量系统分析或度量 R&R 研究，看看测量系统本身的执行情况是否良好。

度量 R&R 结果可用于交叉模型与嵌套模型的所有组合（不管该模型是否平衡）。

您可以从过程中收集整个部件大小范围内部件的随机样本。随机选择几个操作员对每个部件进行多次测量。然后，将变异归因于以下来源：

  • 一个部件与另一个部件之间的制程变异。如果测量可靠，则它是您要研究的最终变异。
  • 多次测量所固有的变异性，即重复能力。在"度量 R&R 分析中的术语和总和定义"中，它称为内变异。
  • 因使用不同操作员测量部件而产生的变异，即重制能力。

接着，度量 R&R 分析会按重复能力和重制能力来报告此变异归因。

度量 R&R 分析中的术语和总和定义
方差总和 | 术语 | 缩写 | 备用术语
V（内） | 重复能力 | EV | 设备变异
V（操作员） | 重制能力 | AV | 评估者变异
V（操作员*部件） | 交互作用 | IV | 交互作用变异
V（内）+ V（操作员）+ V（操作员*部件） | 度量 R&R | RR | 测量变异
V（部件）1 |  | PV | 部件变异
V（内）+ V（操作员）+ V（操作员*部件）+ V（部件） | 总变异 | TV | 总变异
1 当归于部件的方差成分占总变异的 90% 以上时，表示测量系统情况良好。这也就说明对改变部件变异性所作的努力是颇有成效的。

Shewhart 控制图可以标识在某段时间内将要失控的过程；同样，变异性图也可以帮助标识均值或方差存在系统差异的操作员、仪器或部件来源。

有些分析人员使用极差代替方差来研究变异，这是因为极差更容易手动计算。但是，使用计算机进行计算会更容易一些。这一点与 Shewhart [image] 图非常相似，可以将其与极差图或准差图相互关联。但是，JMP 的“变异性图”平台仅支持方差成分方法。

度量 R&R 变异性报表

度量 R&R 报表会给出为操作员和部件的度量研究而解释的变异测量。在您选择度量研究 > 度量 R&R 选项之后，将出现如下所示的对话框，您可以在其中输入制程容忍度，也就是规格限极差 (USL - LSL)。

在本实例中，报表将统计量显示为容忍区间（规格上限 - 规格下限）的某个百分比。这些值是按值 k（一般为 6）进行标度后的方差成分和的平方根。"“度量 R&R”报表" 显示了前面所示实例的“度量 R&R”报表。

“度量 R&R”报表

Barrentine (1991) 提出对可接受的 RR 百分比（测量变异百分比）应用以下准则：

< 10% | 非常好
11%-20% | 尚可
21%-30% | 勉强可接受
> 30% | 不可接受

  • 如果在度量规格对话框中指定了容忍区间，则“度量 R&R”报表中将出现一个名称为“容许百分比”的新列。此列的计算公式为：100*(变异/容忍度)。
  • 如果在度量设置对话框中指定了历史 sigma，则“度量 R&R”报表中将出现一个名称为“制程百分比”的新列。此列定义为 100*(Variation/(K*Historical Sigma))。
  • “度量 R&R”报表下面的汇总表中提供了不同类别的数目 (NDC)。NDC 等于 (1.41*(PV/RR))，四舍五入为最近的整数。

偏差

度量研究 > 偏差选项将为每个 X 变量显示一个图形和一个汇总表，其中会提供变量 X 每个水平的平均偏或观测值与标准值之间的差。

注：“偏差”选项仅适用于已给定“标准”变量的情况。

举个实例，请使用线性分析测量.JMP 数据表。

  • 选择图形 > 变异性/度量图。
  • 在对话框中，选择响应作为 Y，响应变量。
  • 选择标准作为标准变量。
  • 选择部件作为分组变量。
  • 单击确定。
  • 从平台菜单中选择度量研究 > 偏差报表。

此时将出现如"偏差报表" 所示的输出。

偏差报表

右侧是包含每个部件的平均偏差值的表。这些偏差平均值中的每一个值均会与每个部件的实际偏差值一起标绘在图形上，因此您可了解分散情况。在本实例中，部件 2 的偏差范围较广。

线性研究

度量研究 > 线性研究选项在执行回归分析时，将标准变量用作 X 变量，并将偏差用作 Y 变量。此分析将检查偏差与部件大小之间的关系。理想的结果是斜率等于 0。如果斜率显著与 0 有显著差距，您可以得出以下结论：部件大小或作为标准测量的变量与测量能力之间存在显著关系。

注：线性研究选项仅适用于已给定“标准”变量的情况。

接着使用上面的实例，在使用线性分析测量.JMP 数据表创建度量输出后：

  • 从平台菜单中选择度量研究 > 线性研究
  • 在提示您指定制程变异的对话框中输入 16.1。

此时将出现以下输出：

线性研究

线性表示在部件大小范围内测量的准确度。

准确度百分比表示度量产生的偏差在整体制程变异中的百分比。

t 比率是用于检验斜率是否等于 0 的检验统计量。

p 值 >|t| 是指与检验斜率是否等于 0 相关联的 p 值。

R 平方用于测量回归线的拟合，表示按截距和斜率解释的偏差中的变异比例。

注：回归线方程式直接显示在图形下面。

在此您会看到斜率为 -0.131667，与斜率检验相关联的 p 值非常小 (2.04e-17)。由此，您可以得出以下结论：部件大小与测量能力之间存在显著关系。让我们再看一下输出结果，较小部件的偏差为正，即它的测量读数比实际值大；而较大部件的偏差为负，即它的测量读数比实际部件小。


判别比报表

度量研究 > 判别比选项可以将判别比表附加到“变异性”报表中。判别比用于描述对特定产品进行的给定测量的相对有效性。它会将测量的总方差 M 与测量误差的方差 E 加以比较。平台会计算选定模型中每个非嵌套主效应的判别比。判别比 D 的计算公式为：

其中

E = 整个模型的均方误差
n = 每个组中的观测值个数

一般经验是如果判别比小于 2，测量就检测不到产品变异，因此最好改进一下测量过程。如果判别比大于 4，则足以检测到不可接受的产品变异，这就表示需要改进生产过程。


属性度量图

属性度量分析用于度量按一个或多个分组变量 X 汇总的表和图形中响应（例如检验员）的一致性。属性数据是指特定变量具有有限个类别的数据。一般情况下，数据只有两种可能的结果（例如通过/失败）。

数据组织

数据应该采用如下格式，其中每个操作员均在单独的列中，因为一致性和有效性都是通过这些变量计算的。换句话说，如果要比较不同操作员之间的一致性，则每个操作员均需要在单独的 (Y) 列中。

其它所有指定变量（部件、仪器、重复等）应各自堆叠在一个列中。另外，可能还要定义一个可选的标准列，用于“有效性报表”。以 Sample Data 文件夹中包含的数据表属性量规.jmp 为例，如"属性数据实例" 所示。

属性数据实例

不同 Y 列中的响应可以是字符（通过/失败）、数值 (0/1) 或保序（低、中、高）。

启动平台

要开始属性度量分析，请选择图形 > 变异性/度量图。对于属性量规.jmp 实例，请在对话框中填写如"启动平台" 所示的信息。

启动平台

属性度量图

默认情况下，平台会在出现的图中标绘出一致百分比“%”，其值等于每个子组中的匹配项个数除以观测值个数。第一个图使用 x 轴上的所有 X（分组）变量，而第二个图则包含 x 轴（一般为检验员）上的所有 Y 变量。

一致性百分比图

注：如果定义了标准列，则选项显示有效性均值也处于可用状态，它可用于显示与标准列的一致性（即有效性）。

一致性

“一致性报表”将提供为每个 X（分组）水平汇总的一致性。

“一致性比较”将提供每个 Y 变量与其它所有 Y 变量相比的 Kappa 统计量。换句话说，每个操作员均要与其他所有操作员进行比较。

“检验员一致性”报表显示检验的项数。置信区间是得分置信区间，如 Agresti, (1998) 所述。“匹配数”定义为检验的项数和，其中检验员在各个项的每次检验都与自己一致。“检验员评分”等于“匹配数”除以“检查数”。

简单 kappa 系数可用于测量操作员之间的一致性。

其中

且

查看作为 n 个对象中的两个独立评级的两个响应变量，如果具有完整的评定者一致性，则 Kappa 系数等于 +1。当观测的一致性超过机会一致性时，Kappa 系数为正，并且其大小反映了一致性强度。尽管实际生活中不太常见，但是当观测的一致性小于机会一致性时，Kappa 系数为负。Kappa 的最小值介于 -1 和 0 之间，具体取决于边际比例。

简单 Kappa 系数的渐进方差使用下面的公式进行估计：

其中

且

报表会标绘出 Kappa 值，还会提供标准误差。

注：即使变量中的水平不同，平台也会提供属性图中的 Kappa 统计量。

一致性报表

如果指定了标准变量，则平台还会提供一个附加的 Kappa 报表，将每个操作员与标准变量进行比较。

有效性报表

在给定标准变量的情况下，还会出现“有效性报表”。

有效性报表

“一致性计数”表会提供标准变量每个水平的正确次数和不正确次数的单元格计数。

有效性定义为：

这表明，如果操作员 A 对每个部件抽样 4 次，而对第 6 个部件所做的某个决策不一致，但是平台仍然会将其余三个决策计为正确决策。

注：这一点与 MSA 第 3 版不同。在 MSA 第 3 版中，它会将操作员 A 对部件 6 的四次机会全部计为不正确。我们知道，逐个包括所有检查可以分别地向用户提供有关整体检查过程的更多信息。

在有效性报表中，有效性为 95% 置信区间。JMP 使用的是“得分置信区间”。最近的一些文献已经证明以下观点：得分置信区间可以提供更明智的答案，特别是观测值靠近边界的情况。（请参阅 Agresti, 2002）

一致性报表将显示错误警告的概率和误判的概率，其中

  • 错误警告是指确定部件不合格，但它实际上是合格的。
  • 误判是指确定部件合格，但它实际上是不合格的。

假设最低排序值为不合格值，而第二个最低排序值为合格值。

只有在标准变量具有两个水平的情况下，才会显示一致性报表。

错误分类表将显示不正确的标记，其中 y 轴代表标准值或接受的参考值的水平，x 轴包含操作员给定的水平。


石川图

因果图平台

因果图平台可以用于构造石川图（也称为鱼骨图或因果图）。

这类图表对于整理问题（果）的来源（因）很有用，例如在集思广益的讨论过程中，或在进一步的试验准备过程中用于初步分析，以确定存在的变量。

目录

准备制图数据

图表类型

互动式构建图表

文本菜单

插入菜单

移动菜单

其它菜单选项

拖放


准备制图数据

要制作因果图，请首先从数据表中两个列的数据入手。

石川图

"部分 Ishikawa 样本数据" 所示为 Ishikawa.jmp 样本数据表中的一些样本数据 (Montgomery, 1996)。

部分 Ishikawa 样本数据

请注意，父项值出现“Defects in circuit board”（1-5 行）有多种原因，已在子项列中列出。在这些原因中，“Inspection”自身又包含次原因，已在 6-8 行中列出。

注意到"石川图" 中的图形，它的中心线是“Defects in circuit board”，它的上下又有分叉的子项。“Inspection”是这些分支之一，而它本身又有子原因分支。

选择因果图以启动对话框（"因果图启动对话框"）。提供表示 X，父项（样本数据中的父项）和 Y，子项（样本数据中的子项）的列。

因果图启动对话框

在依据列中加入变量将为依据变量的每个值生成单独的因果图。标签列可以在因果图的节点中包含列里的文本。


图表类型

“因果图”平台可以绘制三种类型的图表：鱼骨图（"鱼骨图"）、层次图（"层次图"）和嵌套图（"嵌套图"）。

鱼骨图
层次图
嵌套图

要更改图表类型，请使用鼠标右键单击（Macintosh 中为按住 Control 键并单击）图表中的任意节点。当鼠标在节点上移动时，系统将高亮度显示节点。然后，请从图表类型菜单中选择所需的图表。


互动式构建图表

使用鼠标右键单击图表中的任何节点都将显示相关的菜单（"“因果图”平台节点菜单"），以便您逐步构建图表。您可以使用节点菜单在因果图中编辑新节点，这些菜单可通过使用鼠标右键单击因果图本身来访问。您甚至还可以从此处所示的默认因果图开始，直接创建因果图而无需使用数据表。

“因果图”平台节点菜单

文本菜单

有两种方法可以更改流程图中的文本外观

  • 使用鼠标右键单击图表中高亮度显示的节点。屏幕将显示如"“因果图”平台节点菜单" 所示的菜单，其中包含以下选项：
字体
显示用于选择文本字体的对话框。
颜色
显示用于选择文本颜色的对话框。
左旋转、右旋转和水平
使文本旋转至水平、向左或向右旋转 90 度（请参阅"旋转文本实例"）。
旋转文本实例
  • 使用鼠标右键单击图表中的某个词。这样将弹出包含以下选项的小菜单
字体
显示用于选择文本字体的对话框。
字体颜色
显示用于选择文本颜色的对话框。
旋转文本
使文本旋转至水平，向左或向右旋转 90 度即可（请参阅"旋转文本实例"）。
设定换行
将显示一个对话框，以便您以像素为单位设定文本的换行宽度

插入菜单

插入菜单允许您在现有节点位置插入新项目。

插入 > 前
在高亮度显示节点的相同层级中插入一个新节点。新节点将显示在高亮度显示节点之前。例如，在“子项 2”之前插入“子项 1.5”将生成如下图表。
插入 > 后
在高亮度显示节点的相同层级中插入一个新节点。新节点将显示在高亮度显示节点之后。例如，在 “子项 2”之后插入“子项 3”将生成如下图表。
插入 > 上层
在当前节点的上一层中插入一个新节点。例如，在“父项”的上一层中插入“祖父项”将生成如下图表。
插入 > 下层
在当前节点的下一层中插入一个新节点。例如，在“子项 2”的下一层中插入“孙项 1”将生成如下图表。

移动菜单

“移动”菜单允许您控制分支的显示方向，以便您自定义因果图的外观。

移动 > 第一个
将高亮度显示的节点移动至其父项下最前面的位置。例如，在切换至另一侧后，对“子项 2”执行移动最前操作将生成如下图表。
移动 > 最后一个

将高亮度显示的节点移动至其父项下最末尾的位置。

移动 > 另一面
将高亮度显示的节点移动至父项直线的另一面。例如，将“子项 2”切换至另一面将生成如下图表。
强制靠左
使所有水平绘制的元素显示在父项的左侧。
强制靠右
使所有水平绘制的元素显示在父项的右侧。
强制靠上
使所有垂直绘制的元素显示在父项的上方。
强制靠下
使所有垂直绘制的元素显示在父项的下方。
强制交替

是默认设置，可以将兄弟项交替绘制在父项直线的两侧。

其它菜单选项

更改类型
将整个图表类型更改为鱼骨图、层次结构或嵌套。
文本换行宽度
将显示一个对话框，允许您指定文本换行时的标签宽度。
制成数据表
将当前高亮度显示的节点转换为数据表。请注意，通过将此选项应用于图表的顶层，您可以将其应用于整个图表。
关闭
是一个切换命令，用于显示或隐藏高亮度显示的节点。
删除
删除高亮度显示的节点及其下面的所有内容。

拖放

您可以对因果图中的节点执行拖放操作。抓住因果图中任何选定的部分并拖动到新的位置，图中高亮度显示的长条表示节点将被拖放到的位置。

例如，下图演示了如何将元素 Setup（最初为 Temperature 的子项）拖放至另一位置，成为 Solder Process 的子项 — 也就是成为了与 Flux、Splatter 和 Chain Speed 一样的子项。

下一个实例介绍了使 Inspection 树成为 Solder Process 树的子项的两种方法。请注意，两种拖动操作最终都将获得相同的结果。

这些规则同样也适用于嵌套图和层次图。以下实例演示了将 Temperature 从原来的点（位于 Moisture Content 下）移动至 Missing from reel 下的新位置的两种方法。


基于单元格的图

平行图和方格图

本章中的图形均为数据表中每个单元格的可视化图形。平行图会将每一行用线段连接起来。方格图又称为热度图，可以将数据表显示为彩色矩阵。

目录

简介

平行坐标图

启动平台

平台选项

实例

方格图

启动平台

平台选项


简介

本章中的两种图形样式可以显示数据表中的所有单元格。两种样式都可用于查看数据中的潜在模式。

方格图是一种直接表示数据表的方法，它由矩形单元格阵列构成，且每个单元格与一个数据表条目对应。根据列中值的范围及类型，每一列均以相应的颜色表示。阵列中的彩色单元格与每个数据表条目一一对应。"狗.jmp 值的方格图" 显示了由药品类型和四种组胺级别组成的方格图。

狗.jmp 值的方格图


平行坐标图

平行坐标图可以显示代表数据表中每一行的连接线段。"狗.jmp 数据表中的组胺变量平行图" 中所示的平行图给出了狗.jmp 数据表中的四个组胺变量的平行图。同一次观测中的值被连接起来。

平行坐标图是少数能在单个图形中显示任意数量的列的图形之一。但是，其缺点在于列与列之间的关系仅在相邻的列中才明显，并且只有通过颜色或选择所需的列，您才能在多个列中跟踪线条组。这类图形最初由 Inselberg (1985) 提出，后来由 Wegman (1990) 推广。

狗.jmp 数据表中的组胺变量平行图

启动平台

要制作平行坐标图，请选择图形 > 平行图。然后将出现如"平行坐标图启动对话框" 所示的启动对话框。其中我们已填写了十项全能.jmp 中的成绩。

平行坐标图启动对话框

Y，响应变量将在图形的水平轴上显示。这些值是在输出中实际标绘和连接的值。如果将某个值指定给 X，分组角色，则系统将为该值的每个水平生成一个单独的图形。

启动对话框中将显示以下两个选项：

统一尺度
可以使用相同的尺度来表示所有的图形。也就是说，对于每个标绘的列，垂直距离将表示相同的数量。这样便可以只显示一条 Y 轴。如果没有选择此选项，每个变量将采用不同的尺度。
以零点为中心
可以要求所有的图形都以零点为中心。

平台选项

平台下拉菜单中只有两个可用选项：

显示反转复选框
允许您反转一个或多个变量的尺度。在十项全能.jmp 实例中，跳远（跳高）等田赛项目的值越大越好，而径赛项目的值则越小越好。通过反转径赛项目，较好的成绩将始终显示较高一端。
脚本
是标准的 JMP 脚本菜单。

实例

了解一些熟悉的散点图及其对应的平行图将很有帮助。在下列图中，平行图显示在左侧，而散点图则显示在右侧。

以下关系呈强正相关。请注意平行图中线条的一致性。

相反，强负相关在平行图中表现为窄颈。

现在，我们来考虑同时包含两种情况的情形：两个组，并且都具有强共线性。其中一个组的斜率为正，而另一个组为负。下图高亮度显示了斜率为正的组。

最后，考虑单个离群值的情况。平行图可以体现线条间的总体一致性，同时也表明存在一个明显的异常项。


方格图

方格图是一种直接表示数据表的方法，它由矩形单元格阵列构成，且每个单元格与一个数据表条目对应。根据列中值的范围及类型，每个单元格均以不同的颜色表示。

  • 在每个平台中，记名变量将使用不同的颜色。与其它平台一样，系统将循环使用十二种颜色：红、绿、蓝、黄、橙、蓝 - 绿、紫、黄、青、品红、黄 - 绿、蓝青、紫红。通过使用数据列的值颜色特性（通过列信息命令访问），您可以自定义记名变量和保序变量的颜色。
  • 对于连续变量，系统将指定一系列连续的颜色，以体现变量值的连续范围。
  • 保序变量与连续变量一样，均按顺序排列。

阵列中的彩色单元格与每个数据表条目一一对应。"狗.jmp 方格图" 显示了狗.jmp 数据表的方格图，其中使用了药剂、组织胺 0、组织胺 1、组织胺 3 和组织胺 5 列。

狗.jmp 方格图

由于在基因应用中需要浏览大量的基因表达水平值，方格图也因此而得以普及。

下图显示了 2002、2001 和 1997 年美国全部 50 个州的 SAT 成绩（分为语言和数学部分）。请注意，按 2002 年语言成绩排序的方格图显示了夏威夷州是一个“离群值”，因为该州的数学和语言成绩图案存在明显的差异。

启动平台

要启动“方格图”平台，请选择图形 > 方格图。屏幕将显示如"“方格图”启动平台" 所示的启动对话框。要复制"狗.jmp 方格图" 中显示的方格图，请按照"“方格图”启动平台" 中所示的方法指定变量。

启动对话框中将显示以下两个选项。

统一尺度
可以使用相同的尺度来表示所有的图形。也就是说，对于每个标绘的列，垂直距离将表示相同的数量。
以零点为中心
可以要求将所有的图形调整为零均值。
“方格图”启动平台

平台选项

有两种方法可以访问平台选项。

平台选项的位置

平台下拉菜单中包含两个选项。

图例
可以在图形的右侧附加图例（"方格图图例"）。
脚本
是标准的 JMP 脚本菜单。
方格图图例

单击鼠标右键（Macintosh 中为按住 Control 键并单击）以查看选项菜单，如"方格图选项" 所示。

方格图选项
图形类型
可以确定图形的外观。图形类型选项如"方格图图形类型" 所示。
方格图图形类型
颜色主题
可以显示颜色主题列表，这些主题将影响“色彩图”中的连续变量。请注意，如果需要印刷出版物中常用的灰度图，则黑白选项将十分有用。
以下两个命令可以根据列中的值对图形排序。要显示排序后的图形，请使用鼠标右键单击（Macintosh 中为按住 Control 键并单击）要作为排序依据的列，然后再选择排序命令。整个图形将重新排列，以便与排序后的列相对应。
升序
可以按所单击的列从低到高排列各行。
降序
可以按所单击的列从高到低排列各行。
将列向左移
可以在图中将列向左移动一格。要移动某一列，请用鼠标右键单击（Macintosh 中为按住 Control 键并单击）列，然后选择将列向左移。
无分隔线
可以显示或隐藏用于分隔每列的线，如"分隔线" 所示。
分隔线


Pareto 图

Pareto 图平台

Pareto 图是一种统计质量管理工具，用于显示一个制程或运作中问题的频数、相对频数及累积频数。它是一种条形图，显示一个质量相关制程或运作中问题的严重性（频数）。条柱按频数从左到右以降序排序，使得 Pareto 图在确定应该先解决什么问题方面很有用。

要启动“Pareto 图”平台，请使用图形菜单（或工具栏）中的 Pareto 图命令，或“JMP 起始页”窗口中 QC 选项卡中的 Pareto 图按钮。

目录

Pareto 图

指定变量角色

Pareto 图平台命令

条柱选项

启动选项

合并原因阈值

前后 Pareto 图

双因子比较 Pareto 图

每单位缺陷的分析

将缺陷数用作样本大小

在组间使用恒定样本大小

在组间使用非恒定样本大小


Pareto 图

Pareto 图命令可生成图表，用来显示一个质量相关制程或操作中问题的相对频数或严重性。Pareto 图是条形图，用于显示以降序排列的问题的分类。其中，值为问题原因的列将指定为 Y，称为制程变量。值为频数的列将指定为频数。

您也可以要求生产对比 Pareto 图，这是组合了同一制程变量的两个或多个 Pareto 图的图形显示。接着，Pareto 图可为指定为 X 角色的每个值或者为来自两个 X 变量的水平组合，生成单独的图形显示。指定 X 角色的列称为分类变量。

Pareto 图命令可以将单个 Y（制程）变量制作为不带 X 分类变量、带单个 X 变量或带两个 X 变量的图形。Pareto 工具不区分数值变量和字符变量，或不同建模类型。所有值都被视为离散的，而条柱表示计数或百分比。以下列表说明了 Pareto 图形显示的排列：

  • 不带 X 分类变量的 Y 变量将生成单个图表，其中 Y 变量的每个值都有一个条柱。
  • 带一个 X 分类变量的 Y 变量将生成一行 Pareto 图。X 变量的每个水平都有一个图形，其中每个 Y 水平都有条柱。
  • 带两个 X 变量的 Y 变量将生成多行和多列 Pareto 图。列出的第一个 X 变量的每个水平都有一行，列出的第二个 X 变量的每个水平都有一列。如前所述，对于第一个 X 变量的每个值，这些行都有一个 Pareto 图。

以下几节将逐个举例说明了这些排列。

指定变量角色

失效.jmp 表（"失效.jmp 和失效原始数据.jmp 的部分列表"）位于 Sample Data\Quality Control 文件夹中，其中列出了集成电路制作过程中失败的原因。右边表中的 N 列列出了每种缺陷发生的次数。在 Pareto 图启动对话框中，它是一个频数变量。对于显示在左边（"失效.jmp 和失效原始数据.jmp 的部分列表"）的原始数据表，不对失败原因进行分组。Pareto 图命令根据这两个表生成的结果相同。以下实例使用了带频数列的失败数据。

失效.jmp 和失效原始数据.jmp 的部分列表

选择 Pareto 图命令后，将可看到如"Pareto 图启动对话框" 所示的 Pareto 图启动对话框。选择失败列（失败原因）作为 Y，原因。这是准备用 Pareto 图检查的变量。数据表中的 N 列是频数变量。单击确定后，即可看到如"显示计数的简单 Pareto 图" 所示的 Pareto 图。

Pareto 图启动对话框

每个条柱的高度为每个类别中失败的百分比。例如，contamination 占了失败次数的 45%。条柱以降序排列，其中最常发生的失败排在左边。曲线表示失败从左到右的累积百分比。如果将工具菜单中的十字准线移至 oxide defect 条柱上，累积百分比轴显示 contamination 和 oxide defect 总共占了失败次数的 71%。

"显示计数的简单 Pareto 图" 中的初始图形在其左边显示了计数尺度、以降序排列的条柱以及累积曲线。尺度类型和条柱排列为显示选项，将在下一节介绍。这些选项设置可通过窗口标题栏中的弹出式菜单进行更改。

显示计数的简单 Pareto 图

Pareto 图平台命令

Pareto 图标题栏中的弹出式菜单可用于自定义 Pareto 图的外观。在原因子菜单中也有多个选项，这些选项可影响 Pareto 图中的各个条柱。

最初，可看到 Pareto 图选定了如上所示的多个选项。

以下命令会影响 Pareto 图的整体外观：

百分比尺度
在左垂直轴显示计数和百分比之间切换。
N 图例
在图形框中打开和关闭图例。
类别图例
在标记条柱和独立类别图例之间切换。
饼图
在条形图表示和饼图表示之间切换。
水平方向重新排序/垂直方向重新排序
有一个或多个分组变量时，对分组过的 Pareto 图重新排序。
撤消图形分组
允许将一组 Pareto 图拆分为独立的图形。
显示累积百分比曲线
切换条柱上的累积百分比曲线与右垂直轴上的累积百分比轴。
显示累积百分比轴
切换右垂直轴上的累积百分比轴。
显示累积百分比点
切换 Pareto 图每个水平的累积百分比曲线上的点。
标记累积百分比点
以累积百分比值切换累积曲线上的点的标签。
累积百分比曲线颜色
显示可用于将颜色指定为累积曲线颜色的调色板。
原因
具有多个选项，这些选项可影响一个或多个条柱。有关这些选项的说明，请参阅"条柱选项"。

"使用了显示选项的 Pareto 图" 显示了各个选项的效应。左边的图形关闭了百分比尺度选项，显示的是计数而不是百分比，并在其水平轴上使用了类别图例。其中，垂直计数轴做了重新尺度转换，在大刻度标记处有网格线。"使用了显示选项的 Pareto 图" 中的右图启用了百分比尺度选项，显示了累积百分比曲线。

使用了显示选项的 Pareto 图

条柱选项

您可通过单击条柱将其高亮度显示，还可通过按住 Shift 键并单击相邻的条柱来扩展标准方式中的选择。按住 Ctrl 键并单击（Macintosh 系统中为按住 command(命令) 键并单击）可选择多个非相邻的条形柱。选择条柱时，可访问平台菜单上影响 Pareto 图条柱的命令。这些选项也可通过使用鼠标右键单击图形区的任何地方（在 Macintosh 系统中为按住 control 键并单击）来获得。以下选项适用于图表中高亮度显示的条柱，而不是整个图表：

合并原因
合并选定（高亮度显示）条柱。
分离原因
将选定条柱分离为其原始成分条柱。
移至最前
将一个或多个高亮度显示的条柱移到左边（最前）位置。
移至最后
将一个或多个高亮度显示的条柱移到右边（最后）位置。
颜色
显示一个调色板，用于给一个或多个高亮度显示的条柱着色。
标记
使用显示累积百分比点命令时，将显示一个标记选用区，用于将标记指定累积百分比曲线上的点（与高亮度显示的条柱对应）。
标签
在所有高亮度显示的条柱上方显示条柱值。

"合并条柱实例" 左边的 Pareto 图实例是默认图形，其中每个失败原因都有一个条柱。最小的四个条柱以高亮度显示。右边的实例显示了合并的条柱。条柱高亮度显示且在弹出式菜单中选择了合并原因选项后，将显示右边的图形。合并的条形柱将自动标记为选定条形柱中最大条形柱的名称（附有 + 号和合并条形柱数），或选定条形柱的最大数（如果使用了类别图例）。通过分离原因选项，可将高亮度显示的条柱分开为原始类别。

合并条柱实例

"带条柱的 Pareto 图和相应的饼图表示" 中的图形显示了相同的数据。选择饼图显示选项时，将显示右边的图形。

带条柱的 Pareto 图和相应的饼图表示


启动选项

Pareto 图启动对话框中有如下选项。

合并原因阈值

此选项可用于指定合并原因阈值，方法是指定最小计数或最小比率。要指定阈值，请在启动对话框中选择合并原因阈值选项，如"阈值菜单" 所示。

阈值菜单

在出现的菜单中选择比率或计数，并输入阈值。

例如，使用失败单次.jmp 并指定最小计数 2 时，将产生如下 Pareto 图。计数为 2 或更少的所有原因都合并到标记为 corrosion+3 的最后一个条形柱中。（与"合并条柱实例" 进行比较，看合并了哪些原因）。

阈值计数 = 2 的 Pareto 图


前后 Pareto 图

"失效2.jmp 数据表和 Pareto 启动对话框" 显示了 Sample Data\Quality Control 文件夹中名称为失效2.jmp 的污染物数据。此表记录了清洗扩散炉中的真空管之前制造的电容器样本的失效情况，以及清洗扩散炉之后制造的电容器样本的失效情况。对于每种类型的失效，变量清洗都将样本标识为“before”或“after”。它是一个分类变量，在 Pareto 图启动对话框中充当 X 角色。

失效2.jmp 数据表和 Pareto 启动对话框

分组变量将生成一个 Pareto 图窗口，其中 X，分组变量 clean 的每个值都有并列图形。您可看到"单因子比较 Pareto 图" 中所示的两个 Pareto 图。

这些图形称为比较 Pareto 图的单元。X（分类）变量的每个水平都有一个单元。因为只有一个 X 变量，所有称之为单因子比较 Pareto 图。

单因子比较 Pareto 图

这两个图形的水平轴和垂直轴的尺度相同。第一个图形的条柱以 y 轴值的降序排列，并确定所有单元的顺序。

这两个图形以分类变量水平的字母顺序排列。分类变量的清洗的水平（“after”和“before”）显示了上述各个图形。通过单击分类标题（水平）并将其拖到同一分类的另一个水平，可以重新排列图形顺序。例如，"单因子比较 Pareto 图" 中显示的 clean 变量的比较单元是倒序的。“after”图形排在前面，并以降序排列。“before”图形排在后面，并重新排序以与“after”图形一致。这两个图形的比较显示了清洗之后氧化物缺陷减少，但用"单元重新排序的单因子比较 Pareto 图" 中的前后图形显示方式更容易解释这两个图形。

单元重新排序的单因子比较 Pareto 图

请注意，类别顺序已根据第一个单元做了调整，使它们降序排列。


双因子比较 Pareto 图

通过双因子比较 Pareto 图，可以同时研究两个分类变量的效应。假设上个实例中的电容器制造流程将监控扩散炉清洗前后的生产样本，为期三天。失效3.jmp 有一个名为日期的列，值分别为 OCT 1、OCT 2 和 OCT 3。要查看 Pareto 图的双因子数组，请选择 Pareto 图命令，并将清洗和日期都添加到 X，分组列表中，如"带两个分组变量的 Pareto 图" 所示。

带两个分组变量的 Pareto 图

两个分组变量将生成一个 Pareto 图窗口，其中显示两个 X 变量的每个水平的图形为双因子布局（"双因子比较 Pareto 图"）。左上方单元称为主单元。它的条柱以降序排列。其它单元中的条柱以与主单元相同的顺序排列。通过平台弹出式菜单上的垂直方向重新排序或水平方向重新排序选项，可对单元的行和列重新排序。移到左上角的单元将变成新的主单元，其它所有单元中的条柱将相应重新排列。

单击主单元中的条柱时，相应类别的条柱在其它所有单元中将高亮度显示。按住 Ctrl 键并单击（Macintosh 系统中为按住 command(命令) 键并单击）可选择非相邻的条形柱。

"双因子比较 Pareto 图" 说明 Pareto 图是如何突出重点的。在双因子比较 Pareto 图的每个单元中，选定了表示最常发生的两个问题的条柱。contamination 和 metallization 是所有单元的两个重要类别，但在清洗扩散炉之后就显得问题不大。

双因子比较 Pareto 图


每单位缺陷的分析

每单位缺陷的分析用于比较各组的缺陷率。JMP 计算缺陷率以及缺陷率的 95% 置信区间。根据需要，可以在启动对话框中指定样本常数大小。

虽然可以将原因合并到 Pareto 图中，但这些分析的计算不会发生相应变化。

将缺陷数用作样本大小

举个计算每单位比率的实例，使用失效多次.jmp 样本数据表（请注意，不是失效.jmp，而是失效多次.jmp）。将失败原因指定为 Y，原因且将个数指定为频数后，单击确定生成 Pareto 图。

出现 Pareto 图后，从平台下拉菜单中选择计数分析 > 按单位比率，获得如"“按单位比率”表" 所示的“按单位比率”表。

“按单位比率”表

由于在启动对话框中没有输入样本大小，因此各个原因的缺陷计数总数用于计算每个比率及其 95% 置信区间。

在组间使用恒定样本大小

使用失败多次.jmp，按"Pareto 启动对话框" 所示的方式填写对话框，然后单击确定。请注意，选择每单位分析将出现一些选项。

Pareto 启动对话框

报表出现后，选择计数分析 > 组间检验比率。这将生成如"组比较输出" 所示的表。

组比较输出

统计检验（似然比卡方）将检验两个组每个原因每单位的缺陷数 (DPU) 是否都相同。

在组间使用非恒定样本大小

要为组指定一个唯一的样本大小，请为每个组在数据表中添加行，指定特殊原因代码（如“size樱©，以将行指定为 size 行。例如，请查看摘自失败大小.jmp 中的数据。除了其它原因（Oxide Defect、Silicon Defect 等）外，还可以看到标记为 size 的原因。

要进行分析，请按"非恒定样本大小启动" 所示的方式填写 Pareto 启动对话框。

非恒定样本大小启动

单击确定后，选择按单位比率和组间检验比率，它们都位于平台下拉菜单中的计数分析下面。产生的报表如"阈值计数 = 2 的 Pareto 图" 所示。

非恒定样本大小的 Pareto 分析

请注意，样本大小 640 用于计算组 A 原因的 DPU，而样本大小 1140 用于计算组 B 中原因的 DPU。

如果有两个组变量（如 Day 和 Process），“按单位比率”列出每个原因的每个 Day 和 Process 组合的 DPU 或比率。但是，“组间检验比率”仅检验组间的整体差异。


三元图

三元图平台

要启动“三元图”平台，请使用图形菜单（或工具栏）中的三元图命令，或“JMP 起始页”窗口中图形选项卡中的三元图按钮。

三元图是一种显示三种合成数据的分布及变化的方法，如土壤中沙、泥和粘土的比例，或试验药物中三种化学药剂的比例。您可以使用以比例或绝对度量表示的数据。

三元图将以边刻度在 0 到 1 之间的三角形表示。每条侧边均代表了三种成分中的某一种。三元图中所标绘的点通过从这些点向三角形的每条侧边绘制垂直线，以其交于侧边的数据成分值来表明数值的。

目录

三元图平台

显示选项

弹簧单高跷跳实例


三元图平台

为了举例说明“三元图”平台的功能及选项，考虑 Sample Data 文件夹中的弹簧单高跷跳.jmp 文件。"弹簧单高跷跳数据表的部分内容和三元图启动对话框" 显示了部分数据。这些数据记录了 1985 年香港弹簧单高跷跳锦标赛中，7 位决赛选手的弹簧单高跷跳远测量值 (Aitchison 1986)。弹簧单高跷跳远成绩是按三次连续弹跳的总距离计算，这三次弹跳分别是单足起跳、跨步跳和跳跃。

要以单足起跳 - 跨步跳 - 跳跃对照形式查看每次跳跃的距离，请从图形菜单（或工具栏）选择三元图，或在“JMP 起始页”窗口的图形选项卡页中单击三元图按钮。填写如"弹簧单高跷跳数据表的部分内容和三元图启动对话框" 所示的对话框。

弹簧单高跷跳数据表的部分内容和三元图启动对话框

单击启动对话框中的确定按钮，“三元图”平台将显示如"弹簧单高跷跳的简单三元图" 左侧所示的默认图形。如果使用工具菜单上的放大镜工具进行缩放，您将获得右侧所示的图形，以便更详细地查看点群。

弹簧单高跷跳的简单三元图

如果等高线公式中包含未作为 Y，绘图列出的变量，JMP 会在图形下方附加滑动杆，以便您交互式调整这些值。下图中绘制了 X1、X2 和 X3，而 X4 和 X5 则显示为滑动杆。

使用十字准线工具确定图中点的精确坐标。


显示选项

三元图附带了三个显示命令，可通过三元图标题栏上的弹出式菜单进行访问：

参考标签
在三条轴上显示或隐藏标签。
参考线
显示或隐藏三角形网格线。默认情况下，平台将显示网格。
填充等高线
如果在图形中指定了等高线公式，则可以填充等高线。它允许着色为仅显示线条、填充上层和填充下层。默认情况下，平台将只显示线条。
脚本
包含可用于所有平台的命令子菜单，允许您重新分析或者将用于分析的 JSL 命令保存至窗口或文件，或与数据表一起保存。


弹簧单高跷跳实例

为了更好地了解三次跳跃对总成绩的影响，我们使用表菜单中的汇总命令按决赛者对弹簧单高跷跳.jmp 表进行汇总。要进一步分析此实例，请填写如"显示每个决赛选手和弹簧单高跷跳锦标赛总成绩的汇总表" 所示的“汇总”对话框。创建一个新的列（总计），然后使用公式编辑器计算每个决赛选手的总成绩。"显示每个决赛选手和弹簧单高跷跳锦标赛总成绩的汇总表" 中的数据表以升序排列，其中显示了选手的名次。

显示每个决赛选手和弹簧单高跷跳锦标赛总成绩的汇总表

三次跳跃的总成绩可通过三元图平台显示，如"弹簧单高跷跳锦标赛的总成绩" 中的图形所示。请注意，获胜者和失败者在三元图中均带有标签。要在图形中显示一个或多个标签变量的值，请首先使用列 > 标记/撤消标记确定要将其值显示为标签的列。然后，选择要在数据表中标记的行，如"弹簧单高跷跳锦标赛的总成绩" 左侧所示，并从行菜单中选择标记/撤消标记命令。

弹簧单高跷跳锦标赛的总成绩


树图

直观显示许多组

树图如比是在两维空间中叠在一起的条形图，充满了整个平面。当种类很多时，它将非常有用。

目录

树图

启动平台

类别

大小

颜色

顺序

平台选项

树图实例

污染

失败原因数

汽车安全方面的图示


树图

树图是在有许多水平的组中观测数据模式的图形方式。在直方图失效的情况下，它们更有用。例如，城市.jmp 数据集，它包含了 52 个城市的各种气象和人口统计量。臭氧层的水平的条形图即说明了其存在问题。

尽管很容易看出数据中有唯一的突出值，但是很难看出它对应于哪一座城市。

树图通过在两维上折叠数据来解决这个问题。树图不是为每一个测量绘制单个条形柱，而是通过改变矩形区域的大小或颜色表示数据的大小。

Ben Schneiderman 提出了树图的概念并且大力推广，有一个网站详尽地介绍了这种观点（http://www.cs.umd.edu/hcil/treemap-history/index.shtml）。

一个实例清楚地阐明这种观点。选择图形 > 树图，并且将城市指定为类别变量，将臭氧指定为颜色变量，可以生成上面直方图对应的树图。

按臭氧着色的城市图

通过从连续的色谱中给正方形上色，显示每个城市的臭氧水平。深绿色对应于低的臭氧值，深红色对应于高的臭氧值。随着普通值的增多而降低颜色的深度，因此，淡绿色和粉红色表示值接近平均的臭氧水平。标识为黑色的城市颜色变量为缺失值。

由于我们没有指定任何大小或排列选项，因此树图按字母顺序划分。


启动平台

在选择图形 > 树图之后，您会看到下面的对话框。

树图启动对话框

类别

唯一需要的变量角色是类别变量。在您只指定了类别变量后，JMP 会产生一个树图，图中正方形的颜色来自旋转调色板，按字母顺序排列，并且按照每个组出现的次数确定大小。将城市指定为类别变量将产生类似"只以城市分类" 所示的图。大多数矩形面积相等，因为每个城市只有一个数据点。Portland 有两个测量，因此它的区域大小是其它城市的二倍。

只以城市分类

将两个变量指定给类别，也就是告诉 JMP 按照第一个变量将树图分组，并且按照第二个变量在组中排序。例如，"两个类别的树图" 将地区和城市（按照该顺序）指定为“类别”角色。

两个类别的树图

大小

如果您希望正方形的大小对应于变量的水平，将该变量指定为“大小”角色。按照指定变量的比例绘制由此产生的矩形区域。

例如，查看将城市作为类别变量并将人口作为大小变量的树图（"使用“大小”角色的树图"）

使用“大小”角色的树图

大城市通过大的矩形表示，小城市通过小的矩形表示。

颜色

指定颜色变量，以使矩形的颜色对应于变量的水平。如果颜色变量是连续的，颜色将沿着从绿（低）到红（高）的连续尺度变化。在变量的值取极值时颜色最深，较淡的颜色对应于接近均值的水平。

"按臭氧着色的城市图" 指定城市作为类别变量，臭氧作为颜色变量。正方形的大小仍然以类别变量的出现次数为基础，但是颜色对应于臭氧值。很明显，洛杉矶的值很高。

注：颜色变量的缺失值被绘制成黑色的矩形。

如果颜色变量是分类变量，将从 JMP 的调色板中按顺序选择颜色。在下面的实例中，为类别指定了变量城市，为颜色指定了变量地区。排序（按字母顺序）和大小（出现的次数）使用了默认值。

城市按地区着色

顺序

在默认情况下，按字母顺序绘制树图的方块，值从左上角排到右下角。要更改顺序，请使用顺序角色。

如果您指定了单个顺序变量，绘制方块时高水平的变量聚在一起，低水平的变量聚在一起。例如，下面的树图使用城市作为类别变量，人口作为顺序变量。

使用一个顺序变量的树图

如果您指定两个顺序变量，JMP 产生一个树图，该图按第一个顺序变量横向排列方块，同时按第二个顺序变量纵向排列方块。对于地理数据，这非常有用。例如，城市.jmp 数据集中的变量 X 和 Y 对应于城市的地理位置。"使用两个顺序变量的树图" 中显示了以 X 和 Y 作为顺序变量的树图。

使用两个顺序变量的树图


平台选项

除了标准的 JMP 脚本菜单之外，树图还有以下选项：

更改颜色列
可以从平台下拉菜单中选择。它显示一个对话框，允许您更改给方形着色所使用的列。从对话框中选择新列，并且单击确定即可。

使用鼠标右键单击树图本身，可以访问以下两个选项：

抑制框
关闭显示每个框的黑色轮刻画器。
忽略组层次结构
使层次结构只有一层，并且按排序列排列，而且不使用组合（定义单元格除外）。


树图实例

上面介绍的选项可以组合在一起，用来形成一些有趣的图形。

污染

我们使用同样的数据集，可以查看美国不同的污染指标分布情况，并且显示地理位置和城市人口。

例如，要查看各个城市的臭氧水平，将城市指定为类别，人口指定为大小，同时将 X 和 Y 指定为顺序，这将臭氧指定为颜色。这将产生如"臭氧水平" 所示的图形。

臭氧水平

通过该图形，您可以看出西部城市洛杉矶的臭氧水平很高。其它大城市的臭氧水平略高（Chicago 和 Houston），并且一些大城市的臭氧水平略低于平均水平（New York 和 Washington）。

使用同样的方式可以检查铅的水平。另外一个树图使用了类似的设置（将城市指定为类别，人口指定为大小，同时将 X 和 Y 指定为顺序），但是，将铅指定为颜色变量，产生如"铅的水平" 的图。

铅的水平

Seattle（西北的城市）和 Cleveland（接近国家中部的城市）的铅水平很高。很显然，其它大多数城市的铅水平相当低。请注意，一些城市 (Raleigh, Phoenix) 的铅水平为缺失值。

失败原因数

Pareto 平台可能本身就适用于数量少的类别，树图可以在质量控制情形中用于检查失败的情况。例如，下面的树图使用失效3.jmp 样本数据文件，它位于 Quality Control 子目录中。

其中的树图使用失败和清洗作为类别，N 作为大小，并且将清洗作为颜色。通过查看该图，很显然污染是失败的最大原因，“之前”测量出现的污染比“之后”测量出现的污染要更加严重。

失败树图

汽车安全方面的图示

数据文件汽车.jmp 包含了在汽车安全检验中各个碰撞检验点的测量值。树图让您可以比较不同汽车制造商和车型的这些测量值。

左轮减速的树图

"左轮减速的树图" 显示了将制造商和车型作为类别，车外形尺寸作为大小以及左轮减速（测量左轮减速，在这种情况下，更多的减少将造成的伤害）作为颜色而产生的图。

该图显示有些车似乎由于左轮减速值很大而遭到损坏，Subaru 的中型车 Legacy 最为明显。

您可以从平台下拉菜单中选择更改颜色列并选择另一个颜色列，快速地查看其它安全测量资料。您可以使用该命令来比较不同的测量资料。例如，尽管 Legacy 车型在左轮减速方面得分很差，但是在头部伤害方面的测量指标很好。标致车遇到的问题刚好相反，将"左轮减速的树图" 与"潜在头部伤害的树图" 比较就可以看出这一点（其中颜色列是头部损坏标准）。

潜在头部伤害的树图


统计细节

JMP 中的模型

本附录介绍了不同类型的响应模型、它们的因子、它们的设计代码和参数化。本附录还包括关于正文中所介绍的方法的其它许多细节。

JMP 系统将线性模型与三种不同的响应模型拟合，这三种模型分别标记为连续、保序和记名。不同的响应模型之间在因子方面有许多相同的情况，但是，JMP 只支持连续响应的图形和边缘刻画，不支持保序响应和记名响应的图形和边缘刻画。

不同的计算机程序使用不同的设计矩阵代码，也就产生了不同的参数化，用以拟合效应和构建假设检验。尽管在大多数情况下，JMP 和 SAS GLM 程序产生相同的结果，但是 JMP 使用了与 SAS 系统中的 GLM 程序不同的代码。下面的部分介绍了 JMP 编码的细节，并且重点突出了它与经常被作为行业标准提及的 SAS GLM 程序有哪些不同。

目录

响应模型

连续响应

记名响应

保序响应

连续因子

记名因子

参数的解释

交互作用和交叉效应

嵌套效应

记名因子之间的最小二乘均值

有效的假设检验

记名效应中的奇异性和缺失的单元格

保序因子

保序交互作用

保序交叉模型的假设检验

保序最小二乘均值

保序效应中的奇异性和缺失单元格

缺失单元格的实例

杠杆率图细节

多元详细资料

多元检验

近似的 F 检验

典型详细资料

判别分析

功效计算

计算 LSV

计算 LSN

计算功效

计算调整功效

包含置信限的反预测

随机效应详细资料


响应模型

JMP 将三种线性模型与三种不同的响应拟合：连续、记名和保序响应。

连续响应

JMP 将按最小二乘拟合线性模型，以通常的方式建立连续响应的模型。支持连续响应的分析工具比其它响应类型要丰富得多。可使用杠杆率图、最小二乘均值、对比和输出公式来分析连续响应。记名响应或保序响应与其相对应的其中任何一项功能。从计算的角度来看，连续响应最容易拟合。

记名响应

记名响应使用简单的逻辑斯蒂模型的扩展进行分析。如果是二元（两个水平）响应，逻辑斯蒂响应模型是

可以写成

其中的 [image] 是标准逻辑斯蒂分布的累积分布函数

r 个响应的扩展将每个响应概率与第 r 个概率相关，并且将一组独立的设计参数与这 [image] 个模型拟合。

对于

使用改进的 Newton-Raphson 迭代算法完成极大似然拟合。

保序响应

将一系列平行的逻辑斯蒂曲线与累积概率拟合，建立保序响应的模型。每个曲线有相同的设计参数，但是截距不同，形式如下：

for

其中出现了 r 个响应水平，且 [image] 是标准的逻辑斯蒂累积分布函数

另一种表达方式是按照无法观测的连续变量 z，该变量造成保序响应在与各阈值交叉时发生变化

其中 z 代表线性模型的无法观测函数和误差

并且 ε 具有逻辑斯蒂分布。

由于这些模型能够识别响应的保序字符，因此它们很具吸引力，与记名模型相比，它们需要的参数更少，即使涉及到迭代极大似然的计算，它们的计算速度也很快。


连续因子

连续因子直接作为回归量放入设计矩阵中。如果某个列是其它列的线性函数，该列的参数将被标记为以零固定或不可估计。连续因子在与其它因子（交互和多项式项）交叉时，按照它们的均值居中。如果因子有混合或代码的列属性，或者在指定模型时关闭了居中的多项式选项，居中操作将不会进行。如果有代码列性质，则在拟合之前先对因子进行代码。


记名因子

记名因子被转换为设计矩阵的指标变量。SAS GLM 为每一个记名水平构建了一个指标列。JMP 为除最后一个水平以外的其它每个记名水平构建相同的指标列。在出现最后一个记名水平时，将从因子的其它所有列中减去 1。例如，设想 GLM 和 JMP 的记名因子 A，它包含三个代码的水平，如下所示。

 | GLM |  |  | JMP
A | A1 | A2 | A3 | A13 | A23
A1 | 1 | 0 | 0 | 1 | 0
A2 | 0 | 1 | 0 | 0 | 1
A3 | 0 | 0 | 1 | -1 | -1

在 GLM 中，线性模型设计矩阵在列中有线性相依性，所以最小二乘解使用了广义逆矩阵。选择的解刚好是 A3 参数被设置为零。

在 JMP 中，对线性模型设计矩阵进行代码，除非它们是缺失的单元格或其它偶然的共线性，否则将使其能够达到满秩。最后一个水平的 A 效应参数是其它水平的负总和，使所有的效应水平参数总和为零。

参数的解释

注：记名水平的参数被解释成该水平的预测响应与所有水平的平均预测响应之间的差异。

因子水平的设计列是由该因子水平的 0 - 1 指标减去最后一个水平的指标构建而得。这就是构成以上参数解释的代码。
JMP 参数报表 | 如何解释 | 设计列代码
截距 | 所有水平的均值 | 1
A[1] |  | (A==1) - (A==3)
A[2] |  | (A==3) - (A==3)

交互作用和交叉效应

GLM 和 JMP 交互效应的构建方式都是取要交叉的因子的设计列的行的直积。例如，GLM 代码

 PROC GLM;
 CLASS A B;
 MODEL A B A*B;

产生此设计矩阵：

 |  | A |  |  | B |  |  | AB
A | B | 1 | 2 | 3 | 1 | 2 | 3 | 11 | 12 | 13 | 21 | 22 | 23 | 31 | 32 | 33
A1 | B1 | 1 | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
A1 | B2 | 1 | 0 | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0
A1 | B3 | 1 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0
A2 | B1 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0
A2 | B2 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0
A2 | B3 | 0 | 1 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0
A3 | B1 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0
A3 | B2 | 0 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0
A3 | B3 | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1

使用 JMP 模型拟合命令并要求为列 A 和 B 生成因子模型，产生以下设计矩阵。请注意，该矩阵中的 A13 是前面矩阵中的 A1-A3。但 A13B13 在当前的矩阵中是 A13*B13。

 |  | A |  | B |  | A13 | A13 | A23 | A23
A | B | 13 | 23 | 13 | 23 | B13 | B23 | B13 | B23
A1 | B1 | 1 | 0 | 1 | 0 | 1 | 0 | 0 | 0
A1 | B2 | 1 | 0 | 0 | 1 | 0 | 1 | 0 | 0
A1 | B3 | 1 | 0 | -1 | -1 | -1 | -1 | 0 | 0
A2 | B1 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 0
A2 | B2 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 1
A2 | B3 | 0 | 1 | -1 | -1 | 0 | 0 | -1 | -1
A3 | B1 | -1 | -1 | 1 | 0 | -1 | 0 | -1 | 0
A3 | B2 | -1 | -1 | 0 | 1 | 0 | -1 | 0 | -1
A3 | B3 | -1 | -1 | -1 | -1 | 1 | 1 | 1 | 1

JMP 代码为解决较少水平的因子交互问题节省了内存和一些计算时间。

嵌套效应

GLM 中的嵌套效应与交互效应的代码相同，因为 GLM 根据不在模型中的效应确定适当的检验。模型中未包括的效应可能让包含交互的（或同等意义的嵌套）效应包含了其效应。

JMP 中的嵌套效应的代码方式与此不同。JMP 在括号中使用项，作为每个组的分组项。对于嵌套项的每一个水平组合，JMP 构建括号之外的效应。在嵌套项的水平之间，外部项的水平不需要排列成行。在设计列和参数的构建方面，需分别考虑嵌套的每一个水平。

 |  |  |  | B(A)
 |  |  |  | A1 | A1 | A2 | A2 | A3 | A3
A | B | A13 | A23 | B13 | B23 | B13 | B23 | B13 | B23
A1 | B1 | 1 | 0 | 1 | 0 | 0 | 0 | 0 | 0
A1 | B2 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0
A1 | B3 | 1 | 0 | -1 | -1 | 0 | 0 | 0 | 0
A2 | B1 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0
A2 | B2 | 0 | 1 | 0 | 0 | 0 | 1 | 0 | 0
A2 | B3 | 0 | 1 | 0 | 0 | -1 | -1 | 0 | 0
A3 | B1 | -1 | -1 | 0 | 0 | 0 | 0 | 1 | 0
A3 | B2 | -1 | -1 | 0 | 0 | 0 | 0 | 0 | 1
A3 | B3 | -1 | -1 | 0 | 0 | 0 | 0 | -1 | -1

记名因子之间的最小二乘均值

最小二乘均值指将其它所有因子设置为一些中间值之后与一些水平组合对应的预测值。直接连续回归量的中间值被定义为样本均值。包含无关记名因子的效应的中间值被定义为针对（在我们的代码中结果刚好全部是零的）水平产生的平均效应。保序因子使用"保序最小二乘均值"中其它的中间值。最小二乘均值可能无法估计，如果无法估计，它们将标记为不可估计。JMP 的最小二乘均值在除了使用权重的其它所有情况下都与 GLM （Goodnight 和 Harvey 1978）的最小二乘均值一致。在使用权重的情况下，JMP 使用中间值的加权均值，而 GLM 使用中间值的未加权均值。

如果使用三个与三个交叉模型的参数，则单元格的期望值是

 B1 B2 B3
A1
A2
A3

有效的假设检验

通常，JMP 产生的假设检验与其它大多数可以信赖的程序的假设检验一致，例如 SAS PROC GLM 程序（III 和 IV 类假设）。下面两部分介绍它们之间的区别。

在 SAS GLM 程序中，您可以通过查看可估计函数的通用形式，仅仅查找感兴趣效应及其所包含效应的函数 (Goodnight 1978)，来构建 III 类和 IV 类假设检验。

在 JMP 中，您也可以构建同样的检验，但是由于参数化不同，因此，通过对该效应的所有参数执行联合检验，可以检验效应（假设现在是满秩）。检验不涉及到包含交互作用参数，因为代码使它们在包含的效应方面与检验无关。

如果有缺失的单元格或其它奇异性，JMP 检验不同于 GLM 检验。有几种方式描述它们：

  • JMP 检验相当于检验最小二乘均值不相同，至少是检验主效应的最小二乘均值不相同。如果最小二乘均值不可估计，则检验不能包括一些比较，因此失去了自由度。对于交互作用，JMP 不仅仅可通过模型中的包含效应所描述的边缘模式来检验最小二乘均值的不同。
  • JMP 通过将具有该效应的模型 SSE 与不具有该效应的模型 SSE（至少是没有嵌套的项，使逻辑稍微变得复杂）进行比较来检验效应。JMP 参数化使得这种方法有意义。
  • 尽管 JMP 使用了结构参数化，而不是单元格均值参数化，但是 JMP 实现了 Hocking (1985, 80-89, 163-166) 描述的有效假设检验。有效假设检验从效应所需的假设开始，并且“尽可能”包括该检验的所有内容。当然，如果存在缺失单元格的包含效应，则该检验会由于完整的假设不可估计，而必须放弃一部分假设。有效假设尽可能放弃完整假设很少的一部分。
  • 然而，在 JMP 和 GLM（以及其它程序）中，与存在缺失的单元格相关的假设检验之间的差异并不会被视为感兴趣的检验。如果交互作用很显著，则所包含的主效应检验不会引人注意。如果交互作用不显著，则始终可以从模型中放弃该交互作用。一些检验甚至不是唯一的。如果您在缺失的单元格设计中重新标记水平，GLM IV 类检验可能会发生变化。

下面的部分将继续更详细地介绍该主题。

记名效应中的奇异性和缺失的单元格

假设在设计列之间出现线性相依性的情形。在使用 JMP 编码时，除非没有充足的数据填充需要估计的组合，或者有某种效应混杂或共线性，否则不会出现这种情况。

在出现线性相依性时，该参数的最小二乘解可能不是唯一的，并且可能无法进行某些假设检验。JMP 选择的方法是按顺序将参数估计设置为零，因为 JMP 发现它们的设计列与模型中以前的效应存在线性相依性。报表中的特定列显示哪些参数估计被调整为零，以及哪些参数估计是可以估计的。单独的奇异性报表显示什么是线性相依性。

在奇异性的情况下，JMP 检验的假设可以不同于 GLM 选择的假设。一般来说，JMP 相比 GLM 其检验的自由度更小，因为它以更高的边缘标准接受检验。换句话说，JMP 检验始终对应于在该效应的最小二乘均值之间的检验，但是 GLM，其检验始终没有这种属性。

例如，假设有一个双向模型，它包含交互作用和一缺失的单元格，其中 A 有三个水平，B 有两个水平，并且 A3B2 单元格缺失

每个单元格的期望值是

 B1 B2
A1
A2
A3

很显然，包含数据的任何单元格都有可以估计的期望值。缺失的单元格有不可估计的期望值。事实上，它的期望值正好是奇异性报表中设计列的线性组合

假设您要构建一个检验，比较 B1 和 B2 的最小二乘均值。在本实例中，上表中列的平均值提供了这些最小二乘均值。

LSM(B1) =
LSM(B2) =
LSM(B1) - LSM(B2) =

请注意，这就表示检验 β1 参数相当于最小二乘均值相同的检验。但是，由于 β1 不可估计，此此检验不可估计，并意味着它没有自由度。

现在，在 A 水平之间构建最小二乘均值检验。

LSM(A1) =
LSM(A2) =
LSM(A3) =
LSM(A1) - LSM(A3) =
LSM(A2) - LSM(A3) =

这些都不可估计，但是另外有一种比较可以估计，也就是比较没有缺失单元格的两个 A 列。

LSM(A1) - LSM(A2) =

尽管该效应有两个参数，但是，JMP 使用 1 个自由度检验来真正检验该组合。

使用奇异性组合获取内积并检验它是否为零，可以来验证其是否可以估计。

 | 奇异性 | 组合
参数 | 要检验 | 的组合
m | 1 | 0
a1 | -1 | 1
a2 | -1 | -1
b1 | -1 | 0
ab11 | 1 | 0
ab21 | 1 | 0

结果是任何交互的缺失单元格的设计列始终破坏（记名因子）主效应的自由度。因此，对于检验与这些最小二乘均值对应的效应，最小二乘均值的不可估计性与失去自由度之间有直接的关系。

如何将其与 GLM 进行比较？在没有缺失的单元格时，GLM 和 JMP 执行相同的检验。也就是说，它们有效地检验最小二乘均值是否相等。但是在 GLM 遇到奇异性时，它根据奇异性是 III 类还是 IV 类，从而以不同的方式使这些单元格被忽略。如果是 IV 类，它查找可以发现的可估计组合。这可能不是唯一的，并且如果您重新排列水平，可能会有不同的结果。如果是 III 类，它使可估计函数正交，以获得唯一的检验。但是，从单元格均值的角度来看，可能不好解释检验。

尽管 JMP 与 GLM 相比，起初您会因为失去更多的自由度而苦恼，但是 JMP 的处理方法有一些独到之处：

  1. 检验合情合理地与 LSM 相关。
  2. 检验使用重新参数化模型的减量平方和使计算更为简便。
  3. 检验与 Hocking 的“有效假设检验”一致。
  4. 检验是整体边际检验，意味着它们始终彻底经历交互作用中的其它效应。

最后一点需要一些详细说明：以前面的实例为例，假设考虑 A3B2 缺失单元格的单元格均值的期望值图形。

图形显示缺失单元格的期望单元格均值。A1 和 A2 单元格的均值刻画线穿过 B 水平。JMP 的处理方法表明您不能检验包含缺失的 A2B3 单元格在内的主效应 A，因为缺失的单元格的均值可以是任意值（交互作用项允许此情况发生）。如果缺失的单元格的均值是所示的比较高的值，A 效应将检验非显著性。如果是比较低的值，它将检验显著性。关键您不知道真实情况如何。这就是在声明最小二乘均值不可估计时它们所要表明的内容。这也是效应假设应该表明的内容 — 这一点您不知道。

如果您要检验涉及到单元格子集边缘的假设，那么这就是 GLM IV 类所做的事情。在 JMP 中，您必须执行许多计算或使用对比划分效应，从而自己来构建这类检验。

JMP 与 GLM 区别的实例

GLM 的处理方式不同于 JMP，并且在有缺失的单元格的情形下产生不同的假设检验。尤其是 GLM 不能识别效应中的嵌套与交叉有何不同，但是 JMP 可以识别其中的差异。假设您顺着嵌套设计往下看时，有 A、B(A) 和 C(A B) 三层嵌套，每一个嵌套有不同的水平数。

"比较 GLM 和 JMP 假设"给出了关于 GLM 参数的主效应 A 的检验。第一组列是 JMP 执行的检验。第二组列是 GLM IV 类执行的检验。第三组列是与 JMP 执行的检验等效的检验；它是已经乘以该矩阵的前两列

以便可与 GLM 检验进行比较。最后一组列是 GLM III 类检验。区别在于检验如何在包含的效应之间分布。在 JMP 中，它似乎更像沿着从上往下的结构。在 GLM IV 类中，检验似乎更像沿着从下往上的结构。实际上，检验统计量通常相似。

比较 GLM 和 JMP 假设
参数 | A 的 JMP 检验 |  | A 的 GLM-IV 检验 |  | JMP 旋转检验 |  | A 的 GLM-III 检验
u | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
a1 | 0.6667 | -0.3333 | 1 | 0 | 1 | 0 | 1 | 0
a2 | -0.3333 | 0.6667 | 0 | 1 | 0 | 1 | 0 | 1
a3 | -0.3333 | -0.3333 | -1 | -1 | -1 | -1 | -1 | -1
a1b1 | 0.1667 | -0.0833 | 0.2222 | 0 | 0.25 | 0 | 0.2424 | 0
a1b2 | 0.1667 | -0.0833 | 0.3333 | 0 | 0.25 | 0 | 0.2727 | 0
a1b3 | 0.1667 | -0.0833 | 0.2222 | 0 | 0.25 | 0 | 0.2424 | 0
a1b4 | 0.1667 | -0.0833 | 0.2222 | 0 | 0.25 | 0 | 0.2424 | 0
a2b1 | -0.1667 | 0.3333 | 0 | 0.5 | 0 | 0.5 | 0 | .5
a2b2 | -0.1667 | 0.3333 | 0 | 0.5 | 0 | 0.5 | 0 | .5
a3b1 | -0.1111 | -0.1111 | -0.3333 | -0.3333 | -0.3333 | -0.3333 | -0.3333 | -0.3333
a3b2 | -0.1111 | -0.1111 | -0.3333 | -0.3333 | -0.3333 | -0.3333 | -0.3333 | -0.3333
a3b3 | -0.1111 | -0.1111 | -0.3333 | -0.3333 | -0.3333 | -0.3333 | -0.3333 | -0.3333
a1b1c1 | 0.0833 | -0.0417 | 0.1111 | 0 | 0.125 | 0 | 0.1212 | 0
a1b1c2 | 0.0833 | -0.0417 | 0.1111 | 0 | 0.125 | 0 | 0.1212 | 0
a1b2c1 | 0.0556 | -0.0278 | 0.1111 | 0 | 0.0833 | 0 | 0.0909 | 0
a1b2c2 | 0.0556 | -0.0278 | 0.1111 | 0 | 0.0833 | 0 | 0.0909 | 0
a1b2c3 | 0.0556 | -0.0278 | 0.1111 | 0 | 0.0833 | 0 | 0.0909 | 0
a1b3c1 | 0.0833 | -0.0417 | 0.1111 | 0 | 0.125 | 0 | 0.1212 | 0
a1b3c2 | 0.0833 | -0.0417 | 0.1111 | 0 | 0.125 | 0 | 0.1212 | 0
a1b4c1 | 0.0833 | -0.0417 | 0.1111 | 0 | 0.125 | 0 | 0.1212 | 0
a1b4c2 | 0.0833 | -0.0417 | 0.1111 | 0 | 0.125 | 0 | 0.1212 | 0
a2b1c1 | -0.0833 | 0.1667 | 0 | 0.25 | 0 | 0.25 | 0 | 0.25
a2b1c2 | -0.0833 | 0.1667 | 0 | 0.25 | 0 | 0.25 | 0 | 0.25
a2b2c1 | -0.0833 | 0.1667 | 0 | 0.25 | 0 | 0.25 | 0 | 0.25
a2b2c2 | -0.0833 | 0.1667 | 0 | 0.25 | 0 | 0.25 | 0 | 0.25
a3b1c1 | -0.0556 | -0.0556 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667
a3b1c2 | -0.0556 | -0.0556 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667
a3b2c1 | -0.0556 | -0.0556 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667
a3b2c2 | -0.0556 | -0.0556 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667
a3b3c1 | -0.0556 | -0.0556 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667
a3b3c2 | -0.0556 | -0.0556 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667 | -0.1667


保序因子

使用保序建模类型标记的因子的代码方式不同于记名因子。参数估计的解释方式不相同，检验不相同，并且最小二乘均值也不相同。

保序因子的关键是：第一个因子水平是控制水平或基线水平，并且当保序因子被设为随后的每一个水平时，参数将测量对响应造成的影响。代码适合于表示各种剂量水平的因子，其中第一个剂量是零：

项 | 代码列 |  |
A | a2 | a3 |
A1 | 0 | 0 | 控制水平，零剂量
A2 | 1 | 0 | 低剂量
A3 | 1 | 1 | 高剂量

从 JMP 参数化的角度来看，A 检验是

参数 | GLM - IV 检验 |  | JMP 检验
μ | 0 | 0 | 0 | 0
a13 | 2 | 1 | 1 | 0
a23 | 1 | 2 | 0 | 1
a1:b14 | 0 | 0 | 0 | 0
a1:b24 | 0.11111 | 0 | 0 | 0
a1:b34 | 0 | 0 | 0 | 0
a2:b12 | 0 | 0 | 0 | 0
a3:b13 | 0 | 0 | 0 | 0
a3:b23 | 0 | 0 | 0 | 0
a1b1:c12 | 0 | 0 | 0 | 0
a1b2:c13 | 0 | 0 | 0 | 0
a1b2:c23 | 0 | 0 | 0 | 0
a1b3:c12 | 0 | 0 | 0 | 0
a1b4:c12 | 0 | 0 | 0 | 0
a2b1:c13 | 0 | 0 | 0 | 0
a2b2:c12 | 0 | 0 | 0 | 0
a3b1:c12 | 0 | 0 | 0 | 0
a3b2:c12 | 0 | 0 | 0 | 0
a3b3:c12 | 0 | 0 | 0 | 0

因此，从 JMP 的角度来看，GLM 检验看起来有点奇怪，它将系数放在 a1b24 参数上。

这种设计模式造成下三角为 1，其他地方为 0。

对于简单的主效应模型，这可以写成

请注意，μ 是 [image] 条件下的期望响应， [image] 是 [image] 条件下的期望响应， [image] 是 [image] 条件下的期望响应。因此， [image] 估计从 [image] 移至 [image] 的效应，并且 [image] 估计从 [image] 移至 [image] 的效应。

如果保序主效应的所有参数有相同的符号，则响应效应在保序水平之间是单调的。正在构思的将来的 JMP 功能可以执行参数化：能够将单调性应用于估计并检验估计的单调性（Barlow et.al.1972; Robertson et.al.1988）。我们希望与未约束模型中的检验相比，单调性约束可以带来功效更强的检验。

保序交互作用

保序交互作用与记名效应类似，它是通过因子列的水平直积产生的。假设有两个保序因子 A 和 B，每一个因子有三个水平。JMP 的保序代码产生接下来显示的设计矩阵。交互作用模式是全一下三角矩阵的区组下三角矩阵。

 |  |  |  |  |  | A*B
 |  |  |  |  |  | A2 |  | A3
A | B | A2 | A3 | B2 | B3 | B2 | B3 | B2 | B3
A1 | B1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
A1 | B2 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0
A1 | B3 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 0
A2 | B1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0
A2 | B2 | 1 | 0 | 1 | 0 | 1 | 0 | 0 | 0
A2 | B3 | 1 | 0 | 1 | 1 | 1 | 1 | 0 | 0
A3 | B1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0
A3 | B2 | 1 | 1 | 1 | 0 | 1 | 0 | 1 | 0
A3 | B3 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1

保序交叉模型的假设检验

要知道参数的含义，请查看关于参数的期望单元格均值表，其中 μ 是截距，α2 是水平 A2 的参数，依此类推。

 B1 B2 B3
A1
A2
A3

请注意，A 的主效应检验实际上是检验在第一个水平含有 B 的 A 水平。同样，B 的主效应检验是在第一个水平含有 A 的各种 B 水平的顶部行之间进行检验。在进行两个因子都是不同的治疗剂量的试验时，这是一种合适的检验。主要问题是每一种治疗本身的功效，当应用了两种药物的剂量时，专门用于表示药物交互作用的要点很少。在一些情况下，每一种药物应用的剂量很大，可能会很危险。

请注意，添加与每个单元格相关的所有参数，也就是单元格左边或上面的参数，包括当前行和当前列，就可以获取每一个单元格的期望值。最后一个单元格的期望值是所有参数的总和。

尽管在使用保序和记名代码时，被其它效应包含的效应的假设检验各不相同，但是，不被其它效应包含的效应的检验是相同的。在上面的交叉设计中，不管 A 和 B 是记名拟合还是保序拟合，交互检验是相同的。

保序最小二乘均值

正如前面介绍的那样，最小二乘均值是指将其它所有因子设置为一些中间值之后，与一些水平组合对应的预测值。JMP 将无关的保序因子作为第一个水平（表示控制或基线水平）的影响，从而定义效应的中间值。

针对保序因子的这种最小二乘均值的定义继续秉承了如下思想：包含效应的假设检验等同于最小二乘均值是相等的检验。

保序效应中的奇异性和缺失单元格

通过保序代码，您可以说保序效应的第一个水平是基线水平。因此，即使在交互作用中有缺失的单元格，甚至您没有交互作用数据，也可以很好地检验主效应。

缺失单元格的实例

该实例与上面的实例相同，除了 A3B2 单元格没有数据之外，每个单元格有两个观测值。现在你可以将以记名方式对因子进行代码时的结果与以保序方式对因子进行代码时的结果相比较。总体上模型的整体拟合与"比较记名拟合和保序拟合的汇总信息" 中所示的表中看到的拟合相同。

Y | A | B
12 | 1 | 1
14 | 1 | 1
15 | 1 | 2
16 | 1 | 2
17 | 2 | 1
17 | 2 | 1
18 | 2 | 2
19 | 2 | 2
20 | 3 | 1
24 | 3 | 1

比较记名拟合和保序拟合的汇总信息

由于代码不同，参数估计也大不相同。请注意，缺失的单元格影响所有记名参数的可估计性，但是不影响其它保序参数的可估计性。

比较记名拟合和保序拟合的参数估计

奇异性详细信息表明线性相依性（并且也通过检查值指出缺失的单元格）。

比较记名拟合和保序拟合的奇异性信息

如果是记名拟合，效应检验会缺少自由度。在 B 情况下，没有检验。如果是保序拟合，由于第一个水平基线没有缺失的单元格，因此不会缺少自由度。

比较记名拟合和保序拟合的效应检验

最小二乘均值也不相同。并不是所有的记名 LSM 都可以估计，但是所有的保序 LSM 可以估计。您可以通过查看单元格均值验证均值。请注意，两种拟合的 A*B LSM 是相同的。"记名拟合和保序拟合的最小二乘均值" 显示了记名拟合和保序拟合的最小二乘均值。

记名拟合和保序拟合的最小二乘均值


杠杆率图细节

Sall (1980) 提出了一般线性假设的杠杆率图。本部分介绍了这篇专著中的一些细节。杠杆率图综合了 Belsley、Kuh 和 Welsch (1980) 的部分回归残差杠杆率图，以便应用于任何线性假设。假设您所关心的可估计假设是

杠杆率图通过标绘点来表现该检验的特点，以使每个点与倾斜的回归线的距离表示未约束的残差，在假设约束拟合时与 x 轴的距离表示残差。

当然，这两组残差的平方和之间的差异在于由于假设造成的平方和，这成为 F 检验的主要因素。

受假设约束的参数估计可以编写为

其中 b 是最小二乘估计

当假设约束的 lambda 是拉格朗日倍数时，它的计算公式是

分别比较未约束的残差和假设约束的残差。

要获得杠杆率图，点的 x 轴值 v x 是由于假设造成的残差差异，使得从拟合直线（斜率为 1）到 x 轴的距离就是该差异。y 轴值 v y 就是 x 轴值加上整体模型下的残差，这在"杠杆率图的构建" 中有说明。因此，杠杆率图由以下点组成

和
杠杆率图的构建

在杠杆率图上添加检验

在简单的线性回归中，您可以标绘期望值置信限，作为回归变量 x 的平滑函数，

其中 [image] 是回归量的两维向量。

这种双曲线是测量显著性的有效方法，因为它具有以下良好性质：

  • 如果斜率参数显著与零不相同，置信曲线将与响应均值的水平线交叉（"显著性、边缘和非显著置信曲线的情形。" 中左边的图）。
  • 如果斜率参数没有显著与零不相同，置信曲线将不会与响应均值的水平线交叉（"显著性、边缘和非显著置信曲线的情形。" 中右边的图）。
  • 如果斜率参数的 t 检验刚好位于显著性的边缘，置信曲线将响应均值的水平线作为渐近线（"显著性、边缘和非显著置信曲线的情形。" 中间的图）。

通过代数方式验证该性质，或者可以考虑在回归量值发生变化成为正负无穷大时置信区域将是什么，从而认清该属性。

显著性、边缘和非显著置信曲线的情形。

杠杆率图使用了同样的设计，它计算关于一个变量的置信函数，同时容纳处于样本均值的其它所有变量常数。

对于一般的假设检验，JMP 可以显示相同性质的曲线：置信函数通过调整曲率在中间显示均值，这样如果 F 检验在某些 α 水平下（如 0.05）显著，它将与水平线交叉。

比方说函数

和

其中 F 是假设的 F 统计量， [image] 是关于显著性 α 和 [image] 的参考值， [image] 是在适合的中间值（例如均值）的回归量。

这些函数符合上面列出的相同的性质。如果 F 统计量大于参考值，置信函数与 x 轴交叉。如果 F 统计量小于参考值，置信函数不交叉。如果 F 统计量等于参考值，置信函数将 x 轴作为渐近线。同时中间值的置信函数之间的范围是该点预测值的有效置信区域。


多元详细资料

以下部分介绍用于多元检验的计算以及相关的、准确的和近似的 F 统计量、典型详细资料和判别函数。在以下的部分中，E 是残差叉积矩阵， [image] 估计残差协方差矩阵。E 的对角元素是每个变量的平方和。在判别分析的文献中，它通常称为 W，其中 W 代表 within。

多元检验

多元结果表中的检验统计量是 [image] 特征值 λ 的函数。下面的列表介绍了每个检验统计量的计算。

注：在设置了响应设计之后，初始 E 和 H 矩阵将左乘以 [image] ，再右乘以 M。

Wilk Lambda
Pillai 迹
Hotelling-Lawley 迹
Roy 的最大根
， [image] 的最大特征值。

整个模型 L 是一个零值列（对于截距），它与行数和列数与模型中的参数的数量相等的单位矩阵合并。效应的 L 矩阵是整个模型 L 矩阵中行的子集。

近似的 F 检验

要计算 F 值和自由度，令 p 成为 [image] 的秩。令 q 为 [image] 的秩，其中 L 矩阵确定与要检验的效应关联的 [image] 的元素。令 v 成为误差自由度，并且令 s 为 p 和 q 的最小值。同时令 [image] ， [image] 。

"近似的 F 统计量"根据对应的检验统计量提供了每个近似 F 检验的计算。
近似的 F 统计量
检验 近似的 F 检验 分子自由度 分母自由度
Wilk Lambda
Pillai 迹
Hotelling-Lawley 迹
Roy 的最大根

典型详细资料

典型相关性的计算公式是

典型 Y 的计算公式是

其中 Y 是响应变量的矩阵，M 是响应设计矩阵，V 是 [image] 的特征向量的矩阵。典型 Y 的相关性保存自大于零的特征值对应的特征向量

总样本重心的计算公式是

其中 V 是 [image] 的特征向量矩阵。

效应重心值的计算公式是

其中

且 v 是 [image] 特征向量矩阵 V 的列， [image] 指第 j 个效应的多元最小二乘均值，g 是大于 0 的 [image] 特征值的数量，r 是 X 矩阵的秩。

效应的重心半径的计算方式是

其中 g 是大于 0 的 [image] 特征值的数量，分母 L 由多元最小二乘均值计算而得。

判别分析

从观测值到第 i 组的多元均值的距离是 Mahalanobis 距离 D 2，它的计算方式是

其中

在保存判别列时，N 是观测值的数量，M 是单位矩阵。

平台标题栏上的弹出式菜单中的保存判别值命令将判断得分及其公式作为当前数据表中的列进行保存。Dist[0] 是计算所有距离时需要的二次型。它是 Mahalanobis 距离公式的一部分，在不同的组之间不会发生变化。Dist[i] 是观测值与第 i 个重心之间的 Mahalanobis 距离。Dist[0] 和 Dist[i] 的计算公式是

Dist[0] =

和

Dist[i] = Dist[0] -

假定每个组均具有多元正态分布，观测值属于第 i 个组的后验概率是

Prob[i] =

其中

Prob[0] =


功效计算

以下部分提供了计算 LSV、LSN、功效和调整功效的公式。

计算 LSV

对于一个自由度检验，计算 LSV 很容易。假设 [image] 的 F 检验的公式是：

求标量 Lb 的值，为一些 α 水平（如 0.05）提供 F 检验，并且使用 t 作为一个自由度 F 的平方根，并且适当地使它成为双侧检验，得出的结果是

对于 L 检验某些 [image] ，这是

在标准误差方面它可以编写为

如果您有两个均值的简单模型，其中感兴趣的参数用于测量均值之间的差异，该公式与文献中的 LSD（最小显著差异）相同。

在 JMP“模型拟合”平台中，记名效应的参数度量与水平平均值的差异，而不是与其它均值的差异。因此，该参数的 LSV 是均值差异的 LSD 的一半。

计算 LSN

LSN 通过下面的方程式求 n 的值：

其中

ProbF 是中心的 F 分布函数。
dfH 是假设的自由度
dfR 是整体模型中回归的自由度
是平方的效应大小，可以通过估计

在计划研究时，LSN 用作下限。

计算功效

要计算功效，首先通过方程式求出 Fcrit 的值，得出中心 F 的临界值

然后，得出获取该临界值或更高值的概率

ProbF 的最后一个自变量为非中心值

，对于回顾功效，可以估计为 [image] 。

计算调整功效

调整的功效是经过调整移除了原始估计中的正数偏差的非中心估计函数（Wright 和 O'Brien 1988）。可惜的是非中心估计的调整可能造成负值。让调整的非中心估计成为以下值可以处理负值

其中 N 是实际的样本大小，dfH 是假设的自由度，dfR 是整体模型中的回归自由度。

调整的功效是

其中 Fcrit 的计算公式如上所示。

非中心参数的置信限按照 Dwass (1955) 构建，公式如下

其中 F sample 是效应检验报表中报告的 F 值，F crit 的计算公式如上所示。将 λ 的置信限换成以下的值可以获得功效置信限


包含置信限的反预测

反预测估计自变量的值。在解决生物分析的问题时，使用置信限的反预测特别有用。在 JMP 中，您可以要求连续、记名和保序响应模型单个效应的反预测估计。如果响应是记名变量并且有单个连续效应，您还可以要求反预测估计的置信限。

使用 Fieller 定理计算置信限，该定理基于以下逻辑。目的是在提供了其它回归量和响应的值时预测单个回归量及其置信限的值。

让 b 估计参数 β，以便我们将 b 作为 N(β,V) 分布。

让 x 成为关心的回归量值，并且估计第 i 个值。

让 y 成为响应值。

我们需要在 x[i] 值上的置信区域，使得在提供了 x 的其它所有值时 [image] 。

反预测刚好是

其中括号中的下标“(i)”表示第 i 个成分被省略。可以根据以下关系生成置信区间：

在 [image] 时使用指定的置信区间。该形式的二次方程式结果是

其中

二次方程式可能只有虚根，在这种情况下置信区间成为整个实线，并返回缺失的值。

注：JMP 在计算反预测的置信区间时使用 t 值。SAS 使用 z 值，得出不同的结果。


随机效应详细资料

固定效应的方差矩阵总是修改为包括 Kackar-Harville 校正。BLUP 方差矩阵与 BLUP 和固定效应之间的协方差没有经过 Kackar-Harville 校正，因为当随机效应水平有很多时，它们的校正将需要很多计算且占用很多内存。在 SAS 中，只有在设定了 DDFM=KR 时，才为固定效应和 BLUP 都执行 Kackar-Harville 校正，因此 PROC MIXED 生成的标准误差及此选项将不同于其它所有选项。

这意味着：

  • 只涉及固定效应参数的线性组合的标准误差将与 PROC MIXED DDFM=KR 相对应，假定已经将 PROC MIXED 和 JMP 中使用的各种参数化进行了变换。
  • 只涉及 BLUP 参数的线性组合的标准误差将与 PROC MIXED DDFM=SATTERTH 相对应。
  • 如果数据不平衡，则对于任何 DDFM 选项，即固定效应和 BLUP 都涉及的线性组合的标准误差都将与 PROC MIXED 不一致。但是，这些标准误差将介于您使用 DDFM=SATTERTH 和 DDFM=KR 选项求得的标准误差之间。如果数据平衡，则不管 DDFM 选项，对于平衡数据 JMP 的结果与 SAS 一致，因为 Kackar-Harville 校正为 NULL。

只涉及固定效应参数的线性组合的检验自由度使用 Kenward-Roger 校正计算，因此这些检验的 JMP 结果与使用 DDFM=KR 选项的 PROC MIXED 一致。如果线性组合中存在 BLUP，则 JMP 将使用 Satterthwaite 近似来求自由度。因此，结果遵循的模式与前一段中描述的标准误差模式类似。

有关 Kackar-Harville 校正和 Kenward-Roger DF 方法的详情，请参阅 Kenward and Roger(1997)。Satterthwaite 方法在 SAS PROC MIXED 说明文档中有详细介绍。


试验设计

上一页 | 下一页

JMP 试验设计

JMP 中的“试验设计”平台是用于创建设计试验并在 JMP 数据表中保存试验的一种工具。JMP 支持两种方式构建设计试验：

  • JMP 构建的新设计既可满足工程问题的描述要求，又可确保不超出时间和材料预算；
  • 从设计列表中选择预先已有公式的设计。

试验设计包含以下章节：

试验设计简介

关于设计试验

我的首个试验

使用定制设计器的实例

创建筛选试验

创建响应面试验

创建混料试验

定制设计器的特殊用途

技术论述

构建定制设计

创建定制设计

创建裂区设计

特殊定制设计命令

指定列性质

定制设计工作原理：幕后

筛选设计

筛选设计实例

创建筛选设计

响应面设计

Box-Behnken 设计：网球实例

创建响应面设计

完全析因设计

五因子反应堆实例

创建析因设计

混料设计

选择混料设计类型

创建最优混料设计

使用单纯形中心设计

使用单纯形格子点设计

使用极角点设计

使用 ABCD 设计

创建三元图

拟合混料设计

一个化学混料实例

空间填充设计

空间填充设计简介

使用球填充法

使用拉丁超立方法

使用均匀设计法

比较球填充法、拉丁超立方法和均匀法

使用最低潜能法

钻孔水流模型实例

非线性设计

创建非线性设计实例

创建非线性设计

田口设计

田口设计法

田口设计实例

创建田口设计

扩充设计

化学反应实例：使用 D 最优扩充

创建扩充设计

特殊扩充设计命令

预期功效与样本大小

预期功效分析

单样本和双样本均值

k 样本均值

单样本方差

单样本和双样本比例

每单位计数

Sigma 质量水平

试验设计


试验设计简介

初学者教程

本章教程将为您介绍如何使用 JMP 的定制设计器进行试验设计 (DOE)。其对如何使用 JMP 设计试验进行了概括性介绍。有关如何为特定项目设计试验的更多实例和程序，请参阅本书后面的章节。

目录

关于设计试验

我的首个试验

场景

第 1 步：设计试验

第 2 步：定义因子约束

第 3 步：添加交互作用项

第 4 步：确定试验次数

第 5 步：检查设计

第 6 步：收集和输入数据

第 7 步：分析结果


关于设计试验

在各行业中，提高生产效率和改进质量都是重要的目标。研究如何提高效率和改进质量的方法仍不断发展，从昂贵耗时的试错法进步到 JMP 为您提供的强大、精致且极为经济的统计方法。

JMP 中的试验设计围绕因子、响应和试验展开。JMP 帮助您确定因子是否影响以及如何影响响应。


我的首个试验

如果您从未使用过 JMP 进行试验设计，本部分会向您展示如何设计试验以及如何理解 JMP 输出。

提示：推荐使用本教程介绍的定制设计器来创建试验。JMP 还提供在其它场景下使用的经典设计器。

场景

您的目标是寻找使用微波炉加工一包爆玉米花的更佳程序。您已经对此进行过几次试验，因此很容易确定重要因子的合理范围。

  • 加工爆玉米花的时间（介于 3 至 5 分钟之间）
  • 微波炉使用的火力（介于 5 至 10 档之间）
  • 使用的玉米品牌（Top Secret 或 Wilbur）

在爆玉米花时，大部分玉米粒爆开了，但有些玉米粒未爆开。您希望所有（或几乎所有）的玉米粒都爆开了，没有（或很少）玉米粒未爆开。因此，您根据爆开的玉米粒与玉米粒总数之比定义“最佳爆玉米花包”。

改进任意程序的最佳方式是开展一次试验。对于每次的试验运行，JMP 的定制设计器会确定使用的品牌，每包在微波炉中加工的时间和设定使用的火力。每次试验爆一包玉米。爆一包之后，在 JMP 数据表相应的行中输入玉米粒的总数量和爆开的玉米粒的数量。完成所有的试验运行后，使用 JMP 的模型拟合功能进行数据分析。然后，您可以使用 JMP 的刻画工具确定加工时间、微波炉火力以及品牌的最佳设置。

第 1 步：设计试验

第一步是选择试验设计 > 定制设计（"选择“定制设计器”"）。然后定义响应和因子。

选择“定制设计器”

定义响应：爆开的玉米粒数量和玉米粒总数量

试验中包含两个响应：

  • 爆开的玉米粒数量
  • 该包中玉米粒的总数量。爆一包后，用未爆开的玉米粒数量加上爆开的玉米粒数量以得出该包中玉米粒的总数量。

默认情况下，定制设计器中包含了一个标记为 Y 的响应（"单击展开图标以打开和关闭“响应”面板。"）。

单击展开图标以打开和关闭“响应”面板。

由于存在多个响应，请将它们输入至定制设计器中默认 Y 响应的位置：

  1. 通过双击标记为 Y 的响应并键入“爆开个数”为响应重命名。由于您希望增加爆开玉米粒数量，请将目标设定为最大化。
  2. 单击添加响应按钮并从出现的菜单中选择无以添加第二个响应（玉米粒的总数量）。JMP 会将此响应默认标记为 Y2。
  3. 通过双击标记为 Y2 的响应并键入“总粒数”为响应重命名。

完成后的“响应”面板如"用指定目标重命名的响应" 所示。

用指定目标重命名的响应

定义因子：时间、火力和品牌

此试验中的因子包括：

  • 玉米品牌（Top Secret 或 Wilbur）
  • 爆玉米花的加工时间（介于 3 至 5 分钟之间）
  • 微波炉使用的火力（介于 5 至 10 档之间）

将品牌添加为二水平分类因子：

  1. 单击添加因子并选择分类 > 2 水平。
  2. 双击因子名称并键入品牌以更改因子名称（当前名称为 X1）。
  3. 通过单击当前名称并键入新名称，将默认水平（当前名称为 L1 和 L2）重命名为 Top Secret 和 Wilbur。

将时间添加为二水平连续因子：

  4. 单击添加因子并选择连续。
  5. 双击因子名称并键入时间以更改因子名称（当前名称为 X2）。
  6. 通过单击当前名称并键入新名称，将默认水平（当前名称为 -1 和 1）重命名为 3 和 5。

将火力添加为二水平连续因子：

  7. 单击添加因子并选择连续。
  8. 双击因子名称并键入火力以更改因子名称（当前名称为 X3）。
  9. 通过单击当前名称并键入新名称，将默认水平（当前名称为 -1 和 1）重命名为 5 和 10。完成后的“因子”面板如"用指定值重命名的因子" 所示。
用指定值重命名的因子
  10. 单击继续。

第 2 步：定义因子约束

本试验中的加工时间介于 3 至 5 分钟之间，而微波炉火力则介于 5 至 10 档之间。根据经验，您知道：

  • 不能在试验中长时间高火力加工爆玉米花，因为这样会烧焦某些玉米粒。
  • 不能在试验中短时间低火力加工爆玉米花，因为这样只有少数玉米粒爆开。

要限制试验，以使加工时间加上微波炉火力小于等于 13，但大于等于 10：

  1. 单击定义因子约束标题栏旁边的展开按钮，以打开“约束”面板。
  2. 分别为每个已知约束单击一次添加约束按钮。
  3. 填写信息，如"定义因子约束" 中右侧所示，其避免了火力和时间的总和小于 10，大于 13。请确保在第二个约束中将 <= 更改为 >=。
    如"定义因子约束" 中左侧所示，在平行四边形中的区域是运行的允许范围。您可以看到加工 5 分钟，火力为 10 级是不允许的，同样加工 3 分钟，火力为 5 级也是不允许的。
定义因子约束

第 3 步：添加交互作用项

您可以推测：与爆开玉米粒比例相关的任意因子效应可能取决于某些其它因子的值。例如，Wilbur 品牌的玉米的时间变化的效应可能大于使用 Top Secret 品牌相同时间变化的效应。这种因子表现出的协同效应统称为二因子交互作用。您决定在您的爆玉米花加工过程的先验模型中纳入所有可能的二因子交互作用。

  1. 单击交互作用按钮并选择二次。JMP 会将二因子交互作用添加到模型中。

  2. 单击幂按钮然后选择二次，以添加连续因子的二次效应，火力和时间。如果您怀疑任一因子与响应之间存在曲线关系，就可以执行此操作。二次模型项允许模型拟合这种曲率。

第 4 步：确定试验次数

根据在模型中添加的效应，“设计生成”面板将显示执行试验所需的最少试验次数。您可以使用最小值，任何其它建议的样本大小，或者您可以指定试验次数，只要该值大于最小值。JMP 对您请求的试验次数没有约束。在本例中，我们将使用默认的试验次数 16。

单击制作设计以继续。

第 5 步：检查设计

单击制作设计按钮后，JMP 将生成并显示如下所示的设计表。请注意，因为 JMP 使用随机种子生成定制设计，而且此问题并非只有唯一的最优设计，您的设计表可能与此处显示的不同。

从该表中您可以看到定制设计要求使用每个玉米粒品牌进行 8 次试验。

现在来关注一下“输出选项”区域。试验顺序选项允许您在创建数据表时指定其在表中显示的试验顺序。保留随机化选项，输出表中的行（试验）将以随机顺序显示。然后单击制表。

生成的数据表显示了您应该运行试验的顺序，其中的列供您输入爆开的玉米粒数量和玉米粒总数量。根据数据表，首先在 10 级火力下将第一包 Wilbur 牌的玉米粒加工 3 分钟，然后在 5 级火力下将 Top Secret 牌的玉米粒加工 5 分钟，依次进行。

您无法对微波炉的火力和时间进行微量控制。因此您可以自由地将火力和时间四舍五入。虽然这个整理过的设计与最优设计稍有不同，但其中的差异是可忽略的。

提示：在“输出选项”区域单击制表之前，您可以在“试验顺序”菜单中选择从左至右排序，使 JMP 根据品牌显示结果。

第 6 步：收集和输入数据

根据 JMP 提供的设计加工爆玉米花。然后，计算每包中爆开的和未爆开的玉米粒的数量。最后，将数值（如下所示）手动输入到数据表中的相应列中。

我们已经为您执行了此试验，并且将我们的结果放置在您安装 JMP 时安装的 Sample Data 文件夹中。要打开结果，请选择 Sample Data > Design Experiment > 爆玉米花 DOE 结果.jmp。

第 7 步：分析结果

执行试验并将玉米粒的爆开数量和总数量输入到数据表之后，就可以构建数据模型了。要实现此操作，请从设计数据表开始。数据表左上角的模型面板中包含了一个脚本。一旦创建了设计，相应的分析方法（在此情况下为标准最小二乘分析）便将存储在模型脚本中。

  1. 使用鼠标右键单击模型，然后选择运行脚本。

模型对话框中默认的拟合特性是标准最小二乘。标准最小二乘的一个假设是您的响应成正态分布。但由于您构建的是爆开玉米粒比例的模型，因此假设您的响应来自二项分布则更为合适。您可以更改为广义线形模型来使用此假设。

  2. 将特性更改为广义线形模型，将分布更改为二项，将关联函数更改为 Logit，如"拟合模型" 所示。
拟合模型
  3. 单击运行模型按钮。
  4. 向下滚动以查看“参数估计”表（"研究 p 值"），同时注意观察标记为 p 值 > |t| 的列。该列列出了 p 值。较小的 p 值（小于 0.05）表明结果达到了统计显著性。在此列中，星号表示小 p 值。您可以因此得出：在该试验中，除了包括“品牌”和“火力”的双因子交互作用，所有的模型效应均极为显著。
研究 p 值

您已确认加工时间、火力以及品牌与爆开玉米粒比例之间存在着紧密关系。要进行进一步研究，请使用“预测刻画器”分析因子组合的变化如何影响爆开和未爆开玉米粒的数量：

  1. 单击广义线性模型拟合\刻画器\刻画器以打开“预测刻画器”，然后滚动至报表底部以查看。通过单击预测刻画器标题栏旁边的展开按钮即可打开。刻画器（"预测刻画器"）显示了每个因子的预测迹。
预测刻画器
  2. 移动红色虚线，以查看更改因子值对响应产生的影响。单击时间图中的红线并向左右拖动（"将时间值从 4 移至 5"）。
将时间值从 4 移至 5

随着时间的增加和减少，弯曲的时间和火力预测迹将随着时间值的变化而改变斜率和最大/最小值。实际斜率发生变化表明存在涉及时间和火力的交互效应（合作效应）。

另外，预测迹的陡度体现了因子的重要性。由于火力的预测迹比品牌或时间的预测迹更陡（请参阅"将时间值从 4 移至 5"），您可以看到微波炉火力设置比玉米粒品牌或加工时间更重要。

现在，执行最后一个步骤。

  3. 单击“预测刻画器”标题栏中的红色三角形图标，然后选择意愿函数。
  4. 单击“预测刻画器”标题栏中的红色三角形图标，然后选择最大化意愿。JMP 将自动调整图形，以显示能让最多的玉米粒爆开的最优设置（"最合意的设置"）。

我们的试验发现加工一包玉米，让其爆开玉米粒的比例最大的方法：使用 Wilbur 品牌，加工 5 分钟，并将火力调为 7.8 级（或 8 级）。试验预测在此种设置下加工，产出的玉米粒 97％ 以上都爆开了。

最合意的设置


使用定制设计器的实例

统计方法在工业中的应用日益增加。经证实，最节约成本又能改善质量和生产效率的方法是统计试验设计。为找到最影响质量的关键少数因子的试错法非常昂贵而且耗时。试验设计的目的是探究特征、预测，以进一步在节约成本的基础上改善任意系统或制程的表现。

建议您使用 JMP 定制设计器用来描述过程和创建适于您情况的设计。要使用定制设计器，请先输入制程变量和约束，然后 JMP 会制定适合您独特案例的设计。该方法比之前支持统计试验设计的工具更为普遍，且不需要很多经验和专业技术。

定制设计器可以容纳任意类型和数量的因子。您还可以控制试验运行的次数（可以是大于或等于模型中未知数的任意数）。这使得定制设计比起备选方法更为灵活且更具有成本效益。

本章介绍了几个使用定制设计的实例。它显示了如何使用这个简单的循序渐进的方法利用界面构建设计：

目录

创建筛选试验

创建仅限于主效应的筛选设计

创建筛选设计以拟合所有的二因子交互作用

介于主效应模型和所有交互作用模型之间的折衷设计

创建“超级”筛选设计

具有可变区组大小的筛选设计

使用一次额外试验检查弯曲

创建响应面试验

刻画预测方差面

介绍响应面建模的 I 最优设计

三因子响应面设计

具有区组因子的响应面

创建混料试验

定制设计器的特殊用途

具有固定协变因子的试验设计

创建具有两个难调因子的设计：裂区设计

技术论述


创建筛选试验

您可以使用 JMP 筛选设计器创建筛选设计，但定制设计器更为灵活且普遍。以下描述的简要筛选实例显示了“定制”并不等于“奇异”。定制设计器是通用设计环境。同样地，它可以创建筛选设计。

创建仅限于主效应的筛选设计

要使用定制设计器创建仅限于主效应的筛选设计，请执行以下操作：

  1. 选择试验设计 > 定制设计。
  2. 输入六个连续因子到“因子”面板中（有关详情，请参阅"第 1 步：设计试验"）。"仅限于主效应的筛选设计" 显示了这六个因子。
  3. 单击继续。默认模型仅包含主效应。
  4. 使用默认的八次试验，单击制作设计。

    试验设计专家请注意：结果是分解度为 3 的筛选设计。所有的主效应均可估计，但其会与二因子交互作用混杂。
仅限于主效应的筛选设计
  5. 单击展开按钮（在 Windows/Linux 中为 [image] ，Macintosh 中为 [image] ）以打开别名矩阵。"别名矩阵" 显示了包含 0，1，-1 的表。
别名矩阵

别名矩阵显示模型中的常数系数和主效应项是如何因不在模型中的二因子交互作用项造成偏差的。例如，表中标记为 2 6 和 3 4 的列在 X1 行有一个 1。这意味着 X1 的主效应预期值实际上是 X1 的主效应和二因子交互作用 X2*X6 和 X3*X4 的总和。您假定这些交互作用与 X1 的实际效应相比，大小上可以忽略。

试验设计专家请注意：别名矩阵在部分析因设计中是广义的混杂模式。

创建筛选设计以拟合所有的二因子交互作用

仅限于主效应的设计中存在风险。风险是指二因子交互作用，如果其作用很强，会混淆此类试验的结果。要避免此类风险，您可以创建分解所有二因子交互作用的试验。

试验设计专家请注意：该实例的结果是分解度为 5 的筛选设计。二因子交互作用可被估计，但会与三因子交互作用混杂。

  1. 选择试验设计 > 定制设计。
  2. 输入五个连续因子到“因子”面板中（有关详情，请参阅"第 1 步：设计试验"）。
  3. 单击继续。
  4. 在“模型”面板中选择交互作用 > 二次。
  5. 在“设计生成”面板上的“试验次数”中选择最小值，然后单击制作设计。

"所有二因子交互作用" 显示了具有所有交互作用的二因子设计试验。样本大小为 16（2 的幂），大到足以拟合模型中的所有项。表中的值可能不同于以下显示的值。

所有二因子交互作用
  6. 单击展开按钮以打开别名矩阵。"别名矩阵显示从所有主效应中清除所有二因子交互作用" 显示了包含 0 和1 的表。查看标记为 1 2 的列。在该列中只有一个值为 1。其它所有值均为 0。1 出现在标记为 X1*X2 的行中。所有其它的行和列均相似。这意味着二因子交互作用 X1*X2 预期值不会因其它项造成偏差。在标记为 X1*X2 的行上面的所有行仅含有 0，这表示截距和主效应项不会因任何二因子交互作用造成偏差。
别名矩阵显示从所有主效应中清除所有二因子交互作用

介于主效应模型和所有交互作用模型之间的折衷设计

在筛选情况下，假设有六个连续因子和用于 n = 16 次试验的资源。本节的第一个实例显示了一个拟合所有主效应的 8 次试验设计。如果有 6 个因子，就会有 15 种可能的二因子交互作用。可以拟合常数、主效应和二因子交互作用的试验次数的最小值为 22。这要比资源预算（16 次）要多。如果能在仅限于主效应的设计和能够拟合所有二因子交互作用的设计之间找到一种折衷设计会比较好。

该实例显示如何使用定制设计器获得这样一个折衷设计。

  1. 选择试验设计 > 定制设计。
  2. 定义六个连续因子 (X1 - X6)。
  3. 单击继续。默认情况下，模型包括主效应项。这些项的默认可估计性为必要。
  4. 单击交互作用按钮并选择二次，添加所有二因子交互作用。
  5. 选择所有的交互作用项，然后单击当前可估计性（必要）以展开菜单。将必要更改为如果可能，如"将二因子交互作用指定为“如果可能”的六变量设计模型" 所示。
将二因子交互作用指定为“如果可能”的六变量设计模型
  6. 在试验次数编辑框中键入 16。
    尽管所需试验次数 (16) 要比模型项的总数少，但定制设计器仍构建一个可以估计尽可能多的二因子交互作用的设计。
  7. 在设计生成面板上的编辑对话框中输入 16，然后单击制作设计。

定制设计器创建设计之后，单击展开按钮以打开“别名矩阵”（"别名矩阵"）。表中的值可能与以下所示的内容不同，但模式是相似的。

别名矩阵

在标记为 X1*X2 的行上面的所有行仅含有 0，这表示截距和主效应项不会因任何二因子交互作用造成偏差。标记为 X1*X2 的行在 1 2 列的值为 0.25，在 5 6 行也为 0.25。这意味着估计 X1*X2 的预期值实际上是 X1*X2 和任何 X5*X6 产生的实际效应之和。

试验设计专家请注意：该特定实例的结果是分解度为 4 的筛选设计。二因子交互作用可被估计，但会与其它二因子交互作用混杂。

创建“超级”筛选设计

本节显示如何使用上一实例中使用的技术创建“超级”筛选（超饱和）设计。超饱和设计的试验次数小于因子数，这使得当存在许多因子且试验运行非常昂贵时，超饱和设计更适于因子筛选。

在饱和设计中，试验次数等于模型项数。在超饱和设计中，顾名思义，模型项的个数多于试验次数 (Lin, 1993)。超饱和设计可以检查许多因子，而只使用因子个数一半左右的试验次数。

超饱和设计的需求

使用筛选设计器时，27-4 和 215-11 部分析因设计可用且均关于主效应模型饱和。在饱和设计的分析中，您（仅仅）可以拟合模型，但是不存在估计误差或失拟合的自由度。直到最近，饱和设计才在筛选设计方面表现出效率的局限性。

因子筛选依赖于稀疏性原则。试验者预期在筛选试验中仅有少数几个因子是活动的。问题是不知道哪些是重要的少数因子，哪些是多余的多数因子。在集思广益的讨论中经常会出现许多因子。虽然很难理解，但是在实际筛选试验中很少出现超过 10 个因子的情况。如从许多因子中分离出大约 10 个因子列表会发生什么呢？

如果试验者受试验次数多于因子数的设计的约束，则许多因子会需要许多次试验。这种方法方法通常不经济。结果是在没有数据的帮助下减少了因子列表。在超饱和设计中，模型项的数量超过了试验次数，您可以检查许多因子，而只使用一半次数左右的试验。

但是，其缺点有：

  • 如果试验中活动因子数接近试验次数，则很可能无法标识这些因子。通常规则是试验次数应该至少大于活动因子数 4 倍。如果您预期有 5 个活动因子，则您至少应该有 20 次试验。
  • 超饱和设计的分析尚不能简化成自动程序。但是，使用向前逐步回归是合理的。

实例：8 次试验 12 个因子

作为实例，请看一个具有 12 个因子的超饱和设计。使用模型项指定如果可能以提供用于创建超饱和设计的工具。

在前面的实例中，我们指定二因子交互作用为如果可能。在超饱和设计中，所有项（包括主效应）均为如果可能。请注意在"更改可估计性" 中，仅截距为基本项。

要查看具有 8 次试验和 12 个因子的超饱和设计的实例，请执行以下操作：

  1. 选择试验设计 > 定制设计。
  2. 添加 12 个连续因子并单击继续。
  3. 高亮度显示除了截距的所有项，然后单击当前可估计性（必要）以展开菜单。将必要更改为如果可能，如"更改可估计性" 所示。
更改可估计性
  4. 所需试验次数为 8。要设置此项，请在试验次数编辑框中输入 8。
  5. 单击“定制设计”标题栏上的红色三角形图标并选择模拟响应，如"模拟响应" 所示。
模拟响应
  6. 单击制作设计，然后单击制表 。名为模拟响应的窗口和一个设计表出现，且与"模拟响应和设计表" 中显示的相似。Y 列中的值由“模拟响应”窗口中的模型系数控制。表中的值可能不同于以下显示的值。
模拟响应和设计表
  7. 更改“模拟响应”对话框中系数的默认设置，以与"为 3 个主效应赋值并将标准误差指定为 0.5" 相匹配，然后单击应用。此时 Y 列中的数值将发生变化。由于已经在模拟中将 X2, X9 和 X10 设置为活动因子，分析获得相同的三个因子。
    请注意，随机噪声添加至 Y 列公式，因此您看到的数值可能未必与图中的数值匹配。表中的值可能不同于以下显示的值。
为 3 个主效应赋值并将标准误差指定为 0.5

要使用逐步回归标识活动因子，请执行以下操作：

  1. 在设计表中单击模型旁边的红色三角形，然后选择运行脚本以运行模型脚本。
  2. 将“模型规格”窗口中的特性从标准最小二乘更改为逐步。
  3. 单击运行模型。在显示的结果中单击步骤按钮三次。JMP 输入具有最大效应的因子。在出现的报表，您可以确定三个活动因子：X2、X9 和 X10，如"逐步回归标识活动因子" 所示。步骤历史记录显示在报表的底部。您的估计可能与以下显示的有所差别。
逐步回归标识活动因子

注：此实例定义了少数大的主效应，并将其余的都设定为零。在实际情况下，很难如此清晰地区分效应。

具有可变区组大小的筛选设计

使用筛选设计器创建设计后，列出的设计可用的区组大小为 2 的幂。但是，定制设计可以设定任意大小的区组。本节中显示的区组实例很灵活，因为其使用每区组运行 3 次，而不是 2 的幂。

选择试验设计 > 定制设计后，输入因子，您会看到区组因子在“因子”面板的“值”部分仅显示一个水平。这是由于样本大小此时未知。完成设计之后，JMP 显示相应的由样本大小除以每个区组的试验次数计算而得的区组数。

例如，"一个区组出现在“因子”面板中" 显示当您输入三个连续因子和一个区组因子（每个区组运行 3 次）后，只有一个区组出现在“因子”面板中。

一个区组出现在“因子”面板中

默认的样本大小 为 9 ，要求三个区组。单击继续以后，在“因子”面板中有三个区组（"“因子”面板中的三个区组"）。这是由于默认样本大小为 9，其要求三个区组，每个区组运行 3 次。

“因子”面板中的三个区组

如果在“设计生成面板”中选择网格选项和试验 24 次，“因子”面板则会更改，变为包含 8 个区组（"8 个区组"）。

8 个区组

如果您添加了所有的二因子交互作用并且将试验次数改为 15 ，每个区组运行 3 次将生成 5 个区组（如"将试验次数改为 15" 所示），因此“因子”面板的值部分会显示 5 个区组。

将试验次数改为 15

单击制作设计，然后单击展开按钮（Windows/Linux 中的 [image] 和 Macintosh 中的 [image] ），打开系数的相对方差。"模型系数的相对方差表" 显示了一个表，其中包含模型中每个系数的方差（与未知误差方差相关）。

表中的值可能与下面显示的值稍有不同。请注意每个系数的方差大约是误差方差的十分之一，而且所有的方差大小大致相同。误差方差假定为 1。

模型系数的相对方差表

这里的主要问题是系数方差的相对大小是否小到可以接受的程度。如果不是，请添加更多的试验次数（18 或更多）应该能降低每个系数的方差。

有关详情，请参阅"理解系数方差表"。

试验设计专家请注意：有四行与 X4 相关联（区组因子）。这是由于 X4 有 5 个区组，因此自由度为 4。每个自由度是与模型中一个未知系数相关联的。

使用一次额外试验检查弯曲

在筛选设计中，试验者通常会为设计添加中心点及其它检查点，借以确定假定模型是否恰当。尽管这是一种良好的实践，但并非最好。定制设计器在为选择对于模型假设稳健的设计提供理论基础和易于使用的界面的同时，也对这种并非最好的实践提供了一种改进的方式。

设计中检查点的用途是为不包含在假定模型中的更高阶效应提供一种检测机制。这些高阶项称为潜在项。（用 q 表示在 JMP 的如果可能选项中潜在项的个数）假定模型由基本项组成。（用 p 表示在 JMP 的必要选项中基本项的个数。）

要利用如果可能选项模型项方法的优势，样本大小必须大于基本项个数但小于基本项与潜在项之和。即 p < n < p+q。使用如果可能选项模型项的方法的正式名称为贝叶斯 D 最优设计。这种类型的设计允许在提供潜在项的综合可检测性（及一定程度的可估计性）的同时精确估计所有基本项的方法。

对于一个具有一个截距、两个主效应和一个交互作用的模型的二因子设计，存在 p = 4 个基本项。在定制设计器中输入该模型，默认情况是出现具有如"两个具有交互作用的连续因子" 中所示的因子设置的四次试验设计。

两个具有交互作用的连续因子

假设您能承担一次额外试验 (n = 5)。您想要将此点用作弯曲的检查点。如果您保持模型不变，增加样本大小，则定制设计器将重复四个角点之一。在模型中重复试验是改进项目估计的最优选择，但它无法检查失拟合。

向模型添加两个二次项将使总项数为六项。这是一种直接构建曲面模型的方法。但要达到此目的，定制设计器还需要两次（至少）额外试验，这就超出了五次试验的预算。

贝叶斯 D 最优设计提供了一种仅通过一次额外试验就能检查弯曲的方法。要创建该设计：

  1. 选择试验设计 > 定制设计。
  2. 定义两个连续因子（X1 和 X2）。
  3. 单击继续。
  4. 高亮度显示两个主效应，然后单击“模型”面板上的交互作用按钮，选择二次。结果如"第二个水平的交互作用" 所示。
第二个水平的交互作用
  5. 单击“模型”面板中的幂按钮并选择二次。这样会添加两个二次项。
  6. 选择两个二次项（X1*X1 和 X2*X2），然后单击当前可估计性（必要）以展开菜单。将必要更改为如果可能，如"更改可估计性" 所示。
更改可估计性

现在，将 p = 4 个基本项（截距、两个主效应和交互作用）指定为必要，而将 q = 2 个潜在项（两个二次项）指定为如果可能。所需的试验次数 5 介于 p = 4 和 p + q = 6 之间。

  7. 在试验次数编辑框中输入 5。
  8. 单击制作设计。生成的因子设置显示在"五次试验的贝叶斯 D 最优设计" 中。设计中的值可能不同于下面显示的值。
五次试验的贝叶斯 D 最优设计
  9. 单击制表。此时将出现数据表。
  10. 通过选择图形 > 叠加图创建"叠加图" 中的叠加图，然后插入 X1 为 Y，X2 为 X。叠加图描述了设计如何合并单一附加试验，但将因子设置放置在设计中心，而不是其中一个角。
叠加图


创建响应面试验

响应面试验通常包含少量（通常为 2 到 8）的连续因子。为响应面试验事先设定的模型通常是二次模型。

与筛选试验相反，研究人员在已经知道哪些因子重要的情况下使用响应面试验。响应面试验的主要目标是创建因子和响应间关系的预测模型。使用该预测模型可以让试验者找到该流程的更佳操作设置。

在筛选试验中，一种设计质量的测量标准是系数相对方差的大小。在响应面试验中，因子范围的预测方差比系数方差更重要。显示预测方差的一种途径是 JMP 的预测方差刻画图。该图是一个功能强大的诊断工具，用于计算和比较响应面设计。

刻画预测方差面

以下实例的目标是生成一个简单的预测方差刻画图。遵循以下步骤以创建具有单个连续因子的二次模型设计。

  1. 选择试验设计 > 定制设计。
  2. 通过选择添加因子 > 连续（"添加一个因子和一个二次项"）添加一个连续因子，然后单击继续。
  3. 在模型面板中，选择幂 > 二次以创建一个二次项（"添加一个因子和一个二次项"）。
添加一个因子和一个二次项
  4. 请确保使用默认试验次数 (6)（"调整试验次数"），然后单击制作设计。试验次数与预测响应方差的大小成反比。随着试验次数增加了，预测方差则会减小。
调整试验次数
  5. 单击展开按钮（Windows/Linux 中的 [image] 和 Macintosh 中的 [image] ）以打开预测方差刻画，如"单个因子二次模型的预测刻画" 所示。

对于连续因子，初始设置是因子范围的中间值。对于分类因子，初始设置是第一个水平。如果设计模型是二次，则预测方差函数是四次。y 轴是响应预期值的相对预测方差。

在该设计中，三个设计点为 -1、0 和 1。预测方差刻画显示在区间 [-1,1] 上，上述每个点上的方差均为最大值。

单个因子二次模型的预测刻画

预测方差与误差方差相关。如果相对预测方差为 1，则绝对方差与回归模型的误差方差相等。有关预测方差刻画器的更多详情，请参阅"理解设计和刻画器"。

  6. 单击返回按钮，然后在“设计生成”面板（其给出的样本大小为 3）中选择最小值，以比较刻画图。
  7. 单击制作设计，然后重新打开预测方差刻画图。

这将产生一条与上图形状相同的曲线，但是其最大值在 1 处，而不是 0.5。"预测方差刻画图比较" 比较该二次模型中样本大小为 6 和样本大小为 3 的图。您会发现预测方差随着样本大小的缩小而增大。实际上，预测方差与样本大小成反比，因此，将试验次数加倍会使预测方差减半。这些刻画图显示最大方差和最小方差的设置，以及样本大小为 6（顶部图）和样本大小为 3（底部图）的设置。

预测方差刻画图比较

提示：按住 Control 键并单击（Mac 中为 Command 键）因子，以精确设定因子水平。

  8. 单击返回按钮，在“设计生成”面板中输入样本大小为 4，然后单击制作设计，即可创建不平衡设计。结果如"单因子二次模型的样本大小为 4" 所示。

您可以看到 -1 处的预测方差要比其它样本点低（其值为 0.5，而不是 1）。该图的对称性与因子设置的平衡相关。设计平衡后，图形即会对称，如"预测方差刻画图比较" 所示。如果设计不平衡，预测图也不对称，如"单因子二次模型的样本大小为 4" 所示。

单因子二次模型的样本大小为 4

脚本编写专家请注意：

以下 JSL 代码以图形方式显示了不等间距点三次模型的单因子设计，该设计的预测方差会比等间距设计的小。

从安装 JMP 时安装的 Sample Scripts 文件夹里打开 Cubic Model.jsl，以查看本实例中的脚本。然后从编辑菜单中选择编辑 > 运行脚本。图形显示后，将自由值从等间距点移动到最佳点（-0.445 和 0.445），您会看到区间上的最大方差减小的幅度大于 10％。

 // 拟合三次模型的试验设计。

 n = 4; // 点数

 //以等间距点开始。
 u = [-0.333 0.333];
 x = {-1,u[1],u[2],1};
 y = j(2,1,.2);

 cubicx = function({x1},
 rr=j(4,1,1);for(i=1,i<=3,i++,rr[i+1]=x1^i); rr;);

 NewWindow("试验设计 — 三次多项式的方差函数"，
 Graph(FrameSize(500,300),XScale(-1.0,1.0),yScale(0,1.2),
 Double Buffer,
 M = j(n,1,1);
 for(i=1,i<=3,i++, M = M||(x^i));
 V = M`*M;
 C = inverse(V);
 yFunction(xi=cubicx(x);sqrt(xi`*C*xi),x);
 detV = det(V);
 text({-0.3,1.1},"Determinant = ",char(detV,6,99));
 DragMarker(u,y);
 for(i=1,i<=2,i++,Text({u[i],.25},char(u[i],6,99)));));
 show(n,d,u);
 // 将中点拖至 -0.445 和 0.445
 // 适用于 D 最优设计。

介绍响应面建模的 I 最优设计

定制设计器使用算术最优性准则生成设计。到目前为止，本章中的所有设计均为 D 最优设计。D 最优设计最适合于筛选试验，因为最优性准则的重点是系数的精确估计。如果试验者已经对因子效应进行了精确估计，那就很容易分辨出哪些因子效应重要，而哪些可以忽略。但是，D 最优设计不适合用来设计主要目标是预测的试验。

I 最优设计在因子区域内最小化平均预测方差。这就使得 I 最优设计最适于预测。因此，I 最优性是 JMP 推荐的准则，用于响应面设计。

相对于 D 最优设计而言，I 最优设计在设计空间的极值处设置的试验次数较少。对于一个小实例，考虑二次模型的单因子设计，使用试验次数为 n = 12。此模型的 D 最优设计在指定范围的每个端点及中间各安排四次试验。I 最优设计在每个端点处安排三次试验，在中间安排六次试验。在这种情况下，D 最优设计会在极值处放置三分之二的权重，而 I 最优设计则放置二分之一。

"12 次试验 I 最优设计（左）及 D 最优设计（右）的预测方差刻画" 比较试验次数为 n = 12 的二次模型单因子 I 和 D 最优设计的预测方差刻画图。I 最优设计的方差函数在设计空间中心处比 D 最优设计的对应函数小；边缘处则正相反。

12 次试验 I 最优设计（左）及 D 最优设计（右）的预测方差刻画

I 最优设计的平均方差（相对于误差方差）为 0.178，而 D 最优设计为 0.2。这意味着它的预测置信区间比 I 最优设计的置信区间平均小百分之十。

要比较两个设计准则，请使用 I 最优性准则创建一个二次模型的单因子设计，再使用 D 最优性准则创建另一个设计：

  1. 选择试验设计 > 定制设计。
  2. 添加一个连续因子：X1。
  3. 单击继续。
  4. 单击“模型”面板上的 RSM 按钮，制作 I 最优设计。
  5. 将试验次数更改为 12。
  6. 单击制作设计。
  7. 单击展开按钮（Windows/Linux 中的 [image] 和 Macintosh 中的 [image] ）以打开预测方差刻画，如"12 次试验 I 最优设计（左）及 D 最优设计（右）的预测方差刻画" 中左侧所示。
  8. 重复相同的步骤，创建 D 最优设计，但从定制设计标题栏里的红色三角形菜单中选择最优性准则 > 制作 D 最优设计。“预测方差刻画”的结果应与"12 次试验 I 最优设计（左）及 D 最优设计（右）的预测方差刻画" 中右侧所示的结果相同。

三因子响应面设计

在维数较高的情况下，I 最优设计会更加注重因子区域的中心。使用 16 次试验的 3 因子拟合全二次模型的 D 最优设计和 I 最优设计如"适用于 RSM 模型的 16 次试验 I 最优和 D 最优设计" 所示。

要比较两个设计准则，请使用 I 最优性准则创建一个三因子设计，再使用 D 最优性创建另一个设计：

  1. 选择试验设计 > 定制设计。
  2. 添加三个连续因子：X1、X2 和 X3。
  3. 单击继续。
  4. 单击“模型”面板中的 RSM 按钮，以向模型中添加交互作用和二次项，并将默认最优性准则更改为 I 最优性准则。
  5. 使用默认试验次数为 16。
  6. 单击制作设计。
  7. 该设计显示在“设计”面板中（如"适用于 RSM 模型的 16 次试验 I 最优和 D 最优设计" 中左侧所示）。
  8. 如果您要创建 D 最优设计以供比较，请重复相同的步骤，但从定制设计标题栏里的红色三角形菜单中选择最优性准则 > 制作 D 最优设计。设计应与"适用于 RSM 模型的 16 次试验 I 最优和 D 最优设计" 中右侧所示的相似。设计中的值可能不同于下面显示的值。
适用于 RSM 模型的 16 次试验 I 最优和 D 最优设计

方差函数的刻画图显示在"16 次试验 I 最优设计及 D 优化 RSM 设计的方差刻画图"。这些图形将方差函数的切片显示为每个因子的函数，所有其它因子则固定为零。I 最优设计在中心的预测方差最低。请注意，此设计中有两个中心点。

D 最优设计没有中心点，其位于因子空间中心的预测方差几乎是 I 最优设计方差的三倍。D 最优设验证计顶点的方差没有显示。但应当注意的是，在接近顶点处 D 最优设计的预测效果比 I 最优设计要好。

16 次试验 I 最优设计及 D 优化 RSM 设计的方差刻画图

具有区组因子的响应面

制程同时取决于定性因子和定量因子的情况很普遍。例如，在化学工业，制程的产量可能不仅取决于定量因子温度和压力，还取决于定性因子，如原材料的批次及反应堆的类型。同样，抗生素可以通过口服或注射摄入，其中定性因子有两个水平。抗生素的成分和剂量可以为定量因子（Atkinson 和 Donev，1992）。

响应面设计器（如"响应面设计"所述）仅处理定量因子。您可以通过重复设计因子的每个水平，使用响应面设计器生成具有定性因子的响应面模型 (RSM) 设计。但是，这样耗时费钱是没有必要的。使用定制设计器更加简单，而且具有更高的成本效益，因为它需要的试验次数较少。

  1. 首先，定义两个连续因子（X1 和 X2）。
  2. 单击继续，然后在“模型”面板中单击 RSM 按钮。这将会使建议的最优性准则从 D 优化更改为 I 优化。
  3. 现在，单击添加因子并选择区组 > 每区组运行 4 次，创建一个每区组运行四次的区组因子 (X3)。一旦添加了区组因子，模型就会更新并在“模型”面板中显示区组因子的主效应。区组因子显示有两个水平，但水平数会根据为设计指定的试验次数做出相应的调整。
  4. 在试验次数文本编辑框中输入 12，并请注意，“因子”面板现在显示的是区组因子 X3，具有三个水平。12 次试验就表示 3 个区组，平均每区组运行 4 次。
  5. 单击制作设计。
  6. 从试验顺序列表中选择从右至左排序。
  7. 单击制表以查看"12 次试验的 I 最优设计以及 D 最优设计的 JMP 设计表" 中左侧的 I 优化表。

"12 次试验的 I 最优设计以及 D 最优设计的 JMP 设计表" 比较了 12 次试验的 I 最优设计和 12 次试验的 D 最优设计的结果。要查看 D 最优设计，请执行以下操作：

  1. 单击后退按钮。
  2. 单击“定制设计”标题栏上的红色三角形图标，并选择最优性准则 > 制作 D 最优设计。
  3. 单击制作设计，然后单击制表。
12 次试验的 I 最优设计以及 D 最优设计的 JMP 设计表

"I 最优设计（左侧）和 D 最优设计（右侧）区组设计点图" 显示了由此实例产生的设计图形。通过从主菜单中选择图形 > 叠加图，并使用区组因子 (X3) 作为分组变量，系统会为每个 JMP 表中的试验分别生成这些图形。

请注意，I-最优设计的每个区组内均有一个中心点。D-最优设计仅有一个中心点。然而，其中三个角点都重复（区组 2 和 3 中的 -1, -1、区组 1 和 3 中的 -1, 1，以及区组 1 和 2 中的 1, 1）。图中的值可能不同于下面显示的值。

I 最优设计（左侧）和 D 最优设计（右侧）区组设计点图

以上的任一设计都支持拟合指定模型。在估计模型系数方面，D 最优设计效果稍好。I 最优设计的 D 效率是 92.4%。

I 最优设计在预测设计区域内的响应时效果更佳。使用"技术论述"给出的公式，您可以计算这些设计的相对平均方差。I 最优设计的平均方差（相对于误差方差）为 0.61，而 D 最优设计为 0.86。这意味着 D 最优设计的置信区间平均长百分之十六以上。


创建混料试验

如果因子是混料的一部分，则可以选择使用定制设计器或是专业混料设计器。但是由于其要求所有的因子都为混料成分，因此混料设计器很有限。正常情况是制程设置应根据混料成分百分比的变化而变化。毕竟，最优公式会随着操作环境的改变而改变。定制设计器可以在同一研究中处理混料成分和制程变量。您并不需要修改问题以满足特殊用途设计方法的限制条件。

Atkinson 和 Donev (1992) 的此实例显示了如何创建混料试验设计，其中一个或多个因子不是混料中的成分。在本实例中：

  • 响应为丙烯腈粉末的电磁阻尼。
  • 三种混料成分为硫酸铜、亚硫酸纳和乙二醛。
  • 我们关注的非混料环境因子是光的波长。

尽管波长是连续变量，但研究人员仅关注预测三种离散波长。因此，他们将其视为具有三个水平的分类因子。要创建此定制设计：

  1. 选择试验设计 > 定制设计。
  2. 创建阻尼作为响应。作者没有提到所需阻尼的数量，因此使用鼠标右键单击目标并创建阻尼的响应目标为无。
  3. 在“因子”面板上添加三个混料成分和分类因子、波长。混料成分有范围约束，约束是由化学反应的机制决定的。与其手动输入，不如从安装 JMP 时安装的 Sample Data 文件夹中下载：单击“定制设计”标题栏中的红色三角形图标，然后选择载入因子。选择 Sample Data > Design Experiment > Donev 混合因子.jmp。
混料试验响应面板和因子面板

"混料试验设计生成面板" 中显示的是包含混料成分和波长效应的响应面模型。要创建此模型，请执行以下操作：

  1. 单击交互作用，然后选择二次。此时会出现一个警告对话框，显示 JMP 删除了会与所有混料因子产生交互作用的非混料因子的主效应项。单击确定。
  2. 在“设计生成”面板中键入 18 作为试验次数（"混料试验设计生成面板"），这样会导致每个波长因子的三个水平需执行 6 次试验。
混料试验设计生成面板

  3. 单击制作设计，然后单击制表。生成的数据表如"混料试验设计表" 所示。表中的值可能不同于以下显示的值。
混料试验设计表

Atkinson 和 Donev 也讨论了试验次数限制为 10 的设计。在这种情况下，不可能对每个波长都运行一个完整的混料响应面设计。

要查看此类情况，请执行以下操作：

  1. 单击后退按钮。
  2. 通过高亮度显示所有效应并单击移除项以移除所有效应。
  3. 通过单击主效应按钮以添加主效应。
  4. 在“设计生成”面板上将试验次数改到 10（"10 次试验混料响应面设计"），然后单击制作设计。"10 次试验混料响应面设计" 中右侧所示的设计表显示因子设置为 10 次试验。
10 次试验混料响应面设计

请注意，每个波长的试验次数必须不相同。由于缺失平衡，因此查看预测方差图不失为一个好主意（"10 次试验设计的预测方差图" 中顶部的图）。

3 个波长间的预测方差几乎不变，这就很好地说明了缺失平衡不是问题。

前三个成分值的总和为 1，因为它们是混料成分。如果您改变其中的一个值，那么其它两个值将随之改变以保持总和不变。"10 次试验设计的预测方差图" 中的底部刻画器显示将硫酸铜的比例由 0.4 增加到 0.6 的结果。其它两个成分的值都降低，保持他们的比率不变。

10 次试验设计的预测方差图


定制设计器的特殊用途

前几节讨论过的一些设计可以使用 JMP 中的其它设计器创建，或者在包含设计表的课本里查寻到，本节中介绍的设计则只能使用定制设计器创建。

具有固定协变因子的试验设计

预制表设计的基础是假定试验者控制所有因子。有时，在试验开始前，您可能需要对试验单位进行定量测量（协变量）。如果该变量影响试验响应，协变量应成为设计因子。只允许少数离散值得现成设计有很大的局限性。定制设计器提供了合理的设计选项。

对于该实例，假设有一组学生参与一项研究。体育研究者建议了一个试验，您可以更改睡眠小时数、早餐卡路里含量，然后要求每个学生跑 1/4 英里。已知学生的体重，似乎将此信息纳入试验设计中颇为重要。

要跟进显示列性质的此实例，请从安装 JMP 时安装的 Sample Data 文件夹中打开大班.jmp。

请按照以下步骤构建定制设计：

  1. 选择试验设计 > 定制设计。
  2. 通过单击添加因子并选择连续，以将两个连续变量添加至模型中，并将其命名为卡路里和睡眠。
  3. 单击添加因子然后选择协变量，如"添加协变量因子" 所示。协变量选择会显示当前数据表中的变量列表。
添加协变量因子
  4. 从变量列表中选择体重，然后单击确定。
具有固定协变量的设计
  5. 单击继续。
  6. 在“因子”面板中选择卡路里，在模型面板中选择睡眠，然后单击交叉按钮，以将交互作用添加到模型中（"具有固定协变因子的设计"）。
具有固定协变因子的设计
  7. 单击制作设计，然后单击制表。"设计表" 中的数据表显示设计表。试验可能不尽相同，因为试验的顺序是随机的。
设计表

请记住“体重”为协变因子，对每个学生进行测量，但不受控制。定制设计器含有每位学生的卡路里和睡眠的计算设置。我们期望卡路里、睡眠和体重之间的相关性能够尽可能的小。我们可以通过拟合体重作为卡路里和睡眠的函数的模型，查看定制设计器的表现如何。如果该拟合具有一个小模型平方和，则意味着定制设计器已成功地从“卡路里”和“睡眠”效应中分离出了“体重”效应。

  8. 单击模型旁边的红色三角形图标，然后选择运行脚本，如"模型脚本" 中左侧所示。
模型脚本
  9. 排列对话框，使体重为 Y，卡路里、睡眠和卡路里*睡眠为模型效应，如"模型脚本" 中右侧所示。单击运行模型。

杠杆图几乎水平，方差表的分析显示了模型平方和较之残差更趋近于 0（"检验“体重”与“卡路里”和“睡眠”无关的分析"）。因此，体重与卡路里和睡眠无关。分析中的值可能略微不同于下面显示的值。

检验“体重”与“卡路里”和“睡眠”无关的分析

创建具有两个难调因子的设计：裂区设计

虽然早就出现涉及裂区设计的大量研究文献，但只在最近几年才能够构建最优裂区设计 (Goos 2002)。在定制设计器中可访问裂区设计功能，该设计是最早可用于生成最优裂区设计的可用商业工具。

裂区设计起源于农业，但现在在制造业和工程研究中也得以广泛应用。在裂区试验中，难调因子仅在整区之间改变。整区被分为若干子区，易调因子水平被随机地分配到各个子区中。

本节的实例来源于 Kowalski、Cornell 和 Vining (2002)。该试验研究有关用于制造汽车座垫的乙烯基浓度的五个因子的效应。该试验中的响应和因子描述如下：

  • 其中的三个因子是混料中的成分。它们是比例分别由 m1、m2 和 m3 表示的可塑剂。由于其为混料试验的预期值，因此该成分的比例和始终为 1。另外，混料成分是子区因子。
  • 其中两个因子是制程变量。它们是挤压速度和烘干温度。制程变量是该试验的整区因子。这些因子难于调节。
  • 试验中的响应是用于制造汽车座垫的乙烯基浓度。所关注的响应（浓度）取决于混料的比例和制程变量的效应。

要在 JMP 中创建该设计，请执行以下操作：

  1. 选择试验设计 > 定制设计。
  2. 默认情况下，仅显示一个响应 Y。双击该名称并将其更改为厚度。使用默认目标最大化（"输入响应和因子"）。
输入响应和因子
  3. 在下限中输入 10。
  4. 要添加三个混料因子，请在添加因子数旁的框中键入 3，然后单击添加因子 > 混料。
  5. 将三个混料因子命名为 m1、m2 和 m3。使用这三个因子的默认水平 0 和 1。
  6. 在添加因子数旁的框中键入 2 ，然后单击添加因子 > 连续，以添加两个连续因子。将这两个因子命名为挤压速度和温度。
  7. 请确保您在对应于这两个因子的“值”区域输入了默认水平 -1 和 1。
  8. 要将挤压速度作为整区因子，请单击易然后选择难。
  9. 要将温度作为子区因子，请单击易然后选择难。出现的对话框看起来应与"输入因子" 中的类似。
  10. 单击继续。
输入因子
  11. 选择交互作用 > 二次，以将交互作用项添加到模型中（"添加交互作用项"）。这会出现警告信息，显示 JMP 删除了会与所有混料因子产生交互作用的非混料因子的主效应项。单击确定。
添加交互作用项

请注意，如果您已将具有可估计性的模型项设置为如果可能，则 JMP 无法将因子变化为难。反过来，如果您将具有可估计性的因子设置为难，则 JMP 无法将模型项指定为如果可能。

  12. 单击整区数旁的框，然后键入 7。
  13. 使该试验运行 28 次（"指定整区数和试验次数"）。
指定整区数和试验次数
  14. 单击制作试验。结果显示在"最终设计结构" 中。
最终设计结构
  15. 单击制表。
  16. 从安装 JMP 时安装的 Sample Data 文件夹中，选择 Design Experiment > 乙烯基数据.jmp。表中的值可能不同于以下显示的值。
乙烯基数据设计表
  17. 单击模型脚本旁边的红色三角形图标，然后选择运行脚本。屏幕将显示如"创建模型" 所示的对话框。

裂区设计模型有一个随机效应与整区效应相关。

如"创建模型" 中所示的对话框，JMP 通过为效应名称附加随机 (&R)，以指定误差项。REML 将用于分析，如"创建模型" 中方法旁边的菜单中所示。有关 REML 模型的详细信息，请参阅《JMP 统计和图形指南》。

创建模型
  18. 单击运行模型来运行分析。结果如"分析结果" 所示。
分析结果


技术论述

本节讲述了关于 JMP 中I、D 和贝叶斯 D 最优设计的详细技术信息。

D 最优性：

  • 是定制设计器生成的默认设计类型（但当模型是响应面设计时除外）
  • 最小化模型系数估计的方差。它适用于一阶模型及筛选情况，因为在此情况下的试验目标通常都是确定活动因子，参数估计是关键。
  • 取决于预先指定模型。这就是局限性的所在，因为在大多数实际情况下，事先并不知道模型的形式。
  • 具有旨在降低此预先指定模型系数变异性的试验。由于焦点在于减少系数的标准差，D 最优设计可能不允许检查模型是否正确。在调查一阶模型时，它可能不包括中心点。在极端情况下，D 最优设计可能只有 p 次不同的试验，没有失拟合的自由度。
  • 最大化 D = det[X T X] 时。
  • 在 D = det[X T V -1 X]（其中 V -1 为响应的区组对角方差矩阵）时，D 最优设计裂区设计可以最大化 D (Goos 2002)。

贝叶斯 D 最优性：

  • 是 D 最优性准则的修订版，它既能有效地估计了模型中的参数，且同时具有检测和估计某些更高阶项的能力。如果存在交互作用或弯曲，则贝叶斯 D 最优性准则是有优势的。
  • 当样本大小大于基本项个数但小于基本项和潜在项之和时，效果最佳。即，p + q > n > p。贝叶斯 D 最优设计是一种精确估计所有基本项的同时提供潜在项的综合可检测性（及一定程度的可估计性）的方法。
  • 使用潜在项强制执行允许检测仅包含基本项的模型中的不充分性的试验。设 K 为 (p + q) 乘 (p + q) 的对角矩阵，其中前 p 个对角元素等于 0，而最后 q 个对角元素为常数 k。贝叶斯 D 最优设计可以最大化 (X T X + K) 的行列式。D 最优性准则与贝叶斯 D 最优性准则之间的差异就在于添加至对应于 X T X 矩阵中潜在项的对角元素的常数。

I 最优性：

  • 最小化数据区域内的平均预测方差。
  • 在某些情况下，要比 D 最优性更合适。当您的目标是预测响应而不是系数时，如在响应面设计问题中。使用 I 最优性准则会更加适合，因为您可以在数据区域内的任何地方预测响应，从而找到产生最合意响应值的因子设置。当您的目标是确定最佳试验条件更为适合，同时还适合于确定设计空间中的区域，其中响应位于一个可接受的范围内；或者用于开发反馈 － 控制模型。因此，响应的精确估计优先于参数的精确估计。
  • 最大化此准则：如果 f T(x) 表示对应于因子组合 x 的 X 矩阵中的行，则
其中

是独立于设计的矩矩阵，可提前计算。


构建定制设计

基本步骤

JMP 构建的定制设计既可满足工程问题的描述要求，又可确保不超出时间和材料预算。它们应用广泛、灵活，适用于日常因子筛选或响应优化。要创建这些定制设计，您可以选择试验设计 > 定制设计。

本章将为您介绍完成构建定制设计所需的步骤。

目录

创建定制设计

在定制设计器中输入响应和因子

描述模型

选择试验次数

理解设计和刻画器

理解系数方差表

理解别名矩阵（混杂模式）

指定输出选项

制表

创建裂区设计

特殊定制设计命令

保存响应和因子

载入响应和因子

载入和保存约束

设定随机数生成器

查看诊断报表

保存设计 (X) 矩阵

更改设计准则（D 或 I 最优性）

选择随机起始数

将设计约束为超球面

考虑因子水平约束

高级选项

指定列性质

定义列的下限值和上限值（试验设计编码）

为混料试验设定列为因子

定义响应列值

为列指定设计角色

标识因子变化

定制设计工作原理：幕后


创建定制设计

要开始定制设计，请选择试验设计 > 定制设计，或者单击“JMP 起始页”中试验设计页面上的定制设计按钮。然后，请执行以下步骤。

  • "在定制设计器中输入响应和因子"
  • "描述模型"
  • "选择试验次数"
  • "理解设计和刻画器"
  • "指定输出选项"
  • "制表"

在定制设计器中输入响应和因子

如何输入响应

要输入响应，请执行"输入响应" 中的步骤。

输入响应

提示：要快速输入多个响应，请单击响应数按钮并输入所需的响应数。

指定响应目标类型以及下限和上限

在输入响应时，您可以告诉 JMP 目标是要获取可能的最大值或最小值、要与特定值匹配，您也可以不指定目标。

以下说明阐述了目标类型（"输入响应" 中的第 3 步）与下限和上限（"输入响应" 中的第 4 步）间的关系：

  • 对于诸如强度或产量之类的响应，最佳值通常为可能的最大值。最大化目标支持此目标。
  • 最小化目标支持最佳目标为最小值的目标，如当响应为不纯度或缺陷数量时。
  • 匹配目标值目标支持最佳响应值为特定目标值的目标，如部件尺寸等。默认目标值假定为在下限与上限中间值。

    注：如果目标值范围不对称，则在根据设计生成表后，您可以更改默认目标值。在数据表中，双击列名以打开响应的“列信息”对话框，然后再输入不对称的目标值。

了解响应重要性权重

在计算整体合意性时，JMP 会将您作为重要性权重输入的值（"在定制设计中输入因子" 中的第 4 步）用作每个响应的权重。如果只有一个响应，则没有必要指定重要性。如果有两个响应，那么您可以为其中一个响应分配更高的重要性值，从而为该响应提供更大的权重。

添加模拟响应（如有需要）

如果没有要添加的特定响应，您可能需要添加模拟响应来帮助确定设计能否检测您所预期的效应大小：

  1. 创建设计。
  2. 在单击制表按钮之前，请单击标题栏中的红色三角形图标（"在定制和扩充设计中为模拟响应指定值"），然后选择模拟响应。
  3. 单击制表以创建设计表，其中的 Y 列包含了用于模拟响应的值。
  4. 对于定制和扩充设计，系统在显示设计数据表的同时还将显示一个窗口（"在定制和扩充设计中为模拟响应指定值"）。在该窗口中，请输入要应用于数据表 Y 列中的值，然后单击应用。输入的数字代表方程中的系数。此方程的实例为"在定制和扩充设计中为模拟响应指定值"，如 [image] 所示。其中随机噪声将按均值为 0 且标准差为 1 来分布。
在定制和扩充设计中为模拟响应指定值

如何输入因子

在定制设计中输入因子

因子类型

在添加因子时，请单击添加因子按钮并选择因子类型。

以下说明了可供选择的因子类型。

  • 连续 连续因子只能为数值数据类型。理论上，您可以将连续因子设为您所提供的下限和上限之间的任何值。
  • 分类 分类数据类型没有隐含顺序。如果值为数值，则以数值大小顺序为准。如果值为字符，则以排序顺序为准。分类因子的设置是离散的，并且不存在内在顺序。分类因子的实例为装置、运算符和性别。
  • 区组 区组因子为特殊类型的分类因子。区组因子与分类因子不同，在区组因子的一个水平上所执行的试验次数是有限制的。。
  • 协变量 协变因子为不可控制的，但可在试验中提前得知其值。
  • 混料 混料因子为混料成分的连续因子。试验的因子设置是指混料中的因子比例，该比例在 0 和 1 之间变化。
  • 常数 常数因子是在试验中其值为固定值的因子。
  • 不受控 不受控因子是在试验中不能控制其值的因子，但您要将其包括进模型中。

创建最佳裂区设计

裂区试验可分组进行，其中有一个或数个因子在组内保持不变，而在不同组之间变化。这种设计在工业中有用，因为有些因子在试验中改变水平比较困难或成本高。方便的做法是在若干次试验中使这些因子保持不变。到目前为止，商业软件还不能一般地提供这种设计和对这种试验的分析。

要表示难以更改因子设置，请单击“因子面板更改”列中的易或难并在显示的菜单中进行选择。更改为难将使最终的设计成为一个裂区设计。

有关详情，请参阅"创建裂区设计"。

定义因子约束（如有需要）

有时不可能在整个试验范围内同时更改因子。例如，当您研究影响加工时间和使玉米粒在微波炉玉米花袋中膨胀的微波炉火力的因素时，如果没有加热所有玉米粒，就不可能同时设置高火力和长时间段。因此，这些因子的水平被约束。

要定义约束，请执行以下操作：

  1. 在添加因子并单击继续之后，单击蓝色展开按钮（Windows/Linux 中为 [image] ，Macintosh 中为 [image] ）以打开“定义因子约束”面板。
  2. 单击添加约束按钮。请注意，如果您通过输入禁用组合或选择了球形半径控制设计区，则此功能将禁用。
  3. 在显示的方框中指定系数及其约束值，如"线性不等式约束实例" 所示。单击 <= 按钮以更改为 >=。
  4. 要添加其它约束，请再次单击添加约束按钮并重复以上步骤。
线性不等式约束实例

描述模型

最初，“模型”面板只会列出所输入因子对应的主效应，如"添加项" 所示。

但是，如果不希望将模型约束为主效应，您可以在模型中添加因子交互作用或连续因子的幂。要一次性添加双因子交互作用和二次效应，请单击 RSM 按钮。

添加项

要在模型中添加特定因子类型，请执行以下操作：

操作 | 说明
添加包括选定因子的交互作用项。如果一个都没有选择，JMP 将在指定顺序中添加所有的交互作用。 | 单击交互作用按钮，然后选择二次、三次、四次或五次。将添加相应的项。例如，如果因子为 X1 和 X2，而您又单击了交互作用 > 二次，则 X1*X2 将被添加至模型项列表中。
添加所有的二阶效应，包括二因子交互作用和二次效应 | 单击 RSM 按钮。此时，设计将使用 I 最优性准则而不是 D 最优性准则。
添加选定的交叉乘积项
  1. 高亮度显示因子名称。
  2. 高亮度显示模型列表中的项。
  3. 单击交叉按钮。
在模型效应中添加连续因子的幂 | 单击幂按钮，然后选择二次、三次、四次或五次。

选择试验次数

根据在模型中添加的效应，“设计生成”面板（"用于选择试验次数的选项"）将显示执行试验所需的最少试验次数。同时，它还将显示备选试验次数，并允许您自己选择试验次数。您可以通过添加的额外试验所获取的信息来平衡每次试验的成本。

用于选择试验次数的选项

“设计生成”面板包含以下用于选择所需试验次数的选项：

  • 最小值是创建设计所需的最小项目数。如果选择了最小值，那么最终设计将呈饱和状态（没有误差自由度）。这是一种风险较大的极端选择，只有在禁止额外试验成本时适用。
  • 默认值是定制设计试验次数的建议值。此值源于创建平衡设计的启发式，其试验次数比最小值稍大。
  • 折衷值是另一个推荐选项，它比默认值更保守。其值通常介于默认值和网格之间。
  • 大多数情况下，网格将显示全因子设计中的数据点数，但混料及区组设计除外。通常，网格过大，它只是用于参考和比较的一个选项。

    注：如果选择网格，则不一定生成完全析因设计。
  • 用户指定是您指定的试验次数值。请在试验次数文本框中输入值。

如果完成填写“设计生成”面板，请单击制作设计。

理解设计和刻画器

在创建设计表之前，您可以使用预测刻画器（"析因设计布局"）和曲面图来预览设计并查看详细资料。JMP 通常都会提供预测刻画器，但只会在具有两个或更多变量的情况下显示曲面图。

析因设计布局

每个因子的预测方差是设计和未知误差方差的函数。误差方差假定为 1。即，预测方差给出相关的任何实际误差方差。例如，如果误差方差是 5，而特定因子设置上已报告的预测方差是 0.4，则该点的预测方差为 2。

单个因子二次模型的预测刻画

预测方差在因子允许范围中变小是很理想的。通常，误差方差会随样本大小的增加而下降。比较两个设计的其中一种方法是并列比较两个设计的预测方差刻画器。具有较低平均预测方差的设计是优先的选择。

在刻画器中，拖动图形中的垂直线可以将因子设置更改为不同的点。拖动线条显示每个具有比所需预测方差大的点。

理解系数方差表

在单击定制设计器中的制表前，单击展开按钮（在 Windows/Linux 中为 [image] 和在 Macintosh 中为 [image] ）打开系数的相对方差表。

系数的相对方差表（"系数的相对方差表"）为定制设计显示的所有系数的相对方差。方差是相对于试验前未知的误差方差而言的。误差方差假定为 1。得到误差方差的估计值之后，您可以将其与相对方差相乘以获得系数的估计方差。当使用分析 > 模型拟合拟合模型时，此值的平方根应该与预测系数的标准误差一致。

系数的相对方差表

理解别名矩阵（混杂模式）

在单击定制设计器中的制表前，单击展开按钮（在 Windows/Linux 中为 [image] 和在 Macintosh 中为 [image] ）打开别名矩阵。

如果所有的因子为二水平因子，则别名矩阵只会在定制设计具有二因子交互作用是出现。此表将显示模型项和所有二因子交互作用之间的混杂关系（如果有）。它允许查看 D 最优设计中的混杂模式。

别名矩阵

指定输出选项

使用“输出选项”面板可以指定输出数据表的显示方式：

  • 试验顺序 — 允许您指定创建数据表时试验在表中的显示顺序。选项包括：
    • 保持相同 — 输出表中的行（试验）将按它们在“设计”面板中的顺序显示。
    • 从左至右排序 — 输出表中的行（试验）将从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将从右至左排序。
    • 区组内随机化 — 输出表中的行（试验）将在设置的区组中按随机顺序显示。
  • 中心点数 — 指定位于每个连续因子范围中心的附加试验。
  • 重复次数 — 指定整个设计的重复次数，包括中心点。请在关联文本框中键入所需的设计重复次数。重复一次将使试验次数翻倍。

制表

如果“设计”面板显示了所需的布局，请单击制表。表的一些部分包含了继续在 JMP 中处理表和设计所需的信息。

设计表实例


创建裂区设计

当便于按组（名为整区）运行试验时，将进行裂区试验，其中在试验组中一个或数个因子的值保持恒定。通常这是因为这些因子在试验间难于更改，或者代价昂贵。JMP 称这种因子为难变因子。在工业实践中，由于难变因子的存在才提出了裂区设计的问题。

在完全随机化设计中，任何因子都可以在每一次试验时对其设置进行更改。当某些因子难以更改时，完全随机化设计可能会要求对难于更改的因子设置作出多于所需的更改。

如果您知道有一个或两个因子难于更改，则您可以将因子的更改设置从默认的易设置为难。在制作设计前，可以设定您要运行的整区个数。

有关创建裂区设计的实例，请参阅"创建具有两个难调因子的设计：裂区设计"。

要使用定制设计器创建裂区设计，请执行以下操作：

  1. 因子表中包含一个名为改变的列。默认情况下，所有因子的改变均为易。但是，如果单击因子的改变区域，您也可以选择使因子的改变变为难。请注意，贝叶斯 D-最优裂区设计为不可用。如果具有为如果可能的模型，则 JMP 将使更改因子为难变不可能。
  2. 一旦完成了因子定义并单击了继续，您将看到一个用于提供整区数的编辑框。您可以提供任何值，只要该值大于拟合所有模型参数所需的最小值。您也可以将此字段留空。在此情况下，JMP 将选择一个整区数，以使固定参数的综合不确定性最小。

    注：如果您要在每次创建一个裂区设计时使用某个因子，可以通过在所有试验中将因子设置为“难”来保存步骤。有关详情，请参阅"标识因子变化"。


特殊定制设计命令

在选择试验设计 > 定制设计后，屏幕将显示"单击红色三角形图标以展开命令" 中的窗口。单击标题栏中的红色三角形图标，以展开命令列表。以下部分介绍了这些命令及其用法。

单击红色三角形图标以展开命令

保存响应和因子

如果计划通过已指定有意义的名称和值的因子和（或）响应以作进一步的试验，那么您可以保存这些因子或响应以备将来使用。

要保存因子或响应，请执行以下操作：

  1. 从“试验设计”菜单中选择设计类型。
  2. 在相应的面板中输入因子和响应（有关详情，请参阅"在定制设计器中输入响应和因子"）。
  3. 单击标题栏上的红色三角形图标，然后选择保存响应或保存因子。
    • 选择保存响应将创建一个数据表，其中每个响应都有对应的一行，且名为响应名称的列将标识响应。四个附加列标识了有关响应的更多信息：下限、上限、响应目标和重要性。
    • 选择保存因子将创建一个数据表，其中每个因子都有对应的一列，且每个因子水平都有对应的一行。列具有一个名为设计角色的列性质（在列面板上以星号图标标记），可将这些列标识为试验设计因子并列出其类型（连续、分类、区组等）。
  4. 保存数据表。

载入响应和因子

如果已经保存了响应和因子，则您可以将它们快速应用于设计中，从而避免每次运行试验时都必须重新输入的麻烦。

要使用先前保存的响应和因子来设计试验，请执行以下操作：

  1. 打开包含因子名称和水平的数据表。
  2. 从“试验设计”菜单中选择设计类型。
  3. 单击标题栏上的红色三角形图标（"从 JMP 表中载入因子名称和值"），然后选择载入响应或载入因子。
从 JMP 表中载入因子名称和值

.

提示：可以通过在空表中键入数据来创建一个因子表，但要记得为每列分配因子类型。要执行此操作，请使用鼠标右键单击列名并选择列信息，然后选择列性质 > 设计角色。最后，单击“设计角色”区域的按钮，然后选择相应的角色。

载入和保存约束

在定制、扩充和混料设计中，如果设置了因子约束并计划使用它们作进一步的试验，那么您可以保存这些因子以备将来使用。您可以将这些约束快速应用于设计中，从而避免每次运行试验时都必须重新输入的麻烦。

要保存因子约束，请执行以下操作：

  1. 从“试验设计”菜单中选择设计类型。
  2. 在相应的面板中输入因子约束（有关详情，请参阅"在定制设计器中输入响应和因子"）。
  3. 单击标题栏上的红色三角形图标（"从 JMP 表中载入因子名称和值"），然后选择保存约束。保存约束将创建一个数据表，其中包含您在约束面板中输入的信息。表中的每个约束均有一个对应的列。每个列均有一个名为约束状态的列性质，将该列标识为“小于”或“大于”约束。此外，每个变量均有一个对应的行以及包含不等式条件的附加行。
  4. 保存数据表。

要使用先前保存的因子约束来设计试验，请执行以下操作：

  1. 打开包含约束的数据表。
  2. 从“试验设计”菜单中选择设计类型。
  3. 单击标题栏上的红色三角形图标（"从 JMP 表中载入因子名称和值"），然后选择载入约束。

设定随机数生成器

设计过程从随机数开始。要设定设计器使用的随机数，请单击设计标题栏上的红色三角形图标（"从 JMP 表中载入因子名称和值"），然后选择设定随机种子。

出现的窗口显示了该设计生成种子（"设定随机种子"）。在此窗口中，您可以设定新的随机数后再次运行设计。

如果使用相同的种子作为上一个设计，您将再次得到相同的设计。

设定随机种子

查看诊断报表

要显示相关的 D、G 和 A 有效性，平均预测方差和创建设计的时间长度的表，请在单击制作设计按钮前在定制设计标题栏（"单击红色三角形图标以展开命令"）中单击红色三角形图标并选择显示诊断。现在，当您单击制作设计按钮时，“模型”面板中的模型下会显示一个诊断报表（"显示诊断的定制设计"）。

其中

  • ND 是设计中的数据点数
  • p 是模型中的效应数（包括截距）
  • σM 是设计点中的最大标准预测误差。

这些有效性度量为尝试量化数学设计特征的单个数字。当每个准则的最大有效性是 100 时，很多设计问题是不可能有 100% 的有效性。最好使用这些设计度量来比较这两个具有相同模型和试验次数的可比性设计，而不是使用一些设计质量绝对度量。

显示诊断的定制设计

保存设计 (X) 矩阵

要创建一个脚本并在数据表中将设计矩阵保存为表性质，请单击“定制设计”标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择保存 X 矩阵。脚本将被保存为名为设计矩阵的表性质。在运行脚本时，JMP 会创建一个名为 X 的整体矩阵，并在记录中显示它的行数。如果看不到记录，请选择视图 > 记录（Macintosh 中为窗口 > 记录）。

更改设计准则（D 或 I 最优性）

要更改设计准则，请单击“定制设计”标题栏上的红色三角形图标（"更改设计准则"）并选择最优性准则，然后选择制作 D 优化设计或制作 I 优化设计。

更改设计准则

所有设计类型的建议默认准则是 D 最优，除非您使用“模型”面板中的 RSM 按钮添加了效应，从而使模型成为了二次模型。有关最优性准则的特定信息，请参阅"技术论述"。

选择随机起始数

要改写默认的随机起始数，请单击“定制设计”标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择起始数。在选择此命令时，屏幕将显示如"更改起始数" 所示的窗口以及一个编辑框，您可以在其中为要建立的设计输入随机起始数。您输入的数字将改写默认的起始数，而默认的起始数因设计而异。

更改起始数

为什么要更改起始数？

创建最优设计的一大难题在于，当最优设计有理论存在时，生成最优设计的方法不能保证将找到全局最优设计。所有正交设计都是在线性可加模型下 D 最优的。

随着因子数和样本的变大，优化问题会变得越来越困难。最优化往往收敛到局部最优而不是全局最优值。

了解以下内容会对您十分有用：

  • 如果将随机起始数用于优化，则最终生成的设计将不尽相同。增加随机起始个数会改进结果设计的最优性。
  • 对于二水平因子设计，优化行列式具有公式：
如果 D 是行列式，n 是样本大小，而 c 是设计矩阵的列数，则 LogD = cLogn。
如果由随机数开始而得出的行列式结果满足以上的公式，则运算终止。设计为 D 最优且正交。

随机起始数的默认选择

除非是碰巧，JMP 将不会从随机设计开始。算法（坐标交换）的一次迭代所需时间会大致随样本大小与模型中项数的乘积增长。通过对小样本执行大量的随机起始数，并随设计的增大而依样本大小平方的比例减小随机起始数，生成设计所需的总时间将大致保持在一般样本大小的范围内。

每个设计默认的起始数如下表所示：

样本大小 | 起始数
9 或更小 | 80
9 至 16 | 40
17 至 24 | 10
25 至 32 | 5
大于 32 | 2

最后，如果试验次数是 4 的倍数、每个因子只有两个水平且模型为线性，则上面列出的起始数将乘以 4。对规则的这一修改有助于找到二水平分式析因设计和 Plackett-Burman 设计（或其等效设计）。

将设计约束为超球面

您可以通过编辑球形半径将定制和扩充设计约束为超球面。在制作设计之前，单击“定制设计”标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择球形半径。输入相应的值并单击确定。

请注意超球面约束不适用于其它约束。并且，超球面约束不能生成裂区设计。

如果将每个因子的更改设计为难（请参阅"创建最佳裂区设计"和"创建裂区设计"），球形半径项将变为不可用。相反，一旦设定了球形半径，您就不可以使因子难于更改。

考虑因子水平约束

JMP 为您提供了拒绝特定因子水平的组合的灵活性。您可以对定制和扩充设计执行此操作，有混料因子或区组因子的试验除外。此功能还可用于连续因子或连续与分类因子。

例如，在一次市场研究选择试验中，您可能想排除产品的所有最佳性能位于最低价格的选择。在此情况下，功能因子水平包括最差 (1)、中等 (2) 和最佳 (3)，而价格因子水平包括高 (1)、中 (2) 和低 (3)。您要排除功能的第三个水平（最佳）以及价格的第三个水平（低）。

要排除因子水平组合，请执行以下操作：

  1. 首先添加因子。
  2. 单击设计器窗口中标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择排除的组合。请注意如果您已定义线性不等式约束，则此菜单项将为不可用。
  3. 输入标识不允许项的布尔表达式（"输入布尔表达式"）。JMP 将计算您的表达式，如果表达式为真，则不接受指定的组合。

    注：构成表达式时，请使用水平的保序值而不是水平名称。如果价格因子的水平名称为高、中和低，则它们相应的保序值应为 1、2 和 3。
例如，在"输入布尔表达式" 中，功能==3 & 价格==3 将禁止运行最低价的最佳功能。如果实例中存在两个不被允许的组合，您应使用功能==3 & 价格==3 | 质量==3 & 价格==3，它将告诉 JMP 拒绝最佳功能最低价的试验，和最佳质量在最低价的试验。
输入布尔表达式
  4. 制作设计表。它排除了您指定的因子组合，如"没有价格和功能同时为 L3 的行" 所示。
没有价格和功能同时为 L3 的行

高级选项

以下选项仅适用于试验设计的高级用户。

设定 K 交换值

默认情况下，坐标交换算法将对每次迭代中可能的替换考虑每一行的因子设置。要减少在各个迭代中考虑的行数，您可设定 k 少于 n。这样通常会加快设计创建，但会生成在估计模型中未知数上效率较低的设计。

要更改 K 交换值，请执行以下操作：

  1. 选择试验设计 > 定制设计。
  2. 单击设计器窗口中标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择高级选项 > K 交换值。
  3. 输入一个正整数并单击确定。
  4. 制作设计。

更改每个因子的搜索点

对于主效应模型，定制设计器中的坐标交换算法只会考虑上限值和下限值。不过，您也可以对此进行更改，以便算法考虑更多的搜索点。例如，如果您输入 5，JMP 将考虑各个因子的五个等距设置。要更改搜索点，请执行以下操作：

  1. 选择试验设计 > 定制设计。
  2. 单击设计器窗口中标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择高级选项 > 搜索每个因子的点。
  3. 输入一个正整数并单击确定。
  4. 制作设计。

更改混料总和

如果要在试验中始终保持混料的某个分量为常数，则其它混料分量的总和必须在 0.001 和 1 之间。您可以有一种或多种固定成分，因此剩余总和添加为小于 1 而大于 0。要改变混料总和，请执行以下操作：

  1. 选择试验设计 > 定制设计。
  2. 单击设计器窗口中标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择高级选项 > 混料总和。
  3. 输入一个正整数并单击确定。
  4. 制作设计。

裂区方差比

最优裂区设计取决于随机整区方差对误差方差的方差比。默认情况下，方差是 1。如果具有对此方差比的先验知识，您就可以通过以下步骤得出此方差：

  1. 选择试验设计 > 定制设计。
  2. 单击设计器窗口中标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"），然后选择高级选项 > 裂区方差比。
  3. 输入一个正整数并单击确定。
  4. 制作设计。


指定列性质

数据表中的列可以包含特殊的列性质。要查看表明列性质的实例，请选择帮助（Macintosh 中为查看）> 样本数据目录 > Design Experiment > 弹性数据.jmp。请注意名为拉伸的列，该列具有两个特殊性质：角色和响应限。要查看这两个性质（如"列信息窗口和新建性质菜单" 所示），请在数据表中使用鼠标右键单击列名并选择列信息。

列信息窗口和新建性质菜单

所有的特殊列性质均已在《JMP 用户指南》中进行了介绍。下面我们将讨论特定于试验设计以及用于分析试验设计数据的性质。

定义列的下限值和上限值（试验设计编码）

编码会将您指定范围的数据转换到 -1 和 ＋1。如果选择了分析 > 以 X 拟合 Y，JMP 将使用那些转换后的数据值（仅限于连续变量），以计算分析中有意义的参数估计。这种转换就称为编码。您可以指定列的低值和高值的转换范围。

默认情况下，当 JMP 根据您在“因子”面板中输入的值生成设计表时，它将使用这些值作为编码性质的下限值和上限值。请注意，如果某个列缺失了一个或多个界限，JMP 将用数据的最小值和最大值替换上限值和下限值。

要更改低值和高值的转换范围，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择编码。编码信息将出现在右侧，如"“编码”窗口" 所示。
“编码”窗口
  3. 在文本框内键入所需的下限值和上限值。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

为混料试验设定列为因子

您的数据表中可以包含一列，以作为构成 100% 混料的某个因子。您可以建立一个这样的列，以便在选择分析 > 模型拟合对数据进行分析时，JMP 能够使用该列自动生成无截距模型。

要建立用作混料因子的列，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择混料。混料信息将出现在右侧，如"混料信息" 所示。
混料信息
  3. 输入上限和下限以及项总和。

  4. 根据需要选定 L 伪分量编码和 U 伪分量编码旁边的复选框。使用"混料信息" 中的实例，其中混料总和值为 1，项将被编码为：
XiL = (Xi - Li)/(1 - L) 用于 L 伪分量编码
XiU = (Ui - Xi)/(U - 1)，用于 U 伪分量
其中 Li 和 Ui 为下限和上限，L 是 Li 的总和，U 是 Ui 的总和。如果您在此实例中同时选定两个复选框，若 (1 - L) < (U - 1)，“模型拟合”平台将使用 L 编码，否则将使用 U 编码。
在“模型拟合”报表中，主效应被标记为编码转换。交叉效应没有标记，但会使用编码值。所有拟合功能（如刻画器和保存的公式）均会考虑伪分量编码，但只会在表和图形中显示未编码的值。
  5. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

定义响应列值

您可以在列中保存响应限。如果这样，您无需每次都重新指定响应限即可运行分析。在列中保存这些响应限将有助于在每次使用时保持一致性。例如，如果要运行应用这些约束的分析，并在之后更改数据，则可以使用相同的约束对新数据运行新的分析。

您可以指定下限、中间值、上限以及意愿值，如"定义响应列值" 所示。您还可以选择最大化、匹配目标值、最小化或无，这些都是试验设计响应变量的可能目标。如果存在两个响应，则可以输入一个重要值，以便让 JMP 了解如何度量响应之间的重要性。

要输入响应限，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择响应限。
  3. 完成窗口中的设置，如"定义响应列值" 所示。
定义响应列值
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

为列指定设计角色

您可以告诉 JMP 如何在模型中使用因子列来设计试验 — 将因子列用作连续、分类、区组、协变量、混料、常数、信号或干扰因子。

要为列指定设计角色，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择设计角色，如"选择设计角色" 所示。设计角色信息将出现在右侧。
选择设计角色
  3. 单击“设计角色”下拉菜单并选择您希望 JMP 使用因子列的方式：连续、分类、区组、协变量、混料、常数、信号、噪声、不受控和随机区组。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。

标识因子变化

要使用 JMP 的 DOE（试验设计）命令创建裂区设计，您必须将某个因子标识为“难”，即因子是难于变化的。每次设计试验时都可以在“试验设计”设计面板中将因子标识为“难”（有关详情，请参阅"创建裂区设计"）。但是，如果您知道每次创建裂区设计都要用到的因子，则可以在所有使用该因子的试验中将其列设置为“难”，以节省步骤。

要将因子标识为“难”并使用该因子创建裂区设计，请执行以下操作：

  1. 双击数据网格中的列名。此时将出现“列信息”窗口。
  2. 从列性质下拉菜单中选择因子变化，如"选择因子变化" 所示。因子变化信息将出现在右侧。
选择因子变化
  3. 单击“因子变化”下拉菜单并选择您要 JMP 使用该因子列的方式：易或难。
  4. 单击确定。此时，数据表列面板的列名旁边将出现性质图标 ( [image])，表明该列包含某个性质。


定制设计工作原理：幕后

定制设计器将从每个因子范围内的随机点集开始。计算方法是名为坐标交换的迭代算法 (Meyer and Nachtsheim, 1995)。算法的每次迭代都将检验设计中每个因子的值，以便确定替换该值是否会提高最优性准则。如果是，则新值将替换旧值。迭代将继续，直至在一次完整的迭代中不再发生替换。

为避免收敛至局部最优，整个过程将使用不同的随机起始数重复多次。定制设计器将显示其中的最佳设计。有关详情，请参阅"更改设计准则（D 或 I 最优性）"部分。

有时，设计问题可能具有多个等效解。等效解是在整体设计模型参数时具有相同精度的设计。如果情况如此，在重复单击后退和制作设计按钮时，设计算法可能生成不同（但等效）的设计。


筛选设计

筛选设计已被证明是工业试验中最常用的设计。它们会检查许多因子，以确定其中对制程结果影响最大的因子。

相对于其它设计方法而言，筛选设计要求的试验次数更少，这就是它们实惠的原因。由于这是一种既经济又高效的制程改进方式，因而颇具吸引力。

通常筛选设计是深入试验的一个序幕。明智的做法是只将约四分之一的资源预算用于初始筛选试验中。接着，您可以使用这些结果进行深入研究。

筛选设计的效率取决于效应稀疏性的关键假设。导致效应稀疏性的原因是实际制程通常只有少数的驱动因子，其他因子相对不那么重要。要了解效应稀疏性的重要性，您可以将筛选设计与完全析因设计进行对比：

  • 完全析因设计由因子水平的所有组合组成。试验次数是因子水平的乘积。例如，具有一个二水平因子、一个三水平因子和一个四水平因子的因子试验有 2 x 3 x 4 = 24 次试验。
  • 相比之下，筛选设计将因子限制在二（或三）水平，并仅执行完全析因设计的某个部分，从而减少了试验次数。

筛选设计中的每个因子通常都设定在二水平，以便减少所需的试验次数，并仅对可能存在的一部分水平组合进行响应测量。在上述情况下，您可以将因子限制在二水平，从而实现 2 x 2 x 2 = 8 次试验。此外，通过执行这八个组合中的一半，您仍然可以评估这三个因子的单独效应。因此，筛选方法可以将 24 次试验的试验减少为四次试验。

当然，这种减少也是有代价的。本章详细介绍了筛选方法，并从正反两方面进行了讨论。同时，还说明了如何使用 JMP 的筛选设计器，并在其中提供了一个用于二因子或多因子的常用筛选设计列表。这些因子可以是具有二水平或三水平的连续因子或分类因子。您可以使用的筛选设计列表包含了可将试验运行分为大小相等的区组，其大小是 2 的幂的设计。

目录

筛选设计实例

使用两个连续因子和一个分类因子

使用五个连续因子

创建筛选设计

输入响应

输入因子

选择设计

显示和修改设计

指定输出选项

查看表

继续分析


筛选设计实例

本章分为两部分。第一部分包含使用筛选设计的两个实例。第二部分列出了创建筛选设计需要遵循的步骤，以满足个人需求。

使用两个连续因子和一个分类因子

假设工程师要研究使用电子束焊接机连接两个部件的制程。工程师将这两个部件固定在焊接夹具上使它们紧贴在一起。为电子束生成器输入电压使之生成电子束，为这两个部件加热。理想的熔化区域深度是 0.17 英寸。工程师想要研究焊接制程，以确定电子束生成器使熔化区域产生所需深度的最佳设置。

对于这项研究，工程师想要探究以下三种输入，也就是研究的因子：

  • 操作员，即操作焊接机的技术人员
  • 旋转速度，部件在电子束下的旋转速度
  • 电子束电流，影响电子束强度的电流

每次处理试验后，工程师都会将部件切割成两半。这样会显示出两个部件熔化的区域。此熔化区域的长度就是焊接的穿透深度。此穿透深度就是研究的响应。

这项研究的目标在于：

  • 找到影响焊接深度的因子
  • 量化那些效应
  • 找到能预测焊接深度 0.17 英寸的因子设置

要开始此实例，请从主菜单中选择试验设计 > 筛选设计。请注意，“响应”面板中有单一默认响应，名称为 Y。按照以下步骤更改默认响应：

  1. 双击响应名称并将其更改为深度 (in.)。
  2. 单一默认响应的默认目标是最大化，但此制程的目标是获取目标值 0.17 英寸，下限为 0.12，上限为 0.22。单击目标文本编辑区域并选择匹配目标值，如"具有匹配目标值目标的筛选设计响应" 所示。
具有匹配目标值目标的筛选设计响应
  3. 单击下限文本编辑区域并输入 0.12（可接受的最小值）作为下限，然后单击上限文本编辑区域并输入 0.22（可接受的最大值）作为上限。

此实例具有一个分类因子（操作员）和两个连续因子（速度和电流）。

  4. 单击二水平分类因子旁的添加按钮，添加分类因子。
  5. 在连续框中键入 2 并单击相关的添加按钮，添加两个连续因子。
  6. 双击因子名称并将它们重命名为操作员、速度和电流。
  7. 将速度的上限值和下限值设定为 3 rpm 和 5 rpm。将电流的上限值和下限值设定为 150 amp 和 165 amp，并指定 Mary 和 John 作为分类因子操作员的值，如"具有两个连续因子和一个分类因子的筛选设计" 所示。
具有两个连续因子和一个分类因子的筛选设计
  8. 单击继续。
  9. 在设计列表中选择完全析因设计，如"两个连续因子和一个分类因子的筛选设计列表" 所示，然后单击继续。
两个连续因子和一个分类因子的筛选设计列表

完成设计详细资料后，请单击制表来创建包含指定设计的 JMP 表。此时将显示如"设计数据表" 所示的表。该表会使用您为响应、因子和水平指定的名称。模式变量显示了代码设计试验。

  10. 选择帮助（Macintosh 中为查看）> 样本数据目录 > Design Experiment > DOE 例一.jmp，可查看在本实例中生成的表。
设计数据表

使用五个连续因子

如上一节所示，筛选许多因子效应的试验通常只考虑每个因子的两个水平。这样就能以最少的试验次数检查许多因子。

下面的实例改编自 Meyer, et al. (1996)，介绍了如何在具有多个因子的情况下使用 JMP 的筛选设计器。在这项研究中，一位化学工程师研究了一个化学制程中五个因子对百分比反应的效应。这些因子为：

  • 送入速度，添加到反应室的原材料数量，单位为公升/分钟
  • 催化剂百分比
  • 送入速度，响应室中螺旋推进器的 RPM
  • 反应温度，以摄氏度为单位
  • 反应物的浓度

要启动实例，请执行以下操作：

  1. 选择试验设计 > 筛选设计。
  2. 您将看到一个名称为 Y 的默认响应。将默认响应名称 (Y) 更改为反应百分数。
  3. 添加五个连续因子。
  4. 将默认因子名称 (X1-X5) 更改为送入速度、催化剂、搅拌速度、温度及浓度。
  5. 输入高值和低值，如"筛选许多因子" 所示。
  6. 将最低可接受响应百分比（下限）更改为 90，上限为 99，重要性为 1（"筛选许多因子"）。
筛选许多因子
  7. 单击继续。现在，JMP 列出了针对您指定的因子数的设计，如"二水平筛选设计（左）及设计输出选项（右）" 中左边所示。
  8. 选择列表中的第一项，这是一个 8 次试验的部分析因设计。
  9. 再次单击继续，查看"二水平筛选设计（左）及设计输出选项（右）" 右侧的“设计输出选项”面板。
二水平筛选设计（左）及设计输出选项（右）

设计对话框的选项显示在"设计表输出选项" 中，可用于修改最终设计表。

设计表输出选项
  10. 单击制表来创建数据表，如"筛选实例 JMP 试验表" 所示，它列出了选定设计的试验。请注意，其中还有一个名称为反应百分数的列用于记录试验结果，如数据表右边所示。
筛选实例 JMP 试验表

对于“反应百分数”试验中的五个因子，您预期其中有些因子比其它的更为突出。让我们采取某种分析方法来查找活动效应。

  11. 要运行由数据生成的模型，如先前的"筛选实例 JMP 试验表" 所示，请从 Design Experiment 文件夹中打开化学反应-8次试验.jmp，该文件夹位于您安装 JMP 时所安装的 Sample Data 文件夹内。
  12. 在设计数据表中，使用鼠标右键单击模型脚本并选择运行脚本，或选择分析 > 拟合模型以分析数据。


创建筛选设计

要启动筛选设计，请选择试验设计 > 筛选设计，或单击“JMP 起始页”中试验设计上的筛选设计按钮。然后，执行以下步骤：

  1. "输入响应"
  2. "选择设计"
  3. "显示和修改设计"
  4. "指定输出选项"
  5. "查看表"
  6. "继续分析"

输入响应

要输入响应，请执行"输入响应" 中的步骤。

输入响应

提示：要快速输入多个响应，请单击响应数按钮并输入所需的响应数。

指定目标类型以及下限和上限

在输入响应时，您可以告诉 JMP 目标是要获取可能的最大值或最小值、要与特定值匹配，您也可以不指定目标。

以下说明阐述了目标类型（"输入响应" 中的第 3 步）与下限和上限（"输入响应" 中的第 4 步）间的关系：

  • 对于诸如强度或产量之类的响应，最佳值通常为可能的最大值。最大化目标支持此目标。
  • 最小化目标支持最佳目标为最小值的目标，如当响应为不纯度或缺陷数量时。
  • 匹配目标值目标支持最佳响应值为特定目标值的目标，如部件尺寸等。默认目标值假定为在下限与上限中间值。

    注：如果目标值周围的目标范围不对称，则在根据设计生成表后，您可以更改默认目标值。在数据表中，双击列名以打开响应的“列信息”对话框，然后再输入不对称的目标值。

了解重要性权重

在计算整体合意性时，JMP 会将您作为重要性权重输入的值（"输入响应" 中的第 4 步）用作每个响应的权重。如果只有一个响应，则没有必要指定重要性。如果有两个响应，那么您可以为其中一个响应分配更高的重要性值，从而为该响应提供更大的权重。

输入因子

输入响应后再输入因子。“因子”面板的外观取决于选择的设计。在筛选设计、空间填充设计、混料设计以及响应面设计中输入因子的方式都是相同的。本流程在下面"输入因子" 中有所描述。

有关在田口设计、完全析因设计以及定制设计中输入因子的信息，请参阅"田口设计"、"完全析因设计"及"创建定制设计"。

输入因子

因子类型

通常，设计试验时，您可以在模型中输入不同类型的因子。以下内容说明了您在创建筛选设计时可以选择的因子类型：

  • 连续 连续因子只能为数值数据类型。理论上，您可以将连续因子设为您所提供的下限和上限之间的任何值。
  • 分类 分类数据类型没有默认顺序。如果值为数值，则以数值大小顺序为准。如果值为字符，则以排序顺序为准。分类因子的设置是离散的，并且不存在内在顺序。分类因子的实例为装置、运算符和性别。

输入响应和因子后，请单击继续。

选择设计

您可以使用的筛选设计列表包含了可将试验运行分为大小相等的区组，其大小是 2 的幂的设计。高亮度显示要使用的筛选设计的类型，然后单击继续。

选择筛选设计类型

筛选设计器提供了以下设计类型：

二水平完全析因

完全析因设计包含所有因子水平组合。样本大小是因子水平的乘积。对于二水平设计，样本大小为 2k，其中 k 是因子数。如果因子数大于 3 或 4，这将变得非常昂贵。

这些设计是正交的。这意味着效应的估计是不相关的。如果在分析中移除一个效应，其它估计仍将保持不变。它们的 p 值会有轻微变化，因为误差方差以及自由度的估计是不同的。

完全析因设计允许所有阶（最高至因子数）的交互效应都估计出来。大多数经验建模都涉及一阶近似或二阶近似，近似于因子和响应之间的真实函数关系。"完全析因设计（左）和二水平部分析因设计（右）的表示" 中的左图是二水平因子的几何表示。

二水平部分析因

部分析因设计的样本大小同样是 2 的幂。如果 k 是因子数，则试验次数为 2k - p，其中 p < k 占完全析因的 2-p 分之一。与完全析因设计一样，部分析因设计也是正交的。

筛选设计中的权衡介于试验次数和设计的分解度之间。如果对代价没有约束，您可以多次重复运行 m 个因子水平的所有可能组合。这将可以很好地估计所有对象，包括 m 阶的交互作用效应。但由于运行试验既耗时又耗钱，因此通常只需运行所有可能水平的一部分。这将导致模型中的某些高阶效应不可估计。当效应与其它效应混杂时，往往不可估计。事实上，通过提前确定将哪个交互作用效应与另一个交互作用效应混合，即可设计部分析因设计。

分解度值：混杂的程度

在实践中，很少有试验者担心高于双因子交互作用的交互作用。这些高阶交互作用被假定为零。这样，就可以按分解度值将试验分类为三组：

  • 分解度 = 3 表示主效应与一个或多个双因子交互作用混合，为使主效应有意义，必须将这些双因子交互作用假定为零。
  • 分解度 = 4 表示主效应没有与其它主效应或二因子交互作用混合。但是，二因子交互作用与其它二因子交互作用混合。
  • 分解度 ≥ 5 表示主效应之间、二因子交互作用之间或主效应与二因子交互作用之间没有混杂。

所有的部分析因设计均为最小偏差设计。对于试验设计专家，在指定的分解度下最小偏差设计将最小化最短长度的定义关系的字数。

"完全析因设计（左）和二水平部分析因设计（右）的表示" 中右侧的图是二水平部分析因设计的几何表示。

完全析因设计（左）和二水平部分析因设计（右）的表示

Plackett-Burman 设计

Plackett-Burman 设计是部分析因用于筛选的备选设计。一个极为有用的特点是样本大小是 4 的倍数，而不是 2 的幂。没有样本大小介于 16 和 32 次试验之间的二水平部分析因设计。但存在 20 次试验、24 次试验以及 28 次试验的 Plackett-Burman 设计。

主效应是正交的，且二因子交互作用仅部分地与主效应混杂。这与无法从主效应中区分二因子交互作用的分解度 3 部分析因设计不同。

在效应稀疏性情况下，逐步回归方法允许添加高度显著且稍微相关的二因子交互作用，同时移除某些不显著的主效应。

混合水平设计

如果定性因子有三个值，则先前介绍的三种经典设计都不适用。对于纯三水平因子，JMP 提供了部分析因设计。对于混合二水平和三水平设计，JMP 提供了完全析因设计和专业的正交数组设计，如下所示。

Design | 二水平因子 | 三水平因子
L18 John | 1 | 7
L18 Chakravarty | 3 | 6
L18 Hunter | 8 | 4
L36 | 11 | 12

如果您设计中的因子数小于或等于表中所列，您可以通过从原始设计中选择相应的列子集来使用该设计。其中某些设计是不平衡的，虽然它们都是正交的。

Cotter 设计

当资源很少但因子很多，且您相信可能存在交互作用时，就应使用 Cotter 设计。假设您根据效应稀疏性认为只有非常少效应真正非零。您非常确信这一点，以致敢打赌如果您添加一定数量的效应，如果其包含活动效应，总和将显示效应。但危险在于有些带混合符号的活动效应会相互抵消，且总和仍将接近零，给出假阴性。

Cotter 设计很容易设置。对于 k 个因子，有 2k + 2 次试验。设计类似于“一次更改一个因子”方法，许多书中都认为这低效、幼稚。

Cotter 设计以所有因子都处于其高水平的试验开始。随后的 k 次试验都会轮流有一个因子处于其低水平，而其它因子处于高水平。下一个试验集合会将所有因子设定为低水平，而随后的 k 次试验将轮流使一个因子为高水平，其它为低水平。随机化试验后，就完成了 Cotter 设计。

使用 JMP 生成 Cotter 设计时，JMP 还会包括一个附加列集，作为回归量。这些回归量的形式为因子 Odd 和因子 Even，其中因子是因子名称。这些可通过为每个因子添加所有奇数和偶数交互作用项来构建。例如，如果有三个因子 A、B 和 C：
AOdd = A + ABC | AEven = AB + AC
BOdd = B + ABC | BEven = AB + BC
COdd = C + ABC | CEven = BC + AC

由于 Cotter 设计中的这些列形成了正交变换，所以检验这些组合的参数就等价于检验原始效应的组合。在上面列出的因子实例中，AOdd 估计了包括 A 的偶数项的总和。AEven 估计了包括 A 的奇数项的总和，依此类推。

由于 Cotter 设计存在假阴性危险，因此许多统计学家并不鼓励使用该设计。

如何运行 Cotter 设计

默认情况下，JMP 不会在可用筛选设计列表中包括 Cotter 设计（"选择筛选设计类型"）。但是，如果要执行 Cotter 设计，请执行以下操作：

  1. 输入响应和因子之后（单击继续之前），立即单击“筛选设计”标题栏中的红色三角形图标。
  2. 选择抑制 Cotter 设计。

通过红色三角形菜单更改设置仅适用于当前设计。要更改全部筛选设计的设置，请执行以下操作：

  1. 选择文件 > 首选项。
  2. 单击平台图标。
  3. 单击试验设计以将其高亮度显示。
  4. 撤消选定抑制 Cotter 设计旁边的复选框。

显示和修改设计

选择设计类型后，请单击展开按钮（Windows/Linux 中为 [image] 、Macintosh 中为 [image] ）显示设计，并使用显示和修改设计面板显示修改选项来裁剪设计（"显示和修改选项"）。

显示和修改选项
  • 更改生成规则 — 控制给定因子数的各个部分析因设计的选择。
  • 效应重叠 — 显示部分析因设计的混杂模式。
  • 代码设计 — 显示每次试验中因子的上限值和下限值模式。

效应混叠

要查看哪些效应与哪些效应相混合，请单击展开按钮（Windows/Linux 中为 [image] 、Macintosh 中为 [image] ）以展开“效应重叠”面板。它会显示至二因子交互作用的效应和混杂（"“生成规则”面板和“效应重叠”面板"）。

“生成规则”面板和“效应重叠”面板

例如，具有五个因子的完全析因需要执行 25 = 32 次试验。八次试验只能满足具有三个二水平因子的全因子。其中有必要根据前三个因子构建另外两个因子。

将试验次数从 32 减少到 8 的代价就是效应重叠（混杂）。混杂是向代码设计列乘积分配新因子值的直接结果。

例如，温度的值是送入速度值和浓度值的乘积。这表示您将无法看出温度效应与送入速度和浓度协同（交互）效应之间的区别。

在"“生成规则”面板和“效应重叠”面板" 显示的实例中，所有的主效应都与二因子交互作用混杂。这是分解度 3 设计的特征。

查看混杂模式

JMP 可以创建一个显示指定水平混淆模式的数据表。要创建此表，请执行以下操作：

  1. 单击“效应重叠”区域底部的红色三角形。
  2. 选择显示混杂模式（"显示混杂模式"）。
显示混杂模式
  3. 输入您期望看到的（"输入顺序"）混杂阶数。
输入顺序
  4. 单击确定。

"五因子反应堆实例的第三水平别名" 显示了五因子反应堆实例的三阶混杂型。效应名称以 C（常数）开始并按设计中的顺序编号显示。因此，温度为“4”，二阶混杂为“1 5”（送入速度和浓度），三阶混杂为“1 2 3”（送入速度、催化剂和搅拌速度）。

五因子反应堆实例的第三水平别名

了解代码设计

在“代码设计”面板中，每一行都表示一次试验。加号表示高水平，减号表示低水平。如"默认代码设计" 所示，代码设计前三列的行表示送入速度、催化剂和搅拌速度，是上限值和下限值的所有组合（完全析因设计）。代码设计的第四列（温度）是前三列的元素与元素乘积。同样，最后一列（浓度）是第二列和第三列的乘积。

默认代码设计

更改代码设计

在“更改生成规则”面板中，更改选定标记并单击应用将更改代码设计；它更改了给定因子数的各个部分析因设计的选择。"默认代码设计" 右边的更改生成规则表显示了如何根据前三列构建后两列。温度的选定标记显示了它是送入速度、催化剂和搅拌速度的一个函数。浓度的选定标记显示了它是催化剂和搅拌速度的一个函数。

作为另外的实例，如果您选定"修改后的代码设计和生成规则" 中所示的选项并单击应用，则“代码设计”面板就会改变。代码设计的前三列仍然是前三个因子（送入速度、催化剂和搅拌速度）的完全析因。温度现在是送入速度和催化剂的乘积，所以代码设计的第四列是前两列的元素与元素乘积。浓度是送入速度和搅拌速度的一个函数。

修改后的代码设计和生成规则

指定输出选项

使用“输出选项”面板可指定输出数据表的显示方式。正确设置选项后，请单击制表。

选择输出选项
  • 试验顺序 — 允许您指定创建数据表时试验在表中的显示顺序。选项包括：
    • 保持相同 — 输出表中行（试验）的显示方式将与其在“设计”面板中的方式一致。
    • 从左至右排序 — 输出表中的行（试验）将按从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将按从右至左排序。
    • 区组内随机化 — 输出表中的行（试验）将在设置的区组中按随机顺序显示。
  • 中心点数 — 指定位于中心点的试验次数。
  • 重复次数 — 指定整个设计的重复次数，包括中心点。请在关联文本框中键入所需的设计重复次数。重复一次将使试验次数翻倍。

查看表

单击制表后，您将获得一个概述了试验的数据表。在表中，将为每次试验都显示指定的上限值和下限值。

设计数据表

继续分析

创建和查看数据表后，您可以对数据进行分析。数据表包含一个标记为模型的脚本。使用鼠标右键单击该脚本并选择运行脚本，可运行拟合模型分析（"运行模型脚本"）。

运行模型脚本

随后章节将介绍单击运行模型时出现的分析报表的某些部分。

查看实际值对预测值图

如果模型不包含交互作用，实际值对预测值图（如"实际值对预测值图" 左边所示）将出现在“模型拟合”报表的顶部。

实际值对预测值图

要显示图形中的标签（"实际值对预测值图" 的右边），请选择所有点，使用鼠标右键单击该图形，然后选择行标签。显示在数据表中的模式变量作为每个点的标签。

在"实际值对预测值图" 中，均值线位于 95% 置信曲线界限内，这说明模型并不显著。模型 p 值、R 2 以及 RMSE 出现在图形的下方。

RMSE 是制程噪声的标准差的估计，其中假定未估计效应是可忽略的。在这种情况下，RMSE 为 14.199，比前瞻的要大。这说明主效应以外的效应是重要的。由于设计中二因子交互作用和主效应的混杂，因此如果不进行更多的试验，将无法确定哪些二因子交互作用重要。

查看尺度无关估计报表

当您拟合模型时，JMP 会显示一个“尺度无关估计”报表（"“尺度无关估计”报表实例"），它是“模型拟合”报表的一部分。“尺度无关估计”报表显示了嵌入参数估计表中的个体效应的条形图。表的最后一列是每个效应的 p 值。所有的因子效应都不显著，但催化剂效应已经大到足以引起关注而怀疑其真实性。在这个阶段结果并不明显，但这并不意味着实验失败了。这表示需要一些后续试验。

“尺度无关估计”报表实例

如果此尺度无关估计报表不只是个实例，则您将需要扩充设计，如"扩充设计"中所述。为了进行比较，您也可能需要执行完整的 32 次试验因子的试验数据和分析。有关此内容，请参阅"完全析因设计"。

运行功效分析

如果模型包含交互作用，JMP 会显示“效应详细资料”面板。打开外框节点。然后单击因子标题栏上的红色三角形图标并选择功效分析，运行功效分析。

功效分析实例

有关详情，请参阅《JMP 统计和图形指南》。


响应面设计

响应面设计可用于对连续因子构建二次曲面模型。如果因子区域内存在最小或最大响应，则响应面模型可精确指出。每个因子需要三个不同的值来拟合二次函数，因此标准二水平设计不能拟合曲面。

最常用的响应面设计是中心复合设计，如下方左图所示。它结合了二水平部分因子和其它两种点：

  • 中心点，所有因子值均在零（或中端）位置。
  • 轴（或星）点，所有因子中只有一个设定在零（中端）位置，且有一个因子设定在外部（轴）值处。

Box-Behnken 设计，如下方右图所示，是中心复合设计的备选方法。

Box-Behnken 设计的其中一个特点是每个因子只有三个水平。

两种设计类型之间另一重要区别在于 Box-Behnken 设计在由因子范围定义的立方体角点处没有点。这在出于工程考虑而需要回避此类点时将十分有用。和中心复合设计相比，此特征的缺陷在于更难确定角点附近的预测值。

目录

Box-Behnken 设计：网球实例

查看 Box-Behnken 设计的几何分布

创建响应面设计

输入响应和因子

选择设计

指定轴值（仅限于中心复合设计）

指定输出选项

查看设计表

如果需要，继续分析


Box-Behnken 设计：网球实例

弹性数据.jmp 样本数据文件具有响应面数据，该数据来自于 Derringer 和 Suich (1980) 描述的 tire tread 数据。要查看此实例数据表，请打开安装 JMP 时安装的 Sample Data 文件夹，然后选择 Design Experiment > 弹性数据.jmp。

此试验的目标在于为网球的弹性匹配一个标准目标值 (450)。弹性将随用于制造网球的硅、硅烷和硫的数量的变化而变化。试验者希望针对这些变量的大范围的值进行数据收集，以查看响应面是否能找到与指定弹性目标匹配的因子组合。要继续此实例，请执行以下操作：

  1. 选择试验设计 > 响应面设计。
  2. 通过单击“响应面设计”标题栏上的红色三角形图标并选择载入因子来载入因子。定位至您安装 JMP 时安装的 Sample Data 文件夹，然后选择 Design Experiment > 弹性因子.jmp。
  3. 通过单击“响应面设计”标题栏上的红色三角形图标并选择载入响应来载入响应。定位至您安装 JMP 时安装的 Sample Data 文件夹，然后选择 Design Experiment > 弹性反应.jmp。完成后的“响应”面板和“因子”面板如"弹性数据的响应和因子" 所示。
弹性数据的响应和因子

载入响应数据和因子数据后，“响应面设计”选择对话框将列出如"响应面设计选择" 中所示的设计。

响应面设计选择

为三个效应选定的 Box-Behnken 设计将生成如"三因子 Box-Behnken 设计的 JMP 表" 所示的 15 次试验的设计表。

在现实生活中，您要先开展试验，然后在数据表中输入响应。我们假设一切已经发生，并使用名为弹性数据.jmp 最终数据表。

  1. 打开至您安装 JMP 时安装的 Sample Data 文件夹，然后选择 Design Experiment > 弹性数据.jmp（"三因子 Box-Behnken 设计的 JMP 表"）。
三因子 Box-Behnken 设计的 JMP 表

打开弹性数据.jmp 数据表后，请对数据运行模型拟合分析。数据表包含一个标记为模型的脚本。

  2. 使用鼠标右键单击模型并选择运行脚本，可开始模型拟合分析。
  3. 单击运行模型。

"弹性数据的响应面分析的 JMP 统计报表" 中所示的表将显示标准“模型拟合”分析结果，并对模型中的所有响应面和交叉效应使用参数估计。

预测模型极为显著，且并未显示出失拟合的迹象。所有主效应项以及包含硫的两个交互作用效应均显著。

弹性数据的响应面分析的 JMP 统计报表

有关"弹性数据的响应面分析的 JMP 统计报表" 中表判读的详情，请参阅《JMP 统计和图形指南》的“标准最小二乘：简介”一章。

“响应面”报表也具有如"响应面分析的统计报表" 中所示的表。

响应面分析的统计报表

有关"响应面分析的统计报表" 中响应面分析表的详情，请参阅《JMP 统计和图形指南》的“标准最小二乘：探索预测方程”一章。

使用预测刻画器

现在，使用响应“预测刻画器”以进一步了解响应面，从而找出达到响应目标的最佳设置。这种方法是一次更改一个变量，并查看预测响应的效应。

  1. 如果尚未打开“预测刻画器”，请通过单击“响应”标题栏上的红色三角形并选择因子刻画 > 刻画器（"刻画器"）打开。
刻画器

刻画器（"用于响应面分析的预测刻画器"）显示了每个 x 变量的预测迹。预测迹是当一个变量发生变化而其它变量保持当前值不变时的预测响应 (Jones 1991)。

拉伸的当前预测值 396 是以默认因子设置为根据的。它将由水平虚线表示，该虚线显示在意愿函数目标值（"用于响应面分析的预测刻画器"）稍下一点的位置。刻画显示了因子硅、硅烷和硫的意愿设置，所得拉伸的值为 396，该值接近于指定目标值 450。

该行的每个因子都有一个显示其意愿迹的图形。刻画器还包含了“意愿”列，它将 0 至 1 尺度范围内的意愿绘成图形，且每个 y 变量都具有可调整的意愿函数。整体意愿测量显示在意愿迹行的左侧。

预测刻画器
  2. 调整因子的预测迹并找出接近于目标值的拉伸值。垂直拖动意愿函数中间的抓手以更改目标值。或者通过单击“预测刻画器”标题栏上的红色三角形并选择最大化意愿，找出适当的因子设置。此命令可调整刻画迹以产生最接近指定目标值（由意愿函数给出的目标值）的响应值。可接受值的范围取决于上下抓手所在的位置。

"用于响应面分析的预测刻画器" 显示了最合意的设置结果。分别将硅、硅烷和硫的设置从 1.2、50 和 2.3 更改为 0.98、41.5 和 2.09 后，预测响应由 396 升为目标值的 450。

用于响应面分析的预测刻画器

有关“预测刻画器”的详细说明，请参阅《JMP 统计和图形指南》的“标准最小二乘：探索预测方程”一章。

使用响应面图（等高线刻画器）

查看响应面的另一种方法是使用“等高线刻画器”。单击“响应”标题栏上的红色三角形并选择因子刻画 > 等高线刻画器以显示交互式等高线刻画器，如"用于响应面分析的等高线刻画器" 中所示。

查看以图形显示的响应面时，尤其是存在多个响应时，等高线刻画器将十分有用。此实例显示了当硅烷为固定值，对硅和硫所进行的刻画。

“等高线刻画器”标题栏上的选项可用于设置网格密度，请求曲面图（网状图）以及在指定的区间添加等高线，如"用于响应面分析的等高线刻画器" 中的等高线图所示。每个因子的滑动杆将为当前 X 和当前 Y 设定值。

用于响应面分析的等高线刻画器

"具有上限和下限的等高线刻画器" 显示了当前 x 值具有效应上限和下限时的等高线刻画图，并在等高线上标绘了阴影区域。

具有上限和下限的等高线刻画器

“预测刻画器”和“等高线刻画器”将在《JMP 统计和图形指南》的“标准最小二乘：探索预测方程”一章中作详细论述。

查看 Box-Behnken 设计的几何分布

通过使用“旋转图”平台，可以查看具有三个效应的设计的几何结构。"三效应 Box-Behnken 设计的旋转图" 中所示的旋转图描述了三个 Box-Behnken 设计列。旋转平台上的可用选项可绘制从中心到各点的射线，在框中解析点，还可以抑制 x、y 和 z 轴。您可以清楚地看到角点之间的 12 个点，中心有三个。

三效应 Box-Behnken 设计的旋转图

有关如何创建旋转图的详情，请参阅《JMP 统计和图形指南》。


创建响应面设计

响应面方法 (RSM) 是为找到指定因子范围内的最佳响应而发明的试验技术。此类设计能够为响应拟合二阶预测方程式。这些方程式中的二次项可为真响应函数中的弯曲建模。如果因子区域内存在最大值和最小值，RSM 能够将其找出。在工业应用中，RSM 设计只涉及少量因子。这是因为所需的试验次数随因子数的变化而显著增加。使用响应面设计器，您可以选择对二至八个连续因子使用著名的 RSM 设计。这些设计中的某些设计还允许区组。

响应面设计对于建模和分析曲面十分有用。

要启动响应面设计，请选择试验设计 > 响应面设计，或单击 JMP 起始页试验设计页中的响应面设计按钮。然后，执行以下步骤：

  • "输入响应和因子"
  • "选择设计"
  • "指定轴值（仅限于中心复合设计）"
  • "指定输出选项"
  • "查看设计表"
  • "如果需要，继续分析"

输入响应和因子

输入响应的步骤与筛选设计、空间填充设计、混料设计、响应面设计、定制设计以及完全析因设计中的步骤相同。这些步骤在"在定制设计器中输入响应和因子"中有所详述。

在响应面设计中输入因子的步骤对于此设计是独一无二的。要添加因子，请执行"向响应面设计中输入因子" 中的步骤。

向响应面设计中输入因子

单击继续以继续下一步骤。

选择设计

高亮度显示要使用的响应面设计的类型，然后单击继续。

选择设计类型

响应面设计器提供了以下设计类型：

Box-Behnken 设计

Box-Behnken 设计的每个因子只有三个水平，且在由因子范围定义的立方体角点处没有点。这在出于工程考虑而需要回避极点时将十分有用。和中心复合设计相比，此特征的缺陷在于更难确定角点附近的预测值。

中心复合设计

响应面设计列表包含两种类型的中心复合设计：一致精度和正交。中心复合设计的这些性质与设计中的中心点数和轴值相关：

  • 一致精度表示已选定中心点数，以使中心的预测方差与设计角点处的预测方差大致相同。
  • 对于正交设计，选定中心点数可以使二阶参数估计与其它参数估计尽可能不相关。

指定轴值（仅限于中心复合设计）

选择中心复合（CCD — 一致精度）设计，然后单击继续，您就会看到"显示和修改中心复合设计" 中的面板。它提供了默认的轴尺度信息。在文本框中输入 1.0 可使 JMP 将轴值放置在由因子定义的立方体表面上。它控制了轴点将突出多远。您可以随意输入要使用的值。

显示和修改中心复合设计
  • 可旋转使得预测方差仅取决于与设计中心的尺度距离。这导致轴点比起因子的范围更为极端。如果实际上不能达到此因子范围，建议您选择平面或指定您自己的值。
  • 正交在分析中产生正交效应。这导致轴点比起表示因子范围的 -1 或 1 更为极端。如果实际上不能达到此因子范围，建议您选择平面或指定您自己的值。
  • 平面把轴点保留在 -1 和 1 范围的末端。
  • 用户指定使用的是用户输入的值，该值可以是大于零的任何值。请在试验次数文本框中输入值。

如果要解析设计，请单击解析旁的框。选定此框，JMP 将重新调节整个设计，以便使轴点处于该范围的上限和下限末端（轴范围为 -1 到 1，因子的范围根据尺度收缩）。

指定输出选项

使用“输出选项”面板可指定输出数据表的显示方式。正确设置选项后，请单击制表。

选择输出选项
  • 试验顺序 — 允许您指定创建数据表时试验在表中的显示顺序。选项包括：
    • 保持相同 — 输出表中的行（试验）将按它们在“设计”面板中的顺序显示。
    • 从左至右排序 — 输出表中的行（试验）将从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将从右至左排序。
    • 区组内随机化 — 输出表中的行（试验）将在设置的区组中按随机顺序显示。
  • 中心点数 — 指定位于中心点的试验次数。
  • 重复次数 — 指定整个设计的重复次数，包括中心点。请在关联文本框中键入所需的设计重复次数。重复一次将使试验次数翻倍。

查看设计表

现在，您已获得一个概述试验的数据表，如"设计数据表" 中所述。

设计数据表

如果需要，继续分析

在创建和查看设计表，运行试验以及将结果记录到设计表的 Y 列后，请对数据运行模型拟合分析。数据表包含一个标记为模型的脚本。使用鼠标右键单击该脚本并选择运行脚本（"运行脚本"）以拟合该模型。

运行脚本

单击对话框中的运行模型后，（"运行脚本"），请复查分析。

拟合模型


完全析因设计

完全析因设计包含了一组因子所有可能的组合。这是最为保险的设计方法，但同时也是最耗费试验资源的方法。完全析因设计器同时支持多达九个水平的连续因子和分类因子。

在完全析因设计中，您将在每个因子水平的组合中执行试验。样本大小是因子水平数的乘积。例如，具有一个二水平因子、一个三水平因子和一个四水平因子的因子试验有 2 x 3 x 4 = 24 次试验。

只具有二水平因子的析因设计的样本大小是 2 的幂（通常为 2f，其中 f 是因子数）。存在三个因子时，析因设计点位于立方体的角点处，如下图所示。对于多个因子，设计点为超立方体的角点。

完全析因设计是所有设计类型中最为保险的方法。如果要尝试因子设置的所有组合，使用此方法几乎可避免出现不明确情况。

遗憾的是，因子数中的样本大小会以指数增长，因此，对于大多数实用目的来说，运行完全析因设计显得过于昂贵。

目录

五因子反应堆实例

创建析因设计

输入响应和因子

选择输出选项

制表


五因子反应堆实例

以下实例由 Meyer 等人 (1996) 和 Box、Hunter 以及 Hunter (1978) 改编，文中详述了五因子反应堆实例。

要执行此实例，请打开安装 JMP 时安装的 Sample Data 文件夹。在此文件夹中，打开 Design Experiment > 化学反应-32次试验.jmp。

假设您已使用筛选设计器针对一个化学制程的百分比反应效应研究五个因子的效应（请参阅"筛选设计"）。这些因子（送入速度、催化剂、搅拌速度、温度和浓度）均为二水平连续因子。

  1. 选择试验设计 > 完全析因设计。
  2. 单击“完全析因设计”标题栏上的红色三角形图标，然后选择载入响应。
  3. 通过打开与 JMP 一同安装的 Sample Data 文件夹打开化学反应结果.jmp 以载入响应。在 Sample Data 文件夹中，打开 Design Experiment > 化学反应结果.jmp。
  4. 单击“完全析因设计”标题栏上的红色三角形图标，然后选择载入因子。
  5. 通过打开与 JMP 一同安装的 Sample Data 文件夹打开化学反应因子.jmp 以载入响应。在 Sample Data 文件夹中，打开 Design Experiment > 化学反应因子.jmp。

完成后的对话框如"完全析因实例响应和因子面板" 所示。

完全析因实例响应和因子面板
  6. 单击继续以查看“输出选项”面板。完全析因设计包括五个变量的高因子和低因子所有组合的试验，共有 32 次试验。
  7. 单击制表。

设计数据表（"化学反应 - 32 次试验.jmp"）包含五个变量的高值和低值每个组合的试验。由于存在 5 个变量，因此有 25 = 32 次试验。这就包括了 5 个因子的所有组合，其中每个因子具有 2 个水平。最初，表中存在一个名为反应百分数的空 Y 列，供您在完成试验时输入响应值。

表中的值可能不同于以下显示的值。

25 因子反应堆数据

要查看完成后的试验并继续跟进此实例，请打开安装 JMP 时安装的 Sample Data 文件夹。在此文件夹中，打开 Design Experiment > 化学反应-32次试验.jmp。

化学反应 - 32 次试验.jmp

在拟合因子模型之前浏览数据，即可开始进行分析。

  1. 选择分析 > 分布。
  2. 高亮度显示反应百分数并单击 Y，列。然后，单击确定。
  3. 单击“反应百分数”标题栏上的红色三角形图标并选择正态分位数图。结果如"反应堆数据的响应变量分布" 所示。
反应堆数据的响应变量分布

使用逐步回归启动形式分析。脚本与数据表同时保存，脚本会自动定义包含主效应和所有二因子交互作用的模型分析，并弹出“逐步”控制面板。

  1. 单击模型拟合脚本旁的红色三角形图标并选择运行脚本。
  2. 模型中进入因子的概率（进入的概率）应为 0.05。
  3. 移除因子的概率（剔除的概率）应为 0.1。
运行逐步回归的 JSL 脚本
  4. 使用“逐步”平台的一种有效途径是检查“当前估计值”表中的所有主效应。要执行此操作，请确保将方向旁的菜单指定为混合。
  5. 选定因子主效应复选框，如"启动逐步流程的模型" 所示。
  6. 单击执行。
启动逐步流程的模型

混合逐步流程移除了无关紧要的主效应，添加了重要的交互作用。"混合逐步回归后的模型" 中显示了最终结果。请注意，送入速度和搅拌速度因子不再存在于模型中。

混合逐步回归后的模型
  7. 单击构建模型按钮。此时出现的“模型规格”窗口将使用适合的效应（"拟合预测模型"）自动进行设置。
拟合预测模型
  8. 单击运行模型以查看候选预测模型（"实际值对预测值图和预测模型估计"）的分析。

"实际值对预测值图和预测模型估计" 中左侧的图显示了模型的实际值对预测值图。预测模型的预测反应范围在 40% 至 95% 之间。由 RMSE 测出的随机噪声大小仅为 3.3311%，该值高于数量级而低于预测范围。这是模型具有较佳预测能力的有力证据。

"实际值对预测值图和预测模型估计" 中右侧的图显示了模型系数及其标准误差的表（标记为参数估计）。逐步流程选定的所有效应均极为显著。

实际值对预测值图和预测模型估计

同时，因子“预测刻画器”将为您提供比较因子和查找最佳设置的方法。

  1. 通过单击“响应反应百分数”标题栏上的红色三角形并选择因子刻画 > 刻画器来打开预测刻画器，如"选择刻画器" 所示。
选择刻画器

"查看刻画器" 显示了刻画器的初始外观。“预测刻画器”将在《JMP 统计和图形指南》的"响应面设计"一章和“标准最小二乘：探索预测方程”一章中作详细介绍。

查看刻画器
  2. 单击“预测刻画器”标题栏上的红色三角形，然后选择最大化意愿以查看"查看最大化意愿" 中的刻画器。
查看最大化意愿

将意愿图与反应百分数进行对比显示，其目的在于最大化反应百分数。除非反应百分数高于 90%，否则该反应在经济上难以实施，因此意愿值低于 90% 的反应将逐渐减少并最终变为零。意愿将随反应百分数的递增而线性递增。

当催化剂和温度为最高设置，而浓度为最低设置时，意愿的最大值为 0.945。反应百分数从因子范围的中间值 65.5 提高到最合意的设置值 95.875。


创建析因设计

要启动完全析因设计，请选择试验设计 > 完全析因设计，或单击 JMP 起始页试验设计页上的完全析因设计按钮。然后，执行以下步骤：

  • "输入响应和因子"
  • "选择输出选项"
  • "制表"

输入响应和因子

输入响应的步骤会在"在定制设计器中输入响应和因子"中进行详述

在完全析因设计中输入因子的步骤对于此设计是独一无二的。要添加因子，请参阅"在完全析因设计中输入因子"。

在完全析因设计中输入因子

完成添加因子后，请单击继续。

选择输出选项

使用“输出选项”面板可以指定输出数据表的显示方式：

  • 试验顺序 — 允许您指定创建数据表时试验在表中的显示顺序。选项包括：
    • 保持相同 — 输出表中的行（试验）将按它们在“设计”面板中的顺序显示。
    • 从左至右排序 — 输出表中的行（试验）将从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将从右至左排序。
  • 中心点数 — 指定位于每个连续因子范围中心的附加试验次数。
  • 重复次数 — 指定整个设计的重复次数，包括中心点。请在关联文本框中键入所需的设计重复次数。重复一次将使试验次数翻倍。

制表

单击制表，此时将出现如"析因设计表" 所示的表。

析因设计表


混料设计

混料设计器支持具有作为混料成分的因子的试验。您可以在几种标准的混料设计方法中选择，例如，单纯形设计、极角点设计和格子点设计。对于是极角点设计法，您可以提供一组线性不等式约束，限制混料因子空间的几何分布。

混料性质几乎总是各成分的相关比例的函数，而不是绝对总量的函数。在混料实验中，因子值是其混料比例，它在 0 至 1 之间。每个混料处方的比例总和是 1 (100%)。

混料试验设计与筛选设计完全不同。筛选试验是正交的。即，在试验进程外，一个因子设置可独立于其它因子而改变。筛选试验的解释很简单，因为响应因子效应是分开的。

混料时，不可能在所有因子中独立改变一个因子。当更改一种成分的比例时，一种或多种其它成分也必须更改以作补偿。这一简单事实深刻影响着混料试验的每个方面：因子空间、数据性质以及结果解释。

因为比例总和为 1，混料设计有着引人关注的几何分布。混料可行区域表现为单纯形的形式。例如，以 3D 图形中的三个因子为例。总和为 1 的三个因子平面是三角形切片。您可以旋转该平面以正面查看此三角形并以三元图形式查看点。

目录

选择混料设计类型

创建最优混料设计

使用单纯形中心设计

创建设计

单纯形中心设计实例

使用单纯形格子点设计

使用极角点设计

创建设计

具有范围约束的极角点设计实例

具有线性约束的极角点设计实例

极角点设计法：工作原理

使用 ABCD 设计

创建三元图

拟合混料设计

理解整体模型检验和方差分析报表

理解响应面报表

一个化学混料实例

创建设计

运行混料模型

查看预测刻画器

绘制混料响应面


选择混料设计类型

在选择试验设计 > 混料设计和设置响应和因子后，您可以看到混料设计器显示在"混料设计选择对话框"。在此选择下面设计类型中的一种：

  • 最优设计 选择最优可调用具有所有已定义混合变量的定制设计器。
  • 单纯形中心设计 指定用于确定因子组合的阶数。
  • 单纯形格子点设计 指定所需的网格边缘的水平数。
  • 极角点设计 指定线性约束或限制上限和下限在范围 0 至 1 内。极角点设计最为灵活，因为它可以处理因子值中的约束。
  • ABCD 设计 这个由 Snee (1975) 设计的方法可生成混料的筛选设计。
混料设计选择对话框

以下章节举出了每种混料设计类型的实例。


创建最优混料设计

创建最优混料设计，可使用所有已定义的混料变量调用定制设计器。要创建最优混料设计，请执行以下操作：

  1. 选择试验设计 > 混料设计。
  2. 输入因子和响应。输入响应的步骤会在"在定制设计器中输入响应和因子"中进行详述。
  3. 设置响应和因子后，请单击继续。
  4. 单击最优设计按钮。
  5. 使用以下说明将效应添加至模型。然后单击制作设计并遵循"选择试验次数"中关于设计生成面板和"理解设计和刻画器"中关于预测方差刻画的说明以完成设计的其它步骤。

将效应添加至模型

最初，“模型”面板只会列出所输入因子对应的主效应，如"模型面板" 所示。

模型面板

但是，如果不希望将模型约束为主效应，您可以在模型中添加因子交互作用或连续因子的幂。它们也被称为要 JMP 来估计的附加效应。

要在模型中添加特定因子类型，请执行以下操作：

操作 | 说明
为模型效应添加交互作用项 单击交互作用按钮，然后选择二次、三次、四次或五次。系统将添加相应的值。例如，如果因子为 X1 和 X2，而您又单击了交互作用 > 二次，则 X1*X2 将被添加至模型效应列表中。 --或，交叉效应--
  1. 高亮度显示要交叉的因子和效应。
  2. 单击交叉按钮。系统将添加相应的值。
例如，如果要将因子 X1 和 X2 与效应 X3 进行交叉，则 X1*X3 与 X2*X3 会分别添加至模型效应列表中。
在模型效应中添加连续因子的幂 | 单击幂按钮，然后选择二次、三次、四次或五次。


使用单纯形中心设计

n 因子的 k 阶单纯形中心设计由具有以下内容的混料试验组成：

  • 所有单因子
  • 同一水平下的所有二个因子组合
  • 同一水平下的所有三个因子组合
  • 依此类推，直至在 k 个相同的水平下，每次具有 k 个因子的组合。

此设计始终包括所有成分的量相等的中心点试验。

创建设计

创建单纯形中心设计，请执行以下操作：

  1. 选择试验设计 > 混料设计。
  2. 输入因子和响应。输入响应的步骤会在"在定制设计器中输入响应和因子"中进行详述。
  3. 设置响应和因子后，请单击继续。
  4. 在标记为 K 的框中输入成分数。JMP 将运行每种未混合的成分，然后每次混合 k 种成分的同等比例至指定限制。
  5. 单击单纯形中心设计按钮。
  6. 查看因子设置。
  7. 指定试验顺序，此顺序为创建它时您要试验显示在数据表中的顺序。选项包括：
    • 保持相同 — 输出表中的行（试验）将按它们在“设计”面板中的顺序显示。
    • 从左至右排序 — 输出表中的行（试验）将从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将从右至左排序。
    • 区组内随机化 — 输出表中的行（试验）将在设置的区组中按随机顺序显示。
  8. 指定重复次数。
  9. 单击制表。

单纯形中心设计实例

三因子 1 阶设计试验表（在"1 阶和 2 阶三因子单纯形中心设计" 左方）显示了单个成分及其之后的中心点的试验。右方的试验表表示运行两阶的三个因子。前三次试验是针对单个成分，第二组则显示了三组中每两个成分的组合，而最后一次试验则是中心点。

1 阶和 2 阶三因子单纯形中心设计

要在"1 阶和 2 阶三因子单纯形中心设计" 中生成试验集，请执行以下操作：

  1. 选择试验设计 > 混料设计。
  2. 输入三个连续因子。
  3. 单击继续。
  4. 在 K 框输入 1，并单击单纯形中心以在"创建 1 阶和 2 阶单纯形中心设计" 的左方查看设计。
  5. 单击返回按钮并在 K 框中输入 2。然后单击单纯形中心并在"创建 1 阶和 2 阶单纯形中心设计" 右方查看设计。
创建 1 阶和 2 阶单纯形中心设计

另一个实例：

  1. 选择试验设计 > 混料设计。
  2. 输入五个因子并单击继续。
  3. 在 K 框中使用默认值 4。
  4. 单击单纯形中心。
  5. 单击制表查看显示在"五因子单纯形中心设计的因子设置列表" 中的 31 次试验的 JMP 数据表。
五因子单纯形中心设计的因子设置列表


使用单纯形格子点设计

单纯形格子点设计是创建试验的三角形网格的空间填充设计。此设计为所有组合的集，其中因子值是 i / m，且 i 为从 0 至 m 并使因子总和为 1 的整数。

创建单纯形格子点设计：

  1. 选择试验设计 > 混料设计。
  2. 输入因子和响应。输入响应的步骤会在"在定制设计器中输入响应和因子"中进行详述。
  3. 单击继续。
  4. 在“混料设计类型”对话框中（"混料设计选择对话框"）指定您要的水平数并单击单纯形格子点。

"3、4 及 5 因子水平的三因子单纯形格子点设计" 显示 3 阶、4 阶及 5 阶单纯形格子点设计的三因子试验和相应的几何表示形式。与单纯形中心设计相比，单纯形格子点设计不必包括中心点。

3、4 及 5 因子水平的三因子单纯形格子点设计

"具有五个变量，顺序（阶数）为 3 的单纯形格子点 JMP 设计表" 列出五种效应的 3 阶单纯形格子点试验。在五阶因子实例中，试验滑过超三角形区域并以网格状方式填充空间。

具有五个变量，顺序（阶数）为 3 的单纯形格子点 JMP 设计表


使用极角点设计

极角点设计考虑了因子限制并选择极角点和它们的平均值（由因子限制形成）作为设计点。此设计类型中的附加界限的常用形式为因子值的范围约束、上限及下限。

极角点设计可找出由一个或多个因子指定的界限所约束的因子空间角（角点）。因子须为非负且合计为 1 的性质是基本的混料约束，它构建了一个三角形区域。

有时其它成分需要范围约束来限制其值大于下限或小于上限。范围约束会切掉三角形（单纯形）区域的一部分以构建附加角点。也可能存在线性约束，它可以定义因子的线性组合大于或小于某些常数。

线性约束的区域界限几何图形被称为单纯形，并且因为角点代表操作环境的极限条件，它们通常在试验中用作设计点的最佳位置。

通常要在角点间添加点。共用一个约束界限的点的平均值称为重心点，并且可以添加各种阶数的重心点。由直线连接的两相邻角点间的重心点是二阶重心，因为直线是二维的。共用一个平面的角点的重心点为三阶重心，因为平面是三维的，依此类推。

如果无约束地指定极角点设计，则会产生单纯形中心设计。

创建设计

  1. 选择试验设计 > 混料设计。
  2. 输入因子和响应。这些步骤会在"在定制设计器中输入响应和因子"中进行详述。记得要在因子面板中输入上限和下限。
  3. 单击继续。
  4. 在阶数文本框中，输入您要添加重心的阶数。重心点是共用约束界限的点的平均值。
  5. 如果具有线性约束，则为每个您要添加的约束单击线性约束按钮。然后使用显示的文本框来定义因子的线性组合比某些常数大或小。
  6. 单击极角点设计。此时将显示因子设置。
  7. （可选）更改试验顺序，此顺序为您想在创建数据表时试验的出现顺序。选项包括：
    • 保持相同 — 输出表中的行（试验）将按它们在“设计”面板中的顺序显示。
    • 从左至右排序 — 输出表中的行（试验）将从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将从右至左排序。
    • 区组内随机化 — 输出表中的行（试验）将在设置的区组中按随机顺序显示。
  8. （可选）在选择所需样本大小旁边的文本框中进行输入更改样本大小。
  9. （可选）单击查找子集生成最优子集，它具有在步骤 8 中所介绍的在样本大小框中指定的试验次数。
  10. 单击制表。

具有范围约束的极角点设计实例

以下实例中的设计表，是用于具有"五因子极角点设计实例" 中的范围约束的五个因子，其中的范围小于默认的 0 至 1。

  1. 选择试验设计 > 混料设计。
  2. 添加两个因子并给它们指定显示在"五因子极角点设计实例" 中的值。
  3. 单击继续。
  4. 在阶数文本框（"五因子极角点设计实例"）中输入 4。
五因子极角点设计实例
  5. 单击极角点设计按钮。
  6. 从“试验顺序”菜单中选择从左至右排序。
  7. 单击制表。 "具有范围约束的极角点的 JMP 设计表" 显示了结果表的部分列表。
具有范围约束的极角点的 JMP 设计表

现在让我们返回并输入不同的样本大小（试验次数）。

  8. 依次单击后退、继续。
  9. 在阶数文本框中输入 4 并单击极角点设计按钮。
  10. 在样本大小文本框中，输入 10 作为所需大小。
  11. 单击查找子集生成具有指定试验次数的最优子集。现在，所得设计（"13 次当前试验的 10 次试验子集的 JMP 设计表"）将为 116 次当前试验的最优 10 次试验子集。这在极角点设计生成大量角点时十分有用。
13 次当前试验的 10 次试验子集的 JMP 设计表

具有线性约束的极角点设计实例

以 Snee (1979) 和 Piepel (1988) 所介绍的经典实例为例。此实例有三个因子，X1、X2 和 X3，并具有五个单个因子界限约束和三个附加线性约束：

X1 ≥ 0.1
X1 ≤ 0.5
X2 ≥ 0.1
X2 ≤ 0.7
X3 ≤ 0.7

 90 ≤ 85*X1 + 90*X2 + 100*X3
      85*X1 + 90*X2 + 100*X3 ≤ 95
 .4 ≤ 0.7*X1 + X3

  1. 在因子面板中输入上限和下限。
  2. 单击继续。
  3. 单击线性约束按钮三次。输入如"约束" 中所示的约束。
  4. 单击极角点设计按钮。
  5. 将试验顺序更改为从右至左排序，并保持样本大小为 13 以查看如显示在"约束" 右边的 13 次试验因子设置。
  6. 单击制表。
约束

通过以三元图的形式查看设计，以更好地了解此实例，如"显示 Piepel 实例约束的三元图" 所示。三元图通过显示一个指定成分与三角形中的变量角点的接近程度来显示其与 1 的接近程度。有关详情，请参阅"创建三元图"。

极角点设计法：工作原理

如果存在线性约束，JMP 将使用由 R.E. 开发的 CONSIM 算法。Wheeler 在 Snee (1979) 中有所介绍并由 Piepel (1988) 作为 CONVRT 而介绍。此方法在 Cornell (1990, Appendix 10a) 也有所介绍。此方法结合了约束和检验来查看角点是否与它们相违背。如此这样，它将删除角点并计算新角点。这种处理重心点的方法由 Piepel (1988) 开发，名为 CONAEV。

如果不存在线性约束（只有范围约束），则使用 Snee 和 Marquardt (1974) 及 Snee (1975) 开发的 XVERT 法来构建极角点设计。找到角点后，单纯形中心法会根据指定顺序生成角点组合。

XVERT 法首先会使用具有最小范围的 nf - 1 因子的指定低值和高值，创建完整的 2nf - 1 设计。然后，它根据因子值必须总计为 1 的这一限制计算出省去的那个单因子的值。如果该点处于因子范围内，则将其保留。如果该点不在因子范围内，则它将进行增量或减量以使其处于该范围内，并依次对其它每个因子进行同等总量的减量或增量，从而使这些点仍满足初始限制。

以上算法可创建单体中的可行区域的角点，该单体由因子约束所定义。但是，Snee (1975) 曾经表示，具有边缘的重心和可行区域的面也十分有用。可行区域的广义 n 维面板由界限的 nf-n 定义，并将面重心定义为在其之上的角点平均值。这个算法可生成界限条件下的所有可能组合及均分第一个步骤中生成的角点。


使用 ABCD 设计

此方法是 Snee (1975) 生成的混料筛选设计。要创建 ABCD 设计，请执行以下操作：

  1. 选择试验设计 > 混料设计。
  2. 输入因子和响应。输入响应的步骤会在"在定制设计器中输入响应和因子"中进行详述。
  3. 设置响应和因子后，请单击继续。
  4. 单击 ABCD 按钮。
  5. 查看因子设置。
  6. 指定试验顺序，此顺序为创建它时您要试验显示在数据表中的顺序。选项包括：
    • 保持相同 — 输出表中的行（试验）将按它们在“设计”面板中的顺序显示。
    • 从左至右排序 — 输出表中的行（试验）将从左至右排序。
    • 随机化 — 输出表中的行（试验）将按随机顺序显示。
    • 从右至左排序 — 输出表中的行（试验）将从右至左排序。
    • 区组内随机化 — 输出表中的行（试验）将在设置的区组中按随机顺序显示。
  7. 指定重复次数。
  8. 单击制表。


创建三元图

三种成分的混料问题可以在二维中体现，因为第三种成分为其它成分的线性函数。"显示 Piepel 实例约束的三元图" 中的三元图通过显示一个指定成分与三角形中的变量角点的接近程度来显示其与 1 的接近程度。"混料设计的三元图（左）和四元图（右）" 中左边的图形解释了三元图的意义。

混料设计的三元图（左）和四元图（右）

要以三元图形式查看混料设计，请执行以下操作：

  1. 通过选择试验设计 > 混料设计创建设计并制作设计数据表。
  2. 选择图形 > 三元图。
  3. 填写窗口中的内容并单击确定。

通过显示在"显示 Piepel 实例约束的三元图" 中的三元图，您能最好地了解引自"具有线性约束的极角点设计实例"中的 Piepel (1979) 实例。"显示 Piepel 实例约束的三元图" 中的三元图通过显示一个指定成分与三角形中的变量角点的接近程度来显示其与 1 的接近程度。每个约束都是一条直线。满足所有约束的区域为阴影可行区。在图形中显示有六个活动约束、六个角点、六个重心点以及两个非活动性（多余）约束。

显示 Piepel 实例约束的三元图


拟合混料设计

拟合混料设计模型时，您必须考虑到所有因子的和为一个常数，因此，传统的完全线性模型将不会是完全可估计的。

名为 Scheffé 多项式 (Scheffé1958) 的推荐响应面模型可用于以下方面：

  • 隐藏截距
  • 包括所有的线性主效应项
  • 排除所有的平方项（如 X1*X1）
  • 包括所有的交叉项（如 X1*X2）

要拟合模型，请执行以下操作：

  1. 通过选择试验设计 > 混料设计创建设计并制作设计数据表。请记住，要拟合模型，数据表中的 Y 列必须包含数值，因此，请在制表前指定响应或单击红色三角形菜单并选择模拟响应。
  2. 设计数据表将把模型作为表性质保存在数据表中。这个名为模型的表性质位于表的左边面板中。
  3. 使用鼠标右健单击模型并选择运行脚本以启动“模型规格”对话框，它将自动被保存的模型填满。
  4. 单击运行模型。

在此模型中，参数均易于解释 (Cornell 1990)。线性项上的系数是极值点处的拟合响应，其中混料为单个因子。交叉项系数表明穿过每个因子空间边缘的曲率。您的数值可能与以下显示的有差别。

拟合混料设计

模型报表可能包含所关心的几个部分，包括在下面介绍的整体模型检验、方差分析报表和响应面报表。

理解整体模型检验和方差分析报表

在整体模型方差分析表中，JMP 按照惯例会检验是否除截距外的所有参数为 0。JMP 在不含截距的混料模型中查找隐藏截距，因为效应的线性组合为常数。如果找到隐藏截距，它将执行关于截距模型（而非零截距模型）的整体模型检验。这个检验等同于检验是否除线性参数外的所有参数为 0 并检验它们是否相等。

由于隐藏截距性质，R2 反映截距模型（而非缺失）的信息。

理解响应面报表

JMP 遇到标记为响应面效应 &RS, 的效应时，它会创建附加报表，分析得到的拟合响应面。这些报表原来是为完整响应面，而不是为混料模型而设计。但是，如果 JMP 遇到无截距模型并查出带线性响应面项（而非平方项）的隐藏截距，那么它会折叠计算，压缩最后响应面项来计算最佳值的临界值。它可对生成常数和涉及最后响应面项任何组合执行此操作。

这些报表的等高线图功能不会折叠来处理混料。如果您需要曲面的等高线图，可执行以下任何一项操作：

  • 保存模型预测公式，然后选择图形 > 三元图创建三元图。
  • 使用忽略最后一个因子的完整响应面来重新拟合模型。
  • 选择图形 > 等高线图创建单独的等高线图，并添加点以使图形更光顺。


一个化学混料实例

用来制造汽车座垫 (Cornell, 1990) 的三种可塑剂（软化剂1、软化剂2 和软化剂3）含有 79.5% 的乙烯基。在这 79.5% 的乙烯基比例中，个体可塑剂受到以下约束所限制：0.409 ≤ x1 ≤ 0.849、0 ≤ x2 ≤ 0.252 和 0.151 ≤ x3 ≤ 0.274。

创建设计

要在 JMP 中创建 Cornell 混料设计，请执行以下操作：

  1. 选择试验设计 > 混料设计。
  2. 在“因子”面板中，使用三个默认因子，将它们命名为软化剂1、软化剂2 和软化剂3，并输入如"设置因子" 中所示的高约束和低约束。或者，通过单击“混料设计”标题栏上红色三角形并选择载入因子来载入因子。通过打开安装 JMP 时安装的 Sample Data 文件夹和选择 Design Experiment > 软化剂因子.jmp 来导入因子。
设置因子
  3. 单击继续。
  4. 在阶数文本框中输入 3。
  5. 单击极角点设计。
  6. 单击制表，JMP 使用 9 个因子设置来生成 JMP 表（"混料分析数据"）。
混料分析数据
  7. 通过复制角点和中心点添加额外的五次设计试验。这样总共给设计表提供了 14 行。要执行此操作，高亮度显示您要复制的列，选择编辑 > 复制和行 > 添加行，输入 5 作为要添加的行数，然后单击确定。然后选择编辑 > 粘贴。
  8. 打开安装 JMP 时安装的 Sample Data 文件夹。打开软化剂.jmp查看 Cornell 获得的（"软化剂.jmp"）结果（Y 值）。
软化剂.jmp

运行混料模型

现在运行混料模型：

  1. 使用鼠标右键单击名为混料 RSM 的表性质并选择运行脚本，它可运行创建完成后的对话框的脚本。然后单击运行模型。
  2. 软化剂.jmp 包含名为预测公式 Y 的列。通过单击“响应 Y”标题栏中的红色三角形并选择保存列 > 预测公式来添加此列。要查看预测公式，请使用鼠标右健单击（Mac 中为按住 Ctrl 键并单击）列名并选择公式：
 0-50.1465*p1 - 282.1982*p2 - 911.6484*p3 + p2*317.363 +
p3*p1*1464.3298 + p3*p2*1846.2177

您的数值可能与以下显示的有差别。

请注意：这些结果更正了记录在 Cornell (1990) 中的系数。

“响应面解决方法”报表（"混料响应面分析"）显示在点（0.63505, 0.15568, 0.20927）处出现的最大预测值 19.570299。

混料响应面分析

查看预测刻画器

该报表包含预测刻画器。如果刻画器不可见，在“响应 Y”标题栏中单击红色三角形并选择因子刻画 > 刻画器。

显示在"混料刻画器分析实例" 中的刻画器显示最优设置，其中软化剂1 为 0.6615，软化剂2 为 0.126，软化剂3 为 0.21225，此设置给出一个值为 19.26923 的估计响应。

交叉效应会以曲率形式显示在预测迹中。拖动其中一条垂直参考线，另外两条则向相反方向移动以保持比率。

混料刻画器分析实例

绘制混料响应面

要绘制混料响应面，请执行以下操作：

  1. 选择图形 > 三元图
  2. 通过选择软化剂1、软化剂2 和软化剂3 并单击 Y，标绘按钮来指定图形变量，如"创建三元图" 中所示。通过选择预测公式 Y 并单击等高线公式按钮来标识等高线变量（预测方程）。等高线必须具有预测公式来生成等高线，如"混料响应面的三元图" 中底部的三元图所示。如果没有预测公式，三元图只会显示点。
创建三元图
  3. 单击确定并查看结果，如"混料响应面的三元图" 中所示。
混料响应面的三元图


空间填充设计

在对重复差异的关注远远少于对模型形式的情况下，空间填充设计十分有用。计算机模拟敏感度研究就是这样一种情况。对于此例，以及任何机械的或确定的建模问题，任何的变异性都小到足以忽略不计。

对于没有重复差异的系统，随机化与区组化是无关紧要的。不需要重复，因为重复相同的试验会得到相同的结果。空间填充设计有两个目标。第一个目标是将设计点散布到任意两点间的最大可能距离，从而防止出现重复的点。第二个目标是将这些点均匀分布。

对这些设计类型可以实施四种方法：

  • 球填充（强调点的散布）
  • 拉丁超立方法（点的散布和均匀间距的折衷法）
  • 均匀（模仿均匀概率分布）
  • 最低潜能（在超球面中最小化能量设计）

目录

空间填充设计简介

使用球填充法

创建球填充设计

直观显示球填充设计

使用拉丁超立方法

创建拉丁超立方设计

直观显示拉丁超立方设计

使用均匀设计法

比较球填充法、拉丁超立方法和均匀法

使用最低潜能法

钻孔水流模型实例

创建球填充设计

确定数据分析指引

钻孔试验的结果


空间填充设计简介

空间填充设计对确定的或近乎确定的建模系统十分有用。关于确定的系统的一个实例就是计算机模拟。此类模拟十分复杂，它包括很多具有复杂相互关系的变量。在此类系统上进行设计试验的一个目标就是查找更简单的经验模型，它能充分预测因子在有限范围内的系统行为。

在存在实际随机噪音的系统上进行试验的目标是最小化预测方差。在确定的系统上进行试验不会有方差但会存在偏差。偏差是指近似模型与真实数学函数之差异。空间填充设计的目标是限制偏差。

有两种关于如何限制偏差的方法。一种方法是散布设计点，在试验界限之内使其彼此间距尽可能大。另一种方法是在所关注的区域均匀地散布设计点。

空间填充设计器支持四种设计方法：

  • 球填充设计法 最大化设计点对间的最小距离。
  • 拉丁超立方法 最大化设计点间的最小距离，但是需要均匀隔开每个因子水平。这种方法可生成模仿均匀分布的设计。拉丁超立方法是球填充法和均匀设计法的折衷法。
  • 均匀设计法 最小化设计点（它们为经验均匀分布）和理论均匀分布之间的偏离度。
  • 最低潜能法 将点散布至球体内的中心位置附近。


使用球填充法

球填充设计法可最大化设计点对间的最小距离。此最大化的效应是尽可能多的在设计区内散布点。

创建球填充设计

要使用球填充法，请执行以下操作：

  1. 选择试验设计 > 空间填充。
  2. 输入响应和因子（如有需要）。（请参阅"在定制设计器中输入响应和因子"。）
  3. 改变因子水平值（如有需要）。例如，"两个因子空间填充对话框" 显示，假定有两个现有因子 X1 和 X2，值范围在 0 至 1 之间（而非默认的 -1 至 1）。
  4. 要查看每个点与其最近邻近点之间的偏离度值和最小距离，请在“空间填充”标题栏上单击红色三角形图标并选择显示诊断，如"两个因子空间填充对话框" 所示。
两个因子空间填充对话框
  5. 单击继续。
  6. 在设计规格对话框中（显示在"空间填充设计对话框" 中的左方），指定样本大小。在"空间填充设计对话框" 中显示的实例中，已输入样本大小为 8。
空间填充设计对话框
  7. 单击球填充按钮。JMP 会创建此设计并显示设计试验和设计诊断（如果在第 4 步已指定）。"空间填充对话框、球填充设计设置和设计诊断" 显示打开了“设计诊断”面板，其中最小距离为 0.518。
空间填充对话框、球填充设计设置和设计诊断
  8. 单击制表。

直观显示球填充设计

要直观显示球填充技术的性质，请创建叠加图，调整图形的框架大小，并使用诊断报表中的最小距离作为圆的半径来添加圆：

  1. 使用默认的因子 X1 和 X2 来创建空间填充设计，但将它们的值更改为 0 和 1。
  2. 单击“空间填充”标题栏上的红色三角形图标，并选择显示诊断。
  3. 指定样本大小为 8。
  4. 依次单击球填充按钮和制表。
  5. 选择图形 > 叠加图。
  6. 指定 X1 为 X，X2 为 Y，然后单击确定。
  7. 使用鼠标右键单击图形来调整框架大小，使框架为方形，然后选择大小/尺度 > 调整为相同大小。
  8. 使用鼠标右键单击图形，选择添加图形脚本并输入以下脚本：每行（圆({X1, X2}, 0.518/2)），您可以在“设计诊断”面板中发现最小距离值为 0.518。此脚本以每个设计点为圆心，以 0.259（直径 0.518 的一半）为半径绘制圆，如"8 次试验（左方）和 10 次试验（右方）的球填充实例" 左方所示。这个图形显示了 JMP 填充设计点的高效方式。
  9. 现在重复与前面完全一样的程序，但是样本大小为 10，而不是 8（第 4 步）。记得在图形脚本中将 0.518 更改为由 10 次试验而生成的最小距离。图形出现时，再次设置框架大小并使用诊断报表中作为圆半径的最小距离来创建脚本。您可以看到一个与"8 次试验（左方）和 10 次试验（右方）的球填充实例" 中右方的图类似的图形。请注意球填充的不规则性质。事实上，您可以第三次重复这个过程以获取稍有差别的图片，因为此排列取决于随机启动点。
8 次试验（左方）和 10 次试验（右方）的球填充实例


使用拉丁超立方法

在拉丁超立方中，每个因子有与设计中存在的试验一样多的水平。水平从因子的下限到上限被均匀隔开。像球填充法一样，拉丁超立方法选择点来最大化设计点之间的最小距离，但是有一个约束。这个约束保持因子水平间的等距。

创建拉丁超立方设计

要使用拉丁超立方法，请执行以下操作：

  1. 选择试验设计 > 空间填充。
  2. 输入响应和因子（如有需要）。（请参阅"在定制设计器中输入响应和因子"。）
  3. 改变因子水平值（如有需要）。例如，"四个因子空间填充对话框" 显示了将两个因子添加至两个现有因子并更改它们的值。
  4. 要查看每个点与其最近邻近点之间的偏离度值和最小距离，请在“空间填充”标题栏上单击红色三角形图标并选择显示诊断。
四个因子空间填充对话框
  5. 单击继续。
  6. 在设计规格对话框中指定样本大小。
  7. 单击拉丁超立方按钮。因子设置和设计诊断结果与"8 次试验拉丁超立方设计" 中的结果类似，它显示了具有 8 次试验的拉丁超立方设计。请注意只能为每列（因子）指定每个水平一次，并且每列均为水平的不同排列。
具有 8 个水平的 8 次试验拉丁超立方设计
  8. 单击制表。

直观显示拉丁超立方设计

要直观显示球填充技术的性质，请创建叠加图，调整图形的框架大小，并使用诊断报表中的最小距离作为圆的半径来添加圆：

  1. 首先，使用默认的因子 X1 和 X2 来创建空间填充设计，但将它们的值更改为 0 和 1。
  2. 单击“空间填充”标题栏上的红色三角形图标，并选择显示诊断。
  3. 单击继续。
  4. 指定样本大小为 8。
  5. 单击拉丁超立方按钮。因子设置和设计诊断显示在 "8 次试验拉丁超立方设计" 中。
8 次试验拉丁超立方设计
  6. 单击制表。
  7. 选择图形 > 叠加图。
  8. 指定 X1 为 X，X2 为 Y，然后单击确定。
  9. 使用鼠标右键单击图形并选择大小/尺度 > 框架大小。
  10. 使用鼠标右键单击图形来调整框架大小，使框架为方形，然后选择大小/尺度 > 调整为相同大小。
  11. 使用鼠标右键单击图形，选择添加图形脚本并输入以下脚本：
    每行（圆({X1, X2}, 0.404/2)），您可以在“设计诊断”面板中（"8 次试验拉丁超立方设计"）发现最小距离值为 0.404。此脚本以每个设计点为圆心，以 0.202（直径 0.404 的一半）为半径绘制圆，如"比较 8 次试验（左方）和 10 次试验（右方）的拉丁超立方设计" 左方所示。这个图形显示了 JMP 填充设计点的高效方式。
  12. 重复与前面完全一样的程序,但使用 10 次试验，而不是 8 次试验（第 4 步）。记得在图形脚本中将 0.404 更改为由 10 次试验而生成的最小距离。

您可以看到一个与"比较 8 次试验（左方）和 10 次试验（右方）的拉丁超立方设计" 中右方的图类似的图形。请注意球填充的不规则性质。事实上，您可以再次重复这个过程以获取稍有差别的图片，因为此排列取决于随机启动点。

比较 8 次试验（左方）和 10 次试验（右方）的拉丁超立方设计

请注意拉丁超立方设计中的每对点之间的最小距离小于在球填充设计中的距离。这是因为拉丁超立方设计限制了要均匀间隔的每个因子的水平。球填充设计可无限制地最大化最小距离。


使用均匀设计法

均匀设计法可最小化设计点（具有经验均匀分布）和理论均匀分布之间的偏离度。此类设计在获取未知函数积分的简单和精确估值计时最为有用。估计值是试验中的观测响应的平均值。

  1. 选择试验设计 > 空间填充。
  2. 输入响应和因子（如有需要）。（请参阅"在定制设计器中输入响应和因子"。）
  3. 改变因子水平值（如有需要）。
  4. 要查看每个点与其最近邻近点之间的偏离度值和最小距离，请在“空间填充”标题栏上单击红色三角形图标并选择显示诊断，如"两个因子空间填充对话框" 所示。
  5. 单击继续。
  6. 在设计规格对话框中指定样本大小。
  7. 单击均匀按钮。JMP 会创建此设计并显示设计试验和设计诊断（如果在第 4 步已指定）。请注意“均匀设计”法强调的不是散布点。 "具有 8 次试验的均匀空间填充设计的诊断" 中的最小距离随实际情况而改变。
具有 8 次试验的均匀空间填充设计的诊断
  8. 单击制表。

另外，均匀设计并不保证因子水平的等距。但是，增加试验次数并在每个因子中（选择分析 > 分布）运行分布显示了平的直方图 。

当使用次数增加到 16 次时，每个因子的直方图为平的。


比较球填充法、拉丁超立方法和均匀法

要比较三种空间填充设计法，在“空间填充设计”标题栏中单击红色三角形图标并先选择显示诊断，然后单击球填充、拉丁超立方或均匀按钮。此操作显示每个点与其最近邻近点之间的最小距离和偏离度。此值是设计点与均匀分布之间的差异的积分。

"比较三种 8 次试验的空间填充方法" 显示了三种 8 次试验的空间填充设计的设计诊断比较。请注意均匀设计的偏离度最小（最佳）。球填充设计的偏离度最大（最差）。拉丁超立方偏离度取更接近最优值的中间值。

另请注意球填充法的点对间的最小距离最大（最佳）。均匀设计的有些点对间的距离只有最大值的一半。在散布点方面，“拉丁超立方”设计表现得与球填充设计更为接近。

无论是散布还是偏离度，“拉丁超立方”设计代表了一种健全的折衷方案。

比较三种 8 次试验的空间填充方法

比较的另一个方面就是计算设计所花费的时间。均匀计算法需要最多计算时间。另外，时间将随着点的个数的增加而快速增加。对于可比较的问题，在定制设计器中所有空间填充设计法所花费的时间要多于 D 最优设计。


使用最低潜能法

最低潜能法将点分散到球体内。要了如何创建此设计，请将点想象为相互之间以弹簧连接的电子。库仑力会将点推开，而弹簧却会将它们拉在一起。该设计是最小化系统潜能的点间隔。

要使用最低潜能法，请执行以下操作：

  1. 选择试验设计 > 空间填充。
  2. 输入响应和因子（如有需要）。（请参阅"在定制设计器中输入响应和因子"。）
  3. 改变因子水平值（如有需要）。
  4. 单击继续。
  5. 在设计规格对话框中输入样本大小。
最低潜能设计对话框
  6. 单击最低潜能按钮。JMP 创建此设计并显示设计运行和设计诊断（如果已指定）。
最低潜能设计对话框
  7. 单击制表。


钻孔水流模型实例

Worley (1987) 介绍了一个水流通过钻孔的模型，该孔从地表层开始连通了两个蓄水层。响应变量 y 是指通过地上钻孔的以立方米/年为单位的流率，它由以下方程式确定。

此模型有八个输入变量。

r w = 钻孔的半径，0.05 至 0.15 米
r = 影响范围半径，100 至 50,000 米
T u = 上层蓄水层的传导率，63,070 至 115,600 米 2/年
H u = 上层蓄水层的分压器源头，990 至 1100 米
T l = 下层蓄水层的传导率，63.1 至 116 m2/年
H l = 下层蓄水层的分压器源头，700 至 820 米
L = 钻孔的深度，1120 至 1680 米
K w = 钻孔的水传导性，9855 至 12,045 米/年

此实例为大多数计算机试验的典型例子，因为响应可以表达为简单、显式的输入变量函数。但是，它的简单性对于说明设计方法十分有用。

创建球填充设计

要为钻孔问题创建球填充设计，请执行以下操作：

  1. 选择试验设计 > 空间填充。
  2. 单击“空间填充设计”标题栏上的红色三角形图标，然后选择载入因子。
  3. 打开安装 JMP 时安装的 Sample Data 文件夹。在这个文件夹，打开 Design Experiment > 钻孔水流因子.jmp 来载入因子（"钻孔实例载入的因子"）。
钻孔实例载入的因子

注意：r 和 r w 对数会用于以下问题。

  4. 单击继续。
  5. 指定 32 次试验的样本大小（"空间填充设计法"）。
空间填充设计法
  6. 单击球填充按钮生成设计。
  7. 单击制表制作显示了试验设计设置的表。实例表中的因子设置可能不同于生成设计时的设置，因为这些设计生成于随机种子。
  8. 要查看此实例的已完成的数据表，打开安装 JMP 时安装的 Sample Data 文件夹。打开 Design Experiment > 钻孔水流球形填充.jmp（请参阅"钻孔样本数据"）。此表也有一个表变量，它包含了分析数据的脚本，而分析结果将在表中保存为列。
钻孔样本数据

确定数据分析指引

记住确定的数据没有随机分量十分重要。因此，拟合的统计模型中 p 值失去了它们通常的意义。由于模型项而造成的效应体现为大的 F 统计量（低 p 值）。但是，您不能构建关于效应大小或使用模型构建预测的有效置信区间。

确定数据的任何模型拟合中的残差不是测定噪声的标准。相反，残差显示了当前模型在当前点处的模型偏差。残差中的不同模式表示要添加新项至模型以减少模型偏差。

钻孔试验的结果

从前面章节介绍的实例中可得出以下结果：

  • 对由 8 因子的完全二次模型，对响应 log y 的逐步回归 y 得到预测公式列。
  • 预测偏差列是真实模型列和预测公式列间的差。
  • 每个试验点的预测偏差相对较小。这表明模型拟合数据效果很好。

在实际实例中，通常很难以简单的非分析形式获得真实模型。因此，没有进行附加试验的情况下是不可能知道观测数据之外的点的预测偏差。

在这种情况下，真实模型列包含了一个相对简单的公式，它允许刻画预测偏差以便在数据区域中的任何位置找出其值。要了解此实例中的预测偏差，请执行以下操作：

  1. 选择图形 > 刻画器。
  2. 高亮度显示预测偏差列并单击 Y，预测公式按钮。
  3. 选定展开中间公式框（如"钻孔水流球形填充数据中预测偏差的刻画" 上框的底部所示），因为预测偏差公式也是由公式创建的列的函数。
  4. 单击确定。

"钻孔水流球形填充数据中预测偏差的刻画" 中底部的刻画图显示设计区域中心的预测偏差。如果不存在偏差，刻画迹将会是每个因子的值范围之间的常数。在本例中，变量 Hu 和 Hl 显示了非线性效应。

钻孔水流球形填充数据中预测偏差的刻画

数据中的预测偏差范围小于整个所关注区域的预测偏差范围。要查看此项，请在"预测偏差分布" 中查看预测偏差的分布分析。使用分析 > 分布获取此分析。请注意最大偏差是 1.826，最小偏差是 -0.684（范围为 2.51）。

预测偏差分布

"显示因子区域的最大和最小偏差的预测图" 中顶部的图形显示了整个因子范围的最大偏差 (2.91)。底部的图形显示了可比较的最小偏差 (-4.84)。它给定了一个值为 7.75 的范围。此范围是观测数据范围大小的三倍以上。

显示因子区域的最大和最小偏差的预测图

请记住，在本例中已经指定了真实模型。在任何有意义的应用程序中，每个因子设置的响应是未知的。试验数据的预测偏差对整个设计区域内的偏差估计过低。

有两种方法可以评估此估计不足的范围：

  • 交叉验证 — 在备用点的子集时重新将数据拟合至模型，并查看估计这些点时出现的误差。
  • 验证（试验） — 在不同的设置中执行新的（试验），可评估经验模型的失拟合。


非线性设计

使用“试验设计”菜单或“JMP 起始页试验设计”目录可获得具有参数为非线性的模型的试验设计。

目录

创建非线性设计实例

进行拟合以获取先验参数估计

创建无先验数据的非线性设计

创建非线性设计

标识具有公式的响应/列

设置因子和参数

选择试验次数

查看设计

制作或扩充表


创建非线性设计实例

非线性设计允许科学家生成最优设计和最优扩充数据，从而拟合参数为非线性的模型。可能与标准的多项式模型相比，当此类模型可描述相应制程时，就可以产生更为准确的制程行为预测。

要使用“非线性”设计器，首先需要一个数据表，其中每个因子和每个响应都有对应的一列，且有一列包含显示因子和响应之间函数关系的公式。这就是与您所提供的用于建模的非线性平台相同的表格式。

本节的第一个实例介绍了拥有先验数据时，如何创建非线性设计。第二个实例介绍了在没有数据，但有参数估计的合理初始值时，如何创建设计。

进行拟合以获取先验参数估计

假设您已收集试验数据并将其放入 JMP 数据表中。此表格可以用来创建用于改进模型的非线性参数估计非线性设计。

要执行此实例，请从 Sample Data > Nonlinear Examples > 化学动力学.jmp 中打开化学动力学.jmp。

  1. 化学动力学.jmp（"化学动力学.jmp"）包含列（模型 (x)），其值由表示较差初始假定值的参数值公式产生。
化学动力学.jmp

首先，使用非线性最小二乘将数据拟合至模型，以获取较佳参数值。

  2. 选择分析 > 建模 > 非线性。
  3. 高亮度显示速度 (y) 并单击 Y，响应按钮。
  4. 高亮度显示模型 (x) 并单击 X，预测公式按钮（"运行分析"），然后单击确定。
运行分析
  5. 单击“非线性”控制面板（"单击执行后的结果"）上的执行按钮。
单击执行后的结果
  6. 单击置信限按钮生成置信区间。
  7. 单击保存估计值按钮，以使 JMP 将已拟合参数置于化学动力学.jmp 中名为模型 (x) 的列公式之中。该公式如下所示：

现在创建非线性设计以便拟合模型的非线性参数。

  1. 选择试验设计 > 非线性。
  2. 通过高亮度显示带响应值的列来标识响应并单击确定。在本例中，使用速度 (y)。
选择响应列

请注意在化学动力学.jmp（"化学动力学.jmp"）中，浓度的数据范围为 0.417 至 6.25。因此，这些值将以上限值和下限值出现在“因子”控制面板中。

  3. 将范围更改为一个更广区间：从 0.3 到 7（"更改因子值"）。
更改因子值
  4. 通过将 Vmax 和 k 的分布同时更改为正态，来对参数的先验分布进行说明。
更改分布
  5. 回顾您在上面（"单击执行后的结果"）创建的分析报表并在“解”表中查找 Vmax 和 k 的置信上限和下限。将 Vmax 和 k 值更改为与这些界限对应的值，如"更改值" 中所示。
更改值

现在，您已经描述了这两个参数的不确定性的当前水平。

  6. 在文本框中输入所需试验次数并单击制作设计以预览设计（"选择试验次数"）。
选择试验次数
  7. 单击制表。这样将创建一个新的 JMP 设计表（"制表"），其中的行就是您定义的试验。创建的新表将避免更改样本数据表化学动力学.jmp。但是，在大多数情况下，您需通过单击扩充表来扩充原始表而不是制作一个新表。
制表

新的试验利用了允许浓度的更宽区间。这样将产生更精确的 k 和 Vmax 估计值。

创建无先验数据的非线性设计

此实例介绍了在您尚未收集数据但已具有未知参数的假定值时，如何创建设计。

要继续执行此实例，请打开安装 JMP 时安装的 Sample Data 文件夹。打开 Sample Data > Design Experiment> 初级化学反应动力学.jmp。

产量模型列中的公式将用来创建非线性设计，以便拟合模型的非线性参数。该公式如下所示：

此模型取自 Box 和 Draper (1987)。此公式产生于连续化学反应中中间产品的部分产量。它是一个时间与温度函数。

  1. 打开初级化学反应动力学.jmp，如上所述。
  2. 选择试验设计 > 非线性设计。
  3. 通过高亮度显示包含响应（预测）值的列来标识响应并单击确定（"选择响应列"）。在本例中，使用观测产量。
选择响应列
  4. 将两个因子的值更改为合理范围内的值。（这可能需要进行有根据的推测。）对于此例，请在反应温度中输入 520 和 540。使用 0.1 和 0.3 作为反应时间值。
  5. 保留每个参数的分布作为默认均匀，并将试验次数更改为 12（"更改试验次数"）。
更改试验次数
  6. 依次单击制作设计和制表。您的结果应与"设计表" 中的类似。
设计表

您现在已完成不带数据的设计。

（化学反应动力学.jmp

现在检查设计区。

  7. 选择图形 > 叠加图，创建叠加图。
  8. 高亮度显示反应温度并单击 Y 按钮，高亮度显示反应时间并单击 X 按钮（"创建叠加图"）。
  9. 单击确定。
创建叠加图

请注意，点不在设计区的角上。尤其是在温度值较低而时间值较高时（图形的右下角）没有点。

  10. 选择分析 > 建模 > 非线性。
  11. 高亮度显示观测产量并单击 Y，响应按钮。
  12. 高亮度显示产量模型并单击 X，预测公式按钮，然后单击确定。
  13. 单击“非线性”控制面板上的执行按钮。
  14. 现在从红色三角形菜单中选择刻画器 > 刻画器。

最大化意愿。在化学反应温度的绝对温度为 540 度且化学反应时间为 0.1126 分钟时，最大产量为 60.69%。

最大产量的时间和温度设置


创建非线性设计

要启动非线性设计，打开包含列的数据表，这些列的值由公式产生（有关公式详情，请参阅《JMP 用户指南》）。此公式必须具有参数。

然后，选择试验设计 > 非线性设计，或在“JMP 起始页”的试验设计页上单击非线性设计按钮。然后，执行以下步骤：

  • "标识具有公式的响应/列"
  • "设置因子和参数"
  • "选择试验次数"
  • "查看设计"
  • "制作或扩充表"

标识具有公式的响应/列

  1. 打开包含列的数据表，这些列的值由具有参数的公式产生。
  2. 选择试验设计 > 非线性设计。
  3. 如果数据表中包含有多个具有公式的列，JMP 会要求您标识包含非线性模型公式的列（"标识具有非线性公式的列的实例"）。高亮度显示列名并单击确定。
标识具有非线性公式的列的实例
  4. JMP 会要求您标识包含响应值的列并单击确定。此列不能包含任何缺失值。
选择响应列的实例

设置因子和参数

使用"设置因子和参数的实例" 以了解如何设置因子和参数的名称和值。

设置因子和参数的实例

选择试验次数

“设计生成”面板将显示执行试验所需的最少试验次数。在文本框中键入所需试验次数并单击制作设计。

选择试验次数

查看设计

创建设计表前，JMP 会让您预览设计。

预览设计实例

制作或扩充表

预览设计后，单击制表或扩充表。单击制表创建包括所有试验的新表。单击扩充表将新试验添加至现有表中。

非线性设计表的实例


田口设计

质量是二十世纪八十年代的口号，田口玄一则是质量意识发展的领袖。田口在质量控制领域的技术贡献之一是工业试验的新方法。田口法的目的是开发在任何自然变异（材料、操作员、供应商和环境变化）中都可以运行良好的产品。这就是稳健工程。

大多数田口法是传统的。他的正交表是二水平、三水平和混合水平部分析因设计。其方法的独特方面在于使用信号和噪声因子，内表和外表以及信噪比。

田口法的目的是查找控制因子设置，不管自然环境和制程变异性如何，它都可生成可接受响应。在每个试验中，田口设计法使用了两个名为内表和外表的设计。田口试验是这两个表的叉积。用于调整制程的控制因子构成了内表。与制程或环境变异性关联的噪声因子构成了外表。田口的信噪比是外表观测响应的函数。田口设计器支持田口法的所有此类功能。您可从内表和外表中进行选择，它使用了传统的田口正交表，比如 L4、L8 和 L16。

根据系统变量的信号和噪声因子来对其进行划分是稳健工程的关键部分。信号因子是系统控制输入。噪声因子是特别难于控制或代价昂贵的变量。

内表是信号因子中的设计，而外表是噪声因子中的设计。信噪比是计算整个外表的统计量。其公式取决于试验目的是否要最大化、最小化或匹配所关注的质量特征目标值。

田口试验为内表的每次试验重复了外表设计。数据分析中的响应变量不是原始响应或质量特征，而是信噪比。

JMP 中的田口设计器支持田口所指定的信号和噪声因子、内表和外表以及信噪比。

目录

田口设计法

田口设计实例

分析数据

创建田口设计

详述响应和添加因子

选择内表和外表设计

显示和修改设计

制表


田口设计法

田口法定义两种因子类型：控制因子和噪声因子。对控制因子构建的内部设计可查找最优值设置。对噪声因子的外部设计可查看响应如何在较宽的噪声条件范围中运作。试验可在内部和外部设计试验的所有组合中执行。一个性能统计量由对每次内部试验的外部试验计算得出。它将作为拟合内表设计试验的响应。下面的表列出了推荐的性能统计量。

目的 S/N 比公式

目标值最佳

越大越好（最大化）

越小越好（最小化）


田口设计实例

此实例是在 Baylock Manufacturing Corporation 进行并由 Byrne 和田口 (1986) 说明的试验。此试验的目标是找出预定控制因子设置，它可在最大化附着性（脱拉力）的同时最小化尼龙管的组装成本。

要继续执行此实例，请打开首次安装 JMP 时安装的 Sample Data 文件夹。打开设计试验 > Byrne Taguchi 数据.jmp。或亲自使用试验设计 > 田口设计表生成原始设计表。

此实例的信号与噪声因子将出现在下表中

因子名称 | 类型 | 水平 | 注释
干扰 | 控制 | 3 | 管道和连接器干扰
壁厚 | 控制 | 3 | 连接器的壁厚度
深度 | 控制 | 3 | 将管道插入至连接器的深度
粘度 | 控制 | 3 | 粘度百分比
时间 | 噪声 | 2 | 处理时间
温度 | 噪声 | 2 | 温度
湿度 | 噪声 | 2 | 相对湿度
。

要启动此实例，请执行以下操作：

  1. 选择试验设计 > 田口。
  2. 单击“田口设计”标题栏上的红色三角形图标，然后选择载入因子。
  3. 通过打开首次安装 JMP 时安装的 Sample Data 文件夹来打开因子表。打开 Design Experiment > Byrne Taguchi 因子.jmp。

因子面板将显示四个三水平控制（信号）因子和三个噪声因子，如"Byrne-Taguchi 实例的响应、信号和噪声因子" 中所示。

Byrne-Taguchi 实例的响应、信号和噪声因子
  4. 高亮度显示 L9-Taguchi 以给出内部设计的 L9 田口。
  5. 高亮度显示 L8 以给出八次试验的外表设计。
  6. 单击继续。

外部设计具有三个二水平因子。已生成八次试验的完全析因。但是，它只是用作标识最终 JMP 数据表八个一组的新列的指南（每个外部设计中的水平组合一个）。

  7. 单击制表来创建显示在"数据输入前的田口设计" 中的设计表。
数据输入前的田口设计

假设现在收集了拉脱粘着力的测量标准，并已将其输入到包含缺失数据的列中，如"填写田口设计表（Byrne Taguchi 数据.jmp）" 中所示。在缺失数据列名称的该试验的噪声因子水平（+ 或 -）前添加字母 Y。例如，Y--- 是取自设为低水平的三个噪声因子组的测量单位列。

  8. 要查看完成的试验和继续执行下面的实例，通过选择帮助（Macintosh 中为查看）> 样本数据目录 > Design Experiment > Byrne Taguchi 数据.jmp 打开如"填写田口设计表（Byrne Taguchi 数据.jmp）" 中所示的表。
填写田口设计表（Byrne Taguchi 数据.jmp）

名为 SN 比率 Y 的列是使用显示如下的公式计算所得的性能统计量。此时，它是“越大越好”(LTB) 公式，其为常用对数的平均平方倒数的 -10 倍。

当所有的单个 y 值很小时，此表达式则很大。

分析数据

准备分析 Byrne Taguchi 数据.jmp 中的数据。分析的目的是查找可以同时最大化均值和信噪比的因子设置。

  1. 单击模型脚本旁的红色三角形图标，然后选择如"拟合预测模型" 中所示的运行脚本。

此时出现的窗口将使用适合的效应进行自动设置。它包括四个信号因子的主效应。这两个响应指外表中的均值和信噪比。

拟合预测模型
  2. 单击运行模型。

预测刻画器是查找为此试验给出最高信噪比设置的一种快捷方式。

  3. 通过单击“响应均值 Y”标题栏上的红色三角形并选择因子刻画 > 刻画器打开预测刻画器。

刻画迹（"预测刻画器"）表明前三个因子的不同设置会增加 SN 比率 Y。

预测刻画器

  4. 要查找最优设置，请单击“预测刻画器”标题栏上的红色三角形并选择意愿函数。此操作可将轨迹行和函数设置列添加至刻画器。默认意愿函数设定为试验中所需的越大越好。有关预测刻画器的更多详情，请参阅《JMP 统计和图形指南》的“标准最小二乘：估计透视”章节。
  5. 再次单击“预测刻画器”标题栏上的红色三角形并选择最大化意愿以自动设置预测轨迹，从而根据意愿函数给出最佳结果。

在本例中，干扰和壁厚设置在 L1 至 L2（"Byrne Taguchi 数据的最佳因子设置"）间变化。深度设置在 L1 至 L3 间变化。粘度则无变化。这些新设置将信噪比从 24.0253 提高至 26.9075。

Byrne Taguchi 数据的最佳因子设置


创建田口设计

要启动田口设计，请选择试验设计 > 田口设计表，或单击“JMP 起始页”上“试验设计”页上的田口设计表按钮。然后，执行以下步骤：

  • "详述响应和添加因子"
  • "选择内表和外表设计"
  • "显示和修改设计"
  • "制表"

详述响应和添加因子

“响应”面板有一个单一默认响应。有关设置此响应详情的步骤将在"设置响应" 中进行详述。有关重要性权重和上限与下限的信息，请参阅"了解响应重要性权重"。

设置响应

有关设置因子的步骤将在"输入因子" 中进行详述。

输入因子

完成添加因子后，请单击继续。

选择内表和外表设计

JMP 将根据您的因子数要求您选择内表和外表设计。"使用八个因子来选择设计" 显示当您具有八个因子时您的选择。高亮度显示您要使用的设计并单击继续。

使用八个因子来选择设计

显示和修改设计

选择设计类型后，单击展开按钮（在 Windows/Linux 中为 [image] ，在 Macintosh 中为 [image] ）显示设计和修改选项以定制设计（"显示和修改选项"）。

显示和修改选项
  • 效应重叠 — 显示部分析因设计的混杂模式。有关效应重叠的详情，请参阅"效应混叠"。
  • 代码设计 — 显示每次试验中因子的上限值和下限值模式。有关代码设计的详情，请参阅"了解代码设计"和"更改代码设计"。

制表

单击制表后，将出现一个与显示在"田口设计表" 中的表类似的表。

田口设计表

在代码设计面板中，每行表示一次试验（"田口设计表"）。加号表示高水平，减号表示低水平。

有关编码和如何更改编码的详情，请参阅"了解代码设计"和"更改代码设计"。


扩充设计

最好将试验视为迭代过程。这样，您就可以掌握试验，以避免假定有一个成功的筛选试验优化了您的制程的误导。同时，避免因筛选设计所遗留的一些含糊不清的结果而失望。

扩充设计器可修改现有设计数据表，从而支持您的迭代过程。它将提供以下五种选择：

  • 制定重复设计次数
  • 添加中心点
  • 创建折叠设计
  • 同时添加轴点和中心点，从而将筛选设计变换为响应面设计
  • 使用项多于原始模型的模型将试验添加至设计。

本章节概述了扩充设计器。它还介绍了一个设计扩充的案例研究。

目录

化学反应实例：使用 D 最优扩充

分析扩充设计

创建扩充设计

重复设计

添加中心点

创建折叠设计

添加轴点

添加新的试验和模型项

特殊扩充设计命令

查看诊断报表

保存设计 (X) 矩阵

修改设计准则（D 或 I 最优性）

选择随机起始数

指定球形半径值

限制因子组合


化学反应实例：使用 D 最优扩充

此实例改编自 Meyer 等人 (1996)，阐述了如何使用 JMP 扩充设计器来解析筛选设计造成的含混不清。在这项研究中，一位化学工程师研究了一个化学制程中五个因子对百分比反应的效应。

开始时，打开安装 JMP 时安装的 Sample Data 文件夹。打开 Design Experiment > 化学反应-8 次试验.jmp。然后从试验设计菜单中选择扩充设计。

标识因子和响应并单击确定后，屏幕将出现如"化学反应实例的扩充设计对话框" 中显示的“扩充设计”对话框。

注：可以检查将新的试验分组到单独区组以将分区组因子添加至任何设计。但是，此实例的目的是估计所有二因子在 16 次试验中的交互作用。当模型中存在附加分区组因子时，不能执行此操作。

化学反应实例的扩充设计对话框

现在在“扩充设计”对话框中单击扩充以查看"初始扩充模型" 中的显示。这个模型是由“定制设计器”创建它时将其与数据表一起存储的模型结果。但是，扩充设计具有 16 次试验以估计所有的二因子交互作用。

初始扩充模型

要继续执行扩充的化学反应设计，请从如"使用所有二因子交互作用的扩充模型" 中所示的“交互作用”的弹出式菜单中选择二次。此操作可将所有的二因子交互作用添加至模型。指定模型所给出的“最小”运行试验次数为 16，如“设计生成”文本编辑框中所示。

使用所有二因子交互作用的扩充模型

单击制作设计时，JMP 将计算 D-最优扩充因子设置，这与显示在"D 最优扩充因子设置" 中的设计类似。

D 最优扩充因子设置

注：所得设计是初始随机数种子的函数。要在"D 最优扩充因子设置" 中重新生成精确因子设计表（或最近生成的设计），请从“扩充设计”标题栏上的弹出式菜单中选择设置随机种子。对话框显示了最近使用的随机数。单击确定可再次使用随机数，或单击取消可生成基于新随机数的设计。"指定随机数" 中的对话框显示了用来在"D 最优扩充因子设置" 中生成试验的随机数 (12834729)。

指定随机数

单击制表。

分析扩充设计

假设您已运行此试验并在数据表的“反应百分数”列中记录了结果。此试验的目的在于使用化学反应-8次试验.jmp，它位于 Sample Data 文件夹的 Design Experiment 文件夹。这些文件夹在安装 JMP 时已经安装。"完成的扩充试验（化学反应扩充数据.jmp）" 显示化学反应扩充数据.jmp 样本数据文件。

完成的扩充试验（化学反应扩充数据.jmp）

要启动分析，通过使用鼠标右键单击脚本名称并选择运行来运行随数据表一起保存为表性质的模型脚本。此表性质包括 JSL 命令，它显示所有作为效应的主效应和二因子交互作用的拟合模型对话框。将拟合特点从标准最小二乘更改为逐步，如"生成模型上逐步回归的模型拟合对话框" 中所示。

生成模型上逐步回归的模型拟合对话框

单击运行模型后，屏幕将出现逐步回归控制面板。单击所有主效应项的复选框。然后，从方向菜单中选择混合并确保进入的概率是 0.050，而剔除的概率是 0.100。您将看到如"初始逐步模型" 中所示的对话框。

初始逐步模型

单击执行以启动逐步回归并监视其继续操作，直到所有的项都输入至模型中，此模型在“逐步回归控制”面板中符合进入的概率和剔除的概率准则。"完成的逐步模型" 显示此实例分析的结果。清注意，在催化剂*温度、搅拌速度*温度和温度*浓度交互作用已输入至模型后，送入速度将脱离此模型。

完成的逐步模型

完成“逐步”后，单击“逐步”控制面板上的构建模型以生成此缩减模型，如"新的预测模型对话框" 中所示。现在可以拟合缩减模型以进行附加诊断工作、进行预测及查找最优因子设置。

新的预测模型对话框

"方差和失拟合检测的预测模型分析" 中的“方差分析”和“失拟合检验”表示高度显著的且未出现“失拟合”迹象的回归模型。

方差和失拟合检测的预测模型分析

"预测模型估计图" 中的“尺度无关估计”表显示，催化剂具有最大主效应。但是，显著的二因子交互作用与主效应的大小顺序相同。这就是在章节"筛选设计"所介绍的初始筛选试验有含糊结果的原因。

预测模型估计图

试验的意图是最大化百分比反应。"反应的最大百分比" 中的预测刻画图显示最大值将出现在催化剂、搅拌速度和温度的高水平以及“浓度”的低水平。当您将每个因子的预测迹拖至极值设置时，反应百分数估计将从 65.1 增加至 81.8。

反应的最大百分比

要进行汇总，请比较上一章节的 16 次试验分析与化学反应数据分析：

  • "筛选设计"，分析仅具有 8 次试验的筛选设计会产生五个主效应和两个有混合的交互作用效应。这些因子均不显著，虽然催化剂因子足够大，可以收集数据进行更多次的试验。
  • "完全析因设计"，五个二水平反应因子，32 次试验的完全析因设计是首个专门针对逐步回归的。此方法标识了三个主效应（催化剂、温度和浓度）和两个交互作用（温度*催化剂、浓度*温度）作为显著效应。
  • 通过使用 8 次试验的 D 最优扩充产生 8 次附加试验，逐步分析会返回与 32 次试验相同的结果。重要的是产生了相同的信息，试验次数却仅为一半。因此，对试验设计使用迭代法可以节约时间和金钱。


创建扩充设计

扩充设计器可修改现有的设计数据表。它提供以下五种选择：

  • 重复 — 重复设计指定次数。请参阅"重复设计"。
  • 添加中心点 — 添加中心点。请参阅"添加中心点"。
  • 折叠 — 创建折叠设计。请参阅"创建折叠设计"。
  • 添加轴 — 同时添加轴点和中心点，从而将筛选设计变换为响应面设计。请参阅"添加轴点"。
  • 扩充 — 使用项多于原始模型的模型将试验添加至设计（扩充）。请参阅"添加新的试验和模型项"。

重复设计

重复可直接检查误差方差为常数的假设。在制程或测量变异性大的情况下，它也可以减低回归系数的变异性。

要重复设计指定次数，请执行以下操作：

  1. 打开包含您要扩充的设计的数据表。此实例使用化学反应-8 次试验.jmp，它在 Sample Data 文件夹的 Design Experiment 文件夹。这些文件夹在安装 JMP 时已经安装。
  2. 选择试验设计 > 扩充设计。
  3. 通过高亮度显示列名（"标识因子"）并单击确定来标识您要在扩充设计中使用的因子。
标识因子
  4. 通过高亮度显示列名并单击确定（"确定响应"）来标识您要在扩充设计中使用的响应。
确定响应
  5. 如果您要用分区组因子标识原始试验和所得扩充试验，请选定将新的试验分组到单独区组（"选择扩充类型"）旁的框。
  6. 单击重复按钮。
选择扩充类型
  7. 输入您要 JMP 执行每次试验的次数并单击确定。例如，输入 2 将指定每次试验在所得设计中出现两次。这与重复（"输入试验次数"）一次是相同的。
输入试验次数
  8. 查看设计，如"用两次重复扩充的化学反应数据设计" 中所示。
用两次重复扩充的化学反应数据设计
  9. 如有需要，可通过单击相关标题栏左方的展开图标，查看预测方差刻画和预测方差曲面图（"预测刻画器和曲面图"）。
预测刻画器和曲面图
  10. 单击制表。此时将出现设计表（"重复设计"）。
重复设计

添加中心点

添加中心点对于在因子中心区域检查弯曲和减少预测误差十分有用。

中心点通常是允许纯误差的独立估计的重复点，例如，它可用于失拟合检验。

要添加中心点，请执行以下操作：

  1. 打开包含您要扩充的设计的数据表。此实例使用了化学反应-8次试验.jmp，它在 Sample Data 文件夹的 Design Experiment 文件夹内。这些文件夹在安装 JMP 时已经安装。
  2. 选择试验设计 > 扩充设计。
  3. 通过高亮度显示列名（"标识因子"）并单击确定来标识您要在扩充设计中使用的因子。
  4. 通过高亮度显示列名并单击确定（"确定响应"）来标识您要在扩充设计中使用的响应。
  5. 如果您要用分区组因子标识原始试验和所得扩充试验，请选定将新的试验分组到单独区组（"选择扩充类型"）旁的框。
  6. 单击添加中心点按钮并添加两个中心点。
  7. 输入中心点个数并单击确定。
  8. 单击制表。
  9. 下表显示了附加到设计末尾的两个中心点。
添加了两个中心点的设计

创建折叠设计

折叠设计可去除二因子交互作用和主效应的混杂。这对于作为饱和或近饱和的部分析因或 Plackett-Burman 设计的后续操作尤其有用。

要创建折叠设计，请执行以下操作：

  1. 打开包含您要扩充的设计的数据表。此实例使用化学反应-8 次试验.jmp，它在 Sample Data 文件夹的 Design Experiment 文件夹。这些文件夹在安装 JMP 时已经安装。
  2. 选择试验设计 > 扩充设计。
  3. 通过高亮度显示列名（"标识因子"）并单击确定来标识您要在扩充设计中使用的因子。
  4. 通过高亮度显示列名并单击确定（"确定响应"）来标识您要在扩充设计中使用的响应。
  5. 要用分区组因子标识原始试验和所得扩充试验，请选定将新的试验分组到单独区组（"选择扩充类型"）旁的框。
  6. 单击折叠按钮。
  7. 选择要折叠的因子。如果未选择因子，将默认为折叠所有的设计因子。如果选择了要折叠的因子的子集，剩余因子为原始试验的重复。
    "所有因子的折叠设计列表" 中的实例折叠了所有的五个因子并包括了一个分区组因子。
  8. 单击制表。产生的设计数据表将原始试验集和新的（折叠）试验分别列为区组 1 和区组 2。

如果选择了要折叠的因子的子集，剩余因子为原始试验的重复。

请注意：添加中心点或重复设计也会在 JMP 设计表中生成附加的区组列。

所有因子的折叠设计列表

添加轴点

可以同时添加轴点和中心点，从而将筛选设计变换为响应面设计。

请执行以下操作：

  1. 打开包含您要扩充的设计的数据表。此实例使用化学反应-8 次试验.jmp，它在 Sample Data 文件夹的 Design Experiment 文件夹。这些文件夹在安装 JMP 时已经安装。
  2. 选择试验设计 > 扩充设计。
  3. 通过高亮度显示列名（"标识因子"）并单击确定来标识您要在扩充设计中使用的因子。
  4. 通过高亮度显示列名并单击确定（"确定响应"）来标识您要在扩充设计中使用的响应。
  5. 如果您要用分区组因子标识原始试验和所得扩充试验，请选定将新的试验分组到单独区组（"选择扩充类型"）旁的框。
  6. 单击添加轴。
  7. 依次输入因子单位刻度在 -1 到 +1 之间的轴值和您所需的中心点个数。当单击确定，扩充设计将包括指定的中心点个数并在原始设计中为每个变量构造两个轴点。
输入轴值
  8. 单击制表。此时将出现设计表。"用两个中心点和十个轴点扩充的设计" 显示了一个用五个变量的两个中心点和两个轴点扩充的表。
用两个中心点和十个轴点扩充的设计

添加新的试验和模型项

通过扩充设计器，您可以使用项多于原始模型的模型来添加试验。将试验添加至设计的功能强大。通过将线性模型更改为完全二次模型并添加必要的试验次数，可以达到响应面分析法的目的。例如，假设您在开始时使用了一个二因子、二水平、试验四次的设计。如果将二次项添加至模型和五个新点，JMP 将生成 3 乘 3 的完全析因作为最优扩充设计。

D 最优扩充是功能强大的序贯设计工具。使用此功能，您可以将项添加至原始模型并找出有关此扩展模型的新的最优检验试验。您可以将这两组试验运行分组到单独的区组，它将优化与第一组相关的第二组的组区。

要将新的试验和模型项添加至原始模型，请执行以下操作：

  1. 打开包含您要扩充的设计的数据表。此实例使用了化学反应扩充数据.jmp，它在 Sample Data 文件夹的 Design Experiment 文件夹。这些文件夹在安装 JMP 时已经安装。
  2. 选择试验设计 > 扩充设计。
  3. 通过高亮度显示列名并单击确定来标识您要在扩充设计中使用的因子。
  4. 通过高亮度显示列名并单击确定来标识您要在扩充设计中使用的响应。
  5. 如果您要用分区组因子来标识原始试验和所得扩充试验，请选定将新的试验分组到单独区组旁的框。
  6. 单击扩充按钮。在“因子设计”面板中将显示原始试验（"查看现有设计"）次数。
查看现有设计
  7. 输入您需设计包含的总试验次数。此次数是原始试验次数加上添加试验次数。
  8. 单击制作设计按钮。
    新的试验（"24 次总试验"）次数将显示在“设计”面板中。
24 次总试验
  9. 如果需要，请查看预测方差刻画和预测方差曲面。
  10. 单击制表按钮。扩充设计表与附加试验一同显示在（"选择扩充类型"）。
具有新试验的扩充设计表


特殊扩充设计命令

选择试验设计 > 扩充设计后，屏幕将显示"单击红色三角形图标以展开命令" 中的窗口。单击“扩充设计”标题栏上的红色三角形图标可展开命令列表。大部分此类命令是用于保存和载入变量信息的，并且可在所有设计中获得；有关详情，请参阅"特殊定制设计命令"。以下章节将介绍专用于扩充设计的菜单中的命令。

单击红色三角形图标以展开命令

查看诊断报表

要在扩充设计中显示与 D、G 和 A 效率相关的表，请单击“扩充设计”标题栏上的红色三角形图标并选择显示诊断，然后单击制表按钮。

保存设计 (X) 矩阵

要在 JMP 设计数据表中创建脚本并将其保存为表性质，单击“扩充设计”标题栏中（"单击红色三角形图标以展开命令"）的红色三角形图标并选择保存 X 矩阵。脚本将被保存为名为设计矩阵的表性质。在运行脚本时，JMP 会创建一个名为 X 的整体矩阵，并在记录中显示它的行数。如果记录不可见，选择视图 > 记录。

修改设计准则（D 或 I 最优性）

要修改设计准则，请单击“扩充设计”标题栏上的红色三角形图标（"单击红色三角形图标以展开命令"）并选择最优性准则，然后选择制作 D 最优设计或制作 I 最优设计。所有设计类型的建议默认准则是 D 最优，除非您使用“模型”面板中的 RSM 按钮添加了效应，从而使模型成为了二次模型。

选择随机起始数

要改写默认的随机起始数，请单击“扩充设计”标题栏（"单击红色三角形图标以展开命令"）中的红色三角形图标并选择起始数。在选择此命令时，屏幕将显示如"更改起始数" 所示的窗口以及一个编辑框，您可以在其中为要建立的设计输入随机起始数。您输入的数字将改写默认的起始数，而默认的起始数因设计而异。

更改起始数

有关起始数的附加信息，请参阅"为什么要更改起始数？"。

指定球形半径值

扩充设计可被约束为超球面。要编辑编码因子 (-1, 1) 单位中的设计的球形半径，请单击“扩充设计”标题栏（"单击红色三角形图标以展开命令"）中的红色三角形图标并选择球形半径。输入相应的值并单击确定。

或者，使用 JSL，在构建定制设计前提交以下命令：

 试验设计球形半径 = 1.0；

在此语句中，可用任何正数替换 1.0。

限制因子组合

除对连续因子的线性不等式约束和将设计约束为超球面外，您可以定义一般的因子约束。如果未定义线性不等式约束，您就可以拒绝任何的分类因子水平组合。

有关如何执行此操作的信息，请参阅"考虑因子水平约束"。


预期功效与样本大小

使用试验设计 > 样本大小与功效命令可以解答“我需要执行多少次试验？”这样的问题。重要的数据包括样本大小、功效以及效应大小。这些值取决于效应的假设检验的显著性水平 alpha 和响应中噪声的标准差。您可以提供三个值中的一个或两个。如果您只提供其中一个值，结果是出现其它两个值的图。如果您提供两个值，JMP 将计算出第三个值。该功能适用于单样本、双样本和 k 样本的情形。

在执行预期分析时，使用样本大小与功效命令有助于解答“在给定建议样本大小、群内方差估计值和 alpha 水平的情况下，是否能检测到预期的群组差异？”这样的问题。在此类分析中，您必须向 JMP 给出数据表中组均值和样本大小的估计以及组内标准 (σ) 的估计。

样本大小与功效命令可以确定合理地使试验或样本更可能产生显著结果的样本大小（假定真效应大小至少为某个确定的大小）。它要求您输入三个数据中的两个、要检测的差异、样本大小以及功效，并在以下情况下计算出第三个值：

  • 单样本均值与假设值之间的差
  • 两个样本均值之间的差
  • k 个样本均值间的差异
  • 方差与假设值之间的差
  • 单样本比例与假设值之间的差
  • 两个样本比例之间的差
  • Poisson 分布的样本中每单位计数与假设值之间的差。

计算过程假定每组的单位数均相等。您可以将此平台应用到更一般的试验设计中（如果它们是平衡的，并且指定了参数数量调整）。

目录

预期功效分析

单样本和双样本均值

单样本均值

单样本的功效与样本大小动画

双样本均值

k 样本均值

单样本方差

单样本和双样本比例

每单位计数

Sigma 质量水平


预期功效分析

以下五个值在有关均值的统计检验中的关系极为重要：

  • Alpha Alpha 是显著性水平，防止把零效果宣称为显著的情况出现比例超过 alpha。
  • 误差标准差 误差标准差是围绕均值的随机变异。
  • 样本大小 样本大小是试验中涉及的试验单位（试验或样本）数。
  • 功效 功效是宣称显著性结果的概率。
  • 效应大小 效应大小是均值之间或均值与假设值之间的差异程度。

在进行单样本比较、双样本比较或 k 样本均值比较的试验情况下，JMP 中的“样本大小与功效”命令有助于预先估计所需样本大小、预期功效或预期效应大小。

选择试验设计 > 样本大小与功效，将出现如"样本大小与功效选项" 所示的试验情况下的按钮选项。以下部分将分别对这些选项进行说明，并介绍输入估计参数值和所需计算的方法。

样本大小与功效选项


单样本和双样本均值

单击初始“样本大小”选择列表（"样本大小与功效选项"）中的单样本均值或双样本均值后，"单个均值（左）和两个均值（右）的初始“功效与样本大小”对话框" 中的“功效与样本大小”对话框将会出现，并要求您输入预期试验值。要输入的值取决于您的初始选择。例如，以双样本情况为例。

单个均值（左）和两个均值（右）的初始“功效与样本大小”对话框

初始“功效与样本大小”对话框中的双样本均值选择始终要求填入 Alpha 值和误差标准差 (Error Std Dev)，如图所示，以及其它三个值（要检测的差异、样本大小和功效）中的一个或两个。然后，功效与样本大小平台将计算出缺失项。如果存在两个未指定字段，功效与样本大小平台将构建一幅图形表明这两个值的关系：

  • 如果给出特定效应大小，功效将作为样本大小的函数
  • 如果给出样本大小，功效将作为效应大小的函数
  • 如果给出功效，效应大小将作为样本大小的函数。

“功效与样本大小”对话框要求您根据设计的第一选择输入值：

  • Alpha Alpha 是显著性水平，通常为 0.05。这意味着主观可接受（如果组间真实差异为零）错误地宣称有显著差异情况地比例为 5% (alpha)。
  • 误差标准差 误差标准差是真实残差误差。尽管不知道真实误差，功效计算也会是概率中的一次演算，如果指定了真值，概率将计算出可能发生的情况。
  • 额外参数 额外参数仅可用于多因子设计。一般情况下保留此字段为零。在多因子平衡设计中，除了拟合上述情况中的均值以外，还可以指定具有额外参数（可在此指定）的其它因子。例如，在具有所有三个二因子交互作用的三因子二水平设计中，额外参数的数目是五个 — 其中两个参数用于额外主效应，另三个参数用于交互作用。实际上，您在此处输入的值并不十分重要，除非该试验范围中误差的自由度极少。
  • 要检测的差异 要检测的差异是最小的可检测到的差异（您想要的能够从统计角度表现为显著最小差异）。对于单样本问题，这是假设值与真实值之间的差。
  • 样本大小 样本大小是观测值的总数（试验、试验单位或样本）。样本大小不是每组的数目，而是所有组的总数。计算所得的样本大小数可以具有分数值，您需将其调整为实际单位。通常，您可以通过将估计样本大小增加到能够按组数平均分配的最小数来实现此目的。
  • 功效 功效是获取统计量的概率，该统计量显示统计显著性。功效越大越好，但样本大小中的成本就越高。当效应大小被指定为零时，功效等于 alpha。如果您可以负担，则应尽力获取至少为 0.90 或 0.95 的功效。如果试验需要付出相当大的精力，请制定计划以使试验设计在存在较大效应的情况下有能力将其检测出来。
  • 继续 根据输入的值进行估计。
  • 后退 后退至上一个对话框。
  • 动画脚本 使用动画脚本按钮可运行一个 JSL 脚本，该脚本将运行出一个显示功效或样本大小的交互作用图。有关此动画脚本的说明，请参阅"单样本的功效与样本大小动画"部分。

单样本均值

假设存在某个单样本，我们的目标是在误差标准差为 0.9 时检测出大小为 2 的差，如"单样本实例" 中左侧的对话框所示。要在样本大小为 10 的情况下计算功效，请将对话框中的功效字段留空，然后单击继续。"单样本实例" 中右侧的对话框显示：经计算得出功效为 0.99998，四舍五入为 1。

单样本实例

要查看功效与样本大小的关系图，请同时将样本大小与功效字段留空，然后单击继续。

双击水平轴可获得所需的任意尺度。"单样本实例图" 中左侧的图形显示了样本大小的范围，其功效在 0.2 至 0.95 之间变化。通过更改水平轴的范围可以更改曲线的范围。例如，如"单样本实例图" 中右侧的图形所示，将水平轴的尺度调整为 1 至 8，将得到一条外观更为典型的功效曲线。

单样本实例图

如果仅指定了样本大小（"给定样本大小的功效关于要检测的差异的图"）而将要检测的差异与功效留空，此时将出现功效关于差的图。

给定样本大小的功效关于要检测的差异的图

单样本的功效与样本大小动画

使用单个均值的“功效与样本大小”对话框中的动画脚本按钮可以显示一个交互作用图，该图说明了样本大小对于功效产生变化能力的这一效应。在"说明功效的动画脚本实例" 中所示的实例中，样本大小为 10，Alpha 为 0.05，要检测的差异设定为 0.4。动画开始时显示一条以零均值（表示估计均值与真实均值）定位的正态曲线，以及另一条以 0.4 均值（要检测的差异）定位的正态曲线。提交“第二类”误差（存在差异时未检测到差异）的概率通常在书面表示为 β（此图中的蓝色阴影部分）。

曲线上的抓手可将其拖动，以显示它们的位置对功效的影响。您还可以单击图形下方显示的样本大小和 alpha 的值，以对其进行更改。

说明功效的动画脚本实例

双样本均值

两个样本的对话框十分相似；要检测的差异是两个均值之间的差。假设误差标准差为 0.9（如之前一样），所需的可检测差为 1，样本大小为 16。

将功效字段留空，然后单击继续可查看功效计算结果 0.5433，如"给定差异的功效关于检测样本大小的图" 中左侧的对话框所示。此值远远小于单样本中的值，因为每个均值仅是样本大小的一半。比较是在两个随机样本之间进行，而非某一个样本。

要提高功效，需要一个更大的样本。要找出实际大小，请将样本大小和功效字段都留空，然后检查所得图形，如"给定差异的功效关于检测样本大小的图" 中右侧所示。十字准线工具估计：要获得 0.9 的功效，需要一个大小约为 35 的样本。

给定差异的功效关于检测样本大小的图


k 样本均值

k 样本均值的情况可以检测多达十种的均值。在下一个实例中，假设均值的四个水平预计约为 10 至 13，而误差标准差为 0.9。输入的样本大小为 16 时，则功效计算结果为 0.95，如"k 均值的预期功效和功效对样本大小图" 中左侧的对话框所示。

如果将样本大小和功效都留空，功效与样本大小的计算将得出如"k 均值的预期功效和功效对样本大小图" 中右侧所示的功效曲线。这就确定了大小为 16 的样本是可以接受的。

请注意，均值中的差为 2.236，这是与总均值的差的平方的总和开平方计算而得。在本例中，它是 (-1.5)2+ (-0.5)2+(0.5)2+(1.5)2 的平方根，即 5 的平方根。

k 均值的预期功效和功效对样本大小图


单样本方差

“功效与样本大小”对话框（"样本大小与功效选项"）中的单样本方差选项确定可检测到方差变化的样本大小。此选项通常用于计算出足够大的样本，以确保接受错误假设 (β) 的风险很小。请在对话框中指定基线方差、alpha 水平以及您要检测的变化方向。要指明变化方向，请从监视变化菜单中选择较大或较小。计算结果随即会显示真实方差较其假设值更大还是更小，输入为基线方差。例如，一组硅晶片的电阻系数测量值的方差据称为 100 欧姆-厘米，而买家在单块晶片的方差高于 55 欧姆-厘米时不愿接受发货。

本章中的其它实例均采用美国标准技术研究院 (NIST) 的在线手册的工程实例。您可以通过以下地址访问 NIST 手册中的实例：http://www.itl.nist.gov/div898/handbook。

如同前面的对话框一样，您输入两个项，第三个项将由“功效与样本大小”计算得出。

假设您要对值为 100 的基线方差检测到增加 55，其中 alpha 为 0.05，功效为 0.99。请输入如"比较单方向单样本方差的“样本大小与功效”对话框" 中所示的这些项。单击继续后，计算所得的结果显示您需要输入的样本大小为 170。

如果您要检测出较小方差的变化，请在要检测的差异框中输入负数。

注：记得要在基线方差（而不是标准差）框中输入方差。

比较单方向单样本方差的“样本大小与功效”对话框


单样本和双样本比例

检验比例的功效与样本大小的对话框和计算与检验样本均值的对话框十分相似。当您输入了基线比例并指定了单侧检验或双侧检验时，对话框则不同。比例的样本分布实际上是二项分布，但确定样本大小和检验比例的计算使用正态近似值，如对话框中所示（"单样本和双样本比例的初始“功效与样本大小”对话框"）。

单样本和双样本比例的初始“功效与样本大小”对话框

检验比例在生产线中十分有用，其中的缺陷比例是制程控制监控的一部分。例如，假定某位生产线管理人员要对高于基线 10％ 的缺陷部件的变化情况进行检测。当前生产线运作的缺陷基线约为 10％。除非情况严重到超出 20％ 的缺陷率（超出缺陷基线水平 10％ 的 10％），否则管理员不会停止生产流程。该流程将使用单侧检验进行监控，条件为：alpha 为 5%，不能检测到量值变化的风险（功效为 90%）为 10％。

"将单个比例和“基线与样本大小”图进行比较的对话框" 显示了检测观测比例与基线比例之间的给定差的“样本大小与功效”对话框中的项目，计算所得的样本大小约为 77。要查看"将单个比例和“基线与样本大小”图进行比较的对话框" 中右侧的图形，请将要检测的差异和样本大小字段留空。使用抓手工具（手形工具）移动 x 轴，并显示指定的差异范围和样本大小。

将单个比例和“基线与样本大小”图进行比较的对话框


每单位计数

“每单位计数”选项用于计算 Poisson 分布计数的样本大小，特别是在对每个单位测出一个以上的缺陷时。单位可能是区域，计数可能是分数或大数值。

尽管在给定大小的区域中，缺陷数目常被假定为呈 Poisson 分布，但区域和计数仍被假定为大得足以支持正态近似。

关注的问题包括：

  • 缺陷密度是否处于规定限制之内？
  • 缺陷密度是否大于或小于规定限制？

输入 alpha 和每单位的基线计数。然后输入另两个字段以查看第三个值的计算结果。该检验用于单侧（单尾）变化。根据每单位的基线计数（每单位的缺陷数）输入要检测的差异。计算所得的样本大小将以这些单位表示。

例如，假设晶片生产流程以每块晶片出现 4 个缺陷作为目标，而您想验证新流程是否符合这个目标。

  1. 选择试验设计 > 样本大小与功效。
  2. 单击每单位计数按钮。
  3. 如果新流程能够达到目标，输入 0.1 的 alpha 值作为检验失败的几率。
  4. 输入 0.9 的功效值，它是变化大于 2（每块晶片出现 6 个缺陷）的几率。在这种情况下，有时会称 alpha 为生产者风险而称 beta 为消费者风险。
  5. 单击继续以查看计算所得的样本大小为 8.128（"每单位计数实例的对话框"）。

如果少于 48 个缺陷（在 8 块晶片的样本中，每块晶片出现 6 个缺陷），该流程则符合目标。

每单位计数实例的对话框


Sigma 质量水平

通过选择试验设计 > 样本大小与功效访问“Sigma 质量水平”功能，输入以下三个量中的任意两个才可使用：

  • 缺陷数
  • 机会数
  • Sigma 质量水平

如果单击继续，sigma 质量计算器将使用公式 Sigma 质量水平 = NormalQuantile (1 - 缺陷数/机会) + 1.5 来计算缺失量。

例如，使用“样本大小与功效”功能计算 1,000,000 次机会中出现 50 个缺陷的 Sigma 质量水平：

  1. 选择试验设计 > 样本大小与功效。
  2. 单击 Sigma 质量水平按钮。
  3. 输入 50 作为缺陷数，1,000,000 作为机会数，如"Sigma 质量水平实例 1" 中左侧的窗口所示。
  4. 单击继续。得出结果是 Sigma 质量水平为 5.3，如"Sigma 质量水平实例 1" 中右侧的窗口所示。
Sigma 质量水平实例 1

如果您想知道，对于 1,000,000 次机会多少缺陷可将 Sigma 质量水平减少为“6 sigma”，请输入 6 作为 Sigma 质量水平并将缺陷数留空（"Sigma 质量水平实例 2" 中左侧的窗口）。计算结果（"Sigma 质量水平实例 2" 中右侧的窗口）显示缺陷数不能大于约 3.4。

Sigma 质量水平实例 2


JMP 脚本语言语法参考

上一页 | 下一页

JMP JMP 脚本语言语法参考

此语法参考包含以下部分：

语言元素和编程基础

运算符及其等效函数

内部函数（计算器函数）

实用程序

实用程序

对话框构造函数

首选项命令

用于系统首选项的参数

SAS IOM 命令

数据表

数据表运算符

数据表对象消息

用于元数据的数据表消息

行命令

用于选择行的数据表消息

用于重新排列表的数据表消息

数据表列消息

行状态函数

按列预计算的统计量

按行预计算的统计量

平台

分析平台脚本

可发送到平台和数据表窗口的消息

显示

显示树下标

显示框构造函数

用于所有显示框的消息

用于 Outline Box 的消息

用于图形框内的函数

用于 Frame Box 的消息

用于 Table Box 的消息

用于 Text Box 的消息

用于 Axis Box 的消息

用于 Number Col Box 的消息

用于 String Col Box 的消息

用于 Matrix Box 的消息

用于 Nom Axis Box 的消息

矩阵

构造和处理矩阵

矩阵的下标

数值运算

求矩阵

生产

DataFeed 消息

Open Database 命令

Schedule 命令

JMP 脚本语言语法参考


语法参考

运算符、函数和消息汇总

本附录简要介绍了所有的 JMP 函数、运算符和通用对象消息。（有关平台消息，请参阅“平台”章节中的“特定平台脚本”）。表按章节顺序排列，各个表中的项目按字母顺序排列，而不是按章节中的主题顺序。有关任何 JSL 运算符、函数、消息或命令的详情，请参阅节标题指定的章节或使用“索引”。


语言元素和编程基础

下面是 JSL 中的运算符、计算器函数及通用编程函数。

运算符及其等效函数
 // 注释

行结尾处的注释

 ...脚本 /* 注释 */ 脚本...

可出现在脚本行中间的注释。

 a+b
 Add(a,b)

将 a 和 b 相加。

 a+=b
 AddTo(a,b)

将 b 与 a 相加，然后将结果赋给 a。

 a&b
 And(a,b)

逻辑“与”。如果两个条件均为真，则返回 1；如果任意一个缺失，则返回缺失值；否则，返回 0。

  : name
 dt : name
 As Column(dt, name)

作用域运算符。将 name 强制计算为表（通过可选数据表引用参数 dt 指定）中的数据表列，而不能解析为全局变量。

  :: name
 As Global(name)

作用域运算符。将 name 强制计算为全局变量，而不能解析为数据表列。

 a=b
 Assign(a,b)

将 b 的值赋给 a。

 a/b
 Divide(a,b)
 Divide(x)

将 a 除以 b。如果 a 和 b 都是矩阵，则执行矩阵除法。如果只有一个参数，将返回参数的倒数。

 a/=b
 DivideTo(a,b)

用 b 除 a，然后将结果赋给 a。

 a==b
 Equal(a,b)

如果所有参数的计算结果均为同一值，则返回 1；否则，返回 0。

 Factorial(n)

返回从 1 至 n 的所有数字的乘积。

 a>b; Greater(a,b)
 a>b>c; Greater(a,b,c)

如果 a 严格大于 b（并且 b 严格大于 c），则返回 1；否则，返回 0。

 a>=b; Greater or Equal(a,b)
 a>=b>=c; Greater or Equal(a,b,c)

如果 a 大于或等于 b（并且 b 大于或等于 c），则返回 1；否则，返回 0。

 a<b; Less(a,b)
 a<b<c; Less(a,b,c)

如果 a 严格小于 b（并且 b 严格小于 c），则返回 1；否则，返回 0。

 a<=b; Less or Equal(a,b)
 a<=b<=c; Less or Equal(a,b,c)

如果 a 小于或等于 b（并且 b 小于或等于 c），则返回 1；否则，返回 0。

 a<=b<c
 LessEqual Less(a,b,c)

范围检查，含下界不含上界。

 a<b<=c
 Less LessEqual(a,b,c)

范围检查，含上界不含下界。

 -a
 Minus(a)

求 a 的相反数。

 a*b
 Multiply(a,b)

将 a 与 b 相乘。如果 a 和 b 都是矩阵，则执行矩阵乘法。

 a*=b
 MultiplyTo(a,b)

用 b 乘 a，然后将结果赋给 a。

 !a
 Not(a)

逻辑“非”。将非 0 值映射为 0；将 0 值映射为 1；缺失值仍然保留为缺失值。

 a!=b
 Not Equal(a,b)

如果所有参数的计算结果不为同一值，则返回 1；否则，返回 0。

 a|b
 Or(a,b)

逻辑“或”。如果任意一个或两个条件均为真，则返回 1；如果任意一个缺失，则返回缺失值；否则，返回 0。

 a- -
 Post Decrement(a)

将 a 减 1。

 a++
 Post Increment(a)

将指定位置的 a 加上 1。例如，如果 a = 4，则 a++ 会将 a 更改为 5。

 a^b
 Power(a,b)
 Power (x)

a 自乘指数幂 b。如果只有一个参数，则将幂假定为 2，因此计算 x 2。

 a-b
 Subtract(a,b)

从 a 中减去 b。

 a- =b
 SubtractTo(a,b)

从 a 中减去 b，然后将结果赋给 a。
内部函数（计算器函数）
 Abbrev Date(date)

返回所提供的 date 的字符串表示，格式类似于 "Sun, Feb 29, 2004"。

 Abs(n)

返回与 n 值大小相同的正数。

 a||b
 Concat(a,b)

将第二个字符串附加在第一个字符串后面，并返回整个字符串。

 a :& b
 AndMZ(a,b)

逻辑 And 与版本 3.x 中的方式相同，即将缺失值视为 0；打开 v3 数据表时将自动使用它。

 ArcCosH(expr)

返回反双曲余弦。

 ArcCosine(expr)

返回反余弦。

 ArcSine(expr)
 ArSin

返回反正弦。

 ArcSinH(expr)

返回反双曲正弦。

 ArcTangent(expr)
 ATan(expr)

返回反正切。

 ArcTanH(expr)

返回反双曲正切。

 Arg(Expr, i )

返回表达式中的第 i 个参数，或者 Empty()。ArgExpr() 已过时：请使用 Arg()。

 Arrhenius(n)
 Arrhenius Inv(n)

返回 Arrhenius 或逆 Arrhenius 变换。

 As Date

格式化数字或表达式，以便它们以日期的形式显示在文本窗口中。

 AsName("字符串")

以字符串的形式计算参数，然后将其更改为名称。

 Beta Density(x, alpha, beta)

返回具有形状参数 alpha 和 beta 的 beta 分布在分位数等于 x 时的密度函数。

 Beta Distribution(x, alpha, beta)

返回具有形状参数 alpha 和 beta 的 beta 分布在分位数等于 x 时的累积分布函数。

 Beta Quantile(p, alpha, beta)

返回具有形状参数 alpha 和 beta 的 beta 分布的第 p 个分位数。

 Beta(m, n)

返回 beta 函数。

 Binomial Distribution(p, n, k)

返回试验次数为 n、每次试验的成功概率为 p 并且成功次数为 k 的二项分布的 CDF。

 Binomial Probability(p, n, k)

返回在概率为 p 的情况下在 n 次试验中获得 k 次成功的概率。

 CallDLL(exportedFcn,
 signatureOfFcn, argumentToFcn)

调用 DLL 中的函数。exportedFcn 是指 proc 地址。signatureOfFcn 是表 1 “signatureOfFct 值”（第 82 页）中的某个值。argumentToFcn 是指要传递给函数的参数。

 Ceiling(n)

返回大于或等于其参数 n 的最小整数。

 Char(Expr(expr)); Char(name)
 char(number, width, decimal)

将表达式或数值转换成字符串。

 Chi Square Density (x, df, <center>)

返回自由度为 df、可选非中心参数为 center 且卡方等于 x 时的卡方密度。

 Chi Square Distribution(x, df)
 Chi Square Distribution(x,df,center)

返回自由度为 df、中心为 center 的卡方在分位数等于 x 时的累积分布函数。

 Chi Square Quantile (x, df)
 Chi Square Quantile (x, df, center)

返回自由度为 df、中心为 center 的卡方分布的第 p 个分位数。

 ChiSquare LogDensity(x, df, <nc>)

返回卡方分布在分位数等于 x 时的密度函数值的对数。

 ChiSquare LogDistribution(x,
df, <nc>)

返回卡方分布在分位数等于 x 时的分布函数值的对数。

 ChiSquare LogCDistribution(x,
df, <nc>)

 返回 1 与卡方分布在分位数等于 x 时的分布函数值的对数（值）的差。

 ChiSquare Noncentrality (x,
df, prob)

 计算非中心值，其中：
prob=ChiSquare Distribution (x, df, nc)

 Choose(a, result1, result2, ...)

如果 a 等于 1，则将返回 result1；如果 a 等于 2，则将返回 result2，依此类推。

 Col Shuffle( )

每次计算时均随机正移一些值。无需参数，但是需要使用圆括号。

 Contains("whole", "part")

返回 part 第一个实例在 whole 内的数值位置，其中包含一个或多个字符（如果存在）。

 CosH(expr)

返回双曲余弦。

 Cosine(expr)

返回余弦。

 Count(from, to, steps, times)

以 steps 指定的数字逐行创建始于 from 值、止于 to 值的值。

 Date DMY(day, month, year)

返回指定日期，表示为自 1904 年 1 月 1 日午夜起经过的秒数。

 Date MDY(month, day, year)

返回指定日期，表示为自 1904 年 1 月 1 日午夜起经过的秒数。

 Day Of Week(date)

返回所提供的 date 中星期几的整数表示。

 Day Of Year(date)

返回所提供的 date 中日（年形式）的整数表示。

 Day(date)

返回所提供的 date 中日期的整数表示。

 Derivative(expr, {name, ...})

返回 expr 相对于 name 的导数。name 可以单个变量，或包含多个变量的列表。

 Desirability(yVector,
desireVector,argument)

拟合一个函数来遍历三个点，这三个点适用于定义一组响应变量 (y) 的意愿。其中，yVector 和 desireVector 是包含三个值的矩阵，这三个值对应于定义 Desirability 函数的三个点。实际函数取决于意愿值是否为越大越好、越小越好、匹配目标，还是违反目标。

 e( )

返回常数 e，为 2.7182818284590451...。

 Empty()

只用于返回缺失值；在计算器中用于制作空框。

 Eval(x)

计算 x，然后计算 x 的结果（非引用）。

 EvalExpr(x)

返回一个包含所计算的 x 内的所有表达式的表达式。

 EvalInsert
 EvalInsertInto

允许以下列方式进行多次替代。有关此函数用法的实例，请参阅“进行多次替代 ”。

 resultString = EvalInsert(string with embedded expressions,startDelimiter,endDelimiter)
 EvalInsertInto(string l-value with embedded expressions,startDelimiter,endDelimiter)

 EvalList(list)

返回由 list 内已计算的表达式构成的列表。

 Exp(v)

返回指定常数的 e 的指数值。

 Expr(x)

返回未计算的参数（引用表达式）。

 ExprAsPicture(expr)

将 expr 转换为图片，显示方式与公式计算器一样。

 expr1;expr2;expr3
 Glue(expr1, expr2, ...)

按顺序计算参数语句，并且返回最后一个参数的结果。

 ExtractExpr(expr, pattern)

查找与 pattern 匹配的 expr。

 F Density(x, dfnum,
dfden, <center>)

返回分子自由度和分母自由度分别指定为 dfnum 和 dfden、可选非中心参数为 center 的 F 分布在 x 处的 F 密度。

 F Distribution(x, dfnum, dfden)
 F Distribution(x, dfnum, dfden,
center)

返回分子自由度和分母自由度分别指定为 dfnum 和 dfden、非中心参数为 center 的 F 分布在分位数等于 x 时的累积分布函数。

 F Power(alpha, dfh, dfm, d, n)

根据与 F 检验或 t 检验有关的给定情况计算功效。

 F Quantile(p, dfnum, dfden)
 F Quantile(p, dfnum, dfden, center)

返回分子自由度和分母自由度分别指定为 dfnum 和 dfden、非中心参数为 center 的 F 分布的第 p 个分位数。

 F Sample Size(alpha, dfh, dfm, d, power)

根据与 F 检验或 t 检验有关的给定情况计算样本大小。

 F LogDensity(x, dfn, dfd, <nc>)

返回 F 分布在分位数等于 x 时的密度函数值的对数。

 F LogDistribution(x, dfn, dfd, <nc>)

返回 F 分布在分位数等于 x 时的分布函数值的对数。

 F LogCDistribution(x, dfn, dfd, <nc>)

返回 1 与 F 分布在分位数等于 x 时的正态分布函数值的对数（值）的差。

 F Noncentrality((x, ndf, ddf, prob)

计算非中心值，其中：
prob=F Distribution (x, ndf, ddf, nc)

 First(expr, expr, ...)

执行所有 expr 语句，但仅返回第一个的结果。

 Floor(n)

返回小于或等于其参数的最大整数。

 fn=Function({args}, script);
fn(values)

存储将 args 用作局部变量的 body 脚本。调用时，返回提供了指定 args 的 script 结果。

 For(init, while, increment, body)

只要 while 条件为真，它就反复执行 body 中的语句。Init 和 increment 可用于控制迭代。

 Format(date, "格式")

使用您在第二个参数中指定的格式返回值。

Format Date() 是个别名。

 Gamma Density(x)
 Gamma Density(x, shape, scale,
 threshold)

返回给定 shape、scale 和 threshold 的 gamma 分布在分位数等于 x 时的密度函数值。

 Gamma Distribution(x)
 Gamma Distribution(x, shape,
scale, threshold)

返回给定 shape、scale 和 threshold 的 gamma 分布在分位数等于 x 时的累积分布函数。

 Gamma LogCDistribution(x, alpha)

与 Log (1 - GammaDistribution(x, alpha)) 一样，只是范围更大。

 Gamma LogDensity (x, alpha)

与 Log(GammaDensity(x, alpha)) 一样，只是范围更大。

 Gamma LogDistribution(x, alpha)

与 Log(GammaDistribution(x, alpha)) 一样，只是范围更大。

 Gamma Quantile(p)
 Gamma Quantile(p, shape,
scale, threshold,)

返回给定 shape、scale 和 threshold 参数的 gamma 分布的第 p 个分位数。

 Gamma(t)
 Gamma(t, x)

返回 t 或 t 中每行（如果 t 是列）的 Gamma 函数。

Gamma(t, x) 积分与 Gamma(t) 相同，只是积分界限为 x，而不是无穷。Gamma(t, x) 等效于 GammaDistribution(t, x)*Gamma(t)。请注意，参数的顺序不同。

 Head(exprArg)

返回表达式运算符，但不返回其参数。HeadExpr() 已过时：请使用 Head()。

 HeadName(exprArg)

返回一个包含运算符名称的字符串。HeadNameExpr() 已过时：请使用 HeadName()。

 Hex("文本")

以文本形式返回字符的十六进制代码。

 Hex To Char (string)

将十六进制数字转换为等效的字符。例如，Hex To Char (30) 的计算结果为“0”。

 Hypergeometric
 Distribution(N, K, n, x)
 Hypergeometric
 Distribution(N, K, n, x, r)

返回总体大小为 N、相关类别中的项数为 K、样本大小为 n、相关计数为 x 且可选机会比为 r 的超几何分布在 x 处的累积分布函数。

 Hypergeometric
 Probability(N, K, n, x)
 Hypergeometric
 Probability(N, K, n, x, r)

返回服从超几何分布的随机变量等于 x 的概率，其中总体大小为 N、相关类别中的项数为 K、样本大小为 n、相关计数为 x 且可选机会比为 r。

 I Gamma(t, shape)

返回 t 的不完全 gamma 函数。

 If(condition, result, condition, ...,
 elseResult)

在 condition 计算结果为 True 时返回 result。否则返回 condition 计算结果为 True 时的下一个 result。如果前面的条件都不为真，则使用 elseResult。

 IfMZ(condition, result,
 condition, ..., elseResult)

逻辑 If 与版本 3.x 中的方式相同，即将缺失值视为 0；打开 v3 数据表时将自动使用它。

 In Minutes(n); In Hours(n);
 In Days(n); In Weeks(n);
 In Years(n)

这些运算符将返回每 n 分钟、小时、天、周或年的秒数。

 Include("路径名")

打开路径名标识的脚本文件，解析其中的脚本，并执行该脚本。

 InFormat(string, "格式")
 Parse Date(string, "格式")

解析给定格式的 string，然后返回使用自 1904 年 1 月 1 日午夜起经过的秒数表示的日期/时间值。

 Insert Into(list |expr, item, position)
 Insert Into(list |expr, item)

与 insert 类似，但需在适当的位置进行。List 或 expression 必须是 L 值。

 Insert(list |expr, item, position)
 Insert(list |expr, item)

将新项插到 list 或 expr 的给定位置。如果未给定位置，则将它插到末尾。

 Interpolate(x, x1, y1, x2, y2)
 Interpolate(x, xmat, ymat)

在以下两点 (x1, y1) 和 (x2, y2) 之间或在矩阵 xmat 和 ymat 中以线性方式插入与给定的 x 值对应的 y 值。这些点按升序排列。

 InvertExpr(expr, name)

试图围绕 name 展开 expr。

 Is Empty(global)
 Is Empty(dt)
 Is Empty(col)

如果 global 变量、数据表或数据列没有值（未初始化），则返回 1；否则，返回 0。

 Is Expr(x)

如果计算的参数是表达式，则返回 1；否则，返回 0。

 Is List(x)

如果计算的参数是列表，则返回 1；否则，返回 0。

 Is Matrix(x)

如果计算的参数是矩阵，则返回 1；否则，返回 0。

 IsMissing(expr)

如果表达式生成缺失值，则返回 1；否则，返回 0。

 Is Name(x)

如果计算的参数是仅含名称的表达式，则返回 1；否则，返回 0。

 Is Number(x)

如果计算的参数是数字或缺失数值，则返回 1；否则，返回 0。

 Is Scriptable(x)

如果计算的参数是可脚本化对象，则返回 1；否则，返回 0。

 Is String(x)

如果计算的参数是字符串，则返回 1；否则，返回 0。

 Item(n, "文本")
 Item(n, "文本", "分隔符")

Item 与 Word 相同，但是 Item 将每个分隔符字符均视作一个单独的分隔符，而 Word 则将几个相邻的分隔符视作一个分隔符。

 Length("文本")

计算其参数的长度（字符数）。

 LGamma(t)

返回 t 的 log gamma 函数，也就是 gamma 的自然对数。

 List(a, b, c)
 {a, b, c}

根据一组项构造列表。

 LnZ(n)

返回 n 的自然（以 e 为底）对数或以 base 为底的对数；如果 n 为零，返回 0。用于导数内部计算。

 LoadDLL(path)

载入在 path 中指定的 DLL。

 text=Load Text File(“路径”)

打开按路径存储在变量 text 中的文本文件。

 Local({name=value, ...}, script)

将 name 解析为局部表达式。

 Log(n); Log(n, base); Ln(n)

返回 n 的自然（以 e 为底）对数或以 base 为底的对数。

 Log10(n)

返回 n 的常用对数（以 10 为底）。

 Log1P(n)

与 Log(1 + x) 一样，只是在 x 非常小时它更精确。

 Long Date(date)

返回所提供的 date 的字符串表示，格式类似于 "Sunday, February 29, 2004"。

 Lowercase("文本")

将其参数中的大写字符转换为等价的小写字符。

 Main Menu("字符串", <"字符串">)

执行 JMP 菜单中的字符串命令。可选的第二个参数用于指定要将该命令发送到的窗口的名称。

 Match(a, value1, result1,
 value2, result2, ...)

如果 a 等于 value1，则将返回 result1；如果 a 等于 value2，则将执行 result2，依此类推。

 MatchMZ(a, value1, result1,
 value2, result2, ...)

与版本 3.x 中的方式相同，即将缺失值视为 0；打开 v3 数据表时将自动使用它。

 MDYHMS(date)

返回所提供的 date 的字符串表示，格式类似于 "2/29/04 00:02:20"。

 Modulo(number, divisor)
 Mod(number, divisor)

返回 number 除以 divisor 后的余数。

 Month(date)

返回所提供的 date 中月份的整数表示。

 Munger("文本", offset, find/length)
 Munger("文本", offset, find, replace)

通过插入或删除字符，根据文本生成新字符串。

 NameExpr(x)

返回 x 中未计算的表达式，而非 x 的计算结果。

 NArg(exprArg)

返回表达式运算符中的参数个数。NArgExpr() 已过时：请使用 NArg()。

 NChooseK(n,k)

此函数将返回从 n 个元素中每次取出 k 个元素的组合数（“n 选 k”）。

 N Items(list)
 a=NItems(list)

返回指定 list 中的元素数。可赋给变量。

 Neg Binomial Distribution(p, n, k)

返回试验次数为 n、每次试验的成功概率为 p 并且成功次数为 k 的负二项分布的 cdf。

 Neg Binomial Probability(p, n, k)

返回服从负二项分布的随机变量等于 k 的概率，其中 n 代表试验次数，p 代表每次试验的成功概率。

 Normal Density(x)
 Normal Density(x, mean, stddev)

返回具有 mean 和 stddev 的正态分布在分位数等于 x 时的密度函数值。

 Normal Distribution(x)
 NormalDistribution(x,mean,stddev)

返回具有 mean 和 stddev 的正态分布在分位数等于 x 时的累积分布函数。

 Normal Quantile(p)
 Normal Quantile(p, mean, stddev)
 Probit(p, mean, stddev)

返回具有 mean 和 stddev 的正态分布的第 p 个分位数。

 Normal LogDensity(x)

返回正态分布在分位数等于 x 时的密度函数值的对数。

 Normal LogDistribution(x)

返回正态分布在分位数等于 x 时的分布函数值的对数。

 Normal LogCDistribution(x)

返回 1 与正态分布在分位数等于 x 时的分布函数值的对数（值）的差。

 NTable()

返回打开的数据表的个数。

 Num("字符串")

将字符串转换成数字。

 NumDeriv(expr)

返回 expr 对表达式中第一个参数的一阶数值导数。

 NumDeriv2(expr)

返回 expr 对表达式中第一个参数的二阶数值导数。

 a :| b
 OrMZ(a,b)

逻辑 Or 与版本 3.x 中的方式相同，即将缺失值视为 0；打开 v3 数据表时将自动使用它。

 Parse("字符串")

将字符串转换成 JSL 表达式。

 Parse XML(string,
On Element(“tagname”,
Start Tag(expr), End Tag(expr)))

使用指定 XML 标记上的 On Element 表达式解析 XML 表达式。

 Pi( )

返回常数 π，为 3.1415926535897931...

 Poisson Distribution(lambda, k)

返回具有均值 lambda 的 Poisson 分布在 x 处的累积分布函数。

 Poisson Probability(lambda, k)

返回均值为 lambda 且服从 Poisson 分布的随机变量等于 k 的概率。

 Product(i=initialValue, limitValue, body)

将所有 i 值的 body 结果相乘，最终返回单个积。

 Quantile(p, arguments)
参数的分位数，其中 p 是介于 0 和 1 之间的值，参数为数字、数字列表或矩阵。
 Random Beta (alpha, beta)

生成服从 Beta (alpha, beta) 分布的（伪）随机数。

 Random Binomial(n, p)

返回在试验次数为 n 且相关事件出现的概率为 p 时二项分布中的随机数。

 Random Cauchy(alpha, beta)

返回给定 alpha 和 beta 的 Cauchy 分布。

 Random Exp(lambda)

生成参数 lambda（默认值为 1）的单个参数指数分布。

 Random Gamma(lambda, <scale>)

提供指定 lambda 和可选 scale 的 gamma 分布。

 Random Geometric()

返回当某个特定事件在任意一次试验中出现的概率为 p 时几何分布中的随机数。

 Random Index(n, k)

返回介于 1 和 n 之间的随机整数（没有重复项）的 k X 1 矩阵。

 Random Integer(n)
 Random Integer(k, n)

返回介于 1 和 n 之间或 k 和 n 之间的一个随机整数。

 Random Negative Binomial(r, p)

生成当成功概率为 p 时 r 次成功的负二项分布。

 Random Normal()

生成近似呈正态分布并且均值为 0、方差为 1 的随机数。

 Random Poisson (lambda)

生成指定 lambda 的 Poisson 变量。

 Random Reset(seed)

使用 seed 重新启动随机数序列。

 Random Seed()

设定种子随机数生成器函数 Random Seeded Normal 和 Random Seeded Uniform 的种子。

 Random Seeded Normal

均匀生成介于 0 和 1 之间的随机数，其中将 Random Seed 用作种子值。

 Random Seeded Uniform

均匀生成介于 0 和 1 之间的随机数，其中将 Random Seed 用作种子值。

 Random Triangular(midpoint)

使用您指定的 midpoint 生成 0 和 1 之间的数字的三角分布。

 Random Uniform()
 Random Uniform(x)
 Random Uniform(high, low)

均匀生成介于 0 和 1 之间的随机数。

Random Uniform(x) 生成 0 和 x 之间的数字。

Random Uniform (high,low) 生成 low 和 high 之间的数字。

 Recurse(function)

对定义 function 进行递归调用。

 Remove From(list |expr, position)
 Remove From(list |expr)
 Remove From(list |expr, position, n)

删除指定位置的项。此函数将返回删除的项，但您不一定要为它们赋值。第一个参数必须是 L 值。

 Remove(list |expr)
 Remove(list |expr, position)
 Remove(list |expr, {positions})
 Remove(list |expr, position, n)

复制 list 或 expr，同时删除指定 position 处的项。如果未指定 position，则此函数将从末尾开始删除项。

 Repeat(source, a)
 Repeat(matrix, a, b)

返回将 source 连接 a 次之后的副本，或者返回由 a 行的重复和 b 列的重复构成的矩阵。

 Resample Freq()
 ResampleFreq(fraction)
 ResampleFreq(n)
 Resample(fraction or n,
 FreqColumn)

Resample Freq() 可生成 100% 的再取样。ResampleFreq(fraction) 可生成 fraction*nrow 频数样本。ResampleFreq(n) 可生成 n 频数样本。Resample(fraction 或 n,FreqColumn) 可生成与现有频数列有关的再取样

 Reverse Into(list |expr)

反转指定位置的 list 或 expr 中的元素或项目。

 Reverse(list |expr)

反转 list 或 expr 中的元素或项目。

 Root(n, r)

返回 n 的 r 次方根，其中 r 的默认值为 2（平方根）。

 Round(n, places)

将 n 四舍五入为 places 指定的小数位数。

 Save Text File(“路径”, text)

将 JSL 变量 text 存储在路径指定的文件中。

 Sequence(from,
to,stepsize,
repeatTimes)

生成数据表中各行数字的算术序列，其中指定了 from、to 和 stepsize。repeatTimes 为可选

 Set Clipboard(string)

计算 string 参数的值、查找字符结果，并将该字符串置于剪贴板中。

 Shift Into(list |expr)
 Shift Into(list |expr, n)

移动指定位置的项。

 Shift(list |expr)
 Shift(list |expr, n)

将一项或 n 项从 list 或 expr 的前面移到后面。如果 n 为负，则从后面移到前面。

 Short Date(date)

返回所提供的 date 的字符串表示（mm/dd/yy 格式），例如 "2/29/04" 代表下一个闰日。

 Simplify Expr(expr(expression))
Simplify Expr(nameExpr(global))

以代数方式简化表达式。

 Sine(expr)
 Sin(expr)

返回正弦。

 SinH(expr)

返回双曲正弦。

 Sort List Into(list |expr)

对指定位置的 list 或 expr 中的元素或项目进行排序。

 Sort List(list |expr)

对 list 或 expr 中的元素或项目进行排序。

 SplineCoef(x, y, lambda)

以 knots||a||b||c||d 形式返回一个包含五列的矩阵，其中 knot 是 x 中的唯一值。

 SplineEval(x, coef)

使用 coef 矩阵计算样条预测值，其中 coef 的形式与 SplineCoef() 一样。

 SplineSmooth(x, y, lambda)

返回样条拟合中生成的平滑预测值。

 Sqrt(n)

返回 n 的平方根。

 Squash(expr) [版本 5 中已过时]

函数 1/ [1 + exp(expr)] 的有效计算。

 Squish(expr)

等效于 Squash(-expr) 或 1/[1 + exp(-expr)]

 Step(x, x1, y1, x2, y2, ...)

查找阶梯函数拟合中指定 x 对应的 y。这些点按升序排列。

 Students t Density(x, df)
 t Density(x, df, center)

返回自由度为 df 和 center 的 t 分布在分位数等于 x 时的密度函数值。

 Students t Distribution(x, df)
 t Distribution(x, df, center)

返回参数为 df 和 center 的 t 分布在分位数等于 x 时的累积分布函数。

 Students t Quantile(p, df)
 t Quantile(p, df, center)

返回参数为 df 和 center 的 t 分布的第 p 个分位数。

 SubstituteInto(list |expr,
 Expr(pattern),
 Expr(replace't), ...)

在指定位置替代。

 Substitute(list |expr,
 Expr(pattern),
 Expr(replacement), ...)

查找与 list 或 expr 中的模式匹配的所有项，然后使用 replacement 替代它们。每个模式都必须具有一个名称。

 list[i]; a[b,c]; Subscript(a,b,c)

列表下标可从 list 中提取第 i 项。

 Substr("文本", start, length)

提取文本中以 start 且长度为 length 的部分的字符。

 Summation(init, limitvalue, body)

Summation 可以将所有 i 值的 body 语句结果累加起来，最终返回单个值。

 t LogDensity(x, df, <nc>)

返回 t 分布在分位数等于 x 时的密度函数值的对数。

 t LogDistribution(x, df, <nc>)

返回 t 分布在分位数等于 x 时的分布函数值的对数。

 t LogCDistribution(x, df, <nc>)

返回 1 与 t 分布在分位数等于 x 时的正态分布函数值的对数（值）的差。

 T Noncentrality (x, df, prob)

计算非中心值，其中：
prob=T Distribution (x, df, nc)

 Tangent(expr)
 Tan(expr)

返回参数（以弧度为单位）的正切。

 TanH(expr)

返回其参数的双曲正切。

 Throw()
 Throw("文本")

返回 Throw。如果包括文本，引发会将文本存储在 exception_msg 全局变量中。如果文本以 ! 开头，引发会生成一个有关捕获到异常的位置的报错信息。

 Tick Seconds()

测量脚本运行时间，倒计时到 1/60 秒。

 Time Of Day(date)

返回所提供的 date/time 中时间（日形式）的整数表示。

 Today()

返回当前日期和时间，表示为自 1904 年 1 月 1 日午夜起经过的秒数。

 Tolerance Limit(1-alpha, p, n)

用于将 1-alpha 置信区间构造为均值的常数比例 p，其中样本大小为 n。

 Trim("文本")

删除其参数末尾的空白字符，生成新字符串。

 Try(expr1, expr2)

计算 expr1。如果返回 Throw、停止或没有返回任何内容，则计算 expr2 并返回结果。

 Tukey HSD Quantile(p, alpha,
 nGroups, dfe)

返回 Tukey HSD 分布的第 p 个分位数，其中具有 alpha 显著性水平、nGroups 和误差 df dfe。

 Type(expr)

计算 expr 并返回其类型。

 UnloadDLL()

卸载此前载入的 DLL。

 Uppercase("文本")

将其参数中的小写字符转换为等价的大写字符。

 VMax(matrix)

返回包含 matrix 各列最大值的行向量。

 VMean(matrix)

返回包含 matrix 各列均值的行向量。

 VMin(matrix)

返回包含 matrix 各列最小值的行向量。

 VSum(matrix)

返回包含 matrix 各列之和的行向量。

 VStd(matrix)

返回包含 matrix 各列标准差的行向量。

 Week Of Year(date)

返回 date 中一年中第几周的整数表示。

 Weibull Density(x, shape)
 Weibull Density(x, shape,
 scale,threshold)

返回给定参数的 Weibull 分布在分位数等于 x 时的密度函数值。

 Weibull Distribution(x, shape)
 Weibull Distribution(x, shape,
 scale, threshold)

返回给定参数的 Weibull 分布在分位数等于 x 时的累积分布函数。

 Weibull Quantile(p, shape)
 Weibull Quantile(p, shape,
 scale, threshold)

返回给定参数的 Weibull 分布的第 p 个分位数。

 While(expr,body)

重复检验 expr 条件并执行 body，直至 expr 不再为真。

 Wild()

与 ExtractExpr() 一起用于表达式匹配。

 WildList()

与 ExtractExpr() 一起用于表达式匹配。

 Word(n, "文本")
 Word(n, "文本", "分隔符")

根据指定分隔符从字符串中提取第 n 个语句。

 Words("文本")
 Words("文本","分隔符")

根据指定分隔符从文本中提取语句。

 value=xmlAttr(“属性名称”)

在计算 Parse XML 命令的过程中提取 xml 参数的字符串值。

 value = xmlText()

在计算 Parse XML 命令的过程中提取 XML 标签的主体字符串文本。

 Year(date)

返回 date 中年份的整数表示。

 Zero Or Missing(expr)

如果 expr 生成缺失值或 0，则返回 1；否则，返回 0。


实用程序

以下是 JSL 实用程序函数。

实用程序
 Beep()

产生警告声。

 Caption({x, y}, text, [Delayed(n),
 Spoken(bool)] )

在指定位置使用指定文本弹出一个小窗口。

 Clear Globals()

清除定义的所有全局符号。

 Convert File Path (path,
 <absolute|relative>,
 <POSIX|windows>,
 <base(dir_path)>)

根据附加参数转换文件路径。对于前面的 <可选> 参数，其默认值包括 absolute、POSIX 以及默认目录的基路径。输入路径可以采用 Windows 或 POSIX 样式。

 Exit()

退出 JMP。

 Files In Directory(path)

返回目录 path 中的文件名列表。

 Get Current Directory()

返回“打开文件”操作的当前目录。

 Get Default Directory()

返回默认目录，用于解析相对路径。

 Get File Search Path()

包含当前目录列表，搜索打开的文件。

 Get Path Variable(name)

返回变量中存储的路径。

 Host Is(Windows);
 Host Is(Mac);
 Host Is(Linux);

如果当前主机环境与参数匹配，则返回 True (1)；否则，返回 False (0)。

 JMP Version()

以字符串形式返回 JMP 版本（JMP V6 或更高版本中可用）。

 Lock Globals(name1, name2, ...)

锁定全局变量，防止更改。

 mail("host.id", "主题", "消息", '
 attachment');

（仅适用于 Windows）使用指定 主题和消息文本将电子邮件发送到 host.id。发送可选 attachment 参数指定的附件。

 Pick Directory(<“提示字符串”>)

提示用户使用“打开”对话框输入目录，并以字符串形式返回目录路径。

 Pick File()

提示用户在“打开”对话框中选择文件。

 Print(expr, expr, ...)

将指定 expr 的值输出到日志。

 Quit()

退出 JMP。

 Set Current Directory()

设定“打开文件”操作的当前目录。

 Set Default Directory()

设定默认目录，用于解析相对路径。

 Set File Search Path ({path or
 list of paths})

设定当前目录列表，搜索打开的文件。“.”表示当前目录。

 Set Path Variable(name)

设定变量中存储的路径。

 Show Commands()

列出可脚本化对象和运算符。参数包括 All、Scriptables、Scriptable Objects、DisplayBoxes 和 Translations。

 Show Globals()

显示所有定义的全局符号及其值。

 Show Properties()

显示可脚本化对象的性质。

 Show(expr, expr, ...)

将每个 expr 的名称和值都输出到日志。

 Speak(text)
 Speak(text, Wait(bool))

调用系统语音功能，大声朗读文本。如果打开了 Wait，将暂停脚本执行，直至完成朗读。

 StatusMsg("消息")

将消息字符串写到状态栏。

 Unlock Globals(name1,
 name2, ...)

释放 Lock Globals 命令的锁定。

 Wait(n)

暂停 n 秒，然后才继续执行脚本。

 Watch(global, global, ...)

在窗口中显示全局变量的名称和值。

 Web(string, <JMP Window>)

在默认系统 Web 浏览器中打开 string 中存储的 URL。在 Microsoft Windows 中，可根据需要添加 JMP 窗口作为第二个参数，在 JMP 浏览器中打开 HTML。

 Write("文本")

将文本输出到日志，无需使用引号。
对话框构造函数
 Column Dialog(ColList("rolename",
Contents)

绘制一个用于列角色赋值的对话框。ColList 将使用 rolename 按钮创建一个选择目标。内容必须是以逗号分隔的 ColList 语句，或常用 Dialog 函数中的其它项目。在 ColList 中，可以根据需要使用 MaxCol(n) 或 MinCol(n) 指定最小或最大列数，或使用 Datatype(type) 指定列的必需数据类型。type 选项包括 Numeric、Character 或 Rowstate。

 Dialog(contents)

绘制包含指定内容的对话框。要设定对话框的标题，请将 Title() 用作对话框的第一个项目，如 Title("选择选项")。
首选项命令
 Preferences(arguments)

设定首选项。

 Platform
 Preferences( platform(prefs), ...)

设定平台的首选项。

 Show Preferences(All)
 Show Preferences(platform)
 Show Preferences()

显示当前首选项。
用于系统首选项的参数
 Analysis Destination(window)

指定路由新分析的位置。

 Background Color(color)

设定窗口的背景颜色。

 Calculator Boxing(boolean)

打开外框，显示表达式的层次结构。

 DataTable Title on Output(boolean)

使用数据表名称设定报表标题。

 Date Title on Output(boolean)

使用当前日期设定报表标题。

 Excel Has Labels(boolean)

打开时，强制 JMP 将数据的第一行解释为列标签。

 Excel Selection(boolean)

打开时，提示用户应从 Excel 工作簿导入哪个非空 Excel 工作表。

 Foreground Color(color)

设定窗口的前景颜色。

 Graph Background Color(color)

设定图形框中背景区域的颜色。

 Graph Marker Size(size)

用于绘制标记的默认大小。

 Heading Font(font, size, style)

报表中表列题头的字体选项。

 Initial JMP Starter Window(boolean)

指定启动时是否显示“JMP 起始页”窗口。

 Initial Splash Window(boolean)

允许显示或抑制初始启动画面屏幕。

 Monospaced Font(font, size, style)

用于等宽字体文本的字体选项。

 Outline Connecting Lines(boolean)

在水平相同的外框节点的标题之间绘制线条。

 Report Table Style(style)

指定报表中列的边框。选项包括 Plain、Bordered 和 Embossed。

 Show Explanations(boolean)

一些分析具有解释输出的可选文本。

 Show Menu Tips(boolean)

打开或关闭菜单提示。

 Show Status Bar(boolean)

打开或关闭状态栏的显示。

 Small Font(font, size, style)

用于小型文本的字体选项。

 Text Font((font, size, style)

报表中一般文本的字体选项。

 Thin Postscript Lines(boolean)

仅适用于 Macintosh。指定绘制到 Postscript 打印机的线宽应窄于其它线宽。

 Title Font(font, size, style)

用于标题的字体选项。参数包括字体名称（如 Times）、点大小和样式（Bold、Plain、Underline、Italic）。

 Window Close Options(action)

指定关闭窗口时执行的日志记录操作。
SAS IOM 命令
语法 解释
 SASConnect("serverName",
portID);

提示输入用户名和密码，然后启动与 SAS 会话的连接。

 SAS Disconnect();

断开与 SAS 会话的连接。

 SAS Submit("SAS 代码");

将 SAS 语句提交到 SAS 会话。

 SAS Is Connected();

如果 JMP 当前连接到 SAS 会话，则返回 1；否则，返回 0。

 SAS Submit File("路径")

将指定文件提交到 SAS 会话。

 result = SASGetOutput();

从 SAS 会话的输出窗口中获取结果。结果都是以一个字符串表示。

 result = SASGetLog();

从 SAS 会话的日志窗口中获取结果。结果都是以一个字符串表示。

 SAS Get File(source,dest);

将文件从服务器路径传送到自己的路径。

 SAS Send File(source,dest);

将文件从自己的路径传送到服务器路径。

 result = SAS Get File Refs();

返回一个包含两个列表的列表。第一个列表向服务器会话打开了 fileRef。第二个列表具有与每个 fileRef 关联的路径。

 result = SAS Get File Names();

返回 SAS 会话服务器上该 fileref 中的文件名列表。

 result = SAS Get File Names In
 Path(path)

返回 SAS 会话服务器上该目录路径中的文件名列表。

 result = SAS Load Text File("路径");

这会将该文本置于单字符变量中。如果这是 JSL 文件，则可以使用 eval(parse(result)); 计算它

 result = SAS Get LibRefs();

从 SAS 会话返回 libref。

 SAS Assign
LibRefs("libName","路径",
<"引擎 ">,
<"engineOptions">);

在 SAS 会话中进行 libref 赋值。<引擎> 和 <engineOptions> 可选。

 SAS DeAssign LibRefs("libName");

在 SAS 会话中撤消对 libname 的 libref 赋值。

 result = SAS(name);
 SAS({list of names});

将特殊字符和空格更改为下划线，从而将 JMP 变量名称转换为 SAS 变量名称，并进行各种其它变换，以生成有效的 SAS 名称。

 result = SAS Open For Var
 Names(path);

只打开一个 SAS 数据集，获取其变量的名称，并以字符串列表形式返回这些名称。


数据表

以下是用于处理数据表的 JSL 字。

数据表运算符
 Close(dt); Close(dt, "路径 ")
 Close(dt, NoSave)

关闭数据表。

 Column("名称 ")
 Column(dt, "名称 "); Column(n)

返回列引用。

 Column Name(n)

返回第 n 列的名称，作为表达式（不是作为字符串）。

 Current Data Table()
 Current Data Table(dt2)
 Current Data Table(obj ref)

返回当前（最顶部）的数据表。指定参数时，将当前数据表设定为现有数据表引用或对象引用的数据表。

 jref=Current Journal()

在当前日志顶部返回显示框引用。

 Data Table[n]
 Data Table("名称 ")

全局变量中第 n 个打开的数据表或具有指定名称的表的引用。

 Dif(col, n)

返回当前行中的列值以及前面 n 行的值之间的差。

 For Each Row(script)

在数据表的每一行中重复 script。

 Get Column Names(arguments)

以列表形式返回数据表中的列名。arguments 限制了检索的名称，如下所示：

Numeric、Ordinal、Rowstate、Continuous、Ordinal 和 Nominal 只获取指定类型的列。可以指定多个。String 将返回字符串列表，而不是列引用列表。

 Get Selected Columns

返回选定列列表。

 Lag(col, n)

为每一行返回前面 n 行的列值。

 NCol(dt)
 NCol(matrix)

返回数据表中的列数，由 dt 或 matrix 指定。

 New Table("名称 ")

使用指定的名称新建数据表。

 NRow(dt)
 NRow(matrix)
 NRows(dt)
 NRows(matrix)

返回数据表中的行数，由 dt 或 matrix 指定。

 Open("路径"), [Strip Quotes(bool),
 End of Line(choice), End of
 Field(choice), Labels(bool)])

打开路径指定的数据表。

 Row()
 Row()=n

返回或设定当前行号。不需要参数。[从版本 3 开始替代 i。]

 dt<<Run Script(“名称”)

找到表性质名称并将其作为 JSL 脚本运行。

 Summarize( [byname=By(groupvar)],
 name=stat(column), ...)

计算数据表的汇总统计量；每个 stat 的结果都赋给指定的 name。

 Suppress Formula Eval(bool)

关闭所有数据表的公式自动计算。

 col[n]

返回第 n 行 col 的值。
数据表对象消息
 dt<<Add Multiple Columns("前缀 ",
 n, position, attributes)

在 dt 的指定位置处添加 n 列。

 dt<<Begin Data Update

关闭显示更新，以便允许数据表快速更新。将 End Data Update 与此命令一起使用，停止新打开显示更新。

 dt<<Delete Columns(col, col2, ...)
 dt<<Delete Column

从数据表 dt 中删除列。指定要删除的列。没有参数时，删除选定列（如果有）。Delete Column 是同义词。

 dt<<End Data Update

在 Begin Data Update 消息后恢复显示更新。在需要进行许多更改时，这些命令可用于快速更新数据表。关闭显示更新，可提高速度。

 dt<<Get Name()

返回表的名称。

 dt<<Maximize Display

强制数据表重新测量所有列并缩放为大小最佳的窗口。

 New Column("名称 ", attributes)
 dt<<New Column("名称 ",attribs)

在 dt 中的最后一列后面添加一新列，名称为 name。 可用作命令或消息。

 dt<<Original Order

恢复 dt 中列的保存顺序。

 dt<<Print Window

打印数据表

 dt<<Reorder By Data Type

对 dt 中的列重新排序，依次为行状态、字符、数值。

 dt<<Reorder By Modeling Type

对 dt 中的列重新排序，依次为连续、保序、记名。

 dt<<Reorder By Name

按名称的字母数字顺序对 dt 中的列重新排序。

 dt<<Reverse Order

根据当前顺序反转 dt 中的列。

 dt<<Revert

恢复为 dt 最近保存的版本。

 dt<<Save("路径")

将表保存至指定路径下。

 dt<< Select Rows({list})

选择行号列表中的指定行。

 dt<<Set Name("名称 ")

给表指定名称。

 dt<<Suppress Formula Eval(bool)

关闭数据表 dt 的公式自动计算。

 dt<<Delete Table Variable(name)

删除表变量。

 dt<<Delete Table Property(name)

删除表性质。
用于元数据的数据表消息
 dt<<Get As Matrix

以矩阵方式返回 dt 数值列的值。

 dt<<Get All Columns As Matrix

以矩阵方式返回 dt 中所有列的值。字符列将根据水平进行编号，起始值为 1。

 dt<<Get Property("名称 ")

返回性质名称中的脚本。

 dt<<Get Script

以表达式返回脚本，以重新创建数据表。

 dt<<Get Table Variable("名称 ")

从变量名称返回值。

 dt<<New Table
Property("名称 ", script)

新建存储 script 的表性质名称。

 dt<<New Table
Variable("名称", value)

使用指定的名称和 value 新建表变量。

 dt<<Save Script to Script Window

将用于重新生成数据表的脚本保存在“脚本日志”窗口。

 dt<<Set Matrix(matrix)

将矩阵插入到数据表，根据需要添加新列和行。

 dt<<Set Property("名称 ", script)

将 script 存储在性质名称中。

 dt<<Set Table Variable("名称", value)

将 value 存储在变量名称中。

 dt << Set Label Columns("名称 ", ...)
 dt << Set Label Columns

打开指定列的标签属性。如果没有列出列，则关闭标签属性。

 dt << Set Scroll Lock Columns
("名称", ...)

锁定指定列的滚动。如果没有列出列，则撤销锁定滚动。
行命令
 dt<<Clear Select

关闭当前选择。

 dt<<Color by Column(col)

根据数据表列的值进行颜色赋值。

 dt<<Colors(n)

将颜色 n 赋给选定行。

 dt<<Marker by Column(col)

根据数据表列的值进行标记赋值。

 dt<<Markers(n)

将标记 n 赋给选定行。

 dt<<Next Selected

向下滚动数据表以显示不在视图中的下一个选定行。

 dt<<Previous Selected

向上滚动数据表以显示不在视图中的上一个选定行。

 dt<<Exclude
 dt<<Unexclude

将 dt 中的选定行从已排除切换为已撤消排除或相反。

 dt<<Hide
 dt<<Unhide

将 dt 中的选定行从已隐藏切换为已撤消隐藏或相反。

 dt<<Label
 dt<<Unlabel

将 dt 中的选定行从已标记切换为已撤消标记或相反。

 dt<<Add Rows(count)
 dt<<Add Rows(count, rownum)
 dt<<Add Rows(assignmentList)

在数据表底部或指定 rownum 的开始处添加指定行数。

 dt<<Move Rows(At start);
 dt<<move rows(at end);
 dt<<move rows(after(n));

移动 dt 中的选定行，使它们位于 At Start、At End 或 After(rownumber)。

 dt<<Delete Rows
 dt<<Delete Rows(n)
 dt<<Delete Rows({n,o,p,...})
 dt<<Delete Rows({n::q})

删除当前选定行或指定行。
用于选择行的数据表消息
 dt<<Go To Row(n)

在 dt 中查找并选择行号 n。

 dt<<Invert Row Selection

选择任何当前未选定的行并撤消选定任何当前选定的行。

 dt<<Select All Rows

选择数据表中的所有行。

 dt<<Select Excluded

只选择数据表中当前排除的行。

 dt<<Select Hidden

只选择数据表中当前隐藏的行。

 dt<<Select Labeled

只选择数据表中当前标记的行。

 dt<<Select Where(condition)

选择 dt 中条件计算结果为真的行。
用于重新排列表的数据表消息
 dt<<Concatenate(dt2, ..., Keep
Formulas, Output Table Name("名称"))

根据 dt 和 dt2 的行新建表（名称）。

 dt<<Join(With(withTable),
 Select(columns),
 SelectWith(withcolumns), method,
 Drop Multiples(bool, bool), Include
 NonMatches(bool, bool), Output
 Table Name("名称 "))

以并列方式连接数据表 dt 和 withTable。

 dt<<Sort(By(列 ), order(Descending
 or Ascending), Output Table Name
("名称 "))

根据一个或多个列的值重新排列 dt 的行，从而新建表（名称）。

 dt<<Split(Split(列), Group(gcol),
 ColID(idcol), Remaining Columns
(选项 ), Output Table Name("名称 "))

通过将 dt 中的一个或多个列分为多个列，新建表（名称）。

 dt<<Stack(Stack(列), ColID(idcol),
 Stacked(newcol), Output Table
 Name("名称 "))

将 dt 中几个列的值连接为一列 newcol，新建表（名称）。

 dt<<Subset( Columns(列 ),
 Rows(rowMatrix), Linked, Table
 Name("名称 "), Copy Formula(1|0),
 Suppress Formula Evaluation(1|0),
 Sampling Rate(rate))b

根据在 dt 中指定的行新建表（名称）。

 dt<<Summary(Group(col),
 Subgroup(col), statistic(col))

（可选）根据组和子组，为指定的 numCol 新建汇总统计量表。

 dt<<Transpose(Columns(列 ),
 Rows(rowMatrix), OutputTable Name
("名称 "))

根据指定的行和列新建表（名称）。
数据表列消息
 col<<Data Type(type)

设定 col 的 type；选项包括 Numeric、Character、Rowstate。

 col<<Delete Formula

删除列中的公式。

 col<<Delete Property(name);
 col<<Delete Column Property(name)

删除列中的性质名称。

 col<<Eval Formula

强制计算公式（可能是再次）。

 col<<Format("格式 ", w, d)

设定指定的数值显示格式。

 col<<Formula(expression)

设定变量的公式并进行计算。

 col<<Get Data Type

返回 col 的数据类型。

 col<<Get Formula

返回公式。

 col<<Get Lock

返回当前 Lock 设置。

 col<<Get Modeling Type

返回列的建模类型（"连续"、"保续" 或 "记名"）。

 col<<Get Name()

返回列名。

 col<<Get Format

返回列的格式。

 col<<Get Role

返回 col 的预选定角色。

 col<<Preselect Role(role)

预选择列角色。选项包括 Y、X、Weight、Freq 和 None。

 col<<Set Modeling Type(type)

设定变量的建模类型。选项包括 Continuous、Ordinal 或 Nominal。

 col<<Set Name("名称 ")

设定列名。

 col<<Set Property ("名称 ",
 expression)

将性质名称设定为指定的表达式。

 col<<Values([matrix] or {list})

设定来自矩阵（对于数值变量）或列表（对于字符变量）的值。

 col<<Lock(bool)
 col<<Set Lock(bool)

根据指定布尔参数打开或关闭 Lock 属性。
行状态函数
 As Row State(num)

根据指定的 num 返回行状态。

 dt<<Clear Row States

取消任何生效的行状态。

 Color Of(rowstate)
 Color Of(rowstate)=num

返回或设定颜色指标。

 Color State(num)

返回具有指定颜色的行状态。

 Combine States(rowstate, rowstate, ...)

Combine States 根据两个或多个 rowstate 参数生成行状态组合。

 Excluded State(num)

根据指定的 num 返回要排除的行状态。

 Excluded(rowstate)
 Excluded(rowstate)=num

返回或设定排除指标。

 Hidden State(num)

根据指定的 num 返回要隐藏的行状态。

 Hidden(rowstate)
 Hidden(rowstate)=num

返回或设定隐藏指标。

 Hue State(num)

根据指定的 num 返回色调状态。

 Labeled State(num)

根据指定的 num 返回标记状态。

 Labeled(rowstate)
 Labeled(rowstate)=num

返回或设定标记指标。

 Marker Of(rowstate)
 Marker Of(rowstate)=num

返回或设定行状态的标记指标。

 Marker State(num)

根据指定的 num 返回标记状态。

 Row State(); Row State(n)
 Row State()=m; Row State(n)=m

返回当前行的活动行状态条件（真或假）。

 Selected State(num)

根据指定的 num 返回选定状态。

 Selected(rowstate)
 Selected(rowstate)=num

返回或设定选定指标。

 dt<<Set Row States(matrix)

将行状态赋给数据表中的每一列。矩阵包含与预期状态对应的代码，且每行包括一个项目。

 Shade State(num)

Shade State 将 5 个暗度级别赋给颜色或色调。
按列预计算的统计量
 Col Maximum(expression)
 Col Max(expression)

所有行上 expression 的最大值。

 Col Mean(expression)

所有行上 expression 的均值。

 Col Minimum(expression)
 Col Min(expression)

所有行上 expression 的最小值。

 Col N Missing(expression)

所有行上 expression 的缺失值个数。

 Col Number(expression)

所有行上 expression 的非缺失值个数。

 Col Quantile(expression, p)

所有行上 expression 的第 p 个分位数。

 Col Shuffle( )

每次计算时均随机正移一些值。

 Col Standardize(expression)

标准化所有行上的 expression。

 Col Std Dev(expression)

所有行上 expression 的标准差。

 Col Sum(expression)

所有行上 expression 的总和。
按行预计算的统计量
 Maximum(var1, var2, ...)
 Max(var1, var2, ...)

指定变量的行最大值。

 Mean(var1, var2, ...)

指定变量的行均值。

 Minimum(var1, var2, ...)
 Min(var1, var2, ...)

指定变量的行最小值。

 NMissing(expression)

指定变量中缺失值的个数（按行）。

 Number(var1, var2, ...)

指定变量中非缺失值的个数（按行）。

 Std Dev (var1, var2, ...)

指定变量的行标准差。

 Sum(var1, var2, ...)

指定变量的行总和。


平台

下表汇总了 JSL 用于处理分析平台的通用功能。本章详细讲解了各个平台特定的消息。

分析平台脚本
 Show Properties(obj)

显示指定对象可解释的消息，以及一些基本语法信息。

 obj << message
 Send(obj, message)

将 message 发送到平台 obj。

 obj << message << message...
 obj << {message, message, ...}

发送一系列 message（按从左到右的顺序）到平台 obj。

 obj << ( child << message )

将 message 发送到平台 obj 内的 child 对象。

 Platform(..., Title(“字符串”)

将生成的报表的标题设定为“字符串”，覆盖默认标题。例如，
Bivariate (X(身高), Y(体重), Title(“我的标题”)

 Platform(Action(expression))

启动平台时计算表达式。用于在一行中生成几个平台启动。
可发送到平台和数据表窗口的消息
 obj<<Close Window

关闭 obj 标识的窗口，通常是平台曲面。

 obj<<Data Table Window

激活关联的数据表窗口（显示在最前面）。

 obj<<Journal Window

将窗口的内容附加到日志。

 obj<<Move Window(x, y)

将窗口向右移动 x 像素，向下移动 y 像素。

 obj<<Redo Analysis

使用相同的选项再次启动平台。

 obj<<Report
 Report(obj)

返回平台窗口中报表的显示框引用。

 obj<<Save Script for All Objects

将对象窗口中用于重新生成所有分析的脚本保存到“脚本日志”窗口。

 obj<<Save Script to Datatable

将用于重新生成分析的脚本作为性质保存在关联数据表中。

 obj<<Save Script to Report

将用于重新生成分析的脚本作为文本框保存在报表顶部。

 obj<<Save Script to Script Window

将用于重新生成分析的脚本保存在“脚本日志”中。

 obj<<Size Window(x, y)

调整窗口大小，使其宽度为 x 像素，身高为 y 像素。

 obj<<Zoom Window

缩放窗口；等同于单击窗口角的调整大小按钮。

 obj<<Minimize Window

最小化窗口。等同于单击窗口角中的最小化按钮。

 obj<<Scroll Window(x, y)
 obj<<Scroll Window({x, y})

从当前位置将窗口向左滚动 x 像素，向下滚动 y 像素。

 obj<<Bring Window To Front

将当前窗口显示在前面。

 obj<<Get Script

返回用于重新生成分析的脚本，作为表达式。

 obj<<Get Window Size

获取窗口大小，以像素为单位。返回有序对。

 obj<<Get Window Position

获取窗口位置。返回有序对。

 obj<<Show Window

显示隐藏窗口。

 obj<<Print Window

将选定窗口发送到打印机。


显示

本部分汇总了用于构造和定位 JMP 显示窗口的 JSL。

显示树下标
 db[outlineBox | columnBox("文本")]
 db["文本"]
 Subscript(db, spec)

返回类型为 outlineBox 或 columnBox、标题为文本的显示框。文本可包括 ? 通配符。

 db[boxType(n)]

返回指定 boxType 的第 n 个显示框。

 db[n]

返回框的第 n 个子项，如表框的第 n 列或外框节点的第 n 个子节点。

 HSize()

返回图形框的水平大小（以像素为单位）。

 VSize()

返回图形框的垂直大小（以像素为单位）。

 XOrigin()

返回图形框左边的 x 值

 XRange

返回显示框左边至右边之间的距离。例如，XOrigin()+XRange() 是右边。

 YOrigin

返回图形框底边的 y 值

 YRange()

返回显示框底边至顶边之间的距离。例如，YOrigin()+YRange() 是顶边。
显示框构造函数
 Border Box(<Left(pix)>, <Right(pix)>,
 <Top(Pix)>, <Bottom(Pix)>,
 <Sides(0)>, db)

构造一个显示框，在 db 周围添加空间。

 Button Box("文本", script);

使用文本构造按钮，此按钮被单击时就将执行 script。

 Check Box(OperItem(“项目”,...),
 <script>);

构造一个显示框，显示一个或多个复选框。

 Col List Box(<All>, <width(pixels)>,
 <maxSelected(n)>, <nlines(n)>,
 <script>)

构造一个显示框，显示允许选择数据表列的列表框。maxSelected 参数只影响可以选择一个还是多个项目。它不强制大于 1 的界限。

 ComboBox(OperItem("项目",...),
 <script>);

构造一个显示框，使用弹出式菜单显示组合框。

 Graph Box(...)

构造图形。

Graph() 是别名。

 Global Box(global)

构造一个用于直接编辑 global 值的框。

 Hier Box("文本", box tree)

构造一个树节点（与 Diagram 输出类似），其中包含文本。

 HList Box(items)

根据列出的 items 新建水平类型的列表框。

 Icon Box("名称")
构造包含图标的显示框，其中名称可以是任何 JMP 图标的名称。例如，Icon Box("正态") 构造包含“正态”图标的显示框。
 Journal Box("日志文本")

构建一个框显示指定的日志文本。建议您不要手动生成日志文本。有关获取日志输出的方法，请参阅“Journal Box”。

 LineUpBox(<NCol(n)>,
 <Spacing(pixels)>, db, ...)

构造一个显示框，显示包含 n 列的框的对齐方式。

 ListBox(OperItem("项目",...),
 <width(pixels)>, <maxSelected(n)>,
 <nLines(n)>,<script>);

构造一个显示框，显示由选择项目组成的列表框。

 Matrix Box(matrix)

以常用表形式显示指定的 matrix。

 New Window("标题", box tree)
 New Window(...)

使用指定标题（必需的参数）和显示框树新建窗口。

 Number Col Box("标题 ", {num, ...})
 Number Col Box("标题 ", matrix)

以列表或矩阵形式使用数值条目创建名称为标题的列。

 OutlineBox(items)

根据列出的 items 新建外框。

 PageBreakBox()

创建一个强制分页的显示框。

 PanelBox("标题 ", db)

创建一个显示框，用于标记和环绕参数显示框。

 Popup Box({"命令 1", script1,
"命令 2", script2, ...})

创建弹出式框。唯一的参数是结果为包含偶数个项目的列表的表达式，选择该命令时，将在命令字符串和需要计算的表达式之间交替。如果该命令是空字符串，将插入分隔符行。

 RadioBox({"项目",...}, <script>);

构造一个显示框，显示一组单选按钮。

 obj<<Report
 Report(obj)

返回平台对象的显示树。

 Show Properties(obj)

列出指定可脚本化对象的所有消息。

 Scene Box(x size, y size)

为三维图形创建 x x y 大小的场景框。

 Slider Box(min, max, global, script);

构造一个滑块，用于将 global 的值设定在 min 和 max 指定的范围之内。每次拖动时都将执行 script。

 String Col Box("标题 ", {"字符串 ", ...})

在包含列出的字符串项目的表中创建列。

 Tab Box(“页标题 1”, 第 1 页的内容,
 “页标题 2”, 第 2 页的内容, ...)

带选项卡的对话框窗格

 Table Box(items)

创建报表，其中 items 列为列。

 Text Box("文本 ", script)
 Text Box (“文本”,
 << Set Script(script));

使用指定的文本构造一个框。可选的 script 参数将一个脚本附加到文本框，方法是添加脚本作为第二个参数或发送 Set Script 消息。

 Text Edit Box("文本 ")

使用指定的文本构造一个可编辑框。

 VList Box(items)

根据列出的 items 新建垂直类型的列表框。

 Window(string)

按存储在 string 中的标题查找窗口，并返回该窗口的引用。
用于所有显示框的消息
 Show Properties(db)

显示指定显示框可解释的消息。

 db<<Select
 db<<Deselect

选定（高亮度显示）或撤消选定框。

 db<<Reshow

强制屏幕刷新。

 db<<Journal

将框附加到日志。

 db<<Copy Picture

将框的图片置于剪贴板中。

 db<<Page Break

在框之前插入分页符。

 db<<Set Report Title("标题 ")

设定新标题。

 db<<Class Name

返回框的显示类的名称。

 db<<Child,
 db<<Child(n)

返回框的子项或第 n 个子项。

 db<<Sib
 db<<Sib(n)

返回框的兄弟项或第 n 个兄弟项。

 db<<Parent

返回显示框的父项。

 db<<Append(db2)

将 db2 添加到 db 后的显示树中。

 db<<Sib Append(db2)

附加某个显示作为当前显示的兄弟项。参数的计算结果必须是显示框拥有者或引用。

 db<<Prepend(db2)

将 db2 添加到 db 前的显示树中。

 db<<Delete

删除显示框

 db<<Get Text

返回一个包含框文本的字符串。

 db<<Get HTML

返回一个包含框的 HTML 来源的字符串。

 db<<Get RTF

返回一个包含框的 RTF 来源的字符串。

 db<<Get Journal

返回一个包含框的日志来源的字符串。

 db<<Get Picture

将 db 作为 Picture 对象捕获。

 db<<Get Script

返回用于重建显示框的脚本。

 db<<Save Text("")
 db<<Save Text("路径名 ")

保存一个包含框文本的文件。

 db<<Save HTML("" | "路径名 ",
 format)

以指定的 format 保存图形的 HTML 来源和文件夹。

 db<<Save MSWord(“路径 ”,
 Native)

将显示框另存为 Microsoft Word 文档。（只适用于 Windows）

 db<<Save RTF("" | "路径名 ", format)

以指定的 format 保存图形的 RTF 来源。

 db<<Save Journal("" | "路径名 ")

保存框的日志来源。

 db<<Save Picture("" | "路径名 ",
 format)

保存框的图片。

 db<<Clone Box

制作一份新的显示框。

 db<<Scroll Window(x, y)

滚动包含的窗口。

 db<<Close Window

关闭包含的窗口。

 db<<Zoom Window

缩放包含的窗口。

 db<<Size Window(x, y)

调整包含的窗口大小。

 db<<Move Window(x, y)

移动包含的窗口。

 db<<Journal  Window

将显示框包含的窗口附加到日志；与 Journal 进行比较。
用于 Outline Box 的消息
 outlineBox<<Close(bool)

关闭外框。

 outlineBox<<Horizontal(bool)

水平对齐节点的子项。

 outlineBox<<Open All Below

打开节点的所有子节点。

 outlineBox<<Close All Below

关闭节点的所有子节点。

 outlineBox<<Open All Like This

从此平台打开所有报表窗口中的此节点。

 outlineBox<<Close All Like This

从此平台关闭所有报表窗口中的此节点。

 outlineBox<<Close Where No Outlines

关闭没有子项的所有节点。

 outlineBox<<Set Title("文本")

更改外框的标题。

 oultineBox<<Get Title

获取外框的标题。
用于图形框内的函数
 Arc(x1, y1, x2, y2, startangle,
 endangle)

在指定矩形中内接一段弧。

 Arrow(<pixellength,>{x1,y1}, {x2,y2} )
 Arrow(<pixellength,>[x1,x2,], [y1,y2} )

在第一个点和第二个点之间绘制箭头。可选的第一个参数指定箭头头线的长度（以像素为单位）。

 Back Color(n)

设定用于填充图形背景的颜色。

 Circle({x, y}, radius, ...)

绘制以点为中心、以 radius 为半径的圆。

 Contour Function(expr, xSymbol,
 ySymbol, z, X Grid(min, max, inc),
 Y Grid(min, max, inc), Z Color(color))

绘制几组有关表达式的等高线，即两个符号的函数。z 参数可以是单个值或值指标或矩阵。

 Contour(xVector,yVector,zGridMatrix,
 zContour,<zColors>);

给定用 xVector 的 n 个值和 yVector 的 m 个值生成某个曲面上的值的 n x m 矩阵 zGridMatrix，此函数绘制由 zContour 中的值定义的等高线，绘制时使用 zColors 定义的颜色。

 Drag Line (xMatrix, yMatrix,
 dragScript, mouseupScript)

在矩阵参数指定的坐标处的可拖动顶点之间绘制线段。

 Drag Marker (xMatrix, yMatrix,
 dragScript, mouseupScript)

在矩阵参数指定的坐标处绘制可拖动标记。

 Drag Polygon(xMatrix, yMatrix,
 dragScript, mouseupScript)

使用矩阵参数指定的坐标处的可拖动顶点绘制填充的多边形。

 Drag Rect (xMatrix, yMatrix,
 dragScript, mouseupScript)

使用矩阵参数指定的前两个坐标处的可拖动顶点绘制填充的矩形。

 Drag Text (xMatrix, yMatrix, "文本",
 dragScript, mouseupScript)

在矩阵参数指定的坐标处绘制文本（或指定列表时的所有项目）。

 Fill Color(n)

设定用于填充实区域的颜色。

 Fill Pattern(n)

已过时，因为已经移除模式。请使用 Transparency()。

 GradientFunction(xname, yname,
 [zlow, zhigh], zcolor([color, color]),
 <XGrid(min, max, incr)>,
 <YGrid(min, max, incr)>)

在经过与颜色范围对应的范围时，根据表达式值确定的颜色填充网格中的一组矩形。

 Handle(a, b, dragScript,
 mouseupScript)

在 a 和 b 指定的坐标处放置可拖动标记。拖动时将执行第一个脚本，而在发生 mouseup 事件时将执行第二个脚本。

 HLine(y)
 HLine(x1, x2, y)

跨整个图形或在两个指定界限之间绘制水平线。通过在 y 参数中使用值矩阵的方式可以绘制多条线条。

 In Polygon(x, y, xx, yy)
 In Polygon(x, y, xyPolygon)

返回 1 或 0，指示 (x,y) 是否在 xx 和 yy 向量参数定义的多边形内。

向量参数 (xx,yy) 也可以连接为 2 列矩阵 (xyPolygon)，允许您使用三个参数，而不是四个。另外，x 和 y 可以是可相乘的向量，那么将根据每个 (x,y) 对是否都在多边形内返回有关 0 和 1 的向量。

 Line Style(n)

设定用于绘制图形的线条样式。

 Line({x1, y1}, {x2, y2}, ...)
 Line([x1, x2, ...], [y1, y2}, ...)

在点跟点之间绘制线条。

 Marker Size(n)

设定用于标记的大小。

 Marker(markerID,{x1,y1},{x2,y2}...)
 Marker(mID,[x1,x2,...],[y1,y2...})
 Marker(mID,rowstate,coords ...)
 Marker(rs, mID, [x1,x2,],[y1,y2},...)
 Marker(rs, {x1, y1}, {x2, y2}, ...)

绘制一个或多个标记。

 MouseTrap(dragscript,
 mouseupscript)

捕获单击坐标以更新图形参数。拖动时将执行第一个脚本，而在发生 mouseup 事件时将执行第二个脚本。

 Normal Contour([prob1,...],
 [mean1...], [stddev1...], [corr1...]))

绘制对于 k 总体和两个变量的正态概率等高线。

 Oval(x1, y1, x2, y2, fill)
 Oval({x1, y1}, {x2, y2}, fill)

在对角线坐标为 (x1,y1) 和 (x2,y2) 的矩形中内接一个椭圆。

 Pen Color(n)

设定用于画笔的颜色。

 Pen Size(n)

以像素为单位设定画笔粗细。

 Pie(x1, y1, x2, y2, startangle,
 endangle)

在指定矩形中内接一个填充饼。

 Pixel Line To(x,y)

在当前像素位置到像素坐标指定的位置之间绘制一条宽度为一个像素的线条。

 Pixel Move To(x,y)

移到像素坐标指定的新位置。

 Pixel Origin(x,y)

以图形坐标为后续 Pixel Line To 或 Pixel Move To 命令设定原点。

 Polygon({x1, y1}, {x2, y2}, ...)
 Polygon([x1, x2, ...], [y1, y2}, ...)

填充点定义的区域的内部。

 Rect(x1, y1, x2, y2, fill)
 Rect({x1, y1}, {x2, y2}, fill)

绘制对角线坐标为 (x1,y1) 和 (x2,y2) 的矩形。

 Text Color(n)

设定文本字符串的颜色。

 Text Size(n)

以点为单位设定文本字符串的字体大小。

 text({x, y}, text)
 text({x, y}, text, {x, y}, text, ...)
 text(namedArg, {x, y}, text)

在给定点绘制文本。

 Transparency(alpha)

设定当前绘制的透明度，其中 alpha 基于 0 和 1 之间，0 表示清晰（没有绘制），1 表示完全不透明（默认值）。

 VLine(x)
 VLine(x, y1, y2)

跨整个图形或在两个指定界限之间绘制垂直线。通过在 y 参数中使用值矩阵的方式可以绘制多条线条。

 X Function(expr, symbol, Min(min),
 Max(max), Fill(value), Inc(bound),
 Show Details(n))

随着符号在图形 y 轴的变化，绘制一个函数图。

 X Scale(xmin, xmax)

设定水平尺度范围。

 Y Function(expr, symbol, Min(min),
 Max(max), Fill(value), Inc(bound),
 Show Details(n))

随着符号在图形 X 轴的变化，绘制一个函数图。

 Y Scale(ymin, ymax)

设定垂直尺度范围。如果没有指定尺度，默认为 (0,1)。
用于 Frame Box 的消息
 frameBox<<Add Graphics
 Script(script)

添加一个脚本，在图形框中播放。

 frameBox<<Background
Color(color)

更改背景颜色。

 frameBox<<Edit Graphics Script

弹出一个对话框，用于查看、编辑或删除当前图形脚本。

 frameBox<<Frame Size(x, y)

重置框大小，以像素为单位。

 frameBox<<Marker Size(size)

更改标记大小。

 frameBox<<X Axis(min, max,
 inc, namedArgs)

标度 X 坐标系统。

 frameBox<<Y Axis(min, max,
 inc, namedArgs)

标度 Y 坐标系统。

 frameBox<<Row Colors(color)
 frameBox<<Row Markers(marker)
 frameBox<<Row Exclude(bool)
 frameBox<<Row Hide(bool)
 frameBox<<Row Label(bool)

将这些命令前转到与该报表关联的数据表，从而可以处理选定行的行状态。
用于 Table Box 的消息
 tableBox<<Get

以列表形式获取表项。

 tableBox<<Get As Matrix

以矩阵形式获取表的数值项。

 tableBox<<Make Data Table(name)

将表项转换为新数据表。

 tableBox<<Make Combined
Data Table

与 Make Data Table 一样，但还在报表中搜索具有相同列的报表，并将这些报表连接为一个新数据表。

 tableBox<<Table Style(style)

设定演示样式。
用于 Text Box 的消息
 textBox<<Font Color(n)

设定文本字符串的颜色。

 textBox<<Get Text

返回框的字符串内容。

 textBox<<Rotate Text(direction)

将文本向左或向右旋转 90 度，或将其返回水平位置。

 textBox<<Set Font Size(n)

以点为单位设定文本字符串的字体大小。

 textBox<<Set Font Style(style)

设定文本字符串的字体样式。

 textBox<<Set Font(fontname)

设定文本字符串的字体。

 textBox<<Set Script(script)

将某个脚本与文本框关联。当用户单击 Enter 键时（或文本编辑框失去焦点时），将执行该脚本。

 textBox<<Set Text("字符串")

更改框的字符串内容。

 textbox<<Set Wrap(n)

以像素为单位 (n) 设定换行点。
用于 Axis Box 的消息
 axisBox<<Add Axis Label("字符串")

添加具有指定字符串的轴标签。

 axisBox<<Add Ref Line(number,
 linestyle, color)

以指定的 linestyle 和 color 在 number 处添加参考线。

 axisBox<<Axis Settings(choices)

在单则消息中应用很多轴更改。对于 choices 参数，请从下面的消息进行选择。

 axisBox<<Decimal(width,
 decimalplaces)

更改轴值的数值格式。

 axisBox<<Format("名称")

更改为名称指定的数值格式。

 axisBox<<Inc(n)

设定刻度的增量。

 axisBox<<Interval(choice)

使用日期/事件数据格式指定用于 Inc 的单位。

 axisBox<<Max(max)

只更改轴尺度的最大值。

 axisBox<<Min(min)

只更改轴尺度的最小值。

 axisBox<<Minor Ticks(number)

指定主刻度标记之间的副刻度标记数。

 axisBox<<Remove Axis Label

移除使用 Add Axis Label 添加的任何标签。

 axisBox<<Revert Axis

恢复轴的原始设置（创建时）。

 axisBox<<Rotated Labels(bool)

旋转或撤消旋转各个刻度值的标签。

 axisBox<<Scale(type)

将轴尺度更改为 type（Log 或 Linear）。

 axisBox<<Show Labels(boolean)

显示或隐藏轴值的标签。

 axisBox<<Show Major Grid(bool)

在主刻度值处添加或移除网格线。

 axisBox<<Show Major Ticks(bool)

显示或隐藏主刻度标记。

 axisBox<<Show Minor Grid(bool)

在副刻度值处添加或移除网格线。

 axisBox<<Show Minor Ticks(bool)

显示或隐藏副刻度标记。
用于 Number Col Box 的消息
 numberColBox<<Get As Matrix

以矩阵形式获取值，列向量为特殊形式。

 numberColBox<<Get Format

返回当前格式（width、decimalplaces）。decimalplaces > 100 表示日期/时间值。

 numberColBox<<Get Heading

返回列题头文本。

 numberColBox<<Set Format(width,
 decimalplaces)

设定格式。设定 decimalplaces > 100，获取日期/时间值。

 numberColBox<<Set Heading
("字符串")

更改列题头文本。

 numberColBox<<Get
 numberColBox<<Get(i)

以列表获取值，或第 i 个值。
用于 String Col Box 的消息
 stringColBox<<Get
 stringColBox<<Get(i)

以列表获取值，或第 i 个值。

 stringColBox<<Get Heading

返回列题头文本。

 stringColBox<<Set Heading("文本")

更改列题头文本。
用于 Matrix Box 的消息
 matrixBox<<Get

返回矩阵内容。

 matrixBox<<Make Into Data Table

将矩阵转换成新数据表。

 matrixBox<<Set Format(width,
 decimalplaces)

设定矩阵元素的数值格式。
用于 Nom Axis Box 的消息
 nomAxisBox<<Divider Lines(boolean)

在轴框的标签之间添加或移除分隔线。

 nomAxisBox<<Lower Frame(boolean)

在轴周围添加或移除下框。

 nomAxisBox<<Rotated Tick Labels(boolean)

旋转或撤消旋转各个刻度值处的标签。


矩阵

本部分汇总了用于创建和处理矩阵数据的 JSL。

构造和处理矩阵
 As Table (A)

根据矩阵 A 新建数据表。

 Concat(A, B)
 A||B

水平连接。

 ConcatAssign(A, B)
 A||=B
 ConcatTo(A, B)

代替水平连接。A||=B 等效于 A=A||B.这是赋值运算符。

ConcatTo() 是别名。

 Concat Items({string1, string2, ...},
<delimiter>}

将字符串表达式列表转换成单个字符串，列表中的各项使用分隔符分隔。如果未指定，则分隔符为空格。

 Diag(A)

根据方阵或向量创建对角矩阵。

 Get As Matrix (dt)

将数据表 dt 转换成矩阵。

 Identity(n)

标识阶数为 n 的矩阵。

 Index(i,j)
 i::j

生成一个包含整数 i、i + 1 直至 j 的列矩阵。

 J(n)
 J(nrow, ncol)
 J(nrow, ncol, value)

创建值相同的矩阵。

 Matrix(
{{x11, x12, ..., x1m},
{x21, x22, ..., x2m},
{...},
{xn1, xn2, ..., xnm}})

根据由 n 个列表（由 m 元素组成）组成的列表构造 n x m 矩阵。

 Shape(A, nrow, ncol)

将行矩阵重塑为指定维。

 Transpose(A)
 A`

互换矩阵中的行与列。

 VConcat(A, B)
 A|/B

垂直连接。

 VConcatAssign(A, B)
 A|/=B

代替垂直连接。A|/=B 等效于 A=A|/B。

 VecDiag(A)

根据方阵的对角线创建向量。

 VecQuadratic(symmetric matrix,
rectangular matrix)

用于计算应变量值。等效于
VecDiag(X*Sym*X`)。

 [x11 x12 ... x1m,
  ... ,
 xn1 xn2 ... xnm ]

构造 n x m 矩阵。
矩阵的下标
 A[i, j]
 A[i]

选择矩阵 A 中第 i 行第 j 列的元素。

 i::j

以矩阵形式创建数字序列。

 Loc(A)

创建下标位置矩阵，其中 A 是非 0 且非缺失矩阵。

 LocMin(A)

返回矩阵中最小元素所在的位置。

 LocMax(A)

返回矩阵中最小元素所在的位置。

 LocSorted(A)

创建下标位置矩阵，其中 A 中的值小于或等于 B 中的值。A 必须是排序矩阵。
数值运算
 A|B, Or(A, B), A&B, And(A, B),
!A, Not(A)

有关矩阵的逻辑运算符可生成元素化结果矩阵。

 A+B, A-B, A/B, A++, A--,
Log(A), Sqrt(A), ...

所有基本运算符（除了乘法和除法）均按元素执行运算，并会生成结果矩阵。您可以将矩阵和标量混在一起，但是矩阵的维度必须相同。

 A<B, A<=B, A<B<=C, ...

有关矩阵的比较或范围检查可生成元素化结果矩阵。

 All(A...)

如果所有参数均非 0，则 All 返回标量 1，否则返回 0。

 Any(A...)

如果矩阵中的一个或多个元素非 0，则 Any 返回标量 1，否则返回 0。

 C=A*B
 C=MatrixMult(A, B)

矩阵乘法。

 EDiv(A, B)
 A:/B

元素与元素相除。

 EMult(A, B)
 A:*B

元素与元素相乘。

 Min(A)
 Max(A)
 Min(A, B, ...)

矩阵中的最小或最大元素。

 NCol(A)
 NCol(dt)

返回矩阵或数据表（由 dt 指定）中的列数。

 NRow(A)
 NRow(dt)
 NRows(A)
 NRows(dt)

返回矩阵或 数据表（由 dt 指定）中的行数。

 Rank(vector)
 Rank Index(vector)

返回用作原向量 v 的下标的秩向量，然后按秩对向量排序。

 Ranking(vector)

返回 vector 值的秩向量，1 至 n 表示从低到高，联结任意。

 Ranking Tie(vector)

返回 vector 值的秩向量，但联结的秩平均。

 Trace(A)

迹或方阵对角元素的和。
求矩阵
 Cholesky(A)

求出对称矩阵的下 Cholesky 根 (L)。

 Design(vector)

创建值向量的设计列。

 DesignNom(vector)

此版本的 Design 用于使设计矩阵的满秩形式产生记名效应。

DesignF() 是别名。

 DesignOrd(vector)

此版本的 Design 用于使设计矩阵的满秩形式产生保序效应。

 Det(A)

方阵的行列式。

 DirectProduct(A, B)

方阵或标量的直积（Kronecker 积）。

 Eigen(A)

特征值分解。

 GInverse(A)

广义 (Moore-Penrose) 逆矩阵。

 HDirectProduct(A, B)

维度相同的两个方阵或两个标量的水平直积。

 Inv(A)
 Inverse(A)

矩阵求逆。

 InvUpdate(A, X, 1|-1)

高效更新 XX 矩阵。X 表示要添加的行。在第三个参数位置，1 表示添加一行；-1 表示删除一行。

 Ortho(A)

使用 Gram Schmidt 法对矩阵 A 的列执行正交化。

 OrthoPoly(vector, order)

返回表示间距的下标向量的正交多项式，直至达到给定次数。

 QR(A)

返回 A 的 QR 分解。典型用法是 {Q, R} = QR(A)。

 Solve(A, b)

求解线性系统，即 x=inverse(A)*b。

 SVD(A)

奇异值分解。

 Sweep(A)
 Sweep(A, indices)

清除，或每次只求矩阵一分块的逆。


生产

本部分汇总了用于处理生产设置中的 JMP 的 JSL。

DataFeed 消息
 feed = Open DataFeed(commands)
 feed = DataFeed(commands)

创建 DataFeed 对象。

 feed<<Close

关闭 DataFeed 对象及其窗口。

 feed<<Connect(portSettings)

（只适用于 Windows）设置端口设置，以便连接到设备。

 feed<<Disconnect

（只适用于 Windows）断开设备与数据传送队列之间的连接，但将 DataFeed 对象保留为活动状态。

 feed<<Get Line

从数据传送队列返回并移除一行。

 feed<<Get Lines

以列表形式返回并移除数据传送队列中的所有行。

 feed<<Queue Line(string)

发送一行到数据传送队列的结尾。

 feed<<Restart

重新启动处理排队行。

 feed<<Set Script(script)

指定每次收到数据行时运行的 script。

 feed<<Show Window(bool)

指定是否为数据传送显示状态窗口。

 feed<<Stop

停止处理排队行。
Open Database 命令
 Open Database("connectInfo"
"sqlStatement", "outputTableName")

使用 sqlStatement 打开 connectInfo 指定的数据库，返回名称为 outputTableName 的数据表。
Schedule 命令
 sch<<Clear Schedule()

取消调度队列中的所有事件。

 sch=Schedule(n, script)

对事件进行调度以在 n 秒后运行 script。

JMP 脚本语言语法参考:
语法参考

上一页